Access Node Control Protocol コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
Access Node Control Protocol
Access Node Control Protocol
発行日;2013/06/17   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

Access Node Control Protocol

Access Node Control Protocol(ANCP)機能は、デジタル加入者線アクセス マルチプレクサ(DSLAM)とブロードバンド リモート アクセス サーバ(BRAS)間の通信を強化し、マルチプレクサ側とサーバ側の間でのイベント、アクション、および情報要求の交換をイネーブルにします。 これにより、どちらの側でも適切なアクションを実装できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、『Bug Search Tool』およびご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

Access Node Control Protocol の前提条件

伝送制御プロトコル(TCP)で ANCP を実行するには、ブロードバンド リモート アクセス サーバ(BRAS)で IP をイネーブルにする必要があります。 RADIUS から BRAS への相互作用は ANCP には必要なく、RADIUS サーバに依存します。

リリースおよびプラットフォーム サポートの詳細については、Access Node Control Protocol の機能情報を参照してください。

Access Node Control Protocol の制約事項

Cisco IOS XE Release 2.4 はブロードバンド リモート アクセス サーバ(BRAS)からの RADIUS サーバとの相互作用をサポートします。 RADIUS から BRAS への相互作用は ANCP には必要なく、RADIUS サーバに依存します。

Access Node Control Protocol の詳細

ANCP は、複数の加入者からのトラフィックを集約し、アプリケーションから独立した状態を保ちながら、任意のアプリケーションへの情報を渡します。 ANCP は、現在、デジタル加入者線(DSL)のブロードバンド環境の、DSLAM とブロードバンド リモート アクセス サーバ間のアプリケーションで使用されます。

ANCP 機能により、DSL Aggregation Multiplexer(DSLAM)とネットワーク エッジ デバイス間での閉じた通信が可能になります。 DSLAM と BRAS 間で ANCP を使用すると、イベント、アクション、および情報要求の交換が可能になり、その結果、適切なアクションが DSLAM および BRAS で行われるようになります。

ANCP のアーキテクチャは、ANCP の次の使用をサポートします。

レート アダプティブ モード

レート アダプティブ モードは、特定の回線の回線ビット レートの最大化を支援します。このレートは回線で達成される信号の質に依存します。 レート アダプティブ モードは、DSLAM からブロードバンド リモート アクセス サーバに DSL モデム回線レートを伝送します。

ANCP を実行している BRAS は ANCP ネイバー(DSLAM)からの TCP 要求をリッスンします。

  • TCP セッションの確立後:ANCP は BRAS とそのネイバー間の隣接を確立するために、メッセージの交換を開始します。
  • 隣接の確立後:ANCP イベント メッセージを DSLAM から BRAS へ送信できます。

レート アダプティブ DSL は回線速度を調整するために信号品質を使用します。 BRAS は、通常、サブスクライバ インターフェイスをサービス ライセンス契約(SLA)で同意した最大帯域幅に設定します。

顧客宅内機器(CPE)が、回線速度よりも遅いデータ レートに同期されると、セルまたはパケット損失が DSLAM で発生します。 これを防ぐために、DSLAM は新しく調整された回線レートの BRAS を通知するために ANCP を使用できます。

カスタマー側のポートの状態に応じて、次のようになります。

  • アクティブ:DSLAM は、BRAS に Port Up メッセージを送信します。 適切な Quality Of Service(QoS)は、ANCP によって渡される情報に応じて有効になります。
  • 非アクティブ:DSLAM は、BRAS に Port Down メッセージを送信します。 ANCP は、DSLAM から送信された DSL の状態を報告します。これは、通常、サイレントまたはアイドルです。 ブロードバンド リモート アクセス サーバが別の Port Up メッセージを受信すると、加入者セッションはタイムアウトになるか、新しいシェーピング レートで更新されます。 インターフェイスのシェーピング レートは、ルータが新しい Port Up メッセージを受信するまで変更されません。

RADIUS 相互作用

ブロードバンド リモート アクセス サーバと RADIUS サーバ間の相互作用は、ルータから RADIUS に向けられます。

BRAS は RADIUS サーバに次の属性および属性値ペア(AVP)を送信します。

ANCP ライン レート

アップストリーム データ レート

ダウンストリーム データ レート

出力ポリシー名

VSA 39

属性 197(Ascend-Data-Rate)

属性 255(Ascend-Xmit-Rate)

属性 77(Connect-Speed-Info)

属性タイプ 38(Rx 接続速度 AVP)

属性タイプ 24(Tx 接続速度 AVP)

BRAS は、認証、許可、アカウンティング(AAA)モジュールとのやり取りに、ポイントツーポイント プロトコル(PPPoE)を使用します。 RADIUS は情報を処理し、適切なアクションを実行します。

ポート マッピング

ポート マッピングは、BRAS の VLAN サブインターフェイスと DSLAM の顧客宅内機器(CPE)のクライアントを関連付けます。 VLAN には 802.1Q または queue-in-queue(Q-in-Q)階層型 VLAN が含まれます。 ポート マッピングは、特定の DSLAM ネイバーで CPE クライアント ID をグループ化して、BRAS でグローバル コンフィギュレーション モードで設定されます。

ポートをマッピングするために使用するための 2 つの方法があります。すべての VLAN サブインターフェイスを最初に設定し、ANCP ネイバー マッピングを次に設定する方法と、 インターフェイスでマッピングを直接設定する方法があります。

たとえば、次のコマンドは、Q-in-Q VLAN サブインターフェイスのポート マッピングを設定します。

ancp neighbor name 
dslam-name 
id 
dslam-id
dot1q
 
outer-vlanid
 second-dot1q
 
inner-vlanid
 [interface
 
type number
] client-id
 "
client-id
"

または

ancp neighbor name 
dslam-name 
id
 dslam-id
dot1q
 
outer-vlanid
 client-id
 "
client-id
"

client-id は、DSLAM が各ポートのために BRAS に送信する一意の access-loop-circuit-id です。 DSLAM は、ANCP Port Up イベント メッセージのこの ID を送信します。 access-loop-circuit-id は、次に示すように、アクセス ノード識別子およびデジタル加入者線(DSL)の情報から構成される定義された形式を使用します。

ATM/DSL

" access-node-identifier atm slot/module/port . subinterface : vpi . vci "

イーサネット/DSL

" access-node-identifier ethernet slot / module / port . subinterface [: vlan-id]"

BRAS は、DSLAM が Port Up メッセージを送るまで、ルータのすべてのポートのデフォルト ステートを Down に設定します。

非インタラクティブな運用、管理、および保守

ANCP は、ブロードバンド リモート アクセス サーバから運用、管理、および保守(OAM)の非インタラクティブ操作を実行するように、アウトオブバンド制御チャネルを提供します。 このチャネルにより、特定の DSLAM ポートの ANCP ポートの状態をルータ オペレータが確認できるようになります。 ANCP ポート ステート情報は、BRAS の ANCP ダイナミック データベースに保存されます。

インタラクティブ OAM

インタラクティブ OAM およびスケーリング強化機能は、運用とトラブルシューティングのために ANCP にオンデマンド ping 機能を追加します。


(注)  


この機能はデフォルトでイネーブルになり、設定は必要ありません。


General Switch Management Protocol および ANCP

ANCP は、General Switch Management Protocol(GSMP)を拡張したものです。 GSMP はマスタースレーブ ネイバー関係を定義します。ここで、マスターはスレーブへの接続を開始します。 ANCP では、このマスタースレーブ関係が反転します。BRAS(マスター)は DSLAM(スレーブ)からの着信 ANCP 接続をリッスンして受け入れます。 DSLAM はイベント メッセージを使用して、トポロジの変更や、ポート ダウン イベントまたはポート アップ イベントなどの BRAS への非同期イベントでの通信を行います。

BRAS と DSLAM 間の GSMP 接続は TCP/IP(RFC 3293)経由で発生します。 DSLAM はルータへの接続を開始し、ルータは、適切なインターフェイスで ANCP がイネーブルな場合は接続を受け入れます。

GSMP 隣接プロトコルは GSMP のネイバー関係を確立します。

  1. 隣接を構築中に、次のように行われます。
    1. DSLAM およびルータが機能をネゴシエートし、2 つの端の同期状態が決まります。
    2. GSMP は、転送障害の場合にルータおよび DSLAM がローカルの情報データベースの状態を保持したかどうかや、両方のデバイスで状態更新が必要かどうかを検出します。
    3. 隣接を再同期化する必要があることが GSMP で判断された場合、隣接の同期プロセスが再開されます。これには、次の場所から入手可能な、ANCP 拡張ドラフトで定義されている機能ネゴシエーションが含まれます。

http://tools.ietf.org/id/draft-wadhwa-gsmp-l2control-configuration-02.txt

  1. ANCP では、ネイバー(neighbor1)にそのネイバー(neighbor2)でサポートされていない機能が含まれている場合、neighbor1 はその機能をオフにして、neighbor2 と同じ機能セットで neighbor2 へのパケットを再通信します。
  2. 両方のネイバーが同じ機能セットで同意すると、隣接関係が確立されます。

Access Node Control Protocol の設定方法

ANCP を設定するには、次のグローバルまたはインターフェイス コンフィギュレーション タスクを実行します。

イーサネット インターフェイスでの ANCP のイネーブル化

イーサネット インターフェイスで ANCP をイネーブルにするには、この作業を実行します。

手順の概要

    1.    enable

    2.    configure terminal

    3.    ancp adjacency timer interval

    4.    interface type number

    5.    ip address address mask

    6.    ancp enable

    7.    interface type number . subinterface

    8.    encapsulation dot1q vlanid [second-dot1q second-vlanid]

    9.    exit


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 ancp adjacency timer interval


    例:
    Router(config)# ancp adjacency timer 100
     

    ANCP 隣接タイマー間隔を設定します。これは、ANCP hello パケットを DSLAM に送信するまで待機する時間を示します。

     
    ステップ 4 interface type number


    例:
    Router(config)# interface FastEthernet1/0/0
     

    インターフェイス コンフィギュレーション モードを開始してインターフェイスを定義します。

     
    ステップ 5 ip address address mask


    例:
    Router(config-if)# ip address 10.16.1.2 255.255.0.0
     

    IP アドレスとサブネット マスクをインターフェイスに割り当てます。

     
    ステップ 6 ancp enable


    例:
    Router(config-if)# ancp enable
     

    IP が設定されているインターフェイスで ANCP をイネーブルにします。

     
    ステップ 7 interface type number . subinterface


    例:
    Router(config-if)# interface FastEthernet1/0/0.1
     

    サブインターフェイスを定義するために、サブインターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 8 encapsulation dot1q vlanid [second-dot1q second-vlanid]


    例:
    Router(config-subif)# encapsulation dot1q 100 second-dot1q 200
     

    単一キュー 802.1Q または Q-in-Q VLAN 階層型 VLAN のサブインターフェイスで dot1q VLAN カプセル化をイネーブルにします。

     
    ステップ 9 exit


    例:
    Router(config-subif)# exit
     

    サブインターフェイス コンフィギュレーション モードを終了します。

     

    ATM インターフェイスでの ANCP のイネーブル化

    ancp enable コマンドは、DSLAM から ANCP メッセージを送信する制御 VC に対してのみ設定する必要があります。 ATM インターフェイス上で ANCP をイネーブルにするには、次の作業を行います。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    ancp adjacency timer interval

      4.    interface atm slot / subslot / port . subinterface

      5.    ip address ip-address mask

      6.    pvc vpi / vci

      7.    ancp enable

      8.    exit


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Router> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Router# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 ancp adjacency timer interval


      例:
      Router(config)# ancp adjacency timer 100
       

      ANCP 隣接タイマー間隔を設定します。これは、ANCP hello パケットを DSLAM に送信するまで待機する時間を示します。

       
      ステップ 4 interface atm slot / subslot / port . subinterface


      例:
      Router(config)# interface atm 2/0/1.1
       

      サブインターフェイスを定義するために、サブインターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 5 ip address ip-address mask


      例:
      Router(config-subif)# ip address 10.16.1.2 255.255.0.0
       

      IP アドレスおよびサブネット マスクをサブインターフェイスに割り当てます。

       
      ステップ 6 pvc vpi / vci


      例:
      Router(config-subif)# pvc 2/100
       

      ATM PVC を介した ANCP 接続をイネーブルにするために、ATM 仮想回線コンフィギュレーション モードを開始します。

       
      ステップ 7 ancp enable


      例:
      Router(config-if-atm-vc)# ancp enable
       

      IP が設定されているインターフェイスで ANCP をイネーブルにします。

       
      ステップ 8 exit


      例:
      Router(config-if-atm-vc)# exit
       

      ATM 仮想回線コンフィギュレーション モードを終了します。

       

      ブロードバンド リモート アクセス サーバの VLAN インターフェイスへの DSLAM ポートのマッピング

      BRAS の VLAN インターフェイスに DSLAM ポートをマッピングするには、この作業を実行します。

      手順の概要

        1.    enable

        2.    configure terminal

        3.    ancp atm shaper percent-factor factor

        4.    interface type number.subinterface

        5.    encapsulation dot1q vlan-id

        6.    ancp neighbor name dslam-name [id dslam-id] client-id client-id

        7.    exit


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Router> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 configure terminal


        例:
        Router# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 ancp atm shaper percent-factor factor


        例:
        Router(config)# ancp shaper percent-factor 95
         

        ATM U インターフェイス接続のために ANCP セル タックス アカウンティングをイネーブルにします。

         
        ステップ 4 interface type number.subinterface


        例:
        Router(config)# interface FastEthernet0/0.1
         

        特定のサブインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

         
        ステップ 5 encapsulation dot1q vlan-id


        例:
        Router(config-subif)# encapsulation dot1q 411
         

        指定された VLAN で、トラフィックの IEEE 802.1Q カプセル化をイネーブルにします。

         
        ステップ 6 ancp neighbor name dslam-name [id dslam-id] client-id client-id


        例:
        Router(config-subif)# ancp neighbor name dslam1 id 1.2.3.4 client-id "1.2.3.4. eth 0/0.1"
         

        ANCP が、VLAN サブインターフェイスがマッピングされる DSLAM にアクセスするように指定します。

         
        ステップ 7 exit


        例:
        Router(config-subif)# exit
         

        サブインターフェイス コンフィギュレーション モードを終了します。

         

        ブロードバンド リモート アクセス サーバの PVC インターフェイスへの DSLAM ポートのマッピング

        ancp neighbor name コマンドは、pvc および pvc-in-range コマンド モードで使用可能です。 このコマンドは、PVC と DSLAM ポート間の 1 対 1 マッピングを作成します。 BRAS の PVC インターフェイスに DSLAM ポートをマッピングするには、この作業を実行します。

        手順の概要

          1.    enable

          2.    configure terminal

          3.    ancp atm shaper percent-factor factor

          4.    interface atm slot / subslot / port . subinterface

          5.    次のいずれかを実行します。

          • pvc vpi / vci
          • range pvc start-vpi / start-vci end-vpi / end-vci

          6.    pvc-in-range vpi / vci

          7.    ancp neighbor name dslam-name [id dslam-id] client-id client-id

          8.    end


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Router> enable
           

          特権 EXEC モードをイネーブルにします。

          • パスワードを入力します(要求された場合)。
           
          ステップ 2 configure terminal


          例:
          Router# configure terminal
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3 ancp atm shaper percent-factor factor


          例:
          Router(config)# ancp shaper percent-factor 95
           

          ATM U インターフェイス接続のために ANCP セル タックス アカウンティングをイネーブルにします。

           
          ステップ 4 interface atm slot / subslot / port . subinterface


          例:
          Router(config)# interface atm 2/0/1.1
           

          指定した ATM サブインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

           
          ステップ 5次のいずれかを実行します。
          • pvc vpi / vci
          • range pvc start-vpi / start-vci end-vpi / end-vci


          例:
          Router(config-subif)# pvc 1/101


          例:
                    


          例:
          Router(config-subif)# range pvc 9/100 9/102
           

          PVC と DSLAM ポートの間の 1 対 1 マッピングを作成し、ATM 仮想回線コンフィギュレーション モードを開始します。

          または

          ATM PVC の範囲を定義し、PVC 範囲コンフィギュレーション モードを開始します。

          • ATM PVC の範囲を定義した後は、個々の PVC を設定するために pvc-in-range コマンドを使用します。
           
          ステップ 6 pvc-in-range vpi / vci


          例:
          Router(config-if-atm-range-pvc)# pvc-in-range 9/100
           

          (任意)PVC 範囲コンフィギュレーション モードで範囲内の個々の PVC を設定します。

           
          ステップ 7 ancp neighbor name dslam-name [id dslam-id] client-id client-id


          例:
          Router(config-if-atm-range-pvc)# ancp neighbor name dslam1 id 1.2.3.4 client-id "1.2.3.4. atm0/0.1"
           

          ANCP が、PVC サブインターフェイスがマッピングされる DSLAM にアクセスするように指定します。

          • このコマンドは、PVC 範囲コンフィギュレーション モードおよび ATM 仮想回線コンフィギュレーション モードで使用できます。
           
          ステップ 8 end


          例:
          Router(config-if-atm-range-pvc)# end
           

          PVC 範囲コンフィギュレーション モードを終了します。

           

          Access Node Control Protocol の設定例

          イーサネット インターフェイスでの Access Node Control Protocol のイネーブル化の例

          次に、イーサネット サブインターフェイス 2/0/1 で ANCP をイネーブルにする例を示します。

          interface GigabitEthernet 2/0/1
           ip address 192.168.64.16 255.255.255.0
           ancp enable
          !
          interface GigabitEthernet 2/0/1.1
           encapsulation dot1q 100 second-dot1q 200
          !
          ancp adjacency timer 100

          ATM インターフェイスでの Access Node Control Protocol のイネーブル化の例

          次に、ATM サブインターフェイス 2/0/1.1 で ANCP をイネーブルにする例を示します。

          interface ATM2/0/0.1 point-to-point
           description ANCP Link to one DSLAM
           no ip mroute-cache
           ip address 192.168.0.2 255.255.255.252
           pvc 254/32
             protocol ip 192.168.0.1
             ancp enable
             no snmp trap link-status

          BRAS の VLAN インターフェイスへの DSLAM ポートのマッピング例

          次に、DSLAM の CPE クライアント ポートを BRAS の Q-in-Q VLAN サブインターフェイスにマッピングする例を示します。 例では、192.68.10.5 の IP アドレスの dslam1 という名前の DSLAM ネイバーに、イーサネット インターフェイス 1/0/0.2 に設定された Q-in-Q VLAN 100 および 200 にマッピングされた CPE クライアント ポートがあります。 別の CPE クライアント ポートは、イーサネット インターフェイス 1/0/0.1 に設定された Q-in-Q VLAN 100 および 100 にマッピングされています。

          interface GigabitEthernet1/0/0.1
           encapsulation dot1q 100 second-dot1q 100 
           ancp neighbor name dslam1 id 192.168.10.5 client-id "192.168.10.5 ethernet1/0/0.2"
          !
          interface GigabitEthernet1/0/0.2
           encapsulation dot1q 100 second-dot1q 200
           ancp neighbor name dslam1 id 192.168.10.5 client-id "192.168.10.5 ethernet1/0/0.1"
          !
          ancp atm shaper percent-factor 95
          !

          上の例は、サブインターフェイス レベルでポートを直接マッピングします。 また、次の例に示すように、すべての VLAN サブインターフェイスを最初に設定して、次に ANCP ネイバーでマッピングを実行します。

          interface GigabitEthernet1/0/0.1
           encapsulation dot1q 100 second-dot1q 100
          !
          interface GigabitEthernet1/0/0.2
           encapsulation dot1q 100 second-dot1q 200
          !
          ancp atm shaper percent-factor 95
          !
          ancp neighbor name dslam1 id 192.168.10.5
           dot1q 100 second-dot1q 100 interface GigabitEthernet1/0/0.1 client-id "192.168.10.5  ethernet1/0/0.2"
          !
          ancp neighbor name dslam1 id 192.168.10.5
           dot1q 100 second-dot1q 200 interface GigabitEthernet1/0/0.2 client-id "192.168.10.5 ethernet1/0/0.2"

          BRAS の PVC インターフェイスへの DSLAM ポートのマッピング例

          ancp neighbor name コマンドは、DSLAM の CPE クライアント ポートを BRAS の PVC インターフェイスにマッピングします。 このコマンドは、グローバルに設定することも、または PVC/PVC-in-Range モードで設定することもできます。

          PVC または PVC-in-Range コンフィギュレーション モード

          この例で、ルータは、2 つのポートまたはクライアントを持つ 1 つの DSLAM と接続されます。

          interface ATM2/0/0.1 point-to-point
            description ANCP Link to one DSLAM
            no ip mroute-cache
            ip address 192.168.0.2 255.255.255.252      
            pvc 254/32
               protocol ip 192.168.0.1 255.255.255.252
               ancp neighbor name dslam1 id 192.168.10.5 client-id "dslam-port-x-identifier"
                  no snmp trap link-status
                !
          interface ATM1/0/0.1 multipoint
            description TDSL clients - default TDSL 1024
            class-int speed:ubr:1184:160:10
            range pvc 10/41 10/160
              service-policy input SET-PRECEDENCE-0
              service-policy output premium-plus:l2c:25088
              pvc-in-range 10/103
                description TDSL client 16 Mbps with ANCP
                class-vc speed:ubr:17696:1184:05
                ancp neighbor name dslam1 id 192.168.10.5 client-id "dslam-port-x-identifier"
                 !
            range pvc 11/41 11/160
              service-policy input SET-PRECEDENCE-0
              service-policy output premium-plus:l2c:25088
              pvc-in-range 11/108
                description TDSL client 16 Mbps with ANCP
                class-vc speed:ubr:17696:1184:05
                ancp neighbor name dslam1 id 192.168.10.5 client-id "dslam-port-y-identifier"
                  !

          グローバル コンフィギュレーション モード

          ancp neighbor コマンドがグローバルに設定される場合、次の例のように、ATM インターフェイスの PVC 情報も指定する必要があります。

          interface ATM1/0/0.1 multipoint
           description TDSL clients - default TDSL 1024
           class-int speed:ubr:1184:160:10
           range pvc 10/41 10/160
             service-policy input SET-PRECEDENCE-0
             service-policy output premium-plus:l2c:25088
             pvc-in-range 10/103
               description TDSL client 16 Mbps with ANCP
               class-vc speed:ubr:17696:1184:05
          !
           range pvc 11/41 11/160
             service-policy input SET-PRECEDENCE-0
             service-policy output premium-plus:l2c:25088
             pvc-in-range 11/108
               description TDSL client 16 Mbps with ANCP
               class-vc speed:ubr:17696:1184:05
          !
          ancp neighbor name dslam1 id 192.168.10.5
           atm 10/103 interface ATM1/0/0.1 client-id "dslam-port-x-identifier"
           atm 11/108 interface ATM1/0/0.1 client-id "dslam-port-y-identifier"

          その他の関連資料

          関連資料

          関連項目

          マニュアル タイトル

          Cisco IOS コマンド

          『Cisco IOS Master Commands List, All Releases』

          ANCP コマンド

          『Cisco IOS Access Node Control Protocol Command Reference』

          IEEE 802.1Q VLAN

          『Configuring Routing Between VLANs with IEEE 802.1Q Encapsulation』

          Queue-in-Queue VLAN タグ

          『IEEE 802.1Q-in-Q VLAN Tag Termination』

          RFC

          RFC

          タイトル

          ANCP 拡張ドラフト

          http:/​/​tools.ietf.org/​id/​draft-wadhwa-gsmp-l2control-configuration-02.txt 『GSMP Extensions for Access Node Control Mechanism』(インターネット ドラフト)

          RFC 3292

          『General Switch Management Protocol (GSMP) V3』

          RFC 3293

          『General Switch Management Protocol (GSMP), Packet Encapsulations for Asynchronous Transfer Mode (ATM), Ethernet and Transmission Control Protocol (TCP)』

          シスコのテクニカル サポート

          説明

          リンク

          シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          Access Node Control Protocol の機能情報

          次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

          プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

          表 1 Access Node Control Protocol の機能情報

          機能名

          リリース

          機能情報

          Access Node Control Protocol

          Cisco IOS XE Release 2.4

          Cisco IOS XE Release 2.4 では、この機能が Cisco ASR 1000 に導入されました。

          次のコマンドが導入されました。ancp vdsl ethernet shaper

          インタラクティブ OAM およびスケーリング強化

          Cisco IOS XE Release 2.4

          インタラクティブ OAM およびスケーリング強化機能は、運用とトラブルシューティングのために ANCP にオンデマンド ping 機能を追加します。

          Cisco IOS XE Release 2.4 では、この機能が Cisco ASR 1000 に導入されました。

          次のコマンドが導入または変更されました。ping ancpshow ancp neighbor portshow ancp portshow ancp sessionshow ancp session adjacencyshow ancp session event、および show ancp statistics