IP ルーティング:プロトコル非依存コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
ポリシーベース ルーティングを使用した Multi-VRF 選択
ポリシーベース ルーティングを使用した Multi-VRF 選択
発行日;2013/06/09   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

ポリシーベース ルーティングを使用した Multi-VRF 選択

ポリシーベース ルーティング(PBR)を使用した Multi-VRF 選択機能を使用すると、プロバイダー エッジ(PE)のデバイス上の指定されたインターフェイスが、IP アクセス リストで定義されているパケット長や一致基準に基づいて、バーチャル プライベート ネットワーク(VPN)にパケットをルーティングできます。

パケットのポリシー ルーティングによる VPN ルーティングおよび転送(VRF)の選択を、ルート マップやグローバル ルーティング テーブルを介して、または指定された VRF にイネーブルにできます。

set コマンドと route map コマンドを使用して VRF インスタンスのポリシールーティング パケットをイネーブルにできます。

サポートされるハードウェアでの同じインターフェイス上で、ポリシーベース ルーティングを使用した Multi-VRF 選択機能と送信元 IP アドレス機能に基づいた MPLS VPN VRF 選択機能の両方を設定できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、プラットフォームおよびソフトウェア リリースの不具合の検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

ポリシーベース ルーティングを使用した Multi-VRF 選択の前提条件

  • デバイスは、この機能を設定できるようにするために、ポリシーベース ルーティング(PBR)をサポートする必要があります。 PBR をサポートしないプラットフォームでは、送信元 IP アドレス機能に基づいて MPLS VPN VRF 選択を使用します。
  • この機能を設定する前に、バーチャル プライベート ネットワーク(VPN)の仮想ルーティングおよび転送(VRF)インスタンスを定義する必要があります。 VRF が存在しない場合は、コンソールにエラー メッセージが表示されます。

ポリシーベース ルーティングを使用した Multi-VRF 選択の制限事項

  • ルーティングを支援するすべてのコマンドは、ハードウェア スイッチングもサポートします。ただし、Cisco Discovery Protocol 情報はラインカード上で使用できないため、set ip next-hop verify availability コマンドは除きます。
  • プロトコル独立マルチキャスト(PIM)およびマルチキャスト パケットはポリシーベース ルーティング(PBR)をサポートしていません。また、この機能の一致基準になっている送信元 IP アドレスには、PIM とマルチキャスト パケットを設定できません。
  • set vrf および set ip global next-hop コマンドは、set default interfaceset interfaceset ip default next-hop、および set ip next-hop コマンドとともに設定できます。 ただし、set vrf および set ip global next-hop コマンドは、set default interfaceset interfaceset ip default next-hop、および set ip next-hop コマンドより優先されます。 これら 3 つの set コマンドのいずれかとともに set vrf コマンドを設定しようとした場合、エラー メッセージは表示されません。
  • ポリシーベース ルーティングを使用した Multi-VRF 選択機能は IP プレフィックス リストでは設定できません。
  • set global および set vrf コマンドは、ルート マップに同時に適用することはできません。
  • ポリシーベース ルーティングを使用した Multi-VRF 選択機能は、VRF-lite、つまり、デバイスで実行される IP ルーティング プロトコルだけをサポートします。 マルチプロトコル ラベル スイッチング(MPLS)およびバーチャル プライベート ネットワーク(VPN)は設定できません。 ただし、set vrf コマンドは、MPLS VPN シナリオで機能します。

ポリシーベース ルーティングを使用した Multi-VRF 選択に関する情報

一致基準に基づいた VPN トラフィックのポリシー ルーティング

ポリシーベース ルーティングを使用した Multi-VRF 選択機能は、送信元 IP アドレスに基づく MPLS VPN VRF 選択機能を拡張したものです。 ポリシーベース ルーティングを使用した Multi-VRF 選択機能では、一致基準に基づいてバーチャル プライベート ネットワーク(VPN)トラフィックをポリシー ルーティングできます。 一致基準は、IP アクセス リストに定義されるか、またはパケット長に基づいて定義されます。 シスコ ソフトウェアがサポートする一致基準は、次のとおりです。

  • IP アクセス リスト:IP アドレス、IP アドレスの範囲、および他の IP パケット アクセス リストのフィルタリング オプションに基づいて、一致基準を定義します。 サポートされるアクセス リストは、名前付きアクセス リスト、番号付きアクセス リスト、標準アクセス リスト、および拡張アクセス リストです。 一致基準の定義にはシスコ ソフトウェアのすべての IP アクセス リスト設定オプションを使用できます。
  • パケット長:パケットの長さ(バイト単位)に基づいて、一致基準を定義します。 パケット長フィルタは、match length ルートマップ コンフィギュレーション コマンドを使用してルート マップに定義されます。

ポリシー ルーティングはルート マップで定義します。 ルート マップは、ip policy route-map インターフェイス コンフィギュレーション コマンドを使用して着信インターフェイスに適用します。 IP アクセス リストは、match ip address ルートマップ コンフィギュレーション コマンドを使用して、ルート マップに適用されます。 パケット長の一致基準は、match length ルートマップ コンフィギュレーション コマンドを使用してルート マップに適用されます。 set アクションは、set vrf ルートマップ コンフィギュレーション コマンドを使用して定義されます。 一致基準が評価され、適切な VRF が set コマンドによって選択されます。 この組み合わせを使用すると、着信 VPN トラフィックの一致基準を定義し、VPN パケットをポリシーに従って適切な仮想ルーティングおよび転送(VRF)インスタンスにルーティングできます。

ポリシーベース ルーティングの set コマンド

VRF インスタンスのポリシールーティング パケット

仮想ルーティングおよび転送(VRF)インスタンスのポリシールーティング パケットをイネーブルにするには、次の set コマンドとともにルート マップ コマンドを使用できます。 これらは、デバイスがパケットのルーティング中に使用する順で一覧されています。

  • set tos:IP パケットのヘッダーのタイプ オブ サービス(TOS)ビットを設定します。
  • set df:IP パケットのヘッダーの Don’t Fragment(DF)ビットを設定します。
  • set vrf:指定されたインターフェイスを介してパケットをルーティングします。 宛先インターフェイスは VRF インスタンスにだけ属することができます。
  • set global:グローバル ルーティング テーブルを使用してパケットをルーティングします。 このコマンドは、特定の VRF に属する入力パケットをグローバル ルーティング テーブルを介してルーティングする場合に有効です。
  • set ip vrf next-hop:指定された VRF の下に IPv4 ネクスト ホップがある必要がある場合の、ポリシー ルーティングのルート マップの一致基準を満たす IPv4 パケットの出力先を示しています。
  • set ipv6 vrf next-hop:指定された VRF の下に IPv6 ネクスト ホップがある必要がある場合の、ポリシー ルーティングのルート マップの一致基準を満たす IPv6 パケットの出力先を示しています。
  • set ip global next-hop:ポリシー ルーティングのルート マップの一致基準を満たしたパケットのうち、シスコ ソフトウェアでグローバル ルーティング テーブルが使用されている IPv4 パケットの転送先を示しています。 global キーワードは、IPv4 ネクストホップがグローバル ルーティング テーブル下にあることを明示的に定義します。
  • set ipv6 global next-hop:ポリシー ルーティングのルート マップの一致基準を満たしたパケットのうち、シスコ ソフトウェアでグローバル ルーティング テーブルが使用されている IPv6 パケットの転送先を示しています。 global キーワードは、IPv6 ネクストホップがグローバル ルーティング テーブル下にあることを明示的に定義します。
  • set interface:パケットが VRF に入るときに、レイヤ 2 書き換え情報を使用できる場合は、set interface ポリシーに従って同じ VRF 下の出力インターフェイスからパケットをルーティングします。
  • set ip default vrf:IPv4 継承 VRF ルーティングと、VRF 間ルーティングを提供します。 継承 VRF ルーティングでは、VRF インターフェイスに到着する IPv4 パケットは、同じ出力 VRF インターフェイスでルーティングされます。 VRF 間ルーティングでは、VRF インターフェイスに到着する IPv4 パケットは、他の出力 VRF インターフェイスのいずれかを介してルーティングされます。
  • set ipv6 default vrf:IPv6 の継承 VRF ルーティングと、VRF 間ルーティングを提供します。 継承 VRF ルーティングでは、VRF インターフェイスに到着する IPv6 パケットは、同じ出力 VRF インターフェイスでルーティングされます。 VRF 間ルーティングでは、VRF インターフェイスに到着する IPv6 パケットは、他の出力 VRF インターフェイスのいずれかを介してルーティングされます。
  • set ip default global:グローバル ルーティングに IPv4 VRF を提供します。
  • set ipv6 default global:グローバル ルーティングに IPv6 VRF を提供します。
  • set default interface:ポリシー ルーティングのルート マップの一致条件を満たしたパケットのうち、宛先に対する明示ルートを持っていないパケットの出力先を示します。 インターフェイスは任意の VRF に属することができます。
  • set ip default next-hop:ポリシー ルーティングのルート マップの一致条件を満たしたパケットのうち、シスコ ソフトウェアが宛先に対する明示ルートを持っていない IPv4 パケットの出力先を指定します。
  • set ipv6 default next-hop:ポリシー ルーティングのルート マップの一致条件を満たしたパケットのうち、シスコ ソフトウェアが宛先に対する明示ルートを持っていない IPv6 パケットの出力先を指定します。

通常のルーティングおよび転送動作の変更

ポリシーベース ルーティング(PBR)を設定するときに、標準のルーティングおよび転送動作を変更するために次の 6 種類の set コマンドを使用できます。 set ip next-hop コマンドの潜在的な例外を除き、これらの set コマンドを設定すると、パケットが仮想ルーティングおよび転送(VRF)インスタンスに属していない場合は、インターフェイスに入るパケットのルーティング動作がオーバーライドされます。 パケットはグローバル ルーティング テーブルを介して出力インターフェイスからルーティングされます。

  • set default interface:ポリシー ルーティングのルート マップの一致条件を満たしたパケットのうち、宛先に対する明示ルートを持っていないパケットの出力先を示します。
  • set interface:パケットが VRF インターフェイスに入るときに、レイヤ 2 書き換え情報を使用できる場合は、set interface ポリシーに従って同じ VRF 下の出力インターフェイスからパケットをルーティングします。

    (注)  


    インターフェイスはピアツーピア(P2P)インターフェイスである必要があります。


  • set ip default next-hop:ポリシー ルーティングのルート マップの一致条件を満たしたパケットのうち、シスコ ソフトウェアが宛先に対する明示ルートを持っていない IPv4 パケットの出力先を指定します。
  • set ipv6 default next-hop:ポリシー ルーティングのルート マップの一致条件を満たしたパケットのうち、シスコ ソフトウェアが宛先に対する明示ルートを持っていない IPv6 パケットの出力先を指定します。
  • set ip next-hop:ポリシー ルーティングのルート マップの一致条件を満たした IPv4 パケットの出力先を指定します。 IPv4 パケットが VRF インターフェイスで受信され、同じ VPN 内の別のインターフェイスから送信されている場合、着信パケットの VRF のコンテキストはインターフェイスから継承されます。
  • set ipv6 next-hop:ポリシー ルーティングのルート マップの一致条件を満たした IPv6 パケットの出力先を指定します。 IPv6 パケットが VRF インターフェイスで受信され、同じバーチャル プライベート ネットワーク(VPN)内の別のインターフェイスから送信されている場合、着信パケットの VRF のコンテキストはインターフェイスから継承されます。

継承 VRF、VRF 間、および VRF からグローバルへのルーティングのサポート

ポリシーベース ルーティング(PBR)を使用した Multi-VRF 選択機能は、継承 VRF および VRF 間ルーティングをサポートします。 継承 VRF ルーティングでは、仮想ルーティングおよび転送(VRF)インターフェイスに到着するパケットは、同じ出力 VRF インターフェイスによってルーティングされます。 VRF 間ルーティングでは、VRF インターフェイスに到着するパケットは、他の出力 VRF インターフェイスのいずれかを介してルーティングされます。

VRF からグローバルへのルーティングによって、任意の VRF インターフェイスに入るパケットがグローバル ルーティング テーブルを介してルーティングされます。 パケットが VRF インターフェイスに到着すると、宛先のルックアップは、通常、対応する VRF テーブルでのみ実行されます。 パケットがグローバル インターフェイスに到着した場合、宛先のルックアップはグローバル ルーティング テーブルで実行されます。

ポリシーベース ルーティングを使用した Multi-VRF 選択機能は、継承 VRF、VRF 間、および VRF からグローバルへのルーティングをサポートするために、次の set コマンドを変更します。 これらのコマンドは、デバイスがパケットのルーティング中に使用する順で示されています。

  • set global:グローバル ルーティング テーブルを使用してパケットをルーティングします。 このコマンドは、特定の VRF に属する入力パケットをグローバル ルーティング テーブルを介してルーティングする場合に有効です。
  • set ip global next-hop:ポリシー ルーティングのルート マップの一致基準を満たしたパケットのうち、シスコ ソフトウェアでグローバル ルーティング テーブルが使用されている IPv4 パケットの転送先を示しています。
  • set ipv6 global next-hop:ポリシー ルーティングのルート マップの一致基準を満たしたパケットのうち、シスコ ソフトウェアでグローバル ルーティング テーブルが使用されている IPv6 パケットの転送先を示しています。
  • set ip vrf next-hop:デバイスが VRF テーブルの IPv4 ネクスト ホップをルックアップするようにします。 IPv4 パケットが VRF に属するインターフェイスに到着し、パケットが別の VRF 経由でルーティングされる必要がある場合は、set ip vrf next-hop コマンドを使用できます。
  • set ipv6 vrf next-hop:デバイスが VRF テーブルの IPv6 ネクスト ホップをルックアップするようにします。 IPv6 パケットが VRF に属するインターフェイスに到着し、パケットが別の VRF 経由でルーティングされる必要がある場合は、set ipv6 vrf next-hop コマンドを使用できます。
  • set ip default vrf:IPv4 継承 VRF ルーティングと、VRF 間ルーティングを提供します。 IPv4 継承 VRF ルーティングでは、VRF インターフェイスに到着する IPv4 パケットは、同じ出力 VRF インターフェイスでルーティングされます。 VRF 間ルーティングでは、VRF インターフェイスに到着する IPv4 パケットは、他の出力 VRF インターフェイスのいずれかを介してルーティングされます。
  • set ipv6 default vrf:IPv6 の継承 VRF ルーティングと、VRF 間ルーティングを提供します。 IPv6 継承 VRF ルーティングでは、VRF インターフェイスに到着する IPv6 パケットは、同じ出力 VRF インターフェイスでルーティングされます。 VRF 間ルーティングでは、VRF インターフェイスに到着する IPv6 パケットは、他の出力 VRF インターフェイスのいずれかを介してルーティングされます。
  • set interface:パケットが VRF に入るときに、レイヤ 2 書き換え情報を使用できる場合は、set interface ポリシーに従って同じ VRF 下の出力インターフェイスからパケットをルーティングします。
  • set default interface:ポリシー ルーティングのルート マップの一致条件を満たしたパケットのうち、宛先に対する明示ルートを持っていないパケットの出力先を示します。 インターフェイスは任意の VRF に属することができます。
  • set ip next-hop:IPv4 パケットを、グローバル ルーティング テーブルを介して IPv4 間のルーティングおよび転送環境でルーティングします。
  • set ipv6 next-hop:IPv6 パケットを、グローバル ルーティング テーブルを介して IPv6 間のルーティングおよび転送環境でルーティングします。
  • set vrf:ルート マップでマッチングが適切に行われた後で、適切な VRF を選択します。 VRS 対応 PSV では、VRF 間(または VRF から VRF への)スイッチングが許可されます。

ポリシーベース ルーティングを使用した Multi-VRF 選択の設定方法

ポリシーベース ルーティングを使用した Multi-VRF 選択の一致基準の定義

デフォルトのルーティングと転送を使用する代わりに選択的にパケットをルーティングするために、ポリシーベース ルーティング(PBR)を使用した Multi-VRF 選択機能の一致基準を定義します。

ポリシーベース ルーティング(PBR)を使用した Multi-VRF 選択の一致基準は、アクセス リストで定義します。 標準アクセス リスト、名前付きアクセス リスト、および拡張アクセス リストがサポートされています。

match lengt ルートマップ コンフィギュレーション コマンドを設定して、パケット長に基づいて一致基準を定義できます。 この設定オプションはすべてルート マップの中だけで定義されます。

ここでは、PBR ルート選択を設定する方法について説明します。

標準アクセス リストとともにポリシーベース ルーティングを使用した Multi-VRF 選択の設定

はじめる前に

ここでは、仮想ルーティングおよび転送(VRF)インスタンス、および関連する IP アドレスがすでに定義されていると見なされます。

手順の概要

    1.    enable

    2.    configure terminal

    3.    access-list access-list-number {deny | permit} [source source-wildcard] [log]


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 access-list access-list-number {deny | permit} [source source-wildcard] [log]


    例:
    Device(config)# access-list 40 permit source 10.1.1.0/24 0.0.0.255 
     

    アクセス リストを作成し、ルート マップの一致基準を定義します。

    • 一致基準は、IP アドレス、IP アドレスの範囲、および他の IP パケット アクセス リストのフィルタリング オプションに基づいて定義できます。 サポートされるアクセス リストは、名前付きアクセス リスト、番号付きアクセス リスト、標準アクセス リスト、および拡張アクセス リストです。 一致基準を定義するために、すべての IP アクセス リスト設定オプションを使用できます。
    • この例は、番号 40 の標準アクセス リストを作成しています。 このフィルタは、10.1.1.0/24 サブネット内の IP アドレスを持つすべてのホストからのトラフィックを許可します。
     

    名前付き拡張アクセス リストとともにポリシーベース ルーティングを使用した Multi-VRF 選択の設定

    名前付き拡張アクセス リストでポリシーベース ルーティング(PBR)を使用した Multi-VRF 選択を設定するには、次の手順を実行します。

    はじめる前に

    ここでは、仮想ルーティングおよび転送(VRF)インスタンス、および関連する IP アドレスがすでに定義されていると見なされます。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    ip access-list {standard | extended} [access-list-name | access-list-number]

      4.    [sequence-number] {permit | deny} protocol source source-wildcard destination destination-wildcard [option option-value] [precedence precedence] [tostos] [ttl operator-vaue] [log] [time-range time-range-name] [fragments]


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Device> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Device# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 ip access-list {standard | extended} [access-list-name | access-list-number]


      例:
      Device(config)# ip access-list extended NAMEDACL 
       

      IP アクセス リストのタイプを指定し、対応するアクセス リスト コンフィギュレーション モードを開始します。

      • 標準、拡張、または名前付きアクセス リストを指定できます。
       
      ステップ 4 [sequence-number] {permit | deny} protocol source source-wildcard destination destination-wildcard [option option-value] [precedence precedence] [tostos] [ttl operator-vaue] [log] [time-range time-range-name] [fragments]


      例:
      Device(config-ext-nacl)# permit ip any any option any-options 
       

      アクセス リストでパケットを許可または拒否する基準を定義します。

      • 一致基準は、IP アドレス、IP アドレスの範囲、および他の IP パケット アクセス リストのフィルタリング オプションに基づいて定義できます。 サポートされるアクセス リストは、名前付きアクセス リスト、番号付きアクセス リスト、標準アクセス リスト、および拡張アクセス リストです。 一致基準を定義するために、すべての IP アクセス リスト設定オプションを使用できます。
      • この例は、設定された IP オプションをすべて許可する名前付きアクセス リストを作成しています。
       

      ルート マップでの Multi-VRF 選択の設定

      着信パケットは、ルート マップに定義された一致基準を使用してフィルタリングされます。 マッチングが適切に行われたあと、set コマンド コンフィギュレーションによって、アウトバウンド バーチャル プライベート ネットワーク(VPN)パケットをポリシーに従ってルーティングする VRF が決定されます。

      はじめる前に

      ルート マップを設定する前に仮想ルーティングおよび転送(VRF)インスタンスを定義する必要があります。そうしないと、エラー メッセージがコンソールに表示されます。

      受信エントリは、ip vrf receive コマンドを使用して VRF 選択テーブルに追加する必要があります。 ルート マップで match と set の処理が行われたときにローカル VRF テーブルに受信エントリがない場合、パケットの宛先がローカルであればそのパケットはドロップされます。

      手順の概要

        1.    enable

        2.    configure terminal

        3.    route-map map-tag [permit | deny] [sequence-number]

        4.    次のいずれかを実行します。

        • set ip vrf vrf-name next-hop global-ipv4-address [...global-ipv4-address]
        • set ipv6 vrf vrf-name next-hop global-ipv6-address [...global-ipv6-address]
        • set ip next-hop recursive vrf global-ipv4-address [...global-ipv4-address]
        • set ip global next-hop global-ipv4-address [...global-ipv4-address]
        • set ipv6 global next-hop global-ipv6-address [...global-ipv6-address]

        5.    次のいずれかを実行します。

        • match ip address {acl-number [acl-name | acl-number]}
        • match length minimum-lengthmaximum-length

        6.    end


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Device> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 configure terminal


        例:
        Device# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 route-map map-tag [permit | deny] [sequence-number]


        例:
        Device(config)# route-map map1 permit 10
         

        あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

        • ルートマップ コンフィギュレーション モードを開始します。
         
        ステップ 4次のいずれかを実行します。
        • set ip vrf vrf-name next-hop global-ipv4-address [...global-ipv4-address]
        • set ipv6 vrf vrf-name next-hop global-ipv6-address [...global-ipv6-address]
        • set ip next-hop recursive vrf global-ipv4-address [...global-ipv4-address]
        • set ip global next-hop global-ipv4-address [...global-ipv4-address]
        • set ipv6 global next-hop global-ipv6-address [...global-ipv6-address]


        例:
        Device(config-route-map)# set ip vrf myvrf next-hop 10.0.0.0 
        


        例:
        Device(config-route-map)# set ipv6 vrf myvrf next-hop 2001.DB8:4:1::1/64


        例:
        Device(config-route-map)# set ip next-hop recursive vrf 10.0.0.0 


        例:
        Device(config-route-map)# set ip global next-hop 10.0.0.0


        例:
        Device(config-route-map)# set ipv6 global next-hop 2001.DB8:4:1::1/64
         

        指定された VRF よりも IPv4 ネクスト ホップが低い必要がある場合に、ポリシー ルーティングのルート マップの一致基準を満たすパケットを転送する宛先を示します。

        指定された VRF よりも IPv6 ネクスト ホップが低い必要がある場合に、ポリシー ルーティングのルート マップの一致基準を満たすパケットを転送する宛先を示します。

        ルート マップに設定されている一致基準を満たすパケットのために宛先またはネクスト ホップが使用される IPv4 アドレスを示します。

        ソフトウェアがグローバル ルーティング テーブルを使用するポリシー ルーティングのルート マップの一致条件を満たすパケットを転送するための IPv4 アドレスを示します。

        ソフトウェアがグローバル ルーティング テーブルを使用するポリシー ルーティングのルート マップの一致条件を満たすパケットを転送するための IPv6 アドレスを示します。

         
        ステップ 5次のいずれかを実行します。
        • match ip address {acl-number [acl-name | acl-number]}
        • match length minimum-lengthmaximum-length


        例:
        Device(config-route-map)# match ip address 1 
        or 


        例:
        Device(config-route-map)# match length 3 200
         

        標準アクセス リストまたは拡張アクセス リストで宛先ネットワーク番号のアドレスが許可されているルートを配布し、一致したパケットのポリシー ルーティングを行います。 IP アクセス リストがサポートされます。

        • この例は、標準アクセス リスト 1 を使用して一致基準を定義するように、ルート マップを設定しています。

        IP ヘッダー中のレイヤ 3 パケット長をクラス マップ中の一致条件として指定します。

        • この例は、長さが 3 ~ 200 バイトのパケットに一致するルート マップを設定しています。
         
        ステップ 6 end


        例:
        Device(config-route-map)# end 
         

        特権 EXEC モードに戻ります。

         

        インターフェイスでポリシーベース ルーティングと IP VRF 受信を使用した Multi-VRF 選択の設定

        ルート マップは、ip policy route-map インターフェイス コンフィギュレーション コマンドを使用して着信インターフェイスに適用されます。

        送信元 IP アドレスは仮想ルーティングおよび転送(VRF)選択テーブルに追加する必要があります。 VRF 選択は一方向(単一方向)の機能で、 着信インターフェイスに適用されます。 ルート マップで matchset の処理が行われたときにローカル VRF テーブルに受信エントリがない場合、パケットの宛先がローカルであればそのパケットはドロップされます。

        手順の概要

          1.    enable

          2.    configure terminal

          3.    interface type number [name-tag]

          4.    ip policy route-map map-tag

          5.    ip vrf receive vrf-name

          6.    end


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Device> enable
           

          特権 EXEC モードをイネーブルにします。

          • パスワードを入力します(要求された場合)。
           
          ステップ 2 configure terminal


          例:
          Device# configure terminal
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3 interface type number [name-tag]


          例:
          Device(config)# interface FastEthernet 0/1/0 
           

          インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

           
          ステップ 4 ip policy route-map map-tag


          例:
          Device(config-if)# ip policy route-map map1
           

          インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

          • この設定例は、map1 という名前のルート マップをインターフェイスに付加しています。
           
          ステップ 5 ip vrf receive vrf-name


          例:
          Device(config-if)# ip vrf receive VRF-1
           

          インターフェイスに関連付けられた IP アドレスを VRF テーブルに追加します。

          • このコマンドは、VRF 選択に使用される VRF ごとに設定する必要があります。
           
          ステップ 6 end


          例:
          Device(config-if)# end 
           

          特権 EXEC モードに戻ります。

           

          ポリシーベース ルーティングを使用した Multi-VRF 選択の設定の確認

          ポリシーベース ルーティング(PBR)を使用した Multi-VRF 選択機能の設定を確認するには、次の手順を実行します。 コマンドは任意の順序で入力できます。

          手順の概要

            1.    show ip access-list [access-list-number | access-list-name]

            2.    show route-map [map-name]

            3.    show ip policy


          手順の詳細
            ステップ 1   show ip access-list [access-list-number | access-list-name]

            ポリシーベース ルーティングを使用した Multi-VRF 選択の一致基準の設定を確認します。 コマンド出力には、3 つの標準アクセス リストに一致基準として定義された 3 つのサブネット範囲が表示されます。



            例:
            Device# show ip access-list
             
            Standard IP access list 40
             10 permit 10.1.0.0, wildcard bits 0.0.255.255
            Standard IP access list 50
             10 permit 10.2.0.0, wildcard bits 0.0.255.255
            Standard IP access list 60
             10 permit 10.3.0.0, wildcard bits 0.0.255.255
            
            ステップ 2   show route-map [map-name]

            ルート マップ内の match および set コマンドを確認します。



            例:
            Device# show route-map
            

            出力には、各ルート マップ シーケンスの一致基準および設定アクションが表示されます。 また、出力には、ルート マップ シーケンスごとに、ポリシー ルーティングが行われたパケット数とバイト数も表示されます。



            例:
            Device# show route-map map1 
            
            route-map map1, permit, sequence 10
            Match clauses:
            Set clauses:
             ip next-hop vrf myvrf 10.5.5.5  10.6.6.6  10.7.7.7
             ip next-hop global 10.8.8.8  10.9.9.9
            Policy routing matches: 0 packets, 0 bytes
            Device# show route-map map2 
            route-map map2, permit, sequence 10
            Match clauses:
            Set clauses:
             vrf myvrf 
            Policy routing matches: 0 packets, 0 bytes
            Device# show route-map map3 
            route-map map3, permit, sequence 10
            Match clauses:
            Set clauses:
             global
            Policy routing matches: 0 packets, 0 bytes
            

            次の show route-map コマンドは、set ip vrf next-hop コマンドの出力を表示します。



            例:
            Device(config)# route-map test
             
            Device(config-route-map)# set ip vrf myvrf next-hop 
            Device(config-route-map)# set ip vrf myvrf next-hop 192.168.3.2
            Device(config-route-map)# match ip address 255 101
            Device(config-route-map)# end
            Device# show route-map
             
            route-map test, permit, sequence 10
             Match clauses:
              ip address (access-lists): 101
             Set clauses:
              ip vrf myvrf next-hop 192.168.3.2
             Policy routing matches: 0 packets, 0 bytes

            次の show route-map コマンドは、set ip global コマンドの出力を表示します。



            例:
            Device(config)# route-map test
            Device(config-route-map)# match ip address 255 101
            Device(config-route-map)# set ip global next-hop 192.168.4.2 
            Device(config-route-map)# end
            Device# show route-map
             
            *May 25 13:45:55.551: %SYS-5-CONFIG_I: Configured from console by consoleout-map
            route-map test, permit, sequence 10
             Match clauses:
              ip address (access-lists): 101
             Set clauses:
              ip global next-hop 192.168.4.2
             Policy routing matches: 0 packets, 0 bytes
            
            ステップ 3   show ip policy

            ポリシーベース ルーティングを使用した Multi-VRF 選択のポリシーを確認します。



            例:
            Device# show ip policy
            

            次の show ip policy コマンド出力には、ポリシー ルーティングを設定したインターフェイスおよび関連付けられたルート マップが表示されます。



            例:
            Device# show ip policy 
            
            Interface                Route map
            FastEthernet0/1/0        PBR-VRF-Selection

            ポリシーベース ルーティングを使用した Multi-VRF 選択の設定例

            例:ポリシーベース ルーティングを使用した Multi-VRF 選択の一致基準の定義

            次に、3 つの標準アクセス リストを作成して、3 つの異なるサブネットワークの一致基準を定義する例を示します。 FastEthernet インターフェイス 0/1/0 で受信されたすべてのパケットは、PBR-VRF-Selection ルート マップを経由して、同じルートマップ シーケンスで一致した仮想ルーティングおよび転送(VRF)にルーティングされます。 パケットの送信元 IP アドレスが 10.1.0.0/24 サブネットに含まれる場合は、ルーティングおよび転送に VRF1 が使用されます。

            access-list 40 permit source 10.1.0.0 0.0.255.255
            access-list 50 permit source 10.2.0.0 0.0.255.255
            access-list 60 permit source 10.3.0.0 0.0.255.255
            route-map PBR-VRF-Selection permit 10
             match ip address 40
             set vrf VRF1
             !
            route-map PBR-VRF-Selection permit 20
             match ip address 50
             set vrf VRF2
             !
            route-map PBR-VRF-Selection permit 30
             match ip address 60
             set vrf VRF3
             !
            interface FastEthernet 0/1/0
             ip address 192.168.1.6 255.255.255.252
             ip vrf forwarding VRF4 
             ip policy route-map PBR-VRF-Selection
             ip vrf receive VRF1
             ip vrf receive VRF2
             ip vrf receive VRF3 

            例:ルート マップでの Multi-VRF 選択の設定

            次の例は、myvrf という名前の仮想ルーティングおよび転送(VRF)インターフェイスにポリシーベース ルーティングを適用し、ネクスト ホップの IP アドレスを 10.0.0.2 として指定する set ip vrf next-hop コマンドを示します。

            Device(config)# route-map map1 permit
            Device(config)# set vrf myvrf
            Device(config-route-map)# set ip vrf myvrf next-hop 10.0.0.2
            Device(config-route-map)# match ip address 101
            Device(config-route-map)# end
            

            次の例は、デバイスがグローバル ルーティング テーブルでネクスト ホップ アドレス 10.0.0.1 を使用するように指定する、set ip global コマンドを示します。

            Device(config-route-map)# set ip global next-hop 10.0.0.1 
            

            その他の関連資料

            関連資料

            関連項目

            マニュアル タイトル

            Cisco IOS コマンド

            『Cisco Master Command List, All Releases』

            MPLS と MPLS アプリケーション コマンド

            『Cisco IOS Multiprotocol Label Switching Command Reference』

            IP アクセス リスト コマンド

            『Cisco IOS Security Command Reference』

            シスコのテクニカル サポート

            説明

            リンク

            シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

            http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

            ポリシーベース ルーティングを使用した Multi-VRF 選択の機能情報

            次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

            プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

            表 1 ポリシーベース ルーティングを使用した Multi-VRF 選択の機能情報

            機能名

            リリース

            機能情報

            ポリシーベース ルーティング(PBR)を使用した Multi-VRF 選択

            12.2(33)SRB1

            12.2(33) SXH1

            12.4(24)T

            Cisco IOS XE Release 2.2

            ポリシーベース ルーティング(PBR)を使用した Multi-VRF 選択機能を使用すると、プロバイダー エッジ(PE)のルータ上の指定されたインターフェイスが、IP アクセス リストで定義されているパケット長や一致基準に基づいて、バーチャル プライベート ネットワーク(VPN)にパケットをルーティングできます。 この機能と、MPLS VPN 送信元 IP アドレスに基づく VRF 選択機能は、同じインターフェイス上で一緒に設定できます。

            この機能は、Cisco IOS Release 12.2(33)SRB1 で導入されました。

            サポートは、Cisco IOS Release 12.2(33)SXH1 で追加されました。

            この機能は、Cisco IOS Release 12.4(24)T で統合されました。

            Cisco IOS XE Release 2.2 では、この機能は Cisco ASR 1000 シリーズ アグリゲーション サービス ルータに実装されました。

            次のコマンドが変更されました。set ip global next-hop および set ip vrf next-hop

            IPv6 VRF 対応 PBR のネクストホップの機能拡張

            15.2(2)S

            Cisco IOS XE Release 3.6S

            この機能は、Cisco IOS Release 15.2(2)S で導入されました。

            Cisco IOS XE Release 3.6S では、この機能は Cisco ASR 1000 シリーズ アグリゲーション サービス ルータに導入されました。

            次のコマンドが導入されました。set ipv6 default next-hopset ipv6 next-hop (PBR)

            用語集

            CE デバイス:カスタマー エッジ デバイス。 カスタマー ネットワークに属し、プロバイダー エッジ(PE)デバイスとのインターフェイスとなるデバイス。

            継承 VRF ルーティング:VRF インターフェイスに到着したパケットは、同じ出力 VRF インターフェイスでルーティングされます。

            VRF 間ルーティング:VRF インターフェイスに到着するパケットは、他の出力 VRF のインターフェイス経由でルーティングされます。

            IP:Internet Protocol(インターネット プロトコル)。 TCP/IP スタックにおいてコネクションレス型のネットワーク間サービスを提供するネットワーク層プロトコル。 IP では、アドレッシング、タイプ オブ サービス指定、フラグメンテーションと再編成、セキュリティなどの機能が提供されます。 RFC 791 に定義されています。

            PBR:Policy-Based Routing(ポリシーベース ルーティング)。 PBR では、受信パケットをどのようにルーティングするかをユーザが手動で設定することができます。

            PE デバイス:プロバイダー エッジ デバイス。 サービス プロバイダーのネットワークの一部であり、CE デバイスに接続されたデバイス。 これは、スタティック ルーティングまたは BGP、RIPv1、RIPv2 などのルーティング プロトコルを使用して CE デバイスとルーティング情報を交換します。

            VPN:バーチャル プライベート ネットワーク。 共通のルーティング テーブルを共有するサイトのコレクション。 VPN は、ISP バックボーン ネットワーク上で帯域幅を共有するための安全な方法を提供します。

            VRF:VPN Routing and Forwarding(VPN ルーティングおよび転送)インスタンス。 VRF は、IP ルーティング テーブル、取得されたルーティング テーブル、そのルーティング テーブルを使用する一連のインターフェイス、ルーティング テーブルに登録されるものを決定する一連のルールおよびルーティング プロトコルで構成されています。

            VRF-Lite:サービス プロバイダーが複数の VPN をサポートし、VPN 間で IP アドレスを重複して使用できるようにする機能。