IP ルーティング:プロトコル非依存コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
BGP による QoS ポリシー伝搬
BGP による QoS ポリシー伝搬
発行日;2013/06/09   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

BGP による QoS ポリシー伝搬

BGP による QoS ポリシー伝搬機能を使用すると、ボーダー ゲートウェイ プロトコル(BGP)コミュニティ リスト、BGP 自律システム パス、およびアクセス リストに基づいて IP precedence によってパケットを分類できます。 パケットが分類されたら、専用アクセス レート(CAR)および重み付けランダム早期検出(WRED)など、その他の Quality of Service(QoS)機能を使用してビジネス モデルに合うようにポリシーを指定および強化できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、プラットフォームおよびソフトウェア リリースの不具合の検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

BGP による QoS ポリシー伝搬の前提条件

  • デバイスでボーダー ゲートウェイ プロトコル(BGP)およびシスコ エクスプレス フォワーディング(CEF)または分散型 CEF(dCEF)をイネーブルにします。 bgp-policy コマンドをイネーブルにした ATM インターフェイスのサブインターフェイスでは、dCEF がサポートされないため、CEF モードを使用する必要があります。 dCEF は、ルート スイッチ プロセッサ(RSP)ではなくバーサタイル インターフェイス プロセッサ(VIP)を使用してフォワーディング機能を実行します。
  • ポリシーを定義する。
  • BGP 経由でポリシーを適用する。
  • BGP コミュニティ リスト、BGP 自律システム パス、またはアクセス リストを設定し、インターフェイスでポリシーをイネーブルにする。
  • ポリシーを使用するために専用アクセス レート(CAR)または重み付けランダム早期検出(WRED)をイネーブルにします。

BGP による QoS ポリシー伝搬に関する情報

BGP による QoS ポリシー伝搬の利点

BGP による QoS ポリシー伝搬機能を使用すると、BGP コミュニティ リスト、BGP 自律システム パス、およびアクセス リストに基づいて IP precedence によってパケットを分類できます。 パケットが分類されたら、専用アクセス レート(CAR)および重み付けランダム早期検出(WRED)など、その他の QoS 機能を使用してビジネス モデルに合うようにポリシーを指定および強化できます。

BGP による QoS ポリシー伝搬の設定方法

コミュニティ リストに基づいた BGP による QoS ポリシー伝搬の設定

手順の概要

    1.    enable

    2.    configure terminal

    3.    route-map route-map-name [permit | deny [sequence-number]]

    4.    match community {standard-list-number | expanded-list-number | community-list-name [exact]}

    5.    set ip precedence [number | name]

    6.    exit

    7.    router bgp autonomous-system

    8.    table-map route-map-name

    9.    exit

    10.    ip community-list standard-list-number {permit | deny} [community-number]

    11.    interface type number

    12.    bgp-policy {source | destination} ip-prec-map

    13.    exit

    14.    ip bgp-community new-format

    15.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 route-map route-map-name [permit | deny [sequence-number]]


    例:
    Device(config)# route-map rm1
     

    再配布を制御するためのルート マップを定義し、ルート マップ コンフィギュレーション モードに入ります。

     
    ステップ 4 match community {standard-list-number | expanded-list-number | community-list-name [exact]}


    例:
    Device(config-route-map)# match community 1
     

    ボーダー ゲートウェイ プロトコル(BGP)のコミュニティ リストと照合します。

     
    ステップ 5 set ip precedence [number | name]


    例:
    Device(config-route-map)# set ip precedence 5
     

    コミュニティ リストが一致するときの IP precedence フィールドを設定します。

    (注)     

    優先順位の番号または名前を指定できます。

     
    ステップ 6 exit


    例:
    Device(config-route-map)# exit
     

    ルート マップ インターフェイス コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 7router bgp autonomous-system


    例:
    Device(config)# router bgp 45000
     

    BGP プロセスをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

     
    ステップ 8 table-map route-map-name


    例:
    Device(config-router)# table-map rm1
     

    BGP で学習したルートで IP ルーティング テーブルが更新される場合の、メトリックとタグの値を修正します。

     
    ステップ 9 exit


    例:
    Device(config-router)# exit
     

    ルータ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 10ip community-list standard-list-number {permit | deny} [community-number]


    例:
    Device(config)# ip community-list 1 permit 2
     

    BGP のコミュニティ リストを作成し、アクセスを制御します。

     
    ステップ 11interface type number


    例:
    Device(config)# interface gigabitethernet 0/0/0
     

    インターフェイス(またはサブインターフェイス)を指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 12 bgp-policy {source | destination} ip-prec-map


    例:
    Device(config-if)# bgp-policy source ip-prec-map
     

    IP precedence を使用してパケットを分類します。

     
    ステップ 13 exit


    例:
    Device(config-if)# exit
     

    インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 14 ip bgp-community new-format


    例:
    Device(config)# ip bgp-community new-format
     

    (任意)BGP コミュニティ番号を AA:NN(自律システム:コミュニティ番号/4 バイトの数)の形式で表示します。

     
    ステップ 15 end


    例:
    Device(config)# end
     

    グローバル コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

     

    自律システム パス属性に基づいた BGP による QoS ポリシー伝搬の設定

    手順の概要

      1.    enable

      2.    configure terminal

      3.    route-map route-map-name [permit | deny [sequence-number]]

      4.    match as-path path-list-number

      5.    set ip precedence [number | name]

      6.    exit

      7.    router bgp autonomous-system

      8.    table-map route-map-name

      9.    exit

      10.    ip as-path access-list access-list-number {permit | deny} as-regular-expression

      11.    interface type number

      12.    bgp-policy {source | destination} ip-prec-map

      13.    end


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Device> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Device# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 route-map route-map-name [permit | deny [sequence-number]]


      例:
      Device(config)# route-map rm1
       

      再配布を制御するためのルート マップを定義し、ルート マップ コンフィギュレーション モードに入ります。

       
      ステップ 4match as-path path-list-number


      例:
      Device(config-route-map)# match as-path 2
       

      ボーダー ゲートウェイ プロトコル(BGP)自律システム パス アクセス リストに照合します。

       
      ステップ 5set ip precedence [number | name]


      例:
      Device(config-route-map)# set ip precedence 5
       

      自律システム パスが一致するときの IP precedence フィールドを設定します。

      (注)     

      優先順位の番号または名前を指定できます。

       
      ステップ 6 exit


      例:
      Device(config-route-map)# exit
       

      ルート マップ インターフェイス コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

       
      ステップ 7 router bgp autonomous-system


      例:
      Device(config)# router bgp 45000
       

      BGP プロセスをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

       
      ステップ 8table-map route-map-name


      例:
      Device(config-router)# table-map rm1
       

      BGP で学習したルートで IP ルーティング テーブルが更新される場合の、メトリックとタグの値を修正します。

       
      ステップ 9 exit


      例:
      Device(config-router)# exit
       

      ルータ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

       
      ステップ 10ip as-path access-list access-list-number {permit | deny} as-regular-expression


      例:
      Device(config)# ip as-path access-list 500 permit 45000
       

      自律システム パスのアクセス リストを定義します。

       
      ステップ 11 interface type number


      例:
      Device(config)# interface gigabitethernet 0/0/0
       

      インターフェイス(またはサブインターフェイス)を指定し、インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 12bgp-policy {source | destination} ip-prec-map


      例:
      Device(config-if)# bgp-policy source ip-prec-map
       

      IP precedence を使用してパケットを分類します。

       
      ステップ 13 end


      例:
      Device(config-if)# end
       

      インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

       

      アクセス リストに基づいた BGP による QoS ポリシー伝搬の設定

      手順の概要

        1.    enable

        2.    configure terminal

        3.    route-map route-map-name [permit | deny [sequence-number]]

        4.    match ip address access-list-number

        5.    set ip precedence [number | name]

        6.    exit

        7.    router bgp autonomous-system

        8.    table-map route-map-name

        9.    exit

        10.    access-list access-list-number {permit | deny} source

        11.    interface type number

        12.    bgp-policy {source | destination} ip-prec-map

        13.    end


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1enable


        例:
        Device> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 configure terminal


        例:
        Device# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 route-map route-map-name [permit | deny [sequence-number]]


        例:
        Device(config)# route-map rm1
         

        再配布を制御するためのルート マップを定義し、ルート マップ コンフィギュレーション モードに入ります。

         
        ステップ 4 match ip address access-list-number


        例:
        Device(config-route-map)# match ip address 69
         

        アクセス リストを照合します。

         
        ステップ 5set ip precedence [number | name]


        例:
        Device(config-route-map)# set ip precedence routine
         

        自律システム パスが一致するときの IP precedence フィールドを設定します。

         
        ステップ 6 exit


        例:
        Device(config-route-map)# exit
         

        ルート マップ インターフェイス コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

         
        ステップ 7 router bgp autonomous-system


        例:
        Device(config)# router bgp 45000
         

        ボーダー ゲートウェイ プロトコル(BGP)プロセスをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

         
        ステップ 8table-map route-map-name


        例:
        Device(config-router)# table-map rm1
         

        BGP で学習したルートで IP ルーティング テーブルが更新される場合の、メトリックとタグの値を修正します。

         
        ステップ 9 exit


        例:
        Device(config-router)# exit
         

        ルータ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

         
        ステップ 10access-list access-list-number {permit | deny} source


        例:
        Device(config)# access-list 69 permit 10.69.0.0
         

        アクセス リストを定義します。

         
        ステップ 11 interface type number


        例:
        Device(config)# interface gigabitethernet 0/0/0
         

        インターフェイス(またはサブインターフェイス)を指定し、インターフェイス コンフィギュレーション モードに入ります。

         
        ステップ 12bgp-policy {source | destination} ip-prec-map


        例:
        Device(config-if)# bgp-policy source ip-prec-map
         

        IP precedence を使用してパケットを分類します。

         
        ステップ 13 end


        例:
        Device(config-if)# end
         

        インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

         

        BGP による QoS ポリシー伝搬のモニタリング

        BGP による QoS ポリシー伝搬機能の設定をモニタするには、次のオプション コマンドを使用します。

        コマンドまたはアクション

        目的

        show ip bgp

        適切なコミュニティがプレフィックスで設定されているかどうかを確認するために、ボーダー ゲートウェイ プロトコル(BGP)ルーティング テーブルのエントリを表示します。

        show ip bgp community-list community-list-number
        

        適切なプレフィックスが選択されているかどうかを確認するために、BGP コミュニティによって許可されたルートを表示します。

        show ip cef network

        シスコ エクスプレス フォワーディングのプレフィックスの優先値が適切かどうかを確認するために、指定された IP アドレスに基づいた転送情報ベース(FIB)テーブルのエントリを表示します。

        show ip interface

        インターフェイスに関する情報を表示します。

        show ip route prefix

        適切な優先値がプレフィックスで設定されていることを確認するために、ルーティング テーブルの現在のステータスを表示します。

        BGP による QoS ポリシー伝搬の設定例

        例:BGP による QoS ポリシー伝搬の設定

        次の例では、アクセス リスト、ボーダー ゲートウェイ プロトコル(BGP)コミュニティ リスト、および BGP 自律システムパスを照合するためのルート マップを作成し、ネイバーから学習されたルートに IP precedence を適用する方法を示します。

        次の図では、デバイス A が自律システム 10 と自律システム 60 からのルートを学習します。 Quality of Service(QoS)ポリシーは、定義済みのルート マップに一致するすべてのパケットに適用されます。 デバイス A から自律システム 10 または自律システム 60 へのパケットは、図の番号付きの手順が示すように、適切な QoS ポリシーで送信されます。

        図 1. デバイスのルート学習と QoS ポリシーの適用

        デバイス A の設定

        interface serial 5/0/0/1:0
        ip address 10.28.38.2 255.255.255.0
        bgp-policy destination ip-prec-map
        no ip mroute-cache
        no cdp enable
        frame-relay interface-dlci 20 IETF
        router bgp 30
         table-map precedence-map
         neighbor 10.20.20.1 remote-as 10
         neighbor 10.20.20.1 send-community
        !
        ip bgp-community new-format
        !
        ! Match community 1 and set the IP precedence to priority
        route-map precedence-map permit 10
         match community 1
         set ip precedence priority
        !
        ! Match community 2 and set the IP precedence to immediate
        route-map precedence-map permit 20
         match community 2
         set ip precedence immediate
        !
        ! Match community 3 and set the IP precedence to flash
        route-map precedence-map permit 30
         match community 3
         set ip precedence flash
        !
        ! Match community 4 and set the IP precedence to flash-override
        route-map precedence-map permit 40
         match community 4
         set ip precedence flash-override
        !
        ! Match community 5 and set the IP precedence to critical
        route-map precedence-map permit 50
         match community 5
         set ip precedence critical
        !
        ! Match community 6 and set the IP precedence to internet
        route-map precedence-map permit 60
         match community 6
         set ip precedence internet
        !
        ! Match community 7 and set the IP precedence to network
        route-map precedence-map permit 70
         match community 7
         set ip precedence network
        !
        ! Match ip address access list 69 or match autonomous system path 1
        ! and set the IP precedence to critical
        route-map precedence-map permit 75
         match ip address 69
         match as-path 1
         set ip precedence critical
        !
        ! For everything else, set the IP precedence to routine
        route-map precedence-map permit 80
         set ip precedence routine
        !
        ! Define community lists 
        ip community-list 1 permit 60:1
        ip community-list 2 permit 60:2
        ip community-list 3 permit 60:3
        ip community-list 4 permit 60:4
        ip community-list 5 permit 60:5
        ip community-list 6 permit 60:6
        ip community-list 7 permit 60:7
        !
        ! Define the AS path
        ip as-path access-list 1 permit ^10_60
        !
        ! Define the access list
        access-list 69 permit 10.69.0.0

        デバイス B の設定

        router bgp 10
         neighbor 10.30.30.1 remote-as 30
         neighbor 10.30.30.1 send-community
         neighbor 10.30.30.1 route-map send_community out
        !
        ip bgp-community new-format
        !
        ! Match prefix 10 and set community to 60:1
        route-map send_community permit 10
         match ip address 10
         set community 60:1
        !
        ! Match prefix 20 and set community to 60:2
        route-map send_community permit 20
         match ip address 20
         set community 60:2
        !
        ! Match prefix 30 and set community to 60:3
        route-map send_community permit 30
         match ip address 30
         set community 60:3
        !
        ! Match prefix 40 and set community to 60:4
        route-map send_community permit 40
         match ip address 40
         set community 60:4
        !
        ! Match prefix 50 and set community to 60:5
        route-map send_community permit 50
         match ip address 50
         set community 60:5
        !
        ! Match prefix 60 and set community to 60:6
        route-map send_community permit 60
         match ip address 60
         set community 60:6
        !
        ! Match prefix 70 and set community to 60:7
        route-map send_community permit 70
         match ip address 70
         set community 60:7
        !
        ! For all others, set community to 60:8
        route-map send_community permit 80
         set community 60:8
        !
        ! Define access lists
        access-list 10 permit 10.61.0.0
        access-list 20 permit 10.62.0.0
        access-list 30 permit 10.63.0.0
        access-list 40 permit 10.64.0.0
        access-list 50 permit 10.65.0.0
        access-list 60 permit 10.66.0.0
        access-list 70 permit 10.67.0.0

        その他の関連資料

        関連資料

        関連項目

        マニュアル タイトル

        Cisco IOS コマンド

        『Cisco IOS Master Command List, All Releases』

        IP ルーティングのプロトコル独立型コマンド

        『Cisco IOS IP Routing: Protocol-Independent Command Reference』

        BGP の設定

        『BGP Configuration Guide』

        シスコ エクスプレス フォワーディングの設定

        『Cisco Express Forwarding Configuration Guide』

        専用アクセス レートの設定

        QoS: Classification Configuration Guide』(『Quality of Service Solutions Configuration Guide Library』の一部)の「Configuring Committed Access Rate」モジュール

        重み付けランダム早期検出の設定

        QoS: Congestion Avoidance Configuration Guide』(『Quality of Service Solutions Configuration Guide Library』の一部)の「Configuring Weighted Random Early Detection」モジュール

        シスコのテクニカル サポート

        説明

        リンク

        シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

        http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

        BGP による QoS ポリシー伝搬の機能情報

        次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

        プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

        表 1 BGP による QoS ポリシー伝搬の機能情報

        機能名

        リリース

        機能情報

        BGP による QoS ポリシー伝搬

        BGP による QoS ポリシー伝搬機能を使用すると、BGP コミュニティ リスト、BGP 自律システム パス、およびアクセス リストに基づいて IP precedence によってパケットを分類できます。 パケットが分類されたら、専用アクセス レート(CAR)および重み付けランダム早期検出(WRED)など、その他の QoS 機能を使用してビジネス モデルに合うようにポリシーを指定および強化できます。

        ポリシー ルーティングのインフラストラクチャ

        ポリシー ルーティングのインフラストラクチャ機能により、シスコ エクスプレス フォワーディング(CEF)での IP ポリシーベース ルーティングのフル サポートが実現します。 CEF により高速スイッチングが徐々に時代遅れになるに伴い、ポリシー ルーティングが CEF と統合され、増大するお客様のパフォーマンス要件に対応します。 ポリシー ルーティングがイネーブルの場合、冗長な処理は回避されます。