IP ルーティング:プロトコル非依存コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
複数のトラッキング オプションに対する PBR サポート
複数のトラッキング オプションに対する PBR サポート
発行日;2013/06/09   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

複数のトラッキング オプションに対する PBR サポート

複数のトラッキング オプションに対する PBR サポート機能は、Cisco Discovery Protocol(CDP)を使ったオブジェクト トラッキングの機能を拡張し、追加の方法を使って、ポリシーベース ルーティング(PBR)処理でオブジェクトが使用可能かどうかを確認できます。 確認方法として使用できるのは、Internet Control Message Protocol(ICMP)ping、ユーザ データグラム プロトコル(UDP)ping、または HTTP GET です。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、プラットフォームおよびソフトウェア リリースの不具合の検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

複数のトラッキング オプションに対する PBR サポートの概要

オブジェクト トラッキング

オブジェクト トラッキングは、次のようなオブジェクトをモニタする独立したプロセスです。

  • インターフェイスの回線プロトコルの状態
  • ルーティング テーブル内のエントリの存在
  • ping など、Service Assurance Agent(SAA)動作の結果

ホットスタンバイ ルータ プロトコル(HSRP)、Virtual Router Redundancy Protocol(VRRP)、Gateway Load Balancing Protocol(GLBP)、(この機能を使用した)PBR などのクライアントは、特定のトラッキング対象オブジェクトを登録して、オブジェクトの状態が変化したときに処理を実行できます。

複数のトラッキング オプションに対する PBR サポートの機能設計

複数のトラッキング オプションに対する PBR サポート機能は、トラッキング プロセスを通じて使用できるすべてのオブジェクトへの PBR アクセスを提供します。 トラッキング プロセスを使って、ICMP ping 到達可能性、ルーティング隣接関係、リモート デバイス上で実行中のアプリケーション、ルーティング情報ベース(RIB)内のルートなどの個々のオブジェクトや、インターフェイス回線プロトコルの状態をトラッキングできます。

オブジェクト トラッキングは次のように機能します。 PBR は、特定のオブジェクトのトラッキングが必要なことをトラッキング プロセスに通知します。 一方、トラッキング プロセスはそのオブジェクトの状態が変化した場合に PBR に通知します。

複数のトラッキング オプションに対する PBR サポートの設定方法

Cisco IOS Release 12.3(14)T で IP サービス レベル契約(SLA)に新しい構文が導入されたため、この項の作業は実行している Cisco IOS Release によって異なります。 この機能を使用するには、Cisco IOS Release 12.3(4)T、12.2(25)S 以降のリリースを実行している必要があります。 ここでは、次のタスクについて説明します。

Cisco IOS Release 12.3(11)T、12.2(25)S、およびそれ以前

複数のトラッキング オプションに対する PBR サポートを設定するには、次の作業を実行します。 この作業では、ルート マップを作成および設定し、トラッキング対象オブジェクトの到達可能性を確認します。

はじめる前に

この作業では、Cisco IOS Release 12.3(11)T、12.2(25)S 以前のリリースを実行中のネットワーキング デバイスが必要です。

手順の概要

    1.    enable

    2.    configure terminal

    3.    rtr operation-number

    4.    type echo protocol protocol-type target [source-ipaddr ip-address]

    5.    exit

    6.    rtr schedule operation-number [life {forever | seconds}] [start-time {hh : mm[: ss] [month day | day month] | pending | now | after hh : mm : ss}] [ageout seconds]

    7.    track object-number rtr entry-number [reachability]

    8.    delay {up seconds [down seconds] | [up seconds] down seconds}

    9.    exit

    10.    interface type number

    11.    ip address ip-address mask [secondary]

    12.    ip policy route-map map-tag

    13.    exit

    14.    route-map map-tag [permit | deny] [sequence-number]

    15.    set ip next-hop verify-availability [next-hop-address sequence track object]

    16.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 rtr operation-number


    例:
    Router(config)# rtr 1
     

    SAA RTR コンフィギュレーション モードを開始し、SAA 動作を設定します。

     
    ステップ 4 type echo protocol protocol-type target [source-ipaddr ip-address]


    例:
    Router(config-rtr)# type echo protocol ipicmpecho 10.1.1.10
     

    SAA エンドツーエンド エコー応答時間プローブ動作を設定します。

     
    ステップ 5 exit


    例:
    Router(config-rtr)# exit
     

    SAA RTR コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

     
    ステップ 6 rtr schedule operation-number [life {forever | seconds}] [start-time {hh : mm[: ss] [month day | day month] | pending | now | after hh : mm : ss}] [ageout seconds]


    例:
    Router(config)# rtr schedule 1 life forever start-time now
     

    SAA 動作の時間パラメータを設定します。

     
    ステップ 7 track object-number rtr entry-number [reachability]


    例:
    Router(config)# track 123 rtr 1 reachability
     

    Response Time Reporter(RTR)オブジェクトの到達可能性をトラッキングし、トラッキング コンフィギュレーション モードを終了します。

     
    ステップ 8 delay {up seconds [down seconds] | [up seconds] down seconds}


    例:
    Router(config-track)# delay up 60 down 30
     

    (任意)追跡対象オブジェクトのステート変更の通信を遅延させる時間(秒)を指定します。

     
    ステップ 9 exit


    例:
    Router(config-track)# exit
     

    トラッキング コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

     
    ステップ 10 interface type number


    例:
    Router(config)# interface ethernet 0
     

    インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 11 ip address ip-address mask [secondary]


    例:
    Router(config-if)# ip address 10.1.1.11 255.0.0.0 
     

    インターフェイスのプライマリ IP アドレスまたはセカンダリ IP アドレスを指定します。

    • IPv4 アドレスの設定手順については、『Cisco IOS IP Addressing Services Configuration Guide』の「Configuring IPv4 Addresses」の章を参照してください。
     
    ステップ 12 ip policy route-map map-tag


    例:
    Router(config-if)# ip policy route-map alpha
     

    ポリシー ルーティングをイネーブルにし、ポリシー ルーティングに使用するルート マップを指定します。

     
    ステップ 13 exit


    例:
    Router(config-if)# exit
     

    インターフェイス コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

     
    ステップ 14 route-map map-tag [permit | deny] [sequence-number]


    例:
    Router(config)# route-map alpha
     

    ルート マップを指定し、ルート マップ コンフィギュレーション モードを開始します。

     
    ステップ 15 set ip next-hop verify-availability [next-hop-address sequence track object]


    例:
    Router(config-route-map)# set ip next-hop verify-availability 10.1.1.1 10 track 123
     

    ルート マップを設定し、トラッキング対象オブジェクトの到達可能性を確認します。

     
    ステップ 16 end


    例:
    Router(config-route-map)# end
     

    ルートマップ コンフィギュレーション モードを終了し、ルータを特権 EXEC モードに戻します。

     

    Cisco IOS Release 12.3(14)T、12.2(33)SXH、およびそれ以降

    複数のトラッキング オプションに対する PBR サポートを設定するには、次の作業を実行します。 この作業では、ルート マップを作成および設定し、トラッキング対象オブジェクトの到達可能性を確認します。

    はじめる前に

    この作業では、Cisco IOS Release 12.3(14)T、12.2(33)SXH、またはそれ以降のリリースを実行中のネットワーキング デバイスが必要です。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    ip sla monitor operation-number

      4.    type echo protocol ipIcmpEcho {destination-ip-address| destination-hostname}[source-ipaddr {ip-address| hostname} | source-interface interface-name]

      5.    exit

      6.    ip sla monitor schedule operation-number [life {forever | seconds}] [start-time {hh : mm[: ss] [month day | day month] | pending | now | after hh : mm : ss}] [ageout seconds] [recurring]

      7.    track object-number rtr entry-number [reachability| state]

      8.    delay {up seconds [down seconds] | [up seconds] down seconds}

      9.    exit

      10.    interface type number

      11.    ip address ip-address mask [secondary]

      12.    ip policy route-map map-tag

      13.    exit

      14.    route-map map-tag [permit | deny] [sequence-number]

      15.    set ip next-hop verify-availability [next-hop-address sequence track object]

      16.    end

      17.    show track object-number

      18.    show route-map [map-name| all| dynamic]


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Router> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Router# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 ip sla monitor operation-number


      例:
      Router(config)# ip sla monitor 1
       

      Cisco IOS IP サービス レベル契約(SLA)動作設定を開始し、IP SLA モニタ コンフィギュレーション モードを開始します。

       
      ステップ 4 type echo protocol ipIcmpEcho {destination-ip-address| destination-hostname}[source-ipaddr {ip-address| hostname} | source-interface interface-name]


      例:
      Router(config-sla-monitor)# type echo protocol ipIcmpEcho 10.1.1.1
       

      IP SLA Internet Control Message Protocol(ICMP)エコー プローブ動作を設定します。

       
      ステップ 5 exit


      例:
      Router(config-sla-monitor)# exit
       

      IP SLA モニタ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

       
      ステップ 6 ip sla monitor schedule operation-number [life {forever | seconds}] [start-time {hh : mm[: ss] [month day | day month] | pending | now | after hh : mm : ss}] [ageout seconds] [recurring]


      例:
      Router(config)# ip sla monitor schedule 1 life forever start-time now
       

      単一の Cisco IOS IP SLA 動作のスケジューリング パラメータを設定します。

      • この例では、IP SLA 動作の時間パラメータを設定します。
       
      ステップ 7 track object-number rtr entry-number [reachability| state]


      例:
      Router(config)# track 123 rtr 1 reachability
       

      Response Time Reporter(RTR)オブジェクトの到達可能性をトラッキングし、トラッキング コンフィギュレーション モードを終了します。

       
      ステップ 8 delay {up seconds [down seconds] | [up seconds] down seconds}


      例:
      Router(config-track)# delay up 60 down 30
       

      (任意)トラッキング対象オブジェクトの通信状態変化の遅延時間(秒)を指定します。

       
      ステップ 9 exit


      例:
      Router(config-track)# exit
       

      トラッキング コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

       
      ステップ 10 interface type number


      例:
      Router(config)# interface serial 2/0
       

      インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 11 ip address ip-address mask [secondary]


      例:
      Router(config-if)# ip address 192.168.1.1 255.255.255.0 
       

      インターフェイスのプライマリ IP アドレスまたはセカンダリ IP アドレスを指定します。

      • IPv4 アドレスの設定手順については、『Cisco IOS IP Addressing Services Configuration Guide』の「Configuring IPv4 Addresses」の章を参照してください。
      • この例では、着信インターフェイスの IP アドレスを指定します。 これは、ポリシー ルーティングがイネーブル化されるインターフェイスです。
       
      ステップ 12 ip policy route-map map-tag


      例:
      Router(config-if)# ip policy route-map alpha
       

      ポリシー ルーティングをイネーブルにし、ポリシー ルーティングに使用するルート マップを指定します。

       
      ステップ 13 exit


      例:
      Router(config-if)# exit
       

      インターフェイス コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

       
      ステップ 14 route-map map-tag [permit | deny] [sequence-number]


      例:
      Router(config)# route-map alpha
       

      ルート マップを指定し、ルート マップ コンフィギュレーション モードを開始します。

       
      ステップ 15 set ip next-hop verify-availability [next-hop-address sequence track object]


      例:
      Router(config-route-map)# set ip next-hop verify-availability 10.1.1.1 10 track 123
       

      ルート マップを設定し、トラッキング対象オブジェクトの到達可能性を確認します。

      • この例では、デバイスが到達可能である場合、シリアル インターフェイス 2/0 で受信したパケットを 10.1.1.1 へ転送するようにポリシーを設定します。
       
      ステップ 16 end


      例:
      Router(config-route-map)# end
       

      ルートマップ コンフィギュレーション モードを終了し、ルータを特権 EXEC モードに戻します。

       
      ステップ 17 show track object-number


      例:
      Router# show track 123
       

      (任意)トラッキング情報を表示します。

      • このコマンドを使用して、設定を確認します。 「例」のセクションでこのタスクの出力を参照してください。
       
      ステップ 18 show route-map [map-name| all| dynamic]


      例:
      Router# show route-map alpha
       

      (任意)ルート マップ情報を表示します。

      • この例では、「alpha」という名前のルート マップに関する情報を表示します。 「例」のセクションでこのタスクの出力を参照してください。
       

      次の show track コマンドからの出力は、トラッキング対象オブジェクト 123 が到達可能であることを示しています。

      Router# show track 123
      Track 123
        Response Time Reporter 1 reachability
        Reachability is Up
          2 changes, last change 00:00:33
        Delay up 60 secs, down 30 secs
        Latest operation return code: OK
        Latest RTT (millisecs) 20
        Tracked by:
          ROUTE-MAP 0
      

      次の show route-map コマンドからの出力は、この作業で設定した「alpha」という名前のルート マップに関する情報を示しています。

      Router# show route-map alpha
      route-map alpha, permit, sequence 10
        Match clauses:
        Set clauses:
          ip next-hop verify-availability 10.1.1.1 10 track 123  [up]
        Policy routing matches: 0 packets, 0 bytes

      複数のトラッキング オプションに対する PBR サポートの設定例

      Cisco IOS Release 12.3(11)T、12.2(25)S、およびそれ以前

      次の例では、Cisco IOS リリース 12.3(11)T、12.2(25)S、またはそれ以前のリリースを実行しているルータ上で、PBR 用にオブジェクト トラッキングを設定しています。

      イーサネット インターフェイス 0 で受信したパケットを、デバイスが到達可能である(ping に応答する)場合に限り、10.1.1.1 へ転送するポリシーを設定します。 10.1.1.1 がアップしていない場合は、10.2.2.2 へパケットを転送します。 10.2.2.2 も到達不可能な場合ポリシー ルーティングは失敗し、ルーティング テーブルに従ってパケットをルーティングします。

      リモート デバイスに対して ping を実行するため、2 つの Response Time Reporter (RTR) を設定して、 RTR をトラッキングします。 ポリシー ルーティングがトラッキング対象 RTR の状態をモニタし、それらの状態に基づいて転送を決定します。

      ! Define and start the RTRs.
      rtr 1
       type echo protocol ipicmpecho 10.1.1.1
      rtr schedule 1 start-time now life forever
      !
      rtr 2
       type echo protocol ipicmpecho 10.2.2.2
      rtr schedule 2 start-time now life forever
      !
      ! Track the RTRs.
      track 123 rtr 1 reachability
      track 124 rtr 2 reachability
      !
      ! Enable policy routing on the incoming interface.
      interface ethernet 0
       ip address 10.4.4.4 255.255.255.0
       ip policy route-map beta
      !
      ! 10.1.1.1 is via this interface.
      interface ethernet 1
       ip address 10.1.1.254 255.255.255.0
      !
      ! 10.2.2.2 is via this interface.
      interface ethernet 2
       ip address 10.2.2.254 255.255.255.0
      !
      ! Define a route map to set the next-hop depending on the state of the tracked RTRs.
      route-map beta
       set ip next-hop verify-availability 10.1.1.1 10 track 123
       set ip next-hop verify-availability 10.2.2.2 20 track 124

      Cisco IOS Release 12.3(14)T、12.2(33)SXH、およびそれ以降

      次の例では、Cisco IOS リリース 12.3(14)T、12.2(33)S、およびそれ以降のリリースを実行しているルータ上で、PBR 用にオブジェクト トラッキングを設定しています。

      イーサネット インターフェイス 0 で受信したパケットを、デバイスが到達可能である(ping に応答する)場合に限り、10.1.1.1 へ転送するポリシーを設定します。 10.1.1.1 がアップしていない場合は、10.2.2.2 へパケットを転送します。 10.2.2.2 も到達不可能な場合ポリシー ルーティングは失敗し、ルーティング テーブルに従ってパケットをルーティングします。

      リモート デバイスに対して ping を実行するため、2 つの RTR を設定して、 RTR をトラッキングします。 ポリシー ルーティングがトラッキング対象 RTR の状態をモニタし、それらの状態に基づいて転送を決定します。

      ! Define and start the RTRs.
      ip sla monitor 1
       type echo protocol ipicmpecho 10.1.1.1
      ip sla monitor schedule 1 start-time now life forever
      !
      ip sla monitor 2
       type echo protocol ipicmpecho 10.2.2.2
      ip sla monitor schedule 2 start-time now life forever
      !
      ! Track the RTRs.
      track 123 rtr 1 reachability
      track 124 rtr 2 reachability
      !
      ! Enable policy routing on the incoming interface.
      interface ethernet 0
       ip address 10.4.4.4 255.255.255.0
       ip policy route-map beta
      !
      ! 10.1.1.1 is via this interface.
      interface ethernet 1
       ip address 10.1.1.254 255.255.255.0
      !
      ! 10.2.2.2 is via this interface.
      interface ethernet 2
       ip address 10.2.2.254 255.255.255.0
      !
      ! Define a route map to set the next-hop depending on the state of the tracked RTRs.
      route-map beta
       set ip next-hop verify-availability 10.1.1.1 10 track 123
       set ip next-hop verify-availability 10.2.2.2 20 track 124

      その他の関連資料

      ここでは、複数のトラッキング オプションに対する PBR サポート機能に関する関連資料について説明します。

      関連資料

      関連項目

      マニュアル タイトル

      Cisco IOS ソフトウェア内でのオブジェクト トラッキング

      Cisco IOS IP Application Services Configuration Guide』の「Configuring Enhanced Object Tracking」の章

      IP アドレスの設定

      Cisco IOS IP Addressing Services Configuration Guide』の「Configuring IPv4 Addresses」の章

      標準

      標準

      タイトル

      この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

      --

      MIB

      MIB

      MIB のリンク

      この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

      選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

      http:/​/​www.cisco.com/​go/​mibs

      RFC

      RFC

      タイトル

      この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

      --

      シスコのテクニカル サポート

      説明

      リンク

      シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

      お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

      シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

      http:/​/​www.cisco.com/​en/​US/​support/​index.html

      コマンド リファレンス

      次のコマンドは、このモジュールで説明した機能で導入または修正されたものです。 これらのコマンドの詳細については、『Cisco IOS IP Routing: Protocol-Independent Command Reference』を参照してください。 すべての Cisco IOS コマンドの詳細については、http:/​/​tools.cisco.com/​Support/​CLILookup でコマンド検索ツールを使用するか、http:/​/​www.cisco.com/​en/​US/​docs/​ios/​mcl/​allreleasemcl/​all_​book.html で『Cisco IOS Master Command List, All Releases』を参照してください。

      • set ip next-hop verify-availability

      複数のトラッキング オプションに対する PBR サポートの機能情報

      次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

      プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

      表 1 複数のトラッキング オプションに対する PBR サポートの機能情報

      機能名

      リリース

      機能情報

      複数のトラッキング オプションに対する PBR サポート

      12.3(4)T 12.2(25)S 12.2(33)SXH

      複数のトラッキング オプションに対する PBR サポート機能は、Cisco Discovery Protocol(CDP)を使ったオブジェクト トラッキングの機能を拡張し、追加の方法を使って、ポリシーベース ルーティング(PBR)処理でオブジェクトが使用可能かどうかを確認できます。 確認方法として使用できるのは、Internet Control Message Protocol(ICMP)ping、ユーザ データグラム プロトコル(UDP)ping、または HTTP GET です。

      IP SLA での構文変更により、Cisco IOS Release 12.2(33)SXH で、新しい作業と設定例が導入されました。

      set ip next-hop verify-availability コマンドは、この機能によって導入または変更されました。