IP ルーティング:プロトコル非依存コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
デフォルトのパッシブ インターフェイス
デフォルトのパッシブ インターフェイス
発行日;2013/06/09   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

デフォルトのパッシブ インターフェイス

デフォルトのパッシブ インターフェイス機能は、すべてのインターフェイスがデフォルトでパッシブとして設定されるように許可することで、配信デバイスの設定を簡素化します。 ISP や大規模な企業ネットワークでは、多数のディストリビューション デバイスで 200 以上のインターフェイスがあります。 これらのインターフェイスからルーティング情報を取得するには、すべてのインターフェイスでルーティング プロトコルを設定し、隣接させないインターフェイスで passive-interface コマンドを手動設定する必要があります。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、プラットフォームおよびソフトウェア リリースの不具合の検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

デフォルトのパッシブ インターフェイスに関する情報

デフォルトのパッシブ インターフェイス

大規模な企業ネットワークでは、多数のディストリビューション デバイスで 200 以上のインターフェイスがあります。 デフォルトのパッシブ インターフェイス機能を導入する前に、次の方法でこれらのインターフェイスからルーティング情報を取得できます。

  • バックボーン インターフェイスで Open Shortest Path First(OSPF)などのルーティング プロトコルを設定し、接続されたインターフェイスを再配布する。
  • すべてのインターフェイスでルーティング プロトコルを設定し、手動でそれらのほとんどをパッシブに設定する。

1 つめの方法の場合、ネットワーク オペレータは、再配布が行われるデバイス レベルでタイプ 5 リンクステート アドバタイズメント(LSA)を常に集約できるわけではありません。 そのため、多くのタイプ 5 LSA がドメインでフラッディングされる可能性があります。

2 つめの方法では、多くのタイプ 1 LSA がドメインにフラッディングされる可能性があります。 エリア境界ルータ(ABR)は、タイプ 1 LSA のそれぞれに対してタイプ 3 LSA を生成し、それらをバックボーンにフラッディングします。 ただし、ABR レベルで固有の集約を実行でき、このとき、バックボーンにはサマリー ルートが 1 つだけ挿入されます。これにより、処理のオーバーヘッドが削減されます。

デフォルトのパッシブ インターフェイス機能を導入する前に、すべてのインターフェイスでルーティング プロトコルを設定し、隣接させないインターフェイスに passive-interface ルータ コンフィギュレーション コマンドを手動で設定できます。 ただし、一部のネットワークでは、このソリューションは 200 以上のパッシブ インターフェイスを設定することになります。 デフォルトのパッシブ インターフェイス機能は、すべてのインターフェイスがデフォルトでパッシブとして設定されるようにすることで、この問題を解決しました。 passive-interface default コマンドを使用して、すべてのインターフェイスをデフォルトでパッシブとして設定し、隣接が必要な各インターフェイスを no passive-interface コマンドを使用して設定できます。

デフォルトのパッシブ インターフェイス機能は配信デバイスの設定を簡素化し、ネットワーク管理者は ISP や大規模な企業ネットワーク インターフェイスからルーティング情報を取得することができます。

インターフェイスからのルーティング アップデートの防止

ローカル ネットワーク上の他のデバイスがダイナミックにルートを学習しないようにするには、ルーティング アップデート メッセージがデバイスのインターフェイスから送信されないようにします。 この機能は、ボーダー ゲートウェイ プロトコル(BGP)を除くすべての IP ベース ルーティング プロトコルに適用されます。

Open Shortest Path First(OSPF)および Intermediate System to Intermediate System(IS-IS)は、若干異なる動作をします。 OSPF の場合、パッシブに指定したインターフェイス アドレスが OSPF ドメインのスタブ ネットワークとして表示されます。 OSPF ルーティング情報は、指定されたデバイスのインターフェイスから送受信されません。 IS-IS の場合、指定した IP アドレスはインターフェイス上で IS-IS を実際に実行することなくアドバタイズされます。

指定したインターフェイスからのルーティング アップデートを防止するには、ルータ コンフィギュレーション モードで passive-interface type number コマンドを使用します。

デフォルトのパッシブ インターフェイスの設定方法

デフォルトのパッシブ インターフェイスの設定

Enhanced Interior Gateway Routing Protocol(EIGRP)環境内のデバイスのすべてのインターフェイスをデフォルトでパッシブとして設定し、隣接が必要なインターフェイスだけをアクティブにするには、このタスクを実行します。

手順の概要

    1.    enable

    2.    configure terminal

    3.    router eigrp {autonomous-system-number | virtual-instance-number}

    4.    passive-interface [default] [type number]

    5.    no passive-interface [default] [type number]

    6.    network network-address [options]

    7.    end

    8.    show ip eigrp interfaces

    9.    show ip interface


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 router eigrp {autonomous-system-number | virtual-instance-number}


    例:
    Device(config)# router eigrp 1
     

    EIGRP プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

    • autonomous-system-number:別の EIGRP アドレスファミリ デバイスに対するサービスを識別するための自律システム番号。 ルーティング情報にタグを付加するためにも使用されます。 指定できる範囲は 1 ~ 65535 です。
    • virtual-instance-number:EIGRP 仮想インスタンス名。 この名前は、単一ルータ上のすべてのアドレスファミリ デバイス プロセスで一意でなければいけませんが、デバイス間で一意である必要はありません。
     
    ステップ 4 passive-interface [default] [type number]


    例:
    Device(config-router)# passive-interface default
     

    デフォルトですべてのインターフェイスをパッシブに設定します。

     
    ステップ 5no passive-interface [default] [type number]


    例:
    Device(config-router)# no passive-interface gigabitethernet 0/0/0
     

    隣接が必要なインターフェイスのみアクティブ化します。

     
    ステップ 6 network network-address [options]


    例:
    Device(config-router)# network 192.0.2.0
     

    ルーティング プロトコルがアドバタイズするネットワーク リストを指定します。

     
    ステップ 7end


    例:
    Device(config-router)# end
     

    ルータ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

     
    ステップ 8show ip eigrp interfaces


    例:
    Device# show ip eigrp interfaces
     

    ネットワークのインターフェイスがパッシブに設定されているかどうかを確認します。

     
    ステップ 9show ip interface


    例:
    Device# show ip interface
     

    イネーブルにしたインターフェイスがアクティブかどうかを確認します。

     

    デフォルトのパッシブ インターフェイスの設定例

    例:OSPF のパッシブ インターフェイスの設定

    Open Shortest Path First(OSPF)では、パッシブとして指定されたインターフェイスでは hello パケットは送信されません。 したがって、デバイスはネイバーを検出できず、OSPF ネイバーもそのネットワーク上のデバイスを参照できません。 つまり、このインターフェイスは OSPF ドメインへのスタブ ネットワークとして表示されます。 インターフェイス上で OSPF アクティビティを実行することなく、接続されたネットワークに関連付けられたルートを OSPF ドメインにインポートするときにこの設定が役立ちます。

    passive-interface ルータ コンフィギュレーション コマンドは、通常、network ルータ コンフィギュレーション コマンドでワイルドカードを指定することによって必要以上のインターフェイスが設定されるときに使用します。 次の設定により、OSPF は 172.18.0.0 のすべてのサブネットで実行されます。

    Device(config)# interface GigabitEthernet 0/0/0
    Device(config-if)# ip address 172.18.1.1 255.255.255.0 
    Device(config-if)# exit 
    Device(config)# interface GigabitEthernet 1/0/0
    Device(config-if)# ip address 172.18.2.1 255.255.255.0 
    Device(config-if)# exit 
    Device(config)# interface GigabitEthernet 2/0/0
    Device(config-if)# ip address 172.18.3.1 255.255.255.0 
    Device(config-if)# exit 
    Device(config)# router ospf 1 
    Device(config-router)# network 172.18.0.0 0.0.255.255 area 0 
    Device(config-router)# exit 
    

    172.18.3.0 で OSPF を実行しない場合は、次のコマンドを入力します。

    Device(config)# router ospf 1 
    Device(config-router)# network 172.18.0.0 0.0.255.255 area 0 
    Device(config-router)# no passive-interface GigabitEthernet 2/0/0
    Device(config-router)# exit
     
    

    例:OSPF のデフォルトのパッシブ インターフェイスの設定

    次の例では、ネットワーク インターフェイスを設定し、パッシブとして Open Shortest Path First(OSPF)を実行しているすべてのインターフェイスを設定して、シリアル インターフェイス 0/0/0 を有効にします。

    Device(config)# interface GigabitEthernet 0/0/0
    Device(config-if)# ip address 172.19.64.38 255.255.255.0 secondary 
    Device(config-if)# ip address 172.19.232.70 255.255.255.240 
    Device(config-if)# no ip directed-broadcast 
    Device(config-if)# exit 
    Device(config)# interface Serial 0/0/0 
    Device(config-if)# ip address 172.24.101.14 255.255.255.252 
    Device(config-if)# no ip directed-broadcast 
    Device(config-if)# no ip mroute-cache 
    Device(config-if)# exit 
    Device(config)# interface TokenRing 0/0/0
    Device(config-if)# ip address 172.20.10.4 255.255.255.0 
    Device(config-if)# no ip directed-broadcast 
    Device(config-if)# no ip mroute-cache 
    Device(config-if)# ring-speed 16 
    Device(config-if)# exit 
    Device(config)# router ospf 1 
    Device(config-router)# passive-interface default 
    Device(config-router)# no passive-interface Serial 0/0/0
    Device(config-router)# network 172.16.10.0 0.0.0.255 area 0 
    Device(config-router)# network 172.19.232.0 0.0.0.255 area 4 
    Device(config-router)# network 172.24.101.0 0.0.0.255 area 4 
    Device(config-router)# end
    

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    Cisco IOS コマンド

    『Cisco IOS Master Command List, All Releases』

    IP ルーティングのプロトコル独立型コマンド

    『Cisco IOS IP Routing: Protocol-Independent Command Reference』

    シスコのテクニカル サポート

    説明

    リンク

    シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    デフォルトのパッシブ インターフェイスの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

    表 1 デフォルトのパッシブ インターフェイスの機能情報

    機能名

    リリース

    機能情報

    デフォルトのパッシブ インターフェイス

    ISP や大規模な企業ネットワークでは、多数のディストリビューション デバイスで 200 以上のインターフェイスがあります。 これらのインターフェイスからルーティング情報を取得するには、すべてのインターフェイスでルーティング プロトコルを設定し、隣接させないインターフェイスで passive-interface コマンドを手動設定する必要がありました。 デフォルトのパッシブ インターフェイス機能を使用すると、1 つの passive-interface default コマンドを使用してデフォルトですべてのインターフェイスをパッシブとして設定し、その後、no passive-interface コマンドを使用して隣接させる個々のインターフェイスを設定できるため、ディストリビューション デバイスの設定が簡略化されます。