IP ルーティング:プロトコル非依存コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
Multi-VRF サポート
Multi-VRF サポート
発行日;2013/06/09   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

Multi-VRF サポート

Multi-VRF サポート機能を使用すると、同じカスタマー エッジ(CE)デバイス内でルーティングおよび転送テーブルの複数のインスタンスを設定および維持できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、プラットフォームおよびソフトウェア リリースの不具合の検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

Multi-VRF サポートの前提条件

ネットワークのコア デバイスおよびプロバイダー エッジ(PE)デバイスは、バーチャル プライベート ネットワーク(VPN)操作用に設定する必要があります。

Multi-VRF サポートの制約事項

  • Multi-VRF サポート機能は、レイヤ 3 インターフェイスでのみ設定できます。
  • Multi-VRF サポート機能は、Interior Gateway Routing Protocol(IGRP)や Intermediate System to Intermediate System(IS-IS)ではサポートされません。
  • 特定のデバイスの特定の VPN ルーティングおよび転送(VRF)インスタンスのラベル配布は、ボーダー ゲートウェイ プロトコル(BGP)またはラベル配布プロトコル(LDP)のいずれかで処理できます。ただし、両方のプロトコルで同時に処理することはできません。
  • マルチキャストは、Multi-VRF サポート機能で設定されているレイヤ 3 インターフェイスでは実行できません。

Multi-VRF サポートに関する情報

Multi-VRF サポート機能の動作

Multi-VRF サポート機能を使用すると、サービス プロバイダーは複数のバーチャル プライベート ネットワーク(VPN)をサポートすることができ、複数の VPN で IP アドレスが重複することが可能になります。 Multi-VRF サポート機能は、入力インターフェイスを使用して複数の異なる VPN のルートを区別し、1 つまたは複数のレイヤ 3 インターフェイスを各仮想ルーティングおよび転送(VRF)インスタンスに関連付けることによって仮想パケット転送テーブルを作成します。 VRF のインターフェイスは、FastEthernet ポートなどの物理インターフェイス、または VLAN スイッチ仮想インターフェイス(SVI)などの論理インターフェイスにすることができますが、レイヤ 3 インターフェイスは、一度に複数の VRF に属することはできません。 Multi-VRF サポート機能により、オペレータはカスタマー エッジ(CE)デバイス上で複数のルーティング ドメインをサポートできます。各ルーティング ドメインでは、独自のセットのインターフェイスと独自のセットのルーティングおよび転送テーブルが使用されます。 Multi-VRF サポート機能は、CE がサポートする各ルーティング ドメインに CE のラベル スイッチド パス(LSP)を拡張することができます。

Multi-VRF サポート機能は次のように動作します。

  • 各 CE デバイスは、プロバイダー エッジ(PE)デバイスにサイトのローカル ルートをアドバタイズし、プロバイダー エッジ(PE)デバイスからリモート VPN ルートを学習します。
  • PE デバイスは、スタティック ルーティング、またはボーダー ゲートウェイ プロトコル(BGP)、ルーティング情報プロトコル バージョン 1(RIPv1)または RIPv2 などのルーティング プロトコルを使用して、CE デバイスとルーティング情報を交換します。
  • PE デバイスは、ラベル配布プロトコル(LDP)または BGP を介して CE デバイスと MPLS ラベル情報を交換します。
  • PE デバイスは、すべてのサービス プロバイダーの VPN ルートを PE で維持せずに済むようにするため、直接接続された VPN のみの VPN ルートを維持する必要があります。 各 PE デバイスは、直接接続しているサイトごとに VRF を維持します。 すべてのサイトが同じ VPN に参加している場合、PE デバイス上の複数のインターフェイスを 1 つの VRF に関連付けることができます。 各 VPN は、指定された VRF にマッピングされます。 CE デバイスからローカル VPN ルートを学習した後、PE デバイスは、内部 BGP(iBGP)を介して他の PE デバイスと VPN ルーティング情報を交換します。

Multi-VRF サポート機能を使用すると、複数のカスタマーが 1 つの CE デバイスを共有でき、1 つの物理リンクのみが CE と PE デバイスの間で使用されます。 共有 CE デバイスは、カスタマーごとに別個の VRF テーブルを維持し、カスタマーの独自のルーティング テーブルに基づいて各カスタマーのパケットをルーティングします。 Multi-VRF サポート機能により、PE デバイスの限定機能が CE デバイスにまで拡張され、個別の VRF テーブルの維持を通して、VPN のプライバシーとセキュリティをブランチ オフィスにまで拡張できるようになります。

下の図は、各 CE デバイスが 2 つの CE デバイスであるかのように機能する構成を示します。 Multi-VRF サポート機能はレイヤ 3 機能なので、VRF に関連付けられている各インターフェイスはレイヤ 3 インターフェイスである必要があります。

図 1. 複数の仮想 CE デバイスとして動作する各 CE デバイス

Multi-VRF サポート機能を使用してネットワークでパケットが転送されるしくみ

次に、上の図に示すような、Multi-VRF カスタマー エッジ(CE)対応ネットワークのパケット転送プロセスを示します。

  • CE がバーチャル プライベート ネットワーク(VPN)からパケットを受信すると、CE は入力インターフェイスに基づいたルーティング テーブルを検索します。 ルートが見つかると、CE はそのルートのプロバイダー エッジ(PE)から受信したマルチプロトコル ラベル スイッチング(MPLS)ラベルを強制し、パケットを PE に転送します。
  • 入力 PE が CE からパケットを受信すると、対応するラベル スタックで着信ラベルを交換し、MPLS ネットワークにパケットを送信します。
  • 出力 PE がネットワークからパケットを受信すると、CE からルートのために以前に受信したラベルで VPN ラベルを交換し、CE にパケットを転送します。
  • CE が出力 PE からパケットを受信すると、パケットの着信ラベルを使用して、正しい VPN にパケットを転送します。

マルチ VRF を設定するには、VRF テーブルを作成し、その VRF に関連付けられているレイヤ 3 インターフェイスを指定します。 次に、VPN 内、および CE と PE 間にルーティング プロトコルを設定します。 ボーダー ゲートウェイ プロトコル(BGP)は、プロバイダーのバックボーンでの VPN ルーティング情報の配布で優先されるルーティング プロトコルです。

マルチ VRF ネットワークには、次の 3 つの主要コンポーネントがあります。

  • VPN ルート ターゲット コミュニティ:これは、VPN コミュニティの他のすべてのメンバのリストです。 各 VPN コミュニティ メンバの VPN ルート ターゲットを設定する必要があります。
  • VPN コミュニティ PE デバイスのマルチプロトコル BGP ピアリング:VPN コミュニティのすべてのメンバに VRF の到達可能情報を伝播します。 VPN コミュニティのすべての PE デバイスで BGP ピアリングを設定する必要があります。
  • VPN 転送:VPN サービス プロバイダー ネットワーク上の VPN コミュニティ メンバ間ですべてのトラフィックを転送します。

Multi-VRF サポート機能を設定する場合の考慮事項

  • Multi-VRF サポート機能を持つデバイスは、複数のカスタマーによって共有され、各カスタマーが独自のルーティング テーブルを持ちます。
  • 各カスタマーはそれぞれ異なる仮想ルーティングおよび転送(VRF)テーブルを使用するため、同じ IP アドレスを再利用できます。 重複する IP アドレスは、異なるバーチャル プライベート ネットワーク(VPN)で許可されます。
  • Multi-VRF サポート機能を使用すると、複数のカスタマーがプロバイダー エッジ(PE)デバイスとカスタマー エッジ(CE)デバイスの間で同じ物理リンクを共有できます。 複数の VLAN を持つトランク ポートでは、カスタマー間のパケットが分割されます。 それぞれのお客様には独自の VLAN があります。
  • PE デバイスでは、Multi-VRF サポート機能の使用と、複数の CE デバイスの使用に違いはありません。
  • Multi-VRF サポート機能は、パケットスイッチング レートには影響しません。

Multi-VRF サポートの設定方法

VRF の設定

仮想ルーティングおよび転送(VRF)インスタンスを設定するには、次の手順を実行します。 プロバイダー エッジ(PE)デバイスおよびカスタマー エッジ(CE)デバイスの両方で VRF を設定するようにします。

VRF が設定されていない場合、デバイスには、次のデフォルト設定が適用されます。

  • VRF は定義されていません。
  • インポート マップ、エクスポート マップ、ルート マップは定義されていません。
  • VRF の最大ルートはありません。
  • グローバル ルーティング テーブルはインターフェイスにあります。


(注)  


マルチキャストは、Multi-VRF サポート機能と同じレイヤ 3 インターフェイス上に同時に設定することはできません。


手順の概要

    1.    enable

    2.    configure terminal

    3.    ip routing

    4.    ip vrf vrf-name

    5.    rd route-distinguisher

    6.    route-target {export | import | both} route-target-ext-community

    7.    import map route-map

    8.    exit

    9.    interface type slot/subslot/port[.subinterface]

    10.    ip vrf forwarding vrf-name

    11.    end

    12.    show ip vrf


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 ip routing


    例:
    Device(config)# ip routing
     

    IP ルーティングをイネーブルにします。

     
    ステップ 4 ip vrf vrf-name


    例:
    Device(config)# ip vrf v1
     

    VRF 名を指定し、VRF コンフィギュレーション モードを開始します。

     
    ステップ 5 rd route-distinguisher


    例:
    Device(config-vrf)# rd 100:1
     

    ルート識別子を指定して VRF テーブルを作成します。

    自律システム番号および任意の数(xxx:y)、または IP アドレスおよび任意の数(A.B.C.D:y)のいずれかを入力します。

     
    ステップ 6 route-target {export | import | both} route-target-ext-community


    例:
    Device(config-vrf)# route-target export 100:1
     

    指定された VRF のインポート、エクスポート、またはインポートおよびエクスポート ルート ターゲット コミュニティのリストを作成します。

    自律システム番号および任意の数(xxx:y)、または IP アドレスおよび任意の数(A.B.C.D:y)のいずれかを入力します。

    (注)     

    このコマンドは、BGP が稼働している場合にだけ有効です。

     
    ステップ 7 import map route-map


    例:
    Device(config-vrf)# import map importmap1
     

    (任意)VRF にルート マップを対応付けます。

     
    ステップ 8 exit


    例:
    Device(config-vrf)# exit
     

    グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 9 interface type slot/subslot/port[.subinterface]


    例:
    Device(config)# interface fastethernet3/0/0.10
     

    VRF に関連付けるレイヤ 3 インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

    インターフェイスはルーテッド ポートまたは SVI に設定できます。

     
    ステップ 10 ip vrf forwarding vrf-name


    例:
    Device(config-if)# ip vrf forwarding v1
     

    VRF をレイヤ 3 インターフェイスに対応付けます。

     
    ステップ 11end


    例:
    Device(config-if)# end
     

    特権 EXEC モードに戻ります。

     
    ステップ 12 show ip vrf


    例:
    Device# show ip vrf
     

    VRF 設定を表示します。

     

    ルーティング プロトコルとしての BGP の設定

    ほとんどのルーティング プロトコルは、カスタマー エッジ(CE)デバイスとプロバイダー エッジ(PE)デバイス間で使用できます。 ただし、次の理由で、外部 BGP(eBGP)が推奨されます。

    • BGP は、多数の CE デバイスと通信するのに複数のアルゴリズムを必要としません。
    • BGP は、さまざまな管理によって稼働するシステム間でルーティング情報を渡すように設計されています。
    • BGP によって、CE デバイスにルート属性を簡単に渡すことができます。

    BGP がルーティング プロトコルとして使用されている場合、PE デバイスと CE デバイス間のマルチプロトコル ラベル スイッチング(MPLS)ラベル交換の処理にもその BGP を使用できます。 対照的に、Open Shortest Path First(OSPF)、Enhanced Interior Gateway Routing Protocol(EIGRP)、ルーティング情報プロトコル(RIP)、またはスタティック ルーティングが使用されている場合は、ラベル配布プロトコル(LDP)をラベルのシグナリングに使用する必要があります。

    BGP を PE から CE へのルーティング セッションのために設定するには、CE デバイスと PE デバイスで次の手順を実行します。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    router bgp autonomous-system-number

      4.    network ip-address mask network-mask

      5.    redistribute ospf process-id match internal

      6.    network ip-address wildcard-mask area area-id

      7.    address-family ipv4 vrf vrf-name

      8.    neighbor {ip-address | peer-group-name} remote-as as-number

      9.    neighbor address activate


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Device> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Device# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 router bgp autonomous-system-number


      例:
      Device(config)# router bgp 100
       

      BGP ルーティング プロセスを他の BGP デバイスに渡す自律システム番号で設定し、ルータ コンフィギュレーション モードを開始します。

       
      ステップ 4 network ip-address mask network-mask


      例:
      Device(config-router)# network 10.0.0.0 mask 255.255.255.0
       

      BGP を使用してアナウンスするネットワークおよびマスクを指定します。

       
      ステップ 5 redistribute ospf process-id match internal


      例:
      Device(config-router)# redistribute ospf 2 match internal
       

      OSPF 内部ルートを再配布するようにデバイスを設定します。

       
      ステップ 6 network ip-address wildcard-mask area area-id


      例:
      Device(config-router)# network 10.0.0.0 255.255.255.0 area 0
       

      OSPF を実行しているネットワーク アドレスとマスク、およびそのネットワーク アドレスのエリア ID を識別します。

       
      ステップ 7 address-family ipv4 vrf vrf-name


      例:
      Device(config-router)# address-family ipv4 vrf v12
       

      次の 2 つのコマンドに関連付ける仮想ルーティングおよび転送(VRF)インスタンスの名前を識別し、VRF アドレスファミリ モードを開始します。

       
      ステップ 8 neighbor {ip-address | peer-group-name} remote-as as-number


      例:
      Device(config-router-af)# neighbor 10.0.0.3 remote-as 100
       

      ネイバー アドレス(またはピア グループ名)のこのデバイスの BGP ネイバー テーブルおよびネイバーの自律システム番号を通知します。

       
      ステップ 9 neighbor address activate


      例:
      Device(config-router-af)# neighbor 10.0.0.3 activate
       

      IPv4 アドレスファミリ ネイバーのアドバタイズメントをアクティブ化します。

       

      PE から CE への MPLS 転送およびシグナリングで BGP を使用する場合の設定

      プロバイダー エッジ(PE)デバイスとカスタマー エッジ(CE)デバイス間のルーティングにボーダー ゲートウェイ プロトコル(BGP)を使用する場合は、CE デバイスと PE デバイスの両方の仮想ルーティングおよび転送(VRF)インターフェイスのラベルをシグナリングするように BGP を設定します。 ルータ コンフィギュレーション レベルと、各インターフェイスごとに、シグナリングをグローバルに有効にする必要があります。

      • ルータ コンフィギュレーション レベルでは、neighbor send-label コマンドを使用して、BGP を介したマルチプロトコル ラベル スイッチング(MPLS)ラベルのシグナリングをイネーブルにします。
      • インターフェイス レベルでは、mpls bgp forwarding コマンドを使用して、PE から CE への外部 BGP(eBGP)セッションに使用されるインターフェイスで MPLS 転送をイネーブルにします。
      手順の概要

        1.    enable

        2.    configure terminal

        3.    router bgp autonomous-system-number

        4.    address-family ipv4 vrf vrf-name

        5.    neighbor address send-label

        6.    neighbor address activate

        7.    end

        8.    configure terminal

        9.    interface type slot/subslot/port[.subinterface]

        10.    mpls bgp forwarding


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Device> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 configure terminal


        例:
        Device# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 router bgp autonomous-system-number


        例:
        Device(config)# router bgp 100
         

        BGP ルーティング プロセスを他のデバイスに渡す BGP 自律システム番号で設定し、ルータ コンフィギュレーション モードを開始します。

         
        ステップ 4 address-family ipv4 vrf vrf-name


        例:
        Device(config-router)# address-family ipv4 vrf v12
         

        次の 2 つのコマンドに関連付ける VRF インスタンスの名前を識別し、アドレス ファミリ コンフィギュレーション モードを開始します。

         
        ステップ 5 neighbor address send-label


        例:
        Device(config-router-af)# neighbor 10.0.0.3 send-label
         

        BGP を使用して IPv4 ルートとともに MPLS ラベルをピア デバイスに配布できるようにデバイスを設定します。

        このコマンドを発行するときに BGP セッションが実行中の場合、BGP セッションが再開されるまでコマンドは有効になりません。

         
        ステップ 6 neighbor address activate


        例:
        Device(config-router-af)# neighbor 10.0.0.3 activate
         

        IPv4 アドレスファミリ ネイバーのアドバタイズメントをアクティブ化します。

         
        ステップ 7 end


        例:
        Device(config-router-af)# end
         

        特権 EXEC モードに戻ります。

         
        ステップ 8 configure terminal


        例:
        Device# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 9 interface type slot/subslot/port[.subinterface]


        例:
        Device(config)# interface fastethernet3/0/0.10
         

        BGP セッションで使用されるインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

        インターフェイスはルーテッド ポートまたは SVI に設定できます。

         
        ステップ 10 mpls bgp forwarding


        例:
        Device(config-if)# mpls bgp forwarding
         

        インターフェイスで MPLS 転送をイネーブルにします。

         

        BGP 以外のルーティング プロトコルの設定

        ルーティング情報プロトコル(RIP)、Enhanced Interior Gateway Routing Protocol(EIGRP)、Open Shortest Path First(OSPF)、またはスタティック ルーティングを使用できます。 この設定は OSPF を使用しますが、その他のプロトコルでもプロセスは同じです。

        プロバイダー エッジ(PE)デバイスとカスタマー エッジ(CE)デバイス間のルーティング プロトコルとして OSPF を使用する場合は、ルータ コンフィギュレーション モードで capability vrf-lite コマンドを発行します。


        (注)  


        RIP、EIGRP、OSPF、またはスタティック ルーティングが使用されている場合、ラベルのシグナリングにラベル配布プロトコル(LDP)を使用する必要があります。

        Multi-VRF サポート機能は、Interior Gateway Routing Protocol(IGRP)や Intermediate System to Intermediate System(IS-IS)ではサポートされません。

        Multi-VRF サポート機能が設定されているレイヤ 3 インターフェイスにマルチキャストを同時に設定することはできません。


        手順の概要

          1.    enable

          2.    configure terminal

          3.    router ospf process-id [vrf vpn-name]

          4.    log-adjacency-changes

          5.    redistribute bgp autonomous-system-number subnets

          6.    network ip-address subnet-mask area area-id

          7.    end

          8.    show ip ospf


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Device> enable
           

          特権 EXEC モードをイネーブルにします。

          • パスワードを入力します(要求された場合)。
           
          ステップ 2 configure terminal


          例:
          Device# configure terminal
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3 router ospf process-id [vrf vpn-name]


          例:
          Device(config)# router ospf 100 vrf v1
           

          OSPF ルーティングをイネーブルにし、仮想ルーティングおよび転送(VRF)テーブルを指定して、ルータ コンフィギュレーション モードを開始します。

           
          ステップ 4 log-adjacency-changes


          例:
          Device(config-router)# log-adjacency-changes
           

          (任意)隣接ステートの変更を記録します。

          これは、デフォルトの状態です。

           
          ステップ 5 redistribute bgp autonomous-system-number subnets


          例:
          Device(config-router)# redistribute bgp 800 subnets
           

          デバイスをボーダー ゲートウェイ プロトコル(BGP)ネットワークから OSPF ネットワークに情報を再配布するように設定します。

           
          ステップ 6 network ip-address subnet-mask area area-id


          例:
          Device(config-router)# network 10.0.0.0 255.255.255.0 area 0
           

          OSPF が動作するネットワーク アドレスとマスク、およびそのネットワーク アドレスのエリア ID を示します。

           
          ステップ 7end


          例:
          Device(config-router)# end
           

          特権 EXEC モードに戻ります。

           
          ステップ 8 show ip ospf


          例:
          Device# show ip ospf
           

          OSPF ルーティング プロセスに関する情報を表示します。

           

          PE から CE への MPLS 転送およびシグナリングで LDP を使用する場合の設定

          手順の概要

            1.    enable

            2.    configure terminal

            3.    interface type slot /subslot/port[.subinterface]

            4.    mpls ip


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 enable


            例:
            Device> enable
             

            特権 EXEC モードをイネーブルにします。

            • パスワードを入力します(要求された場合)。
             
            ステップ 2 configure terminal


            例:
            Device# configure terminal
             

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 3 interface type slot /subslot/port[.subinterface]


            例:
            Device(config)# interface fastethernet3/0/0.10
             

            VRF に関連付けられたインターフェイスのインターフェイス コンフィギュレーション モードを開始します。 インターフェイスはルーテッド ポートまたは SVI に設定できます。

             
            ステップ 4 mpls ip


            例:
            Device(config-if)# mpls ip
             

            このインターフェイスの通常のルーテッド パスで IPv4 パケットの MPLS 転送をイネーブルにします。

             

            Multi-VRF サポートの設定例

            次の図は、Multi-VRF のトポロジの例です。



            例:PE デバイスでの Multi-VRF サポートの設定

            次に、VRF を設定する例を示します。

            configure terminal
            ip vrf v1
             rd 100:1
             route-target export 100:1
             route-target import 100:1
             exit
            ip vrf v2
             rd 100:2
             route-target export 100:2
             route-target import 100:2
             exit

            次に、ルーティングおよびラベルの交換の両方に BGP を使用して、PE から CE への接続を設定する例を示します。

            router bgp 100
             address-family ipv4 vrf v2
              neighbor 10.0.0.8 remote-as 800
              neighbor 10.0.0.8 activate
              neighbor 10.0.0.8 send-label
              exit
             address-family ipv4 vrf vl
              neighbor 10.0.0.8 remote-as 800
              neighbor 10.0.0.8 activate
              neighbor 10.0.0.8 send-label
              end
            configure terminal
             interface fastethernet3/0/0.10
              ip vrf forwarding v1
              ip address 10.0.0.3 255.255.255.0
              mpls bgp forwarding
              exit
             interface fastethernet3/0/0.20
              ip vrf forwarding v2
              ip address 10.0.0.3 255.255.255.0
              mpls bgp forwarding
              exit

            次に、ルーティングおよび LDP ラベルの交換に OSPF を使用して、PE から CE への接続を設定する例を示します。

            router ospf 100 vrf v1
             network 10.0.0.0 255.255.255.0 area 0
             exit
            router ospf 101 vrf v2
             network 10.0.0.0 255.255.255.0 area 0
             exit
            interface fastethernet3/0/0.10
             ip vrf forwarding v1
             ip address 10.0.0.3 255.255.255.0
             mpls ip
             exit
            interface fastethernet3/0/0.20
             ip vrf forwarding v2
             ip address 10.0.0.3 255.255.255.0
             mpls ip
             exit

            例:CE デバイスでの Multi-VRF サポートの設定

            次に、VRF の設定例を示します。

            configure terminal
             ip routing
             ip vrf v11
              rd 800:1
              route-target export 800:1
              route-target import 800:1
              exit
             ip vrf v12
              rd 800:2
              route-target export 800:2
              route-target import 800:2
              exit

            次に、CE デバイスの VPN 接続を設定する例を示します。

            interface fastethernet3/8/0
             ip vrf forwarding v11
             ip address 10.0.0.8 255.255.255.0
             exit
            interface fastethernet3/11/0
             ip vrf forwarding v12
             ip address 10.0.0.8 255.255.255.0
             exit
            router ospf 1 vrf v11
             network 10.0.0.0 255.255.255.0 area 0
             network 10.0.0.0 255.255.255.0 area 0
             exit
            router ospf 2 vrf v12
             network 10.0.0.0 255.255.255.0 area 0
             network 10.0.0.0 255.255.255.0 area 0
             exit

            (注)  


            BGP が PE デバイスと CE デバイス間のルーティングに使用されている場合、次の例に示すコマンドを使用して、PE デバイスからの BGP 学習ルートを OSPF に再配布できます。


            router ospf 1 vrf v11
             redistribute bgp 800 subnets
             exit
            router ospf 2 vrf v12
             redistribute bgp 800 subnets
             exit

            次に、ルーティングおよびラベルの交換の両方に BGP を使用して、PE から CE への接続を設定する例を示します。

            router bgp 800
             address-family ipv4 vrf v12
             neighbor 10.0.0.3 remote-as 100
             neighbor 10.0.0.3 activate
             neighbor 10.0.0.3 send-label
             redistribute ospf 2 match internal
             exit
             address-family ipv4 vrf vl1
             neighbor 10.0.0.3 remote-as 100
             neighbor 10.0.0.3 activate
             neighbor 10.0.0.3 send-label
             redistribute ospf 1 match internal
             end
            interface fastethernet3/0/0.10
              ip vrf forwarding v11
              ip address 10.0.0.8 255.255.255.0
              mpls bgp forwarding
              exit
            interface fastethernet3/0/0.20
              ip vrf forwarding v12
              ip address 10.0.0.8 255.255.255.0
              mpls bgp forwarding
              exit

            次に、ルーティングおよび LDP ラベルの交換の両方に OSPF を使用して、PE から CE への接続を設定する例を示します。

            router ospf 1 vrf v11
             network 10.0.0.0 255.255.255.0 area 0
             exit
            router ospf 2 vrf v12
             network 10.0.0.0 255.255.255.0 area 0
             exit
            interface fastethernet3/0/0.10
              ip vrf forwarding v11
              ip address 10.0.0.3 255.255.255.0
              mpls ip
              exit
            interface fastethernet3/0/0.20
              ip vrf forwarding v12
              ip address 10.0.0.3 255.255.255.0
              mpls ip
              exit

            その他の関連資料

            関連資料

            関連項目

            マニュアル タイトル

            Cisco IOS コマンド

            『Cisco Master Command List, All Releases』

            MPLS と MPLS アプリケーション コマンド

            『Cisco IOS Multiprotocol Label Switching Command Reference』

            マルチ VRF を使用する OSPF

            OSPF Configuration Guide』の「OSPF Support for Multi-VRF in CE Routers」モジュール

            シスコのテクニカル サポート

            説明

            リンク

            シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

            http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

            Multi-VRF サポートの機能情報

            次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

            プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

            表 1 Multi-VRF サポートの機能情報

            機能名

            リリース

            機能情報

            Multi-VRF サポート

            12.1(11)EA1

            12.1(20)EW

            12.2(4)T

            12.2(8)YN

            12.2(18)SXD

            12.2(25)EWA

            12.2(28)SB

            Cisco IOS XE Release 2.1

            Cisco IOS XE Release 3.5S

            Multi-VRF サポート機能を使用すると、同じ CE デバイス内でルーティングおよび転送テーブルの複数のインスタンスを設定および維持できます。

            Multi-VRF サポート機能は、Cisco IOS Release 12.1(11)EA1 で導入されました。

            この機能は Cisco IOS Release 12.1(20)EW に統合されました。

            この機能は Cisco IOS Release 12.2(4)T に統合されました。

            この機能は Cisco IOS Release 12.2(8)YN に統合されました。

            この機能は Cisco IOS Release 12.2(18)SXD に統合されました。

            この機能は Cisco IOS Release 12.2(25)EWA に統合されました。

            この機能は Cisco IOS Release 12.2(28)SB に統合されました。

            この機能は、Cisco IOS XE Release 3.1 で、Cisco ASR 1000 シリーズ アグリゲーション サービス ルータに導入されました。

            Cisco IOS XE Release 3.5S では、Cisco ASR 903 ルータのサポートが追加されました。