IP ルーティング:プロトコル非依存コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
IPv4 ループ フリー代替高速再ルーティング
IPv4 ループ フリー代替高速再ルーティング
発行日;2013/06/09   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

IPv4 ループ フリー代替高速再ルーティング

リンクやルータに障害が発生すると、分散ルーティング アルゴリズムによって障害を考慮した新しいルートが計算されます。 計算のための時間をルーティングの遷移と呼びます。 遷移が完了し、すべてのルータがネットワーク上の共通のビューで収束されるまで、送信元と宛先のペア間の接続は中断されます。 事前計算済みの代替ネクスト ホップを使用してルーティングの遷移時間を 50 ミリ秒より少なくするために、IPv4 ループ フリー代替高速再ルーティング機能を使用できます。 リンク障害の通知を受けると、ルータはトラフィック損失を減らすために、修復パスにすぐに切替えます。

IPv4 ループ フリー代替高速再ルーティングは、修復パスの事前計算をサポートします。 修復パスの計算は、Intermediate System-to-Intermediate System(IS-IS)ルーティング プロトコルによって実行され、結果の修復パスはルーティング情報ベース(RIB)に送信されます。 修復パスのインストールは、シスコ エクスプレス フォワーディング(以前は CEF と呼ばれる)と Open Shortest Path First(OSPF)によって実行されます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、プラットフォームおよびソフトウェア リリースの不具合の検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

IPv4 ループ フリー代替高速再ルーティングのための前提条件

  • ループ フリー代替(LFA)高速再ルーティング(FRR)は、インターフェイスがポイントツーポイント インターフェイスである場合だけ、インターフェイスを介して到達可能なパスを保護できます。
  • LAN インターフェイスが 1 つのネイバーに物理的に接続されている場合、LFA FRR で保護するために、LAN インターフェイスをポイントツーポイント インターフェイスとして設定する必要があります。

IPv4 ループ フリー代替高速再ルーティングの制約事項

  • マルチプロトコル ラベル スイッチング(MPLS)トラフィック エンジニアリング(TE)トンネルは保護インターフェイスとして使用できません。 ただし、MPLS TE トンネルは、TE トンネルがプライマリ パスとして使用される限り、保護(修復)インターフェイスとして使用できます。
  • ロードバランス サポートは、FRR で保護されたプレフィックスで利用可能ですが、50 ミリ秒のカットオーバーの時間は保証されません。
  • 最大 8 個の FRR 保護のインターフェイスで同時にカットオーバーを実行することができます。
  • レイヤ 3 VPN だけがサポートされます。
  • IPv4 マルチキャストはサポートされていません。
  • IPv6 はサポートされていません。
  • IS-IS は、プライマリ インターフェイスがトンネルであるプレフィックスの LFA を計算しません。
  • LFA 計算は、同じレベルまたは領域に属するインターフェイスまたはリンクに制限されます。 したがって、バックアップ LFA の計算時に同じ LAN 上のすべてのネイバーを除外すると、トポロジのサブセットで修復を使用できなくなる可能性があります。
  • 物理インターフェイスおよび物理ポートチャネル インターフェイスのみ保護されます。 サブインターフェイス、トンネル、および仮想インターフェイスは保護されません。
  • TE ラベル スイッチド パス(LSP)は、バックアップ パスとして使用できます。 ただし、プライマリ パスは、リング トポロジの FRR を完了するために使用できる物理インターフェイスである必要があります。
  • ボーダー ゲートウェイ プロトコル(BGP)プレフィックス独立コンバージェンス(PIC)と IP FRR は、同じプレフィックスに使用されない限り、同じインターフェイス上に設定できます。

次の制限は、ASR 903 シリーズ アグリゲーション サービス ルータに適用されます。

  • Cisco ASR 903 シリーズ アグリゲーション サービス ルータで LFA FRR をイネーブルにするには、mpls ldp explicit-null コマンドをイネーブルにする必要があります。implicit-null キーワードはサポートされていません。
  • ASR 903 は最大 4000 の LFA FRR ルートをサポートします。
  • LFA FRR は、等コスト マルチパス(ECMP)ではサポートされません。
  • リモート LFA トンネルは、ハイ アベイラビリティ対応ではないため、ステートフル スイッチオーバー(SSO)と共存できますが、SSO 準拠ではありません。
  • 双方向フォワーディング(BFD)によってトリガされる高速再ルーティングはサポートされません。 LFA FRR トポロジの一部になっているインターフェイスでは、BFD を設定しないでください。

IPv4 ループ フリー代替高速再ルーティングに関する情報

IS-IS および IP FRR

ローカル リンクがネットワークで失敗した場合、IS-IS は、影響を受けるすべてのプレフィックスの新しいプライマリ ネクストホップ ルートを再計算します。 これらのプレフィックスは、RIB および転送情報ベース(FIB)で更新されます。 プライマリ プレフィックスがフォワーディング プレーンで更新されるまで、影響を受けるプレフィックス宛てのトラフィックは廃棄されます。 このプロセスには数百ミリ秒かかることがあります。

IP FRR で、IS-IS はプライマリ パスで障害が発生した場合に使用するために、フォワーディング プレーンに対する LFA ネクストホップ ルートを計算します。 LFA はプレフィックスごとに計算されます。

特定のプライマリ パスに複数の LFA がある場合、IS-IS はプライマリ パスの単一 LFA を選ぶために、タイブレーク ルールを使用します。 複数 LFA パスを持つプライマリ パスの場合、プレフィックスは LFA パス間で均等に分散されます。

修復パス

修復パスでは、ルーティングの遷移時にトラフィックが転送されます。 リンクやルータに障害が発生すると、物理層シグナルの損失が発生するため、まず、隣接ルータだけが障害を認識します。 ネットワーク内のその他すべてのルータは、この障害に関する情報がルーティング プロトコルによって伝播されるまで(これには数百ミリ秒かかる可能性があります)、この障害の性質と場所を認識しません。 したがって、このネットワーク障害の影響を受けたパケットがそれぞれの宛先に到達するように準備する必要があります。

障害が発生したリンクに隣接するルータは、障害が発生したリンクを使用していた可能性のあるパケットに対して、一連の修復パスを使用します。 これらの修復パスは、ルータが障害を検出してから、ルーティングの遷移が完了するまで使用されます。 ルーティングの遷移が完了するまでに、ネットワーク内のすべてのルータは転送データを変更し、障害が発生したリンクはルーティングの計算から除外されます。

修復パスは、障害が検出されるとすぐにアクティブになるようにするために、障害を予測して事前計算されます。

IPv4 LFA FRR 機能は次の修復パスを使用します。
  • 等コスト マルチパス(ECMP)は、宛先への等コスト パス分割セットのメンバーとして、リンクを使用します。 セットの他のメンバーは、リンクに障害が発生したときに代替パスを提供できます。
  • LFA は、ループバックしないで宛先にパケットを送るネクストホップ ルートです。 ダウンストリーム パスは LFA のサブセットです。

LFA の概要

LFA はプライマリ ネイバー以外のノードです。 トラフィックは、ネットワーク障害発生後に LFA にリダイレクトされます。 LFA は、失敗について認識せずに転送を決定します。

LFA は、トラフィックの転送に障害のある要素を使用したり、保護ノードを使用することはできません。 LFA はループを発生させてはなりません。 LFA は、インターフェイスがプライマリ パスとして使用できる限り、デフォルトでサポートされるすべてのインターフェイスでイネーブルになります。

プレフィックスごとの LFA を使用する利点は次のとおりです。
  • プライマリ パスでリンクがダウンした場合、修復パスが移行中にトラフィックを転送します。
  • プレフィックスごとの LFA を持つすべての宛先が保護されます。 これにより、サブセット(障害の遠端のノード)のみが保護されない状態で残ります。

LFA の計算

プレフィックスごとに LFA を計算する汎用アルゴリズムについては、RFC 5286 を参照してください。 IS-IS は、メモリ使用量を減らすための少量の変更とともに RFC 5286 を実装します。 保護のプレフィックスを検証する前にすべてのネイバーの Sender Policy Framework(SPF)を実行する代わりに、IS-IS は SPF がネイバーごとに実行された後でプレフィックスを検査します。 SPF の実行後に IS-IS がプレフィックスを検査するため、IS-IS は各ネイバー SPF の実行後に最適な修復パスを保持します。 IS-IS では、すべてのネイバーに対する SPF の結果を保存する必要はありません。

RIB とルーティング プロトコル間の連携

ルーティング プロトコルは、タイブレーク アルゴリズムを実装して、プレフィックスの修復パスを計算します。 計算の結果は、プライマリ パス付きの一連のプレフィックスになり、いくつかのプライマリ パスが修復パスに関連付けられます。

タイブレーク アルゴリズムは特定の条件を満たすか、または特定の属性を持つ LFA を考慮します。 複数の LFA がある場合、tie-break キーワードとともに fast-reroute per-prefix コマンドを設定します。 ルールによってすべての候補 LFA が除外される場合、そのルールはスキップされます。

プライマリ パスには、複数の LFA を設定できます。 デフォルトのタイブレーク ルールを実装し、ユーザがこれらのルールを変更できるようにするには、ルーティング プロトコルが必要です。 タイブレーク アルゴリズムの目的は、複数の候補 LFA を除外し、プレフィックス単位のプライマリ パスごとに 1 つの LFA を選択し、プライマリ パスが失敗したときに複数の候補 LFA でトラフィックを分散させることです。

タイブレーク ルールでは、すべての候補を除外することはできません。

タイブレークには、次の属性が使用されます。
  • ダウンストリーム:保護された宛先へのメトリックが宛先へのノードを保護しているメトリックよりも低い候補を除外します。
  • ラインカード分離:保護されたパスと同じラインカードを共有している候補を除外します。
  • 共有リスク リンク グループ(SRLG):保護されたパス SRLG のいずれかに属する候補を除外します。
  • 負荷分散:保護されたパスを共有するプレフィックスで残りの候補を分散させます。
  • 最低修復パス メトリック:保護されたプレフィックスへのメトリックが高い候補を除外します。
  • ノードの保護:保護されたノードではない候補を除外します。
  • プライマリ パス:ECMP ではない候補を除外します。
  • セカンダリ パス:ECMP の候補を除外します。

IPv4 ループ フリー代替高速再ルーティングの設定方法

高速再ルーティングのサポートの設定


(注)  


LFA 計算はすべてのルートに対してイネーブルになり、FRR はサポートされるすべてのインターフェイスでイネーブルになります。


手順の概要

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    ip address ip-address mask

    5.    ip router isis area-tag

    6.    isis tag tag-number

    7.    exit

    8.    interface type number

    9.    ip address ip-address mask

    10.    ip router isis area-tag

    11.    isis tag tag-number

    12.    exit

    13.    router isis area-tag

    14.    net net

    15.    fast-reroute per-prefix {level-1 | level-2} {all | route-map route-map-name}

    16.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
              
     
    特権 EXEC モードをイネーブルにします。
    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
              
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface type number


    例:
    Device(config)# interface GigabitEthernet0/0/0
              
     

    インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 4 ip address ip-address mask


    例:
    Device(config-if)# ip address 10.1.1.1 255.255.255.0
              
     

    インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

     
    ステップ 5 ip router isis area-tag


    例:
    Device(config-if)# ip router isis ipfrr
              
     

    インターフェイス上で IP の IS-IS ルーティング プロセスを設定して、エリア指示子をルーティング プロセスに添付します。

     
    ステップ 6 isis tag tag-number


    例:
    Device(config-if)# isis tag 17
              
     

    IP プレフィックスが IS-IS リンクステート パケット(LSP)に追加されたときに、インターフェイスに設定された IP アドレスにタグを設定します。

     
    ステップ 7 exit


    例:
    Device(config-if)# exit
              
     

    インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 8 interface type number


    例:
    Device(config)# interface GigabitEthernet0/0/1
              
     

    インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 9 ip address ip-address mask


    例:
    Device(config-if)# ip address 192.168.255.2 255.255.255.0
              
     

    インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

     
    ステップ 10 ip router isis area-tag


    例:
    Device(config-if)# ip router isis ipfrr
              
     

    インターフェイス上で IP の IS-IS ルーティング プロセスを設定して、エリア指示子をルーティング プロセスに添付します。

     
    ステップ 11 isis tag tag-number


    例:
    Device(config-if)# isis tag 17
              
     

    IP プレフィックスが IS-IS LSP に追加されたときに、インターフェイスに設定された IP アドレスにタグを設定します。

     
    ステップ 12 exit


    例:
    Device(config-if)# exit
              
     

    インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 13 router isis area-tag


    例:
    Device(config)# router isis ipfrr
              
     

    IS-IS ルーティング プロトコルをイネーブルにし、IS-IS プロセスを指定して、ルータ コンフィギュレーション モードを開始します。

     
    ステップ 14 net net


    例:
    Device(config-router)# net 49.0001.0101.2800.0001.00
              
     

    ルーティング プロセスの IS-IS Network Entity(NET)を設定します。

     
    ステップ 15 fast-reroute per-prefix {level-1 | level-2} {all | route-map route-map-name}


    例:
    Device(config-router)# fast-reroute per-prefix level-2 all
              
     
    プレフィックス単位の FRR をイネーブルにします。
    • すべてのプレフィックスを保護するために、all キーワードを設定します。
     
    ステップ 16 end


    例:
    Device(config-router)# end
              
     

    ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

     

    IPv4 ループ フリー代替高速再ルーティングの設定例

    例:IPv4 ループ フリー代替高速再ルーティングの設定のサポート

    次の図は、インターフェイス タグを使用して BGP ネクスト ホップを保護する IPv4 LFA FRR を示します。
    図 1. サンプル IPv4 LFA FRR 設定

    次に、上記の図に示すように、ルータ A の IPv4 LFA FRR を設定する例を示します。 ルータ A は、タグ 17 とともにプレフィックス 10.0.0.0/24 と 192.168.255.0/24 をアドバタイズします。

    Device# configure terminal
    Device(config)# interface GigabitEthernet0/0/0
    Device(config-if)# ip address 10.1.1.1 255.255.255.0
    Device(config-if)# ip router isis ipfrr
    Device(config-if)# isis tag 17
    Device(config-if)# exit
    Device(config)# interface GigabitEthernet0/0/1
    Device(config-if)# ip address 192.168.255.2 255.255.255.0
    Device(config-if)# ip router isis ipfrr
    Device(config-if)# isis tag 17
    Device(config-if)# exit
    Device(config)# router isis ipfrr
    Device(config-router)# net 49.0001.0001.0001.0001.00
    Device(config-router)# fast-reroute per-prefix level-2
          

    次に、上記の図に示すように、他のルータの IPv4 LFA FRR を設定する例を示します。 他のルータは、ルータ A に設定された 2 つのプレフィックスの修復パスの計算にタグ 17 を使用できます。

    Device(config)# router isis
    Device(config-router)# net 47.0004.004d.0001.0001.c11.1111.00
    Device(config-router)# fast-reroute per-prefix level-2 route-map ipfrr-include
    Device(config-router)# exit
    Device(config)# route-map ipfrr-include
    Device(config-router)# match tag 17

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    Cisco IOS コマンド

    『Master Commands List, All Releases』

    MPLS コマンド

    『Multiprotocol Label Switching Command Reference』

    IP ルーティング:Protocol-Independent コマンド

    『IP Routing: Protocol-Independent Command Reference』

    IS-IS コマンド

    『IP Routing: ISIS Command Reference』

    MIB

    MIB

    MIB のリンク

    なし

    選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

    http:/​/​www.cisco.com/​go/​mibs

    シスコのテクニカル サポート

    説明

    リンク

    シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    IPv4 ループ フリー代替高速再ルーティングの設定に関する機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

    表 1 IPv4 ループ フリー代替高速再ルーティングの設定に関する機能情報

    機能名

    リリース

    機能情報

    IPv4 ループ フリー代替高速再ルーティング

    リンクやルータに障害が発生すると、配布されたルーティング アルゴリズムによって、変更を考慮した新しいルートが計算されます。 計算のための時間をルーティングの遷移と呼びます。 遷移が完了し、すべてのルータがネットワーク上の共通のビューで収束されるまで、送信元と宛先のペア間の接続は中断されます。 事前計算済みの代替ネクスト ホップを使用してルーティングの遷移時間を 50 ミリ秒より少なくするために、IPv4 ループ フリー代替高速再ルーティング機能を使用できます。 リンク障害の通知を受けると、ルータはトラフィック損失を減らすために、修復パスにすぐに切替えます。

    IPv4 ループ フリー代替高速再ルーティングは、修復パスの事前計算に重点を置いています。 修復パスの計算は、IS-IS ルーティング プロトコルによって実行され、結果(修復パス)は RIB に送信されます。 修復パスのインストールは、シスコ エクスプレス フォワーディングによって実行されます。

    Cisco IOS XE Release 3.6S では、この機能は ASR 903 シリーズ アグリゲーション サービス ルータに導入されました。

    次のコマンドが導入または変更されました。debug isis fast-reroutefast-reroute load-sharing disablefast-reroute per-prefixfast-reroute tie-breakshow isis fast-reroute