IP ルーティング:プロトコル非依存コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
IPv6 ルーティング:スタティック ルーティング
IPv6 ルーティング:スタティック ルーティング
発行日;2013/06/09   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

IPv6 ルーティング:スタティック ルーティング

この機能は、IPv6 のスタティック ルーティングを提供します。 スタティック ルートは、手動で設定され、2 つのネットワーク デバイス間の明示パスを定義します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、プラットフォームおよびソフトウェア リリースの不具合の検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

IPv6 ルーティング:スタティック ルーティングの前提条件

スタティック IPv6 ルートでデバイスを設定する前に、ipv6 unicast-routing グローバル コンフィギュレーション コマンドを使用して IPv6 パケットの転送をイネーブルにし、1 つ以上のインターフェイスで IPv6 をイネーブルにし、そのインターフェイスで IPv6 アドレスをイネーブルにする必要があります。

IPv6 ルーティング:スタティック ルーティングの制約事項

  • IPv6 スタティック ルートは、IPv4 ip route コマンドのタグおよび永続キーワードをサポートしません。
  • IPv6 は、仮想ルーティングおよび転送(VRF)テーブルへのスタティック ルートの挿入をサポートしていません。
  • スタティック設定が、リブート時やユーザがデバイスを切断して再接続するときに失われるため、ダイナミック インターフェイス上でスタティック設定を設定しないでください。

IPv6 ルーティング:スタティック ルーティングに関する情報

スタティック ルート

ネットワーキング デバイスでは、手動で設定したルート情報、またはルーティング プロトコルを使用してダイナミックに学習したルート情報を使用して、パケットを転送します。 スタティック ルートは、手動で設定され、2 つのネットワーク デバイス間の明示パスを定義します。 ダイナミック ルーティング プロトコルとは異なり、スタティック ルートは動的に更新されず、ネットワーク トポロジが変更された場合は手動で再設定する必要があります。 スタティック ルートを使用する利点は、セキュリティが高まり、リソースが効率化されることです。 スタティック ルートでは、ダイナミック ルーティング プロトコルよりも少ない帯域幅を使用し、ルートの計算および通信に CPU サイクルが使用されません。 スタティック ルートを使用する場合の主なデメリットは、ネットワーク トポロジが変更された場合に自動的に再設定されないことです。

スタティック ルートはダイナミック ルーティング プロトコルに再配布できますが、ダイナミック ルーティング プロトコルによって生成されたルートは、スタティック ルーティング テーブルに再配布できません。 スタティック ルートを使用するルーティング ループの設定を回避するアルゴリズムはありません。

スタティック ルートは、外部ネットワークへのパスが 1 つしかない小規模ネットワークでは有用です。また、大規模ネットワークの場合は、より厳格な制御が必要な、他のネットワークへの特定のタイプのトラフィックやリンクにセキュリティを提供します。 一般に、大半のネットワークでは、ダイナミック ルーティング プロトコルを使用してネットワーキング デバイス間の通信を行いますが、特殊なケース用として 1 つまたは 2 つのスタティック ルートを設定している場合があります。

直接接続されているスタティック ルート

直接接続されたスタティック ルートでは、出力インターフェイスだけが指定されます。 宛先は、出力インターフェイスに直接接続されていると想定されるため、パケットの宛先はネクストホップ アドレスとして使用されます。 次に、このような定義の例を示します。

ipv6 route 2001:DB8::/32 gigabitethernet1/0/0 

この例では、アドレス プレフィックス 2001:DB8::/32 を持つすべての宛先がインターフェイス GigabitEthernet1/0/0 経由で直接到達可能であることを指定しています。

直接接続されたスタティック ルートは、有効な IPv6 インターフェイス(つまり、アップ状態にあり、かつ IPv6 がイネーブルになっているインターフェイス)を示している場合にかぎり、IPv6 ルーティング テーブルに挿入される候補となります。

再帰スタティック ルート

再帰スタティック ルートでは、ネクスト ホップだけが指定されます。 出力インターフェイスはネクスト ホップから取得されます。 次に、このような定義の例を示します。

ipv6 route 2001:DB8::/32 2001:DB8:3000:1

この例では、アドレス プレフィックス 2001:DB8::/32 を持つすべての宛先が、アドレス 2001:DB8:3000:1 を持つホストを介して到着可能であることを指定しています。

再帰スタティック ルートが有効である(つまり、IPv6 ルーティング テーブルに挿入される候補である)のは、指定したネクスト ホップが直接的または間接的に有効な IPv6 出力インターフェイスに解決され、ルートが自己再帰型ではなく、再帰深度が IPv6 転送の最大再帰深度を超えていない場合だけです。

自身のネクスト ホップ解決に使用されるのがそのルート自身である場合、ルートは自己再帰します。 たとえば、IPv6 ルーティング テーブルに次のルートがあるとします。

IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
R   2001:DB8::/32 [130/0]
     via ::, Serial2/0
B   2001:DB8:3000:0/16 [200/45]
     Via 2001:DB8::0104

次の例では、再帰 IPv6 スタティック ルートを定義します。

ipv6 route 
2001:DB8::/32 2001:0BD8:3000:1

このスタティック ルートは、自己再帰型であるため、IPv6 ルーティング テーブルには挿入されません。 スタティック ルートのネクスト ホップ 2001:DB8:3000:1 は、自身が再帰ルートである(つまり、ネクスト ホップだけを指定する)BGP ルート 2001:DB8:3000:0/16 を介して解決されます。 BGP ルートのネクスト ホップ 2001:DB8::0104 はスタティック ルートを介して解決されます。 したがって、スタティック ルートは、スタティック ルート自身のネクスト ホップを解決するために使用されることになります。

一般に、自己再帰型スタティック ルートの手動設定は禁止されていませんが、有用ではありません。 ただし、IPv6 ルーティング テーブルに挿入された再帰スタティック ルートが、ダイナミック ルーティング プロトコルを介して学習された、ネットワークでの何らかの一時的変更の結果として自己再帰になる場合があります。 このような状況が発生すると、スタティック ルートが自己再帰になった事実が検出され、そのスタティック ルートは IPv6 ルーティング テーブルから削除されます(設定からは削除されません)。 以降のネットワーク変更によって、スタティック ルートが自己再帰でなくなる場合があります。この場合、そのスタティック ルートは IPv6 ルーティング テーブルに再挿入されます。

完全指定のスタティック ルート

完全指定のスタティック ルートでは、出力インターフェイスとネクスト ホップの両方が指定されています。 この形式のスタティック ルートは、出力インターフェイスがマルチアクセス インターフェイスであり、ネクスト ホップを明示的に識別する必要がある場合に使用されます。 ネクスト ホップは、指定した出力インターフェイスに直接接続されている必要があります。 次の例に、完全指定のスタティック ルートの定義を示します。

ipv6 route 2001:DB8:/32 gigabitethernet1/0/0 2001:DB8:3000:1

完全指定のルートが有効である(つまり、IPv6 ルーティング テーブルに挿入される候補である)のは、指定した IPv6 インターフェイスが IPv6 対応であり、かつアップ状態となっている場合です。

フローティング スタティック ルート

フローティング スタティック ルートは、設定されたルーティング プロトコルを介して学習されたダイナミック ルートのバックアップに使用されるスタティック ルートです。 フローティング スタティック ルートには、バックアップしているルーティング プロトコルよりも大きなアドミニストレーティブ ディスタンスが設定されています。 このため、ルーティング プロトコルを介して学習されたダイナミック ルートは、フローティング スタティック ルートよりも常に優先して使用されます。 ルーティング プロトコルを介して学習されたダイナミック ルートが失われると、フローティング スタティック ルートが代わりに使用されます。 次に、フローティング スタティック ルートを定義する例を示します。

ipv6 route 2001:DB8:/32 gigabitethernet1/0/0 2001:DB8:3000:1 210

3 つのタイプの IPv6 スタティック ルートのいずれも、フローティング スタティック ルートとして使用できます。 フローティング スタティック ルートは、ダイナミック ルーティング プロトコルよりも大きいアドミニストレーティブ ディスタンスを使用して設定する必要があります。これは、小さいアドミニストレーティブ ディスタンスが設定されたルートの方が優先されるためです。


(注)  


デフォルトで、スタティック ルートはダイナミック ルートよりも小さいアドミニストレーティブ ディスタンスを持っているため、スタティック ルートは、ダイナミック ルートよりも優先して使用されます。


IPv6 スタティック ルーティングの設定方法

スタティック IPv6 ルートの設定

手順の概要

    1.    enable

    2.    configure terminal

    3.    ipv6 route ipv6-prefix / prefix-length ipv6-address | interface-type interface-number ipv6-address]} [administrative-distance] [administrative-multicast-distance | unicast| multicast] [tag tag]


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 ipv6 route ipv6-prefix / prefix-length ipv6-address | interface-type interface-number ipv6-address]} [administrative-distance] [administrative-multicast-distance | unicast| multicast] [tag tag]


    例:
    Device(config)# ipv6 route ::/0 serial 2/0
     

    スタティック IPv6 ルートを設定します。

    • デフォルトのスタティック IPv6 ルートは、シリアル インターフェイス上で設定されます。
    • この表の直後の構文例で、スタティック ルートを設定するための ipv6 route コマンドの特別な使用法を参照してください。
     

    デフォルトの IPv6 スタティック ルートを使用するための再帰 IPv6 スタティック ルートの設定

    デフォルトでは、再帰 IPv6 スタティック ルートは、デフォルト ルート(::/0)を使用して解決されません。 従来の動作に戻して、デフォルト ルートを使用して解決できるようにするには、次の作業を実行します。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    ipv6 route static resolve default


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Device> enable 
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Device# configure terminal 
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 ipv6 route static resolve default


      例:
      Device(config)# ipv6 route static resolve default 
       

      デフォルトの IPv6 スタティック ルートを使用して再帰 IPv6 スタティック ルートを解決できるようにします。

       

      フローティング スタティック IPv6 ルートの設定

      手順の概要

        1.    enable

        2.    configure terminal

        3.    ipv6 route ipv6-prefix / prefix-length {ipv6-address | interface-type interface-number ipv6-address]} [administrative-distance] [administrative-multicast-distance | unicast | multicast] [tag tag]


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Device> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 configure terminal


        例:
        Device# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 ipv6 route ipv6-prefix / prefix-length {ipv6-address | interface-type interface-number ipv6-address]} [administrative-distance] [administrative-multicast-distance | unicast | multicast] [tag tag]


        例:
        Device(config)# ipv6 route 2001:DB8::/32 serial 2/0 201
         

        スタティック IPv6 ルートを設定します。

        • この例では、フローティング スタティック IPv6 ルートが設定されます。
        • デフォルトのアドミニストレーティブ ディスタンスは、次のとおりです。
          • 接続されたインターフェイス:0
          • スタティック ルート:1
          • Enhanced Interior Gateway Routing Protocol(EIGRP)サマリー ルート:5
          • 外部ボーダー ゲートウェイ プロトコル(eBGP):20
          • 内部 Enhanced IGRP:90
          • IGRP:100
          • Open Shortest Path First(OSPF):110
          • Intermediate System-to-Intermediate System(IS-IS):115
          • ルーティング情報プロトコル(RIP):120
          • 外部ゲートウェイ プロトコル(EGP):140
          • EIGRP 外部ルート:170
          • 内部 BGP:200
          • 不明:255
         

        スタティック IPv6 ルートの設定と動作の確認

        手順の概要

          1.    enable

          2.    次のいずれかを実行します。

          • show ipv6 static [ipv6-address | ipv6-prefix / prefix-length][interface interface-type interface-number] [recursive] [detail]
          • show ipv6 route [ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number]

          3.    debug ipv6 routing


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Device> enable
           

          特権 EXEC モードをイネーブルにします。

          • パスワードを入力します(要求された場合)。
           
          ステップ 2次のいずれかを実行します。
          • show ipv6 static [ipv6-address | ipv6-prefix / prefix-length][interface interface-type interface-number] [recursive] [detail]
          • show ipv6 route [ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number]


          例:
          Device# show ipv6 static


          例:
          Device# show ipv6 route static
           

          IPv6 ルーティング テーブルの現在の内容を表示します。

          • これらの例は、IPv6 スタティック ルートを表示する 2 つの方法を示しています。
           
          ステップ 3 debug ipv6 routing


          例:
          Device# debug ipv6 routing
           

          IPv6 ルーティング テーブルの更新およびルート キャッシュの更新に関するデバッグ メッセージを表示します。

           

          IPv6 スタティック ルーティングの設定例

          スタティック ルートは、さまざまな目的に使用できます。 一般的な使用方法は、次のとおりです。

          • 手動集約
          • トラフィック廃棄
          • デフォルトの固定ルート
          • バックアップ ルート

          多くの場合、シスコ ソフトウェアには、同一の目的を果たすための代替メカニズムが用意されています。 スタティック ルートを使用するか、またはいずれかの代替メカニズムを使用するかは、ローカルの状況によって決まります。

          手動集約の設定例

          次に、RIP にアドバタイズされるローカル インターフェイス プレフィックスを集約するために使用するスタティック ルートの例を示します。 スタティック ルートは、廃棄ルートとしても機能し、より具体的なインターフェイス プレフィックスの対象とならない 2001:DB8:1::/48 宛先に対する、ルータが受信したパケットを廃棄します。

          Router> enable
          Router# configure terminal
          Enter configuration commands, one per line.  End with CNTL/Z.
          Router(config)# interface gigabitethernet0/0/0
          Router(config-if)# ipv6 address 2001:DB8:2:1234/64
          Router(config-if)# exit
          Router(config)# 
          Router(config)# interface gigabitethernet1/0/0
          Router(config-if)# ipv6 address 2001:DB8:3:1234/64
          Router(config-if)# exit
          Router(config)#
          Router(config)# interface gigabitethernet2/0/0
          Router(config-if)# ipv6 address 2001:DB8:4:1234/64
          Router(config-if)# exit
          Router(config)#
          Router(config)# interface gigabitethernet3/0/0
          Router(config-if)# ipv6 address 2001:DB8::1234/64
          Router(config-if)# ipv6 rip one enable
          Router(config-if)# exit
          Router(config)#
          Router(config)# ipv6 router rip one
          Router(config-rtr)# redistribute static
          Router(config-rtr)# exit
          Router(config)#
          Router(config)# ipv6 route 2001:DB8:1:1/48 null0
          Router(config)# end
          Router#
          00:01:30: %SYS-5-CONFIG_I: Configured from console by console
          Router# show ipv6 route static
          
          IPv6 Routing Table - 3 entries
          Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
                 U - Per-user Static route
                 I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
                 O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
                 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
          S   2001:DB8:1::/48 [1/0]
               via ::, Null0

          例:トラフィック廃棄の設定

          インターフェイス null0 をポイントするようにスタティック ルートを設定することで、特定のプレフィックスへのトラフィックを廃棄できます。 たとえば、プレフィックス 2001:DB8:42:1/64 へのすべてのトラフィックを廃棄する必要がある場合は、次のスタティック ルートが定義されます。

          Device> enable
          Device# configure
           terminal
          Enter configuration commands, one per line.  End with CNTL/Z.
          Device(config)# ipv6 route 2001:DB8:42:1::/64 null0 
          Device(config)# end
          

          例:デフォルトの固定ルートの設定

          デフォルトのスタティック ルートは、多くの場合、単純なルータ トポロジで使用されます。 次の例で、ルータは、GigabitEthernet 0/0/0 を経由してローカル サイトに接続され、シリアル 2/0/0 とシリアル 3/0/0 を経由して企業のメイン ネットワークに接続されます。 非ローカル トラフィックはすべて、2 つのシリアル インターフェイスを介してルーティングされます。

          Router(config)# interface gigabitethernet0/0/0
          Router(config-if)# ipv6 address 2001:DB8:17:1234/64
          Router(config-if)# exit
          Router(config)# interface Serial2/0/0
          Router(config-if)# ipv6 address 2001:DB8:1:1234/64
          Router(config-if)# exit
          Router(config)# interface Serial3/0/0
          Router(config-if)# ipv6 address 2001:DB8:2:124/64
          Router(config-if)# exit
          Router(config)# ipv6 route ::/0 Serial2/0
          Router(config)# ipv6 route ::/0 Serial3/0
          Router(config)# end
          Router#
          00:06:30: %SYS-5-CONFIG_I: Configured from console by console
          Router# show ipv6 route static
          IPv6 Routing Table - 7 entries
          Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
                 U - Per-user Static route
                 I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
                 O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
                 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
          S   ::/0 [1/0]
               via ::, Serial2/0
               via ::, Serial3/0

          例:フローティング スタティック ルートの設定

          多くの場合、フローティング スタティック ルートは、接続の問題が発生した場合にバックアップ パスを提供するために使用されます。 次の例では、ルータは、GigabitEthernet0/0/0 を介してネットワーク コアに接続されており、IS-IS を介してルート 2001:DB8:1:1/32 を学習します。 GigabitEthernet0/0/0 インターフェイスに障害が発生するか、またはルート 2001:DB8:1:1/32 が IS-IS を介して学習されなくなった(ネットワークのいずれかの箇所で接続が失われていることを示します)場合、トラフィックはバックアップ ISDN インターフェイスを介してルーティングされます。

          Router> enable
          Router# configure
           terminal
          Enter configuration commands, one per line.  End with CNTL/Z.
          Router(config)# interface gigabitethernet0/0/0
          Router(config-if)# ipv6 address 2001:DB8:17:1234/64
          Router(config-if)# exit
          Router(config)# interface gigabitethernet0/0/0
          Router(config-if)# ipv6 address 2001:DB8:1:1234/64
          Router(config-if)# ipv6
           router
           isis
          Router(config-if)# exit
          Router(config)# router isis
          Router(config-router)# net 42.0000.0000.0000.0001.00
          Router(config-router)# exit
          Router(config)# interface BRI1/0
          Router(config-if)# encapsulation ppp
          Router(config-if)# ipv6 enable
          Router(config-if)# isdn switch-type basic-net3
          Router(config-if)# ppp authentication chap optional
          Router(config-if)# ppp multilink
          Router(config-if)# exit
          Router(config)# dialer-list 1 protocol ipv6 permit
          Router(config)# ipv6 route 2001:DB8:1::/32 BRI1/0 200
          Router(config)# end
          Router#
          00:03:07: %SYS-5-CONFIG_I: Configured from console by console

          その他の関連資料

          関連資料

          関連項目

          マニュアル タイトル

          IPv6 アドレッシングと接続

          『IPv6 Configuration Guide』

          Cisco IOS コマンド

          『Cisco IOS Master Commands List, All Releases』

          IPv6 コマンド

          『Cisco IOS IPv6 Command Reference』

          Cisco IOS IPv6 機能

          『Cisco IOS IPv6 Feature Mapping』

          標準および RFC

          標準/RFC

          タイトル

          IPv6 に関する RFC

          IPv6 の RFC

          MIB

          MIB

          MIB のリンク

          選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

          http:/​/​www.cisco.com/​go/​mibs

          シスコのテクニカル サポート

          説明

          リンク

          シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          IPv6 ルーティング:スタティック ルーティングの機能情報

          次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

          プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

          表 1 IPv6 ルーティング:スタティック ルーティングの機能情報

          機能名

          リリース

          機能情報

          IPv6 ルーティング:スタティック ルーティング

          12.0(22)S

          12.2(2)T

          12.2(14)S

          12.2(17a)SX1

          12.2(25)SG

          12.2(28)SB

          12.2(33)SRA

          Cisco IOS XE Release 2.1

          スタティック ルートは、手動で設定され、2 つのネットワーク デバイス間の明示パスを定義します。

          次のコマンドが導入または変更されました。ipv6 routeipv6 route static resolve defaultshow ipv6 routeshow ipv6 static