IP ルーティング:プロトコル非依存コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
基本的な IP ルーティング
基本的な IP ルーティング
発行日;2013/06/09   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

基本的な IP ルーティング

この章では、基本的な IP ルーティングを設定する方法について説明します。 インターネット プロトコル(IP)は、パケットのルーティングのためのアドレシング情報と制御情報が格納された、ネットワーク層(レイヤ 3)プロトコルです。 IP は RFC 791 に規定されており、インターネット プロトコル スイートの主要なネットワーク層プロトコルです。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、プラットフォームおよびソフトウェア リリースの不具合の検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

基本的な IP ルーティングに関する情報

可変長サブネット マスク

Enhanced Interior Gateway Routing Protocol(EIGRP)、Intermediate System-to-Intermediate System(IS-IS)、Open Shortest Path First(OSPF)、Routing Information Protocol(RIP)バージョン 2、およびスタティック ルートは、可変長サブネット マスク(VLSM)をサポートします。 VLSM により、異なるインターフェイスの同じネットワーク番号に別のマスクを使用できるため、IP アドレスを維持し、使用可能なアドレス空間をより効率的に使用できます。 ただし、VLSM を使用すると、ネットワーク管理者によるアドレスの割り当てや現行の管理も難しくなります。

VLSM および適切なアドレス割り当て方法の詳細については、RFC 1219 を参照してください。


(注)  


VLSM の使用決定については、慎重に検討してください。 アドレス割り当ては間違えやすく、一般的に VLSM を使用したネットワークのモニタは複雑になります。


VLSM を実装する最善の方法は、既存のアドレッシング計画を維持し、いくつかのネットワークを段階的に VLSM に移行してアドレス レンジを回復することです。

スタティック ルート

スタティック ルートは、指定のパスを通るように発信元と宛先の間でパケットを移動させるユーザ定義のルートです。 スタティック ルートは、デバイスが特定の宛先へのルートを確立できない場合に重要になることがあります。 また、ルーティングできないすべてのパケットを送るラスト リゾート ゲートウェイを指定する場合にも役立ちます。

スタティック ルートを設定するには、ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance] [name] [permanent | track number] [tag tag] グローバル コンフィギュレーション コマンドを使用します。

スタティック ルートは、削除されるまでデバイス設定に残ります(no ip route グローバル コンフィギュレーション コマンドを使用します)。 ただし、アドミニストレーティブ ディスタンス値を慎重に割り当てることにより、ダイナミック ルーティング情報でスタティック ルートを上書きすることができます。 アドミニストレーティブ ディスタンスは、個々のルータやルータのグループなど、ルーティング情報発信元の信頼性を表す数値です。 数値的に、アドミニストレーティブ ディスタンスは 0 ~ 255 の整数です。 通常は、値が大きいほど、信頼性の格付けが下がります。 アドミニストレーティブ ディスタンスが 255 の場合はルーティング情報の送信元をまったく信頼できないため、無視する必要があります。

各ダイナミック ルーティング プロトコルには、デフォルトのアドミニストレーティブ ディスタンスが設定されています(下の表を参照)。 ダイナミック ルーティング プロトコルからの情報でスタティック ルートを上書きする場合は、スタティック ルートのアドミニストレーティブ ディスタンスがダイナミック プロトコルのものよりも大きいことを確認します。

表 1 ダイナミック ルーティング プロトコルのデフォルト アドミニストレーティブ ディスタンス

ルートの送信元

デフォルト距離

接続されているインターフェイス

0

スタティック ルート

1

Enhanced Interior Gateway Routing Protocol(EIGRP)サマリー ルート

5

外部ボーダー ゲートウェイ プロトコル(BGP)

20

内部 EIGRP

90

Interior Gateway Routing Protocol(IGRP)

100

Open Shortest Path First(OSPF)

110

Intermediate System to Intermediate System(IS-IS)

115

ルーティング情報プロトコル(RIP)

120

外部ゲートウェイ ルーティング プロトコル(EGP)

140

On Demand Routing(ODR)

160

外部 EIGRP

170

内部 BGP

200

Unknown

255

インターフェイスを指定したスタティック ルートは、redistribute static ルータ コンフィギュレーション コマンドが RIP、EIGRP、およびその他のダイナミック ルーティング プロトコルに指定されているかどうかにかかわらず、それらのルーティング プロトコルを介してアドバタイズされます。 これらのスタティック ルートがアドバタイズされるのは、インターフェイスを指し示すスタティック ルートが接続された結果、静的な性質を失ったとルーティング テーブルで見なされるためです。 ただし、network コマンドで定義されたネットワークではないインターフェイスへのスタティック ルートを定義する場合、redistribute static コマンドがこれらのプロトコルに指定されない限り、ダイナミック ルーティング プロトコルはルートをアドバタイズしません。

インターフェイスがダウンすると、ダウンしたインターフェイスを経由するすべてのスタティック ルートが IP ルーティング テーブルから削除されます。 また、スタティック ルートの転送先デバイス アドレスに指定されたアドレスに有効なネクスト ホップをソフトウェアが検出できない場合も、IP ルーティング テーブルからスタティック ルートが削除されます。


(注)  


E クラスの送信元アドレス(240.0.0.0/4)を持つパケットは、Cisco ASR 1000 シリーズ アグリゲーション サービス ルータでドロップされますが、RFC 1812(IP Version 4 ルータの要件)は、特に送信元アドレスに対してでなく、宛先アドレスに対してのみこの動作を定義します。


デフォルト ルート

ラスト リゾート ゲートウェイとしても知られるデフォルト ルートは、ルーティング テーブルに明示的には表示されていないネットワークにアドレス指定されたパケットをルーティングするために使用されます。 デバイスはすべてのネットワークへのルートを定められない場合があります。 完全なルーティング機能を提供するために、ネットワーク管理者は一部のデバイスをスマート デバイスとして使用し、残りのデバイスにそのスマート デバイスへのデフォルト ルートを提供します。 (スマート デバイスには、インターネットワーク全体のルーティング テーブル情報があります)。デフォルト ルートは動的に配信されるか、または個々のデバイスに手動で設定できます。

ほとんどのダイナミックな内部ルーティング プロトコルには、スマート デバイスがダイナミックなデフォルト情報を生成し、それを他のデバイスに渡す処理を発生させるメカニズムが含まれます。

次のコマンドを使用してデフォルト ルートを設定できます。
  • ip default-gateway
  • ip default-network
  • ip route 0.0.0.0 0.0.0.0

IP ルーティングがデバイス上でディセーブルな場合にデフォルト ゲートウェイを定義するには、ip default-gateway グローバル コンフィギュレーション コマンドを使用できます。 たとえば、デバイスがホストの場合、デバイスのデフォルト ゲートウェイを定義するためにこのコマンドを使用できます。 また、このコマンドは、デバイスがブート モードのときに、デバイスにシスコ ソフトウェア イメージを転送するために使用できます。 ブート モードでは、IP ルーティングはデバイスでイネーブルにされていません。

ip default-gateway コマンドとは異なり、デバイスで IP ルーティングがイネーブルになっている場合に ip default-network コマンドを使用できます。 ip default-network コマンドを使用してネットワークを指定すると、デバイスは、インストールのためのそのネットワークへのルートを、そのデバイスのラスト リゾート ゲートウェイとして認識します。

ip default-network コマンドを使用して設定されたラスト リゾート ゲートウェイは、デフォルト ルートを伝播させるルーティング プロトコルに応じて、異なる方法で伝播されます。 デフォルト ルートを伝播する Interior Gateway Routing Protocol(IGRP)と Enhanced Interior Gateway Routing Protocol(EIGRP)では、ip default-network コマンドで指定されたネットワークは IGRP または EIGRP で認識されている必要があります。 ネットワークは、ルーティング テーブルの IGRP または EIGRP から派生したネットワークである必要があります。または、ネットワークへのルートを生成するために使用するスタティック ルートは、IGRP または EIGRP に再配布されるか、これらのプロトコルに network コマンドを使用してアドバタイズする必要があります。 ラスト リゾート ゲートウェイが ip default-network コマンドを使用して設定されている場合、ルーティング情報プロトコル(RIP)は、ネットワーク 0.0.0.0 にルートをアドバタイズします。 ip default-network コマンドで指定されたネットワークは、明示的に RIP でアドバタイズする必要はありません。

ip route 0.0.0.0 0.0.0.0 コマンドを使用して、ネットワーク 0.0.0.0 0.0.0.0 へのスタティック ルートを作成することは、デバイスのラスト リゾート ゲートウェイを設定するもう 1 つの方法です。 ip default-network コマンドと同様に、0.0.0.0 へのスタティック ルートを使用することは、ルーティング プロトコルには依存しません。 ただし、IP ルーティングをデバイスでイネーブルにする必要があります。 IGRP はネットワーク 0.0.0.0 へのルートを認識しません。 したがって、ip route 0.0.0.0 0.0.0.0 コマンドを使用して作成されたデフォルト ルートを伝播できません。 ip default-network コマンドを使用して、IGRP がデフォルト ルートを伝搬するようにします。

EIGRP は、ネットワーク 0.0.0.0 へのルートを伝播しますが、スタティック ルートはルーティング プロトコルに再配布する必要があります。

シスコ ソフトウェアのリリースによっては、ip route 0.0.0.0 0.0.0.0 コマンドを使用して作成されたデフォルト ルートは、RIP デバイスによって自動的にアドバタイズされます。 一部のリリースでは、ルートが RIP によって学習されていない場合、RIP はデフォルト ルートをアドバタイズしません。 redistribute コマンドを使用して、RIP へのルートの再配布が必要な場合があります。

ip route 0.0.0.0 0.0.0.0 コマンドを使用して作成されたデフォルト ルートは、Open Shortest Path First(OSPF)および Intermediate System to Intermediate System(IS-IS)で伝播されません。 また、これらのデフォルト ルートは、OSPF または IS-IS に redistribute コマンドを使用して再配布できません。 OSPF または IS-IS ルーティング ドメインにデフォルト ルートを生成するには、default-information originate コマンドを使用します。

デフォルト ネットワーク

デフォルト ネットワークは、ルーティング テーブルに確立されていない宛先にパケットをルーティングするために使用されます。 IP ルーティングがデバイスでイネーブルになっている場合にデフォルト ネットワークを設定するには、ip default-network network-number グローバル コンフィギュレーション コマンドを使用できます。 デフォルト ネットワークを設定すると、デバイスは、インストールのためのそのネットワークへのルートを、そのデバイスのラスト リゾート ゲートウェイとして認識します。

ラスト リゾート ゲートウェイ

デフォルト情報をダイナミック ルーティング プロトコルを介して渡している場合、その他の設定は不要です。 ルーティング テーブルは定期的にスキャンされ、デフォルト ルートとして最適なデフォルト ネットワークが選択されます。 ルーティング情報プロトコル(RIP)の場合、ネットワーク 0.0.0.0 という唯一の選択肢しかありません。 Enhanced Interior Gateway Routing Protocol(EIGRP)の場合、システム デフォルトの候補となるいくつかのネットワークがある場合があります。 シスコ ソフトウェアは、アドミニストレーティブ ディスタンスとメトリックの両方の情報を使用して、デフォルト ルート(ラスト リゾート ゲートウェイ)を判断します。 選択したデフォルト ルートは、show ip route 特権 EXEC コマンドのラスト リゾート ゲートウェイの表示に表示されます。

ダイナミックなデフォルト情報がソフトウェアに渡されない場合、デフォルト ルートの候補を ip default-network グローバル コンフィギュレーション コマンドで指定します。 この方法では、ip default-network コマンドは引数として未接続ネットワークを使用します。 このネットワークが任意のソース(ダイナミックまたはスタティック)のルーティング テーブルに表示される場合、デフォルト ルート候補としてフラグが付けられ、デフォルト ルートとして使用できる選択肢になります。

デバイスのデフォルト ネットワークにインターフェイスがなく、そのネットワークに対するルートはある場合、そのネットワークはデフォルト パス候補と見なされます。 ルート候補は検査され、アドミニストレーティブ ディスタンスおよびメトリックに基づいて最適な候補が選択されます。 最適なデフォルト パスに対するゲートウェイは、ラスト リゾート ゲートウェイになります。

パスの最大数

デフォルトでは、ほとんどの IP ルーティング プロトコルでルーティング テーブルに最大 4 つのパラレル ルートがインストールされます。 スタティック ルートには、常に 6 つのルートがインストールされます。 ボーダー ゲートウェイ プロトコル(BGP)は例外で、デフォルトでは宛先へのパスが 1 つ(最良パス)しか許可されていません。 ただし、BGP は、等コストおよび不等コスト マルチパスのロード シェアリングを使用するように設定できます。

ルーティング テーブルへのインストールを設定できるパラレル ルートの数は、インストールされているシスコ ソフトウェアのバージョンによって変わります。 許可されるパラレル パスの最大数を変更するには、ルータ コンフィギュレーション モードで maximum-paths number-paths コマンドを使用します。

マルチインターフェイスの負荷分散

マルチインターフェイスの負荷分散により、複数のインターフェイスにわたって同じ宛先に向かうトラフィックを効率的に制御できます。 traffic-share min ルータ コンフィギュレーション コマンドでは、同じ宛先に複数のパスを使用できる場合、最小メトリックのパスだけがルーティング テーブルにインストールされるように指定します。 許可されるパスの数が 7 つ以上になることはありません。 ダイナミック ルーティング プロトコルの場合、パスの数はmaximum-paths ルータ コンフィギュレーション コマンドによって制御します。 スタティック ルートの発信元には、6 つのパスをインストールできます。 それよりも多くのパスを利用できる場合、余分なパスは廃棄されます。 インストールされたいくつかのパスがルーティング テーブルから削除されると、保留中のルートが自動的に追加されます。

ルーティング情報の再配布

シスコ ソフトウェアは、複数のルーティング プロトコルを同時に実行するだけでなく、あるルーティング プロトコルから別のルーティング プロトコルに情報を再配布できます。 たとえば、Enhanced Interior Gateway Routing Protocol(EIGRP)で送信されたルートを、ルーティング情報プロトコル(RIP)を使用して再アドバタイズしたり、EIGRP プロトコルを使用してスタティック ルートを再アドバタイズするようにデバイスを設定できます。 あるルーティング プロトコルから別のルーティング プロトコルへの再配布は、すべての IP ベース ルーティング プロトコルで設定できます。

また、2 つのドメイン間でルート マップを設定することにより、ルーティング ドメイン間でルートの再配布を条件に応じて制御することもできます。 ルート マップは、permit および deny ステートメント、match および set 句、およびシーケンス番号を使用して設定されるルートまたはパケット フィルタです。

再配布はプロトコルに依存しない機能ですが、match および set コマンドのいくつかは特定のプロトコルに固有のものです。

1 つまたは複数の match コマンドおよび 1 つまたは複数の set コマンドを、ルート マップ コンフィギュレーション モードで設定します。 match コマンドがない場合、すべてが一致します。 set コマンドがない場合、設定アクションは実行されません。

再配布用のルート マップを定義するには、route-map map-tag [permit | deny] [sequence-number] グローバル コンフィギュレーション コマンドを使用します。

ルーティング プロトコルのメトリックを、必ずしも別のルーティング プロトコルのメトリックに変換する必要はありません。 たとえば、RIP メトリックはホップ カウントですが、EIGRP メトリックは 5 つのメトリック値の組み合わせです。 このような場合、再配布されるルートにダイナミック メトリックが割り当てられます。 この場合の再配布は、ルーティング ループを防ぐために、インバウンド フィルタリングと共に一貫して慎重に適用する必要があります。

redistribute コマンドに設定したオプションを削除するには、期待する結果が得られるように no redistribute コマンドを慎重に使用する必要があります。

サポートされるメトリック変換

ここでは、ルーティング プロトコル間でサポートされる自動メトリック変換について説明します。 次の説明では、メトリック変換に代わるデフォルト再配布メトリックが定義されていないことを前提とします。

  • ルーティング情報プロトコル(RIP)は自動的にスタティック ルートを再配布できます。 スタティック ルートにはメトリック 1(直接接続)が割り当てられます。
  • ボーダー ゲートウェイ プロトコル(BGP)は、通常、ルーティング アップデートでメトリックを送信しません。
  • スタティック ルートと関連のインターフェイスが Enhanced Interior Gateway Routing Protocol(EIGRP)ネットワーク ステートメントで扱われる限り、EIGRP は他の EIGRP ルートの自律システムから自動的にスタティック ルートを再配布できます。 EIGRP は、スタティック ルートに対して、直接接続として指定するメトリックを割り当てます。 EIGRP は、他の自律システムの EIGRP アップデートから派生したルートのメトリックを変更しません。

(注)  


デフォルト メトリックが設定されている限り、すべてのプロトコルが他のルーティング プロトコルからルートを再配布できることに注意してください。


no redistribute コマンド実装のプロトコルの違い


注意    


redistribute コマンドに設定したオプションを削除するには、期待する結果が得られるように no redistribute コマンドを慎重に使用する必要があります。 ほとんどの場合、キーワードを変更またはディセーブルにしても、他のキーワードの状態には影響しません。


異なるプロトコルでは、no redistribute コマンドは次のように異なる方法で実装されます。

  • ボーダー ゲートウェイ プロトコル(BGP)、Open Shortest Path First(OSPF)、およびルーティング情報プロトコル(RIP)の設定で、no redistribute コマンドは、実行コンフィギュレーションの redistribute コマンドから、指定されたキーワードのみを除外します。 これらでは、その他のプロトコルから再配布するときに、減算キーワードの方式を使用します。 たとえば、BGP で no redistribute static route-map interior を設定する場合、ルート マップのみが再配布から除外され、redistribute static がフィルタなしでそのまま残ります。
  • no redistribute isis コマンドは、実行コンフィギュレーションから Intermediate System to Intermediate System(IS-IS)の再配布を削除します。 IS-IS は、IS-IS が再配布されているかどうかや、プロトコルを再配布しているかどうかに関係なく、コマンド全体を削除します。
  • Enhanced Interior Gateway Routing Protocol(EIGRP)は、EIGRP コンポーネント バージョン rel5 より前の減算キーワード方式を使用していました。 EIGRP コンポーネント バージョン rel5 以降、no redistribute コマンドによって、他のプロトコルから再配布するときに redistribute コマンド全体が削除されます。

ルーティング情報発信元のフィルタリング

いくつかのルーティング情報が他の情報よりも正確な場合があるため、ルーティング情報発信元のフィルタリングにより、さまざまな発信元からのルーティング情報に優先順位を付けられます。 アドミニストレーティブ ディスタンスは、個々のデバイスやデバイスのグループなど、ルーティング情報発信元の信頼性を表す数値です。 大規模なネットワークでは、一部のルーティング プロトコルとデバイスが、ルーティング情報発信元として他よりも信頼性が高い場合があります。 また、複数のルーティング プロセスが IP の同じデバイスで実行されている場合、同じルートを複数のルーティング プロセスによってアドバタイズできます。 アドミニストレーティブ ディスタンスの値を指定すると、デバイスはルーティング情報の送信元をインテリジェントに区別できるようになります。 常にルーティング プロトコルのアドミニストレーティブ ディスタンスが最短(値が最小)であるルートが選択されます。

ネットワークごとに独自の要件があるため、アドミニストレーティブ ディスタンスの割り当てに関する一般的なガイドラインはありません。 ネットワーク全体のアドミニストレーティブ ディスタンスの適切なマトリクスを判断する必要があります。

たとえば、Enhanced Interior Gateway Routing Protocol(EIGRP)とルーティング情報プロトコル(RIP)を使用するデバイスを検討します。 EIGRP から派生するルーティング情報を RIP から派生するルーティング情報よりも信頼すると仮定します。 この例では、デフォルトの EIGRP アドミニストレーティブ ディスタンスがデフォルトの RIP アドミニストレーティブ ディスタンスよりも小さいため、デバイスは EIGRP から派生する情報を使用して RIP から派生する情報を無視します。 ただし、EIGRP から派生する情報の発信元が失われた場合(発信元ネットワークの停電など)、デバイスは EIGRP から派生する情報が再提示されるまで RIP から派生する情報を使用します。


(注)  


アドミニストレーティブ ディスタンスを使用して、同じルーティング プロトコルを実行しているデバイスからのルーティング情報を格付けすることもできます。 フォワーディング ループなど、整合性のないルーティング情報が生じる可能性があるため、アドミニストレーティブ ディスタンスのこの特定用途に不慣れな場合、この使用方法は推奨しません。



(注)  


ルートの重みは、distance コマンドでは設定できなくなりました。 ルートの重みを設定するには、ルート マップを使用します。


認証キー管理およびサポートされるプロトコル

キー管理を使用すると、ルーティング プロトコルで使用される認証キーを制御できます。 キー管理をサポートしないプロトコルもあります。 認証キーは、ディレクタ レスポンス プロトコル(DRP)エージェント、Enhanced Interior Gateway Routing Protocol(EIGRP)、およびルーティング情報プロトコル(RIP)バージョン 2 で利用可能です。

キー チェーンを定義し、キー チェーンに属するキーを特定し、各キーの有効期間を指定して認証キーを管理できます。 各キーには独自のキー ID があります(key chain コンフィギュレーション コマンドで指定します)。キー ID はローカルに保存されます。 キー ID、およびメッセージに関連付けられたインターフェイスの組み合わせにより、使用中の認証アルゴリズムおよびメッセージ ダイジェスト アルゴリズム 5(MD5)認証キーが一意に識別されます。

複数のキーにライフタイムを設定できます。 存在する有効なキーの数にかかわらず、送信される認証パケットは 1 つだけです。 キー番号はソフトウェアによって昇順に調べられ、最初に見つかった有効なキーが使用されます。 キー変更中は、有効期間が重なっても問題ありません。

基本的な IP ルーティングの設定方法

ルーティング情報の再配布

ルート マップを使用した再配布の制御の有無にかかわらず、1 つのルーティング ドメインから別のルーティング ドメインにルートを再配布できます。 どのルートを再配布するかを制御するには、ルート マップを設定し、redistribute コマンドからルート マップを参照します。

ここでは、使用するプロトコルに応じて、ルート(ルート マップ)を再配布するための条件を定義する方法、ルートを再配布する方法、ルートの再配布のためにオプションを削除する方法について説明します。

再配布ルートの条件の定義

ルート マップは、ルート再配布を制御するため(またはポリシー ベース ルーティングを実装するため)に使用できます。 1 つのルーティング プロトコルから別のルーティング プロトコルにルートを再配布するための条件を定義するには、route-map コマンドを設定します。 その後、必要に応じて、ルート マップ コンフィギュレーション モードで少なくとも 1 個の match コマンドを使用します。 少なくとも 1 個の match コマンドがこのタスクで使用されるのは、このタスクの目的が、再配布の基準となる 1 つ以上の条件を定義する方法を示すことであるためです。


(注)  


ルート マップは、match コマンドには必要はありませんが、set コマンドにのみ指定できます。 match コマンドがない場合、すべてがルート マップに一致します。



(注)  


このテーブルに示されない他の match コマンドが多数あります。 追加の match コマンドについては、『Cisco IOS Master Command List』を参照してください。


コマンドまたはアクション

目的

match as-path path-list-number 

BGP 自律システム パス アクセス リストを照合します。

match community {standard-list-number | expanded-list-number | community-list-name match community[exact]} 

BGP コミュニティを照合します。

match ip address {access-list-number [access-list-number... | access-list-name...] | access-list-name [access-list-number...| access-list-name] | prefix-list prefix-list-name [prefix-list-name...]} 

パケットのポリシー ルーティングが許可されている、または標準アクセス リスト、拡張アクセス リスト、またはプレフィックス リストで許可されている宛先ネットワーク アドレスを持つルートを照合します。

match metric metric-value

指定したメトリックを持つルートに一致します。

match ip next-hop {access-list-number | access-list-name} [access-list-number | access-list-name]

指定されたアクセス リストの 1 つによって渡された、ネクストホップ デバイス アドレスを照合します。

match tag tag-value [tag-value]

指定したタグの値に一致します。

match interface type number [type number]

指定したインターフェイスをネクストホップとして使用するルートを照合します。

match ip route-source {access-list-number | access-list-name} [access-list-number | access-list-name]

アドバタイズされたアクセス リストによって指定されたアドレスを照合します。

match route-type {local | internal | external [type-1 | type-2] | level-1 | level-2}

指定したルートのタイプに一致します。

一致基準が満たされた場合(ルート マップによって再配布されるルートで)に、システムが実行するルーティング アクションを任意に指定するには、必要に応じて、ルート マップ コンフィギュレーション モードで 1 つまたは複数の set コマンドを使用します。


(注)  


ルート マップは、set コマンドには必要はありませんが、match コマンドにのみ指定できます。



(注)  


このテーブルに示されない他の set コマンドがあります。 追加の set コマンドについては、『Cisco IOS Master Command List』を参照してください。


コマンドまたはアクション

目的

set community {community-number [additive] [well-known]| none} 

コミュニティ属性を設定します(BGP 用)。

set dampening halflife reuse suppress max-suppress-time

ルート ダンプニング パラメータを設定します(BGP 用)。

set local-preference number-value

パスにローカル プリファレンス値を割り当てます(BGP 用)。

set origin {igp | egp as-number | incomplete} 

ルート オリジン コードを設定します。

set as-path{tag | prepend as-path-string } 

自律システム パスを変更します(BGP 用)。

set next-hop next-hop

ネクスト ホップのアドレスを指定します。

set automatic-tag

タグ テーブルの自動計算をイネーブルにします。

set level {level-1 | level-2 | level-1-2 | stub-area | backbone}

ルートをインポートするエリアを指定します。

set metric metric-value

再配布されるルートのメトリック値を設定します(EIGRP 以外のすべてのプロトコル)。

set metric bandwidth delay reliability load mtu

再配布されるルートのメトリック値を設定します(EIGRP 専用)。

set metric-type {internal | external | type-1 | type-2}

再配布されるルートのメトリック タイプを設定します。

set metric-type internal 

ネクスト ホップの内部ゲートウェイ プロトコル(IGP)メトリックと一致するように、外部 BGP ネイバーにアドバタイズされるプレフィックスの Multi Exit Discriminator(MED)値を設定します。

set tag tag-value

再配布されるルートに適用するタグ値を設定します。

ルーティング ドメイン間でのルートの再配布

1 つのルーティング ドメインから別のルーティング ドメインにルートを再配布してルート再配布を制御するには、この作業を実行します。 この作業は、BGP ドメインに OSPF ルートを再配布する方法を示します。

手順の概要

    1.    enable

    2.    configure terminal

    3.    router bgp autonomous-system

    4.    redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [metric metric-value] [metric-type type-value] [match {internal | external type-value}] [tag tag-value] [route-map map-tag] [subnets]

    5.    default-metric number

    6.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 router bgp autonomous-system


    例:
    Device(config)# router bgp 109
     

    BGP ルーティング プロセスをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

     
    ステップ 4redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [metric metric-value] [metric-type type-value] [match {internal | external type-value}] [tag tag-value] [route-map map-tag] [subnets]


    例:
    Device(config-router)# redistribute ospf 2 level-1       
    
     

    指定されたルーティング ドメインから別のルーティング ドメインにルートを再配布します。

     
    ステップ 5 default-metric number


    例:
    Device(config-router)# default-metric 10        
    
     

    再配布されたルートのデフォルトのメトリック値を設定します。

    (注)     

    redistribute コマンドで指定されたメトリック値は、default-metric コマンドを使用して指定されたメトリック値に優先します。

     
    ステップ 6 end


    例:
    Device(config-router)# end        
    
     

    ルータ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

     

    再配布ルートのオプションの削除


    注意    


    redistribute コマンドに設定したオプションを削除するには、期待する結果が得られるように no redistribute コマンドを慎重に使用する必要があります。


    異なるプロトコルでは、no redistribute コマンドは次のように異なる方法で実装されます。

    • BGP、OSPF、RIP の設定では、no redistribute コマンドは、実行コンフィギュレーションの redistribute コマンドから、指定されたキーワードのみを削除します。 これらでは、その他のプロトコルから再配布するときに、減算キーワードの方式を使用します。 たとえば、BGP で no redistribute static route-map interior を設定する場合、ルート マップのみが再配布から除外され、redistribute static がフィルタなしでそのまま残ります。
    • no redistribute isis コマンドは、実行コンフィギュレーションから IS-IS 再配布を削除します。 IS-IS は、IS-IS が再配布されているかどうかや、プロトコルを再配布しているかどうかに関係なく、コマンド全体を削除します。
    • EIGRP は、EIGRP コンポーネント バージョン rel5 の前は、減算キーワード方式を使用していました。 EIGRP コンポーネント バージョン rel5 以降、no redistribute コマンドによって、他のプロトコルから再配布するときに redistribute コマンド全体が削除されます。
    • no redistribute connected コマンドで、redistribute コマンドが router bgp または router ospf コマンドで設定されている場合、動作は減算になります。 router isis または router eigrp コマンドで設定されている場合、動作はコマンドの完全な削除になります。

    次の OSPF コマンドは、ルータ コンフィギュレーション モードの再配布から削除されるさまざまなオプションを示します。

    コマンドまたはアクション

    目的

    no redistribute connected metric 1000 subnets

    設定されたメトリックの値 1000 と設定されたサブネットを削除し、設定で redistribute connected コマンドを保持します。

    no redistribute connected metric 1000 

    設定されたメトリックの値 1000 を削除し、設定で redistribute connected subnets コマンドを保持します。

    no redistribute connected subnets 

    設定されたサブネットを削除し、設定で redistribute connected metric metric-value コマンドを保持します。

    no redistribute connected 

    redistribute connected コマンドとコマンドに設定されたすべてのオプションを削除します。

    ルーティング情報のフィルタリングの設定


    (注)  


    ルートが Open Shortest Path First(OSPF)プロセス間で再配信される場合、OSPF メトリックは保持されません。


    ルーティング アップデートでのルートのアドバタイジングの制御

    他のデバイスが 1 つまたは複数のルートを学習しないように、ルーティング アップデートでのルートのアドバタイズを抑制できます。 ルーティング アップデートでルートのアドバタイズを抑制するには、ルータ コンフィギュレーション モードで、distribute-list {access-list-number | access-list-name} out [interface-name | routing-process | as-number] コマンドを使用します。

    Open Shortest Path First(OSPF)では、インターフェイス名を指定できません。 OSPF に使用する場合、この機能は外部ルートにのみ適用されます。

    ルーティング アップデートの処理の制御

    着信アップデートに含まれている特定のルートを処理することを回避したい場合があります(これは、Open Shortest Path First(OSPF)または Intermediate System to Intermediate System(IS-IS)には適用されません)。 着信アップデートのルートを抑制するには、distribute-list {access-list-number | access-list-name} in [interface-type interface-number] コマンドをルータ コンフィギュレーション モードで使用します。

    ルーティング情報発信元のフィルタリング

    ルーティング情報発信元をフィルタリングするには、distance ip-address wildcard- mask [ip-standard-acl | ip-extended-acl | access-list-name] コマンドをルータ コンフィギュレーション モードで使用します。

    認証キーの管理

    手順の概要

      1.    enable

      2.    configure terminal

      3.    key chain name-of-chain

      4.    key number

      5.    key-string text

      6.    accept-lifetime start-time {infinite | end-time | duration seconds}

      7.    send-lifetime start-time {infinite | end-time | duration seconds}

      8.    end

      9.    show key chain


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:

      複数のキーにライフタイムを設定できます。 存在する有効なキーの数にかかわらず、送信される認証パケットは 1 つだけです。 キー番号はソフトウェアによって昇順に調べられ、最初に見つかった有効なキーが使用されます。 キー変更中は、有効期間が重なっても問題ありません。

      Device> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Device# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 key chain name-of-chain


      例:
      Device(config)# key chain chain1
       

      キー チェーンを定義して、キー チェーン コンフィギュレーション モードを開始します。

       
      ステップ 4key number


      例:
      Device(config-keychain)# key key1
       

      キーチェーン コンフィギュレーション モードでキー番号を識別し、キーチェーン キー コンフィギュレーション モードを開始します。

       
      ステップ 5 key-string text


      例:
      Device(config-keychain-key)# key-string string1
       

      キー ストリングを確認します。

       
      ステップ 6 accept-lifetime start-time {infinite | end-time | duration seconds}


      例:
      Device(config-keychain-key)# accept-lifetime 13:30:00 Dec 22 2011 duration 7200
       

      キーを受け入れることができる期間を指定します。

       
      ステップ 7send-lifetime start-time {infinite | end-time | duration seconds}


      例:
      Device(config-keychain-key)# send-lifetime 14:30:00 Dec 22 2011 duration 3600
       

      キーを送信できる期間を指定します。

       
      ステップ 8end


      例:
      Device(config-keychain-key)# end
       

      キーチェーン キー コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

       
      ステップ 9show key chain


      例:
      Device# show key chain
       

      (任意)認証キー情報を表示します。

       

      IP ネットワークのモニタリングおよびメンテナンス

      IP ルーティング テーブルからのルートの消去

      特定のテーブルのすべての内容を削除できます。 特定の構造の内容が無効になっている、または無効であると思われるときに、テーブルの消去が必要になる場合があります。

      IP ルーティング テーブルから 1 つまたは複数のルートを除外するには、clear ip route {network [mask] | *} コマンドを特権 EXEC モードで使用します。

      システムおよびネットワーク統計情報の表示

      システムおよびネットワークの統計情報を表示するには、次の show コマンドを使用できます。 IP ルーティング テーブル、キャッシュ、データベースの内容など、特定の統計情報を表示できます。 また、ノードの到達可能性に関する情報を表示し、デバイスから送信されたパケットがネットワークを通過するルーティング パスを検出することもできます。 この情報は、リソースの使用状況を判定してネットワークの問題を解決するために使用されます。

      コマンドまたはアクション

      目的

      show ip cache policy

      ポリシー ルート キャッシュのキャッシュ エントリを表示します。

      show ip local policy

      ローカル ポリシー ルート マップがある場合はそれを表示します。

      show ip policy

      ポリシー ルート マップを表示します。

      show ip protocols

      アクティブ ルーティング プロトコルのパラメータと現在の状態を表示します。

       
      show ip route [ip-address [mask] [longer-prefixes] | protocol [process-id] | list {access-list-number | access-list-name} | static download]

      ルーティング テーブルの現在の状態を表示します。

      show ip route summary

      サマリー形式でルーティング テーブルの現在のステータスを表示します。

      show ip route supernets-only

      スーパーネットを表示します。

      show key chain [name-of-chain]

      認証キーの情報を表示します。

      show route-map [map-name]

      設定されたすべてのルート マップ、または指定した 1 つのルート マップだけを表示します。

      基本的な IP ルーティングの設定例

      例:可変長サブネット マスク

      次の例では、クラス B ネットワーク アドレス 172.16.0.0 に 2 つの異なるサブネット マスクを使用します。 /24 サブネット マスクは、LAN インターフェイスに使用されます。 /24 マスクの場合、1 つのサブネットにつきホスト IP アドレスを 254 個持つサブネットを 265 個使用できます。 /24 マスクを使用するサブネット範囲の最後のサブネット(172.16.255.0)は、ポイントツーポイント インターフェイスでの使用に予約されており、さらに長い /30 マスクを割り当てられます。 172.16.255.0 で /30 マスクを使用すると、1 つのサブネットにつきホスト アドレスを 2 つ持つサブネットが 64 個(172.16.255.0 ~ 172.16.255.252)作成されます。

      注意:一義的なルーティングを確実なものにするために、ネットワーク内の LAN インターフェイスには 172.16.255.0/24 を割り当てないでください。

      Device(config)# interface GigabitEthernet 0/0/0
      Device(config-if)# ip address 172.16.1.1 255.255.255.0
      Device(config-if)# ! 8 bits of host address space reserved for GigabitEthernet interfaces 
      Device(config-if)# exit
      Device(config)# interface Serial 0/0/0
      Device(config-if)# ip address 172.16.255.5 255.255.255.252
      Device(config-if)# ! 2 bits of address space reserved for point-to-point serial interfaces
      Device(config-if)# exit
      Device(config)# router rip 
      Device(config-router)# network 172.16.0.0
      Device(config-router)# ! Specifies the network directly connected to the device 
      

      例:ダイナミック プロトコルによるスタティック ルートの上書き

      次の例では、アドミニストレーティブ ディスタンスが 110 未満のルートを使用できない場合、デバイス B(スタティック ルートをインストール済み)からネットワーク 10.0.0.0 へのパケットは 172.18.3.4 経由でルーティングされます。 次の図は、この例を示します。 アドミニストレーティブ ディスタンスが 110 未満のプロトコルによって学習されたルートにより、デバイス B はネットワーク 10.0.0.0 宛てのトラフィックを代替パスであるデバイス D を経由させて送ります。

      Device(config)# ip route 10.0.0.0 255.0.0.0 172.18.3.4 110
      
      図 1. スタティック ルートの上書き

      例:IP ルーティングがディセーブルな場合のスタティック IP ネクストホップとしての IP デフォルト ゲートウェイ

      次の例では、IP ルーティングがディセーブルの場合に、デフォルト ルートとして IP アドレス 172.16.5.4 を設定する例を示します。

      Device> enable
      Device# configure terminal
      Device(conf)# no ip routing
      Device(conf)# ip default-gateway 172.16.15.4

      例:アドミニストレーティブ ディスタンス

      次の例では、router eigrp グローバル コンフィギュレーション コマンドで、自律システム 1 での Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティングを設定します。 network コマンド設定により、ネットワーク 192.168.7.0 と 172.16.0.0 で EIGRP ルーティングが指定されます。 1 つめの distance ルータ コンフィギュレーション コマンドでは、デフォルトのアドミニストレーティブ ディスタンスが 255 に設定されます。これにより、明示的なディスタンスが設定されていないデバイスからのルーティング アップデートをすべて無視するようにデバイスに対して指示します。 2 つめの distance コマンドでは、内部 EIGRP ルートに 80 のアドミニストレーティブ ディスタンス、外部 EIGRP ルートに 100 のアドミニストレーティブ ディスタンスが設定されます。 3 つめの distance コマンドでは、アドレス 172.16.1.3 のデバイスに 120 のアドミニストレーティブ ディスタンスが設定されます。

      Device(config)# router eigrp 1 
      Device(config-router)# network 192.168.7.0 
      Device(config-router)# network 172.16.0.0 
      Device(config-router)# distance 255 
      Device(config-router)# distance eigrp 80 100 
      Device(config-router)# distance 120 172.16.1.3 0.0.0.0 
      

      (注)  


      EIGRP から派生したルートのアドミニストレーティブ ディスタンスを設定するには、distance eigrp コマンドを使用する必要があります。


      次の例では、アドレス 192.168.7.18 のデバイスにアドミニストレーティブ ディスタンス 100 を割り当て、サブネット 192.168.7.0 のその他すべてのデバイスにアドミニストレーティブ ディスタンス 200 を割り当てます。

      Device(config-router)# distance 100 192.168.7.18 0.0.0.0 
      Device(config-router)# distance 200 192.168.7.0 0.0.0.255 
      

      ただし、これら 2 つのコマンドの順序を逆にすると、アドレス 192.168.7.18 のデバイスを含め、サブネット 192.168.7.0 のすべてのデバイスにアドミニストレーティブ ディスタンス 200 が割り当てられます。

      Device(config-router)# distance 200 192.168.7.0 0.0.0.255 
      Device(config-router)# distance 100 192.168.7.18 0.0.0.0 
      

      (注)  


      アドミニストレーティブ ディスタンスの割り当ては、固有の問題を解決するために使用できます。 ただし、アドミニストレーティブ ディスタンスは、ルーティング ループまたは他のネットワーク障害が発生しないように、慎重に一貫して適用する必要があります。


      次の例では、学習される IP ルートのディスタンス値は 90 です。 デフォルトのアドミニストレーティブ ディスタンス値が 110 のルートよりも、これらの IP ルートが優先されます。

      Device(config)# router isis 
      Device(config-router)# distance 90 ip 

      例:スタティック ルーティングの再配布

      次の例では、3 つのスタティック ルートが指定されます。そのうち 2 つはアドバイタイズされます。 スタティック ルートは、redistribute static ルータ コンフィギュレーション コマンドを指定し、これら 2 つのネットワークだけが Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスに渡されることを許可するアクセス リストを指定することによって作成されます。 再配布されるスタティック ルートは、ルーティング ループ発生の可能性を最小限に抑えるために、1 つのデバイスだけから発信される必要があります。

      Device(config)# ip route 192.168.2.0 255.255.255.0 192.168.7.65 
      Device(config)# ip route 192.168.5.0 255.255.255.0 192.168.7.65 
      Device(config)# ip route 10.10.10.0 255.255.255.0 10.20.1.2 
      Device(config)# ! 
      Device(config)# access-list 3 permit 192.168.2.0 0.0.255.255 
      Device(config)# access-list 3 permit 192.168.5.0 0.0.255.255 
      Device(config)# access-list 3 permit 10.10.10.0 0.0.0.255 
      Device(config)# ! 
      Device(config)# router eigrp 1 
      Device(config-router)# network 192.168.0.0 
      Device(config-router)# network 10.10.10.0 
      Device(config-router)# redistribute static metric 10000 100 255 1 1500
      Device(config-router)# distribute-list 3 out static
      

      例:EIGRP 再配布

      Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティング プロセスは、1 つの自律システムだけにルーティング情報を提供します。 シスコ ソフトウェアは、サービスを提供する自律システムごとに個別の EIGRP プロセスを実行し、異なるルーティング データベースを維持する必要があります。 ただし、これらのルーティング データベース間でルーティング情報を転送できます。

      次の設定では、ネットワーク 10.0.0.0 が EIGRP 自律システム 1 の下で設定され、ネットワーク 192.168.7.0 が EIGRP 自律システム 101 の下で設定されます。

      Device(config)# router eigrp 1 
      Device(config-router)# network 10.0.0.0 
      Device(config-router)# exit 
      Device(config)# router eigrp 101 
      Device(config-router)# network 192.168.7.0 
      

      次の例では、ネットワーク 192.168.7.0 からのルートが自律システム 1 に再配布されます(自律システム 101 からのその他のルーティング情報は渡しません)。

      Device(config)# access-list 3 permit 192.168.7.0 
      Device(config)# ! 
      Device(config)# route-map 101-to-1 permit 10 
      Device(config-route-map)# match ip address 3 
      Device(config-route-map)# set metric 10000 100 1 255 1500 
      Device(config-route-map)# exit 
      Device(config)# router eigrp 1 
      Device(config-router)# redistribute eigrp 101 route-map 101-to-1 
      Device(config-router)#! 
      

      次の例は、ネットワーク 192.168.7.0 から自律システム 1 にルートを再配布するための代替方法です。 前の設定とは違い、この方法では再配布されるルートのメトリックを設定できません。

      Device(config)# access-list 3 permit 192.168.7.0 
      Device(config)# ! 
      Device(config)# router eigrp 1 
      Device(config-router)# redistribute eigrp 101 
      Device(config-router)# distribute-list 3 out eigrp 101 
      Device(config-router)# !
      

      例:EIGRP と RIP 間の相互再配布

      内部ルーティング プロトコルとしてルーティング情報プロトコル(RIP)を使用する大学での WAN を想定します。 ルーティング プロトコルとして Enhanced Interior Gateway Routing Protocol(EIGRP)を使用する地域ネットワーク 172.16.0.0 にこの大学が WAN を接続すると想定します。 この場合の目的は、地域ネットワーク内のデバイスに、大学のネットワーク内のネットワークをアドバタイズすることです。

      次の例では、相互再配布が EIGRP と RIP の間に構成されます。

      Device(config)# access-list 10 permit 172.16.0.0 
      Device(config)# ! 
      Device(config)# router eigrp 1 
      Device(config-router)# network 172.16.0.0 
      Device(config-router)# redistribute rip metric 10000 100 255 1 1500 
      Device(config-router)# default-metric 10
      Device(config-router)# distribute-list 10 out rip 
      Device(config-router)# exit
      Device(config)# router rip 
      Device(config-router)# redistribute eigrp 1 
      Device(config-router)# ! 
      

      この例では、EIGRP ルーティング プロセスが開始されます。 network ルータ コンフィギュレーション コマンドにより、ネットワーク 172.16.0.0(地域ネットワーク)が EIGRP ルーティング情報を送受信するように設定されます。 redistribute ルータ コンフィギュレーション コマンドにより、RIP から派生したルーティング情報がルーティング アップデートでアドバタイズされるように設定されます。 default-metric ルータ コンフィギュレーション コマンドにより、EIGRP メトリックが RIP から派生したすべてのルートに割り当てられます。 distribute-list ルータ コンフィギュレーション コマンドにより、シスコ ソフトウェアに対して、アクセス リスト 10(この例では定義されません)を使用して、各送信アップデートのエントリを制限するように指示します。 アクセス リストにより、地域ネットワークへの大学ルートの不正なアドバタイズが防止されます。

      例:EIGRP と BGP 間の相互再配布

      次の例では、Enhanced Interior Gateway Routing Protocol(EIGRP)とボーダー ゲートウェイ プロトコル(BGP)の間で相互再配布が設定されます。

      EIGRP ルーティング プロセス 101 からのルートは BGP 自律システム 50000 に挿入されます。 フィルタは、適切なルート(この場合は 3 つのネットワーク)がアドバタイズされるように設定されます。 BGP 自律システム 50000 からのルートが、EIGRP ルーティング プロセス 101 に挿入されます。 同じフィルタが使用されます。

      Device(config)# ! All networks that should be advertised from R1 are controlled with ACLs: 
      Device(config)# access-list 1 permit 172.18.0.0 0.0.255.255 
      Device(config)# access-list 1 permit 172.16.0.0 0.0.255.255 
      Device(config)# access-list 1 permit 172.25.0.0 0.0.255.255
      Device(config)# ! Configuration for router R1:
      Device(config)# router bgp 50000 
      Device(config-router)# network 172.18.0.0 
      Device(config-router)# network 172.16.0.0 
      Device(config-router)# neighbor 192.168.10.1 remote-as 2 
      Device(config-router)# neighbor 192.168.10.15 remote-as 1 
      Device(config-router)# neighbor 192.168.10.24 remote-as 3 
      Device(config-router)# redistribute eigrp 101 
      Device(config-router)# distribute-list 1 out eigrp 101 
      Device(config-router)# exit 
      Device(config)# router eigrp 101 
      Device(config-router)# network 172.25.0.0
      Device(config-router)# redistribute bgp 50000 
      Device(config-router)# distribute-list 1 out bgp 50000 
      Device(config-router)# ! 

      注意    


      他の適切なオプションがない場合、BGP は内部ゲートウェイ プロトコル(IGP)に再配布されます。 BGP から IGP への再配布は、配布リスト、IP プレフィックス リスト、およびプレフィックス番号を制限するためのルート マップ ステートメントを使用した適切なフィルタと共に適用されます。


      例:OSPF ルーティングおよびルート再配布

      OSPF は、通常、多数の内部ルータ、エリア境界ルータ(ABR)、および自律システム境界ルータ(ASBR)間での調整が必要です。 OSPF ベースのデバイスは最低でも、すべてのデフォルト パラメータ値を使用し、認証なしで、インターフェイスをエリアに割り当てて設定できます。

      ここでは、次の設定例について説明します。

      • 最初の例は、基本的な OSPF コマンドを示した簡単な設定です。
      • 2 番目の例は、任意に割り当てられた単一の OSPF 自律システム内での内部デバイス、ABR、および ASBR の設定を示しています。
      • 3 番目の例は、より複雑な設定と、OSPF ベースのルーティング環境の制御で使用できるさまざまなツールの用途を示しています。

      例:基本的な OSPF 設定

      次の例では、OSPF ルーティング プロセス 1 をイネーブルにし、エリア 0.0.0.0 にギガビット イーサネット インターフェイス 0/0/0 を接続し、OSPF から RIP と OSPF から RIP に再配布するシンプルな OSPF の設定を示します。

      Device(config)# interface GigabitEthernet 0/0/0 
      Device(config-if)# ip address 172.16.1.1 255.255.255.0 
      Device(config-if)# ip ospf cost 1 
      Device(config-if)# exit 
      Device(config)# interface GigabitEthernet 1/0/0 
      Device(config-if)# ip address 172.17.1.1 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# router ospf 1 
      Device(config-router)# network 172.18.0.0 0.0.255.255 area 0.0.0.0 
      Device(config-router)# redistribute rip metric 1 subnets 
      Device(config-router)# exit 
      Device(config)# router rip 
      Device(config-router)# network 172.17.0.0 
      Device(config-router)# redistribute ospf 1 
      Device(config-router)# default-metric 1 
      Device(config-router)# ! 
      

      次の例では、4 つのエリア ID を 4 つの IP アドレス範囲に割り当てています。 この例では、OSPF ルーティング プロセス 1 が初期化され、4 つの OSPF エリア(10.9.50.0、2、3、および 0)が定義されます。 エリア 10.9.50.0、2、および 3 は特定のアドレス範囲をマスクし、エリア 0 は他のすべてのネットワークで OSPF をイネーブルにします。

      Device(config)# router ospf 1 
      Device(config-router)# network 172.18.20.0 0.0.0.255 area 10.9.50.0 
      Device(config-router)# network 172.18.0.0 0.0.255.255 area 2 
      Device(config-router)# network 172.19.10.0 0.0.0.255 area 3 
      Device(config-router)# network 0.0.0.0 255.255.255.255 area 0 
      Device(config-router)# exit 
      Device(config)# ! GigabitEthernet interface 0/0/0 is in area 10.9.50.0:
      Device(config)# interface GigabitEthernet 0/0/0 
      Device(config-if)# ip address 172.18.20.5 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# ! GigabitEthernet interface 1/0/0 is in area 2: 
      Device(config)# interface GigabitEthernet 1/0/0 
      Device(config-if)# ip address 172.18.1.5 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# ! GigabitEthernet interface 2/0/0 is in area 2: 
      Device(config)# interface GigabitEthernet 2/0/0 
      Device(config-if)# ip address 172.18.2.5 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# ! GigabitEthernet interface 3/0/0 is in area 3:
      Device(config)# interface GigabitEthernet 3/0/0 
      Device(config-if)# ip address 172.19.10.5 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# ! GigabitEthernet interface 4/0/0 is in area 0:
      Device(config)# interface GigabitEthernet 4/0/0 
      Device(config-if)# ip address 172.19.1.1 255.255.255.0
      Device(config-if)# exit 
      Device(config)# ! GigabitEthernet interface 5/0/0 is in area 0:
      Device(config)# interface GigabitEthernet 5/0/0 
      Device(config-if)# ip address 10.1.0.1 255.255.0.0 
      Device(config-if)# !
      

      network ルータ コンフィギュレーション コマンドは順番に評価されるため、設定ではこれらのコマンドの特定の順序が重要になります。 シスコ ソフトウェアは、各インターフェイスの address/wildcard-mask ペアを順番に評価します。 詳細については、『IP Routing Protocols Command Reference』を参照してください。

      1 つめの network コマンドについて考察します。 エリア ID 10.9.50.0 が、サブネット 172.18.20.0 があるインターフェイスに設定されます。 ギガビット イーサネット インターフェイス 0/0/0 に一致が判定されたと仮定します。 ギガビット イーサネット インターフェイス 0/0/0 はエリア 10.9.50.0 だけに接続されます。

      2 つめの network コマンドが次に評価されます。 エリア 2 について、同じ処理がすべてのインターフェイスに適用されます(ギガビット イーサネット インターフェイス 0/0/0 を除く)。 ギガビット イーサネット インターフェイス 1/0/0 に一致が判定されたと仮定します。 OSPF がそのインターフェイスに対してイネーブルになり、ギガビット イーサネット 1/0/0 がエリア 2 に接続されます。

      インターフェイスを OSPF エリアに接続するこのプロセスは、すべてのnetwork コマンドに対して継続します。 この例にある最後の network コマンドは特別な場合なので、注意してください。 このコマンドを使用すると、すべての利用可能なインターフェイス(明示的に別のエリアに接続されていないもの)が、エリア 0 に接続されます。

      例:内部デバイス、ABR、および ASBR の設定

      次の図は、単一の OSPF 自律システム内にあるさまざまなデバイスの設定例を図示した一般的なネットワーク マップです。

      図 2. OSPF 自律システムのネットワーク マップ例

      この設定では、OSPF 自律システム 1 に 5 つのデバイスが設定されています。

      • デバイス A とデバイス B は、両方ともエリア 1 内の内部デバイスです。
      • デバイス C は OSPF ABR です。 デバイス C では、エリア 1 が E3 に割り当てられ、エリア 0 が S0 に割り当てられることに注意してください。
      • デバイス D は、エリア 0(バックボーン エリア)の内部デバイスです。 この場合、どちらの network ルータ コンフィギュレーション コマンドも同じエリア(エリア 0、つまりバックボーン エリア)を指定しています。
      • デバイス E は OSPF ASBR です。 ボーダー ゲートウェイ プロトコル(BGP)ルートは OSPF に再配布され、これらのルートは OSPF によってアドバタイズされることに注意してください。

      (注)  


      OSPF 自律システムのすべてのエリアの定義を、自律システム内のすべてのデバイスの設定に含める必要はありません。 直接接続されたエリアだけ、定義する必要があります。 次の例では、ABR(デバイス C)がエリア 1 にサマリー リンク ステート アドバタイズメント(LSA)を挿入するときに、エリア 0 のルートがエリア 1 のデバイス(デバイス A およびデバイス B)によって学習されます。


      自律システム 60000 は、IP アドレス 172.16.1.6 で、外部ピアへの BGP リンクを介して外部に接続されます。

      次に、上の図の一般的なネットワーク マップの設定例を示します。

      デバイス A の設定 -- 内部デバイス
      Device(config)# interface GigabitEthernet 1/0/0 
      Device(config-if)# ip address 192.168.1.1 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# router ospf 1 
      Device(config-router)# network 192.168.1.0 0.0.0.255 area 1 
      Device(config-router)# exit 
      
      デバイス B の設定 -- 内部デバイス
      Device(config)# interface GigabitEthernet 2/0/0 
      Device(config-if)# ip address 192.168.1.2 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# router ospf 1 
      Device(config-router)# network 192.168.1.0 0.0.0.255 area 1 
      Device(config-router)# exit 
      
      デバイス C の設定 -- ABR
      Device(config)# interface GigabitEthernet 3/0/0 
      Device(config-if)# ip address 192.168.1.3 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# interface Serial 0/0/0 
      Device(config-if)# ip address 192.168.2.3 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# router ospf 1 
      Device(config-router)# network 192.168.1.0 0.0.0.255 area 1 
      Device(config-router)# network 192.168.2.0 0.0.0.255 area 0 
      Device(config-router)# exit 
      
      デバイス D の設定 -- 内部デバイス
      Device(config)# interface GigabitEthernet 4/0/0
      Device(config-if)# ip address 10.0.0.4 255.0.0.0 
      Device(config-if)# exit 
      Device(config)# interface Serial 1/0/0 
      Device(config-if)# ip address 192.168.2.4 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# router ospf 1 
      Device(config-router)# network 192.168.2.0 0.0.0.255 area 0 
      Device(config-router)# network 10.0.0.0 0.255.255.255 area 0 
      Device(config-router)# exit 
      
      デバイス E の設定 -- ASBR
      Device(config)# interface GigabitEthernet 5/0/0 
      Device(config-if)# ip address 10.0.0.5 255.0.0.0 
      Device(config-if)# exit 
      Device(config)# interface Serial 2/0/0 
      Device(config-if)# ip address 172.16.1.5 255.255.255.0 
      Device(config-if)# exit 
      Device(config)# router ospf 1 
      Device(config-router)# network 10.0.0.0 0.255.255.255 area 0 
      Device(config-router)# redistribute bgp 50000 metric 1 metric-type 1 
      Device(config-router)# exit 
      Device(config)# router bgp 50000 
      Device(config-router)# network 192.168.0.0 
      Device(config-router)# network 10.0.0.0 
      Device(config-router)# neighbor 172.16.1.6 remote-as 60000
      

      例:複雑な OSPF 設定

      次の設定例では、ABR の設定でいくつかのタスクを実行しています。 これらのタスクは 2 つの一般カテゴリに分けられます。

      • 基本的な OSPF 設定
      • ルート再配布

      この設定で概略を示した個々のタスクについて、次に簡単に説明します。 次の図は、インターフェイスのネットワーク アドレス範囲とエリア割り当てを示します。

      図 3. OSPF のインターフェイスとエリア指定の設定例

      この例の基本的な設定作業は、次のとおりです。

      • ギガビット イーサネット インターフェイス 0/0/0 からギガビット イーサネット インターフェイス 3/0/0 のアドレス範囲を設定します。
      • 各インターフェイスで OSPF をイネーブルにします。
      • 各エリアおよび各ネットワークに OSPF 認証パスワードを設定します。
      • リンクステート メトリックおよびその他の OSPF インターフェイス設定オプションを割り当てます。
      • エリア ID 10.0.0.0 のスタブ エリアを作成する (area ルータ コンフィギュレーション コマンドの authentication および stub オプションは、別々の area コマンド エントリで指定されますが、1 つの area コマンドにマージできます)。
      • バックボーン エリア(エリア 0)を指定します。

      再配布に関連した設定タスクを次に示します。

      • さまざまなオプションが設定された OSPF に Enhanced Interior Gateway Routing Protocol(EIGRP)およびルーティング情報プロトコル(RIP)を再配布します(メトリック タイプ、メトリック、タグ、およびサブネットなど)。
      • EIGRP と OSPF を RIP に再配布する。

      次に、OSPF の設定例を示します。

      Device(config)# interface GigabitEthernet 0/0/0
      Device(config-if)# ip address 192.168.110.201 255.255.255.0 
      Device(config-if)# ip ospf authentication-key abcdefgh 
      Device(config-if)# ip ospf cost 10 
      Device(config-if)# exit 
      Device(config)# interface GigabitEthernet 1/0/0 
      Device(config-if)# ip address 172.19.251.201 255.255.255.0 
      Device(config-if)# ip ospf authentication-key ijklmnop 
      Device(config-if)# ip ospf cost 20 
      Device(config-if)# ip ospf retransmit-interval 10 
      Device(config-if)# ip ospf transmit-delay 2 
      Device(config-if)# ip ospf priority 4 
      Device(config-if)# exit 
      Device(config)# interface GigabitEthernet 2/0/0
      Device(config-if)# ip address 172.19.254.201 255.255.255.0 
      Device(config-if)# ip ospf authentication-key abcdefgh 
      Device(config-if)# ip ospf cost 10 
      Device(config-if)# exit 
      Device(config)# interface GigabitEthernet 3/0/0
      Device(config-if)# ip address 10.56.0.201 255.255.0.0 
      Device(config-if)# ip ospf authentication-key ijklmnop 
      Device(config-if)# ip ospf cost 20 
      Device(config-if)# ip ospf dead-interval 80 
      Device(config-if)# exit 
      

      次の設定では、OSPF はネットワーク 172.19.0.0 にあります。

      Device(config)# router ospf 1 
      Device(config-router)# network 10.0.0.0 0.255.255.255 area 10.0.0.0 
      Device(config-router)# network 192.168.110.0 0.0.0.255 area 192.168.110.0 
      Device(config-router)# network 172.19.0.0 0.0.255.255 area 0 
      Device(config-router)# area 0 authentication 
      Device(config-router)# area 10.0.0.0 stub 
      Device(config-router)# area 10.0.0.0 authentication 
      Device(config-router)# area 10.0.0.0 default-cost 20 
      Device(config-router)# area 192.168.110.0 authentication 
      Device(config-router)# area 10.0.0.0 range 10.0.0.0 255.0.0.0 
      Device(config-router)# area 192.168.110.0 range 192.168.110.0 255.255.255.0 
      Device(config-router)# area 0 range 172.19.251.0 255.255.255.0 
      Device(config-router)# area 0 range 172.19.254.0 255.255.255.0 
      Device(config-router)# redistribute eigrp 200 metric-type 2 metric 1 tag 200 subnets 
      Device(config-router)# redistribute rip metric-type 2 metric 1 tag 200 
      Device(config-router)# exit 
      

      次の設定では、EIGRP 自律システム 1 が 172.19.0.0 にあります。

      Device(config)# router eigrp 1 
      Device(config-router)# network 172.19.0.0 
      Device(config-router)# exit 
      Device(config)# ! RIP for 192.168.110.0: 
      Device(config)# router rip 
      Device(config-router)# network 192.168.110.0 
      Device(config-router)# redistribute eigrp 1 metric 1 
      Device(config-router)# redistribute ospf 201 metric 1 
      Device(config-router)# exit
      

      例:デフォルト メトリック値の再配布

      次に、ルーティング情報プロトコル(RIP)および Enhanced Interior Gateway Routing Protocol(EIGRP)の両方を実行するように設定された自律システム 1 のデバイスの例を示します。 この例では、RIP を使用して EIGRP から派生したルートをアドバタイズし、EIGRP から派生したルートに RIP メトリック 10 を割り当てます。

      Device(config)# router rip 
      Device(config-router)# redistribute eigrp 1 
      Device(config-router)# default-metric 10 
      Device(config-router)# exit 
      

      例:ルート マップを使用した場合と使用しない場合の再配布

      ここでは、ルート マップを使用した場合と、使用しない場合の再配布の例を示します。 IP および Connectionless Network Service(CLNS)の両方のルーティング プロトコルの例が示されています。 次の例では、すべての Open Shortest Path First(OSPF)ルートを Enhanced Interior Gateway Routing Protocol(EIGRP)に再配布します。

      Device(config)# router eigrp 1 
      Device(config-router)# redistribute ospf 101 
      Device(config-router)# exit 
      

      次の例では、ホップ カウントが 1 のルーティング情報プロトコル(RIP)ルートを OSPF に再配布しています。 これらのルートは、メトリック 5、メトリック タイプ 1、およびタグ 1 の外部リンク ステート アドバタイズメント(LSA)として OSPF に再配布されます。

      Device(config)# router ospf 1 
      Device(config-router)# redistribute rip route-map rip-to-ospf 
      Device(config-router)# exit 
      Device(config)# route-map rip-to-ospf permit 
      Device(config-route-map)# match metric 1 
      Device(config-route-map)# set metric 5 
      Device(config-route-map)# set metric-type type 1 
      Device(config-route-map)# set tag 1 
      Device(config-route-map)# exit 
      

      次の例では、OSPF で学習されたタグ 7 のルートを、RIP メトリック 15 として再配布しています。

      Device(config)# router rip 
      Device(config-router)# redistribute ospf 1 route-map 5 
      Device(config-router)# exit 
      Device(config)# route-map 5 permit 
      Device(config-route-map)# match tag 7 
      Device(config-route-map)# set metric 15 
      

      次の例では、シリアル インターフェイス 0/0/0 のネクスト ホップ デバイスで、OSPF エリア内およびエリア間ルートをボーダー ゲートウェイ プロトコル(BGP)に 5 の INTER_AS メトリックで再配布します。

      Device(config)# router bgp 50000 
      Device(config-router)# redistribute ospf 1 route-map 10 
      Device(config-router)# exit 
      Device(config)# route-map 10 permit 
      Device(config-route-map)# match route-type internal 
      Device(config-route-map)# match interface serial 0/0/0 
      Device(config-route-map)# set metric 5 
      

      次の例では、2 つのタイプのルートを(IP と CLNS のいずれもサポートする)統合 IS-IS ルーティング テーブルに再配布しています。 1 つめのタイプは、タグ 5 の OSPF 外部 IP ルートです。これらのルートは、メトリック 5 のレベル 2 IS-IS リンクステート パケット(LSP)に挿入されます。 2 番目のタイプは CLNS アクセス リスト 2000 と一致する ISO-IGRP から発生した CLNS プレフィックスです。これらのルートはメトリック 30 のレベル 2 IS-IS LSP に再配布されます。

      Device(config)# router isis 
      Device(config-router)# redistribute ospf 1 route-map 2 
      Device(config-router)# redistribute iso-igrp nsfnet route-map 3 
      
      Device(config-router)# exit 
      Device(config)# route-map 2 permit 
      Device(config-route-map)# match route-type external 
      Device(config-route-map)# match tag 5 
      Device(config-route-map)# set metric 5 
      Device(config-route-map)# set level level-2 
      Device(config-route-map)# exit 
      Device(config)# route-map 3 permit 
      Device(config-route-map)# match address 2000 
      Device(config-route-map)# set metric 30 
      Device(config-route-map)# exit 
      

      次の設定では、タグ 1、2、3、および 5 の OSPF 外部ルータがそれぞれメトリック 1、1、5、および 5 の RIP に再配布されています。 タグ 4 の OSPF ルートは再配布されません。

      Device(config)# router rip 
      Device(config-router)# redistribute ospf 101 route-map 1 
      Device(config-router)# exit 
      Device(config)# route-map 1 permit 
      Device(config-route-map)# match tag 1 2 
      Device(config-route-map)# set metric 1 
      Device(config-route-map)# exit 
      Device(config)# route-map 1 permit 
      Device(config-route-map)# match tag 3 
      Device(config-route-map)# set metric 5 
      Device(config-route-map)# exit 
      Device(config)# route-map 1 deny 
      Device(config-route-map)# match tag 4 
      Device(config-route-map)# exit 
      Device(config)# route map 1 permit 
      Device(config-route-map)# match tag 5 
      Device(config-route-map)# set metric 5 
      Device(config-route-map)# exit 
      

      次の設定の場合、RIP が学習したネットワーク 172.18.0.0 のルートと ISO-IGRP が学習したプレフィックス 49.0001.0002 のルートを、メトリック 5 の IS-IS レベル 2 LSP に再配布します。

      Device(config)# router isis 
      Device(config-router)# redistribute rip route-map 1 
      Device(config-router)# redistribute iso-igrp remote route-map 1 
      Device(config-router)# exit 
      Device(config)# route-map 1 permit 
      Device(config-route-map)# match ip address 1 
      Device(config-route-map)# match clns address 2 
      Device(config-route-map)# set metric 5 
      Device(config-route-map)# set level level-2 
      Device(config-route-map)# exit 
      Device(config)# access-list 1 permit 172.18.0.0 0.0.255.255 
      Device(config)# clns filter-set 2 permit 49.0001.0002... 
      

      次の設定例では、default-information ルータ コンフィギュレーション コマンドでルート マップを参照する手順を示しています。 この参照タイプは、「条件付きのデフォルト発信元」と呼ばれます。 172.20.0.0 がルーティング テーブルにある場合、OSPF はタイプ 2 メトリック 5 のデフォルト ルート(ネットワーク 0.0.0.0)を発信します。

      Device(config)# route-map ospf-default permit 
      Device(config-route-map)# match ip address 1 
      Device(config-route-map)# set metric 5 
      Device(config-route-map)# set metric-type type-2 
      Device(config-route-map)# exit 
      Device(config)# access-list 1 172.20.0.0 0.0.255.255 
      Device(config)# router ospf 101 
      Device(config-router)# default-information originate route-map ospf-default 
      

      例:キー管理

      次の例では、chain1 という名前のキー チェーンが設定されます。 この例では、ソフトウェアは有効なキーとして key1 を常に受け入れて送信します。 キー key2 は午後 1:30 から 午後 3:30 まで受け入れられ、 午後 2:00 から 午後 3:00 まで送信されます。 重複により、キーの移行またはデバイスの設定時間の相違に対処できます。 同様に、キー key3 はすぐに key2 に従い、時刻の相違に対処するためそれぞれに 30 分あります。

      Device(config)# interface GigabitEthernet 0/0/0
      Device(config-if)# ip rip authentication key-chain chain1 
      Device(config-if)# ip rip authentication mode md5 
      Device(config-if)# exit 
      Device(config)# router rip
      Device(config-router)# network 172.19.0.0 
      Device(config-router)# version 2 
      Device(config-router)# exit 
      Device(config)# key chain chain1 
      Device(config-keychain)# key 1 
      Device(config-keychain-key)# key-string key1 
      Device(config-keychain-key)# exit
      Device(config-keychain)# key 2 
      Device(config-keychain-key)# key-string key2 
      Device(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 2005 duration 7200 
      Device(config-keychain-key)# send-lifetime 14:00:00 Jan 25 2005 duration 3600  
      Device(config-keychain-key)# exit
      Device(config-keychain)# key 3 
      Device(config-keychain-key)# key-string key3 
      Device(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 2005 duration 7200 
      Device(config-keychain-key)# send-lifetime 15:00:00 Jan 25 2005 duration 3600 
      Device(config-keychain-key)# end 
      

      次の例では、chain1 という名前のキー チェーンが設定されます。

      Device(config)# key chain chain1 
      Device(config-keychain)# key 1 
      Device(config-keychain-key)# key-string key1 
      Device(config-keychain-key)# exit
      Device(config-keychain)# key 2 
      Device(config-keychain-key)# key-string key2 
      Device(config-keychain-key)# accept-lifetime 00:00:00 Dec 5 2004 23:59:59 Dec 5 2005 
      Device(config-keychain-key)# send-lifetime 06:00:00 Dec 5 2004 18:00:00 Dec 5 2005 
      Device(config-keychain-key)# exit 
      Device(config-keychain)# exit 
      Device(config)# interface GigabitEthernet 0/0/0 
      Device(config-if)# ip address 172.19.104.75 255.255.255.0 secondary 172.19.232.147 255.255.255.240 
      Device(config-if)# ip rip authentication key-chain chain1 
      Device(config-if)# media-type 10BaseT 
      Device(config-if)# exit 
      Device(config)# interface GigabitEthernet 1/0/0
      Device(config-if)# no ip address 
      Device(config-if)# shutdown 
      Device(config-if)# media-type 10BaseT 
      Device(config-if)# exit 
      Device(config)# interface Fddi 0 
      Device(config-if)# ip address 10.1.1.1 255.255.255.0 
      Device(config-if)# no keepalive 
      Device(config-if)# exit 
      Device(config)# interface Fddi 1/0/0
      Device(config-if)# ip address 172.16.1.1 255.255.255.0 
      Device(config-if)# ip rip send version 1 
      Device(config-if)# ip rip receive version 1 
      Device(config-if)# no keepalive 
      Device(config-if)# exit 
      Device(config)# router rip 
      Device(config-router)# version 2 
      Device(config-router)# network 172.19.0.0 
      Device(config-router)# network 10.0.0.0 
      Device(config-router)# network 172.16.0.0 
      

      その他の関連資料

      関連資料

      関連項目

      マニュアル タイトル

      『Cisco IOS Master Command List, All Releases』

      『Cisco IOS Master Command List, All Releases』

      IP ルーティングのプロトコル独立型コマンド:コマンド構文の詳細、コマンド モード、デフォルト設定、使用上の注意事項、および例

      『Cisco IOS IP Routing: Protocol-Independent Command Reference』

      基本的なシステム管理の実行

      『Basic System Management Configuration Guide』

      最大パス数の変更

      BGP Configuration Guide』の「BGP Multipath Load Sharing for Both eBGP and iBGP in an MPLS-VPN」モジュール

      BGP ルート マップ設定作業および設定例。

      BGP Configuration Guide』の「Connecting to a Service Provider Using External BGP」モジュール

      BGP コミュニティとルート マップ。

      BGP Configuration Guide』の「BGP Cost Community」モジュール

      RFC

      RFC

      タイトル

      RFC 791

      インターネット プロトコル

      RFC 1219

      可変長サブネット マスク

      シスコのテクニカル サポート

      説明

      リンク

      シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

      お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

      シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

      http:/​/​www.cisco.com/​en/​US/​support/​index.html

      基本的な IP ルーティングの機能情報

      次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

      プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

      表 2 基本的な IP ルーティングの機能情報

      機能名

      リリース

      機能情報

      IP ルーティング

      IP ルーティング機能により、このモジュールと他の IP ルーティング プロトコルのモジュールで説明されている基本的な IP ルーティング機能が導入されました。