インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
IPv6 自動 6to4 トンネル
IPv6 自動 6to4 トンネル
発行日;2013/06/10   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

IPv6 自動 6to4 トンネル

この機能は、IPv6 自動 6to4 トンネルに対するサポートを提供します。 自動 6to4 トンネルを使用すると、孤立した IPv6 ドメインを、IPv4 ネットワークを介してリモート IPv6 ネットワークに接続できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の注意事項と機能情報については、プラットフォームおよびソフトウェア リリースのバグ検索ツールとリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

IPv6 自動 6to4 トンネルに関する情報

自動 6to4 トンネル

自動 6to4 トンネルを使用すると、孤立した IPv6 ドメインを、IPv4 ネットワークを介してリモート IPv6 ネットワークに接続できます。 自動 6to4 トンネルと、手動で設定されたトンネルとの主な違いは、トンネルがポイントツーポイントではなく、ポイントツーマルチポイントである点です。 自動 6to4 トンネルでは、ルータは、IPv4 インフラストラクチャを仮想非ブロードキャスト マルチアクセス(NBMA)リンクとして処理するため、ペアでは設定されません。 IPv6 アドレスに埋め込まれた IPv4 アドレスは、自動トンネルのもう一方のエンドを検出するために使用されます。

自動 6to4 トンネルは、孤立した IPv6 ネットワーク内の境界ルータに設定できます。これにより、IPv4 インフラストラクチャを介した別の IPv6 ネットワーク内の境界ルータへのパケット単位のトンネルが作成されます。 トンネル宛先は、プレフィックス 2002::/16 で始まる IPv6 アドレス(形式は 2002:border-router-IPv4-address ::/48)から抽出される、境界ルータの IPv4 アドレスによって決定されます。 埋め込まれた IPv4 アドレスのあとには、サイト内のネットワークへの番号付けに使用できる 16 ビットが続きます。 6to4 トンネルの両端の境界ルータは、IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。 6to4 トンネルは、境界ルータ間または境界ルータとホスト間に設定されます。

6to4 トンネルの最も単純な展開シナリオは、複数の IPv6 サイトを相互接続することです。各 IPv6 サイトには、共有 IPv4 ネットワークへの 1 つ以上の接続があります。 この IPv4 ネットワークは、グローバル インターネットまたは企業バックボーンである場合があります。 主な要件は、各サイトがグローバルに一意な IPv4 アドレスを持っていることです。Cisco ソフトウェアでは、このアドレスを使用して、グローバルに一意な 6to4/48 IPv6 プレフィックスを構成します。 他のトンネリング メカニズムと同様に、ホスト名を IPv4 と IPv6 両方の IP アドレスにマッピングするドメイン ネーム システム(DNS)によって、アプリケーションは必要なアドレスを選択できます。

IPv6 自動 6to4 トンネルの設定方法

自動 6to4 トンネルの設定

はじめる前に

6to4 トンネルでは、トンネルの宛先は、境界ルータの IPv4 アドレスによって決定されます。このアドレスは、プレフィックス 2002::/16 と連結されて 2002:border-router-IPv4-address::/48 という形式になります。 6to4 トンネルの両端の境界ルータは、IPv4 プロトコル スタックと IPv6 プロトコル スタックの両方をサポートしている必要があります。


(注)  


IPv4 互換トンネル 1 つだけの設定、および 6to4 IPv6 トンネル 1 つだけの設定が、1 台のルータ上でサポートされます。 同じルータ上でこれら両方のトンネル タイプを設定する場合は、これらのタイプが同じトンネル送信元を共有しないようにすることを強く推奨します。

6to4 トンネルと IPv4 互換トンネルがインターフェイスを共有できない理由は、両方が NBMA「ポイントツーマルチポイント」アクセス リンクであり、多重化パケット ストリームからのパケットを着信インターフェイスの単一パケット ストリームに整理するにはトンネル送信元だけを使用できる点です。 したがって、IPv4 プロトコル タイプが 41 のパケットがインターフェイスに到着すると、このパケットは IPv4 アドレスに基づいて、IPv6 トンネル インターフェイスにマッピングされます。 ただし、6to4 トンネルと IPv4 互換トンネルの両方が同じ送信元インターフェイスを共有する場合、ルータは、着信パケットの割り当て先となる IPv6 トンネル インターフェイスを特定できません。

手動で設定された IPv6 トンネルの場合、手動トンネルは「ポイントツーポイント」リンクであり、トンネルの IPv4 送信元と IPv4 宛先が両方とも定義されているため、同じ送信元インターフェイスを共有できます。

>
手順の概要

    1.    enable

    2.    configure terminal

    3.    interface tunnel tunnel-number

    4.    ipv6 address {ipv6-address / prefix-length | prefix-name sub-bits/prefix-length

    5.    tunnel source {ip-address| interface-t ype interface-number}

    6.    tunnel mode ipv6ip [6rd | 6to4 | auto-tunnel | isatap

    7.    exit

    8.    ipv6 route [vrf vrf-name] ipv6-prefix / prefix-length{ipv6-address | interface-type interface-number [ipv6-address]} [nexthop-vrf [vrf-name1 | default]] [administrative-distance] [administrative-multicast-distance | unicast | multicast] [next-hop-address] [tag tag]


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface tunnel tunnel-number


    例:
    Router(config)# interface tunnel 1
     

    トンネル インターフェイスおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 4 ipv6 address {ipv6-address / prefix-length | prefix-name sub-bits/prefix-length


    例:
    Router(config-if)# ipv6 address 3ffe:b00:c18:1::3/127
     

    インターフェイスに割り当てられている IPv6 ネットワークを指定し、インターフェイスで IPv6 処理をイネーブルにします。

     
    ステップ 5 tunnel source {ip-address| interface-t ype interface-number}


    例:
    Router(config-if)# tunnel source loopback 1
     

    トンネル インターフェイスの送信元インターフェイスのタイプおよび番号を指定します。

     
    ステップ 6 tunnel mode ipv6ip [6rd | 6to4 | auto-tunnel | isatap


    例:
    Router(config-if)# tunnel mode ipv6ip 6rd
     

    スタティック IPv6 トンネル インターフェイスを設定します。

    • auto-tunnel キーワードは、Cisco ASR 1000 シリーズ ルータではサポートされません。
     
    ステップ 7 exit


    例:
    Router(config-if) exit
     

    インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

     
    ステップ 8 ipv6 route [vrf vrf-name] ipv6-prefix / prefix-length{ipv6-address | interface-type interface-number [ipv6-address]} [nexthop-vrf [vrf-name1 | default]] [administrative-distance] [administrative-multicast-distance | unicast | multicast] [next-hop-address] [tag tag]


    例:
    Router(config)# ipv6 route 2002::/16 tunnel 0
     

    指定したトンネル インターフェイスに IPv6 6to4 プレフィックス 2002::/16 のスタティック ルートを設定します。

    (注)     

    6to4 オーバーレイ トンネルを設定する場合は、6to4 トンネル インターフェイスに IPv6 6to4 プレフィックス 2002::/16 のスタティック ルートを設定する必要があります。

    • ipv6 route コマンドで指定したトンネル番号は、interface tunnel コマンドで指定したトンネル番号と同じである必要があります。
     

    IPv6 自動 6to4 トンネルの設定例

    例:6to4 トンネルの設定

    次の例では、孤立した IPv6 ネットワーク内の境界ルータ上に 6to4 トンネルを設定します。 IPv4 アドレスは 192.168.99.1 であり、IPv6 プレフィックス 2002:c0a8:6301::/48 に変換されます。 IPv6 プレフィックスは、トンネル インターフェイス用として 2002:c0a8:6301::/64 にサブネット化されます。つまり、最初の IPv6 ネットワークは 2002:c0a8:6301:1::/64、2 番めの IPv6 ネットワークは 2002:c0a8:6301:2::/64 になります。 スタティック ルートによって、IPv6 プレフィックス 2002::/16 のその他のすべてのトラフィックは、自動トンネリングのためにトンネル インターフェイス 0 に送信されます。

    interface GigabitEthernet0/0/0
     description IPv4 uplink
     ip address 192.168.99.1 255.255.255.0
    !
    interface GigabitEthernet1/0/0
     description IPv6 local network 1
     ipv6 address 2002:c0a8:6301:1::1/64 
    !
    interface GigabitEthernet2/0/0
     description IPv6 local network 2
     ipv6 address 2002:c0a8:6301:2::1/64 
    !
    interface Tunnel0
     description IPv6 uplink
     no ip address
     ipv6 address 2002:c0a8:6301::1/64 
     tunnel source GigabitEthernet0/0/0
     tunnel mode ipv6ip 6to4
    !
    ipv6 route 2002::/16 tunnel 0

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    IPv6 アドレッシングと接続

    『IPv6 Configuration Guide』

    Cisco IOS コマンド

    『Cisco IOS Master Commands List, All Releases』

    IPv6 コマンド

    『Cisco IOS IPv6 Command Reference』

    Cisco IOS IPv6 機能

    『Cisco IOS IPv6 Feature Mapping』

    標準および RFC

    標準/RFC

    タイトル

    IPv6 に関する RFC

    『IPv6 RFCs』

    MIB

    MIB

    MIB のリンク

    選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

    http:/​/​www.cisco.com/​go/​mibs

    シスコのテクニカル サポート

    説明

    リンク

    シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    IPv6 自動 6to4 トンネルの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

    表 1 IPv6 自動 6to4 トンネルの機能情報

    機能名

    リリース

    機能情報

    IPv6 トンネリング:自動 6to4 トンネル

    Cisco IOS XE Release 2.1

    自動 6to4 トンネルを使用すると、孤立した IPv6 ドメインを、IPv4 ネットワークを介してリモート IPv6 ネットワークに接続できます。

    tunnel mode ipv6iptunnel source の各コマンドが導入または変更されました。