Flexible NetFlow コンフィギュレーション ガイド、Cisco IOS XE Release 3S(ASR 1000)
データ エクスポートでの Flexible NetFlow 出力機能
データ エクスポートでの Flexible NetFlow 出力機能
発行日;2013/06/06   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

データ エクスポートでの Flexible NetFlow 出力機能

この機能は、Quality of Service(QoS)と暗号化を使用したエクスポート パケットの送信をイネーブルにします。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、『Bug Search Tool』およびご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

データ エクスポートでの Flexible NetFlow 出力機能の前提条件

  • ネットワーキング デバイスで、Flexible NetFlow がサポートされたシスコ リリースが稼働していること。

IPv4 トラフィック

  • ネットワーキング デバイスが IPv4 ルーティング用に設定されていること。
  • シスコ エクスプレス フォワーディングまたは分散型シスコ エクスプレス フォワーディングのいずれかが、使用中のルータおよび Flexible NetFlow をイネーブルにするすべてのインターフェイスでイネーブルにされていること。

IPv6 トラフィック

  • ネットワーキング デバイスが、IPv6 ルーティング用に設定されていること。
  • シスコ エクスプレス フォワーディング IPv6 または分散型シスコ エクスプレス フォワーディングのいずれかが、使用中のルータおよび Flexible NetFlow をイネーブルにするすべてのインターフェイスでイネーブルにされていること。

データ エクスポートでの Flexible NetFlow 出力機能について

フロー エクスポータ

フロー エクスポータは、ルータのコンフィギュレーションで別のコンポーネントとして作成されます。 エクスポータは、フロー モニタ キャッシュから NetFlow コレクタなどのリモート システムへデータをエクスポートするために、フロー モニタに割り当てられます。 フロー モニタでは、複数のエクスポータをサポートできます。 各エクスポータは、使用されるフロー モニタ、およびデータのエクスポート先の NetFlow コレクタのシステム要件を満たすようにカスタマイズできます。

Flexible NetFlow フロー エクスポータの利点

Flexible NetFlow では、お客様の要件に応じて多数のさまざまなフロー エクスポータを設定できます。 次に、Flexible NetFlow フロー エクスポータの利点のいくつかを示します。

  • エクスポータを使用すると、分析するすべてのタイプのトラフィックに対してエクスポータを作成できるため、トラフィックのタイプごとに異なる NetFlow コレクタへ送信することができます。 以前の NetFlow では、分析されたすべてのトラフィックのキャッシュ内のデータが、最大 2 つのエクスポート先に送信されました。
  • フロー エクスポータでは、フロー モニタごとに最大 10 のエクスポータがサポートされます。 以前の NetFlow は、キャッシュごとに 2 つのエクスポート先のみに制限されていました。
  • フロー エクスポータは、エクスポートに TCP と UDP の両方を使用できます。
  • リリースによっては、フロー エクスポータで、エクスポート先に送信されるパケット内のサービス クラス(CoS)を使用できるため、ネットワーク全体でパケットに適切なプライオリティが指定されます。 以前の NetFlow エクスポータは、エクスポート先に送信されるパケット内で CoS を使用していませんでした。
  • リリースによっては、フロー エクスポータ トラフィックを暗号化できます。

データ エクスポートでの Flexible NetFlow 出力機能の設定方法

制約事項

フロー エクスポータごとに、1 つ宛先のみがサポートされます。 複数の宛先にデータをエクスポートする場合は、複数のフロー エクスポータを設定してフロー モニタに割り当てる必要があります。 フロー エクスポータは、フロー モニタ キャッシュからのデータ エクスポートをイネーブルにするためにフロー モニタに追加されます。


(注)  


次の作業では、これらのタスクで使用される Flexible NetFlow コマンドに必要なキーワードおよび引数のみについて説明します。 これらの Flexible NetFlow コマンドで使用可能なその他のキーワードと引数については、『Cisco IOS Flexible NetFlow Command Reference』を参照してください。


フロー エクスポータの設定

フロー エクスポータを設定するには、次の必須作業を実行します。


(注)  


フロー エクスポータごとに、1 つ宛先のみがサポートされます。 複数の宛先にデータをエクスポートする場合は、複数のフロー エクスポータを設定してフロー モニタに割り当てる必要があります。

IPv4 または IPv6 アドレスのいずれかを使用して宛先にエクスポートできます。


手順の概要

    1.    enable

    2.    configure terminal

    3.    flow exporter exporter-name

    4.    description description

    5.    destination {ip-address | hostname} [vrf vrf-name]

    6.    export-protocol {netflow-v5 | netflow-v9 | ipfix}

    7.    dscp dscp

    8.    source interface-type interface-number

    9.    option {exporter-stats | interface-table | sampler-table | vrf-table} [timeout seconds]

    10.    output-features

    11.    template data timeout seconds

    12.    transport udp udp-port

    13.    ttl seconds

    14.    end

    15.    show flow exporter exporter-name

    16.    show running-config flow exporter exporter-name


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 flow exporter exporter-name


    例:
    Device(config)# flow exporter EXPORTER-1
     

    フロー エクスポータを作成し、Flexible NetFlow フロー エクスポータ コンフィギュレーション モードを開始します。

    • このコマンドでは、既存のフロー エクスポータを変更することもできます。
     
    ステップ 4 description description


    例:
    Device(config-flow-exporter)# description Exports to the datacenter
     

    (任意)コンフィギュレーションおよび show flow exporter コマンドの出力に表示されるエクスポータの説明を設定します。

     
    ステップ 5 destination {ip-address | hostname} [vrf vrf-name]


    例:
    Device(config-flow-exporter)# destination 172.16.10.2
     

    エクスポータの宛先システムの IP アドレスまたはホスト名を指定します。

    (注)     

    IPv4 または IPv6 アドレスのいずれかを使用して宛先にエクスポートできます。

     
    ステップ 6 export-protocol {netflow-v5 | netflow-v9 | ipfix}


    例:
    Device(config-flow-exporter)# export-protocol netflow-v9
     

    エクスポータで使用される NetFlow エクスポート プロトコルのバージョンを指定します。 NBAR から抽出されたフィールドのエクスポートは IPFIX でのみサポートされています。

    • デフォルト値:netflow-v9
     
    ステップ 7 dscp dscp


    例:
    Device(config-flow-exporter)# dscp 63
     

    (任意)エクスポータによって送信されるデータグラムの Diffserv コード ポイント(DSCP)パラメータを設定します。

    • 引数 dscp の範囲は 0 ~ 63 です。 デフォルト:[0]。
     
    ステップ 8 source interface-type interface-number


    例:
    Device(config-flow-exporter)# source ethernet 0/0
     

    (任意)エクスポータで、エクスポートされたデータグラムの送信元 IP アドレスとして IP アドレスを使用するローカル インターフェイスを指定します。

     
    ステップ 9 option {exporter-stats | interface-table | sampler-table | vrf-table} [timeout seconds]


    例:
    Device(config-flow-exporter)# option exporter-stats timeout 120
     

    (任意)エクスポータのオプション データ パラメータを設定します。

    • 3 つのオプションを同時に設定できます。
    • 引数 seconds の範囲は、1 ~ 86,400 です。 デフォルト値:600。
     
    ステップ 10 output-features


    例:
    Device(config-flow-exporter)# output-features
     

    (任意)Quality of Service(QoS)と暗号化を使用したエクスポート パケットの送信をイネーブルにします。

     
    ステップ 11 template data timeout seconds


    例:
    Device(config-flow-exporter)# template data timeout 120
     

    (任意)タイムアウトに基づいてテンプレートの再送信を設定します。

    • 引数 seconds の範囲は、1 ~ 86400 です(86400 秒 = 24 時間)。
     
    ステップ 12 transport udp udp-port


    例:
    Device(config-flow-exporter)# transport udp 650
     

    エクスポートされるデータグラムを宛先システムが待機する UDP ポートを指定します。

    • 引数 udp-port の範囲は 1 ~ 65536 です。
     
    ステップ 13 ttl seconds


    例:
    Device(config-flow-exporter)# ttl 15
     

    (任意)エクスポータによって送信されるデータグラムの存続可能時間(TTL)値を設定します。

    • 引数 seconds の範囲は 1 ~ 255 です。
     
    ステップ 14 end


    例:
    Device(config-flow-exporter)# end
     

    フロー エクスポータ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

     
    ステップ 15 show flow exporter exporter-name


    例:
    Device# show flow exporter FLOW_EXPORTER-1
     

    (任意)指定されたフロー エクスポータの現在のステータスを表示します。

     
    ステップ 16 show running-config flow exporter exporter-name


    例:
    Device# show running-config flow exporter FLOW_EXPORTER-1 
     

    (任意)指定されたフロー エクスポータの設定を表示します。

     

    フロー エクスポータの現在のステータスの表示

    フロー エクスポータの現在のステータスを表示するには、次のオプション作業を実行します。

    手順の概要

      1.    enable

      2.    show flow exporter [export-ids {netflow-v5| netflow-v9} | [name] exporter-name [statistics | templates]]


    手順の詳細
      ステップ 1   enable

      enable コマンドによって、特権 EXEC モードを開始します(プロンプトが表示されたらパスワードを入力します)。



      例:
      Device> enable
      Device#
      
      ステップ 2   show flow exporter [export-ids {netflow-v5| netflow-v9} | [name] exporter-name [statistics | templates]]

      show flow exporter コマンドでは、指定するフロー エクスポータの現在のステータスを表示します。



      例:
      Device# show flow exporter EXPORTER-1
      Flow Exporter EXPORTER-1:
        Description:              Exports to the datacenter
        Export protocol:          NetFlow Version 9
        Transport Configuration:
          Destination IP address: 172.16.10.2
          Source IP address:      172.16.6.2
          Source Interface:       GigabitEthernet1/0/0
          Transport Protocol:     UDP
          Destination Port:       650
          Source Port:            55864
          DSCP:                   0x3F
          TTL:                    15
          Output Features:        Used
        Options Configuration:
          exporter-stats (timeout 120 seconds)
          interface-table (timeout 120 seconds)
          sampler-table (timeout 120 seconds)
      

      フロー エクスポータの設定の確認

      入力したコンフィギュレーション コマンドを確認するには、次のオプション作業を実行します。

      手順の概要

        1.    enable

        2.    show running-config flow exporter exporter-name


      手順の詳細
        ステップ 1   enable

        enable コマンドによって、特権 EXEC モードを開始します(プロンプトが表示されたらパスワードを入力します)。



        例:
        Device> enable
        Device#
        
        ステップ 2   show running-config flow exporter exporter-name

        show running-config flow exporter コマンドでは、指定するフロー エクスポータのコンフィギュレーション コマンドを表示します。



        例:
        Device# show running-config flow exporter EXPORTER-1
        Building configuration...
        Current configuration:
        !
        flow exporter EXPORTER-1
         description Exports to the datacenter
         destination 172.16.10.2
         source GigabitEthernet1/0/0
         dscp 63
         ttl 15
         transport udp 650
         template data timeout 120
         option exporter-stats timeout 120
         option interface-table timeout 120
         option sampler-table timeout 120
        !
        end

        データ エクスポートによる Flexible NetFlow の設定とイネーブル化

        キャッシュ データをエクスポートするトラフィックのタイプを設定するには、フロー モニタを作成する必要があります。 データのエクスポートを開始する 1 つ以上のインターフェイスに適用することによって、フロー モニタをイネーブルにする必要があります。 データ エクスポートで Flexible NetFlow を設定してイネーブルにするには、次の必須タスクを実行します。

        各フロー モニタには、専用のキャッシュが割り当てられています。 フロー モニタごとに、キャッシュ エントリの内容およびレイアウトを定義するレコードが必要です。 レコード フォーマットは、事前定義済みのレコード フォーマットのいずれかにすることもできますが、上級のユーザであれば Flexible NetFlow フロー レコード コンフィギュレーション モードで collect および match コマンドを使用して独自のレコード フォーマットを作成することもできます。


        (注)  


        フロー モニタのレコード フォーマットを record コマンドで変更するには、その前にフロー モニタを適用してあるすべてのインターフェイスから、フロー モニタを削除しておく必要があります。


        手順の概要

          1.    enable

          2.    configure terminal

          3.    flow monitor monitor-name

          4.    record {record-name | netflow-original | netflow {ipv4 | ipv6 record [peer] }]

          5.    exporter exporter-name

          6.    exit

          7.    interface type number

          8.    {ip | ipv6} flow monitor monitor-name {input | output}

          9.    end

          10.    show flow monitor [[name] monitor-name [cache [format {csv | record | table}]][statistics]]


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Device> enable
           

          特権 EXEC モードをイネーブルにします。

          • パスワードを入力します(要求された場合)。
           
          ステップ 2 configure terminal


          例:
          Device# configure terminal
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3 flow monitor monitor-name


          例:
          Device(config)# flow monitor FLOW-MONITOR-1
           

          フロー モニタを作成し、Flexible NetFlow フロー モニタ コンフィギュレーション モードを開始します。

          • このコマンドでは、既存のフロー モニタを変更することもできます。
           
          ステップ 4 record {record-name | netflow-original | netflow {ipv4 | ipv6 record [peer] }]


          例:
          Device(config-flow-monitor)# record netflow ipv4 original-input
           

          フロー モニタのレコードを指定します。

           
          ステップ 5 exporter exporter-name


          例:
          Device(config-flow-monitor)# exporter EXPORTER-1 
           

          事前に作成されたエクスポータの名前を指定します。

           
          ステップ 6 exit


          例:
          Device(config-flow-monitor)# exit 
           

          Flexible NetFlow フロー モニタ コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

           
          ステップ 7 interface type number


          例:
          Device(config)# interface GigabitEthernet 0/0/0
           

          インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

           
          ステップ 8 {ip | ipv6} flow monitor monitor-name {input | output}

          例:
          Device(config-if)# ip flow monitor FLOW-MONITOR-1 input
           

          作成済みのフロー モニタを、トラフィックの分析対象となるインターフェイスに割り当てることで、そのフロー モニタをアクティブにします。

           
          ステップ 9 end


          例:
          Device(config-if)# end
           

          インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

           
          ステップ 10 show flow monitor [[name] monitor-name [cache [format {csv | record | table}]][statistics]]


          例:
          Device# show flow monitor FLOW-MONITOR-2 cache
           

          (任意)Flexible NetFlow フロー モニタのステータスおよび統計情報を表示します。 これは、データ エクスポートがフロー モニタ キャッシュに対してイネーブルになっていることを確認します。

           

          データ エクスポートでの Flexible NetFlow 出力機能の設定例

          例:QoS を使用したエクスポート パケット送信の設定

          次に、Flexible NetFlow エクスポート パケットで QoS をイネーブルにする例を示します。


          (注)  


          Flexible NetFlow エクスポート パケットは、FastEthernet インターフェイス 0/1(送信先が到達可能なインターフェイス)で、QoS を使用して送信先ホスト(IP アドレス 10.0.1.2)に送信されます。


          この例は、グローバル コンフィギュレーション モードで開始します。

          !
          flow record FLOW-RECORD-1
           match ipv4 source address
           collect counter packets
          !
          flow exporter FLOW-EXPORTER-1
           destination 10.0.1.2
           output-features
           dscp 18
          !
          flow monitor FLOW-MONITOR-1
           record FLOW-RECORD-1
           exporter FLOW-EXPORTER-1
           cache entries 1024
          !
          ip cef
          !
          class-map match-any COS3
          !
          policy-map PH_LABS_FRL_64k_16k_16k_8k_8k
           class COS3
            bandwidth percent 2
            random-detect dscp-based
            random-detect exponential-weighting-constant 1
            random-detect dscp 18 200 300 10
          !
          interface Ethernet 0/0
           ip address 10.0.0.1 255.255.255.0
           ip flow monitor FLOW-MONITOR-1 input
          !
          interface Ethernet 0/1
           ip address 10.0.1.1 255.255.255.0
           service-policy output PH_LABS_FRL_64k_16k_16k_8k_8k
          !
          

          次に、エクスポートされたデータでの QoS の使用をイネーブルにする出力機能サポートを使用して、フロー モニタでデータをエクスポートする出力例を示します。

          Device# show flow monitor FLOW-MONITOR-1
          Flow Exporter FLOW-EXPORTER-1:
            Description:              User defined
            Tranport Configuration:
              Destination IP address: 10.0.1.2
              Source IP address:      10.0.0.1
              Transport Protocol:     UDP
              Destination Port:       9995
              Source Port:            56750
              DSCP:                   0x12
              TTL:                    255
              Output Features:        Used

          その他の関連資料

          関連資料

          関連項目

          参照先

          Cisco IOS コマンド

          『Cisco IOS Master Command List, All Releases』

          Flexible NetFlow の概念情報および設定作業

          『Flexible NetFlow コンフィギュレーション ガイド』

          Flexible NetFlow コマンド

          『Cisco IOS Flexible NetFlow Command Reference』

          標準/RFC

          標準

          タイトル

          この機能によりサポートされる新規または変更された標準/RFC はありません。

          MIB

          MIB

          MIB のリンク

          なし

          選択したプラットフォーム、シスコ ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

          http:/​/​www.cisco.com/​go/​mibs

          シスコのテクニカル サポート

          説明

          リンク

          シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          データ エクスポートでの Flexible NetFlow:出力機能の機能情報

          次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

          プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

          表 1 データ エクスポートでの Flexible NetFlow:出力機能の機能情報

          機能名

          リリース

          機能情報

          Flexible NetFlow:データ エクスポートでの出力機能

          12.4(20)T

          Cisco IOS XE Release 3.1S

          QoS と暗号を使用したエクスポート パケットの送信をイネーブルにします。

          次のコマンドが導入されました。output-features