Cisco Networking Service コンフィギュレーション ガイド、Cisco IOS XE Release 3S(Cisco ASR 1000)
Cisco Networking Service フロースルー プロビジョニング
Cisco Networking Service フロースルー プロビジョニング
発行日;2013/06/05   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

Cisco Networking Service フロースルー プロビジョニング

Cisco Networking Service フロースルー プロビジョニング機能は、大量のネットワーク デバイスを自動設定するためのインフラストラクチャを提供します。 Cisco Networking Service イベント エージェントおよび設定エージェントにより、現場で技術者がデバイスを初期化する必要はなくなります。 その結果、加入者の最初のオーダー エントリから、シスコの製造、出荷を経て、最終的なデバイス プロビジョニング、加入者の課金までの自動ワークフローが実現します。 これは、サービス プロバイダーおよび他の同様のビジネス モデルの根本問題、つまりサービスのアクティブ化における労働力の活用に焦点を合わせています。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、『Bug Search Tool』およびご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

Cisco Networking Service フロースルー プロビジョニングについて

Cisco Networking Service フロースルー プロビジョニング

Cisco Networking Service フロースルー プロビジョニング機能は、大量のネットワーク デバイスを自動設定するためのインフラストラクチャを提供します。 Cisco Networking Service イベント エージェントおよび設定エージェントにより、現場で技術者がデバイスを初期化する必要はなくなります。 その結果、加入者の最初のオーダー エントリから、シスコの製造、出荷を経て、最終的なデバイス プロビジョニング、加入者の課金までの自動ワークフローが実現します。 この機能は、今日のサービス プロバイダーおよび他の同様のビジネス モデルの根本問題、つまりサービスのアクティブ化における労働力の活用に焦点を合わせています。

こうした自動化を実現するために、Cisco Networking Service フロースルー プロビジョニングは、ユーザが作成した標準化設定テンプレートを使用します。 ただし、こうしたテンプレートを使用するには、すべての加入者に一様な、既知の固定ハードウェア設定が必要です。 これには、各シャーシ内のラインカードやモジュールを手動で事前にステージングしておく必要があります。 シャーシ内のインベントリは製造時にはわかっていますが、どのラインカードまたはモジュールがどのスロットに挿入されているかを制御するのは、手間がかかり、エラーが起こりやすい作業です。

こうした問題を解決するために、Cisco Networking Service フロースルー プロビジョニングでは新しいシスコ コマンド セット(cns コマンド)が定義されています。 リモート デバイスに初めて電源を入れると、これらのコマンドは次を行います。

  1. 各デバイス インターフェイスに順々に、Cisco Networking Service 設定エンジンに接続しようとする事前設定済みの一時ブートストラップ設定を適用します。 正常に接続されると、接続インターフェイスが決まります。
  2. Cisco Networking Service エージェントと呼ばれるソフトウェアを使用して、Cisco IE2100 デバイスに搭載された Cisco Networking Service 設定エンジンに接続します。
  3. デバイスに一意の ID、および製品番号と場所別のデバイスのラインカードまたはモジュールのインベントリの判読可能な説明を XML フォーマットで Cisco Networking Service 設定エンジンに渡します。

今度は、設定エンジンが次を行います。

  1. デバイス ID、メイン シャーシ用定義済み設定テンプレート、および各ラインカードまたはモジュール用サブ設定テンプレートに基づいて、Lightweight Directory Access Protocol(LDAP)ディレクトリを配置します。
  2. テンプレートの slot-number パラメータを、シャーシのインベントリの実際のスロット番号に置き換えます。これにより、テンプレートは正しいラインカードまたはモジュールのスロット設定と一致する加入者固有の設定になります。
  3. この初期設定をターゲット デバイスにダウンロードします。 Cisco Networking Service エージェントは、直接デバイスに設定を適用します。

次の図に、Cisco Networking Service フロースルー プロビジョニング アーキテクチャを示します。

図 1. Cisco Networking Service フロースルー プロビジョニング アーキテクチャ

Cisco Networking Service フロー スルー プロビジョニングの設定

Cisco Networking Service フロースルー プロビジョニングには、リモート デバイスにおける 3 種類の設定があります。

ブートストラップ設定

Cisco Configuration Express(Cisco.com オーダー エントリ ツールに組み込まれた既存サービス)を使用したシスコへのオーダーの一部として、このソリューションが依存する事前設定済みブートストラップ設定を指定します。 Cisco Networking Service 設定エンジンへの接続を提供する一般加入者に固有ではないブートストラップ設定を指定します。 シスコは、すべて自動化された製造段階で、オーダーのすべてのデバイスにこの設定を適用します。 この設定は、電源投入時に自動的に実行されます。

初期設定

Cisco Networking Service 設定エンジンは、初期設定を 1 回だけダウンロードして一時ブートストラップ設定を置き換えます。 この設定は、デバイスの不揮発性 RAM(NVRAM)に保存してもしなくても構いません。

  • 設定を保存すると、ブートストラップ設定は上書きされます。
  • 設定を保存しなかった場合、デバイスの電源を切断した後で投入するたびにダウンロード手順が繰り返し実行されます。 ダウンロード手順を繰り返し実行すると、デバイスはユーザの介入なしに最新のシスコ コンフィギュレーションに更新されます。

差分(部分)設定

以降のリブート時に、差分(部分)設定が実行されて、ネットワークをシャットダウンすることなく設定が更新されます。 このような設定は、ユーザが開始するプッシュ処理またはデバイスからの要求に応じたプル処理で配布できます。

一意の ID

Cisco Networking Service フロースルー プロビジョニングの鍵は、各デバイスに単純で管理しやすい一意の ID を関連付ける機能です。この一意の ID は、オーダー エントリ、課金、プロビジョニング、および出荷についてお客様のシステムに適合し、お客様のオーダー エントリ システムをシスコの受注システムにリンクできます。 こうした ID には次の特性が必要です。

  • 受注処理の一部として製造時から使用可能。
  • 輸送用カートンおよびシャーシに記録可能。
  • デバイスのシスコ ソフトウェアで使用可能。
  • デバイスの初回電源投入後に変更可能。
  • 特定のシャーシおよびネットワークへの特定のエントリ ポイントの両方を表す。

こうした ID を定義するために、Cisco Networking Service フロースルー プロビジョニングでは、Cisco Networking Service エージェントに設定方法、特に一意の ID の定義方法の指定に使用する新しいコマンド セット(cns コマンド)が用意されています。 シスコ ソフトウェアは、ユーザが指定する指示および提供する情報に従って、シャーシのシリアル番号、MAC アドレス、IP アドレスなどの一意の ID を自動検出できます。 cns コマンドは、発注時に Cisco Configuration Express に対して指定された、製造されるデバイスのブートストラップ設定の一部です。

この範囲内で、Cisco Configuration Express および cns コマンドを使用して、製造時に通し番号が付けられ、自動的にユニットのブートストラップ設定に組み込まれる、独自の仕様に合わせたカスタム資産タグを定義できます。

シスコは、cns コマンドでサポートされる各種 ID に対してカートンにタグを付けています。そのため、この ID を出荷時にバーコードで読み取り、加入者のシステムに提供できます。 また、これらの ID は、お客様のシステムとシスコのオーダー ステータス エンジンとの間の XML ソフトウェアの直接インターフェイスからも使用できるため、バーコードで読み取る必要がなくなります。 Cisco Networking Service エージェントは、フィードバック メカニズムも提供します。このメカニズムでは、リモート デバイスが XML イベントまたはコマンドを受信してデバイスの ID を変更でき、同じデバイスが旧/新規 ID を示すイベントをブロードキャストします。

管理ポイント

ほとんどのネットワークで、少数のリモート デバイスがローカルで個々に設定されています。 これは、ネットワークの同期化が失われるだけでなく、自動再設定が既存の設定と競合して、デバイスが使用できなくなり、さらにはネットワークとの接続が失われる可能性がシステムに発生し、重大な問題になる可能性があります。

この問題に対処するために、ネットワーク内に管理ポイントを指定できます。通常は、Cisco IE2100 Cisco Networking Service 設定エンジンに管理ポイントを指定し、すべてのリモート デバイス上の設定を追跡するように設定します。

このソリューションをイネーブルにするには、実行コンフィギュレーションに変更があるたびに Cisco Networking Service イベント バス上でイベントを発行するように Cisco Networking Service エージェントを設定します。 このイベントは、変更点(旧/新)を正確に示します。そのため、管理ポイントで、デバイスへの Telnet 接続、スクリプトの適用、実行コンフィギュレーション全体の読み替え、旧設定と新設定の違いの特定など、拡張性のない一連の動作を実行する必要がなくなります。 また、設定変更の簡易ネットワーク管理プロトコル(SNMP)通知トラップ(SNMP MIB セットを介して行われる)をアレンジすることもできます。

ポイントツーポイント イベント バス

今日のビジネス環境では、お客様が実際に支払うものを上回るレベルのサービスをお客様に対して保証できる必要があります。 そのために、ネットワーク全体に小さなポーリング/クエリーをブロードキャストするとともに、クエリー基準に従って通常はデバイスの小さなサブセットから大量の応答を予想するサービス保証アプリケーションをアクティブにします。

これらのクエリーをスケーラブルにするため、応答するデバイスはイベント バスの通常のブロードキャスト プロパティをバイパスし、その代わりにダイレクト ポイントツーポイント チャネルで応答する必要があります。 すべてのデバイスは、応答する必要があるクエリーを認識できるようにブロードキャストされたポーリングの利点を必要としますが、デバイスが互いの応答を認識する必要はありません。 不必要な応答ブロードキャストの一部としてデバイスのクエリー応答を大量にコピー、再送信することは、重大なスケーラビリティの制約になります。

こうしたスケーラビリティの問題に対処するために、Cisco Networking Service イベント バスには、ポーラー ステーションと直接通信するポイントツーポイント接続機能があります。

Cisco Networking Service フロースルー プロビジョニングの利点

自動設定

Cisco Networking Service フロースルー プロビジョニングは、設定要件を Cisco Networking Service 設定エンジンに移行し、シスコ コンフィギュレーションを自動更新できるようにして、インストールを簡略化します。 レジストラは、XML、Active Directory Services Interface(ADSI)/Active Directory、HTTP/Web サーバ、ATM Switch Processor(ASP)、Publish-Subscribe イベント バスなど、一般的な業界標準およびテクノロジーを使用します。 Cisco Networking Service 設定エージェントは、Cisco Networking Service 設定エンジンがリモート デバイスをプラグアンドプレイ方式で設定できるようにします。

一意の IP アドレスとホスト名

Cisco Networking Service フロースルー プロビジョニングは、DNS リバース ルックアップを使用して、IP アドレスを渡すことでホスト名を取得し、IP アドレスおよび任意でホスト名をリモート デバイスに割り当てます。 そのため、IP アドレスおよびホスト名は一意であることが保証されます。

技術者に対する要件の軽減

Cisco Networking Service フロースルー プロビジョニングにより、技術的な経験が少ないか、なくてもリモート デバイスを設置できます。 ネットワークへの接続時に設定が自動で行われるので、ネットワーク エンジニアや技術者がインストールを行う必要がありません。

迅速な展開

技術的な経験が少ないか、まったくないユーザでも、シスコ ソフトウェアに関する知識や使用経験を必要としないですぐにリモート デバイスを設置できるため、デバイスを直接最終的に設置される場所に出荷して、技術者がいなくても稼働させることができます。

直接出荷

デバイスは、リモート エンドユーザ サイトに直接出荷されるため、倉庫での保管や人手による作業は必要ありません。 設定は、ネットワークへの接続時に自動的に行われます。

リモート更新

Cisco Networking Service フロースルー プロビジョニングは、設定の更新、サービスの追加や削除を自動的に処理します。 Cisco Networking Service 設定エンジンはプッシュ処理を実行してリモート デバイスに情報を送信します。

セキュリティ

リモート デバイスとの間のイベント トラフィックは、ネットワークの不正リスナーまたは侵入者に対して不透明です。 Cisco Networking Service エージェントは、シスコ ソフトウェアの最新セキュリティ機能を利用しています。

Cisco Networking Service イベント エージェント パラメータ

Cisco Networking Service イベント エージェント コマンド cns event には、設定可能なパラメータがあります。 バックアップ Cisco Networking Service イベント ゲートウェイを設定している場合は、failover-time キーワードが便利です。 Cisco Networking Service イベント エージェントがゲートウェイに接続しようとしていて、プライマリ ゲートウェイへのルートよりも前にバックアップ ゲートウェイへのルートが使用できることを検出した場合、seconds 引数は、Cisco Networking Service イベント エージェントがバックアップ ゲートウェイへの接続を試行する前にプライマリ ゲートウェイへのルートを検索する時間を指定します。

帯域幅が制約されたリンクを使用していない場合は、キープアライブ タイムアウトと再試行回数を設定する必要があります。 そうすることにより、Cisco IE2100 設定エンジンに障害が発生した場合でも管理ネットワークを正常に復元できます。 キープアライブ データがないと、このような障害が発生した場合、すべてのデバイスで手動の作業が必要になります。 seconds 値に retry-count 値を掛けた値によって、Cisco Networking Service イベント エージェントがゲートウェイへの接続を切断して、再接続を試行するまでのアイドル時間が決まります。 retry-count の値には 2 以上を推奨します。

オプションの source キーワードを使用する場合、送信元 IP アドレスを特定のインターフェイスのセカンダリ IP アドレスにして、管理ネットワークが運用中のネットワークの上で稼働できるようにします。


(注)  


その他の Cisco Networking Service エージェントを設定できますが、cns event コマンドが入力されるまで他の Cisco Networking Service エージェントは稼働しません。これは、Cisco Networking Service イベント エージェントがその他のすべての Cisco Networking Service エージェントの Cisco Networking Service イベント バスへの転送接続を提供するためです。


Cisco Networking Service フロースルー プロビジョニングの設定方法

Cisco Networking Service イベント エージェントおよび EXEC エージェントの設定

手順の概要

    1.    enable

    2.    configure terminal

    3.    cns config partial {host-name | ip-address} [encrypt] [port-number] [source interface name] [inventory]

    4.    logging cns-events [severity-level]

    5.    cns exec [encrypt] [port-number] [source {ip-address | interface-type-number}]

    6.    cns event {hostname | ip-address} [encrypt] [port-number] [backup] [failover-time seconds] [keepalive seconds retry-count] [source ip-address | interface-name][clock-timeout time] [reconnect-time time]

    7.    exit


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Device> enable
    
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Device# configure terminal
    
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 cns config partial {host-name | ip-address} [encrypt] [port-number] [source interface name] [inventory]


    例:
    Device(config)# cns config partial 172.28.129.22 80
    
     

    (任意)Cisco Networking Service 設定エージェントを起動します。これにより、シスコ クライアントに Cisco Networking Service 設定サービスが提供され、差分(部分)設定が開始されます。

    • コンフィギュレーション サーバのポート番号を指定するには、オプションの port-number 引数を使用します。 デフォルトは 80 です。
    • Cisco Networking Service 設定エージェントの通信の送信元として IP アドレスを使用するように指定するには、オプションの source キーワードと ip-address 引数を使用します。
    • HTTP 要求の一部として Cisco Networking Service 設定エンジンにデバイスのラインカードとモジュールのインベントリを送信するには、オプションの inventory キーワードを使用します。
    (注)     

    SSL をサポートするイメージに限り、オプションの encrypt キーワードを使用できます。

     
    ステップ 4 logging cns-events [severity-level]


    例:
    Device(config)# logging cns-events 2
    
     

    (任意)XML フォーマットのシステム イベント メッセージ ロギングを Cisco Networking Service イベント バスを介して送信できます。

    • メッセージをログに記録する重大度の番号または名前を指定するには、オプションの severity-level 引数を使用します。 デフォルトはレベル 7(デバッグ)です。
     
    ステップ 5 cns exec [encrypt] [port-number] [source {ip-address | interface-type-number}]


    例:
    Device(config)# cns exec source 172.17.2.2
    
     

    (任意)Cisco Networking Service EXEC エージェントをイネーブルにし、設定します。これにより、シスコ クライアントに Cisco Networking Service EXEC サービスが提供されます。

    • EXEC サーバのポート番号を指定するには、オプションの port-number 引数を使用します。 デフォルトは 80 です。
    • Cisco Networking Service EXEC エージェントの通信の送信元として IP アドレスを使用するように設定するには、オプションの source キーワードと ip-address/interface-type number 引数を使用します。
    (注)     

    SSL をサポートするイメージに限り、オプションの encrypt キーワードを使用できます。

     
    ステップ 6 cns event {hostname | ip-address} [encrypt] [port-number] [backup] [failover-time seconds] [keepalive seconds retry-count] [source ip-address | interface-name][clock-timeout time] [reconnect-time time]


    例:
    Device(config)# cns event 172.28.129.22 source 172.22.2.1
    
     

    シスコ クライアントに Cisco Networking Service イベント サービスを提供する Cisco Networking Service イベント ゲートウェイを設定します。

    • SSL をサポートするイメージに限り、オプションの encrypt キーワードを使用できます。
    • イベント サーバのポート番号を指定するには、オプションの port-number 引数を使用します。 デフォルトは、11011(暗号化なし)および 11012(暗号化あり)です。
    • このゲートウェイがバックアップ ゲートウェイであることを示すには、オプションの backup キーワードを使用します。 バックアップ ゲートウェイを設定する前に、プライマリ ゲートウェイが設定されていることを確認します。
    • バックアップ ゲートウェイへのルートが確立された後、プライマリ ゲートウェイのルートを待機する時間間隔(秒)を指定するには、オプションの failover-time キーワードと seconds 引数を使用します。
    • キープアライブ タイムアウト(秒)および再試行回数を指定するには、オプションの keepalive キーワードと seconds および retry-count 引数を使用します。
    • Cisco Networking Service イベント エージェントの通信の送信元として IP アドレスを使用するように指定するには、オプションの source キーワードと ip-address/interface-name 引数を使用します。
    • 正確なクロックを必要とする転送(SSL など)にクロックが設定されるのを Cisco Networking Service イベント エージェントが待機する最大時間(分)を指定するには、オプションの clock-timeout キーワードを使用します。
    • 最大再試行タイムアウトの設定可能な上限を指定するには、オプションの reconnect-time キーワードを使用します。
    (注)     

    cns event コマンドを入力するまで、Cisco Networking Service イベント バスへの転送接続は確立しません。そのため、その他の Cisco Networking Service エージェントは稼働しません。

     
    ステップ 7 exit


    例:
    Device(config)# exit
    
     

    グローバル コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

     

    トラブルシューティングのヒント

    • Cisco Networking Service イベント エージェントが Cisco Networking Service イベント ゲートウェイに接続されていることを確認するには、show cns event connections コマンドを使用します。
    • イメージ エージェントのサブジェクト名が登録されていることを確認するには、show cns event subject コマンドを使用します。 Cisco Networking Service イメージ エージェントのサブジェクト名は cisco.mgmt.cns.image で始まります。

    Cisco Networking Service フロースルー プロビジョニングの設定例

    例:Cisco Networking Service フロースルー プロビジョニング

    例:HDLC プロトコル上で T1 を使用した Cisco Configuration Express ファイル

    次に、リモート ルータを最終的な設置場所に配送する前に、Cisco Configuration Express ファイルを使用してリモート デバイスを設定する例を示します。 この例では、172.28.129.22 が Cisco Networking Service 設定エンジンの IP アドレスです。

    cns config initial 172.28.129.22 no-persist 
    !cns configure and event agents
    cns event 172.28.129.22
    controller t1 0 
    !T1 configuration 
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24 speed 64
    exit
    cns id s0:0 ipaddress
    interface s0:0 
    !Assigns IP address to s0:0
    ip address slarp retry 2
    exit
    ip route 10.0.0.0 0.0.0.0 s0:0 
    !IP static route
    end
    

    例:T1 設定テンプレート

    次に、T1 設定テンプレートを使用して T1 で使用するための設定を作成する例を示します。

    hostname ${LDAP://this:attrName=IOShostname}
    enable password ${LDAP://this:attrName=IOSpassword}
    controller T1 0
    clock source ${LDAP://this:attrName=IOST1-clocksource}
    linecode ${LDAP://this:attrName=IOST1-line}
    framing ${LDAP://this:attrName=IOST1-framing}
    channel-group ${LDAP://this:attrName=IOST1-channel-group} 
    timeslots ${LDAP://this:attrName=IOST1-timeslots} 
    speed ${LDAP://this:attrName=IOST1-speed}
    

    例:音声設定テンプレート

    次に、音声設定テンプレートを使用して音声を使用するための設定を作成する例を示します。

    voice-port 1/1
    codec ${LDAP://this:attrName=IOSvoice-port1}
    exit
    dial-peer voice 1 pots
    application ${LDAP://this:attrName=IOSdial-peer1}
    port 1/1
    

    例:リモート デバイス

    次に、リモート デバイスの設定例を示します。

    Router# show running-config
    Current configuration: 1659 bytes
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname tira-24V
    !
    !
    network-clock base-rate 64k
    ip subnet-zero
    ip cef
    !
    ip audit notify log
    ip audit po max-events 100
    !
    class-map match-any voice
    match access-group 100
    !
    !
    policy-map qos
    class voice
    priority percent 70
    voice service voip
    h323
    !
    no voice confirmation-tone
    voice-card 0
    !
    !
    controller T1 0
    framing sf
    linecode ami
    !
    controller T1 1
    mode cas
    framing esf
    linecode b8zs
    ds0-group 0 timeslots 1 type e&m-immediate-start
    ds0-group 1 timeslots 2 type e&m-immediate-start
    !
    !
    interface Ethernet0
    ip address 10.1.1.2 255.255.0.0
    !
    interface Serial0
    bandwidth 1536
    ip address 10.11.11.1 255.255.255.0
    no ip mroute-cache
    load-interval 30
    clockrate 148000
    !
    ip classless
    ip route 223.255.254.254 255.255.255.0 10.3.0.1
    !
    no ip http server
    ip pim bidir-enable
    !
    access-list 100 permit udp any range 16384 32767 any
    access-list 100 permit tcp any any eq 1720
    call rsvp-sync
    !
    voice-port 1:0
    timeouts wait-release 3
    !
    voice-port 1:1
    timeouts wait-release 3
    !
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    dial-peer voice 1000 pots
    destination-pattern 1000
    port 1:0
    forward-digits 0
    !
    dial-peer voice 1001 pots
    destination-pattern 1001
    no digit-strip
    port 1:1
    forward-digits 0
    !
    dial-peer voice 2000 voip
    destination-pattern 2000
    session target ipv4:10.11.11.2
    codec g711ulaw
    !
    dial-peer voice 2001 voip
    destination-pattern 2001
    session target ipv4:10.11.11.2
    signal-type ext-signal
    codec g711ulaw
    !
    !
    line con 0
    line aux 0
    line 2 3
    line vty 0 4
    

    例:シリアル インターフェイスの使用

    次に、Cisco IE2100 Cisco Networking Service 設定エンジンに接続し、設定をダウンロードするためのシリアル インターフェイスの設定例を示します。 IE2100 IP アドレスは、10.1.1.1 です。 10.1.1.0 ネットワークに接続するためのゲートウェイの IP アドレスは 10.11.11.1 です。 Cisco Networking Service デフォルト ID はホスト名なので、cns id コマンドは必要ありません。 ただし、hostname コマンドが Cisco Networking Service 設定エンジン上の設定ファイルを取得するために重要になります。

    この設定は、リモート ルータ上の各シリアル インターフェイスを順に自動試行して、config-cli コマンドをそのインターフェイスに適用し、cns config initial コマンド内で指定されたアドレスに ping を試みます。 成功すると、通常の初期設定が行われます。

    ! Initial basic configuration (serial interface) PPP
    cns connect serial retry-interval 1 retries 1
     config-cli ip address negotiated
     config-cli encapsulation ppp
     config-cli ip directed-broadcast
     config-cli no keepalive
     config-cli no shutdown
     exit
    hostname 26ML
     ip route 10.1.1.1 255.255.255.0 10.11.11.1
     cns config initial 10.1.1.1 no-persist
     cns inventory config
    ! Initial basic configuration (serial interface) HDLC
     cns config connect serial retry-interval 1 retries 1
     config-cli ip address slarp retry 1
     config-cli no shutdown
     exit
    hostname tira-36V
     ip route 10.1.1.1 255.255.255.0 10.11.11.1
     cns config initial 10.1.1.1 no-persist
     cns inventory config
    Incremental configuration (serial interface)
     cns config partial 10.1.1.1
     cns event 10.1.1.1
    

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    Cisco IOS コマンド

    『Cisco IOS Master Commands List, All Releases』

    Cisco Networking Service コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用上の注意事項、および例

    『Cisco IOS Cisco Networking Services Command Reference』

    Cisco Networking Service 設定エンジン(CE)

    『Cisco CNS Configuration Engine Administrator Guide, 1.3』

    シスコのテクニカル サポート

    説明

    リンク

    シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Cisco Networking Service フロースルー プロビジョニングの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

    表 1 Cisco Networking Service フロースルー プロビジョニングの機能情報

    機能名

    リリース

    機能情報

    Cisco Networking Service フロースルー プロビジョニング

    Cisco IOS XE Release 3.8S

    12.2(8)T

    Cisco Networking Service フロースルー プロビジョニング機能は、大量のネットワーク デバイスを自動設定するためのインフラストラクチャを提供します。 Cisco Networking Service イベント エージェントおよび設定エージェントにより、現場で技術者がデバイスを初期化する必要はなくなります。 その結果、加入者の最初のオーダー エントリから、シスコの製造、出荷を経て、最終的なデバイス プロビジョニング、加入者の課金までの自動ワークフローが実現します。 これは、サービス プロバイダーおよび他の同様のビジネス モデルの根本問題、つまりサービスのアクティブ化における労働力の活用に焦点を合わせています。

    この機能により、cns config cancelcns config initialcns config partialcns eventcns idcns inventorycns mib-access encapsulationcns notifications encapsulationconfig-clidebug cns configdebug cns eventdebug cns managementdebug cns xml-parserline clishow cns config connectionsshow cns config outstandingshow cns event statsshow cns event subject の各コマンドが導入または変更されました。
    (注)     

    cns config connect-intf コマンドは、cns connect および cns template connect コマンドに置き換えられました。