Cisco Network Positioning System Cisco ASR 1000 ルータ リリース 1.0 コンフィギュレーション ガイド
NPS の設定例
NPS の設定例
発行日;2013/01/28   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

NPS の設定例

このモジュールでは、Cisco Network Positioning System の設定例について説明します。

CE-Facing PE の設定例

以下の例では、MC 対応のエンティティを 1 つおよび MC 非対応のエンティティを 2 つ定義した CE-Facing PE の設定を示しています。

hostname ccnsr1.com
ip host ccnsr.com 172.16.0.2
xmpp server type pfm ccnsr.com
xmpp server type cd ccnsr.com 
interface eth0
  ip address 172.17.0.2 255.255.255.0
  no shutdown
router ospf 10
  network 172.17.0.0 0.0.255.255 area 0
pfm ce-facing
  entity 1
    ce-table table1
  entity 2
    pfr-mc disable
    ce-table table2
  entity 3
    pfr-mc disable
    ce-table table10
pfm local-host 10.1.0.2
ce-table table1
  ce-address ipv4 10.1.0.1
  ce-address ipv4 10.1.1.1
  ce-address ipv4 10.1.2.1
  ce-address ipv4 10.5.1.1
  ce-address ipv4 10.5.2.1
ce-table table2
  ce-address ipv4 10.2.1.1 pfr-mc
  ce-address ipv4 10.2.2.1
ce-table table10
  ce-address ipv4 10.3.1.1 pfr-mc
  ce-address ipv4 10.3.2.1
  ce-address ipv4 10.3.3.1
wsma agent
  host 10.1.0.2 username cisco password cisco
  host 10.2.1.1 username cisco password cisco
  host 10.3.1.1 username cisco password cisco
  host 10.5.1.2 username cisco password cisco
  reconnect-time 60
ip route 0.0.0.0 0.0.0.0 27.0.0.1
  
hostname ccnsr1.com
ip host ccnsr.com 172.16.0.2
xmpp server type pfm ccnsr.com
xmpp server type cd ccnsr.com 
router ospf 10
  network 172.17.0.0 0.0.255.255 area 0
pfm ce-facing
  entity 1
    ce-table table1
  entity 2
    pfr-mc disable
    ce-table table2
  entity 3
    pfr-mc disable
    ce-table table10
pfm local-host 10.1.0.2
ce-table table1
  ce-address ipv4 10.1.0.1
  ce-address ipv4 10.1.1.1
  ce-address ipv4 10.1.2.1
  ce-address ipv4 10.5.1.1
  ce-address ipv4 10.5.2.1
ce-table table2
  ce-address ipv4 10.2.1.1 pfr-mc
  ce-address ipv4 10.2.2.1
ce-table table10
  ce-address ipv4 10.3.1.1 pfr-mc
  ce-address ipv4 10.3.2.1
  ce-address ipv4 10.3.3.1
wsma agent
  host 10.1.0.2 username cisco password cisco
  host 10.2.1.1 username cisco password cisco
  host 10.3.1.1 username cisco password cisco
  host 10.5.1.2 username cisco password cisco
  reconnect-time 60
  

DCE-Facing PE の設定例

以下の例では、サービス解決アプリケーションと Jabber サーバも実行している DCE-Facing PE の設定を示しています。

hostname ccnsr.com
ip host ccnsr.com 172.16.0.2
xmpp server type pfm ccnsr.com
xmpp server type cd ccnsr.com
interface eth0
  ip address 172.16.0.2 255.255.255.0
  no shutdown

router ospf 10
  network 172.16.0.0 0.0.255.255 area 0
pfm local-host 10.4.1.1
pfm dce-facing
ip route 0.0.0.0 0.0.0.0 172.16.0.1

jabber server
  domain ccnsr.com
  ipaddr ipv4 172.16.0.2
cd xmpp username test password test

service-resolution dc dc1 pe-addr 10.4.0.1
service-resolution dc dc2 pe-addr 10.4.1.1
service-resolution dc dc3 pe-addr 10.4.2.1
service-resolution dc dc4 pe-addr 10.4.3.1
service-resolution dc dc5 pe-addr 10.4.4.1
service-resolution dc dc6 pe-addr 10.4.5.1

service-resolution service-request timeout 3600
  
hostname ccnsr.com
ip host ccnsr.com 172.16.0.2
xmpp server type pfm ccnsr.com
xmpp server type cd ccnsr.com
router ospf 10
  network 172.16.0.0 0.0.255.255 area 0

pfm local-host 10.4.1.1
pfm dce-facing
ip route 0.0.0.0 0.0.0.0 172.16.0.1

cd xmpp username test password test
service-resolution dc dc1 pe-addr 10.4.0.1
service-resolution dc dc2 pe-addr 10.4.1.1
service-resolution dc dc3 pe-addr 10.4.2.1
service-resolution dc dc4 pe-addr 10.4.3.1
service-resolution dc dc5 pe-addr 10.4.4.1
service-resolution dc dc6 pe-addr 10.4.5.1

service-resolution service-request timeout 3600