Cisco Unified Border Element(SP Edition)コンフィギュレーション ガイド:統合モデル
シャーシ間ハイ アベイラビリティ
シャーシ間ハイ アベイラビリティ
発行日;2012/07/12 | 英語版ドキュメント(2012/03/30 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

シャーシ間ハイ アベイラビリティ

内容

シャーシ間ハイ アベイラビリティの前提条件

シャーシ間のハイ アベイラビリティの制約事項

シャーシ間ハイ アベイラビリティについて

排他的仮想 IP と排他的仮想 MAC

LAN-LAN トポロジ

WAN-LAN トポロジ

冗長グループと SBC による転送

シャーシ間-シャーシ内変換

シャーシ内からシャーシ間への変換

シャーシ間からシャーシ内への変換

シャーシ間ハイ アベイラビリティの設定

シャーシ間ハイ アベイラビリティを使用したスタティック ルーティングの設定

シャーシ間ハイ アベイラビリティを使用したダイナミック ルーティングの設定

SBC への冗長グループの割り当て

シャーシ間ハイ アベイラビリティの管理と監視

冗長グループインフラストラクチャの管理と監視

SBC 冗長性グループの管理と監視

シャーシ間ハイ アベイラビリティの設定例

シャーシ間ハイ アベイラビリティ

シャーシ間ハイ アベイラビリティ機能は、地理的に分散したマルチボックス冗長性を提供します。統合 Session Border Controller(SBC)および分散 SBC は、ボックス間のハイ アベイラビリティをサポートします。

シャーシ間ハイ アベイラビリティ機能は、Cisco ASR 1001 シリーズ ルータ、Cisco ASR 1002 シリーズ ルータ、Cisco ASR 1004 シリーズ ルータ、Cisco ASR 1006 シリーズ ルータ、および Cisco ASR 1013 シリーズ ルータでサポートされます。

Cisco Unified Border Element(SP Edition)は、以前は Integrated Session Border Controller と呼ばれていました。このマニュアルでは Session Border Controller(SBC)と呼びます。

本章で使用されているコマンドの詳細な説明については、次の場所にある『 Cisco Unified Border Element (SP Edition) Command Reference: Unified Model 』を参照してください。

http://www.cisco.com/en/US/docs/ios/sbc/command/reference/sbcu_book.html

すべての Cisco IOS コマンドの詳細については、http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、Cisco IOS マスター コマンド リストを参照してください。

シャーシ間ハイ アベイラビリティの機能履歴

 

リリース
変更内容

Cisco IOS XE Release 3.2S

この機能は、Cisco ASR 1000 シリーズ ルータで導入されました。

Cisco IOS XE Release 3.3S

Cisco ASR 1006 シリーズ ルータ、Cisco ASR 1013 シリーズ ルータ、およびシャーシ間変換に関連するサポート情報が追加されました。

シャーシ間ハイ アベイラビリティの前提条件

次に、シャーシ間ハイ アベイラビリティ機能に関する前提条件を示します。

SBC で共有されるインターフェイスは、同じ冗長インターフェイス識別子(RII)を持つ必要があります。

アクティブ デバイスとスタンバイ デバイスの、SBC インターフェイス、仮想ルーティングおよび転送(VRF)、ルート、sbc 冗長性グループなどの周辺設定は、SBC 機能と同じであることが必要です。SBC 固有の設定はスタンバイに複製されます。したがって、アクティブな Cisco ASR 1000 シリーズ ルータだけに完全な SBC 固有の設定が必要です。

アクティブ デバイスとスタンバイ デバイスは、同じバージョンの Cisco IOS XE ソフトウェアを実行する必要があります。

アクティブ デバイスとスタンバイは、制御パス用の L2 接続を介して接続する必要があります。

組み込みサービス プロセッサは、アクティブ デバイスとスタンバイ デバイスで同じである必要があります。RP も一致し、同様の物理ポート アダプタ設定になっていることが必要です。

タイムスタンプとコール タイマーが一致するように、両方の Cisco ASR 1000 シリーズ ルータで、ネットワーク タイム プロトコル(NTP)を設定するか、クロックを同じに設定する必要があります。

遅延時間は、タイム アウトを防止するため、すべての制御リンクおよびデータ リンクで最小にする必要があります。

Gigabit Ether Channel などの物理的に冗長なリンクを、制御パスおよびデータ パスに使用する必要があります。

シャーシ間のハイ アベイラビリティの制約事項

次に、シャーシ間ハイ アベイラビリティ機能に関する制約事項を示します。

冗長性を持たせるための 2 台を超える SBC クラスタ化はサポートされません。

ボックスツーボックス アプリケーションのフェールオーバー時間は、非ボックスツーボックス アプリケーションではより高くなります。

LAN および MESH シナリオはサポートされません。

デュアル IOS デーモンが設定されている場合、デバイスはシャーシ間ハイ アベイラビリティ構成をサポートしません。

SBC のアクティブ/スタンバイ モードだけがサポートされます。

SBC インターフェイスをシグナリングおよびメディア アドレスに使用する必要があります。物理インターフェイスの IP アドレスは使用できません。

VRF は、SBC データの正確な同期のため、アクティブ ルータとスタンバイ ルータに同じ順序で定義する必要があります。

スタンバイ ルータに複製された設定は、スタートアップ コンフィギュレーションにコミットされず、実行コンフィギュレーションに設定されます。ユーザが write memory コマンドを実行して、アクティブ ルータから同期された変更をスタンバイ ルータでコミットする必要があります。

シャーシ間ハイ アベイラビリティとシャーシ内ハイ アベイラビリティの共存はサポートされません。

Cisco ASR 1001 シリーズ ルータ、Cisco ASR 1002 シリーズ ルータ、および Cisco ASR 1004 シリーズ ルータでは、ソフトウェア冗長性を使用したシャーシ間冗長はサポートされません。

Cisco ASR 1006 シリーズ ルータおよび Cisco ASR 1013 シリーズ ルータでは、シャーシ内冗長性を使用したシャーシ間冗長はサポートされません。これは、シャーシの単一の RP および ESP でサポートされます。

シャーシ間ハイ アベイラビリティについて

シャーシ間ハイ アベイラビリティ機能を使用すると、ルータ ペアが相互にバックアップとして動作することが可能になります。この機能を設定し、複数のフェールオーバー条件に基づいてアクティブ ルータを判断できます。フェールオーバーが発生すると、中断なくスタンバイ ルータが引き継ぎ、コール シグナリングの処理と、メディア転送の実行を開始します。

冗長インターフェイスのグループは、冗長グループと呼ばれます。 図 1 は、アクティブ/スタンバイ デバイス シナリオを表現しています。また、1 つの発信インターフェイスを持つルータのペアについて、冗長グループを設定する方法を示します。

設定可能なコントロール リンクおよびデータ同期リンクによってルータが結合されます。コントロール リンクは、ルータのステータスを通信するために使用されます。データ同期リンクは、SBC からステートフル情報を転送し、コールとメディア フローについてステートフル データベースを同期するために使用されます。冗長インターフェイスの各ペアは同じ一意の ID 番号(RII とも呼びます)で設定されます。

図 1 冗長グループの設定

 

冗長グループ メンバーのステータスは、コントロール リンクで送信される Hello メッセージを使用することで判断できます。設定された時間内に、いずれかのルータが Hello メッセージに応答しない場合、エラーが発生したと見なされ、スイッチオーバーが開始されます。ミリ秒単位でエラーを検出するには、双方向フォワーディング検出(BFD)プロトコルと統合されたフェールオーバー プロトコルをコントロール リンクで実行します。Hello メッセージについて次のパラメータを設定できます。

アクティブ タイマー

スタンバイ タイマー

Hellotime:Hello メッセージが送信される間隔。

Holdtime:アクティブまたはスタンバイ ルータがダウン状態と宣言されるまでの時間。

hellotime のデフォルトは、ホットスタンバイ ルータ プロトコル(HSRP)に合わせるために 3 秒です。また、holdtime のデフォルトは 10 秒です。また、 timers hellotime msec コマンドを使用して、これらのタイマーをミリ秒単位で設定することもできます。

スイッチオーバーの影響を受けるインターフェイスのペアを判断するには、冗長インターフェイスの各ペアについて RII を設定する必要があります。

プライオリティはスタートアップ コンフィギュレーションまたは実行コンフィギュレーションで設定できるの対し、実行時間プライオリティは指定された任意の時点のルータのプライオリティです。実行時間プライオリティは、減少が行われていない場合は設定されたプライオリティと同じになります。またはインターフェイスの障害と減少に基づいて減らすことができます。次のプライオリティ要因によりスイッチオーバーが発生する可能性があります:

最も優先度が高いルータがアクティブ ルータになります。アクティブ ルータまたはスタンバイ ルータで障害が発生した場合、減分値と呼ばれる設定可能な数値分、ルータの優先度が減らされます。アクティブ ルータの優先度が、スタンバイ ルータの優先度を下回る場合、スイッチオーバーが発生し、スタンバイ ルータがアクティブ ルータになります。このデフォルトの動作を無効にするには、冗長グループについて preemption 属性をディセーブルにします。また、インターフェイスの L1 状態がダウン状態になった場合、各インターフェイスを設定して優先度を減らします。この数は、冗長グループに設定されているデフォルトの値よりも優先されます。


) デフォルトで、プリエンプションはイネーブルになりません。これは prempt コマンドを使用してイネーブルにできます。プリエンプションが設定されている場合、スタンバイ ルータがフェールオーバーを開始します。


冗長グループの優先度が変更されるエラー イベントごとに、タイム スタンプ、影響を受けた冗長グループに関する情報、以前の優先度、新しい優先度、およびエラー イベントの原因の説明を含む syslog エントリが生成されます。

ルータまたはインターフェイスの優先度が、設定可能なしきい値レベルを下回ると、アクティブ ルータはフェールオーバーを開始します。

スタンバイ ルータへのスイッチオーバーは、次の状況で行われる可能性があります。

アクティブ ルータで停電またはリロードが発生した場合(クラッシュも含まれます)。

アクティブ ルータの冗長グループを手動でリロードするには、 redundancy application reload group rg-number self コマンドを使用します。

任意のモニタ対象インターフェイスで 2 つの連続する Hello メッセージに失敗した場合、インターフェイスは強制的にテスト モードになります。この問題が発生すると、いずれのユニットもまずインターフェイス上のリンク ステータスを確認してから、次のテストを実行します。

ネットワーク アクティビティ テスト

ARP テスト

ブロードキャスト ping テスト

排他的仮想 IP と排他的仮想 MAC

仮想 IP(VIP)と仮想 MAC は、SBC アプリケーションが、トラフィックを受信するインターフェイスを制御するために使用します。1 つのデバイス上のインターフェイスは別のデバイス上の別のインターフェイスとペアにされ、両方のインターフェイスが同じ冗長グループに関連付けられます。アクティブな冗長グループに関連付けられているインターフェイスは、排他的に VIP アドレスと仮想 MAC を所有します。そのデバイスのアドレス解決プロトコル(ARP)プロセスによって、VIP に関係する ARP 要求に対する ARP 応答が送信されます。また、インターフェイスのイーサネット コントローラは、仮想 MAC 宛てのパケットを受信するようにプログラミングされます。冗長グループのフェールオーバーが発生すると、VIP と仮想 MAC の所有権は変化します。新しくアクティブになった冗長グループに関連付けられたインターフェイスは、gratuitous ARP を送信し、インターフェイスのイーサネット コントローラをプログラミングして、仮想 MAC 宛てのパケットを受け入れます。

LAN-LAN トポロジ

シャーシ間ハイ アベイラビリティ機能は LAN-LAN トポロジをサポートします。 図 2 に LAN-LAN トポロジを示します。トラフィックは、適切な SBC インターフェイス上の IP アドレスへのアップ ストリームまたはダウン ストリーム ルータでスタティック ルーティングを設定するによって、多くの場合 SBC に送信されます。さらに、Cisco ASR 1000 シリーズ ルータは、アップストリームまたはダウンストリーム ルータとのダイナミック ルーティングに参加します。LAN 側インターフェイスでサポートされるダイナミック ルーティングの設定によって、ルーティング プロトコルのコンバージェンスへの依存関係が生まれるため、フェールオーバーの所要時間が長くなります。

図 2 LAN-LAN トポロジ

 

WAN-LAN トポロジ

シャーシ間ハイ アベイラビリティ機能は WAN-LAN トポロジをサポートします。


) ただし、非対称ルーティングはシャーシ間ハイ アベイラビリティ機能でサポートされません。


図 3 に、LAN が LAN/LAN トポロジのものと同様の WAN-LAN トポロジを示します。WAN では、VIP は不要です。SBC インターフェイス ネットワークはダイナミック ルーティングにより両方の Cisco ASR 1000 シリーズ ルータで分散できます。OSPF、ISIS、BGP などのルーティング プロトコルは、WAN リンク上で動作できます。

WAN 側ルータの障害によるトラフィックのフェールオーバーでは隣接する WAN リンクまたは WAN 接続は、ルーティング プロトコルのコンバージェンスに依存します。これらの障害シナリオでは 1 秒未満のフェールオーバーを実現できませんが、ルーティング プロトコルのキープ アライブ タイマーを調整し、BFD 機能を使用することで(使用可能な場合)、障害検出を最小化できます。IOS トラッキング機能を使用し、WAN リンクが障害になった場合にフェールオーバーをトリガーするように Cisco ASR 1000 シリーズ ルータの冗長グループのプライオリティ値を減らすことで、完全な接続とともにスタンバイ ルータにフェールオーバーし、SBC のダウン タイムを最小限にできます。

図 3 WAN-LAN トポロジ

冗長グループと SBC による転送

冗長グループでは、各クライアントがスタンバイおよびアクティブ デバイス間の接続を確立する必要があります。Cisco ASR 1000 シリーズ ルータ プラットフォームのボックスツーボックスの実装は、Stream Control Transmission Protocol(SCTP)を使用したスタンバイおよびアクティブ ルータ間の接続を使用します。この接続は、冗長ファシリティ クライアントによって、2 つのボックスを同期した状態に保つために、イベントとステータスの交換に使用されます。プラットフォームには、プラットフォーム固有のステータスとイベントを交換するために信頼できるユーザ データグラム プロトコル(UDP)接続を使用する MCP C クライアントもあります。

SBC には独自のクライアントがあり、ステータス、イベント、および複製データを交換するために TCP 接続を使用します。これらの接続を表示するには show redundancy application transport clients コマンドを使用し、接続、ポート、および IP アドレスの詳細を表示するには show redundancy application group コマンドを使用します。

シャーシ間-シャーシ内変換

Cisco IOS XE Release 3.3S から、シャーシ間のハイ アベイラビリティ機能も Cisco ASR 1006 シリーズ ルータと Cisco ASR 1013 シリーズ ルータでサポートされます。

シャーシ内ハイ アベイラビリティは、Cisco ASR 1000 シリーズ ルータに 2 つのルーティング プロセッサ(RP)があり、1 つの RP がアクティブ モードでもう 1 つがスタンバイ モードの場合に発生します。シャーシ間のハイ アベイラビリティは 2 台の Cisco ASR 1000 シリーズ ルータがあり、1 台がアクティブ モードで他方がスタンバイ モードで、各ルータに 1 つの RP がある場合に発生します。

ここでは、ハイ アベイラビリティ interchassis-intrachassis 変換に関する手順をリストします。

「シャーシ内からシャーシ間への変換」

「シャーシ間からシャーシ内への変換」

シャーシ内からシャーシ間への変換

次に、デュアル RP から単一 RP ボックスツーボックスへの変換に関する手順を説明します。


ステップ 1 デュアル RP とデュアル転送プロセッサ(FP)がある Cisco ASR 1006 シリーズ ルータおよび Cisco ASR 1013 シリーズ ルータをステートフル スイッチオーバー(SSO)モードで設定します。

ステップ 2 SBC 機能を設定し、正常な動作を確認するためにテスト コールを生成します。

ステップ 3 OIR または CLI のシャットダウン方法を使用して、ボックスから 1 つの RP と 1 つの FP を取り外します。

ステップ 4 アプリケーション冗長性を設定します。

Router(config)# interface GigabitEthernet0/1/1
Router(config-if)# redundancy rii 600
Router(config-if)# redundancy group 1 ip 10.2.3.4 exclusive decrement 200
Router(config-if)# exit
Router(config)# redundancy
Router(config-red)# application redundancy
Router(config-red-app)# group 1

Router(config-red-app-grp)# name SBC

Router(config-red-app-grp)# data GigabitEthernet 0/0/1

Router(config-red-app-grp)# control GigabitEthernet 0/0/2 protocol 1

Router(config-red-app-grp)# timers delay 100 reload 400

Router(config-red-app-grp)# track 1 decrement 1

Router(config-red-app-grp)# track 2 decrement 1

Router(config-red-app-grp)# exit

Router(config-red-app)# protocol 1

Router(config-red-app-prtcl)# name BFD

Router(config-red-app-prtcl)# timers hellotime 4 holdtime 6

Router(config-red-app-prtcl)# authentication md5 key-string 0 n1 100

ステップ 5 RG がシャットダウンした後、SBC アプリケーションの冗長設定を追加します。

Router(config)# redundancy
Router(config-red)# application redundancy
Router(config-red-app)# group 1

Router(config-red-app-grp)# name SBC

Router(config-red-app-grp)# shutdown
Router(config-red-app-grp)# exit
Router(config-red-app)# exit
Router(config-red)# exit
Router(config)# sbc redundancy-group 1 tcp
Router(config)# redundancy
Router(config-red)# application redundancy
Router(config-red-app)# group 1
Router(config-red-app-grp)# no shutdown

ステップ 6 SBC の設定を保存し、 no sbc コマンドを使用して SBC の設定を削除します。

Router(config)# no sbc ASR1

ステップ 7 別の Cisco ASR 1000 シリーズ ルータはまだ設定されていないため、Cisco ASR 1000 シリーズ ルータが ACTIVE モードまたは UNKNOWN モードであることを確認します。

Router# show redundancy application transport group

ステップ 8 保存された設定を使用して SBC を再度設定します。

Router(config)# sbc ASR1

ステップ 9 SBC が正常に機能していることを確認するためにテスト コールを発信します。

ステップ 10 1 つの RP と 1 つの FP を使用して、2 番目の Cisco ASR 1000 シリーズ ルータをオンラインにします。

ステップ 11 2 番目の Cisco ASR 1000 シリーズ ルータでアプリケーション冗長性を設定します。

Router(config)# interface GigabitEthernet0/1/1
Router(config-if)# redundancy group 1 ip 10.1.1.1 exclusive decrement 50
Router(config-if)# redundancy rii 10
Router(config-if)# exit
Router(config)# redundancy
Router(config-red)# application redundancy
Router(config-red-app)# group 1
Router(config-red-app-grp)# name SBC
Router(config-red-app-grp)# data GigabitEthernet 1/0/1
Router(config-red-app-grp)# control GigabitEthernet 0/0/1 protocol 1
Router(config-red-app-grp)# timers delay 100 reload 400
Router(config-red-app-grp)# track 1 decrement 1
Router(config-red-app-grp)# track 2 decrement 1
Router(config-red-app-grp)# exit
Router(config-red-app)# protocol 1
Router(config-red-app-prtcl)# name BFD
Router(config-red-app-prtcl)# timers hellotime 4 holdtime 6
Router(config-red-app-prtcl)# authentication md5 key-string 0 n1 100

ステップ 12 RG をシャット ダウンした後、2 番目の Cisco ASR 1000 シリーズ ルータに SBC アプリケーションの冗長設定を追加します。

Router(config)# redundancy
Router(config-red)# application redundancy
Router(config-red-app)# group 1

Router(config-red-app-grp)# name SBC

Router(config-red-app-grp)# shutdown
Router(config-red-app-grp)# exit
Router(config-red-app)# exit
Router(config-red)# exit
Router(config)# sbc redundancy-group 1 tcp
Router(config)# redundancy
Router(config-red)# application redundancy
Router(config-red-app)# group 1
Router(config-red-app-grp)# no shutdown

ステップ 13 2 番目の Cisco ASR 1000 シリーズ ルータを、STANDBY HOT モードとなるように設定します。

Router# show redundancy application transport group

ステップ 14 最初の Cisco ASR 1000 シリーズ ルータがまだ ACTIVE モードかどうかを確認します。

Router# show redundancy application transport group

ステップ 15 SBC の設定が、STANDBY モードの Cisco ASR 1000 シリーズ ルータに同期しているかどうかを確認します。

Router# show run

ステップ 16 SBC がまだ機能しているかどうかを確認するためにテスト コールを発信します。

シャーシ間からシャーシ内への変換

次に、単一 RP ボックスツーボックスからデュアル RP への変換に関する手順を説明します。


ステップ 1 ボックスツーボックス モードの単一 RP および単一 FP を使用して、2 台の Cisco ASR 1000 シリーズ ルータを設定します。

ステップ 2 ボックスツーボックス動作が正常であることを確認するため、複数のフェールオーバーを使用したテスト コールを生成します。

ステップ 3 両方の Cisco ASR 1000 シリーズ ルータで RG をシャットダウンします。

Router(config)# redundancy
Router(config-red)# application redundancy
Router(config-red-app)# group 1
Router(config-red-app-grp)# shutdown

ステップ 4 両方の Cisco ASR 1000 シリーズ ルータから SBC の冗長性設定を削除します。

Router (config)# no sbc redundancy-group 1 tcp

ステップ 5 両方の Cisco ASR 1000 シリーズ ルータから RG の設定を削除します。

Router(config-red)# no application redundancy

ステップ 6 SBC の設定を保存し、 no sbc コマンドを使用して SBC の設定を削除します。

Router(config)# no sbc ASR1

ステップ 7 ACTIVE モードの Cisco ASR 1000 シリーズ ルータに 1 つの RP および 1 つの FP を追加します。

ステップ 8 保存された設定を使用して SBC を再度設定します。

Router(config)# sbc ASR1

ステップ 9 プライマリ Cisco ASR 1000 シリーズ ルータの SBC アプリケーションがアクティブ化され、正しく機能しているかどうかを確認します。

Router# show redundancy application transport group

ステップ 10 SBC が機能しているかどうかを確認するためにテスト コールを生成し、次のステップを実行するためにこのコールをアクティブなままにします。

ステップ 11 SSO の冗長性を設定します。

Router(config)# redundancy
Router(config-red)# mode sso

ステップ 12 設定が同期され、SBC のトラフィックに中断がないかどうかを確認します。

Router# show run

ステップ 13 SBC がまだ機能していることを確認するためにテスト コールを発信します。

シャーシ間ハイ アベイラビリティの設定

シャーシ間ハイ アベイラビリティを設定するには、『 Security Configuration Guide: Zone-Based Policy Firewall Cisco IOS XE Release 3S 』の「Configuring Firewall Stateful Inter-Chassis Redundancy」の章の次の項を参照してください。

http://www.cisco.com/en/US/partner/docs/ios-xml/ios/sec_data_zbf/configuration/xe-3s/sec-data-zbf-xe-book.html

この章で説明する内容は、次のとおりです。

冗長アプリケーション グループの設定

冗長グループ プロトコルの設定

仮想 IP アドレスおよび冗長インターフェイス識別子の設定

コントロールおよびデータ インターフェイスの設定

シャーシ間ハイ アベイラビリティを使用したスタティック ルーティングの設定

スタティック ルートがアップストリーム ルータまたはレイヤ 3 スイッチで使用される場合、VIP が Cisco ASR 1000 シリーズ ルータの LAN 側インターフェイス上で設定されている必要があります。宛先 IP アドレスが SBC インターフェイスの IP アドレスに設定されたスタティック ルートは、VIP アドレスをネクスト ホップ アドレスとして設定します。このシナリオでは、フェールオーバー中に最適なコンバージェンス時間が得られますが、ルータまたはレイヤ 3 スイッチと Cisco ASR 1000 シリーズ ルータの間で LAN のユニキャスト フラッディング問題が発生します。

デフォルトの ARP テーブルのエージング タイムは 4 時間ですが、MAC テーブルのエージング タイムは数分です。ARP タイムアウトよりも大きいか等しい MAC エージング タイマーが、アップストリーム LAN とダウンストリーム LAN の両方でユニキャスト フラッディングを防ぐために必要です。ARP テーブルがタイム アウトした後、VIP への ARP 要求を送信します。アクティブな Cisco ASR 1000 シリーズ ルータは VMAC で ARP 要求に応答します。MAC テーブルが更新され、ユニキャスト フラッディング問題が解決されます。

MAC エージング タイマーを増やすか、ユニキャスト フラッディング問題がある VLAN の ARP エージング タイマーを短く設定するには、ルータまたはレイヤ 3 スイッチで次のいずれかのコマンドを使用します。

VLAN インターフェイス上の arp timeout コマンド

mac-address-table aging-time vlan コマンド

シャーシ間ハイ アベイラビリティを使用したダイナミック ルーティングの設定

SBC インターフェイスは、ボックスがアクティブになると SBC がアドバタイズされるように、Open Shortest Path First(OSPF)エリアの一部として含まれている必要があります。次に、ルーティングを使用した SBC ボックスツーボックスのアプリケーションを示す OSPF 構成の例を示します。

router ospf 200
router-id 4.4.4.10
priority 11
nsf
network 4.4.0.0 0.0.255.255 area 0
 
interface SBC1
ip address 10.2.0.1 255.255.255.0 secondary
ip address 10.2.0.10 255.255.255.0 secondary
ip address 10.2.0.100 255.255.255.0
ip ospf 200 area 0

) 重複する IP アドレスを防ぐために、SBC インターフェイスがスタンバイ ルータでダウン/ダウン状態のままになっています。


SBC への冗長グループの割り当て

この作業では、SBC に冗長グループを割り当てる方法を示します。


) SBC インターフェイス上の設定は、アクティブ ルータとスタンバイ ルータで同様です。ただし、冗長グループのトラフィック インターフェイスの IP アドレスおよび共有冗長性 IP アドレスは異なります。
Cisco ASR 1001 ルータ、Cisco ASR 1002 ルータ、および Cisco ASR 1004 ルータでこの手順を実行する際、冗長モードを NONE に設定します。


手順の概要

1. enable

2. configure terminal

3. redundancy

4. application redundancy

5. group id

6. shutdown

7. exit

8. exit

9. exit

10. sbc redundancy-group group-number tcp

11. redundancy

12. application redundancy

13. group id

14. no shutdown

15. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードをイネーブルにします。

ステップ 3

redundancy

 

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 4

application redundancy

 

Router(config-red)# application redundancy

冗長アプリケーション コンフィギュレーション モードを開始します。

ステップ 5

group id

 

Router(config-red-app)# group 1

冗長アプリケーション グループ コンフィギュレーション モードを開始します。

id :冗長グループ ID を 1 ~ 2 の範囲で指定します。

ステップ 6

shutdown

 

Router(config-red-app-grp)# shutdown

SBC に冗長グループを割り当てるには、冗長グループをシャット ダウンする必要があります。

ステップ 7

exit

 

Router(config-red-app-grp)# exit

冗長アプリケーション グループ コンフィギュレーション モードを終了し、冗長アプリケーション コンフィギュレーション モードを開始します。

ステップ 8

exit

 

Router(config-red-app)# exit

冗長アプリケーション コンフィギュレーション モードを終了して、冗長コンフィギュレーション モードを開始します。

ステップ 9

exit

 

Router(config-red)# exit

冗長コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードを開始します。

ステップ 10

sbc redundancy-group group-number tcp

 

Router(config)# sbc redundancy-group 1 tcp

次のものを追跡するため、SBC に冗長グループを割り当てます。

group-number :冗長グループ番号を指定します。

tcp :Transmission Control Protocol(TCP)、および冗長グループ プロトコルを指定します。

ステップ 11

redundancy

 

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 12

application redundancy

 

Router(config-red)# application redundancy

冗長アプリケーション コンフィギュレーション モードを開始します。

ステップ 13

group id

 

Router(config-red-app)# group 1

冗長アプリケーション グループ コンフィギュレーション モードを開始します。

id :冗長グループ ID を 1 ~ 2 の範囲で指定します。

ステップ 14

no shutdown

 

Router(config-red-app-grp)# no shutdown

冗長グループがアクティブ化されます。

ステップ 15

end

 

Router(config)# end

冗長アプリケーション グループ コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

シャーシ間ハイ アベイラビリティの管理と監視

次の項の説明に従い、シャーシ間ハイ アベイラビリティ機能を管理および監視できます。

「冗長グループインフラストラクチャの管理と監視」

「SBC 冗長性グループの管理と監視」

冗長グループインフラストラクチャの管理と監視

冗長グループのインフラストラクチャを管理および監視するには、次のコマンドを使用します。

redundancy application reload group group-number { peer | self }:アクティブ冗長グループのステータスに影響を与えずに、アクティブな冗長グループをリロードし、スタンバイ冗長性グループをアクティブ冗長グループにします。

show redundancy application { group-id | all }:指定したグループまたはすべてのグループに関する要約情報を示します。

show redundancy application faults { group-id | all }:指定したグループまたはすべてのグループについて障害情報を示します。

show redundancy application if-mgr { group-id | all }:指定したグループまたはすべてのグループについて if-mgr に関する情報を示します。

show redundancy application interface interface :冗長グループに関連付けられたインターフェイス情報を表示します。

show redundancy application protocol group-id :指定したグループまたはすべてのグループに関するプロトコル情報を示します。

show redundancy application transport { group-id | clients }:指定したグループまたはすべてのグループに関するトランスポート情報を示します。

冗長グループに関連付けられた指定のタイプの情報のデバッグ ロギングをイネーブルにするには、次のコマンドを使用します。

debug redundancy application vp { event | error }

debug redundancy application transport { db | trace | event | error | timer }

debug redundancy application media { packet | event | error | timer | nbr | all }

debug redundancy application protocol { event | error | media | peer | detail | all }

debug redundancy application faults { event | error | fault | func | db | all }

debug platform software rg { tdl | terse | detail | error }

SBC 冗長性グループの管理と監視

SBC 冗長性グループを管理および監視するには、次のコマンドを使用します。

show sbc name rg transport :SBC 冗長性グループに関連するトランスポート情報を表示します。

show sbc name rg statistics :SBC 冗長性グループに関連するトランスポート統計情報を表示します。

clear sbc name rg :SBC の冗長グループのボックスツーボックスの統計情報をクリアします。

monitor event-trace sbc ha :デバッグを支援するためのブート履歴と遷移ログを生成するため、重要な冗長性グループ イベントを含めるように、SBC に関するイベント トレーシングを設定します。

次に、 show sbc name rg transport コマンドの出力例を示します。

Router# show sbc MySBC rg transport
SBC HA RG connection parameters for domain 2
---------------------------------------------
Application Type 1
Handler 53
My IP address 1.0.0.7
My L4 Port 1060
L3 Protocol 1
L4 Protocol 1
Peer IP address 1.0.0.6
Peer L4 Port 1060
My MTU 1464
My L4 Offset 28

次に、 show sbc name rg statistics コマンドの出力例を示します。

Router# show sbc MySBC rg statistics
SBC HA B2B statistics
---------------------
Number of messages successfully queued = 407
Number of messages successfully sent = 407
Number of IPS messages sent = 370
Number of messages queue failures = 0
Number of attempted-send message failures = 0
Number of message header malloc failures = 0
Number of no packet available failures = 0
Number of high watermark of queued messages = 16
Number of high watermark of recv messages = 15
 
Number of messages received = 412
Number of received IPS messages = 356
Number of received messages discarded = 0
Number of received messages dropped(no group) = 0
Number of received large IPS messages = 37
Number of large message send failures = 0
Number of large message send total = 0
Number of large message recv failures = 0
Number of large message not sent, unsupp by peer = 0

次に、 show monitor event-trace sbc ha all コマンドの出力例を示します。この例では、SBC のハイ アベイラビリティ イベントからのすべてのメッセージが表示されます。

Router# show monitor event-trace sbc ha all
 
*Jan 16 10:21:49.718: RF: Is Active, from boot = 0x1
*Jan 16 10:21:49.720: IPC: Initialised as master
*Jan 16 10:21:49.720: RF: Active reached, from boot = 0x1
*Jan 16 10:21:59.448: ILT: Registered on 48, result = 0x1
*Jan 16 10:21:59.448: RF: Start SM on 48
*Jan 16 10:49:02.523: IPC: Session to peer opened
*Jan 16 10:49:02.605: ISSU: Negotiation starting
*Jan 16 10:49:02.605: RF: Delaying progression at 300
*Jan 16 10:49:02.617: ISSU: Negotiation done
*Jan 16 10:49:02.617: RF: Negotiation result = 0x1
*Jan 16 10:49:02.617: RF: Peer state change, peer state = 0x1
*Jan 16 10:49:02.617: RF: Resuming progression at event 300
*Jan 16 10:50:00.853: ISSU: Transformed transmit message
*Jan 16 10:50:00.853: IPC: Queuing message type SBC_HA_MPF_CAPS_MSG_TYPE
*Jan 16 10:50:00.854: IPC: Queued message type SBC_HA_MPF_CAPS_MSG_TYPE

シャーシ間ハイ アベイラビリティの設定例

シャーシ間ハイ アベイラビリティに関する設定例の一覧については、『 Security Configuration Guide: Zone-Based Policy Firewall Cisco IOS XE Release 3S 』の「Configuring Firewall Stateful Inter-Chassis Redundancy」の章の次の項を参照してください。

http://www.cisco.com/en/US/partner/docs/ios-xml/ios/sec_data_zbf/configuration/xe-3s/sec-data-zbf-xe-book.html

Example: Configuring the Redundancy Application Group

Example: Configuring the Redundancy Group Protocol

Example: Configuring Virtual IP Address and Redundant Interface Identifier

Example: Configuring Control and Data Interface