Cisco ASR 1000 シリーズ アグリゲーション サービス ルータ ソフトウェア コンフィギュレーション ガイド
MPLS レイヤ 2 VPN の設定
MPLS レイヤ 2 VPN の設定
発行日;2013/01/07 | 英語版ドキュメント(2012/12/20 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

MPLS レイヤ 2 VPN の設定

機能情報の確認

内容

L2VPN インターワーキングの概要

L2VPN インターワーキング モード

イーサネット(ブリッジ型)インターワーキング

IP(ルーテッド)インターワーキング

フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキングの前提条件

フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキング

フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキングの設定

例: ATM-PE ルータでのフレーム リレーと ATM とのブリッジ型インターワーキング

例:フレーム リレー PE ルータでのフレーム リレーと ATM とのブリッジ型インターワーキング

Virtual Private Wire Service のギガビット EtherChannel

サポート対象モード

GEC Like-to-Like モード

Any-to-GEC モード

Virtual Private Wire Service のギガビット EtherChannel に対する制限事項

Virtual Private Wire Service のギガビット EtherChannel の設定

EtherChannel-to-EtherChannel over MPLS(ブリッジ型)インターワーキング

EtherChannel-to-EtherChannel over MPLS(ルーテッド)インターワーキング

例:GEC Like-to-Like(ルーテッド)インターワーキング

Any-to-EtherChannel over MPLS(ブリッジ型)インターワーキング

Any-to-EtherChannel over MPLS(ルーテッド)インターワーキング

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

MPLS レイヤ 2 VPN の設定に関する機能情報

用語集

MPLS レイヤ 2 VPN の設定

 

フレーム リレーと非同期転送モード(ATM)とのブリッジ型インターワーキング機能により、フレーム リレー接続仮想回線(VC)と、さまざまなプロバイダ エッジ(PE)ルータに接続した ATM 接続 VC との相互運用が可能になります。この相互運用性を実現するために、ブリッジ型(イーサネット)インターワーキング メカニズムに対応するブリッジ型カプセル化が使用されています。イーサネット フレームは、Ethernet over MPLS(EoMPLS)を使用した MPLS ネットワークを通じて転送されます。このインターワーキング機能は、フレーム リレー接続 VC と ATM 接続 VC に接続した PE ルータで、RFC 2684 および RFC 2427 に基づいて実行されます。

ギガビット EtherChannel(GEC)の Virtual Private Wire Services(VPWS)で xconnect をサポートする ASR 1000 の機能により、サービス プロバイダーは、単一の統合されたパケットベースのネットワーク インフラストラクチャである Cisco MPLS ネットワークを使用して、既存のデータ リンク レイヤ(レイヤ 2)ネットワークを持つカスタマー サイト間を接続できます。別々のネットワーク管理環境による別々のネットワークに代わり、サービス プロバイダーは、MPLS バックボーン上でレイヤ 2 接続が可能になります。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。機能と注意点に関する最新情報については、ご使用のプラットフォームとソフトウェア リリースに該当するリリース ノートを参照してください。本モジュールに記載されている機能についての情報と、各機能がサポートされているリリースの一覧については、「MPLS レイヤ 2 VPN の設定に関する機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS と Cisco Catalyst のオペレーティング システム ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

L2VPN インターワーキングの概要

インターワーキングとは、2 つの異種接続回線(AC)を相互接続する変換機能です。インターワーキング機能にはいくつかの種類があります。使用される機能は、使用する AC のタイプ、扱うデータのタイプ、および必要とする機能性のレベルによって異なります。Cisco IOS XE ソフトウェアでサポートしているレイヤ 2 バーチャル プライベート ネットワーク(L2VPN)インターワーキング機能は、主にブリッジ型インターワーキングおよびルーテッド インターワーキングの 2 種類です。

マルチ プロトコル ラベル スイッチング(MPLS)と IP を介したレイヤ 2(L2)転送は、イーサネットツーイーサネット プロトコルやポイントツーポイント プロトコル(PPP)、イーサネットと VLAN 間、イーサネットとフレーム リレー間などで使用する AC 向けです。インターワーキング機能を使用することで、異種の L2 カプセル化どうしの変換が容易になります。

L2VPN インターワーキング モード

L2VPN インターワーキングは、イーサネット(ブリッジ型)モードまたは IP(ルーテッド)モードで機能します。疑似回線クラス コンフィギュレーション モードで interworking {ethernet | ip} コマンドを発行することで、このモードを指定できます。

interworking コマンドを実行すると、AC はローカルで終端されます。この 2 つのキーワードには次の機能があります。

ethernet キーワードを指定すると、AC からイーサネット フレームが抽出されて、疑似回線に送信されます。イーサネットのエンドツーエンドの送信が再開します。イーサネット フレーム以外の AC フレームはドロップされます。VLAN の場合、VLAN タグが削除され、タグなしイーサネット フレームが残されます。

ip キーワードを指定すると、AC から IP パケットが抽出されて、疑似回線に送信されます。IPv4 パケットを含まない AC フレームはドロップされます。

次の項では、イーサネット インターワーキング モードおよび IP インターワーキング モードについて詳しく説明します。

イーサネット(ブリッジ型)インターワーキング

イーサネット インターワーキングは、ブリッジ型インターワーキングとも呼ばれます。イーサネット フレームは、疑似回線を介してブリッジされます。CE ルータでは、ブリッジ グループ仮想インターフェイス(BVI)やルーテッド ブリッジ エンカプセレーション(RBE)などのブリッジ型カプセル化モデルを使用して、ネイティブでイーサネット トラフィックのブリッジやトラフィックのルーティングが可能です。PE ルータは、イーサネット Like-to-Like モードで動作します。

イーサネット インターワーキング モードでは次のサービスを提供します。

LAN サービス:この例として、サービス プロバイダー(SP)ネットワークへのイーサネット接続を有するサイトと非同期転送モード(ATM)の接続を有するサイトが混在する企業があります。このような企業で、そのすべてのサイトへの LAN 接続が必須の場合、あるサイトのイーサネットまたは VLAN からのトラフィックを IP/MPLS ネットワークを通じて送信し、別のサイトの ATM VC に対してブリッジ型トラフィックとしてカプセル化できます。

接続サービス:この例として、ブロードキャスト リンクと非ブロードキャスト リンクとの間で互換性のある手順を持たない Internal Gateway Protocol(IGP)を実行している多数のサイトを有する企業があります。このような企業には、Open Shortest Path First(OSPF)や Intermediate System-to-Intermediate System(IS-IS)などの IGP をサイト間で実行する複数のサイトがあります。このような場合、ルート アドバタイズメントや指定ルータ選択のように、基礎となる L2 プロトコルに依存する手順が一部に存在し、ポイントツーポイント ATM 接続とブロードキャスト イーサネット接続とでは手順が異なっていることがあります。したがって、ATM を介したブリッジ型カプセル化を使用することで、IGP を実行している CE ルータ間の同種イーサネット接続を実現できます。

IP(ルーテッド)インターワーキング

IP インターワーキングは、ルーテッド インターワーキングとも呼ばれます。CE ルータは、CE ルータと PE ルータ間のリンク上で IP をカプセル化します。新しいタイプの VC を使用して、MPLS の IP 疑似回線に対するシグナリングを実行します。この疑似回線をまたいで L2 カプセル化と IP カプセル化との変換が必要です。L2 カプセル化が異なると、アドレス解決プロトコルとルーティング プロトコルの処理も異なるので、これらのプロトコルの操作には特別の配慮が必要です。

IP インターワーキング モードは、サイトへの L2 接続があるかどうかに関係なく、これらのサイト間で IP 接続を実現するために使用します。これは、レイヤ 3 VPN とは異なります。レイヤ 3 VPN は本質的にポイントツーポイントであり、サービス プロバイダーはカスタマーに関するルーティング情報を保持していないためです。

アドレス解決は、以下のようにカプセル化によって異なります。

イーサネットではアドレス解決プロトコル(ARP)を使用します。

ATM では Inverse ARP を使用します。

PPP では IP 制御プロトコル(IPCP)を使用します。

したがって、アドレス解決を PE ルータで終端する必要があります。また、エンドツーエンドのアドレス解決はサポートされていません。ルーティング プロトコルは、ブロードキャストとポイントツーポイント メディアでは異なる動作をします。イーサネットでは、CE ルータでスタティック ルーティングを使用するか、イーサネット側をポイントツーポイント ネットワークとして扱うルーティング プロトコルを設定する必要があります。

ルーテッド インターワーキングでは、AC から抽出された IP パケットは疑似回線に送信されます。この疑似回線は、IP レイヤ 2 転送(VC タイプ 0x000B)の Like-to-Like モードで動作します。ネットワーク サービス プロバイダー(NSP)側のエンドでは、AC テクノロジーに基づいて、目的とするアダプテーションがインターワーキング機能によって完了します。IPv4 ではないパケットはドロップされます。

ルーテッド インターワーキングでは、次の事項に留意する必要があります。

ARP、Inverse ARP、および IPCP はルーティング プロトコルにパントされます。

したがって、NSP のエンドに置いたルータでは、イーサネットとフレーム リレーおよび ATM とフレーム リレーとのポイントツーポイントのサブインターフェイス接続回線に、次のアドレス解決機能を提供する必要があります。

イーサネット:PE デバイスは、CE ルータからのすべての ARP 要求に対してプロキシ ARP サーバとして機能します。PE ルータは、そのローカル インターフェイスの MAC アドレスで応答します。

ATM とフレーム リレーとのポイントツーポイントのサブインターフェイス:デフォルトでは、フレーム リレーでも ATM でも、ポイントツーポイントのサブインターフェイスでは Inverse ARP が動作しません。IP アドレスとサブネット マスクによって、接続されたプレフィックスが定義されているので、CE デバイスでは設定は不要です。

インターワーキングでは、起動する疑似回線で両方の AC の MTU が一致している必要があります。一方の AC のデフォルトの MTU が、他方の AC の MTU と一致している必要があります。

表 1 は、さまざまな AC で設定できる MTU の範囲を示しています。

 

表 1 さまざまな AC の MTU の範囲

AC のタイプ
サポートされている MTU1 の範囲

ATM

64 ~ 9216

ギガビット イーサネット

1500 ~ 9216

POS

64 ~ 9216

ファスト イーサネット

1500 ~ 9216

1.AC に設定する MTU は、コア ネットワークの MTU 以下であることが必要です。そのようにすることで、トラフィックがフラグメント化することがなくなります。

OSPF を実行するイーサネット接続 VC を備えた CE ルータは、 ospfIfType オプションを指定して設定する必要があります。これにより、基礎となる物理ブロードキャスト リンクが OSPF プロトコルによって P2P リンクとして扱われます。

フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキングの前提条件

フレーム リレーのデータリンク接続識別子(DLCI)と ATM AAL5SNAP とのブリッジ型インターワーキング機能をルータに設定する前に、次の前提条件を満たしていることを確認します。

フレーム リレーのプロバイダー エッジ(PE)ルータでフレーム リレー スイッチングがイネーブルになっていること。

カスタマー エッジ(CE)ルータで、ブリッジ グループ仮想インターフェイスまたはルーテッド ブリッジ エンカプセレーションをサポートしていること。

フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキング

この機能により、それぞれ異なる PE ルータに接続した ATM 接続 VC とフレーム リレー接続 VC と間で相互運用が可能になります。このインターワーキングでは、ブリッジ型(イーサネット)インターワーキング メカニズムに対応するブリッジ型カプセル化を使用します。イーサネット フレームは、Ethernet over MPLS(EoMPLS)を使用した MPLS ネットワークを通じて転送されます。この機能は、ブリッジ型モードのみで設定でき、ルーテッド モードでは設定できません。

図 1 は、ATM 接続 VC とフレーム リレー接続 VC に接続した PE ルータで実行されるインターワーキング機能を示しています。

図 1 フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキングのネットワーク トポロジ

 

インターワーキング機能を備えた ATM 側 PE ルータでは、ATM セグメントから MPLS クラウドへのトラフィックが発生すると、ブリッジ型カプセル化(ATM および SNAP ヘッダ)は破棄され、VC タイプ 5(イーサネット)を使用して疑似回線で転送するために必要なラベルを伴ってイーサネット フレームがカプセル化されます。逆方向の転送では、MPLS クラウドからのラベル ディスポジション後、ブリッジ型カプセル化を使用してイーサネット フレームが AAL5SNAP によってカプセル化されます。

インターワーキング機能を備えた FR 側 PE ルータでは、FR セグメントから MPLS クラウドへのトラフィックが発生すると、ブリッジ型カプセル化(フレーム リレーおよび SNAP ヘッダ)は破棄され、VC タイプ 5(イーサネット)を使用して疑似回線で転送するために必要なラベルを伴ってイーサネット フレームがカプセル化されます。逆方向の転送では、MPLS クラウドからのラベル ディスポジション後、ブリッジ型カプセル化を使用してイーサネット フレームが FR によってカプセル化されます。

PE ルータは、カスタマー エッジ(CE)ルータからの送信では、シスコと IETF の両方のフレーム リレーについてカプセル化の変換を自動的にサポートしますが、CE ルータへの送信では IETF への変換のみをサポートします。Cisco CE ルータは、シスコ カプセル化を送信するように設定されていても、IETF カプセル化を受信時に扱うことができます。

次のモードがサポートされています。

AAL5SNAP カプセル化タイプを使用した ATM 相手先固定接続(PVC)モード、および ATM PVC を対象とした既存の Quality of Service(QoS)機能。

フレーム リレーの DLCI モードおよびフレーム リレーを対象とした既存の QoS 機能。

PVC ステータス シグナリングは、Like-to-Like の場合と同様に機能します。PE ルータでは、疑似回線のアベイラビリティに基づいて PVC ステータスが CE ルータにレポートされます。

MPLS に接続する場合は、疑似回線両側の接続回線の最大伝送単位(MTU)が一致している必要があります。OAM セルのような、AAL5 ではないトラフィックは RP レベルで処理されるようにパントされます。ATM の PE ルータ上で実行する OAM セル エミュレーションを( oam-ac emulation-enable コマンドを使用して)設定した VC では、設定した間隔で CE ルータにエンドツーエンドの F5 ループバック セルを送信できます。疑似回線がダウンしている場合は、エンドツーエンドの F5 セグメントのアラーム表示信号(AIS)およびリモート障害表示(RDI)が、PE ルータから CE ルータに送信されます。

図 2 は、フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキング機能のプロトコル スタックを示しています。

図 2 フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキングのプロトコル スタック

 

フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキングの設定

フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキング機能を ATM-PE ルータに設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. no ip domain lookup

4. mpls label range minimum-value maximum-value [static minimum-static-value maximum-static-value ]

5. mpls label protocol ldp

6. mpls ip default-route

7. mpls ldp graceful-restart

8. xconnect logging pseudowire status

9. pseudowire-class [ pw-class-name ]

10. encapsulation mpls

11. interworking ethernet

12. exit

13. interface loopback loopback-interface-number

14. ip address ip-address mask

15. exit

16. interface GigabitEthernet slot/subslot/port

17. ip address ip-address mask

18. negotiation auto

19. mpls ip

20. exit

21. interface atm slot/subslot/port

22. no ip address

23. atm clock internal

24. no atm enable-ilmi-trap

25. exit

26. interface atm slot/subslot/port [ .subinterface-number {point-to-point}]

27. mtu bytes

28. no atm enable-ilmi-trap

29. pvc [ name ] vpi/vci l2transport

30. encapsulation encapsulation-type

31. xconnect peer-ip-address vc-id encapsulation mpls pw-class pw-class-name

32. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# no ip domain lookup

IP の Domain Naming System(DNS)をディセーブルにします。

ステップ 4

mpls label range minimum-value maximum-value [ static minimum-static-value maximum-static-value ]

 

Router(config)# mpls label range 101 4000 static 4001 5001

パケット インターフェイス上でマルチ プロトコル ラベル スイッチング(MPLS)アプリケーションから使用可能なローカル ラベルの範囲を設定します。

ステップ 5

mpls label protocol ldp

 

Router(config)# mpls label protocol ldp

ATM-PE ルータのラベル配布プロトコル(LDP)を指定します。

ステップ 6

mpls ip default-route

 

Router(config)# mpls ip default-route

IP デフォルト ルートに関連付けられているラベルの配布をイネーブルにします。

ステップ 7

mpls ldp graceful-restart

 

Router(config)# mpls ldp graceful-restart

MPLS LDP グレースフル リスタートをイネーブルにします。

ステップ 8

xconnect logging pseudowire status

 

Router(config)# xconnect logging pseudowire status

疑似回線ステータス イベントのシステム ロギング(syslog)レポートをイネーブルにします。

ステップ 9

pseudowire-class [ pw-class-name ]

 

Router(config)# pseudowire-class atm-fr-bridged

指定した名前の疑似回線クラスを確立して、疑似回線クラス コンフィギュレーション モードを開始します。

ステップ 10

encapsulation mpls

 

Router(config-pw-class)# encapsulation mpls

インターフェイス上で MPLS カプセル化をイネーブルにします。

ステップ 11

interworking ethernet

 

Router(config-pw-class)# interworking ethernet

L2VPN イーサネット インターワーキング機能をイネーブルにします。

ステップ 12

exit

疑似回線クラス コンフィギュレーション モードを終了します。

ステップ 13

interface loopback loopback-interface-number

 

Router(config)# interface loopback 0

ループバックの論理インターフェイスを指定します。

ステップ 14

ip address ip-address mask

 

Router(config-if)# ip address 44.1.1.2 255.255.255.255

ループバック インターフェイスの IP アドレスを指定します。

ステップ 15

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 16

interface GigabitEthernet slot/subslot/port

 

Router(config)# interface GigabitEthernet 0/0/1

PE ルータを接続するギガビット イーサネット インターフェイスを指定します。

ステップ 17

ip address ip-address mask

 

Router(config-if)# ip address 10.10.1.2 255.255.255.0

ギガビット イーサネット インターフェイスの IP アドレスを指定します。

ステップ 18

negotiation auto

 

Router(config-if)# negotiation auto

ギガビット イーサネット インターフェイスの速度、デュプレックス、および自動フロー制御を自動ネゴシエーション プロトコルで設定できるようにします。

ステップ 19

mpls ip

 

Router(config-if)# mpls ip

MPLS コアへの IPv4 パケットの MPLS 転送をイネーブルにします。

ステップ 20

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 21

interface atm slot/subslot/port

 

Router(config)# interface atm 0/1/2

ATM インターフェイスを設定して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 22

no ip address

 

Router(config-if)# no ip address

以前に設定した IP アドレスを削除します。

ステップ 23

atm clock internal

 

Router(config-if)# atm clock internal

ATM インターフェイスで送信クロックを内部的に生成できるようにします。

ステップ 24

no atm enable-ilmi-trap

 

Router(config-if)# no atm enable-ilmi-trap

統合ローカル管理インターフェイス(ILMI)の ATM トラップをディセーブルにします。

ステップ 25

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 26

interface atm slot/subslot/port [. subinterface-number {point-to-point}]

 

Router(config)# interface atm 0/1/2.1 point-to-point

ATM インターフェイスを設定して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 27

mtu bytes

 

Router(config-subif)# mtu 1500

最大パケット サイズまたは最大伝送単位(MTU)サイズを調整します。

(注) 両方の接続回線の MTU サイズが一致している必要があります。

ステップ 28

no atm enable-ilmi-trap

 

Router(config-subif)# no atm enable-ilmi-trap

ILMI の ATM トラップをディセーブルにします。

ステップ 29

pvc [ name ] vpi / vci l2transport

 

Router(config-subif)# pvc cisco 10/100 l2transport

ATM PVC に名前を割り当てて、ATM PVC で実行するカプセル化のタイプを指定し、ATM 仮想回線のコンフィギュレーション モードを開始します。

ステップ 30

encapsulation encapsulation-type

 

Router(config-if-atm-l2trans-pvc)# encapsulation aal5snap

ATM ポイントツーポイント インターフェイスの AAL5SNAP カプセル化(Any-to-Any)を設定します。

ステップ 31

xconnect peer-ip-address vc-id encapsulation mpls pw-class pw-class-name

 

Router(config-if-atm-l2trans-pvc)# xconnect 190.1.1.1 100 encapsulation mpls pw-class atm-fr-bridged

接続回線を疑似回線にバインドし、Any Transport over MPLS(AToM)スタティック疑似回線を設定します。

ステップ 32

exit

現在のモードを終了して、グローバル コンフィギュレーション モードに戻ります。

例: ATM-PE ルータでのフレーム リレーと ATM とのブリッジ型インターワーキング

フレーム リレーと ATM とのブリッジ型インターワーキング機能を ATM-PE ルータに設定する例を次に示します。

no ip domain lookup
mpls label range 101 4000 static 4001 5001
mpls label protocol ldp
mpls ip default-route
mpls ldp graceful-restart
xconnect logging pseudowire status
!
pseudowire-class atm-fr-bridged
encapsulation mpls
interworking ethernet
!
interface Loopback0
ip address 44.1.1.2 255.255.255.255
!
interface GigabitEthernet0/0/1
ip address 10.10.1.2 255.255.255.0
negotiation auto
mpls ip
!
interface ATM0/1/2
no ip address
atm clock INTERNAL
no atm enable-ilmi-trap
!
interface ATM0/1/2.1 point-to-point
mtu 1500
no atm enable-ilmi-trap
pvc 10/100 l2transport
encapsulation aal5snap
xconnect 190.1.1.1 100 pw-class atm-fr-bridged
!
!

 

フレーム リレーと ATM とのブリッジ型インターワーキング機能をフレーム リレー PE ルータに設定するには、次の手順を実行します。


) 次の設定では、チャネライズド T1/E1 インターフェイスを使用しています。Packet over SONET(PoS)などの他のインターフェイス上でフレーム リレーを設定できます。


手順の概要

1. enable

2. configure terminal

3. (オプション)ipv6 unicast-routing

4. mpls label protocol ldp

5. mpls ip default-route

6. mpls ldp graceful-restart

7. frame-relay switching

8. xconnect logging pseudowire status

9. controller t1 slot/subslot/port

10. framing esf

11. clock source internal

12. linecode b8zs

13. cablelength long db-loss-value

14. channel-group channel-group-number timeslots range

15. exit

16. pseudowire-class [ pw-class-name ]

17. encapsulation mpls

18. interworking ethernet

19. exit

20. interface loopback loopback-interface-number

21. ip address ip-address mask

22. exit

23. interface serial slot/subslot/port:timeslot

24. no ip address

25. encapsulation frame-relay

26. frame-relay intf-type dce

27. frame-relay interface-dlci dlci switched

28. exit

29. interface GigabitEthernet slot/subslot/port

30. ip address ip-address mask

31. negotiation auto

32. mpls ip

33. exit

34. connect connection-name interface dlci l2transport

35. xconnect peer-ip-address vc-id encapsulation mpls pw-class pw-class-name

36. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 unicast-routing

 

Router# ipv6 unicast-routing

(オプション)IPv6 ユニキャスト データグラムの転送タスクをイネーブルにします。

ステップ 4

mpls label protocol ldp

 

Router(config)# mpls label protocol ldp

フレーム リレー PE ルータのラベル配布プロトコル(LDP)を指定します。

ステップ 5

mpls ip default-route

 

Router(config)# mpls ip default-route

IP デフォルト ルートに関連付けられているラベルの配布をイネーブルにします。

ステップ 6

mpls ldp graceful-restart

 

Router(config)# mpls ldp graceful-restart

MPLS LDP グレースフル リスタートをイネーブルにします。

ステップ 7

frame-relay switching

 

Router(config)# frame-relay switching

フレーム リレーのデータ回線終端装置(DCE)で PVC スイッチングをイネーブルにします。

ステップ 8

xconnect logging pseudowire status

 

Router(config)# xconnect logging pseudowire status

疑似回線ステータス イベントのシステム ロギング(syslog)レポートをイネーブルにします。

ステップ 9

controller t1 slot/subslot/port

 

Router(config)# controller T1 0/3/0

T1 コントローラを設定し、コントローラ コンフィギュレーション モードを開始します。

ステップ 10

framing esf

 

Router(config-controller)# framing esf

T1 データ回線の拡張スーパー フレーム(ESF)を選択します。

ステップ 11

clock source internal

 

Router(config-controller)# clock source internal

DS1 リンクのクロック ソースを設定し、インターフェイスから内部クロックを使用します。

ステップ 12

linecode b8zs

 

Router(config-controller)# linecode b8zs

T1 コントローラのライン コード タイプとして Binary 8-Zero Substitution(B8ZS)を指定します。

ステップ 13

cablelength long db-loss-value

 

Router(config-controller)# cablelength long 0db

送信信号の減衰値を 0 dB にします。これはデフォルト値です。

ステップ 14

channel-group channel-group-number timeslots range

 

Router(config-controller)# channel-group 0 timeslots 1-24

T1 インターフェイスまたは E1 インターフェイスでシリアル WAN を設定します。

ステップ 15

exit

疑似回線クラス コンフィギュレーション モードを終了します。

ステップ 16

pseudowire-class [ pw-class-name ]

 

Router(config)# pseudowire-class atm-fr-bridged

指定した名前の疑似回線クラスを確立して、その疑似回線クラスのコンフィギュレーション モードを開始します。

ステップ 17

encapsulation mpls

 

Router(config-pw-class)# encapsulation mpls

インターフェイス上で MPLS カプセル化をイネーブルにします。

ステップ 18

interworking ethernet

 

Router(config-pw-class)# interworking ethernet

L2VPN イーサネット インターワーキング機能をイネーブルにします。

ステップ 19

exit

疑似回線クラス コンフィギュレーション モードを終了します。

ステップ 20

interface loopback loopback-interface-number

 

Router(config)# interface loopback 0

ループバックの論理インターフェイスを指定します。

ステップ 21

ip address ip-address mask

 

Router(config-if)# ip address 44.1.1.2 255.255.255.255

ループバック インターフェイスの IP アドレスを指定します。

ステップ 22

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 23

interface serial slot/subslot/port:timeslot

 

Router(config)# interface Serial 0/3/0:0

チャネライズド T1 コントローラに作成したシリアル インターフェイスを指定します。

ステップ 24

no ip address

 

Router(config-if)# no ip address

以前に設定した IP アドレスを削除します。

ステップ 25

encapsulation frame-relay

 

Router(config-if)# encapsulation frame-relay

シリアル インターフェイス上で Cisco フレーム リレーのカプセル化を設定します。

ステップ 26

frame-relay intf-type dce

 

Router(config-if)# frame-relay intf-type dce

フレーム リレー スイッチのタイプを設定します。このルータは、他のルータに接続するスイッチとして機能します。

ステップ 27

frame-relay interface-dlci dlci switched

 

Router(config-if)# frame-relay interface-dlci 101 switched

データリンク接続識別子(DLCI)をルータ上の指定したフレーム リレー サブインターフェイスに割り当てます。

ステップ 28

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 29

interface GigabitEthernet slot/subslot/port

 

Router(config)# interface GigabitEthernet 0/0/1

PE ルータを接続するギガビット イーサネット インターフェイスを指定します。

ステップ 30

ip address ip-address mask

 

Router(config-if)# ip address 10.10.1.2 255.255.255.0

ギガビット イーサネット インターフェイスの IP アドレスを指定します。

ステップ 31

negotiation auto

 

Router(config-if)# negotiation auto

ギガビット イーサネット インターフェイスの速度、デュプレックス、および自動フロー制御を自動ネゴシエーション プロトコルで設定できるようにします。

ステップ 32

mpls ip

 

Router(config-if)# mpls ip

MPLS コアへの IPv4 パケットの MPLS 転送をイネーブルにします。

ステップ 33

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 34

connect connection-name interface dlci l2transport

 

Router(config)# connect fr-atm-2 Serial0/3/0:0 101 l2transport

フレーム リレー PVC 間の接続を定義します。

ステップ 35

xconnect peer-ip-address vc-id encapsulation mpls pw-class pw-class-name

 

Router(config-conn)# xconnect 190.1.1.1 100 encapsulation mpls pw-class atm-fr-bridged

接続回線を疑似回線にバインドし、AToM スタティック疑似回線を設定します。

ステップ 36

exit

グローバル コンフィギュレーション モードを終了します。

例:フレーム リレー PE ルータでのフレーム リレーと ATM とのブリッジ型インターワーキング

フレーム リレーと ATM とのブリッジ型インターワーキング機能をフレーム リレー PE ルータに設定する例を次に示します。

ipv6 unicast-routing
mpls label protocol ldp
mpls ip default-route
mpls ldp graceful-restart
frame-relay switching
xconnect logging pseudowire status
!
controller T1 0/3/0
framing esf
clock source internal
linecode b8zs
cablelength long 0db
channel-group 0 timeslots 1-24
!
pseudowire-class atm-fr-bridged
encapsulation mpls
interworking ethernet
!
interface Loopback0
ip address 190.1.1.1 255.255.255.255
!
interface Serial0/3/0:0
no ip address
encapsulation frame-relay
frame-relay intf-type dce
frame-relay interface-dlci 101 switched
!
interface GigabitEthernet1/3/1
ip address 10.10.1.1 255.255.255.0
negotiation auto
mpls ip
!
 
connect fr-atm-2 Serial0/3/0:0 101 l2transport
xconnect 44.1.1.2 100 pw-class atm-fr-bridged
!

Virtual Private Wire Service のギガビット EtherChannel

AToM 向け GEC は、GEC を備えた MPLS バックボーン上でレイヤ 2 パケットを転送する VPWS 向けのソリューションです。

この機能を使用するサービス プロバイダーは、単一の統合されたパケットベースのネットワーク インフラストラクチャである Cisco MPLS ネットワークを使用して、データ リンク レイヤ(レイヤ 2)ネットワークを持つカスタマー サイト間を接続できます。別々のネットワーク管理環境による別々のネットワークに代わり、サービス プロバイダーは、MPLS バックボーン上でレイヤ 2 接続が可能になります。

サポート対象モード

VPWS 向け GEC の機能では次のモードがサポートされています。

「GEC Like-to-Like モード」

「Any-to-GEC モード」

GEC Like-to-Like モード

GEC Like-to-Like モードでは、2 つのセグメント(CE1-PE1 および CE2-PE2、図 3 を参照)がいずれも GEC タイプである 2 台の物理インターフェイスの間でデータの切り替えができます。

GEC Like-to-Like モードには次の機能があります。

「EtherChannel-to-EtherChannel over MPLS(ブリッジ型)インターワーキング」

「EtherChannel-to-EtherChannel over MPLS(ルーテッド)インターワーキング」

図 3 VPWS 向け GEC 機能の GEC Like-to-Like モードのトポロジ

Any-to-GEC モード

Any-to-GEC モードでは、2 つのセグメント CE1-PE1 と CE2-PE2 が互いに異なるタイプである 2 台の物理インターフェイスの間でデータの切り替えができます。この場合、図 4 に示すように、セグメントの一方は GEC としますが、他方は PPP、イーサネット、フレーム リレー、または ATM とすることができます。

Any-to-GEC モードには次の機能があります。

「Any-to-EtherChannel over MPLS(ブリッジ型)インターワーキング」

「Any-to-EtherChannel over MPLS(ルーテッド)インターワーキング」

図 4 VPWS 向け GEC 機能の Any-to-GEC モードのトポロジ


) ブリッジ型インターワーキングは、レイヤ 3 のコンテンツを無視して、レイヤ 2(L2)パケットを考慮する場合に使用します。ブリッジ型インターワーキングでは、接続回線から抽出されたイーサネット フレームが MPLS 疑似回線に送信されます。



) ルーテッド インターワーキングは、レイヤ 3 パケットの伝送に使用します。ルーテッド インターワーキングでは、接続回線から抽出した IP パケットが MPLS 疑似回線に送信されます。


Virtual Private Wire Service のギガビット EtherChannel に対する制限事項

VPWS のギガビット EtherChannel には、次の制限事項があります。

VPWS 向け GEC は、Q-in-Q カプセル化およびリモート ポート シャットダウンをサポートしていません。

ポート チャネルでサポートされているメンバ リンクは最大 4 つで、1 台のルータでサポートされているポート チャネル バンドルは最大 64 個です。

Virtual Private Wire Service のギガビット EtherChannel の設定

GEC の VPWS サポート機能は、EtherChannel インターフェイスでは AToM でサポートされ、次の機能があります。

「EtherChannel-to-EtherChannel over MPLS(ブリッジ型)インターワーキング」

「EtherChannel-to-EtherChannel over MPLS(ルーテッド)インターワーキング」

「Any-to-EtherChannel over MPLS(ブリッジ型)インターワーキング」

「Any-to-EtherChannel over MPLS(ルーテッド)インターワーキング」

EtherChannel-to-EtherChannel over MPLS(ブリッジ型)インターワーキング

PE ルータのアップストリーム インターフェイス上で L2VPN インターワーキングを設定します。PE ルータ上の L2VPN インターワーキングの設定の詳細については、「L2VPN インターワーキング モード」を参照してください。

MPLS 転送を設定した後、PE ルータのダウン ストリーム インターフェイスで次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. mpls label protocol ldp

4. interface loopback loopback-interface-number

5. ip address ip-address ip-subnet-mask

6. exit

7. pseudowire-class pw-class-name

8. encapsulation mpls

9. interworking ethernet

10. exit

11. interface port-channel number

12. xconnect peer-ip-address vc-id encapsulation mpls pseudowire-class pw-class-name

13. interface GigabitEthernet slot | subslot | port

14. channel-group port-channel number

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

対応する CLI セッションの特権レベルを変更します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls label protocol ldp

 

Router# mpls label protocol ldp

LDP をデフォルトのラベル配布プロトコルとすることを指定します。

ステップ 4

interface loopback loopback-interface-number

 

Router# interface loopback 1

ループバック インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip address ip-address mask

 

Router# ip address 10.10.2.1 255.255.255.0

ループバック インターフェイスの IP アドレスとマスクを設定します。

ステップ 6

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 7

pseudowire-class pw-class-name

 

Router(config)# pseudowire-class gec-bridged

レイヤ 2 疑似回線クラスの名前を指定し、疑似回線クラス コンフィギュレーション モードを開始します。

ステップ 8

encapsulation mpls

 

Router(config-pw)# encapsulation mpls

疑似回線でデータをカプセル化するトンネリング方式として MPLS を使用します。

ステップ 9

interworking ethernet

 

Router(config-pw)# interworking ethernet

L2VPN インターワーキング機能をイネーブルにし、接続回線からイーサネット フレームを抽出して疑似回線に送信するようにします。イーサネット エンドツーエンド送信が想定されます。イーサネット フレームを含まない接続回線フレームはドロップされます。VLAN の場合は、VLAN タグを削除して、純粋なイーサネット フレームとします。

ステップ 10

exit

xconnect コンフィギュレーション モードを終了します。

ステップ 11

interface port-channel number

 

Router(config)# interface port-channel 1

Cisco Cable Modem Termination System(CMTS)に EtherChannel インターフェイスを作成します。

ステップ 12

xconnect peer-ip-address vc-id encapsulation mpls pseudowire-class pw-class-name

 

Router(config-if)# xconnect 10.0.0.1 707 encapsulation mpl pseudowire-class gec-bridged

接続回線を疑似回線にバインドして AToM スタティック疑似回線を設定し、トンネリング方式として MPLS を指定して、xconnect コンフィギュレーション モードを開始します。

ステップ 13

interface GigabitEthernet slot | subslot | port

 

Router(config)# interface GigabitEthernet 0/0/1

ギガビット イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 14

channel-group port-channel number

 

Router(config-if) channel-group 1

EtherChannel グループに EtherChannel インターフェイスを設定します。


) EtherChannel-to-EtherChannel over MPLS(ブリッジ型)インターワーキング モードは、VLAN でもサポートされています。


EtherChannel-to-EtherChannel over MPLS(ルーテッド)インターワーキング

PE ルータのアップストリーム インターフェイス上で L2VPN インターワーキングを設定します。PE ルータ上の L2VPN インターワーキングの設定の詳細については、「L2VPN インターワーキング モード」を参照してください。

MPLS 転送を設定した後、PE ルータのダウン ストリーム インターフェイスで次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. mpls label protocol ldp

4. interface loopback loopback-interface-number

5. ip address ip-address ip-subnet-mask

6. exit

7. pseudowire-class pw-class-name

8. encapsulation mpls

9. interworking ip

10. exit

11. interface port-channel number

12. xconnect peer-ip-address vc-id encapsulation mpls pw-class pw-class-name

13. interface GigabitEthernet slot | subslot | port

14. channel-group port-channel number

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

対応する CLI セッションの特権レベルを変更します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls label protocol ldp

 

Router# mpls label protocol ldp

LDP をデフォルトのラベル配布プロトコルとすることを指定します。

ステップ 4

interface loopback loopback-interface-number

 

Router# interface loopback 1

ループバック インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip address ip-address mask

 

Router# ip address 10.10.2.1 255.255.255.0

ループバック インターフェイスの IP アドレスとマスクを設定します。

ステップ 6

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 7

pseudowire-class pw-class-name

 

Router(config)# pseudowire-class gec-bridged

レイヤ 2 疑似回線クラスの名前を指定し、疑似回線クラス コンフィギュレーション モードを開始します。

ステップ 8

encapsulation mpls

 

Router(config-pw)# encapsulation mpls

疑似回線でデータをカプセル化するトンネリング方式として MPLS を使用します。

ステップ 9

interworking ip

 

Router(config-pw)# interworking ip

L2VPN インターワーキング機能をイネーブルにし、接続回線から IP パケットを抽出して疑似回線に送信するようにします。IPv4 パケットを含まない接続回線フレームはドロップされます。

ステップ 10

exit

xconnect コンフィギュレーション モードを終了します。

ステップ 11

interface port-channel number

 

Router(config)# interface port-channel 1

Cisco Cable Modem Termination System(CMTS)に EtherChannel インターフェイスを作成します。

ステップ 12

xconnect peer-ip-address vc-id encapsulation mpls pseudowire-class pw-class-name

 

Router(config-if)# xconnect 10.0.0.1 707 encapsulation mpl pseudowire-class gec-routed

接続回線を疑似回線にバインドして AToM スタティック疑似回線を設定し、トンネリング方式として MPLS を指定して、xconnect コンフィギュレーション モードを開始します。

ステップ 13

interface GigabitEthernet slot | subslot | port

 

Router(config)# interface GigabitEthernet 0/0/1

ギガビット イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 14

channel-group port-channel number

 

Router(config-if) channel-group 1

EtherChannel グループに EtherChannel インターフェイスを設定します。


) EtherChannel-to-EtherChannel over MPLS(ルーテッド)インターワーキング モードは、VLAN でもサポートされています。


例:GEC Like-to-Like(ルーテッド)インターワーキング

GEC Like-to-Like(ルーテッド)インターワーキング機能の設定例を次に示します。

no ip domain lookup
mpls label range 101 4000 static 4001 5001
mpls label protocol ldp
mpls ip default-route
mpls ldp graceful-restart
xconnect logging pseudowire status
!
pseudowire-class gec-bridged
encapsulation mpls
interworking ethernet!
pseudowire-class gec-routed
encapsulation mpls
interworking ip
!
interface Loopback0
ip address 44.1.1.2 255.255.255.255
!
interface GigabitEthernet0/0/1
ip address 10.10.1.2 255.255.255.0
negotiation auto
mpls ip
!
interface port-channel 1
xconnect 190.1.1.1 100 encapsulation mpls pw-class gec-bridged
!
interface GigabitEthernet0/0/3
channel-group 1
!
interface GigabitEthernet0/0/2
channel-group 1
!
router ospf 10
log-adjacency-changes
network 44.1.1.2 0.0.0.0 area 0

network 10.10.1.2 0.0.0.255 area 0

Any-to-EtherChannel over MPLS(ブリッジ型)インターワーキング

Cisco ASR 1000 シリーズ ルータに Any-to-EtherChannel over MPLS(ブリッジ型)インターワーキングを設定できます。

Any-to-EtherChannel over MPLS(ブリッジ型)インターワーキングでは、次のモードをサポートしています。

フレーム リレーと EtherChannel とのインターワーキング

ATM と EtherChannel とのインターワーキング

イーサネットと EtherChannel とのインターワーキング

Any-to-EtherChannel over MPLS(ブリッジ型)インターワーキングでは、使用するモードに関係なく、PE ルータのアップストリーム インターフェイスに L2VPN インターワーキングが設定されます。PE ルータ上の L2VPN インターワーキングの設定の詳細については、「L2VPN インターワーキング モード」を参照してください。

PE ルータのダウン ストリーム インターフェイスでフレーム リレーまたは ATM を設定する方法については、「フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキングの設定」を参照してください。もう一方の PE ルータのダウン ストリーム インターフェイスでは、「EtherChannel-to-EtherChannel over MPLS(ブリッジ型)インターワーキング」で説明している手順を実行します。

イーサネットと EtherChannel とのインターワーキング モードの場合、もう一方の PE ルータのダウン ストリーム インターフェイスでは、「EtherChannel-to-EtherChannel over MPLS(ブリッジ型)インターワーキング」で説明している手順を実行します。 これらの PE ルータ上のダウン ストリーム インターフェイスで、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. mpls label protocol ldp

4. interface loopback loopback-interface-number

5. ip address ip-address ip-subnet-mask

6. exit

7. pseudowire-class pw-class-name

8. encapsulation mpls

9. interworking ethernet

10. interface GigabitEthernet slot | subslot | port

11. xconnect peer-ip-address vc-id encapsulation mpls pw-class pw-class-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

対応する CLI セッションの特権レベルを変更します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls label protocol ldp

 

Router# mpls label protocol ldp

LDP をデフォルトのラベル配布プロトコルとすることを指定します。

ステップ 4

interface loopback loopback-interface-number

 

Router# interface loopback 1

ループバック インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip address ip-address mask

 

Router# ip address 10.10.2.1 255.255.255.0

ループバック インターフェイスの IP アドレスとマスクを設定します。

ステップ 6

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 7

pseudowire-class pw-class-name

 

Router(config)# pseudowire-class gec-bridged

レイヤ 2 疑似回線クラスの名前を指定し、疑似回線クラス コンフィギュレーション モードを開始します。

ステップ 8

encapsulation mpls

 

Router(config-pw)# encapsulation mpls

疑似回線でデータをカプセル化するトンネリング方式として MPLS を使用します。

ステップ 9

interworking ethernet

 

Router(config-pw)# interworking ethernet

L2VPN インターワーキング機能をイネーブルにし、接続回線からイーサネット フレームを抽出して疑似回線に送信するようにします。イーサネット エンドツーエンド送信が想定されます。イーサネット フレームを含まない接続回線フレームはドロップされます。VLAN の場合は、VLAN タグを削除して、純粋なイーサネット フレームとします。

ステップ 10

interface GigabitEthernet slot | subslot | port

 

Router(config)# interface GigabitEthernet 0/0/1

ギガビット イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 11

xconnect peer-ip-address vc-id encapsulation mpls pseudowire-class pw-class-name

 

Router(config-if)# xconnect 10.0.0.1 707 encapsulation mpl pseudowire-class gec-bridged

接続回線を疑似回線にバインドして AToM スタティック疑似回線を設定し、トンネリング方式として MPLS を指定して、xconnect コンフィギュレーション モードを開始します。


) Ethernet-to-EtherChannel over MPLS(ブリッジ型)インターワーキング モードは、VLAN でもサポートされています。


Any-to-EtherChannel over MPLS(ルーテッド)インターワーキング

Cisco ASR 1000 シリーズ ルータに Any-to-EtherChannel over MPLS(ルーテッド)インターワーキングを設定できます。

Any-to-EtherChannel over MPLS(ルーテッド)インターワーキングでは、次のモードをサポートしています。

ATM と EtherChannel とのインターワーキング

イーサネットと EtherChannel とのインターワーキング

PPP と EtherChannel とのインターワーキング

PE ルータのアップストリーム インターフェイス上で L2VPN インターワーキングを設定します。PE ルータ上の L2VPN インターワーキングの設定の詳細については、「L2VPN インターワーキング モード」を参照してください。

PE ルータのダウン ストリーム インターフェイスで ATM を設定する方法については、「フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキングの設定」を参照してください。もう一方の PE ルータのダウン ストリーム インターフェイスでは、「EtherChannel-to-EtherChannel over MPLS(ルーテッド)インターワーキング」で説明している手順を実行します。

イーサネットと EtherChannel とのインターワーキング モードについては、「Any-to-EtherChannel over MPLS(ブリッジ型)インターワーキング」を参照してください。

PPP と EtherChannel とのインターワーキング モードの場合、もう一方の PE ルータのダウン ストリーム インターフェイスでは、「EtherChannel-to-EtherChannel over MPLS(ルーテッド)インターワーキング」で説明している手順を実行します。これらの PE ルータ上のダウン ストリーム インターフェイスで、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. (オプション)ipv6 unicast-routing

4. mpls ip default-route

5. mpls ldp graceful-restart

6. xconnect logging pseudowire status

7. controller t1 slot | subslot | port

8. clock source internal

9. linecode b8zs

10. cablelength long db-loss-value

11. channel-group channel-group-number timeslots range

12. exit

13. pseudowire-class pw-class-name

14. encapsulation mpls

15. interworking ethernet

16. exit

17. interface loopback loopback-interface-number

18. ip address ip-address mask

19. exit

20. interface serial slot | subslot | port:timeslot

21. no ip address

22. encapsulation ppp

23. clock source internal

24. xconnect vc-id pw-class pw-class pw-class-name

25. xconnect peer-loopback vc-id pw-class pe-class-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 unicast-routing

 

Router# ipv6 unicast-routing

(オプション)IPv6 ユニキャスト データグラムの転送タスクをイネーブルにします。

ステップ 4

mpls ip default-route

 

Router(config)# mpls ip default-route

IP デフォルト ルートに関連付けられているラベルの配布をイネーブルにします。

ステップ 5

mpls ldp graceful-restart

 

Router(config)# mpls ldp graceful-restart

MPLS LDP グレースフル リスタートをイネーブルにします。

ステップ 6

xconnect logging pseudowire status

 

Router(config)# xconnect logging pseudowire status

疑似回線ステータス イベントのシステム ロギング(syslog)レポートをイネーブルにします。

ステップ 7

controller t1 slot/subslot/port

 

Router(config)# controller T1 0/3/0

T1 コントローラを設定し、コントローラ コンフィギュレーション モードを開始します。

ステップ 8

clock source internal

 

Router(config-controller)# clock source internal

DS1 リンクのクロック ソースを設定し、インターフェイスから内部クロックを使用します。

ステップ 9

linecode b8zs

 

Router(config-controller)# linecode b8zs

T1 コントローラのライン コード タイプとして Binary 8-Zero Substitution(B8ZS)を指定します。

ステップ 10

cablelength long db-loss-value

 

Router(config-controller)# cablelength long 0db

送信信号の減衰値を 0 dB にします。これはデフォルト値です。

ステップ 11

channel-group channel-group-number timeslots range

 

Router(config-controller)# channel-group 0 timeslots 1-24

T1 インターフェイスまたは E1 インターフェイスでシリアル WAN を設定します。

ステップ 12

exit

疑似回線クラス コンフィギュレーション モードを終了します。

ステップ 13

pseudowire-class [ pw-class-name ]

 

Router(config)# pseudowire-class atm-fr-bridged

指定した名前の疑似回線クラスを確立して、その疑似回線クラスのコンフィギュレーション モードを開始します。

ステップ 14

encapsulation mpls

 

Router(config-pw-class)# encapsulation mpls

インターフェイス上で MPLS カプセル化をイネーブルにします。

ステップ 15

interworking ethernet

 

Router(config-pw-class)# interworking ethernet

L2VPN イーサネット インターワーキング機能をイネーブルにします。

ステップ 16

exit

疑似回線クラス コンフィギュレーション モードを終了します。

ステップ 17

interface loopback loopback-interface-number

 

Router(config)# interface loopback 0

ループバックの論理インターフェイスを指定します。

ステップ 18

ip address ip-address mask

 

Router(config-if)# ip address 44.1.1.2 255.255.255.255

ループバック インターフェイスの IP アドレスを指定します。

ステップ 19

exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 20

interface serial slot/subslot/port:timeslot

 

Router(config)# interface Serial 0/3/0:0

チャネライズド T1 コントローラに作成したシリアル インターフェイスを指定します。

ステップ 21

no ip address

 

Router(config-if)# no ip address

以前に設定した IP アドレスを削除します。

ステップ 22

encapsulation ppp

 

Router(config-if)# encapsulation frame-relay

シリアル インターフェイスで PPP(シリアル インターフェイス対応)カプセル化を設定します。

ステップ 23

clock source internal

T1/E1 リンクではインターフェイスから内部クロックを使用することを指定します。

ステップ 24

xconnect peer-loopback vc-id pw-class pe-class-name

接続回線を疑似回線にバインドして AToM スタティック疑似回線を設定し、トンネリング方式として MPLS を指定して、xconnect コンフィギュレーション モードを開始します。


) Ethernet-to-EtherChannel over MPLS(ブリッジ型)インターワーキング モードは、VLAN でもサポートされています。


その他の参考資料

次の項では、フレーム リレーと ATM とのブリッジ型インターワーキングおよび GEC(VPWS)機能での xconnect のサポートに関する資料について説明します。

標準

標準
タイトル

この機能がサポートする新しい規格または変更された規格はありません。

--

MIB

MIB
MIB のリンク

CISCO-IETF-PW-MIB

CISCO-IETF-PW-MPLS-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに対する MIB を特定してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC2
タイトル

RFC 2684

『Multiprotocol Encapsulation over ATM Adaptation Layer 5』

RFC 2427

『Multiprotocol Interconnect over Frame Relay』

2.サポートされている RFC をすべて紹介しているわけではありません。

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

MPLS レイヤ 2 VPN の設定に関する機能情報

表 2 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 3.6.0S 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、対応するコマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Cisco Catalyst オペレーティング システムのソフトウェア イメージでサポートしている特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

 

表 2 MPLS レイヤ 2 VPN の設定に関する機能情報

機能名
リリース
機能情報

フレーム リレーと ATM とのブリッジ型インターワーキング

3.6.0S

フレーム リレーと ATM とのブリッジ型インターワーキング機能は、それぞれ異なる PE ルータに接続しているフレーム リレー接続 VC と ATM 接続 VC との間を相互運用します。ブリッジ型(イーサネット)インターワーキング メカニズムに対応するブリッジ型カプセル化を使用します。イーサネット フレームは、Ethernet over MPLS(EoMPLS)を使用した MPLS ネットワークを通じて転送されます。

Cisco IOS XE Release 3.6.0S では、この機能が ASR 1000 シリーズ アグリゲーション サービス ルータに実装されました。

この機能に関する詳細については、次の各項を参照してください。

「フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキング」

「フレーム リレー DLCI と ATM AAL5SNAP とのブリッジ型インターワーキングの設定」

ASR1000 での GEC(VPWS)の xconnect サポート

3.6.0S

GEC(VPWS)で xconnect をサポートする ASR 1000 の機能により、サービス プロバイダーは、単一の統合されたパケットベースのネットワーク インフラストラクチャである Cisco MPLS ネットワークを使用して、既存のデータ リンク レイヤ(レイヤ 2)ネットワークを持つカスタマー サイト間を接続できます。別々のネットワーク管理環境による別々のネットワークに代わり、サービス プロバイダーは、MPLS バックボーン上でレイヤ 2 接続が可能になります。

Cisco IOS XE Release 3.6.0S では、この機能が ASR 1000 シリーズ アグリゲーション サービス ルータに実装されました。

この機能に関する詳細については、次の各項を参照してください。

「Virtual Private Wire Service のギガビット EtherChannel」

「Virtual Private Wire Service のギガビット EtherChannel の設定」

用語集

ATM:Asynchronous Transfer Mode(非同期転送モード)。スイッチド ネットワークを介して固定長パケットを送信するデータ転送方式。高速で高信頼性のパケット転送が可能なこの方式は、音声、ビデオ、およびデータの伝送に適しています。

AToM:Any Transport over MPLS。AToM は、MPLS バックボーン上でレイヤ 2 パケットを転送するソリューションです。AToM 機能を使用するサービス プロバイダーは、単一の統合されたパケットベースのネットワーク インフラストラクチャである Cisco MPLS ネットワークを使用して、既存のデータ リンク レイヤ(レイヤ 2)ネットワークを持つカスタマー サイト間を接続できます。別々のネットワーク管理環境による別々のネットワークに代わり、サービス プロバイダーは、MPLS バックボーン上でレイヤ 2 接続が可能になります。

EoMPLS:Ethernet over MPLS。このテクノロジーは、既存の MPLS バックボーン ネットワークを活用し、カスタマー サイトとのイーサネット接続に基づいて透過型 LAN サービスを提供します。

GEC:ギガビット EtherChannel。ギガビット/秒の伝送速度を実現する高性能イーサネット技術。スイッチ、ルータ インターフェイス、およびサーバの各リンクにわたって、レジリエンシー(復元力)とロード シェアリング機能を備えた柔軟でスケーラブルな帯域幅を提供します。チャネルあたり最大で 8 つのリンクをサポートします。

MPLS:マルチプロトコル ラベル スイッチング。あるネットワーク ノードから次のネットワーク ノードにデータを伝送する高性能な通信ネットワークのメカニズム。MPLS を使用すると、離れたノード間の仮想リンクを容易に作成できます。これにより、さまざまなネットワーク プロトコルのパケットをカプセル化できます。

VPLS:Virtual Private LAN Service(バーチャル プライベート LAN サービス)。IP ネットワークと MPLS ネットワークを経由してイーサネット ベースのマルチポイントツーマルチポイントの通信を実現する方法。