Cisco ASR 1000 シリーズ アグリゲーション サービス ルータ ソフトウェア コンフィギュレーション ガイド
ブリッジ ドメイン インターフェイスの設定
ブリッジ ドメイン インターフェイスの設定
発行日;2013/01/07 | 英語版ドキュメント(2012/12/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

ブリッジ ドメイン インターフェイスの設定

機能情報の確認

内容

ブリッジ ドメイン インターフェイスの制限

ブリッジ ドメイン インターフェイスに関する情報

イーサネット仮想回線の概要

ブリッジ ドメイン インターフェイスのカプセル化

MAC アドレスの割り当て

IP プロトコルのサポート

IP 転送のサポート

パケット転送

レイヤ 2 から 3

レイヤ 3 からレイヤ 2

ブリッジ ドメインとブリッジ ドメイン インターフェイスのステートをリンクする

BDI の初期状態

BDI のリンク状態

ブリッジ ドメイン インターフェイスの統計情報

ブリッジ ドメイン インターフェイスの作成または削除

ブリッジ ドメイン インターフェイスのスケーラビリティ

ブリッジ ドメイン インターフェイスの設定方法

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

ブリッジ ドメイン インターフェイスの機能情報

ブリッジ ドメイン インターフェイスの設定

Cisco ASR 1000 シリーズ アグリゲーション サービス ルータは、レイヤ 3 IP にレイヤ 2 イーサネット セグメントをパッケージングするためのブリッジ ドメインのインターフェイス(BDI)機能をサポートします。

機能情報の確認

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「ブリッジ ドメイン インターフェイスの機能情報」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

ブリッジ ドメイン インターフェイスの制限

ブリッジ ドメイン インターフェイスに関連する制約事項は次のとおりです。

システムごとにサポートされるブリッジ ドメイン インターフェイスは 4096 のみです。

ブリッジ ドメイン インターフェイスは次の機能をサポートしません。

PPP over Ethernet(PPPoE)

ホットスタンバイ ルータ プロトコル(HSRP)

仮想ルータ冗長プロトコル(VRRP)

双方向フォワーディング検出(BFD)プロトコル

Netflow

Network-Based Application Recognition(NBAR)または Advanced Video Coding(AVC)

Multicast

BDI の場合、最大伝送単位(MTU)サイズは 1500 および 9216 バイトの間で設定できます。

ブリッジ ドメイン インターフェイスに関する情報

ブリッジ ドメイン インターフェイスは、レイヤ 2 ブリッジ型ネットワークとレイヤ 3 のルーテッド ネットワーク トラフィック間のトラフィックの双方向フローを許可する論理インターフェイスです。ブリッジ ドメイン インターフェイスは、ブリッジ ドメインと同じインデックスによって識別されます。各ブリッジ ドメインは、レイヤ 2 ブロードキャスト ドメインを表します。ブリッジ ドメインに関連付けることができるブリッジ ドメイン インターフェイスは、1 つだけです。

ブリッジ ドメイン インターフェイスは次の機能をサポートします。

IP 終了

レイヤ 3 VPN の終了

アドレス解決プロトコル(ARP)、G-ARP および P-ARP の処理

MAC アドレスの割り当て

ブリッジ ドメイン インターフェイスを設定する前に、次の概念を理解しておく必要があります:

「イーサネット仮想回線の概要」

「ブリッジ ドメイン インターフェイスのカプセル化」

「MAC アドレスの割り当て」

「IP プロトコルのサポート」

「IP 転送のサポート」

「パケット転送」

「ブリッジ ドメイン インターフェイスの統計情報」

ーサネット仮想回線の概要

イーサネット仮想回線(EVC)は、プロバイダーがお客様に提供しているレイヤ 2 サービスの単一インスタンスのエンドツーエンド表現です。さまざまなパラメータが統合されて、サービスが提供されます。シスコ EVC フレームワークでは、ブリッジ ドメインは、サービス インスタンスと呼ばれているレイヤ 2 インターフェイス(1 つまたは複数)で構成されます。サービス インスタンスは、あるルータ上のあるポート上で EVC をインスタンス化したものです。サービス インスタンスは、設定に基づいてブリッジ ドメインに関連付けられます。

着信フレームは、次の基準に基づいてサービス インスタンスとして分類できます。

シングル 802.1Q VLAN タグ、優先度タグ付き、または 802.1ad VLAN タグ

両 QinQ(内部および外部)VLAN タグ、または 802.1ad S-VLAN と C-VLAN タグの両方

外部 802.1p CoS ビット、内部 802.1p CoS ビット、またはその両方

ペイロード イーサネット タイプ(5 つの選択肢をサポート:IPv4、IPv6、PPPoE-all、PPoE-discovery、PPPoE-session)

サービス インスタンスは、他のマッピング基準もサポートします。

[Untagged]:802.1Q または 802.1ad ヘッダがないすべてのフレームにマッピングします。

[Default]:すべてのフレームにマッピングします。

EVC アーキテクチャの詳細については、次の URL の『 Carrier Ethernet Configuration Guide 』の「Configuring Ethernet Virtual Connections on the Cisco ASR 1000 Router」の章を参照してください。

http://www.cisco.com/en/US/docs/ios-xml/ios/cether/configuration/xe-3s/ce-ether-vc-infra-xe.html

ブリッジ ドメイン インターフェイスのカプセル化

EVC はブリッジ ドメインに存在する各イーサネット フロー ポイント(EFP)で様々なカプセル化を使用する機能を提供します。パケットは異なるカプセル化を設定した 1 つまたは複数の EFP から出力されている可能性があるため、BDI 出力ポイントは出力パケットのカプセル化を認識しないことがあります。

ブリッジ ドメインでは、すべての EFP で異なるカプセル化がある場合、BDI のタグ付けを解除する必要があります(802.1Q タグなしを使用)。EFP でブリッジ ドメインのすべてのトラフィック(ポップまたはプッシュ)をカプセル化します。ブリッジ ドメインのトラフィックのカプセル化を可能にするためには、各 EFP で rewrite を設定します。

ブリッジ ドメインでは、すべての EFP で同じカプセル化がある場合は、 encapsulation コマンドを使用して BDI 上にカプセル化を設定します。BDI でのカプセル化をイネーブルにすると、タグのプッシングまたはポッピングが有効になり、それにより EFP で rewrite コマンドを設定する必要がなくなります。BDI でのカプセル化の設定の詳細については、 「ブリッジ ドメイン インターフェイスの設定方法」 を参照してください。

MAC アドレスの割り当て

Cisco ASR 1000 シャーシ上のすべてのブリッジ ドメインは、同じ MAC アドレスを共有します。最初のブリッジ ドメイン インターフェイスに MAC アドレスが割り当てられます。その後、同じ MAC アドレスが、そのブリッジ ドメインで作成されたすべてのブリッジ ドメイン インターフェイスに割り当てられます。


mac-address コマンドを使用して、ブリッジ ドメイン インターフェイスにスタティック MAC アドレスを設定できます。


IP プロトコルのサポート

ブリッジ ドメイン インターフェイスは、Cisco ASR 1000 シリーズ アグリゲーション サービス ルータをイネーブルにし、次の IP 関連プロトコルのレイヤ 2 ブリッジ ドメインのレイヤ 3 のエンド ポイントとして機能します。

ARP

DHCP

HTTP

ICMP

NTP

RARP

SNMP

TCP

Telnet

TFTP

UDP

IP 転送のサポート

ブリッジ ドメイン インターフェイスは次の IP 転送機能をサポートします。

IPv4 の入力および出力アクセス コントロール リスト(ACL)

IPv4 の入力および出力 QoS ポリシー。ブリッジ ドメイン インターフェイスの入力および出力サービス ポリシーでサポートされる動作は次のとおりです。

分類

マーキング

ポリシング

IPv4 L3 VRF

ケット転送

ブリッジ ドメイン インターフェイスはレイヤ 2 およびレイヤ 3 ネットワーク インフラ間のブリッジングおよび転送サービスを提供します。

レイヤ 2 から 3

レイヤ 2 ネットワークからレイヤ 3 ネットワークへのパケット フローの間に、着信パケットの宛先 MAC アドレスがブリッジ ドメイン インターフェイスの MAC アドレスと一致するか、宛先 MAC アドレスがマルチキャスト アドレスの場合、パケットまたはパケットのコピーがブリッジ ドメイン インターフェイスに転送されます。


) MAC アドレス ラーニングは、ブリッジ ドメイン上のインターフェイスで実行できません。



) ブリッジ ドメインでは、未知のユニキャスト フレームをフラッディングすると、ブリッジ ドメインのインターフェイスは含まれません。


レイヤ 3 からレイヤ 2

パケットがルータの物理インターフェイスのレイヤ 3 に到達すると、ルート検索アクションが実行されます。ルート検索がブリッジ ドメイン インターフェイスに向かうと、ブリッジ ドメイン インターフェイスはレイヤ 2 カプセル化を追加し、対応するブリッジ ドメインにフレームを転送します。バイト カウンタが更新されます。

ブリッジ ドメイン インターフェイスが属するブリッジ ドメインでのレイヤ 2 検索中に、ブリッジ ドメインは、宛先 MAC アドレスに基づいて適切なサービス インスタンスにパケットを転送します。

ブリッジ ドメインとブリッジ ドメイン インターフェイスのステートをリンクする

ブリッジ ドメイン インターフェイスはレイヤ 3 のルーティング可能な IOS インターフェイスおよびブリッジ ドメインのポートとして機能します。ブリッジ ドメイン インターフェイスとブリッジ ドメインのいずれも、個々の管理状態で動作します。

ブリッジ ドメイン インターフェイスをシャットダウンすると、レイヤ 3 データ サービスは停止しますが、関連するブリッジ ドメインの状態は上書きされず、影響を受けません。

ブリッジ ドメインをシャットダウンすると、サービス インスタンスやブリッジ ドメイン インターフェイスを含むすべての関連メンバへのレイヤ 2 転送が停止します。ブリッジ ドメインの動作状態は、関連するサービス インスタンスによって影響を受けます。ブリッジ ドメイン インターフェイスは、関連するサービス インスタンスの 1 つが起動しない限り、動作することはできません。


) ブリッジ ドメイン インターフェイスは内部インターフェイスであるため、ブリッジ ドメイン インターフェイスの動作状態はブリッジ ドメインの動作状態には影響しません。


BDI の初期状態

BDI 最初の管理ステートは、BDI の作成方法によって異なります。BDI がスタートアップ コンフィギュレーションのブート時に作成された場合、BDI のデフォルトの管理ステートは、スタートアップ コンフィギュレーションに shutdown コマンドが含まれている場合を除き、このステートを維持します。この動作は、他のすべてのインターフェイスと一致します。BDI がユーザによって AT コマンド プロンプトで動的に作成される場合、デフォルトの管理ステートはダウンです。

BDI のリンク状態

すべての Cisco IOS インターフェイスと同様に BDI は、管理上のダウン状態、動作上のダウン状態、アップ状態の 3 種類のステートからなるリンク状態を維持します。BDI のリンク状態は、対応するユーザによって設定された BDI 管理状態セットおよびインターフェイス ステートの下位レベルの障害表示の状態の 2 つの独立する入力から得られます。BDI のリンク状態は、2 つの入力の状態に基づいて定義されます。

障害表示の状態
BDI の管理状態

--

シャットダウン
シャットダウンなし
No faults asserted

Admin-down

Up

At least one fault asserted

Admin-down

Operationally-down

ブリッジ ドメイン インターフェイスの統計情報

ブリッジ ドメイン インターフェイスなどの仮想インターフェイスの場合は、プロトコル カウンタは QFP から定期的に検索されます。

パケットがレイヤ 2 ブリッジ ドメイン ネットワークからドメインのインターフェイスを介してレイヤ 3 のルーティング ネットワークに流れると、パケットはブリッジ ドメイン インターフェイスの入力パケットおよびバイトとして処理されます。パケットがレイヤ 3 インターフェイスに到達し、ブリッジ ドメイン インターフェイスを介してレイヤ 2 ブリッジ ドメインに転送されると、パケットは出力パケットおよびバイトとして処理され、カウンタが適宜更新されます。

BDI はすべての Cisco IOS インターフェイスで、ケースとしてレイヤ 3 パケット カウンタの標準セットを維持します。レイヤ 3 のパケット カウンタを表示するには、show interface コマンドを使用します。

カウンタの表記法は、レイヤ 3 クラウドに関連します。たとえば、input はレイヤ 2 BD からレイヤ 3 クラウドに入るトラフィックを示し、output はレイヤ 3 クラウドからレイヤ 2 BD に向かうトラフィックを示します。

BDI ステータスの統計情報を表示するには、 show interfaces accounting コマンドを使用します。送受信されるパケットおよびバイト全体のカウントを表示するには、 show interface <if-name> コマンドを使用します。

ブリッジ ドメイン インターフェイスの作成または削除

Cisco IOS ルータのインターフェイスまたはサブインターフェイスを定義する場合は、名前を付け、どのように IP アドレスに割り当てられるかを指定します。システムへブリッジ ドメインを追加する前にブリッジ ドメイン インターフェイスを作成でき、この新しいブリッジ ドメイン インターフェイスは、関連するブリッジ ドメインの設定後にアクティブになります。


) ブリッジ ドメイン インターフェイスが作成されると、ブリッジ ドメインが自動的に作成されます。


ブリッジ ドメイン インターフェイスとブリッジ ドメインの両方が作成されると、システムは、ブリッジ ドメインとブリッジ ドメイン インターフェイスのペアをマッピングするために必要なアソシエーションを保持します。

ブリッジ ドメインとブリッジ ドメイン インターフェイスのマッピングはシステムに保持されます。ブリッジ ドメイン インターフェイスは、アソシエーションを示すために関連するブリッジ ドメインのインデックスを使用されます。

ブリッジ ドメイン インターフェイスのスケーラビリティ

表 6 に、Cisco ASR 1000 シリーズのアグリゲーション サービス ルータのフォワーディング プロセッサに基づいてブリッジ ドメイン インターフェイスのスケーラビリティ番号を一覧表示します。

 

表 6 Cisco ASR 1000 シリーズのアグリゲーション サービス ルータのフォワーディング プロセッサに基づいたブリッジ ドメイン インターフェイスのスケーラビリティ番号

説明
ASR1000-ESP5、
ASR 1001、
ASR 1002-F(ESP2.5)
ASR1000-ESP10、
ASR1000-ESP10-N、
ASR1000-ESP20
ASR1000-ESP40

ルータごとのブリッジ ドメイン インターフェイスの最大数

4096

4096

4096

ブリッジ ドメイン インターフェイスの設定方法

ブリッジ ドメイン インターフェイスを設定するには、次の手順を実行します。

手順の概要

1. configure terminal

2. interface BDI interface number

3. encapsulation encapsulation dot1q <first-tag> [second-dot1q <second-tag>]

4. ip address ip-address mask

5. mac-address {mac-address}

6. no shut

7. shut

手順の詳細

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface BDI {interface number}

 

Router(config)# interface BDI3

Cisco ASR 1000 シリーズ アグリゲーション サービス ルータで、ブリッジ ドメイン インターフェイスを指定します。

ステップ 3

encapsulation encapsulation dot1q <first-tag> [second-dot1q <second-tag>]

 

Router(config-if)#encapsulation dot1Q 1 second-dot1q 2

カプセル化タイプを定義します。

例では、カプセル化タイプとして dot1q を定義しています。

ステップ 4

ip address ip-address mask

 

または

ipv6 address { X:X:X:X::X link-local | X:X:X:X::X / prefix [ anycast | eui-64 ] | autoconfig [ default ]}

 

Router(config-if)# ip address 2.2.2.1 255.255.255.0

ブリッジ ドメイン インターフェイスの IPv4 または IPv6 アドレスを指定します。

ステップ 5

mac-address {mac-address}

 

Router(config-if)# mac-address 1.1.3

ブリッジ ドメイン インターフェイスの MAC アドレスを指定します。

ステップ 6

no shut
 
hostname(config-if)# no shut

Cisco ASR 1000 シリーズ アグリゲーション サービス ルータで、ブリッジ ドメイン インターフェイスをイネーブルにします。

ステップ 7

shut
 
hostname(config-if)# shut

Cisco ASR 1000 シリーズ アグリゲーション サービス ルータで、ブリッジ ドメイン インターフェイスをディセーブルにします。

次に、IP アドレス 2.2.2.1 255.255.255.0 でブリッジ ドメイン インターフェイスを設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface BDI3
Router(config-if)# encapsulation dot1Q 1 second-dot1q 2
Router(config-if)# ip address 2.2.2.1 255.255.255.0
Router(config-if)# mac-address 1.1.3
Router(config-if)# no shut
Router(config-if)# exit
Router(config)#
 

show コマンドを使用して、ブリッジ ドメイン インターフェイスの設定情報を表示できます。

show interfaces bdi: 対応する BDI の設定情報の概要を表示します。

例:

Router# show interfaces BDI3
 

show platform software interface fp active name :フォワーディング プロセッサのブリッジ ドメイン インターフェイスの設定を表示します。

例:

Router# show platform software interface fp active name BDI4
 

show platform hardware qfp active interface if-name: データ パスのブリッジ ドメイン インターフェイス コンフィギュレーションを表示します。

例:

Router# show platform hardware qfp active interface if-name BDI4
 

次の debug コマンドを使用してブリッジ ドメイン インターフェイスの設定をデバッグできます。

debug platform hardware qfp feature :Cisco Quantum Flow Processor(QFP)機能をデバッグします。

次に、すべてのクライアントの l2bd をデバッグする例を示します。

Router# debug platform hardware qfp active feature l2bd client all

選択した CPP L2BD Client のデバッグがオンになります。

 

platform trace runtime process forwarding-manager module :Forwarding Manager プロセスの Forwarding Manager Route Processor および Embedded Service Processor のトレース メッセージをイネーブルにします。

次の例では、スロット 0 の ESP プロセッサの Forwarding Manager フォワーディング プロセッサ モジュールのトレース レベルを情報トレース レベル(info)に設定します。

Router(config)# platform trace runtime slot F0 bay 0 process forwarding-manager module interfaces level info
 

platform trace boottime process forwarding-manager module interfaces :ブートアップ中の Route Processor Forwarding Manager プロセスの Forwarding Manager Route Processor および Embedded Service Processor のトレース メッセージをイネーブルにします。

次の例では、スロット R0 の ESP プロセッサの Forwarding Manager フォワーディング プロセッサ モジュールのトレース レベルを情報トレース レベル(max)に設定します。

Router(config)# platform trace boottime slot R0 bay 1 process forwarding-manager forwarding-manager level max
 

各コマンドに使用できるコマンドおよびオプションの詳細については、次の URL で『 Cisco IOS Configuration Fundamentals Command Reference Guide 』を参照してください。

http://www.cisco.com/en/US/docs/ios/fundamentals/command/reference/cf_book.html

その他の参考資料

関連資料

関連項目
参照先

Cisco ASR 1000 シリーズ アグリゲーション サービス ルータでのイーサネット仮想接続の設定

『Carrier Ethernet Configuration Guide, Cisco IOS XE Release 3S』

EVC Quality of Service

http://www.cisco.com/en/US/docs/ios/ios_xe/qos/configuration/guide/qos_evc_xe.html

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

標準

標準
タイトル

なし

--

MIB

MIB
MIB のリンク

なし

選択されたプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに対応する MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

ブリッジ ドメイン インターフェイスの機能情報

表 7 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 7 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 7 ブリッジ ドメイン インターフェイスの機能情報

機能名
リリース
機能情報

ブリッジ ドメイン インターフェイスの設定

Cisco IOS XE 3.2.0S

この機能は、Cisco ASR 1000 シリーズのアグリゲーション サービス ルータで導入されました。

ブリッジ ドメイン インターフェイスの設定

Cisco IOS XE 3.7.0S

この機能は、Cisco ASR 1000 シリーズの集約サービス ルータで更新されました。この機能のために次の項が更新されました。

「ブリッジ ドメイン インターフェイスに関する情報」