QoS:ポリシングおよびシェーピング コンフィギュレーション ガイド Cisco IOS XE Release 3S(Cisco ASR 1000)
ATM VC での PPP セッション キューイング
ATM VC での PPP セッション キューイング

目次

ATM VC での PPP セッション キューイング

ATM VC での PPP セッション キューイング機能を使用すると、ユーザ指定のレートに応じた PPP over Ethernet over ATM(PPPoEoA)セッションのシェーピングおよびキューイングを行うことができます。 ATM VC に存在する複数のセッションに Quality of Service(QoS)ポリシーを適用することも、それらのセッションの一部にのみ QoS ポリシーを適用することもできます。 ルータは、加入者のデジタル加入者線アクセス マルチプレクサ(DSLAM)への接続が輻輳状態にならないように、VC で PPPoEoA トラフィックに使用されるすべての帯域幅の合計をシェーピングします。 キューイング関連の機能は、PPPoEoA セッションで実行される各種アプリケーションに対してさまざまなサービス レベルを提供します。

モジュラ Quality of Service(QoS)コマンドライン インターフェイス(MQC)を使用してルータでセッション シェーピングを直接設定するには、ネストされた 2 つのレベルからなる階層型サービス ポリシーを使用します。 階層型ポリシーは次のコンポーネントからなります。

  • 子ポリシー:priority、bandwidth、police などの QoS コマンドを使用して QoS アクションを定義します。

  • 親ポリシー:shape コマンドまたは bandwidth remaining ratio コマンド、あるいはこの両方のコマンドを含む class-default クラスだけがこれに含まれます。
    • shape コマンド:特定のアルゴリズムに従って、指定されたビット レートに応じてセッション トラフィックをシェーピングします。
    • bandwidth remaining ratio コマンド:輻輳中にセッションに割り当てる未使用帯域幅の量を決定するためにルータで使われる ratio 値を指定します。

(注)  


ATM VC での PPP セッション キューイングは、PPP 終端集約(PTA)および L2TP アクセス コンセントレータ(LAC)の両方の設定で機能します。


次の図に、ATM VC での PPP セッション キューイングを示します。



機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

ATM VC での PPP セッション キューイングの前提条件

  • PPPoEoA セッションがイネーブルになっている必要があります。

  • class-map コマンドを使用してトラフィック クラスを作成し、トラフィックの分類に使われる一致基準を指定します。

  • RADIUS を使用した動的 PPPoEoA セッション キューイングでは、次の前提条件があります。
    • ルータ上で認証、許可、およびアカウンティング(AAA)をイネーブルにすること。
    • 動的 QoS 対応 RADIUS サーバを設定すること。
    • RADIUS サーバ上に加入者のユーザ プロファイルを作成すること。

ATM VC での PPP セッション キューイングに関する制約事項

  • シェーピングされない VC(つまりピーク セル レート(PCR)や持続セル レート(SCR)が指定されていない VC)に PPP セッション キューイングを設定することはできません。

  • セッション キューイング ポリシーが適用される VC を、シェーピング対象の仮想パス(VP)に含めることはできません。

  • 同じ ATM カテゴリ(たとえばシェーピング対象の未指定ビット レート(UBR))に、高帯域幅 VC と低帯域幅 VC の両方が含まれている場合、SAR メカニズムが原因で高帯域幅 VC のスループットが低下する可能性があります。 回避策は、低帯域幅 VC と高帯域幅 VC にそれぞれ異なる ATM クラスを使用することです。 たとえば、低帯域幅 VC をシェーピング対象 UBR として設定し、高帯域幅 VC を可変ビット レート非リアルタイム(VBR-nrt)または固定ビット レート(CBR)として設定します。

  • CLASS-BASED QOS MIB には、セッションに適用されるサービス ポリシーの統計情報が含まれません。

  • RADIUS アカウンティングには、キューイング統計情報が含まれません。

ATM VC での PPP セッション キューイングについて

ATM VC での PPP セッションに対する QoS ポリシーの動的適用

ルータでは、RADIUS を使用して PPPoEoA セッションに QoS ポリシー マップを動的に適用できます。 実際にはルータで QoS ポリシーが設定されますが、RADIUS で次の属性/値(AV)ペアを設定することで、セッションに動的に適用するポリシー マップの名前を指定できます。

"ip:sub-qos-policy-in=<name of the QoS policy in ingress direction>"
"ip:sub-qos-policy-out=<name of egress policy>"

これらの AV ペアは、次のいずれかの RADIUS プロファイルの中で定義します。

  • ユーザ プロファイル:RADIUS サーバのユーザ プロファイルには、ユーザに適用されるポリシー マップ名を識別するエントリが含まれています。 ポリシー マップ名は、セッションの認可後に RADIUS がルータにダウンロードするサービスです。

  • サービス プロファイル:RADIUS サーバ上のサービス プロファイルはセッション ID と AV ペアを指定します。 セッション ID として、たとえばセッションの IP アドレスが可能です。 AV ペアは、ユーザが属するサービス(ポリシー マップ名)を定義します。

ポリシー サーバからサービス ログイン要求を受信すると、RADIUS は、ログイン済み加入者用のサービスを有効にするために、ルータに認可変更(CoA)要求を送信します。 認可に成功すると、ルータは ip:sub-qos-policy-in[out]= AV ペア を使用して RADIUS からポリシー マップ名をダウンロードし、QoS ポリシーを PPPoEoA セッションに適用します。 サービス ポリシーにはキューイング関連のアクションが含まれるため、ルータは適切なクラス キューを設定します。


(注)  


なおルータでは RADIUS ベンダー固有の属性(VSA)38(Cisco-Policy-Down および Cisco-Policy-Up)もサポートされますが、QoS ポリシー定義には ip:sub-qos-policy-in[out]= AV ペアを使用することをお勧めします。


PPP セッション キューイングの継承

PPP セッションには、親インターフェイスのキューが継承されるか、あるいは独自のキューが割り当てられます。 セッション キューイング設定の対象となる各 PPPoEoA セッションには、独自のキュー セットが割り当てられます。

次の表に、ルータがセッション トラフィックを送信する宛先のキューを示します。

表 1 PPP セッションのキューの継承

キューイング ポリシー

セッション トラフィックに使用されるキュー

ポリシーなし

VC のデフォルト キュー

VC に適用

VC キュー

セッションに適用

セッションのキュー

PPP セッション キューイングをサポートするインターフェイス

ルータはアウトバウンド トラフィックに関してのみ、シェーピングされた ATM VC での PPP セッション キューイングをサポートします。

インバウンド ATM インターフェイスでの PPP セッション キューイングはサポートされません。

混合設定とキューイング

混合設定とは、すべてのセッションに QoS が適用されるわけではない設定のことです。 一部の VC では、キューイング ポリシーが VC レベルで適用される一方、他の VC ではキューイング ポリシーがセッションで適用されます。 一部のセッションにはポリシーがまったく適用されません。 したがって、ルータは階層型キューイング フレームワーク(HQF)を使用して次のようにトラフィックを誘導します。

  • VC およびセション レベルで適用されるキューイング ポリシーがない場合、ルータは、VC 上のポリシング専用ポリシーが適用されるセッションからのトラフィックも、ポリシーが適用されないセッションからのトラフィックも含め、VC 上のすべてのトラフィックをデフォルト キューに送信します。

  • キューイング ポリシーが VC レベルで適用されるが、セッション レベルでは適用されない場合、ルータは VC 上のキューイング ポリシーに関連付けられたキューにトラフィックを送信します。

  • キューイング ポリシーが VC 上の一部のセッションにだけ適用され、残りのセッションには適用されない場合、ルータは、ポリシング専用ポリシーが適用されるトラフィックまたはポリシーが適用されないトラフィックを VC のデフォルト キューに送信します。 キューイング ポリシーが適用されるトラフィックは、セッションに適用されるキューイング ポリシーに関連付けられたキューに送信されます。

帯域幅モードおよび ATM ポート オーバーサブスクリプション

ATM ポートは、予約帯域幅モードまたは共有帯域幅モードで動作可能です。

ポートのサブスクリプションが超過していなければ(つまり、ポート上のすべての VC の帯域幅合計がポート帯域幅を下回っている場合)、ポートは予約帯域幅モードで動作し、ポート上の VC ごとに一定の帯域幅が予約されます。 VC に割り当てられた帯域幅のすべてを使用しないとしても、未使用の帯域幅はポート上の VC 間で共有されません。

ATM ポートのサブスクリプションが超過している場合(つまり、ポート上のすべての VC の帯域幅合計がポート帯域幅を上回っている場合)、ポートは共有帯域幅モードで動作します。 このモードでは、ポート上の他の VC が未使用帯域幅を再使用できます。その際、それぞれの VC のシェーピング レートが上限となります(VC 上のトラフィックはその VC のシェーピング レートを超過できません)。

セッション レベルのオーバーサブスクリプション

セッション レベルのオーバーサブスクリプションは、セッション トラフィックのシェーピング後に、セッション トラフィック合計がサブインターフェイス シェープ レートを超過した場合に発生します。 すべての優先トラフィックを考慮した後、ルータは、セッションに適用されるポリシーの親ポリシーで設定された bandwidth remaining ratio コマンドで指定される値に従って、VC 上の残りの帯域幅をそれぞれのセッションに配分します。 bandwidth remaining ratio コマンドが親ポリシーで指定されていない場合、ルータはデフォルト比率 1 を使用します。

ATM VC での PPP セッション キューイングの設定方法

仮想テンプレートを使用した PPP セッション キューイングの設定

仮想テンプレートは論理インターフェイスであり、その設定では、特定の目的、ユーザ固有の設定情報、ルータに依存する情報に関する汎用設定情報を指定できます。 インターフェイスで仮想テンプレートを設定し、その仮想テンプレートに QoS ポリシー マップを適用します。 仮想テンプレートは、ポリシー マップで指定された QoS 機能を継承します。 ルータはインターフェイスでセッションを確立するときに、セッション用に作成される仮想アクセス インターフェイス(VAI)に対して、仮想テンプレート設定で指定された QoS 機能を適用します。これには、仮想テンプレートに関連付けられたポリシー マップで指定された QoS 機能も含まれます。

ATM インターフェイスで設定されたブロードバンド集約グループ(bba-group)は、ルータが QoS ポリシーをセッションに適用するために使用する仮想テンプレートを参照します。 セッションが ATM インターフェイスに到達すると、ルータはセッション用の仮想アクセス インターフェイス(VAI) を作成して、仮想テンプレートに関連付けられたポリシーをセッションに適用します。

仮想テンプレートを使用して PPPoEoA セッション キューイングを設定するには、次の設定作業を行います。

階層型 QoS ポリシーの設定

手順の概要

    1.    enable

    2.    configure terminal

    3.    policy-map policy-map-name

    4.    class class-map-name

    5.    priority level level

    6.    police bps [burst-normal burst-max] [conform-action action] [exceed-action action] violate-action action

    7.    set cos value

    8.    bandwidth remaining ratio

    9.    exit

    10.    policy-map policy-map-name

    11.    class class-default

    12.    bandwidth remaining ratio

    13.    shape [average] mean-rate[burst-size] [excess-burst-size]

    14.    service-policy policy-map-name


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。

     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 policy-map policy-map-name


    例:
    Router(config)# policy-map policy-map-name
     

    子ポリシーを作成または変更します。 ポリシーマップ コンフィギュレーション モードを開始します。

    policy-map-name は子ポリシー マップの名前です。

     
    ステップ 4 class class-map-name


    例:
    Router(config-pmap)# class class-map-name
     

    指定するトラフィック クラスをポリシー マップに割り当てます。 ポリシーマップ クラス コンフィギュレーション モードを開始します。

    class-map-name は、設定済みのクラス マップの名前です。これは QoS アクションを定義する対象となるトラフィック クラスです。

    子ポリシー マップに含めるトラフィック クラスごとに、ステップ 2 ~ 6 を繰り返します。

     
    ステップ 5 priority level level

    例:
    Router(config-pmap-c)# priority level level
     

    (オプション)複数レベルの絶対優先サービス モデルを定義します。 特定のレベルの優先サービスが設定されたトラフィック クラスをイネーブルにすると、その特定のレベルの優先サービスがイネーブルにされたすべてのトラフィックに、単一の優先キューが関連付けられることになります。

    level は、特定の優先レベルを表す番号です。 有効な値は、1(高プライオリティ)~ 4(低プライオリティ)です。 デフォルトは 1 です。

     
    ステップ 6 police bps [burst-normal burst-max] [conform-action action] [exceed-action action] violate-action action


    例:
    Router(config-pmap-c)# police bps [burst-normal] [burst-max] [conform-action action] [exceed-action action] [violate-action  action]
     

    (オプション)トラフィック ポリシングを設定します。

    bps は、ビット/秒単位の平均レートです。 有効値は 8000 ~ 200000000 です。

    (オプション)burst-normal は、バイト単位のノーマル バースト サイズです。 有効値は 1000 ~ 51200000 です。 デフォルトのノーマル バースト サイズは 1500 バイトです。

    (オプション)burst-max は超過バースト サイズ(バイト)です。 有効値は 1000 ~ 51200000 です。

    (オプション)conform-action action は、レート制限に適合するパケットに対して実行するアクションを指定します。

    (オプション)exceed-action action は、レート制限を超過するパケットに対して実行するアクションを指定します。

    (オプション)violate-action action は、ノーマルおよび最大バースト サイズに違反するパケットに対して実行するアクションを指定します。

     
    ステップ 7 set cos value

    例:
    Router(config-pmap-c)# set cos value
     

    (オプション)送信パケットのレイヤ 2 サービス クラス(CoS)値を設定します。

    値は、特定の IEEE 802.1Q CoS 値(0 ~ 7)です。

     
    ステップ 8 bandwidth remaining ratio

    例:
    Router(config-pmap-c)# bandwidth remaining ratio
     

    (オプション)クラス レベルまたはサブインターフェイス レベルのキューの帯域幅余剰比率を指定します。輻輳時には、非優先キューに割り当てる余剰帯域幅(優先トラフィックによって使用されていない帯域幅)の量を判断するために、この比率が使用されます。

    ratio は、他のサブインターフェイスまたはキューと比較したこのサブインターフェイスまたはキューの相対的な重みを指定します。 有効な値は 1 ~ 1000 です。

     
    ステップ 9 exit

    例:
    Router(config-pmap-c)# exit
     

    ポリシーマップ クラス コンフィギュレーション モードを終了します。

     
    ステップ 10 policy-map policy-map-name


    例:
    Router(config-pmap)# policy-map policy-map-name
     

    親ポリシーを作成または変更します。

    policy-map-name は、親ポリシー マップの名前です。

     
    ステップ 11 class class-default


    例:
    Router(config-pmap)# class class-default
     

    親 class-default クラスを設定または変更します。

    親ポリシーの class-default クラスは 1 つだけ設定できます。 他のトラフィック クラスは設定しないでください。

     
    ステップ 12 bandwidth remaining ratio

    例:
    Router(config-pmap-c)# bandwidth remaining ratio
     

    (オプション)クラス レベルまたはサブインターフェイス レベルのキューの帯域幅余剰比率を指定します。輻輳時には、非優先キューに割り当てる余剰帯域幅(優先トラフィックによって使用されていない帯域幅)の量を判断するために、この比率が使用されます。

    ratio は、他のサブインターフェイスまたはキューと比較したこのサブインターフェイスまたはキューの相対的な重みを指定します。 有効な値は 1 ~ 1000 です。

     
    ステップ 13 shape [average] mean-rate[burst-size] [excess-burst-size]


    例:
                
                  Router(config-pmap-c)# shape [average] mean-rate [burst-size] [excess-burst-size]
     

    指示されたビット レートにトラフィックをシェーピングし、ATM オーバーヘッド アカウンティングをイネーブルにします。

    (オプション)average は、各インターバルで送信される最大ビット数を指定する認定バースト(Bc)です。 このオプションがサポートされるのは Performance Routing Engine 3(PRE3)だけです。

    mean-rate(平均レート)は、認定情報レート(CIR)とも呼ばれます。 トラフィックのシェーピングに使用されるビット レートを bps 単位で指定します。 このコマンドを逆方向明示的輻輳通知(BECN)の近似値と併用すると、ビット レートは許容ビット レート範囲の上限値になります。

    (オプション)burst-size は、測定インターバル内のビット数(Bc)です。

    (オプション)excess-burst-size は、Be の超過が許可される受け入れ可能なビット数です。

     
    ステップ 14 service-policy policy-map-name


    例:
    Router(config-pmap-c)# service-policy policy-map-name
     

    親の class-default クラスに子ポリシーを適用します。

    policy-map-name は、ステップ 1 で設定した子ポリシー マップの名前です。

     

    次に、階層型 QoS ポリシーを設定する例を示します。 この例で、子ポリシーは「Premium」と「Silver」という 2 つのトラフィック クラスに関する QoS 機能を設定します。 Premium トラフィックが優先され、40 パーセントでポリシングされます。 ルータは Premium トラフィックの IP precedence レベルを 3 に設定します。 Silver トラフィックは 80000 bps でポリシングされ、IP precedence レベル 3 が設定されます。 子ポリシーが親ポリシーの class-default クラスに適用されて、トラフィックが 200,000 Kbps にシェーピングされます。

    Router(config)# policy-map child-policy
    Router(config-pmap)# class Premium
    Router(config-pmap-c)# priority
    Router(config-pmap-c)# police percent 40
    Router(config-pmap-c)# set ip precedence 3
    Router(config-pmap-c)# class Silver
    Router(config-pmap-c)# police 80000 10000 conform-action transmit exceed-action drop
    Router(config-pmap-c)# set ip precedence 5
    Router(config-pmap-c)# exit
    Router(config-pmap)# policy-map Parent
    Router(config-pmap)# class class-default
    Router(config-pmap-c)# shape 200000
    Router(config-pmap-c)# service-policy output child-policy
    Router(config-pmap-c)# exit
    Router(config-pmap)# exit
    Router(config)#

    階層型ポリシー マップと仮想テンプレートの関連付け

    手順の概要

      1.    enable

      2.    configure terminal

      3.    interface virtual-template template- number

      4.    service-policy {input | output} policy-map-name

      5.    exit


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Router> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。

       
      ステップ 2 configure terminal


      例:
      Router# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 interface virtual-template template- number


      例:
      Router(config)# interface virtual-template template-number
       

      仮想テンプレートを作成し、インターフェイス コンフィギュレーション モードを開始します。

      template-number は、識別するために仮想テンプレート インターフェイスに割り当てる番号です。 有効な値の範囲は 1 ~ 200 です。

      ルータ上には最大 200 個の仮想テンプレート インターフェイスを設定できます。

       
      ステップ 4 service-policy {input | output} policy-map-name


      例:
      Router(config-if)# service-policy {input | output} policy-map-name
       

      指定したポリシー マップを、指定したインバウンドまたはアウトバウンドの方向で仮想テンプレート インターフェイスに関連付けます。

      input は、ポリシー マップをインバウンド トラフィックに適用することを指定します。

      output は、ポリシー マップをアウトバウンド トラフィックに適用することを指定します。

      policy-map-name は、設定済みのポリシー マップの名前です。

       
      ステップ 5 exit

      例:
      Router(config-if)# exit
       

      インターフェイス コンフィギュレーション モードを終了します。

       

      次に、ポリシー マップを仮想テンプレートに関連付ける方法を例示します。 この例では、「Parent」という名前のポリシー マップが「VirtualTemplate1」という名前の仮想テンプレートに関連付けられます。

      Router(config)# interface virtual-template1
      Router(config-if)# service-policy output Parent
      Router(config-if)# exit
      Router(config)#

      ATM サブインターフェイスへの仮想テンプレートの適用

      手順の概要

        1.    enable

        2.    configure terminal

        3.    bba-group pppoe group-name

        4.    virtual-template template-number

        5.    exit

        6.    interface atm number.subinterface [point-to-point]

        7.    pvc [name] vpi/vci

        8.    protocol pppoe group group-name

        9.    exit

        10.    exit


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Router> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。

         
        ステップ 2 configure terminal


        例:
        Router# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 bba-group pppoe group-name


        例:
        Router(config)# bba-group pppoe group-name
         

        PPP over Ethernet(PPPoE)プロファイルを作成します。 BBA グループ コンフィギュレーション モードを開始します。

        group-name は、PPPoE プロファイルの名前です。

         
        ステップ 4 virtual-template template-number


        例:
        Router(config-bba-grp)# virtual-template template-number
         

        仮想アクセス インターフェイスのクローンを作成する際に使われる仮想テンプレートに BBA グループを関連付けます。

        template-number は、仮想テンプレートの識別番号です。

         
        ステップ 5 exit

        例:
        Router(config-bba-grp)# exit
         

        BBA グループ コンフィギュレーション モードを終了します。

         
        ステップ 6 interface atm number.subinterface [point-to-point]

        例:
        Router(config)# interface atm number.subinterface [point-to-point]
         

        サブインターフェイスを作成または変更します。 サブインターフェイス コンフィギュレーション モードを開始します。

        atm は、インターフェイス タイプです。

        number は、インターフェイスのスロット、モジュール、およびポート番号です(たとえば 1/0/0)。

        .subinterface は、サブインターフェイスの番号です(たとえば、1/0/0.1)。

        (オプション)point-to-point は、サブインターフェイスが別のサブインターフェイスに直接接続されることを示します。

         
        ステップ 7 pvc [name] vpi/vci

        例:
        Router(config-subif) pvc [name] vpi/vci 
         

        ATM 相手先固定接続(PVC)を作成または変更します。 ATM 仮想回線コンフィギュレーション モードを開始します。

        (オプション)name は PVC を識別します。15 文字まで使用できます。

        vpi/ は、この PVC の ATM ネットワーク仮想パス識別子(VPI)を指定します。 スラッシュを指定する必要があります。 有効な値は、0 ~ 255 です。 ルータは、この有効範囲に含まれない値を接続 ID として扱います。 デフォルト値は 0 です

        (注)     

        引数 vpi および vci の両方を 0 に設定することはできません。つまり、一方を 0 に設定した場合、もう一方も 0 にすることはできません。

        vci は、この PVC の ATM ネットワーク仮想チャネル識別(VCI)を指定します。 有効な値は 0 ~ 1 の範囲で、atm vc-per-vp コマンドによってこのインターフェイスに関して設定された最大値未満です。 範囲外の値を設定すると、「認識されないコマンド」というエラー メッセージが表示されます。

        VCI 値が意味を持つのはローカルに限られます。したがって、ATM ネットワーク全体ではなく、単一のリンクでのみ一義的です。 通常、0 ~ 31 までの小さい値は特定のトラフィック(たとえば F4 OAM、SVC シグナリング、ILMI など)に予約されているため、使用できません。

         
        ステップ 8 protocol pppoe group group-name

        例:
        Router(config-atm-vc)# protocol pppoe group group-name
         

        PPP over Ethernet(PPPoE)セッションを相手先固定接続(PVC)で確立できるようにします。

        group は、インターフェイス上の PPPoE セッションで使用される PPPoE プロファイル(bba-group)を指定します。

        group-name は、インターフェイス上の PPPoE セッションで使用される PPPoE プロファイル(bba-group)の名前です。

        group group-name は、QoS ポリシーを含む仮想テンプレート インターフェイスをセッションに適用するために使われる bba-group を指します。

         
        ステップ 9 exit

        例:
        Router(config-atm-vc)# exit
         

        ATM 仮想回線コンフィギュレーション モードを終了します。

         
        ステップ 10 exit

        例:
        Router(config-subif)# exit
         

        サブインターフェイス コンフィギュレーション モードを終了します。

         

        次に、仮想テンプレートを ATM インターフェイスに関連付けて、その仮想テンプレート内のポリシーをインターフェイス上のセッションに適用する例を示します。 この例では、「Parent」という名前のサービス ポリシーが、「pppoeoa-group」という名前の bba-group に関連付けられた仮想テンプレート 8 に適用されます。 bba-group は、ATM サブインターフェイス 4/0/1.10 の PVC 101/210 に適用されます。

        bba-group pppoe pppoeoa-group
        Virtual-Template 8
        interface ATM4/0/1.10 point-to-point
        pvc 101/210
        vbr-nrt 4000 2000 50
        no dbs enable
        encapsulation aal5snap
        protocol pppoe group pppoeoa-group
        !
        interface Virtual-Template8
        ip unnumbered Loopback5555
        no logging event link-status
        peer default ip address pool pool-1
        ppp authentication chap
        service-policy output Parent

        RADIUS を使用した PPP セッション キューイングの設定

        RADIUS を使用して PPPoEoA セッション キューイングを設定するには、次の設定作業を行います。

        ポリシー マップの設定

        ルータでは、RADIUS を使用して PPPoEoA セッションに QoS ポリシー マップを適用することができます。

        RADIUS プロファイルへの Cisco QoS AV ペアの追加

        シスコの属性と値(AV:Attribute - Value)のペアは、シスコなどのベンダーが独自の拡張属性をサポートするために使用できるベンダー固有属性(VSA)です。 RADIUS 属性 26 は、ルータと RADIUS サーバの間でベンダー固有の情報をやり取りするために使用される Cisco VSA です。

        RADIUS ユーザ プロファイルには、RADIUS サーバが認証する各ユーザについてのエントリが含まれます。 エントリごとに、ユーザがアクセスできる属性が設定されます。 RADIUS を使用して PPPoEoA セッション キューイングを設定するときには、適切なユーザ プロファイルに次の Cisco AV ペアを入力します。

        Cisco-AVPair = "ip:sub-qos-policy-out=<name of egress policy>"
        

        この Cisco AV ペアは、PPPoEoA セッションに QoS 機能を適用するときにルータで使用するポリシー マップを識別します。 RADIUS はポリシー サーバからサービス ログオン要求を受信すると、ログイン済みユーザに対してそのサービスを有効にするために、認可変更(CoA)要求をルータに送信します。 認証に成功すると、ルータは Cisco AV ペアを使用して RADIUS からポリシー マップ名をダウンロードし、QoS ポリシーをセッションに適用します。


        (注)  


        ルータは RADIUS ベンダー固有属性(VSA)38(Cisco-Policy-Down および Cisco-Policy-Up)もサポートしていますが、QoS ポリシー定義には上記の属性を使用することを推奨します。


        ATM VC での PPP セッション キューイングの確認

        手順の概要

          1.    enable

          2.    configure terminal

          3.    show policy-map [interface interface]

          4.    show policy-map session [uid uid-number] [input | output [class class-name]]

          5.    show running-config


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Router> enable
           

          特権 EXEC モードをイネーブルにします。

          • パスワードを入力します(要求された場合)。

           
          ステップ 2 configure terminal


          例:
          Router# configure terminal
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3 show policy-map [interface interface]


          例:
          Router# show policy-map [interface interface]
           

          指定したインターフェイスに関連付けられているポリシー マップに関する情報を表示します。 インターフェイスを指定しない場合、ルータ上で設定されているすべてのポリシー マップに関する情報が表示されます。

          interface interface は、インターフェイスのタイプと番号です(atm 4/0/0 など)。

           
          ステップ 4 show policy-map session [uid uid-number] [input | output [class class-name]]

          例:
          Router# show policy-map session [uid uid-number] [input | output [class class-name]]
           

          加入者セッションに対して有効な QoS ポリシー マップを表示します。

          (任意)uid は固有のセッション ID を定義します。

          (任意)uid-number は固有のセッション ID です。 有効な値は 1 ~ 65535 です。

          (任意)input は、固有のセッションのアップストリーム トラフィックを表示します。

          (任意)output は、固有のセッションのダウンストリーム トラフィックを表示します。

          (任意)class は、QoS ポリシー マップ定義に含まれるクラスを識別します。

          (任意)class-name は、QoS ポリシー マップに定義に含まれるクラス名を指定します。

           
          ステップ 5 show running-config


          例:
          Router# show running-config
           

          ルータ上の実行コンフィギュレーションを表示します。 出力には、AAA 設定と、ポリシー マップ、ATM VC、PPPoEoA、ダイナミック帯域幅選択、仮想テンプレート、RADIUS サーバの設定が表示されます。

           

          ATM VC での PPP セッション キューイングの設定例

          例:ATM VC での PPP セッション キューイングの設定

          次に、PPPoEoA セッション キューイングを設定する例を示します。 この例では、「pm_hier2_0_2」という名前の階層型 QoS ポリシーが Virtual-Template555 に関連付けられ、それが「pppoeoa Group」という名前のブロードバンド集約グループに適用されます。

          bba-group pppoe pppoeoa-group
          Virtual-Template 555
          !
          policy-map pm_hier2_child_0_2
          class cm_0
          priority level 1
          police percent 5 2 ms 0 ms conform-action transmit exceed-action drop violate-action drop
          queue-limit 77 packets
          class cm_1
          shape average percent 80
          bandwidth remaining ratio 80
          class class-default
          shape average percent 50
          bandwidth remaining ratio 20
          policy-map pm_hier2_0_2
          class class-default
          shape average percent 100
          bandwidth remaining ratio 100
          service-policy pm_hier_child_0_2
          interface ATM2/0/7.5555 point-to-point
          pvc 1/5555
          vbr-nrt 4000 2000 50
          no dbs enable
          encapsulation aal5snap
          protocol pppoe group pppoeoa-group
          !
          !
          interface Virtual-Template555
          ip unnumbered Loopback5555
          no logging event link-status
          peer default ip address pool pool-1
          ppp authentication chap
          service-policy output pm_hier2_0_2

          例:階層型ポリシー マップの設定および適用

          例:階層型ポリシー マップの設定および適用に、階層型ポリシーを設定して仮想テンプレートにそれを適用する例を示します。 この例には、「gold」および「bronze」トラフィック クラスに関する QoS 機能を定義した「child1」という名前の子ポリシー マップが含まれます。 child1 ポリシーは、512000 bps にシェーピングされる親ポリシー マップに適用されます。 階層型ポリシーは、「virtual-template 1」という名前の仮想テンプレートに適用されます。

          Router(config)# policy-map child1
          Router(config-pmap)# class gold
          Router(config-pmap-c)# priority
          Router(config-pmap-c)# police percent 40
          Router(config-pmap-c)# class bronze
          Router(config-pmap-c)# police 8000
          Router(config-pmap-c)# exit
          Router(config-pmap)# policy-map parent
          Router(config-pmap)# class class-default
          Router(config-pmap-c)# shape 512000
          Router(config-pmap-c)# service-policy child1
          Router(config-pmap-c)# exit
          Router(config-pmap)# exit
          Router(config)# interface virtual-template 1
          Router(config-if)# service-policy output parent

          例:ATM VC での PPP セッション キューイング用 RADIUS の設定

          例:ATM VC での PPP セッション キューイング用 RADIUS の設定に、ポリシー マップ名をルータにダウンロードするために使われる Cisco AV ペアを定義する方法を示します。 加入者のユーザ プロファイル例の最初の 3 行に、ユーザ パスワード、サービス タイプ、プロトコル タイプが示されます。 この情報は、加入者のユーザ プロファイルが最初に作成される時点でユーザ プロファイルに入力されます。 最後の行は、ユーザ プロファイルに追加された Cisco QoS AV ペアの例です。 ルータにダウンロードされるポリシー マップ名は p23 です。

          userid	Password = "cisco"
          Service-Type = Framed,
          Framed-Protocol = PPP,
          cisco-avpair = "sub-qos-policy-out=p23"

          例:ATM VC での PPP セッション キューイングの確認

          PPP セッション情報の表示:show pxf cpu queue session コマンド

          例:ATM VC での PPP セッション キューイングの確認では、show pppoe session コマンドを使用して、ルータで確立されているセッションを表示します。 この場合、1 つのセッションがアクティブになっていて、そのセッション ID(SID)は 6 です。

          Router# show pppoe session
          1 session in LOCALLY_TERMINATED (PTA) State
          1 session total
          Uniq ID	PPPoE	RemMAC	Port	VT	VA	State
          	SID	LocMAC	VA-st	Type
          	14	6	0009.b68d.bb37	ATM2/0/7.5555	555	Vi3.1	PTA
          			0009.b68d.bc37	VC: 1/5555 			UP
          

          例:ATM VC での PPP セッション キューイングの確認では、show policy-map session コマンドを使用して、ダウンストリーム方向のトラフィックに関する QoS ポリシー マップ統計情報を表示します。 また、この例ではポリシー マップ設定も表示されます。

          Router# show pppoe session
          1 session in LOCALLY_TERMINATED (PTA) State
          1 session total
          Uniq ID	PPPoE	RemMAC	Port	VT	VA	State
          	SID	LocMAC	VA-st	Type
          	14	6	0009.b68d.bb37	ATM2/0/7.5555	555	 Vi3.1 	PTA 
          	0009.b68d.bc37 VC: 1/5555	UP 
          Router#
          Router#
          Router# show policy-map session uid 14
          SSS session identifier 14 -
          	Service-policy output: pm_hier2_0_2
          Class-map: class-default (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: any 
          0 packets, 0 bytes
          30 second rate 0 bps
          Queueing
          queue limit 50 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 2000000, bc 8000, be 8000
          target shape rate 2000000
          bandwidth remaining ratio 100
          	Service-policy : pm_hier2_child_0_2
          queue stats for all priority classes:
          Queueing
          priority level 1
          queue limit 77 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          Class-map: cm_0 (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 0 
          0 packets, 0 bytes
          30 second rate 0 bps
          Priority: 0% (0 kbps), burst bytes 4470, b/w exceed drops: 0
          Priority Level: 1 
          Police:
          104000 bps, 1536 limit, 0 extended limit
          conformed 0 packets, 0 bytes; action: transmit
          exceeded 0 packets, 0 bytes; action: drop
          violated 0 packets, 0 bytes; action: drop
          Class-map: cm_1 (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 1 
          0 packets, 0 bytes
          30 second rate 0 bps
          Queueing
          queue limit 237 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 1600000, bc 6400, be 6400
          target shape rate 1600000
          bandwidth remaining ratio 80 
          Class-map: class-default (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: any 
          0 packets, 0 bytes
          30 second rate 0 bps
          Queueing
          queue limit 77 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 1000000, bc 4000, be 4000
          target shape rate 1000000
          bandwidth remaining ratio 20 
          Router# show policy-map pm_hier2_0_2
          Policy Map pm_hier2_0_2
          Class class-default
          Average Rate Traffic Shaping
          cir 100%
          bandwidth remaining ratio 100 
          service-policy pm_hier2_child_0_2
          Router# show policy-map pm_hier2_child_0_2
          Policy Map pm_hier2_child_0_2
          Class cm_0
          priority level 1
          police percent 5 2 ms 0 ms conform-action transmit exceed-action drop violate-action drop
          queue-limit 77 packets
          Class cm_1
          Average Rate Traffic Shaping
          cir 80%
          bandwidth remaining ratio 80 
          Class class-default
          Average Rate Traffic Shaping
          cir 50%
          bandwidth remaining ratio 20 

          その他の関連資料

          関連資料

          関連項目

          マニュアル タイトル

          Cisco IOS コマンド

          『Cisco IOS Master Commands List, All Releases』

          QoS コマンド

          『Cisco IOS QoS Command Reference』

          テクニカル サポート

          説明

          リンク

          右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          ATM VC での PPP セッション キューイングの機能情報

          次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、特定のソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースのみを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

          プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

          表 2 ATM VC での PPP セッション キューイングの機能情報

          機能名

          リリース

          機能情報

          ATM VC での PPP セッション キューイング

          Cisco IOS XE Release 2.5

          ATM 仮想回路(VC)での PPP セッション キューイングを使用すると、ユーザ指定のレートに従って PPP over Ethernet over ATM(PPPoEoA)セッションをシェーピングし、キューに入れることができます。

          この機能は、Cisco IOS Release XE 2.5 で Cisco ASR 1000 シリーズ ルータにが導入されました。

          Cisco and the Cisco Logo are trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and other countries. A listing of Cisco's trademarks can be found at www.cisco.com/​go/​trademarks . Third party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1005R)