FlexWAN/Enhanced FlexWAN モジュール インストレーション コンフィギュレーション ノート
FlexWANおよび拡張FlexWAN モジュールでのMPLSの設定
FlexWANおよび拡張FlexWANモジュールでのMPLSの設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

FlexWANおよび拡張FlexWAN

MPLSの設定

MPLSの概要

FlexWANおよび拡張FlexWANモジュールでのMPLS

FlexWANおよび拡張FlexWANモジュールでのMPLSサポート

サポート対象機能

MPLSの注意事項および制限事項

MPLSの制限事項

MPLSの設定

MPLS QoSの概要

FlexWANおよび拡張FlexWANのMPLS QoS機能の概要

信頼状態

分類

マーキングおよびポリシング

IP ToSの維持

FlexWANおよび拡張FlexWANでのMPLS QoSの使用

IP/MPLS(MPLS、MPLS VPN)エッジ

入力ポート機能

出力ポート機能

MPLS/IP(MPLS、MPLS VPN)エッジ

入力ポート機能

出力ポート機能

MPLSコア

入力ポート機能

出力ポート機能

MPLS QoSの設定

FlexWAN MPLS QoS(Supervisor Engine 2の場合)

FlexWAN MPLS QoS(SUP720-3BXLの場合)

サポート対象のFlexWANおよび拡張FlexWAN MPLS QoS機能

MPLS EXPフィールドの概要

MPLS EXPフィールドの設定

MPLS用のクラス ベースド マーキングの設定

MPLSパケットを分類するクラス マップの設定

MPLS experimentalフィールドを設定するポリシー マップの設定

サービス ポリシーの結合

QoS動作の確認

設定例

入力PEルータの設定

コア ルータの入力側および出力側の設定

MPLS VPNの設定

FlexWANおよび拡張FlexWANモジュールでのMPLS VPN

MPLS VPNサポート

MPLS VPNの注意事項および制限事項

MPLS VPNのメモリ要件および推奨事項

MPLSのラベルに基づくロードバランシング

MPLS VPN QoSの設定

設定例

AToM

AToMの制限事項

Ethernet over MPLSの注意事項および制限事項

ATM AAL5 over MPLSの制限事項

ATM Cell Relay over MPLSの制限事項

Frame Relay over MPLSの制限事項

レイヤ2パケットのAToM伝送

旧リリースのAToMとの互換性

AToMの利点

AToMの設定方法

前提条件

AToMおよびQoS

Ethernet over MPLS

SUP720-3BXLベースのEoMPLS

Cisco Supervisor Engine 2ベースのEoMPLS

サポート対象モジュール

Supervisor Engine 2またはFlexWANベース システムに対応するEoMPLS VLANモードの設定

Ethernet over MPLS VLANモード設定時の注意事項

Supervisor Engine 2またはFlexWANベース システムに対応するEoMPLSポート モードの設定

Ethernet over MPLSポート モード設定時の注意事項

設定の確認

ATM AAL5 over MPLS VCモード

サポート対象モジュール

ATM AAL5 over MPLS VCモードの設定

設定の確認

トラブルシューティングのヒント

ATM Cell Relay over MPLS VCモード

ATM Cell Relay over MPLS VCモードの設定

ATM Cell Relay VCモードの確認

トラブルシューティングのヒント

Frame Relay over MPLS

サポート対象モジュール

DLCI間接続を指定したFRoMPLSの設定

設定の確認

レイヤ2ローカル スイッチング

レイヤ2ローカル スイッチング(ATM間)

サポート対象モジュール

制限事項

AAL5カプセル化タイプを使用するATM VC間ローカル スイッチングの設定

AAL0カプセル化タイプを使用するATM VC間ローカル スイッチングの設定

AAL0カプセル化タイプを使用するATM VP間ローカル スイッチングの設定

フレームリレーDLCIローカル スイッチングの設定

設定の確認

トラブルシューティングのヒント

他のPE装置がフレームリレー パケットを伝送できるようにする方法

LMIおよびFRoMPLS

AToMでQoSを設定する方法

AToMでのexperimentalビットの設定

EoMPLSおよびEXPビット

ATM AAL5 over MPLSおよびEXPビット

ATM Cell Relay over MPLSおよびEXPビット

FRoMPLSおよびEXPビット

EXPビットによるパケット プライオリティの設定

トラフィック シェーピングのイネーブル設定

EoMPLS QoSの例

EoMPLS QoSの例 ― インターフェイスに割り当てられたトラフィック ポリシーの表示

EoMPLS QoSの例 ― VLAN上でのQoSの設定

ATMoMPLS QoSの例 ― 入力QoSの設定

FRoMPLS QoSの例 ― 入力QoSの設定

AToMのロードバランシング

ロードバランシングの注意事項

最低利用モードの制限事項

FlexWANおよび拡張FlexWAN
モジュールでのMPLSの設定

この章では、FlexWANおよび拡張FlexWANモジュール上でMultiprotocol Label Switching(MPLS;マルチプロトコル ラベル スイッチング)およびAny Transport over Multiprotocol Label Switching(AToM)を設定する方法について説明します。

この章の構成は次のとおりです。

「MPLSの設定」

「MPLS QoSの概要」

「FlexWANおよび拡張FlexWANでのMPLS QoSの使用」

「MPLS QoSの設定」

「MPLS VPNの設定」

「MPLS VPN QoSの設定」

「AToM」

「Ethernet over MPLS」

「ATM AAL5 over MPLS VCモード」

「ATM Cell Relay over MPLS VCモード」

「Frame Relay over MPLS」

「レイヤ2ローカル スイッチング」

「AToMでQoSを設定する方法」

「AToMのロードバランシング」

MPLSの設定

ここではMPLSについて説明し、設定情報を提供します。

「MPLSの概要」

「FlexWANおよび拡張FlexWANモジュールでのMPLS」

「FlexWANおよび拡張FlexWANモジュールでのMPLSサポート」

「サポート対象機能」

「MPLSの注意事項および制限事項」

「MPLSの設定」

MPLSの概要

MPLSではラベル スイッチングを使用して、Packet over SONET、フレームリレー、ATMなど、さまざまなリンク レベル テクノロジーを使用してパケットを転送します。ラベルはグルーピングまたはForwarding Equivalence Class(FEC)に基づいてパケットに割り当てられます。同じFECに属しているパケットは、同様の扱いを受けます。ラベルはレイヤ2およびレイヤ3ヘッダー間で追加されるか(パケット環境の場合)、またはVirtual Path Identifier/Virtual Channel Identifier(VPI/VCI;仮想パス識別子/仮想チャネル識別子)フィールドで追加されます(ATMネットワークの場合)。

MPLSネットワークでは、エッジ ルータが着信ラベルのラベル検索を実行し、着信ラベルと発信ラベルを入れ換え、次のホップにパケットを送信します。MPLSネットワークの入力エッジ限定でパケットにラベルが追加され、出力エッジで削除されます。コア ネットワークはラベルを読み取って、適切なサービスを適用し、ラベルに基づいてパケットを転送します。

図4-1に、カスタマー ネットワークの2つのサイトを接続する、サービス プロバイダーのMPLSネットワークを示します。

図4-1 MPLSネットワーク

 

MPLSの詳細については、次のURLを参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/xcftagov.ht

FlexWANおよび拡張FlexWANモジュールでのMPLS

Supervisor Engine 2が搭載されている場合、ラベル検索およびラベル操作はFlexWANおよび拡張FlexWANモジュール上で実行されます。

Supervisor Engine 720が搭載されている場合、PFC3BXLがIP/MPLS、MPLS/MPLS、MPLS/IPパスのあらゆるMPLS転送を実行します。

すべてのMPLS Quality of Service(QoS;サービス品質)機能は、FlexWANおよび拡張FlexWANモジュールがローカルで処理します。したがって、FlexWANおよび拡張FlexWANモジュールのQoS動作は、7500 VIP QoSと同様と考えられます。

FlexWANおよび拡張FlexWANモジュールでのMPLSサポート

MPLSは次のCatalyst 6000ファミリーおよびCisco 7600シリーズFlexWANモジュール上でサポートされます。

WS-X6182-2PA FlexWAN

WS-X6582-2PA拡張FlexWAN

サポート対象機能

SUP720-3BXLおよびSupervisor Engine 2では次の機能がサポートされます。


) Cisco IOS 12.2SXリリースの機能は、Cisco IOS 12.2、12.2T、および12.2Sでもサポートされます。各リリースに対応するマニュアルを参照してください。該当する場合、ここではCisco IOS 12.2SXリリースでサポートされる、プラットフォームに依存しない機能を扱っているマニュアルを紹介します。Cisco IOS 12.2Sリリースは、Cisco 7600シリーズ ルータ用のソフトウェア イメージをサポートしません。また、Cisco IOS 12.2Sのマニュアルには、Cisco 7600シリーズ ルータに関するサポートが記載されていません。


シスコ ルータのMPLS ― この機能は、Label Edge Router(LER;ラベル エッジ ルータ)でのIPパケットに対するラベルの追加および削除、さらにLabel Switch Router(LSR;ラベル スイッチ ルータ)でのラベル スイッチングに関して、基本的なMPLSサポートを提供します。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120st/120st21/fs_
rtr.htm
を参照してください。

Any Transport over MPLS(AToM)。MPLSバックボーン上でレイヤ2パケットを転送します。
「AToM」を参照してください。

MPLS Traceroute ― MPLS対応ネットワーク内のルータからTracerouteを開始できるようにします。
http://www.cisco.com/en/US/products/sw/iosswrel/ps1612/prod_release_note09186a0080088012.html#72218 を参照してください。

Multi-VRF for CE Routers(VRF Lite) ― VRF-Liteは、サービス プロバイダーが複数のVirtual Private Network(VPN;仮想私設網)をサポートできるようにする機能です。VPN間でIPアドレスを重複させることができます。
http://www.cisco.com/en/US/products/hw/routers/ps259/prod_bulletin09186a00800921d7.html を参照してください。


) VRF Liteは、VRFインターフェイス間のIPv4転送、IPv4 ACL、およびIPv4 HSRPの各機能とともにサポートされます。IPv4マルチキャストはサポートされません。



) VRF Liteは、PFC3Aを搭載したSupervisor Engine 720でもサポートされます。


MPLS Label Distribution Protocol(LDP) ― MPLS LDPはInternet Engineering Task Force(IETF)によって標準化され、Cisco IOSソフトウェアで対応しています。MPLS LDPによって、スケーラビリティで柔軟性が高く、複数のサービス レベルをサポートするIP VPNを構築できます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s14/fs2sldp.htm を参照してください。

MPLS VPN ― この機能を使用すると、Cisco IOSネットワーク上でスケーラブルなIPv4レイヤ3 VPNバックボーン サービスを展開できます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120st/120st21/fs_vpn.htm を参照してください。

MPLS VPN Carrier Supporting Carrier(CSC) ― この機能により、MPLS VPNを使用しているサービス プロバイダーは、自社のバックボーン ネットワークをセグメント単位で他のプロバイダーに使用させることができます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ftcsc8.htm を参照してください。

MPLS VPN ― Carrier Supporting Carrier ― IPv4 BGP Label Distribution ― この機能により、CSCネットワークを設定し、Border Gateway Protocol(BGP)がバックボーン キャリアProvider Edge(PE;プロバイダー エッジ)ルータとカスタマー キャリアCustomer Edge(CE;カスタマー エッジ)ルータ間でルートおよびMPLSラベルの転送が可能になります。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftcscl13.htm を参照してください。

MPLS VPN ― 自律システム間サポート ― MPLS VPNがサービス プロバイダーと自律システムの橋渡しをできるようになります。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s24/fsias24.htm を参照してください。

MPLS VPN ― Inter-AS ― IPv4 BGP Label Distribution。この機能により、Autonomous System
Boundary Router(ASBR;自律システム境界ルータ)がPEルータのMPLSラベルとIPv4ルートを交換できるようになります。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftiasl13.htm を参照してください。

MPLS VPNに関するHot Standby Router Protocol(HSRP)サポート ― HSRP仮想IPアドレスがデフォルトのルーティング テーブルではなく、適切なIPルーティング テーブルに追加されるようになります。
http://www.cisco.com/en/US/products/sw/iosswrel/ps1834/products_feature_guide09186a008008021e.
html
を参照してください。


) WANインターフェイス(FlexWAN、拡張FlexWAN、またはOSM)だけを使用する場合、HSRPサポートは該当しません。


OSPF Sham Link: MPLS VPNに関するOSPF Sham-Link(偽装リンク)サポート ― 偽装リンクを使用してOpen Shortest Path First(OSPF)プロトコルが動作しているVPNクライアント サイトを接続し、MPLS VPNの設定でバックドアOSPFリンクを共有できます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ospfshmk.htm を参照してください。

external BGP(eBGP)およびinternal BGP(iBGP)のBGPマルチパス ロードシェアリング ― MPLS VPNを使用するように設定されたBGPネットワークで、eBGPパスおよびiBGPパスの両方を含めたマルチパス ロードバランシングを設定できます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t4/fteibmpl.htm を参照してください。

Any Transport over MPLS(AToM): Ethernet over MPLS: ポート モード(EoMPLS)。「Supervisor Engine 2またはFlexWANベース システムに対応するEoMPLSポート モードの設定」を参照してください。

Any Transport over MPLS(AToM): ATM AAL5 over MPLS(AAL5oMPLS) ― 「ATM AAL5 over MPLS VCモードの設定」を参照してください。

Any Transport over MPLS(AToM): ATM Cell Relay over MPLS: VPモード ― 「AAL0カプセル化タイプを使用するATM VP間ローカル スイッチングの設定」を参照してください。

Any Transport over MPLS(AToM): Ethernet over MPLS(EoMPLS) ― 「Ethernet over MPLS」を参照してください。

Any Transport over MPLS(AToM): Frame Relay over MPLS(FRoMPLS) ― 「Frame Relay over MPLS」を参照してください。

Any Transport over MPLS(AToM): PPP over MPLS(PPPoMPLS) ― MPLSバックボーンを介してPPP Protocol Data Unit(PDU;プロトコル データ ユニット)を転送します。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s23/atom/index.htm を参照してください。

Any Transport over MPLS(AToM): Single Cell Relay - Virtual Circuit(VC;仮想回線)モード(CRoMPLS) ― 「ATM Cell Relay over MPLS VCモード」を参照してください。

ATM PVC Bundle Enhancement - MPLS-EXP Based PVC Selection ― パケットのMPLS-EXP値に基づいて、ATM-Permanent Virtual Circuit(PVC;相手先固定接続)バンドルのPVCを選択できるようになります。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ftmpls.htm を参照してください。

Frame Relay PVC BundleおよびMPLS QoSサポート ― フレームリレーPVCバンドルおよびMPLS QoS(expビット)サポート。expビットをバンドル メンバーにマッピングします。

IPv6スイッチング: Provider Edge Router over MPLS(6PE) ― IPv6エッジ ルータを起点とするIPv6パケットをIPv4制御プレーンが動作しているMPLSネットワーク バックボーン上で送信できます。MPLS Pルータのソフトウェアを変更する必要はありません。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ipv6_vgf.htm を参照してください。

MPLS Class of Service(CoS;サービス クラス) ― MPLS対応CoS機能によって、ネットワーク管理者はMPLSネットワーク上で差別化したサービス タイプを提供できます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t5/cos.htm を参照してください。

MPLS CoS Enhancements ― サービス プロバイダーはカスタマーのIP precedenceフィールドの値を上書きする代わりに、MPLS experimentalフィールドを設定できます。カスタマーは引き続きIPヘッダーを使用できます。パケットがMPLSネットワークを通過する過程で、IPパケットのCoSが変更されることはありません。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/mct1214t.htm を参照してください。

MPLS DiffServトンネル モード サポート ― サービス プロバイダーはカスタマーのQoS DSCPまたはIP precedenceの設定に影響を与えることなく、MPLS EXPを使用してQoSの条件を適用できます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftdtmode.htm を参照してください。

MPLS LDP - MIB通知 ― 重要なMPLS LDPイベント用にSNMPトラップを提供します。

MPLS over ATM: Virtual Circuit(VC;仮想回線)Merge ― MPLS over ATM: VC Mergeサポート。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ftlsc.htm を参照してください。

MPLS QoS Enhancements ― MPLS QoS拡張機能を使用すると、サービス プロバイダーはIP precedence/DSCPフィールドを変更しなくても、MPLS experimentalフィールド内で各パケットを設定することによって、タイプ、入力インターフェイス、およびその他の要因に基づいてパケットを分類できます。たとえば、サービス プロバイダーはPE1が受信するパケットのレートを考慮に入れて、または考慮しないで、パケットを分類できます。レートを考慮する場合、サービス プロバイダーはレート内のパケットにレート外のパケットとは異なるマーキングを行います。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120st/120st14/mct1214t.htm を参照してください。

Dynamic Packet Transport(DPT;ダイナミック パケット トランスポート)上のMPLSサポート ― DPTによって、IPトラフィックに不要なオーバーヘッドを課すことなく、SONET/SDHトランスポートに通常伴う信頼性および復元性が得られます。DPTでは逆回転する二重の光ファイバ リングを使用し、データと制御トラフィックを同時に伝送できます。DPTはパケット アドレッシング、パケット ストリッピング、帯域制御、およびパケットでのメッセージ伝達制御にSpatial Reuse Protocol(SRP)を使用します。SRPはメディアに依存しないMAC(メディア アクセス制御)レイヤ プロトコルです。
http://www.cisco.com/warp/public/cc/techno/wnty/dpty/tech/dptm_wp.htm を参照してください。

MPLS VPN - MIB通知 ― 重要なMPLS VPNイベント用にSNMPトラップを提供します。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftvpnm13.htm を参照してください。

MPLS VPN - OSPF PE-CEサポート ― VPNに含まれる複数のCEルータに接続されたPEルータ上のインターフェイスまたはサブインターフェイスごとに別々のルータIDを設定すると、ルータがサイト間でルーティング情報を交換するときにOSPFによって柔軟性が向上します。

MPLS VPN ID ― ルータ上で複数のVPNを設定できます。VPN名(固有のASCII文字列)を使用して、ルータ上で設定された特定のVPNを参照できます。または、VPN IDを使用することによって、ルータ上の特定のVPNを識別できます。VPN IDは標準仕様(RFC 2685)に準拠します。VPNに一貫性のあるVPN IDを与えるために、そのVPNに対応するサービス プロバイダー ネットワーク内のすべてのルータに同じVPN IDを割り当てます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ftvpnid.htm を参照してください。

PEおよびCE間のEIGRPに関するPLLS VPNサポート ― サービス プロバイダーは、MPLS VPNネットワーク内のPEおよびCE間でEIGRPを設定できます。
http://www.cisco.com/en/US/products/sw/iosswrel/ps1829/products_feature_guide09186a00801eff61.
html
を参照してください。

Multi-Protocol BGP(MP-BGP) - MPLS VPN ― MPLS VPNは、MPLSプロバイダーのコア ネットワークによって相互接続された1組のサイトで構成されます。各サイトに1つ以上のCEがあり、各CEは1つ以上のPEに接続します。PEはBorder Gateway Protocol-Multiprotocol(MP-BGP)を使用して、動的に相互通信を行います。
http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/vpnsc/mpls/2_0/prov_gd/pgmpls1.htm を参照してください。

Multicast-VPN: MPLS VPNのマルチキャスト サポート ― Cisco IOSのMulticast-VPN機能は、MPLS VPNクラウド内のマルチキャスト トラフィックをサポートします。MPLS VPNがサポートするのはユニキャスト トラフィックの接続だけなので、MPLS VPNと組み合わせてMulticast-VPNを配置することによって、サービス プロバイダーはMPLS VPNカスタマーにユニキャストとマルチキャストの両方の接続性を提供できます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftmltvpn.htm を参照してください。

MPLSトラフィック処理トンネルにおける隣接転送に関するOSPFサポート ― OSPFにMPLSトラフィック処理トンネル上で転送経路を作成させます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/relnote/xprn120s/index.htm を参照してください。

MQC policeコマンド内でのMPLS EXP送信の設定 ― ポリシー マップにset-mpls-exp-transmitを追加できます。
http://www/univercd/cc/td/doc/product/software/ios121/121relnt/7000/7x_121e.htm#xtocid10 を参照してください。

MPLS Traffic Engineering - DiffServ Aware(DS-TE) ― DiffServ対応型のトラフィック処理によってMPLSトラフィック処理が拡張され、制約に基づいた保証トラフィック ルーティングを実行できるようになります。その結果、標準トラフィックに対してCBRが満たすより制約の強い帯域幅条件が満たされます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s18/fsdserv3.
htm
を参照してください。

MPLS Traffic Engineering Forwarding Adjacency ― MPLS TE Forwarding Adjacency機能を使用すると、ネットワーク管理者はShortest Path First(SPF)アルゴリズムに基づいて、トラフィック処理Label Switched Path(LSP;ラベル スイッチド パス)トンネルをInterior Gateway Protocol(IGP;内部ゲートウェイ プロトコル)ネットワーク内のリンクとして扱うことができます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s18/fstefa_3.htm を参照してください。

OSPF Forwarding Adjacency ― OSPF Forwarding Adjacency機能によって、MPLS TE Forwarding Adjacency機能にOSPFサポートが追加されます。その結果、ネットワーク管理者はSPFアルゴリズムに基づいて、トラフィック処理LSPトンネルをIGPネットワーク内のリンクとして扱うことができます。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s24/
ospffa.htm
を参照してください。

MPLS Traffic Engineering(TE) - Interarea Tunnels ― MPLS TE Interarea Tunnels機能を使用すると、複数のIGPエリアおよびレベルにまたがるMPLS TEトンネルを設定できます。その結果、トンネル ヘッド エンド ルータとテール エンド ルータの両方が同じエリアになければならないという制約がなくなります。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s18/fsiarea3.htm を参照してください。

MPLS TE: リンクおよびノード保護、RSVP Helloサポート ― Fast ReRoute(FRR)は、障害箇所でLSPをローカルに修復し、ヘッドエンド ルータが新しいエンドツーエンドLSPを確立して置き換える間、そのLSP上でデータが流れ続けるようにすることによって、リンクおよびノード障害からMPLS TE LSPを保護するメカニズムです。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s24/fsfrr24.htm を参照してください。

MPLSの注意事項および制限事項

FlexWANおよび拡張FlexWANモジュール上でMPLSを設定するときには、次の注意事項および制限事項に従ってください。

「MPLSの制限事項」

MPLSの制限事項

MPLSには次の制限が適用されます。

Maximum Transmission Unit(MTU;最大伝送ユニット)の確認および分割は、FlexWANおよび拡張FlexWANモジュール上のすべてのMPLSおよびVRF IP/MPLSパスでサポートされます。

Supervisor Engine 2の場合、MPLS Provider(P;プロバイダー)機能は、レイヤ2スイッチングもサポートするイーサネット インターフェイスではサポートされません。これらのインターフェイスでP機能をサポートするには、たとえばWS-6516-GBICモジュール上のギガビット イーサネット インターフェイスから、Pスイッチングができるように設定された
OSM-4GE-WANモジュール上のインターフェイスへ、トランクを作成するのが唯一の方法です。WS-6516-GBICモジュール上のインターフェイスはトランキング モードに設定し、OSM-4GE-WANモジュールのインターフェイス上に適切なサブインターフェイスを作成する必要があります。SUP720-3BXLベースのシステムの場合、MPLS P機能はサポートされます。

Cisco Supervisor Engine 2の場合、ロードシェアリングがサポートされるのはPEパス上だけです。P装置上ではサポートされません。

デフォルトのEXP処理方式は、MPLS Differentiated(DiffServ)ショート パイプ モードです。


) その他の制限事項については、「MPLS VPNの注意事項および制限事項」「Ethernet over MPLSの注意事項および制限事項」「ATM AAL5 over MPLSの制限事項」「ATM Cell Relay over MPLSの制限事項」、および「Frame Relay over MPLSの制限事項」を参照してください。


MPLSの設定

MPLSの設定については、次のURLにアクセスして『Multiprotocol Label Switching on Cisco Routers』フィーチャ モジュールを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/mpls4t.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/xcftagov.htm
#1021991

MPLS QoSの概要

ネットワーク管理者はMPLS QoSによって、MPLSネットワーク上でサービス レベルの差別化を実現できます。ネットワーク管理者は個々の送信フレームまたはパケットに適したサービス クラスを指定することによって、多種多様なネットワーク要件を満たすことができます。付加したMPLSラベルでEXPビットを設定することによって、フレームおよびパケットにさまざまなサービス クラスを定義できます。


) FlexWANおよび拡張FlexWANモジュールで利用できるMPLS QoS機能はすべて、モジュラ式のQoS CLI(コマンドライン インターフェイス)から管理します。モジュラ式QoS CLI(MQC)は、トラフィック クラスを定義し、トラフィック ポリシー(ポリシー マップ)を作成して設定し、それらのトラフィック ポリシーをインターフェイスに結合できるコマンドライン インターフェイスです。モジュラ式QoS CLIの詳細については、『Cisco IOS Quality of Service Solutions Configuration Guide』Release 12.2を参照してください。URLは
http://www.cisco.com/en/US/products/sw/iosswrel/ps5014/products_feature_guide_chapter09186a008008813a.htmlです。


FlexWANおよび拡張FlexWANのMPLS QoS機能の概要

次に、FlexWANおよび拡張FlexWANモジュールのMPLS QoS機能について簡単に説明します。

信頼状態

ポートに信頼状態を割り当てることによって、着信フレームにあるがままの既存のプライオリティを信頼する(残す)か、またはプライオリティを書き換えてゼロに戻すかをポートに指示します。FlexWANまたは拡張FlexWANモジュールのポートには、IP precedenceに関してデフォルトの信頼状態が与えられていて変更できません。FlexWANまたは拡張FlexWANモジュールはデフォルトで、受信パケットに指定されているIP precedenceまたはDSCP値を受け入れます。これらの値をマーキングする場合は、入力トラフィックがFlexWANまたは拡張FlexWANモジュール上にある間にその入力トラフィックに適用する、分散クラス ベース パケット マーキング ポリシーを設定します。


) FlexWANまたは拡張FlexWANモジュールでは、デフォルトでType of Service(ToS;サービス タイプ)が維持されます。


分類

分類は、パケットをQoSラベルに対応付けることによって、そのパケットに個別のパスを生成するプロセスです。受信MPLSパケットの場合、FlexWANまたは拡張FlexWANモジュールはmatch mpls experimentalコマンドを使用して、受信した最上位ラベルのEXPを照合します。生成されたQoSラベルは、そのパケットに対して今後実行される、あらゆるQoSアクションを示します。


) FlexWANまたは拡張FlexWANモジュールはqos-group、match input-interface、discard-class、FR-DE、ATM CLP、COS、source address、およびdestination addressを除くすべての一致条件をサポートします。


マーキングおよびポリシング

ポリシングは、着信トラフィックのレートと設定されているポリサーを比較することによって、パケットがプロファイルに適合しているかどうかを決定します。ポリサーはトラフィック フローが消費する帯域幅を制限します。結果はマーカーに引き渡されます。

マーキングでは、パケットがプロファイルに適合していない場合に実行するアクションについて、ポリサー設定情報を調べます。アクションのマーキングは、変更しないでパケットを渡す、パケット内のQoSラベルをマーク ダウンする、またはパケットを廃棄するのいずれかです。

FlexWANまたはFlexWANモジュールはMPLSマーキングおよびポリシングを実行します。インターフェイスはデフォルトで信頼されます。


) FlexWANまたは拡張FlexWANモジュールは、qos_group、ATM CLP bit、set cos、FR-DE、および
discard-classを除き、あらゆる形式のsetコマンドをサポートします。


IP ToSの維持

FlexWANまたは拡張FlexWANモジュールは、付加、交換、廃棄を含めたあらゆるMPLS操作時に、IP ToSを自動的に維持します。そのためのコマンドを設定する必要はありません。

FlexWANおよび拡張FlexWANでのMPLS QoSの使用

ここでは、下記を対象にFlexWANおよび拡張FlexWAN MPLS QoSを使用する方法について説明します。

「IP/MPLS(MPLS、MPLS VPN)エッジ」

「MPLS/IP(MPLS、MPLS VPN)エッジ」

「MPLSコア」


) FlexWANおよび拡張FlexWANモジュールでのEthernet/MPLS(EoMPLS)QoSについては、「EoMPLSおよびEXPビット」を参照してください。


IP/MPLS(MPLS、MPLS VPN)エッジ

ここでは、MPLSネットワークの入力側でサポートされるMPLS QoS機能について説明します。


) デフォルトでは、LSP全体でIP DSCPが維持されます。


入力ポート機能

IP/MPLS用の機能は、IPルーティング用の機能と同じです。FlexWANおよび拡張FlexWANモジュール ポートの機能は、受信したIPヘッダー内の情報を分類します。

EXPマーキング サポート

Cisco Supervisor Engine 2の場合、EXPマーキングはBasic MPLSおよびMPLS/VPNに関してサポートされます。MPLS VPNでは、付加(プッシュ)されたラベルに限り、EXP、IP precedence、およびIP情報に基づくDSCPマーキングが存在します。

Supervisor Engine 750-3BXLのMPLSおよびMPLS VPNでは、付加(プッシュ)されたラベルに限り、IP情報(IP precedence、DSCP、ACL)に基づいたEXPマーキングがサポートされます。


) IP/MPLSエッジでは、set mpls experimentalコマンドは入力ポリシーとしてサポートされません。


出力ポート機能

FlexWANおよび拡張FlexWANモジュール ポートの機能は、match mpls experimentalコマンドを使用して分類します。match mpls experimentalコマンドは、最上位レベルのラベル内のEXPについては照合しません。

Supervisor Engine 2の場合、ラベル スタックのすべてのラベルについて、EXP値に基づいた出力QoSポリシーでのEXPマーキングがサポートされます。

Supervisor Engine 720-3BXLの場合、ラベル スタックのすべてのラベルについて、EXP値に基づいた出力QoSポリシーでのEXPマーキングがサポートされます。

MPLS/IP(MPLS、MPLS VPN)エッジ

ここでは、MPLSネットワークの出力側でサポートされるMPLS QoS機能について説明します。

入力ポート機能

FlexWANおよび拡張FlexWANモジュール ポートの機能は、match mpls experimentalコマンドを使用して分類します。match mpls experimentalコマンドは、受信した最上位レベルのラベル内のEXPについては照合しません。

Supervisor Engine 2およびSupervisor Engine 720-3BXLでは、EXPの照合がサポートされます。

出力ポート機能

FlexWANおよび拡張FlexWANモジュール ポートの機能は、送信したIPヘッダー内の情報に基づいて分類します。

Supervisor Engine 2およびSupervisor Engine 720-3BXLでは、EXPの照合がサポートされます。

MPLSコア

ここでは、MPLS/MPLSコアでサポートされるMPLS QoS機能について説明します。

入力ポート機能

FlexWANおよび拡張FlexWANモジュール ポートの機能は、match mpls experimentalコマンドを使用して分類します。match mpls experimentalコマンドは、受信した最上位レベルのラベル内のEXPについて照合します。

Cisco Supervisor Engine 2およびSupervisor Engine 720-3BXLでは、EXPビットに基づいた入力QoSポリシーでのEXPマーキングがサポートされます。

出力ポート機能

FlexWANおよび拡張FlexWANモジュール ポートの機能は、match mpls experimentalコマンドを使用して分類します。

Supervisor Engine 2およびSupervisor Engine 720-3BXLでは、EXPマーキングがサポートされます。

MPLS QoSの設定


) MPLS VPNネットワークのエッジおよびコアにおける入力および出力ポート機能については、
「FlexWANおよび拡張FlexWANでのMPLS QoSの使用」を参照してください。


QoSはモジュラ式のQoS CLIを使用して設定します(クラス マップおよびポリシー マップ)。QoS機能はFlexWANおよび拡張FlexWANモジュールに分散されて実行されます。

ここでは、MPLS QoSの設定について説明します。

「FlexWAN MPLS QoS(Supervisor Engine 2の場合)」

「FlexWAN MPLS QoS(SUP720-3BXLの場合)」

「サポート対象のFlexWANおよび拡張FlexWAN MPLS QoS機能」

「MPLS EXPフィールドの概要」

「MPLS EXPフィールドの設定」

「MPLS用のクラス ベースド マーキングの設定」

FlexWAN MPLS QoS(Supervisor Engine 2の場合)

Supervisor Engine 2が搭載されている場合、FlexWANおよび拡張FlexWANモジュールはラベル検索およびラベル操作を実行します。Supervisor Engine 2の場合にFlexWANおよび拡張FlexWANモジュールが提供する機能は、次のとおりです。

IP ToS/DSCPをMPLS EXPビットにマップする機能

ラベルのEXPビットに基づいた出力キューイング

MQCのガイドラインに基づいたコンフィギュレーション コマンド

FlexWAN MPLS QoS(SUP720-3BXLの場合)

SUP720-3BXLはMPLS QoS機能を提供しますが、FlexWANおよび拡張FlexWANモジュールはそれらの機能を使用しません。すべてのMPLS QoS機能は、FlexWANおよび拡張FlexWANモジュールによって分散されます。この点は、FlexWANおよび拡張FlexWANモジュールのQoS動作は、Cisco 7500 VIPのQoSと同様です。SUP720-3BXLの場合、FlexWANおよび拡張FlexWANモジュールがすべての入出力QoSを実行し、SUP720-3BXLがMPLSスイッチングを実行します。


) Cisco 7500 VIPでは、MPLS DiffServトンネリング モードにqos-groupおよびdiscard-classを多く使用します。しかし、Supervisor Engine 2およびSUP720-3BXLはどちらもqos-groupまたはdiscard-classをサポートしません。


SUP720-3BXLでは、FlexWANおよび拡張FlexWANモジュールは次の機能を提供します。

IP ToS/DSCP/EXPを出力CoSビットにマップする機能

出力CoSビットに基づいたMPLSパケットの出力キューイング。PFC3BXLは、最上位の発信EXPビットを出力CoS値にコピーします。FlexWANおよび拡張FlexWANモジュールは、match mpls experimentalコマンドを使用して出力CoS値を照合します。

MQCのガイドラインに基づいたコンフィギュレーション コマンド

サポート対象のFlexWANおよび拡張FlexWAN MPLS QoS機能

FlexWANおよび拡張FlexWANモジュールは、次のMPLS QoS機能をサポートします。

MPLS EXP分類を使用するQoS機能

MPLS EXPポリシングおよびマーキング

MPLS QoSではその他に、次のQoS機能がIP QoSの場合と同様にサポートされます。

Weighted Fair Queuing(WFQ;均等化キューイング)

Class Based Weighted Fair Queuing(CBWFQ;クラス ベース均等化キューイング)

Low Latency Queuing(LLQ;低遅延キューイング)

Weighted Random Early Detection(WRED;重み付きランダム早期検出)

トラフィック シェーピング

ポリシング


) AToM QoS機能については、「AToMでQoSを設定する方法」を参照してください。


MPLS EXPフィールドの概要

サービス プロバイダーが自社ネットワークを通過するIPパケット内で変更されたIP precedence値の使用を望まない場合があります。MPLS experimental(EXP)フィールド値を設定すると、そのようなサービス プロバイダーのニーズを満たせます。

MPLS EXPフィールドにさまざまな値を選択することによって、輻輳時でもパケットに必要なプライオリティが得られるように、パケットをマーキングできます。

デフォルトでは、付加時にIP precedence値がMPLS experimentalフィールドにコピーされます。MPLS EXPビットはポリシーでマーキングできます。

図4-2に、カスタマー ネットワークの2つのサイトを接続する、サービス プロバイダーのMPLSネットワークを示します。

図4-2 カスタマーIPネットワークの2つのサイトを接続するMPLSネットワーク

 

MPLS EXPフィールドの設定

入力インターフェイス上でset mpls experimentalコマンドを使用し、ラベル付加時にプッシュされたラベル エントリの値を設定します。

デフォルトでは、ラベル エッジ ルータがプッシュされたすべてのラベル エントリのMPLS EXP
フィールドに、IPパケットのIP precedenceをコピーします。

set mpls experimental コマンドを使用することにより、任意でMPLSヘッダーのMPLS EXPフィールドにIP precedenceまたはDSCPフィールドをマップできます。

MPLS用のクラス ベースド マーキングの設定

MPLS用のクラス ベースド マーキングを設定するには(Supervisor Engine 2またはSUP720-3BXL)、次に説明する作業が必要です。

「MPLSパケットを分類するクラス マップの設定」

「MPLS experimentalフィールドを設定するポリシー マップの設定」

「サービス ポリシーの結合」

「QoS動作の確認」


) MPLS用のクラス ベースド マーキング(Supervisor Engine 2)は、入力PEのPに対応するインターフェイス上に限ってサポートされます。


MPLSパケットを分類するクラス マップの設定

クラス マップを設定するには、グローバル コンフィギュレーション モードから始めて次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map class-name

パケットを照合させるクラス マップを指定します。

ステップ 2

Router(config-cmap)# match mpls experimental value

クラスと照合させるパケット特性を指定します。

ステップ 3

Router(config-cmap)# exit

クラス マップ コンフィギュレーション モードを終了します。

次に、MPLS experimental値が3のすべてのパケットがexp-classという名前のクラスでanyと一致する例を示します。

Router(config)# class-map match-any exp-class
Router(config-cmap)# match mpls experimental 3
Router(config-cmap)# exit

MPLS experimentalフィールドを設定するポリシー マップの設定

ポリシー マップを設定するには、グローバル コンフィギュレーション モードから始めて次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-name

1つ以上のインターフェイスに結合可能なポリシー マップを作成し、サービス ポリシーを指定します。

ステップ 2

Router(config-pmap)# class class-name

class-map コマンドですでに指定されているクラス マップ名を指定します。

ステップ 3

Router(config-pmap-c)# set mpls experimental value1

パケットを指定のポリシー マップと照合させる場合は、MPLSビットの設定値を指定します。

ステップ 4

Router(config-pmap-c)# exit

ポリシー マップ コンフィギュレーション モードを終了します。

1.シェーピングなど、サポート対象の他の機能を設定することもできます。

次に、ポリシー マップMARKINGと照合させる各パケットのMPLS experimentalフィールド値を5に設定する例を示します。

Router(config)# policy-map MARKING
Router(config-pmap)# class exp-class
Router(config-pmap-c)# set mpls experimental 5
Router(config-pmap-c)# exit
Router(config-pmap)# exit

サービス ポリシーの結合

インターフェイスにサービス ポリシーを結合するには、グローバル コンフィギュレーション モードから始めて次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface name

出力インターフェイスを指定します。

ステップ 2

Router(config-if)# service-policy {input | output} policy-name

指定のポリシー マップをインターフェイスに結合します。

ステップ 3

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

次に、サービス ポリシーset_experimental_5をPOS出力インターフェイスPOS6/0/0に結合する例を示します。

Router(config)# policy-map MARKING
Router(config-pmap)# class exp-class
Router(config-pmap-c)# set mpls experimental 5
Router(config-pmap-c)# exit
Router(config-pmap)# exit
 
Router(config)# interface POS6/0/0
Router(config-if)# service-policy output set_experimental_5
Router(config-if)# exit

QoS動作の確認

MPLS QoSの動作を確認する手順は、次のとおりです。

 

コマンド
目的

Router# show policy-map interface [interface-name]

QoSの詳細情報を表示します。

設定例

ここで紹介する設定例は、Cisco 7600シリーズ ルータ上でサポートされるFlexWANおよび拡張FlexWANモジュールに当てはまります。

入力PEルータの設定

次に、MPLSネットワークに入るIP precedenceが1のIPパケットを2000000 bpsにシェーピングし、MPLS experimentalフィールドを3に設定する例を示します。


ステップ 1 トラフィック クラスを定義します。

Router(config)# class-map exp1
Router(config-cmap)# match mpls experimental 1
Router(config-cmap)# exit
 

) IP precedence値ではなくMPLS experimental値と照合させるように、トラフィック クラスを定義する必要があります。


ステップ 2 トラフィック クラスに対してアクションを実行するポリシーを定義します。

Router(config)# policy-map gold1
Router(config-pmap)# class exp 1
Router(config-pmap-c)# shape average 2000000
Router(config-pmap-c)# set mpls experimental 3
Router(config-pmap-c)# exit
 

ステップ 3 PEルータの出力インターフェイスにポリシーを適用します。

Router(config)# interface POS6/1/0
Router(config-if)#ip address 153.61.0.2 255.255.0.0
Router(config-if)#tag-switching ip
Router(config-if)#service-policy output gold1
Router(config-if)#exit
 


 

コア ルータの入力側および出力側の設定

次に、Pルータで入力側および出力側を設定する例を示します。


ステップ 1 入力側を設定します。

Router(config)# interface pos 5/0/0
Router(config-if)# ip address 153.61.0.1 255.255.0.0
Router(config-if)# tag-switching ip
Router(config-if)# service-policy input gold1

ステップ 2 出力側を設定します。

Router(config)# interface pos 5/0/3
Router(config-if)# ip address 153.62.0.1 255.255.0.0
Router(config-if)# tag-switching ip
Router(config-if)# service-policy input gold1
 


 

MPLS VPNの設定

ここではMPLS VPNの設定方法について説明します。

「FlexWANおよび拡張FlexWANモジュールでのMPLS VPN」

「MPLS VPNサポート」

「MPLS VPNの注意事項および制限事項」

「MPLS VPNのメモリ要件および推奨事項」

「MPLSのラベルに基づくロードバランシング」

MPLS VPNの設定については、次のURLにアクセスして『MPLS Virtual Private Networks』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t7/vpn_en.htm

FlexWANおよび拡張FlexWANモジュールでのMPLS VPN

Supervisor Engine 2の場合、入力側FlexWANまたは拡張FlexWANモジュールはパケットを受信し、MFIB検索を実行し、パケットをSupervisor Engine 2に送ります。Supervisor Engine 2は出力側FlexWANまたは拡張FlexWANモジュールにパケットを送り、そこでVPNラベル(および任意のIGPトンネル ラベル)が付加されます。

SUP720-3BXLでは、入力側拡張FlexWANがパケットを受信してSUP720-3BXLに転送し、そこで必要なVPN検索が実行され、VPNラベル(および任意のIGPトンネル ラベル)が付加されます。SUN720-3BXLはさらに、MPLSパケットを出力側FlexWANまたは拡張FlexWANモジュールに送信し、そこからMPLSフレームが送出されます。

MPLS VPNサポート

MPLS VPNをサポートするのは、次のCatalyst 6000ファミリーおよびCisco 7600シリーズのFlexWANモジュールです。

WS-X6182-2PA FlexWAN

WS-X6582-2PA拡張FlexWAN

MPLS VPNの注意事項および制限事項

MPLS VPNには次の制限が適用されます。

Cisco Supervisor Engine 2を使用するシステムでは、ロードシェアリングはPEのip2tagおよびtag2ipパスでサポートされます。tag2tagパスでのロードバランシングは、独自に設定しないかぎり(MPLSのラベルに基づくロードバランシング)サポートされません。SUP720-3BXLを使用するシステムでは、ロードシェアリングがサポートされます。

Cisco Supervisor Engine 2を使用するシステムでは、MTUの確認および分割はサポートされません。SUP720-3BXLを使用するシステムでは、MTUの確認および分割がサポートされます。

Cisco Supervisor Engine 2またはSUP720-3BXLシステムでFlexWANモジュールだけが搭載されている場合、シャーシあたりの総VRF数は1024です。

MPLS VPNのメモリ要件および推奨事項

Cisco 7600シリーズ ルータまたはCatalyst 6500シリーズ スイッチをMPLS VPN環境でPEルータとして動作させる場合、 表4-1 に記載されたメモリ要件が当てはまります。

 

表4-1 MPLS VPNのメモリ要件および推奨事項

MSFC2のメモリ構成
インターネット ルート、eBGPセッション、およびVPNv4ルートの最大数

512 MBのMSFC2

100,000のインターネット ルート、750のeBGPセッション、および100,000のVPNv4ルート

Supervisor Engine 2のメモリ構成
インターネット ルート、eBGPセッション、およびVPNv4ルートの最大数

256 MBのSupervisor Engine 2

100,000のインターネット ルート、750のeBGPセッション、および175,000のVPNv4ルート

Supervisor Engine 720のメモリ構成
インターネット ルート、eBGPセッション、およびVPNv4ルートの最大数

1 GBのPFC3BXLを搭載したSupervisor Engine 720

1,000,000のインターネット ルート、1200のeBGPセッション、および500,000のVPNv4ルート

FlexWANのメモリ構成
インターネット ルート、eBGPセッション、およびVPNv4ルートの最大数

128 MB×2のFlexWAN

100,000のインターネット ルート、750のeBGPセッション、および75,000のVPNv4ルート

512 MB×2の拡張FlexWAN

1,000,000のインターネット ルート、750のeBGPセッション、および500,000のVPNv4ルート

インターネット ルート、eBGPセッション、およびVPNv4ルートの数が 表4-1 に記載されている数を超える場合は、次に上位のメモリ オプションにアップグレードしてください。システムに
FlexWANモジュールが搭載されている場合、コンフィギュレーション ファイルで指定したインターネット ルート、eBGPセッション、およびVPNv4ルートの数が表に記載されたFlexWANの要件を超えていてはなりません。

MPLSのラベルに基づくロードバランシング


) MPLSのラベルに基づくロードバランシングは、Cisco Supervisor Engine 2を搭載したシステムでサポートされます。


Cisco 7600ルータがPルータとして設定されている場合は、 mpls load-balance per-label コマンドを使用してタグ間トラフィックのロードバランシングをイネーブルまたはディセーブルにすることによって、等コストのパス間でのトラフィックが確実に分散されるようにできます。

イネーブルの場合、MPLSのラベルに基づくロードバランシングによって、MPLSインターフェイス間で着信ラベル(プレフィクス)に基づいてトラフィックが分散されることが保証されます。各MPLSインターフェイスは、等しい数の着信ラベルをサポートします。

mpls load-balance per-label
[no] mpls load-balance per-label
 

デフォルトはディセーブルです。

デフォルトの設定に戻すには、コマンドのno形式を使用します。

次に、タグ間トラフィックのロードバランシングをイネーブルにする例を示します。

Router(config)# mpls load-balance per-label
Router(config)#

) mpls load-balance per-labelコマンドを使用できるのは、Supervisor Engine 2が搭載されたシステムに限られます。


show mpls ttfib コマンドを使用すると、ロードバランサに指定されている着信ラベル(アスタリスク*で表示)を調べることができます。 show mpls ttfib コマンドの出力例を示します。

Router# show mpls ttfib
Local Outgoing Packets Tag LTL Dest. Destination Outgoing
Tag Tag or VC Switched Index Vlanid Mac Address Interface
4116 21 0 0xE0 1020 0000.0400.0000 PO4/1/0*
34 0 0x132 1019 00d0.040d.380a Serial6/1/0
45 0 0xE3 4031 0000.0430.0000 PO4/0/0
4117 16 0 0x132 1019 00d0.040d.380a Serial6/1/0*
17 0 0xE0 1020 0000.0400.0000 PO4/1/0
18 0 0xE3 4031 0000.0430.0000 PO4/0/0
4118 21 0 0xE0 1020 0000.0400.0000 PO4/1/0*
56 0 0xE3 4031 0000.0430.0000 PO4/0/0
4119 35 0 0xE3 4031 0000.0430.0000 PO4/0/0*
47 0 0xE0 1020 0000.0400.0000 PO4/1/0
 

) SUP720-3BXLは、コマンドを使用しないでMPLSラベルの付加されたパケットを処理します。パケットのラベルが3つ以下で、そのパケットがIPv4の場合、SUP720-3BXLは送信元および宛先IPv4アドレスを使用します。パケットがIPv4ではない場合、またはラベルが3つより多い場合、SUP720-3BXLは第5ラベルすなわち最下位のラベルまで解析し、それをハッシュに使用します。


MPLS VPN QoSの設定


) MPLS VPNネットワークのエッジおよびコアにおける入力および出力ポート機能については、
「FlexWANおよび拡張FlexWANでのMPLS QoSの使用」を参照してください。


FlexWANモジュールは、次のMPLS VPN QoS機能をサポートします。

MPLS EXP分類を使用するFlexWAN QoS機能

MPLS EXPマーキング。FlexWANおよび拡張FlexWANモジュールをSupervisor Engine 2と組み合わせた場合に実行されます。「MPLS用のクラス ベースド マーキングの設定」を参照してください。

MPLS EXPポリシングおよびマーキング。FlexWANおよび拡張FlexWANモジュールを
SUP720-3BXLと組み合わせた場合に実行されます。

これらの機能のほかに、Supervisor Engine 2搭載システムの場合、MPLS VPNはFlexWANおよび拡張FlexWANモジュールの入力WANインターフェイス上でset ip precedenceコマンドもサポートします。

FlexWANおよび拡張FlexWANモジュール上のMPLS VPN QoSサポートには、次の制限事項があります。

PFC2のQoS機能は、MPLS VPNではサポートされません。

MPLS VPN QoSがサポートされるのは、VPNインターフェイス上に限られます。

Match IP precedence、Set IP precedence、およびMPLS Experimental値がサポートされるのは、入力インターフェイス上に限られます。

設定例

次に、MPLS VPN上でQoSを設定する例を示します。

Router# configure terminal
Router(config)# class-map match-any vpn-class
Router(config-cmap)# match ip precedence 3
Router(config-cmap)# exit
Router(config)# policy-map VPN-MARKING
Router(config-pmap)# class vpn-class
Router(config-pmap-c)# set ip precedence 5
Router(config-pmap-c)# set mpls exp 5
Router(config-pmap-c)# ^Z
Router# configure terminal
Router(config)# interface POS 6/0/0
Router(config-if)# service-policy output VPN-MARKING
Router(config-if)# ^Z
Router# show running-config interface p6/0/0
Building configuration...
 
Current configuration :175 bytes
!
interface POS 6/0/0
ip vrf forwarding TEST
ip address 194.3.1.3 255.255.255.0
negotiation auto
service-policy input VPN-MARKING
mls qos trust dscp
end

Router#

AToM

Any Transport over MPLS(AToM)は、MPLSバックボーンを介してレイヤ2パケットを転送します。AToMでは、エッジ ルータ間で指定されたLabel Distribution Protocol(LDP)セッションを使用して、接続を確立して維持します。転送は2レベルのラベルを使用し、エッジ ルータ間でスイッチングすることによって行われます。外部ラベル(トンネル ラベル)は、入力PE側で、MPLSバックボーン上を出力PEまでパケットをルーティングします。VCラベルは、トンネル終端(出力PE上の特定の出力インターフェイスおよびAAL5 PDUのVPI/VCI値、フレームリレーPDUのData
Link Connection Identifier(DLCI)値、またはイーサネット フレームのVLAN識別子)で接続を判別する分離(demux)ラベルです。

AToMは、SUP720-3BXL搭載システムおよびSupervisor Engine 2搭載システムに対して、次の
like-to-likeトランスポート タイプをサポートします。

Ethernet over MPLS(VLANモードおよびポート モード)


) SUP720-3BXL搭載システムは、ハードウェアによるEoMPLSとともにOSM、FlexWAN、またはFlexWAN2ベースのEoMPLSをサポートします。


ATM AAL5 over MPLS

ATM Cell Relay over MPLS

Frame Relay over MPLS

AToMを設定するには、次の概念を理解しておく必要があります。

「レイヤ2パケットのAToM伝送」

「旧リリースのAToMとの互換性」

「AToMの利点」

AToMの制限事項

次の制限事項は、AToM環境のあらゆるトランスポート タイプに適用されます。

シーケンシング ― AToMは、異常パケットの検出をサポートしません。

アドレス形式 ― すべてのPEルータ上で、/32がマスクのループバック アドレスになるように、LDPルータIDを設定します。このように設定しない場合、コンフィギュレーションによっては正常に機能しないことがあります。

分解および再組み立て ― 終端間のすべての中間リンクで、MTUを受信した最大のレイヤ2パケットを伝送できるだけの大きさにします。

制御ワード ― CLIで制御ワードをイネーブルまたはディセーブルにすることはできません。制御ワードは FRoMPLSおよびATM AAL5 over MPLSで必須です。ATM Cell Relay over MPLSの場合、制御ワードは任意ですが、現在はCLIオプションがないので付加されません。また、廃棄パケットでの存在は想定されていません。

Ethernet over MPLSの注意事項および制限事項

Ethernet over MPLS機能には、次の制限事項があります。

分解および再組み立て ― 終端間のすべての中間リンクで、MTUを受信した最大のレイヤ2パケットを伝送できるだけの大きさにします。

パケットのフォーマット EoMPLSは、IEEEの802.1Q規格に適合したVLANパケットをサポートします。802.1Q仕様で、イーサネット フレームにVLANメンバーシップ情報を追加する標準方式が定められています。

プライベートVLAN EoMPLSは、プライベートVLANではサポートされません。

レイヤ2接続 EoMPLSでレイヤ2接続を使用する場合の制限事項は、次のとおりです。

ソフトウェアベース(すなわちFlexWAN、拡張FlexWAN、またはOSMベース)のEoMPLSを使用するPE間でダイレクト レイヤ2接続を確立することはできません。

EARLベースのEoMPLSではレイヤ2接続は可能ですが、これはFlexWAN 1および2に関するマニュアルなので、ここでは扱いません。

MPLSバックボーンでイーサネットVLANパケットを伝送するようにルータが設定されている場合、それらのルータ間で複数のレイヤ2接続を使用することはできません。ピア ルータでスパニングツリー ツリーがディセーブルの場合に、2つめのレイヤ2接続を追加すると、スパニングツリー ステートが常時切り替わることになります。

Ethernet over MPLSおよびトランク ― Ethernet over MPLSとともにトランクを使用する場合は、次の制限事項があります。詳細については、Cisco 7600シリーズ ルータのソフトウェア マニュアルを参照してください。

スパニングツリー ― EoMPLSクラウド上でイーサネット スパニングツリーBridge Protocol Data Unit(BPDU;ブリッジ プロトコル データ ユニット)をサポートする場合は、Ethernet over MPLS VLANのスーパバイザ エンジン スパニングツリーをディセーブルにする必要があります。ディセーブルに設定することにより、EoMPLS VLANがカスタマー スイッチへのトランクだけで伝送されるようになります。ディセーブルに設定しなかった場合は、BPDUがEoMPLSクラウドではなく、スーパバイザ エンジンに送られます。

ネイティブVLAN ― トランクのネイティブVLANをEoMPLS VLANとして設定することはできません。

L2プロトコル トンネリング PFC3BXL搭載システムでは、MPLSクラウドでどのプロトコル(CDP、VTP、BPDUなど)をトンネリングし、どのプロトコルをローカルで終端させるかの設定をユーザ側で選択できます。これはソフトウェア スイッチング パスでサポートされます。

EoMPLSパケットを受信するインターフェイスでは、ISLカプセル化はサポートされません。

固有のVLANがインターフェイス間に必要です。さまざまなインターフェイスに同じVLAN IDを使用することはできません。

ルーティング テーブルおよびCEFテーブルのEoMPLSトンネル宛先ルートは、/32ビット マスクのアドレスを指定して設定し、PEルータ間でMPLS転送が正しく行われるようにする必要があります。この制限事項は、すべてのAToMトランスポートに当てはまります。

802.1Q over EoMPLSで802.1Qがサポートがサポートされるのは、MPLSネットワークに接続する発信インターフェイスがL2カード上のポートの場合です。

PFC3BXLでは、MPLSネットワークに接続する出力インターフェイスがL2カードの場合、EoMPLSトラフィックのシェーピングはサポートされません。

PFC3BXLを使用するEoMPLSは、宛先MACアドレスがローカル セグメントにあるか、リモート セグメントにあるかを判別するためのレイヤ2検索を実行しません。また、(従来のLANブリッジングのように)レイヤ2のアドレス ラーニングを実行しません。この機能(ローカル スイッチングまたはヘアピン処理)を利用できるのは、アップリンクとしてFlexWANベースのモジュールを使用している場合だけです。

ATM AAL5 over MPLSの制限事項

ATM AAL5 over MPLS機能には、次の制限事項があります。

分解および再組み立て ― 終端間のすべての中間リンクで、MTUを受信した最大のレイヤ2パケットを伝送できるだけの大きさにします。

ATM Cell Relay over MPLSの制限事項

ATM Cell Relay over MPLS機能には、次の制限事項があります。

PVCでの設定 PVC上に限り、ATM Cell Relay over MPLSを設定できます。

Single Cell Relay over MPLS(SCRoMPLS): このリリースでは、各MPLSパケットにATMセルが1つずつ含まれます。言い換えると、ATMセルごとに1つのパケットとして伝送されます。


) セルのパッキングはサポートされません。


SCRoMPLSでは、VCの片側にATM Port Adapter(PA;ポート アダプタ)インターフェイスを装備したWS-X6182-2PA FlexWANまたはWS-X6582-2PA拡張FlexWANがある場合、MPLSクラウドの両側でVPI/VCIが一致していなければなりません。


) SCRoMPLSでは、VCの片側にATM PAインターフェイスを装備したWS-X6182-2PA
FlexWANまたはWS-X6582-2PA拡張FlexWANがあり、VPI/VCIが一致していなかった場合、VCはアクティブになりますが、トラフィックをスイッチングしません。


制御ワード 制御ワードはサポートされません。

VCCモード ATM Cell Relay over MPLSがサポートするのは、Virtual Channel Connection(VCC;仮想チャネル接続)モードだけです。

分解および再組み立て ― 終端間のすべての中間リンクで、MTUを受信した最大のレイヤ2パケットを伝送できるだけの大きさにします。

Frame Relay over MPLSの制限事項

Frame Relay over MPLS機能には、次の制限事項があります。

ポートベース モード(多対1): 特定のインターフェイス/ポートで着信したすべてのDLCIが1つのMPLS LSPにマップされます。このモードはサポートされません。

FRF.12はPE-CEリンクではサポートされません。

MPLS LSPで伝送されるLFI/MLPPP over FR DLCIはサポートされません。

設定されたEXP値に基づいてMPLS EXPにDEビットをマッピングすることはサポートされません。

レイヤ2パケットのAToM伝送

AToMは入力PEでレイヤ2フレームをカプセル化して、擬似回線の反対側の対応PEに送信します。これが2つのPEルータ間の接続です。出力PEはカプセル化を解除して、レイヤ2フレームを送信します。

PEルータ間でレイヤ2フレームが正しく伝送されるかどうかは、PEルータの設定しだいです。ルータ間で接続(擬似回線)を確立します。各PEルータ上で次の情報を指定します。

擬似回線で伝送するレイヤ2データのタイプ(イーサネット、フレームリレー、ATMなど)

ピアPEルータのループバック インターフェイスのIPアドレス(PEルータが通信可能になる)

擬似回線を固有のものとして表すVC ID

次に、レイヤ2パケットを伝送できるようにPEルータを設定する基本的な手順を示します。トランスポート タイプ(EoMPLS、ATMoMPLS、FRoMPLS)ごとに、少しずつ手順が異なります。


ステップ 1 PEルータ上のインターフェイスまたはサブインターフェイスを定義します。

Router# interface interface-type interface-number
 

ステップ 2 インターフェイスのカプセル化タイプ(dot1qなど)を指定します。

Router(config-if)# encapsulation encapsulation-type
 

ステップ 3 次の作業を行います。

ピアPEルータのLDPルータIDを指定することによって、ピアPEルータに接続します。

2つのPEルータ間で共有する、固有の識別子を指定します。vcid は32ビットの識別子です。

peer-router-idとVC IDの組み合わせは、ルータ上で固有でなければなりません。2つの回線で同じ組み合わせのpeer-router-idとVC IDを使用することはできません。

擬似回線でデータをカプセル化するためのトンネリング方式を指定します。AToMの場合、データをカプセル化するためのトンネリング方式はmplsです。

Router(config-if)# mpls l2transport route destination vc-id

) この例では、インターフェイスそのものにmpls l2transport routeコマンドを指定しています。FRoMPLSまたはATMoMPLSの場合、これは当てはまりません。この設定が有効なのは、VLANインターフェイス上のソフトウェアベースVLANモードEoMPLSだけです。


 


 

旧リリースのAToMとの互換性

旧リリースのAToMでは、AToM回線を設定するコマンドがmpls l2 transport routeでした。これがxconnectコマンドに変更されました。xconnectコマンドを使用すると、FRoMPLSおよびEoMPLS回線を設定できます。


) ATM AAL5 over MPLS回線およびATM Cell Relay over MPLS回線を設定するには、mpls l2 transport routeコマンドを使用する必要があります。


AToMの利点

ここでは、MPLSネットワークでレイヤ2パケットを送信できるようにする、利点のうちのいくつかについて説明します。

AToM製品群は、Cisco 7600シリーズ ルータを含めた複数のシスコ製ルータ プラットフォームにまたがり、イーサネット、フレームリレーをはじめ、多数のレイヤ2パケット タイプに対応します。したがって、サービス プロバイダーはあらゆるタイプのトラフィックをバックボーンで伝送し、あらゆるタイプのカスタマーに対応できます。

AToMはMPLS上でレイヤ2パケットを伝送するために開発された規格に準拠しています(AToMが準拠している具体的な規格については、Ethernet over MPLSを参照)。このことは、ネットワークに標準のメソドロジーを組み込もうとするサービス プロバイダーにとって有利です。他のレイヤ2ソリューションは独自仕様なので、ネットワークの拡張に関してサービス プロバイダーが制約を受ける可能性があります。また、サービス プロバイダーが1つのベンダーの機器に拘束されることにもなりかねません。

AToMへのアップグレードは、カスタマーに対してトランスペアレントです。サービス プロバイダーのネットワークはカスタマー ネットワークから切り離されるので、サービス プロバイダーはカスタマーへのサービスに影響を与えることなくAToMにアップグレードできます。カスタマーにとっては、従来のレイヤ2バックボーンを使用しているのと同じです。

AToMの設定方法

ここではAToMの基本的な設定方法について、次の手順を含めて説明します。

「Ethernet over MPLS」

「ATM AAL5 over MPLS VCモード」

「ATM Cell Relay over MPLS VCモード」

「Frame Relay over MPLS」

「レイヤ2ローカル スイッチング」

前提条件

AToMを設定する前に、ネットワークを次のように設定しておいてください。

PEルータがIPを使用して相互に到達できるように、コアでIPルーティングを設定します。

PEルータ間にLSPが存在するように、コアでMPLSを設定します。

AToMおよびQoS

MPLS AToMでは、ラベルの3つのEXPビットを使用して、パケットのキューを判別します。LSPトンネル ラベルは最後から2つめのルータで削除される可能性があるので、VCラベルとLSPトンネル ラベルの両方にEXPビットを固定的に設定します。詳細については、「AToMでQoSを設定する方法」を参照してください。

Ethernet over MPLS

Ethernet over MPLSは、MPLSパケットでイーサネットPDUをカプセル化し、MPLSネットワーク上で転送することによって機能します。各PDUは1つのパケットとして転送されます。Ethernet over MPLSはさまざまな方法で設定できます。

VLANモード ― MPLSネットワーク上の1つのVCを使用して、送信元の802.1Q VLANから宛先の802.1Q VLANまで、イーサネット トラフィックを伝送します。

ポート モード ― ポート上のすべてのトラフィックにMPLSネットワーク上の1つのVCを共有させます。

EoMPLSを設定する方法は、SUP720-3BXLシステムでは2つ、Supervisor Engine 2搭載システムでは1つです。

SUP720-3BXLベースのEoMPLS

SUP720-3BXLベースのシステムでは、Supervisor Engine 720がMPLS機能をサポートします。
Supervisor Engine 720はFlexWANモジュールを使用しないで、L2トラフィックを受信し、ラベルを付加し、MPLSコアにフレームをスイッチングします。

MPLSネットワークのコアに対応するFlexWANモジュールをSUP720-3BXLベース システムに装備することもできます。この場合、FlexWANベースのコンフィギュレーションとSUP720-3BXLベースのコンフィギュレーションのどちらでも使用できます。


) MPLSネットワークのコアに対応するようにOSMを設定することもできます。
http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/optical/122sx/mpls.htm#wp1128955を参照してください。



) 1つのシステムで、FlexWANベースのコンフィギュレーションとSUP720-3BXLベースのコンフィギュレーションの両方を同時に有効にできます。シスコはこの構成をサポートしますが、推奨はしません。MPLSコアのアップリンクがFlexWAN対応インターフェイスを経由しないかぎり、FlexWANベースのEoMPLS接続はアクティブになりません。その結果、非WANインターフェイスに届いたFlexWANベースEoMPLSのパケットは廃棄されます。


Cisco Supervisor Engine 2ベースのEoMPLS

MPLSネットワークのコアに対応するFlexWANモジュールをSupervisor Engine 2ベース システムに装備する必要があります。

サポート対象モジュール

EoMPLSをサポートするのは、次のCatalyst 6000ファミリーおよびCisco 7600シリーズのFlexWANモジュールです。

WS-X6182-2PA FlexWAN

WS-X6582-2PA拡張FlexWAN

Supervisor Engine 2またはFlexWANベース システムに対応するEoMPLS VLANモードの設定

FlexWANベース システムの2つの終端間でレイヤ2 VLANパケットが転送されるようにMPLSを設定するには、PEルータ上で次の作業を行います。

OSPFをIGPとして使用する場合は、32ビット マスクを指定してPEルータ上のすべてのループバック アドレスを設定し、PEルータ間のMPLS転送が正しく行われるようにする必要があります。

 

コマンド
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。プロンプトに対してパスワードを入力します。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config-vlan)# vlan {vlan-id | vlan-range}

VLAN IDまたはVLAN範囲を入力します。

ステップ 4

Router(config)# interface gigabitEthernet

レイヤ2インターフェイスを指定します。

ステップ 5

Router(config-if)# switchport

ポートのスイッチングを設定します。

ステップ 6

Router(config-if)# switchport trunk encapsulation dot1

インターフェイスがトランキング モードのときのトランク特性を設定します。

ステップ 7

Router(config-if)# switchport trunk allowed vlan range

特定のVLANの許可リストを変更します。

ステップ 8

Router(config-if)# switchport mode trunk

トランキングVLANレイヤ2インターフェイスを指定します。

ステップ 9

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 10

Router (config)# interface vlan vlanid

固有のVLAN ID番号を作成します。

ステップ 11

Router(config-if)# mpls l2transport route destination vc-id

レイヤ2 VLANパケットを伝送するためのVCを指定します。

引数destinationでリモート ルータのループバック アドレスを指定します。

引数vc-idは、ユーザ側で指定する値です。VCごとに固有でなければなりません。VC IDを使用してVCの終端を接続します。

次に、mode trunkの設定を示します。

CE1の設定

!
interface FastEthernet1/0/0
no ip address
no ip mroute-cache
negotiation auto
no cdp enable
no shut
!
interface FastEthernet1/0/0.1
encapsulation dot1Q 2
ip address 180.8.0.1 255.255.0.0
no cdp enable
no shut
!
interface FastEthernet1/0/0.2
encapsulation dot1Q 3
ip address 180.9.0.1 255.255.0.0
no cdp enable
no shut
!
 

CE2の設定

!!
interface FastEthernet4/0/0
no ip address
no ip directed-broadcast
negotiation auto
no cdp enable
no shut
!
interface FastEthernet4/0/0.1
encapsulation dot1Q 2
ip address 180.8.0.2 255.255.0.0
no ip directed-broadcast
no cdp enable
no shut
!
interface FastEthernet4/0/0.2
encapsulation dot1Q 3
ip address 180.9.0.2 255.255.0.0
no ip directed-broadcast
no cdp enable
no shut
!

PE1の設定

!!
vlan 2-3
!
mpls ldp router-id Loopback0 force
!
interface FastEthernet1/0
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-3
switchport mode trunk
no shut
!
interface Vlan2
no ip address
no ip mroute-cache
mpls l2transport route 11.11.11.11 2
no shut
!
interface Vlan3
no ip address
no ip mroute-cache
mpls l2transport route 11.11.11.11 3
no shut
!
interface Loopback0
ip address 13.13.13.13 255.255.255.255
!
 

PE2の設定

!
vlan 2-3
!
mpls ldp router-id Loopback0 force
!
interface FastEthernet1/1
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-3
switchport mode trunk
no shut
!
interface Vlan2
no ip address
no ip mroute-cache
mpls l2transport route 13.13.13.13 2
no shut
!
interface Vlan3
no ip address
no ip mroute-cache
mpls l2transport route 13.13.13.13 3
no shut
!
interface Loopback0
ipaddress 11.11.11.11 255.255.255.255
!
 

SUP720-3BXLベース システムにEoMPLS VLANモードを設定する手順については、
http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/optical/122sx/mpls.htm#wp1252154 を参照してください。

繰り返しますが、FlexWANベースのコンフィギュレーションとSUP720-3BXLベースのコンフィギュレーションのどちらでも使用できます。次に、Supervisor Engine 2上のdot1Qトンネリングで両方とも使用する場合の設定を示します。


) IPアドレスは、CE装置のサブインターフェイス上で設定します。


CE1の設定

!
interface POS1/0/0
no ip address
no ip mroute-cache
negotiation auto
no cdp enable
no shut
!
interface POS1/0/1
encapsulation dot1Q 2
ip address 180.8.0.1 255.255.0.0
no cdp enable
no shut
!
interface POS1/0/2
encapsulation dot1Q 3
ip address 180.9.0.1 255.255.0.0
no cdp enable
no shut
!

CE2の設定

!
interface POS4/0/0
no ip address
no ip directed-broadcast
negotiation auto
tag-switching ip
no cdp enable
no shut
!
interface POS4/0/1
encapsulation dot1Q 2
ip address 180.8.0.2 255.255.0.0
no ip directed-broadcast
no cdp enable
no shut
!
interface POS4/0/2
encapsulation dot1Q 3
ip address 180.9.0.2 255.255.0.0
no ip directed-broadcast
no cdp enable
no shut
!

PE1の設定(Supervisor Engine 2)

!
vlan 2-3
!
interface POS1/1/0
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-3
switchport mode trunk
no shut
!
interface Vlan2
no ip address
no ip mroute-cache
mpls l2transport route 11.11.11.11 2
no shut
!
interface Vlan3
no ip address
no ip mroute-cache
mpls l2transport route 11.11.11.11 3
no shut
!

PE2の設定(Supervisor 720)

!
vtp mode transparent
!
interface POS7/1/0
no ip address
no shut
!
interface POS7/1/1
encapsulation dot1Q 2
xconnect 13.13.13.13 2 encapsulation mpls
no shut
!
interface POS7/1/2
encapsulation dot1Q 3
xconnect 13.13.13.13 3 encapsulation mpls
no shut
!

Ethernet over MPLS VLANモード設定時の注意事項

Ethernet over MPLSをVLANモードで設定する場合の注意事項は、次のとおりです。

AToMの制御ワードはサポートされます。しかし、ピアPEが制御ワードをサポートしない場合、制御ワードはディセーブルです。このネゴシエーションはLDPラベル バインドによって行われます。

ハードウェア レベルでCyclic Redundancy Check(CRC;巡回冗長検査)エラー、フレーミング エラー、およびラント パケットのあるイーサネット パケットは、入力側で廃棄されます。

設定の確認

MPLSトンネル上のレイヤ2 VLANトランスポートの設定を表示して確認する手順は、次のとおりです。


ステップ 1 すべてのインターフェイスについて、IPステータスと設定の概要を表示するには、show vlan briefコマンドを発行します。双方向通信が可能なインターフェイスの場合は、Protocolフィールドに[up]が表示されます。インターフェイス ハードウェアが使用可能な場合は、Statusフィールドに[up]が表示されます。

Router# show vlan brief
osr1#sh vlan brief
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------
1 default active
2 VLAN0002 active
3 VLAN0003 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
 

ステップ 2 PEルータの終端が相互に相手を検出したかどうかを確認するには、show mpls ldp discoveryコマンドを発行します。相手のPEルータからLDP helloメッセージを受信したPEルータは、相手のルータと指定のラベル スペースが「検出された」ものとみなします。

Router# show mpls ldp discovery
osr1#show mpls ldp discovery
Local LDP Identifier:
13.13.13.13:0
Discovery Sources:
Interfaces:
POS6/1/0 (ldp): xmit/recv
LDP Id: 12.12.12.12:0
Targeted Hellos:
13.13.13.13 -> 11.11.11.11 (ldp): active/passive, xmit/recv
LDP Id: 11.11.11.11:0
 

ステップ 3 ラベル配布セッションが確立されているかどうかを確認するには、show mpls ldp neighborコマンドを発行します。出力の3行めから、LDPセッションの状態が動作可能であり、メッセージが送受信されていることがわかります。

Router# show mpls ldp neighbor
osr1#show mpls ldp neighbor
Peer LDP Ident: 12.12.12.12:0; Local LDP Ident 13.13.13.13:0
TCP connection: 12.12.12.12.646 - 13.13.13.13.11010
State: Oper; Msgs sent/rcvd: 1649/1640; Downstream
Up time: 23:42:45
LDP discovery sources:
POS6/1/0, Src IP addr: 34.0.0.2
Addresses bound to peer LDP Ident:
23.2.1.14 37.0.0.2 12.12.12.12 34.0.0.2
99.0.0.1
Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 13.13.13.13:0
TCP connection: 11.11.11.11.646 - 13.13.13.13.11013
State: Oper; Msgs sent/rcvd: 1650/1653; Downstream
Up time: 23:42:29
LDP discovery sources:
Targeted Hello 13.13.13.13 -> 11.11.11.11, active, passive
Addresses bound to peer LDP Ident:
11.11.11.11 37.0.0.1 23.2.1.13
 

ステップ 4 ラベル転送テーブルが正しく作成されているかどうかを確認するには、show mpls forwarding-tableコマンドを発行します。出力に示されるデータは、次のとおりです。

Local tag ― このルータが割り当てたラベル

Outgoing tag or VC ― 次ホップが割り当てたラベル

Prefix or Tunnel Id ― このラベルを持つパケットの行き先となるアドレスまたはトンネル

Bytes tag switched ― この着信ラベルでスイッチングされたバイト数

Outgoing interface ― このラベルのパケットが通過したインターフェイス

Next Hop ― 発信ラベルを割り当てたネイバのIPアドレス

Router# show mpls forwarding-table
osr1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 223.255.254.254/32 \
0 Gi2/1 23.2.0.1
20 Untagged l2ckt(2) 133093 Vl2 point2point
21 Untagged l2ckt(3) 185497 Vl3 point2point
24 Pop tag 37.0.0.0/8 0 POS6/1/0 34.0.0.2
25 17 11.11.11.11/32 0 POS6/1/0 34.0.0.2
26 Pop tag 12.12.12.12/32 0 POS6/1/0 34.0.0.2
osr1#
 

ステップ 5 現在ルーティングされているVCの状態を調べるには、show mpls l2transport vcコマンドを発行します。

Router# show mpls l2transport vc
osr1#show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Vl2 Eth VLAN 2 11.11.11.11 2 UP
Vl3 Eth VLAN 3 11.11.11.11 3 UP

 

ステップ 6 各VCの詳細情報を表示するには、キーワードdetailを追加します。

Router# show mpls l2transport vc detail
osr1#show mpls l2transport vc detail
Local interface: Vl2 up, line protocol up, Eth VLAN 2 up
Destination address: 11.11.11.11, VC ID: 2, VC status: up
Tunnel label: 17, next hop 34.0.0.2
Output interface: POS6/1/0, imposed label stack {17 18}
Create time: 01:24:44, last status change time: 00:10:55
Signaling protocol: LDP, peer 11.11.11.11:0 up
MPLS VC labels: local 20, remote 18
Group ID: local 71, remote 89
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 1009, send 1019
byte totals: receive 133093, send 138089
packet drops: receive 0, send 0
 
Local interface: Vl3 up, line protocol up, Eth VLAN 3 up
Destination address: 11.11.11.11, VC ID: 3, VC status: up
Tunnel label: 17, next hop 34.0.0.2
Output interface: POS6/1/0, imposed label stack {17 19}
Create time: 01:24:38, last status change time: 00:10:55
Signaling protocol: LDP, peer 11.11.11.11:0 up
MPLS VC labels: local 21, remote 19
Group ID: local 72, remote 90
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 1406, send 1414
byte totals: receive 185497, send 191917
packet drops: receive 0, send 0
 


 

Supervisor Engine 2またはFlexWANベース システムに対応するEoMPLSポート モードの設定

FlexWANベース システムにおいて、EoMPLS上で802.1Q-in-802.1Qトラフィックおよびネイティブ イーサネット トラフィックをサポートするには、次の手順で、ポートベースのEoMPLSを設定します。

 

コマンド
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。プロンプトに対してパスワードを入力します。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config-vlan)# vlan {vlan-id | vlan-range}

VLAN IDまたはVLAN範囲を入力します。

ステップ 4

Router(config-vlan)vlan dot1q tag native

トランクのすべてのVLANに対してdot1qタギングをイネーブルにします。

ステップ 5

Router(config)# interface gigabitEthernet

レイヤ2インターフェイスを指定します。

ステップ 6

Router(config-if)# switchport

ポートのスイッチングを設定します。

ステップ 7

Router(config-if)# switchport mode dot1qtunnel

トランキング モードをトンネリングに設定します。

ステップ 8

Router(config-if)# switchport access vlan vlan_id

指定のVLANからのトラフィックを受け付けるようにポートを設定します。

ステップ 9

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 10

Router (config)# interface vlan vlanid

固有のVLAN ID番号を作成します。

ステップ 11

Router(config-if)# mpls l2transport route destination vc-id

 

レイヤ2 VLANパケットを伝送するためのVCを指定します。

引数destinationでリモート ルータのループバック アドレスを指定します。

引数vc-idは、ユーザ側で指定する値です。VCごとに固有でなければなりません。VC IDを使用してVCの終端を接続します。

次に、タグのないパケットに関するポート モード アクセスの設定例を示します。CE装置のメイン インターフェイス上でIPアドレスを設定する必要があります。

CE1の設定

!
interface POS1/0/0
ip address 180.8.0.1 255.255.0.0
no ip mroute-cache
negotiation auto
no cdp enable
no shut
!

CE2の設定

!
interface POS4/0/0
ip address 180.8.0.2 255.255.0.0
no ip directed-broadcast
negotiation auto
tag-switching ip
no cdp enable
no shut
!

PE1の設定

!
vlan 2
!
interface POS1/4/0
no ip address
switchport
switchport access vlan 2
switchport mode access
no shut
!
interface Vlan2
no ip address
no ip mroute-cache
 
mpls l2transport route 11.11.11.11 2
no shut
!

PE2の設定

!
vlan 2
!
interface POS7/0/0
no ip address
switchport
switchport access vlan 2
switchport mode access
no shut
!
interface Vlan2
no ip address
no ip mroute-cache
 
mpls l2transport route 13.13.13.13 2
no shut
!
 

次に、ポート モードdot1Qトンネリングの設定例を示します。この場合、CE装置上でサブインターフェイスを設定する必要があります。パケットに特定のアクセスVLANがあります。

CE1の設定

!
interface POS1/0/0
no ip address
no ip mroute-cache
negotiation auto
no cdp enable
no shut
!
interface POS1/0/1
encapsulation dot1Q 2
ip address 180.8.0.1 255.255.0.0
no cdp enable
no shut
!
interface POS1/0/2
encapsulation dot1Q 3
ip address 180.9.0.1 255.255.0.0
no cdp enable
no shut
!

CE2の設定

!
interface POS4/0/0
no ip address
no ip directed-broadcast
negotiation auto
tag-switching ip
no cdp enable
no shut
!
interface POS4/0/1
encapsulation dot1Q 2
ip address 180.8.0.2 255.255.0.0
no ip directed-broadcast
no cdp enable
no shut
!
interface POS4/0/2
encapsulation dot1Q 3
ip address 180.9.0.2 255.255.0.0
no ip directed-broadcast
no cdp enable
no shut
!

PE1の設定


) この設定には、vlan dot1q tag nativeが必要です。


!
vlan 2
!
vlan dot1q tag native
!
interface POS1/0/1
no ip address
switchport
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode dot1q-tunnel
no cdp enable
spanning-tree bpdufilter enable
no shut
!
interface Vlan2
no ip address
no ip mroute-cache
 
mpls l2transport route 11.11.11.11 2
no shut
!

PE2の設定


) この設定には、vlan dot1q tag nativeが必要です。


!
vlan 2
!
vlan dot1q tag native
!
interface POS7/1/0
no ip address
switchport
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode dot1q-tunnel
no cdp enable
spanning-tree bpdufilter enable
no shut
!
interface Vlan2
no ip address
no ip mroute-cache
 
mpls l2transport route 13.13.13.13 2
no shut
!

SUP720-3BXLベース システムにEoMPLSポート モードを設定する手順については、
http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/optical/122sx/mpls.htm#wp1110361 を参照してください。

 


) VLANの基盤ポートがアクセス ポートまたは.1q in .1qトンネルの場合、FlexWANモジュールを使用して、後ろのSupervisor Engine 2の設定例と同様、MPLSコアにアクセスする必要があります。


次に、SUP720-3BXLおよびSupervisor Engine 2の設定例を示します。CE装置の設定も2通り示します。メイン インターフェイス上でIPアドレスを設定する場合とサブインターフェイス上でIPアドレスを設定する場合です。

CE1の設定(メイン インターフェイス)

!
interface POS1/0/0
ip address 180.8.0.1 255.255.0.0
no ip mroute-cache
negotiation auto
no cdp enable
no shut
!

CE1の設定(サブインターフェイス)

!
interface POS1/0/0
no ip address
no ip mroute-cache
negotiation auto
no cdp enable
no shut
!
interface POS1/0/1
encapsulation dot1Q 2
ip address 180.8.0.1 255.255.0.0
no cdp enable
no shut
!
interface POS1/0/2
encapsulation dot1Q 3
ip address 180.9.0.1 255.255.0.0
no cdp enable
no shut
!
!

CE2の設定(メイン インターフェイス)

!
interface POS4/0/0
ip address 180.8.0.2 255.255.0.0
no ip directed-broadcast
negotiation auto
tag-switching ip
no cdp enable
no shut
!

CE2の設定(サブインターフェイス)

!
interface POS4/0/0
no ip address
no ip directed-broadcast
negotiation auto
tag-switching ip
no cdp enable
no shut
!
interface POS4/0/1
encapsulation dot1Q 2
ip address 180.8.0.2 255.255.0.0
no ip directed-broadcast
no cdp enable
no shut
!
interface POS4/0/2
encapsulation dot1Q 3
ip address 180.9.0.2 255.255.0.0
no ip directed-broadcast
no cdp enable
no shut
!

PE1の設定(Supervisor Engine 2)

!
vlan 2
!
interface POS1/1/0
no ip address
switchport
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode dot1q-tunnel
no cdp enable
spanning-tree bpdufilter enable
no shut
!
interface Vlan2
no ip address
no ip mroute-cache
mpls l2transport route 11.11.11.11 2
no shut
!

PE2の設定(SUP720-3BXL)

!
interface GigabitEthernet7/4
no ip address
xconnect 13.13.13.13 2 encapsulation mpls
no shut
!
 

Ethernet over MPLSポート モード設定時の注意事項

Ethernet over MPLSをポート モードで設定する場合の注意事項は、次のとおりです。

AToMの制御ワードはサポートされます。しかし、ピアPEが制御ワードをサポートしない場合、制御ワードはディセーブルです。このネゴシエーションはLDPラベル バインドによって行われます。

ハードウェア レベルでCyclic Redundancy Check(CRC;巡回冗長検査)エラー、フレーミング エラー、およびラント パケットのあるイーサネット パケットは、入力側で廃棄されます。

ポート モードとイーサネットVLANモードを同時に使用することはできません。メイン インターフェイスをポート間トランスポートとしてイネーブルにした場合は、サブインターフェイス上でコマンドを入力することもできません。

設定の確認

MPLSトンネル上のレイヤ2 VLANトランスポートの設定を表示して確認する手順は、次のとおりです。


ステップ 1 すべてのインターフェイスについて、IPステータスと設定の概要を表示するには、show vlan briefコマンドを発行します。双方向通信が可能なインターフェイスの場合は、Protocolフィールドに[up]が表示されます。インターフェイス ハードウェアが使用可能な場合は、Statusフィールドに[up]が表示されます。

Router# show vlan brief
osr1#sh vlan brief
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
2 VLAN0002 active Gi1/4
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
 

ステップ 2 PEルータの終端が相互に相手を検出したかどうかを確認するには、show mpls ldp discoveryコマンドを発行します。相手のPEルータからLDP helloメッセージを受信したPEルータは、相手のルータと指定のラベル スペースが「検出された」ものとみなします。

Router# show mpls ldp discovery
osr1#show mpls ldp discovery
Local LDP Identifier:
13.13.13.13:0
Discovery Sources:
Interfaces:
POS6/1/0 (ldp): xmit/recv
LDP Id: 12.12.12.12:0
Targeted Hellos:
13.13.13.13 -> 11.11.11.11 (ldp): active/passive, xmit/recv
LDP Id: 11.11.11.11:0
 

ステップ 3 ラベル配布セッションが確立されているかどうかを確認するには、show mpls ldp neighborコマンドを発行します。出力の3行めから、LDPセッションの状態が動作可能であり、メッセージが送受信されていることがわかります。

Router# show mpls ldp neighbor
osr1#show mpls ldp neighbor
Peer LDP Ident: 12.12.12.12:0; Local LDP Ident 13.13.13.13:0
TCP connection: 12.12.12.12.646 - 13.13.13.13.11010
State: Oper; Msgs sent/rcvd: 1715/1706; Downstream
Up time: 1d00h
LDP discovery sources:
POS6/1/0, Src IP addr: 34.0.0.2
Addresses bound to peer LDP Ident:
23.2.1.14 37.0.0.2 12.12.12.12 34.0.0.2
99.0.0.1
Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 13.13.13.13:0
TCP connection: 11.11.11.11.646 - 13.13.13.13.11013
State: Oper; Msgs sent/rcvd: 1724/1730; Downstream
Up time: 1d00h
LDP discovery sources:
Targeted Hello 13.13.13.13 -> 11.11.11.11, active, passive
Addresses bound to peer LDP Ident:
11.11.11.11 37.0.0.1 23.2.1.13

ステップ 4 ラベル転送テーブルが正しく作成されているかどうかを確認するには、show mpls forwarding-tableコマンドを発行します。出力に示されるデータは、次のとおりです。

Local tag ― このルータが割り当てたラベル

Outgoing tag or VC ― 次ホップが割り当てたラベル

Prefix or Tunnel Id ― このラベルを持つパケットの行き先となるアドレスまたはトンネル

Bytes tag switched ― この着信ラベルでスイッチングされたバイト数

Outgoing interface ― このラベルのパケットが通過したインターフェイス

Next Hop ― 発信ラベルを割り当てたネイバのIPアドレス

Router# show mpls forwarding-table
osr1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 223.255.254.254/32 \
0 POS2/1/1 23.2.0.1
20 Untagged l2ckt(2) 55146580 Vl2 point2point
24 Pop tag 37.0.0.0/8 0 POS6/1/0 34.0.0.2
25 17 11.11.11.11/32 0 POS6/1/0 34.0.0.2
26 Pop tag 12.12.12.12/32 0 POS6/1/0 34.0.0.2
 

ステップ 5 現在ルーティングされているVCの状態を調べるには、show mpls l2transport vcコマンドを発行します。

Router# show mpls l2transport vc
osr1#show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Vl2 Eth VLAN 2 11.11.11.11 2 UP
 
osr3#show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Gi7/4 Ethernet 13.13.13.13 2 UP
 

ステップ 6 各VCの詳細情報を表示するには、キーワードdetailを追加します。

Router# show mpls l2transport vc detail
osr1#show mpls l2transport vc detail
Local interface: Vl2 up, line protocol up, Eth VLAN 2 up
Destination address: 11.11.11.11, VC ID: 2, VC status: up
Tunnel label: 17, next hop 34.0.0.2
Output interface: POS6/1/0, imposed label stack {17 18}
Create time: 00:15:13, last status change time: 00:11:46
Signaling protocol: LDP, peer 11.11.11.11:0 up
MPLS VC labels: local 20, remote 18
Group ID: local 71, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 407857, send 407684
byte totals: receive 53827205, send 55444697
packet drops: receive 0, send 0
 


 

ATM AAL5 over MPLS VCモード

ATM AAL5 over MPLSは、MPLSパケット内でATM AAL5 SDUをカプセル化して、MPLSネットワーク上で転送します。各ATM AAL5 SDUは1つのパケットとして転送されます。

サポート対象モジュール

ATM AAL5 over MPLSをサポートするのは、次のCatalyst 6000ファミリーおよびCisco 7600シリーズのFlexWANモジュールです。

WS-X6182-2PA FlexWAN

WS-X6582-2PA拡張FlexWAN

ATM AAL5 over MPLS VCモードの設定

MPLSバックボーンの両側でPEルータを設定することによって、MPLSバックボーン ネットワークにAAL5 PDUを受け入れさせることができます。MPLS上でAAL5 PDUを伝送するには、入力PEルータから出力PEルータへの仮想回線を確立します。この仮想回線は、あるPEルータから相手先PEルータにAAL5 PDUを伝送します。

 

コマンドまたはアクション
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。プロンプトに対してパスワードを入力します。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface atmslot/port

ATMインターフェイスを指定します。

ステップ 4

Router(config-if)# pvc vpi/vci l2transport

VPIおよびVCIを割り当てます。l2transport キーワードで、PVCが終端PVCではなくスイッチドPVCであることを指定します。

ATM AAL5を設定できるのは、PVC上に限られます。

ステップ 5

Router(config-if)# encapsulation aal5

PVCのATM AAL5カプセル化方式を指定します。PEおよびCEルータ上でも、同じカプセル化タイプを指定する必要があります。

ステップ 6

Router(config-atm-vc)# mpls l2transport route destination vc-id

レイヤ2パケットを伝送するVCを作成します。


) VCはポイントツーポイント サブインターフェイス、マルチポイント サブインターフェイス、およびすべてのメイン インターフェイスに設定できます。



) WS-X6182-2PA FlexWANまたはWS-X6582-2PA拡張FlexWANが拡張ATM PAを装備している場合、マルチポイント サブインターフェイスまたはメイン インターフェイスに、カプセル化タイプの混在した複数のVCを設定できます。


次に、AAL5 over MPLSの設定例を示します。

 

PE1
PE2
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
 
!
interface Loopback0
ip address 131.131.131.131 255.255.255.255
 
interface ATM9/1.502 point-to-point
mls qos trust dscp
pvc 4/42 l2transport
encapsulation aal5
mpls l2transport route 123.123.123.123 502
!
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
 
!
interface Loopback0
ip address 123.123.123.123 255.255.255.255
 
!
interface ATM9/1.502 point-to-point
description hi-there!
mls qos trust dscp
pvc 4/42 l2transport
encapsulation aal5
mpls l2transport route 131.131.131.131 502
!

設定の確認

show running-configコマンドを使用すると、現在実行中のコンフィギュレーション ファイルの内容、または特定のインターフェイス(たとえば、上記PE1に対応するインターフェイス)の設定が表示されます。

c31#show running-config interface ATM9/1.502
Building configuration...
 
Current configuration : 155 bytes
!
interface ATM9/1.502 point-to-point
mls qos trust dscp
pvc 4/42 l2transport
encapsulation aal5
mpls l2transport route 123.123.123.123 502
! !
end
 

次のshow mpls 12transport vcコマンドは、インターフェイスがAAL5 over MPLS用に設定されていることを示しています。

c31#show mpls l2transport vc vcid 502 detail
Local interface: AT9/1.502 up, line protocol up, ATM AAL5 4/42 up
Destination address: 123.123.123.123, VC ID: 502, VC status: up
Tunnel label: 25, next hop point2point
Output interface: PO4/1, imposed label stack {25 20}
Create time: 1d02h, last status change time: 00:33:28
Signaling protocol: LDP, peer 123.123.123.123:0 up
MPLS VC labels: local 19, remote 20
Group ID: local 82, remote 80
MTU: local 4470, remote 4470
Remote interface description: hi-there!
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 1554872, send 1558795
byte totals: receive 2280634366, send 2281764774
packet drops: receive 0, send 0
 

show atm pvcコマンドを使用すると、すべてのATM PVC情報およびトラフィック情報が表示されます。

c31#
c31#show atm pvc 4/42
ATM9/1.502: VCD: 2, VPI: 4, VCI: 42
UBR, PeakRate: 599040
AAL5 over MPLS, etype:0x1C, Flags: 0xC3F, VCmode: 0x0
InPkts: 1573889, OutPkts: 1569951, InBytes: 2297940310, OutBytes: 2296823212
InPRoc: 0, OutPRoc: 0
InFast: 0, OutFast: 0, InAS: 1573889, OutAS: 1569951
InPktDrops: 0, OutPktDrops: 0
InByteDrops: 0, OutByteDrops: 0
OAM cells received: 0
F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
OAM cells sent: 0
F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
OAM cell drops: 0
Status: UP
 

show atm vcコマンドを使用すると、すべてのATM PVC情報およびSwitched Virtual Circuit(SVC;相手先選択接続)情報、さらにトラフィック情報が表示されます。

c31#show atm vc 2
ATM9/1.502: VCD: 2, VPI: 4, VCI: 42
UBR, PeakRate: 599040
AAL5 over MPLS, etype:0x1C, Flags: 0xC3F, VCmode: 0x0
InPkts: 1573896, OutPkts: 1569957, InBytes: 2297940836, OutBytes: 2296823668
InPRoc: 0, OutPRoc: 0
InFast: 0, OutFast: 0, InAS: 1573896, OutAS: 1569957
InPktDrops: 0, OutPktDrops: 0
InByteDrops: 0, OutByteDrops: 0
OAM cells received: 0
OAM cells sent: 0
Status: UP
 

トラブルシューティングのヒント

トラブルシューティングに役立つコマンドは、debug acircuit、debug mpls l2transport ipc、debug cwan atom、およびdebug mpls l2transport vcです。

ATM Cell Relay over MPLS VCモード

シングル セル リレー機能を使用すると、各MPLSパケットにATMセルを1つずつ挿入できます。

ATM Cell Relay over MPLS VCモードの設定

ATM cell relay over MPLS VCを設定する手順は、次のとおりです。

 

コマンドまたはアクション
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。

プロンプトに対してパスワードを入力します。

ステップ 2

Router(config)# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface atmslot/port

ATMインターフェイスを指定します。

ステップ 4

Router(config-if)# pvc vpi/vci l2transport

VPIおよびVCIを割り当てます。l2transport キーワードで、PVCが終端PVCではなくスイッチドPVCであることを指定します。

ステップ 5

Router(config-if)# encapsulation aal0

ATMセル リレーの場合、このコマンドでインターフェイスに対して未処理セル カプセル化を指定します。

ステップ 6

Router(config-atm-vc)# mpls l2transport route destination vc-id

レイヤ2パケットを伝送するVCを作成します。


) VCはポイントツーポイント サブインターフェイス、マルチポイント サブインターフェイス、およびすべてのメイン インターフェイスに設定できます。



) WS-X6182-2PA FlexWANまたはWS-X6582-2PA拡張FlexWANが拡張ATM PAを装備している場合、マルチポイント サブインターフェイスまたはメイン インターフェイスに、カプセル化タイプの混在した複数のVCを設定できます。



) 各PEルータにOC-12 ATM OSMインターフェイスが1つずつある場合は、VPI/VCIを一致させる必要はありません。VCの片側でPEルータの1つに、ATM PAインターフェイスを装備した
WS-X6182-2PA FlexWANまたはWS-X6582-2PA拡張FlexWANがある場合、VPI/VCIを一致させる必要があります。


次に、Cell Relay over MPLSの設定例を示します。

 

PE1
PE2
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
 
!
interface Loopback0
ip address 131.131.131.131 255.255.255.255
 
!
interface ATM9/1.501 point-to-point
mls qos trust dscp
pvc 4/41 l2transport
encapsulation aal0
mpls l2transport route 123.123.123.123 501
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
 
!
interface Loopback0
ip address 123.123.123.123 255.255.255.255
 
!
interface ATM9/1.501 point-to-point
mls qos trust dscp
pvc 4/41 l2transport
encapsulation aal0
mpls l2transport route 131.131.131.131 501
!

ATM Cell Relay VCモードの確認

show running-configコマンドを使用すると、現在実行中のコンフィギュレーション ファイルの内容、または特定のインターフェイス(上記PE1に対応するインターフェイス)の設定が表示されます。

c31#show running-config interface ATM9/1.501
Building configuration...
 
Current configuration : 155 bytes
!
interface ATM9/1.501 point-to-point
mls qos trust dscp
pvc 4/41 l2transport
encapsulation aal0
mpls l2transport route 123.123.123.123 501
!
end
 

show mpls 12transport コマンドから、インターフェイスがVCモード セル リレーとして設定されていることがわかります。

c31#
c31#show mpls l2transport vc vcid 501 detail
Local interface: AT9/1.501 up, line protocol up, ATM VCC CELL 4/41 up
Destination address: 123.123.123.123, VC ID: 501, VC status: up
Tunnel label: 25, next hop point2point
Output interface: PO4/1, imposed label stack {25 19}
Create time: 1d01h, last status change time: 00:15:55
Signaling protocol: LDP, peer 123.123.123.123:0 up
MPLS VC labels: local 18, remote 19
Group ID: local 82, remote 80
MTU: local n/a, remote n/a
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 48755771, send 48895612
byte totals: receive 2535300092, send 2542571824
packet drops: receive 0, send 0
 
c31#
 

show atm pvcコマンドを使用すると、すべてのATM PVC情報およびトラフィック情報が表示されます。

c31#show atm pvc 4/41
ATM9/1.501: VCD: 1, VPI: 4, VCI: 41
UBR, PeakRate: 599040
AAL0-Cell Relay over MPLS, etype:0x1B, Flags: 0xC3E, VCmode: 0x0
InBytes: 2567612684, OutBytes: 2560342200
Status: UP
 

show atm vcコマンドを使用すると、すべてのATM PVC情報およびSVC情報、さらにトラフィック情報が表示されます。

c31#show atm vc 1
 
ATM9/1.501: VCD: 1, VPI: 4, VCI: 41
UBR, PeakRate: 599040
AAL0-Cell Relay over MPLS, etype:0x1B, Flags: 0xC3E, VCmode: 0x0
InBytes: 2567615492, OutBytes: 2560345424
Status: UP

トラブルシューティングのヒント

トラブルシューティングに役立つコマンドは、debug acircuit、debug mpls l2transport ipc、debug cwan atom、およびdebug mpls l2transport vcです。

Frame Relay over MPLS

Frame Relay over MPLSでは、MPLSパケット内でフレームリレーPDUをカプセル化して、MPLSネットワーク上で転送します。

サポート対象モジュール

FRoMPLSをサポートするのは、次のCisco Catalyst 6000ファミリーおよびCisco 7600シリーズのFlexWANモジュールです。

WS-X6182-2PA FlexWAN

WS-X6582-2PA拡張FlexWAN


) FRoMPLSは、メディア タイプでフレームリレー カプセル化がサポートされるかぎり、あらゆるFlexWAN PAでサポートされます。


DLCI間接続を指定したFRoMPLSの設定

DLCI間接続を指定してFRoMPLSを設定する手順は、次のとおりです。

 

コマンドまたはアクション
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。プロンプトに対してパスワードを入力します。

ステップ 2

Router(config)# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# frame-relay switching

フレームリレー装置上でPVCスイッチングをイネーブルにします。

ステップ 4

Router(config)# interface serialslot/port

シリアル インターフェイスを指定します。

ステップ 5

Router(config-if)# encapsulation frame-relay [cisco | ietf]

インターフェイスに対してフレームリレー カプセル化を指定します。さまざまなカプセル化タイプを指定できます。あるインターフェイスをシスコのカプセル化方式に設定し、もう一方のインターフェイスをIETFのカプセル化方式に設定することもできます。

ステップ 6

Router(config-if)# frame-relay intf-type dce

インターフェイスがDCEスイッチであることを指定します。Network-to-Network Interface(NNI)およびData Terminal Equipment(DTE;データ端末装置)接続をサポートするようにインターフェイスを指定することもできます。

ステップ 7

Router(config)# connect connection-name interface dlci l2transport

フレームリレーPVC間の接続を定義します。l2transportキーワードを使用して、PVCがローカルでスイッチングされるPVCではなく、バックボーン ネットワーク上でトンネリングされることを指定します。

connection-name引数は、ユーザ側で指定する文字列です。

interface引数は、PVC接続を定義するインターフェイスです。

dlci引数は、接続するPVCのDLCI番号です。

ステップ 8

Router(config-if)# xconnect peer-router-id vcid encapsulation mpls

レイヤ2パケットを伝送するVCを作成します。接続タイプがDLCI間の場合、FRoMPLSではconnectサブモードでxconnectコマンドを使用します。

次に、DLCI間接続を指定してFRoMPLSを設定する例を示します。

 

PE1
PE2
frame-relay switching
mpls label protocol ldp
mpls ldp router-id Loopback0 force
tag-switching id
!
interface Loopback0
ip address 13.13.13.13 255.255.255.255
!
interface POS1/1/0
mtu 5000
no ip address
encapsulation frame-relay IETF
mls qos trust dscp
clock source internal
frame-relay lmi-type ansi
frame-relay intf-type dce
!
! P router facing interface POS4/1
!
interface POS4/0/1
mtu 5000
ip address 32.0.0.1 255.0.0.0
mpls label protocol ldp
tag-switching ip
mls qos trust dscp
clock source internal
!
router ospf 100
log-adjacency-changes
passive-interface POS1/1
network 13.13.13.13 0.0.0.0 area 100
network 32.0.0.0 0.255.255.255 area 100
!
connect atom_1 POS1/1/0 16 l2transport
xconnect 11.11.11.11 100 encapsulation mpls
frame-relay switching
mpls label protocol ldp
mpls ldp router-id Loopback0 force
tag-switching id
!
interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface POS7/0/1
mtu 5000
no ip address
encapsulation frame-relay IETF
mls qos trust dscp
clock source internal
frame-relay lmi-type ansi
frame-relay intf-type dce
!
! P router facing interface POS8/0/2
!
interface POS8/2
mtu 5000
ip address 35.0.0.1 255.0.0.0
mpls label protocol ldp
tag-switching ip
mls qos trust dscp
clock source internal
!
router ospf 100
log-adjacency-changes
passive-interface POS7/1
network 11.11.11.11 0.0.0.0 area 100
network 35.0.0.0 0.255.255.255 area 100
!
connect atom_1 POS7/0/1 17 l2transport
xconnect 13.13.13.13 100 encapsulation mpls

設定の確認


) インターフェイスPOS1/1のDLCIとインターフェイスPOS7/1のDLCIを一致させる必要はありません。DLCIは、connectコマンドを使用して接続する、独立した2つのDLCIにできます。


設定を確認するには、show mpls l2transport vcコマンドを使用します。

PE1#sh mpls l2 vc 100 detail
Local interface: PO1/1/0 up, line protocol up, FR DLCI 16 up
Destination address: 11.11.11.11, VC ID: 100, VC status: up
Tunnel label: 17, next hop point2point
Output interface: PO4/0/1, imposed label stack {17 1009}
Create time: 00:09:28, last status change time: 00:01:17
Signaling protocol: LDP, peer 11.11.11.11:0 up
MPLS VC labels: local 1009, remote 1009
Group ID: local 0, remote 0
MTU: local 5000, remote 5000
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 60, send 62
byte totals: receive 8870, send 9648
packet drops: receive 0, send 0
PE2#sh mpls l2 vc 100 detail
Local interface: PO7/0/1 up, line protocol up, FR DLCI 16 up
Destination address: 13.13.13.13, VC ID: 100, VC status: up
Tunnel label: 18, next hop point2point
Output interface: PO8/2, imposed label stack {18 1009}
Create time: 00:03:32, last status change time: 00:01:54
Signaling protocol: LDP, peer 13.13.13.13:0 up
MPLS VC labels: local 1009, remote 1009
Group ID: local 0, remote 0
MTU: local 5000, remote 5000
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 4, send 4
byte totals: receive 1416, send 1388
packet drops: receive 0, send 0
 
PE1#sh frame-relay pvc 16
 
PVC Statistics for interface POS1/1/0 (Frame Relay DCE)
 
DLCI = 16, DLCI USAGE = SWITCHED(tag tunnel), PVC STATUS = ACTIVE, INTERFACE = POS1/1
 
input pkts 68 output pkts 66 in bytes 11500
out bytes 10688 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
switched pkts 0
Detailed packet drop counters:
no out intf 0 out intf down 0 no out PVC 0
in PVC down 0 out PVC down 0 pkt too big 0
shaping Q full 0 pkt above DE 0 policing drop 0
pvc create time 00:16:28, last time pvc status changed 00:09:34
 
PE2#sh frame-relay pvc 16
 
PVC Statistics for interface POS7/0/1 (Frame Relay DCE)
 
DLCI = 16, DLCI USAGE = SWITCHED(tag tunnel), PVC STATUS = ACTIVE, INTERFACE = POS7/1
input pkts 27 output pkts 28 in bytes 5676
out bytes 6110 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
switched pkts 0
Detailed packet drop counters:
no out intf 0 out intf down 0 no out PVC 0
in PVC down 0 out PVC down 0 pkt too big 0
shaping Q full 0 pkt above DE 0 policing drop 0
pvc create time 00:10:50, last time pvc status changed 00:10:21

レイヤ2ローカル スイッチング

ローカル スイッチングを使用すると、同じルータ上のタイプが同じ2つのインターフェイス間(ATM間またはフレームリレー間)で、またはタイプの異なるインターフェイス間(フレームリレー/ATMまたはATM/イーサネット)間で、レイヤ2データをスイッチングできます。インターフェイスは同じライン カード上にあっても、2つの異なるカード上にあってもかまいません。

ここでは、ATM間でレイヤ2ローカル スイッチングを行う方法、およびフレームリレーDLCIローカル スイッチングを行う方法について説明します。

「レイヤ2ローカル スイッチング(ATM間)」

「フレームリレーDLCIローカル スイッチングの設定」

「他のPE装置がフレームリレー パケットを伝送できるようにする方法」

レイヤ2ローカル スイッチング(ATM間)

ATM間のレイヤ2ローカル スイッチングは、L2スイッチング機能を提供します。したがって、カスタマーのATM VC/VPからセッション終端サービス プロバイダーのATM VC/VPに流れるトラフィックをスイッチングできます。ATM間のレイヤ2ローカル スイッチングには、3つのモードがあります。

AAL5カプセル化タイプを使用するATM VC間ローカル スイッチング

AAL0カプセル化タイプを使用するATM VC間ローカル スイッチング(セル リレー モード)

AAL0カプセル化タイプを使用するATM VP間ローカル スイッチング

サポート対象モジュール

ATM間のレイヤ2ローカル スイッチングがサポートされるのは、FlexWANおよび拡張FlexWAN上に限られます。

表4-2 に、ポート アダプタ サポートを示します。

 

表4-2 ATM間のレイヤ2ローカル スイッチングをサポートするポート アダプタ

AAL5カプセル化タイプを
使用するATM VC間ローカル
スイッチング
AAL0カプセル化タイプを
使用するATM VC間ローカル
スイッチング
AAL0カプセル化タイプを
使用するATM VP間ローカル
スイッチング

PA-A3-OC3

PA-A3-OC3

PA-A3-OC3

PA-A3-E3

PA-A3-E3

PA-A3-E3

PA-A3-T3

PA-A3-T3

PA-A3-T3

PA-A6-OC3

PA-A6-E3

PA-A6-T3

制限事項

AAL5カプセル化タイプを使用するATM VC間ローカル スイッチング

QoSをサポートしません。

現在、Supervisor Engine 2およびSupervisor Engine 720でサポートされます。

AAL0カプセル化タイプを使用するATM VC間ローカル スイッチング(セル リレー モード)

QoSをサポートしません。

現在、Supervisor Engine 2およびSupervisor Engine 720でサポートされます。

ATMセルごとに1つのパケットとして伝送されます。セル パッキングはサポートされません。

設定できるのはPVC上だけです。

接続の両端に同じVPI/VCIが必要です。VPI/VCIが異なっていると、接続はアクティブになりますが、パケットがスイッチングされません。

AAL0カプセル化タイプを使用するATM VP間ローカル スイッチング

QoSをサポートしません。

現在、Supervisor Engine 2およびSupervisor Engine 720でサポートされます。

ATMセルごとに1つのパケットとして伝送されます。セル パッキングはサポートされません。

設定できるのはPermanent Virtual Pipe(PVP)上だけです。

ATMセルごとに1つのパケットとして伝送されます。セル パッキングはサポートされません。

接続の両端に同じVPI/VCIが必要です。VPI/VCIが異なっていると、接続はアクティブになりますが、パケットがスイッチングされません。

AAL5カプセル化タイプを使用するATM VC間ローカル スイッチングの設定

ATM VC間ローカル スイッチングの設定手順は、次のとおりです。

 

コマンドまたはアクション
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。

プロンプトに対してパスワードを入力します。

ステップ 2

Router(config)# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface atmslot/port

ATMインターフェイスを指定します。

ステップ 4

Router(config-if)# pvc vpi/vci l2transport

VPIおよびVCIを割り当てます。l2transport キーワードで、PVCが終端PVCではなくスイッチドPVCであることを指定します。

ATM AAL5を設定できるのは、PVC上に限られます。

ステップ 5

Router(config-if)# encapsulation aal5

PVCのATM AAL5カプセル化方式を指定します。

ステップ 6

Router(config)# connect connection-name atm slot/port-1 |vpi/vci] atm slot/port-2 [vpi|vci]

ATMインターフェイスを接続します。

次に、AAL5カプセル化タイプを指定したATM VC間ローカル スイッチングの例を示します。

int ATM2/0/0
pvc 100/100 l2transport
encapsulation aal5
int ATM2/1/0
pvc 105/105 l2transport
encapsulation aal5
connect vc2vc ATM2/0/0 100/100 ATM2/1/0 105/105

AAL5カプセル化タイプを使用するATM VC間ローカル スイッチングの確認

show atm pvcコマンドを使用すると、すべてのATM PVC情報およびトラフィック情報が表示されます。

router#show atm pvc 100/100
ATM2/0/0: VCD: 44, VPI: 100, VCI: 100
UBR, PeakRate: 149760
AAL5 L2transport, etype:0x1C, Flags: 0xC3F, VCmode: 0x0
InPkts: 0, OutPkts: 0, InBytes: 0, OutBytes: 0
InPRoc: 0, OutPRoc: 0, Broadcasts: 0
InFast: 0, OutFast: 0, InAS: 0, OutAS: 0
InPktDrops: 0, OutPktDrops: 0
InByteDrops: 0, OutByteDrops: 0
CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0
Out CLP=1 Pkts: 0
OAM cells received: 0
F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
OAM cells sent: 0
F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
OAM cell drops: 0
Status: UP
 
router#show atm pvc 105/105
ATM2/1/0: VCD: 46, VPI: 100, VCI: 100
UBR, PeakRate: 149760
AAL5 L2transport, etype:0x1C, Flags: 0xC3F, VCmode: 0x0
InPkts: 0, OutPkts: 0, InBytes: 0, OutBytes: 0
InPRoc: 0, OutPRoc: 0, Broadcasts: 0
InFast: 0, OutFast: 0, InAS: 0, OutAS: 0
InPktDrops: 0, OutPktDrops: 0
InByteDrops: 0, OutByteDrops: 0
CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0
Out CLP=1 Pkts: 0
OAM cells received: 0
F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
OAM cells sent: 0
F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
OAM cell drops: 0
Status: UP
 

show connection allコマンドを使用すると、設定されているすべての接続が表示されます。

router#show connection all
ID Name Segment 1 Segment 2
State
========================================================================
36 vc2vc ATM2/0/0 100/100 ATM2/1/0 105/105 UP

AAL0カプセル化タイプを使用するATM VC間ローカル スイッチングの設定

AAL0カプセル化タイプを使用するATM VC間ローカル スイッチングの設定手順は、次のとおりです。

 

コマンドまたはアクション
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。プロンプトが表示された場合は、パスワードを入力します。

ステップ 2

Router(config)# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface atmslot/port

ATMインターフェイスを指定します。

ステップ 4

Router(config)# pvc vpi/vci l2transport

 

VPIおよびVCIを割り当てます。l2transport キーワードで、PVCが終端PVCではなくスイッチドPVCであることを指定します。

ステップ 5

Router(config-if)#encapsulation aal0

PVCのカプセル化方式としてATM AAL0を指定します。

ステップ 6

Router(config)# connect connection-name atm slot/port-1 |vpi/vci] atm slot/port-2 [vpi|vci]

ATMインターフェイスを接続します。

次に、AAL0カプセル化タイプを指定したATM VC間ローカル スイッチングの例を示します。

int ATM2/0/0
pvc 100/100 l2transport
encapsulation aal0
int ATM2/1/0
pvc 100/100 l2transport
encapsulation aal0
connect vc2vc ATM2/0/0 100/100 ATM2/1/0 100/100
 

AAL0カプセル化タイプを使用するATM VC間ローカル スイッチングの確認

show atm pvcコマンドを使用すると、すべてのATM PVC情報およびトラフィック情報が表示されます。

router#show atm pvc 100/100
ATM2/0/0: VCD: 44, VPI: 100, VCI: 100
UBR, PeakRate: 149760
AAL5 L2transport, etype:0x1C, Flags: 0xC3F, VCmode: 0x0
InPkts: 0, OutPkts: 0, InBytes: 0, OutBytes: 0
InPRoc: 0, OutPRoc: 0, Broadcasts: 0
InFast: 0, OutFast: 0, InAS: 0, OutAS: 0
InPktDrops: 0, OutPktDrops: 0
InByteDrops: 0, OutByteDrops: 0
CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0
Out CLP=1 Pkts: 0
OAM cells received: 0
F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
OAM cells sent: 0
F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
OAM cell drops: 0
Status: UP
 
router#show atm pvc 100/100
ATM2/1/0: VCD: 46, VPI: 100, VCI: 100
UBR, PeakRate: 149760
AAL5 L2transport, etype:0x1C, Flags: 0xC3F, VCmode: 0x0
InPkts: 0, OutPkts: 0, InBytes: 0, OutBytes: 0
InPRoc: 0, OutPRoc: 0, Broadcasts: 0
InFast: 0, OutFast: 0, InAS: 0, OutAS: 0
InPktDrops: 0, OutPktDrops: 0

InByteDrops: 0, OutByteDrops: 0

CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0

Out CLP=1 Pkts: 0

OAM cells received: 0

F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0

F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0

OAM cells sent: 0

F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0

F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0

OAM cell drops: 0

Status: UP

 

show connection allコマンドを使用すると、設定されているすべての接続が表示されます。

router#show connection all
ID Name Segment 1 Segment 2
State
========================================================================
36 vc2vc ATM2/0/0 100/100 ATM2/1/0 105/105 UP

AAL0カプセル化タイプを使用するATM VP間ローカル スイッチングの設定

AAL0カプセル化タイプを使用するATM VP間ローカル スイッチングの設定手順は、次のとおりです。

 

コマンドまたはアクション
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。

プロンプトに対してパスワードを入力します。

ステップ 2

Router(config)# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface atmslot/port

ATMインターフェイスを指定します。

ステップ 4

Router(config-if)# atm pvp vpi l2transport

PVPがATMセルの伝送専用であることを指定します。
l2transportキーワードで、PVPがセル リレー用であることを指定します。このコマンドを入力すると、 l2transport PVPサブモードが開始されます。このサブモードは、レイヤ2トランスポート専用であり、標準PVPには対応しません。

ステップ 5

Router(config)# connect connection-name atm slot/port-1 |vpi/vci] atm slot/port-2 [vpi|vci]

ATMインターフェイスを接続します。

次に、ATM VP間ローカル スイッチングの例を示します。

int ATM2/0/0
atm pvp 100 l2transport
int ATM2/1/0
atm pvp 100 l2transport
 
connect vp2vp ATM2/0/0 100 ATM2/1/0 100

ATM VP間ローカル スイッチングの確認

次のshow atm vpコマンドは、インターフェイスがVPモード セル リレーとして設定されていることを示しています。

router#show connection all
ID Name Segment 1 Segment 2
State
========================================================================
36 vp2vp ATM2/0/0 100 ATM2/1/0 100 UP
 
BRAS#show atm vp 100
ATM2/0/0 VPI: 100, Cell Relay,
ATM2/0/0 VPI: 100, PeakRate: 0, CesRate: 0, DataVCs: 0, CesVCs: 0, Status: ACTIVE
 
VCD VCI Type InPkts OutPkts AAL/Encap Status
45 3 PVC 0 0 F4 OAM ACTIVE 46 4 PVC 0 0 F4 OAM ACTIVE
TotalInPkts: 0, TotalOutPkts: 0, TotalInFast: 0, TotalOutFast: 0, TotalBroadcasts: 0
TotalInPktDrops: 0, TotalOutPktDrops: 0
ATM2/1/0 VPI: 100, Cell Relay,
ATM2/1/0 VPI: 100, PeakRate: 0, CesRate: 0, DataVCs: 0, CesVCs: 0, Status: ACTIVE
 
VCD VCI Type InPkts OutPkts AAL/Encap Status
47 3 PVC 0 0 F4 OAM ACTIVE 48 4 PVC 0 0 F4 OAM ACTIVE
TotalInPkts: 0, TotalOutPkts: 0, TotalInFast: 0, TotalOutFast: 0, TotalBroadcasts: 0
TotalInPktDrops: 0, TotalOutPktDrops: 0
 

フレームリレーDLCIローカル スイッチングの設定

フレームリレーDLCIローカル スイッチングでは、あるインターフェイス上の1つのDLCIが同じCisco 7600シリーズ ルータ上で、異なるインターフェイスの別のDLCIに接続されます。フレームリレーDLCIローカル スイッチングの設定手順は、次のとおりです。


) 2つのDLCI上で順番に次の手順を実行し、2つのDLCIを接続します。



) この設定ではframe-relay routeコマンドがサポートされなくなったので、connectコマンドを使用します。


 

コマンドまたはアクション
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。

プロンプトに対してパスワードを入力します。

ステップ 2

Router(config)# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# frame-relay switching

フレームリレーDCE装置またはNNI上でPVCスイッチングをイネーブルにします。

ステップ 4

Router(config)# interface serialslot/port

シリアル インターフェイスを指定します。

ステップ 5

Router(config-if)# encapsulation frame-relay [cisco | ietf]

インターフェイスに対してフレームリレー カプセル化を指定します。さまざまなカプセル化タイプを指定できます。あるインターフェイスをシスコのカプセル化方式に設定し、もう一方のインターフェイスをIETFのカプセル化方式に設定することもできます。

ステップ 6

Router(config-if)# frame-relay intf-type dce

インターフェイスがDCEスイッチであることを指定します。Network-to-Network Interface(NNI)およびDTE接続をサポートするようにインターフェイスを指定することもできます。

ステップ 7

Router(config)#connect connection-name interface_1 dlci_1 interface_2 dlci_2

フレームリレーPVC間の接続を定義します。

connection-name引数は、ユーザ側で指定する文字列です。

interface引数は、PVC接続を定義するインターフェイスです。

dlci引数は、接続するPVCのDLCI番号です。

次に、同じルータ(osr4)において、インターフェイスpos4/1上のDLCIとインターフェイスpos4/2上のDLCI間でフレームリレーDLCIローカル スイッチングを設定する例を示します(osr1およびosr3はCE)。


) インターフェイスPOS4/1のDLCIとインターフェイスPOS4/2のDLCIを一致させる必要はありません。DLCIは、connectコマンドを使用して接続する、独立した2つのDLCIにできます。


OSR1での設定

!
interface POS4/1/0
mtu 9000
no ip address
encapsulation frame-relay
!
interface POS4/1/0.1 point-to-point
ip address 11.11.1.1 255.255.255.0
frame-relay interface-dlci 16
!

OSR4での設定

!
frame-relay switching
!
interface POS4/1/1
mtu 9000
no ip address
encapsulation frame-relay
clock source internal
frame-relay intf-type dce
!
interface POS4/1/2
mtu 9000
no ip address
encapsulation frame-relay
clock source internal
frame-relay intf-type dce
!
connect test1 POS4/1/1 16 POS4/1/2 16
!

OSR3での設定

!
interface POS8/0/2
mtu 9000
no ip address
encapsulation frame-relay
!
interface POS8/0/2.1 point-to-point
ip address 11.11.1.2 255.255.255.0
frame-relay interface-dlci 16
!

設定の確認

基本的な接続性を確認するには、pingコマンドを使用します。

osr1#ping
Protocol [ip]:
Target IP address: 11.11.1.2
Repeat count [5]: 100
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 11.11.1.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 1/1/4 ms
osr1#
 

すべてのVCコンポーネントについて統計情報を表示するには、show frame pvcコマンドを使用します。

osr4#sh frame pvc 16
 
PVC Statistics for interface POS4/1/1 (Frame Relay DCE)
 
DLCI = 16, DLCI USAGE = SWITCHED(fr), PVC STATUS = ACTIVE, INTERFACE = POS4/1
 
input pkts 100 output pkts 100 in bytes 10400
out bytes 10400 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
switched pkts 0
Detailed packet drop counters:
no out intf 0 out intf down 0 no out PVC 0
in PVC down 0 out PVC down 0 pkt too big 0
shaping Q full 0 pkt above DE 0 policing drop 0
pvc create time 02:11:44, last time pvc status changed 02:04:23
 
PVC Statistics for interface POS4/1/2 (Frame Relay DCE)
 
DLCI = 16, DLCI USAGE = SWITCHED(fr), PVC STATUS = ACTIVE, INTERFACE = POS4/2
 
input pkts 100 output pkts 100 in bytes 10400
out bytes 10400 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
switched pkts 0
Detailed packet drop counters:
no out intf 0 out intf down 0 no out PVC 0
in PVC down 0 out PVC down 0 pkt too big 0
shaping Q full 0 pkt above DE 0 policing drop 0
pvc create time 02:11:45, last time pvc status changed 02:07:30
osr4#
 

show connect allコマンドを使用すると、接続が表示されます。

osr4#sh connect all
 
ID Name Segment 1 Segment 2 State
========================================================================
1 test1 POS4/1/1 16 POS4/1/2 16 UP
 

トラブルシューティングのヒント

トラブルシューティングに役立つコマンドは、debug frame-relay event、debug acircuit、debug mpls l2transport ipc、debug cwan atom、およびdebug mpls l2transport vcです。

他のPE装置がフレームリレー パケットを伝送できるようにする方法

インターフェイスはDTE装置またはデータ回線終端装置(DCE)スイッチとして設定することも、NNIでスイッチに接続されるスイッチとして設定することもできます。インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

frame-relay intf-type [dce | dte | nni]

次の表でキーワードについて説明します。

 

キーワード
説明

dce

ルータまたはアクセス サーバがルータに接続されたスイッチとして動作できるようにします。

dte

ルータまたはアクセス サーバがDTE装置として動作できるようにします。DTEがデフォルトです。

nni

ルータまたはアクセス サーバがスイッチに接続されたスイッチとして動作できるようにします。

LMIおよびFRoMPLS

Local Management Interface(LMI;ローカル管理インターフェイス)は、PVCのステータス情報を伝えるプロトコルです。PVCが追加、削除、または変更されると、LMIが終端にステータスの変化を通知します。LMIはさらに、リンクがアクティブかどうかを確認するポーリングのメカニズムも提供します。


) LMIが動作するのは、インターフェイス上でキープアライブをイネーブルにした場合だけです
(キープアライブ パケットがインターフェイスをアクティブな状態で維持)。


LMIの機能

PVCのステータスを判別するために、LMIは報告する側の装置からフレームリレー エンドユーザ装置へのPVCが使用できるかどうかを調べます。PVCが使用できる場合、LMIはステータスが[Active]であることを報告します。これは、報告側の装置とフレームリレー エンドユーザ装置間ですべてのインターフェイス、回線プロトコル、およびコア セグメントが動作可能だということを意味します。これらのコンポーネントのいずれかが使用できない場合は、[Inactive]というステータスが報告されます。


) LMIステータスを報告できるインターフェイス タイプは、DCEおよびNNIだけです。


のトポロジー例にLMIの機能を示します。

図4-3 トポロジー例

 


) • CE1およびPE1、PE2およびCE2は、フレームリレーLMIピアです。

CE1およびCE2は、フレームリレー スイッチにすることも、エンドユーザ装置にすることもできます。

各フレームリレーPVCは複数のセグメントからなります。

DLCI値は各セグメントに対してローカルであり、セグメントからセグメントにトラフィックがスイッチングされたときに変更されます。2つのフレームリレーPVCセグメントがあります。PE1とCE1間に1つ、PE2とCE2間に1つです。


 

DLCI間接続

DLCI間接続がある場合、LMIはPE装置とCE装置間のフレームリレー ポート上でローカルに動作します。

CE1のPVCが使用できる場合は、CE1からPE1にアクティブのステータスが送信されます。
CE1がスイッチの場合、LMIはCE1からCE1に接続されたユーザ装置へのPVCが使用できるかどうかを調べます。

PE1がCE1にアクティブ ステータスを送信するのは、次の条件が満たされている場合です。

PE1のPVCが使用可能である。

PE1がリモートPEルータからMPLSラベルを受信した。

PE1とリモートPE間にMPLSトンネル ラベルがある。

CE2がPE2にActiveのステータスを伝えている。CE2がスイッチの場合、LMIはPE1からCE2に接続されたエンドユーザ装置へのPVCが使用できるかどうかを調べます。

DTE/DCEの設定では、LMIの動作は次のようになります。

ネットワーク(DTE)にアクセスするフレームリレー装置は、ポーリングを実行しません。ネットワーク装置(DCE)はLMIのポーリングに応答します。したがって、DTE側に問題があっても、ポーリングを実行しないので、DCEはその問題を認識しません。

LMIの詳細情報

設定手順を含め、LMIの詳細については、次のURLにアクセスして『Configuring Frame Relay,
Configuring the LMI』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fwan_c/wcffrely.htm#xtocid8

AToMでQoSを設定する方法

AToMでサポートされるQoS機能は、次のとおりです。

CE対向カード上でのマーキング ― (インポジション パケット)一致条件、match-dlci、match-any、またはclass-defaultを指定


) CE対向カードでのマーキングの場合、match-dcliが適用されるのはFlexWANモジュールだけです。


コア対向カード上でのシェーピング、match exp、およびmatch-anyを指定

CE対向カードでのシェーピング(ディスポジション パケット)、match-anyを指定

コア対向カード上でのWRED、一致条件、match-exp、またはmatch-anyを指定

ここではAToMでのQoSの設定方法について、次の手順を含めて説明します。

「AToMでのexperimentalビットの設定」

「EXPビットによるパケット プライオリティの設定」

「トラフィック シェーピングのイネーブル設定」


) PFC QoS機能は、ATMoMPLSパケットおよびFRoMPLSパケットには適用されません。


AToMでのexperimentalビットの設定

設定手順および例については、「AToMでのexperimentalビットの設定」を参照してください。

MPLS AToMでは、ラベルの3つのEXPビットを使用して、パケットのキューを判別します。LSPトンネル ラベルは最後から2つめのルータで削除される可能性があるので、VCラベルとLSPトンネル ラベルの両方にEXPビットを固定的に設定します。ここでは、トランスポート固有のEXPビット実装について説明します。

EoMPLSおよびEXPビット


) この説明が当てはまるのは、FlexWANベースのEoMPLSだけです。PFC3BXL QoSについては、
http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/software/122sx/swcg/qos.htmを参照してください。


FlexWANベースのEoMPLSは、次のQoS実装をサポートします。

VLANインターフェイス ポリシー

コア対向インターフェイス ポリシー

VLANインターフェイス ポリシーは個々のVLANに適用します。個々のVLANごとに固有のポリシーを設定できます。ポリシー内で、802.1q Pビットに基づいて分類を行い、MPLS EXPビットを設定できます。VLAN内のすべてのトラフィックに適用されるトラフィック シェーパを1つ実装することもできます。

コア対向インターフェイス ポリシーは、EoMPLSアップリンク インターフェイスに適用します。このポリシーは、すべてのVLANからのトラフィックに適用されます。各種VLANが区別されることはありません。ポリシー内で、MPLS EXPビットに基づいて分類を行い、次の機能を設定できます。

クラス ベースド トラフィック シェーピング

Class Based Weighted Fair Queuing(CBWFQ;クラス ベース均等化キューイング)

Low Latency Queuing(LLQ;低遅延キューイング)

Weighted Random Early Detection(WRED;重み付きランダム早期検出)


) VLANインターフェイス ポリシーとコア対向インターフェイス ポリシーの両方を同時に使用することはできません。FlexWANベースのEoMPLSにQoSを設定する場合は、VLANインターフェイス ポリシーまたはコア対向インターフェイス ポリシーのどちらかを選択する必要があります。


QoSを有効にするためのコマンドの詳細については、次のマニュアルを参照してください。

『Modular Quality of Service Command-Line Interface』

『Cisco IOS Quality of Service Solutions Command Reference』Release 12.2

EXPビットによるパケット プライオリティの設定

EoMPLSでは、ラベル内の3つのEXPビットを使用してパケットのプライオリティを判別し、QoSを提供します。LER間でQoSをサポートするには、VCラベルとトンネル ラベルの両方にEXPビットを設定します。EXPビットに値を割り当てなかった場合、802.1qヘッダーの「タグ制御情報」フィールドに設定されたプライオリティ ビットがEXPビット フィールドに書き込まれます。

EXPビットの設定手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config)# class-map class-name

ユーザ定義のトラフィック クラス名を指定します。

ステップ 2

Router(config-cmap)# match cos 0-7

照合させるCoS値(0~7)とともにIEEE 802.1Qパケットを指定します。または、match anyコマンドを使用することもできます。

ステップ 3

Router(config-cmap)# policy-map policy-name

設定するトラフィック ポリシーの名前を指定します。

ステップ 4

Router(config-pmap)# class class-name

トラフィック ポリシー別にトラフィックを分類するために定義されているトラフィック クラス名(class-mapコマンドで設定)を指定します。

ステップ 5

Router (config-pmap-c)# set mpls experimental value

パケットを指定のポリシー マップと照合させる場合は、MPLSビットの設定値を指定します。

ステップ 6

Router(config)# interface vlan vlan-number

VLANインターフェイスを入力します。

ステップ 7

Router(config-if)# service-policy [input | output] policy-name

インターフェイスにトラフィック ポリシーを結合します。


) 同じポリシー マップでトラフィック シェーピングをイネーブルにして、EXPビットを設定できます。



) 入力方向または出力方向のどちらか一方にサービス ポリシーを設定できます。ただし、ポリシーは必ずコア対向FlexWANモジュール ポート上で実装し、コア対向FlexWANモジュール ポートから出ていくトラフィックだけに適用します。


トラフィック シェーピングのイネーブル設定

トラフィック シェーピングは、データの伝送速度を制限します。平均速度のシェーピングによって、伝送速度がCommitted Information Rate(CIR;認定情報速度)に制限されます。トラフィック シェーピングを追加するには、次のコマンドを発行します。

 

コマンド
目的

ステップ 1

Router(config)# class-map class-name

ユーザ定義のトラフィック クラス名を指定します。

ステップ 2

Router(config-cmap)# match any

あらゆるパケットを照合することを指定します(ポリシー マップでclass-defaultを使用するのと同様)。

ステップ 3

Router(config-cmap)# policy-map policy-name

設定するトラフィック ポリシーの名前を指定します。

ステップ 4

Router(config-pmap)# class class-name

トラフィック ポリシー別にトラフィックを分類するために定義されているトラフィック クラス名(class-mapコマンドで設定)を指定します。

ステップ 5

Router (config-pmap-c)# shape average cir 2

指定したビット レートに従ってトラフィックをシェーピングします。

ステップ 6

Router(config)# interface vlan vlan-number

VLANインターフェイスを入力します。

ステップ 7

Router(config-if)# service-policy [input | output] policy-name

インターフェイスにトラフィック ポリシーを割り当てます。

2.サポートされるパラメータだけを示しています。

シェーピング平均速度は、リンク速度を255で割った最も近い倍数に丸められます。シェーピング値がリンク速度を255で割った値を下回る場合は、255で割ったリンク速度に切り上げられます。

次に、シェーピング値を丸める例を示します。

Router# show pol p2
Policy Map p2
class any-pkt
shape average 2000000 8000 8000
 
Router# show pol int
 
Vlan101
 
service-policy input:p2
 
class-map:any-pkt (match-all)
2018169 packets, 4575195376 bytes
30 second offered rate 295768000 bps, drop rate 0 bps
match:any
queue size 0, queue limit 0
packets input 40492, packet drops 1977677
tail/random drops 0, no buffer drops 0, other drops 1977677
shape:cir 2000000, Bc 8000, Be 8000
input bytes 40847436, shape rate 1874000 bps
 
class-map:class-default (match-any)
0 packets, 0 bytes
30 second offered rate 0 bps, drop rate 0 bps
match:any
0 packets, 0 bytes
30 second rate 0 bps
 

インターフェイスに割り当てられたトラフィック ポリシーの表示

インターフェイスに結合されたトラフィック ポリシーを表示するには、次のコマンドを発行します。

Router# show policy-map vlan50
service-policy input: badger
 
class-map: blue (match-all)
0 packets, 0 bytes
30 second offered rate 0 bps, drop rate 0 bps
match: any
queue size 0, queue limit 2
packets input 0, packet drops 0
tail/random drops 0, no buffer drops 0, other drops 0
shape: cir 2000000, Bc 8000, Be 8000
output bytes 0, shape rate 0 bps
 
class-map: class-default (match-any)
0 packets, 0 bytes
30 second offered rate 0 bps, drop rate 0 bps
match: any
0 packets, 0 bytes

30 second rate 0 bps

ATM AAL5 over MPLSおよびEXPビット

ATM AAL5 over MPLSでは、EXPビットを固定的に設定できます。

EXPビットに値を割り当てなかった場合は、ヘッダーの「タグ制御情報」フィールドのプライオリティ ビットがゼロに設定されます。

ATM Cell Relay over MPLSおよびEXPビット

ATM Cell Relay over MPLSは、VCモードでEXPビットを固定的に設定できます。

EXPビットに値を割り当てなかった場合は、ヘッダーの「タグ制御情報」フィールドのプライオリティ ビットがゼロに設定されます。

FRoMPLSおよびEXPビット

FRoMPLSは、ラベルに指定されている、PDUのプライオリティを決定する3つのEXPビットを使用してQoSを提供します。EXPビットに値を割り当てなかった場合は、ヘッダーの「タグ制御情報」フィールドのプライオリティ ビットがゼロに設定されます。FRoMPLSの場合、DLCI単位でEXPビットを設定する必要があります。

EXPビットによるパケット プライオリティの設定

VCラベルとLSPトンネル ラベルの両方にEXPビットを設定します。VCラベルにEXPビットを設定するのは、最後から2つめのルータでLSPトンネル ラベルが削除される可能性があるからです。

EXPビットの設定手順は、次のとおりです。

 

コマンドまたはアクション
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。プロンプトに対してパスワードを入力します。

ステップ 2

Router(config)# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# class-map class-name

ユーザ定義のトラフィック クラス名を指定します。

ステップ 4

Router(config-cmap)# match any

あらゆるパケットを照合することを指定します。このリリースで使用するキーワードは、anyだけです。その他のキーワードを指定すると、予想外の結果になることがあります。

ステップ 5

Router(config-cmap)# policy-map policy-name

設定するトラフィック ポリシーの名前を指定します。

ステップ 6

Router(config-pmap)# class class-name

トラフィック ポリシー別にトラフィックを分類するために定義されているトラフィック クラス名(class-mapコマンドで設定)を指定します。

ステップ 7

Router(config-pmap-c)# set mpls experimental value

パケットを指定のポリシー マップと突き合わせる場合は、MPLSビットの設定値を指定します。

ステップ 8

Router(config)# interface slot/port

インターフェイスを入力します。

ステップ 9

Router(config-if)# service-policy input policy-name

インターフェイスにトラフィック ポリシーを結合します。

トラフィック シェーピングのイネーブル設定

トラフィック シェーピングは、データの伝送速度を制限します。平均速度のシェーピングによって、伝送速度がCommitted Information Rate(CIR;認定情報速度)に制限されます。トラフィック シェーピングを追加するには、次のコマンドを発行します。

 

コマンドまたはアクション
目的

ステップ 1

Router# enable

イネーブルEXECモードを有効にします。プロンプトに対してパスワードを入力します。

ステップ 2

Router(config)# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# class-map class-name

ユーザ定義のトラフィック クラス名を指定します。

ステップ 4

Router(config-cmap)# match any

あらゆるパケットを照合することを指定します。このリリースで使用するキーワードは、anyだけです。その他のキーワードを指定すると、予想外の結果になることがあります。

ステップ 5

Router(config-cmap)# policy-map policy-name

設定するトラフィック ポリシーの名前を指定します。

ステップ 6

Router(config-pmap)# class class-name

トラフィック ポリシー別にトラフィックを分類するために定義されているトラフィック クラス名(class-mapコマンドで設定)を指定します。

ステップ 7

Router(config-pmap-c)# shape average bit value

指定したビット レートに従ってトラフィックをシェーピングします。

ステップ 8

Router(config)#interface slot/port

インターフェイスを入力します。

ステップ 9

Router(config-if)# service-policy input policy-name

インターフェイスにトラフィック ポリシーを結合します。


) 同じポリシー マップでトラフィック シェーピングをイネーブルにして、EXPビットを設定できます。



) EoMPLS VLANのポリシング除外 ― VLANベースの入力ポリサーからEoMPLSアップリンク ポートのトラフィックを除外します。


インターフェイスに割り当てられたトラフィック ポリシーの表示

インターフェイスに結合されたトラフィック ポリシーを表示するには、show policy-map interfaceコマンドを使用します。

EoMPLS QoSの例

出力MPLSトンネルが均等化キューイングとして設定されたFlexWANインターフェイス上で伝送される場合、シェーピング値はリンク速度を255で割った最も近い倍数に丸められます。シェーピング値が255で割ったリンク速度を下回る場合は、255で割ったリンク速度に切り上げられます。

次に、シェーピング値を丸める例を示します。

Router# show pol p2
Policy Map p2
class any-pkt
shape average 2000000 8000 8000
 
Router# show pol int
 
Vlan101
 
service-policy input:p2
 
class-map:any-pkt (match-all)
2018169 packets, 4575195376 bytes
30 second offered rate 295768000 bps, drop rate 0 bps
match:any
queue size 0, queue limit 0
packets input 40492, packet drops 1977677
tail/random drops 0, no buffer drops 0, other drops 1977677
shape:cir 2000000, Bc 8000, Be 8000
(shape parameter is rounded to 2439000 due to granularity)
input bytes 40847436, shape rate 1874000 bps
 
class-map:class-default (match-any)
0 packets, 0 bytes
30 second offered rate 0 bps, drop rate 0 bps
match:any
0 packets, 0 bytes
30 second rate 0 bps
 

EoMPLS QoSの例 ― インターフェイスに割り当てられたトラフィック ポリシーの表示

インターフェイスに結合されたトラフィック ポリシーを表示するには、次のコマンドを発行します。

Router# show policy-map vlan50
service-policy input: badger
 
class-map: blue (match-all)
0 packets, 0 bytes
30 second offered rate 0 bps, drop rate 0 bps
match: any
queue size 0, queue limit 2
packets input 0, packet drops 0
tail/random drops 0, no buffer drops 0, other drops 0
shape: cir 2000000, Bc 8000, Be 8000
output bytes 0, shape rate 0 bps
 
class-map: class-default (match-any)
0 packets, 0 bytes
30 second offered rate 0 bps, drop rate 0 bps
match: any
0 packets, 0 bytes
30 second rate 0 bps

EoMPLS QoSの例 ― VLAN上でのQoSの設定

次に、VLAN上でQoSを設定する例を示します。

class-map blue
match cos 1 2 3
!
policy-map badger
class blue
set mpls experimental 1
class class-default
shape average 2000000 8000 8000
!
interface vlan50
no ip address
no ip mroute-cache
load-interval 30
mpls l2transport route 192.168.255.255 50
service-policy input badger
no cdp enable

ATMoMPLS QoSの例 ― 入力QoSの設定

入力QoSの例を示します。入力側では、ポリシーがマルチポイント l2transport PVCに結合されます。ここでは、PVC 1/101上のすべてのパケットに対してEXPビットが5に設定されます。

class-map match-any anyclass
match any
!
policy-map set-policy
class anyclass
set mpls experimental 5
 
interface ATM6/0/0
no ip address
logging event link-status
atm clock INTERNAL
pvc 1/101 l2transport
encapsulation aal5
mpls l2transport route 10.10.10.10 101
service-policy input set-policy
 

入力シェーピングの場合、設定は上記と同じですが、ポリシー マップで指定するアクションをシェーピングに変更します。

policy-map shape-policy
class anyclass
shape average 16000 3200 3200
 
For output shaping based on MPLS EXP, the policy is configured on the main interface.
class-map match-any exp2
match mpls experimental 2
!
policy-map shape-policy
class exp2
shape average 16000 32 32
 
interface POS4/0/1
ip address 20.1.1.1 255.255.255.0
service-policy output shape-policy
no ip mroute-cache
load-interval 30
no keepalive
mpls label protocol ldp
tag-switching ip
mls qos trust dscp
clock source internal
no cdp enable

FRoMPLS QoSの例 ― 入力QoSの設定

入力側では、スイッチド フレームリレーDLCIにポリシーを結合します。次の設定では、DLCI 10のフレームリレー パケットを照合し、一致したパケットにラベルを付加するときに、EXPビットを5に設定します。

class-map match-any anyclass
match any
!
!
policy-map set-policy
class anyclass
set mpls experimental 5
 
map-class frame-relay dlci101
service-policy input set-policy
 
interface POS1/0/1
no ip address
encapsulation frame-relay IETF
no ip mroute-cache
load-interval 30
no keepalive
mls qos trust dscp
clock source internal
frame-relay interface-dlci 101 switched
class dlci101
 

入力シェーピングの場合、設定は上記と同じですが、ポリシー マップで指定するアクションを次のようにシェーピングに変更します。

policy-map shape-policy
class anyclass
shape average 1600000 6400 6400
 

MPLS EXPに基づいた出力シェーピングの場合、メイン インターフェイス上でポリシーを設定します。

class-map match-any exp2
match mpls experimental 2
!
policy-map shape-policy
class exp2
shape average 1600000 6400 6400
 
interface POS4/0/1
ip address 20.1.1.1 255.255.255.0
service-policy output shape-policy
no ip mroute-cache
load-interval 30
no keepalive
mpls label protocol ldp
tag-switching ip
mls qos trust dscp
clock source internal
no cdp enable
 

MPLS EXPに基づいたWREDの場合、メイン インターフェイス上でポリシーを設定します。

class-map match-any exp2
match mpls experimental 2
!
policy-map wred-pol
class exp2
bandwidth percent 20
random-detect
 
interface POS4/0/1
service-policy output wred-pol
 

AToMのロードバランシング

ルータはロードバランシングによって、複数の最適パスを利用して所定の宛先まで到達できます。デフォルトでは、大部分のAToMモード(SUP720-3BXLベースのEoMPLSは除く、 AToM
Load-Balancing
を参照)では同じようなロードバランシング メカニズムを使用して、コア対向インターフェイスのトンネル ラベルを決定します。すなわち、ルータは各リンクの負荷に関係なく、利用できるすべてのパスにAToM VCを分散させます。ルータはVCラベルのハッシュによってインデックス値を作成し、それを使用してトンネル ラベルを選択します。選択されたトンネル ラベルは、所定のPCのラベル スタックのいちばん上に置かれます。

Cisco 7600シリーズ ルータは、また別のロードバランシング方式を提供します。この方式では、次の順序に基づいて、利用可能なすべてのパスの中から最も利用されていないパスが選択されます。

同じパケット プロセッサ コンプレックス上のさまざまなポート

同じパケット プロセッサ コンプレックスにおいて選択されたポート上のさまざまなインターフェイス

ロードバランシングの注意事項

最低利用モードをイネーブルにするには、コンフィギュレーション コマンドを入力し(1行に1コマンド)、各コマンドの最後にCtrl-Zを押します。

PE-7600B#conf t
PE-7600B(config)#mpls load-balance per-l2transport-circuit
 

最低利用モードをディセーブルにするには、コンフィギュレーション コマンドを入力し(1行に1コマンド)、各コマンドの最後にCtrl-Zを押します。

PE-7600B#conf t
PE-7600B(config)#no mpls load-balance per-l2transport-circuit
 

現在のロードバランシング モードを表示するには、show cwan atom load-balance-modeコマンドを使用します。

PE-7600B#sh cwan atom load-balance-mode
Current load balancing mode : per-l2transport-circuit
 

) すでにアクティブになっているシステムで最低利用ロードバランシング モードをイネーブルにした場合、作用するのはそれ以後の新しいAToM VCだけです。既存のAToM VCは影響を受けません。最低利用ロードバランシング モードを既存のすべてのVCに適用する場合は、VCフラッピングを実行します。


最低利用モードの制限事項

MPLSコアの対向インターフェイスがWANインターフェイスとLANインターフェイスの混合になっている場合、使用可能なWANインターフェイスが少なくとも1つあるかぎり、AToM VCはアクティブのままです。ただし、この設定は推奨できません。AToM VCがLANインターフェイスに届いたディスポジション パケットを廃棄する可能性があります。

この種の設定を伝える警告メッセージを無視すると、AToM VCが正常に動作しない場合があるので、ディスポジション パケットを失う危険性があります。