オプティカル サービス モジュール コンフィギュレーション ノート Cisco IOS Release 12.1E
OSM上でのMPLSの設定
OSM上でのMPLSの設定
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

OSM上でのMPLSの設定

MPLSの設定

MPLSの概要

OSM上のMPLSサポート

MPLSの制限事項および制約

サポート対象外のMPLS機能

MPLSの制限事項

MPLSの設定

MPLS QoSの設定

サポート対象外のMPLS QoSコマンド

サポート対象のMPLS QoS機能

FlexWANでのMPLS QoSサポート

OSMでのMPLS QoSサポート

MPLS QoSの制限事項および制約

試験的なMPLSフィールド(EXPフィールド)

MPLS QoSの設定

MPLSパケット分類用のクラス マップの設定

MPLS EXPフィールド設定用のポリシー マップの設定

サービス ポリシーの適用

QoS動作の確認

設定例

入力PEルータの設定

MPLS VPNの設定

OSM上のMPLS VPNサポート

MPLS VPNの制限事項および制約

MPLS VPNメモリ要件と推奨事項

ラベル ロード バランシング単位のMPLS

MPLS VPNの設定

MPLS VPN CoSの設定

設定例

EoMPLSの設定

OSM上でのMPLSの設定

この章では、OSM(オプティカル サービス モジュール)上でMultiprotocol Label Switching(MPLS;マルチプロトコル ラベル スイッチング)およびEthernet over Multiprotocol Label Switching(EoMPLS)を設定する方法について説明します。

この章の内容は次のとおりです。

「MPLSの設定」

「MPLS QoSの設定」

「MPLS VPNの設定」

「MPLS VPN CoSの設定」

「EoMPLSの設定」

MPLSの設定

ここでは、MPLSの設定について説明します。

「MPLSの概要」

「OSM上のMPLSサポート」

「MPLSの制限事項および制約」

「MPLSの設定」

MPLSの概要

MPLSは、ラベル スイッチングを使用して、Packet-over-SONET(POS)、フレーム リレー、ATM、イーサネットなどの各種リンク レベルのテクノロジーでパケットを転送します。ラベルは、グループ分け、つまりForwarding Equivalence Class(FEC)に基づいてパケットに割り当てられます。同じFECに属するパケットは、同じように処理されます。ラベルは、レイヤ2ヘッダーとレイヤ3ヘッダーの間(パケット環境の場合)、またはVirtual Path Identifier(VPI;仮想パス識別子)/Virtual Channel Identifier(VCI;仮想チャネル識別子)フィールド(ATMネットワークの場合)に挿入されます。

MPLSネットワークでは、エッジ ルータが着信ラベルのラベル検索を行い、着信ラベルを発信ラベルと交換し、次のホップにパケットを送信します。ラベルは、MPLSネットワークの入力エッジでのみパケットに加えられ、出力エッジで削除されます。コア ネットワークはラベルを読み取り、該当するサービスを適用し、ラベルに基づいてパケットを転送します。

OSM上のMPLSサポート

MPLSは、次のCatalyst 6000ファミリーおよびCisco 7600シリーズOSMでサポートされます。

OC-3 POS

OSM-4OC3-POS-SI

OSM-8OC3-POS-SI、SL

OSM-16OC3-POS-SI、SL

OSM-4OC3-POS-SI+

OSM-8OC3-POS-SI+、SL+

OSM-16OC3-POS-SI+、-SL+

OC-12 POS

OSM-2OC12-POS-MM、SI、SL

OSM-4OC12-POS-MM、SI、SL

OSM-2OC12-POS-MM+、SI+、SL+

OSM-4OC12-POS-MM+、SI+、SL+

OC-12 ATM

OSM-2OC12-ATM-MM

OSM-2OC12-ATM-SI

OSM-2OC12-ATM-MM+

OSM-2OC12-ATM-SI+

OC-48 POS

OSM-1OC48-POS-SS、SI、SL

OSM-1OC48-POS-SS+、SI+、SL+

チャネライズド

OSM-1CHOC48/T3-SS

OSM-1CHOC12/T3-SI

OSM-1CHOC12/T1-SI

OSM-12CT3/T1

OC-48 POS/DPT

OSM-2OC48/1DPT-SS、SI、SL


) OSM-2OC48/1DPT-SS、SI、SLは、POSモードのMPLSのみをサポートしています。


ギガビット イーサネット

OSM-4GE-WAN-GBIC

OSM-2+4GE-WAN+

WS-X6182-2PA FlexWAN

MPLSの制限事項および制約

OSMモジュール上のMPLSサポートには、次のプラットフォーム固有の制限事項および制約が適用されます。

「サポート対象外のMPLS機能」

「MPLSの制限事項」

サポート対象外のMPLS機能

CLI(コマンドライン インターフェイス)では次の機能を設定できますが、これらの機能はサポートされていません。

MPLS-TE

MPLS-CsC

MPLS-InterAS-VPN

MPLSの制限事項

次のMPLS制限事項が適用されます。

負荷分散はPEパスに限ってサポートされており、Pデバイスではサポートされていません。

Pパスでは、MTU検出および分割は行いません。

MPLS Provider(P)機能は、レイヤ2スイッチングをサポートするイーサネット インターフェイスではサポートされません。イーサネット インターフェイスでP機能をサポートするには、ギガビット イーサネット インターフェイス上からのトランクを作成するのが唯一の方法です。たとえば、WS-6516-GBICモジュール上のギガビット イーサネット インターフェイスから、Pスイッチングの許可を設定したOSM-4GE-WANモジュール上のインターフェイスにトランクを作成します。WS-6516-GBICモジュール上のインターフェイスをトランキング モードにし、必要なサブインターフェイスをOSM-4GE-WANモジュール インターフェイス上に作成します。

2ポートのOC-12 ATM OSMでのカプセル化 ― インターフェイスがAAL5SNAPカプセル化に設定されている場合(デフォルト)にのみ、MPLSはサポートされます。

MPLSの設定

MPLSの設定については、次のURLにアクセスし、『Multiprotocol Label Switching on Cisco Routers』フィーチャ モジュールを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/mpls4t.htm

MPLS QoSの設定

MPLS QoS(サービス品質)の設定の詳細については、次のURLにアクセスして、『MPLS Class Of Service Enhancement』フィーチャ モジュールを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/mct1214t.htm

ここでは、MPLS QoSの設定について説明します。

「サポート対象外のMPLS QoSコマンド」

「サポート対象のMPLS QoS機能」

「MPLS QoSの制限事項および制約」

「試験的なMPLSフィールド(EXPフィールド)」

「MPLS QoSの設定」

「設定例」

サポート対象外のMPLS QoSコマンド

次のコマンドは、FlexWANおよびOSM上ではサポートされていません。

access-list rate-limit

rate-limit

サポート対象のMPLS QoS機能

サポートされるMPLS QoS機能は、次のとおりです。

FlexWANでのMPLS QoSサポート

FlexWANモジュールでは、次のQoS機能がサポートされています。

入力QoS

policeコマンド

set ip precedenceコマンド

出力QoS

Low Latency Queueing(LLQ)

クラスベース トラフィック シェーピング(出力)

Weighted Random Early Detection(WRED;重み付きランダム早期検出)

set mpls experimentalコマンド

階層化ポリシー マップ

次の機能はサポートされていません。

qos-group

OSMでのMPLS QoSサポート

OSMでは次のQoS機能がサポートされます。OSMでのIP QoSサポートについては、「OSM上でのQoSの設定」を参照してください。

入力QoS(match mpls experimentalコマンド)

クラスベース トラフィック シェーピング

出力QoS

クラスベース トラフィック シェーピング

CBWFQ

LLQ

WRED

set mpls experimentalコマンド

MPLS QoSの制限事項および制約

Cisco 7600シリーズ ルータでのMPLS QoSサポートには、次の制限事項が適用されます。

MPLS試験ビットの設定またはマッピングでは、設定はIP/タグパス対応のProvider Edge(PE;プロバイダー エッジ)ルータの出力インターフェイスに適用する必要があります。

Access Control List(ACL;アクセス制御リスト)は、VRFインターフェイスではサポートされていません。

試験的なMPLSフィールド(EXPフィールド)

MPLS EXPフィールド値を設定すると、ネットワークを通じてトランスポートされたIPパケット内の変更されたIP precedence値を必要としないサービス プロバイダーの要件を満たします。

MPLS EXPフィールドに対して別の値を選択することで、輻輳期間に必要とするプライオリティをパケットに設定できるように、パケットをマーキングできます。

デフォルトでは、適用中に、IP precedence値がMPLS EXPフィールドにコピーされます。set mpls experimentalポリシーは、PEルータの出力インターフェイスまたはプロバイダー コア(P)ルータの入力インターフェイスに対して適用できます。

図 11-1に、カスタマーに属するネットワークの2つのサイトを接続する、サービス プロバイダーのMPLSネットワークを示します。

図 11-1 カスタマーのIPネットワークの2つのサイトを接続するMPLSネットワーク

 

MPLS QoSの設定

MPLS QoSを設定するには、次の作業を実行します。

「MPLSパケット分類用のクラス マップの設定」

「MPLS EXPフィールド設定用のポリシー マップの設定」

「サービス ポリシーの適用」

「QoS動作の確認」

OSM QoS機能の設定については、 OSM上でのQoSの設定 を参照してください。

MPLSパケット分類用のクラス マップの設定

クラス マップを設定するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config)# class-map class-name

パケットを照合するクラス マップを指定します。

ステップ 2

Router(config-cmap)# match mpls experimental value

クラスと照合するパケットの特性を指定します。

ステップ 3

Router(config-cmap)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、MPLS EXP値4を含むすべてのパケットをトラフィック クラスexp4によって照合する例を示します。

Router(config)# class-map exp4
Router(config-cmap)# match mpls experimental 4
Router(config-cmap)# exit
 

MPLS EXPフィールド設定用のポリシー マップの設定

ポリシー マップを設定するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config)# policy-map policy-name

1つまたは複数のインターフェイスに適用できるポリシー マップを作成し、サービス ポリシーを指定します。

ステップ 2

Router(config-pmap)# class class-name

以前に class-map コマンドで指定したクラスマップの名前を指定します。

ステップ 3

Router(config-pmap-c)# set mpls experimental value1

パケットが指定されたポリシー マップに一致する場合は、MPLSビットの設定対象となる値を指定します。

ステップ 4

Router(config-pmap-c)# exit

ポリシー マップ コンフィギュレーション モードを終了します。

1.シェーピングなどの追加サポート対象機能を設定することもできます。

次に、クラスマップexp4によって照合した各パケットのMPLS EXPフィールド値を、5に設定する例を示します。

Router(config)# policy-map set_experimental_5
Router(config-pmap)# class exp4
Router(config-pmap-c)# set mpls experimental 5
Router(config-pmap-c)# exit
Router(config-pmap)# exit

サービス ポリシーの適用

インターフェイスにサービス ポリシーを適用するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config)# interface name

出力インターフェイスを指定します。

ステップ 2

Router(config-if)# service-policy {input | output} policy-name

指定したポリシー マップをインターフェイスに適用します。

ステップ 3

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

次に、サービス ポリシーset_experimental_5を、POS出力インターフェイスに適用する例を示します。

Router(config)# interface POS6/1
Router(config-if)# service-policy output set_experimental_5
Router(config-if)# exit
 

QoS動作の確認

MPLS QoSの動作を確認するには、次のコマンドを実行します。

 

コマンド
説明

Router# show policy-map interface [interface-name]

QoSの詳細情報を表示します。

設定例

ここに記載されている設定例は、Cisco 7600シリーズ ルータ上でサポートされているOSMまたはFlexWANモジュールに使用できます。

入力PEルータの設定

次の例では、MPLSネットワークに入るIP precedenceが1のIPパケットを2,000,000ビット/秒にシェーピングし、MPLS EXPフィールドを5に設定します。IP precedenceが0のIPパケットがMPLSネットワークに入った場合には、3,000,000ビット/秒にシェーピングし、MPLS EXPフィールドを3に設定します。それ以外のIP precedenceのIPパケットがMPLSネットワークに入った場合には、5,000,000ビット/秒にシェーピングします。


ステップ 1 2つのトラフィック クラスを定義します。

Router(config)# class-map gold
Router(config-cmap)# match mpls experimental 1
Router(config-cmap)# exit
Router(config)# class-map silver
Router(config-cmap)# match mpls experimental 0
Router(config-cmap)# exit
 

) トラフィック クラスは、IP precedence値ではなく、MPLS EXP値で照合するように定義してください。


ステップ 2 異なるトラフィック クラスには、異なる動作を指定したポリシーを定義します。

Router(config)# policy-map policy1
Router(config-pmap)# class gold
Router(config-pmap-c)# set mpls experimental 5
Router(config-pmap-c)# shape average 2000000
Router(config-pmap-c)# exit
Router(config-pmap)# class silver
Router(config-pmap-c)# set mpls experimental 3
Router(config-pmap-c)# shape average 3000000
Router(config-pmap-c)# exit
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 5000000
Router(config-pmap-c)# exit
Router(config-pmap)# exit
 

ステップ 3 PEルータの出力インターフェイスにポリシーを適用します。

Router(config)# interface GE-WAN7/1
Router(config-if)# service-policy output policy1
 

ステップ 4 QoS設定を確認します。

Router# show policy-map interface POS6/2
 
POS6/2
 
service-policy output:policy1
 
class-map:gold (match-all)
0 packets, 0 bytes
30 second offered rate 0 bps, drop rate 0 bps
match:mpls experimental 1
queue size 0, queue limit 500
packets output 0, packet drops 0
tail/random drops 0, no buffer drops 0, other drops 0
set:
mpls experimental 5
shape:cir 2000000, Bc 8000, Be 8000
output bytes 0, shape rate 0 bps
 
class-map:silver (match-all)
9521 packets, 9425790 bytes
30 second offered rate 3681000 bps, drop rate 1505000 bps
match:mpls experimental 0
queue size 0, queue limit 128
packets output 2845, packet drops 6676
tail/random drops 6676, no buffer drops 0, other drops 0
set:
mpls experimental 3
shape:cir 3000000, Bc 12000, Be 12000
output bytes 2816550, shape rate 642000 bps
 
class-map:class-default (match-any)
0 packets, 0 bytes
30 second offered rate 0 bps, drop rate 0 bps
match:any
0 packets, 0 bytes
30 second rate 0 bps
queue size 0, queue limit 128
packets output 0, packet drops 0
tail/random drops 0, no buffer drops 0, other drops 0
shape:cir 5000000, Bc 20000, Be 20000
output bytes 0, shape rate 0 bps
Router#
 


 

MPLS VPNの設定

次に、MPLS VPNの設定方法について説明します。

「OSM上のMPLS VPNサポート」

「MPLS VPNの制限事項および制約」

「MPLS VPNメモリ要件と推奨事項」

「MPLS VPNの設定」

OSM上のMPLS VPNサポート

MPLS VPNは下記のOSMでサポートされています。

OC-3 POS

OSM-4OC3-POS-SI

OSM-8OC3-POS-SI、SL

OSM-16OC3-POS-SI、SL

OSM-4OC3-POS-SI+

OSM-8OC3-POS-SI+、SL+

OSM-16OC3-POS-SI+、-SL+

OC-12 POS

OSM-2OC12-POS-MM、SI、SL

OSM-4OC12-POS-MM、SI、SL

OSM-2OC12-POS-MM+、SI+、SL+

OSM-4OC12-POS-MM+、SI+、SL+

OC-12 ATM

OSM-2OC12-ATM-MM

OSM-2OC12-ATM-SI

OSM-2OC12-ATM-MM+

OSM-2OC12-ATM-SI+

OC-48 POS

OSM-1OC48-POS-SS、SI、SL

OSM-1OC48-POS-SS+、SI+、SL+

チャネライズド

OSM-1CHOC12/T3-SI

OSM-1CHOC12/T1-SI

OSM-12CT3/T1

OC-48 POS/DPT2

OSM-2OC48/1DPT-SS、SI、SL

ギガビット イーサネット

OSM-4GE-WAN-GBIC

OSM-2+4GE-WAN+

WS-X6182-2PA FlexWAN

MPLS VPNの制限事項および制約

MPLS VPNの制限事項は、次のとおりです。

PEおよびPパス上では、負荷分散はサポートされません。

MTUチェックおよびフラグメンテーションはサポートされていません。

各システムにつき、合計255のVPN Routing/Forwarding instance(VRF;VPNルーティング/転送インスタンス)ルートがサポートされます。

拡張OSMは、MPLSレイヤ3設定のシャーシごとに、最低511 VRFから最高1,023 VRFをサポートします。

MPLS Provider(P)機能は、レイヤ2スイッチングをサポートするイーサネット インターフェイスではサポートされません。イーサネット インターフェイスでP機能をサポートするには、ギガビット イーサネット インターフェイス上からのトランクを作成するのが唯一の方法です。たとえば、WS-6516-GBICモジュール上のギガビット イーサネット インターフェイスから、Pスイッチングの許可を設定したOSM-4GE-WANモジュール上のインターフェイスにトランクを作成します。WS-6516-GBICモジュール上のインターフェイスをトランキング モードにし、必要なサブインターフェイスをOSM-4GE-WANモジュール インターフェイス上に作成します。

MPLS VPNメモリ要件と推奨事項

Cisco 7600シリーズ ルータまたはCatalyst 6500シリーズ スイッチがMPLS VPN環境でPEルータとして機能する場合、 表 11-1 に示されているメモリ要件を適用します。

 

表 11-1 MPLS VPNメモリ要件と推奨事項

MSFC2のメモリ設定
インターネット ルート、eBGPセッション、およびVPNv4ルートの最大数

512 MBのMSFC2

インターネット ルート:100,000、eBGPセッション:750、VPNv4ルート:100,000

Supervisor Engine IIのメモリ設定
インターネット ルート、eBGPセッション、およびVPNv4ルートの最大数

256MBのSupervisor Engine II

インターネット ルート:100,000、eBGPセッション:750、VPNv4ルート:175,000

OSMのメモリ設定
インターネット ルート、eBGPセッション、およびVPNv4ルートの最大数

256 MBのOSM

インターネット ルート:100,000、eBGPセッション:750、VPNv4ルート:175,000

FlexWANのメモリ設定
インターネット ルート、eBGPセッション、およびVPNv4ルートの最大数

2×128 MBのFlexWAN

インターネット ルート:100,000、eBGPセッション:750、VPNv4ルート:100,000

インターネット ルート、eBGPセッション、およびVPNv4ルート数が 表 11-1 に示されている数を超える場合は、次のメモリ オプションにアップグレードしてください。システムにFlexWANモジュールがインストールされている場合は、コンフィギュレーション ファイル内のインターネット ルート、eBGPセッション、およびVPNv4ルート数は、FlexWAN用の表にリストされている要件を超えないようにしなければなりません。

ラベル ロード バランシング単位のMPLS

Cisco 7600シリーズ ルータをPルータとして設定すると、 mpls load-balance per-label コマンドを使ってトラフィックが等価コスト パス間に分配されていることを確認し、タグ/タグ トラフィック用にロード バランシングをイネーブルまたはディセーブルにすることができます。

ロード バランシングをイネーブルにすると、ラベル ロード バランシング単位のMPLSにより、MPLSインターフェイス間の着信ラベル(プレフィクス単位)に基づいて、トラフィックのバランスを確実に保つことができます。各MPLSインターフェイスは、均等の着信ラベル数をサポートしています。

mpls load-balance per-label
[no] mpls load-balance per-label
 

デフォルトはディセーブルです。

このコマンドのno形式を使用して、デフォルト設定に戻ります。

次に、ラベル ロード バランシング単位のMPLSをPOSインターフェイス上でイネーブルにする例を示します。

Router(config)# interface pos 4/1
Router(config-if)# mpls load-balance per-label
 

show mpls ttfib コマンドを使用して、ロード バランサに含まれる着信ラベル(アスタリスク*により表示される)を見ることができます。次に、 show mpls ttfib コマンドの出力を示します。

Router# show mpls ttfib
Local Outgoing Packets Tag LTL Dest. Destination Outgoing
Tag Tag or VC Switched Index Vlanid Mac Address Interface
4116 21 0 0xE0 1020 0000.0400.0000 PO4/1*
34 0 0x132 1019 00d0.040d.380a GE5/3
45 0 0xE3 4031 0000.0430.0000 PO4/4
4117 16 0 0x132 1019 00d0.040d.380a GE5/3*
17 0 0xE0 1020 0000.0400.0000 PO4/1
18 0 0xE3 4031 0000.0430.0000 PO4/4
4118 21 0 0xE0 1020 0000.0400.0000 PO4/1*
56 0 0xE3 4031 0000.0430.0000 PO4/4
4119 35 0 0xE3 4031 0000.0430.0000 PO4/4*
47 0 0xE0 1020 0000.0400.0000 PO4/1
 

MPLS VPNの設定

MPLS VPNの設定の詳細については、次のURLにアクセスし、『MPLS Virtual Private Networks』フィーチャ モジュールを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t7/vpn_en.htm

MPLS VPN CoSの設定

MPLS VPNは、基本MPLSと同じQoS機能セットをサポートしています。サポートされるQoS機能およびMPLS VPN QoSの設定の詳細については、『MPLS Class Of Service Enhancement』フィーチャ モジュールを参照してください(MPLS QoSの設定を参照)。

これらの機能に加え、MPLS VPNは、OSMの入力WANインターフェイス上でのset ip precedenceコマンドをサポートしています。

OSM上でのMPLS VPN CoSサポートには、次の制約があります。

MPLS VPNでは、PFC2 QoS機能はサポートされません。

MPLS VPN CoSは、VPNインターフェイスに限ってサポートされます。

Match IP precedence、SET IP precedence、およびMPLS EXP値は、入力インターフェイス上でのみサポートされます。

設定例

次に、MPLS VPNでCoSを設定する例を示します。

Router# configure terminal
Router(config)# class-map match-any vpn-class
Router(config-cmap)# match ip precedence 3
Router(config-cmap)# exit
Router(config)# policy-map VPN-MARKING
Router(config-pmap)# class vpn-class
Router(config-pmap-c)# set ip precedence 5
Router(config-pmap-c)# set mpls exp 5
Router(config-pmap-c)# ^Z
Router# configure terminal
Router(config)# interface ge-WAN 5/4
Router(config-if)# service-policy input VPN-MARKING
Router(config-if)# ^Z
Router# show running-config interface g5/4
Building configuration...
 
Current configuration :175 bytes
!
interface GE-WAN5/4
ip vrf forwarding TEST
ip address 194.3.1.3 255.255.255.0
negotiation auto
service-policy input VPN-MARKING
mls qos trust dscp
end
Router#

EoMPLSの設定

EoMPLSを使用すると、VLAN環境でブリッジ、ルータ、またはスイッチを使用しなくても、異なる場所にある2つのVLANネットワークを接続できます。MPLSバックボーンの両側でLabel Edge Router(LER;ラベル エッジ ルータ)を設定することによって、MPLSバックボーン ネットワークでレイヤ2 VLANトラフィックを受信するように設定できます。

EoMPLSの詳細および4ポート ギガビット イーサネットWAN(GBIC)OSMとPOS OSM上でEoMPLSを設定する方法については、次のURLにアクセスし、『Ethernet over MPLS』フィーチャ モジュールを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121limit/121ex/121ex8a/eompls9.htm