オプティカル サービス モジュール コンフィギュレーション ノート Cisco IOS Release 12.1E
OSM上でのDSSの設定
OSM上でのDSSの設定
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

OSM上でのDSSの設定

DSSの概要

DSSの設定

入力DSSの設定

入力DSBの設定

OSM上でのDSSの設定

この章では、OSM(オプティカル サービス モジュール)上でDestination Sensitive Services(DSS)を設定する方法について説明します。

この章の内容は次のとおりです。

「DSSの概要」

「DSSの設定」

DSSの概要

DSSにより、既知の自律システム番号に対してトラフィック アカウンティングおよびトラフィック シェーピングを実行し、ネットワーク回線のピアリングおよびトランジット アグリーメントに関するエンジニアリングおよびプランニングができます。DSSは、次のOSMの入力WANポート上でサポートされます。

OC-3 POS

OSM-4OC3-POS-SI

OSM-8OC3-POS-SI、SL

OSM-16OC3-POS-SI、SL

OSM-4OC3-POS-SI+

OSM-8OC3-POS-SI+、SL+

OSM-16OC3-POS-SI+、-SL+

OC-12 POS

OSM-2OC12-POS-MM、SI、SL

OSM-4OC12-POS-MM、SI、SL

OSM-2OC12-POS-MM+、SI+、SL+

OSM-4OC12-POS-MM+、SI+、SL+

OC-48 POS

OSM-1OC48-POS-SS、SI、SL

OSM-1OC48-POS-SS+、SI+、SL+

チャネライズド

OSM-1CHOC48/T3-SS

OSM-1CHOC12/T3-SI

OSM-1CHOC12/T1-SI

OSM-12CT3/T1

OC-48 POS/DPT

OSM-2OC48/1DPT-SS、SI、SL

ギガビット イーサネット

OSM-4GE-WAN-GBIC

OSM-2+4GE-WAN+

DSSには、2つの独立したサービスがあります。

Destination Sensitive Billing(DSB)

DSBにより、宛先トラフィック インデックスに基づく課金が可能です。その結果、トラフィックがたどるルートに基づいて、カスタマーのトラフィックを分類することができます。カスタマーのトラフィックが固有のソフトウェア インターフェイス上に存在する場合、宛先ネットワークに基づいて、太平洋横断、大西洋横断、衛星、国内、およびその他のプロバイダーのトラフィックを識別し、課金することができます。DSBはパケットおよびバイトカウンタを提供するので、宛先ネットワーク別にIPパケット数を調べることができます。DSBは、7種類のインデックスのいずれか1つにトラフィックを分類することによってトラフィッククラスを表すルートマップを使用して実装します。

Destination Sensitive Traffic Shaping(DSTS)

DSTSでは、宛先トラフィック インデックスの設定に基づいて、着信トラフィック シェーピングを実行します。

設定については、「DSSの設定」を参照してください。


) CLIでは設定可能ですが、DSBおよびDSTSの両方を同じインターフェイス上に適用しないでください。


DSSの設定

WANインターフェイスに入力DSSおよびDSBを設定すると、そのWANインターフェイスに届いたトラフィックが分類され、課金されます。

以下に入力DSSおよびDSBの設定方法について説明します。

「入力DSSの設定」

「入力DSBの設定」

入力DSSの設定

OSM上に入力DSSを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router(config)# route-map map-tag [permit | deny] [sequence-number]

あるルーティング プロトコルから別のルーティング プロトコルへ再配信するルートの条件を定義します。

ステップ 2

Router(config-route-map)# match community-list community-list-number

BGPコミュニティを照合します。

ステップ 3

Router(config-route-map)# set traffic-index 1-8

BGPトラフィック インデックスを作成します。

ステップ 4

Router(config)# router bgp autonomous-system

BGPルーティングを設定します。

ステップ 5

Router(config-router)# table-map route-map-name

BGPが学習したルートを反映させてIPルーティング テーブルが更新されたときに、メトリックおよびタグの値を変更します。

ステップ 6

Router(config)# ip bgp-community new-format

AA:NN(自律システム コミュニティ番号/2バイトの番号)の形式でBGPコミュニティを表示します。

ステップ 7

Router(config)# ip community-list 40 100:120

BGPのコミュニティ リストを作成し、そのリストへのアクセスを制御します。

ステップ 8

Router(config-pmap)# class-map [match-all | match-any]

定義したクラスに対してパケットを照合するためのクラス マップを作成し、一致条件を指定します。

ステップ 9

Router(config-pmap-c)# match bgp-index bgp-index

照合するための具体的なBGPインデックスを指定します。

ステップ 10

Router(config)# policy-map policy_map

1つまたは複数のインターフェイスに適用できるポリシー マップを作成または変更し、サービス ポリシーを指定します。

ステップ 11

Router(config-pmap)# class class-name

サービス ポリシーに含めるクラスを定義します。

ステップ 12

Router(config-pmap-c)# shape [average | peak] mean-rate [[burst-size] [excess-burst-size]]

指定されたビット レートに合わせてトラフィックをシェーピングします。

ステップ 13

Router(config)# interface

ポリシー マップを適用するWANインターフェイスを指定します。

ステップ 14

Router(config-if)# service-policy input policy-map

指定したポリシーマップを、入力インターフェイスに適用します。

入力DSSを設定する手順は、次のとおりです。


ステップ 1 BGPトラフィック インデックスを作成することによって、BGPルートを分類します。

Router(config)# route-map dss-map1 permit 1
Router(config-route-map)# match community 40
Router(config-route-map)#s et traffic-index 1
Router(config-route-map)# exit
Router(config)# route-map dss-map3
Router(config-route-map)# match community 50
Router(config-route-map)# set traffic-index 3
Router(config-route-map)# exit
Router(config)# route-map dss-map7
Router(config-route-map)# match community 60
Router(config-route-map)# set traffic-index 7
Router(config-route-map)# exit
 

ステップ 2 自律システムに対してBGPルーティングをイネーブルに設定し、ルートマップを適用します。

Router(config)# router bgp 100
Router(config-router)# table-map dss-map1
Router(config)# ip bgp-community new-format
Router(config)# ip community-list 10 100:120
Router(config-router)# exit
 

ステップ 3 BGPインデックスをトラフィック インデックス クラスに対応付けます。

Router(config)# class-map dss1
Router(config-cmap)# match bgp-index 1
Router(config-cmap)# exit
Router(config)# class-map dss3
Router(config-cmap)# match bgp-index 3
Router(config-cmap)# exit
Router(config)# class-map dss7
Router(config-cmap)# match bgp-index 7
Router(config-cmap)# exit
 

ステップ 4 ポリシー マップおよびトラフィック シェーピングのパラメータを設定します。

Router(config)# policy-map dss-policy
Router(config-pmap)# class dss1
Router(config-pmap-c)#s hape average 64000
Router(config-pmap-c)# exit
Router(config-pmap)# class dss3
Router(config-pmap-c)# shape average 1024000
Router(config-pmap-c)# exit
Router(config-pmap)# class dss7
Router(config-pmap-c)# shape average 384000
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)#
 

ステップ 5 ポリシー設定を該当するWANインターフェイスに適用します。

Router(config)# interface ge-wan 4/1
Router(config-if)# service-policy input dss-policy
Router(config-if)# exit
Router(config)
 

ステップ 6 DSSの設定情報を表示します。

Router# show ip cef 8.1.1.0
8.1.1.0/24, version 340, cached adjacency 19.1.1.3
0 packets, 0 bytes, Precedence critical (5), traffic_index 1
via 19.1.1.3, 0 dependencies, recursive
next hop 19.1.1.3, Vlan19 via 19.1.1.3/32
valid cached adjacency
 
Router# show ip bgp 8.1.1.0
BGP routing table entry for 8.1.1.0/24, version 14
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Not advertised to any peer
12
19.1.1.3 from 19.1.1.3 (19.1.1.3)
Origin IGP, metric 0, localpref 100, valid, external, best
Community: 100:120
 
Router# show class-map dss1
Class Map match-all dss1 (id 8)
Match bgp-index 1
 
Router# show policy-map interface ge-wan 4/1
 
GigabitEthernet4/1
 
service-policy input: dss-policy
 
class-map: dss1 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
match: bgp-index 1
queue size 0, queue limit 2
packets input 0, packet drops 0
(テキスト出力は省略)
 
Router(config)#
 


 

入力DSBの設定

OSM上に入力DSBを設定し、BGPポリシー アカウンティング設定を表示し、入力DSBカウンタをクリアする手順は、次のとおりです。


ステップ 1 ポート上の入力DSBをイネーブルにします。

Router(config)# interface GE-WAN6/2
Router(config-if)# ingress-dsb
 

ステップ 2 インターフェイス上のBGPポリシー アカウンティングをイネーブルにします。

Router(config-if)# bgp-policy accounting
Router(config-if)# end
 

ステップ 3 入力インターフェイス上のBGPポリシー アカウンティング設定を表示します。

Router# show cef interface GE-WAN6/2 policy
GE_WAN6/2 is up (if_number 18)
Corresponding hwidb fast_if_number 18
Corresponding hwidb firstsw->if_number 18
BGP based Policy accounting is enabled
Index Packets Bytes
1 5259200 315552000
2 5259300 315558000
3 5259300 315558000
4 5258900 315534000
5 5258916 315534960
6 5259000 315540000
7 5259100 315546000
8 0 0
Router#
 

ステップ 4 すべての入力DSBカウンタをクリアします。

Router# clear cef interface policy-statistics
 

ステップ 5 特定インターフェイスの入力DSBカウンタをクリアします。

Router# clear cef interface GE-WAN6/2 policy-statistics