オプティカル サービス モジュール コンフィギュレーション ノート Cisco IOS Release 12.1E
OC-12 ATM OSMの設定
OC-12 ATM OSMの設定
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

OC-12 ATM OSMの設定

ATMの概要

サポート対象の機能

OC-12 ATMインターフェイスの設定

OC-12 ATM OSMの初期設定

ATMインターフェイスのイネーブル化

有効なVCIおよびVPI設定

各VPの最大VC数の設定

VCの設定

PVCの作成

PVC用のRFC 1483ブリッジングの設定

メイン インターフェイス上のRFC 1483ブリッジングの設定

802.1Qトンネリングの設定

RFC 1483 BREの設定

PVCトラフィック パラメータの設定

SVCの設定

ILMIとの通信設定

SVCコール セットアップを実行するPVCの設定

NSAPアドレスの設定

ESIフィールドおよびセレクタ フィールドの設定

完全なNSAPアドレスの設定

SVCの作成

SONETおよびSDHコンフィギュレーション コマンド

atm framing sonet | sdh

atm sonet stm-4

atm sonet report

atm sonet threshold

OC-12 ATM OSMの設定

この章では、2ポートのOC-12ATM WAN OSM(オプティカル サービス モジュール)について説明します。

この章の内容は次のとおりです。

「ATMの概要」

「サポート対象の機能」

「OC-12 ATMインターフェイスの設定」

「VCの設定」

「SONETおよびSDHコンフィギュレーション コマンド」

ATMの概要

Asynchronous Transfer Mode(ATM;非同期転送モード)は、セル スイッチングと多重化テクノロジーを使用し、回線交換の利点(一定の転送遅延と保証された転送量)と、パケット交換の利点(断続的なトラフィックを効率的に処理するフレキシビリティ)の両方を備えています。

ATMは、コネクション型の接続環境です。ATMネットワークで送受信されるトラフィックはすべて、先頭にVirtual Path Identifier(VPI;仮想パス識別子)およびVirtual Channel Identifier(VCI;仮想チャネル識別子)が設定されています。VPI/VCIぺアが1つの仮想回線としてみなされます。各仮想回線は、ATMネットワーク上の他のノードにプライベートに接続します。仮想回線は他のルータまたはホストへのポイントツーポイント接続として処理され、双方向トラフィックがサポートされます。

各ATMノードは、ATMネットワーク上で通信する他のすべてのノードに対して、個別に接続を確立する必要があります。これらの接続はすべて、ネットワーク運用者が設定するPermanent Virtual Circuit(PVC;相手先固定接続)、またはATMシグナリング機構により設定および廃棄されるSwitched Virtual Circuit(SVC;相手先選択接続)を使用して確立されます。このシグナリングは、ATMフォーラムUser Network Interface(UNI)仕様V3.x, 4.0に基づいています。

サポート対象の機能

2ポートのOC-12 ATM OSMのWANポートでは、次の機能をサポートしています。

MPLS VPN

PVC

SVC

1つのモジュールにつき最大1000 VC、1つの物理ATMインターフェイスにつき100 VCをサポート

VPI範囲0~255(デフォルトは15)

VCI範囲1~1,023(デフォルトは1,023)

RFC1577 Classical IP over ATM

RFC1483ブリッジング サポート(PVCのみ)

1483ルーテッド カプセル化のブリッジング(BRE)

ポイントツーポイント サブインターフェイスでのマルチキャスト パケットのハードウェア スイッチング

ポイントツーマルチポイント サブインターフェイスでのマルチキャスト パケットのソフトウェア スイッチング

UNI 3.xおよびUNI 4.0

ILMI 1.0

VC単位のレイヤ3キューイング

レイヤ3トラフィック シェーピング

Committed Information Rate(CIR;認定情報速度)

EIR

OSM-2OC12-ATM-MM/SI+によるPFC Quality of Service(QoS;サービス品質)

VP単位シェーピング

VC単位シェーピング

Unspecified Bit Rate(UBR;無規定ビット レート)およびVariable Bit Rate-Non Real Time(VBR-nrt;可変ビット レート非リアルタイム)

Per-VC Class-Based Weighted Fair Queueing(VC単位CBWFQ;VC単位クラスベース均等化キューイング)

Low Latency Queueing(LLQ)

Weighted Random Early Detection(WRED;重み付きランダム早期検出)

Committed Access Rate(CAR;専用アクセス レート)


) OC-12 ATM OSMでは、AAL5 CPCS PDUのCommon Part Convergence Sub-layer User-to-User(CPCS-UU)フィールドを正常に設定、削除、または伝送できません。これにより、このフィールドのカスタムな使用に影響が生じます。さらに、フレーム リレーのコマンド レスポンス(C/R)ビットの転送にCPCS-UUバイトを使用するFRF8.1の使用にも影響が生じます。


WAN OSMポートに対するQoSの設定情報および設定例については、「OSM上のQoSの設定」を参照してください。

WAN OSMポートに対するMPLS QoSの設定情報および設定例については、「MPLS QoSの設定」を参照してください。

Cisco IOS QoSの総合的な設定情報については、次のCisco IOSマニュアルを参照してください。

『Cisco IOS Quality of Service Solutions Configuration Guide』(URLは次のとおり)

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_c/index.htm

『Cisco IOS Quality of Service Solutions Command Reference』(URLは次のとおり)

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_r/index.htm

OC-12 ATMインターフェイスの設定

ここでは、OC-12 ATM OSMインターフェイスの初期設定の手順について説明します。

「OC-12 ATM OSMの初期設定」

「ATMインターフェイスのイネーブル化」

OC-12 ATM OSMの初期設定

起動時、新しいOC-12 ATM OSMのインターフェイスはシャットダウンしています。インターフェイスをイネーブルにするには、コンフィギュレーション モードで、 no shutdown コマンドを入力する必要があります。OC-12 ATMインターフェイスをイネーブルにしたときに追加の設定を行わないと、コンフィギュレーション ファイルのデフォルトのインターフェイス パラメータが使用されます。 表 8-1 に、デフォルトのパラメータを示します。

 

表 8-1 OC-12c/STM-4c ATMモジュールのデフォルト設定値

パラメータ
コンフィギュレーション
コマンド
デフォルト値

Maximum Transmission Unit(MTU;最大伝送ユニット)

[no] mtu bytes

4,470バイト

ループバック

[no] loopback [diagnostic | line]

ループバックなし

各VPのATM VC

atm vc-per-vp

1,023

新しいOC-12 ATMモジュールが正しく搭載されている(ACTIVE LEDが点灯し、すべてのケーブルが正しく接続されている)ことを確認したら、 configure コマンドを使用して、ATMインターフェイスを設定できます。

ATMインターフェイスのイネーブル化

Catalyst 6000ファミリー スイッチおよびCisco 7600シリーズ ルータのインターフェイス アドレスは、スロット番号とポート番号により、 slot/port 形式で設定されます。たとえば、スロット4に搭載した2ポートOC-12 ATM OSMのインターフェイスのスロット/ポート アドレスは、 4/1 になります。

configure コマンドを使用するには、 enable コマンドを使用して、EXECコマンド インタープリタのイネーブル レベルを開始する必要があります。パスワードが設定されている場合には、パスワードの入力が要求されます。

次に、2ポートのOC-12 ATM OSMの設定手順を示します。特に明記されていないかぎり、各設定手順の最後に Return キーを押してください。

ATMインターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# show module

show module コマンドを入力し、システムがモジュールを認識していることを確認します。

ステップ 2

Router# show interface atm slot/port

show interface コマンドを入力し、各ポートのステータスを調べます。

ステップ 3

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 4

Router(config)# interface atm slot/port

interface コマンドに続けて type およびslot/portを入力し、新しく設定するインターフェイスを指定します。

ステップ 5

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスにIPアドレスおよびサブネット マスクを割り当てます。

ステップ 6

Router(config-if)# no shutdown

Router(config-if)# end

インターフェイス ステートをアップに変更し、インターフェイスをイネーブルにします。

ステップ 7

Router# copy running-config startup-config

新しい設定をメモリに書き込みます。

次に、OC-12 ATM OSMインターフェイスを設定する例を示します。

Router# configure terminal
Router(config)# interface atm 4/0
Router(config-if)# ip address 1.2.3.4 255.255.255.0
Router(config-if)# no shutdown
Router# copy running-config startup-config
 

有効なVCIおよびVPI設定

各ATMインターフェイスに設定されるデフォルトのVPI数は15です。各VPIには最大1,023のVCIを設定できます。

表 8-2 に、VP単位のVC数およびVPIの最大数を示します。

 

表 8-2 有効なVCIおよびVPI設定

各VPのVC数
VPI最大数

1,024

15

512

31

256

63

128

127

64

255

32

255

16

255

各VPの最大VC数の設定

ATMインターフェイスは、デフォルトで、各VPに最大1,023のVCを設定できるようになっています。この値を変更するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface atm slot/port

インターフェイス コンフィギュレーション モードを開始し、設定対象のATMインターフェイスを指定します。

ステップ 2

Router(config-if)# atm vc-per-vp

各VPの最大VC数(16、32、64、128、256、512、1,024)を設定します。デフォルト値は1,024です。

ステップ 3

Router(config-if)# no shutdown

この設定を使用して、インターフェイスをイネーブルにします。

VCの設定

ここでは、PVC、ブリッジドPVC(RFC 1483)、PVCトラフィックのパラメータ、およびSVCを設定するための基本事項について説明します。また、2ポートのOC-12 ATM OSMに固有のコマンドおよびコンフィギュレーションが記載されています。

「PVCの作成」

「PVC用のRFC 1483ブリッジングの設定」

「RFC 1483 BREの設定」

「SVCの設定」

「ILMIとの通信設定」

「SVCコール セットアップを実行するPVCの設定」

「NSAPアドレスの設定」

「SVCの作成」

OC-12 ATM OSMがサポートしている他のCisco IOS機能およびコマンドについては、次のURLにアクセスし、『Cisco IOS Wide-Area Networking Configuration Guide』Release 12.1の「Configuring ATM」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdatm.htm

コマンド構文の詳細については、次のURLにアクセスし、『Cisco IOS Wide-Area Networking Command Reference』Release 12.1のATMの章を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wratm/index.htm

PVCの作成

ATMインターフェイス上にPVCを作成し、interface-ATM-VCコンフィギュレーション モードを開始するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config)# interface atm slot/port

interface コマンドに続けて type およびslot/portを入力し、新しく設定するインターフェイスを指定します。

ステップ 2

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスにIPアドレスおよびサブネット マスクを割り当てます。

ステップ 3

Router(config-if)# pvc [ name ] vpi / vci [ ilmi | qsaal ]

新しいATM PVCを作成し、名前(任意)およびVPI/VCI番号を割り当てます。interface-ATM-VCコンフィギュレーション モードを開始します。任意に、Integrated Local Management Interface(ILMI)またはQSAALカプセル化を設定します。

ステップ 4

Router(config-if-atm-vc)# protocol protocol protocol-address [[ no ] broadcast ]

PVCにプロトコル アドレスをマッピングします。

ステップ 5

Router(config-if-atm-vc)# encapsulation {aal5mux | aal5snap}

(任意)AALおよびカプセル化タイプを設定します。デフォルトは、aal5snapです。

次に、PVCを作成する例を示します。

Router(config)# interface atm 4/0
Router(config-if)# ip address 10.212.13.4 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# pvc cisco 0/56
Router(config-if-atm-vc)# protocol ip 10.212.13.5 broadcast
Router(config-if-atm-vc)# encapsulation aal5snap
Router(config-if-atm-vc)#
 

PVC用のRFC 1483ブリッジングの設定

OC-12 ATM OSM上で実装されているように、RFC 1483ブリッジングは、OC-12 ATM OSMおよびイーサネット ポート上にあるATMインターフェイス間レイヤ2 PDUのポイントツーポイント ブリッジングをサポートします。

図 8-1は、2つのOC-12 ATM OSMを使用することでATMクラウドを介し、レイヤ2 PDUを転送するトポロジーを示します。この例では、スイッチおよびルータに設置されたモジュールのATMポート間のトランク リンク上でVLANは転送されます。トラフィックはATMポートを通過したあと、OC-12 ATM OSM上のRFC 1483に設定され、ATMクラウドへと伝送されます。

図 8-1 RFC 1483ブリッジング トポロジーの例

 

OC-12 ATM OSM用のRFC 1483ブリッジングは、AAL5-MUXおよびAAL5-LLC Subnetwork Access Protocol(SNAP)カプセル化PVCでサポートされています。RFC 1483ブリッジドPVCはATM OSM上で終端される必要があります。終端までのブリッジド接続上を転送されるトラフィックは、図 8-1に示されるように、イーサネット ポートを通過して転送されなければなりません。RFC 1483ブリッジドPVC間のブリッジングはサポートされていません。


) SVC環境のRFC 1483ブリッジングはサポートされていません。



) VLAN Trunk Protocol(VTP;VLANトランク プロトコル)が正常に機能するには、各メイン インターフェイスに、VLAN 1および1,002~1,005に関連付けられたVC用に設定されているサブインターフェイスがあることを確認してください。


PVC用のRFC 1483ブリッジングを設定するには、グローバル コンフィギュレーション モードを開始し、下記のコマンドを使用します。

 

コマンド
説明

ステップ 1

Router(config)# interface atm slot/port

設定する新しいインターフェイスを指定します。

ステップ 2

Router(config-if)# atm bridge-enable

メイン インターフェイスのブリッジングをイネーブルにします。

ステップ 3

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 4

Router(config)# interface atm slot/port [ . subinterface-number point-to-point ]

PVCを設定するサブインターフェイスを指定します。

ステップ 5

Router(config-subif)# pvc [ name ] vpi / vci

新しいATM PVCを作成し、名前(任意)およびVPI/VCI番号を割り当てます。

ステップ 6

Router (config-if-atm-vc)# bridge-vlan vlan_id [dot1q1] [dot1q-tunnel2] [lan-fcs]3

VLANをPVCにバインドします。

dot1qキーワードを使用し、ATM PVCを介してCoS(サービス クラス)情報を保存します。

FlexWANのRFC 1483ブリッジング設定時、lan-fcsキーワードを使用し、ATMクラウドを介してLANチェックサムを保存します。

ステップ 7

Router (config-if-atm-vc)#

デフォルトのカプセル化タイプを指定します。

ステップ 8

Router (config-if-atm-vc)# ^Z

コンフィギュレーション モードを終了します。

ステップ 9

Router# show interface atm slot/port [ . subinterface-number

サブインターフェイス設定とステータスを確認します。

ステップ 10

Router# show interface atm slot/port switchport

メイン インターフェイス スイッチ ポート設定とステータスを確認します。

ステップ 11

Router# show interface atm slot/port trunk

トランク設定を確認し、許容VLAN用のフォワーディング ステートを示します。

1.dot1qキーワードが指定されると、802.1QヘッダーがATM PVCを介して伝送されます。これにより、PVCを介してCoS情報を保存することができます。dot1qキーワードを指定しない場合、QoS実行時に入力側はCoS値として0を使用します。

2.dot1q-tunnelキーワードが指定されると、802.1Qトンネリングがイネーブルになります。これにより、サービス プロバイダーは単一のVLANを使用して複数のVLANを所有するカスタマーをサポートする一方で、カスタマーのVLAN IDを維持し、異なるカスタマーVLANのトラフィックを分離しておくことができます。802.1Qトンネリングの詳細については、「802.1Qトンネリングの設定」を参照してください。

3.lan-fcsのキーワード オプションはFlexWANに対してのみ適用されます。

下記の例では、ブリッジングがOC-12 ATM OSM上のメインATMインターフェイスでイネーブルにされ、aal5snapカプセル化が行われているPVCはVLAN 666に関連付けられており、もう一つのPVCは、VLAN 777に関連付けられています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface atm 6/1
Router(config-if)# atm bridge-enable
Router(config)# interface atm 6/1.3 point-to-point
Router(config-subif)# pvc 103/103
Router(config-if-atm-vc)# bridge-vlan 666 dot1q
Router(config-if-atm-vc)# oam-pvc manage
Router(config-if-atm-vc)# exit
Router(config-subif)# exit
Router(config)# interface atm 6/1.4 point-to-point
Router(config-subif)# pvc 104/104
Routerconfig-if-atm-vc)# bridge-vlan 777
Router(config-if-atm-vc)#
Router(config-if-atm-vc)# ^Z
Router#
 

下記のコマンドでインターフェイス設定とステータスを確認します。

Router# show interface atm 6/1.3
ATM6/1.3 is up, line protocol is up
Hardware is ATM OC12 LC
Internet address is 8.8.8.1/24
MTU 4470 bytes, BW 599040 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM
5 packets input, 566 bytes
5 packets output, 566 bytes
1445 OAM cells input, 1446 OAM cells output
Router# show interface atm 6/1 switchport
Name:AT6/1
Switchport:Enabled
Administrative Mode:trunk
Operational Mode:trunk
Administrative Trunking Encapsulation:dot1q
Operational Trunking Encapsulation:dot1q
Negotiation of Trunking:Off
Access Mode VLAN:1 (default)
Trunking Native Mode VLAN:1 (default)
Administrative private-vlan host-association:none
Administrative private-vlan mapping:none
Operational private-vlan:none
Trunking VLANs Enabled:666,777,1002-1005
Pruning VLANs Enabled:2-1001
Router# show interface atm 6/1 trunk
 
Port Mode Encapsulation Status Native vlan
AT6/1 on 802.1q trunking 1
 
Port Vlans allowed on trunk
AT6/1 666,777,1002-1005
 
Port Vlans allowed and active in management domain
AT6/1 666,777,1002-1005
 
Port Vlans in spanning tree forwarding state and not pruned
AT6/1 666,777,1002-1005
 
 
 
Router# show running-config interface atm 6/1
Building configuration...
 
Current configuration :306 bytes
!
interface ATM6/1
no ip address
atm clock INTERNAL
atm mtu-reject-call
atm bridge-enable
no atm auto-configuration
no atm ilmi-keepalive
no atm address-registration
mls qos trust dscp
switchport
switchport trunk allowed vlan 666,777,1002-1005
switchport mode trunk
switchport nonegotiate
end
 
Router# show running-config interface atm 6/1.3
Building configuration...
 
Current configuration :172 bytes
!
interface ATM6/1.3 point-to-point
ip address 8.8.8.1 255.255.255.0
pvc 103/103
bridge-vlan 666
oam-pvc manage
encapsulation aal5snap
!
mls qos trust dscp
end
 
Router# show running-config interface atm 6/1.4
Building configuration...
 
Current configuration :129 bytes
!
interface ATM6/1.4 point-to-point
pvc 104/104
bridge-vlan 777
encapsulation aal5snap
!
mls qos trust dscp
end
 

メイン インターフェイス上のRFC 1483ブリッジングの設定

メイン インターフェイス上のRFC 1483ブリッジングをイネーブルにするには、 bridge-vlan コマンドを使用します。下記の例では、ブリッジングがメインATMインターフェイス上でイネーブルにされています。PVCは、OC-12 ATM OSM上のメイン インターフェイスで設定され、PVC 10/10はVLAN 99に関連付けられ、PVC 10/11はVLAN 100に関連付けられます。 show interface atm コマンドを使用して、インターフェイスの設定およびステータスを表示します。

router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
router(config)# int atm 6/2
router(config-if)# pvc 10/10
router(config-if-atm-vc)# bridge-vlan 99 dot1q
router(config-if-atm-vc)# pvc 10/11
router(config-if-atm-vc)# bridge-vlan 100
router(config-if-atm-vc)# end
router(config)# sh ru int atm 6/2
Building configuration...
 
Current configuration :326 bytes
!
interface ATM6/2
no ip address
shutdown
atm clock INTERNAL
atm mtu-reject-call
atm bridge-enable
no atm ilmi-keepalive
pvc 10/10
bridge-vlan 99 dot1q
!
pvc 10/11
bridge-vlan 100
!
mls qos trust dscp
switchport
switchport trunk allowed vlan 99,100
switchport mode trunk
switchport nonegotiate
end
 

802.1Qトンネリングの設定

Service Provider(SP;サービス プロバイダー)は、802.1Qトンネリングにより単一のVLANを使用して複数のVLANを所有するカスタマーをサポートする一方で、カスタマーのVLAN IDを維持し、異なるカスタマーVLANのトラフィックを分離させておくことができます。dot1qトンネリングおよびL2プロトコル トンネリングは、SPのルータでのみ設定されます。カスタマー側で、これらの設定を認識することはありません。

図 8-2に、2つのCPE(カスタマー側装置)デバイス(CPE1およびCPE2)を示します。各CPEデバイスには、VLAN 15に関連付けされたPVCがあり、次のコマンドを使用するとイネーブルになります。

Router(config-if)# pvc 2/100
Router(config-if-atm-vc)# bridge-vlan 15 dot1q
 

SP側では、PVCはVLAN 99に関連付けられ、 dot1q-tunnel キーワードが指定されます。また、メインATMインターフェイスにも atm bridge-enable dot1q-tunnel コマンドがあります。 dot1q-tunnel キーワードにより、スパニング ツリーBPDUフィルターおよびL2プロトコルの両方が、自動的にイネーブルになります。次に、この設定例を示します。

Router(config-if)# atm bridge-enable dot1q-tunnel
Router(config-if)# pvc 2/100
Router(config-if-atm-vc)# bridge-vlan 99 dot1q-tunnel
 

図 8-2 802.1Qトンネリングのネットワーク

 

この例では、カスタマーのVLANは、SPによりトンネリングされています。フレームは、15の明示的な802.1Qタグを付けてSPドメインに入ったあと、99のSP VLANタグを付けて転送されます。SPネットワーク内では、ネットワークはSP VLANしか認識しません。元のカスタマーVLANは、SPネットワークを通過する際に回復します。VLAN 99は外され、元のフレームは、dot1qトンネル インターフェイスを通過するときに回復します。

Cisco 7600ルータの802.1Qトンネリングの詳細については、次のURLにアクセスし、『Cisco 7600 Series Cisco IOS Software Configuration Guide, 12.1E』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/ios121_8/swcg/dot1qtnl.htm

802.1Qトンネリングをイネーブルにするには、 bridge-vlan < vlan > dot1q-tunnelコマンドを使用します。

bridge-vlan vlan [dot1q] [dot1q-tunnel]
[no] bridge-vlan vlan [dot1q] [dot1q-tunnel]

カスタマー設定

次に、カスタマー側で802.1Qトンネリングを設定する例を示します。


) カスタマー側で802.1Qトンネリングをイネーブルにするには、bridge-vlanコマンドを使用してdot1qキーワードを入力する必要があります。


Router(config)# interface ATM6/2
router(config-if)# no ip address
router(config-if)# atm clock internal
router(config-if)# atm mtu-reject-call
router(config-if)# atm bridge-enable
Router(config-if-atm-vc)# pvc 2/101
Router(config-if-atm-vc)# bridge-vlan 15 dot1q
 

SP設定

次に、SP側で802.1Qトンネリングを設定する例を示します。


) SP側で802.1Qトンネリングをイネーブルにするには、bridge-vlanコマンドを使用してdot1q-tunnelキーワードを入力する必要があります。


Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# int atm 6/2
router(config-if)# atm bridge-enable dot1q-tunnel
router(config-if)# pvc 2/101
router(config-if-atm-vc)# bridge-vlan 99 dot1q-tunnel
 

次に、802.1Qトンネリングがイネーブルの設定例を示します。

interface ATM6/2
no ip address
shutdown
atm clock INTERNAL
atm mtu-reject-call
atm bridge-enable dot1q-tunnel
no atm ilmi-keepalive
pvc 2/101
bridge-vlan 99 dot1q-tunnel
!
mls qos trust dscp
switchport
switchport trunk allowed vlan 99
switchport mode trunk
switchport nonegotiate
spanning-tree bpdufilter enable
end
 

次に、 show l2protocol-tunnel コマンドの出力を示します。

Router# show l2protocol-tunnel
COS for Encapsulated Packets: 5
 
Port Protocol Shutdown Drop Encapsulation Decapsulation Drop
Threshold Threshold Counter Counter Counter
------- -------- --------- --------- ------------- ------------- -------------
Gi4/2 cdp ---- ---- 0 0 0
stp ---- ---- 0 0 0
vtp ---- ---- 0 0 0
ATM6/2 cdp ---- ---- n/a n/a n/a
stp ---- ---- n/a n/a n/a
vtp ---- ---- n/a n/a n/a

) 802.1Qトンネリングがイネーブルの場合、show l2protocol-tunnelコマンドの出力のカウンタをATMインターフェイスに適用できません。


次に、 show dot1q-tunnel コマンドの出力を示します。

Router# show dot1q-tunnel
LAN Port(s)
-----------
Gi4/2
 
ATM Port(s)
-----------
ATM6/1
 

RFC 1483 BREの設定

Bridging of Routed Encapsulations(BRE;ルーテッド カプセル化のブリッジング)は、OC-12 ATM OSMがRFC 1483ルーテッド カプセル化パケットを受信し、レイヤ2フレームとしてそのパケットを転送できるようにします。


) 同じPVCとVLAN上に、RFC 1483ブリッジングとBREを同時に設定することはサポートされていません。


OC-12 ATM OSM上のATM PVCにBREを設定する場合、PVCはルーテッドPDUを受け取り、RFC 1483ルーテッド カプセル化ヘッダーを取り除き、イーサネットMACヘッダーをパケットに追加します。レイヤ2カプセル化パケットはスーパバイザ エンジンにより、VLAN番号と宛先MACによって判別されるレイヤ2インターフェイスにスイッチングされます。

図 8-3は、OC-12 ATM OSMがルーテッドPDUを受信し、それらをレイヤ2フレームとしてカプセル化し、このフレームをレイヤ2カスタマー デバイスに転送するトポロジーを示しています。

図 8-3 BREトポロジーの例

 

BREをPVCに設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router(config)# vlan

レイヤ2 VLANを設定します。

ステップ 2

Router(config)# interface atm slot/port [ . subinterface-number point-to-point ]

PVCを設定するサブインターフェイスを指定します。

ステップ 3

Router(config-subif)# pvc [ name ] vpi / vci

新しいATM PVCを作成し、名前(任意)およびVPI/VCI番号を割り当てます。

ステップ 4

Router (config-if-atm-vc)# bre-connect vlan [ip ip address]

PVCでBREをイネーブルにします。

BREスイッチからCPEへパケットを最初に送る場合、ipキーワードを使用することで、BREデバイスにARP要求を生成させ、CPEのMACアドレスを取得します。

ステップ 5

Router(config)# interface GigabitEthernet slot/port

設定するギガビット イーサネット ポートを指定します。

ステップ 6

Router(config-if)# switchport

レイヤ2スイッチング用のギガビット イーサネット ポートを設定します。

ステップ 7

Router(config-if)# switchport access vlan vlan_id

(任意)インターフェイスでのトランキングを停止した場合に使用する、デフォルトのVLANを指定します。

ステップ 8

Router(config-if)# switchport mode access

インターフェイスを非トランキング モードにします。

次の例ではBREを設定する手順を示します。


ステップ 1 VLANインターフェイスを設定します。

Router(config)# interface vlan 10
Router(config-if)# no shutdown
Router(config-if)# end
Router#
 

ステップ 2 デフォルトのVLANをイーサネット インターフェイスに設定します。

Router(config)# interface GigabitEthernet3/3
Router(config-if)# no ip address
Router(config-if)# switchport
Router(config-if)# switchport access vlan 10
Router(config-if)# switchport mode access
Router(config-if)# end
Router#
 

ステップ 3 ATMメイン インターフェイスをイネーブルにします。

Router(config)# interface atm3/1
Router(config-if)# no ip address
Router(config-if)# no shutdown
Router(config-if)# end
Router#
 

ステップ 4 PVCを設定します。

Router(config)# interface atm3/1.1 point-to-point
Router(config-if)# no ip address
Router(config-subif)# mtu 1500
Router(config-subif)# pvc 1/101
Router(config-if-atm-vc)# bre-connect 10
Router(config-subif)# end
Router#
 


 


) ATMインターフェイスでBRE VLANだけが設定されている場合、メインATMインターフェイスでspanning-tree bpdufilter enableコマンドを入力する必要があります。このコマンドを入力することにより、ATMインターフェイスのすべてのスパニング ツリーBPDUはブロックされます。また、同じATMインターフェイスまたはこのサブインターフェイスの1つで、RFC 1483ブリッジドVLANも設定されている場合、このインターフェイスでBPDUを明示的にブロックしようとしないかぎり、spanning-tree bpdufilter enableコマンドを入力すべきではありません。


PVCトラフィック パラメータの設定

サポートされるトラフィック パラメータのサービス カテゴリは、UBRおよびVBR-nrtです。各PVC接続について、1つのカテゴリだけを指定することができます。新しいカテゴリを指定すると、既存のカテゴリが置換されます。

PVCトラフィックのパラメータを設定するには、interface-ATM-VCコンフィギュレーション モードで次のいずれかのコマンドを実行します。

 

コマンド
説明

Router(config-if-atm-vc)# ubr

UBRを設定します。UBRはデフォルト設定です。

Router(config-if-atm-vc)# vbr-nrt pcr scr mbs

VBR-nrtを設定します。

-pcr -scr 、および -mbs 引数にはそれぞれ、Peak Cell Rate(PCR;ピーク セル レート)、Sustainable Cell Rate(SCR;平均セル レート)、およびMaximum Burst Size(MBS;最大バースト サイズ)を指定します。

VBR-nrt PVCの設定可能な最高速度は、299,520 Mbpsです。MBSの最大セル数は255です。

次に、PCRを1,000、SCRを500、MBSを64に指定して、VBR-nrtを設定する例を示します。

Router(config-if-atm-vc)# vbr-nrt 1000 500 64
Router(config-if-atm-vc)#
 

SVCの設定

ATM SVCはダイナミックに作成されて開放されるので、帯域幅がオンデマンドで提供されます。このサービスを利用するには、ルータとスイッチ間にシグナリング プロトコルを設定する必要があります。

ATMシグナリング ソフトウェアにより、UNIでのATM接続をダイナミックに設定、保持、および消去することができます。ATMシグナリング ソフトウェアは、ILMIまたはコンフィギュレーションで選択したバージョンに応じて、ATMフォーラムUNI 3.xまたは4.0に準拠しています。

UNIモードでは、Cisco 7600ルータはATMレベルのコール ルーティングを実行しません。ATMコール ルーティングはATMスイッチにより実行され、ルータは決められた回線を使用してパケットをルーティングします。ルータは回線終端のユーザおよびLAN相互接続デバイスとして認識され、ATMスイッチはネットワークとして認識されます。

SVCを使用するには、次の作業を実行する必要があります。

「ILMIとの通信設定」(必須)

「SVCコール セットアップを実行するPVCの設定」(必須)

「NSAPアドレスの設定」(必須)

「SVCの作成」(任意)

ILMIとの通信設定

SVC環境では、ルータがSNMPトラップおよび新しいネットワーク プレフィクスを受信できるように、ILMIと通信するPVCを設定する必要があります。ILMI PVCの vpi および vci の推奨値は、0および16です。ILMIとの通信を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

Router(config-if)# pvc [ name ] vpi / vci [ ilmi | qsaal ]

ATMメイン インターフェイス上にILMI PVCを作成します。

次に、ATMメイン インターフェイス上にILMI PVCを作成する例を示します。

Router(config-if)# pvc cisco 0/16 ilmi

) ILMI PVCを設定できるのは、ATMメイン インターフェイスだけです。ATMサブインターフェイスに設定することはできません。


ILMI PVCを設定したあとで、インターフェイス コンフィギュレーション モードで次のコマンドを実行することにより、任意でILMIキープアライブ機能をイネーブルにすることができます。

 

コマンド
説明

Router(config-if)# atm ilmi-keepalive [ seconds ]

ILMIキープアライブをイネーブルにし、キープアライブのインターバルを指定します。

デフォルトでは、SNMPトラップおよび新しいネットワーク プレフィクスを受信できるように、ILMIアドレス登録がイネーブルに設定されています。ILMIキープアライブ機能はデフォルトではディセーブルです。イネーブルにした場合、デフォルトのキープアライブ インターバルは3秒です。

次に、ILMIキープアライブ インターバルを3分に設定する例を示します。

Router(config-if)# atm ilmi-keepalive 180
 

SVCコール セットアップを実行するPVCの設定

ルータとATMスイッチ間には1つの専用PVCが設定されます。SVCのコール確立要求およびコール終了要求はすべて、このPVCにより伝送されます。コールが確立されると、ルータ相互間のSVCによるデータ伝送が開始されます。

SVCをセットアップするには、事前にシグナリングPVCを設定する必要があります。

すべてのSVC接続を対象とするシグナリングPVCを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

Router(config-if)# pvc [ name ] vpi / vci [ ilmi | qsaal ]

SVCを使用するATMメイン インターフェイス用のシグナリングPVCを設定します。

次に、シグナリングPVCを設定する例を示します。

Router(config-if)# pvc 0/5 qsaal
Router(config-if-atm-vc)#

) シグナリングPVCを設定できるのは、ATMメイン インターフェイスだけです。ATMサブインターフェイスに設定することはできません。


VPIおよびVCIは、ATMスイッチと同じ値を設定する必要があります。VPIの標準値は0、VCIの標準値は5です。

NSAPアドレスの設定

シグナリングを使用するATMインターフェイスにはすべて、Network Service Access Point(NSAP;ネットワーク サービス アクセス ポイント)アドレスを設定する必要があります。NSAPアドレスはインターフェイスのATMアドレスで、ネットワーク全体で一意のアドレスでなければなりません。

NSAPアドレスを設定するには、次のいずれかの作業を行います。

「ESIフィールドおよびセレクタ フィールドの設定」

「完全なNSAPアドレスの設定」

ESIフィールドおよびセレクタ フィールドの設定

スイッチがILMIを使用してルータにNSAPアドレス プレフィクスを配信可能で、ルータにILMI経由でスイッチと通信するPVCが設定されている場合には、 atm esi-address コマンドを使用して、End Station ID(ESI)フィールドおよびセレクタ フィールドを設定できます。 atm esi-address コマンドにESI(12桁の16進数)およびセレクタ バイト(2桁の16進数)を入力することによって、ATMアドレスを設定できます。NSAPプレフィクス(26桁の16進数)は、ATMスイッチにより提供されます。

ルータがスイッチからNSAPプレフィクスを取得し、アドレスの他のフィールドにローカル入力値を使用するよう設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config-if)# pvc [ name ] vpi / vci [ ilmi | qsaal ]

ATMメイン インターフェイスに、ILMIを使用してスイッチと通信するILMI PVCを設定します。

ステップ 2

Router(config-if-atm-vc)# exit

インターフェイス コンフィギュレーション モードに戻ります。

ステップ 3

Router(config-if)# atm esi-address esi . selector

NSAPアドレスのESIおよびセレクタ フィールドを入力します。

Router(config-if)# pvc 0/16 ilmi
Router(config-if-atm-vc)# exit
Router(config-if)# atm esi-address 3456.7890.1234.12
 

ILMI PVCの vpi の推奨値は0、vciの推奨値は16です。

ILMI PVCのキープアライブ インターバルを指定することもできます。

完全なNSAPアドレスの設定

ATM NSAPアドレスを手作業で設定する場合には、アドレス全体を16進数形式で入力する必要があります。入力値はすべて16進数とみなされるからです。完全なNSAPアドレスを設定するには、次の形式で、40桁の16進数を入力する必要があります。

XX.XXXX.XX.XXXXXX.XXXX.XXXX.XXXX.XXXX.XXXX.XXXX.XX

) ATM NSAPアドレスはすべて、ATMフォーラムUNI仕様に準拠している上記のドット付き16進形式で入力できます。ドット付き形式により、アドレスが有効値かどうかを確認することができます。アドレス形式が正しいことがわかっている場合は、ドットを省略してもかまいません。


インターフェイスにはデフォルトのNSAPアドレスは設定されないので、SVC用のNSAPアドレスは必ず設定しなければなりません。ATMインターフェイスの送信元NSAPアドレスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

Router(config-if)# atm nsap-address nsap-address

インターフェイスのATM NSAPアドレスを設定します。

次に、NSAPアドレスを設定する例を示します。

Router(config-if)# atm nsap-address BC.CDEF.01.234567.890A.BCDE.F012.3456.7890.1334.13
Router(config-if)#
 

atm nsap-address コマンドと atm esi-address コマンドは、どちらか1つだけしか使用できません。ルータで atm nsap-address コマンドを実行すると、 atm esi-address コマンドの設定は無視されます。逆の場合も同じです。 show interface atm コマンドを実行すると、インターフェイスのATMアドレスを表示することができます。

SVCの作成

SVCを作成するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config-if)# svc [ name ] nsap address

(任意)SVCを作成し、宛先NSAPアドレスを指定します。

ステップ 2

Router(config-if-atm-vc)# encapsulation {aal5mux | aal5snap}

(任意)AALおよびカプセル化タイプを設定します。デフォルトは、aal5snapです。

ステップ 3

Router(config-if-atm-vc)# protocol protocol protocol-address [[ no ] broadcast ]

SVCにプロトコル アドレスをマップします。

SVCに名前を指定すると、 svc name コマンドを入力してinterface-ATM-VCコンフィギュレーション モードを再開したり、 no svc name コマンドを入力してSVCコンフィギュレーションを削除したりすることができます。

aal-encap 引数でサポートされるAALおよびカプセル化タイプのリストは、『 Cisco IOS Wide-Area Networking Command Reference 』のChapter「ATM Commands」の encapsulation aal5 コマンドの説明を参照してください。デフォルトは、AAL5およびSNAPカプセル化です。

次に、SVCを作成する例を示します。

Router(config-if)# svc nsap BC.CDEF.01.234567.890A.BCDE.F012.3456.7890.1334.13
Router(config-if-atm-vc)# encapsulation aal5mux
Router(config-if-atm-vc)# protocol ip 1.1.1.5 broadcast
Router(config-if-atm-vc)#
 

SONETおよびSDHコンフィギュレーション コマンド

2ポートOC-12 ATM OSMのデフォルトのフレーム同期方式はSONETですが、このモジュールはSDHもサポートしています。ここでは、オペレーション モードの変更、BERスレッシュホールド値の指定、およびアラーム通知のイネーブル化を実行するコマンドについて説明します。

atm framing sonet | sdh

フレーム同期方式を指定するには、atm framing sonet | sdhコマンドを使用します。デフォルトのフレーム同期方式はSONETです。

Router(config-if)# atm framing sdh
Router(config-if)#
 

atm sonet stm-4

オペレーション モードを設定し、SONET Physical Layer Interface Module(PLIM;物理レイヤ インターフェイス モジュール)のセルレート デカップリングに使用するATMセル タイプを制御するには、atm sonet stm-4インターフェイス コンフィギュレーション コマンドを使用します。このコマンドのno形式を使用すると、デフォルトのSynchronous Transport Signalレベル12(STS-12c)オペレーション モードに戻ります。


) atm sonet stm-4コマンドおよびatm framing sdhコマンドは、いずれもフレーム同期方式をSDHに変更します。この2つのコマンドの機能は同じです。


[no] atm sonet stm-4

次に、モードをSTS-12からSTM-4に変更し、コンフィギュレーションを確認する例を示します。

Router(config-if)# atm sonet stm-4
Router(config-if)# end
Router# show controllers atm 3/1
Interface ATM3/1 is up
 
hwidb addr:42773F94, instance addr:42780F64
 
Framing mode:SDH (STM-4)
Clock source:Line
 
VPIs in use:3, max VPIs:15
 
VPI # VCs VPI # VCs VPI # VCs
--- ----- --- ----- --- -----
0 201 1 3 255 1
 
ATM framing errors:
HCS (correctable): 1058413
HCS (uncorrectable):3851467
LCD: 18
 
SONET Subblock:
SECTION
LOF = 0 LOS = 2 RDOOL = 0 BIP(B1) = 1020363
Active Alarms:None
Active Defects:None
Alarm reporting enabled for:LOF LOS B1-TCA
LINE
AIS = 0 RDI = 5 FEBE = 437717490 BIP(B2) = 457516655
Active Alarms:None
Active Defects:None
Alarm reporting enabled for:B2-TCA SF
PATH
AIS = 0 RDI = 13 FEBE = 345027 BIP(B3) = 1229383
LOP = 2 NEWPTR = 0 PSE = 0 NSE = 0
Active Alarms:None
Active Defects:None
Alarm reporting enabled for:LOP B3-TCA
 
BER thresholds: SF = 10e-3, SD = 10e-6
TCA thresholds: B1 = 10e-6, B2 = 10e-6, B3 = 10e-6
Router#

atm sonet report

ATM SONETアラーム通知を設定するには、atm sonet reportインターフェイス コンフィギュレーション コマンドを使用します。このコマンドのno形式を実行すると、アラーム通知が解除されます。

[no] atm sonet report {all | b1-tca | b2-tca | b3-tca | default | lais | lrdi | pais | plop | pplm | prdi | ptim | puneq | sd-ber | sf-ber | slof | slos}

次に、B1スレッシュホールド超過アラートをイネーブルにする例を示します。

Router(config-if)# atm sonet report b1-tca
Router(config-if)#
 

atm sonet threshold

BERスレッシュホールド値を設定するには、atm sonet thresholdインターフェイス コンフィギュレーション コマンドを使用します。このコマンドのno形式を使用すると、コンフィギュレーションが削除されます。

[no] atm sonet-threshold {b1-tca value | b2-tca value| b3-tca value| sd-ber value| sf-ber value}

次に、B1スレッシュホールドを設定する例を示します。

Router(config-if)# atm sonet threshold b1-tca 9
Router(config-if)#