オプティカル サービス モジュール コンフィギュレーション ノート Cisco IOS Release 12.1E
チャネライズドOC-12/T3 SONET/SDH OSMの設定
チャネライズドOC-12/T3 SONET/SDH OSMの設定
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

チャネライズドOC-12/T3 SONET/SDH OSMの設定

チャネライズドOSMの概要

サポート対象の多重化およびマッピング

チャネライズドOC-12/T3 OSMがサポートする機能

SONETの適合性

SONETのエラー、アラーム、およびパフォーマンスのモニタリング

SONETの同期

WANプロトコル

ネットワーク管理

DS3サポート

DSUモード

QoSプロトコル

チャネライズド モジュールの設定

SONETコントローラの設定

POSインターフェイスの設定

DS3シリアル インターフェイスの設定

SDHフレーム同期とAU-3マッピングによるインターフェイスの設定

SDHフレーム同期とAU-4マッピングによるインターフェイスの設定

APSの設定

実行インターフェイスの設定

保護インターフェイスの設定

フレーム リレーおよびフレーム リレー トラフィック シェーピングの設定

フレーム リレーの制限および制約

フレーム リレー トラフィック シェーピングの設定例

設定例

チャネライズドPOSの設定

チャネライズドDS3の設定

基本的なAPSの設定

複数APSインターフェイスの設定

チャネライズドOC-12/T3 SONET/SDH OSMの設定

この章では、1ポートのチャネライズドOC-12(OSM-1CHOC12/T3-SI)SONET/SDH OSM(オプティカル サービス モジュール)を設定する方法について説明します。

この章の内容は次のとおりです。

「チャネライズドOSMの概要」

「チャネライズド モジュールの設定」

チャネライズドOSMの概要

ここでは、チャネライズドOSM上でのSONET/SDHのマッピング、多重階層、およびサポート対象の機能について説明します。

「サポート対象の多重化およびマッピング」

「チャネライズドOC-12/T3 OSMがサポートする機能」

「チャネライズド モジュールの設定」

サポート対象の多重化およびマッピング

OSM-1CHOC12/STM-4 T3-SIモジュールは、OC-3、DS3、DS3サブレートまでのチャネライズド コンフィギュレーションをサポートしています。

図 5-1は、1ポート チャネライズドOC-12/STM-4 OSMがサポートするSONET多重階層を示しています。

図 5-2は、1ポート チャネライズドOC-12/STM-4 OSMがサポートするSDH多重階層を示しています。

図 5-1 1ポート チャネライズドOC-12 OSMがサポートするSONET多重階層

 

図 5-2 1ポート チャネライズドOC-12 OSMがサポートするSDH多重階層

 

チャネライズドOC-12/T3 OSMがサポートする機能

OSM-1CHOC12/T3-SIは、次の標準Cisco IOS SONET/SDH機能をサポートしています。

「SONETの適合性」

「SONETのエラー、アラーム、およびパフォーマンスのモニタリング」

「SONETの同期」

「WANプロトコル」

「ネットワーク管理」

「DS3サポート」

「DSUモード」

「QoSプロトコル」

SONETの適合性

OSM-1CHOC12/T3-SIは、1+1 SONET APSをサポートしています。

SONETのエラー、アラーム、およびパフォーマンスのモニタリング

サポートされるSONETエラー、アラーム、およびパフォーマンスのモニタリングは、次のとおりです。

Signal Failure Bit Error Rate(SFBER;信号損失ビット エラー レート)

Signal Degrade Bit Error Rate(SDBER;信号劣化ビット エラー レート)

信号ラベル ペイロード作成(C2)

パス トレース バイト(J1)

Loss of Signal(LOS;信号損失)

Loss of Frame(LOF;フレーム損失)

B1のエラー カウント

B1のTCA

Line Alarm Indication Signal(LAIS;回線アラーム検出信号)

Line Remote Defection Indication(LRDI;回線リモート障害検出)

Line Remote Error Indication(LREI;回線リモート エラー検出)

B2のエラー カウント

B2のTCA

Path Alarm Indication Signal(PAIS;パス アラーム検出信号)

Path Remote Defect Indication(PRDI;パス リモート障害検出)

Path Remote Error Indication(PREI;パス リモート エラー検出)

B3のエラー カウント

B3のTCA

Loss of Pointer(LOP;ポインタ損失)

Path Unequipped Indication Signal(PUNEQ;未実装パス表示信号)

Path Label Mismatch(PPLM)

New Pointer Event(NEWPTR;新規ポインタ イベント)

Positive Stuffing Event(PSE)

Negative Stuffing Event(NSE)

SONETの同期

サポートされるSONET同期化機能は、次のとおりです。

ローカル タイミング(ダーク ファイバまたはWDM装置を介したルータ間接続用の内部タイミング)

フル稼働時の温度で+/-4.6 ppmのクロック精度

ループ タイミング(SONET/SDH装置への接続用のループ タイミング)

WANプロトコル

サポートされるWANプロトコルは、次のとおりです。

Multiprotocol Label Switching(MPLS)およびMPLS/VPN

チャネライズドOSMのMPLS/VPNの設定情報については、「OSM上でのMPLSの設定」を参照してください。

PPP(ポイントツーポイント プロトコル)IETF RFC 1661

HDLC(ハイレベル データ リンク制御)(IETF RFC 1662)

PPP over SONET、1+x43の自己同期ペイロード スクランブリングを使用

フレーム リレー

フレーム リレー対応のチャネライズド インターフェイスの設定については、次のURLにアクセスし、『Cisco IOS Wide-Area Networking Configuration Guide』Release 12.1の「Configuring Frame Relay」および『Cisco IOS Wide-Area Networking Command Reference』Release 12.1を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdfrely.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wrdfrely.htm

フレーム リレーのトラフィック シェーピングの設定については、次のURLにアクセスし、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Configuring Distributed Traffic Shaping」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt4/qcfdts.htm

APSおよびMSPに関するCisco Protection Group Protocol over UDP/IP(ポート172)

シリアル インターフェイス カプセル化の設定については、次のURLにアクセスし、『Cisco IOS Interface Configuration Guide』の「Configuring Serial Interfaces」および『Cisco IOS Interface Command Reference』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_c/index.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_r/index.htm

ネットワーク管理

サポートされるネットワーク管理機能は、次のとおりです。

ローカル ループバック

ネットワーク ループバック

NetFlowデータ エクスポート

一定のタイミングで収集するパフォーマンス統計情報(RFC 1595)

DS3サポート

サポートされるDS3機能は、次のとおりです。

フレーム同期制御、CビットまたはM23

ローカル(内部)クロック モード

ループバック モード

各DS3チャネルのBit Error Rate Test(BERT;ビット エラー レート テスト)診断

送受信アラーム処理

パフォーマンスおよびエラー カウンタ

Far-End Alarm and Control(FEAC;遠端アラームおよび制御)サポート

DSUモード

サポートされるDSUモードは、次のとおりです。

Digital Link

Verilink

Adtran

Larscom

Kentrox

QoSプロトコル

チャネライズドOSMに設定するQoS(サービス品質)については、「OSM上でのQoSの設定」を参照してください。

チャネライズドOSMでは次のQoS機能がサポートされます。

LANおよびWANポート上のPFC2 QoS

Differentiated Services Control Point(DSCP)

IP precedence分類

クラスに基づくマーキングの設定については、次のURLにアクセスし、『Class-Based Marking』フィーチャ モジュールを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/cbpmark2.htm

分類およびプライオリティのマーキングは、下記に基づいて行われます。

Ethertype

IP Source Address(SA;送信元アドレス)

IP Destination Address(DA;宛先アドレス)

TCPポート番号

UDPポート番号

IP SA + TCP/UDPポート番号+ IP DA + TCP/UDPポート番号

WANポート上のClass-Based Weighted Fair Queuing(CBWFQ;クラスベース均等化キューイング)

WANポート上のLow Latency Queueing(LLQ)

Cisco IOSの分類、マーキングおよびキューイングに関する一般情報については、次のURLにアクセスし、『Cisco IOS Quality of Service Solutions Configuration Guide』Release 12.1の「Classification」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_c/index.htm

プラットフォームに依存しないCisco IOS QoSコマンドについては、次のURLにアクセスし、『Cisco IOS Quality of Service Solutions Command Reference』Release 12.1を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_r/index.htm

チャネライズド モジュールの設定

ここでは、チャネライズド モジュールの設定方法について説明します。

「SONETコントローラの設定」

「POSインターフェイスの設定」

「DS3シリアル インターフェイスの設定」

「SDHフレーム同期とAU-3マッピングによるインターフェイスの設定」

「SDHフレーム同期とAU-4マッピングによるインターフェイスの設定」

「APSの設定」

「フレーム リレーおよびフレーム リレー トラフィック シェーピングの設定」

「設定例」

SONETコントローラの設定

SONETコントローラの設定手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# controller sonet slot/port

ポートを選択して、コントローラ コンフィギュレーション モードを開始します。

ステップ 3

Router(config-controller)# [ no ] framing { sonet | sdh }

チャネライズドOC-12のフレーム同期モードをSONETまたはSDHに設定します。

SDHは、SONETと同等のITU規格です。

SONETがデフォルト値です。

ステップ 4

Router(config-controller)#

sts-1 {sts-1 number} serial {T3 | E3}

sts-1 {start sts-1 number} - {end sts-1 number} pos

au-3 {au-3 number} serial {T3 | E3}

au-3 {start au-3 number} - {end au-3 number} pos

au-4 { start-au4-number} vc-3 {vc3-number} serial [ t3 | e3 ]

au-4 { start-au4-number} - { end-au4-number} pos

インターフェイスに対応するチャネルを設定します。ニーズに適合するチャネル プロビジョニング コマンド オプションを選択します。

ステップ 5

Router(config-controller)# clock source { internal [primary | secondary] | line [primary | secondary] }

SONETコントローラが使用するクロックソースを設定します。

internal ― ポート アダプタ ラインからクロックソースを取得します。

line ― ネットワークからクロックソースを取得します。

primary ― 内部回路に優先順位の最も高いクロックを提供します。

secondary ― プライマリ クロックの障害時に、内部回路にセカンダリ クロックを提供します。ネットワークをクロックソースとするのがデフォルトの設定です。

ステップ 6

Router(config-controller)# [ no ] loopback { internal | line }

SONETコントローラ上でループバック モードをイネーブルまたはディセーブルにします。

internal ― 送信パスから受信パスにデータがループされるので、外部接続に依存しないで、内部でデータを送信して診断できます。

line ― 外部ポートから送信ポートにデータがループされ、外部ポートへ再び送出されます。

ループバックはディセーブルがデフォルトの設定です。

ステップ 7

Router(config-controller)# alarm-report {all | b1-tca | b2-tca | b3-tca | lais | lrdi | pplm | ptim | sd-ber | sf-ber | slof | slos}

(任意)アラーム レポートをイネーブルにします。

ステップ 8

Router(config-controller)# threshold {b1-tca value | b2-tca value| b3-tca value| sd-ber value| sf-ber value}

(任意)BER(ビット エラー レート)のスレッシュホールド値を設定します。

ステップ 9

Router(config-controller)# [ no ] description string

(任意)SONETコントローラについて記述する最大80文字のテキストを指定します。記述なしがデフォルトの設定です。

POSインターフェイスの設定

コントローラの設定を確認したあとで、Packet over SONET(POS)インターフェイスを設定できます。ここで紹介するのは基本的な設定手順です。ネットワークの要件に応じて、他のインターフェイス パラメータを指定しなければならない場合があります。

POSインターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# interface POS slot/port :channel#

設定するシリアル ポートおよびチャネルを指定します。

ステップ 3

Router(config-if)# encapsulation hdlc | ppp

カプセル化タイプを指定します。

ステップ 4

Router(config-if)# pos flag j1 expect message rxpathmessagetext | length [16|64] | message txpathmessagetext

(任意)チャネライズド インターフェイスのパス メッセージを指定します。

ステップ 5

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスにIPアドレスおよびサブネット マスクを割り当てます。

ステップ 6

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

DS3シリアル インターフェイスの設定

コントローラの設定を確認してから、対応するDS3チャネルとシリアル インターフェイスをコントローラ上に設定できます。


) T3インターフェイスをVeriLink DSUに接続する場合、T3インターフェイスでサポートされる最低帯域幅は6,316 Kbpsです。帯域幅は、6,316 Kbpsから最大44,210 Kbpsまでの整数倍でなくてはなりません。


DS3インターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# interface serial slot/port :channel#

設定するシリアル ポートおよびチャネルを指定します。

ステップ 3

Router(config-if)# framing {c-bit | m23}

フレーム同期を指定します。

ステップ 4

Router(config-if)# [ no ] dsu mode {0-4}

DSUモードを指定します。

0 ― Digital-Link

1 ― Kentrox

2 ― Larscom

3 ― Adtran

4 ― Verilink

ステップ 5

Router(config-if)# [ no ] dsu remote [accept | fullrate]

ローカル(近端)インターフェイスがリモート(遠端)インターフェイスからの着信要求を受け付けるかどうか、またはローカル インターフェイスからリモート インターフェイスに対してフルレートの帯域幅設定を要求するかどうかを指定します。

ステップ 6

Router(config-if)# [ no ] dsu bandwidth Kilobits/sec

DSUサブレート帯域幅を設定します。

ステップ 7

Router(config-if)# [no] scramble

ペイロード スクランブリングをイネーブルにします。

ステップ 8

Router(config-if)# [ no ] loopback { local | network | remote }

ループバック モードを設定します。

ステップ 9

Router(config-if)# [ no ] bert pattern [ 2^15 | 2^20 ] interval [ 1-1440 ]

(任意)BERTを設定します。

ステップ 10

Router(config-if)# alarm-report {all | b3-tca | pais | pplm | plop | prdi | ptim | ptiu | puneq}

(任意)パス アラーム レポートをイネーブルにします。

ステップ 11

Router(config-if)# overhead {c2 byte value | j1 {expect message message-string | length 16-64 |

message message-string}

SONETパス ヘッダー バイトの値を指定します。

ステップ 12

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスにIPアドレスおよびサブネット マスクを割り当てます。

ステップ 13

Router(config-if)# [ no ] keepalive

キープアライブ メッセージをオンまたはオフにします。

ステップ 14

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

次に、非チャネライズドDS3インターフェイス設定の例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# controller t3 3/0
Router (config-controller)#no channelized
Router (config-controller)# exit
Router (config)# interface serial 1/0
Router (config-if)# dsu bandwidth 16000
Router (config-if)# encapsulation frame-relay
Router (config-if)# ip address 10.10.10.10.255.255.255.255
Router (config-if)# no shutdown
Router (config-if)# exit
Router(config)#

SDHフレーム同期とAU-3マッピングによるインターフェイスの設定

ここでは、SDHフレーム同期とAU-3マッピングによりインターフェイスをイネーブルにする方法、およびOSM-1CHO12/T3-SIチャネライズド モジュールでのIPルーティングの指定方法を説明します。SDHフレーム同期とAU-3マッピングによりインターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# controller sonet slot/port

コントローラを選択します。

ステップ 3

Router(config-controller)# framing sdh

フレーム同期を指定します。

ステップ 4

Router(config-controller)# aug mapping au-3

AUGマッピングを指定します。

ステップ 5

Router(config-controller)# au-3 au-3 number serial {T3 | E3}

AU-3チャネルを設定します。

ステップ 6

Router(config-controller)# exit

コントローラ コンフィギュレーション モードを終了します。

ステップ 7

Router(config)# interface serial slot/port:au-3 number

インターフェイスを選択します。

ステップ 8

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスにIPアドレスおよびサブネット マスクを割り当てます。

ステップ 9

Router(config-if)# [ no ] shutdown

インターフェイスをイネーブルにします。

この例では、ポートは12 E3インターフェイスとして設定されます。


) E3インターフェイスをDigital Link DL3100E E3アクセス マルチプレクサDSUに接続する場合、Digital Link DSU上で「クリア チャネル」モードを使用する必要があります。E3インターフェイスをCisco 12000シリーズ12ポートPacket over E3ライン カードに接続する場合、Cisco 12000シリーズ12ポートPacket over E3ライン カード上にdsu mode kentroxを設定しなくてはなりません。E3インターフェイスをCisco C7500またはCisco C7200 E3ポート アダプタ(PA)に接続する場合、E3 PAのE3インターフェイス上にdsu mode 1を設定しなくてはなりません。



ステップ 1 configure terminal EXECコマンドを入力して、次のようにグローバル コンフィギュレーション モードを開始します。

router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
 

ステップ 2 E3チャネルを設定します。

router(config)# controller sonet 4/1
router(config-controller)# framing sdh
router(config-controller)# overhead s1s0 2
router(config-controller)# aug mapping au-3
router(config-controller)# au-3 1 serial e3
router(config-controller)# au-3 2 serial e3
router(config-controller)# au-3 3 serial e3
router(config-controller)# au-3 4 serial e3
router(config-controller)# au-3 5 serial e3
router(config-controller)# au-3 6 serial e3
router(config-controller)# au-3 7 serial e3
router(config-controller)# au-3 8 serial e3
router(config-controller)# au-3 9 serial e3
router(config-controller)# au-3 10 serial e3
router(config-controller)# au-3 11 serial e3
router(config-controller)# au-3 12 serial e3
 

ステップ 3 E3インターフェイスを設定します。

Router(config)# interface serial 5/2:1
Router(config-if)# ip address 10.2.1.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:2
Router(config-if)# ip address 10.2.2.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:3
Router(config-if)# ip address 10.2.3.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:4
Router(config-if)# ip address 10.2.4.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:5
Router(config-if)# ip address 10.2.5.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:6
Router(config-if)# ip address 10.2.6.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:7
Router(config-if)# ip address 10.2.7.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:8
Router(config-if)# ip address 10.2.8.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:9
Router(config-if)# ip address 10.2.9.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:10
Router(config-if)# ip address 10.2.10.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:11
Router(config-if)# ip address 10.2.11.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:12
Router(config-if)# ip address 10.2.12.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
 

ステップ 4 copy running-config startup-config コマンドを使用して、NVRAM(不揮発性RAM)に新しい設定を書き込みます。

router# copy running-config startup-config
[OK]
router#
 


 

SDHフレーム同期とAU-4マッピングによるインターフェイスの設定

ここでは、SDHフレーム同期とAU-4マッピングによりインターフェイスをイネーブルにする方法、およびOSM-1CHO12/T3-SIチャネライズド モジュールでのIPルーティングの指定方法を説明します。この例では、ポートは12 E3インターフェイスとして設定されます。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# controller sonet slot/port

コントローラを選択します。

ステップ 3

Router(config-controller)# framing sdh

フレーム同期を指定します。

ステップ 4

Router(config-controller)# aug mapping au-4

AUGマッピングを指定します。

ステップ 5

Router(config-controller)#
au-4 start-au4-number vc-3 VC3-number serial [ t3 | e3 ]

au-4 start-au4-number - end-au4-number pos

チャネルを設定し、インターフェイス番号を定義します。

ステップ 6

Router(config-controller)# exit

コントローラ コンフィギュレーション モードを終了します。

ステップ 7

Router(config)# interface serial slot/port. au-4:au-3

インターフェイスを選択します。

ステップ 8

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスにIPアドレスおよびサブネット マスクを割り当てます。

ステップ 9

Router(config-if)# [ no ] shutdown

インターフェイスをイネーブルにします。

この例では、1つのSTM-4 POSインターフェイス、2つのSTM-1インターフェイス、および2つのDS3シリアル インターフェイスを設定するためにAU-4マッピングが使用されています。slot/port. au-4:au-3から、DS3インターフェイス名が作成されます。1~3の範囲のVC-3番号は、選択されたAU-4中のTUG-3(またはVC3)番号です。

STM-4インターフェイス名は最初のAU-4番号から作成されます。


ステップ 1 configure terminal EXECコマンドを入力して、次のようにグローバル コンフィギュレーション モードを開始します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
 

ステップ 2 チャネルを設定します。

Router(config)# controller sonet 5/1
Router(config-controller)# framing sdh
Router(config-controller)# aug mapping au-4
Router(config-controller)# au-4 1-4 pos
Router(config-controller)# au-4 5 pos
Router(config-controller)# au-4 6 vc-3 1 serial t3
Router(config-controller)# au-4 6 vc-3 2 serial t3
Router(config-controller)# au-4 7 pos
Router(config-controller)# end
 

ステップ 3 インターフェイスを設定します。

Router(config)# interface pos 5/1:1
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.10 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface pos 5/1:5
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.11 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface serial 5/1.6:1
Router(config_if)# framing c-bit
Router(config-if)# dsu mode 0
Router(config-if)# dsu remote accept
Router(config-if)# dsu bandwidth 30000
Router(config-if)# scramble
Router(config-if)# loopback remote
Router(config-if)# ip address 10.10.10.12. 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface serial 5/1.6:2
Router(config_if)# framing c-bit
Router(config-if)# dsu mode 0
Router(config-if)# dsu remote accept
Router(config-if)# dsu bandwidth 45000
Router(config-if)# scramble
Router(config-if)# loopback remote
Router(config-if)# ip address 10.10.10.12. 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface pos 5/1:7
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.13 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
 

ステップ 4 copy running-config startup-config コマンドを使用して、NVRAM(不揮発性RAM)に新しい設定を書き込みます。

Router# copy running-config startup-config
[OK]
Router#
 


 

APSの設定

APSにより、POS回線の切り替えが可能です。これは、通常SONET装置を電気通信装置に接続する場合に必要になります。APSを設定すると、介在するSONET装置からSONETネットワークに保護POSインターフェイスが提供され、回線上で保護POSインターフェイスが実行POSインターフェイスになります。


) OSM-1CHO12/T3-SIでは、APSは、インターフェイス レベルではなくSONETコントローラ レベルで設定されることに注意してください。


保護インターフェイスは、実行インターフェイスのあるルータのIPアドレスを指定して設定します。APS Protect Group Protocolが、実行インターフェイスを制御するプロセスと保護インターフェイスを制御するプロセス間の通信を引き受けます。APS Protect Group Protocolを使用すると、ルータ障害、チャネル信号の劣化または損失、または手動介入が発生した場合に、POSインターフェイスを切り替えることができます。

APSのサポートには、SONET接続が2つ必要です。電気通信環境では、SONET回線をAPSとして設定する必要があります。オペレーション、モード、および復帰オプションを設定することも必要です。SONET接続が別々の2台のルータでホーミングされる場合(標準設定)、APS通信用として、2台のルータ間にOut-Of-Band(OOB;帯域外)通信チャネルを設定する必要があります。

APSを設定する場合は、先に実行インターフェイスを設定し、さらにAPS OOB通信パスとして使用するインターフェイスのIP アドレスを指定することを推奨します。


) 保護インターフェイスがアクティブ回線になり、稼働中の回線が検出されたときにディセーブルにされることがないように、実行インターフェイスを設定してから保護インターフェイスを設定します。


APSの詳細については、次のURLにアクセスし、『Cisco IOS Interface Configuration Guide』Release 12.1を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_c/index.htm

実行インターフェイスの設定

実行インターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router(config)# controller sonet slot/port

configプロンプトから、SONETコントローラ コンフィギュレーション モードを開始します。

ステップ 2

Router(config-controller)# aps working circuit-number

このインターフェイスを実行インターフェイスとして設定します。

ステップ 3

Router(config-controller)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# s how aps

Router# s how aps controller

コントローラ情報を表示して、コンフィギュレーションを確認します。


) ルータに複数の保護インターフェイスが設定されている場合、各インターフェイスにaps groupコマンドを設定してから、対応するaps protectコマンドを設定する必要があります。


保護インターフェイスの設定

保護インターフェイスを設定するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config)# controller sonet slot/port

configプロンプトから、SONETコントローラ コンフィギュレーション モードを開始します。

ステップ 2

Router(config-controller)# aps protect circuit-number ip-address

このインターフェイスを保護インターフェイスとして設定します。実行インターフェイスのあるルータのIPアドレスを指定します。

ステップ 3

Router(config-controller)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# s how aps

Router# s how aps controller

コントローラ情報を表示して、コンフィギュレーションを確認します。

フレーム リレーおよびフレーム リレー トラフィック シェーピングの設定

ここでは、フレーム リレーの設定、プラットフォーム固有のコマンド、および制限事項について説明します。

「フレーム リレーの制限および制約」

「フレーム リレー トラフィック シェーピングの設定例」

フレーム リレー対応のチャネライズド インターフェイスの設定については、次のURLにアクセスし、『Cisco IOS Wide-Area Networking Configuration Guide』Release 12.1の「Configuring Frame Relay」および『Cisco IOS Wide-Area Networking Command Reference』Release 12.1を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdfrely.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wrdfrely.htm

フレーム リレーのトラフィック シェーピングの設定については、次のURLにアクセスし、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Configuring Distributed Traffic Shaping」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt4/qcfdts.htm

フレーム リレーの制限および制約

下記の制限および制約がフレーム リレーに適用されます。

フレームリレーはSVC上ではサポートされません。

フレーム リレー用に設定したメイン インターフェイスにIPアドレスを割り当てることはできません。

フレーム リレーがサポートされるのはポイントツーポイント接続だけです。

フレーム リレー スイッチング機能はサポートされません。フレーム リレー スイッチングを設定できるのは、frame-relay intf-type dceオプションの設定時に限定されます。

フレーム リレーのフラグメンテーションおよび圧縮はサポートされません。

Data Link Connection Identifier(DLCI)のFECNおよびBECN統計はサポートされません。

FIFO(先入れ先出し)キューイングだけがサポートされます。

DLCIを設定できるのはサブインターフェイスだけです。メイン インターフェイスには設定できません。

各シャーシに設定できるDLCIの最大数は、300です。

クラスベースのトラフィック シェーピングだけがサポートされます。次のコマンドはサポートされていません。

Router(config-pmap-c)# shape [average | peak] mean-rate [[burst-size] [excess-burst-size]]

Router(config-pmap-c)# priority {kbps | percent percent} [bytes]

Router(config-pmap-c)# fair-queue number-of-queues

Router(config-map-class)# frame-relay adaptive-shaping [becn | foresight]1

Router(config-map-class)# frame-relay cir {in | out} bps

Router(config-map-class)# frame-relay {bc | be} {in | out} bits

Router(config-map-class)# frame-relay traffic-rate average [peak]

Router(config-map-class)# frame-relay priority-group list-number

Router(config-map-class)# frame-relay fragment fragment_size

Router(config-if)# frame-relay payload-compress packet-by-packet

Router(config-if)# frame-relay de-group group-number dlci

Router# show traffic-shape queue

フレーム リレー トラフィック シェーピングの設定例

 

コマンド
説明

ステップ 1

Router(config-pmap)# class-map [match-all | match-any]

定義したクラスに対してパケットを照合するためのクラス マップを作成し、一致条件を指定します。クラスの一致条件は、IP DSCPまたはIP precedenceを基準にすることができます。

ステップ 2

Router(config-pmap)# match

一致条件を指定します。

ステップ 3

Router(config)# policy-map policy_map

1つまたは複数のインターフェイスに適用できるポリシー マップを作成または変更し、サービス ポリシーを指定します。

ステップ 4

Router(config-pmap)# class class-name

サービス ポリシーに含めるクラスを定義します。

ステップ 5

Router(config-pmap-c)#shape average mean-rate [burst-size]

指定されたビット レートに合わせてトラフィックをシェーピングします。

ステップ 6

Router(config)# map-class frame-relay map-class-name

マップクラスを指定し、QoSの値を定義します。

ステップ 7

Router(config-map-class)# no frame-relay adaptive-shaping

バックワードの通知をディセーブルにします。

ステップ 8

Router(config-map-class)# service-policy input policy-map

指定したポリシーマップを、入力インターフェイスに適用します。

ステップ 9

Router(config-map-class)# service-policy output policy-map

指定したポリシー マップを、出力インターフェイスに適用します。

ステップ 10

Router(config)#interface interface

ポリシー マップの適用先インターフェイスを指定します。

ステップ 11

Router(config-subif)# ip address ip_address mask

サブインターフェイスにIPアドレスを割り当てます。

ステップ 12

Router(config-subif)# no cdp enable

CDPをディセーブルにします。

ステップ 13

Router(config-subif)# frame-relay interface-dlci dlci

指定したフレーム リレー サブインターフェイスに、DLCIを割り当てます。

ステップ 14

Router(config-fr-dlci)# class class-name

サービス ポリシーに設定されている、class-mapコマンドで定義したクラス名を指定します。

サブインターフェイスのCDPは、確実にディセーブルに設定することを推奨します。サブインターフェイスでCDPを使用する場合は、入力キューの深度を調整しなければならないことがあります。着信CDPパケット数に対応させるには、メイン インターフェイスの入力キュー深度を、CDPをイネーブルにしたサブインターフェイス数よりも、わずかに大きく設定します。デフォルトの入力キュー深度は75です。この値は、次に示すhold-queueインターフェイス コマンドで変更できます。

Router(config-if)#hold-queue 300 in
 

次に、サブインターフェイス6/1:1.1または6/1:1.2から送出されるトラフィックを1 Mbpsにシェーピングする例を示します。

Router(config)# class-map class-p2p-all
Router(config-cmap)# match any
Router(config-cmap)# exit
Router(config)# policy-map dts-p2p-all-action
Router(config-pmap)# class class-p2p-all
Router(config-pmap-c)# shape average 1000000
Router(config-pmap-c)# exit
Router(config)# interface Serial6/1:1.1 point-to-point
Router(config-subif)# service-policy output dts-p2p-all-action
Router(config-subif)# exit
Router(config)# interface serial6/1:1.2 point-to-point
Router(config-subif)# service-policy output dts-p2p-all-action
 

次の例では、DLCIごとのトラフィック設定を示します。

Router(config)# class-map match-all fr-classmap

Router(config-cmap)# match any

Router(config-cmap)# exit
Router(config)# policy-map fr-pmap
Router(config-pmap)# class fr-classmap
Router(config-pmap-c)# shape average 8000000 32000 32000
Router(config-pmap-c)# exit
Router(config)# interface Serial6/1:1.1 point-to-point
Router(config-subif)# ip address 72.0.0.1 255.255.0.0
Router(config-subif)# mls qos trust dscp
Router(config-subif)# frame-relay interface-dlci 18
Router(config-fr-dlci)# class fr-shaping
Router(config-fr-dlci)# exit
Router(config)# map-class frame-relay fr-shaping
Router(config-map-class)# no frame-relay adaptive-shaping
Router(config-map-class)# service-policy input fr-pmap
Router(config-map-class)# service-policy output fr-pmap

チャネライズドPOSの設定

次に、チャネライズドPOSの設定例を示します。STS-1番号は、OC-12フレーム内の論理STS-1パスで、1~12の範囲になります。OC-3チャネルでは、STS-1番号はOC-3境界を越えることができません。たとえば、sts-1 1-6は、不正な設定です。

チャネライズドPOSとして設定してから、各POSインターフェイスを適切に設定します。


ステップ 1 SONETコントローラを設定します。

Router(config)# controller sonet 2/1
 

ステップ 2 チャネルを設定します。

Router(config-controller)# sts-1 1-3 pos
Router(config-controller)# sts-1 13-15 pos
Router(config-controller)# sts-1 16-18 pos
Router(config-controller)# exit
 

ステップ 3 POSインターフェイスを設定します。

Router(config)# interface pos 2/1:13
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.10 255.255.255.0
Router(config-if)# end
 


 

チャネライズドDS3の設定

次に、チャネライズドDS3の設定例を示します。


ステップ 1 SONETコントローラを設定します。

Router(config)# controller sonet 2/1
 

ステップ 2 チャネルを設定します。

Router(config-controller)# sts-1 4 serial t3
Router(config-controller)# exit
 

ステップ 3 シリアル インターフェイスを設定します。

Router(config)# interface serial 2/1:4
Router(config-if)# framing c-bit
Router(config-if)# dsu mode 0
Router(config-if)# dsu remote accept
Router(config-if)# dsu bandwidth 30000
Router(config-if)# scramble
Router(config-if)# loopback remote
Router(config-if)# ip address 10.1.1.1. 255.255.255.0
Router(config-if)# end
 


 

基本的なAPSの設定

ルータAとルータB上でAPSを設定する例を示します(図 5-3図 5-3を参照)。この例では、ルータAに実行インターフェイスを設定し、ルータBに保護インターフェイスを設定します。ルータAの実行インターフェイスが使用できなくなると、ルータB上の保護インターフェイスに接続が自動的に切り替えられます。実行インターフェイスと保護インターフェイスは、コントローラ レベルで設定します。

図 5-3 基本的なAPSの構成

 


ステップ 1 実行インターフェイスのあるルータAの設定は、次のとおりです。

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.7 255.255.255.0
Router(config)# controller sonet 7/1
Router(config-controller)# aps working 1
Router(config-controller)# end
Router#
 

ステップ 2 保護インターフェイスのあるルータBの設定は、次のとおりです。

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.6 255.255.255.0
Router(config-controller)# controller sonet 3/1
Router(config-controller)# aps protect 1 7.7.7.7
Router(config-controller)# end
Router#
 


 

複数APSインターフェイスの設定

複数の保護/実行インターフェイスを設定する場合は、 aps group コマンドを使用します。図 5-4に、複数の実行/保護インターフェイスをグループ分けして設定する例を示します。この例では、実行インターフェイスと保護インターフェイスを指定してルータAを設定し、ルータBも実行インターフェイスと保護インターフェイスを指定して設定します。ルータAの実行インターフェイス2/0が使用できなくなると、ルータBの保護インターフェイス3/0に接続が切り替えられます。これはどちらもAPSグループ10に属しているためです。ルータBの実行インターフェイス2/0が使用できなくなった場合も同様です。接続は同じAPSグループ20に属しているため、ルータAの保護インターフェイス3/0に切り替えられます。

図 5-4 複数の実行/保護インターフェイスの構成

 


) 保護インターフェイスがアクティブ回線になり、稼働中の回線が検出時にディセーブルにされることがないように、実行インターフェイスを設定してから保護インターフェイスを設定してください。



ステップ 1 ルータAでは次のように設定し、グループ10用の実行インターフェイスとグループ20用の保護インターフェイスを指定します。

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.6 255.255.255.0
Router(config-if)# exit
Router(config)# controller sonet 7/1
Router(config-controller)# aps group 10
Router(config-controller)# aps working 1
Router(config-controller)# exit
Router(config)# contoller sonet 3/0
Router(config-controller)# aps group 20
Router(config-controller)# aps protect 1 7.7.7.7
Router(config-controller)# end
Router#
 

ステップ 2 ルータBでは次のように設定し、グループ10用の保護インターフェイスとグループ20用の実行インターフェイスを指定します。

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.7 255.255.255.0
Router(config-if)# exit
Router(config)# controller sonet 2/0
Router(config-controller)# aps group 20
Router(config-controller)# aps working 1
Router(config-controller)# exit
Router(config)# controller sonet 3/0
Router(config-controller)# aps group 10
Router(config-controller)# aps protect 1 7.7.7.6
Router(config-controllers)# end
Router#