オプティカル サービス モジュール ソフトウェア コンフィギュレーション ノート Cisco IOS 12.2SR
OC-12 ATM OSM の設定
OC-12 ATM OSM の設定
発行日;2012/02/02 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

OC-12 ATM OSM の設定

ATM の概要

サポート対象の機能

OC-12 ATM インターフェイスの設定

OC-12 ATM OSM の初期設定

ATM インターフェイスのイネーブル化

有効な VCI および VPI 設定

各 VP の最大 VC 数の設定

VC の設定

PVC の作成

PVC トラフィック パラメータの設定

SVC の設定

ILMI との通信設定

SVC コール セットアップを実行する PVC の設定

NSAP アドレスの設定

SVC の作成

RFC 1483 スパニングツリー インターオペラビリティの拡張性

サポート対象のスーパーバイザおよびライン カード

前提条件

インターオペラビリティ問題の概要

BPDU のパケット形式

BPDU 変換コマンド ライン インターフェイスの要約

BPDU 変換を必要とする標準的なトポロジー

APS の設定

実行インターフェイスの設定

保護インターフェイスの設定

単一ルータでの基本 APS の設定

基本的な複数ルータ APS 構成

複数 APS インターフェイスの構成

APS コマンド

SONET および SDH コンフィギュレーション コマンド

atm framing sonet | sdh

atm sonet stm-4

atm sonet report

atm sonet threshold

show controllers atm

OC-12 ATM OSM の設定

この章では、2 ポートの OC-12 ATM WAN OSM(オプティカル サービス モジュール)について説明します。

この章の内容は次のとおりです。

「ATM の概要」

「サポート対象の機能」

「OC-12 ATM インターフェイスの設定」

「VC の設定」

「APS の設定」

「SONET および SDH コンフィギュレーション コマンド」

ATM の概要

Asynchronous Transfer Mode(ATM; 非同期転送モード)は、セル スイッチングと多重化テクノロジーを使用し、回線交換の利点(一定の転送遅延と保証された転送量)と、パケット交換の利点(断続的なトラフィックを効率的に処理するフレキシビリティ)の両方を備えています。

ATM は、コネクション型の接続環境です。ATM ネットワークで送受信されるトラフィックはすべて、先頭に Virtual Path Identifier(VPI; 仮想パス識別子)および Virtual Channel Identifier(VCI; 仮想チャネル識別子)が設定されています。VPI/VCI ペアが 1 つの Virtual Circuit(VC; 仮想回線)としてみなされます。各 VC は、ATM ネットワーク上の他のノードにプライベートに接続します。VC は他のルータまたはホストへのポイントツーポイント接続として処理され、双方向トラフィックがサポートされます。

各 ATM ノードは、ATM ネットワーク上で通信する他のすべてのノードに対して、個別に接続を確立する必要があります。これらの接続はすべて、ネットワーク運用者が設定する Permanent Virtual Circuit(PVC; 相手先固定接続)、または ATM シグナリング機構により設定および廃棄される Switched Virtual Circuit(SVC; 相手先選択接続)を使用して確立されます。このシグナリングは、ATM フォーラム User Network Interface(UNI)仕様 V3.x または 4.0 に基づいています。

サポート対象の機能

2 ポートの OC-12 ATM OSM の WAN ポートでは、次の機能をサポートしています。

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; 仮想私設網)

PVC

SVC(最大 100)

モジュールにつき最大 1,000 VC、1 つの物理 ATM インターフェイスにつき 500 VC をサポート

VPI 範囲 0 ~ 255(デフォルトは 15)

VCI 範囲 1 ~ 1,023(デフォルトは 1,023)

RFC 1577 classical IP over ATM

RFC 1483 ブリッジング サポート(PVC のみ)

ポイントツーポイント サブインターフェイスでのマルチキャスト パケットのハードウェア スイッチング

ポイントツーマルチポイント サブインターフェイスでのマルチキャスト パケットのソフトウェア スイッチング

UNI 3.x および UNI 4.0

ILMI 1.0

VC 単位のレイヤ 3 キューイング

レイヤ 3 トラフィック シェーピング

Committed Information Rate(CIR; 認定情報速度)

Excess Information Rate(EIR)

OSM-2OC12-ATM-MM/SI+ による Policy Feature Card(PFC; ポリシー フィーチャ カード)Quality of Service(QoS; サービス品質)

Virtual Path(VP; 仮想パス)単位シェーピング

VC 単位シェーピング

Unspecified Bit Rate(UBR; 未指定ビット レート)および Variable Bit Rate(VBR; 可変ビット レート)-Non Real Time(VBR-NRT)

Per-VC Class-Based Weighted Fair Queuing(Per-VC CBWFQ;VC 単位クラスベース均等化キューイング)

Low Ratency Queuing(LLQ; 低遅延キューイング)

Weighted Random Early Detection(WRED; 重み付きランダム早期検出)

Committed Access Rate(CAR; 専用アクセス レート)

SONET Linear APS 1+1

Per-VLAN Spanning-Tree plus(PVST+)から 802.1d Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)への変換


) OC-12 ATM OSM では、AAL5 CPCS PDU の Common Part Convergence Sublayer User-to-User(CPCS-UU)フィールドを正常に設定、削除、または伝送できません。これにより、このフィールドのカスタムな使用に影響が生じます。さらに、フレームリレーのコマンド レスポンス(C/R)ビットの転送に CPCS-UU バイトを使用する FRF8.1 の使用にも影響が生じます。


WAN OSM ポートに対する QoS の設定情報および設定例については、「OSM 上の QoS の設定」 を参照してください。

WAN OSM ポートに対する MPLS QoS の設定情報および設定例については、「MPLS QoS の設定」 を参照してください。

Cisco IOS QoS の一般的な設定情報については、次の Cisco IOS マニュアルを参照してください。

『Cisco IOS Quality of Service Solutions Configuration Guide』(URL は次のとおり)

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_c/index.htm

『Cisco IOS Quality of Service Solutions Command Reference』(URL は次のとおり)

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_r/index.htm

OC-12 ATM インターフェイスの設定

ここでは、OC-12 ATM OSM インターフェイスの初期設定の手順について説明します。

「OC-12 ATM OSM の初期設定」

「ATM インターフェイスのイネーブル化」

「有効な VCI および VPI 設定」

OC-12 ATM OSM の初期設定

起動時、新しい OC-12 ATM OSM のインターフェイスはシャットダウンしています。インターフェイスをイネーブルにするには、コンフィギュレーション モードで、 no shutdown コマンドを入力する必要があります。OC-12 ATM インターフェイスをイネーブルにしたときに追加の設定を行わないと、コンフィギュレーション ファイルのデフォルトのインターフェイス パラメータが使用されます。 表8-1 に、デフォルトのパラメータを示します。

 

表8-1 OC-12c/STM-4c ATM モジュールのデフォルト設定値

パラメータ
コンフィギュレーション コマンド
デフォルト値

Maximum Transmission Unit(MTU; 最大伝送ユニット)

[no] mtu bytes

4,470 バイト

ループバック

[no] loopback [diagnostic | line]

ループバックなし

各 VP の ATM VC

atm vc-per-vp

1,023

新しい OC-12 ATM モジュールが正しく搭載されている(ACTIVE LED が点灯し、すべてのケーブルが正しく接続されている)ことを確認したら、 configure コマンドを使用して、ATM インターフェイスを設定できます。

ATM インターフェイスのイネーブル化

Cisco 7600 シリーズ ルータは、 slot/port の形式で表されたスロット番号およびポート番号に基づいて、インターフェイスのアドレスを識別します。たとえば、スロット 4 に搭載した 2 ポート OC-12 ATM OSM のインターフェイスのスロット/ポート アドレスは、 4/1 になります。

configure コマンドを使用するには、 enable コマンドを使用して、EXEC コマンド インタープリタのイネーブル レベルを開始する必要があります。パスワードが設定されている場合は、パスワードの入力が要求されます。

次に、2 ポートの OC-12 ATM OSM の設定手順を示します。特に明記されていないかぎり、各設定手順の最後に Return キーを押してください。

ATM インターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# show module

システムがモジュールを認識していることを確認します。

ステップ 2

Router# show interface atm slot/port

各ポートのステータスを調べます。

ステップ 3

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 4

Router(config)# interface atm slot/port

設定する新しいインターフェイスを指定します。

ステップ 5

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

ステップ 6

Router(config-if)# no shutdown

Router(config-if)# end

インターフェイス ステートをアップに変更し、インターフェイスをイネーブルにします。

ステップ 7

Router# copy running-config startup-config

新しい設定をメモリに書き込みます。

次に、OC-12 ATM OSM インターフェイスを設定する例を示します。

Router# configure terminal
Router(config)# interface atm 4/0
Router(config-if)# ip address 1.2.3.4 255.255.255.0
Router(config-if)# no shutdown
Router# copy running-config startup-config
 

有効な VCI および VPI 設定

各 ATM インターフェイスに設定されるデフォルトの VPI 数は 15 です。各 VPI には最大 1,023 の VCI を設定できます。

表8-2 に、VP 単位の VC 数および VPI の最大数を示します。

 

表8-2 有効な VCI および VPI 設定

各 VP の VC 数
VPI 最大数

1,024

15

512

31

256

63

128

127

64

255

32

255

16

255

各 VP の最大 VC 数の設定

ATM インターフェイスは、デフォルトで、各 VP に最大 1,023 の VC を設定できるようになっています。この値を変更するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface atm slot/port

インターフェイス コンフィギュレーション モードを開始し、設定対象の ATM インターフェイスを指定します。

ステップ 2

Router(config-if)# atm vc-per-vp

各 VP の最大 VC 数(16、32、64、128、256、512、または 1,024)を設定します。デフォルト値は 1,024 です。

ステップ 3

Router(config-if)# no shutdown

この設定を使用して、インターフェイスをイネーブルにします。

VC の設定

ここでは、PVC、ブリッジド PVC(RFC 1483)、PVC トラフィックのパラメータ、および SVC を設定するための基本事項について説明します。また、2 ポートの OC-12 ATM OSM に固有のコマンドおよびコンフィギュレーションが記載されています。

「PVC の作成」

「PVC トラフィック パラメータの設定」

「SVC の設定」

「RFC 1483 スパニングツリー インターオペラビリティの拡張性」

OC-12 ATM OSM がサポートしている他の Cisco IOS 機能およびコマンドについては、次の URL にアクセスし、『Cisco IOS Wide-Area Networking Configuration Guide』 Release 12.1 の「Configuring ATM」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdatm.htm

コマンド構文の詳細については、次の URL にアクセスし、『Cisco IOS Wide-Area Networking Command Reference』 Release 12.1 の「ATM commands」の章を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wratm/index.htm

PVC の作成

ATM インターフェイス上に PVC を作成し、インターフェイス ATM VC コンフィギュレーション モードを開始するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config)# interface atm slot/port

設定する新しいインターフェイスを指定します。

ステップ 2

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

ステップ 3

Router(config-if)# pvc [ name ] vpi / vci [ ilmi | qsaal ]

新しい ATM PVC を作成し、名前(任意)および VPI/VCI 番号を割り当てます。インターフェイス ATM VC コンフィギュレーション モードを開始します。任意に、ILMI または QSAAL カプセル化を設定します。

ステップ 4

Router(config-if-atm-vc)# protocol protocol protocol-address [[ no ] broadcast ]

PVC にプロトコル アドレスをマッピングします。

ステップ 5

Router(config-if-atm-vc)# encapsulation {aal5mux | aal5snap}

(任意)ATM Adaptation Layer(AAL; ATM アダプテーション レイヤ)およびカプセル化タイプを設定します。デフォルトは、aal5snap です。

次に、PVC を作成する例を示します。

Router(config)# interface atm 4/0
Router(config-if)# ip address 10.212.13.4 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# pvc cisco 0/56
Router(config-if-atm-vc)# protocol ip 10.212.13.5 broadcast
Router(config-if-atm-vc)# encapsulation aal5snap
Router(config-if-atm-vc)#
 

PVC トラフィック パラメータの設定

サポートされるトラフィック パラメータのサービス カテゴリは、UBR および VBR-NRT です。各 PVC 接続について、1 つのカテゴリだけを指定できます。新しいカテゴリを指定すると、既存のカテゴリが置換されます。

PVC トラフィックのパラメータを設定するには、インターフェイス ATM VC コンフィギュレーション モードで次のいずれかのコマンドを実行します。

 

コマンド
説明
Router(config-if-atm-vc)# ubr

UBR を設定します。UBR はデフォルト設定です。

Router(config-if-atm-vc)# vbr-nrt pcr scr mbs

VBR-NRT を設定します。

-pcr -scr 、および -mbs 引数にはそれぞれ、Peak Cell Rate(PCR; ピーク セル レート)、Sustainable Cell Rate(SCR)、および Maximum Burst Size(MBS)を指定します。

VBR-NRT PVC の設定可能な最高速度は、299,520 Mbps です。MBS の最大セル数は 255 です。

次に、PCR を 1,000、SCR を 500、MBS を 64 に指定して、VBR-NRT を設定する例を示します。

Router(config-if-atm-vc)# vbr-nrt 1000 500 64
Router(config-if-atm-vc)#

SVC の設定

ATM SVC はダイナミックに作成されて解放されるので、帯域幅がオンデマンドで提供されます。このサービスを利用するには、ルータとスイッチとの間にシグナリング プロトコルを設定する必要があります。

ATM シグナリング ソフトウェアにより、UNI での ATM 接続を動的に設定、保持、および消去できます。ATM シグナリング ソフトウェアは、ILMI またはコンフィギュレーションで選択したバージョンに応じて、ATM フォーラム UNI 3.x または 4.0 に準拠しています。

UNI モードでは、Cisco 7600 シリーズ ルータは ATM レベルのコール ルーティングを実行しません。ATM コール ルーティングは ATM スイッチにより実行され、ルータは決められた回線を使用してパケットをルーティングします。ルータは回線終端のユーザおよび LAN 相互接続デバイスとして認識され、ATM スイッチはネットワークとして認識されます。

SVC を使用するには、次の作業を実行する必要があります。

「ILMI との通信設定」(必須)

「SVC コール セットアップを実行する PVC の設定」(必須)

「NSAP アドレスの設定」(必須)

「SVC の作成」(任意)

ILMI との通信設定

SVC 環境では、ルータが SNMP(簡易ネットワーク管理プロトコル)トラップおよび新しいネットワーク プレフィクスを受信できるように、Integrated Local Management Interface(ILMI)と通信する PVC を設定する必要があります。ILMI PVC で推奨される vpi 値 および vci 値は、それぞれ 0 および 16 です。ILMI 通信を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

Router(config-if)# pvc [ name ] vpi / vci [ ilmi | qsaal ]

ATM メイン インターフェイス上に ILMI PVC を作成します。

次に、ATM メイン インターフェイス上に ILMI PVC を作成する例を示します。

Router(config-if)# pvc cisco 0/16 ilmi

) ILMI PVC を設定できるのは、ATM メイン インターフェイスだけです。ATM サブインターフェイスに設定することはできません。


ILMI PVC を設定したあとで、インターフェイス コンフィギュレーション モードで次のコマンドを実行することにより、任意で ILMI キープアライブ機能をイネーブルにすることができます。

 

コマンド
説明

Router(config-if)# atm ilmi-keepalive [ seconds ]

ILMI キープアライブをイネーブルにし、キープアライブのインターバルを指定します。

デフォルトでは、SNMP トラップおよび新しいネットワーク プレフィクスを受信できるよう、ILMI アドレス登録がイネーブルに設定されます。ILMI キープアライブ機能はデフォルトではディセーブルです。イネーブルにした場合、デフォルトのキープアライブ インターバルは 3 秒です。

次に、ILMI キープアライブ インターバルを 3 分に設定する例を示します。

Router(config-if)# atm ilmi-keepalive 180

SVC コール セットアップを実行する PVC の設定

ルータと ATM スイッチ間には 1 つの専用 PVC が設定されます。SVC のコール確立要求およびコール終了要求はすべて、この PVC により伝送されます。コールが確立されると、ルータ相互間の SVC によるデータ伝送が開始されます。

SVC をセットアップするには、事前にシグナリング PVC を設定する必要があります。

すべての SVC 接続を対象とするシグナリング PVC を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

Router(config-if)# pvc [ name ] vpi / vci [ ilmi | qsaal ]

SVC を使用する ATM メイン インターフェイス用のシグナリング PVC を設定します。

次に、シグナリング PVC を設定する例を示します。

Router(config-if)# pvc 0/5 qsaal
Router(config-if-atm-vc)#

) シグナリング PVC を設定できるのは、ATM メイン インターフェイスだけです。ATM サブインターフェイスに設定することはできません。


VPI および VCI は、ATM スイッチと同じ値を設定する必要があります。VPI の標準値は 0、VCI の標準値は 5 です。

NSAP アドレスの設定

シグナリングを使用する ATM インターフェイスにはそれぞれ、Network Service Access Point(NSAP; ネットワーク サービス アクセス ポイント)アドレスを設定する必要があります。NSAP アドレスはインターフェイスの ATM アドレスで、ネットワーク全体で一意のアドレスでなければなりません。

NSAP アドレスを設定するには、次のいずれかの作業を行います。

「ESI フィールドおよびセレクタ フィールドの設定」

「完全な NSAP アドレスの設定」

ESI フィールドおよびセレクタ フィールドの設定

スイッチが ILMI を使用してルータに NSAP アドレス プレフィクスを配信でき、ルータに ILMI 経由でスイッチと通信する PVC が設定されている場合には、 atm esi-address コマンドを使用して、End Station ID(ESI)フィールドおよびセレクタ フィールドを設定できます。 atmesi-address コマンドに ESI(12 桁の 16 進数)およびセレクタ バイト(2 桁の 16 進数)を入力することによって、ATM アドレスを設定できます。NSAP プレフィクス(26 桁の 16 進数)は、ATM スイッチにより提供されます。

ルータがスイッチから NSAP プレフィクスを取得し、そのアドレスの他のフィールドにローカル入力値を使用するよう設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config-if)# pvc [ name ] vpi/vci [ ilmi | qsaal ]

ATM メイン インターフェイスに、ILMI を使用してスイッチと通信する ILMI PVC を設定します。

ステップ 2

Router(config-if-atm-vc)# exit

インターフェイス コンフィギュレーション モードに戻ります。

ステップ 3

Router(config-if)# atm esi-address esi . selector

NSAP アドレスの ESI およびセレクタ フィールドを入力します。

Router(config-if)# pvc 0/16 ilmi
Router(config-if-atm-vc)# exit
Router(config-if)# atm esi-address 3456.7890.1234.12
 

ILMI PVC の vpi の推奨値は 0、vciの推奨値は 16 です。

ILMI PVC のキープアライブ インターバルを指定することもできます。

完全な NSAP アドレスの設定

ATM NSAP アドレスを手作業で設定する場合には、アドレス全体を 16 進数形式で入力する必要があります。入力値はすべて 16 進数とみなされるからです。完全な NSAP アドレスを設定するには、次の形式で、40 桁の 16 進数を入力する必要があります。

XX.XXXX.XX.XXXXXX.XXXX.XXXX.XXXX.XXXX.XXXX.XXXX.XX

) ATM NSAP アドレスはすべて、ATM フォーラム UNI 仕様に準拠している上記のドット付き 16 進形式で入力できます。ドット付き形式により、アドレスが有効値かどうか確認できます。アドレス形式が正しいことがわかっている場合は、ドットを省略してもかまいません。


インターフェイスにはデフォルトの NSAP アドレスは設定されないので、SVC 用の NSAP アドレスは必ず設定しなければなりません。ATM インターフェイスの送信元 NSAP アドレスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

Router(config-if)# atm nsap-address nsap-address

インターフェイスの ATM NSAP アドレスを設定します。

次に、NSAP アドレスを設定する例を示します。

Router(config-if)# atm nsap-address BC.CDEF.01.234567.890A.BCDE.F012.3456.7890.1334.13
Router(config-if)#

 

atmnsap-address コマンドと atmesi-address コマンドは、どちらか 1 つだけしか使用できません。ルータで atmnsap-address コマンドを実行すると、 atmesi-address コマンドの設定は無視されます。逆の場合も同様です。 show interface atm コマンドを実行すると、インターフェイスの ATM アドレスを表示できます。

SVC の作成

SVC を作成するには、インターフェイス コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config-if)# svc [ name ] nsap address

(任意)SVC を作成し、宛先 NSAP アドレスを指定します。

ステップ 2

Router(config-if-atm-vc)# encapsulation {aal5mux | aal5snap}

(任意)AAL およびカプセル化タイプを設定します。デフォルトは、aal5snap です。

ステップ 3

Router(config-if-atm-vc)# protocol protocol protocol-address [[ no ] broadcast ]

SVC にプロトコル アドレスをマップします。

SVC に名前を指定すると、 svc name コマンドを入力してインターフェイス ATM VC コンフィギュレーション モードを再開したり、 no svc name コマンドを入力して SVC コンフィギュレーションを削除したりできます。

aal-encap 引数でサポートされる AAL およびカプセル化タイプのリストは、『 Cisco IOS Wide-Area Networking Command Reference 』の「ATM Commands」の章の encapsulation aal5 コマンドの説明を参照してください。デフォルトは、AAL5 および Subnetwork Access Protocol(SNAP)カプセル化です。

次に、SVC を作成する例を示します。

Router(config-if)# svc nsap BC.CDEF.01.234567.890A.BCDE.F012.3456.7890.1334.13
Router(config-if-atm-vc)# encapsulation aal5mux
Router(config-if-atm-vc)# protocol ip 1.1.1.5 broadcast
Router(config-if-atm-vc)#

 

RFC 1483 スパニングツリー インターオペラビリティの拡張性

RFC 1483 スパニングツリー インターオペラビリティの拡張機能により、Cisco 7600 シリーズ ルータと、Catalyst 5500 のレガシー ATM スイッチ、Cisco 7200 ルータ、および Cisco 7500 ルータの間で、異なる 2 つの BPDU 形式(PVST+ と 802.1d)でのインターオペラビリティが実現されます。

ここでは、1483 ブリッジモード ATM PVC での各種スパニングツリーの実装に関するインターオペラビリティ機能について説明します。従来、ベンダーは 1483 カプセル化でスパニングツリーを必ずしも実装していたわけではありません。また、Cisco IOS バージョンによっては、スパニングツリー オプションの全範囲をサポートしていないものもあります。この機能の目的は、RFC 1483 ブリッジモード カプセル化において、相互作用できる共通のスパニングツリーの実現という実用上の課題を緩和することです。


) このフィーチャ セットは、RFC 1483 ブリッジモード ATM PVC でのみサポートされます。


まず、基本的な用語について説明します。

IEEE 802.1D は、MAC(メディア アクセス制御)ブリッジを介する LAN の相互接続に関する標準規格です(図8-3 を参照)。802.1D は、Spanning-Tree Protocol(STP; スパニングツリー プロトコル)を使用して、ブロードキャスト ストームの原因となるブリッジ トポロジー内のループを解消します。

IEEE 802.1D で定義されている STP は、ネットワーク内の不要なループを防止しながら、パスの冗長性を実現するリンク管理プロトコルです。IEEE 802.1D スパニング ツリーにより、スイッチで設定されている VLAN 数に関係なく、スイッチ全体で 1 つのスパニング ツリー インスタンスを維持できるようになります。

BPDU は、各種スパニングツリーの実装で使用されるフレームの総称です。STP は BPDU の情報を使用して、スイッチド ネットワークのルート スイッチとルート ポート、および各スイッチド セグメントのルート ポートと指定ポートを選択します。

PVST は、シスコ独自のプロトコルで、シスコ製装置が VLAN 単位で複数のスパニング ツリー トポロジーをサポートできるようにします。PVST は IEEE 802.1D(図8-3 を参照)で定義されている BPDU を使用しますが、スイッチごとに 1 つの STP インスタンスではなく、VLAN ごとに 1 つの STP インスタンスがあります。

PVST+ は、シスコ独自のプロトコルで、VLAN ごとに 1 つの STP インスタンスを作成します(PVST と同様)。ただし、PVST+ は PVST を拡張し、シスコ独自の BPDU を PVST で使用される標準の IEEE 802.1D フレーム形式(図8-3 を参照)ではなく、特別な 802.2 SNAP OUI(図8-1 を参照)によって使用します。PVST+ BPDU は、別名 Shared Spanning Tree Protocol(SSTP)BPDU といいます。


) ここでは RFC 1483 について説明していますが、現在では RFC 2684 に改定されています。


サポート対象のスーパーバイザおよびライン カード

Cisco 7600 ルータでは、次のスーパーバイザおよびライン カードにより、PVST と PVST+ の BPDU インターオペラビリティをサポートします。

Supervisor 720 ライン カード

拡張 FlexWAN

7600 SIP-200

ATM OSM

前提条件

RFC 1483 スパニングツリー インターオペラビリティの拡張機能には、Cisco IOS Rlease 12.2(18)SXF1 以降が必要です。

インターオペラビリティ問題の概要

現在のインターオペラビリティ問題の概要は、次のとおりです。

STP BPDU を送信する場合、ベンダーによる ATM とイーサネット間ブリッジングの実装の多くは、RFC 1483 付録 B の仕様に完全に準拠しているわけではありません。最も標準的なものは、OUI:00-80-C2 および PID:00-07 を使って ATM Common Part Convergence Sublayer(CPCS)SNAP PDU を使用することです。付録 B では、BPDU を含まない一般的なイーサネット フレーム用に、この OUI/PID の組み合わせが規定されていました。付録 B では、BPDU を含むフレーム用に、OUI:00-80-C2、PID:00-0E が規定されています。

ATM インターフェイス上でシスコ製品が使用するスパニングツリー プロトコルには、いくつかの種類があります。Catalyst 5000 は、ATM インターフェイス上で PVST のみをサポートします。Cisco 7600 シリーズ ルータは、ATM インターフェイス上で PVST+ のみをサポートします。その他のシスコ製ルータのほとんどは、ATM インターフェイス上で従来の IEEE 802.1D を実装します。

Cisco 7600 シリーズ ルータが Cisco 7600 FlexWAN モジュール上で最初に 1483 ブリッジングを実装した際(Cisco IOS 12.1E で)、プラットフォームでは OUI:00-80-C2 および PID:00-0E を使用して、他のすべての Cisco IOS 製品とのインターオペラビリティを最大化していました。

ただし、PID:00-0E を含む PVST または 802.1D の BPDU を送信しない実装が多くあるため、Cisco 7600 シリーズ ルータは、Cisco IOS 12.2SX でより一般的な RFC 1483(PID:00-07 を含む)の実装に戻しました。この機能は、PID:00-07 または PID:00-0E のいずれかにより、1483 での BPDU のカプセル化のオプションを提供します。

BPDU のパケット形式

ここでは、BPDU の各種パケット形式について説明します。図8-1 に、PVST+ で使用される(PVST では使用されない)一般的な IEEE 802.2/802.3 フレーム形式を示します。

図8-1 IEEE 802.2/802.3 SNAP カプセル化(RFC 1042)

 

Catalyst 5000 PVST BPDU のパケット形式

Catalyst 5000 シリーズ スイッチは、ATM インターフェイス上で PVST 形式で BPDU を受信します(図8-2 を参照)。

図8-2 Catalyst 5000 スイッチが使用する BPDU PVST フレーム

 

Catalyst 5000 が送信する BPDU は、PID:0x00-07 を使用します。これは、RFC 1483 に準拠しません。また、Cisco 7600 ルータもこのデータ形式で BPDU を送信できます。

Catalyst 5000 スイッチは、 bridge-domain コマンドの ignore-bpdu-pid オプション キーワードを使用して、デフォルトでこのフレームを送信します。

Catalyst 5000 は、PVST+ BPDU を受信できません。次のエラー メッセージが表示され、ATM ポートをブロックします。

%SPANTREE-2-RX_1QNON1QTRUNK:Rcved 1Q-BPDU on non-1Q-trun port 6/1 vlan 10

%SPANTREE-2-RX_BLKPORTPVID:Block 6/1 on rcving vlan 10 for inc peer vlan 0

Cisco 7200/7500 IEEE BPDU のフレーム形式

図8-3 に、Cisco 7200/7500 ルータの IEEE BPDU のフレーム形式を示します。

図8-3 Cisco 7200/7500 IEEE BPDU のフレーム形式

 

Cisco 7600 PVST+ BPDU のフレーム形式

Cisco 7600 ルータの PVST+ BPDU パケット形式は、図8-4 のとおりです。これらの BPDU は、IEEE BPDU ではありませんが、シスコ独自の SSTP BPDU です。

図8-4 Cisco 7600 PVST+ BPDU のフレーム(1483 ブリッジド)

 

Cisco L2PT BPDU のフレーム形式

図8-5 に、Cisco Layer 2 Protocol Tunneling(L2PT; レイヤ 2 プロトコル トンネリング)BPDU SNAP のフレーム形式を示します。

図8-5 L2PT BPDU SNAP のフレーム形式

 

BPDU 変換コマンド ライン インターフェイスの要約

前の項で説明したインターオペラビリティの問題を解決するために、シスコでは bridge-domain コマンドに次の新しいキーワードを導入しました。

ignore-bpdu-pid

pvst-tlv

ignore-bpdu-pid キーワード

ignore-bpdu-pid キーワードを使用しない場合、デバイス間の PVC は RFC 1483 準拠方式で動作します。これを、 strict モード といいます。 ignore-bpdu-pid キーワードを使用する場合は、 loose モード といいます。

このキーワードを使用しない場合、IEEE BPDU は、RFC 1483 に準拠する PID:0x00-0E を使用して送信されます。

このキーワードを使用すると、IEEE BPDU は、通常 1483 データ用に指定される PID:0x00-07を使用して送信されます。

詳細については、「BPDU のパケット形式」 を参照してください。

シスコ独自の PVST+ BPDU は、 ignore-bpdu-pid キーワードが使用されているかどうかに関わらず、常に PID:0x00-07 を使用するデータ フレームで送信されます。

PID:00-07 を含む PVST(または 802.1D)BPDU を送信するデバイスに接続している場合は、< ignore > キーワードを使用します。このデバイスには、ATM DSL モデムなど大多数の CPE デバイスが含まれます。

pvst-tlv キーワード

pvst-tlv キーワードにより、PVST または IEEE STP のみを認識するデバイスとの相互運用において、BPDU 変換がイネーブルになります。Cisco 7600 ATM モジュールは、PVST+ のみをサポートするので、ATM モジュールで PVST のみを認識する Catalyst 5000 スイッチ、または IEEE 形式のみを認識するその他の Cisco IOS ルータに接続する場合は、 pvst-tlv キーワードを使用する必要があります。

pvst-tlv キーワードにより、PVST+ BPDU は、送信時に IEEE BPDU に変換されます。

pvst-tlv キーワードにより、IEEE BPDU は、受信時に PVST+ BPDU に変換されます。

Cisco 7600 ルータが Cisco 7200 ルータに接続される場合

たとえば、Cisco 7200 ルータは、RFC 1483 準拠方式で IEEE BPDU のみを認識するデバイスです。そのため、Cisco 7600 ルータが Cisco 7200 ルータに接続される場合、次のキーワードを使用する必要があります。

bridge-domain <vlan> pvst-tlv <vlan>

この場合、Cisco 7200 ルータは IEEE BPDU に関して RFC 1483 準拠方式で動作する必要があるため、 ignore-bpdu-pid キーワードは使用されません。

Cisco 7600 ルータが Catalyst 5500 ATM モジュールに接続される場合

Catalyst 5500 ATM モジュールは、RFC 1483 非準拠方式で PVST BPDU のみを認識するデバイスです。したがって、Cisco 7600 ルータが Catalyst 5500 ATM モジュールに接続される場合、次の両方のキーワードを使用する必要があります。

bridge-domain <vlan> ignore-bpdu-pid pvst-tlv <vlan>

L2PT トポロジーの CLI

L2PT トポロジーの BPDU 変換をイネーブルにするには、次のコマンドラインを使用します。

bridge-domain <PE vlan> dot1q-tunnel ignore-bpdu-pid pvst-tlv <CE vlan>

BPDU 変換を必要とする標準的なトポロジー

ここでは、最も一般的なネットワーク シナリオについて説明し、各例におけるデバイス間の BPDU 変換をイネーブルにするのに必要な設定コマンドを示します。

Cisco 7600、Catalyst 5500、および Catalyst 6500 の L2PT トポロジー

図8-6 に、Catalyst 5500 スイッチと Cisco 7600 ルータ間でデータ パケットが送信される場合のネットワーク トポロジーの一例を示します。

図8-6 Catalyst 5500 スイッチおよび Cisco 7600 ルータの L2PT トポロジー

 

図8-6 に示すように、L2PT はCisco 7600 のインターフェイス ATM6/1/0 および Catalyst 6500 のインターフェイス Ethernet2/1 で設定されます。

PVST パケットは、Catalyst 5500 スイッチから Cisco 7600 ルータに送信されます。Cisco 7600 ルータは、L2PT を介して Catalyst 6500 にこれらの BPDU を送信します。カスタマー ネットワークにパケットを送信する前に、これらの BPDU のカプセル化が解除され、復元されます。

Cisco 7600 および Catalyst 6500 は Provider Edge(PE; プロバイダー エッジ)デバイスで、それ以外は Customer Edge(CE; カスタマー エッジ)デバイスであることを前提とします。

ATM の設定例

着信するトラフィックはすべて、dot1q-tunnel を介して送信される必要があります。PE-VLAN が 200 で CE-VLAN が 100 の場合の設定は、次のとおりです。

Router(config)#int atm 6/1/0
Router(config-if)#pvc 6/200
Router(config-if-atm-vc)#bridge-domain 200 dot1q-tunnel ignore-bpdu-pid pvst-tlv 100
Router(config-if-atm-vc)#

イーサネットの設定例

イーサネットの設定は、次のようになります。

Router(config)#int gig2/1/0
Router(config-if)#switchport
Router(config-if)#switchport access vlan 200
Router(config-if)#switchport mode dot1q-tunnel
Router(config-if)#l2protocol-tunnel

CE-VLAN 100 は、カスタマー サイトで使用されます。Catalyst 5500 は、データ形式で IEEE BPDU を送信します。Cisco 7600 ルータは BPDU を受信すると、まず PVST+ 形式に変換します。次に、フレームの Destination Address(DA ;宛先アドレス)MAC がプロトコル トンネルの MAC アドレスに変更され、レイヤ 2 クラウドに送信されます。

もう一端では、フレームがインターフェイス gige2/1/0 から送信される際に、DA MAC が PVST+ DA MAC に再度変更され、PVST+ BPDU が CPE デバイスに送信されます。

Cisco 7600 および Cisco 7200 の L2PT トポロジー

図8-7 に示す例では、Cisco 7600 ルータは Cisco 7200 ルータと通信する必要があります。

図8-7 Cisco 7600 ルータおよび Cisco 7200 ルータの L2PT トポロジー

 

PE の設定

PE での設定は、次のようになります。

!On PE 1
interface ATM2/0/0
no ip address
atm mtu-reject-call
pvc 7/101
bridge-domain 200 dot1q-tunnel
!
end
!On PE 2
interface ATM3/0/0
no ip address
pvc 2/101
bridge-domain 200 dot1q-tunnel pvst-tlv 100
!
end

Cisco 7600 CE の設定

Cisco 7600 CE 1 の設定は、次のようになります。

!On CE 1
interface ATM1/1/0
no ip address
atm mtu-reject-call
pvc 7/101
bridge-domain 101
!
end

Cisco 7200 CE の設定

Cisco 7200(CE 2)ルータの設定は、次のようになります。

!On CE 2
interface ATM4/0
no ip address
no atm ilmi-keepalive
pvc 2/101
!
bridge-group 101
end

Cisco 7200 CE から Cisco 7600 CE へのデータ伝送シーケンス

これまでに説明した設定およびトポロジーを前提とすると、Cisco 7200 CE から Cisco 7600 CE へのデータ伝送シーケンスは次のようになります。

1. Cisco 7200 CE 2 は、RFC 1483 形式で MAC ヘッダーなしの BPDU を送信します。

2. Cisco 7600 PE はこれを受信すると、IEEE BPDU から PVST+ BPDU 形式に変換します。

3. VLAN 100 は、PVST+ BPDU に挿入されます。

4. 次に、フレームの DA MAC はプロトコル トンネルの DA MAC を使用するように書き換えられ、ATM ネットワーク クラウドに送信されます。

5. L2PT BPDU は、PE1 のインターフェイス ATM2/0/0 から送信されなければなりません。DA MAC は、PVST+ DA MAC に復元されます。

6. 最後に、PVST+ BPDU は 7600 CE 1 デバイスに送信されます。

7600 の基本的なバックツーバック シナリオ

図8-8 の基本的なバックツーバック シナリオは、次のとおりです。

図8-8 Cisco 7600 ルータの基本的なバックツーバック トポロジー

 

交換される PDU は、PVST+ BPDU です。PVST+ BPDU は、PID:0x0007 を使用して送信されます。設定は、次のとおりです。

Router(config)#int atm 2/1/0
Router(config-if)#pvc 2/202
Router(config-if-atm-vc)#bridge-domain 101
Router(config-if-atm-vc)#

Catalyst 5500 スイッチおよび Cisco 7600 ルータのバックツーバック トポロジー

図8-9 に示す別のトポロジー例は、単純なバックツーバック設定で、基本的な Catalyst 5500 および Cisco 7600 のインターオペラビリティをテストするのに使用されます。

図8-9 バックツーバック トポロジーにおける Catalyst 5500 スイッチおよび Cisco 7600 ルータ

 

Catalyst 5000 の ATM モジュールのような、データ形式(PID:0x0007)の IEEE BPDU を送受信するデバイスに接続されている場合は、次のように設定する必要があります。

Router(config)#int atm 2/1/0
Router(config-if)#pvc 2/202
Router(config-if-atm-vc)#bridge-domain 101 ignore-bpdu-pid pvst-tlv 101
Router(config-if-atm-vc)#

Cisco 7600 ルータは、発信 PVST+ BPDU を IEEE BPDU に変換します。また ignore-bpdu-pid キーワードもイネーブルであるため、PID:0x0007 が使用されます。これは、Catalyst 5500 スイッチが要求しているものです。

Cisco 7600 および Cisco 7200 のバックツーバック トポロジー

PID:0x000E を使用して IEEE BPDU を送信する、RFC 1483 に完全に準拠するデバイスに接続している場合は、 bridge-domain コマンドで新しい ignore-bpdu-pid キーワードを使用する必要があります。

図8-10 Cisco 7600 ルータおよび Cisco 7200 ルータのバックツーバック トポロジー

 

たとえば、Cisco 7600 ルータが Cisco 7200 ルータに接続されている場合、次のような設定になります。

Router(config)#int atm 2/1/0
Router(config-if)#pvc 2/202
Router(config-if-atm-vc)#bridge-domain 101 pvst-tlv 101
Router(config-if-atm-vc)#

) この場合、CE-VLAN はブリッジドメイン VLAN と同一である必要があります。


APS の設定

Automatic Protection Switching(APS; 自動保護スイッチング)機能は、Telcordia 発行の『 GR-253-CORE SONET Transport Systems: Common Generic Criteria 』のセクション 5.3 に記述されているように、Linear 1+1 APS をサポートしています。

Linear APS は、回線レイヤでの保護を行うよう定義されています。OC-N 信号で伝送されるすべての STS Synchronous Payload Envelope(SPE; 同期ペイロード エンベロープ)は保護されるため、保護スイッチングが発生した場合に VC はすべて同時にスイッチングされます。

OC-12 ATM OSM 上のポートは、以下によって保護されます。

同一 OC-12 ATM OSM 上の別のポート

同一ルータ内の別の OC-12 ATM OSM 上の別のポート

別のルータ内の別の OC-12 ATM OSM 上の別のポート


) ルータ障害を防ぐために別のルータ内の APS をインストールするには、実行インターフェイスの現行の VC コンテキストに合わせて、保護インターフェイスをアップデートしておく必要があります。このためには、VC コンフィギュレーションを保護インターフェイスに手動で設定する必要があります。


APS を設定する場合は、実行インターフェイスおよび APS OOB(帯域外)通信パスとして使用するインターフェイスの IP アドレスを最初に指定することを推奨します。


) 保護インターフェイスがアクティブ回線になり、現用回線が検出時にディセーブルにされることがないように、実行インターフェイスを設定してから保護インターフェイスを設定します。


APS の詳細および他の APS 機能の設定情報については、次の URL にアクセスし、『Cisco IOS Interface Configuration Guide』 Release 12.1 を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_c/index.htm

実行インターフェイスの設定

実行インターフェイスを設定する手順は、次のとおりです。


) 通常の ATM インターフェイスの設定には、それぞれの IP アドレスと VC が異なる複数のサブインターフェイスが組み込まれています。保護インターフェイスを設定する際は、実行インターフェイスと同じ VC を組み込むようにしてください。同じ IP アドレスを複数のインターフェイスで使用することはできないため、保護インターフェイスに設定する IP アドレスは、同じサブネット内になければなりません。


 

コマンド
説明

ステップ 1

Router(config)# interface atm slot/port

ATM インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-controller)# aps working circuit-number

このインターフェイスを実行インターフェイスとして設定します。

ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show controllers atm

Router# show interface atm

Router# show aps

Router# show aps controller

インターフェイスが正しく設定されているかどうかを確認するために、ATM コントローラおよびインターフェイスの情報を表示します。


) ルータに複数の保護インターフェイスが設定されている場合、各インターフェイスに aps group コマンドを設定してから、対応する aps protect コマンドを設定する必要があります。


保護インターフェイスの設定

保護インターフェイスを設定するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config)# interface atm slot/port

ATM インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# aps protect circuit-number ip-address

このインターフェイスを保護インターフェイスとして設定します。実行インターフェイスのあるルータの IP アドレスを指定します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show controllers atm

Router# show interface atm

Router# s how aps

インターフェイスが正しく設定されているかどうかを確認するために、ATM コントローラおよびインターフェイスの情報を表示します。

単一ルータでの基本 APS の設定

図8-11 に、ルータ A およびルータ B での APS の設定を示します。ルータ A には、実行インターフェイスと保護インターフェイスの両方が設定されています。実行インターフェイス ATM1/0 が使用できなくなると、保護インターフェイス ATM3/0 に接続が自動的に切り替えられます。通常、単一ルータの APS 構成は、ライン カードの障害を防ぐために使用します。

図8-11 基本的な単一ルータの APS 構成

 

 


ステップ 1 ルータ A にループバック インターフェイスを設定します。

RouterA# configure terminal
RouterA(config)# interface Loopback 0/0
RouterA(config-if)# ip address 7.7.7.7 255.255.255.255
RouterA(config-if)# end
RouterA#
 

ステップ 2 ルータ A に実行インターフェイスおよび保護インターフェイスを設定します。

RouterA# configure terminal
RouterA(config)# interface ATM 1/0
RouterA(config-if)# aps working 1
RouterA(config-if)# exit
RouterA(config)# interface ATM 3/0
RouterA(config-if)# aps protect 1 7.7.7.7
RouterA(config-if)# end
 

ステップ 3 実行インターフェイスと保護インターフェイスの両方に VC を設定します。

RouterA# configure terminal
RouterA(config)# int atm 1/0.1 point-to-point
RouterA(config-subif)# ip address 10.1.1.1 255.255.255.0
RouterA(config-subif)# pvc 0/100
RouterA(config-subif)# exit
RouterA(config)# int atm 3/0.1 point-to-point
RouterA(config-subif)# ip address 10.1.1.1 255.255.255.0
RouterA(config-subif)# pvc 0/100
RouterA(config-subif)# exit
RouterA(config)# end
RouterA#

) APS プロトコルでは回線(エンドツーエンドではない)の冗長性が利用できるため、保護インターフェイスに IP アドレスを 2 回設定する必要があります。保護インターフェイスには、自動設定機能はありません。保護インターフェイスで冗長性が必要な VC は、すべて手動で設定する必要があります。



 

基本的な複数ルータ APS 構成

図8-12 に、ルータ A およびルータ B での APS の設定を示します。ルータ A には実行インターフェイスが、ルータ B には保護インターフェイスが設定されています。ルータ A の実行インターフェイスが使用できなくなると、ルータ B の保護インターフェイスに接続が自動的に切り替えられます。通常、この構成は、ライン カードとルータ両方の障害を防ぐために使用します。

図8-12 基本的な複数ルータの APS 構成

 


ステップ 1 ルータ A に実行インターフェイスを設定します。

RouterA# configure terminal
RouterA(config)# interface ethernet 0/0
RouterA(config-if)# ip address 7.7.7.7 255.255.255.0
RouterA(config-if)# exit
RouterA(config)# interface ATM 1/0
RouterA(config-if)# aps working 1
RouterA(config-if)# end
RouterA#
 

ステップ 2 ルータ B に保護インターフェイスを設定します。

RouterB# configure terminal
RouterB(config)# interface ethernet 0/0
RouterB(config-if)# ip address 7.7.7.6 255.255.255.0
RouterB(config)# interface ATM 3/0
RouterB(config-if)# aps protect 1 7.7.7.7
RouterB(config-if)# end
RouterB#
 
 

ステップ 3 ルータ A に VC を設定します。

RouterA# configure terminal
RouterA(config)# int atm 1/0.1 point-to-point
RouterA(config-subif)# ip address 10.1.1.1 255.255.255.0
RouterA(config-subif)# pvc 0/100
RouterA(config-subif)# exit
RouterA(config)# end
RouterA#
 

ステップ 4 ルータ B に同じ VC を設定します。

RouterB# configure terminal
RouterB(config)# int atm 3/0.1 point-to-point
RouterB(config-subif)# ip address 10.1.1.1 255.255.255.0
RouterB(config-subif)# pvc 0/100
RouterB(config-subif)# exit
RouterB(config)# end
RouterB#

複数 APS インターフェイスの構成

1 つのルータに複数の保護/実行インターフェイスを設定するには、aps group コマンドを使用します。図8-13 に、1 つのルータに複数の実行/保護インターフェイスを設定する例を示します。ルータ A にもルータ B にも、実行インターフェイスと保護インターフェイスが設定されています。ルータ A の実行インターフェイス 2/0 が使用できなくなると、ルータ B の保護インターフェイス 3/0 に接続が切り替えられます。これはどちらも APS グループ 10 に属しているためです。ルータ B の実行インターフェイス 2/0 が使用できなくなった場合も同様です。接続は同じ APS グループ 20 に属しているため、ルータ A の保護インターフェイス 3/0 に切り替えられます。

図8-13 複数 APS インターフェイスの構成

 


) 保護インターフェイス検出時に、保護インターフェイスがアクティブ回線になり、実行回線がディセーブルにされることがないように、実行インターフェイスを設定してから保護インターフェイスを設定してください。



ステップ 1 ルータ A では次のように設定し、グループ 10 用の実行インターフェイスとグループ 20 用の保護インターフェイスを指定します。

RouterA# configure terminal
RouterA(config)# interface ethernet 0/0
RouterA(config-if)# ip address 7.7.7.6 255.255.255.0
RouterA(config)# interface ATM2/0
RouterA(config)# aps group 10
RouterA(config-if)# aps working 1
RouterA(config)# interface ATM3/0
RouterA(config-if)# aps group 20
RouterA(config-if)# aps protect 1 7.7.7.7
RouterA(config-if)# end
RouterA#
 

ステップ 2 ルータ B では次のように設定し、グループ 10 用の保護インターフェイスとグループ 20 用の実行インターフェイスを指定します。

RouterB# configure terminal
RouterB(config)# interface ethernet 0/0
RouterB(config-if)# ip address 7.7.7.7 255.255.255.0
RouterB(config)# interface ATM2/0
RouterB(config)# aps group 20
RouterB(config-if)# aps working 1
RouterB(config)# interface ATM3/0
RouterB(config-if)# aps group 10
RouterB(config-if)# aps protect 1 7.7.7.6
RouterB(config-if)# end
RouterB#
 


 

APS コマンド

ATM の APS では、次のコマンドが利用できます。これらのコマンドの使用方法については、次の URL を参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios111/cc111/posaps.htm#xtocid13


) ATM でこれらのコマンドを使用する場合は、インターフェイスを POS から ATM に変更してください。


aps authenticate

aps force

aps group

aps lockout

aps manual

aps protect

aps revert

aps timers

aps unidirectional

aps working

show aps

SONET および SDH コンフィギュレーション コマンド

2 ポート OC-12 ATM OSM のデフォルトのフレーム同期方式は SONET ですが、このモジュールは SDH もサポートしています。ここでは、動作モードの変更、BER(ビット エラー レート)スレッシュホールド値の指定、およびアラーム通知のイネーブル化を実行するコマンドについて説明します。

atm framing sonet | sdh

フレーム同期方式を指定するには、atm framing sonet | sdh コマンドを使用します。デフォルトのフレーム同期方式は SONET です。

Router(config-if)# atm framing sdh
Router(config-if)#

atm sonet stm-4

オペレーション モードを設定し、SONET Physical Layer Interface Module(PLIM)のセルレート デカップリングに使用する ATM セル タイプを制御するには、atm sonet stm-4 インターフェイス コンフィギュレーション コマンドを使用します。このコマンドの no 形式を使用すると、デフォルトの Synchronous Transport Signal Level 12(STS-12c)オペレーション モードに戻ります。


) atm sonet stm-4 コマンドおよび atm framing sdh コマンドは、いずれもフレーム同期方式を SDH に変更します。この 2 つのコマンドの機能は同じです。


[no] atm sonet stm-4

次に、モードを STS-12 から STM-4 に変更し、コンフィギュレーションを確認する例を示します。

Router(config-if)# atm sonet stm-4
Router(config-if)# end
Router# show controllers atm 3/1
Interface ATM3/1 is up
 
hwidb addr:42773F94, instance addr:42780F64
 
Framing mode:SDH (STM-4)
Clock source:Line
 
VPIs in use:3, max VPIs:15
 
VPI # VCs VPI # VCs VPI # VCs
--- ----- --- ----- --- -----
0 201 1 3 255 1
 
ATM framing errors:
HCS (correctable): 1058413
HCS (uncorrectable):3851467
LCD: 18
 
SONET Subblock:
SECTION
LOF = 0 LOS = 2 RDOOL = 0 BIP(B1) = 1020363
Active Alarms:None
Active Defects:None
Alarm reporting enabled for:LOF LOS B1-TCA
LINE
AIS = 0 RDI = 5 FEBE = 437717490 BIP(B2) = 457516655
Active Alarms:None
Active Defects:None
Alarm reporting enabled for:B2-TCA SF
PATH
AIS = 0 RDI = 13 FEBE = 345027 BIP(B3) = 1229383
LOP = 2 NEWPTR = 0 PSE = 0 NSE = 0
Active Alarms:None
Active Defects:None
Alarm reporting enabled for:LOP B3-TCA
 
BER thresholds: SF = 10e-3, SD = 10e-6
TCA thresholds: B1 = 10e-6, B2 = 10e-6, B3 = 10e-6
Router#
 

atm sonet report

ATM SONET アラーム通知を設定するには、atm sonet report インターフェイス コンフィギュレーション コマンドを使用します。このコマンドの no 形式を実行すると、アラーム通知が解除されます。

[no] atm sonet report {all | b1-tca | b2-tca | b3-tca | default | lais | lrdi | pais | plop | pplm | prdi | ptim | puneq | sd-ber | sf-ber | slof | slos}

次に、B1 スレッシュホールド超過アラートをイネーブルにする例を示します。

Router(config-if)# atm sonet report b1-tca
Router(config-if)#

atm sonet threshold

BER スレッシュホールド値を設定するには、atm sonet threshold インターフェイス コンフィギュレーション コマンドを使用します。このコマンドの no 形式を使用すると、コンフィギュレーションが削除されます。

[no] atm sonet-threshold {b1-tca value | b2-tca value| b3-tca value| sd-ber value| sf-ber value}

次に、B1 スレッシュホールドを設定する例を示します。

Router(config-if)# atm sonet threshold b1-tca 9
Router(config-if)#

show controllers atm

物理ポートのハードウェア情報を表示するには、show controllers atm コマンドを使用します。

show controllers atm [slot/port-adapter/port]

次に、OC-12ATM ラインカードの出力を表示する例を示します。

Router# show controllers atm 6/1
 

このコマンドの出力は、次のとおりです。

~~~~~~~~~
btaps2#sh cont atm 6/1
Interface ATM6/1 is up
hwidb: 0x4316B388, instance: 0x4316EC30, 5 i/f transitions
Framing mode: SONET (STS-12c) Clock source: Internal -- Reason: Configured
VPIs in use: 0, max VPIs: 15
ATM framing errors:
HCS (correctable): 8
HCS (uncorrectable): 4375
LCD: 0
 
SONET Subblock:
APS <============APS 情報
COAPS = 0 PSBF = 0
State: PSBF_state = false
Rx(K1/K2): 0 /0 Tx(K1/K2): 0 /5
SECTION
LOF = 0 LOS = 0 BIP(B1) = 65
LINE
AIS = 0 RDI = 0 FEBE = 712 BIP(B2) = 0
PATH
AIS = 0 RDI = 1 FEBE = 65535 BIP(B3) = 134
LOP = 0 NEWPTR = 0 PSE = 0 NSE = 0
 
Active Defects: None
Active Alarms: None
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA
 
BER thresholds: SF = 10e-3, SD = 10e-6
TCA thresholds: B1 = 10e-6, B2 = 10e-6, B3 = 10e-6
 
Rx S1S0 = 00, Rx C2 = 13
 
PATH TRACE BUFFER : STABLE
Remote hostname : btaps1
Remote interface: ATM6/1
Remote IP addr : 0.0.0.0
Remote Rx(K1/K2): 00/00 Tx(K1/K2): 00/00
~~~~~~~~