オプティカル サービス モジュール ソフトウェア コンフィギュレーション ノート Cisco IOS 12.2SR
チャネライズド OC-12/T3 SONET/SDH OSM の設定
チャネライズド OC-12/T3 SONET/SDH OSM の設定
発行日;2012/02/02 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

チャネライズド

チャネライズド OSM の概要

サポート対象の多重化およびマッピング

チャネライズド OC-12/T3 OSM がサポートする機能

SONET の適合性

SONET のエラー、アラーム、およびパフォーマンスのモニタリング

SONET の同期

WAN プロトコル

ネットワーク管理

DS-3 サポート

DSU モード

QoS プロトコル

チャネライズド モジュールの設定

SONET コントローラの設定

POS インターフェイスの設定

DS-3 シリアル インターフェイスの設定

SDH フレーム同期と AU-3 マッピングによるインターフェイスの設定

SDH フレーム同期と AU-4 マッピングによるインターフェイスの設定

APS の設定

実行インターフェイスの設定

保護インターフェイスの設定

フレームリレーおよびフレームリレー トラフィック シェーピングの設定

フレームリレーの制限および制約

フレームリレー トラフィック シェーピングの設定例

設定例

チャネライズド POS の設定

チャネライズド DS-3 の設定

基本的な APS の設定

複数 APS インターフェイスの構成

チャネライズド
OC-12/T3 SONET/SDH OSM の設定

この章では、1 ポートのチャネライズド OC-12(OSM-1CHOC12/T3-SI)SONET/Synchronous Digital Hierarchy(SDH; 同期デジタル ハイアラーキ)OSM(オプティカル サービス モジュール)を設定する方法について説明します。

この章の内容は次のとおりです。

「チャネライズド OSM の概要」

「チャネライズド モジュールの設定」

チャネライズド OSM の概要

ここでは、チャネライズド OSM 上での SONET/SDH のマッピング、多重階層、およびサポート対象の機能について説明します。

「サポート対象の多重化およびマッピング」

「チャネライズド OC-12/T3 OSM がサポートする機能」

「チャネライズド モジュールの設定」

サポート対象の多重化およびマッピング

OSM-1CHOC12/STM-4 T3-SI モジュールは、OC-3、DS-3、DS-3 サブレートまでのチャネライズド コンフィギュレーションをサポートしています。

図5-1は、1 ポート ChOC-12/STM-4 OSM がサポートする SONET 多重階層を示しています。

図5-2は、1 ポート ChOC-12/STM-4 OSM がサポートする SDH 多重階層を示しています。

図5-1 1 ポート ChOC-12 OSM がサポートする SONET 多重階層

 

図5-2 1 ポート ChOC-12 OSM がサポートする SDH 多重階層

 

チャネライズド OC-12/T3 OSM がサポートする機能

OSM-1CHOC12/T3-SI は、次の標準 Cisco IOS SONET/SDH 機能をサポートしています。

「SONET の適合性」

「SONET のエラー、アラーム、およびパフォーマンスのモニタリング」

「SONET の同期」

「WAN プロトコル」

「ネットワーク管理」

「DS-3 サポート」

「DSU モード」

「QoS プロトコル」

SONET の適合性

OSM-1CHOC12/T3-SI は、1+1 SONET Automatic Protection Switching(APS; 自動保護スイッチング)をサポートしています。

SONET のエラー、アラーム、およびパフォーマンスのモニタリング

サポートされる SONET エラー、アラーム、およびパフォーマンスのモニタリングは、次のとおりです。

Signal Failure Bit Error Rate(SFBER; 信号損失ビット エラー レート)

Signal Degrade Bit Error Rate(SDBER; 信号劣化ビット エラー レート)

信号ラベル ペイロード作成(C2)

パス トレース バイト(J1)

Loss of Signal(LOS; 信号損失)

Loss of Frame(LOF; フレーム損失)

B1 のエラー カウント

B1 の Threshold Crossing Alarm(TCA; スレッシュホールド超過アラーム)

Line Alarm Indication Signal(LAIS; 回線アラーム検出信号)

Line Remote Defection Indication(LRDI; 回線リモート障害検出)

Line Remote Error Indication(LREI; 回線リモート エラー検出)

B2 のエラー カウント

B2 の TCA

Path Alarm Indication Signal(PAIS; パス アラーム検出信号)

Path Remote Defect Indication(PRDI; パス リモート障害検出)

Path Remote Error Indication(PREI; パス リモート エラー検出)

B3 のエラー カウント

B3 の TCA

Loss of Pointer(LOP; ポインタ損失)

Path Unequipped(PUNEQ)

Path Label Mismatch(PPLM)

New Pointer Event(NEWPTR)

Positive Stuffing Event(PSE)

Negative Stuffing Event(NSE)

SONET の同期

サポートされる SONET 同期化機能は、次のとおりです。

ローカル タイミング(ダーク ファイバまたは WDM 装置を介したルータ間接続用の内部タイミング)

全動作温度で +/-4.6 ppm のクロック精度

ループ タイミング(SONET/SDH 装置への接続用のループ タイミング)

WAN プロトコル

サポートされる WAN プロトコルは、次のとおりです。

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)および MPLS/Virtual Private Network(VPN; 仮想私設網)

チャネライズド OSM の MPLS/VPN の設定情報については、「OSM 上での MPLS の設定」を参照してください。

PPP(ポイントツーポイント プロトコル)IETF RFC 1661

High-Level Data Link Control(HDLC; ハイレベル データリンク制御)(IETF RFC 1662)

PPP over SONET、1+x43 の自己同期ペイロード スクランブリングを使用

フレームリレー

フレームリレー対応のチャネライズド インターフェイスの設定については、次の URL にアクセスし、『Cisco IOS Wide-Area Networking Configuration Guide』Release 12.1 の「Configuring Frame Relay」および『Cisco IOS Wide-Area Networking Command Reference』Release 12.1 を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdfrely.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wrdfrely.htm

フレームリレーのトラフィック シェーピングの設定については、次の URL にアクセスし、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Configuring Distributed Traffic Shaping」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt4/qcfdts.htm

APS および MSP に関する Cisco Protection Group Protocol over UDP/IP(ポート 172)

シリアル インターフェイス カプセル化の設定については、次の URL にアクセスし、『Cisco IOS Interface Configuration Guide』の「Configuring Serial Interfaces」および『Cisco IOS Interface Command Reference』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_c/index.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_r/index.htm

ネットワーク管理

サポートされるネットワーク管理機能は、次のとおりです。

ローカル ループバック

ネットワーク ループバック

NetFlow データ エクスポート

一定のタイミングで収集するパフォーマンス統計情報(RFC 1595)

DS-3 サポート

サポートされる DS-3 機能は、次のとおりです。

フレーム同期制御、C ビットまたは M23

ローカル(内部)クロック モード

ループバック モード

各 DS-3 チャネルの Bit Error Rate Test(BERT; ビット エラー レート テスト)診断

送受信アラーム処理

パフォーマンスおよびエラー カウンタ

Far-End Alarm and Control(FEAC)サポート

DSU モード

サポートされる Data Service Unit(DSU; データ サービス ユニット)モードは、次のとおりです。

Digital Link

Verilink

Adtran

Larscom

Kentrox

QoS プロトコル

チャネライズド OSM に設定する Quality of Service(QoS; サービス品質)については、「OSM 上での QoS の設定」を参照してください。

チャネライズド OSM では次の QoS 機能がサポートされます。

LAN および WAN ポート上の Policy Feature Card 2(PFC2; ポリシー フィーチャ カード 2)QoS

Differentiated Services Control Point(DSCP)

IP precedence 分類

クラスに基づくマーキングの設定については、次の URL にアクセスし、『Class-Based Marking』フィーチャ モジュールを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/cbpmark2.htm

分類およびプライオリティのマーキングは、下記に基づいて行われます。

Ethertype

IP Source Address(SA; 送信元アドレス)

IP Destination Address(DA; 宛先アドレス)

TCP ポート番号

UDP ポート番号

IP SA + TCP/UDP ポート番号+ IP DA + TCP/UDP ポート番号

WAN ポート上の Class-Based Weighted Fair Queuing(CBWFQ; クラスベース均等化キューイング)

WAN ポート上の Low Latency Queuing(LLQ; 低遅延キューイング)

フレームリレー、HDLC、および PPP のカプセル化の階層型トラフィック シェーピング

Cisco IOS の分類、マーキング、およびキューイングに関する一般情報については、次の URL にアクセスし、『Cisco IOS Quality of Service Solutions Configuration Guide』 Release 12.1 の「Classification」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_c/index.htm

プラットフォームに依存しない Cisco IOS QoS コマンドについては、次の URL にアクセスし、『Cisco IOS Quality of Service Solutions Command Reference』 Release 12.1 を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_r/index.htm

チャネライズド モジュールの設定

ここでは、チャネライズド モジュールの設定方法について説明します。

「SONET コントローラの設定」

「POS インターフェイスの設定」

「DS-3 シリアル インターフェイスの設定」

「SDH フレーム同期と AU-3 マッピングによるインターフェイスの設定」

「SDH フレーム同期と AU-4 マッピングによるインターフェイスの設定」

「APS の設定」

「フレームリレーおよびフレームリレー トラフィック シェーピングの設定」

「設定例」

SONET コントローラの設定

SONET コントローラの設定手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# controller sonet slot/port

ポートを選択して、コントローラ コンフィギュレーション モードを開始します。

ステップ 3

Router(config-controller)# [ no ] framing { sonet | sdh }

ChOC-12 のフレーム同期モードを SONET または SDH に設定します。

SDH は、SONET と同等の ITU 規格です。

SONET がデフォルト値です。

ステップ 4

Router(config-controller)#

sts-1 {sts-1 number} serial {T3 | E3}

sts-1 {start sts-1 number} - {end sts-1 number} pos

au-3 {au-3 number} serial {T3 | E3}

au-3 {start au-3 number} - {end au-3 number} pos

au-4 {start-au4-number} vc-3 {vc3-number} serial [ t3 | e3 ]

au-4 {start-au4-number} - {end-au4-number} pos

インターフェイスに対応するチャネルを設定します。ニーズに適合するチャネル プロビジョニング コマンド オプションを選択します。

ステップ 5

Router(config-controller)# clock source { internal [primary | secondary] | line [primary | secondary] }

SONET コントローラが使用するクロック ソースを設定します。

internal ― ポートアダプタ ラインからクロックソースを取得します。

line ― ネットワークからクロックソースを取得します。

primary ― 内部回路に優先順位の最も高いクロックを提供します。

secondary ― プライマリ クロックの障害時に内部回路にセカンダリ クロックを提供します。ネットワークをクロックソースとするのがデフォルトの設定です。

ステップ 6

Router(config-controller)# [ no ] loopback { internal | line }

SONET コントローラ上でループバック モードをイネーブルまたはディセーブルにします。

internal ― 送信パスから受信パスにデータがループされるので、外部接続に依存しないで、内部でデータを送信して診断できます。

line ― 外部ポートから送信ポートにデータがループされ、外部ポートへ再び送出されます。

ループバックはディセーブルがデフォルトの設定です。

ステップ 7

Router(config-controller)# alarm-report {all | b1-tca | b2-tca | b3-tca | lais | lrdi | pplm | ptim | sd-ber | sf-ber | slof | slos}

(任意)アラーム レポートをイネーブルにします。

ステップ 8

Router(config-controller)# threshold {b1-tca value | b2-tca value| b3-tca value| sd-ber value| sf-ber value}

(任意)BER(ビット エラー レート)のスレッシュホールド値を設定します。

ステップ 9

Router(config-controller)# [ no ] description string

(任意)SONET コントローラについて記述する最大 80 文字のテキストを指定します。記述なしがデフォルトの設定です。

POS インターフェイスの設定

コントローラの設定を確認したあとで、Packet over SONET(POS)インターフェイスを設定できます。ここで紹介するのは基本的な設定手順です。ネットワークの要件に応じて、他のインターフェイス パラメータを指定しなければならない場合があります。

POS インターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# interface POS slot/port :channel#

設定するシリアル ポートおよびチャネルを指定します。

ステップ 3

Router(config-if)# encapsulation hdlc | ppp

カプセル化タイプを指定します。

ステップ 4

Router(config-if)# pos flag j1 expect message rxpathmessagetext | length [16|64] | message txpathmessagetext

(任意)チャネライズド インターフェイスのパス メッセージを指定します。

ステップ 5

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

ステップ 6

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

DS-3 シリアル インターフェイスの設定

コントローラの設定を確認してから、対応する DS-3 チャネルとシリアル インターフェイスをコントローラ上に設定できます。


) T3 インターフェイスを VeriLink DSU に接続する場合、T3 インターフェイスでサポートされる最低帯域幅は 6,316 Kbps です。帯域幅は、6,316 Kbps から最大 44,210 Kbps までの整数倍でなくてはなりません。


DS-3 インターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# interface serial slot/port :channel#

設定するシリアル ポートおよびチャネルを指定します。

ステップ 3

Router(config-if)# framing {c-bit | m23}

フレーム同期を指定します。

ステップ 4

Router(config-if)# [ no ] dsu mode {0-4}

DSU モードを指定します。

0 ― Digital-Link

1 ― Kentrox

2 ― Larscom

3 ― Adtran

4 ― Verilink

ステップ 5

Router(config-if)# [ no ] dsu remote [accept | fullrate]

ローカル(近端)インターフェイスがリモート(遠端)インターフェイスからの着信要求を受け付けるかどうか、またはローカル インターフェイスからリモート インターフェイスに対してフルレートの帯域幅設定を要求するかどうかを指定します。

ステップ 6

Router(config-if)# [ no ] dsu bandwidth Kilobits/sec

DSU サブレート帯域幅を設定します。

ステップ 7

Router(config-if)# [no] scramble

ペイロード スクランブリングをイネーブルにします。

ステップ 8

Router(config-if)# [ no ] loopback { local | network | remote }

ループバック モードを設定します。

ステップ 9

Router(config-if)# [ no ] bert pattern [ 2^15 | 2^20 ] interval [ 1-1440 ]

(任意)BERT を設定します。

ステップ 10

Router(config-if)# alarm-report {all | b3-tca | pais | pplm | plop | prdi | ptim | ptiu | puneq}

(任意)パス アラーム レポートをイネーブルにします。

ステップ 11

Router(config-if)# overhead {c2 byte value | j1 {expect message message-string | length 16-64 |

message message-string}

SONET パス ヘッダー バイトの値を指定します。

ステップ 12

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

ステップ 13

Router(config-if)# [ no ] keepalive

キープアライブ メッセージをオンまたはオフにします。

ステップ 14

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

次に、非チャネライズド DS-3 インターフェイス設定の例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# controller t3 3/0
Router (config-controller)#no channelized
Router (config-controller)# exit
Router (config)# interface serial 1/0
Router (config-if)# dsu bandwidth 16000
Router (config-if)# encapsulation frame-relay
Router (config-if)# ip address 10.10.10.10.255.255.255.255
Router (config-if)# no shutdown
Router (config-if)# exit
Router(config)#

SDH フレーム同期と AU-3 マッピングによるインターフェイスの設定

ここでは、SDH フレーム同期と AU-3 マッピングによりインターフェイスをイネーブルにする方法、および OSM-1CHO12/T3-SI チャネライズド モジュールでの IP ルーティングの指定方法を説明します。SDH フレーム同期と AU-3 マッピングによりインターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# controller sonet slot/port

コントローラを選択します。

ステップ 3

Router(config-controller)# framing sdh

フレーム同期を指定します。

ステップ 4

Router(config-controller)# aug mapping au-3

AUG マッピングを指定します。

ステップ 5

Router(config-controller)# au-3 au-3 number serial {T3 | E3}

AU-3 チャネルを設定します。

ステップ 6

Router(config-controller)# exit

コントローラ コンフィギュレーション モードを終了します。

ステップ 7

Router(config)# interface serial slot/port:au-3 number

インターフェイスを選択します。

ステップ 8

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

ステップ 9

Router(config-if)# [ no ] shutdown

インターフェイスをイネーブルにします。

この例では、ポートは 12 E3 インターフェイスとして設定されます。


) E3 インターフェイスを Digital Link DL3100E E3 アクセス多重化 DSU に接続する場合、Digital Link DSU 上で「クリア チャネル」モードを使用する必要があります。E3 インターフェイスを Cisco 12000 シリーズ 12 ポート Packet over E3 ライン カードに接続する場合、Cisco 12000 シリーズ 12 ポート Packet over E3 ライン カード上で dsu mode kentrox を設定する必要があります。E3 インターフェイスを Cisco C7500 または Cisco C7200 E3 ポート アダプタ(PA)に接続する場合は、E3 PA 上の E3 インターフェイスで dsu mode 1 を設定する必要があります。



ステップ 1 configure terminal EXEC コマンドを入力して、次のようにグローバル コンフィギュレーション モードを開始します。

router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

ステップ 2 E3 チャネルを設定します。

router(config)# controller sonet 4/1
router(config-controller)# framing sdh
router(config-controller)# overhead s1s0 2
router(config-controller)# aug mapping au-3
router(config-controller)# au-3 1 serial e3
router(config-controller)# au-3 2 serial e3
router(config-controller)# au-3 3 serial e3
router(config-controller)# au-3 4 serial e3
router(config-controller)# au-3 5 serial e3
router(config-controller)# au-3 6 serial e3
router(config-controller)# au-3 7 serial e3
router(config-controller)# au-3 8 serial e3
router(config-controller)# au-3 9 serial e3
router(config-controller)# au-3 10 serial e3
router(config-controller)# au-3 11 serial e3
router(config-controller)# au-3 12 serial e3
 

ステップ 3 E3 インターフェイスを設定します。

Router(config)# interface serial 5/2:1
Router(config-if)# ip address 10.2.1.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:2
Router(config-if)# ip address 10.2.2.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:3
Router(config-if)# ip address 10.2.3.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:4
Router(config-if)# ip address 10.2.4.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:5
Router(config-if)# ip address 10.2.5.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:6
Router(config-if)# ip address 10.2.6.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:7
Router(config-if)# ip address 10.2.7.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:8
Router(config-if)# ip address 10.2.8.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:9
Router(config-if)# ip address 10.2.9.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:10
Router(config-if)# ip address 10.2.10.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:11
Router(config-if)# ip address 10.2.11.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:12
Router(config-if)# ip address 10.2.12.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
 

ステップ 4 copy running-config startup-config コマンドを使用して、NVRAM(不揮発性 RAM)に新しい設定を書き込みます。

router# copy running-config startup-config
[OK]
router#
 


 

SDH フレーム同期と AU-4 マッピングによるインターフェイスの設定

ここでは、SDH フレーム同期と AU-4 マッピングによりインターフェイスをイネーブルにする方法、および OSM-1CHO12/T3-SI チャネライズド モジュールでの IP ルーティングの指定方法を説明します。この例では、ポートは 12 E3 インターフェイスとして設定されます。

 

コマンド
説明

ステップ 1

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 2

Router(config)# controller sonet slot/port

コントローラを選択します。

ステップ 3

Router(config-controller)# framing sdh

フレーム同期を指定します。

ステップ 4

Router(config-controller)# aug mapping au-4

AUG マッピングを指定します。

ステップ 5

Router(config-controller)#
au-4 start-au4-number vc-3 VC3-number serial [ t3 | e3 ]

au-4 start-au4-number - end-au4-number pos

チャネルを設定し、インターフェイス番号を定義します。

ステップ 6

Router(config-controller)# exit

コントローラ コンフィギュレーション モードを終了します。

ステップ 7

Router(config)# interface serial slot/port. au-4:au-3

インターフェイスを選択します。

ステップ 8

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

ステップ 9

Router(config-if)# [ no ] shutdown

インターフェイスをイネーブルにします。

この例では、1 つの STM-4 POS インターフェイス、2 つの STM-1 インターフェイス、および 2 つの DS-3 シリアル インターフェイスを設定するために AU-4 マッピングが使用されています。slot/port. au-4:au-3 から、DS-3 インターフェイス名が作成されます。1 ~ 3 の範囲の VC-3 番号は、選択された AU-4 中の TUG-3(または VC-3)番号です。

STM-4 インターフェイス名は最初の AU-4 番号から作成されます。


ステップ 1 configure terminal EXEC コマンドを入力して、次のようにグローバル コンフィギュレーション モードを開始します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
 

ステップ 2 チャネルを設定します。

Router(config)# controller sonet 5/1
Router(config-controller)# framing sdh
Router(config-controller)# aug mapping au-4
Router(config-controller)# au-4 1-4 pos
Router(config-controller)# au-4 5 pos
Router(config-controller)# au-4 6 vc-3 1 serial t3
Router(config-controller)# au-4 6 vc-3 2 serial t3
Router(config-controller)# au-4 7 pos
Router(config-controller)# end
 

ステップ 3 インターフェイスを設定します。

Router(config)# interface pos 5/1:1
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.10 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface pos 5/1:5
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.11 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface serial 5/1.6:1
Router(config_if)# framing c-bit
Router(config-if)# dsu mode 0
Router(config-if)# dsu remote accept
Router(config-if)# dsu bandwidth 30000
Router(config-if)# scramble
Router(config-if)# loopback remote
Router(config-if)# ip address 10.10.10.12. 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface serial 5/1.6:2
Router(config_if)# framing c-bit
Router(config-if)# dsu mode 0
Router(config-if)# dsu remote accept
Router(config-if)# dsu bandwidth 45000
Router(config-if)# scramble
Router(config-if)# loopback remote
Router(config-if)# ip address 10.10.10.12. 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface pos 5/1:7
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.13 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
 

ステップ 4 copy running-config startup-config コマンドを使用して、NVRAM に新しい設定を書き込みます。

Router# copy running-config startup-config
[OK]
Router#


 

APS の設定

APS により、POS 回線の切り替えが可能です。これは、通常 SONET 装置を電気通信装置に接続する場合に必要になります。APS を設定すると、介在する SONET 装置から SONET ネットワークに保護 POS インターフェイスが提供され、回線上で保護 POS インターフェイスが実行 POS インターフェイスになります。


) OSM-1CHO12/T3-SI では、APS は、インターフェイス レベルではなく SONET コントローラ レベルで設定されることに注意してください。


保護インターフェイスは、実行インターフェイスのあるルータの IP アドレスを指定して設定します。APS Protect Group Protocol が、実行インターフェイスを制御するプロセスと保護インターフェイスを制御するプロセス間の通信を引き受けます。APS Protect Group Protocol を使用すると、ルータ障害、チャネル信号の劣化または損失、または手動介入が発生した場合に、POS インターフェイスを切り替えることができます。

APS のサポートには、SONET 接続が 2 つ必要です。電気通信環境では、SONET 回線を APS として設定する必要があります。オペレーション、モード、および復帰オプションを設定することも必要です。SONET 接続が別々の 2 台のルータでホーミングされる場合(標準設定)、APS 通信用として、2 台のルータ間に Out-Of-Band(OOB; 帯域外)通信チャネルを設定する必要があります。

APS を設定する場合は、先に実行インターフェイスを設定し、さらに APS OOB 通信パスとして使用するインターフェイスの IP アドレスを指定することを推奨します。


) 保護インターフェイスがアクティブ回線になり、現用回線が検出時にディセーブルにされることがないように、実行インターフェイスを設定してから保護インターフェイスを設定します。


APS の詳細については、次の URL にアクセスし、『Cisco IOS Interface Configuration Guide』 Release 12.1 を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_c/index.htm

実行インターフェイスの設定

実行インターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router(config)# controller sonet slot/port

config プロンプトから、SONET コントローラ コンフィギュレーション モードを開始します。

ステップ 2

Router(config-controller)# aps working circuit-number

このインターフェイスを実行インターフェイスとして設定します。

ステップ 3

Router(config-controller)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# s how aps

Router# s how aps controller

コントローラ情報を表示して、コンフィギュレーションを確認します。


) ルータに複数の保護インターフェイスが設定されている場合、各インターフェイスに aps group コマンドを設定してから、対応する aps protect コマンドを設定する必要があります。


保護インターフェイスの設定

保護インターフェイスを設定するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config)# controller sonet slot/port

config プロンプトから、SONET コントローラ コンフィギュレーション モードを開始します。

ステップ 2

Router(config-controller)# aps protect circuit-number ip-address

このインターフェイスを保護インターフェイスとして設定します。実行インターフェイスのあるルータの IP アドレスを指定します。

ステップ 3

Router(config-controller)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# s how aps

Router# s how aps controller

コントローラ情報を表示して、コンフィギュレーションを確認します。

フレームリレーおよびフレームリレー トラフィック シェーピングの設定

ここでは、フレームリレーの設定、プラットフォーム固有のコマンドおよび制限事項について説明します。

「フレームリレーの制限および制約」

「フレームリレー トラフィック シェーピングの設定例」

フレームリレー対応のチャネライズド インターフェイスの設定については、次の URL にアクセスし、『Cisco IOS Wide-Area Networking Configuration Guide』 Release 12.1 の「Configuring Frame Relay」および『Cisco IOS Wide-Area Networking Command Reference』 Release 12.1 を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdfrely.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wrdfrely.htm

フレームリレーのトラフィック シェーピングの設定については、次の URL にアクセスし、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Configuring Distributed Traffic Shaping」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt4/qcfdts.htm

フレームリレーの制限および制約

次の制限および制約がフレームリレーに適用されます。

フレームリレーは SVC 上ではサポートされません。

フレームリレー用に設定したメイン インターフェイスに IP アドレスを割り当てることはできません。

フレームリレーがサポートされるのはポイントツーポイント接続だけです。

フレームリレー スイッチング機能はサポートされません。フレームリレー スイッチングを設定できるのは、frame-relay intf-type dce オプションの設定時に限定されます。

フレームリレーのフラグメンテーションおよび圧縮はサポートされません。

Data Link Connection Identifier(DLCI)の Forward Explicit Congestion Notification(FECN; 前方明示的輻輳通知)および Backward Explicit Congestion Notification(BECN; 逆方向明示的輻輳通知)統計はサポートされません。

First-in first-out(FIFO; 先入れ先出し)キューイングだけがサポートされます。

DLCI を設定できるのはサブインターフェイスだけです。メイン インターフェイスには設定できません。

各シャーシに設定できる DLCI の最大数は 300 です。

クラスベースのトラフィック シェーピングだけがサポートされます。次のコマンドはサポートされていません。

Router(config-pmap-c)# shape [average | peak] mean-rate [[burst-size] [excess-burst-size]]

Router(config-pmap-c)# priority {kbps | percent percent} [bytes]

Router(config-pmap-c)# fair-queue number-of-queues

Router(config-map-class)# frame-relay adaptive-shaping [becn | foresight]1

Router(config-map-class)# frame-relay cir {in | out} bps

Router(config-map-class)# frame-relay {bc | be} {in | out} bits

Router(config-map-class)# frame-relay traffic-rate average [peak]

Router(config-map-class)# frame-relay priority-group list-number

Router(config-map-class)# frame-relay fragment fragment_size

Router(config-if)# frame-relay payload-compress packet-by-packet

Router(config-if)# frame-relay de-group group-number dlci

Router# show traffic-shape queue

フレームリレー トラフィック シェーピングの設定例

 

コマンド
説明

ステップ 1

Router(config-pmap)# class-map [match-all | match-any]

定義したクラスに対してパケットを照合するためのクラス マップを作成し、一致条件を指定します。クラスの一致条件は、IP DSCP または IP precedence を基準にすることができます。

ステップ 2

Router(config-pmap)# match

一致条件を指定します。

ステップ 3

Router(config)# policy-map policy_map

1 つまたは複数のインターフェイスに適用できるポリシー マップを作成または変更し、サービス ポリシーを指定します。

ステップ 4

Router(config-pmap)# class class-name

サービス ポリシーに含めるクラスを定義します。

ステップ 5

Router(config-pmap-c)#shape average mean-rate [burst-size]

指定されたビット レートに合わせてトラフィックをシェーピングします。

ステップ 6

Router(config)# map-class frame-relay map-class-name

マップ クラスを指定し、QoS の値を定義します。

ステップ 7

Router(config-map-class)# no frame-relay adaptive-shaping

バックワードの通知をディセーブルにします。

ステップ 8

Router(config-map-class)# service-policy input policy-map

指定したポリシー マップを、入力インターフェイスに適用します。

ステップ 9

Router(config-map-class)# service-policy output policy-map

指定したポリシー マップを、出力インターフェイスに適用します。

ステップ 10

Router(config)#interface interface

ポリシー マップの適用先インターフェイスを指定します。

ステップ 11

Router(config-subif)# ip address ip_address mask

サブインターフェイスに IP アドレスを割り当てます。

ステップ 12

Router(config-subif)# no cdp enable

CDP をディセーブルにします。

ステップ 13

Router(config-subif)# frame-relay interface-dlci dlci

指定したフレームリレー サブインターフェイスに、DLCI を割り当てます。

ステップ 14

Router(config-fr-dlci)# class class-name

map-class frame-relay コマンドで定義したマップ クラス名を指定します。

サブインターフェイスの CDP は、明示的にディセーブルに設定することを推奨します。サブインターフェイスで CDP を使用する場合は、入力キューの深度を調整しなければならないことがあります。着信 CDP パケット数に対応させるには、メイン インターフェイスの入力キュー深度を、CDP をイネーブルにしたサブインターフェイス数よりも、わずかに大きく設定します。デフォルトの入力キュー深度は 75 です。この値は、次に示す hold-queue インターフェイス コマンドで変更できます。

Router(config-if)#hold-queue 300 in
 

次に、サブインターフェイス 6/1:1.1 または 6/1:1.2 から送出されるトラフィックを 1 Mbps にシェーピングする例を示します。

Router(config)# class-map class-p2p-all
Router(config-cmap)# match any
Router(config-cmap)# exit
Router(config)# policy-map dts-p2p-all-action
Router(config-pmap)# class class-p2p-all
Router(config-pmap-c)# shape average 1000000
Router(config-pmap-c)# exit
Router(config)# interface Serial6/1:1.1 point-to-point
Router(config-subif)# service-policy output dts-p2p-all-action
Router(config-subif)# exit
Router(config)# interface serial6/1:1.2 point-to-point
Router(config-subif)# service-policy output dts-p2p-all-action
 

次の例では、DLCI ごとのトラフィック設定を示します。

Router(config)# class-map match-all fr-classmap

Router(config-cmap)# match any

Router(config-cmap)# exit
Router(config)# policy-map fr-pmap
Router(config-pmap)# class fr-classmap
Router(config-pmap-c)# shape average 8000000 32000 32000
Router(config-pmap-c)# exit
Router(config)# interface Serial6/1:1.1 point-to-point
Router(config-subif)# ip address 72.0.0.1 255.255.0.0
Router(config-subif)# mls qos trust dscp
Router(config-subif)# frame-relay interface-dlci 18
Router(config-fr-dlci)# class fr-shaping
Router(config-fr-dlci)# exit
Router(config)# map-class frame-relay fr-shaping
Router(config-map-class)# no frame-relay adaptive-shaping
Router(config-map-class)# service-policy input fr-pmap
Router(config-map-class)# service-policy output fr-pmap

チャネライズド POS の設定

次に、チャネライズド POS の設定例を示します。STS-1 番号は、OC-12 フレーム内の論理 STS-1 パスで、1 ~ 12 の範囲になります。OC-3 チャネルでは、STS-1 番号は OC-3 境界を越えることができません。たとえば、sts-1 1-6 は、不正な設定です。

チャネライズド POS として設定してから、各 POS インターフェイスを適切に設定します。


ステップ 1 SONET コントローラを設定します。

Router(config)# controller sonet 2/1
 

ステップ 2 チャネルを設定します。

Router(config-controller)# sts-1 1-3 pos
Router(config-controller)# sts-1 13-15 pos
Router(config-controller)# sts-1 16-18 pos
Router(config-controller)# exit
 

ステップ 3 POS インターフェイスを設定します。

Router(config)# interface pos 2/1:13
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.10 255.255.255.0
Router(config-if)# end
 


 

チャネライズド DS-3 の設定

次に、チャネライズド DS-3 の設定例を示します。


ステップ 1 SONET コントローラを設定します。

Router(config)# controller sonet 2/1
 

ステップ 2 チャネルを設定します。

Router(config-controller)# sts-1 4 serial t3
Router(config-controller)# exit
 

ステップ 3 シリアル インターフェイスを設定します。

Router(config)# interface serial 2/1:4
Router(config-if)# framing c-bit
Router(config-if)# dsu mode 0
Router(config-if)# dsu remote accept
Router(config-if)# dsu bandwidth 30000
Router(config-if)# scramble
Router(config-if)# loopback remote
Router(config-if)# ip address 10.1.1.1. 255.255.255.0
Router(config-if)# end
 


 

基本的な APS の設定

ルータ A とルータ B 上で APS を設定する例を示します(図5-3 を参照)。この例では、ルータ A に実行インターフェイスを設定し、ルータ B に保護インターフェイスを設定します。ルータ A の実行インターフェイスが使用できなくなると、ルータ B 上の保護インターフェイスに接続が自動的に切り替えられます。実行インターフェイスと保護インターフェイスは、コントローラ レベルで設定します。

図5-3 基本的な APS の構成

 


ステップ 1 実行インターフェイスのあるルータ A の設定は、次のとおりです。

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.7 255.255.255.0
Router(config)# controller sonet 7/1
Router(config-controller)# aps working 1
Router(config-controller)# end
Router#
 

ステップ 2 保護インターフェイスのあるルータ B の設定は、次のとおりです。

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.6 255.255.255.0
Router(config-controller)# controller sonet 3/1
Router(config-controller)# aps protect 1 7.7.7.7
Router(config-controller)# end
Router#
 


 

複数 APS インターフェイスの構成

複数の保護/実行インターフェイスを設定する場合は、 aps group コマンドを使用します。図5-4 に、複数の実行/保護インターフェイスをグループ分けして設定する例を示します。この例では、実行インターフェイスと保護インターフェイスを指定してルータ A を設定し、ルータ B も実行インターフェイスと保護インターフェイスを指定して設定します。ルータ A の実行インターフェイス 2/0 が使用できなくなると、ルータ B の保護インターフェイス 3/0 に接続が切り替えられます。これはどちらも APS グループ 10 に属しているためです。ルータ B の実行インターフェイス 2/0 が使用できなくなった場合も同様です。接続は同じ APS グループ 20 に属しているため、ルータ A の保護インターフェイス 3/0 に切り替えられます。

図5-4 複数の実行/保護インターフェイスの構成

 


) 保護インターフェイスがアクティブ回線になり、現用回線が検出時にディセーブルにされることがないように、実行インターフェイスを設定してから保護インターフェイスを設定してください。



ステップ 1 ルータ A では次のように設定し、グループ 10 用の実行インターフェイスとグループ 20 用の保護インターフェイスを指定します。

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.6 255.255.255.0
Router(config-if)# exit
Router(config)# controller sonet 7/1
Router(config-controller)# aps group 10
Router(config-controller)# aps working 1
Router(config-controller)# exit
Router(config)# contoller sonet 3/0
Router(config-controller)# aps group 20
Router(config-controller)# aps protect 1 7.7.7.7
Router(config-controller)# end
Router#
 

ステップ 2 ルータ B では次のように設定し、グループ 10 用の保護インターフェイスとグループ 20 用の実行インターフェイスを指定します。

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.7 255.255.255.0
Router(config-if)# exit
Router(config)# controller sonet 2/0
Router(config-controller)# aps group 20
Router(config-controller)# aps working 1
Router(config-controller)# exit
Router(config)# controller sonet 3/0
Router(config-controller)# aps group 10
Router(config-controller)# aps protect 1 7.7.7.6
Router(config-controllers)# end
Router#