オプティカル サービス モジュール ソフトウェア コンフィギュレーション ノート Cisco IOS Release 12.2SX
4 ポート ギガビット イーサネット WAN OSM の設定
4 ポート ギガビット イーサネット WAN OSM の設定
発行日;2012/01/15 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

4 ポート ギガビット イーサネット WAN OSM の設定

サポート対象の機能

OSM-4GE-WAN-GBIC から OSM-2+4GE-WAN+ へのアップグレード前の設定保存

ギガビット イーサネット WAN ポートの設定

インターフェイスの基本設定

OSM-2+4GE-WAN+ での完全優先 LLQ サポートの設定

QoS

アドバンスト QinQ サービス マッピング

QinQ 変換 ― ダブル タグ/シングル タグ変換

QinQ トランスペアレント トンネリング(ダブル タグ/ダブル タグ変換)

範囲外パケットと範囲内未指定パケット

アドバンスト QinQ サービス マッピングの VLAN 単位のロード バランシング

アドバンスト QinQ サービス マッピングの設定

ギガビット イーサネット WAN インターフェイス上での QinQ 変換のイネーブル化

前提条件

制約

QinQ リンク バンドル上での QinQ 変換のイネーブル化

前提条件

制約

サービス プロバイダー エッジ ルータの設定

前提条件

QinQ 変換の設定 ― ダブル タグ/シングル タグ変換

前提条件

制約

QinQ トランスペアレント トンネリング(ダブル タグ/ダブル タグ変換)の設定

前提条件

制約

ポリシー マップでの内部 CoS ビット使用の設定

前提条件

制約

QinQ マッピングおよび変換のディセーブル化

アドバンスト QinQ サービス マッピングの設定例

QinQ 変換(2 つのタグから 1 つのタグへの変換)の設定例

QinQ トランスペアレント トンネリングの設定例

ポートチャネル インターフェイスを使用する QinQ 変換例

4 ポート ギガビット イーサネット WAN OSM の設定

この章では、Catalyst 6500 シリーズ スイッチおよび Cisco 7600 シリーズ ルータ上でサポートされる 4 ポート ギガビット イーサネット WAN OSM(オプティカル サービス モジュール)(OSM-2+4GE-WAN+ および OSM-4GE-WAN-GBIC)の機能について説明します。

この章の内容は次のとおりです。

「サポート対象の機能」

「OSM-4GE-WAN-GBIC から OSM-2+4GE-WAN+ へのアップグレード前の設定保存」

「ギガビット イーサネット WAN ポートの設定」

「QoS」

「アドバンスト QinQ サービス マッピング」

サポート対象の機能

ギガビット イーサネット WAN OSM では、次のレイヤ 3 機能がサポートされます。

分散 IP サービスの転送

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)

Ethernet over Multiprotocol Label Switching(EoMPLS)

Frame Relay over MPLS

ATM Cell Relay over MPLS VC モード

ATM AAL5 over MPLS

IOS Modular QoS Command Line Interface(MQC; モジュラ QoS コマンドライン インターフェイス)QoS(サービス品質)

フロー制御

802.1Q VLAN(仮想 LAN)トランキング

アドバンスト 802.1Q/802.1Q(QinQ)サービス マッピング

Hot Standby Routing Protocol(HSRP)

ジャンボ フレーム

ポートあたり最大 32,000 の MAC アドレスのサポート

最大 32,000 の同時 Access Control List(ACL; アクセス制御リスト)エントリのサポート

最大 32,000 の同時 QoS エントリのサポート

SNMP(簡易ネットワーク管理プロトコル)I および II

ポートあたり 4 つの RMON グループ(統計情報、履歴、アラーム、イベント)

Online Insertion and Removal(OIR; ホットスワップ)

ISL(スイッチ間リンク)


) OSM-2+4GE-WAN+ モジュールはレイヤ 2 ギガビット イーサネット LAN ポートの ISL はサポートしますが、レイヤ 3 ギガビット イーサネット WAN ポートの ISL はサポートしません。


OSM のレイヤ 2 ギガビット イーサネット ポートは、Cisco Catalyst 6500 シリーズ スイッチまたは Cisco 7600 シリーズ ルータのスーパーバイザ エンジンから設定されます。OSM のレイヤ 2 ギガビット イーサネット ポートの機能サポートおよび設定情報については、「レイヤ 2 ソフトウェア機能」 のリンクを参照してください。

OSM-4GE-WAN-GBIC から OSM-2+4GE-WAN+ へのアップグレード前の設定保存

OSM-4GE-WAN-GBIC から OSM-2+4GE-WAN+ にアップグレードする場合、既存の設定は保存されず、新しい OSM-2+4GE-WAN+ に適用されません。

OSM-4GE-WAN-GBIC から OSM-2+4GE-WAN+ へアップグレードする場合の既存の設定を保存する手順は、次のとおりです。


ステップ 1 write memory コマンドを入力してから、OSM-4GE-WAN-GBIC を取り外します。

ステップ 2 新しい OSM-2+4GE-WAN+ を取り付けます。

ステップ 3 copy startup-config running-config コマンドを入力します。

ステップ 4 write memory コマンドを入力します。


警告 OSM-4GE-WAN-GBIC ポート内での GBIC(ギガビット インターフェイス コンバータ)の向きは、OSM-2+4GE-WAN+ の LAN ポートの GBIC の向きとは逆です(上下逆)。



 

ギガビット イーサネット WAN ポートの設定

4 ポート ギガビット イーサネット WAN OSM 上の 4 つのギガビット イーサネット WAN ポートは、Cisco IOS ソフトウェアによって制御され、あらゆる標準 Cisco IOS 機能をサポートします。標準 Cisco IOS 機能および GE-WAN ポートでサポートされるルーティング プロトコルの設定については、次の URL にアクセスし、該当する Cisco IOS コンフィギュレーション ガイドおよびコマンドリファレンスを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/index.htm

インターフェイスの基本設定

4 ポート ギガビット イーサネット WAN OSM が正しく搭載されていることを確認してから、 configure コマンドを使用して、ギガビット イーサネット WAN インターフェイスを設定します。

次に、基本的な設定の手順を示します。この手順ではインターフェイスをイネーブルにして、IP ルーティングを指定します。システム コンフィギュレーションの要件に応じて、他のコンフィギュレーション サブコマンドの入力が必要になることがあります。


) 4 ポート ギガビット イーサネット WAN モジュール上のサブインターフェイスは HSRP グループ番号を共有できません。その結果、ギガビット イーサネット WAN ポート当たり 16 の HSRP グループのみがサポートされます。



) メイン ギガビット イーサネット WAN インターフェイスに指定した Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズは、メイン インターフェイス上に設定したすべてのサブインターフェイスに適用されます。メイン インターフェイスに指定した MTU サイズと異なる MTU サイズを、サブインターフェイスに指定することはできません。


ギガビット イーサネット WAN インターフェイスを設定する手順は、次のとおりです。


ステップ 1 show version コマンドを入力し、システムがモジュールを認識していることを確認します。

Router# show version
 

ステップ 2 show interface コマンドを入力し、各ポートのステータスを調べます。

Router# show interface
 

ステップ 3 コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

Router# configure terminal
 

ステップ 4 ip routing コマンドを入力し、IP ルーティングをイネーブルにします。

Router(config)# ip routing
 

ステップ 5 プロンプトに、 interface コマンドに続けて type ge-wan ) および slot/port 番号を入力することによって、新しく設定するインターフェイスを指定します。次に、スロット 3 にギガビット イーサネット WAN OSM が搭載されている場合の例を示します。

Router(config)# interface ge-wan 3/0
 

ステップ 6 次の例のように、 ip address コンフィギュレーション サブコマンドを使用して、IP アドレスとサブネットマスクをインターフェイスに割り当てます。

Router(config-if)# ip address 10.1.2.3 255.255.255.255
 

デフォルトでは、デュプレックス、速度、フロー制御など、GE-WAN インターフェイスのリンク パラメータの自動ネゴシエーションが設定されます。フロー制御をディセーブルにしてインターフェイスを強制的に 1000/全二重モードにするには、コマンドで自動ネゴシエーションをオフにします。

Router(config-if)# no negotiation auto

) アクティブなインターフェイスのネゴシエーション モードを変更すると、新しいネゴシエーション モードが開始できるよう、インターフェイスが停止してフラップされ、バックアップされます。このため、ネゴシエーション モードの変更は、インターフェイスのシャットダウン時以外は行わないことを推奨します。



ヒント リンク パラメータの自動ネゴシエーションをデフォルト設定に戻すには、negotiation auto コマンドを使用してください。


ステップ 7 シャットダウン ステートをアップに変更し、インターフェイスをイネーブルにします。

Router(config-if)# no shutdown
 

no shutdown コマンドによって、 enable コマンドがギガビット イーサネット モジュールに割り当てられます。また、受信した最新のコンフィギュレーション コマンドに基づいてモジュールの自動設定も行われます。

ステップ 8 新しい設定をメモリに書き込みます。

Router# copy running-config startup-config
 

設定が保存されると、OK メッセージが表示されます。


 

OSM-2+4GE-WAN+ での完全優先 LLQ サポートの設定

Cisco IOS Release 12.2(18)SXE 以降、Low Latency Queuing(LLQ; 低遅延キューイング)機能は OSM-2+4GE-WAN+ OSM 用に変更されます。この変更により、プライオリティ キュー ポリシングがモジュール上でサポートされるようになります。Hierarchical Queuing Framework(HQF)を使用することにより、 police コマンドが OSM 上のクラスの完全優先に結合されます。


) 以前のリリースでの priority percent % コマンドおよび priority kbps コマンドは、サポートされていません。

ポリシーに 2 番めに優先されるポリシング クラスが含まれる場合、まず police を設定する必要があります。


完全優先 LLQ サポートを設定するには、グローバル コンフィギュレーション モードを開始して、次の作業を実行します。

 

コマンドまたは操作
説明

ステップ 1

Router(config)# policy-map policy-name

 

Router(config)# policy-map policy11

作成または変更されるポリシー マップ名を指定します。

ステップ 2

Router(config-pmap)# class class-name

 

Router(config)# class class204

サービス ポリシーに含まれている定義済みクラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# priority

 

Router(config)# priority

完全優先クラスを設定します。

ステップ 4

Router(config-pmap-c)# police rate

 

Router(config-pmap-c) # police 1000000#

ポリシング レート(bps)を設定します。

次に、OSM-2+4GE-WAN+ OSM での一般的な設定例および確認例を示します。

!
Policy Map child
Class dscp-ef
priority
police cir 1000000 bc 31250 be 31250 conform-action transmit exceed-action drop
Class dscp-af21
bandwidth remaining 35 (%)
Class dscp-af31
bandwidth remaining 30 (%)
Class class-default
bandwidth remaining 25 (%)
!
Policy Map parent
Class vlan-2
bandwidth 5000 (kbps)
shape average 6000000 24000 24000
service-policy child
!
interface ge-wan7/1
no ip address
negotiation auto
mls qos trust dscp
service-policy output parent
end
!
interface ge-wan7/1.2
encapsulation dot1Q 2
ip address 10.10.10.1 255.255.255.0
mls qos trust dscp
no cdp enable
end
 

次に、設定を確認するコマンドを示します。

Router#show policy interface ge-wan7/1

 

GE-WAN7/1
 
Service-policy output:parent

 

Class-map:vlan-2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:vlan 2
Queueing
queue limit 1250 (packets)
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts queued/bytes queued) 0/0
bandwidth 5000 kbps
shape (average) cir 6000000, bc 24000, be 24000
target shape rate 6000000

(シェープ パラメータは、粒度により 5,952,000 bps に四捨五入されます。)

 
Service-policy :child
 
Class-map:dscp-ef (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:ip dscp ef
Priority:b/w exceed drops: 0
police:
cir 1000000 bps, bc 31250 bytes

(ポリシング Committed Information Rate [CIR; 認定情報速度]は、粒度により 983,040 bps に四捨五入されます。)

 
Class-map:dscp-af21 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:ip dscp af21
Queueing
queue limit 350 (packets)
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts queued/bytes queued) 0/0
bandwidth remaining 35% (1400 kbps)

(帯域幅パラメータは、粒度により 1,392 kbps に四捨五入されます。)

 
Class-map:dscp-af31 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:ip dscp af31
Queueing
queue limit 300 (packets)
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts queued/bytes queued) 0/0
bandwidth remaining 30% (1200 kbps)

(帯域幅パラメータは、粒度により 1,196 kbps に四捨五入されます。)

 
Class-map:class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:any
Queueing
queue limit 250 (packets)
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts queued/bytes queued) 0/0
bandwidth remaining 25% (1000 kbps)
 
Class-map:class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:any
queue limit 248750 (packets)
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts queued/bytes queued) 0/0
Router#

QoS

ギガビット イーサネット WAN モジュールは、次の QoS の実装をサポートします。

Differentiated Services Code Point(DSCP)分類

IP precedence 分類

クラスベース トラフィック シェーピング

Class-Based Weighted Fair Queuing(CBWFQ; クラスベース均等化キューイング) ― OSM-2+4GE-WAN+ でのみサポートされます。

LLQ ― OSM-2+4GE-WAN+ でのみサポートされます。

Weighted Random Early Detection(WRED; 重み付きランダム早期検出) ― OSM-2+4GE-WAN+ でのみサポートされます。

Dotlq カプセル化の階層型トラフィック シェーピング ― OSM-2+4GE-WAN+ のサブインターフェイス上の出力トラフィックでのみサポートされます

CBWFQ、LLQ、および WRED による EoMPLS サポート ― EoMPLS アップリンク インターフェイスに CBWFQ、LLQ、または WRED が適用されます。OSM-2+4GE-WAN+ でのみサポートされます。

WAN OSM ポートに対する QoS の設定情報および設定例については、「OSM 上の QoS の設定」 を参照してください。

設定については、 第10章「OSM 上での DSS の設定」 を参照してください。

アドバンスト QinQ サービス マッピング

IEEE 802.1Q VLAN 規格には、次のような 2 つの VLAN タグを使用してパケットにタグを付けるトランキング オプションが用意されています。

カスタマーのタグを指定する内部タグ

サービス プロバイダーのタグを指定する外部タグ(これにより、中間のネットワーク全体で複数の VLAN をまとめてトランキング可能)

このようなダブル タグ付きトンネルは、通常、IEEE 802.1Q-in-802.1Q(QinQ)トンネリングと呼ばれます。

しかし、標準の QinQ トンネリングには制限があります。ダブル タグ付き VLAN では異なるカスタマーを識別できますが、同一カスタマー向けの異なるサービス フローを区別するのは容易ではありません。各サービス フローには別々の VLAN を使用できますが、IEEE 802.1Q では VLAN は最大で 1,024 個に制限されています。拡張 VLAN ではルータあたり最大 4,096 個ですが、この数でさえ、多数のカスタマーが多数のサービスを使用した場合にはたちまち枯渇してしまいます。

アドバンスト QinQ サービス マッピング機能では、OSM-2+4GE-WAN+ OSM のギガビット イーサネット WAN(GE-WAN)インターフェイスをイネーブルにし、QinQ アクセス ゲートウェイとして機能させることによって、こうした問題を解決できます。このアクセス ゲートウェイは、内部および外部 VLAN タグの組み合わせを特定カスタマーのサービス フローの Unique Identifier(UID; 固有識別情報)として使用することによって、QinQ トンネリングを強化します。これによって、インターフェイスは次のような機能を実行できます。

Customer Edge(CE; カスタマー エッジ)および Provider Edge(PE; プロバイダー エッジ)VLAN タグの一意の組み合わせに基づいて、内部 CE VLAN タグと外部 PE VLAN タグでタグ付けされたパケットを指定の発信トランク VLAN に変換します。サポートされているパケット変換のタイプは次の 2 つです。

QinQ 変換(ダブル タグ/シングル タグ変換) ― 発信パケットが送信される際、元の着信パケットの CE および PE タグが単一のトランク VLAN タグに置き換えられます。

QinQ トランスペアレント トンネリング(ダブル タグ/ダブル タグ変換) ― 発信パケットが送信される際、元の着信パケットの外部 PE タグが外部トランク VLAN タグに置き換えられます。内部 CE VLAN タグは、発信パケットでも変更されずに残ります。

CE および PE VLAN タグの一意の組み合わせに基づくトラフィック シェーピングをサポートします。

元のパケットの外部 PE VLAN タグまたは内部 CE VLAN タグのいずれかから優先順位付けビット(P ビット)をコピーして、発信トランク VLAN タグ内の IEEE 802.1P P ビットを設定します。

Cisco IOS Release 12.2(18)SXE 以降では、複数の GE-WAN インターフェイスを 1 つの仮想 QinQ リンク バンドル(別称:ポートチャネル)に束ねることもできます。これにより設定が簡素化され、物理インターフェイス間を移動するトラフィックを自動的にロードバランシングできます。

QinQ 変換のプロセスおよび QinQ リンク バンドルの使用方法の詳細については、次の項を参照してください。

QinQ 変換 ― ダブル タグ/シングル タグ変換

ダブル タグ/シングル タグ変換では、アドバンスト QinQ サービス マッピング機能によって、内部 CE VLAN タグと外部 PE VLAN タグの両方が単一のトランク VLAN タグに置き換えられます。次に、元の着信パケットと変換済みの発信パケットの両方のフォーマットを示します。

 

元の着信パケット
DA
SA
ETYPE=
0x8100
PE VLAN タグ
ETYPE=1
0x8100
CE VLAN 1 タグ
データ
FCS
変換済みの発信パケット
 
DA
SA
ETYPE=
0x8100
トランク VLAN
タグ
データ
FCS
 
 

1.カスタマーがサービス プロバイダーに送信する前に VLAN ID でこのパケットをタグ付けしなかった場合、CE VLAN タグは存在しないこともあります。PE VLAN タグは常に存在します。

インターフェイスでパケットが受信されると、以下の処理が行われます。

内部 CE VLAN タグと外部 PE VLAN タグが検査され、その一意の組み合わせを使用して、QoS 処理、レート シェーピング、および対応するサービス ポリシー マップで指定されたスイッチングが実行されます。

パケットに PE VLAN タグが含まれる一方、この特定の CE VLAN タグにマッピングが設定されていない場合、または着信パケットに内部 CE VLAN タグが含まれていない場合、(サブインターフェイスが範囲外パケット用に設定されていないかぎり)インターフェイスでそのパケットが廃棄されます。

内部および外部 VLAN タグを削除し、VLAN のサブインターフェイス上に設定されたトランク VLAN タグに置き換えます。

使用されているサービス ポリシー マップに応じて、802.1P ビット(P ビット)が次のいずれかの方法でトランク VLAN タグに設定されます。

外部 PE VLAN タグに含まれていた P ビットをトランク VLAN タグにコピーする(デフォルト)

内部 CE VLAN タグに含まれていた P ビットをトランク VLAN タグにコピーする( set cos cos-inner コマンドがサービス ポリシー マップで使用されている場合)

インターフェイスまたはサブインターフェイスが、信頼性がないものとしてマーキングされている場合は、P ビットを 0 に設定する

変換済みのシングル タグ付きパケットが適切な宛先またはサービスに転送されます。

QinQ トランスペアレント トンネリング(ダブル タグ/ダブル タグ変換)

アドバンスト QinQ サービス マッピング機能をダブル タグ/ダブル タグ変換を行うように設定した場合は、ギガビット イーサネット WAN インターフェイスで外部 PE VLAN タグがトランク VLAN タグに置き換えられます。内部 CE VLAN タグは変更されません。次に、元の着信パケットと変換済みの発信パケットの両方のフォーマットを示します。

 

元の着信パケット
DA
SA
ETYPE=
0x8100
PE VLAN タグ
ETYPE=2
0x8100
CE VLAN 1 タグ
データ
FCS
変換済みの発信パケット
DA
SA
ETYPE=
0x8100
トランク VLAN
タグ
ETYPE=
0x8100
CE VLAN タグ
データ
FCS

2.カスタマーがサービス プロバイダーに送信する前に VLAN ID でこのパケットをタグ付けしなかった場合、CE VLAN タグは存在しないこともあります。この場合は、シングル タグからシングル タグへの変換になります。

インターフェイスでパケットが受信されると、以下の処理が行われます。

内部 CE VLAN タグと外部 PE VLAN タグが検査され、その一意の組み合わせを使用して、QoS 処理、レート シェーピング、および対応するサービス ポリシー マップで指定されたスイッチングが実行されます。

パケットに PE VLAN タグが含まれる一方、この特定の CE VLAN タグにマッピングが設定されていない場合、または着信パケットに内部 CE VLAN タグが含まれていない場合、(サブインターフェイスが範囲外パケット用に設定されていないかぎり)インターフェイスでそのパケットが廃棄されます。

外部 PE VLAN タグを削除し、VLAN のサブインターフェイス上に設定されたトランク VLAN タグに置き換えます。内部 CE VLAN タグは変更されません。

使用されているサービス ポリシー マップに応じて、802.1P ビット(P ビット)が次のいずれかの方法でトランク VLAN タグに設定されます。

外部 PE VLAN タグに含まれていた P ビットをトランク VLAN タグにコピーする(デフォルト)

内部 CE VLAN タグに含まれていた P ビットをトランク VLAN タグにコピーする( set cos cos-inner コマンドがサービス ポリシー マップで使用されている場合)

インターフェイスまたはサブインターフェイスが、信頼性がないものとしてマーキングされている場合は、P ビットを 0 に設定する

変換済みのダブル タグ付きパケットが適切な宛先またはサービスに転送されます。

範囲外パケットと範囲内未指定パケット

各 PE VLAN では、最大 32 個の CE VLAN がサポートされています。これは、32 で割り切れる数(0、32、64 など)で始まる 1 つの連続したブロック内にある必要があります。最初の CE VLAN ID を( bridge-domain コマンドを使用して)ある PE VLAN に指定すると、Cisco IOS ソフトウェアは、対応する 32 個の ID ブロックをその PE VLAN に自動的に関連付けます。他の CE VLAN は、その特定の PE VLAN に対してすべて範囲外とみなされます。

たとえば、CE VLAN ID として 131 を指定すると、128 ~ 159 の CE VLAN ID がその特定の PE VLAN に自動的に関連付けられます。そのブロックの外にある CE VLAN(1 ~ 127、160 ~ 4094)は、すべて範囲外とみなされます。さらに、着信パケットに CE VLAN タグがない場合も、範囲外とみなされます。

デフォルトの動作では、QinQ 変換が設定されたインターフェイスで受信された範囲外パケットはすべて廃棄されます。この動作は、範囲外パケットにマッチするサブインターフェイスを設定することによって変更できます。

また、QinQ アクセス ゲートウェイ インターフェイスでは、範囲内(32 個の VLAN ID のブロック内)であっても明示的にサブインターフェイスにマッピングされていない CE VLAN を持つパケットはすべて廃棄されます。この動作は変更不可能です。たとえば、特定の PE VLAN についてある CE VLAN を 32 と指定し、他の CE VLAN を指定しなかった場合、インターフェイスでは、33 ~ 63 の CE VLAN を持つその PE VLAN のパケットは廃棄されます。

アドバンスト QinQ サービス マッピングの VLAN 単位のロード バランシング

Cisco IOS Release 12.2(18)SXE 以降では、複数の GE-WAN インターフェイスを 1 つの QinQ リンク バンドルに束ねることができます。これは、物理的な GE-WAN インターフェイスと同様に設定する仮想インターフェイスです。QinQ リンク バンドルの使用には、次の利点があります。

個々の GE-WAN 物理インターフェイスを設定する必要がないため、設定が簡素化されます。その代わりに、この 1 つの仮想インターフェイスのみを必要な QinQ パラメータで設定します。これらのパラメータは、バンドル内のすべての物理インターフェイスで使用されます。

個々の物理インターフェイスを単一の論理インターフェイスに集約できるため、帯域幅が増加します。

バンドル内の 1 つのリンクがダウンした場合でも、リンクが再確立されるまでトラフィックは残りのインターフェイス間に再割り当てされるため、アベイラビリティが向上します。

物理インターフェイス間で、PE VLAN のロードバランシングをイネーブルにします。作成された PE VLAN は、ラウンドロビン方式でバンドル内の物理インターフェイス間に自動的に配分されます。QinQ リンク バンドルで物理インターフェイスが追加または削除されると、PE VLAN が物理インターフェイス間で自動的に再割り当てされるため、これらの VLAN のトラフィック フローの中断は最小限に抑制されます。


) ロードバランシング アルゴリズムは、PE VLAN 数にのみ基づいていて、特定 PE VLAN のすべてのパケットが同じ物理インターフェイスを介して送信されます。ロードバランシングでは、各 PE トンネル内で伝送される個々の CE VLAN の帯域幅または数を考慮しません。特定 PE VLAN の割り当ては、PE VLAN が最初に作成された際に決定され、この割り当ては、QinQ リンク バンドルでインターフェイスが追加または削除されない限り変更されません。


アプリケーションまたはロケーションなど管理ニーズに応じて、物理インターフェイスを論理的に分類できます。バンドルの仮想インターフェイスの統計情報およびバンドル内の各物理インターフェイスの統計情報を表示することにより、集約インターフェイスの統計情報を取得できます。

QinQ リンク バンドル内のインターフェイスおよびカード上で、トラフィック フローを中断せずに OIR およびその他のメンテナンス動作を実行できるため、ネットワーク管理が簡素化されます。その代わりに、トラフィックは残りの物理インターフェイス間に自動的に再配分されます。カードおよびそのインターフェイスがバック アップされると、トラフィックは再びバンドル内のすべてのスロットに再配分されます。

スロット間で OSM-2+4GE-WAN+ モジュールを移動する場合に、インターフェイス設定をすべて再入力する必要がありません。その代わりに必要な手順は、QinQ リンク バンドルから古いインターフェイスを削除して、新しいインターフェイスを追加するだけです。このあとで、バンドルの設定は新しいロケーションのカードに自動的に適用されます。

QinQ リンク バンドルは、LAN インターフェイス上で Ether Channel の作成に使用される port-channel および channel-group コマンドと同じコマンドを使用して作成されるため、学習が必要なラーニング カーブは最小限ですみます。QinQ リンク バンドルでは、Ether Channel と同じモニタリング手順およびメンテナンス手順を使用します。

アドバンスト QinQ サービス マッピングの設定

ここでは、アドバンスト QinQ サービス マッピング機能をイネーブル化し設定するために必要な、以下の設定作業について説明します。

「ギガビット イーサネット WAN インターフェイス上での QinQ 変換のイネーブル化」

「QinQ リンク バンドル上での QinQ 変換のイネーブル化」

「サービス プロバイダー エッジ ルータの設定」

「QinQ 変換の設定 ― ダブル タグ/シングル タグ変換」

「QinQ トランスペアレント トンネリング(ダブル タグ/ダブル タグ変換)の設定」

「ポリシー マップでの内部 CoS ビット使用の設定」

「QinQ マッピングおよび変換のディセーブル化」

ギガビット イーサネット WAN インターフェイス上での QinQ 変換のイネーブル化

アドバンスト QinQ サービス マッピング機能を使用するには、まず PE ルータにメトロ イーサネット ネットワーク経由で接続されたギガビット イーサネット WAN インターフェイス上で、QinQ 変換をイネーブルにする必要があります。また、着信パケットの IEEE 802.1Q ヘッダー内の IEEE 802.1P ビット(P ビット)を維持する場合は、オプションでそのインターフェイスを信頼性があるものとして設定できます。

ギガビット イーサネット WAN インターフェイスで QinQ 変換をイネーブルにし、オプションでそのインターフェイスを信頼性があるものとして設定するには、以下の手順を実行します。

前提条件

この機能には、Cisco IOS リリース 12.2(18)SXD 以降が稼働する Cisco Supervisor Engine 2 または Supervisor Engine 720 モジュールを搭載した Cisco Catalyst 6500 シリーズ スイッチまたは Cisco 7600 シリーズ ルータが必要です。

この機能は、OSM-2+4GE-WAN+ ギガビット イーサネット拡張 OSM 上のギガビット イーサネット WAN(GE-WAN)インターフェイスでのみサポートされています。この機能は、他のポート アダプタ モジュールまたは LAN のギガビット イーサネット(GE)インターフェイスではサポートされていません。

Cisco IOS ソフトウェア イメージでは、OSM-2+4GE-WAN+ ギガビット イーサネット拡張 OSM カードをサポートする必要があります。

メイン インターフェイス上の IP、MPLS、およびその他のレイヤ 3 設定をすべて削除してから、QinQ 変換をイネーブルにする必要があります。


) GE-WAN インターフェイスを QinQ 動作用に設定する場合、Cisco IOS CLI(コマンドライン インターフェイス)によりすべての IP 設定がブロックされますが、その他のレイヤ 3 機能を設定することは可能です。QinQ を正常に動作させるには、このような設定をすべてインターフェイスから削除する必要があります。


制約

この設定は、OSM-2+4GE-WAN+ 拡張 OSM 上のギガビット イーサネット WAN インターフェイスでのみサポートされています。

QinQ アクセス ゲートウェイとして設定できるのは、メイン インターフェイスだけです。そのうえで特定の VLAN マッピングを指定するためにサブインターフェイスを設定します。

ギガビット イーサネット WAN インターフェイスを QinQ アクセス ゲートウェイとして設定すると、IP、MPLS またはその他のレイヤ 3 設定に関しては設定できなくなります。このような設定をインターフェイスに追加すると、QinQ 動作が妨げられる可能性があります。

MPLS Experimental(EXP)ビット マッピングと階層型 QoS は、QinQ 変換に使用されているギガビット イーサネット WAN インターフェイスではサポートされていません。

各 PE VLAN(または外部 VLAN)では、最大 32 個の連続した CE VLAN(または内部 VLAN)がサポートされています。この CE VLAN 範囲は、32 で割り切れる境界数で始まる必要があります(32~63、64~95、4000~4031、4032~4063、4064~4094 など)。無効な VLAN または予約 VLAN は、この規則から除外されます。たとえば、VLAN 0 は無効で、VLAN 1 はデフォルトでネイティブ VLAN 用に予約されているため、最初の範囲は 2 ~ 31 になります。また、各 PE VLAN には、この 32 個の VLAN の範囲から外れる VLAN に適用されるデフォルト機能を設定できます。

ルータ内で PE VLAN を設定できるギガビット イーサネット WAN インターフェイスは 1 つだけです。

PE VLAN は、ルータ内のいずれかのインターフェイスで使用されているネイティブ VLAN と同一の ID を持つことはできません。インターフェイスのデフォルト ネイティブ VLAN は VLAN ID 1 で、ルータでの QinQ タギングの使用を簡素化するために、このデフォルトを使用することを推奨します。

PE VLAN は、同じインターフェイスまたはペアのインターフェイスで使用されている MPLS 関連 VLAN ID と同一の ID を持つことができません。GE-WAN インターフェイス 1 および 2 はペアを構成し、GE-WANインターフェイス 3 および 4 もペアになります。

たとえば、インターフェイス 1 が VLAN ID 200 を MPLS ベースの機能(MPLS VPN、AToM、または VPLS)に割り当てた場合、VLAN 200 をインターフェイス 1 または 2 の PE VLAN として使用できません。しかし、インターフェイス 3 または 4 では VLAN 200 は使用できます。これらのインターフェイスは別のインターフェイス ペアだからです。

VLAN 4095 は予約されており、CE VLAN として使用できません。CE VLAN ID 4095 が含まれるパケットは、QinQ 変換用に設定されたサブインターフェイスによって自動的に廃棄されます。しかし VLAN 4095 は、ネイティブ(非 QinQ)VLAN として継続して使用できます。

1006 ~ 4094 の VLAN ID は、PE VLAN または内部 VLAN 用に使用できます。内部 VLAN は自動的にレイヤ 3 LAN ポート、WAN インターフェイス、WAN サブインターフェイスといった特定の機能に割り当てられるため、PE VLAN の使用とシステムによる内部 VLAN の使用とを調整する必要があります。特に、内部 VLAN では 1 ~ 1005 の ID を使用できないため、1006~4094のVLAN ID の一部を内部 VLAN として使用できるように確保しておく必要があります。内部 VLAN として使用できる VLAN ID がなくなると、新しいカードのインストールや一部のソフトウェア機能の使用が不可能になることがあります。

ルータは、デフォルトでは、1006 で始まって増加する連続した値を内部 VLAN として割り当てます。この動作を vlan internal allocation policy descending グローバル コンフィギュレーション コマンドを使用して変更し、ルータが 4094 で始まって減少する連続した値を内部 VLAN として割り当てるようにすることを推奨します。


) 割り当て方式を変更した場合、変更を有効にするためにルータを再起動する必要があります。これは、いくつかの内部 VLAN がルータのスタートアップ時に自動割り当てされているためです。



ヒント 使用中の内部 VLAN の数を表示するには、show vlan internal usage コマンドを使用します。

match vlan コマンドは、この機能ではサポートされません。

手順概要

1. enable

2. configure terminal

3. vlan internal allocation policy descending

4. interface ge-wan slot/port

5. no ip address

6. mode dot1q-in-dot1q access-gateway

7. description string

8. no shutdown

9. end


ヒント VLAN 変換の Class of Service(CoS; サービス クラス)ビットを保持するのに、mls qos trust コマンドを設定する必要はありません。このコマンドは、mode dot1q-in-dot1q access-gateway コマンドで設定された GE-WAN インターフェイス上では無効であるためです。インターフェイスまたはポートチャネル グループが QinQ 変換用に設定されている場合は常に、VLAN の CoS ビットを信頼します。


手順詳細

 

コマンドまたは操作
説明

ステップ 1

enable

 

Router> enable

Router#

イネーブル EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vlan internal allocation policy descending

 

Router(config)# vlan internal allocation policy descending

Router(config)#

(任意)4094 で始まって、降順の連番で内部 VLAN を割り当てます。この設定は、PE VLAN ID の割り当てと重ならないようにすることを推奨します。


) 割り当て方式を変更した場合、変更を有効にするためにルータを再起動する必要があります。これは、いくつかの内部 VLAN がルータのスタートアップ時に自動割り当てされているためです。


ステップ 4

interface ge-wan slot/port

 

Router(config)# interface ge-wan 5/1

Router(config-if)#

OSM-2+4GE-WAN+ ギガビット イーサネット WAN ポート上の指定されたギガビット イーサネット WAN インターフェイスについて、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

no ip address

 

Router(config-if)# no ip address

Router(config-if)#

(任意)インターフェイスに設定されている IP アドレスを削除します。これは、インターフェイスに IP アドレスがあらかじめ設定されている場合に必要となります。

ステップ 6

mode dot1q-in-dot1q access-gateway

 

Router(config-if)# mode dot1q-in-dot1q access-gateway

Router(config-if)#

インターフェイスで QinQ 変換を有効にし、アドバンスト QinQ サービス マッピング機能をイネーブルにします。

ステップ 7

description string

 

Router(config-if)# description Connected to ISP ABC Port SJ-2

Router(config-if)#

(任意)インターフェイスの説明を指定します。 string パラメータには、当該インターフェイス、そのネイバや用途の説明のほか、このインターフェイスと設定をメンテナンスし、問題をトラブルシューティングするのに役立つあらゆる情報を任意のテキストで指定できます。

ステップ 8

no shutdown

 

Router(config-if)# no shutdown

Router(config-if)#

インターフェイスをアクティブにし、トラフィックを転送できるようにします。


) 設定するギガビット イーサネット WAN インターフェイスごとに、ステップ 4 から ステップ 8 を繰り返します。


ステップ 9

end

 

Router(config-if)# end

Router#

インターフェイス コンフィギュレーション モードを終了し、イネーブル EXEC モードに戻ります。

以下に、ギガビット イーサネット WAN インターフェイスの設定例を示します。

!
interface GE-WAN3/4
description connected to SJ QinQ Tunnel
no ip address
logging event link-status
negotiation auto
mode dot1q-in-dot1q access-gateway

QinQ リンク バンドル上での QinQ 変換のイネーブル化

QinQ リンク バンドル上でアドバンスト QinQ サービス マッピング機能を使用するには、仮想ポートチャネル インターフェイスを作成し、このインターフェイス上で QinQ 変換をイネーブルにする必要があります。そのあとで、ポートチャネル グループにギガビット イーサネット WAN インターフェイスを割り当てる必要があります。これらの作業を実行する手順は、次のとおりです。

前提条件

QinQ リンク バンドル機能には、Cisco IOS リリース 12.2(18)SXE 以降が稼働する Cisco Supervisor Engine 2 または Supervisor Engine 720 モジュールを搭載した Cisco Catalyst 6500 シリーズ スイッチまたは Cisco 7600 シリーズ ルータが必要です。

QinQ リンク バンドル機能を使用する場合、ポートチャネル グループには、OSM-2+4GE-WAN+ ギガビット イーサネット拡張 OSM 上のギガビット イーサネット WAN(GE-WAN)インターフェイスのみが含まれている必要があります。この機能は、他のポート アダプタ モジュールまたは LAN のギガビット イーサネット(GE)インターフェイスではサポートされていません。

Cisco IOS ソフトウェア イメージが、OSM-2+4GE-WAN+ ギガビット イーサネット拡張 OSM カードをサポートしている必要があります。

制約

ギガビット イーサネット WAN インターフェイス用に記載されたすべての制約は、QinQ リンク バンドリングの使用にも適用されます。これらの制約のリストについては、「制約」 を参照してください。

QinQ リンク バンドリングで使用されるチャネル グループには、OSM-2+4GE-WAN+ OSM カード上のGE-WAN インターフェイスしか含められません。

QinQ リンク バンドリングで使用されるポートチャネル インターフェイスには、OSM-2+4GE-WAN+ OSM カードでサポートされる最大 MTU である 9170 バイト以上の MTU 値を設定しないでください。

アドバンスト QinQ 変換用に OSM-2+4GE-WAN+ OSM 上の GE-WAN インターフェイスで channel-group コマンドを使用する場合は、 mode on オプションのみがサポートされます。QinQ リンク バンドル上では、その他のモード オプションはサポートされません。

MPLS が設定されている場合は、GE-WAN インターフェイス上で channel-group コマンドを使用できません。 channel-group コマンドを使用する前に、インターフェイスからすべての mpls コンフィギュレーション コマンドを削除する必要があります。

ポートチャネル グループのメイン ポートチャネル インターフェイスまたは各メンバー インターフェイスには、サービス ポリシーを適用できません。その代わりに、適切なポートチャネル サブインターフェイスにサービス ポリシーを適用する必要があります。また入力サービス ポリシーは、QinQ リンク バンドル用に使用されているポートチャネル上ではサポートされません。

QinQ ポートチャネル インターフェイスのサービス ポリシーでは、 shaping および set cos cos-inner コマンドのみをサポートします。QinQ ポートチャネル インターフェイス上では、 bandwidth コマンドなどその他のコマンドを使用できません。

ポートチャネル インターフェイス カウンタを表示するには、 show interface port-channel { number | number.subif } コマンドを使用します。ただし、QinQ リンク バンドリング用に GE-WAN インターフェイスを使用するチャネル グループでは、 show interface port-channel counters および show counters interface port-channel コマンドはサポートされません。

手順概要

1. enable

2. configure terminal

3. vlan internal allocation policy descending

4. interface port-channel number

5. no ip address

6. mode dot1q-in-dot1q access-gateway

7. description string

8. no shutdown

9. interface ge-wan slot/port

10. no ip address

11. channel-group number mode on

12. no shutdown

13. end


ヒント VLAN 変換の CoS ビットを保持するのに、mls qos trust コマンドを設定する必要はありません。このコマンドは、mode dot1q-in-dot1q access-gateway コマンドで設定された GE-WAN インターフェイスまたはポートチャネル グループ上では無効であるためです。インターフェイスまたはポートチャネル グループが QinQ 変換用に設定されている場合は常に、VLAN の CoS ビットを信頼します。


手順詳細

 

コマンドまたは操作
説明

ステップ 1

enable

 

Router> enable

Router#

イネーブル EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vlan internal allocation policy descending

 

Router(config)# vlan internal allocation policy descending

Router(config)#

(任意)4094 で始まって、降順の連番で内部 VLAN を割り当てます。PE VLAN ID の割り当てと重なることを防ぐために、この設定を推奨します。


) 割り当て方式を変更する場合、変更を有効にするためにルータを再起動する必要があります。これは、内部 VLAN の番号がルータのスタートアップ時に自動割り当てされるためです。


ステップ 4

interface port-channel number

 

Router(config)# interface port-channel 5

Router(config-if)#

仮想ポートチャネル インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始します。 number の有効範囲は、1 ~ 256 です。

ステップ 5

no ip address

 

Router(config-if)# no ip address

Router(config-if)#

(任意)インターフェイスに設定されている IP アドレスを削除します。これは、インターフェイスに IP アドレスがあらかじめ設定されている場合に必要となります。

ステップ 6

mode dot1q-in-dot1q access-gateway

 

Router(config-if)# mode dot1q-in-dot1q access-gateway

Router(config-if)#

インターフェイスで QinQ 変換を有効にし、アドバンスト QinQ サービス マッピング機能をイネーブルにします。


) このコマンドは、OSM-2+4GE-WAN+ カード上の GE-WAN インターフェイスではないチャネル グループ メンバーをすでに含むポートチャネル上では使用できません。


ステップ 7

description string

 

Router(config-if)# description QinQ Link Bundle connected to LA-10/1

Router(config-if)#

(任意)インターフェイスの説明を指定します。 string パラメータには、当該インターフェイス、そのネイバや用途の説明のほか、このインターフェイスと設定をメンテナンスし、問題をトラブルシューティングするのに役立つあらゆる情報を任意のテキストで指定できます。

ステップ 8

no shutdown

 

Router(config-if)# no shutdown

Router(config-if)#

インターフェイスをアクティブにし、トラフィックを転送できるようにします。

ステップ 9

interface ge-wan slot/port

 

Router(config)# interface ge-wan 5/1

Router(config-if)#

OSM-2+4GE-WAN+ ギガビット イーサネット WAN ポート上の指定された各ギガビット イーサネット WAN インターフェイスについて、インターフェイス コンフィギュレーション モードを開始します。

ステップ 10

no ip address

 

Router(config-if)# no ip address

Router(config-if)#

(任意)インターフェイスに設定されている IP アドレスを削除します。これは、インターフェイスに IP アドレスがあらかじめ設定されている場合に必要となります。

ステップ 11

channel-group number mode on

 

Router(config-if)# channel-group 5 mode on

Router(config-if)#

指定されたチャネル グループにこの物理インターフェイスを追加します。 number は、ステップ 4 でポートチャネル インターフェイス用に指定されたものと同じである必要があります。


mode on オプションのみが、GE-WAN インターフェイス上で QinQ リンク バンドリング用に設定されたポートチャネルで許可されています。


ステップ 12

no shutdown

 

Router(config-if)# no shutdown

Router(config-if)#

インターフェイスをアクティブにし、トラフィックを転送できるようにします。


) ポートチャネル グループに追加されるギガビット イーサネット WAN インターフェイスごとに、ステップ 9ステップ 12 を繰り返します。


ステップ 13

end

 

Router(config-if)# end

Router#

インターフェイス コンフィギュレーション モードを終了し、イネーブル EXEC モードに戻ります。


) ブリッジ ドメインから最後の内部 VLAN が削除されたあとで、ロード バランシングを再度実行する場合は、ポートチャネルで shutdown コマンドおよび no shutdown コマンドを実行します。


次に、2 つの GE-WAN 物理インターフェイスをそのチャネル グループの一部として持つポートチャネル インターフェイスの設定例を示します。

!
interface Port-channel3
no ip address
logging event link-status
speed nonegotiate
mode dot1q-in-dot1q access-gateway
!
interface GE-WAN2/1
no ip address
logging event link-status
negotiation auto
channel-group 3 mode on
!
interface GE-WAN2/3
no ip address
logging event link-status
negotiation auto
channel-group 3 mode on
 

次の設定例では、1 つまたは複数の無効なインターフェイスを含むポートチャネル インターフェイス上で、QinQ 変換をイネーブルにしようとした場合に表示されるエラー メッセージを示します。

Router# configure terminal
Router(config)# interface port-channel 30
7600-2(config-if)# mode dot1q-in-dot1q access-gateway
 
% 'mode dot1q-in-dot1q access-gateway' is not supported on Port-channel30
% Port-channel30 contains 2 Layer 2 Gigabit Ethernet interface(s)
 
Router(config-if)#
 

ポートチャネル インターフェイスのステータスおよびそのチャネル グループのメンバーを表示するには、 show interface コマンドを使用します。たとえば上記の設定でこのコマンドを使用すると、次の出力が表示されます。

Router# show interface Port-channel 3
 
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 0007.8508.474a (bia 000d.edb5.7d7b)
MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Full-duplex, Auto-speed
input flow-control is off, output flow-control is unsupported
Members in this channel: GE2/1 Pseudo GE2/3 Pseudo
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
 
Router#
 

QinQ 変換で使用される内部、外部、およびトランク VLAN を表示するには、 show cwan qinq コマンドを使用します。次に、 show cwan qinq コマンドを単独で使用した場合、および次の各オプション キーワードを指定した場合の、ポートチャネル インターフェイスの出力例を示します。

configured ― 設定されたすべてのブリッジ ドメインの統計情報を表示します。

detail ― 各ブリッジ ドメインの内部 VLAN 設定の詳細を表示します。

list ― 現在設定されている割り当てを表示します。


注意 show cwan qinq [configured | detail | list] コマンドは、ポートチャネル インターフェイスにのみ適用されます。物理インターフェイスでこのコマンドを使用すると、誤った内容が出力される場合があります。

Router#show cwan qinq
 
Bridge-domain Interface Egress-if Inner-start Total Active
3 Po1 GE3/1 0 1 1
Sub-Interface Trunk-vlan Inner-vlan Service State
Po1.2 2 4 dot1q up/up
 
Router#show cwan qinq configured
 
Port-channel1 has total 2 bridge-domain vlan(s)
Po1 - GE-WAN3/1 has 1 bridge-domain vlan(s) egress configured
13
Po1 - GE-WAN3/2 has 1 bridge-domain vlan(s) egress configured
3
 
Router#show cwan qinq detail
 
Port-channel1 has total 2 bridge-domain vlan(s)
Po1 - GE-WAN3/1 has 1 bridge-domain vlan(s) detail
Bridge-domain Inner Configured Active
------------- ------ ---------- ------
13 active 1 1
Po1 - GE-WAN3/1 has 2 bridge-domain vlan(s) detail
Bridge-domain Inner Configured Active
------------- ------ ---------- ------
3 active 1 1
 
Router#show cwan qinq list
 
Port-channel1 has total 2 bridge-domain vlan(s)
Po1 - GE-WAN3/1 has 1 bridge-domain vlan(s) egress active
13
Po1 - GE-WAN3/1 has 2 bridge-domain vlan(s) egress active
3
 

show cwan qinq load-balance コマンドも、ポートチャネル インターフェイスにのみ適用されます。

Router#show cwan qinq load-balance
 
Port-channel1 has total 2 bridge-domain vlan(s)
Po1 - GE-WAN3/1 has 1 bridge-domain vlan(s)
Po1 - GE-WAN3/1 has 2 bridge-domain vlan(s) detail
 
Router#show cwan qinq load-balance detail
Port-channel1 has total 2 bridge-domain vlan(s)
Po1 - GE-WAN3/1 has 1 bridge-domain vlan(s) detail
Bridge-domain Inner Configured Active
------------- ------ ---------- ------
13 active 1 1
Po1 - GE-WAN3/1 has 2 bridge-domain vlan(s) detail
Bridge-domain Inner Configured Active
------------- ------ ---------- ------
3 active 1 1
 

次の関連 show コマンドは、ポートチャネルおよび物理インターフェイスの両方に適用されます。

Router#show cwan qinq bridge-domain
 
GE-WAN3/1, group 1, total_rate_active 1
13
GE-WAN3/2, group 1, total_rate_active 1
3
Port-channel1, group 1, total_rate_active 2
 
Router#show cwan qinq interface
 
Interface Status Egress op PE CE TRNK Input packets/ Output packets/
Input bytes Output bytes
---------------- --------- ------ -- ---- ---- ---- -------------------- ----------------
Po1.2 up/up GE3/2 1 3 4 2 0 0
0 0
Po1.12 up/up GE3/1 1 13 14 12 0 0
0 0
 

) これらの関連コマンドの詳細については、『Cisco 7600 Router Cisco IOS Command Reference』 Rlease 12.2SX を参照してください。


サービス プロバイダー エッジ ルータの設定

ここでは、QinQ アクセス ゲートウェイとして機能するギガビット イーサネット WAN インターフェイスに接続されたサービス プロバイダー エッジ ルータ上のギガビット イーサネット インターフェイスの設定手順について説明します。

前提条件

サービス プロバイダー エッジ ルータでは、ギガビット イーサネット インターフェイスを使用している必要があります。

手順概要

1. enable

2. configure terminal

3. vlan vlan-id

4. interface GigabigEthernet slot/port

5. no ip address

6. mls qos trust [ cos | dscp | ip-precedence ]

7. switchport

8. switchport trunk encapsulation dot1q

9. switch trunk allowed vlan { vlan-list | vlan-range }

10. switchport mode trunk

11. description string

12. no shutdown

13. end

手順詳細

 

コマンドまたは操作
説明

ステップ 1

enable

 

Router> enable

Router#

イネーブル EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vlan vlan-id

 

Router(config)# vlan 22

Router(config)#

PE VLAN として使用する VLAN ID を(まだ入力していない場合)ルータの VLAN データベースに追加します。 vlan-id の有効範囲は、ルータまたはスイッチで使用されている Cisco IOS ソフトウェア イメージに応じて、1 ~ 1023、または 1 ~ 4094 のいずれかとなります。

ステップ 4

interface GigabitEthernet slot/port

 

Router(config)# interface GigabitEthernet3/1

Router(config-if)#

指定されたギガビット イーサネット インターフェイスについて、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

no ip address

 

Router(config-if)# no ip address

Router(config-if)#

インターフェイスに設定されている IP アドレスを削除します。

ステップ 6

mls qos trust [ cos | dscp | ip-precedence ]

 

Router(config-if)# mls qos trust dscp

Router(config-if)#

(任意)着信フレーム内の信頼できる QoS ビットを指定します。

cos ― (任意)着信フレーム内の CoS ビットに信頼性を指定し、その CoS ビットから内部 DSCP 値を得ます。

dscp ― (任意、デフォルト)着信パケット内の Type of Service(ToS; サービス タイプ)ビットに DSCP 値が含まれることを指定します。

ip-precedence ― (任意)着信パケット内の(ToS ビットに含まれる)IP precedence ビットに信頼性を指定し、その IP precedence ビットから内部 DSCP 値を得ます。


) インターフェイスを信頼性がないものとして設定するには、no mls qos trust コマンドを使用します。そのインターフェイスでは、すべての着信パケットの P ビットが 0 となります。


ステップ 7

switchport

 

Router(config-if)# switchport

Router(config-if)#

インターフェイスでレイヤ 2 スイッチングを行うように設定します。

ステップ 8

switchport trunk encapsulation dot1q

 

Router(config-if)# switchport trunk encapsulation dot1q

Router(config-if)#

IEEE 802.1Q カプセル化を使用するようにトランク リンクを設定します。

ステップ 9

switch trunk allowed vlan { vlan-list | vlan-range }

 

Router(config-if)# switch trunk allowed vlan 3001-4000

Router(config-if)#

(任意)トランク上で許可される PE VLAN のリストを設定します。デフォルトでは、すべての VLAN が許可されます。カンマで区切った個々の VLAN ID のリストか、ハイフンで区切った VLAN ID 範囲のいずれかを指定できます。

ステップ 10

switchport mode trunk

 

Router(config-if)# switchport mode trunk

Router(config-if)#

インターフェイスをトランキング モードに固定します。

ステップ 11

description string

 

Router(config-if)# description Connected to Metro interface SJ-3

Router(config-if)#

(任意)インターフェイスの説明を指定します。 string パラメータには、当該インターフェイス、そのネイバや用途の説明のほか、このインターフェイスと設定をメンテナンスし、問題をトラブルシューティングするのに役立つあらゆる情報を任意のテキストで指定できます。

ステップ 12

no shutdown

 

Router(config-if)# no shutdown

Router(config-if)#

インターフェイスをアクティブにし、トラフィックを転送できるようにします。


) 設定するインターフェイスごとに ステップ 4ステップ 12 を繰り返します。


ステップ 13

end

 

Router(config-if)# end

Router#

インターフェイス コンフィギュレーション モードを終了し、イネーブル EXEC モードに戻ります。

次に、QinQ 変換を行うギガビット イーサネット WAN ポートに接続されたギガビット イーサネット インターフェイスの設定例を示します。VLAN ID 3001 は、PE VLAN として使用されています。

vlan 3001
 
...
 
!
interface GigabitEthernet3/1
description connected to Metro SJ-3 (QinQ tunnel)
no ip address
logging event link-status
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3001-4000
switchport mode trunk

QinQ 変換の設定 ― ダブル タグ/シングル タグ変換

アドバンスト QinQ サービス マッピング機能をダブル タグ/シングル タグ変換として知られる QinQ 変換に設定した場合、発信インターフェイスでは、内部 CE VLAN タグと外部 PE VLAN タグの両方がトランク VLAN タグで置き換えられます。ダブル タグ/シングル タグ変換を行うようにサブインターフェイスを設定するには、以下の手順を実行します。


) QinQ 変換を設定するのに、Cisco IOS Release 12.2(18)SXD では bridge-vlan コマンドを使用していましたが、Cisco IOS Release 12.2(18)SXE 以降のリリースでは、このコマンドが bridge-domain に変更されました。以前の bridge-vlan を使用した設定は、ロード時に自動的に bridge-domain に設定されます。


前提条件

ギガビット イーサネット WAN インターフェイスまたはポートチャネル インターフェイス上では、あらかじめ QinQ VLAN 変換をイネーブルにしておく必要があります。「ギガビット イーサネット WAN インターフェイス上での QinQ 変換のイネーブル化」 または 「QinQ リンク バンドル上での QinQ 変換のイネーブル化」 を参照してください。

制約

各外部 PE VLAN について、最大 32 個の内部 CE VLAN を設定できます。内部 CE VLAN は、無効な VLAN または予約 VLAN を除いて、32 ブロックの境界値(32、64 など)で始まる連続したブロック内に含まれる必要があります。

まず特定の PE VLAN に少なくとも 1 つの内部 CE VLAN ID を設定しないかぎり、その PE VLAN には範囲外の設定を指定できません。これは、システムが範囲内および範囲外の VLAN ID を決定できるようにするためです。

VLAN 4095 は予約されており、CE VLAN として使用できません。CE VLAN ID 4095 が含まれるパケットは、QinQ 変換用に設定されたサブインターフェイスによって自動的に廃棄されます。しかし VLAN 4095 は、ネイティブ(非 QinQ)VLAN として継続して使用できます。

PE VLAN は、ルータで使用中の同じ ID をネイティブ(非 QinQ)VLAN として持つことはできません。

手順概要

1. enable

2. configure terminal

3. interface { ge-wan slot/port.subinterface | port-channel number.subinterface }

4. encapsulation dot1q trunk-vlan-id

5. bridge-domain vlan-id dot1q inner-vlan-id
または
bridge-domain vlan-id dot1q-tunnel out-range

6. mls qos trust [ cos | dscp | ip-precedence ]

7. service policy input policy-name

8. service policy output policy-name

9. end

手順詳細

 

コマンドまたは操作
説明

ステップ 1

enable

 

Router> enable

Router#

イネーブル EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface { ge-wan slot/port.subinterface | port-channel number.subinterface }

 

Router(config)# interface ge-wan 5/1.64

Router(config-subif)#

指定されたサブインターフェイスについて、サブインターフェイス モードを開始します。

ステップ 4

encapsulation dot1q trunk-vlan-id

 

Router(config-subif)# encapsulation dot1q 2

Router(config-subif)#

指定された IEEE 802.1Q トランク VLAN を発信パケットで使用するようにサブインターフェイスを設定します。

trunk-vlan-id ― トラフィックに使用されるトランク VLAN ID を指定します。有効範囲は 1 ~ 4094 の任意の VLAN ですが、割り当て済みの番号、および予約されている 1002 ~ 1005 の範囲の番号を除きます。

ステップ 5

bridge-domain vlan-id dot1q inner-vlan-id

または

bridge-domain vlan-id dot1q-tunnel out-range

 

Router(config-subif)# bridge-domain 2 dot1q 64

Router(config-subif)#

 

または

 

Router(config-subif)# bridge-domain 2 dot1q-tunnel out-range

Router(config-subif)#

指定された外部(プロバイダー)VLAN ID について、指定された内部(カスタマー)VLAN ID に対するテーブル マップを作成し、これらの VLAN タグがパケット出力時にトランク VLAN タグによって置き換えられるように指定します。

vlan-id ― PE または外部 VLAN の VLAN ID です。有効範囲は 1 ~ 4094 ですが、ネイティブ VLAN(デフォルトでは 1)および予約されている 1002 ~ 1005 の範囲の番号を除きます。この値は、PE ルータで実際に設定されている VLAN と一致する必要があります。

dot1q inner-vlan-id ― PE VLAN にマッピングされる CE または内部 VLAN の VLAN ID です。有効範囲は 1 ~ 4094 ですが、予約されている 1002 ~ 1005 の範囲の番号を除きます。

dot1q-tunnel out-range ― 特定のプロバイダー VLAN について 32 個の VLAN のマッピング済みブロックの外にあるすべての内部(カスタマー)VLAN ID のテーブル マップを作成します。PE VLAN の out-range マッピングを指定しなければ、CE VLAN タグを持たないか、マッピング済みブロック外の CE VLAN を持つその PE VLAN のパケットは、インターフェイスによってすべて廃棄されます。


) 少なくとも 1 つのサブインターフェイスを PE VLAN の特定の CE VLAN ID で設定しなければ、dot1q-tunnel out-range オプションは使用できません。



) ある PE VLAN について最初の inner-vlan-id を指定すると、インターフェイスはその PE VLAN に 32 個の VLAN の正しいブロックを自動的に関連付けます。それらの CE VLAN は、他の用途には使用できません。たとえば 98 を CE VLAN として指定すると、96 ~ 127 の VLAN がその PE VLAN に関連付けられます。他の CE VLAN がその PE VLAN で受信された場合、範囲外とみなされます。


ステップ 6

mls qos trust [ cos | dscp | ip-precedence ]

 

Router(config-subif)# mls qos trust dscp

Router(config-subif)#

(任意)着信フレーム内の信頼できる QoS ビットを指定します。

cos ― (任意)着信フレーム内の CoS ビットに信頼性を指定し、その CoS ビットから内部 DSCP 値を得ます。

dscp ― (任意、デフォルト)着信パケット内の ToS ビットに DSCP 値が含まれることを指定します。

ip-precedence ― (任意)着信パケット内の(ToS ビットに含まれる)IP precedence ビットに信頼性を指定し、その IP precedence ビットから内部 DSCP 値を得ます。


) インターフェイスを信頼性がないものとして設定するには、no mls qos trust コマンドを使用します。その場合、レイヤ 2 インターフェイスでは、QoS 処理が実行される前にすべての着信パケットの P ビットが 0 となります。


ステップ 7

service policy input policy-name

 

Router(config-subif)# service policy input policy-in1

Router(config-subif)#

(GE-WAN 物理インターフェイス上でのみサポートされ、ポートチャネル インターフェイス上ではサポートされません)。ギガビット イーサネット WAN インターフェイスで受信されるときに、着信パケットで使用されるポリシー マップを指定します。

ステップ 8

service policy output policy-name

 

Router(config-subif)# service policy output cos-xlat1

Router(config-subif)#

ギガビット イーサネット WAN インターフェイスから送信される前に発信パケットで使用されるポリシー マップを指定します。


set cos cos-inner コマンドを使用するポリシー マップは、出力ポリシーとしてサブインターフェイスで適用される必要があります。



) 設定するサブインターフェイス/VLAN マッピングごとに、ステップ 3ステップ 8 を繰り返します。


ステップ 9

end

 

Router(config)# end

Router#

グローバル コンフィギュレーション モードを終了し、イネーブル EXEC モードに戻ります。

次に、2 つのダブル タグ/シングル タグ マッピングを 1 つのサブインターフェイス上に作成する標準的な設定を示します。最初のサブインターフェイス設定によって特定の PE/CE マッピングが作成され、第 2 のサブインターフェイス設定によって範囲外設定が作成されます。

interface GE-WAN 3/3
no ip address
mode dot1q-indot1q access-gateway
...
!
interface GE-WAN3/3.42
encapsulation dot1Q 2
bridge-domain 133 dot1q 42
mls qos trust dscp
end
...
!
interface GE-WAN3/3.5032
encapsulation dot1Q 31
bridge-domain 133 dot1q-tunnel out-range
mls qos trust dscp
end
 

これらの QinQ マッピングは次のように動作します。

第 1 のサブインターフェイスは、PE VLAN ID 133 と CE VLAN ID 42 でタグ付けされた着信パケットにマッチし、それらのパケットをシングル トランク VLAN ID 2 を持つ発信パケットに変換します。またこの設定によって、32 ~ 63 の CE VLAN のブロックが自動的に PE VLAN 133 に関連付けられます。その範囲の CE VLAN ID と PE VLAN 133 を持つパケットが、明示的に他のサブインターフェイスにマッピングされていない場合、パケットは廃棄されます。他の CE VLAN が PE VLAN 133 で受信された場合、範囲外とみなされます。

第 2 のサブインターフェイスは、PE VLAN ID 133 でタグ付けされ、CE VLAN を持たないか、範囲外(1 ~ 31 または 64 ~ 4094 の範囲)の CE VLAN ID を持つ着信パケットにマッチします。これらのパケットは、外部タグとしてトランク VLAN ID 31 と(存在する場合)元の CE VLAN 内部タグを持つ発信パケットに変換されます。

この設定は、PE VLAN ID 133 を持つパケットで次のマッピングを実行します。

 

表4-1 ダブル タグ/シングル タグ マッピングの例

PE VLAN ID
CE VLAN ID
動作

133

1 ~ 31

トランク VLAN31 にマッピング、CE VLAN 1 ~ 31(範囲外)

133

32 ~ 41

廃棄(明示的にマッピングされていないため)

133

42

トランク VLAN 2 にマッピング(GE-WAN3/3.42 によって明示的にマッピング)

133

43 ~ 63

廃棄(明示的にマッピングされていないため)

133

64 ~ 4094

トランク VLAN31 にマッピング、CE VLAN 64 ~ 4094(範囲外)

133

(なし)

トランク VLAN 31 にマッピング(範囲外)

QinQ トランスペアレント トンネリング(ダブル タグ/ダブル タグ変換)の設定

アドバンスト QinQ サービス マッピング機能をダブル タグ/ダブル タグ変換として知られる QinQ トランスペアレント トンネリングを行うように設定した場合は、ギガビット イーサネット WAN インターフェイスで外部(PE)VLAN タグがトランク VLAN タグで置き換えられます。内部 CE VLAN タグは(存在する場合)変更されません。ダブル タグ/ダブル タグ変換を行うようにサブインターフェイスを設定するには、以下の手順を実行します。


) QinQ 変換を設定するのに、Cisco IOS Release 12.2(18)SXD では bridge-vlan コマンドを使用していましたが、Cisco IOS Release 12.2(18)SXE 以降のリリースでは、このコマンドが bridge-domain に変更されました。以前の bridge-vlan を使用した設定は、ロード時に自動的に bridge-domain に設定されます。


前提条件

ギガビット イーサネット WAN インターフェイスまたはポートチャネル インターフェイス上では、あらかじめ QinQ VLAN 変換をイネーブルにしておく必要があります。「ギガビット イーサネット WAN インターフェイス上での QinQ 変換のイネーブル化」 または 「QinQ リンク バンドル上での QinQ 変換のイネーブル化」 を参照してください。

制約

各外部 PE VLAN について、最大 32 個の内部 CE VLAN を設定できます。内部 VLAN は、32 ブロックの境界値(0、32、64 など)で始まる連続したブロック内に含まれる必要があります。

VLAN 4095 は予約されており、CE VLAN として使用できません。CE VLAN ID 4095 が含まれるパケットは、QinQ 変換用に設定されたサブインターフェイスによって自動的に廃棄されます。しかし VLAN 4095 は、ネイティブ(非 QinQ)VLAN として継続して使用できます。

まず特定の PE VLAN に少なくとも 1 つの内部 CE VLAN ID を設定しないかぎり、その PE VLAN には範囲外の設定を指定できません。これは、システムが範囲内および範囲外の VLAN ID を決定できるようにするためです。

PE VLAN は、ルータで使用中の同じ ID をネイティブ(非 QinQ)VLAN として持つことはできません。

また入力サービス ポリシー( service-policy input コマンド)は、QinQ リンク バンドル用に使用されているポートチャネル上ではサポートされません。

手順概要

1. enable

2. configure terminal

3. interface { ge-wan slot/port.subinterface | port-channel number.subinterface }

4. encapsulation dot1q trunk-vlan-id

5. bridge-domain vlan-id dot1q-tunnel { inner-vlan-id | out-range }

6. mls qos trust [ cos | dscp | ip-precedence ]

7. service policy input policy-name

8. service policy output policy-name

9. end

手順詳細

 

コマンドまたは操作
説明

ステップ 1

enable

 

Router> enable

Router#

イネーブル EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface { ge-wan slot/port.subinterface | port-channel number.subinterface }

 

Router(config)# interface ge-wan 5/1.64

Router(config-subif)#

指定されたサブインターフェイスについて、サブインターフェイス モードを開始します。

ステップ 4

encapsulation dot1q trunk-vlan-id

 

Router(config-subif)# encapsulation dot1q 2

Router(config-subif)#

指定された IEEE 802.1Q トランク VLAN を発信パケットで使用するようにサブインターフェイスを設定します。

trunk-vlan-id ― トラフィックに使用されるトランク VLAN ID を指定します。有効範囲は 1 ~ 4094 の任意の VLAN ですが、割り当て済みの番号、および予約されている 1002 ~ 1005 の範囲の番号を除きます。

ステップ 5

bridge-domain vlan-id dot1q-tunnel { inner-vlan-id | out-range }

 

Router(config-subif)# bridge-domain 2 dot1q 64

Router(config-subif)#

 

または

 

Router(config-subif)# bridge-domain 2 dot1q out-range

Router(config-subif)#

指定された外部(プロバイダー)VLAN ID について、指定された内部(カスタマー)VLAN ID に対するテーブル マップを作成し、外部 VLAN タグがパケット出力時にトランク VLAN タグによって置き換えられるように指定します(内部タグは変更されません)。

vlan-id ― PE または外部 VLAN の VLAN ID です。有効範囲は 1 ~ 4094 ですが、ネイティブ VLAN(デフォルトでは 1)および予約されている 1002 ~ 1005 の範囲の番号を除きます。この値は、PE ルータで実際に設定されている VLAN と一致する必要があります。

inner-vlan-id ― PE VLAN にマッピングされる CE または内部 VLAN の VLAN ID です。有効範囲は 1 ~ 4094 ですが、予約されている 1002 ~ 1005 の範囲の番号を除きます。

out-range ― 特定のプロバイダー VLAN について 32 個の VLAN のマッピング済みブロックの外にあるすべての内部 VLAN ID とマッチします。PE VLAN の out-range マッピングを指定しなければ、インターフェイスでマッピング済みブロックの外にある CE VLAN を持つその PE VLAN のすべてのパケットが廃棄されます。


) 少なくとも 1 つのサブインターフェイスを PE VLAN の特定の CE VLAN ID について設定しなければ、out-range オプションは使用できません。



) ある PE VLAN について最初の inner-vlan-id を指定すると、インターフェイスはその PE VLAN に 32 個の VLAN の正しいブロックを自動的に関連付けます。それらの CE VLAN は、他の用途には使用できません。たとえば 98 を CE VLAN として指定すると、96 ~ 127 の VLAN がその PE VLAN に関連付けられます。他の CE VLAN がその PE VLAN で受信された場合、範囲外とみなされます。


ステップ 6

mls qos trust [ cos | dscp | ip-precedence ]

 

Router(config-subif)# mls qos trust dscp

Router(config-subif)#

(任意)着信フレーム内の信頼できる QoS ビットを指定します。

cos ― (任意)着信フレーム内の CoS ビットに信頼性を指定し、その CoS ビットから内部 DSCP 値を得ます。

dscp ― (任意、デフォルト)着信パケット内の ToS ビットに DSCP 値が含まれることを指定します。

ip-precedence ― (任意)着信パケット内の(ToS ビットに含まれる)IP precedence ビットに信頼性を指定し、その IP precedence ビットから内部 DSCP 値を得ます。


) インターフェイスを信頼性がないものとして設定するには、no mls qos trust コマンドを使用します。その場合、レイヤ 2 インターフェイスでは、QoS 処理が実行される前にすべての着信パケットの P ビットが 0 となります。


ステップ 7

service policy input policy-name

 

Router(config-subif)# service policy input policy-in1

Router(config-subif)#

(GE-WAN 物理インターフェイス上でのみサポートされ、ポートチャネル インターフェイス上ではサポートされません)。ギガビット イーサネット WAN インターフェイスで受信されるときに、着信パケットで使用されるポリシー マップを指定します。

ステップ 8

service policy output policy-name

 

Router(config-subif)# service policy output cos-xlat1

Router(config-subif)#

ギガビット イーサネット WAN インターフェイスから送信される前に発信パケットで使用されるポリシー マップを指定します。


) 設定するサブインターフェイス/VLAN マッピングごとに、ステップ 3ステップ 8 を繰り返します。


ステップ 9

end

 

Router(config)# end

Router#

グローバル コンフィギュレーション モードを終了し、イネーブル EXEC モードに戻ります。

以下に、2 つのダブル タグ/ダブル タグ マッピングを 1 つのサブインターフェイス上に作成する標準的な設定を示します。最初のサブインターフェイス設定によって特定の PE/CE マッピングが作成され、第 2 のサブインターフェイス設定によって範囲外設定が作成されます。

!
interface GE-WAN1/1.98
encapsulation dot1Q 12
bridge-domain 65 dot1q-tunnel 98
mls qos trust dscp
end
...
!
interface GE-WAN1/1.5096
encapsulation dot1Q 31
bridge-domain 65 dot1q-tunnel out-range
mls qos trust dscp
end
 

これらの QinQ マッピングは次のように動作します。

第 1 のサブインターフェイスは、PE VLAN ID 65 と CE VLAN ID 98 でタグ付けされた着信パケットにマッチし、それらのパケットをトランク VLAN ID 12 と CE VLAN ID 98 を持つ発信パケットに変換します。またこの設定によって、96 ~ 127 の CE VLAN のブロックが自動的に PE VLAN 65 に関連付けられます。その範囲の CE VLAN ID と PE VLAN 65 を持つパケットが、明示的に他のインターフェイスにマッピングされていない場合、パケットは廃棄されます。他の CE VLAN が PE VLAN 65 で受信された場合、範囲外とみなされます。

第 2 のサブインターフェイスは、PE VLAN ID 65 でタグ付けされ、CE VLAN タグを持たないか、範囲外(1 ~ 95 または 128 ~ 4094 の範囲)の CE VLAN ID を持つ着信パケットにマッチします。これらのパケットは、トランク VLAN ID 31 と(存在する場合)元の CE VLAN タグを持つ発信パケットに変換されます。

この設定は、PE VLAN ID 65 を持つパケットで次のマッピングを実行します。

 

表4-2 ダブル タグ/ダブル タグ マッピングの例

PE VLAN ID
CE VLAN ID
動作

65

1 ~ 95

トランク VLAN 31 にマッピング、CE VLAN 1 ~ 31(範囲外)

65

96 ~ 97

廃棄(明示的にマッピングされていないため)

65

98

トランク VLAN 12 にマッピング、CE VLAN 98(GE-WAN3/3.42 によって明示的にマッピング)

65

99 ~ 127

廃棄(明示的にマッピングされていないため)

65

128 ~ 4094

トランク VLAN 31 にマッピング、CE VLAN 128 ~ 4094(範囲外)

65

(なし)

トランク VLAN 31 にマッピング(範囲外)

ポリシー マップでの内部 CoS ビット使用の設定

デフォルトでは、IEEE 802.1Q/IEEE 802.1Q 変換によって外部 PE VLAN タグから IEEE 802.1P ビット(P ビット)がコピーされ、発信パケットのトランク VLAN タグの IEEE 802.1Q ヘッダー内に P ビットが設定されます。この動作を変更するには、 set cos cos-inner コマンドが含まれたクラス マップを持つポリシー マップを作成します。その場合、P ビットは、システムによって内部 CE VLAN タグから、発信パケットに付加されるトランク VLAN タグにコピーされます。

前提条件

ポリシー マップを作成したら、サブインターフェイス コンフィギュレーション モードで service-policy output コマンドを使用し、そのマップを VLAN の適切なサブインターフェイスに適用する必要があります。詳細については、次の項を参照してください。

「QinQ 変換の設定 ― ダブル タグ/シングル タグ変換」

「QinQ トランスペアレント トンネリング(ダブル タグ/ダブル タグ変換)の設定」

制約

set cos cos-inner コマンドは、内部 CE VLAN で設定されたサブインターフェイスについてのみサポートされています。 set cos cos-inner コマンドは、 bridge-domain コマンドで out-range オプションを使用しているサブインターフェイスではサポートされていません。

メイン ギガビット イーサネット WAN インターフェイスまたはメイン ポートチャネル インターフェイスでは、これらのポリシー マップを使用できません。

set cos cos-inner コマンドを有効にするには、 mls qos trust コマンドを使用して、インターフェイスまたはサブインターフェイスを信頼性のあるインターフェイスとして設定する必要があります。そうしなければ、インターフェイスまたはサブインターフェイスが信頼性を持たない場合に、そのインターフェイスでは着信パケットの 802.1P ビットが 0 となり、そのビットが発信パケットにコピーされます。

手順概要

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class { class-name | class-default }

5. set cos cos-inner

6. shape { average | peak } mean-rate [ bc [ be ]]

7. (必要に応じて他のコンフィギュレーション コマンド)

8. end

手順詳細

 

コマンドまたは操作
説明

ステップ 1

enable

 

Router> enable

Router#

イネーブル EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

Router(config)# policy-map pmap1

Router(config-pmap)#

1 つまたは複数のインターフェイスに適用できるポリシー マップを作成または変更し、サービス ポリシーを指定し、さらにポリシー マップ コンフィギュレーション モードを開始します。

policy-map-name ― ポリシー マップの名前です。この名前には、最大 40 文字の英数字を使用できます。

ステップ 4

class { class-name | class-default }

 

Router(config-pmap)# class class-default

Router(config-pmap-c)#

ポリシー クラスを作成または変更し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

class-name ― 設定または変更するクラスの名前です。

class-default ― 他のクラスが指定されていない場合に使用するデフォルトのクラスを指定します。

ステップ 5

set cos cos-inner

 

Router(config-pmap-c)# set cos cos-inner

Router(config-pmap-c)#

(任意)QinQ 変換された発信パケットのトランク VLAN タグの IEEE 802.1 優先順位付けビット(P ビット)を設定します。着信パケットの内部(CE)VLAN タグのプライオリティ値が使用されます。デフォルト値はこのコマンドの no 形式です。この場合、着信パケットの外部(PE)VLAN タグの P ビットが使用されます。

ステップ 6

shape { average | peak } mean-rate [ bc [ be ]]

 

Router(config-pmap-c)# shape average 4000000 16000 16000

Router(config-pmap-c)#

(任意)ポリシーで使用されるトラフィック シェーピング レートを指定します。

average ― (任意)各インターバルに送信されるビットの最大数が、Committed Burst Size(Bc)に等しくなります。

peak ― (任意)各インターバルに送信されるビットの最大数が、Bc と Excess Burst Size(Be)の合計に等しくなるように指定します。

mean-rate ― (任意)Committed Information Rate(CIR; 認定情報速度)とも呼ばれます。トラフィック シェーピングで使用されるビット レート(bps)を示します。

bc ― (任意)測定インターバルの Bc 内のビット数です。

be ― (任意)Be を超えて許可されるビット数です。

ステップ 7

end

 

Router(config-pmap-c)# end

Router#

ポリシー マップ クラス コンフィギュレーション モードを終了し、イネーブル EXEC モードに戻ります。

次に、 set cos cos-inner コマンドを使用した、標準的なポリシー マップの設定例を示します。

!
policy-map pmap1
class class-default
shape average 4000000
set cos cos-inner

QinQ マッピングおよび変換のディセーブル化

ギガビット イーサネット インターフェイスまたはそのサブインターフェイスの 1 つで QinQ ダブル タグ付きパケットのマッピングと変換をディセーブルにするには、次の手順のいずれかを実行します。

「インターフェイスでのすべての QinQ 変換のディセーブル化」

「1 つのサブインターフェイスでの QinQ 変換のディセーブル化」

インターフェイスでのすべての QinQ 変換のディセーブル化

ギガビット イーサネット WAN インターフェイスまたはポートチャネル インターフェイスですべての QinQ 変換をディセーブルにするには、次の手順を実行します。この手順では、サブインターフェイスとその設定もすべてインターフェイスから削除されます。これによって、関連付けられた VLAN は他の用途や他のカードで使用できます。


ヒント 設定を別のインターフェイスに移す場合は、設定を保存してからこの手順を開始してください。



) インターフェイス カードをルータから取り外してもインターフェイスの設定は削除されません。Cisco IOS では、ユーザが OIR 操作を行っているものと見なされるからです。カードに設定された VLAN を他のインターフェイスで使用できるようにするには、カードをシャーシから取り外す前に、カード上のすべてのインターフェイスで QinQ 変換をディセーブルにする必要があります。


前提条件

set cos cos-inner コマンドを含むサービス ポリシーをインターフェイスにあらかじめ適用した場合は、まずこのサービス ポリシーを削除してから、 no mode dot1q-in-dot1q access-gateway コマンドを使用する必要があります。

手順概要

1. enable

2. configure terminal

3. interface { ge-wan slot/port | port-channel number }

4. shutdown

5. no mode dot1q-in-dot1q access-gateway

6. end

手順詳細

 

コマンドまたは操作
説明

ステップ 1

enable

 

Router> enable

Router#

イネーブル EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface { ge-wan slot/port | port-channel number }

 

Router(config)# interface ge-wan 5/1

Router(config-if)#

指定されたギガビット イーサネット WAN インターフェイスまたはポートチャネル インターフェイスに関して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

shutdown

 

Router(config-if)# shutdown

Router(config-if)#

(任意)インターフェイスをディセーブルにし、トラフィックを転送しないようにします。

ステップ 5

no mode dot1q-in-dot1q access-gateway

 

Router(config-if)# no mode dot1q-in-dot1q access-gateway

Router(config-if)#

インターフェイス上の QinQ 変換をディセーブルにします。これによってアドバンスト QinQ サービス マッピング機能はディセーブルとなり、すべてのサブインターフェイス設定がインターフェイスから削除されます。


) 設定を別のインターフェイスに移す場合は、設定を保存してからこのコマンドを実行してください。


ステップ 6

end

 

Router(config-if)# end

Router#

グローバル コンフィギュレーション モードを終了し、イネーブル EXEC モードに戻ります。

1 つのサブインターフェイスでの QinQ 変換のディセーブル化

個々のサブインターフェイスで QinQ 変換をディセーブルにするには、以下の手順を実行します。サブインターフェイスは、続けて他のトラフィックの転送に使用するかどうかによって、完全に削除することも、 bridge-domain 設定だけを削除することもできます。いずれの方式でも、サブインターフェイスで使用されている CE および PE VLAN は解放されます。

前提条件

set cos cos-inner コマンドを含むサービス ポリシーをインターフェイスにあらかじめ適用した場合は、まずこのサービス ポリシーを削除してから、 no bridge-domain コマンドを使用する必要があります。

手順概要

1. enable

2. configure terminal

3. no interface { ge-wan slot/port.subinterface | port-channel number.subinterface }

または

4. interface { ge-wan slot/port.subinterface | port-channel number.subinterface }

5. no bridge-domain vlan-id dot1q { inner-vlan-id | out-range }

6. end

手順詳細

 

コマンドまたは操作
説明

ステップ 1

enable

 

Router> enable

Router#

イネーブル EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

no interface { ge-wan slot/port.subinterface | port-channel number.subinterface }

 

Router(config)# no interface ge-wan 5/1.64

Router(config-subif)#

サブインターフェイスとその設定を完全に削除します。このインターフェイスでのすべてのトラフィック転送が停止します。


) このコマンドを入力したら、ステップ 6 へ進みます。


または

ステップ 4

interface { ge-wan slot/port.subinterface | port-channel number.subinterface }

 

Router(config)# interface ge-wan 5/1.64

Router(config-subif)#

指定されたサブインターフェイスについて、サブインターフェイス モードを開始します。

ステップ 5

no bridge-domain vlan-id dot1q { inner-vlan-id | out-range }

 

Router(config-subif)# no bridge-domain 2 dot1q 64

Router(config-subif)#

サブインターフェイスのテーブル マッピングを削除し、VLAN のこの特定の組み合わせについて QinQ 変換をディセーブルにします。トラフィックは、サブインターフェイスの残りの設定に応じて、引き続き転送されます。

ステップ 6

end

 

Router(config-subif)# end

Router#

サブインターフェイス コンフィギュレーション モードを終了し、イネーブル EXEC モードに戻ります。

QinQ 変換(2 つのタグから 1 つのタグへの変換)の設定例

以下のコンフィギュレーション ファイルからの引用は、単純な QinQ 変換の設定を示しています。ここでは、着信パケットが内部 CE VLAN および外部 PE VLAN タグ付きで受信されます。その後パケットは、設定されたポリシー マップを使用して、単一のトランク VLAN タグを付けて出力されます。

この設定では、ギガビット イーサネット WAN インターフェイス 4/1 が QinQ アクセス ゲートウェイとして設定され、以下の 2 つの PE/CE マッピングが示されています。

最初のサブインターフェイス セットは、PE VLAN ID 2 と CE VLAN ID 32 ~ 46 について設定されます。これらは、すべて信頼性のあるサブインターフェイスとして設定され( mls qos trust dscp )、 set cos cos-inner コマンドを使用するポリシー マップが使用されます。これにより、カスタマーの元の CE VLAN タグ内の 802.1P ビットが発信トランク VLAN タグにコピーされます。

サブインターフェイス 47 は、PE VLAN ID 2 と範囲外の CE VLAN ID(47 ~ 63)を持つすべての着信パケットにマッチするように設定されています。 set cos cos-inner コマンドは、このコマンドが含まれたポリシー マップを使用している場合でも、範囲外パケットには無効であることに注意してください。

第 2 のサブインターフェイス セットは、トランク VLAN ID 100 と PE VLAN ID 45 について設定されます。これらのサブインターフェイスでは、CE VLAN ID 1237 ~ 1240 の着信を受け入れます。この設定には、 out-of-range のサブインターフェイスは含まれないため、PE VLAN ID 45 と範囲外の CE VLAN ID(1216 ~ 1236 および 1241 ~ 1247)を持つ着信パケットはすべて廃棄されます。すべてのサブインターフェイスで、 set cos cos-inner コマンドを含まないポリシー マップが使用されます。これは、トランク VLAN タグで元の PE VLAN タグ内の 802.1P ビットが使用されることを意味します。

!
vlan internal allocation policy descending
!
vlan 1-1240
!
policy-map pmap1
class class-default
shape average 4000000
set cos cos-inner
policy-map pmap2
class class-default
shape average 8000000 32000 32000
set cos cos-inner
policy-map pmap3
class class-default
shape average 20000000 80000 80000
set cos cos-inner
policy-map pmap4
class class-default
shape average 2000000 16000 16000
!
!
interface GigabitEthernet4/1
description connected to SP GE1/3
no ip address
logging event link-status
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/2
no ip address
shutdown
!
!--This is the QinQ Access Gateway interface
interface GE-WAN4/1
description connected to PE-4 GigabitEthernet0/3
no ip address
logging event link-status
negotiation auto
mode dot1q-in-dot1q access-gateway
!--This command configures the interface as trusted, which
!--is required to be able to use the original packet’s 802.1P CoS bits.
mls qos trust dscp
 
!--First set of PE/CE mappings
!
interface GE-WAN4/1.32
encapsulation dot1Q 32
!--note that this bridge-domain command automatically configures the
!--CE VLAN range for this PE VLAN to be from 32 to 63
bridge-domain 2 dot1q 32
mls qos trust dscp
service-policy output pmap3
!
interface GE-WAN4/1.33
encapsulation dot1Q 33
bridge-domain 2 dot1q 33
mls qos trust dscp
service-policy output pmap2
!
interface GE-WAN4/1.34
encapsulation dot1Q 34
bridge-domain 2 dot1q 34
mls qos trust dscp
service-policy output pmap1
!
interface GE-WAN4/1.35
encapsulation dot1Q 35
bridge-domain 2 dot1q 35
mls qos trust dscp
service-policy output pmap2
!
interface GE-WAN4/1.36
encapsulation dot1Q 36
bridge-domain 2 dot1q 36
mls qos trust dscp
service-policy output pmap3
!
interface GE-WAN4/1.37
encapsulation dot1Q 37
bridge-domain 2 dot1q 37
mls qos trust dscp
service-policy output pmap1
!
interface GE-WAN4/1.38
encapsulation dot1Q 38
bridge-domain 2 dot1q 38
mls qos trust dscp
service-policy output pmap1
!
interface GE-WAN4/1.39
encapsulation dot1Q 39
bridge-domain 2 dot1q 39
mls qos trust dscp
service-policy output pmap2
!
interface GE-WAN4/1.40
encapsulation dot1Q 40
bridge-domain 2 dot1q 40
mls qos trust dscp
service-policy output pmap3
!
interface GE-WAN4/1.41
encapsulation dot1Q 41
bridge-domain 2 dot1q 41
mls qos trust dscp
service-policy output pmap2
!
interface GE-WAN4/1.42
encapsulation dot1Q 42
bridge-domain 2 dot1q 42
mls qos trust dscp
service-policy output pmap1
!
interface GE-WAN4/1.43
encapsulation dot1Q 43
bridge-domain 2 dot1q 43
mls qos trust dscp
service-policy output pmap2
!
interface GE-WAN4/1.44
encapsulation dot1Q 44
bridge-domain 2 dot1q 44
mls qos trust dscp
service-policy output pmap3
!
interface GE-WAN4/1.45
encapsulation dot1Q 45
bridge-domain 2 dot1q 45
mls qos trust dscp
service-policy output pmap3
!
interface GE-WAN4/1.46
encapsulation dot1Q 46
bridge-domain 2 dot1q 46
mls qos trust dscp
service-policy output pmap1
!
interface GE-WAN4/1.47
description out-of-range configuration for CE VLANs 47 to 63
encapsulation dot1Q 47
bridge-domain 2 dot1q-tunnel out-range
mls qos trust dscp
!-- Although this policy map includes the set cos cos-inner command,
!-- this command is not used for out-of-range packets
service-policy output pmap4
 
!--Second set of PE/CE mappings
!
interface GE-WAN4/1.1237
encapsulation dot1Q 1237
!--note that this bridge-domain command automatically configures the
!--CE VLAN range for this PE VLAN to be from 1216 to 1247
bridge-domain 45 dot1q 1237
no mls qos trust
service-policy output pmap4
!
interface GE-WAN4/1.1238
encapsulation dot1Q 1238
bridge-domain 45 dot1q 1238
no mls qos trust
service-policy output pmap4
!
interface GE-WAN4/1.1239
encapsulation dot1Q 1239
bridge-domain 45 dot1q 1239
no mls qos trust
service-policy output pmap4
!
interface GE-WAN4/1.1240
encapsulation dot1Q 1240
bridge-domain 45 dot1q 1240
no mls qos trust
service-policy output pmap4
 
...

QinQ トランスペアレント トンネリングの設定例

以下のコンフィギュレーション ファイルからの引用は、単純な QinQ トランスペアレント トンネリングの標準設定を示しています。ここでは、着信パケットが内部 CE VLAN および外部 PE VLAN タグ付きで受信されます。その後パケットは、設定されたポリシー マップを使用して、新しいトランク VLAN タグと元の内部 CE VLAN タグを付けて出力されます。この設定を、2 つのタグから 1 つのタグへの変換と呼びます。

この設定では、ギガビット イーサネット WAN インターフェイス 4/1 が QinQ アクセス ゲートウェイとして設定され、以下の特性を持つ PE/CE マッピングが作成されます。

PE VLAN ID 152

CE VLAN ID 2048 ~ 2079

サブインターフェイス GE-WAN 4/1.15233 は、上記範囲外の CE VLAN ID(1 ~ 2047 または 2080 ~ 4094)を含むあらゆるパケットにマッチします。

インターフェイスとすべてのサブインターフェイスは、範囲外のサブインターフェイスを除いて、信頼性があるものとして設定されます( mls qos trust dscp )。そのためこれらのインターフェイスでは、パケットの元の PE VLAN タグ内の 802.1P ビットが、発信トランク VLAN タグにコピーされます(元の CE VLAN タグは変更されず、そこには元の 802.1P ビットが含まれます)。

!
vlan internal allocation policy descending
!
vlan 1-4094
 
...
 
!--This is an IP LAN interface
interface GigabitEthernet4/1
description QinQ tunnel to Catalyst 3550 Gigabit Ethernet 0/6
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 340
switchport mode trunk
!
!
interface GigabitEthernet4/2
no ip address
shutdown
!
!--This is the QinQ Access Gateway interface
interface GE-WAN4/1
description connected to GSR Gigabit Ethernet 4/1
no ip address
logging event link-status
no negotiation auto
mode dot1q-in-dot1q access-gateway
mls qos trust dscp
!
interface GE-WAN4/1.15201
encapsulation dot1Q 180
!--note that this bridge-domain command automatically configures the
!--CE VLAN range for this PE VLAN to be from 2048 to 2079
bridge-domain 152 dot1q-tunnel 2048
mls qos trust dscp
!
interface GE-WAN4/1.15203
encapsulation dot1Q 182
bridge-domain 152 dot1q-tunnel 2049
mls qos trust dscp
!
interface GE-WAN4/1.15204
encapsulation dot1Q 183
bridge-domain 152 dot1q-tunnel 2050
mls qos trust dscp
!
interface GE-WAN4/1.15205
encapsulation dot1Q 184
bridge-domain 152 dot1q-tunnel 2051
mls qos trust dscp
!
interface GE-WAN4/1.15206
encapsulation dot1Q 185
bridge-domain 152 dot1q-tunnel 2052
mls qos trust dscp
!
interface GE-WAN4/1.15207
encapsulation dot1Q 186
bridge-domain 152 dot1q-tunnel 2053
mls qos trust dscp
!
interface GE-WAN4/1.15208
encapsulation dot1Q 187
bridge-domain 152 dot1q-tunnel 2054
mls qos trust dscp
!
interface GE-WAN4/1.15209
encapsulation dot1Q 188
bridge-domain 152 dot1q-tunnel 2055
mls qos trust dscp
!
interface GE-WAN4/1.15210
encapsulation dot1Q 189
bridge-domain 152 dot1q-tunnel 2056
mls qos trust dscp
!
interface GE-WAN4/1.15211
encapsulation dot1Q 190
bridge-domain 152 dot1q-tunnel 2057
mls qos trust dscp
!
interface GE-WAN4/1.15212
encapsulation dot1Q 191
bridge-domain 152 dot1q-tunnel 2058
mls qos trust dscp
!
interface GE-WAN4/1.15213
encapsulation dot1Q 192
bridge-domain 152 dot1q-tunnel 2059
mls qos trust dscp
!
interface GE-WAN4/1.15214
encapsulation dot1Q 193
bridge-domain 152 dot1q-tunnel 2060
mls qos trust dscp
!
interface GE-WAN4/1.15215
encapsulation dot1Q 194
bridge-domain 152 dot1q-tunnel 2061
mls qos trust dscp
!
interface GE-WAN4/1.15216
encapsulation dot1Q 195
bridge-domain 152 dot1q-tunnel 2062
mls qos trust dscp
!
interface GE-WAN4/1.15217
encapsulation dot1Q 196
bridge-domain 152 dot1q-tunnel 2063
mls qos trust dscp
!
interface GE-WAN4/1.15218
encapsulation dot1Q 197
bridge-domain 152 dot1q-tunnel 2064
mls qos trust dscp
!
interface GE-WAN4/1.15219
encapsulation dot1Q 198
bridge-domain 152 dot1q-tunnel 2065
mls qos trust dscp
!
interface GE-WAN4/1.15220
encapsulation dot1Q 199
bridge-domain 152 dot1q-tunnel 2066
mls qos trust dscp
!
interface GE-WAN4/1.15221
encapsulation dot1Q 200
bridge-domain 152 dot1q-tunnel 2067
mls qos trust dscp
!
interface GE-WAN4/1.15222
encapsulation dot1Q 201
bridge-domain 152 dot1q-tunnel 2068
mls qos trust dscp
!
interface GE-WAN4/1.15223
encapsulation dot1Q 202
bridge-domain 152 dot1q-tunnel 2069
mls qos trust dscp
!
interface GE-WAN4/1.15224
encapsulation dot1Q 203
bridge-domain 152 dot1q-tunnel 2070
mls qos trust dscp
!
interface GE-WAN4/1.15225
encapsulation dot1Q 204
bridge-domain 152 dot1q-tunnel 2071
mls qos trust dscp
!
interface GE-WAN4/1.15226
encapsulation dot1Q 205
bridge-domain 152 dot1q-tunnel 2072
mls qos trust dscp
!
interface GE-WAN4/1.15227
encapsulation dot1Q 206
bridge-domain 152 dot1q-tunnel 2073
mls qos trust dscp
!
interface GE-WAN4/1.15228
encapsulation dot1Q 207
bridge-domain 152 dot1q-tunnel 2074
mls qos trust dscp
!
interface GE-WAN4/1.15229
encapsulation dot1Q 208
bridge-domain 152 dot1q-tunnel 2075
mls qos trust dscp
!
interface GE-WAN4/1.15230
encapsulation dot1Q 209
bridge-domain 152 dot1q-tunnel 2076
mls qos trust dscp
!
interface GE-WAN4/1.15231
encapsulation dot1Q 210
bridge-domain 152 dot1q-tunnel 2077
mls qos trust dscp
!
interface GE-WAN4/1.15232
encapsulation dot1Q 211
bridge-domain 152 dot1q-tunnel 2078
mls qos trust dscp
!
! This creates an out-of-range configuration that matches CE VLANs
! that are out of the configured CE VLAN range of 2048 to 2079
interface GE-WAN4/1.15233
encapsulation dot1Q 212
bridge-domain 152 dot1q-tunnel out-range
no mls qos trust
!
...
 

ポートチャネル インターフェイスを使用する QinQ 変換例

次に、2 つの GE-WAN 物理インターフェイスを含む QinQ リンク バンドルの設定例を示します。 bridge-domain コマンドは、ポートチャネル仮想インターフェイスのサブインターフェイスで設定されることに注意してください。

vlan internal allocation policy ascending
!
vlan 1, 100-1000, 2976-3008
!
policy-map pmap4
class class-default
set cos cos-inner
policy-map pmap1
class class-default
shape average 4000000
set cos cos-inner
policy-map pmap2
class class-default
shape average 8000000 32000 32000
policy-map pmap3
class class-default
shape average 20000000 80000 80000
!
!
interface Port-channel1
no ip address
logging event link-status
mode dot1q-in-dot1q access-gateway
!
interface Port-channel1.101
encapsulation dot1Q 101
bridge-domain 101 dot1q 101
service-policy output pmap1
!
interface Port-channel1.102
encapsulation dot1Q 102
bridge-domain 102 dot1q 102
service-policy output pmap2
!
interface Port-channel1.103
encapsulation dot1Q 103
bridge-domain 103 dot1q 103
!
interface Port-channel1.104
encapsulation dot1Q 104
bridge-domain 104 dot1q 104
!
interface Port-channel1.201
encapsulation dot1Q 201
bridge-domain 201 dot1q 201
!
!
! GigabitEthernet interfaces are not used for QinQ
! link bundling, but can be used for
! other purposes
interface GigabitEthernet4/1
no ip address
shutdown
!
interface GigabitEthernet4/2
no ip address
shutdown
!
interface GE-WAN4/1
no ip address
logging event link-status
negotiation auto
mls qos trust dscp
channel-group 1 mode on
!
interface GE-WAN4/2
no ip address
logging event link-status
negotiation auto
mls qos trust dscp
channel-group 1 mode on
!
interface GE-WAN4/3
no ip address
shutdown
!
interface GE-WAN4/4
no ip address
shutdown
...