オプティカル サービス モジュール ソフトウェア コンフィギュレーション ノート Cisco IOS Release 12.2SX
OC-3c/STM-1、OC-12c/STM-4、および OC-48c/STM-16 SONET/SDH OSM の 設定
OC-3c/STM-1、OC-12c/STM-4、および OC-48c/STM-16 SONET/SDH OSM の設定
発行日;2012/01/15 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

OC-3c/STM-1、OC-12c/STM-4、および OC-48c/STM-16 SONET/SDH OSM の設定

サポート対象の機能

SONET/SDH 規格の適合性

SONET/SDH のエラー、アラーム、およびパフォーマンスのモニタリング

SONET/SDH の同期

WAN プロトコル

DPT プロトコル

BCP

BCP による QoS サポート

ルーティングおよびスケーラビリティ プロトコル

ネットワーク管理

QoS プロトコル

セキュリティ プロトコル

MPLS

POS の概要

SONET の距離制限

インターフェイスの設定

POS/SDH OSM の初期設定

インターフェイスの設定

POS/SDH OSM 設定のカスタマイズ

POS/SDH OSM インターフェイスの選択

フレーム同期の設定

SONET オーバーヘッドの指定

POS SPE スクランブリングの設定

show コマンドによるシステム ステータスの確認

APS の設定

実行インターフェイスの設定

保護インターフェイスの設定

基本的な APS の設定

複数 APS インターフェイスの構成

フレームリレーおよびフレームリレー トラフィック シェーピングの設定

フレームリレーの制限および制約

フレームリレー トラフィック シェーピングの設定例

DPT プロトコルの設定

BCP の設定

使用上の注意事項および制限

QoS サポート

OC-3c/STM-1 POS モジュールの設定例

マルチポイント ブリッジングの設定

制限および使用上の注意事項

前提条件

フレームリレー インターフェイスのマルチポイント ブリッジングの設定

POS OSM 上での完全優先 LLQ サポートの設定

OC-3c/STM-1、OC-12c/STM-4、および OC-48c/STM-16 SONET/SDH OSM の設定

この章では、OC-3c/STM-1、OC-12c/STM-4、および OC-48c/STM-16 Packet over SONET(POS)/Synchronous Digital Hierarchy(SDH; 同期デジタル ハイアラーキ)OSM(オプティカル サービス モジュール)について説明します。

この章の内容は次のとおりです。

「サポート対象の機能」

「POS の概要」

「インターフェイスの設定」

サポート対象の機能

ここでは、OC-3c/STM-1、OC-12c/STM-4、および OC-48c/STM-16 POS/SDH OSM 上でサポートされる標準の Cisco IOS POS/SDH 機能について説明します。

「SONET/SDH 規格の適合性」

「SONET/SDH のエラー、アラーム、およびパフォーマンスのモニタリング」

「SONET/SDH の同期」

「WAN プロトコル」

「DPT プロトコル」

「BCP」

「ルーティングおよびスケーラビリティ プロトコル」

「ネットワーク管理」

「QoS プロトコル」

「セキュリティ プロトコル」

「MPLS」

「マルチポイント ブリッジングの設定」

SONET/SDH 規格の適合性

SONET/SDH 規格に適合している機能は、次のとおりです。

Bellcore GR-253-CORE

ITU-T G.707、G.783、G.957、G.958

1+1 SONET Automatic Protection Switching(APS; 自動保護スイッチング)(G.783 Annex A に準拠)

1+1 SDH Multiplex Section Protection(MSP)(G.783 Annex A に準拠)

APS リフレクタ モード

SONET/SDH のエラー、アラーム、およびパフォーマンスのモニタリング

サポートされる SONET/SDH エラー、アラーム、およびパフォーマンスのモニタリングは、次のとおりです。

Signal Failure Bit Error Rate(SFBER; 信号損失ビット エラー レート)

Signal Degrade Bit Error Rate(SDBER; 信号劣化ビット エラー レート)

信号ラベル ペイロード作成(C2)

パス トレース バイト(J1)

セクション:

Loss of Signal(LOS; 信号損失)

Loss of Frame(LOF; フレーム損失)

B1 のエラー カウント

B1 の TCA(スレッシュホールド超過アラート)

回線:

Line Alarm Indication Signal(LAIS; 回線アラーム検出信号)

Line Remote Defect Indication(LRDI; 回線リモート障害検出)

Line Remote Error Indication(LREI; 回線リモート エラー検出)

B2 のエラー カウント

B2 の TCA

パス:

Path Alarm Indication Signal(PAIS; パス アラーム検出信号)

Path Remote Defect Indication(PRDI; パス リモート障害検出)

Path Remote Error Indication(PREI; パス リモート エラー検出)

B3 のエラー カウント

B3 の TCA

Loss of Pointer(LOP; ポインタ損失)

New Pointer Events(NEWPTR)

Positive Stuffing Event(PSE)

Negative Stuffing Event(NSE)

SONET/SDH の同期

サポートされるSONET/SDH 同期化機能は、次のとおりです。

ローカル(内部)タイミング(ダーク ファイバまたは WDM 装置を介したルータ間接続用)

ループ(ライン)タイミング(SONET/SDH 装置への接続用)

全動作温度で +/-20 ppm のクロック精度

WAN プロトコル

サポートされる WAN プロトコルは、次のとおりです。

IETF RFC 1661、PPP(ポイントツーポイント プロトコル)

IETF RFC 1662、High-Level Data Link Control(HDLC; ハイレベル データリンク制御)フレーム同期での PPP

IETF RFC 2615、PPP over SONET/SDH(1+x43 の自己同期ペイロード スクランブリングを使用)

APS および MSP に関する Cisco Protect Group Protocol over UDP/IP(ポート 172)

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)


) 2 ポートの OC-48c/STM-16 POS/DPT OSM は、MPLS をサポートしていますが、EoMPLS はサポートしていません。


Ethernet over Multiprotocol Label Switching(EoMPLS)

フレームリレー

フレームリレーの POS インターフェイスの設定については、次の URL にアクセスし、『Cisco IOS Wide-Area Networking Configuration Guide』 Release 12.1 の「Configuring Frame Relay」および『Cisco IOS Wide-Area Networking Command Reference』 Release 12.1 を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdfrely.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wrdfrely.htm

フレームリレーのトラフィック シェーピングの設定については、次の URL にアクセスし、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Configuring Distributed Traffic Shaping」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt4/qcfdts.htm

プラットフォーム別のコンフィギュレーション、コマンド、および制限事項については、「フレームリレーおよびフレームリレー トラフィック シェーピングの設定」 を参照してください。


) 2 ポートの OC-48c/STM-16 POS/DPT OSM は、フレームリレーをサポートしていません。


DPT プロトコル

2 ポートの OC-48c/STM-16 POS/DPT OSM(OSM-2OC48/1DPT)は、次の Dynamic Packet Transport(DPT; ダイナミック パケット トランスポート)プロトコルをサポートしています。

DPT Spatial Reuse Protocol(SRP)MAC

DPT SRP fairness algorithm(SRP-fa)

DPT SRP Intelligent Protection Switching(IPS)

SRR(Single Ring Recovery)

BCP

Bridging Control Protocol(BCP; ブリッジング制御プロトコル)は、SONET ネットワーク上でイーサネット フレームの転送を可能にし、メトロポリタン エリアを通るエンタープライズ LAN バックボーン トラフィックの高速化を実現します。OSM に BCP を実装することには、IEEE 802.1D、IEEE 802.1Q VLAN(仮想 LAN)、および高速スイッチド LAN のサポートが含まれます。

次に、RFC 3518 規定の BCP をサポートする OSM を示します。

OC-3 POS:

OSM-4OC3-POS-SI

OSM-4OC3-POS-SI+

OSM-8OC3-POS-SI、-SL

OSM-8OC3-POS-SI+、-SL+

OSM-16OC3-POS-SI、-SL

OSM-16OC3-POS-SI+

OC-12 POS:

OSM-2OC12-POS-MM、-SI、-SL

OSM-2OC12-POS-MM+、-SI+

OSM-4OC12-POS-MM、-SI、-SL

OSM-4OC12-POS-SI+

OC-48 POS:

OSM-1OC48-POS-SS、-SI、-SL

OSM-1OC48-POS-SS+、-SI+、-SL+

OSM-2OC48-POS/DPT-SS、-SI、-SL


) インターオペラビリティのために、次のことに留意してください。BCP を搭載した OSM POS インターフェイスではレイヤ 2 とレイヤ 3 のトラフィックを同時に転送可能ですが、他のシスコ製品のプラットフォーム上の POS インターフェイスでは、BCP 有効時の転送はレイヤ 2 に限定されます。


図3-1 に、BCP を使用して SONET ネットワーク経由で VLAN トラフィックを透過的に転送するトポロジーを示します。

図3-1 SONET ネットワークの BCP トポロジー

 

図3-2に、VLAN ID を使用して複数のカスタマーに Virtual Private Network(VPN; 仮想私設網)を作成し、BCP によって SONET ネットワーク経由で VPN トラフィックを転送するトポロジーを示します。

図3-2 VPN ネットワークの BCP トポロジー

 

BCP の設定については、「BCP の設定」を参照してください。

BCP による QoS サポート

Quality of Service(QoS; サービス品質)は、パケットのプライオリティを決めるラベルの 3 つの EXP ビットを使用した BCP リンクでサポートされます。Label Edge Router(LER; ラベル エッジ ルータ)間で QoS をサポートするには、VC ラベルおよびトンネル ラベルの両方に EXP ビットを設定します。トンネル ラベルは最後から 2 番めのルータで削除されるため、EXP ビットは VC ラベル内に設定する必要があります。

ルーティングおよびスケーラビリティ プロトコル

サポートされるルーティングおよびスケーラビリティ プロトコルは、次のとおりです。

Distributed Cisco Express Forwarding(dCEF)

WCCP v2

Policy Feature Card 2(PRC2; ポリシー フィーチャ カード 2)の場合のみ、GRE カプセル化トンネリング(ソフトウェアでサポート)


) Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)トンネル IP の送信元および送信先 VPN Routing/Forwarding instance(VRF; VPN ルーティング/転送インスタンス)メンバーシップは、tunnel vrfコマンドではサポートされていません。


ネットワーク管理

サポートされるネットワーク管理機能は、次のとおりです。

ローカル(診断)ループバック

ネットワーク ループバック

NetFlow データ エクスポート

IP over Data Communications Channel(DCC; データ通信チャネル)


) 2 ポートの OC-48c/STM-16 POS/SDH OSM は、DCC をサポートしていません。


一定のタイミング(現在、15 分おき、15 の倍数分おき、1 日おき)で収集する RFC 1595 パフォーマンス統計情報

リジェネレータ セクション

多重化セクション

パス エラー秒数

重大エラー秒数

重大エラー フレーム同期秒数

QoS プロトコル

サポートされる QoS 機能は、次のとおりです。

モジュールあたり 2,048 の QoS キュー(32 のサービスクラス、64 の DSCP キュー/クラス)

クラスベース トラフィック シェーピング

Differentiated Services Control Point(DSCP)分類

IP precedence 分類

Class-Based Weighted Fair Queuing(CBWFQ; クラスベース均等化キューイング)

Low Ratency Queuing(LLQ; 低遅延キューイング)

フレームリレー、HDLC、および PPP のカプセル化の階層型トラフィック シェーピング


) OC-48 POS/DPT モジュールは LLQ、CBWFQ、または DSCP 分類をサポートしません。クラスベース トラフィック シェーピングは入力トラフィックのみサポートされます。


セキュリティ プロトコル

ここでは、サポートされるセキュリティ機能を示します。

標準および拡張 Access Control List(ACL; アクセス制御リスト)

名前付き、ダイナミック、リフレクシブ、および時間ベースの ACL

IPv4 NAT(ソフトウェア サポート)

MPLS

MPLS は、すべての Catalyst 6500 および Cisco 7600 シリーズ モジュールでサポートされます。

プラットフォーム固有の制限事項と制約、およびサポートされている機能については、 第11章「OSM 上での MPLS の設定」 を参照してください。

MPLS および OSM 上での MPLS の設定方法については、次の URL にアクセスし、Multiprotocol Label Switching on Cisco Routers フィーチャ モジュールを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/mpls4t.htm

MPLS の概要については、次の URL にアクセスし、『Multiprotocol Label Switching』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/index.htm

POS の概要

POS は、2 地点間で IP トラフィックを高速伝送する方式の 1 つです。このテクノロジーは、PPP と SONET および SDH インターフェイスを結合します。

SONET は、51.840 Mbps ~ 2.5 Gbps(同期トランスポート信号、STS-1 ~ STS-48)以上の階層型速度での光デジタル伝送に関して、American National Standards Institute(ANSI; 米国規格協会)規格(T1.1051988)が定義したオクテット同期多重化方式です。SDH は、155.520 Mbps(STM-1)~ 2.5 Gbps(STM-16)以上の階層型速度で行われる光デジタル伝送に関する同等の国際規格です。SONET の電気仕様は、シングルモード光ファイバ、マルチモード光ファイバ、および CATV 75 ohm 同軸ケーブルに関して定義されています。OC-3c/STM-1、OC-12c/STM-4、および OC-48c/STM-16 POS/SDH OSM を使用すると、シングルモードおよびマルチモード光ファイバを介して、Optical Carrier 3、12、および 48(OC-3、OC-12、および OC-48)の速度で伝送できます。

SONET/SDH の伝送速度は、51.840 Mbps の整数倍です。現在、次の伝送倍数が指定されており、広く使用されています。

OC-3c/STM-1c ― 155.520 Mbps

OC-12c/STM-4c ― 622.080 Mbps

OC-48c/STM-16c ― 2488.320 Mbps

POS 仕様(RFC 1619)では、SONET/SDH リンクでの PPP カプセル化の使用について規定されています。SONET/SDH は定義上、ポイントツーポイント回線であり、PPP はこのようなリンク上での使用に適しています。PPP は、SONET/SDH トランスポートをオクテット型の全二重同期リンクとして扱います。PPP は物理レイヤにオクテット インターフェイスを提供します。オクテット ストリームは SONET/SDH Synchronous Payload Envelope(SPE; 同期ペイロード エンベロープ)にマッピングされ、オクテット境界が SPE のオクテット境界と位置合わせされます。PPP フレームは、SPE ペイロード内の行で特定されます。フレームは可変長なので、SPE 境界を越えることができます。

POS の基本速度は、OC-3/STM-1、すなわち 155.520 Mbps です。使用できるデータ帯域幅は 149.760 Mbps で、これは OC-3c/STM-1 SPE からセクション、回線、およびパスのオーバーヘッドを取り除いたものです。

SONET の距離制限

光ファイバ伝送仕様では、2 種類の光ファイバ(シングルモードおよびマルチモード)が定義されています。シングルモードのカテゴリ内で、さらに 3 種類の伝送タイプ(短距離、中距離、および長距離)が定義されています。マルチモードカテゴリでは、短距離の 1 種類だけです。

ケーブルの距離制限およびパワー バジェットについては、次の URL を参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/hardware/osmodule/02prep.htm

インターフェイスの設定

ここでは、OC-3c/STM-1、OC-12c/STM-4、および OC-48c/STM-16 OSM を設定する方法について説明します。

「POS/SDH OSM の初期設定」

「インターフェイスの設定」

「POS/SDH OSM 設定のカスタマイズ」

「show コマンドによるシステム ステータスの確認」

「APS の設定」

「フレームリレーおよびフレームリレー トラフィック シェーピングの設定」

「DPT プロトコルの設定」

「BCP の設定」

「OC-3c/STM-1 POS モジュールの設定例」

POS/SDH OSM の初期設定

新しい POS/SDH OSM を取り付ける場合、または既存インターフェイスの設定を変更する場合、イネーブル EXEC モードで configure コマンドを使用し、コンフィギュレーション モードを開始する必要があります。 表3-1 に、イネーブルに設定されているモジュールのデフォルト値を示します。詳細については、「POS/SDH OSM 設定のカスタマイズ」を参照してください。

 

表3-1 POS/SDH モジュールのデフォルト設定値

パラメータ
コンフィギュレーション コマンド
デフォルト値

キープアライブ

[ no ] keepalive

keepalive

カプセル化

encapsulation [ hdlc | ppp | frame-relay ]

hdlc

Cisco Discovery Protocol(CDP)

[ no ] cdp enable

cdp イネーブル

Maximum Transmission Unit(MTU; 最大伝送ユニット)

[ no ] mtu bytes

4,470 バイト

フレーム同期

pos framing [ sdh | sonet ]

SONET OC-3c、OC-12c、OC-48c

帯域幅

[ no ] bandwidth kilobits

155000; 622000; 2500000

SONET オーバーヘッド

pos flag [ c2 value | j0 value | s1s0 value | s1 ignore]

c2 を 0xcf、j0 を 0xcc、s1s0 を 0 に設定、s1 は受信した s1 バイトの設定を無視するように設定

内部ループ

[ no ] loop [ internal | line ]

ループバックなし

POS SPE スクランブリング

[ no ] pos scramble-atm

POS SPE スクランブルなし

Cyclic Redundancy Check(CRC; 巡回冗長検査)

crc [ 16 | 32 ]

32

クロックソース

clock source [ internal | line ]

line

インターフェイスの設定

新しい POS/SDH OSM が正しく搭載されていることを確認してから、イネーブル EXEC モードで configure コマンドを使用し、新しいインターフェイスを設定します。インターフェイスの IP アドレスなど、必要な情報を揃えておいてください。

次に、基本的な設定の手順を示します。この手順ではインターフェイスをイネーブルにして、IP ルーティングを指定します。

Catalyst 6500 シリーズ スイッチおよび Cisco 7600 シリーズ ルータは、 slot/port の形式で表されたモジュールのスロット番号およびポート番号に基づいて、インターフェイスのアドレスを識別します。たとえば、1 ポートの OC-48c/STM-16 POS/SDH OSM がスロット 4 に搭載されている場合、インターフェイスのスロット/ポートアドレスは 4/1 です。カードが 1 ポートだけの場合でも、 slot/port の形式で指定する必要があります。

configure コマンドを使用するには、 enable コマンドを使用して、EXEC コマンド インタープリタのイネーブル レベルを開始する必要があります。パスワードが設定されている場合には、パスワードの入力が要求されます。

POS/SDH OSM を設定する手順は、次のとおりです(特に明記されていないかぎり、各設定手順の最後に、 Return キーを押してください)。

 

コマンド
説明

ステップ 1

Router# show version

show version コマンドを入力し、システムがモジュールを認識していることを確認します。

ステップ 2

Router# show interface

show interface コマンドを入力し、各ポートのステータスを調べます。

ステップ 3

Router# configure terminal

コンフィギュレーション モードを開始し、コンフィギュレーション サブコマンドの入力元として、コンソール端末を指定します。

ステップ 4

Router(config)# ip routing

ip routing コマンドを入力し、IP ルーティングをイネーブルにします。

ステップ 5

Router(config)# interface pos slot/port

interface コマンドに続けて type および slot/port を入力し、新しく設定するインターフェイスを指定します。

ステップ 6

Router(config-if)# ip address ip-address mask [secondary]

インターフェイスに IP アドレスおよびサブネット マスクを割り当てます。

ステップ 7

Router(config-if)# encapsulation encapsulation-type

このインターフェイスの HDLC カプセル化が有効であることを確認します。 encapsulation-type は、キーワード hdlc ppp または frame-relay のいずれかです。

ステップ 8

Router(config-if)# clock source { line | internal }

クロックソースのデフォルト値が正しいことを確認します。デフォルト値は line です。ネットワークをクロックソースにする場合は、この値を使用します。

2 台の Cisco 7600 シリーズ ルータまたは Catalyst 6500 シリーズ スイッチをバックツーバックで接続する場合、あるいはクロックの利用できないダーク ファイバを介して接続する場合は、通常、clock source internal コマンドを使用します。いずれの場合も、各装置のクロックソースを internal に設定してください。

ステップ 9

Router(config-if)# no shutdown

インターフェイス ステートをアップに変更し、インターフェイスをイネーブルにします。

ステップ 10

Router(config-if)# keepalive

状況に応じて、キープアライブ メッセージをオンまたはオフに設定します。キープアライブ メッセージは、HDLC などのカプセル化プロトコルの場合に便利です。キープアライブはデフォルトでオンです。

ステップ 11

Router# copy running-config startup-config

新しい設定をメモリに書き込みます。

POS/SDH OSM 設定のカスタマイズ

ここでは、新しいプラットフォーム固有のコマンドについて説明します。OSM の設定で使用される他のコマンドについては、Cisco IOS Release 12.1 のコマンド リファレンスを参照してください。

ネットワーク環境に合わせて、あらゆる POS/SDH OSM コンフィギュレーション パラメータのデフォルト値を変更できます。POS/SDH OSM の設定をカスタマイズする場合は、次の作業が必要です。

「POS/SDH OSM インターフェイスの選択」

「フレーム同期の設定」

「SONET オーバーヘッドの指定」

「POS SPE スクランブリングの設定」

POS/SDH OSM インターフェイスの選択

コンフィギュレーション コマンドでは、Packet over SONET を表す pos で、OC-3c/STM-1、OC-12c/STM-4、または OC-48c/STM-16 インターフェイスを指定します。特定の POS インターフェイスを選択するには、コンフィギュレーション モードで interface pos slot/port コマンドを使用します。

Router(config)# interface pos slot/port

フレーム同期の設定

pos framing コマンドを使用すると、フレーム同期を SONET OC または SDH STM に設定できます。デフォルト値は SONET です。

Router(config-if)# pos framing [sdh|sonet]

SONET オーバーヘッドの指定

pos flag コマンドを使用すると、フレーム ヘッダーの特定の要素に値を指定できます。

Router(config-if)# pos flag [c2 value] [j0 value] [s1s0 value]
 

この場合

c2 はパス信号識別子です。 value は次のいずれか 1 つです。

0xCF = PPP または HDLC(デフォルト)

0x13 = ATM

j0 はセクション トレース バイトです。 value は、日本の一部の SDH 装置とのインターオペラビリティが必要な場合は 0x1 です。デフォルト値は 0xCCです。

s1s0 は、ペイロード ポインタ バイトの一部です。 value は、次のいずれか 1 つです。

0 = OC-3c(デフォルト)

2 = AU-4

POS SPE スクランブリングの設定

POS スクランブリング コマンドを使用すると、POS SPE ペイロードのスクランブルが可能です。デフォルトでは、POS SPE のスクランブルを行いません。

Router(config-if)#[no] pos scramble-atm
 

show コマンドによるシステム ステータスの確認

各 OSM は、設定、トラフィック、およびエラーに関する情報を保持しています。 show コマンドを使用してこの情報にアクセスできます。

次に、 show コマンドを使用してモジュールとシステムのステータスを確認する例を示します。

show interfaces コマンドおよび show interfaces pos slot/port コマンドを使用して、システム インターフェイス情報を表示します。次に、スロット 5 に搭載されたモジュールのポート 1 に show interface pos slot/port コマンドを使用した例を示します。

Router# show interfaces pos 5/1
POS5/1 is administratively down, line protocol is down
Hardware is Packet over SONET
MTU 4470 bytes, BW 155000 Kbit, DLY 100 usec, rely 255/255, load 1/255
Encapsulation HDLC, crc 32, loopback not set, keepalive set (10 sec)
Scramble disabled
Last input never, output never, output hang never
Last clearing of "show interface" counters never
queuing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 parity
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 applique, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
...
(テキスト出力は省略)
 

show version コマンドを使用し、システム ハードウェアの構成(搭載されている各モジュール タイプの数)、Cisco IOS ソフトウェアのバージョン、コンフィギュレーション ファイルの名前と保管場所、およびブート イメージを表示します。次に、Catalyst 6509 スイッチに show version コマンドを使用した例を示します。

Router# show version
WS-C6509 Software, Version NmpSW: 6.1(2)
Copyright (c) 1995-2001 by Cisco Systems
NMP S/W compiled on Jan 25 2001, 12:28:23
System Bootstrap Version: 6.1(2)
Hardware Version: 2.0 Model: WS-C6509 Serial #: SCA042101NG
Mod Port Model Serial # Versions
--- ---- ------------------- ----------- ----------------------------------- ---
1 2 WS-X6K-SUP2-2GE SAD044102J9 Hw : 1.1
Fw : 6.1(2)
Fw1: 6.1(3)
Sw : 6.1(2)
Sw1: 6.1(2)
WS-F6K-PFC2 SAD04470KPP Hw : 1.0
3 8 WS-X6408-GBIC SAD03090264 Hw : 1.4
Fw : 4.2(0.24)VAI78
Sw : 6.1(2)
4 8 WS-X6408A-GBIC SAD043500LE Hw : 1.3
Fw : 5.4(2)
Sw : 6.1(2)
5 4 OSM-4OC12-POS-MM SAD050202EJ Hw : 0.101
Fw : 12.1(6.5)E1
Sw : 12.1(6.5)E1
6 24 WS-X6224-100FX-MT SAD03040765 Hw : 1.2
Fw : 4.2(0.24)VAI78
Sw : 6.1(2)
9 48 WS-X6248 SAD03200773 Hw : 1.1
Fw : 4.2(0.24)VAI78
Sw : 6.1(2)
15 1 WS-F6K SAD044803FK Hw : 1.1
Fw : 12.1(3a)E4
Sw : 12.1(3a)E4
DRAM FLASH NVRAM
Module Total Used Free Total Used Free Total Used Free
------ ------- ------- ------- ------- ------- ------- ----- ----- -----
1 130944K 57316K 73628K 16384K 6647K 9737K 512K 302K 210K
Uptime is 2 days, 19 hours, 50 minutes
Console> (enable))
 

show protocols コマンドを使用して、設定されているあらゆるレベル 3 プロトコルについて、グローバル(システム全体)およびインターフェイス固有のステータスを表示します。

show running-config コマンドを使用して、RAM の現在の実行コンフィギュレーションを表示します。

Router# show running-config
Building configuration...
Current configuration:
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Maxwell
!
enable secret 5 $1$ZBC0$tJO8EeP3VI769LAw.3edJ1
enable password xxxx
!
ip host ray 172.27.136.253
ip host crusty 171.69.209.28
ip domain-name cisco.com
ip name-server 171.69.209.10
clock timezone EST -5
clock summer-time EDT recurring
!
interface POS0/0
no ip address
shutdown
crc 32
!
interface POS0/1
no ip address
shutdown
crc 32
!
(テキスト出力は省略)

APS の設定

APS により、POS 回線の切り替えが可能です。これは、通常 SONET 装置を電気通信装置に接続する場合に必要になります。APS を設定すると、介在する SONET 装置から SONET ネットワークに保護 POS インターフェイスが提供され、回線上で保護 POS インターフェイスが実行 POS インターフェイスになります。

保護インターフェイスは、実行インターフェイスのあるルータの IP アドレスを指定して設定します。APS Protect Group Protocol が、実行インターフェイスを制御するプロセスと保護インターフェイスを制御するプロセス間の通信を引き受けます。APS Protect Group Protocol を使用すると、ルータ障害、チャネル信号の劣化または損失、または手動介入が発生した場合に、POS インターフェイスを切り替えることができます。

APS のサポートには、SONET 接続が 2 つ必要です。電気通信環境では、SONET 回線を APS として設定する必要があります。オペレーション、モード、および復帰オプションを設定することも必要です。SONET 接続が別々の 2 台のルータでホーミングされる場合(標準設定)、APS 通信用として、2 台のルータ間に Out-Of-Band(OOB; 帯域外)通信チャネルを設定する必要があります。

APS を設定する場合は、先に実行インターフェイスを設定し、さらに APS OOB 通信パスとして使用するインターフェイスの IP アドレスを指定することを推奨します。


) 保護インターフェイスがアクティブ回線になり、現用回線が検出時にディセーブルにされることがないように、実行インターフェイスを設定してから保護インターフェイスを設定します。


APS の詳細および他の APS 機能の設定情報については、次の URL にアクセスし、『Cisco IOS Interface Configuration Guide』 Release 12.1 を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_c/index.htm

実行インターフェイスの設定

実行インターフェイスを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router(config)# interface pos slot / port

実行インターフェイスとして設定する POS インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-controller)# aps working circuit-number

このインターフェイスを実行インターフェイスとして設定します。

ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show controllers pos

Router# show interface pos

Router# show aps

Router# show aps controller

インターフェイスが正しく設定されているかどうかを確認するために、POS コントローラおよびインターフェイスの情報を表示します。


) ルータに複数の保護インターフェイスが設定されている場合、各インターフェイスに aps group コマンドを設定してから、対応する aps protect コマンドを設定する必要があります。


保護インターフェイスの設定

保護インターフェイスを設定するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンド
説明

ステップ 1

Router(config)# interface pos slot / port

保護インターフェイスとして設定する POS インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# aps protect circuit-number ip-address

このインターフェイスを保護インターフェイスとして設定します。実行インターフェイスのあるルータの IP アドレスを指定します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show controllers pos

Router# show interface pos

Router# how aps

インターフェイスが正しく設定されているかどうかを確認するために、POS コントローラおよびインターフェイスの情報を表示します。

基本的な APS の設定

ルータ A とルータ B 上で APS を設定する例を示します(図3-3 を参照)。この例では、ルータ A に実行インターフェイスを設定し、ルータ B に保護インターフェイスを設定します。ルータ A の実行インターフェイスが使用できなくなると、ルータ B 上の保護インターフェイスに接続が自動的に切り替えられます。実行インターフェイスと保護インターフェイスは、コントローラ レベルで設定します。

図3-3 基本的な APS の構成

 


ステップ 1 実行インターフェイスのあるルータ A の設定は、次のとおりです。

Router# configure terminal
Router(config)# interface loopback 1
Router(config-if)# ip address 7.7.7.7 255.255.255.0
Router(config)# exit
Router(config)# interface pos 2/0
Router(config-if)# aps working 1
router(config-if)# pos ais-shut
Router(config-if)# end
Router#
 

ステップ 2 保護インターフェイスのあるルータ B の設定は、次のとおりです。

Router# configure terminal
Router(config)# interface loopback 2
Router(config-if)# ip address 7.7.7.6 255.255.255.0
Router(config)# exit
Router(config-if)# interface pos 3/0
Router(config-if)# aps protect 1 7.7.7.7
router(config-if)# pos ais-shut
Router(config-if)# end
Router#
 


 

複数 APS インターフェイスの構成

複数の保護/実行インターフェイスを設定する場合は、 aps group コマンドを使用します。図3-4 に、複数の実行/保護インターフェイスをグループ分けして設定する例を示します。この例では、実行インターフェイスと保護インターフェイスを指定してルータ A を設定し、ルータ B も実行インターフェイスと保護インターフェイスを指定して設定します。ルータ A の実行インターフェイス 2/0 が使用できなくなると、ルータ B の保護インターフェイス 3/0 に接続が切り替えられます。これはどちらも APS グループ 10 に属しているためです。ルータ B の実行インターフェイス 2/0 が使用できなくなった場合も同様です。接続は同じ APS グループ 20 に属しているため、ルータ A の保護インターフェイス 3/0 に切り替えられます。

図3-4 複数の実行/保護インターフェイスの構成

 


) 保護インターフェイスがアクティブ回線になり、現用回線が検出時にディセーブルにされることがないように、実行インターフェイスを設定してから保護インターフェイスを設定してください。



ステップ 1 ルータ A では次のように設定し、グループ 10 用の実行インターフェイスとグループ 20 用の保護インターフェイスを指定します。

router# configure terminal
router(config)# interface ethernet 0/0
router(config-if)# ip address 7.7.7.6 255.255.255.0
router(config-if)# exit
router(config)# interface POS 2/0
router(config-if)# aps group 10
router(config-if)# aps working 1
router(config-if)# exit
router(config)# interface POS 3/0
router(config-if)# aps group 20
router(config-if)# aps protect 1 7.7.7.7
router(config-if)# end
router#
 

ステップ 2 ルータ B では次のように設定し、グループ 10 用の保護インターフェイスとグループ 20 用の実行インターフェイスを指定します。

router# configure terminal
router(config)# interface ethernet 0/0
router(config-if)# ip address 7.7.7.7 255.255.255.0
router(config-if)# exit
router(config)# interface POS 2/0
router(config-if)# aps group 20
router(config-if)# aps working 1
router(config-if)# exit
router(config)# interface POS 3/0
router(config-if)# aps group 10
router(config-if)# aps protect 1 7.7.7.6
router(config-if)# end
router#
 


 

フレームリレーおよびフレームリレー トラフィック シェーピングの設定

ここでは、フレームリレーの設定、プラットフォーム固有のコマンドおよび制限事項について説明します。

「フレームリレーの制限および制約」

「フレームリレー トラフィック シェーピングの設定例」

フレームリレーのインターフェイスの設定については、次の URL にアクセスし、『Cisco IOS Wide-Area Networking Configuration Guide』 Release 12.1 の「Configuring Frame Relay」および『Cisco IOS Wide-Area Networking Command Reference』 Release 12.1 を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdfrely.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wrdfrely.htm

フレームリレーのトラフィック シェーピングの設定については、次の URL にアクセスし、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Configuring Distributed Traffic Shaping」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt4/qcfdts.htm

フレームリレーの制限および制約

次の制限および制約がフレームリレーに適用されます。

フレームリレーは SVC 上ではサポートされません。

フレームリレー用に設定したメイン インターフェイスに IP アドレスを割り当てることはできません。

フレームリレーがサポートされるのはポイントツーポイント接続だけです。

フレームリレー スイッチング機能はサポートされません。フレームリレー スイッチングを設定できるのは、frame-relay intf-type dce オプションの設定時に限定されます。

フレームリレーのフラグメンテーションおよび圧縮はサポートされません。

First-in first-out(FIFO; 先入れ先出し)キューイングだけがサポートされます。

Data Link Connection Identifier(DLCI)を設定できるのはサブインターフェイスだけです。メイン インターフェイスには設定できません。

クラスベースのトラフィック シェーピングだけがサポートされます。次のコマンドはサポートされていません。

Router(config-pmap-c)# shape [average | peak] mean-rate [[burst-size] [excess-burst-size]]

Router(config-pmap-c)# priority {kbps | percent percent} [bytes]

Router(config-pmap-c)# fair-queue number-of-queues

Router(config-map-class)# frame-relay adaptive-shaping [becn | foresight]

Router(config-map-class)# frame-relay cir {in | out} bps

Router(config-map-class)# frame-relay {bc | be} {in | out} bits

Router(config-map-class)# frame-relay traffic-rate average [peak]

Router(config-map-class)# frame-relay priority-group list-number

Router(config-map-class)# frame-relay fragment fragment_size

Router(config-if)# frame-relay payload-compress packet-by-packet

Router(config-if)# frame-relay de-group group-number dlci

Router# show traffic-shape queue

フレームリレー トラフィック シェーピングの設定例

フレームリレー トラフィック シェーピングを設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router(config-pmap)# class-map [match-all | match-any]

定義したクラスに対してパケットを照合するためのクラス マップを作成し、一致条件を指定します。クラスの一致条件は、IP DSCP または IP precedence を基準にすることができます。

ステップ 2

Router(config-pmap)# match

一致条件を指定します。

ステップ 3

Router(config)# policy-map policy_map

1 つまたは複数のインターフェイスに適用できるポリシー マップを作成または変更し、サービス ポリシーを指定します。

ステップ 4

Router(config-pmap)# class class-name

サービス ポリシーに含めるクラスを定義します。

ステップ 5

Router(config-pmap-c)# shape average mean-rate [burst-size]

指定されたビット レートに合わせてトラフィックをシェーピングします。

ステップ 6

Router(config)# map-class frame-relay map-class-name

マップ クラスを指定し、QoS の値を定義します。

ステップ 7

Router(config-map-class)# no frame-relay adaptive-shaping

バックワードの通知をディセーブルにします。

ステップ 8

Router(config-map-class)# service-policy input policy-map

指定したポリシー マップを、入力インターフェイスに適用します。

ステップ 9

Router(config-map-class)# service-policy output policy-map

指定したポリシー マップを、出力インターフェイスに適用します。

ステップ 10

Router(config)# interface interface

ポリシー マップの適用先インターフェイスを指定します。

ステップ 11

Router(config-subif)# ip address ip_address mask

サブインターフェイスに IP アドレスを割り当てます。

ステップ 12

Router(config-subif)# no cdp enable

CDP をディセーブルにします。

ステップ 13

Router(config-subif)# frame-relay interface-dlci dlci

指定したフレームリレー サブインターフェイスに、DLCI を割り当てます。

ステップ 14

Router(config-fr-dlci)# class class-name

map-class frame-relay コマンドで定義したマップ クラス名を指定します。

サブインターフェイスの CDP は、明示的にディセーブルに設定することを推奨します。サブインターフェイスで CDP を使用する場合は、入力キューの深度を調整しなければならないことがあります。着信 CDP パケット数に対応させるには、メイン インターフェイスの入力キュー深度を、CDP をイネーブルにしたサブインターフェイス数よりも、わずかに大きく設定します。デフォルトのキュー深度は 75 です。この値は、hold-queue インターフェイス コマンドで変更できます。

Router(config-if)# hold-queue 300 in
 

次に、入力と出力の両方のトラフィック フローで、DLCI 18 のトラフィックを 8 Mbps にシェーピングする設定の例を示します。

Router(config)# class-map match-all fr-classmap
Router(config-cmap)# match any
Router(config-cmap)# exit
Router(config)# policy-map fr-map
Router(config-pmap)# class fr-classmap
Router(config-pmap-c)# shape average 8000000 32000 32000
Router(config-pmap-c)# exit
Router(config)# map-class frame-relay fr-shaping
Router(config-map-class)# no frame-relay adaptive-shaping
Router(config-map-class)# service-policy input fr-pmap
Router(config-map-class)# service-policy output fr-pmap
Router(config-map-class)# exit
Router(config)# interface POS7/15.1 point-to-point
Router(config-subif)# ip address 72.0.0.1 255.255.0.0
Router(config-subif)# no cdp enable
Router(config-subif)# frame-relay interface-dlci 18
Router(config-fr-dlci)# class fr-shaping
Router(config-fr-dlci)# exit

DPT プロトコルの設定

DPT は、信頼性の高いオプティカル パケット リングのインフラストラクチャ上で、インターネットと IP サービスを拡大し配信するパケット リング テクノロジーです。

DPT の全般情報については、次の URL にアクセスし、『Dynamic Packet Transport Feature Guide』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/srpapsgs.htm

2 ポートの OC-48c/STM-16c OSM は、2 ポートの POS/SDH アップリンク モジュール、またはシングルポート DPT モジュールとして使用できます。2 ポートの OC-48c/STM-16c OSM を DPT モジュールとして使用する場合は、OC-48 インターフェイスの 1 つがサイド A インターフェイス、もう 1 つがサイド B インターフェイスとして機能します。

図3-5 は、Cisco 12000 シリーズ ルータにインストールされた 2 つの 1 ポート OC-48c/STM-16c SRP モジュールと、Cisco 7600 シリーズ ルータにインストールされた 1 つの 2 ポート OC-48c/STM-16c OSM で生成される DPT リングを示しています。

図3-5 SRP/DPT リング例

 

2 ポートの OC-48c/STM-16 OSM に DPT を設定するには、設定モードから次の作業を実行します。

 

コマンド
説明

ステップ 1

Router(config)# hw-module slot 4 srp

モジュールを SRP/DPT モードに変更します。

ステップ 2

Router(config)# interface srp 4/1

設定対象の SRP インターフェイスを選択します。

ステップ 3

Router(config-if)# ip address 10.1.2.1 255.255.255.0

IP アドレスを設定します。

ステップ 4

Router(config-if)# no cdp enable

CDP をディセーブルにします。

ステップ 5

Router(config-if)# no shutdown

インターフェイスをアップにします。

ステップ 6

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 7

Router(config)# exit

コンフィギュレーション モードを終了します。

ステップ 8

Router# show interfaces srp 4 /1

インターフェイスの設定を表示します。

この例は、SRP/DPT モードに、2 ポートの OC-48c/STM-16c OSM を設定する方法を示しています。

Router(config)# hw-module slot 4 srp

) スロット 4 のモジュールが、SRP/DPT モードに設定されて、自動的にリロードされるまで待ってください。そのあとで、設定を続けてください。


Router(config)# interface srp 4/1
Router(config-if)# ip address 10.1.2.1 255.255.255.0
Router(config-if)# no cdp enable
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# exit
Router# show interfaces srp 4/1
SRP4/1 is up, line protocol is up
Hardware is SRP, address is 00d0.01d7.4c0a (bia 00d0.01d7.4c0a)
Internet address is 10.1.2.1/24
MTU 4470 bytes, BW 2488000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 41/255
Encapsulation SRP2,
Side A: loopback not set
Side B: loopback not set
3 nodes on the ring MAC passthrough not set
Side A: not wrapped IPS local: IDLE IPS remote: IDLE
Side B: not wrapped IPS local: IDLE IPS remote: IDLE
Scramble enabled
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
queuing strategy: fifo
Output queue :0/40 (size/max)
Side A: 5 minutes output rate 0 bits/sec, 0 packets/sec
5 minutes input rate 0 bits/sec, 0 packets/sec
Side B: 5 minutes output rate 0 bits/sec, 0 packets/sec
5 minutes input rate 0 bits/sec, 0 packets/sec
L2 Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes
L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast
L3 out Switched: ucast: 0 pkt, 0 bytes
360563 packets input, 286645033 bytes, 0 no buffer
Received 0 broadcasts, 43 runts, 0 giants, 0 throttles
50 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 7 abort
847443 packets output, 34168034 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
0 output buffer failures, 0 output buffers swapped out
Side A received errors:
33 input errors, 0 CRC, 0 ignored,
29 framer runts, 0 framer giants, 4 framer aborts,
0 mac runts, 0 mac giants, 0 mac aborts
Side B received errors:
17 input errors, 0 CRC, 0 ignored,
14 framer runts, 0 framer giants, 3 framer aborts,
0 mac runts, 0 mac giants, 0 mac aborts
Router#
 

BCP の設定

SONET 上で、イーサネット フレームの転送に BCP が使用された場合、レイヤ 3 のルーティング情報を交換する必要がなくなります。POS リンクが、従来から信頼性のある高速 SONET ネットワーク上の VLAN トラフィックを伝送するイーサネット トランクのような役割を果たします。DPT OSM では、BCP はサポートされていません。

使用上の注意事項および制限

BCP 設定時に、次の注意事項および制限に従ってください。

複合 PXF では、それぞれ VLAN のインスタンスを 1 つのみサポートします。そのため、複合 PXF ごとに複数のインターフェイスがサポートされる可能性がでてきますが、VLAN では同様な設定(複合 PXF ごとに複数のインターフェイスを設定)はできません。個々の POS OSM によりますが、各インターフェイスは他のインターフェイスと複合 PXF を共有する可能性があります。たとえば、4 ポートの OC-12 POS OSM 上では、ポート 1 およびポート 2 が 1 つの複合 PXF を共有しポート 3 およびポート 4 で別の複合 PXF を共有できます。VLAN 400 をポート 1 に設定した場合、その同じ VLAN をポート 2 に設定することはできませんが、ポート 3 もしくはポート 4 に設定することができます。

さらに、所定の VLAN を BCP に設定する場合、同じ複合 PXF に適用されたインターフェイス上で同一の VLAN を別のブリッジング機能(フレーム リレー ブリッジングおよび Virtual Private LAN Service [VPLS])に設定できません。

POS インターフェイスがブリッジングをサポートするには、POS インターフェイスの最小 MTU サイズが、VLAN インターフェイスおよびイーサネットインターフェイスの MTU サイズより 24 バイト以上大きく設定する必要があります。これは、RFC 3518 ヘッダーの 6 バイトおよび 802.1Q のヘッダーの 18 バイトを考慮しています。

たとえば、入力イーサネット ポート上で MTU サイズが 3000 バイトある場合、POS ポートの MTU サイズは最低 3024 バイト必要になります。

QoS サポート

OSM は、DSCP ベースのキューイングとシェーピングを使用します。しかし、BCP はレイヤ 2 のトラフィック転送を行うため、DSCP の値を見る必要がなくなります。その代わりに、802.1Q ヘッダー内にある 3 ビットの Class of Service(CoS; サービス クラス)フィールドが 6 ビットの DSCP 値にマッピングされます。

BCP が有効な場合、802.1Q ヘッダーの CoS 値がデフォルトの CoS/DSCP マッピングに従い、IP ヘッダー内の DSCP 値にマッピングされます。

 

CoS

0

1

2

3

4

5

6

7

DSCP

0

8

16

24

32

40

48

56

レイヤ 3 の OSM ポートでの QoS については、 第8章「OC-12 ATM OSM の設定」 を、PFC2 の QoS サポートについては、次の URL 上の『Cisco 7600 Series Router Software Configuration Guide』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/12111bex/swcg/qos.htm

BCP の設定手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router(config)# interface pos mod/port

インターフェイスを選択します。

ステップ 2

Router(config-if)# encapsulation ppp

インターフェイスに PPP カプセル化を設定します。

ステップ 3

Router(config-if)# bridge-enable1

インターフェイス上の BCP をイネーブルにします。

ステップ 4

Router(config-if)# switchport trunk {allowed | pruning vlan {add | all | except | remove}}

トランクの特性を設定します。

ステップ 5

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 6

Router# show interface pos mod/num

インターフェイスの設定を表示します。

1.ポートをシャットダウン ステートにして bridge-enable コマンドを入力してください。ポートのステートがアップの時に bridge-enable コマンドを入力してしまった場合は、shutdown コマンド、続けて no shutdown コマンドを入力し、POS ポートの BCP をアップさせます。

POS インターフェイス上で設定される VLAN(VLAN 400 以外)すべての BCP 転送例です。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface pos 3/2
Router(config)# encapsulation ppp
Router(config-if)# bridge-enable
Router(config-if)# switchport trunk allowed vlan all
Router(config-if)# switchport trunk allowed vlan remove vlan 400
Router(config-if)# shutdown
Router(config-if)# no shutdown
Router(config-if)# end
Router# show running-config interface pos 3/2
!
interface POS3/2
ip address 2.2.2.2 255.255.255.0
encapsulation ppp
bridge-enable
switchport
switchport trunk allowed vlan 1-399,401-1005
switchport mode trunk
no cdp enable
end
 
Router# show interface pos 3/2 switchport
Name:Po3/2
Switchport:Enabled
Administrative Mode:trunk
Operational Mode:trunk
Administrative Trunking Encapsulation:dot1q
Operational Trunking Encapsulation:dot1q
Negotiation of Trunking:Off
Access Mode VLAN:1 (default)
Trunking Native Mode VLAN:1 (default)
Administrative private-vlan host-association:none
Administrative private-vlan mapping:none
Operational private-vlan:none
Trunking VLANs Enabled:1-399,401-1005
Pruning VLANs Enabled:2-1001
 
Router# show interface pos 3/2 trunk
 
Port Mode Encapsulation Status Native vlan
Po3/2 on 802.1q trunking 1
 
Port Vlans allowed on trunk
Po3/2 1-399,401-1005
 
Port Vlans allowed and active in management domain
Po3/2 1,31-32,34,91-92,100,500,1002-1005
 
Port Vlans in spanning tree forwarding state and not pruned
Po3/2 31-32,34,91-92,100,1002-1005
 

OC-3c/STM-1 POS モジュールの設定例

次に、スロット 3 に OC-3c/STM-1 POS モジュールが搭載されている Cisco 7600 シリーズ ルータ(1 番めのルータ)と、スロット 3 に POS Interface Processor(POSIP)モジュールが搭載されている Cisco 7500 シリーズ ルータ(2 番めのルータ)をバックツーバックで接続する場合のコンフィギュレーション ファイル コマンドの例を示します。

1 番めのルータのコンフィギュレーション コマンド

interface pos 3/1
ip address 10.1.2.3 255.0.0.0
clock source internal
no shutdown
no keepalive
no cdp enable
no ip mroute-cache
crc 32
 

2 番めのルータのコンフィギュレーション コマンド

interface pos 3/0/0
ip address 10.1.2.4 255.0.0.0
clock source internal
no shutdown
no keepalive
no cdp enable
crc 32

 

マルチポイント ブリッジングの設定

マルチポイント ブリッジングを設定すると、フレーム リレーの DLCI に対してポイントツーマルチポイント ブリッジングが可能になります。この機能により、次の OSM 上でのブリッジングでは、VLAN ごとに複数の DLCI を使用できます。

8 ポート OC-3 POS

16 ポート OC-3 POS

2 ポート OC-12 POS

4 ポート OC-12 POS

1 ポート OC-48 POS

2 ポート OC-48 POS/DPT

マルチポイント ブリッジングにより、サービス プロバイダーは、既存のフレーム リレー レガシー ネットワークの実証済みのテクノロジーに加えて、イーサネットベースのレイヤ 2 サービスをサポートできるようになります。これによりカスタマーは、フレーム リレー クラウドを介して現在の VLAN ベース ネットワークを使用できます。また、サービス プロバイダーは既存のカスタマー ベースをサポートしながら、コア ネットワークを最新のギガビット イーサネット光テクノロジーへと段階的に移行できます。

フレーム リレー インターフェイスでは、 RFC 1490 ブリッジングを使用します。このカプセル化方式によって各タイプのレイヤ 2 ネットワーク経由でイーサネット フレームの送信ができます。


RFC 1490 は廃止されて、RFC 2427Multiprotocol Interconnect over Frame Relay』に改定されました。混乱を避けるため、このマニュアルでは元の RFC 番号を引き続き使用します。


Cisco IOS Rlease 12.2(18)SXE では、マルチポイント ブリッジングは次の動作モードをサポートします。

Raw(デフォルト) ― デフォルトのブリッジング アクセス モードで、ブリッジド接続は BPDU パケットの処理および送信を行います。

アクセス ― アクセス専用のブリッジング アクセス モードで、ブリッジド接続は BPDU パケットの処理および送信を行いません。

802.1Q ― IEEE 802.1Q タギングを実行して、ATM ネットワーク上のイーサネット フレームからの Class of Service(CoS; サービス クラス)情報を維持します。

802.1Q トンネル ― IEEE 802.1Q トンネリング モードで、サービス プロバイダーが 1 つの VLAN を使用して、複数の VLAN を持つカスタマーをサポートし、さらにタグなしフレームを受信します。

制限および使用上の注意事項

マルチプロトコル ブリッジング機能には、次の制限事項が適用されます。

拡張 OSM でのみサポートされ、非拡張 OSM はサポートされません。

フレーム リレー インターフェイス上のマルチポイント ブリッジングは、IETF カプセル化のみをサポートします。シスコのカプセル化は、マルチポイント ブリッジングの実行中にはサポートされません。

マルチポイント ブリッジングを行う場合、VLAN ID 1 をブリッジ ドメインとして使用できません。

マルチポイント ブリッジングでは、VLAN ごとに絶対最大数 60 の VC をサポートします。また、ピアごとの VLAN の絶対最大数は、4096 です。ただし、VLAN ごとに VC は最大で 30、VC ごとに VLAN は最大で 1024 までの設定にすることを推奨します。

前提条件

マルチポイント ブリッジングに適用される前提条件は、次のとおりです。

マルチポイント ブリッジングで VLAN を使用可能にするには、 vlan コマンドを使用して、VLAN データベースにこれらの VLAN を手動で追加する必要があります。

フレームリレー インターフェイスのマルチポイント ブリッジングの設定

ここでは、フレームリレー インターフェイスでのマルチポイント ブリッジングの設定について説明します。個々の DLCI 回線にマルチポイント ブリッジングを設定できます。オプションで、802.1Q タギングまたは 802.1Q トンネリングを追加できます。この作業を実行する手順は、次のとおりです。

手順概要

1. enable

2. configure terminal

3. vlan { vlan-id | vlan-range }

4. interface iftype slot/port

5. no ip address

6. encapsulation frame-relay ietf


) encapulsulation frame-relay ietf コマンドは、シスコのカプセル化と連動しません。


7. mls qos trust { cos | dscp }

8. interface iftype slot/port.subinterface { multipoint | point-to-point }

9. mls qos trust { cos | dscp }

10. frame-relay interface-dlci dlci [ ietf ]

11. bridge-domain vlan-id [ access | dot1q | dot1q-tunnel ] [ split-horizon ]

12. end

手順詳細

 

コマンドまたは操作
説明

ステップ 1

enable

 

Router> enable

Router#

イネーブル EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vlan { vlan-id | vlan-range }

 

Router(config)# vlan 2,5,10-12,20,25,4000

Router(config-vlan)#

VLAN データベースに 指定された VLAN ID を追加して、VLAN コンフィギュレーション モードを開始します。

vlan-id ― 単一の VLAN ID を指定します。有効範囲は、1 ~ 4094 です(ただし、VLAN 1 はマルチポイント ブリッジングでサポートされません)。

vlan-range ― 複数の VLAN ID をリストまたは範囲として指定します。 vlan-range には、カンマ(,)、ダッシュ(-)、またはその両方で区切った VLAN ID のリストを指定できます。


) マルチポイント ブリッジングで VLAN を使用するには、事前に VLAN データベースにその VLAN ID を手動で入力しておく必要があります。


ステップ 4

interface iftype slot/port

 

Router(config)# interface pos 4/1

Router(config-if)#

指定されたインターフェイスについて、コンフィギュレーション モードを開始します。

ステップ 5

no ip address

 

Router(config-if)# no ip address

Router(config-if)#

インターフェイスに設定されている IP アドレス(存在する場合)を削除します。

ステップ 6

encapsulation frame-relay ietf

 

Router(config-if)# encapsulation frame-relay ietf

Router(config-if)#

IETF カプセル化を使用して、インターフェイス上のフレーム リレーのカプセル化をイネーブルにします。各 DLCI に対して、ここか ステップ 10 のいずれかで ietf キーワードを指定する必要があります。


) マルチポイント ブリッジングは、cisco キーワードを使用するシスコのカプセル化をサポートしません。



) マルチポイント インターフェイス上のフレーム リレー DLCI に対しては、ietf キーワードを使用できません。マルチポイント インターフェイスに接続された DLCI 上でブリッジドメインを設定する場合、まず IETF カプセル化を使用して、インターフェイスでのフレーム リレーのカプセル化をイネーブルにする必要があります。


ステップ 7

mls qos trust { cos | dscp }

 

Router(config-if)# mls qos trust cos

Router(config-if)#

(任意)インターフェイスの信頼状態を指定します。デフォルトの状態は信頼性がない状態ですが、次のオプションのいずれかを使用して変更できます。

cos ― (任意)着信フレーム内の CoS ビットに信頼性を指定し、その CoS ビットから内部 DSCP 値を得ます。

dscp ― (任意)着信パケット内の ToS ビットに DSCP 値が含まれることを指定します。

ステップ 8

interface iftype slot/port.subinterface { multipoint | point-to-point }

 

Router(config-if)# interface pos 4/1.21

Router(config-subif)#

指定されたサブインターフェイスについて、コンフィギュレーション モードを開始します。

ステップ 9

mls qos trust { cos | dscp }

 

Router(config-subif)# mls qos trust cos

Router(config-subif)#

(任意)サブインターフェイスの信頼状態を指定します。デフォルトの状態は信頼性がない状態ですが、次のオプションのいずれかを使用して変更できます。

cos ― (任意)着信フレーム内の CoS ビットに信頼性を指定し、その CoS ビットから内部 DSCP 値を得ます。

dscp ― (任意)着信パケット内の ToS ビットに DSCP 値が含まれることを指定します。

ステップ 10

frame-relay interface-dlci dlci

 

Router(config-subif)# frame-relay interface-dlci 28

Router(config-fr-dlci)#

サブインターフェイスに指定された DLCI を作成して、DLCI コンフィギュレーション モードを開始します。

dlci ― 指定されたサブインターフェイスで使用される DLCI 番号です。


) このコマンドには、マルチポイント ブリッジングの使用時にサポートされない別のオプションも含まれます。


ステップ 11

bridge-domain vlan-id [ access | dot1q | dot1q-tunnel ] [ split-horizon ]

 

Router(config-fr-dlci)# bridge-domain 100 dot1q-tunnel

Router(config-fr-dlci)#

RFC 1490 ブリッジングをイネーブルにして、PVC にブリジッド VLAN をマッピングします。次のオプションがサポートされます。


) このコマンドには、マルチポイント ブリッジング設定でサポートされないオプションも含まれます。


vlan-id ― このブリッジング設定で使用される VLAN 番号です。有効範囲は、2 ~ 4094 です(ただし、事前に ステップ 3 で VLAN データベースに VLAN ID を追加しておく必要があります)。


) デフォルトの設定では、フレームは dotlq ヘッダーでタグ付けされませんが、STP および BPDU は送信されます。


access ― ブリッジング アクセス モードをイネーブルにして、ブリッジド接続が BPDU を処理および送信しないようにします。

dot1q ― (任意)dotlq トラフィックを終了します。また、IEEE 802.1Q タギングをイネーブルにして、ATM ネットワーク上のイーサネット フレームからの CoS 情報を維持します。このオプションを指定しなければ、CoS 値は維持されません。

dot1q-tunnel ― (任意)IEEE 802.1Q トンネリング モードをイネーブルにして、サービス プロバイダーが 1 つの VLAN を使用して、複数の VLAN を持つカスタマーをサポートし、さらにタグなしフレームを受信できるようにします。


access オプション、dot1q オプション、および dot1q-tunnel オプションは、いずれか 1 つだけしか使用できません。これらのいずれのオプションも指定しない場合、接続は [raw] ブリッジング アクセス モードで動作します。このモードは、接続で BPDU パケットを処理および転送する点以外は、access と同様です。



split-horizon ― (任意)RFC 1490 スプリット ホライズン モードをイネーブルにして、同一 VLAN 内の PVC 間でのブリッジングをグローバルに回避します。


ステップ 12

end

 

Router(config-fr-dlci)# end

Router#

DLCI コンフィギュレーション モードを終了し、イネーブル EXEC モードに戻ります。

次に、フレーム リレー インターフェイス上でのマルチポイント ブリッジングの設定例を示します。

frame-relay switching
...
!
interface POS3/8
no ip address
encapsulation frame-relay ietf
logging event link-status
mls qos trust dscp
clock source internal
frame-relay intf-type dce
!
interface POS3/8.10 multipoint
mls qos trust dscp
frame-relay interface-dlci 120
bridge-domain 100 dot1q-tunnel
frame-relay interface-dlci 130
bridge-domain 100 dot1q-tunnel

POS OSM 上での完全優先 LLQ サポートの設定

Cisco IOS Release 12.2(18)SXE 以降、LLQ 機能は POS OSM 用に変更されます。この変更により、プライオリティ キュー ポリシングが POS OSM 上でサポートされるようになります。Hierarchical Queuing Framework(HQF)を使用することにより、 police コマンドが OSM 上のクラスの完全優先に結合されます。


) このコマンドは、OC-3 および OC-12 モジュールでサポートされます。OC-48 モジュールではサポートされません。OC-3 および OC-12 モジュールでは、以前のリリースの priority percent % および priority kbps コマンドはサポートされていません。ただし、POS OC-48 OSM ではこれらのコマンドもまだサポートされています。

ポリシーに 2 番めに優先されるポリシング クラスが含まれる場合、まず police を設定する必要があります。


完全優先 LLQ サポートを設定するには、グローバル コンフィギュレーション モードを開始して、次の作業を実行します。

 

コマンドまたは操作
説明

ステップ 1

Router(config)# policy-map policy-name

 

Router(config)# policy-map policy11

作成または変更されるポリシー マップ名を指定します。

ステップ 2

Router(config-pmap)# class class-name

 

Router(config)# class class204

サービス ポリシーに含まれている定義済みクラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# priority

 

Router(config)# priority

 

完全優先クラスを設定します。

ステップ 4

Router(config-pmap-c)# police rate

 

Router(config-pmap-c) # police 1000000#

ポリシング レート(bps)を設定します。

次に、サポート対象の POS OSM での一般的な設定例および確認例を示します。

!
Policy Map child-pos
Class prec1
priority
police cir 1000000 bc 31250 be 31250 conform-action transmit exceed-action drop
Class prec2
bandwidth remaining 50 (%)
Class prec3
bandwidth remaining 30 (%)
Class class-default
bandwidth remaining 20 (%)
!
Class class-default
bandwidth 2200 (kbps)
shape average 3000000 12000 12000
service-policy child-pos
!
interface POS3/2
no ip address
encapsulation frame-relay
mls qos trust dscp
clock source internal
end
!
interface POS3/2.16 point-to-point
ip address 25.0.0.1 255.255.255.0
mls qos trust dscp
no cdp enable
frame-relay interface-dlci 16
service-policy output parent-pos
end
 

次に、設定を確認するコマンドを示します。

Router #show policy interface pos3/2.16
 
POS3/2.16
 
Service-policy output:parent-pos
 
Class-map:class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:any
Queueing
queue limit 550 (packets)
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts queued/bytes queued) 0/0
bandwidth 2200 kbps
shape (average) cir 3000000, bc 12000, be 12000
target shape rate 3000000

(シェープ パラメータは、粒度により 2,944,000 bps に四捨五入されます。)

lower bound cir 0, adapt to fecn 0
 
Service-policy :child-pos
 
Class-map:prec1 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:ip precedence 1
Priority:b/w exceed drops:0
police:
cir 1000000 bps, bc 31250 bytes

(ポリシング Commited Information Rate [CIR; 認定情報速度] は、粒度により 983,040 bps に四捨五入されます。)

 
Class-map:prec2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:ip precedence 2
Queueing
queue limit 150 (packets)
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts queued/bytes queued) 0/0
bandwidth remaining 50% (600 kbps)

(帯域幅パラメータは、粒度により 504 kbps に四捨五入されます。)

 
Class-map:prec3 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:ip precedence 3
Queueing
queue limit 90 (packets)
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts queued/bytes queued) 0/0
bandwidth remaining 30% (360 kbps)

(帯域幅パラメータは、粒度により 300 kbps に四捨五入されます。)

 
Class-map:class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match:any
Queueing
queue limit 60 (packets)
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts queued/bytes queued) 0/0
bandwidth remaining 20% (240 kbps)

(帯域幅パラメータは、粒度により 197 kbps に四捨五入されます。)

Router#