Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2SX
ローカルSPANおよびRSPANの設定
ローカルSPANおよびRSPANの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

ローカルSPANおよびRSPANの設定

ローカルSPANおよびRSPANの機能概要

ローカルSPANおよびRSPANの概要

ローカルSPANの概要

RSPANの概要

モニタ対象トラフィック

ローカルSPANおよびRSPAN送信元の概要

送信元ポート

送信元VLAN

ローカルSPANおよびRSPAN宛先ポートの概要

ローカルSPANおよびRSPAN設定時の注意事項および制約事項

機能の非互換性

ローカルSPANおよびRSPANセッションの制限

Supervisor Engine 720

Supervisor Engine 2

ローカルSPANおよびRSPANに関する注意事項および制約事項

VSPANに関する注意事項および制約事項

RSPANに関する注意事項および制約事項

ローカルSPANおよびRSPANの設定

ローカルSPANの設定

RSPANの設定

RSPAN VLANの設定

RSPAN送信元セッションの設定

RSPAN宛先セッションの設定

ローカルSPANおよびRSPANの送信元VLANフィルタリングの設定

無条件トランクとしての宛先ポートの設定

ローカルSPANの宛先トランク ポートVLANフィルタリングの設定

設定の確認

設定例

ローカルSPANおよびRSPANの設定

この章では、Cisco 7600シリーズ ルータ上でローカルSwitched Port Analyzer(SPAN;スイッチド ポート アナライザ)とRemote SPAN(RSPAN)を設定する手順について説明します。

この章の構成は次のとおりです。

「ローカルSPANおよびRSPANの機能概要」

「ローカルSPANおよびRSPAN設定時の注意事項および制約事項」

「ローカルSPANおよびRSPANの設定」


) • この章で使用しているコマンドの構文および使用方法の詳細については、『Cisco 7600 Series Router Cisco IOS Command Reference』を参照してください。

OSM(オプティカル サービス モジュール)WANポートおよびFlexWANポートは、SPANまたはRSPANをサポートしません。


 

ローカルSPANおよびRSPANの機能概要

ここでは、ローカルSPANおよびRSPANの機能について説明します。

「ローカルSPANおよびRSPANの概要」

「ローカルSPANおよびRSPAN送信元の概要」

「ローカルSPANおよびRSPAN宛先ポートの概要」

ローカルSPANおよびRSPANの概要

ローカルSPANおよびRSPANセッションを使用すると、1つまたは複数のポート、または1つまたは複数のVLANを対象にトラフィックをモニタし、モニタしたトラフィックを1つまたは複数の宛先ポートに送信できます。Release 12.2(18)SXD以降のリリースでは、VLAN単位でフィルタリングを宛先トランク ポートに設定できます。

ローカルSPANおよびRSPANは、SwitchProbeデバイス、その他のRemote Monitoring(RMON)プローブなどのネットワーク アナライザにトラフィックを送信します。SPANは、送信元ポートまたはVLAN(仮想LAN)上のトラフィックのスイッチングには影響しません。SPANは、送信元ポートとVLANによって送受信されるパケットのコピーを宛先ポートに送信します。その宛先ポートは、SPAN専用に設定しなければなりません。

ここでは、ローカルSPANおよびRSPANの概要を説明します。

「ローカルSPANの概要」

「RSPANの概要」

「モニタ対象トラフィック」

ローカルSPANの概要

ローカルSPANセッションは、送信元ポートおよび送信元VLANを、1つまたは複数の宛先ポートに対応付けたものです。ローカルSPANセッションは、単一のルータ上に設定します。ローカルSPANには、個別の送信元および宛先のセッションはありません。

ローカルSPANセッションは、RSPAN VLANを伝送する送信元トランク ポートから送信元RSPAN VLANトラフィックをローカルにコピーしません。ローカルSPANセッションは、送信元RSPAN GREでカプセル化されたトラフィックを送信元ポートからローカルにコピーしません。

ローカルSPANセッションごとに、送信元としてポートまたはVLANを使用することはできますが、両方を使用できません。

ローカルSPANは、任意のVLAN上の1つまたは複数の送信元ポートからのトラフィック、あるいは1つまたは複数のVLANからのトラフィックを分析するために宛先ポートへコピーします(図 40-1を参照)。たとえば図 40-1の場合、イーサネット ポート5(送信元ポート)上の全トラフィックが、イーサネット ポート10にコピーされます。イーサネット ポート10のネットワーク アナライザは、イーサネット ポート5に物理的に接続していなくても、このポートからのあらゆるトラフィックを受信できます。

図 40-1 SPANの設定例

 

RSPANの概要

RSPANは、異なるルータ上の送信元ポート、送信元VLAN、および宛先ポートをサポートして、ネットワーク上の複数のルータをリモート モニタします(図 40-2を参照)。

RSPANは、RSPAN送信元セッション、RSPAN VLAN、およびRSPAN宛先セッションで構成されています。異なるルータ上で、RSPAN送信元セッションと宛先セッションを個別に設定します。1つのルータ上でRSPAN送信元セッションを設定するには、一連の送信元ポートまたはVLANを1つのRSPAN VLANに対応付けます。別のルータ上でRSPAN宛先セッションを設定するには、宛先ポートをRSPAN VLANに対応付けます。

各RSPANセッションのトラフィックは、レイヤ2非ルータブル トラフィックとして、ユーザが指定したRSPAN VLAN上で伝送されます。このRSPAN VLANは、参加しているすべてのルータのRSPANセッション専用です。参加しているすべてのルータは、レイヤ2トランクによって接続されている必要があります。

RSPAN送信元セッションは、RSPAN VLANを伝送する送信元トランク ポートから送信元RSPAN VLANトラフィックをローカルにコピーしません。RSPAN送信元セッションは、送信元RSPAN GREでカプセル化されたトラフィックを送信元ポートからローカルにコピーしません。

RSPAN送信元セッションごとに、送信元としてポートまたはVLANを使用することはできますが、両方を使用できません。

RSPAN送信元セッションは、送信元ポートまたは送信元VLANからトラフィックをコピーし、RSPAN VLAN上のトラフィックをRSPAN宛先セッションへスイッチングします。RSPAN宛先セッションはトラフィックを宛先ポートへスイッチングします。

図 40-2 RSPANの設定

 

モニタ対象トラフィック

ここでは、ローカルSPANおよびRSPANがモニタできるトラフィックについて説明します。

「モニタ対象トラフィックの方向」

「モニタ対象トラフィック」

「重複トラフィック」

モニタ対象トラフィックの方向

ローカルSPANセッションおよびRSPAN送信元セッションに、入力トラフィック(入力SPAN)のモニタ、出力トラフィック(出力SPAN)のモニタ、または両方向でのトラフィック フローのモニタを行うように設定できます。

入力SPANは、送信元ポートおよびVLANが受信したトラフィックを、宛先ポートで分析できるようにコピーします。出力SPANは、送信元ポートおよびVLANが送信したトラフィックをコピーします。 both キーワードを入力すると、SPANは送信元ポートまたはVLANで受信され、宛先ポートに送信されたトラフィックをコピーします。

モニタ対象トラフィック

デフォルトでは、ローカルSPANがマルチキャスト フレームおよびBridge Protocol Data Unit(BPDU;ブリッジ プロトコル データ ユニット)フレームを含む、すべてのトラフィックをモニタします。RSPANはBPDUモニタをサポートしません。

重複トラフィック

設定によっては、SPANが、同じ送信元のトラフィックの複数のコピーを、宛先ポートに送信します。たとえば、双方向SPAN(入力および出力の両方)セッションが、s1およびs2の2つをSPAN送信元、d1をSPAN宛先ポートとして設定されている場合、パケットがs1からルータに入って、出力パケットとしてルータからs2に送信されると、s1の入力SPANおよびs2の出力SPAN両方が、パケットのコピーをSPAN宛先d1に送信します。パケットがs1からs2へスイッチングされたレイヤ2だった場合、両方のSPANパケットは同一になります。パケットがs1からs2にレイヤ3スイッチングされた場合は、レイヤ3書き換えによって送信元および宛先レイヤ2アドレスが変更され、SPANパケットは異なるものとなります。

ローカルSPANおよびRSPAN送信元の概要

ここでは、ローカルSPANおよびRSPANの送信元について説明します。

「送信元ポート」

「送信元VLAN」

送信元ポート

送信元ポートは、トラフィック分析のためにモニタ対象になるポートです。スイッチングおよびルーティングされているポートの両方を、SPAN送信元ポートとして設定できます。SPANは、1つまたは複数の送信元ポートを、単一のSPANセッションでモニタできます。任意のVLANに送信元ポートを設定できます。トランク ポートを、送信元ポートとして設定したり、非トランク送信元ポートと混在させることができます。SPANは、送信元トランク ポートからのカプセル化をコピーしません。

送信元VLAN

送信元VLANは、トラフィック分析のためにモニタ対象になるVLANです。VLAN-based SPAN(VSPAN)は、VLANをSPAN送信元として使用します。送信元VLANにあるすべてのポートが、送信元ポートになります。

ローカルSPANおよびRSPAN宛先ポートの概要

宛先ポートは、ローカルSPANおよびRSPANが分析用のトラフィックを送信するレイヤ2またはレイヤ3 LANポートです。

ポートを宛先ポートとして設定すると、そのポートはトラフィックを受信できなくなります。ポートを宛先ポートとして設定すると、そのポートはSPAN機能専用になります。SPAN宛先ポートでは、SPANセッションに必要なトラフィック以外の転送は行われません。

トランク ポートを宛先ポートとして設定することができます。これによって、宛先トランク ポートがカプセル化したトラフィックを転送することができます。Release 12.2(18)SXD以降のリリースでは、許可VLANリストを使用して、VLAN単位でフィルタリングを宛先トランク ポートに設定できます(「ローカルSPANの宛先トランク ポートVLANフィルタリングの設定」を参照)。

ローカルSPANおよびRSPAN設定時の注意事項および制約事項

ここでは、ローカルSPANとRSPAN設定に関する注意事項および制約事項について説明します。

「機能の非互換性」

「ローカルSPANおよびRSPANセッションの制限」

「ローカルSPANおよびRSPANに関する注意事項および制約事項」

「VSPANに関する注意事項および制約事項」

「RSPANに関する注意事項および制約事項」

機能の非互換性

ローカルSPANおよびRSPANには、機能の互換性がありません。

CSCef78235 の注意事項が解決されているリリースでは、Supervisor Engine 720ハードウェア リビジョンを使用した場合、ローカルSPANおよびRSPAN送信元ポートはVACLリダイレクトされたトラフィックをコピーしません。

CSCef78235の注意事項が解決されていないリリースでは、次のようになります。

Supervisor Engine 720ハードウェア リビジョン3.2以上を使用した場合、ローカルSPAN送信元ポートはVACLリダイレクトされたトラフィックをコピーしません。

Supervisor Engine 720ハードウェア リビジョン3.2未満を使用した場合、ローカルSPAN送信元ポートはVACLリダイレクトされたトラフィックをコピーします。

Supervisor Engine 720ハードウェア リビジョンを使用した場合、RSPAN送信元ポートはVACLリダイレクトされたトラフィックをコピーします。

ハードウェア リビジョンを表示するには show module version | include WS-SUP720-BASE コマンドを入力します。次に例を示します。

Router# show module version | include WS-SUP720-BASE
7 2 WS-SUP720-BASE SAD075301SZ Hw :3.2
 

ポートチャネル インターフェイス(EtherChannel)をSPAN送信元にできます。

EtherChannelのアクティブなメンバー ポートをSPAN送信元ポートとして設定はできません。EtherChannelの非アクティブなメンバー ポートは、SPAN送信元として設定できますが、これらのポートは中断状態になりトラフィックを伝送しません。

ポート チャネル インターフェイス(EtherChannel)をSPAN宛先にはできません。

EtherChannelのアクティブなメンバー ポートをSPAN宛先ポートとして設定はできません。EtherChannelの非アクティブなメンバー ポートは、SPAN宛先ポートとして設定できますが、これらのポートは中断状態になりトラフィックを伝送しません。

SPAN宛先ポートは入力トラフィックを廃棄するので、次の機能は、SPAN宛先ポートとは機能的に互換性がありません。

プライベートVLAN

IEEE 802.1xポートベースの認証

ポート セキュリティ

STP(スパニングツリー プロトコル)および関連機能(PortFast、PortFast BPDUフィルタリング、BPDUガード、UplinkFast、BackboneFast、EtherChannelガード、ルート ガード、ループ ガード)

VLAN Trunking Protocol(VTP;VLANトランキング プロトコル)

Dynamic Trunking Protocol(DTP)

IEEE 802.1Qトンネリング


) SPAN宛先ポートは、IEEE 802.3Zフロー コントロールに参加できます。


ローカルSPANおよびRSPANセッションの制限

ここでは、ローカルSPANおよびRSPANセッションの上限を説明します。

「Supervisor Engine 720」

「Supervisor Engine 2」

Supervisor Engine 720

Supervisor Engine 720ローカルSPANおよびRSPANセッションの上限は、次のとおりです。

 

総セッション数
ローカルSPANおよびRSPAN送信元セッション
RSPAN宛先セッション

66

2(入力または出力または両方)

64

Supervisor Engine 720ローカルSPANおよびRSPAN送信元および宛先の上限は、次のとおりです。

 

ローカル
SPANセッションごと
RSPAN
送信元セッションごと
RSPAN
宛先セッションごと

出力または「両方」の送信元

1

1

--

入力送信元

--

Release 12.2(18)SXDより前のリリース

64

64

Release 12.2(18)SXD以降のリリース

128

128

RSPAN宛先セッション送信元

--

--

1 RSPAN VLAN

セッションごとの宛先

64

1 RSPAN VLAN

64

Supervisor Engine 2


) • ローカルSPANセッションの出力SPAN送信元を設定した場合、Supervisor Engine 2はRSPANをサポートしません。

RSPANを設定した場合、Supervisor Engine 2はローカルSPANの出力SPAN送信元をサポートしません。


 

Supervisor Engine 2ローカルSPANおよびRSPANセッションの上限は、次のとおりです。

 

総セッション数
ローカルSPAN
セッション
RSPAN送信元
セッション
RSPAN宛先
セッション

66

2(入力または出力または両方)

0

64

1(入力)

1(入力または出力または両方)

64

1または2(出力)

0

64

Supervisor Engine 2ローカルSPANおよびRSPAN送信元および宛先の上限は、次のとおりです。

 

ローカルSPANセッション
ごと
RSPAN送信元セッション
ごと
RSPAN宛先セッション
ごと

出力または「両方」の送信元

1(RSPAN送信元セッションで設定の場合は0)

1(ローカルSPAN出力送信元セッションで設定の場合は0)

--

入力送信元

--

Release 12.2(18)SXDより前
のリリース

64

64

Release 12.2(18)SXD以降の
リリース

128

128

RSPAN宛先セッション送信元

--

--

1 RSPAN VLAN

セッションごとの宛先

64

1 RSPAN VLAN

64

ローカルSPANおよびRSPANに関する注意事項および制約事項

次の注意事項および制約事項は、ローカルSPANおよびRSPANに適用されます。

ふたたび monitor session コマンドを入力しても、前に設定したSPANパラメータを消去しません。設定済みのSPANパラメータをクリアするには、 no monitor session コマンドを使用する必要があります。

イネーブルなローカルSPANおよびRSPANは、すでに入力された設定があれば、その設定を使用します。

ネットワーク アナライザをSPAN宛先ポートに接続します。

SPANセッションでは、SPAN宛先ポートはすべて、SPAN送信元すべてからのトラフィックを全部受信します。


) Release 12.2(18)SXD以降のリリースでは、許可VLANリストを使用して、宛先トランク ポートVLANフィルタリングを設定できます(ローカルSPANの宛先トランク ポートVLANフィルタリングの設定を参照)。宛先トランク ポートVLANフィルタリングを使用すると、セッション内ではすべてのSPAN宛先ポートがSPAN送信元すべてからのトラフィックを全部受信するという制限を解除します。宛先トランク ポートVLANフィルタリングを使用すると、各宛先トランク ポートから送信されるトラフィックをVLAN単位で選択できます。


レイヤ2 LANポート( switchport コマンドで設定されたLANポート)とレイヤ3 LANポート( switchport コマンドを使用せずに設定されたLANポート)の両方を送信元または宛先として設定できます。

1つのセッションに、個別の送信元ポートおよび送信元VLANを混在させることはできません。

Supervisor Engine 720を使用した場合、VACLはトラフィックを出力SPAN送信元ポートにリダイレクトすると、SPANはVACLリダイレクトされたトラフィックをコピーしません。

Supervisor Engine 2を使用した場合、VACLはトラフィックを出力SPAN送信元ポートにリダイレクトすると、SPANはVACLリダイレクトされたトラフィックをコピーします。

複数の入力送信元ポートを指定する場合、各ポートはそれぞれ異なるVLANに属するものであってもかまいません。

1つのセッション内では、送信元VLANとフィルタVLANを混在させることはできません。送信元VLANまたはフィルタVLANを使用することはできますが、両方を同時に使用することはできません。

送信元を指定し、トラフィックの方向(入力、出力、または両方)を指定しない場合、「両方」がデフォルトで使用されます。

SPANはレイヤ2イーサネット フレームをコピーしますが、送信元トランク ポートISLまたは802.1Qタグはコピーしません。宛先ポートをトランクとして設定し、タグ付きトラフィックをトラフィック アナライザにローカルに送信できます。

ローカルSPANセッションおよびRSPAN送信元セッションは、RSPAN VLANを伝送する送信元トランク ポートから送信元RSPAN VLANトラフィックをローカルにコピーしません。

1つのSPANセッションにおける宛先ポートとして指定したポートは、もう1つのSPANセッションの宛先ポートにすることはできません。

宛先ポートとして設定されたポートは、送信元ポートとして設定できません。

宛先ポートは、VACLリダイレクトされたトラフィックを送信します。

宛先ポートは、スパニングツリー インスタンスには関与しません。ローカルSPANはモニタ対象トラフィックにBPDUを含めます。したがって宛先ポートで確認されるBPDUは、送信元ポートから送られたものです。RSPANはBPDUモニタをサポートしません。

出力送信元として設定されているポートからの伝送用にルータを経由して送信されるすべてのパケットは、宛先ポートにコピーされます。このパケットには、STP(スパニングツリー プロトコル)がポートをブロッキング ステートにするためポート経由でルータから送出されないパケットや、STPがVLANをトランク ポートでブロッキング ステートに移行するので、トランク ポートにあるパケットが含まれます。

VSPANに関する注意事項および制約事項


) ローカルSPANおよびRSPANはすべて、VSPANをサポートします。


ここでは、VSPANに関する注意事項および制約事項について説明します。

入力および出力の両方が設定されているVSPANセッションについては、2つのパケットが同じVLANでスイッチングされている場合、それらは宛先ポートから(1つは入力ポートからの入力トラフィックとして、もう1つは出力ポートからの出力トラフィックとして)転送されます。

VSPANは、VLAN内のレイヤ2ポートを出入りするトラフィックだけをモニタします。

VLANを入力送信元として設定し、トラフィックがモニタ対象VLANにルーティングされる場合、ルーティングされたトラフィックは、VLAN内のレイヤ2ポートで受信する入力トラフィックとしてみなされないため、モニタされません。

VLANを出力送信元として設定し、トラフィックがモニタ対象VLANにルーティングされる場合、ルーティングされたトラフィックは、VLAN内のレイヤ2ポートから送信される出力トラフィックとしてみなされないため、モニタされません。

RSPANに関する注意事項および制約事項

ここでは、RSPANに関する注意事項および制約事項について説明します。

ローカルSPANセッションの出力SPAN送信元を設定した場合、Supervisor Engine 2はRSPANをサポートしません。

RSPANを設定した場合、Supervisor Engine 2はローカルSPANの出力SPAN送信元をサポートしません。

参加しているすべてのルータは、レイヤ2によってトランク接続されている必要があります。

RSPAN VLANをサポートするネットワーク装置は、RSPAN中間装置とすることができます。

ネットワークが伝送するRSPAN VLANの数に制限はありません。

中間ネットワーク デバイスでは、サポートできるRSPAN VLANの数が制限される場合があります。

すべての送信元、中間、宛先ネットワーク装置において、RSPAN VLANを設定しなければなりません。VLAN Trunking Protocol(VTP;VLANトランキング プロトコル)がイネーブルの場合、1~1024の番号がついたVLANの設定をRSPAN VLANとして伝播できます。1024より大きい番号のVLANは、すべての送信元、中間、および宛先ネットワーク装置で、RSPAN VLANとして手動で設定する必要があります。

VTPおよびVTPプルーニングをイネーブルにすると、RSPANトラフィックはトランクでプルーニングされて、RSPANトラフィックがネットワーク全体に不必要にフラッディングするのを防ぎます。

RSPAN VLANは、RSPANトラフィックに対してのみ使用できます。

管理トラフィックを伝送するのに使用するVLANを、RSPAN VLANとして設定しないでください。

アクセス ポートをRSPAN VLANに割り当てないでください。RSPANは、RSPAN VLAN中のアクセス ポートを中断ステートにします。

RSPAN VLAN内のRSPANトラフィックの伝送用に選択されたトランク ポート以外は、設定しないでください。

MAC(メディア アクセス制御)アドレス ラーニングは、RSPAN VLAN上でディセーブルです。

RSPAN送信元ルータのRSPAN VLAN上にある出力Access Control List(ACL;アクセス制御リスト)を使用して、RSPAN宛先へ送信されるトラフィックをフィルタリングできます。

RSPANはBPDUモニタをサポートしません。

RSPAN VLANをVSPANセッション中の送信元として設定しないでください。

すべての関与しているネットワーク装置がRSPAN VLANの設定をサポートし、すべての関与しているネットワーク装置で各RSPANセッションに対して同じRSPAN VLANを使用するかぎり、VLANをRSPAN VLANとして設定できます。

ローカルSPANおよびRSPANの設定

ここでは、ローカルSPANおよびRSPANの設定方法について説明します。

「ローカルSPANの設定」

「RSPANの設定」

「ローカルSPANおよびRSPANの送信元VLANフィルタリングの設定」

「無条件トランクとしての宛先ポートの設定」

「ローカルSPANの宛先トランク ポートVLANフィルタリングの設定」

「設定の確認」

「設定例」

ローカルSPANの設定

ローカルSPANは、個別の送信元および宛先セッションを使用しません。ローカルSPANセッションを設定するには、ローカルSPAN送信元および宛先に同じセッション番号を設定します。ローカルSPANセッションを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# monitor session local_span_session_number source {{ single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]}}

ローカルSPAN送信元セッション番号を送信元ポートまたはVLANに関連付け、モニタするトラフィック方向を選択します。

ステップ 2

Router(config)# monitor session local_span_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list }

ローカルSPAN送信元セッション番号および宛先ポートを関連付けます。

ステップ 3

Router(config)# no monitor session { session_number | all | local | range session_range [[, session_range ],...]}

モニタ設定を消去します。

ローカルSPANセッションを設定する場合、構文について次の点に注意してください。

local_span_session_number の範囲は、1~66です。

single_interface interface type slot / port の形式で、 type は、 ethernet fastethernet gigabitethernet 、または tengigabitethernet になります。

interface_list single_interface single_interface single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一のVLANのID番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

宛先ポートを脱退するときにモニタ対象トラフィックにタグを付けるには、無条件で宛先ポートをトランクに設定してから、宛先として設定する必要があります(無条件トランクとしての宛先ポートの設定を参照)。

モニタ セッションを消去する際、次の構文情報に注意してください。

他のパラメータを指定しないで入力されたno monitor session number コマンドは、セッションの session_number を消去します。

session_range は、 first_session_number - last_session_number です。


) no monitor session rangeコマンドでは、ダッシュの前後にスペースを入れません。複数の範囲を入力する場合、カンマの前後にスペースを入れないでください。


次に、セッション1の双方向送信元として、Fast Ethernet 5/1を設定する例を示します。

Router(config)# monitor session 1 source interface fastethernet 5/1
 

次に、SPANセッション1の宛先として、ポートFastEthernet 5/48を設定する例を示します。

Router(config)# monitor session 1 destination interface fastethernet 5/48
 

詳細については、「設定例」を参照してください。

RSPANの設定

RSPANは、ルータで送信元セッションを、別のルータで宛先セッションを使用します。ここでは、RSPANセッションの設定手順について説明します。

「RSPAN VLANの設定」

「RSPAN送信元セッションの設定」

「RSPAN宛先セッションの設定」

RSPAN VLANの設定

VLANをRSPAN VLANとして設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# vlan vlan_ID {[- vlan_ID ]|[, vlan_ID ])

単独のイーサネットVLAN、イーサネットVLANの範囲、またはカンマで区切ったリストで複数のイーサネットVLANを作成または変更します(スペースは挿入しないでください)。

ステップ 2

Router(config-vlan)# remote-span

VLANをRSPAN VLANとして設定します。

Router(config-vlan)# no remote-span

RSPAN VLANの設定を消去します。

ステップ 3

Router(config-vlan)# end

VLANデータベースを更新して、イネーブルEXECモードに戻ります。

RSPAN送信元セッションの設定

RSPAN送信元セッションを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# monitor session RSPAN_source_session_number source {{ single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]}}

RSPAN送信元セッション番号を送信元ポートまたはVLANに関連付け、モニタするトラフィック方向を選択します。

ステップ 2

Router(config)# monitor session RSPAN_source_session_number destination remote vlan rspan_vlan_ID

RSPAN送信元セッション番号をRSPAN VLANに関連付けます。

ステップ 3

Router(config)# no monitor session { session_number | all | range session_range [[, session_range ],...] | remote }

モニタ設定を消去します。

モニタ セッションを設定する際、次の構文情報に注意してください。

RSPAN VLANを設定するには、「RSPAN VLANの設定」を参照してください。

RSPAN_source_span_session_number の範囲は、1~66です。

single_interface interface type slot / port の形式で、 type は、 ethernet fastethernet gigabitethernet 、または tengigabitethernet になります。

interface_list single_interface single_interface single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一のVLANのID番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

モニタ セッションを消去する際、次の構文情報に注意してください。

他のパラメータを指定しないで入力されたno monitor session number コマンドは、セッションの session_number を消去します。

session_range は、 first_session_number - last_session_number です。


) no monitor session rangeコマンドでは、ダッシュの前後にスペースを入れません。複数の範囲を入力する場合、カンマの前後にスペースを入れないでください。


次に、セッション2の送信元として、ポートFast Ethernet 5/2を設定する例を示します。

Router(config)# monitor session 2 source interface fastethernet 5/2
 

次に、セッション2の宛先として、RSPAN VLAN 200を設定する例を示します。

Router(config)# monitor session 2 destination remote vlan 200
 

詳細については、「設定例」を参照してください。

RSPAN宛先セッションの設定


) RSPAN送信元セッション ルータにRSPAN宛先セッションを設定し、RSPANトラフィックをローカルにモニタするようにできます。


RSPAN宛先セッションを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# monitor session RSPAN_destination_session_number source remote vlan rspan_vlan_ID

RSPAN宛先セッション番号をRSPAN VLANに関連付けます。

ステップ 2

Router(config)# monitor session RSPAN_destination_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list }}

RSPAN宛先セッション番号を宛先ポートに関連付けます。

ステップ 3

Router(config)# no monitor session { session_number | all | range session_range [[, session_range ],...] | remote }

モニタ設定を消去します。

モニタ セッションを設定する際、次の構文情報に注意してください。

モニタ対象トラフィックにタグ付けをするには、ポートを無条件にトランクに設定してから、そのポートを宛先として設定する必要があります(無条件トランクとしての宛先ポートの設定を参照)。

RSPAN_destination_span_session_number の範囲は、1~66です。

single_interface interface type slot / port の形式で、 type は、 ethernet fastethernet gigabitethernet 、または tengigabitethernet になります。

interface_list single_interface single_interface single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

モニタ セッションを消去する際、次の構文情報に注意してください。

no monitor session number コマンドを他のパラメータを指定せずに入力すると、セッションの session_number が削除されます。

session_range は、 first_session_number - last_session_number です。


) no monitor session rangeコマンドでは、ダッシュの前後にスペースを入れません。複数の範囲を入力する場合、カンマの前後にスペースを入れないでください。


次に、セッション3の送信元として、RSPAN VLAN 200を設定する例を示します。

Router(config)# monitor session 3 source remote vlan 200
 

次に、セッション3の宛先として、ポートFast Ethernet 5/47を設定する例を示します。

Router(config)# monitor session 3 destination interface fastethernet 5/47
 

詳細については、「設定例」を参照してください。

ローカルSPANおよびRSPANの送信元VLANフィルタリングの設定

送信元がトランク ポートである場合に、送信元VLANフィルタリングは特定のVLANをモニタします。

ローカルSPANまたはRSPAN送信元がトランク ポートである場合、送信元VLANフィルタリングを設定するには、次の作業を行います。

 

コマンド
説明

Router(config)# monitor session session_number filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

ローカルSPANまたはRSPAN送信元がトランク ポートである場合、送信元VLANフィルタリングを設定します。

Router(config)# no monitor session session_number filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

送信元VLANフィルタリングを消去します。

送信元VLANフィルタリングを設定する場合、構文について次の点に注意してください。

single_vlan は、単一のVLANのID番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

次に、送信元がトランク ポートである場合に、VLAN 1~5およびVLAN 9をモニタする例を示します。

Router(config)# monitor session 2 filter vlan 1 - 5 , 9

無条件トランクとしての宛先ポートの設定

宛先ポートを脱退するときにモニタ対象トラフィックにタグを付けるには、宛先ポートをトランクとして設定します。

宛先ポートをトランクとして設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface type 1 slot/port

設定するLANポートを選択します。

ステップ 2

Router(config-if)# switchport

LANポートをレイヤ2スイッチング用に設定します(LANポートにレイヤ2スイッチングがまだ設定されていない場合にのみ必須)。

ステップ 3

Router(config-if)# switchport trunk encapsulation { isl | dot1q }

カプセル化を設定して、レイヤ2スイッチング ポートをISLまたは802.1Qトランクとして設定します。

ステップ 4

Router(config-if)# switchport mode trunk

無条件にポートをトランクに設定します。

ステップ 5

Router(config-if)# switchport nonegotiate

DTPを使用しないようにトランクを設定します。

1.type = ethernetfastethernetgigabitethernet、またはtengigabitethernet

次に、無条件IEEE 802.1Qトランクとしてポートを設定する例を示します。

Router(config)# interface fastethernet 5/12
Router(config-if)# switchport
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# switchport mode trunk
Router(config-if)# switchport nonegotiate

ローカルSPANの宛先トランク ポートVLANフィルタリングの設定

Release 12.2(18)SXD以降のリリースでは、宛先ポートがトランクである場合、トランク上で許可されたVLANリストを使用して、宛先ポートから送信されたトラフィックをフィルタリングできます(CSCeb01318)。

宛先トランク ポートVLANフィルタリングを使用すると、すべてのSPAN宛先ポートがSPAN送信元すべてからのトラフィックを全部受信するという制限を解除します。宛先トランク ポートVLANフィルタリングを使用すると、各宛先トランク ポートから送信されるトラフィックをVLAN単位で選択できます。

宛先トランク ポートVLANフィルタリングをローカルSPAN宛先トランク ポート上に設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface type 2 slot/port

設定するローカルSPAN宛先トランク ポートを選択します。

ステップ 2

Router(config-if)# switchport trunk allowed vlan { add | except | none | remove } vlan [, vlan [, vlan [,...]]

トランク上で許容されるVLANのリストを設定します。

2.type = ethernetfastethernetgigabitethernet、またはtengigabitethernet

ローカルSPAN宛先トランク ポート上で許容されるVLANのリストを設定する場合、構文について次の点に注意してください。

vlanパラメータは、1~4094の間の1つのVLAN番号、または2つのVLAN番号で指定する(小さい方数を先にして、間をダッシュで区切る)VLAN範囲です。カンマで区切ったvlanパラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべてのVLANが許容されます。

許可リストからすべてのVLANを削除するには、 switchport trunk allowed vlan none コマンドを入力します。

許可リストにVLANを追加するには、 switchport trunk allowed vlan add コマンドを入力します。

SPAN設定を削除しないで、許可VLANリストを変更できます。

次に、各宛先トランク ポートがVLANからトラフィックを送信するように宛先トランク ポートVLANフィルタリングがSPANトラフィックをフィルタリングする場合、送信元として複数のVLANを、宛先として複数のトランク ポートを持ったローカルSPANセッションの設定例を示します。

interface GigabitEthernet1/1
description SPAN destination interface for VLAN 10
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/2
description SPAN destination interface for VLAN 11
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 11
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/3
description SPAN destination interface for VLAN 12
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 12
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/4
description SPAN destination interface for VLAN 13
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 13
switchport mode trunk
switchport nonegotiate
!
monitor session 1 source vlan 10 - 13
monitor session 1 destination interface Gi1/1 - 4

設定の確認

設定を確認するには、 show monitor session コマンドを入力します。

次に、セッション2の設定を確認する例を示します。

Router# show monitor session 2
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Fa3/1
Dest RSPAN VLAN: 901
Router#
 

次に、セッション2の詳細を完全に表示する例を示します。

Router# show monitor session 2 detail
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Fa1/1-3
TX Only: None
Both: None
Source VLANs:
RX Only: None
TX Only: None
Both: None
Source RSPAN VLAN: None
Destination Ports: None
Filter VLANs: None
Dest RSPAN VLAN: 901

設定例

次に、RSPAN送信元セッション2の設定例を示します。

Router(config)# monitor session 2 source interface fastethernet1/1 - 3 rx
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッション1とセッション2の設定を消去する例を示します。

Router(config)# no monitor session range 1-2
 

次に、複数の送信元のあるRSPAN送信元セッションの設定例を示します。

Router(config)# monitor session 2 source interface fastethernet 5/15 , 7/3 rx
Router(config)# monitor session 2 source interface gigabitethernet 1/2 tx
Router(config)# monitor session 2 source interface port-channel 102
Router(config)# monitor session 2 source filter vlan 2 - 3
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッションの送信元を削除する例を示します。

Router(config)# no monitor session 2 source interface fastethernet 5/15 , 7/3
 

次に、セッションの送信元に対するオプションを削除する例を示します。

Router(config)# no monitor session 2 source interface gigabitethernet 1/2
Router(config)# no monitor session 2 source interface port-channel 102 tx
 

次に、セッションのVLANフィルタリングを削除する例を示します。

Router(config)# no monitor session 2 filter vlan 3
 

次に、RSPAN宛先セッション8の設定例を示します。

Router(config)# monitor session 8 source remote vlan 901
Router(config)# monitor session 8 destination interface fastethernet 1/2 , 2/3