Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2SX
Supervisor Engine 720 MPLS QoSの 設定
Supervisor Engine 720 MPLS QoSの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

Supervisor Engine 720 MPLS QoSの設定

マニュアルの内容

用語

PFC3BXLおよびPFC3BでのMPLS QOS機能

MPLS実験フィールド

信頼

分類

ポリシングおよびマーキング

IP ToSの保持

EXP変換

MPLS DiffServトンネリング モード

MPLS QoSの概要

IP PrecedenceフィールドでのQoSの指定

PFC3BXLおよびPFC3BのMPLS QoS

MPLSネットワークの入力エッジでのLER

MPLSネットワークのコアにあるLSR

MPLSネットワークの出力エッジでのLER

PFC3BXLおよびPFC3BのMPLS QoSの概要

EoMPLSエッジでのLER

イーサネットからMPLS

MPLSからイーサネット

IPエッジ(MPLS、MPLS VPN)でのLER

IPからMPLS

MPLSからIP

MPLS VPN

MPLSコアでのLSR

MPLSからMPLS

PFC3BXLまたはPFC3BのMPLS QoSデフォルト設定

MPLS QoSコマンド

PFC3BXLまたはPFC3BのMPLS QoSの設定

QoSのグローバルなイネーブル化

注意事項および制約事項

queueing-onlyモードのイネーブル化

制約事項および使用上の注意事項

MPLSパケットを分類するためのクラス マップの設定

制約事項および使用上の注意事項

ポリシー マップの設定

EXP値をすべてのインポーズされたラベルに設定するためのポリシー マップの設定

policeコマンドを使用したポリシー マップの設定

ポリシー マップの確認

インターフェイス サマリーの確認

すべてのクラスのコンフィギュレーションの確認

PFC3BXLまたはPFC3B上の出力EXP変換の設定

名前付きEXP変換マップの設定

インターフェイスへの出力EXP変換マップの付加

EXP値マッピングの設定

入力EXPのDSCPマップへの定義

出力DSCP to EXPマップの定義

MPLS DiffServトンネリング モード

ショート パイプ モード

ショート パイプの制約事項および注意事項

ユニフォーム モード

ユニフォーム モードの制約事項および注意事項

MPLS DiffServトンネリングの制約事項および使用上の注意事項

ショート パイプ モードの設定

入力PEルータ ― カスタマー側に向かうインターフェイス

入力PEルータの設定 ― P側に向かうインターフェイス

Pルータの設定 ― 出力インターフェイス

出力PEルータの設定 ― カスタマー側に向かうインターフェイス

設定例

ユニフォーム モードの設定

入力PEルータの設定 ― カスタマー側に向かうインターフェイス

入力PEルータの設定 ― P側に向かうインターフェイス

出力PEルータの設定 ― カスタマー側に向かうインターフェイス

Supervisor Engine 720 MPLS QoSの設定

マニュアルの内容

ここでは、Multiprotocol Label Switching(MPLS;マルチプロトコル ラベル スイッチング)ネットワークでサポートされるQOS機能をPFC3BXL搭載Supervisor Engine 720およびPFC3B搭載Supervisor Engine 720(以下それぞれPFC3BXLおよびPFC3Bと称する)上で実施する手順について説明します。

この章の内容は、次のとおりです。

「用語」

「MPLS QoSの概要」

「PFC3BXLおよびPFC3BのMPLS QoS」

「PFC3BXLおよびPFC3BのMPLS QoSの概要」

「PFC3BXLまたはPFC3BのMPLS QoSデフォルト設定」

「MPLS QoSコマンド」

「PFC3BXLまたはPFC3BのMPLS QoSの設定」

「MPLS DiffServトンネリング モード」

「ショート パイプ モードの設定」

「ユニフォーム モードの設定」

用語

ここでは、MPLS QoS用語を定義します。

Class of Service(CoS;サービス クラス) ― スイッチド ネットワークを通過するときにイーサネット フレームのプライオリティを示すISL(スイッチ間リンク)ヘッダまたは802.1Q ヘッダどちらかの3ビットのことです。802.1QヘッダのCoSビットは通常802.1pビットと呼ばれます。パケットがレイヤ2およびレイヤ3ドメインの両方を横断するときにQoSを維持するため、Type of Service(ToS;サービス タイプ)値とCoS値は互いにマッピングすることができます。

分類 ― QoSをマーキングするトラフィックを選択するプロセスです。

Differentiated Services Code Point(DSCP;差別化サービス コード ポイント) ― IPヘッダのToSバイトの上位6ビットです。DSCPは、IPパケットにのみ存在します。

E-LSP ― E-LSPはLabel Switched Path(LSP;ラベル スイッチド パス)の1つであり、ノードはここでMPLSヘッダのEXP(実験)ビットから排他的にMPLSパケットのQoS処理を判断します。QoS処理がEXP(クラスおよびドロップ優先順位の両方)から判断されるため、いくつかのクラスのトラフィックを1つのLSPに多重化することができます(同じラベルを使用)。EXPフィールドは3ビット フィールドであるため1つのLSPは最大8つのトラフィックのクラスをサポートすることができます。制御プレーン トラフィック用にいくつかの値が予約されている場合、またはクラスのいくつかがそれらに対応するドロップ優先順位を持っている場合、クラスの最大数はもっと少なくなります。

EXPビット ― EXPビットはノードがパケットに与えるQoS処理(Per Hop Behavior)を定義するのに用いられます。これは、IPネットワークのDiffServ Code Point(DSCP;差別化サービス コード ポイント)に相当します。DSCPは、クラスとドロップ優先順位を定義します。EXPビットは、一般にIP DSCPでエンコードされた情報をすべて伝送するのに用いられます。ただし、ドロップ優先順位をエンコードするためにEXPビットが排他的に用いられる場合もあります。

フレーム ― レイヤ2でトラフィックを伝送します。レイヤ2フレームは、レイヤ3パケットを伝送します。

IP Precedence ― IPヘッダのToSバイトの上位3ビットです。

QoSタグ ― レイヤ3パケットおよびレイヤ2フレームで伝達されるプライオリティ値です。レイヤ2 CoSラベルは、0(ロー プライオリティ)~7(ハイ プライオリティ)の範囲です。レイヤ3 IP precedenceラベルは、0(ロー プライオリティ)~7(ハイ プライオリティ)の範囲です。IP precedence値は、1バイトのToSフィールドの上位3ビットで定義されます。レイヤ3 DSCPラベルは、0~63の値を持つことができます。DSCP値は1バイトのIP ToSフィールドのうち上位6ビットで定義されます。

LER ― パケット上のラベルのインポーズおよびディスポーズを行うデバイスであり、Provider Edge(PE;プロバイダー エッジ)ルータとも呼ばれます。

LSR ― パケット上のラベルに基づいてトラフィックを転送するデバイスであり、P(プロバイダー)ルータとも呼ばれます。

マーキング ― パケットのレイヤ3 DSCP値を設定するプロセスです。マーキングはまた、MPLS EXPフィールドで異なった値を選択してパケットにマーキングし、輻輳時にパケットが必要なプライオリティを持つようにするプロセスでもあります。

パケット ― レイヤ3でトラフィックを伝送します。

ポリシング ― トラフィック フローが使用する帯域幅を制限する処理です。ポリシングによって、トラフィックのマーキングまたはディスポジションが可能になります。

PFC3BXLおよびPFC3BでのMPLS QOS機能

QoSにより、ネットワークは選択されたネットワーク トラフィックに提供するサービスを向上させることができます。ここでは、PFC3BXLおよびPFC3BによりMPLSネットワークでサポートされる次のQOS機能を実施する手順について説明します。

「MPLS実験フィールド」

「IP ToSの保持」

「分類」

「ポリシングおよびマーキング」

「IP ToSの保持」

「EXP変換」

「MPLS DiffServトンネリング モード」


) MPLS QoSは、http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/software/122sx/swcg/qos.htmの『Cisco 7600 Series Cisco IOS Software Configuration Guide, 12.2SXConfiguring PFC QoS」の章に記載されているPFC3 QoS機能をMPLSトラフィックに拡張したものです。この章は、PFC3BXLおよびPFC3BのMPLS QoS機能についての補足情報を提供することを意図したものです。この章を読む前に、上記の章のPFC3 QoS機能を理解しておいてください。



) このマニュアルで使用するコマンドの構文および使用方法の詳細については、『Cisco 7600 Series Router Cisco IOS Command Reference』を参照してください。



) PFC3BXLおよびPFC3Bで利用できるすべてのポリシングとマーキングは、Modular QoS
Command-Line Interface(MQC;モジュール型コマンドライン インターフェイス)から管理されます。MQCは、トラフィック クラスを定義し、トラフィック ポリシー(ポリシー マップ)を作成して設定し、これらのトラフィック ポリシーをインターフェイスに付加することを可能にするコマンド ライン インターフェイスです。MQCの詳細については、以下のURLの『Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2』を参照してください。
http://www.cisco.com/en/US/products/sw/iosswrel/ps5014/products_feature_guide_chapter09186a008008813a.html


MPLS実験フィールド

MPLS EXP(実験フィールド)値を設定すると、サービス プロバイダーが自己のネットワークで伝送されたIPパケット内で変更されたIP precedenceフィールドの値を望まない場合に、サービス プロバイダーの要件を満たすことができます。

MPLS EXPフィールドで異なった値を選択することにより、輻輳時にパケットが必要なプライオリティを持つようパケットをマーキングすることができます。

デフォルトでは、IP precedence値はインポジション中にMPLS EXPフィールドにコピーされます。PFC3BXLまたはPFC3BポリシーによりMPLS EXPビットをマーキングすることができます。

信頼

受信MPLSパケットについては、PFC3BXLおよびPFC3Bは常に受信した最上位ラベルのEXPを信頼します。入力インターフェイス信頼ステート、ポートCoS、policy-map trustコマンドはMPLSパケットにまったく影響を与えません。

分類

分類とはマーキングするトラフィックを選択するプロセスです。分類は、トラフィックを複数の優先順位レベル、すなわちサービス クラスに分割することによりこのプロセスを実施します。トラフィック分類は、クラス ベースのQoSプロビジョニングのプライマリ コンポーネントです。PFC3BXLおよびPFC3Bは、(ポリシーのインストール後)受信MPLSパケットの受信最上位ラベルのEXPビットに基づいて分類を決定します。詳細については「MPLSパケットを分類するためのクラス マップの設定」を参照してください。

ポリシングおよびマーキング

ポリシングを行うと、設定レートを超えたトラフィックは廃棄されるか、またはより高いドロップ優先順位にマークダウンされます。マーキングは、パケット フローを識別して、これらを区別する手法です。パケット マーキングを利用すれば、ネットワークを複数の優先プライオリティ レベルまたはサービス クラスに分割することができます。

どのPFC3BXLおよびPFC3BのMPLS QoSのポリシングおよびマーキング機能を実行できるかは、受信トラフィック タイプおよびトラフィックに適用される転送動作によって異なります。詳細については「ポリシー マップの設定」を参照してください。

IP ToSの保持

PFC3BXLおよびPFC3Bは、インポジション、スワッピング、ディスポジションを含むすべてのMPLS動作中、自動的にIP ToSを保持します。IP ToSを保存するコマンドを入力する必要はありません。

EXP変換

最大8個の出力EXP変換マップを設定して、内部EXP値が出力EXP値として書き込まれる前に内部EXP値を変換することができます。出力EXP変換マップは、ルータ ポート、サブインターフェイス、またはSwitched Virtual Interface(SVI)に付加できます。EXP変換マップをスイッチポートに付加することはできません。コンフィギュレーションについては、「PFC3BXLまたはPFC3B上の出力EXP変換の設定」を参照してください。

MPLS DiffServトンネリング モード

PFC3BXLおよびPFC3Bは、MPLS DiffServトンネリング モードを使用します。トンネリングは、ネットワークの1つのエッジから、そのネットワークの別のエッジまでのQoSトランスペアレンシを提供します。詳細については、「MPLS DiffServトンネリング モード」を参照してください。

MPLS QoSの概要

MPLSのQoS機能を利用するとネットワーク管理者はMPLSネットワーク全体で差別化されたサービスを提供することができます。差別化サービスは、QoSによって各送信パケットに指定されたサービスを提供することにより、幅広い要件を満たします。サービスは、IPパケット内のIP
precedenceビット設定を使用するなど様々な方法で指定することができます。

IP PrecedenceフィールドでのQoSの指定

IPパケットを1つのサイトから別のサイトへ送信する場合、IP Precedenceフィールド(IPパケットのヘッダのDSCPフィールドの上位3ビット)がQoSを指定します。IP precedenceマーキングに基づき、パケットにはそのQoSで所望の処理が与えられます。サービス プロバイダー ネットワークがMPLSネットワークである場合、ネットワークのエッジでIP PrecedenceビットがMPLS EXPフィールドにコピーされます。ただし、サービス プロバイダーは、あるMPLSパケットのQoSに、提供するサービスによって決定される異なった値を設定したい場合もあります。

この場合、サービス プロバイダーはMPLS EXPフィールドを設定することができます。IPヘッダはカスタマーが利用できるよう引き続き利用可能であり、IPパケットのQoSはパケットがMPLSネットワークを移動する間変更されません。

詳細については『「MPLS DiffServトンネリング モード」』を参照してください。

PFC3BXLおよびPFC3BのMPLS QoS

ここでは、MPLS QoSがPFC3BXLとPFC3Bでどのように機能するのかを説明します。

図 31-1に、カスタマー ネットワークの2つのサイトを接続するサービス プロバイダーのMPLSネットワークを示します。

図 31-1 カスタマーのIPネットワークの2つのサイトを接続するMPLSネットワーク

 

このネットワークは両方向ですが、ここではパケットは左から右へ移動します。

図 31-1の記号の意味は次のとおりです。

CE1 ― カスタマー装置1

PE1 ― サービス プロバイダー入力LER(ラベル エッジ ルータ)

P1 ― サービス プロバイダーのネットワークのコア内のLSR(ラベル スイッチ ルータ)

P2 ― サービス プロバイダーのネットワークのコア内のLSR

PE2 ― サービス プロバイダー出力LER

CE2 ― カスタマー装置2


) PE1およびPE2は、MPLSネットワークとIPネットワークの境界にあります。


ここでは、MPLSネットワーク内のLERとLSRの動作について説明します。

「MPLSネットワークの入力エッジでのLER」

「MPLSネットワークのコアにあるLSR」

「MPLSネットワークの出力エッジでのLER」


) 入力インターフェイスでのQoS機能は、入力インターフェイスがLANポートであるか、OSM上のWANポートであるか、FlexWANまたはEnhanced FlexWANカード上のポート アダプタであるかによって異なります。ここでは、LANポートの場合について説明します。OSMの詳細については、『OSM Configuration Note, 12.2SX』を参照してください。FlexWANまたはEnhanced FlexWANカードの詳細については、『FlexWAN and Enhanced FlexWAN Installation and Configuration Note』を参照してください。


MPLSネットワークの入力エッジでのLER


) 着信ラベルには集約または非集約の2つのタイプがあります。集約ラベルの場合は、ネクスト ホップおよび発信インターフェイスを検出するときに、IP検索を通して着信MPLSまたはMPLS VPNパケットをスイッチングする必要があります。非集約ラベルの場合は、パケットにIPネクスト ホップ情報が格納されます。


エッジLERは、次に示すとおりMPLSネットワークの入力側または出力側のどちらかで稼働することができます。

MPLSネットワークの入力側では、LERがパケットを次のように処理します。

1. レイヤ2またはレイヤ3トラフィックはエッジLER(PE1)でMPLSネットワークのエッジに入ります。

2. PFC3BXLまたはPFC3Bは、入力インターフェイスからトラフィックを受信し、802.1pビットまたはIP ToSビットを使用してEXPビットを判別し、分類、マーキング、ポリシングを実行します。着信IPパケットの分類については、入力サービス ポリシーもACLを使用することができます。

3. PFC3BXLまたはPFC3Bは各着信パケットについてIPアドレスで検索を実行し、ネクスト ホップ ルータを決定します。

4. 適切なラベルがパケットにプッシュ(インポジション)され、QoS決定の結果としてのEXP値はラベル ヘッダのMPLS EXPフィールドにコピーされます。

5. PFC3BXLまたはPFC3Bは、ラベル付きパケットを適切な処理用出力インターフェイスに転送します。

6. PFC3BXLまたはPFC3Bはまた、802.1pビットまたはIP ToSビットを出力インターフェイスに転送します。

7. 出力インターフェイスでは、ラベル付きパケットはクラスごとに区別され、マーキングまたはポリシングが行われます。LANインターフェイスについては、出力分類はまだMPLSではなくIPに基づいて行われています。

8. (EXPによってマーキングされた)ラベル付きパケットは、コアMPLSネットワークに送信されます。

MPLSネットワークのコアにあるLSR

MPLSネットワークのコアで使用されるLSRはパケットを次のように処理します。

1. エッジLER(または他のコア デバイス)からの着信MPLSラベル付きパケット(および802.1pビットまたはIP ToSビット)がコアLSRに着信します。

2. PFC3BXLまたはPFC3Bは、入力インターフェイスからトラフィックを受信し、EXPビットを使用して、分類、マーキング、ポリシングを実行します。

3. PFC3BXLまたはPFC3Bは、テーブル検索を実施してネクストホップLSRを決定します。

4. 適切なラベルがパケットに配置(スワップ)され、MPLS EXPビットがラベル ヘッダにコピーされます。

5. PFC3BXLまたはPFC3Bは、ラベル付きパケットを適切な処理用出力インターフェイスに転送します。

6. PFC3BXLまたはPFC3Bはまた、802.1pビットまたはIP ToSビットを出力インターフェイスに転送します。

7. 送信パケットは、MPLS EXPフィールドによって区別され、マーキングまたはポリシングが行われます。

8. (EXPによってマーキングされた)ラベル付きパケットは、コアMPLSネットワークの別のLSRまたは出力エッジのLERに送信されます。


) パケットはMPLSパケットであるため、サービス プロバイダー ネットワーク内には、キューイング機構が参照するIP Precedenceフィールドはありません。パケットは、プロバイダー エッジ ルータであるPE2に着信するまでMPLSパケットのままです。


MPLSネットワークの出力エッジでのLER

MPLSネットワークの出力側では、LERがパケットを次のように処理します。

1. コアLSRからのMPLSラベル付きパケット(および802.1pビットまたはIP ToSビット)が
MPLSネットワーク バックボーンから接続される出力LER(PE2)に着信します。

2. PFC3BXLまたはPFC3Bは、パケットからMPLSラベルをポップします(ディスポジション)。集約ラベルは、元の802.1pビットまたはIP ToSビットを使用して分類されます。非集約ラベルは、デフォルトではEXP値で分類されます。

3. 集約ラベルについては、PFC3BXLまたはPFC3BはIPアドレスを検索し、パケットの宛先を決定します。次にPFC3BXLまたはPFC3Bはそのパケットを適切な処理用出力インターフェイスに転送します。非集約ラベルについては、転送はラベルに基づいて行われます。デフォルトでは、非集約ラベルは出力PEではなく最後から2番めのホップ ルータでポップされます。

4. PFC3BXLまたはPFC3Bはまた、802.1pビットまたはIP ToSビットを出力インターフェイスに転送します。

5. パケットは、802.1pビットまたはIP ToSビットに従って区別され、それに従って処理されます。


) MPLS実験ビットを使用すると、MPLSパケットのQoSを指定することができます。IP PrecedenceおよびDSCPビットを使用すると、IPパケットのQoSを指定することができます。


PFC3BXLおよびPFC3BのMPLS QoSの概要

PFC3BXLおよびPFC3BのMPLS QoSの第一の目的はIP QoSをサポートすることです。MPLSパケットについては、PFC3BXLおよびPFC3Bが正規のQoSマーキングとポリシング ロジックを適用できるようEXP値は内部DSCPにマッピングされます。

入力および出力ポリシーについては、MPLS QoSマーキングおよびポリシングの決定は入力PFC3BXLまたはPFC3Bでインターフェイスに従い行われます。入力インターフェイスは物理ポート、サブインターフェイス、またはVLANです。

QoSポリシーACLは、入力および出力検索用に別途QoS TCAMでプログラミングされます。TCAM出力検索は、IP Forwarding Table(FIB;IP転送テーブル)およびNetFlowの検索が完了したあとで行われます。

各QoS TCAMの検索結果により、ポリサー設定とポリシング カウンタを含むRAMへのインデックスが生成されます。追加RAMには、マイクロフロー ポリサー設定が含まれ、マイクロフロー ポリシング カウンタはQoS ACLと一致する各NetFlowエントリ内に維持されます。

入力および出力集約およびマイクロフロー ポリシングの結果は統合されて最終ポリシング決定となります。不適合パケットは、廃棄するか、DSCP内でマークダウンすることがきます。

ここでは、次のPFC3BXLまたはPFC3B MPLS QoSについて説明します。

「EoMPLSエッジでのLER」

「IPエッジ(MPLS、MPLS VPN)でのLER」

「MPLSコアでのLSR」


) ここでは、LANポート、OSMポート、FlexWANポートのQoS機能について説明します。別の機能がどのように動作するかについては、適切なライン カード資料を参照してください。


EoMPLSエッジでのLER

ここでは、LERで機能するEthernet over MPLS(EoMPLS)QoSの概要を説明します。

EoMPLS QoSサポートは、IPからMPLSのQoSに似ています。


) EoMPLSでは、ポートがuntrustedの場合、trust CoSステートは自動的にVCタイプ5(ポート モード)ではなくVCタイプ4(VLANモード)に設定されます(トンネルでの802.1q CoS保持も同様です)。


EoMPLS QoSは次の状況をサポートします。

標準的MPLS QoS機能

トンネル入力で受信されたパケットは、EoMインターフェイスではuntrustedとして扱われます。ただし、trust CoSが入力ポートで自動的に設定され、ポリシー マーキングが適用されないVCタイプ4は例外です。

入力ポートがtrustedとして設定された場合、EoMインターフェイスで受信されたパケットは元のIPパケット ヘッダのQoSポリシーによってマーキングされません(IPポリシーによるマーキングはuntrustedポートで機能します)。

802.1p CoSが802.1qヘッダを介して利用可能な場合、802.1p CoSは入口から出口まで保持されます。

トンネル出口から先では、1pタグがEoMヘッダ(VCタイプ4)でトンネリングされている場合には、キューイングは保持された802.1p CoSに基づいて行われます。それ以外の場合には、キューイングはQoS決定から導出されたCoSに基づいて行われます。

イーサネットからMPLS

Ethernet to MPLSの入力インターフェイス、PFC3BXLまたはPFC3BのQoS、出力インターフェイスの機能は、IP to MPLSの対応する機能と同様です。詳細については「IP-to-MPLSライン カード入力分類」「IP-to-MPLSのPFC3BXLまたはPFC3B分類」および「IP-to-MPLSライン カード出力分類」を参照してください。

MPLSからイーサネット

MPLS to Ethernetについては、出力IPポリシーが適用できない(パケットがMPLSとしてだけ分類できる)EoMカプセル開放の場合を除き、入力インターフェイス、PFC3BXLまたはPFC3BのQoS、出力インターフェイスの機能は、MPLS to IPの対応する機能と同様です。

詳細については「MPLS-to-IPライン カード入力分類」「MPLS-to-IPのPFC3BXLまたはPFC3Bの分類」および「MPLS-to-IPライン カード出力分類」を参照してください。

IPエッジ(MPLS、MPLS VPN)でのLER

ここでは、MPLSおよびMPLS VPNネットワークの入力(CE-to-PE)および出力(PE-to-CE)エッジでのLERのQoS機能について説明します。MPLSとMPLS VPNのどちらも一般MPLS QoS機能をサポートします。追加的なMPLS VPN特定QoSについては「MPLS VPN」を参照してください。

IPからMPLS

PFC3BXLまたはPFC3BはIP-to-MPLSエッジで次のMPLS QoS機能を提供します。

mls qos trust またはpolicy-mapコマンドに基づくEXP値の割り当て

ポリシーを利用したEXP値のマーキング

ポリシーを利用したトラフィックのポリシング

ここではPFC3BXLまたはPFC3BがIP-to-MPLSエッジでサポートするMPLS QoS分類について説明します。さらに、入力および出力インターフェイス ライン カードによって提供される機能についても説明します。

IP-to-MPLS分類

PFC3BXLまたはPFC3BのIPトラフィック用入力および出力ポリシーでは、IP Precedence、IP DSCP、IP ACLのmatchコマンドを使用して元の受信IPでトラフィックが分類されます。出力ポリシーでは、トラフィックはインポーズされたEXP値や入力ポリシーによって行われたマーキングに基づいて分類されません。

PFC3BXLまたはPFC3Bはポートの信頼およびQoSポリシーを適用した後、内部DSCPを割り当てます。次にPFC3BXLまたはPFC3Bは、インポーズしたラベルに内部DSCP-to-EXPグローバル マップに基づいてEXP値を割り当てます。複数のラベルがインポーズされている場合、EXP値は各ラベルとも同じです。MPLSラベルがインポーズされたとき、PFC3BXLまたはPFC3Bは元のIP ToSを保持します。

PFC3BXLまたはPFC3Bは、内部DSCP-to- CoSグローバル マップに基づいて出力CoSを割り当てます。デフォルトの内部DSCP-to-EXPマップおよび内部DSCP-to-CoSマップが整合している場合、出力CoSはインポーズされたEXPと同じ値を持ちます。

入力ポートがIP-to-IPおよびIP-to-MPLSトラフィックの両方を受信した場合、分類を用いてこの2つのタイプのトラフィックを分離する必要があります。たとえば、IP-to-IPおよびIP-to-MPLSトラフィックの宛先アドレス範囲が異なっている場合、宛先アドレスに基づいてトラフィックを分類し、次にIP ToSポリシーをIP-to-IPトラフィックに適用し、(インポーズされたMPLSヘッダにEXP値をマーキングまたは設定する)ポリシーをIP-to-MPLSトラフィックに適用することができます。次の2つの例を参照してください。

IP ToSをマーキングするPFC3BXLまたはPFC3Bポリシーが内部DSCPを設定します。 ― これがすべてのトラフィックに適用された場合、IP-to-IPトラフィックについては出力ポートが(内部DSCPから導出された)CoSを出力パケットのIP ToSバイトにリライトします。IP-to-MPLSトラフィックでは、PFC3BXLまたはPFC3Bが内部DSCPをインポーズされたEXP値にマッピングします。

MPLS EXPをマーキングするPFC3BXLまたはPFC3Bポリシーが内部DSCPを設定します。 ― これがすべてのトラフィックに適用された場合、IP-to-IPトラフィックについては出力ポートが入力IPポリシー(または信頼)に従いIP ToSをリライトします。CoSはToSからマッピングされます。IP-to-MPLSトラフィックでは、PFC3BXLまたはPFC3Bが内部DSCPをインポーズされたEXP値にマッピングします。

IP-to-MPLSのPFC3BXLまたはPFC3B分類

PFC3BXLまたはPFC3BはPE1への入力で次のMPLS QoS機能を提供します。

優先順位、DSCP、アクセス グループのマッチング

アクション:set mpls experimental imposition、police、set impositionとともにpolice

PFC3BXLまたはPFC3BはPE1の出力で次のMPLS QoS機能を提供します。

mpls experimental topmostのマッチング

アクション:なし

IP-to-MPLSライン カード入力分類

IP to MPLSの分類はIP to IPと同じです。LANインターフェイス分類は受信した802.1Q値に基づいて行われます。OSMおよびFlexWANインターフェイスは受信IPヘッダの情報に基づいて分類を行います。

IP-to-MPLSライン カード出力分類

LANインターフェイス分類は着信EXP値に基づいて行われます。出力CoSは、その値からマッピングされます。

OSMおよびFlexWANインターフェイスは、match mpls experimentalコマンドを使用してEXP値のプロキシとして出力CoSのマッチングを行うときにトラフィックを分類します。match mpls experimentalコマンドは最上位ラベルのEXP値のマッチングは行いません。

出力ポートがトランク ポートである場合、LANポートとOSM GE WANポートは出力CoSを出力フレームの802.1Qフィールドにコピーします。

MPLSからIP

PFC3BXLまたはPFC3BはMPLS-to-IPエッジで次のMPLS QoS機能を提供します。

出力インターフェイスに従いMPLSドメインからの送信時にEXP値をIP DSCPに伝播するオプション

MPLS-to-IP出力インターフェイスでIPサービス ポリシーを使用するオプション

ここでは、MPLS-to-IP MPLS QoS分類について説明します。さらに、ここでは入力および出力インターフェイス ライン カードによって提供される機能についても説明します。

MPLS-to-IP分類

PFC3BXLまたはPFC3BはQoS結果に基づいて内部DSCP(PFC3BXLまたはPFC3Bが各フレームに割り当てる内部プライオリティ)を割り当てます。QoS結果は次の影響を受けます。

デフォルトの信頼EXP値

ラベル タイプ(プレフィクス単位または集約)

VPNの数

明示的NULLの使用

QoSポリシー

次のような3つの異なった分類モードがあります。

正規MPLS分類 ― 非集約ラベルについては、MPLSの再循環がないため、PFC3BXLまたはPFC3BはMPLS EXP入力または出力ポリシーに基づいてパケットを分類します。PFC3BXは、EXP-to-DSCP-to-CoSマッピングから導出されたCOSに基づいてパケットをキューに入れます。この基礎となるIP DSCPは、出力カプセル開放後保持されるか、(EXP-to-DSCPマップを介して)EXPから上書きされます。

VPN CAMでヒットした集約ラベルのIP分類 ― PFC3BXLまたはPFC3Bは、基本となるIP ToSを保持するか、EXP-to-DSCPグローバル マップから導出された値によってIP ToSをリライトするか、またはIP Tosを出力IPポリシーから導出された任意の値に変換します。どの場合も、出力キューイングはDSCP-to-CoSマップから導出された最終IP ToSに基づいています。

VPN CAMにない集約ラベルでのIP分類 ― 再循環の後、PFC3BXLまたはPFC3BはMPLSカプセル開放隣接で指定された入力予約VLANに基づきMPLS-to-IPパケットを正規IP-to-IPパケットと区別します。予約されたVLANはVPNおよび非VPNの両方についてVRFに従い割り当てられます。再循環後の入力ToSは元のIP ToS値でも、元のEXP値から導出したものでもかまいません。出力IPポリシーはこの入力ToSを任意の値に上書きすることができます。


) 再循環の詳細については、「再循環」を参照してください。


PE-to-CE入力上の着信MPLSパケットの場合、PFC3BXLまたはPFC3BではMPLS分類のみがサポートされます。入力IPポリシーはサポートされません。MPLSコアからのPE-to-CEトラフィックは出力時にIPとして分類またはポリシングされます。

MPLS-to-IPのPFC3BXLまたはPFC3Bの分類

PFC3BXLまたはPFC3BはPE2への入力で次のMPLS QoS機能を提供します。

EXP値のマッチング

アクション:police

PFC3BXLまたはPFC3BはPE2の出力で次のMPLS QoS機能を提供します。

優先順位、DSCP、アクセス グループのマッチング

アクション:police

MPLS-to-IPライン カード入力分類

LANインターフェイス分類はEXP値に基づきます。OSMおよびFlexWANインターフェイスは、match mpls experimentalコマンドを使用してトラフィックを分類します。match mpls experimentalコマンドは受信最上位ラベルのEXP値のマッチングを行います。

MPLS-to-IPライン カード出力分類


) 出力分類キューイングはLANおよびWANポートでは異なっています。


MPLS to IPの分類は、IP to IPと同じです。

LANインターフェイス分類は出力CoSに基づきます。OSMおよびFlexWANインターフェイスは、送信されたIPヘッダの情報に基づいてトラフィックを分類します。


) 出力ポリシーではPFC3BXLまたはPFC3BのQoS機能またはOSM QoS機能を使用することができます。ただし、同じ出力ポリシーで両方を使用することはできません。


出力ポートがトランク ポートである場合、LANポートおよびOSM GE WANポートは出力CoSを出力フレームの802.1Qフィールドにコピーします。


) MPLS to IPについては、出力インターフェイスのMPLS IP(またはタグIP)がイネーブルの場合は出力IP ACLまたはQoSは出力インターフェイスでは有効ではありません。例外はVPN CAMヒットです。この場合パケットは出力ではIPとして分類されます。


MPLS VPN

上記に加えて、以下の点がMPLS VPNネットワークに適用されます。

MPLS VPNでは次のPE MPLS QoS機能がサポートされます。

VPNサブインターフェイスを介したCE-to-PE IPトラフィックの分類、ポリシング、マーキング

VPN単位のQoS(ポート単位、VLAN単位、またはサブインターフェイス単位)

Customer Edge(CE;カスタマー エッジ)-to-PEトラフィック、またはCE-to-PE-to-CEトラフィックでは、サブインターフェイス サポートによりIP QoS入力または出力ポリシーをサブインターフェイスおよび物理インターフェイスに適用することができます。CE側のあるVPNに対応する特定のインターフェイスまたはサブインターフェイスではVPN単位のポリシングも提供されます。

同じVPNに属する複数のインターフェイスがある状況では、同じPFC3BXLまたはPFC3Bに対応するすべての類似インターフェイスについて、入力または出力サービス ポリシー内の同じ共有ポリサーを使用したVPN単位のポリシング集約を実行することができます。

集約VPNラベルについては、再循環の場合のEXP伝播はサポートされないかもしれません。これは、最終パケットがどの出力インターフェイスを使用するのかということを、MPLS隣接が知らないためです。


) 再循環については、「再循環」を参照してください。


VPN内のすべてのインターフェイスがEXP伝播をイネーブルにしている場合、PFC3BXLまたはPFC3BはEXP値を伝播します。

次のPE MPLS QoS機能がサポートされています。

IPパケット用の一般的なMPLS QoS機能

VPNサブインターフェイスを介したCE-to-PE IPトラフィックの分類、ポリシング、マーキング

VPN単位のQoS(ポート単位、VLAN単位、またはサブインターフェイス単位)

MPLSコアでのLSR

ここでは、MPLSおよびMPLS VPNネットワークのコア(MPLS-to-MPLS)でのLSRのMPLS QoS機能について説明します。Carrier Supporting Carrier(CsC)QoS機能の入力機能、出力インターフェイス、およびPFC3BXLまたはPFC3Bの機能は、次のセクションで説明するMPLS to MPLSのものと同じです。CsCとMPLS to MPLSの相違は、CsCラベルがMPLSドメイン内部にインポーズできることです。

MPLSからMPLS

PFC3BXLまたはPFC3BはMPLSコアで次のMPLS QoS機能をサポートします。

サービス ポリシーに基づくEXP単位のポリシング

入力最上位EXP値を新たにインポーズされたEXP値へのコピーすること

MPLSドメイン間の出力境界でのEXP変換オプション(隣り合った2つのMPLSドメイン間でインターフェイス エッジ上のEXP値を変更)

特定のEXP値について個々のラベル フローに基づくマルチフロー ポリシング

最上位ラベルをマルチラベル スタックからポップする場合に最上位EXP値を基礎となるEXP値へ伝播するオプション

ここでは、MPLS-to-MPLSのPFC3BXLまたはPFC3B MPLS QoS分類について説明します。さらに、入力および出力インターフェイス ライン カードによって提供される機能についても説明します。

MPLS-to-MPLS分類

PFC3BXLまたはPFC3Bは、受信MPLSパケットについてポート信頼状態、入力CoS、およびあらゆるpolicy-map trustコマンドを無視します。その代わり、PFC3BXLまたはPFC3Bは最上位ラベルのEXP値を信頼します。


) match mpls experimentalコマンドを入力すると、PFC3BXLまたはPFC3BのMPLSトラフィック用入力および出力ポリシーは、受信最上位ラベルのEXP値に基づいてトラフィックを分類します。


そしてEXP-to-DSCPグローバル マップを使用してEXP値を内部DSCPにマッピングします。
PFC3BXLまたはPFC3Bの次の手順は、ラベルをスワッピングしているのか、新しいラベルをインポーズしているのか、それともラベルをポップしているのかによって異なります。

ラベルのスワッピング ― ラベルをスワッピングする場合、PFC3BXLまたはPFC3Bは受信最上位ラベルのEXP値を保持して、これを送信最上位ラベルのEXP値にコピーします。PFC3BXLまたはPFC3Bは、内部DSCP-to-CoSグローバル マップを使用して出力CoSを割り当てます。DSCPグローバル マップが整合している場合は、出力CoSは送信最上位ラベルのEXPに基づきます。

PFC3BXLまたはPFC3Bはpoliceコマンドのexceedおよびviolateアクションを使用して不適合なトラフィックをマークダウンすることができます。適合するトラフィックはマーキングしないため、conformアクションはtransmittedである必要があり、setコマンドを使用することはできません。PFC3BXLまたはPFC3Bがマークダウンを実行している場合、内部DSCPは内部DSCPマークダウン マップへのインデックスとして使用されます。PFC3BXLまたはPFC3Bは、内部DSCP-to-EXPグローバル マップを使用して内部DSCPの結果をEXP値にマークダウンします。PFC3BXLまたはPFC3Bは新しいEXP値を最上位送信ラベルにリライトし、新しいEXP値をスタックの他のラベルにはコピーしません。PFC3BXLまたはPFC3Bは、内部DSCP-to-CoSグローバル マップを使用して出力CoSを割り当てます。DSCPマップが整合している場合は、出力CoSは送信最上位ラベルのEXP値に基づきます。

追加ラベルのインポーズ ― 新しいラベルを既存のラベル スタックにインポーズする場合、
PFC3BXLまたはPFC3Bは内部DSCP-to-EXPマップを使用して内部DSCPをインポーズされたラベルのEXP値にマッピングします。そして次にインポーズされたラベルのEXP値を基礎となるスワップされたラベルにコピーします。PFC3BXLまたはPFC3Bは、内部DSCP-to-CoSグローバル マップを使用して出力CoSを割り当てます。DSCPマップが整合している場合は、出力CoSはインポーズされたラベルのEXP値に基づきます。

PFC3BXLまたはPFC3Bは適合するトラフィックをマーキングし、不適合なトラフィックを
マークダウンすることができます。PFC3BXLまたはPFC3Bは、内部DSCPをマーキングした後、内部DSCP-to-EXPグローバル マップを使用して内部DSCPを新しくインポーズされたラベルのEXP値にマッピングします。そしてPFC3BXLまたはPFC3Bは、インポーズされたラベルのEXP値を基礎となるスワップされたラベルにコピーします。PFC3BXLまたはPFC3Bは、内部DSCP-to-CoSグローバル マップを使用して出力CoSを割り当てます。したがって、出力CoSはインポーズされたラベルのEXP値に基づきます。

ラベルのポップ ― ラベルをマルチラベル スタックからポップする場合、PFC3BXLまたはPFC3BはエクスポーズされたラベルのEXP値を保持します。PFC3BXLまたはPFC3Bは、内部DSCP-to-CoSグローバル マップを使用して出力CoSを割り当てます。DSCPマップが整合している場合は、出力CoSはポップされたラベルのEXP値に基づきます。

EXP伝播が出力インターフェイスで設定されている場合、PFC3BXLまたはPFC3Bは
DSCP-to-EXPグローバル マップを使用して、エクスポーズされたラベルのEXP値に内部DSCPをマッピングします。PFC3BXLまたはPFC3Bは、内部DSCP-to-CoSグローバル マップを使用して出力CoSを割り当てます。DSCPマップが整合している場合は、出力CoSはエクスポーズされたラベルのEXP値に基づきます。

MPLS-to-MPLSのPFC3BXLまたはPFC3Bの分類

PFC3BXLまたはPFC3BはP1またはP2への入力で次のMPLS QoS機能を提供します。

mpls experimental topmostのマッチング

アクション:set mpls experimental imposition、police、set impositionとともにpolice

PFC3BXLまたはPFC3BはP1またはP2の出力で次のMPLS QoS機能を提供します。

mpls experimental topmostのマッチング

アクション:なし

MPLS-to-MPLSライン カード入力分類

MPLSの入力インターフェイス分類は、ポート タイプおよびライン カードによって異なります。

LANインターフェイス分類はPFC3BXLまたはPFC3Bからの出力CoSに基づきます。OSMおよびFlexWANインターフェイスは、match mpls experimentalコマンドを使用してトラフィックを分類します。match mpls experimentalコマンドは受信最上位ラベルのEXP値のマッチングを行います。

MPLS-to-MPLSライン カード出力分類

LANインターフェイス分類はPFC3BXLまたはPFC3Bからの出力CoSに基づきます。OSMおよびFlexWANインターフェイスは、match mpls experimentalコマンドを使用してトラフィックを分類します。match mpls experimentalコマンドは出力CoSのマッチングを行いますが、最上位ラベルのEXP値のマッチングは行いません。

出力ポートがトランク ポートである場合、LANポートとOSM GE WANポートは出力CoSを出力フレームの802.1Qフィールドにコピーします。

PFC3BXLまたはPFC3BのMPLS QoSデフォルト設定

ここでは、PFC3BXLまたはPFC3B MPLS QoSデフォルト設定について説明します。

次のグローバルPFC3BXLまたはPFC3BのMPLS QoS設定が適用されます。

 

機能
デフォルト値

PFC QoSのグローバル イネーブル ステート


) PFC QoSがディセーブルで他のすべてのPFC QoSパラメータがデフォルト値の場合、デフォルトEXPはIP Precedenceからマッピングされます。



) PFC QoSがイネーブルで、他のすべてのPFC QoSパラメータがデフォルト値の場合、PFC QoSはルータシリーズ ルータのLANポート(デフォルトはuntrusted)から送信されたすべてのトラフィックでレイヤ 3 DSCPを0(untrustedポートに限る)に、レイヤ2 CoSを0、インポーズされたEXPを0に設定します。trust Cosでは、デフォルトのEXP値がCOSからマッピングされます。trust DSCPでは、デフォルトのEXP値がIP Precedenceからマッピングされます。OSM WANポート(デフォルトはtrust DSCP)では、DSCPがインポーズされたEXPにマッピングされます。


 

PFC QoS ポート イネーブル ステート

PFC QoSがグローバルにイネーブルの場合、イネーブル

ポートのCoS値

0

microflowポリシング

イネーブル

VLAN内microflowポリシング

ディセーブル

ポートベースまたはVLANベースのPFC QoS

ポートベース

EXP/DSCPマップ(EXP値から設定されたDSCP)

EXP 0 = DSCP 0
EXP 1 = DSCP 8
EXP 2 = DSCP 16
EXP 3 = DSCP 24
EXP 4 = DSCP 32
EXP 5 = DSCP 40
EXP 6 = DSCP 48
EXP 7 = DSCP 56

IP precedenceからDSCPへのマッピング(IP precedence値に基づくDSCPの設定)

IP precedence 0 = DSCP 0
IP precedence 1 = DSCP 8
IP precedence 2 = DSCP 16
IP precedence 3 = DSCP 24
IP precedence 4 = DSCP 32
IP precedence 5 = DSCP 40
IP precedence 6 = DSCP 48
IP precedence 7 = DSCP 56

DSCP/EXPマップ(DSCP値から設定されたEXP)

DSCP 0~7 = EXP 0
DSCP 8~15 = EXP 1
DSCP 16~23 = EXP 2
DSCP 24~31 = EXP 3
DSCP 32~39 = EXP 4
DSCP 40~47 = EXP 5
DSCP 48~55 = EXP 6
DSCP 56~63 = EXP 7

DSCPマップからマークダウンされたDSCP

マークダウンされたDSCP値は元のDSCP値と等しい(マークダウンなし)

EXP変換マップ

デフォルトでは変換マップなし

ポリサー

なし

ポリシー マップ

なし

NetFlowテーブルのMPLSフロー マスク

ラベル+EXP値

MPLSコアQoS

MPLSコアQoSでは4つの可能性があります。

スワッピング ― 着信EXPフィールドが送信EXPフィールドにコピーされます。

スワッピング+インポーズ ― 着信EXPフィールドはスワッピングされたEXPフィールドとインポーズされたEXPフィールドの両方にコピーされます。


) EXPフィールドのセット付きサービス ポリシーがある場合、そのEXPフィールドはインポーズされたラベルとスワッピングされたラベルに置かれます。


最上位ラベルのディスポジション ― エクスポーズされたEXPフィールドは保持されます。

ラベルだけのディスポジション ― エクスポーズされたIP
DSCPは保持されます。

MPLSからIPエッジのQoS

エクスポーズされたIP DSCPを保持します。


) PFC3BXLまたはPFC3BはQoSキューイングを実施しません。QoSキューイングはライン カード
(LAN、WAN、FlexWANモジュール)で実施されます。


MPLS QoSコマンド

Cisco 7600シリーズ ルータ上のPFC3BXLまたはPFC3BのMPLS QoSは次のMPLS QoSコマンドをサポートします。

match mpls experimental topmost

set mpls experimental imposition

police

mls qos map exp-dscp

mls qos map dscp-exp

mls qos map exp-mutation

mls qos exp-mutation

show mls qos mpls


) サポートされる非MPLS QoSコマンドについては、「PFC QoSの設定」を参照してください。


次のコマンドはサポートされません。

set qos-group <0-99>

set discard-class <0-63>?????


) Cisco 7600シリーズ ルータ固有のCisco IOS MPLS QoSコマンドの詳細については、
http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/software/122sx/cmdref/index.htm
Cisco 7600 Series Router Cisco IOS Command Reference』を参照してください。


PFC3BXLまたはPFC3BのMPLS QoSの設定

ここではCisco 7600シリーズ ルータ上でPFC3BXLまたはPFC3BのMPLS QoSを設定する手順を説明します。

「QoSのグローバルなイネーブル化」

「queueing-onlyモードのイネーブル化」

「MPLSパケットを分類するためのクラス マップの設定」

「ポリシー マップの設定」

「policeコマンドを使用したポリシー マップの設定」

「ポリシー マップの確認」

「PFC3BXLまたはPFC3B上の出力EXP変換の設定」

「EXP値マッピングの設定」

QoSのグローバルなイネーブル化

PFC3BXLまたはPFC3BでQoSを設定する前に、mls qosコマンドでQoS機能をグローバルにイネーブルにする必要があります。このコマンドはデフォルトのトラフィックのQoS条件をイネーブルにします。

mls qosコマンドがイネーブルになると、PFC3BXLまたはPFC3Bはプライオリティ値を各フレームに割り当てます。この値が内部DSCPです。内部DSCPは受信フレームの内容とQoS設定に基づいて割り当てられます。この値は出力フレームのCoSおよびToSフィールドにリライトされます。

QoSをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos

スイッチ上でQoSをイネーブルにします。QoSをグローバルにディセーブルにするには、no mls qosコマンドを使用します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos

設定を確認します。

次に、QoSをグローバルにイネーブルにする例を示します。

Router(config)# mls qos
Router(config)# end
Router#
 

次に、設定を確認する例を示します。

Router# show mls qos
QoS is enabled globally
Microflow policing is enabled globally
QoS ip packet dscp rewrite enabled globally
 
Qos trust state is DSCP on the following interfaces:
Gi4/1 Gi4/1.12
 
Qos trust state is IP Precedence on the following interfaces:
Gi4/2 Gi4/2.42
Vlan or Portchannel(Multi-Earl) policies supported: Yes
Egress policies supported: Yes
 
 
----- Module [5] -----
QoS global counters:
Total packets: 5957870
IP shortcut packets: 0
Packets dropped by policing: 0
IP packets with TOS changed by policing: 6
IP packets with COS changed by policing: 0
Non-IP packets with COS changed by policing: 3
MPLS packets with EXP changed by policing: 0
Router#
 

注意事項および制約事項

PFC3BXLまたはPFC3BでQoSがディセーブル(no mls qos)の場合、CoS値とToS値は次のようにEXP値内で着信フレームから送信フレームまで保持されます。

受信パケットがIPパケットである場合のIP-to-MPLSまたはEoMPLSインポジション

QoSがディセーブル(no mls qos)の場合、EXP値は受信IP ToSに基づきます。

QoSがキューイングのみの場合、EXP値は受信IP ToSに基づきます。

受信パケットが非IPパケットの場合のEoMPLSインポジション

QoSがディセーブルの場合、EXP値は入力CoSに基づきます。

QoSがキューイングのみの場合、EXP値は受信IP ToSに基づきます。

MPLS-to-MPLS動作

QoSがディセーブルのときにスワッピングする場合、EXP値は元のEXP値に基づきます(EXP変換がない場合)。

QoSがキューイングのみのときにスワッピングする場合、EXP値は元のEXP値に基づきます(EXP変換がない場合)。

QoSがディセーブルのときに追加ラベルをインポーズする場合、EXP値は元のEXP値に基づきます(EXP変換がない場合)。

QoSがキューイングのみのときに追加ラベルをインポーズする場合、EXP値は元のEXP値に基づきます(EXP変換がない場合)。

QoSがディセーブルのときに1つのラベルをポップする場合、EXP値は基礎となるEXP値に基づきます。

QoSがキューイングのみのときに1つのラベルをポップする場合、EXP値は基礎となるEXP値に基づきます。


) EXP値はMPLS-to-IPディスポジションとは関係がありません。



) no mls qos rewrite ip dscpコマンドは、MPLSとは非互換です。デフォルトのmls qos rewrite ip dscpコマンドは、PFC3BXLまたはPFC3Bがインポーズしたラベルで正しいEXP値を割り当てられるようイネーブルの状態にしておく必要があります。


queueing-onlyモードのイネーブル化

queueing-onlyモードをイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos queueing-only

queueing-onlyモードをイネーブルにします。

Router(config)# no mls qos queueing-only

PFC QoSをグローバルにディセーブルにします。


) queueing-onlyモードを個別にディセーブルすることはできません。


 

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos

設定を確認します。

queueing-onlyモードをイネーブルにする場合、スイッチは次の処理を行います。

マーキングおよびポリシングをグローバルにディセーブルにします。

すべてのポートがレイヤ2 CoSを信頼するように設定します。


) ルータシリーズ ルータでは、タグなし入力トラフィックと、trust CoSに設定できないポートを介して受信されるトラフィックにポートCoS値が適用されます。


次に、queueing-onlyモードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# mls qos queueing-only
Router(config)# end

Router#

制約事項および使用上の注意事項

PFC3BXLまたはPFC3BでQoSがディセーブル(no mls qos)の場合、EXP値は次のように決定されます。

受信パケットがIPパケットの場合のIP-to-MPLSまたはEoMPLSのインポジション

QoSがディセーブル(no mls qos)の場合、EXP値は受信IP ToSに基づきます。

QoSがキューイングのみ(mls qos queueing-only)の場合、EXP値は受信IP ToSに基づきます。

受信パケットが非IPパケットの場合のEoMPLSインポジション

QoSがディセーブルの場合、EXP値は入力CoSに基づきます。

QoSがキューイングのみの場合、EXP値は受信IP ToSに基づきます。

MPLS-to-MPLS動作

QoSがディセーブルの場合のスワッピングでは、EXP値は元のEXP値に基づきます(EXP変換がない場合)。

QoSがキューイングのみの場合のスワッピングでは、EXP値は元のEXP値に基づきます(EXP変換がない場合)。

QoSがディセーブルのときに追加ラベルをインポーズする場合、EXP値は元のEXP値に基づきます(EXP変換がない場合)。

QoSがキューイングのみのときに追加ラベルをインポーズする場合、EXP値は元のEXP値に基づきます(EXP変換がない場合)。

QoSがディセーブルのときに1つのラベルをポップする場合、EXP値は基礎となるEXP値に基づきます。

QoSがキューイングのみのときに1つのラベルをポップする場合、EXP値は基礎となるEXP値に基づきます。


) EXP値はMPLS-to-IPディスポジションとは関係がありません。


MPLSパケットを分類するためのクラス マップの設定

match mpls experimental topmostコマンドを使用して、パケットEXP値によるMPLSドメイン内のトラフィック クラスを定義することができます。これにより、policeコマンドを使用してインターフェイス ベースでEXPトラフィックをポリシングするためのサービス ポリシーを定義することができます。

クラス マップを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# class-map class-name

パケットがマッチングされるクラス マップを指定します。

ステップ 2

Router(config-cmap)# match mpls experimental topmost value

そのクラスにマッチングされるパケット特性を指定します。

ステップ 3

Router(config-cmap)# exit

クラス コンフィギュレーション モードを終了します。

次に、MPLS EXP値3を含むすべてのパケットがトラフィック クラスexp3によってマッチングされる例を示します。

Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# class-m exp3
Router(config-cmap)# match mpls exp ?
topmost Match MPLS experimental value on topmost label
 
Router(config-cmap)# match mpls experimental topmost 3
Router(config-cmap)# exit
 
Router(config)#
Router(config)# policy-map exp3
Router(config-pmap)# class exp3
Router(config-pmap-c)# police 1000000 8000000 c transmit exceed drop
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)#
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show class exp3
Class Map match-all exp3 (id 61)
Match mpls experimental topmost 3
Router#
Router# show policy-map exp3
Policy Map exp3
Class exp3
police cir 1000000 bc 8000000 be 8000000 conform-action transmit exceed-action drop
Router# show running-config interface f3/27
Building configuration...
 
Current configuration : 173 bytes
!
interface FastEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
end
 
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface f3/27
Router(config-if)# ser in exp3
Router(config-if)#
Router#
Enter configuration commands, one per line. End with CNTL/Z.
R7# show running-config interface f3/27
Building configuration...
 
Current configuration : 173 bytes
!
interface FastEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
service-policy input exp3
end
 
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show mls qos mpls
QoS Summary [MPLS]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In exp3 0 2 dscp 0 0 0
 
All 5 - Default 0 0* No 0 3466140423 0
Router#
Router# show policy-map interface f3/27
FastEthernet3/27
 
Service-policy input: exp3
 
class-map: exp3 (match-all)
Match: mpls experimental topmost 3
police :
1000000 bps 8000000 limit 8000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
 
Router#
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface f3/27
Router(config-if)# no ser in ip2tag
service-policy ip2tag is not attached to this interface
Router(config-if)# no ser in exp3
Router(config-if)# ser out ip2tag
Router(config-if)#
Router#sh mls
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Vl300 5 In x 44 1 No 0 0 0
Fa3/27 5 Out iptcp 24 2 -- 0 0 0
 
All 5 - Default 0 0* No 0 3466610741 0
 

制約事項および使用上の注意事項

MPLSパケットを分類するときには、次の制約事項および注意事項が適用されます。

match mpls experimentalコマンドは、パケットがクラス マップによって指定されるクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用すべきEXPフィールド値の名前を指定します。

match mpls experimentalコマンドを使用するには、まずclass-mapコマンドを入力して設定したい一致基準のクラスの名前を指定する必要があります。クラスを識別した後で、match mpls experimentalコマンドを使用してその一致基準を設定することができます。

クラス マップで複数のコマンドを指定する場合、最後に入力されたコマンドだけが適用されます。最後のコマンドは、それ以前に入力されたコマンドを無効にします。

ポリシー マップの設定

1つのインターフェイスに付加できるポリシー マップは、1つに限られます。ポリシー マップには、ポリシー マップ コマンドがそれぞれ異なる1つまたは複数のポリシー マップ クラスを含めることができます。

インターフェイスで受信するトラフィック タイプごとに、個別のポリシー マップ クラスをポリシー マップ内に設定します。各トラフィック タイプ用の全コマンドを、同一のポリシー マップ クラスに入れます。PFC3BXLまたはPFC3BのQoSは、一致したトラフィックに複数のポリシー マップ クラスからのコマンドを適用することはありません。

EXP値をすべてのインポーズされたラベルに設定するためのポリシー マップの設定

MPLS EXPフィールドの値をすべてのインポーズされたラベル エントリに設定するには、QoSポリシー マップ クラス コンフィギュレーション モードでset mpls experimental impositionコマンドを使用します。設定をディセーブルにするには、コマンドのno形式を入力します。


) set mpls experimental impositionコマンドは、set mpls experimentalコマンドと置き換わったものです。


 

コマンド
説明

ステップ 1

Router(config)# policy-map policy_name

ポリシー マップを作成します。

ステップ 2

Router(config-pmap)# class-map name [match-all | match-any]

QoSクラス マップ コンフィギュレーション モードにアクセスしてQoSクラス マップを設定します。

ステップ 3

Router(config-pmap-c)# set mpls experimental imposition {mpls-exp-value | from-field [table table-map-name]}

MPLS実験(EXP)フィールドの値をすべてのインポーズされたラベル エントリに設定します。

ステップ 4

Router(config-pmap-c)# exit

クラス コンフィギュレーション モードを終了します。

次に、MPLS EXP値3で定義されるDSCP値に従いMPLS EXPインポジション値を設定する例を示します。

Router#
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# access-l 101 p tcp any any
Router(config)# class-map iptcp
Router(config-cmap)# match acc 101
Router(config-cmap)# exit
Router(config)#
Router(config-cmap)# policy-map ip2tag
Router(config-pmap)# class iptcp
Router(config-pmap-c)# set mpls exp ?
imposition Set Experimental value at tag imposition

topmost EXP値を最上位ラベルに設定します。

Router(config-pmap-c)#set mpls exp imposition 3
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)#
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router#
Router# show pol ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3
Router# show class iptcp
Class Map match-all iptcp (id 62)
Match access-group101
 
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# int f3/27
Router(config-if)# ser in ip2tag
Router(config-if)#
Routers
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show pol ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3
Router# show class-map iptcp
Class Map match-all iptcp (id 62)
Match access-group 101
 
Router# show access-l 101
Extended IP access list 101
10 permit tcp any any
Router# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In iptcp 24 2 No 0 0 0
Vl300 5 In x 44 1 No 0 0 0
 
All 5 - Default 0 0* No 0 3466448105 0
Router#
Router# show policy-map interface f3/27
FastEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
set mpls experimental 3:
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
 
 

次に、設定を確認する例を示します。

Router# show policy map ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3
 

制約事項および使用上の注意事項

次の制約事項および注意事項は、すべてのインポーズされたラベル上でのEXP値の設定に適用されます。次の点に注意してください。

ラベル インポジション中にはset mpls experimental impositionコマンドを使用してください。このコマンドはMPLS EXPフィールドをすべてのインポーズされたラベル エントリに設定します。

set mpls experimental impositionコマンドは、入力インターフェイス(インポジション)上でのみサポートされます。

set mpls experimental impositionコマンドは、EXP値を直接マーキングしません。その代わり、このコマンドは内部DSCP-to-EXPグローバル マップを介してEXPにマッピングされる内部DSCPをマーキングします。

(元の受信IPヘッダに基づく)分類および(内部DSCPに行われる)マーキングではIP-to-IPトラフィックとIP-to-MPLSトラフィックが区別されないことに十分注意してください。IP ToSおよびEXPのマーキングに使用されるコマンドを使用した場合、内部DSCPのマーキングと同じ結果となります。

ラベル インポジション中に、プッシュされたラベル エントリ値をデフォルト値とは異なった値に設定するには、set mpls experimental impositionコマンドを使用します。

また任意でIP precedence、DSCPフィールド、またはQoS IP ACLとともに set mpls experimental imposition コマンドを利用して、すべてのインポーズされたラベル エントリにMPLS EXPフィールドの値を設定することができます。

ラベルをPFC3BXLまたはPFC3Bで受信IPトラフィックにインポーズする場合は、set mpls experimental impositionコマンドでEXPフィールドをマーキングすることができます。

このコマンドの詳細については、
http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/products_command_reference_chapter09186a008017cf44.html#wp1092877 の『Cisco IOS Switching Services Command Reference, Release 12.3』を参照してください。

policeコマンドを使用したポリシー マップの設定

ポリシングは特定のトラフィック クラスを特定のレートに速度制限する機能を提供するPFC3BXLまたはPFC3Bのハードウェアの機能です。PFC3BXLまたはPFC3Bはaggregateポリシングおよびmicroflowポリシングをサポートします。

aggregateポリシングは、送信元、宛先、プロトコル、送信元ポート、宛先ポートが異なっていても関係なくポートに着信するすべてのトラフィックを測定します。microflowポリシングは、フロー ベース(送信元、宛先、プロトコル、送信元ポート、宛先ポート ベース)でポートに着信するすべてのトラフィックを測定します。aggregateポリシングとmicroflowポリシングの詳細については、「ポリサー」を参照してください。

トラフィック ポリシングを設定するには、policeコマンドを使用します。このコマンドの詳細については、 http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/software/122sx/cmdref/p1.htm の『Cisco 7600 Series Router Cisco IOS Command Reference, Release 12.2 SX』を参照してください。

 

コマンド
説明

ステップ 1

Router(config)# policy-map policy_name

ポリシー マップを作成します。

ステップ 2

Router(config-pmap)# class-map name [match-all | match-any]

QoSクラス マップ コンフィギュレーション モードにアクセスしてQoSクラス マップを設定します。

ステップ 3

Router(config-pmap-c)# police {aggregate name}

クラスを共有aggregateポリサーに追加します。

ステップ 4

Router(config-pmap-c)# police bps burst-normal burst-max conform-action action exceed-action action violate-action action

per-class-per-interfaceポリサーを作成します。

ステップ 5

Router(config-pmap-c)# police flow {bits-per-second [normal-burst-bytes] | [conform-action action] [exceed-action action]

入力フロー ポリサーを作成します(出力ポリシーではサポートされません)。

ステップ 6

Router(config-pmap-c)# exit

クラス コンフィギュレーション モードを終了します。

次に、ポリサーでポリシー マップを作成する例を示します。

 
Router(config)# policy-map ip2tag
Router(config-pmap)# class iptcp
Router(config-pmap-c)# no set mpls exp topmost 3
Router(config-pmap-c)# police 1000000 1000000 c set-mpls-exp?
set-mpls-exp-imposition-transmit
 
Router(config-pmap-c)# police 1000000 1000000 c ?
drop drop packet
set-clp-transmit set atm clp and send it
set-dscp-transmit set dscp and send it
set-frde-transmit set FR DE and send it
set-mpls-exp-imposition-transmit set exp at tag imposition and send it
set-prec-transmit rewrite packet precedence and send it
set-qos-transmit set qos-group and send it
transmit transmit packet
 
Router(config-pmap-c)# police 1000000 1000000 c set-mpls-exp-imposit 3 e d
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# interface f3/27
Router(config-if)# ser in ip2tag
Router(config-if)#
 

次に、設定を確認する例を示します。

Router# sh p
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# shw pol ip2tag
Policy Map ip2tag
Class iptcp
police cir 1000000 bc 1000000 be 1000000 conform-action set-mpls-exp-imposition-transmit 3 exceed-action drop
Router# show run int f3/27
Building configuration...
 
Current configuration : 202 bytes
!
interface FastEthernet3/27
logging event link-status
service-policy input ip2tag
end
 
Router# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In iptcp 24 2 No 0 0 0
Vl300 5 In x 44 1 No 0 0 0
 
All 5 - Default 0 0* No 0 3468105262 0
Router# show policy interface f3/27
FastEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
police :
1000000 bps 1000000 limit 1000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: set-mpls-exp-imposition-transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
R7# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In iptcp 24 2 No 0 0 0
Vl300 5 In x 44 1 No 0 0 0
 
All 5 - Default 0 0* No 0 3468161522 0
 

制約事項および使用上の注意事項

policeコマンドを使用してポリシー マップを設定するときには、次の制約事項および注意事項が適用されます。

MPLSでは、exceed-action actionおよびviolate-action actionがIP使用と同様に動作します。パケットは廃棄される場合もあり、EXP値がマークダウンされる場合もあります。これらのアクションがIP-to-IPトラフィックに与える影響については、「ポリシー マップの設定」を参照してください。

MPLSでは、set-dscp transmit actionおよびset-prec-transmit actionがキューイングに影響を与えるCoSビットにマッピングされる内部DSCPを設定します。ただし、インポジションを除きEXP値の変更は行いません。

受信MPLSトラフィックのラベルをPFC3BXLまたはPFC3Bでスワッピングするときは、policeコマンドのpoliced-dscp-transmit exceedおよびviolateアクションで不適合なトラフィックをマークダウンすることができます。PFC3BXLまたはPFC3Bでは適合するトラフィックはマーキングされません。不適合なトラフィックをマークダウンする場合は、PFC3BXLまたはPFC3Bは送信最上位ラベルをマーキングします。PFC3BXLまたはPFC3Bはマーク ダウンをラベル スタックに伝播しません。

MPLSでは、フロー キーはラベルおよびEXP値に基づきます。フローマスク オプションはありません。それ以外では、フロー キー動作はIP-to-IPと同様です。「ポリシー マップの設定」を参照してください。

policeコマンドを使用すれば、ラベル インポジション中に、プッシュされたラベル エントリ値をデフォルト値とは異なった値に設定することができます。

PFC3BXLまたはPFC3Bでラベルを受信IPトラフィックにインポーズする場合は、conformアクションのset-mpls-exp-imposition-transmit値を使用してEXPフィールドにマーキングすることができます。

IP-to-MPLSインポジション中、IP ToSマーキングはサポートされません。ポリシーを設定してIP ToSをマーキングする場合は、PFC3BXLまたはPFC3BがEXP値をマーキングします。

ポリシー マップの確認

MPLS QoSクラスのインターフェイス サマリーまたは指定されたインターフェイス上のすべてのサービス ポリシーで設定されたすべてのクラスのコンフィギュレーションでポリシー マップを確認することができます。

インターフェイス サマリーの確認

ポリシー マップのMPLS QoSクラスのインターフェイス サマリーを表示するには、show mls qos mplsコマンドを使用します。

 

コマンド
説明

ステップ 1

Router(config-pmap-c)# end

ポリシー マップ クラス コンフィギュレーション モードを終了します。


) ポリシー マップにクラスを追加するには、追加のclassコマンドを入力します。


 

ステップ 2

Router# show mls qos mpls [{interface interface-number} | {module slot}

ポリシー マップのMPLS QoSクラスのインターフェイス サマリーを表示します。

次に、show mls qos mplsコマンドの例を示します。

Router# show mls qos mpls
QoS Summary [MPLS]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In exp3 0 2 dscp 0 0 0
 
All 5 - Default 0 0* No 0 3466140423 0
 

すべてのクラスのコンフィギュレーションの確認

指定されたインターフェイス上のすべてのサービス ポリシーに設定されたすべてのクラスのコンフィギュレーションを表示するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config-pmap-c)# end

ポリシー マップ クラス コンフィギュレーション モードを終了します。


) ポリシー マップにクラスを追加するには、追加のclassコマンドを入力します。


 

ステップ 2

Router# show policy interface interface-name

指定されたインターフェイス上のすべてのポリシー マップに設定されたすべてのクラスのコンフィギュレーションを表示します。

次に、インターフェイスf3/27のすべてのクラスのコンフィギュレーションの例を示します。

Router# show policy interface f3/27
FastEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
police :
1000000 bps 1000000 limit 1000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: set-mpls-exp-imposition-transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
 

PFC3BXLまたはPFC3B上の出力EXP変換の設定

ここでは、PFC3BXLまたはPFC3Bに出力EXP変換を設定する手順について説明します。

「名前付きEXP変換マップの設定」

「インターフェイスへの出力EXP変換マップの付加」

出力DSCP変換の詳細については、「PFC3による出力DSCPの変換」を参照してください。

名前付きEXP変換マップの設定

名前付きEXP変換マップを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos map exp-mutation name mutated_exp1 mutated_exp2 mutated_exp3 mutated_exp4 mutated_exp5 mutated_exp6 mutated_exp7 mutated_exp8

名前付きEXP変換マップを設定します。

Router(config)# no mls qos map exp-mutation name

デフォルトのマッピングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos maps

設定を確認します。

名前付きEXP変換マップを設定する際、次の点に注意してください。

変換されたEXP値にマッピングする最大8つのEXP値を入力することができます。

複数のコマンドを入力して、追加のEXP値を変換されたEXP値にマッピングできます。

変換されたEXP値ごとに個別のコマンドを入力できます。

内部EXP値が入力EXP値として書き込まれる前に内部EXP値を変換するため、15個の入力EXP変換マップを設定できます。入力EXP変換マップを、PFC QoSがサポートする任意のインターフェイスに付加できます。

PFC QoSは、内部DSCP値から出力EXP値を導出します。入力EXP変換を設定する場合、PFC QoSは変換されたEXP値から入力EXP値を導出しません。

インターフェイスへの出力EXP変換マップの付加

出力EXP変換マップをインターフェイスに付加するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface {{ vlan vlan_ID } | { type 1 slot/port [. subinterface ]} | { port-channel number [. subinterface ]}}

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# mls qos exp-mutation exp-mutation-table-name

出力EXP変換マップをインターフェイスに付加します。

Router(config-if)# no mls qos exp-mutation

インターフェイスから出力DSCP変換マップを削除します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show running-config interface {{ vlan vlan_ID } | { type slot/port } | { port-channel number }}

設定を確認します。

1.type = ethernetfastethernetgigabitethernet、またはtengigabitethernet

次に、mutemap2という名前の出力EXP変換マップを付加する例を示します。

Router(config)# interface fastethernet 3/26
Router(config-if)# mls qos exp-mutation mutemap2
Router(config-if)# end
 

EXP値マッピングの設定

ここでは、EXP値を他の値にマッピングする手順について説明します。

「入力EXPのDSCPマップへの定義」

「出力DSCP to EXPマップの定義」


) これらのマップのDSCPは、内部DSCP値のことであり、パケットDSCPのことではありません。


入力EXPのDSCPマップへの定義

入力EXP-to-DSCPマップを定義するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos map exp-dscp values8

受信したEXP値から内部DSCP値へのマッピングを設定します。EXP値に対応する8つのDSCP値を入力する必要があります。有効値は0~63です。

Router(config)# no mls qos map exp-dscp

デフォルトのマッピングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos maps

設定を確認します。

次に、入力EXP-to-DSCPマップを設定する例を示します。

Router(config)# mls qos map exp-dscp 43 43 43 43 43 43 43 43
Router(config)#
 

次に、設定を確認する例を示します。

Router(config)# show mls qos map exp-dscp
Exp-dscp map:
exp: 0 1 2 3 4 5 6 7
------------------------------------
dscp: 43 43 43 43 43 43 43 43

出力DSCP to EXPマップの定義

出力DSCP-to-EXPマップを定義するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos map dscp-exp dscp-values to exp-values8

最終DSCP分類を最終EXP値に設定します。1つのEXP値には一回に最大8つのDSCP値を入力することができます。有効値は0~7です。

Router(config)# no mls qos map dscp-exp

デフォルトのマッピングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos maps

設定を確認します。

次に、信頼されたインターフェイスの出力DSCP-to-EXPマップを設定する例を示します。

Router(config)# mls qos map dscp-exp 20 25 to 3
Router(config)#

MPLS DiffServトンネリング モード

トンネリングは、QoSにネットワークの1つのエッジから、そのネットワークの別のエッジまでをトランスペアレントにする機能を提供します。トンネルは、ラベル インポジションのある場所から開始します。トンネルは、ラベル ディスポジションのある場所、すなわちラベルがスタックから除去された場所で終了します。そしてパケットは下部に異なったPer-Hop Behavior(PHB)レイヤを持つMPLSパケットとして、またはIP PHBレイヤ付きIPパケットとして送信されます。

PFC3BXLまたはPFC3Bでは、ネットワーク経由でパケットを転送する方法が2つあります。

ショート パイプ モード ― ショート パイプ モードでは、出力PFルータは中間プロバイダー(P)ルータによって使用されるマーキングの代わりに元のパケット マーキングを使用します。EXPマーキングはパケットToSバイトには伝播しません。

モードの説明については、「ショート パイプ モード」を参照してください。

コンフィギュレーションについては、「ショート パイプ モードの設定」を参照してください。

ユニフォーム モード ― ユニフォーム モードでは、IPパケットのマーキングはサービス プロバイダーのQoSマーキングをコアに反映するよう操作することができます。このモードでは、CEおよびコア ルータを含むネットワーク全体で矛盾のないQoS分類およびマーキングが提供されます。EXPマーキングは基礎となるToSバイトへ伝播されます。

説明については、「ユニフォーム モード」を参照してください。

設定手順については、「ユニフォーム モードの設定」を参照してください。

どちらのトンネリング モードもラベルがパケットに付与されたりパケットから削除されたりするエッジおよび最後から2番めのLSRの動作に影響を与えます。これらのモードは、中間ルータのラベルのスワッピングには影響を与えません。サービス プロバイダーは、カスタマーごとに異なったタイプのトンネリング モードを選択することができます。

詳細については、
http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080110bd5.html を参照してください。

ショート パイプ モード

ショート パイプはカスタマーおよびサービス プロバイダーが異なったDiffServドメインにある場合に使用されます。このモードを利用することにより、サービス プロバイダーはカスタマーの
DiffServ情報を保持しながら自分自身のDiffServポリシーを実施することができるため、サービス プロバイダー ネットワークを通してDiffServのトランスペアレンシが提供されます。

コアで実施されるQoSポリシーはパケットToSバイトには伝播しません。MPLS EXP値に基づく分類は、カスタマー側に向かう出力PEインターフェイスで終了します。カスタマー側に向かう出力PEインターフェイスは、元のIPパケット ヘッダに基づいており、MPLSヘッダに基づいてはいません。


) (カスタマーのPHBマーキングに基づいており、プロバイダーのPHBマーキングには基づいていない)出力IPポリシーが存在する場合は自動的にショート パイプ モードとなります。


図 31-2 VPNでのショート パイプ モード動作

 

ショート パイプ モードは次のように機能します。

1. CE1はIPパケットをIP DSCP値1でPE1に送信します。

2. PE1はインポーズされたラベル エントリでMPLS EXPフィールドを5に設定します。

3. PE1はパケットをP1に送信します。

4. P1はスワッピングされたラベル エントリでMPLS EXPフィールド値を5に設定します。

5. P1はパケットをP2に送信します。

6. P2はIGPラベル エントリをポップします。

7. P2はパケットをPE2に送信します。

8. PE2はBGPラベルをポップします。

9. PE2はパケットをCE2に送信しますが、QoSはIP DSCP値に基づきます。

詳細については、
http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080110bd5.html の「 MPLS DiffServ Tunneling Modes」を参照してください。

ショート パイプの制約事項および注意事項

ショート パイプ モードでは次の制約事項が適用されます。

MPLS-to-IP出力インターフェイスがEoMPLS(隣接にはEoMビット セットがある)である場合、ショート パイプ モードはサポートされません。

ユニフォーム モード

ユニフォーム モードでは、パケットはIPおよびMPLSネットワークで一律に扱われます。すなわちIP Precedence値およびMPLS EXPビットは常に同じPHBに対応しています。ルータがパケットのPHBの変更またはカラー変更をする場合はいつでも、その変更はすべてのカプセル化マーキングに伝播されなくてはなりません。パケット パス上のルータでのラベル インポジションまたはディスポジションによりPHBが追加またはエクスポーズされる場合、伝播はルータのみによって実行されます。カラーはすべてのレベルのすべての場所で反映される必要があります。たとえば、パケットのQoSマーキングがMPLSネットワークで変更された場合、IP QoSマーキングはその変更を反映します。

図 31-3 ユニフォーム モード動作

 

この手順は、IP Precedenceビット マーキングまたはDSCPマーキングが存在するかどうかによって異なります。

IP Precedenceビット マーキングが存在する場合は次のアクションが発生します。

1. IPパケットがサービス プロバイダー エッジ ルータであるPE1でMPLSネットワークに着信します。

2. ラベルはパケットにコピーされます。

3. MPLS EXPフィールド値のカラー変更が行われた場合(たとえば、あまりに多くのパケットが送信中であるためパケットがレート外となった場合)、この値はIGPラベルにコピーされます。BGPラベルの値は変更されません。

4. 最後から2番めのホップでは、IGPは削除されます。この値は次の低レベルのラベルにコピーされます。

5. すべてのMPLSラベルがIPパケットとして送出されたパケットから削除されたとき、IP
PrecedenceまたはDSCP値はコアで最後に変更されたEXP値として設定されます。

次に、IP Precedenceビット マーキングが存在する例を示します。

1. CE1(カスタマー装置1)で、IPパケットはIP Precedence値3を持っています。

2. パケットがPE1(サービス プロバイダーのエッジ ルータ)でMPLSネットワークに着信すると、IP Precedence値3はパケットのインポーズされたラベル エントリにコピーされます。

3. IGPラベル ヘッダのMPLS EXPフィールドはマークダウンによりMPLSコア(たとえばP1)内で変更されるかもしれません。


) IP Precedenceビットは3であるため、BGPラベルおよびIGPラベルも3を含みます。ユニフォーム モードではラベルは常に同一であるためです。パケットはIPネットワークとMPLSネットワークで一律に扱われます。


ユニフォーム モードの制約事項および注意事項

ユニフォーム モードでは次の制約事項が適用されます。

出力IP ACLまたはサービス ポリシーがMPLS-to-IP出口ポイントで設定された場合には、再循環のためユニフォーム モードが常に実施されます。

MPLS DiffServトンネリングの制約事項および使用上の注意事項

ここでは、MPLS DiffServトンネリングの制約事項および使用上の注意事項について説明します。

MPLS EXPフィールドは3ビット フィールドであるため1つのLSPは最大8クラスのトラフィック(すなわち8つのPHB)をサポートすることができます。

MPLS DiffServトンネリング モードはE-LSPをサポートします。E-LSPはLSPの1つであり、ノードはここでMPLSヘッダのEXPビットから排他的にMPLSパケットのQoS処理を判別します。

次の機能は、MPLS DiffServトンネリング モードでサポートされます。

MPLS PHBレイヤ管理(レイヤ管理は、PHBマーキングの追加レイヤをパケットに提供する機能です。)

管理されたCEルータでの制御によるMPLSレイヤ管理のスケーラビリティ向上

MPLSはパケットのQoSをトンネリングすることができます(すなわち、QoSはエッジ間でトランスペアレント)。QoSトランスペアレンシにより、IPパケットのIPマーキングはMPLSネットワーク全体で保持されます。

MPLS EXPフィールドには、IP PrecedenceまたはDSCPフィールドでマーキングされたPHBとは異なった値を別途マーキングすることができます。

ショート パイプ モードの設定

ここでは、次の設定を行う手順について説明します。

「入力PEルータ ― カスタマー側に向かうインターフェイス」

「入力PEルータの設定 ― P側に向かうインターフェイス」

「Pルータの設定 ― 出力インターフェイス」

「出力PEルータの設定 ― カスタマー側に向かうインターフェイス」


) このステップは1つの方法を示すものですが、ショート パイプ モードを設定する唯一の方法というわけではありません。



) IPクラスを含む出力サービス ポリシーをインターフェイスに付加した場合、出力PE(またはPHP)でのショート パイプ モードは自動的に設定されます。


入力PEルータ ― カスタマー側に向かうインターフェイス

この手順は、ポリシー マップを設定して、インポーズされたラベル エントリにMPLS EXPフィールドを設定するものです。

EXP値を設定するには、入力LANまたはOSMポートはuntrustedである必要があります。FlexWANポートにはtrustの概念がありませんが、従来のCisco IOSルータ同様入力ToSは変更されません(マーキング ポリシーが設定されていない場合)。

MPLSとVPNについては、入力PEはすべての入力PFC3BXLまたはPFC3B IPポリシーをサポートします。IP ACL/DSCP/precedenceに基づくPFC IPポリシーの分類については、
http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/software/122sx/swcg/qos.htm を参照してください。

インポーズされたラベル エントリでMPLS EXPフィールドを設定するポリシー マップを設定するには次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos

QoS機能をイネーブルにします。

ステップ 2

Router(config)# access-list acl_index permit any

アクセス リスト機構を設定します。

ステップ 3

Router(config)# class-map class-name

 

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 4

Router(config-cmap)# match access-group acl_index

 

内容が一致基準として使用される番号付きまたは名前付きACLを指定します。

ステップ 5

Router(config)# policy-map name

 

1つまたは複数のクラスに一致するパケットのQoSポリシーを設定します。

ステップ 6

Router(config-pmap)# class class-name

 

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 7

Router(config-pmap-c)# police bits_per_second [normal_burst_bytes] conform-action set-mpls-exp-transmit exp_value exceed-action drop

 

次のアクションを含むトラフィック ポリシング機能を設定します。

SLA(サービスレベル アグリーメント)で指定されたレート リミットに一致するパケットをとるアクション

SLAで指定されたレート リミットを超えるパケットをとるアクション

action フィールドには、 MPLS EXPフィールドが設定される exp-valueを入力します。

ステップ 8

Router(config)# interface type slot/port

 

Cisco 7600シリーズ ルータのインターフェイス タイプを設定します。設定するインターフェイスのタイプ、ポート、コネクタ、またはインターフェイス カードの番号およびバックプレーン スロット番号を指定します。

ステップ 9

Router(config-if)# no mls qos trust

ポートをuntrusted状態に戻します。

ステップ 10

Router(config-if)# service-policy input policy_map_name

 

指定されたポリシー マップを入力インターフェイスに付加し、サービス ポリシー マップのの名前を指定します。

設定例

次に、インポーズされたラベル エントリでMPLS EXPフィールドを設定するポリシー マップを設定する例を示します。

 
Router(config)# mls qos
Router(config)# access-list 1 permit any
Router(config)# class-map CUSTOMER-A
Router(config-cmap)# match access-group 1
Router(config)# policy-map set-MPLS-PHB
Router(config-pmap)# class CUSTOMER-A
Router(config-pmap-c)# police 50000000 conform-action set-mpls-exp-transmit 4 exceed-action drop
Router(config)# interface GE-WAN 3/1
Router(config-if)# no mls qos trust
Router(config)# interface GE-WAN 3/1.31
Router(config-if)# service-policy input set-MPLS-PHB
 

入力PEルータの設定 ― P側に向かうインターフェイス

この手順はMPLS EXPフィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するものです。


) ここで示すQoS機能は、OSMおよびFlexWANおよびEnhanced FlexWANモジュールに限り使用可能です。


MPLS EXPフィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos

QoS機能をイネーブルにします。

ステップ 2

Router(config)# class-map class-name

 

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match mpls experimental exp-list

 

パケットがそのクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用するMPLS EXPフィールド値を指定します。

ステップ 4

Router(config)# policy-map name

 

1つまたは複数のクラスに一致するパケットのQoSポリシーを設定します。

ステップ 5

Router(config-p-map)# class class-name

 

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth-kbps | percent percent }

 

トラフィック クラスに最小帯域幅保証を指定します。1秒あたりキロバイトまたは全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

 

帯域幅保証を持つトラフィック クラスのWREDドロップ ポリシーをイネーブルにします。

ステップ 9

Router(config)# interface type slot/port

 

Cisco 7600シリーズ ルータのインターフェイス タイプを設定します。設定するインターフェイス タイプ、ポート、コネクタ、またはインターフェイス カードの番号およびバックプレーン スロット番号を指定します。

ステップ 10

Router(config-if)# service-policy output name

 

QoSポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


) bandwidthコマンドおよびrandom-detectコマンドはLANカードでは利用できません。


設定例

次に、MPLS EXPフィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# mls qos
Router(config)# class-map MPLS-EXP-4
Router(config-c-map)# match mpls experimental 4
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 4/1
Router(config-if)# service-policy output output-qos
 

Pルータの設定 ― 出力インターフェイス


) ここで示すQoS機能は、OSMおよびFlexWANおよびEnhanced FlexWANモジュールに限り使用可能です。


MPLS EXPフィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos

QoS機能をイネーブルにします。

ステップ 2

Router(config)# class-map class-name

 

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match mpls experimental exp-list

パケットがそのクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用するMPLS EXPフィールド値を指定します。

ステップ 4

Router(config)# policy-map name

1つまたは複数のクラスに一致するパケットのQoSポリシーを設定します。

ステップ 5

Router(config-p-map)# class class-name

 

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth-kbps | percent percent }

 

トラフィック クラスに最小帯域幅保証を指定します。1秒あたりキロバイトまたは全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

 

WREDをIP PrecedenceまたはMPLS EXPフィールド値に基づくポリシーに適用します。

ステップ 9

Router(config)# interface type slot/port

Cisco 7600シリーズ ルータのインターフェイス タイプを設定します。設定するインターフェイス タイプ、ポート、コネクタ、またはインターフェイス カードの番号およびバックプレーン スロット番号を指定します。

ステップ 10

Router(config-if)# service-policy output name

 

QoSポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


) bandwidthコマンドおよびrandom-detectコマンドはLANカードでは利用できません。


設定例

次に、MPLS EXPフィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# mls qos
Router(config)# class-map MPLS-EXP-4
Router(config-c-map)# match mpls experimental 4
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 2/1
Router(config-if)# service-policy output output-qos

出力PEルータの設定 ― カスタマー側に向かうインターフェイス


) ここで示すQoS機能は、OSMおよびFlexWANおよびEnhanced FlexWANモジュールに限り使用可能です。


IP DSCP値に基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# cmls qos

QoS機能をイネーブルにします。

ステップ 2

Router(config)# c class-map class-name

 

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match ip dscp dscp-values

 

DSCP値を一致基準として使用します。

ステップ 4

Router(config)# policy-map name

 

1つまたは複数のクラスに一致するパケットのQoSポリシーを設定します。

ステップ 5

Router(config-p-map)# class class-name

 

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth-kbps | percent percent }

 

トラフィック クラスに最小帯域幅保証を指定します。1秒あたりキロバイトまたは全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect dscp-based

 

帯域幅保証を持つトラフィック クラスのWREDドロップ ポリシーをイネーブルにします。

ステップ 9

Router(config)# interface type slot/port

 

Cisco 7600シリーズ ルータのインターフェイス タイプを設定します。設定するインターフェイス タイプ、ポート、コネクタ、またはインターフェイス カードの番号およびバックプレーン スロット番号を指定します。

ステップ 10

Router(config-if)# service-policy output name

 

QoSポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


) bandwidthコマンドおよびrandom-detectコマンドはLANカードでは利用できません。


設定例

次に、IP DSCP値に基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# mls qos
Router(config)# class-map IP-PREC-4
Router(config-c-map)# match ip precedence 4
Router(config)# policy-map output-qos
Router(config-p-map)# class IP-PREC-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface GE-WAN 3/2.32
Router(config-if)# service-policy output output-qos
 

ユニフォーム モードの設定

ここでは、次の設定を行う手順について説明します。

「ユニフォーム モードの制約事項および注意事項」

「入力PEルータの設定 ― カスタマー側に向かうインターフェイス」

「入力PEルータの設定 ― P側に向かうインターフェイス」

「出力PEルータの設定 ― カスタマー側に向かうインターフェイス」


) このステップは1つの方法を示すものですが、ユニフォーム モードを設定する唯一の方法というわけではありません。


入力PEルータの設定 ― カスタマー側に向かうインターフェイス

ユニフォーム モードでは、信頼状態をIP PrecedenceまたはIP DSCPに設定するとPFC3BXLまたはPFC3BはIP PHBをMPLS PHBにコピーすることができます。


) この説明は、LANまたはOSMポートのPFC3BXLまたはPFC3B QoSに適用されます。FlexWANおよびEnhanced FlexWAN QoSの詳細については、
http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/flexport/4885_01.htmの『Enhanced FlexWAN Module, Fabric Enabled Installation and Configuration Note』を参照してください。


インポーズされたラベル エントリでMPLS EXPフィールドを設定するポリシー マップを設定するには次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos

QoS機能をイネーブルにします。

ステップ 2

Router(config)# access-list acl_index permit any

アクセス リスト機構を設定します。

ステップ 3

Router(config)# class-map class-name

 

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 4

Router(config-cmap)# match access-group acl_index

 

内容が一致基準として使用される番号付きまたは名前付きACLを指定します。

ステップ 5

Router(config)# policy-map name

 

1つまたは複数のクラスに一致するパケットのQoSポリシーを設定します。

ステップ 6

Router(config-pmap)# class class-name

 

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 7

Router(config-pmap-c)# police bits_per_second [normal_burst_bytes] conform-action transmit exceed-action drop

 

次のアクションを含むトラフィック ポリシング機能を設定します。

SLAで指定されたレート リミットに適合するパケットをとるアクション

SLAで指定されたレート リミットを超えるパケットをとるアクション

ステップ 8

Router(config)# interface type slot/port

 

Cisco 7600シリーズ ルータのインターフェイス タイプを設定します。設定するインターフェイス タイプ、ポート、コネクタ、またはインターフェイス カードの番号およびバックプレーン スロット番号を指定します。

ステップ 9

Router(config-if)# mls qos trust dscp

DSCP値の検査によりトラフィックを分類します。

ステップ 10

Router(config-if)# service-policy input name

 

QoSポリシーをインターフェイスに付加し、そのインターフェイスに着信するパケット上で適用すべきポリシーを指定します。

設定例

次に、インポーズされたラベル エントリでMPLS EXPフィールドを設定するポリシー マップを設定する例を示します。

Router(config)# mls qos
Router(config)# access-list 1 permit any
Router(config)# class-map CUSTOMER-A
Router(config-cmap)# match access-group 1
Router(config)# policy-map SLA-A
Router(config-pmap)# class CUSTOMER-A
Router(config-pmap-c)# police 50000000 conform-action transmit exceed-action drop
Router(config)# interface GE-WAN 3/1
Router(config-if)# mls qos trust dscp
Router(config)# interface GE-WAN 3/1.31
Router(config-if)# service-policy input SLA-A
 

入力PEルータの設定 ― P側に向かうインターフェイス

MPLS EXPフィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# mls qos

QoS機能をイネーブルにします。

ステップ 2

Router(config)# class-map class-name

 

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match mpls experimental exp-list

 

パケットがそのクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用するMPLS EXPフィールド値を指定します。

ステップ 4

Router(config)# policy-map name

 

1つまたは複数のクラスに一致するパケットのQoSポリシーを設定します。

ステップ 5

Router(config-p-map)# class class-name

 

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth-kbps | percent percent }

 

トラフィック クラスに最小帯域幅保証を指定します。1秒あたりキロバイトまたは全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

 

帯域幅保証を持つトラフィック クラスのWREDドロップ ポリシーをイネーブルにします。

ステップ 9

Router(config)# interface type slot/port

 

Cisco 7600シリーズ ルータのインターフェイス タイプを設定します。設定するインターフェイス タイプ、ポート、コネクタ、またはインターフェイス カードの番号およびバックプレーン スロット番号を指定します。

ステップ 10

Router(config-if)# service-policy output name

 

QoSポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


) bandwidthコマンドおよびrandom-detectコマンドはLANカードでは利用できません。


設定例

次に、MPLS EXPフィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# mls qos
Router(config)# class-map MPLS-EXP-3
Router(config-c-map)# match mpls experimental 3
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-3
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 4/1
Router(config-if)# service-policy output output-qos
 

出力PEルータの設定 ― カスタマー側に向かうインターフェイス

カスタマー側に向かうインターフェイスで出力PEルータを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# pmls qos

QoS機能をイネーブルにします。

ステップ 2

Router(config)# p class-map class-name

 

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match ip precedence precedence-value

 

IP precedence値を一致基準として識別します。

ステップ 4

Router(config)# p policy-map name

 

1つまたは複数のクラスに一致するパケットのQoSポリシーを設定します。

ステップ 5

Router(config-p-map)# class class-name

 

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth-kbps | percent percent }

 

トラフィック クラスに最小帯域幅保証を指定します。1秒あたりキロバイトまたは全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

 

WREDをIP PrecedenceまたはMPLS EXPフィールド値に基づくポリシーに適用します。

ステップ 9

Router(config)# interface type slot / port

 

Cisco 7600シリーズ ルータのインターフェイス タイプを設定します。設定するインターフェイス タイプ、ポート、コネクタ、またはインターフェイス カードの番号およびバックプレーン スロット番号を指定します。

ステップ 10

Router(config-if)mpls propagate-cos

EXP値がMPLSドメイン出口LER出力ポートで基礎となるIP DSCPへ伝播するのをイネーブルにします。

ステップ 11

Router(config-if)# service-policy output name

 

QoSポリシーをインターフェイスに付加し、そのインターフェイスに着信するパケット上で適用すべきポリシーを指定します。


) bandwidthコマンドおよびrandom-detectコマンドはLANカードでは利用できません。


設定例

次に、カスタマー側に向かうインターフェイスで出力PRルータを設定する例を示します。

Router(config)# mls qos
Router(config)# class-map IP-PREC-4
Router(config-c-map)# match ip precedence 4
Router(config)# policy-map output-qos
Router(config-p-map)# class IP-PREC-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface GE-WAN 3/2.32
Router(config-if)mpls propagate-cos
Router(config-if)# service-policy output output-qos