Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2SX
レイヤ3インターフェイスの設定
レイヤ3インターフェイスの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

レイヤ3インターフェイスの設定

レイヤ3インターフェイスのサブインターフェイスの設定

IPルーティングおよびアドレスの設定

IPXルーティングおよびネットワーク番号の設定

AppleTalkルーティング、ケーブルの範囲、およびゾーンの設定

レイヤ3インターフェイス上でのその他のプロトコルの設定

レイヤ3インターフェイスの設定

この章では、Cisco 7600シリーズ ルータ上でレイヤ3インターフェイスを設定する方法について説明します。ここでの説明は、次のURLから利用できるRelease 12.2のマニュアルに記載されている情報および手順を補足するものです。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/index.htm

この章の構成は次のとおりです。

「レイヤ3インターフェイスのサブインターフェイスの設定」

「IPルーティングおよびアドレスの設定」

「IPXルーティングおよびネットワーク番号の設定」

「AppleTalkルーティング、ケーブルの範囲、およびゾーンの設定」

「レイヤ3インターフェイス上でのその他のプロトコルの設定」


) • この章で使用しているコマンドの構文および使用方法の詳細については、『Cisco 7600 Series Router Cisco IOS Command Reference』および次のURLにあるRelease 12.2のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/index.htm

設定するレイヤ3 VLANインターフェイスは2000個までにすることを推奨します。

Release 12.2(18)SXD以降のリリースでは、VLANデータベースで定義されていないレイヤ2 VLAN用にVLANインターフェイスを作成すると、VLANデータベース内のレイヤ2 VLANを自動的に定義します(CSCed89216)。

VLAN(仮想LAN)インターフェイスをサポートするには、VLANを作成および設定し、レイヤ2 LANポートにVLANメンバーシップを割り当てます。詳細については、「VLANの設定」および「VTPの設定」を参照してください。

Catalyst 6500シリーズ スイッチおよびCisco 7600シリーズ ルータは次の機能をサポートしません。

Integrated routing and bridging(IRB)

Concurrent routing and bridging(CRB)

Remote source-route bridging(RSRB)

ルーテッドされないプロトコルのブリッジングを行うには、VLANインターフェイス上でブリッジ グループを使用します。これはフォールバック ブリッジングと呼ばれることもあります。VLANインターフェイス上のブリッジ グループはMSFCのソフトウェアでサポートされます。

Catalyst 6500シリーズ スイッチおよびCisco 7600シリーズ ルータはブリッジ グループ用IEEEブリッジング プロトコルをサポートしません。ブリッジ グループを設定してVLANブリッジまたはDEC Spanning-Tree Protocol(STP;スパニングツリー プロトコル)を使用してください。


 

レイヤ3インターフェイスのサブインターフェイスの設定

MPLSをサポートするように、レイヤ3インターフェイスのサブインターフェイスを設定することができます。サブインターフェイスを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router> enable

イネーブルEXECモードを開始します。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface {{ type 1 slot / port . subinterface } | { port-channel port_channel_number . subinterface }}

インターフェイスを選択して、サブインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

Router(config-subif)# encapsulation dot1q vlan_ID [ native ]

サブインターフェイスの802.1Qカプセル化を設定します。

ステップ 5

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

1.type = ethernetfastethernetgigabitethernettengigabitethernet、またはge-wan

サブインターフェイスを設定するとき、次の点に注意してください。

サブインターフェイスは、MPLSをサポートするためだけに設定してください。

ISL(スイッチ間リンク)カプセル化を設定しないでください。

VLAN IDがIEEE 802.1QネイティブVLANのIDの場合、 native キーワードを必ず使用してください。 native キーワードを使用せずに、IEEE 802.1QトランクのネイティブVLANでカプセル化を設定しないでください。

VLAN IDはルータに対してグローバルであるため、サブインターフェイス上、またはレイヤ3 VLANインターフェイスに関してVLANを内部的に使用することができます。

サブインターフェイスまたはレイヤ3 VLANインターフェイスで、内部VLANを設定することはできません。

レイヤ3 VLANインターフェイスで、サブインターフェイスVLANを設定することはできません。

サブインターフェイス上では、レイヤ3 VLANインターフェイスとともに使用されるVLANを設定することはできません。


) 1つのVLAN、別のVLAN上のサブインターフェイス、またはサブインターフェイスに、使用するVLANを設定することはできません。


VLAN Trunking Protocol(VTP;VLANトランキング プロトコル)トランスペアレント モードでは、任意の標準範囲または拡張範囲のVLAN IDを使用して、サブインターフェイスを設定することができます。VLAN ID 1~1005は、VTPドメインでグローバルであり、VTPドメイン内の他のネットワーク装置上で定義することができるため、VTPクライアント/サーバ モードでは、拡張範囲VLANのみをサブインターフェイスとともに使用することができます。VTPクライアント/サーバ モードでは、標準範囲VLANがサブインターフェイスから除外されます。


) サブインターフェイス上で標準範囲VLANを設定する場合、VTPモードをトランスペアレントから変更できません。


IPルーティングおよびアドレスの設定

詳しい説明および設定手順については、次のマニュアルを参照してください。

次のURLの『 Cisco IOS IP and IP Routing Configuration Guide 』Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/index.htm

次のURLの『 Cisco IOS IP and IP Routing Command Reference 』Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipras_r/index.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fiprrp_r/index.htm


) • maximum pathsコマンドの詳細については、『Cisco 7600 Series Router Cisco IOS Command Reference』を参照してください。

Policy Feature Card(PFC;ポリシー フィーチャ カード)およびDistributed Feature Card(DFC)は、 match ip address set ip next-hop ip default next-hop Policy-Based Routing(PBR;ポリシーベース ルーティング)キーワードを使用するルート マップ シーケンス用のPBRをハードウェアでサポートします。

PBRの設定については、次のURLにある『 Cisco IOS Quality of Service Solutions Configuration Guide 』Release 12.2の「Classification」および「Configuring Policy-Based Routing」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt1/qcfpbr.htm

Multilayer Switch Feature Card 3(MSFC3;マルチレイヤ スイッチ フィーチャ カード3)アドレスがPBR ACLの範囲内にある場合、MSFC3にアドレス指定されたトラフィックはMSFC3に転送されないで、ハードウェアでポリシー ルーティングされます。MSFC3にアドレス指定されたトラフィックのポリシー ルーティングを禁止するには、MSFC3にアドレス指定されたトラフィックを拒否するようにPBR ACLを設定します。

フローをソフトウェアでスイッチングするMSFC3に送信するPBRルートマップに、フィルタリングを実行するCisco IOS ACLのオプションはいずれも拒否されます。たとえば、ロギングは、PBRルートマップに、フィルタリングを実行するCisco IOS ACLのAccess Control Entry(ACE;アクセス制御エントリ)ではサポートされません。

PBRが設定されているスイッチング モジュール ポートを介したPBRトラフィックは、スイッチング モジュールがリセットした場合にソフトウェアでルーティングされます(CSCee92191)。


 

レイヤ3インターフェイスにIPルーティングおよびIPアドレスを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# ip routing

IPルーティングをイネーブルにします(IPルーティングがディセーブルになっている場合のみ必須)。

ステップ 2

Router(config)# router ip_routing_protocol

IPルーティング プロトコルを指定します。

ステップ 3

Router(config-router)# ip_routing_protocol_commands

IPルーティング プロトコルを設定します。

ステップ 4

Router(config-router)# exit

IPルーティング プロトコルのコンフィギュレーション モードを終了します。

ステップ 5

Router(config)# interface { vlan vlan_ID } | { type 2 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 6

Router(config-if)# ip address ip_address subnet_mask

IPアドレスおよびIPサブネットを設定します。

ステップ 7

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 8

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 9

Router# show interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show ip interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show running-config interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

設定を確認します。

2.type = ethernetfastethernetgigabitethernettengigabitethernet、またはge-wan

次に、IP Routing Information Protocol(RIP)ルーティングをイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ip routing
Router(config)# router rip
Router(config-router)# network 10.0.0.0
Router(config-router)# end
Router#
 

次に、ポートFastEthernet 5/4にIPアドレスを設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 5/4
Router(config-if)# ip address 172.20.52.106 255.255.255.248
Router(config-if)# no shutdown
Router(config-if)# end
Router#
 

次に、show interfacesコマンドを使用して、ポートFastEthernet 5/4のインターフェイスIPアドレスの設定およびステータスを表示する例を示します。

Router# show interfaces fastethernet 5/4
FastEthernet5/4 is up, line protocol is up
Hardware is Cat6K 100Mb Ethernet, address is 0050.f0ac.3058 (bia 0050.f0ac.3058)
Internet address is 172.20.52.106/29
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
7 packets input, 871 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
8 packets output, 1658 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Router#
 

次に、show ip interfaceコマンドを使用して、ポートFastEthernet 5/4の詳細な設定およびステータスを表示する例を示します。

Router# show ip interface fastethernet 5/4
FastEthernet5/4 is up, line protocol is up
Internet address is 172.20.52.106/29
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.10
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP Fast switching turbo vector
IP Normal CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
IP multicast multilayer switching is disabled
IP mls switching is enabled
Router#
 

次に、show running-configコマンドを使用して、ポートFastEthernet 5/4のインターフェイスIPアドレスの設定を表示する例を示します。

Router# show running-config interfaces fastethernet 5/4
Building configuration...
 
Current configuration:
!
interface FastEthernet5/4
description "Router port"
ip address 172.20.52.106 255.255.255.248
no ip directed-broadcast
!

IPXルーティングおよびネットワーク番号の設定


) Multilayer Switch Feature Card(MSFC;マルチレイヤ スイッチ フィーチャ カード)は、高速スイッチングでInternetwork Packet Exchange(IPX)をサポートしています。


詳しい説明および設定手順については、次のマニュアルを参照してください。

次のURLの『 Cisco IOS AppleTalk and Novell IPX Configuration Guide 』Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fatipx_c/index.htm

次のURLの『 Cisco IOS AppleTalk and Novell IPX Command Reference 』Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fatipx_r/index.htm

IPXルーティングを設定し、レイヤ3インターフェイスにIPXを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# ipx routing

IPXルーティングをイネーブルにします。

ステップ 2

Router(config)# router ipx_routing_protocol

IPルーティング プロトコルを指定します。 このステップでは、他のコマンド(ルーティングするネットワークを指定する network コマンドなど)を使用する場合があります。

ステップ 3

Router(config)# interface { vlan vlan_ID } | { type 3 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 4

Router(config-if)# ipx network [ network | unnumbered ] encapsulation encapsulation_type

IPXネットワーク番号を設定します。このステップにより、インターフェイス上でIPXルーティングがイネーブルになります。インターフェイス上でIPXルーティングをイネーブルにするとき、カプセル化タイプも指定できます。

ステップ 5

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Router# show interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show ipx interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show running-config interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

設定を確認します。

3.type = ethernetfastethernetgigabitethernettengigabitethernet、またはge-wan

次に、IPXルーティングをイネーブルにし、インターフェイスVLAN 100にIPXネットワーク アドレスを割り当てる例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ipx routing
Router(config)# ipx router rip
Router(config-ipx-router)# network all
Router(config-ipx-router)# interface vlan 100
Router(config-if)# ipx network 100 encapsulation snap
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config

AppleTalkルーティング、ケーブルの範囲、およびゾーンの設定

詳しい説明および設定手順については、次のマニュアルを参照してください。

次のURLの『 Cisco IOS AppleTalk and Novell IPX Configuration Guide 』Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fatipx_c/index.htm

次のURLの『 Cisco IOS AppleTalk and Novell IPX Command Reference 』Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fatipx_r/index.htm

AppleTalkルーティングを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# appletalk routing

AppleTalk ルーティング をイネーブルにします。

ステップ 2

Router(config)# interface { vlan vlan_ID } | { type 4 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 3

Router(config-if)# appletalk cable-range cable_range

インターフェイスにケーブル範囲を割り当てます。

ステップ 4

Router(config-if)# appletalk zone zone_name

インターフェイスにゾーン名を割り当てます。

ステップ 5

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Router# show interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show appletalk interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show running-config interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

設定を確認します。

4.type = ethernetfastethernetgigabitethernettengigabitethernet、またはge-wan

次に、AppleTalkルーティングをイネーブルにして、インターフェイスVLAN 100にAppleTalkケーブルの範囲およびゾーン名を割り当てる例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# appletalk routing
Router(config)# interface vlan 100
Router(config-if)# appletalk cable-range 100-100
Router(config-if)# appletalk zone Engineering
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config

レイヤ3インターフェイス上でのその他のプロトコルの設定

レイヤ3インターフェイスにその他のプロトコルを設定する手順については、次のマニュアルを参照してください。

次のURLの『 Cisco IOS Apollo Domain, VINES, DECnet, ISO CLNS, and XNS Configuration Guide 』Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fapolo_c/index.htm

次のURLの『 Cisco IOS Apollo Domain, VINES, DECnet, ISO CLNS, and XNS Command Reference 』Release 12.2

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fapolo_r/index.htm