Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2SX
オプションのSTP機能の設定
オプションのSTP機能の設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

オプションのSTP機能の設定

PortFastの機能概要

BPDUガードの機能概要

PortFast BPDUフィルタリングの機能概要

UplinkFastの機能概要

BackboneFastの機能概要

EtherChannelガードの機能概要

ルート ガードの機能概要

ループ ガードの機能概要

PortFastのイネーブル化

PortFast BPDUフィルタリングのイネーブル化

BPDUガードのイネーブル化

UplinkFastのイネーブル化

BackboneFastのイネーブル化

EtherChannelガードのイネーブル化

ルート ガードのイネーブル化

ループ ガードのイネーブル化

オプションのSTP機能の設定

この章では、オプションのSpanning-Tree Protocol(STP;スパニングツリー プロトコル)機能を設定する手順について説明します。


) この章で使用しているコマンドの構文および使用方法の詳細については、『Cisco 7600 Series Router Cisco IOS Command Reference』を参照してください。


この章の構成は次のとおりです。

「PortFastの機能概要」

「BPDUガードの機能概要」

「PortFast BPDUフィルタリングの機能概要」

「UplinkFastの機能概要」

「BackboneFastの機能概要」

「EtherChannelガードの機能概要」

「ルート ガードの機能概要」

「ループ ガードの機能概要」

「PortFastのイネーブル化」

「PortFast BPDUフィルタリングのイネーブル化」

「BPDUガードのイネーブル化」

「UplinkFastのイネーブル化」

「BackboneFastのイネーブル化」

「EtherChannelガードのイネーブル化」

「ルート ガードのイネーブル化」

「ループ ガードのイネーブル化」


) STPの設定手順については、「STPおよびIEEE 802.1s MSTの設定」を参照してください。


PortFastの機能概要

STP PortFastを使用すると、アクセス ポートとして設定されたレイヤ2 LANインターフェイスが、リスニング ステートおよびラーニング ステートを経由せずに、ただちにフォワーディング ステートを開始します。1台のワークステーションまたはサーバに接続されたレイヤ2アクセス ポート上でPortFastを使用すると、STPのコンバージェンスを待たずに、装置がただちにネットワークに接続されます。1台のワークステーションまたはサーバに接続されたインターフェイスがBridge Protocol Data Unit(BPDU;ブリッジ プロトコル データ ユニット)を受信しないようにする必要があります。PortFast用に設定されているポートでも、STPは稼働しています。PortFast対応ポートは、必要に応じて、ブロッキング ステートにただちに移行できます(これは、上位BPDUを受信したときに発生することがあります)。トランク ポート上でPortFastをイネーブルにできます。PortFastには、設定値と異なる動作値を設定できます。


注意 PortFastの目的は、アクセス ポートがSTPのコンバージェンスを待つ時間を最小限に抑えることです。したがって、PortFastはアクセス ポート上でのみ使用する必要があります。ルータに接続されたポート上でPortFastをイネーブルにすると、一時的なブリッジング ループが発生する可能性があります。

BPDUガードの機能概要

BPDUガードがポート上でイネーブルになっている場合、BPDUガードはBPDUを受信するポートをシャットダウンします。BPDUガードがグローバルに設定されている場合は、BPDUガードはPortFast動作ステートのポート上でのみ有効です。有効な設定では、PortFastレイヤ2 LANインターフェイスはBPDUを受信しません。PortFastレイヤ2 LANインターフェイスがBPDUを受信した場合、認証されていない装置が接続された場合と同じように、無効な設定として通知されます。このようにBPDUガード機能では、管理者が手動でレイヤ2 LANインターフェイスを再び作動させなければならないので、無効な設定に対する安全な対処が可能になります。BPDUガードはインターフェイス レベルで設定可能です。インターフェイス レベルで設定されたBPDUガードは、PortFast設定に関係なく、ポートがBPDUを受信するとすぐにポートをシャットダウンします。


) グローバルに設定されているBPDUガードは、PortFast動作ステートのすべてのインターフェイスに適用されます。


PortFast BPDUフィルタリングの機能概要

PortFast BPDUフィルタリングを使うことで、管理者は特定ポート上でのBPDU送信やBPDU受信をシステムで禁止することができます。

グローバルに設定されたPortFastフィルタリングは、動作中のすべてのPortFastポートに適用されます。PortFast動作ステートのポートは、ホストに接続されているとみなされ、通常BPDUを廃棄します。動作中のPortFastポートがBPDUを受信すると、ポートはすぐにPortFast動作ステータスを失います。この場合、PortFast BPDUフィルタリングはこのポート上でディセーブルになり、STPはポート上でBPDUの送信を再開します。

PortFast BPDUフィルタリングはポート単位で設定することもできます。PortFast BPDUフィルタリングがポート上で明示的に設定されている場合、BPDUは送信されず、受信したすべてのBPDUは廃棄されます。


注意 ホストに接続されていないポートにPortFast BPDUフィルタリングを設定すると、このポートは受信したすべてのBPDUを無視し、フォワーディングに移行するため、ブリッジング ループが発生することがあります。

PortFast BPDUフィルタリングをグローバルにイネーブルにし、ポート設定をPortFast BPDUフィルタリングのデフォルトに設定すると(PortFast BPDUフィルタリングのイネーブル化を参照)、PortFastはPortFast BPDUフィルタリングをイネーブルまたはディセーブルにします。

ポート設定がデフォルトに設定されていない場合、PortFast設定はPortFast BPDUフィルタリングに影響しません。 表 19-1 に、使用可能なPortFast BPDUフィルタリングの組み合わせを示します。PortFast BPDUフィルタリングを使用すると、エンド ホストの接続直後に、アクセス ポートがフォワーディング ステートに直接移行できます。

 

表 19-1 PortFast BPDUフィルタリングのポート設定

ポート単位の設定
グローバル
コンフィギュレーション
PortFastのステート
PortFast BPDUフィルタリングのステート

Default

Enable

Enable

イネーブル1

Default

Enable

ディセーブル

ディセーブル

Default

ディセーブル

適用不可

ディセーブル

ディセーブル

適用不可

適用不可

ディセーブル

Enable

適用不可

適用不可

Enable

1.ポートは10以上のBPDUを送信します。このポートがいずれかのBPDUを受信した場合、PortFastおよびPortFast BPDUフィルタリングはディセーブルになります。

UplinkFastの機能概要

UplinkFastは、直接接続されたリンクの障害発生後高速コンバージェンスを行い、アップリンク グループを使用して、冗長レイヤ2リンク間でロードバランスを実行します。アップリンク グループは、(VLAN[仮想LAN]ごとの)レイヤ2 LANインターフェイスの集合であり、どの時点でも、その中の1つのインターフェイスだけが転送を行います。つまり、アップリンク グループは、(転送を行う)ルート ポートと、(セルフループを行うポートを除く)ブロックされたポートの集合で構成されます。アップリンク グループは、転送中のリンクで障害が起きた場合に代替パスを提供します。


) UplinkFastは、配線クローゼット スイッチに使用すると最も効果的です。それ以外の用途には、この機能は有用でない場合もあります。


図 19-1は、リンク障害が発生していないときのトポロジー例です。スイッチA(ルート ブリッジ)は、リンクL1を通じてスイッチBに、リンクL2を通じてスイッチCに直接接続されています。スイッチBに直接接続されているスイッチCのレイヤ2 LANインターフェイスは、ブロッキング ステートです。

図 19-1 直接リンク障害が発生する前のUplinkFastの例

 

スイッチCが、現在アクティブ リンクであるルート ポート上のL2でリンク障害( 直接 リンク障害)を検出すると、UplinkFastはスイッチCでブロックされていたポートのブロックを解除し、リスニング ステートおよびラーニング ステートを経ずに、ただちにフォワーディング ステートに移行させます(図 19-2を参照)。このスイッチ オーバーに要する時間は1~5秒です。

図 19-2 直接リンク障害が発生したあとのUplinkFastの例

 

BackboneFastの機能概要

ネットワーク装置上のルート ポートまたはブロックされたポートが、そのポートの指定ブリッジから下位BPDUを受信すると、BackboneFastが開始されます。下位BPDUにより、1台のネットワーク装置をルート ブリッジおよび指定ブリッジの両方として識別します。ネットワーク装置が下位BPDUを受信すると、ネットワーク装置はそのネットワーク装置が直接接続されていないリンク( 間接 リンク)で障害が発生した(つまり、指定ブリッジからルート ブリッジへの接続が切断された)ものとみなします。標準的なSTPルールに従う場合、ネットワーク装置は設定されている最大エージング タイム(STPの max-age コマンドで指定)の間下位BPDUを無視します。

ネットワーク装置は、ルート ブリッジへの代替パスの有無を判別します。下位BPDUがブロックされたポートに到達した場合には、ネットワーク装置のルート ポートおよびその他のブロックされたポートがルート ブリッジへの代替パスになります(セルフループ ポートはルート ブリッジの代替パスとはみなされません)。下位BPDUがルート ポートに到達した場合には、すべてのブロック ポートがルート ブリッジへの代替パスになります。下位BPDUがルート ポートに到達し、かつブロックされたポートがない場合には、ネットワーク装置はルート ブリッジへの接続が切断されたものとみなし、ルートの最大エージング タイムを満了させ、通常のSTPルールに従ってルート ブリッジになります。

ネットワーク装置にルート ブリッジへの代替パスがある場合、ネットワーク装置はそれらの代替パスを使用して、ルート リンク クエリProtocol Data Unit(PDU;プロトコル データ ユニット)と呼ばれる新しい種類のPDUを送信します。ネットワーク装置はルート ブリッジへのすべての代替パスに対して、ルート リンク クエリPDUを送信します。ルートへの代替パスがまだ存在していることが判明すると、ネットワーク装置は、下位BPDUを受信したポートの最大エージング タイムを満了させます。ルート ブリッジへのすべての代替パスが、ネットワーク装置とルート ブリッジ間の接続が切断されていることを示している場合には、ネットワーク装置は、下位BPDUを受信したポートの最大エージング タイムを満了させます。1つまたは複数の代替パスからルート ブリッジに引き続き接続できる場合には、ネットワーク装置は、下位BPDUを受信したすべてのポートをDesignated Port(DP;指定ポート)にして、(ブロッキング ステートになっていた場合)ブロッキング ステートから、リスニング ステートおよびラーニング ステートを経て、フォワーディング ステートに移行させます。

図 19-3は、リンク障害が発生していないときのトポロジー例です。スイッチA(ルート ブリッジ)は、リンクL1を通じてスイッチBに、リンクL2を通じてスイッチCに直接接続されています。スイッチBに直接接続されているスイッチCのレイヤ2 LANインターフェイスは、ブロッキング ステートです。

図 19-3 間接リンク障害が発生する前のBackboneFastの例

 

リンクL1で障害が発生した場合、スイッチCはリンクL1に直接接続されていないので、この障害を検出できません。一方、スイッチBはL1を通じてルート ブリッジに直接接続されているので、この障害を検出し、自身をルートに選定し、スイッチCに対して自身がルートであることを表すBPDUの送信を開始します。スイッチCがスイッチBから下位BPDUを受信すると、スイッチCは間接障害が発生したことを推測します。この時点で、BackboneFastにより、スイッチCのブロック ポートは、そのポートに設定されている最大エージング タイムの満了を待たずに、ただちにリスニング ステートに移行します。BackboneFastはさらに、スイッチCのレイヤ2 LANインターフェイスをフォワーディング ステートに移行させ、スイッチBからスイッチAまでのパスを提供します。この切り替えに要する時間は約30秒で、転送遅延時間の2倍にあたります(転送遅延時間がデフォルトの15秒に設定されている場合)。図 19-4に、BackboneFastがリンクL1で発生した障害に応じてどのようにトポロジーを再設定するかを示します。

図 19-4 間接リンク障害が発生したあとのBackboneFastの例

 

図 19-5に示すメディア共有型トポロジーに新しいネットワーク装置が組み込まれた場合、BackboneFastは起動されません。これは、認識している指定ブリッジ(スイッチB)から下位BPDUが着信していないためです。新しいネットワーク装置は、自らがルート ブリッジであることを伝える下位BPDUの送信を開始します。しかし、他のネットワーク装置はこれらの下位BPDUを無視します。その結果、新しいネットワーク装置はスイッチBがルート ブリッジであるスイッチAへの指定ブリッジであることを学習します。

図 19-5 メディア共有型トポロジーにおけるネットワーク装置の追加

 

EtherChannelガードの機能概要

EtherChannelガードは正しく設定されていないEtherChannelを検出します(Cisco 7600シリーズ ルータのインターフェイスがEtherChannelとして設定されているが、他の装置のインターフェイスまたはその一部が同じEtherChannelに設定されていない場合など)。

他の装置の設定に誤りがあることが検出されると、EtherChannelガードはCisco 7600シリーズ ルータのインターフェイスをerrdisableステートにします。

ルート ガードの機能概要

STPルート ガード機能を使用すると、ポートがルート ポートやブロックされたポートにならなくなります。ルート ガードに設定されたポートが上位BPDUを受信すると、このポートはただちにルートとして一貫性のない(ブロックされた)ステートになります。

ループ ガードの機能概要

ループ ガードは、ポイントツーポイント リンク上の単一方向リンク障害が原因で発生することのあるブリッジング ループの防止に有効です。グローバルにイネーブル化されたループ ガードは、システム上のすべてのポイントツーポイント ポートに適用されます。ループ ガードはルート ポートおよびブロックされたポートを検出し、これらのポートがセグメント上のDPからBPDUを受信し続けるようにします。ループ ガードがイネーブルになっているルート ポートまたはブロックされたポートがDPからのBPDUの受信を停止した場合、このポートはポート上に物理リンク エラーがあると想定して、ループに一貫性のないブロッキング ステートに移行します。ポートがBPDUを受信すると、ただちにこのループに一貫性のないステートから回復します。

ループ ガードはポート単位でイネーブルにすることができます。ループ ガードをイネーブルにすると、すべてのアクティブ インスタンスまたはポートが属するVLANにループ ガードが自動的に適用されます。ループ ガードをディセーブルにした場合は、指定したポートに対してディセーブルになります。ループ ガードをディセーブルにすると、ループに一貫性のないすべてのポートがリスニング ステートに移行します。

チャネル上でループ ガードをイネーブルに設定し、最初のリンクが単一方向になった場合、ループ ガードは影響を受けたポートがチャネルから除外されるまで、チャネル全体をブロックします。図 19-6に、3台のルータ構成におけるループ ガードを示します。

図 19-6 ループ ガードが設定された三角型のスイッチ設定

 

図 19-6に、次の設定を示します。

スイッチAおよびスイッチBはディストリビューション スイッチです。

スイッチCは、アクセスルータです。

ループ ガードは、スイッチA、B、Cのポート3/1および3/2でイネーブルです。

ルートルータでループ ガードをイネーブルにしても、効果はありませんが、ルートルータが非ルートルータになった場合に保護されます。

ループ ガードを使用するときは、次の注意事項に従ってください。

PortFast対応ポートまたはダイナミックなVLANポートでは、ループ ガードをイネーブルにできません。

ルート ガードがイネーブルの場合は、ループ ガードをイネーブルにできません。

ループ ガードは、次のように他の機能と相互作用します。

ループ ガードはUplinkFastまたはBackboneFastの機能には影響しません。

ポイントツーポイント リンクに接続されていないポート上でループ ガードをイネーブルにしても、機能しません。

ルート ガードは、強制的に、ポートを常にルート ポートとして指定された状態にします。ポートがルート ポートまたは代替ポートの場合のみ、ループ ガードは有効です。特定のポート上でループ ガードとルート ガードの両方を同時にイネーブルにすることはできません。

ループ ガードはスパニングツリーで認識されているポートを使用します。ループ ガードは、Port Aggregation Protocol(PAgP)が提供する論理ポートを利用できます。ただし、チャネルを形成するには、そのチャネルにグループ化するすべての物理ポートの設定に互換性がなければなリません。チャネルを形成するために、PAgPはすべての物理ポート上でルート ガードまたはループ ガードの設定を均一にします。

ループ ガードに適用される注意事項は、次のとおりです。

スパニングツリーは、BPDUを送信するチャネル内で最初に動作するポートを常に選択します。このリンクが単一方向になった場合、チャネル内の他のリンクが適切に機能している場合でも、ループ ガードはチャネルをブロックします。

ループ ガードによってブロックされている一連のポートをグループ化して、チャネルを形成した場合、スパニングツリーはこれらのポートのステート情報をすべて失い、新しいチャネル ポートは指定された役割を使用してフォワーディング ステートに移行できます。

チャネルがループ ガードによってブロックされている場合に、チャネルが切断されると、スパニングツリーはすべてのステート情報を失います。チャネルを形成する1つまたは複数のリンクが単一方向リンクである場合も、各物理ポートは指定された役割を使用して、フォワーディング ステートに移行できます。


) UniDirectional Link Detection(UDLD;単一方向リンク検出)をイネーブルにして、リンク障害を特定することができます。UDLDが障害を検出するまでループが発生することがありますが、ループ ガードはこのループを検出できません。


ディセーブル化されたスパニングツリー インスタンスまたはVLAN上では、ループ ガードは無効です。

PortFastのイネーブル化


注意 PortFastは、単一のエンド ステーションをレイヤ2アクセス ポートに接続する場合に限って 使用してください。そうしない場合、ネットワーク ループが発生する可能性があります。

レイヤ2アクセス ポート上でPortFastをイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface { type 2 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree portfast

単一のワークステーションまたはサーバに接続されたレイヤ2アクセス ポート上でPortFastをイネーブルにします。

ステップ 3

Router(config-if)# spanning-tree portfast default

PortFastをディセーブルにします。

ステップ 4

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 5

Router# show running interface { type 1 slot/port } | { port-channel port_channel_number }

設定を確認します。

2.type = ethernetfastethernetgigabitethernet、またはtengigabitethernet

次に、インターフェイスFastEthernet 5/8上でPortFastをイネーブルにする例を示します。

Router# configure terminal
Router(config)# interface fastethernet 5/8
Router(config-if)# spanning-tree portfast
Router(config-if)# end
Router#
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/8
Building configuration...
 
Current configuration:
!
interface FastEthernet5/8
no ip address
switchport
switchport access vlan 200
switchport mode access
spanning-tree portfast
end
 
Router#

PortFastのデフォルト設定をイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# spanning-tree portfast default

PortFastをデフォルトに設定します。

ステップ 2

Router(config)# show spanning-tree summary totals

グローバル コンフィギュレーションを確認します。

ステップ 3

Router(config)# show spanning-tree interface x detail

特定のポートに対する効果を確認します。

ステップ 4

Router(config-if)# spanning-tree portfast trunk

ポート上でPortFastトランクをイネーブルにします。

ステップ 5

Router# show spanning-tree interface fastEthernet x detail

設定を確認します。

次に、PortFastのデフォルト設定をイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree portfast default
Router(config)# ^Z
 
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is disabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 0 0 0 1 1
VLAN0010 0 0 0 2 2
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by default
Link type is point-to-point by default
BPDU:sent 10, received 0
 
Router(config-if)# spanning-tree portfast trunk
%Warning:portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
BPDU:sent 30, received 0
Router#

PortFast BPDUフィルタリングのイネーブル化

ここでは、PortFast BPDUフィルタリングを設定する手順について説明します。

PortFast BPDUフィルタリングをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# spanning-tree portfast bpdufilter default

ルータ上でBPDUフィルタリングをグローバルにイネーブル化します。

ステップ 2

Router# show spanning-tree summary totals

設定を確認します。

各ポート上で、BPDUフィルタリングはデフォルトに設定されています。次に、ポート上でPortFast BPDUフィルタリングをイネーブルにして、PVST+モードで設定を確認する例を示します。


) PVST+については、「STPおよびIEEE 802.1s MSTの設定」を参照してください。


Router(config)# spanning-tree portfast bpdufilter default
Router(config)# ^Z
 
Router# show spanning-tree summary totals
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is enabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

非トランキング ポート上でPortFast BPDUフィルタリングをイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface fastEthernet 4/4

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree bpdufilter enable

BPDUフィルタリングをイネーブルにします。

ステップ 3

Router# show spanning-tree interface fastEthernet 4/4

設定を確認します。

次に、非トランキング ポート上でPortFast BPDUフィルタリングをイネーブルにする例を示します。

Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree bpdufilter enable
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4
 
Vlan Role Sts Cost Prio.Nbr Status
---------------- ---- --- --------- -------- --------------------------------
VLAN0010 Desg FWD 1000 160.196 Edge P2p
Router# show spanning-tree interface fastEthernet 4/4 detail
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
BPDU:sent 0, received 0
Router#

BPDUガードのイネーブル化

BPDUガードをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# spanning-tree portfast bpduguard default

Router(config)# no spanning-tree portfast bpduguard default

BPDUガードをグローバルにイネーブルにします。

BPDUガードをグローバルにディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary totals

設定を確認します。

次に、BPDUガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree portfast bpduguard
Router(config)# end
Router#

次に、設定を確認する例を示します。

Router# show spanning-tree summary totals default
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is enabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#

UplinkFastのイネーブル化

UplinkFastを使用すると、ブリッジ プライオリティが49152に増えるとともに、Cisco 7600シリーズ ルータ上のすべてのレイヤ2 LANインターフェイスのSTPポート コストに3000が加算されます。その結果、ルータがルート ブリッジになる可能性が低くなります。 max_update_rate 値は、1秒間に送信されるマルチキャスト パケット数を表します(デフォルトは150パケット/秒です)。ブリッジ プライオリティを設定しているVLAN上では、UplinkFastをイネーブルにすることはできません。ブリッジ プライオリティを設定しているVLAN上でUplinkFastをイネーブルにするには、グローバル コンフィギュレーション モードで no spanning-tree vlan vlan_ID priority コマンドを入力して、VLANのブリッジ プライオリティをデフォルトに戻します。


) UplinkFastをイネーブルにすると、Cisco 7600シリーズ ルータ上のすべてのVLANに影響します。個々のVLANについてUplinkFastを設定することはできません。


UplinkFastをイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# spanning-tree uplinkfast [ max-update-rate max_update_rate ]

UplinkFastをイネーブルにします。

Router(config)# no spanning-tree uplinkfast max-update-rate

デフォルトのレートに戻します。

Router(config)# no spanning-tree uplinkfast

UplinkFastをディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

UplinkFastがイネーブルになっていることを確認します。

次に、UplinkFastをイネーブルにして、アップデート速度を400パケット/秒に設定する例を示します。

Router# configure terminal
Router(config)# spanning-tree uplinkfast max-update-rate 400
Router(config)# exit
Router#
 

次に、UplinkFastがイネーブルになっていることを確認する例を示します。

Router# show spanning-tree uplinkfast
UplinkFast is enabled
Router#

BackboneFastのイネーブル化


) BackboneFastが適切に動作するのは、ネットワーク内のすべてのネットワーク装置上でイネーブルになっている場合だけです。BackboneFastは、トークンリングVLANではサポートされません。この機能は、サードパーティ製のネットワーク装置と組み合わせて使用することができます。


BackboneFastをイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# spanning-tree backbonefast

BackboneFastをイネーブルにします。

Router(config)# no spanning-tree backbonefast

BackboneFastをディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

UplinkFastがイネーブルになっていることを確認します。

次に、BackboneFastをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree backbonefast
Router(config)# end
Router#
 

次に、BackboneFastがイネーブルになっていることを確認する例を示します。

Router# show spanning-tree backbonefast
BackboneFast is enabled
 
BackboneFast statistics
-----------------------
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
Router#

EtherChannelガードのイネーブル化

EtherChannelガードをイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# spanning-tree etherchannel guard misconfig

EtherChannelガードをイネーブルにします。

Router(config)# no spanning-tree etherchannel guard misconfig

EtherChannelガードをディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary | include EtherChannel

EtherChannelガードがイネーブルになっていることを確認します。

次に、EtherChannelガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree etherchannel guard misconfig
Router(config)# end
Router#
 

次に、設定を確認する例を示します。

Router# show spanning-tree summary | include EtherChannel
EtherChannel misconfiguration guard is enabled
 

errdisableステートのインターフェイスを表示するには、 show interface status err-disable コマンドを入力します。

誤っている設定が消去されると、errdisableステートのインターフェイスは自動的に回復します。インターフェイスを手動でサービス状態に戻すには、 shutdown コマンドを入力してから、該当するインターフェイスに対して no shutdown コマンドを入力します。

ルート ガードのイネーブル化

ルート ガードをイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface { type 3 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree guard root

ルート ガードをイネーブルにします。

Router(config-if)# no spanning-tree guard root

ルート ガードをディセーブルにします。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning-tree

Router# show running interface { type 1 slot/port } | { port-channel port_channel_number }

設定を確認します。

3.type = ethernetfastethernetgigabitethernet、またはtengigabitethernet

ルートとして一貫性のないステートになっているポートを表示するには、 show spanning-tree inconsistentports コマンドを入力します。

ループ ガードのイネーブル化

スパニングツリーのループ ガード機能をポート単位でイネーブルまたはディセーブルにするには、 set spanning-tree guard コマンドを使用します。

ルータ上でグローバルにループ ガードをイネーブル化する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router(config)# spanning-tree loopguard default

ルータ上でグローバルにループ ガードをイネーブル化します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning tree interface 4/4 detail

この設定がポートに作用していることを確認します。

次に、ループ ガードをグローバルにイネーブルにする例を示します。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree loopguard default
Router(config)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled by default on the port
BPDU:sent 0, received 0
 

特定のインターフェイス上でループ ガードをイネーブルにするには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface { type 4 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree guard loop

ループ ガードを設定します。

ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning tree interface 4/4 detail

この設定がポートに作用していることを確認します。

4.type = ethernetfastethernetgigabitethernet、またはtengigabitethernet

次に、ループ ガードをイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree guard loop
Router(config-if)# ^Z
 

次に、設定を確認する例を示します。

Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled on the port
BPDU:sent 0, received 0
Router#