Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2SX
レイヤ2スイッチング用LANポートの 設定
レイヤ2スイッチング用LANポートの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

レイヤ2スイッチング用LANポートの設定

レイヤ2スイッチングの機能概要

レイヤ2イーサネット スイッチングの概要

レイヤ2イーサネット スイッチングの概要

セグメント間のフレーム スイッチング

アドレス テーブルの作成

VLANトランクの概要

トランキングの概要

カプセル化タイプ

レイヤ2 LANポート モード

レイヤ2 LANインターフェイスのデフォルト設定

レイヤ2 LANインターフェイス設定時の注意事項および制約事項

レイヤ2スイッチング用のLANインターフェイスの設定

レイヤ2スイッチング用のLANポートの設定

トランクとしてのレイヤ2スイッチング ポートの設定

ISLまたは802.1Qトランクとしてのレイヤ2スイッチング ポートの設定

DTPを使用するためのレイヤ2トランクの設定

DTPを使用しないようにするためのレイヤ2トランクの設定

アクセスVLANの設定

802.1QネイティブVLANの設定

トランク上で許容されるVLANのリストの設定

プルーニング適格VLANのリストの設定

トランクの設定の完了

レイヤ2トランクの設定の確認

設定および確認の例

レイヤ2アクセス ポートとしてのLANインターフェイスの設定

カスタムIEEE 802.1Q EtherTypeフィールド値の設定

レイヤ2スイッチング用LANポートの設定

この章では、CLI(コマンドライン インターフェイス)を使用して、Cisco 7600シリーズ ルータ上でレイヤ2スイッチング用のイーサネット、ファスト イーサネット、ギガビット イーサネット、および10ギガビット イーサネットLANポートを設定する方法について説明します。この章の設定作業は、LANスイッチング モジュール上のLANポート、およびスーパバイザ エンジン上のLANポートに適用されます。


) この章で使用しているコマンドの構文および使用方法の詳細については、『Cisco 7600 Series Router Cisco IOS Command Reference』を参照してください。


この章の構成は次のとおりです。

「レイヤ2スイッチングの機能概要」

「レイヤ2 LANインターフェイスのデフォルト設定」

「レイヤ2 LANインターフェイス設定時の注意事項および制約事項」

「レイヤ2スイッチング用のLANインターフェイスの設定」


) レイヤ3インターフェイスの設定手順については、「レイヤ3インターフェイスの設定」を参照してください。


レイヤ2スイッチングの機能概要

ここでは、Cisco 7600シリーズ ルータにおけるレイヤ2スイッチングの機能について説明します。

「レイヤ2イーサネット スイッチングの概要」

「VLANトランクの概要」

「レイヤ2 LANポート モード」

レイヤ2イーサネット スイッチングの概要

ここではレイヤ2イーサネット スイッチングについて説明します。

「レイヤ2イーサネット スイッチングの概要」

「セグメント間のフレーム スイッチング」

「アドレス テーブルの作成」

レイヤ2イーサネット スイッチングの概要

Cisco 7600シリーズ ルータは、レイヤ2イーサネット セグメント間の同時パラレル接続をサポートしています。イーサネット セグメント間のスイッチド コネクションが維持されるのは、パケットの伝送時間の長さだけです。次のパケットには、別のセグメント間に新しい接続が確立されます。

Cisco 7600シリーズ ルータは、広帯域のデバイスおよび多数のユーザに起因する輻輳問題を解決するために、デバイス(サーバなど)ごとに専用の10 Mbps、100 Mbps、または1000 Mbps衝突ドメインを割り当てます。各LANポートは、それぞれ別のイーサネット衝突ドメインに接続されているので、スイッチング環境が適切に設定されていれば、サーバは全帯域幅にアクセスできます。

衝突はイーサネット ネットワークに重大な輻輳を引き起こしていますが、有効な解決策の1つは全二重通信です。イーサネットは通常、半二重モードで動作します。つまり、各ステーションは送信または受信のどちらか一方しか実行できません。全二重モードでは、2つのステーション間で同時に送受信を行うことができます。パケットを双方向に同時に送ることができるので、有効イーサネット帯域幅は2倍になります。

セグメント間のフレーム スイッチング

Cisco 7600シリーズ ルータ上の各LANポートは、1台のワークステーションまたはサーバに接続することも、ハブを介して複数のワークステーションまたはサーバをネットワークに接続することもできます。

標準的なイーサネット ハブでは、すべてのポートがハブ内の共通のバックプレーンに接続され、ハブに接続されたすべての装置が、ネットワークの帯域幅を共用します。2つのステーション間で、相当量の帯域幅を使用するセッションを確立した場合には、そのハブに接続された他のすべてのステーションで、ネットワークのパフォーマンスが低下します。

このようなパフォーマンス低下を軽減するために、ルータは各LANポートをそれぞれ独立したセグメントとして扱います。異なるLANポートに接続されているステーションが相互に通信する必要がある場合、ルータは、一方のLANポートから他方のLANポートにワイヤ速度でフレームを転送して、各セッションが全帯域幅を利用できるようにします。

LANポート間のフレーム スイッチングを効率的に行うために、ルータはアドレス テーブルを維持します。フレームがルータに着信すると、ルータは送信元ネットワーク デバイスのMAC(メディア アクセス制御)アドレスと、フレームを受信したLANポートを対応付けます。

アドレス テーブルの作成

Cisco 7600シリーズ ルータは、受信したフレームの送信元アドレスを使用して、アドレス テーブルを作成します。アドレス テーブルに宛先アドレスが登録されていないフレームをルータが受信すると、そのフレームを受信したポート以外の、同一VLAN(仮想LAN)のすべてのLANポートに、フレームをフラッディングします。宛先ステーションから応答があると、ルータは関連する送信元アドレスおよびポートIDをアドレス テーブルに追加します。ルータは以後、LANポートすべてに後続フレームをフラッディングせずに、1つのLANポートだけに転送します。

アドレス テーブルには、エントリのフラッディングを伴わずに32000以上のアドレス エントリを保管できます。ルータは設定変更可能なエージング タイマーによって定められたエージング メカニズムを使用するので、アドレスが所定の秒数だけ非アクティブ状態になると、アドレス テーブルから削除されます。

VLANトランクの概要

ここでは、Cisco 7600シリーズ ルータ上でのVLANトランクについて説明します。

「トランキングの概要」

「カプセル化タイプ」

トランキングの概要


) VLANの詳細については、「VLANの設定」を参照してください。


トランクとはルータとその他のネットワーキング装置間のポイントツーポイント リンクです。トランクは1つのリンクを介して複数のVLANトラフィックを伝送するので、VLANをネットワーク全体に拡張することができます。

次の2種類のトランキング カプセル化方式が、すべてのイーサネット ポートで使用可能です。

ISL(スイッチ間リンク) ― ISLはシスコ独自のトランキング カプセル化方式です。


) 次のスイッチング モジュールはISLカプセル化をサポートしません。

• WS-X6502-10GE
• WS-X6548-GE-TX、WS-X6548V-GE-TX、WS-X6548-GE-45AF
• WS-X6148-GE-TX、WS-X6148V-GE-TX、WS-X6148-GE-45AF


802.1Q ― 802.1Qは、業界標準のトランキング カプセル化方式です。

1つのイーサネット ポートまたはEtherChannelに対してトランクを設定できます。EtherChannelの詳細については、「EtherChannelの設定」を参照してください。

イーサネット トランク ポートは、数種類のトランキング モードをサポートしています(レイヤ2 LANポート モードを参照)。さらに、トランクでのISLまたは802.1Qカプセル化の使用、またはカプセル化タイプの自動ネゴシエーションを指定することもできます。


) カプセル化タイプをネゴシエーションするようにLANポートを設定できます。カプセル化タイプをネゴシエーションするようにWANインターフェイスを設定することはできません。


Dynamic Trunking Protocol(DTP)はLANポート上のトランク自動ネゴシエーションを管理します。DTPは、ISLトランクおよび802.1Qトランクの両方で自動ネゴシエーションをサポートします。

トランキングを自動ネゴシエーションするには、LANポートが同じVLAN Trunking Protocol(VTP;VLANトランキング プロトコル)ドメインに存在する必要があります。異なるドメイン内のLANポートを強制的にトランクするには、 trunk キーワードまたは nonegotiate キーワードを使用します。VTPドメインの詳細については、「VTPの設定」を参照してください。

カプセル化タイプ

表 10-1 に、イーサネット トランクのカプセル化タイプを示します。

 

表 10-1 イーサネット トランクのカプセル化タイプ

カプセル化
機能

switchport trunk encapsulation isl

トランク リンクにISLカプセル化を指定します。


) 一部のモジュールではISLカプセル化をサポートしません(トランキングの概要を参照)。


 

switchport trunk encapsulation dot1q

トランク リンクに802.1Qカプセル化を指定します。

switchport trunk encapsulation negotiate

LANポートが近接LANポートとネゴシエーションを行い、近接LANポートの設定および機能に応じて、ISLトランク(優先)または802.1Qトランクになるように指定します。

リンクがISLトランクまたは802.1Qトランクのどちらになるかは、接続された2つのLANポートのトランキング モード、トランク カプセル化タイプ、およびハードウェア機能によって決まります。

レイヤ2 LANポート モード

表 10-2 に、レイヤ2 LANポート モードを示し、LANポートにおける各モードの機能について説明します。

 

表 10-2 レイヤ2 LANポート モード

モード
機能

switchport mode access

LANポートは永続的な非トランキング モードになり、リンクを非トランク リンクに変換するようにネゴシエーションを行います。近接LANポートが変更に同意しなくても、LANポートは非トランク ポートになります。

switchport mode dynamic desirable

リンクからトランク リンクへの変換をLANポートにアクティブに試行させます。近接LANポートが trunk desirable 、または auto モードに設定されていれば、LANポートはトランク ポートになります。このモードは、すべてのLANポートのデフォルト モードです。

switchport mode dynamic auto

LANポートにリンクからトランク リンクへの変換を試行させます。近接LANポートが trunk または desirable モードに設定されていれば、LANポートはトランク ポートになります。

switchport mode trunk

LANポートは永続的なトランキング モードになり、リンクをトランク リンクに変換するようにネゴシエーションを行います。近接ポートが変更に同意しなくても、LANポートはトランク ポートになります。

switchport nonegotiate

LANポートを永続的なトランキング モードにしますが、LANポートがDTPフレームを生成するのを防ぎます。トランク リンクを確立するには、近接ポートを手動でトランク ポートとして設定する必要があります。


) DTPはPPP(ポイントツーポイント プロトコル)です。ただし、インターネットワーキング装置によっては、DTPフレームが正しく転送されないことがあります。この問題を避けるために、これらのリンク上でトランキングを行わない場合は、DTPをサポートしない装置に接続されているLANポートが、accessキーワードを使用して設定されていることを確認してください。DTPをサポートしない装置へのトランキングをイネーブルにするには、nonegotiateキーワードを使用して、LANポートをトランクにし、DTPフレームが生成されないようにします。


レイヤ2 LANインターフェイスのデフォルト設定

表 10-3 に、レイヤ2 LANポートのデフォルト設定を示します。

 

表 10-3 レイヤ2 LANインターフェイスのデフォルト設定

機能
デフォルト設定

インターフェイス モード:

switchport コマンドの入力前

レイヤ3(未設定)

switchport コマンドの入力後

switchport mode dynamic desirable

トランク カプセル化

switchport trunk encapsulation negotiate

VLAN許容範囲

VLAN 1~4094(予約済みVLANを除く)( VLANの範囲を参照)

プルーニングに適格なVLAN範囲

VLAN 2~1001

デフォルト アクセスVLAN

VLAN 1

ネイティブVLAN(802.1Qトランク用)

VLAN 1

Spanning-Tree Protocol(STP;スパンニングツリー プロトコル)

すべてのVLANでイネーブル

STPポート プライオリティ

128

STPポート コスト

10 MbpsイーサネットLANポートでは100

10/100 Mbpsファスト イーサネットLANポートでは19

100 Mbpsファスト イーサネットLANポートでは19

1000 Mbpsギガビット イーサネットLANポートでは4

10000 Mbps 10ギガビット イーサネットLANポートでは2

レイヤ2 LANインターフェイス設定時の注意事項および制約事項

レイヤ2 LANポートを設定する際、次の注意事項および制約事項に注意してください。

次のスイッチング モジュールは、ISLカプセル化をサポートしません。

WS-X6502-10GE

WS-X6548-GE-TX、WS-X6548V-GE-TX、WS-X6548-GE-45AF

WS-X6148-GE-TX、WS-X6148V-GE-TX、WS-X6148-GE-45AF

次に示す設定時の注意事項および制約事項は、802.1Qトランクを使用するときに適用され、
ネットワークのトランキングの構築方法が多少制限されます。802.1Qトランクを使用するときは、これらの制約事項に注意してください。

802.1Qトランクを介してシスコ製スイッチを接続するときは、802.1QトランクのネイティブVLANがトランク リンクの両端で同じであることを確認してください。トランクの一端のネイティブVLANと反対側の端のネイティブVLANが異なると、スパニングツリー ループの原因になります。

ネットワーク上のすべてのネイティブVLANについてスパニングツリーをディセーブルにせずに、802.1QトランクのVLAN上のスパニングツリーをディセーブルにすると、スパニングツリー ループが発生することがあります。802.1QトランクのネイティブVLAN上で、スパニング ツリーをイネーブルのままにしておくことを推奨します。この設定ができない場合は、ネットワークのすべてのVLAN上でスパニング ツリーをディセーブルにしてください。スパニングツリーをディセーブルにする場合には、事前にネットワークに物理的なループが存在しないことを確認してください。

802.1Qトランクを介して2台のシスコ製スイッチを接続すると、トランク上で許容されるVLANごとにスパニングツリーBridge Protocol Data Unit(BPDU;ブリッジ プロトコル データ ユニット)が交換されます。トランクのネイティブVLAN上のBPDUは、タグなしの状態で、予約済みIEEE 802.1dスパニングツリー マルチキャストMAC(メディア アクセス制御)アドレス(01-80-C2-00-00-00)に送信されます。トランクのほかのすべてのVLAN上のBPDUは、タグ付きの状態で、予約済みCisco Shared Spanning Tree(SSTP)マルチキャストMACアドレス(01-00-0c-cc-cc-cd)に送信されます。

他社製の802.1Qスイッチでは、すべてのVLANに対してスパニングツリー トポロジーを定義するスパニングツリーのインスタンス(Mono Spanning Tree[MST])が1つしか維持されません。802.1Qトランクを介してシスコ製ルータを他社製のルータに接続すると、他社製ルータのMSTとシスコ製ルータのネイティブVLANスパニングツリーが組み合わされて、Common Spanning Tree(CST)と呼ばれる単一のスパニングツリー トポロジーが形成されます。

シスコ製スイッチは、トランクのネイティブVLAN以外のVLANにあるSSTPマルチキャストMACアドレスにBPDUを送信します。したがって、他社製のスイッチではこれらのフレームがBPDUとして認識されず、対応するVLANのすべてのポート上でフラッディングされます。他社製の802.1Qクラウドに接続されたほかのシスコのスイッチは、フラッディングされたこれらのBPDUを受信します。このようにして、シスコのスイッチは、他社製の802.1Qスイッチ クラウドにわたって、VLAN別のスパニングツリー トポロジーを維持できます。シスコのスイッチを隔てている他社製の802.1Qクラウドは、802.1Qトランクを介して他社製の802.1Qクラウドに接続されたすべてのスイッチ間の単一のブロードキャスト セグメントとして処理されます。

シスコのスイッチを他社製の802.1Qクラウドに接続するすべての802.1Qトランク上で、ネイティブVLANが同じであることを確認します。

他社製の特定の802.1Qクラウドに複数のシスコのスイッチを接続する場合は、すべての接続に802.1Qトランクを使用する必要があります。ISLトランクまたはアクセス ポートを介して、シスコのスイッチを他社製の802.1Qクラウドに接続することはできません。このように接続すると、ルータはISLトランク ポートまたはアクセス ポートのスパニングツリー ポート ステートを「矛盾する」状態にし、ポートを介してトラフィックが送信されなくなります。

レイヤ2スイッチング用のLANインターフェイスの設定

ここでは、Cisco 7600シリーズ ルータにおけるレイヤ2スイッチングの設定手順について説明します。

「レイヤ2スイッチング用のLANポートの設定」

「トランクとしてのレイヤ2スイッチング ポートの設定」

「レイヤ2アクセス ポートとしてのLANインターフェイスの設定」

「カスタムIEEE 802.1Q EtherTypeフィールド値の設定」


) インターフェイスをデフォルト設定に戻すには、default interface {ethernet | fastethernet | gigabitethernet | tengigabitethernet} slot/portコマンドを使用します。


レイヤ2スイッチング用のLANポートの設定

レイヤ2スイッチング用のLANポートを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface type 1 slot/port

設定するLANポートを選択します。

ステップ 2

Router(config-if)# shutdown

(任意)設定が完了するまでトラフィック フローを防止するために、インターフェイスをシャットダウンします。

ステップ 3

Router(config-if)# switchport

LANポートをレイヤ2スイッチング用に設定します。


) LANポートをレイヤ2ポートとして設定するには、キーワードを指定せずにswitchportコマンドを1度入力する必要があります。そのあとで、キーワードとともにさらにswitchportコマンドを入力してください。


 

Router(config-if)# no switchport

レイヤ2 LANポートの設定を消去します。

ステップ 4

Router(config-if)# no shutdown

インターフェイスをアクティブにします(インターフェイスをシャットダウンしている場合に限り必要)。

ステップ 5

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 6

Router# show running-config interface [ type 1 slot/port ]

インターフェイスの実行コンフィギュレーションを表示します。

ステップ 7

Router# show interfaces [ type 1 slot/port ] switchport

インターフェイスのスイッチ ポートの設定を表示します。

ステップ 8

Router# show interfaces [ type 1 slot/port ] trunk

インターフェイスのトランクの設定を表示します。

1.type = ethernetfastethernetgigabitethernet、またはengigabitethernet

switchport コマンドを入力したあとのデフォルト モードは、 switchport mode dynamic desirable です。近接ポートがトランキングをサポートし、かつトランキングを許可するように設定されている場合、 switchport コマンドを入力すると、リンクはレイヤ2トランクになります。LANトランク ポートは、デフォルトでカプセル化についてネゴシエーションします。近接ポートがISLおよび802.1Qカプセル化をサポートし、かつ両方のポートがカプセル化タイプについてネゴシエーションするように設定されていれば、トランクはISLカプセル化を使用します(10ギガビット イーサネット ポートはISLカプセル化をサポートしません)。

ISLまたは802.1Qトランクとしてのレイヤ2スイッチング ポートの設定


) • ここに記載された作業を実行する前に、「レイヤ2スイッチング用のLANポートの設定」の手順を実行します。

キーワードを指定せずに switchport コマンドを入力する場合(前述のステップ 3)、デフォルト モードは switchport mode dynamic desirable および switchport trunk encapsulation negotiate です。


 

レイヤ2スイッチング ポートをISLまたは802.1Qトランクとして設定するには、次の作業を行います。

 

コマンド
説明

Router(config-if)# switchport trunk encapsulation { isl | dot1q | negotiate }

(任意)カプセル化を設定して、レイヤ2スイッチング ポートをISLまたは802.1Qトランクとして設定します。

Router(config-if)# no switchport trunk encapsulation

デフォルトのトランク カプセル化モード( negotiate )に戻します。

レイヤ2スイッチング ポートをISLまたは802.1Qトランクとして設定する場合、構文について次の点に注意してください。

switchport mode trunk コマンド(DTPを使用しないようにするためのレイヤ2トランクの設定を参照)は、 switchport trunk encapsulation negotiate コマンドと互換性がありません。

switchport mode trunk コマンドを使用できるようにするには、カプセル化または802.1Qを設定する必要があります。

次のスイッチング モジュールは、ISLカプセル化をサポートしません。

WS-X6502-10GE

WS-X6548-GE-TX、WS-X6548V-GE-TX、WS-X6548-GE-45AF

WS-X6148-GE-TX、WS-X6148V-GE-TX、WS-X6148-GE-45AF


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


DTPを使用するためのレイヤ2トランクの設定


) ここに記載された作業を実行する前に、「レイヤ2スイッチング用のLANポートの設定」の手順を実行します。


DTPを使用するようにレイヤ2トランクを設定するには、次の作業を行います。

 

コマンド
説明

Router(config-if)# switchport mode dynamic { auto | desirable }

(任意)DTPを使用するようにトランクを設定します。

Router(config-if)# no switchport mode

デフォルトのトランク トランキング モード( switchport
mode dynamic desirable
)に戻します。

DTPを使用するようにレイヤ2トランクを設定する際、次の構文情報に注意してください。

インターフェイスがレイヤ2アクセス ポートの場合、またはトランキング モードを指定する場合に限り必須です。

トランキング モードの詳細については、表 10-2を参照してください。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


DTPを使用しないようにするためのレイヤ2トランクの設定


) ここに記載された作業を実行する前に、「レイヤ2スイッチング用のLANポートの設定」の手順を実行します。


DTPを使用しないようにレイヤ2トランクを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config-if)# switchport mode trunk

(任意)無条件にポートをトランクに設定します。

Router(config-if)# no switchport mode

デフォルトのトランク トランキング モード
switchport mode dynamic desirable )に戻します。

ステップ 2

Router(config-if)# switchport nonegotiate

(任意)DTPを使用しないようにトランクを設定します。

Router(config-if)# no switchport nonegotiate

ポート上でDTPをイネーブルにします。

DTPを使用しないようにレイヤ2トランクを設定する際、次の構文情報に注意してください。

switchport mode trunk コマンドを入力する前に、カプセル化を設定する必要があります(ISLまたは802.1Qトランクとしてのレイヤ2スイッチング ポートの設定を参照)。

switchport nonegotiate コマンドを使用できるようにするには、 switchport mode trunk コマンドを入力する必要があります。

switchport mode dynamic trunk コマンドを入力します。トランキング モードの詳細については、表 10-2を参照してください。

switchport nonegotiate コマンドを入力する前にカプセル化を設定し(ISLまたは802.1Qトランクとしてのレイヤ2スイッチング ポートの設定を参照)、 switchport mode trunk コマンドを使用して無条件にポートをトランクに設定する必要があります(DTPを使用するためのレイヤ2トランクの設定を参照)。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


アクセスVLANの設定


) ここに記載された作業を実行する前に、「レイヤ2スイッチング用のLANポートの設定」の手順を実行します。


アクセスVLANを設定するには、次の作業を行います。

 

コマンド
説明

Router(config-if)# switchport access vlan vlan_ID

(任意)インターフェイスがトランキングを停止した場合に使用するアクセスVLANを設定します。 vlan_ID の値は1~4094です(予約済みVLANは除く。 VLANの範囲を参照)。

Router(config-if)# no switchport access vlan

デフォルト値に戻します(VLAN 1)。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


802.1QネイティブVLANの設定


) ここに記載された作業を実行する前に、「レイヤ2スイッチング用のLANポートの設定」の手順を実行します。


802.1QネイティブVLANを設定するには、次の作業を行います。

 

コマンド
説明

Router(config-if)# switchport trunk native vlan vlan_ID

(任意)802.1QネイティブVLANを設定します。

Router(config-if)# no switchport trunk native vlan

デフォルト値に戻します(VLAN 1)。

ネイティブVLANを設定する際、次の構文情報に注意してください。

vlan_ID の値は1~4094です(予約済みVLANは除く。 VLANの範囲を参照)。

アクセスVLANがネイティブVLANとして自動的に使用されることはありません。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


トランク上で許容されるVLANのリストの設定


) ここに記載された作業を実行する前に、「レイヤ2スイッチング用のLANポートの設定」の手順を実行します。


トランク上で許容されるVLANのリストを設定するには、次の作業を行います。

 

コマンド
説明

Router(config-if)# switchport trunk allowed vlan { add | except | none | remove } vlan [, vlan [, vlan [,...]]

(任意)トランク上で許容されるVLANのリストを設定します。

Router(config-if)# no switchport trunk allowed vlan

デフォルト値に戻します(すべてのVLANを許容)。

トランク上で許容されるVLANのリストを設定する際、次の構文情報に注意してください。

vlanパラメータは、1~4094の間の1つのVLAN番号、または2つのVLAN番号で指定する(小さい方数を先にして、間をダッシュで区切る)VLAN範囲です。カンマで区切ったvlanパラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべてのVLANが許容されます。

VLAN 1を削除できます。トランクからVLAN 1を削除した場合も、トランク インターフェイスはVLAN 1のCisco Discovery Protocol(CDP)、VTP、Port Aggregation Protocol(PAgP)、DTPなどの管理トラフィックを引き続き送受信します。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


プルーニング適格VLANのリストの設定


) ここに記載された作業を実行する前に、「レイヤ2スイッチング用のLANポートの設定」の手順を実行します。


レイヤ2トランクでプルーニング適格VLANのリストを設定するには、次の作業を行います。

 

コマンド
説明

Router(config-if)# switchport trunk pruning vlan { none |{{ add | except | remove } vlan [, vlan [, vlan [,...]]}}

(任意)トランクでプルーニング適格VLANのリストを設定します( VTPプルーニングの概要を参照)。

Router(config-if)# no switchport trunk pruning vlan

デフォルト値に戻します(すべてのVLANがプルーニング適格)。

トランク上で許容されるプルーニング適格VLANのリストを設定する際、次の構文情報に注意してください。

vlanパラメータは、1~4094の範囲の単一のVLAN番号(予約済みVLANを除く。 VLANの範囲を参照)、または2つのVLAN番号(小さい番号が先、ダッシュで区切る)で指定するVLAN範囲です。カンマで区切ったvlanパラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、プルーニングが許容されるVLANのリストには、すべてのVLANが含まれます。

VTPトランスペアレント モードのネットワーク装置は、VTP Joinメッセージを送信しません。VTPトランスペアレント モードのネットワーク装置にトランク接続されているCisco 7600シリーズ ルータでは、トランスペアレント モード ネットワーク装置によって使用されるVLAN、またはプルーニング不適格としてトランスペアレント モード ネットワーク装置全体に伝送する必要があるVLANを設定します。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


トランクの設定の完了

レイヤ2トランクの設定を完了するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config-if)# no shutdown

インターフェイスをアクティブにします(インターフェイスをシャットダウンしている場合に限り必要)。

ステップ 2

Router(config-if)# end

コンフィギュレーション モードを終了します。

レイヤ2トランクの設定の確認

レイヤ2トランクの設定を確認するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router# show running-config interface type 2 slot/port

インターフェイスの実行コンフィギュレーションを表示します。

ステップ 2

Router# show interfaces [ type 1 slot/port] switchport

インターフェイスのスイッチ ポートの設定を表示します。

ステップ 3

Router# show interfaces [ type 1 slot/port] trunk

インターフェイスのトランクの設定を表示します。

2.type = ethernetfastethernetgigabitethernet、またはtengigabitethernet

設定および確認の例

次に、ポートFastEthernet 5/8を802.1Qトランクとして設定する例を示します。この例では、近接ポートが802.1Qトランキングをサポートするように設定されていることを前提としています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 5/8
Router(config-if)# shutdown
Router(config-if)# switchport
Router(config-if)# switchport mode dynamic desirable
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# no shutdown
Router(config-if)# end
Router# exit
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/8
Building configuration...
Current configuration:
!
interface FastEthernet5/8
no ip address
switchport
switchport trunk encapsulation dot1q
end
 
Router# show interfaces fastethernet 5/8 switchport
Name: Fa5/8
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Enabled
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: ALL
 
Router# show interfaces fastethernet 5/8 trunk
 
Port Mode Encapsulation Status Native vlan
Fa5/8 desirable n-802.1q trunking 1
 
Port Vlans allowed on trunk
Fa5/8 1-1005
 
Port Vlans allowed and active in management domain
Fa5/8 1-6,10,20,50,100,152,200,300,303-305,349-351,400,500,521,524,570,801-8
02,850,917,999,1002-1005
 
Port Vlans in spanning tree forwarding state and not pruned
Fa5/8 1-6,10,20,50,100,152,200,300,303-305,349-351,400,500,521,524,570,801-8
02,850,917,999,1002-1005
 
Router#

レイヤ2アクセス ポートとしてのLANインターフェイスの設定


) 存在しないVLANにLANポートを割り当てると、VLANデータベースにそのVLANを作成するまで、LANポートはシャットダウンされます( イーサネットVLANの作成または変更を参照)。


LANポートをレイヤ2アクセス ポートとして設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# interface type 3 slot/port

設定するLANポートを選択します。

ステップ 2

Router(config-if)# shutdown

(任意)設定が完了するまでトラフィック フローを防止するために、インターフェイスをシャットダウンします。

ステップ 3

Router(config-if)# switchport

LANポートをレイヤ2スイッチング用に設定します。


) LANポートをレイヤ2ポートとして設定するには、キーワードを指定せずにswitchportコマンドを1度入力する必要があります。そのあとで、キーワードとともにさらにswitchportコマンドを入力してください。


 

ステップ 4

Router(config-if)# no switchport

レイヤ2 LANポートの設定を消去します。

ステップ 5

Router(config-if)# switchport mode access

LANポートをレイヤ2アクセス ポートとして設定します。

Router(config-if)# no switchport mode

デフォルトのスイッチポート モード( switchport mode dynamic desirable )に戻します。

ステップ 6

Router(config-if)# switchport access vlan vlan_ID

LANポートをVLANに入れます。 vlan_ID の値は1~4094です(予約済みVLANは除く。 VLANの範囲を参照)。

Router(config-if)# no switchport access vlan

デフォルトのアクセスVLANに戻します(VLAN 1)。

ステップ 7

Router(config-if)# no shutdown

インターフェイスをアクティブにします(インターフェイスをシャットダウンしている場合に限り必要)。

ステップ 8

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 9

Router# show running-config interface [ type 1 slot/port ]

インターフェイスの実行コンフィギュレーションを表示します。

ステップ 10

Router# show interfaces [ type 1 slot/port ] switchport

インターフェイスのスイッチ ポートの設定を表示します。

3.type = ethernet、fastethernet、gigabitethernet、またはtengigabitethernet

次に、ポートFastEthernet 5/6をVLAN 200のアクセス ポートとして設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 5/6
Router(config-if)# shutdown
Router(config-if)# switchport
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 200
Router(config-if)# no shutdown
Router(config-if)# end
Router# exit
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/6
Building configuration...
!
Current configuration:
interface FastEthernet5/6
no ip address
switchport access vlan 200
switchport mode access
end
 
Router# show interfaces fastethernet 5/6 switchport
Name: Fa5/6
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Enabled
Access Mode VLAN: 200 (VLAN0200)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: ALL
 
Router#

カスタムIEEE 802.1Q EtherTypeフィールド値の設定

Release 12.2(17a)SX以降のリリースでは、802.1Qタグ付きまたは802.1pタグ付きフレームの標準0x8100 EtherTypeフィールド値を使用しないネットワーク装置をサポートするように、ポートでカスタムEtherTypeフィールド値を設定できます。

EtherTypeフィールドのカスタム値を設定するには、次の作業を行います。

 

コマンド
説明

Router(config-if)# switchport dot1q ethertype value

ポートの802.1Q EtherTypeフィールド値を設定します。

Router(config-if)# no switchport dot1q ethertype

デフォルトの802.1Q EtherTypeフィールド値(0x8100)に戻します。

カスタムEtherTypeフィールド値を設定するときは、次の点に注意してください。

カスタムEtherTypeフィールド値を使用するには、ネットワーク上のトラフィック パス内のネットワーク装置すべてがカスタムEtherTypeフィールド値をサポートする必要があります。

トランク ポート、アクセス ポート、トンネル ポート上のカスタムEtherTypeフィールド値を設定できます。

ポートごとに、EtherTypeフィールド値1つのみをサポートします。カスタムEtherTypeフィールド値で設定されたポートでは、他のEtherTypeフィールド値を持つフレームはタグ付きフレームとして認識されません。たとえば、カスタムEtherTypeフィールド値で設定されたトランク ポートでは、802.1Qタグ付きフレームの標準0x8100 EtherTypeフィールド値は認識されず、このフレームが属するVLANにフレームを配置することができません。


注意 カスタムEtherTypeフィールド値で設定されたポートは、他のEtherTypeフィールド値を持つフレームをタグなしのフレームとみなします。カスタムEtherTypeフィールド値を持つトランク ポートは、他のEtherTypeフィールド値を持つフレームをネイティブVLANに配置します。カスタムEtherTypeフィールド値を持つアクセス ポートまたはトンネル ポートは、他のEtherTypeフィールド値を持つフレームをアクセスVLANに配置します。カスタムEtherTypeフィールド値を正しく設定しないと、フレームは間違ったVLANに配置される場合があります。

次のモジュールで、カスタムEtherTypeフィールド値を設定できます。

スーパバイザ エンジン

WS-X6516A-GBIC

WS-X6516-GBIC


) WS-X6516A-GBICおよびWS-X6516-GBICモジュールは、設定したカスタム
EtherTypeフィールド値を各ポートASIC(特定用途向けIC)(1~8、および9~16)でサポートされるポートすべてに適用します。


WS-X6516-GE-TX

WS-X6748-GE-TX

WS-X6724-SFP

WS-X6704-10GE

WS-X6816-GBIC

EtherChannelのポート上のカスタムEtherTypeフィールド値は設定できません。

カスタムEtherTypeフィールド値が設定されたポートからは、EtherChannelを形成できません。

次に、EtherTypeフィールド値を0x1234に設定する例を示します。

Router (config-if)# switchport dot1q ethertype 1234
Router(config-if)#