Cisco 7600 シリーズ イーサネット サービス Plus ラ イン カード コンフィギュレーション ガイド
Quality Of Service(QoS)の設定
Quality Of Service(QoS)の設定
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

Quality Of Service(QoS)の設定

サポート対象インターフェイス

QoS 機能

入力 QoS 機能

入力トラスト

入力キュー スケジューリング

入力分類

入力ポリシング

入力マーキング

入力帯域幅とクラスベース WFQ(CBWFQ)

低遅延キューイング(LLQ)(入力プライオリティ)

入力シェーピング

出力 QoS 機能

出力分類

出力ポリシング

出力マーキング

出力シェーピング

出力キュー スケジューリング

MQC による QoS 機能の設定

分類の設定

制約事項および使用上のガイドライン

ポリシングの設定

制約事項および使用上のガイドライン

検証

インターフェイスへの QoS トラフィック ポリシーの結合

入力インターフェイスへの QoS トラフィック ポリシーの結合

出力インターフェイスへの QoS トラフィック ポリシーの結合

マーキングの設定

制約事項および使用上のガイドライン

検証

シェーピングの設定

制約事項および使用上のガイドライン

検証

QoS キュー スケジューリングの設定

制約事項および使用上のガイドライン

WRED の設定

制約事項および使用上のガイドライン

帯域幅と CBWFQ の設定

制約事項および使用上のガイドライン

LLQ の設定

制約事項および使用上のガイドライン

Bandwidth Remaining Ratio(BRR)の設定

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードにおける PFC QoS の設定

Cisco 7600 シリーズ ES+ ラインカードにおける PFC QoS の設定時の注意事項

HQoS の設定

Ethernet Virtual Connection Service(EVCS)QoS サポート

制約事項および使用上のガイドライン

EVC 設定例

ポート チャネル メンバーリンクの QoS

サポートされる出力 QoS の設定

制約事項および使用上のガイドライン

ポート チャネル メンバーリンクの QoS の設定例

IPv6 - ホップバイホップ(HBH)レート リミッタ

制約事項および使用上のガイドライン

IPv6 - HBH レート リミッタの設定

Quality Of Service(QoS)の設定

この章では、Cisco 7600 シリーズ ルータの Cisco 7600 シリーズ Ethernet Services Plus(ES+; イーサネット サービス プラス)ラインカードで Quality of Service(QoS)を設定する方法について説明します。


) Cisco 7600 シリーズ ES+ ラインカードの QoS にはレイヤ 2 フレーム サイズを使用します。



) QoS をグローバルにイネーブルにすると、6xxx カードと Ethernet Services 20(ES20; イーサネット サービス 20)ラインカード間、6xxx カードと ES+ ラインカード間、ES20 ラインカードと ES+ ラインカード間でクロス バンドリングは許可されません。


この章で使用するコマンドの詳細については、 http://www.cisco.com/univercd/cc/td/doc/product/software/ios122sr/cr/index.htm Cisco IOS Release 12.2 SR Command References 』を参照してください。

プラットフォームに対応する他の QoS マニュアルまたは Cisco IOS ソフトウェアの QoS マニュアルを参照する前に、この章で Cisco 7600 シリーズ ES+ ラインカード固有の QoS 機能サポートおよび設定時の注意事項を確認してください。

Cisco IOS Release 12.2 における QoS の概念および機能の詳細については、 http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/12_2sr/qos_12_2sr_book.html の『 Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2SR 』を参照してください。

この章の内容は次のとおりです。

「サポート対象インターフェイス」

「QoS 機能」

「MQC による QoS 機能の設定」

「分類の設定」

「ポリシングの設定」

「マーキングの設定」

「シェーピングの設定」

「QoS キュー スケジューリングの設定」

「Cisco 7600 シリーズ ES+ ラインカードにおける PFC QoS の設定」

「HQoS の設定」

「Ethernet Virtual Connection Service(EVCS)QoS サポート」

「ポート チャネル メンバーリンクの QoS」

「IPv6 - ホップバイホップ(HBH)レート リミッタ」

サポート対象インターフェイス

Cisco 7600 シリーズ ES+ ラインカードは、次のインターフェイスで QoS をサポートします。

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力方向のみでサポート)

ポート チャネル レイヤ 3 メンバーリンク(出力方向のみでサポート)


) 次のインターフェイスは Modular QoS Command Line Interface(MQC; モジュラ QoS コマンドライン インターフェイス)コマンドをサポートしますが、Cisco IOS Release 12.2(33)SRD で使用できる QoS サポートは限られています。その他の QoS 機能は今後のリリースに含まれる予定です。


ポート チャネル レイヤ 2 メイン インターフェイス

ポート チャネル レイヤ 3 メイン インターフェイス

ポート チャネル レイヤ 2 メンバーリンク

QoS 機能

ここでは、入力 QoS および出力 QoS の機能について説明します。

入力 QoS 機能

ここでは、Cisco 7600 シリーズ ES+ ラインカードにおける入力 QoS サポートについて説明します。

入力トラスト

トラストとは、着信フレームに記載されているとおりに既存プライオリティを信頼する(残す)か、またはプライオリティをゼロに書き換えるようにポートに指示するポート割り当てのことです。

パケットは、プライオリティ値がパケット ヘッダーにすでに書き込まれている状態でインターフェイスに到着します。ルータは、定義済みルールに従って有効なアプリケーションまたはネットワーク デバイスがプライオリティ設定を設定しているかどうか、ユーザがより良いサービスを期待してプライオリティ設定を設定しているかどうかを判断する必要があります。

ルータは、プライオリティ値を受け入れるか別の値に変更するかを決める必要があります。ルータは、ポートの「トラスト」設定を使用してこの決断を行います。

メイン レイヤ 3 インターフェイスおよびレイヤ 3 サブインターフェイスは、Differentiated Services Code Point(DSCP; DiffServ コード ポイント)をデフォルトで常に信頼します。スイッチポート インターフェイスおよびサービス インスタンスは、ポートは信頼せず、Enhanced Address Recognition Logic(EARL)QoS を無視します。

入力 Type of Service(ToS; タイプ オブ サービス)を変更するには、マーキングを使用します。マーキングの詳細については、「マーキングの設定」を参照してください。

入力キュー スケジューリング

Cisco 7600 シリーズ ES+ ラインカードでは入力キュー スケジューリングがサポートされます。入力スケジューリングの設定の詳細については、「QoS キュー スケジューリングの設定」を参照してください。

入力分類

分類ではトラフィック記述子が使用されて特定グループにパケットが分類され、そのパケットが定義されてネットワークで QoS 処理用にアクセスできるようになります。パケット分類を使用すると、複数のプライオリティ レベルまたは Class of Service(CoS; サービス クラス)にネットワーク トラフィックを区分できます。

トラフィックは、以下を判断するために分類されます。

さらに処理を進めるようにマーク付けするかどうか

レート制限固有のトラフィック タイプにポリシングを行うかどうか

Cisco 7600 シリーズ ES+ ラインカードでは入力分類がサポートされます。分類の設定の詳細については、「分類の設定」を参照してください。

入力ポリシング

ポリシングでは、特定ポートまたは VLAN ポートの一群を通過するトラフィックで使用できる帯域幅を制限できます。ポリシングは、ルータが送受信するデータ量をキロバイト/秒単位で定義することで動作します。

ポリシングを設定すると、プロファイル外の QoS 値トラフィックがドロップされるかマーキングされて、ルータのデータの流れが制限されます。ルータでは、ポリシングにより、インターフェイスの帯域幅だけに基づく場合よりも低いレベルに、特定タイプのレートを制限できます。

Cisco 7600 シリーズ ES+ ラインカードでは入力ポリシングがサポートされます。ポリシングの設定の詳細については、「ポリシングの設定」を参照してください。

入力マーキング

トラフィックは、分類後にマーキングできます。マーキングは、パケットの分類ビットを選択的に修正し、ネットワーク内でトラフィックを識別する方法です。その他のインターフェイスは、マーキングに基づいてトラフィックをマッチングできます。

Cisco 7600 シリーズ ES+ ラインカードでは入力マーキングがサポートされます。マーキングの設定の詳細については、「マーキングの設定」を参照してください。

入力帯域幅とクラスベース WFQ(CBWFQ)

入力帯域幅では、ポリシー マップに属するクラスに割り当てられる帯域幅を指定または変更できます。Class-Based Weighted Fair Queueing(CBWFQ; クラスベース WFQ)は、ユーザ定義のトラフィック クラスをサポートするために、標準的な WFQ 機能を拡張したものです。入力帯域幅および CBWFQ は、メイン レイヤ 3 インターフェイス、レイヤ 3 サブインターフェイス、およびサービス インスタンスでサポートされます。

Cisco 7600 シリーズ ES+ ラインカードでは、入力帯域幅および CBWFQ がサポートされます。詳細については、「帯域幅と CBWFQ の設定」を参照してください。

低遅延キューイング(LLQ)(入力プライオリティ)

Low Latency Queuing(LLQ; 低遅延キューイング)では、ポリシー マップ内のクラス マップに帯域幅を割り当てることができます。

Cisco 7600 シリーズ ES+ ラインカードでは LLQ がサポートされます。詳細については、「LLQ の設定」を参照してください。

入力シェーピング

Cisco 7600 シリーズ ES+ ラインカードでは入力シェーピングがサポートされます。shape average コマンドは、メイン レイヤ 3 インターフェイス、レイヤ 3 サブインターフェイス、サービス インスタンスの入力のフラット/Hierarchical QoS(HQoS; 階層型 QoS)ポリシー マップでサポートされます。詳細については、「シェーピングの設定」を参照してください。


) 入力キューイング コマンドは、ポート チャネル サービス インスタンスではサポートされません。


出力 QoS 機能

ここでは、Cisco 7600 シリーズ ES+ ラインカードの出力ポートにおける QoS 機能について説明します。

出力分類

分類ではトラフィック記述子が使用されて特定グループにパケットが分類され、そのパケットが定義されてネットワークで QoS 処理用にアクセスできるようになります。パケット分類を使用すると、複数のプライオリティ レベルまたは CoS にネットワーク トラフィックを区分できます。

トラフィックは、以下を判断するために分類されます。

さらに処理を進めるようにマーク付けするかどうか

レート制限固有のトラフィック タイプでキューに入れるかどうか

Cisco 7600 シリーズ ES+ ラインカードでは出力分類がサポートされます。分類の設定の詳細については、「分類の設定」を参照してください。

出力ポリシング

Cisco 7600 シリーズ ES+ ラインカードでは出力ポート ポリシングがサポートされます。

出力マーキング

トラフィックの分類後、ルータはトラフィックをマーキングできます。パケットの分類ビットを選択的に修正し、指定マーキングに基づいてパケットを差別化するためにマーキングを使用します。

Cisco 7600 シリーズ ES+ ラインカードでは出力ポート マーキングがサポートされます。マーキングの設定の詳細については、「マーキングの設定」を参照してください。

出力シェーピング

トラフィック シェーピングでは、インターフェイスから出力されるトラフィックを制御して、リモート ターゲット インターフェイスの速度にフローを合わせ、指定されているポリシーにトラフィックを準拠させることができます。ダウンストリーム要件を満たして、データとレートが一致しないトポロジのボトルネックを解消するため、シェーピングを使用できます。

Cisco 7600 シリーズ ES+ ラインカードでは、出力ポート、サブインターフェイス、サービス インスタンスでシェーピングがサポートされます。シェーピングの設定の詳細については、「シェーピングの設定」を参照してください。

出力キュー スケジューリング

出力ラインカードは輻輳回避機能を使用し、輻輳を防止してバッファのオーバーフローを避けます。

Cisco 7600 シリーズ ES+ ラインカードでは、CBWFQ、LLQ、Weighted Random Early Detection(WRED; 重み付けランダム早期検出)がサポートされます。出力スケジューリングの設定の詳細については、「QoS キュー スケジューリングの設定」を参照してください。

MQC による QoS 機能の設定

MQC は、ユーザがトラフィック ポリシーを作成し、そのポリシーをインターフェイスに結合できる CLI 構造です。トラフィック ポリシーには、トラフィック クラスおよび 1 つまたは複数の QoS 機能を指定します。トラフィック クラスは、トラフィックを選択するために使用されるのに対して、トラフィック ポリシーの QoS 機能は分類されたトラフィックの取り扱いを決定します。

Cisco 7600 シリーズ ES+ ラインカード上で MQC を使用して QoS 機能を設定するには、次の基本的な作業を行います。


ステップ 1 class-map コマンドを使用して、トラフィック クラスを定義します。

ステップ 2 トラフィック クラスと 1 つまたは複数の QoS 機能を対応付けることによって、トラフィック ポリシーを作成します( policy-map コマンドを使用)。

ステップ 3 service-policy コマンドを使用して、インターフェイスにトラフィック ポリシーを結合します。


 

MQC の詳細については、次の URL にアクセスし、『 Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2 』の「Modular Quality of Service Command-Line Interface Overview」を参照してください。

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800bd908.html

分類の設定

QoS 分類機能を使用して、ネットワーク トラフィックを選択し、クラス別に分類して、一定の一致条件に基づいてその後の QoS 処理が実行されるようにします。デフォルト クラスである「class-default」は、設定されているクラス マップのどの選択条件とも一致しないトラフィックが振り分けられるクラスです。

制約事項および使用上のガイドライン

表 7-1 に、Cisco 7600 シリーズ ルータ上で Cisco 7600 シリーズ ES+ ラインカード向けにサポートされる QoS 分類機能の情報を示します この表に記載されているコマンドの詳細については、『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。

 

表 7-1 QoS 分類機能のサポート

機能(match コマンド)
サポート対象インターフェイス

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス1

サービス インスタンス1

ポート チャネル サービス インスタンス1

ポート チャネル サブインターフェイス(入力のみ)

CoS のマッチング( match cos コマンド)

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス2

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

SVI インターフェイス3

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)

ポート チャネル レイヤ 3 メンバーリンク(出力のみ)

内部 CoS のマッチング(match cos inner コマンド)

次のインターフェイスの入力および出力

サービス インスタンス

ポート チャネル サービス インスタンス

入力 VLAN のマッチング( match input vlan コマンド)

次のインターフェイスの出力

メイン レイヤ 3

(注) 入力側の非インテリジェント ラインカードおよび出力側の Cisco 7600 シリーズ ES+ ラインカードで使用します。出力側でサービス ポリシーが適用され、入力側からの VLAN とのマッチングが行われます。

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)

ポート チャネル レイヤ 3 メンバーリンク(出力のみ)

IP precedence のマッチング( match ip precedence コマンド)

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)

ポート チャネル レイヤ 3 メンバーリンク(出力のみ)

MPLS Experimental(EXP)ビットのマッチング( match mpls experimental コマンド)

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)

ポート チャネル レイヤ 3 メンバーリンク(出力のみ)

VLAN のマッチング

match vlan コマンド:レイヤ 2 IEEE 802.1Q フレームの外部 VLAN のマッチング)

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス2

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)

内部 VLAN のマッチング

match vlan inner コマンド:レイヤ 2 フレームに含まれる 802.1Q タグの最も内側の VLAN のマッチング)

次のインターフェイスの入力および出力

レイヤ 3 サブインターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)

送信元 MAC アドレスのマッチング

match source-address mac コマンド:送信元 MAC アドレスのマッチング

次のインターフェイスの入力および出力

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

1.レイヤ 2 ACL を使用して、送信元 Media Access Control(MAC; メディア アクセス制御)アドレスだけに基づいて分類されます。

2.サブインターフェイス/Ethernet Virtual Circuit(EVC; イーサネット仮想回線)トラフィックとメイン インターフェイスに適用されるポリシーマップをマッチングさせるため。

3.Cisco 7600 シリーズ ES+ ラインカードでは、Ethernet over MPLS(EoMPLS)および Virtual Private LAN Service(VPLS)に限り SVI の分類がサポートされます。

手順概要

1. enable

2. configure terminal

3. class-map [match-all | match-any] class-map-name

4. match type

詳細手順

 

コマンド
目的

ステップ 1

enable

 
Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを要求されたら入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

class-map [ match-all | match-any ] class-map-name

 

 

Router(config)# class-map match-all acl9 (id 1049)

トラフィック クラスを作成します。

match-all :(任意)クラスで定義されたすべてのマッチング ステートメントの論理積を使用し、クラス マップのすべての一致基準と一致しなければならないことを指定します。これは、デフォルト値です。

match-any :(任意)クラスで定義されたすべてのマッチング ステートメントの論理和を使用し、1 つまたは複数の一致基準と一致しなければならないことを指定します。

class-map-name :ユーザ定義のクラス名を指定します。

(注) 一意のクラス マップを 4,000 まで定義できます。

ステップ 4

match type

 

 

Router(config-cmap)# match ip precedence 5

トラフィックに適用する一致基準を指定します。 type は、 表 7-1 に示されている Cisco 7600 シリーズ ES+ ラインカードがサポートする match コマンドの形式の 1 つです。

コマンド ステートメントを指定できます。

次の例は、ipp5 というクラス マップを設定して、IP precedence 5 のマッチング ステートメントを入力する方法を示しています。

Router# enable
Router# configure terminal
Router(config)# class-map ipp5
Router(config-cmap)# match ip precedence 5
Router(config-cmap)#
 

以下は、複数のマッチング ステートメントでクラス マッチングを設定する例です。

Router# enable
Router# configure terminal
Router(config)# class-map match-any many (id 1047)
Router(config-cmap)# match ip precedence 3
Router(config-cmap)# match access-group 100
Router(config-cmap)# match mpls experimental 5
 

以下は、指定 ACL でクラス マッチングを設定する例です。

Router# enable
Router# configure terminal
Router(config)# class-map match-all acl9 (id 1049)
Router(config-cmap)# match access-group name rock
 

次の例は、match vlan および class-default が親に含まれる子ポリシーでの論理積演算を示しています。

Router# enable
Router# configure terminal
Router(config)# class-map match-all childAND
Router(config-cmap)# match vlan inner 2-3
Router(config-cmap)# match cos inner 5 6
Router(config)# policy-map testchildAND
Router(config-pmap)# class childAND
Router(config-pmap-c)# shape average 100000000
Router(config)# policy-map parentAND
Router(config-pmap)# class vlan12
Router(config-pmap-c)# shape average 500000000

Router(config-pmap-c)# service-policy testchildAND

 

次の例は、show class-map コマンドを使用して、指定クラス マップのクラス マップ情報を表示する方法を示しています。

Router# show class-map ipp5
Class Map match-all ipp5 (id 1)

Match ip precedence 5

 

次の例は、show class-map コマンドを使用し、拡張 ACL でクラス マップ情報マッチングを表示する方法を示しています。

 
Router# show class-map acl5
Class Map match-all acl5 (id 1042)
Match access-group 102
 

次の例は、HQoS ポリシーの親クラスの VLAN で分類を確認する方法を示しています。

head# show policy-map match
Policy Map match
Class vlan11
shape average 2000000 8000 8000
service-policy match4
Class vlan12
shape average 2000000 8000 8000
service-policy match4
Class vlans
shape average 500000000 2000000 2000000
service-policy match2
 

ポリシングの設定

Cisco 7600 シリーズ ES+ ラインカードでは次の機能がサポートされます。

個別アクション

複数のアクション

シングル レート、2 カラー ポリサー

粒度

精度(レートおよびバケットの深さ)

統計

パーセントベース ポリサー

デュアル レート、3 カラー

パーセントベース ポリサー

カラー認識ポリサーのサポートなし

シングル レート 3 カラーのサポートなし

カラー非認識モード

階層型ポリシー(最大 2 レベル)

さまざまなレートでの 256 のプロファイル

マイクロフロー ポリシング

ポリシングは、次のインターフェイスの入力および出力でサポートされます。

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)(Trident ごとに集約)

レイヤ 3 ポート チャネル メンバーリンク

マイクロフロー ポリシングは、次のインターフェイスの入力でサポートされます。

メイン レイヤ 3 インターフェイス(マイクロフロー ポリシング)

レイヤ 3 サブインターフェイス(マイクロフロー ポリシング)

ポート チャネル サブインターフェイス(マイクロフロー ポリシング)

制約事項および使用上のガイドライン

ポリシングを設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

Cisco 7600 シリーズ ES+ ラインカードでは、ラインカードあたり 最大 1k の一意のグローバル ポリシー マップ がサポートされます。

Cisco 7600 シリーズ ES+ ラインカードでは、16K の EVC がサポートされます。ラインカードごとに 16K の入力サービス ポリシーおよび 16K の出力サービス ポリシーがサポートされます。

ポリシー マップごとのクラス マップは最大 255 です。


) CLI を使用して最低 64,000 bps で親の親レベル シェーパーを設定できますが、これは 160,000 bps に切り上げられます。


ポリサーの Committed Information Rate(CIR; 認定情報レート)および Peak Information Rate(PIR; 最大情報レート)は、64,000 bps ~ 10 Gbps の任意の値です。

サービス ポリシーで、ポリシング アクションの一部としてクラスベース マーキングとマーキングの両方を設定した場合、ポリシングを使用するマーキングがクラスベース マーキングより優先されます。

キューイング処理と組み合わせてポリシングを設定する場合

その他の帯域幅クラスがポリシー マップに設定されている場合は、exceed または violate アクションのいずれかがドロップされる必要があります。conform アクションは任意のアクションです。

その他の帯域幅クラスが設定されていない場合は、conform、exceed、violate は任意のアクションです。

Trident ごとに最大 48,000 のポリサーが、1 レート 2 カラーまたは 2 レート 3 カラーのポリサー用にサポートされます。

EVC マイクロフロー ポリサーはサポートされません。

サポートされるマイクロフロー ポリシングを設定する場合

ポリシーには、マイクロフロー ポリシング コマンドを指定する必要があります。マイクロフロー ポリシングは他の QoS 機能(マーキング、ポリシング、キューイング)ではサポートされません。

マイクロフロー ポリシングは Policy Feature Card(PFC; ポリシー フィーチャ カード)の処理です。その他の QoS 機能(マーキング、ポリシング、キューイング)は Trident で実装します。

ポリシーの実装を Trident から PFC に、または PFC から Trident に移すマイクロフロー ポリシングの変更はサポートされません。このような変更では、結合している ES40 インターフェイスからポリシーを削除し、変更してから、ES40 インターフェイスに再結合する必要があります。

表 7-2 に、Cisco 7600 シリーズ ルータ上で Cisco 7600 シリーズ ES+ ラインカード向けにサポートされるポリシング機能の情報を示します。

 

表 7-2 QoS ポリシング機能のサポート

ポリシング コマンド
ポリシング アクション(set コマンド)

police bps value conform-action action exceed-action action

パケットを伝送します(transmit アクション)。

パケットをドロップします( drop コマンド)。

IP precedence 値を設定します( set ip precedence コマンド)。

IP DSCP 値を設定します( set ip dscp コマンド)。

インポジションの MPLS EXP ビット(0 ~ 7)を設定します( set-mpls-experimental-imposition コマンド)。

topmost ラベルの MPLS EXP ビットを設定します( set-mpls-experimental-topmost コマンド)。

COS 値を設定します(set cos コマンド)。

COS-inner 値を設定します(set cos-inner コマンド)。

police cir percent % conform-action action exceed-action action

パケットを伝送します(transmit アクション)。

パケットをドロップします( drop コマンド)。

IP precedence 値を設定します( set ip precedence コマンド)。

IP DSCP 値を設定します( set ip dscp コマンド)。

インポジションの MPLS EXP ビット(0 ~ 7)を設定します( set-mpls-experimental-imposition コマンド)。

topmost ラベルの MPLS EXP ビットを設定します( set-mpls-experimental-topmost コマンド)。

COS 値を設定します(set cos コマンド)。

COS-inner 値を設定します(set cos-inner コマンド)。

police cir bps value pir bps value conform-action action exceed-action action violate-action action

パケットを伝送します(transmit アクション)。

パケットをドロップします( drop コマンド)。

IP precedence 値を設定します( set ip precedence コマンド)。

IP DSCP 値を設定します( set ip dscp コマンド)。

インポジションの MPLS EXP ビット(0 ~ 7)を設定します( set-mpls-experimental-imposition コマンド)。

topmost ラベルの MPLS EXP ビットを設定します( set-mpls-experimental-topmost コマンド)。

COS 値を設定します(set cos コマンド)。

COS-inner 値を設定します(set cos-inner コマンド)。

police cir percent % pir percent % conform-action action exceed-action action violate-action action

パケットを伝送します(transmit アクション)。

パケットをドロップします( drop コマンド)。

IP precedence 値を設定します( set ip precedence コマンド)。

IP DSCP 値を設定します( set ip dscp コマンド)。

インポジションの MPLS EXP ビット(0 ~ 7)を設定します( set-mpls-experimental-imposition コマンド)。

topmost ラベルの MPLS EXP ビットを設定します( set-mpls-experimental-topmost コマンド)。

COS 値を設定します(set cos コマンド)。

COS-inner 値を設定します(set cos-inner コマンド)。

手順概要

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class { class-name | class-default }

5. police bps value conform-action action exceed-action action

または

police cir percent % conform-action action exceed-action action

または

police cir bps value pir bps value conform-action action exceed-action action violate-action action

または

police cir percent % pir percent % conform-action action exceed-action action violate-action action

詳細手順

 

コマンド
目的

ステップ 1

enable

 
Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを要求されたら入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

Router(config)# policy-map policy-map-test

トラフィック ポリシーを作成または変更し、ポリシー マップ コンフィギュレーション モードを開始します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。40 字以内の英数字を使用できます。

ステップ 4

class { class-name | class-default }

 

 

Router (config-pmap)# class acgroup2

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

ステップ 5

police bps-value conform-action action exceed-action action

 

 

Router(config-pmap-c)# police 5000000 conform-action drop exceed-action set-dscp-transmit

トークン バケット アルゴリズムを使用してトラフィック クラスが使用できる最大帯域幅を指定します。

bps value:平均速度をビット/秒で指定します。有効値は、8000 ~ 200000000 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 7-2 に、可能なアクションを示します。

または

police cir percent % conform-action action exceed-action action

 

Router(config-pmap-c)# police cir percent 20 conform-action transmit exceed-action set-prec-transmit 1

インターフェイスで使用可能な帯域幅の割合に基づいてトラフィック ポリシングを設定します。

cir:Committed Information Rate(CIR; 認定情報レート) を指定します。
認定情報レート(CIR) がトラフィックのポリシングに使用されることを示します。

percent:帯域幅の割合を CIR の計算に使用することを指定します。

%:CIR の帯域幅割合を指定します。有効値は、1 ~ 100 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 7-2 に、可能なアクションを示します。

または

police cir bps-value pir bps-value conform-action action exceed-action action violate-action action

 

 

Router(config-pmap-c)# police cir 1000000 pir 2000000 conform-action set-cos-transmit 3 exceed-action set-cos-transmit 1 violate-action drop

CIR および Peak Information Rate(PIR; 最大情報レート)の 2 つのレートを使用してトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィックのポリシングに使用されることを示します。

pir:PIR を指定します。PIR がトラフィックのポリシングに使用されることを示します。

bps-value:平均速度をビット/秒で指定します。有効値は、8000 ~ 200000000 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 7-2 に、可能なアクションを示します。

または

police cir percent % pir percent % conform-action action exceed-action action violate-action action

 

Router(config-pmap-c)# police cir percent 20 pir percent 40 conform-action transmit exceed-action set-prec-transmit 1 violate-action drop

CIR および PIR の 2 つのレートを使用してトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィックのポリシングに使用されることを示します。

percent:帯域幅の割合を CIR の計算に使用することを指定します。

%:CIR または PIR の帯域幅割合を指定します。有効値は、1 ~ 100 です。

pir:PIR を指定します。PIR がトラフィックのポリシングに使用されることを示します。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 7-2 に、可能なアクションを示します。

次の例では、すべてのアクションは別の行で設定されています。

Router# (config)# policy-map ABC
Router(config-pmap)# class class-default
Router(config-pmap-c)# police 10000000 8000 8000
Router(config-pmap-c-police)# conform-action set-cos-transmit 2
Router(config-pmap-c-police)# exceed-action set-cos-transmit 1
Router(config-pmap-c-police)# end
Router#
Router# show policy-map ABC
Policy Map ABC
Class class-default
police cir 10000000 bc 8000 be 8000
conform-action set-cos-transmit 2
exceed-action set-cos-transmit 1
Router#
 

次の例では、1 レート 2 カラー ポリサーを設定します。

Router(config)# policy-map 1r2c
Router(config-pmap)# class class-default
Router(config-pmap-c)# police 2000000
Router(config-pmap-c-police)# conform-action transmit
Router(config-pmap-c-police)# exceed-action drop
Router(config-pmap-c-police)# end
Router# show policy-map 1r2c
Policy Map 1r2c
Class class-default
police cir 2000000 bc 62500
conform-action transmit
exceed-action drop
Router#
 

次の例では、1 レート 2 カラー ポリサーをパーセントで設定します。

Router(config)# policy-map 1r2c_percent
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir percent 20
Router(config-pmap-c-police)# conform-action set-cos-transmit 0
Router(config-pmap-c-police)# exceed-action drop
Router(config-pmap-c-police)# end
Router#
Router# show policy-map 1r2c_percent
Policy Map 1r2c_percent
Class class-default
police cir percent 20
conform-action set-cos-transmit 0
exceed-action drop
Router#
 

次の例では、2 レート 3 カラー ポリサーを設定します。

Router(config)# policy-map 2r3c
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir 2000000 pir 3000000
Router(config-pmap-c-police)# conform-action set-prec-transmit 3
Router(config-pmap-c-police)# exceed-action set-prec-transmit 2
Router(config-pmap-c-police)# violate-action set-prec-transmit 1
Router(config-pmap-c-police)# end
Router#
Router# show policy-map 2r3c
Policy Map 2r3c
Class class-default
police cir 2000000 bc 62500 pir 3000000 be 93750
conform-action set-prec-transmit 3
exceed-action set-prec-transmit 2
violate-action set-prec-transmit 1
Router#
 

次の例では、2 レート 3 カラー ポリサーをパーセントで設定します。

Router(config)# policy-map 2r3c_percent
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir percent 10 pir percent 20
Router(config-pmap-c-police)# conform-action transmit
Router(config-pmap-c-police)# exceed-action set-cos-transmit 0
Router(config-pmap-c-police)# violate-action drop
Router(config-pmap-c-police)# end
Router#
Router# show policy-map 2r3c_percent
Policy Map 2r3c_percent
Class class-default
police cir percent 10 pir percent 20
conform-action transmit
exceed-action set-cos-transmit 0
violate-action drop
Router#
 

次の例では、64 Kbps の CIR で class-default にシングル レート、2 カラー ポリサー、送信の conform アクション、およびドロップの exceed アクションを可能な限り小さな Committed Burst(Bc; 認定バースト)で設定します。

Router# enable
Router# configure terminal
Router(config)# policy-map police
Router(config-pmap)# class test8
Router(config-pmap-c)# police 64000 2000
 

次の例では、class-default にシングル レート、2 カラー ポリサー、およびポリシングを指定して子ポリシーを設定します。

Router# enable
Router# configure terminal
Router(config)# policy-map police5
Router(config-pmap)# class test18
Router(config-pmap-c)# service policy child-level
Router(config-pmap-c)# police cir 64000 50

 

次の例は、クラスおよびポリシー マップの 2R3C 設定を示しています。

Router# enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class cos2

Router(config-pmap-c)# police 1000000 pir 2000000 conform-action set-cos-transmit 3 exceed-action set-cos-transmit 1 violate-action drop

次の例では、64 Kbps の CIR および CIR の 2 倍の PIR で class-default にデュアル レート、3 カラー ポリサー、送信の conform アクション、および exceed アクション マーク dscp af11 および violate マーク dscp cs1 を Bc のデフォルト設定で設定します。

Router# enable
Router# configure terminal
Router(config)# policy-Map qos_test
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir 64000 bc 2000 pir 128000 be 2000 conform-action transmit exceed-action set-dscp-transmit af11 violate-action set-dscp-transmit cs1

 

次の例では、class-default にデュアル レート、3 カラー ポリサーを設定します。

Router# enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir percent 20 pir percent 40 conform-action transmit exceed-action set-prec-transmit 1 violate-action drop
 

検証

ポリシングを検証するには、次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map

すべての設定済みポリシー マップを表示します。

Router# show policy-map policy-map-name

ユーザが指定したポリシー マップを表示します。

Router# show policy-map interface

インターフェイスに結合しているすべての入力ポリシーおよび出力ポリシーの統計と設定を表示します。

次の例は、show policy-map interface コマンドを EXEC モードで使用してポリシング統計を表示する方法を示しています。

Router# show policy-map interface
TenGigabitEthernet3/1
service-policy output: x
class-map: a (match-all)
0 packets, 0 bytes
5 minute rate 0 bps
match: ip precedence 0
police:
1000000 bps, 10000 limit, 10000 extended limit
conformed 0 packets, 0 bytes; action: transmit
exceeded 0 packets, 0 bytes; action: drop

conformed 0 bps, exceed 0 bps, violate 0 bps

show policy-map interface コマンドを使用してポリシング統計を表示する別の例を次に示します。この場合、統計は EVC ポリサーごとに 1 レート 2 カラーです。

Router# show policy-map interface ten 4/1 service instance 1

TenGigabitEthernet4/1: EFP 1

Service-policy input: evc_ingress

Counters last updated 00:00:00 ago

Class-map: class-default (match-any)

72077 packets, 36903424 bytes

5 minute offered rate 981000 bps, drop rate 440000 bps

Match: any

police:

cir 10000000 bps, bc 8000 bytes

conformed 87426 packets, 44762112 bytes; actions:

transmit

exceeded 85974 packets, 44018688 bytes; actions:

drop

conformed 556000 bps, exceed 448000 bps

インターフェイスへの QoS トラフィック ポリシーの結合

トラフィック クラスでトラフィック ポリシーをイネーブルにするには、インターフェイス上でトラフィック ポリシーを設定しておく必要があります。トラフィック ポリシーは、イーサネット サブインターフェイス、メイン インターフェイス、サービス インスタンスにも結合できます。

トラフィック ポリシーは、インターフェイス(入力)に着信するトラフィックおよびそのインターフェイス(出力)から送信されるトラフィックに適用できます。

入力インターフェイスへの QoS トラフィック ポリシーの結合

入力インターフェイスにトラフィック ポリシーを結合すると、そのインターフェイスに着信したトラフィックにポリシーが適用されます。入力インターフェイスにトラフィック ポリシーを結合するには、インターフェイス コンフィギュレーション モードから次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# service-policy input policy-map-name

インターフェイスの入力方向にトラフィック ポリシーを結合します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。

出力インターフェイスへの QoS トラフィック ポリシーの結合

出力インターフェイスにトラフィック ポリシーを結合すると、そのインターフェイスから送信されるトラフィックにポリシーが適用されます。出力インターフェイスにトラフィック ポリシーを結合するには、インターフェイス コンフィギュレーション モードから次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# service-policy output policy-map-name

インターフェイスの出力方向にトラフィック ポリシーを結合します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。

マーキングの設定

トラフィック クラスの作成後、トラフィック ポリシーを設定することによって、これらのクラスで選択されたトラフィックに特定のアクションを適用するように、マーキング機能を設定できます。

通常、パケット マークは識別用です。パケットがマーキングされた後、ダウンストリーム デバイスはマーキングに基づいてトラフィックを識別し、ネットワーク要求に従ってトラフィックを分類します。この分類が発生するのは、マークを基準としてパケットを識別するようにトラフィック クラス内の match コマンド( match ip precedence match ip dscp match cos など)が設定されている場合です。その後、このトラフィック クラスを使用するトラフィック ポリシーによって、マーキング済みトラフィックに適した QoS 機能を設定できます。

場合によっては、識別以外の目的にマーキングを使用できます。たとえば、分散 WRED では IP precedence、IP DSCP、または MPLS EXP 値を使用して、パケットを検出し、ドロップできます。

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードにおいてクラスベース マーキングを設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

クラス マップごとのマーキング ステートメントの数に制限はありません。

マーキングは親およびリーフで設定できます。

EARL マーキングは使用されません。

マーキングは、キューイング ポリシーと組み合わせることができます。

マーキング統計は、show policy-map interface コマンドの出力には含まれません。マーキング統計の代わりに分類統計を参照してください。

表 7-3 に、Cisco 7600 シリーズ ルータ上で Cisco 7600 シリーズ ES+ ラインカード向けにサポートされる QoS クラスベース マーキング機能の情報を示します。

 

表 7-3 QoS クラスベース マーキング機能のサポート

マーキング機能(set コマンド)
サポート対象インターフェイス

IP DSCPの設定

set ip dscp コマンド:0 ~ 63 の値を使用して、ToS バイトで IP DSCP をマーキング)

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)

ポート チャネル レイヤ 3 メンバーリンク(出力のみ)

IP precedence の設定

set ip precedence コマンド:0 ~ 7 の値を使用して、IP ヘッダーの precedence 値をマーキング)

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)

ポート チャネル レイヤ 3 メンバーリンク(出力のみ)

レイヤ 2 IEEE 802.1Q CoS の設定

set cos コマンド:802.1Q タグ付きフレームで 0 ~ 7 の CoS 値をマーキング)

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス4

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス(入力の EoMPLS を除く)

ポート チャネル サービス インスタンス

ポート チャネル サブインターフェイス(入力のみ)

ポート チャネル レイヤ 3 メンバーリンク(出力のみ)

レイヤ 2 802.1Q CoS の設定

set cos-inner コマンド:ブリッジド フレームで 0 ~ 7 の内部 CoS フィールドをマーキング)

次のインターフェイスの入力および出力

レイヤ 3 サブインターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

レイヤ 2 802.1Q CoS の設定

set cos-inner cos コマンド:外部 CoS を内部 CoS にコピー)

次のインターフェイスの入力および出力

レイヤ 3 サブインターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

レイヤ 2 802.1Q CoS の設定

set cos cos-inner コマンド)

次のインターフェイスの入力および出力

レイヤ 3 サブインターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ラベル インポジションでの MPLS EXP ビットの設定

set mpls experimental imposition コマンド)

次のインターフェイスの入力

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

SVI インターフェイス(EoMPLS および VPLS 用)

サービス インスタンス(EVC ベース EoMPLS)

ポート チャネル サービス インスタンス(スイッチポートではサポートされません)

MPLS EXP topmost の設定

set mpls experimental topmost コマンド)

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

4.サブインターフェイス/EVC トラフィックとメイン インターフェイスに適用されるポリシー マップをマッチングさせるため。

手順概要

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class { class-name | class-default }

5. set type

詳細手順

 

コマンド
目的

ステップ 1

enable

 
Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを要求されたら入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

 

Router(config)# policy-map policymap3

トラフィック ポリシーを作成または変更し、ポリシー マップ コンフィギュレーション モードを開始します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。40 字以内の英数字を使用できます。

ステップ 4

class { class-name | class-default }

 

 

Router(config-pmap)# class class1

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

ステップ 5

set type

 

Router(config-pmap-c)# set ip precedence2

トラフィックに適用するマーキング アクションを指定します。 type は、 表 7-3 に示されている Cisco 7600 シリーズ ES+ ラインカードがサポートする set コマンドの形式の 1 つです。

次の例は、policy1 というサービス ポリシーの作成を示しています。このサービス ポリシーは、class コマンドの使用により、以前定義した分類ポリシーに関連付けられます。この例では、class1 という分類ポリシーが設定されていることを前提とします。

Router# enable
Router# configure terminal
Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# set ip precedence 1
 

次の例では、インポーズされた MPLS EXP ビットを 1 に設定するようにマーキングを設定します。

Router# enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class test
Router(config-pmap-c)# set mpls experimental imposition 1

 

次の例では、内部 cos 値を設定するようにマーキングを設定します。

Router# enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class test
Router(config-pmap-c)# set cos inner 1

 

次の例では、インポーズされた MPLS EXP ビットを 1 に設定するようにマーキングを設定します。

Router# enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class test
Router(config-pmap-c)# set mpls experimental topmost 1

検証

マーキングを検証するには、次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map

すべての設定済みポリシー マップを表示します。

Router# show policy-map policy-map-name

ユーザが指定したポリシー マップを表示します。

Router# show policy-map interface

インターフェイスに結合しているすべての入力ポリシーおよび出力ポリシーの統計と設定を表示します。

クラスベース マーキング機能の設定の詳細については、次の URL にある『 Class-Based Marking 』を参照してください。

http://www.cisco.com/en/US/docs/ios/12_1t/12_1t5/feature/guide/cbpmark2.html

シェーピングの設定

ここでは、トラフィックをシェーピングする QoS トラフィック ポリシーの設定について説明します。シェーピングは、キュー内のパケットを特定のプロファイルに準拠させるために遅延させるプロセスです。

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードにおいてシェーピングを設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

最大 256 のシェーピング プロファイルがサポートされます。

シェーピングは階層のどのレベルでも実行できます。

シェーピング レートは、64 Kbps からリンク レートの範囲です。

デュアル シェーパーはサポートされません。

サービス インスタンス、ポート チャネル サービス インスタンス、およびレイヤ 3 サブインターフェイスでは、親 class-default と子ポリシーの 2 レベル ポリシー マップがサポートされます。

メイン インターフェイスでは、親の親 class-default、親のユーザ定義クラス、および子のユーザ定義クラスの3 レベル ポリシー マップがサポートされます。

リーフ レベル シェーパーのシェーパー CIR の粒度は次のとおりです。

64,000 ~ 32,768,000 bps、粒度は 16,000 bps

32,768,000 ~ 131,008,000 bps、粒度は 64,000 bps

親レベル シェーパーのシェーパー CIR の粒度は次のとおりです。

64,000 bps ~ 10 Gbps の任意の値

親の親レベル シェーパーのシェーパー CIR の粒度は次のとおりです。

160,000 ~ 40,960,000 bps、粒度は 160,000 bps

40,960,000 ~ 163,840,000 bps、粒度は 640,000 bps

163,840,000 ~ 655,360,000 bps、粒度は 2,560,000 bps

655,360,000 bps ~ 10 Gbps、粒度は 10,240,000 bps

shape average percent コマンドはサポートされません。

131,008,000 bps を超えるシェーパー CIR は、ES+ ポートのリーフ レベルでは使用できません。ただし、サービスグループ フラット ポリシーだけは例外です。

輻輳管理機能の設定の詳細については、ご使用の Cisco IOS ソフトウェア リリースに対応する『 Cisco IOS Quality of Service Solutions Configuration Guide 』を参照してください。

表 7-4 に、Cisco 7600 シリーズ ルータ上で Cisco 7600 シリーズ ES+ ラインカード向けにサポートされる QoS トラフィック シェーピング機能の情報を示します。

 

表 7-4 QoS トラフィック シェーピング機能のサポート

トラフィック シェーピング機能(コマンド)
Cisco 7600 シリーズ ES+ ラインカード

クラスベース シェーピング

shape average コマンド)

次のインターフェイスの入力および出力

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

ポート チャネル サービス インスタンス

ポート チャネル レイヤ 3 メンバーリンク(出力のみ)

手順概要

1. enable

2. configure terminal

3. class-map [match-all | match-any] class-map-name

4. match [ip dscp ip-dscp-value | ip precedence ip-precedence-value | mpls experimental mpls-exp-value]

5. policy-map policy-name

6. class class-name

7. shape average cir [bc] [be]

詳細手順

 

コマンド
目的

ステップ 1

enable

 
Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを要求されたら入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

class-map [match-all | match-any] class-map-name

 

Router(config)# class-map class-interface-all

クラスとパケットの照合に使用されるクラス マップを作成します。

ステップ 4

match [ip dscp ip-dscp-value | ip precedence ip-precedence-value | mpls experimental mpls-exp-value]

 

Router(config-cmap)# match ip precedence 2

指定 IP DSCP、IP precedence、MPLS EXP のうちいずれかの値を一致基準として指定します。

ステップ 5

policy-map policy-name

 

Router(config)# policy-map test2

設定するポリシー マップの名前を指定します。

ステップ 6

class class-name

 

Router(config-pmap)# class classtest

サービス ポリシーに組み込まれている定義済みクラスの名前を指定します。

ステップ 7

shape average cir [bc] [be]

 

Router(config-pmap-c)# shape average 10000000

平均速度またはピーク速度のトラフィック シェーピングを指定します。

次の例は、メイン インターフェイスでのトラフィック シェーピングを示しています。インターフェイス gi1/1 から出力されるトラフィックは、10 Mbps のレートでシェーピングされます。

Router# enable
Router# configure terminal
Router(config)# class-map class-interface-all
Router(config-cmap)# match ip precedence 2
Router(config-cmap)# exit
Router(config)# policy-map dts-interface-all-action
Router(config-pmap)# class class-interface-all
Router(config-pmap-c)# shape average 10000000
Router(config-pmap-c)# exit
Router(config)# interface gi1/1

Router(config-if)# service-policy output dts-interface-all-action

以下は、クラスで定義されている CoS 値キューイングでマッチングするスイッチポート インターフェイスにおける出力シェーピング ポリシーの例です。

Router# enable
Router# configure terminal
Router(config)# policy-map switchport-cos-policy
Router(config-pmap)# class cos1
Router(config-pmap-c)# shape ave 100000000
 

ポリシーは、メイン スイッチポートの出力方向で適用されます。

Router# enable
Router# configure terminal
Router(config)# interface TenGigabitEthernet9/1
Router(config-if)# switchport
Router(config-if)# switchport access vlan 2000
Router(config-if)# switchport mode access
Router(config-if)# service-policy output switchport-cos-policy
 

次の例では、シェーピングは HQoS ポリシー マップの親レベルで適用されます。

Router# enable
Router# configure terminal
Router(config)# policy-map child2
Router(config-pmap)# class prec5
Router(config-pmap-c)# shape average 100000000
Router(config)# policy-map pcd
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 300000000
Router(config-if)# service-policy child2
 

次の例では、class-default に WRED を指定したシェーピング ポリシーを設定します。

 
Router# enable
Router# configure terminal
Router(config)# policy Map qos_test
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape ave 100Mbps
Router(config-pmap-c)# random-detect dscp-based aggregate
 
 
 

検証

トラフィック シェーピングを検証するには、次のコマンドを使用します。

 

コマンド
目的

Router# show interface [interface-name] shape

トラフィック シェーピングの詳細ステータスを表示します。

Router# show policy policy-name

指定トラフィック ポリシーを構成するすべてのクラスの設定を表示します。

Router# show policy policy-name class class-name

指定トラフィック ポリシーの指定クラスの設定を表示します。

QoS キュー スケジューリングの設定

ここでは、QoS キュー スケジューリングを設定する場合の Cisco 7600 シリーズ ES+ ラインカード固有の情報について説明します。

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードにおいてキューイング機能を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

子レベルでポリシーマップごとに設定できるデータ キューの数は、プライオリティ キューの設定によって異なります。

プライオリティ キューが設定されていない場合は、各加入者は最大 8 つの通常のキューを持つことができます。

任意のプライオリティ レベルのプライオリティ キューが設定されている場合は、各加入者は 2 つのプライオリティ キューおよび最大 6 つの通常のキューを持つことができます。

プライオリティ キューが 1 つだけ設定されている場合は、その他のプライオリティ キューは保留され、通常のキューとして使用できません。

Trident ごとに入力に 4k の親キューおよび出力に 8k の親キュー(設定不能)

Trident ごとに入力に 32K の子キューおよび出力に 64k の子キュー(設定不能)

サブインターフェイス/EVC の親 class-default はさらにスケーリングされます。

親のユーザ定義クラスマップは、メイン レイヤ 3 インターフェイスおよびポート チャネル レイヤ 3 メンバーリンク(出力のみ)でサポートされます。

QoS キュー スケジューリングでは、次のコマンドがサポートされます。

bandwidth x kbps

bandwidth percent x%

bandwidth remaining percent x %

bandwidth remaining ratio

priority

priority level level

queue-limit queue-size

queue-limit queue-size packets

random-detect

random-detect exponential-weighting-constant 1-16

random-detect min-threshold max-threshold mark-prob

random-detect dscp-based aggregate

random-detect dscp 0-63 min-threshold max-threshold mark-prob

random-detect prec-based

random-detect precedence 0-7 min-threshold max-threshold mark-prob

輻輳管理機能の設定の詳細については、ご使用の Cisco IOS ソフトウェア リリースに対応する『 Cisco IOS Quality of Service Solutions Configuration Guide 』を参照してください。

WRED の設定

WRED は、一般的に IP precedence に基づいてパケットを選択的にドロップします。IP precedence が高いパケットは、IP precedence が低いパケットよりドロップされる可能性が低くなります。WRED は、次のインターフェイスの出力でサポートされます。

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル レイヤ 3 メンバーリンク

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードの WRED を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

WRED サポートは、precedence ベース、dscp ベース、cos ベースです。random-detect コマンドを使用したデフォルトは、precedence ベースの WRED です。

dscp ベースは集約モードに限ってサポートされます。

precedence ベースは集約モードと非集約モードの両方でサポートされます。

cos ベースは非集約モードに限ってサポートされます。

インターフェイスごとのサポートは次のとおりです。

スイッチポートでは、cos ベースだけがサポートされます。

EVC およびサブインターフェイスでは、dscp ベース、precedence ベース、cos ベースがサポートされます。

メイン レイヤ 3 インターフェイスでは、dscp ベースと precedence ベースだけがサポートされます。

入力方向および親クラスではサポートされません。

すべてのプライオリティ レベルのプライオリティ キューではサポートされません。

クラス キューのランダム検出にはキューイング機能が必要です。

デフォルト クラスのランダム検出にはキューイング機能は不要です。

Cisco 7600 シリーズ ES+ ラインカードでは、discard-class ベース、ecn、および WRED はサポートされません。

Cisco 7600 シリーズ ES+ ラインカードでは集約 WRED がサポートされます。

キューごとに 8 つのカーブがサポートされます。

WRED の show policymap interface コマンドは、送信されたパケット数を表示しません。ランダムおよびテール ドロップの数が表示されます。

最大しきい値は 16 ~ 1000000 である必要があります。

MPLS パケットの EXP ベース WRED がサポートされます。

手順概要

1. enable

2. configure terminal

3. policy-map policy-name

4. class class-name

5. shape average cir [bc] [be]

6. random-detect

詳細手順

 

コマンド
目的

ステップ 1

enable

 
Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを要求されたら入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-name

 

Router(config)# policy-map wred

設定するポリシー マップの名前を指定します。

ステップ 4

class class-name

 

Router(config-pmap)# class IPP1

サービス ポリシーに組み込まれている定義済みクラスの名前を指定します。

ステップ 5

shape average cir [bc] [be]

 

Router(config-pmap-c)# shape average 200000000

指定クラスの指定ビット レートにトラフィックをシェーピングします。

ステップ 6

random-detect

 

Router(config-pmap-c)# random-detect dscp-based aggregate

WRED をイネーブルにします。

以下は WRED 設定の例です。

Router# enable
Router# configure terminal
Router(config)# policy-map wredtest
Router(config-pmap)# class cos5
Router(config-pmap-c)# shape average 200000000
Router(config-pmap-c)# random-detect dscp-based aggregate
Router(config-pmap-c)# random-detect dscp values 0 min 100 max 200 mark-prob 1
Router(config-pmap-c)# random-detect dscp values 1 min 300 max 500 mark-prob 1
Router(config-pmap-c)# random-detect dscp values 2 min 600 max 900 mark-prob 1
 

次の例では、IPP=1、3、5、7 と一致するクラス マップを設定し、出力インターフェイスに適用される WRED ポリシーを設定します。

Router# enable
Router# configure terminal
Router(config)# policy-map wred
Router(config-pmap)# class IPP1
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# random-detect precedence-based
Router(config-pmap)# class IPP3
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# random-detect precedence-based
Router(config-pmap)# class IPP5
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# random-detect precedence-based
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# random-detect precedence-based
 

次の例は、show policy map interface コマンドの出力を示しています(送信パケットは表示されません)。

Router# enable
Router# configure terminal
Router# show policy-map int gig 11/1 service instance 1
 
GigabitEthernet11/1: EFP 1
 
Service-policy output: temp_parent
 
Counters last updated 00:00:00 ago
 
Class-map: class-default (match-any)
139358 packets, 71351296 bytes
5 minute offered rate 1745000 bps, drop rate 283000 bps
Match: any
Queueing
queue limit 2048 packets
(queue depth/total drops/no-buffer drops) 0/104062/0
(pkts output/bytes output) 35296/18071552
shape (average) cir 10000000, bc 40000, be 40000
target shape rate 10000000
 
Service-policy : temp
 
Counters last updated 00:00:00 ago
 
Class-map: class-default (match-any)
139358 packets, 71351296 bytes
5 minute offered rate 1745000 bps, drop rate 1304000 bps
Match: any
 
queue limit 2048 packets
(queue depth/total drops/no-buffer drops) 0/104062/0
(pkts output/bytes output) 35296/18071552
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
class Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes thresh thresh prob

帯域幅と CBWFQ の設定

CBWFQ は、ユーザ定義のトラフィック クラスをサポートするために、標準的な WFQ 機能を拡張したものです。CBWFQ では、プロトコルおよび ACL を含む一致基準に基づいてトラフィック クラスを定義します。

帯域幅は次のインターフェイスの出力でサポートされます。

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル レイヤ 3 メンバーリンク


) ポート チャネル サービス インスタンスを除いて、帯域幅は HQoS の場合に限り上記のインターフェイスの入力でサポートされます。入力キューイングは、ポート チャネル サービス インスタンスではサポートされません。


制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードの 帯域幅と CBWFQ を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

bandwidth kbps および bandwidth percent x% コマンドがサポートされます。

入力では、bandwidth kbps、bandwidth remaining ratio、bandwidth remaining percent、および bandwidth percent x% コマンドが、メイン レイヤ 3 インターフェイス、レイヤ 3 サブインターフェイス、およびサービス インスタンスでサポートされます。

入力では、bandwidth kbps、bandwidth remaining ratio、bandwidth remaining percent、および bandwidth percent x% コマンドは HQoS ポリシー マップの子に設定する必要があります。

bandwidth remaining percent コマンドは子/リーフ レベルでサポートされます。bandwidth remaining ratio コマンドは、親および子/リーフ レベルでサポートされます。

QoS ポリシー マップ内で使用される bandwidth コマンドは、クラス間で一致している必要があります。たとえば、同じポリシー マップ内で bandwidth kbps が指定された class1 と bandwidth remaining ratio が指定された class2 はサポートされません。


) ただし、親と子のポリシー マップでは一致している必要はありません。たとえば、bandwidth remaining ratio が指定された親と bandwidth kbps が指定された子はサポートされます。


手順概要

1. enable

2. configure terminal

3. policy-map policy-name

4. class { class-name | class-default }

5. bandwidth {bandwidth-kbps | percent percent | remaining {ratio ratio | percent percent}}

詳細手順

 

コマンド
目的

ステップ 1

enable

 
Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを要求されたら入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

 

Router(config)# policy-map policy1

トラフィック ポリシーを作成または変更し、ポリシー マップ コンフィギュレーション モードを開始します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。40 字以内の英数字を使用できます。

ステップ 4

class { class-name | class-default }

 

 

Router(config)# class c3

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

ステップ 5

bandwidth {bandwidth-kbps | percent percent | remaining {ratio ratio|percent percent}}

 

Router(config-pmap-c)# bandwidth 20000

クラスに割り当てる帯域幅容量(kbps)または使用可能な帯域幅の割合を指定します。レイヤ 2 のオーバーヘッドにも対応できるだけの帯域幅容量を設定する必要があります。

次の例は、トラフィック クラス 1 および 2 に割り当てる帯域幅の容量を指定する、policy1 というサービス ポリシーを示しています。

Router# enable
Router# configure terminal
Router(config)# class-map class1
Router(config-cmap)# match ip dscp 30
Router(config-cmap)# exit
 
Router(config)# class-map class2
Router(config-cmap)# match ip dscp 10

Router(config-cmap)# exit

Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 30000
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config-pmap)# class class2
Router(config-pmap-c)# bandwidth 20000
Router(config-pmap-c)# exit
Router(config-pmap)# exit

Router(config)#

Router(config)# interface gigabit ethernet 2/1
Router(config-if)# service-policy output policy1
Router(config-if)# exit

次の例では、bandwidth コマンドを使用して、レート保証が設定されている複数のユーザ クラスを持つQoS ポリシーを設定します。

 
Router(config)# policy-map policy1
Router(config)# Class c1
Router(config-pmap-c)# Bandwidth percent 1%
Router(config-pmap)# Class c2
Router(config-pmap-c)# Bandwidth percent 10%
Router(config-pmap)# Class c3
Router(config-pmap-c)# Bandwidth percent 88%
Router(config-pmap)# Class class-default
Router(config-pmap-c)# Bandwidth 1%

次の例では、レート保証が設定されている複数のユーザ クラスを持つ QoS ポリシーを設定します。

Router# enable
Router# configure terminal
Router(config)# Policy Map parent_policy
Router(config-pmap)# class-default
Router(config-pmap-c)# shape average 20000000
Router(config-pmap-c)# bandwidth remaining ratio 5
Router(config-pmap-c)# service-policy child_policy
 
Router(config)# policy-map child_policy
Router(config-pmap)# class video
Router(config-pmap-c)# priority
Router(config-pmap-c)# police 10000000
Router(config-pmap)# class critical
Router(config-pmap-c)# bandwidth remaining percent 80
Router(config-pmap)# class class-default
Router(config-pmap-c)# bandwidth remaining percent 20

CBWFQ を検証するには、次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map policy-map

指定ポリシー マップを構成するすべてのクラスの設定を表示します。

Router# show policy-map policy-map class class-name

指定ポリシー マップの指定クラスの設定を表示します。

Router# show policy-map interface interface-name

指定インターフェイスのすべてのポリシー マップ用に設定されているすべてのクラスの設定を表示します。

Router# show queue interface-type interface-number

特定インターフェイスのキューイング設定および統計を表示します。

LLQ の設定

LLQ では、priority コマンドを使用してポリシー マップ内のクラス マップに帯域幅を割り当てます。

LLQ は、次のインターフェイスの出力でサポートされます。

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

スイッチポート インターフェイス

サービス インスタンス

ポート チャネル サービス インスタンス

ポート チャネル レイヤ 3 メンバーリンク

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードの LLQ を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

入力 LLQ

デュアル プライオリティ キュー(高、中、データ)。

LLQ 設定が可能なのはリーフ ポリシー マップだけです。

priority および priority level コマンドがサポートされますが、同じポリシー マップで両方のコマンドを使用することはできません。

ビット レートによる基本的なプライオリティ/低遅延キューはサポートされません。

パーセントによる基本的な低遅延キューはサポートされません。

ビット レートによるプライオリティ キューはサポートされません。

出力 LLQ

デュアル プライオリティ キュー(高、中、データ)。

LLQ 設定が可能なのはリーフ ポリシー マップだけです。

priority および priority level コマンドがサポートされますが、同じポリシー マップで両方のコマンドを使用することはできません。

ビット レートによる基本的なプライオリティ/低遅延キューはサポートされません。

パーセントによる基本的な低遅延キューはサポートされません。

ビット レートによるプライオリティ キューはサポートされません。

手順概要

1. enable

2. configure terminal

3. policy-map policy-name

4. class { class-name | class-default }

5. police bps-value conform-action action exceed-action action

または

police cir percent % conform-action action exceed-action action

または

police cir bps-value pir bps-value conform-action action exceed-action action violate-action action

または

police cir percent % pir percent % conform-action action exceed-action action violate-action action

6. priority

または

priority level

詳細手順

 

コマンド
目的

ステップ 1

enable

 
Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを要求されたら入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-name

 

Router(config)# policy-map silver

設定するポリシー マップの名前を指定します。

ステップ 4

class { class-name | class-default }

 
Router(config-pmap)# class classcos0

サービス ポリシーに組み込まれている定義済みクラスの名前を指定します。

ステップ 5

police bps-value conform-action action exceed-action action

 

 

Router(config-pmap-c)# police 5000000 conform-action set-dscp-transmit 0 exceed-action drop

トークン バケット アルゴリズムを使用してトラフィック クラスが使用できる最大帯域幅を指定します。

bps-value:平均速度をビット/秒で指定します。有効値は、8000 ~ 200000000 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 7-2 に、可能なアクションを示します。

または

police cir percent % conform-action action exceed-action action

 

Router(config-pmap-c)# police cir percent 20 conform-action transmit exceed-action set-prec-transmit 1

インターフェイスで使用可能な帯域幅の割合に基づいてトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィックのポリシングに使用されることを示します。

percent:帯域幅の割合を CIR の計算に使用することを指定します。

%:CIR の帯域幅割合を指定します。有効値は、1 ~ 100 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 7-2 に、可能なアクションを示します。

または

police cir bps-value pir bps-value conform-action action exceed-action action violate-action action

 

 

Router(config-pmap-c)# police cir 1000000 pir 2000000 conform-action set-cos-transmit 3 exceed-action set-cos-transmit 1 violate-action drop

CIR および PIR の 2 つのレートを使用してトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィックのポリシングに使用されることを示します。

pir:PIR を指定します。PIR がトラフィックのポリシングに使用されることを示します。

bps-value:平均速度をビット/秒で指定します。有効値は、8000 ~ 200000000 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 7-2 に、可能なアクションを示します。

または

police cir percent % pir percent % conform-action action exceed-action action violate-action action

 

Router(config-pmap-c)# police cir percent 20 pir percent 40 conform-action transmit exceed-action set-prec-transmit 1 violate-action drop

CIR および PIR の 2 つのレートを使用してトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィックのポリシングに使用されることを示します。

percent:帯域幅の割合を CIR の計算に使用することを指定します。

%:CIR または PIR の帯域幅割合を指定します。有効値は、1 ~ 100 です。

pir:PIR を指定します。PIR がトラフィックのポリシングに使用されることを示します。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 7-2 に、可能なアクションを示します。

ステップ 6

priority

 
Router(config-pmap-c)# priority

ポリシー マップに属するトラフィック クラスに、厳密なプライオリティを指定します。

または

priority level

 

Router(config-pmap-c)# priority level 1

ポリシー マップに属するトラフィック クラスに、プライオリティ レベルを指定します。

次の例では、クラスで定義されている CoS 値キューイングでマッチングするスイッチポート インターフェイスにおける出力 LLQ ポリシーを設定します。

Router# enable
Router# configure terminal
Router(config)# policy map switchport-llq-policy
Router(config-pmap)# class cos0
Router(config-pmap-c)# police 500000000
Router(config-pmap-c)# priority
 

ポリシーをインターフェイスに適用します。

Router# enable
Router# configure terminal
Router(config)# interface TenGigabitEthernet9/1
Router(config-if)# switchport
Router(config-if)# switchport access vlan 2000
Router(config-if)# switchport mode access
Router(config-if)# service-policy output switchport-llq-policy
 

次の例では、厳密なプライオリティが設定されているクラス c1 に簡単な LLQ QoS ポリシーを設定します。

Router# enable
Router# configure terminal
Router(config)# Policy Map qos_llq
Router(config-pmap)# Class c1
Router(config-pmap-c)# police 500000000
Router(config-pmap-c)# priority
 

次の例では、テスト用の最小パーセント値とデフォルトのバースト値が設定されている複数のプライオリティ クラスを持つ LLQ ポリシーを設定します。

Router# enable
Router# configure terminal
Router(config-pmap)# Class-map Voice
Router(config-pmap-c)# police cir percent 10
Router(config-pmap-c)# Priority
Router(config-pmap)# Class-map Video
Router(config-pmap-c)# Police cir percent 20
Router(config-pmap-c)# Priority
Router(config-pmap)# Class-default

 

Bandwidth Remaining Ratio(BRR)の設定

Bandwidth Remaining Ratio(BRR)は、リンクが輻輳(オーバーサブスクライブ)状態のときにユーザ間で帯域幅が分割される比率を指定します。この機能を使用すると、リンク レートを EVC や L3 サブインターフェイスなどの論理インターフェイスに割り当てることができます。この機能が必要とされるのは、シェーピング レートをオーバーサブスクライブできるため、論理インターフェイスが他の論理インターフェイスで使用されていない帯域幅を利用できるためです。

BRR は階層型ポリシー マップを使用して論理インターフェイスに実装します。

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードにおいて BRR を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

BRR を親または子クラスのポリシー マップ内のアクションとして設定できます。BRR は、論理インターフェイスで最小比率 1 および最大比率 1000 に設定できます。

暗黙 BRR の 1 はサポートされていないため、ポリシーで BRR を明示的に 1 に設定する必要があります。これは、LLQ クラスで BRR 1 が必要という意味ではありません(同じクラス内の LLQ 設定および CBWFQ 設定は CLI によって拒否されます)。LLQ クラスには帯域幅保証があるため、子レベルの BRR では自動的に LLQ クラスを帯域幅共有に参加させないようにします。

BRR を設定するには、bandwidth remaining ratio number コマンドを使用します。数値が大きくなるに従い、リンクが輻輳状態の場合に、QoS ポリシー マップが適用される論理インターフェイスが受け取る帯域幅が増加します。

HQoS ポリシー マップの親レベルの BRR は、ポートがトラフィックによって輻輳している場合に限り機能します。ポート上の全トラフィックがリンク帯域幅より低い場合は、すべての着信トラフィックには発信に十分な帯域幅があり、BRR は必要ありません。

ES+ ラインカードの BRR では、帯域幅共有は動的に計算されます。トラフィック プロファイルが変更されると帯域幅共有が変更されるように、BRR 計算は定期的に更新されます。

フラット ポリシー マップと HQoS ポリシー マップ間の BRR はサポートされません。

子ポリシー マップと親ポリシー マップの BRR 設定は類似しています。ただし、子レベルでは BRR 計算を開始する輻輳レベルは物理ポート レベルから親シェーパー レベルに移ります。

親レベルでは、BRR を機能させるために BRR とシェーパーを設定する必要があります。

BRR は、ポート チャネル サービス インスタンスおよびポート チャネル メンバーリンクでサポートされます(レイヤ 3)。BRR は、メンバーリンク上でロード バランスされたすべてのサービス インスタンス間で維持されます。たとえば、サービス インスタンス 1、2、3 がリンク Gi1/1 にロード バランスされ、サービス インスタンス 4、5 がリンク Gi1/2 にロード バランスされた場合、BRR は リンク Gi1/1 のサービス インスタンス 1、2、3 の間、およびリンク Gi1/2 のサービス インスタンス 4 と5 の間で維持されます。

ES+ ラインカードではサービス伝播がサポートされます。ポートが出力で輻輳状態の場合、すべての LLQ トラフィックが処理された後で、サービス伝播によりユーザ間のリンクに残っている帯域幅が設定比率で分割されます。

サービス伝播は常にオンです。

サービス伝播は、親に帯域幅保証がない場合に自動的にオンになります。

ES+ ラインカードのバッファ スペースが不足しないように、子クラスのキューそれぞれに queue-limit num of pkts コマンドを設定することを強く推奨します。num of pkts はキューに適切な数値です。queue-limit コマンドを設定しないと、送信トラフィックのBRR が不適切になることがあります。

手順概要

1. enable

2. configure terminal

3. policy-map policy-name

4. class { class-name | class-default }

5. shape average cir [bc] [be]

6. bandwidth remaining ratio ratio

7. service-policy policy-map

詳細手順

 

コマンド
目的

ステップ 1

enable

 
Router# enable

特権 EXEC モードをイネーブルにします。

パスワードを要求されたら入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-name

 

Router(config)# policy-map silver

設定するポリシー マップの名前を指定します。

ステップ 4

class { class-name | class-default }

 
Router(config-pmap)# class classcos0

サービス ポリシーに組み込まれている定義済みクラスの名前を指定します。

ステップ 5

shape average cir [bc] [be]

 

Router(config-pmap-c)# shape average 10000000

平均速度またはピーク速度のトラフィック シェーピングを指定します。

ステップ 6

bandwidth remaining ratio ratio

 
Router(config-pmap-c)# bandwidth remaining ratio 2

クラス レベルまたはサブインターフェイス レベルのキューの BRR を指定します。この BRR は、プライオリティ トラフィックによって使用されていない余分な帯域幅を判断し、非プライオリティ キューに割り当てるために輻輳時に使用します。

(注) BRR の値は 1 ~ 1000 です。

ステップ 7

service-policy policy-map

 
Router(config-pmap-c)# service-policy cust2-classes

ポリシー マップをクラスに結合します。

次の設定では、3 つのサービス インスタンスの出力で 3 つのポリシー マップが適用されます。gold、silver、bronze のサービス インスタンスが全クォータの 300、300、および 100 Mbps のプライオリティ トラフィックを送信する場合、PRP/サービス伝播がオンであるため、リンク帯域幅の残り(1 Gbps ~ 700 Mbps)300 Mbps は 1 : 2 : 3 の比率でユーザ間で共有されます。各ユーザが取得する帯域幅は次のとおりです。

ユーザ A:1 / (1+2+3) * 300 Mbps = 非 LLQ トラフィック 50 Mbps

ユーザ B:2 / (1+2+3) * 300 Mbps = 非 LLQ トラフィック 100 Mbps

ユーザ C:3 / (1+2+3) * 300 Mbps = 非 LLQ トラフィック 150 Mbps

Router# enable
Router# configure terminal
Router(config)# policy-map data_gold_child_out
Router(config-pmap)# class video
Router(config-pmap-c)# priority
Router(config-pmap-c)# police 300000000
Router(config-pmap-c)# set cos 4
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 300000000
Router(config-pmap-c)# set cos 3
 
Router(config)# policy-map data_gold_parent_out
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 500000000
Router(config-pmap-c)# bandwidth remaining ratio 3
Router(config-pmap-c)# service-policy data_gold_child_out
 
Router(config)# policy-map data_silver_child_out
Router(config-pmap)# class video
Router(config-pmap-c)# priority
Router(config-pmap-c)# police 300000000
Router(config-pmap-c)# set cos 4
Router(config-pmap)# class gaming
Router(config-pmap-c)# bandwidth remaining ratio 2
Router(config-pmap-c)# set cos 2
Router(config-pmap)# class class-default
Router(config-pmap-c)# bandwidth remaining ratio 1
Router(config-pmap-c)# set cos 1
 
Router(config)# policy-map data_silver_parent_out
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 500000000
Router(config-pmap-c)# bandwidth remaining ratio 2
Router(config-pmap-c)# service-policy data_silver_child_out
 
Router(config)# policy-map data_bronze_child_out
Router(config-pmap)# class video
Router(config-pmap-c)# priority
Router(config-pmap-c)# police 100000000
Router(config-pmap-c)# set cos 4
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 300000000
Router(config-pmap-c)# set cos 1
 
Router(config)# policy-map data_bronze_parent_out
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 500000000
Router(config-pmap-c)# bandwidth remaining ratio 1
Router(config-pmap-c)# service-policy data_bronze_child_out
 
 

Cisco 7600 シリーズ ES+ ラインカードにおける PFC QoS の設定

Cisco 7600 シリーズ ES+ ラインカードでは、Cisco 7600 シリーズ ルータの PFC によってサポートされるものと同じ QoS 機能の多くがサポートされます。

ここでは、Cisco 7600 シリーズ ES+ ラインカード固有の設定時の注意事項がある QoS 機能について説明します。このマニュアルに記載された Cisco 7600 シリーズ ES+ ラインカード固有の注意事項を検討してから、次の URL にある『Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SR』を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/ios/12.2SR/configuration/guide/qos.html

Cisco 7600 シリーズ ES+ ラインカードにおける PFC QoS の設定時の注意事項

Cisco 7600 シリーズ ES+ ラインカードでは、入力 Cos-to-Exp マーキングの場合に限り、SVI インターフェイスの PFC QoS がサポートされます。

HQoS の設定

Cisco 7600 シリーズ ES+ ラインカードでは、Cisco MQC を使用して設定する HQoS がサポートされます。次の HQoS 機能がサポートされます。

4 レベルの HQoS(2 レベルのポリシー マップは、メイン インターフェイスに結合している場合は 3 レベルの階層、サブインターフェイスに結合している場合は 4 レベルの階層)

精密な QoS:ポリシングおよびシェーピング、64 Kbps のデータ レート

カラー ブラインド ポリシング:2 レート 3 カラー ポリサーおよび 1 レート 2 カラー ポリサー


) カラー認識ポリシングはサポートされません。


入力および出力分類

イーサネットのサブインターフェイス/スイッチ ポート QoS

出力 CBWFQ

LLQ(入力および出力)

IP/MPLS およびレイヤ 2 CoS 分類の出力 HQoS

Any Transport over MPLS(AToM)QoS 機能

階層型ポリシング

入力シェーピング

スケーリング

128,000 のキュー

16,000 のトラフィック シェーパー

Trident あたり 48,000 のポリサー

出力の Trident あたり 8,000 の HQoS ポリシー マップ (20xGE および 40xGE ポート ラインカードでは、Trident の最初の 5 つのポートで最大 4,000 の HQoS ポリシー マップを適用できます。同様に Trident の次の 5 つのポートでも最大 4,000 のポリシー マップを適用でき、出力では Trident あたり 4000 + 4000 = 8000 の HQoS ポリシー マップになります)。入力では、Trident のポート 10 個に最大 3,904 の HQoS ポリシー マップを適用できます。出力とは異なり、5 ポートごとの入力に対する制限はありません。

IOS 階層レベルは次のように表されます。現在、最大 5 レベルまでサポートされています。

物理またはメイン インターフェイス

サブインターフェイスまたは論理レイヤ

親の親クラス

親クラス

子クラス

2 レベルのポリシー マップには、メイン インターフェイスに結合している場合は 3 レベルの階層、サブインターフェイスに結合している場合は 4 レベルの階層があります。

3 レベルのポリシー マップには、メイン インターフェイスに結合している場合は 4 レベルの階層、サブインターフェイスに結合している場合は 5 レベルの階層があります。

入力では、3 レベルの HQoS がサポートされます(ポート、親、子)。

表 7-5 に、サポートされる HQoS 機能を示します。

 

表 7-5 HQoS 機能のサポート

インターフェイス タイプ
マーキング
ポリシング
シェーピング
帯域幅
プライオリティとプライオリティの割合(%)
プライオリティとポリシング
WRED

メイン レイヤ 3 インターフェイス

CoS、prec/dscp、EXP

あり

あり

あり

なし

あり

あり

レイヤ 3 サブインターフェイス

CoS、prec/dscp、EXP

あり

あり

あり

なし

あり

あり

サービス インスタンス

外部 CoS、prec/dscp、内部 CoS

あり

あり

あり

なし

あり

あり

SVI インターフェイス

EARL マーキング

EARL ポリシング

なし

なし

なし

なし

なし

スイッチポート インターフェイス

外部 CoS

あり

あり

あり

なし

あり

あり

ポート チャネル サービス インスタンス

外部 CoS、内部 CoS

あり

あり

あり

なし

あり

あり

ポート チャネル レイヤ 3 メンバーリンク

CoS、prec/dscp、EXP

あり

あり

あり

なし

あり

あり

 

次の例では、クラスごとに異なる割合の帯域幅を割り当てる子ポリシーを設定します。

!
Router# enable
Router# configure terminal
Router(config)# policy-map child
Router(config-pmap)# class User-A
Router(config-pmap-c)# bandwidth percent 40
Router(config-pmap-c)# exit
Router(config-pmap)# class User-B
Router(config-pmap-c)# bandwidth percent 60
Router(config-pmap-c)# exit
Router(config-pmap)# exit
!

次の例では、出力サブインターフェイスに親サービス ポリシーを適用します。

!
Router# enable
Router# configure terminal
Router(config)# interface TenGigabitEthernet 2/1.1
Router(config-if-srv)# encapsulation dot1q 11
Router(config-if)# service-policy output parent
 

次の例は、メイン インターフェイスに 2 レベル HQoS ポリシーを設定する方法を示しています。

Router(config)# policy-map child_1
Router(config-pmap)# class prec1
Router(config-pmap-c)# priority level 1
Router(config-pmap)# class prec2
Router(config-pmap-c)# priority level 52
Router(config-pmap)# class class-default
Router(config-pmap-c)# Police 100kbps
!
Router(config)# policy-map HQoS_parent
Router(config-pmap)# class class-default
outer(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# service-policy child_1

 

次の例は、EVC インターフェイスに 2 レベル HQoS ポリシーを設定する方法を示しています。

Router(config)# policy-map child_1
Router(config-pmap)# class cos1
Router(config-pmap-c)# priority level 1
Router(config-pmap)# class cos 2
Router(config-pmap-c)# priority 2
Router(config-pmap)# class class-default
Router(config-pmap-c)# Police 100kbps
!
Router(config)# policy-map HQoS_parent
Router(config-pmap)# class class-default
outer(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# service-policy child_1

 

次の例では、メイン インターフェイスに入力 3 レベル HQoS ポリシーを設定します。

Router(config)# policy-map child_1
Router(config-pmap)# class prec123
Router(config-pmap-c)# random-detect precedence based
Router(config-pmap)# class prec456
Router(config-pmap-c)# shape average 10M
Router(config-pmap)# class class-default
!
Router(config)# policy-map HQoS_parent
Router(config-pmap)# class ACL_c1
Router(config-pmap-c)# Police 100kbps
Router(config-pmap-c)# priority 1
Router(config-pmap-c)# service policy child_1
Router(config-pmap)# class ACL_c2
Router(config-pmap-c)# Police 100kbps
Router(config-pmap-c)# priority level 2
Router(config-pmap-c)# service policy child_2
Router(config-pmap)# class class-default
Router(config-pmap-c)# Police 100kbps
Router(config-pmap-c)# service policy child_3
!
Router(config)# policy-map HQos_grandparent
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape 100000000
Router(config-pmap-c)# service-policy HQoS_parent
 

次の例では、メイン インターフェイスに出力 3 レベル HQoS ポリシーを設定します。

Router(config)# policy-map child_1
Router(config-pmap)# class prec123
Router(config-pmap-c)# random-detect precedence based
Router(config-pmap)# class prec456
Router(config-pmap-c)# shape average 10M
Router(config-pmap)# class class-default
!
Router(config)# policy-map HQoS_parent
Router(config-pmap)# class ACL_c1
Router(config-pmap-c)# Police 100kbps
Router(config-pmap-c)# priority level 1
Router(config-pmap-c)# service policy child_1
Router(config-pmap)# class ACL_c2
Router(config-pmap-c)# Police 100kbps
Router(config-pmap-c)# priority level 2
Router(config-pmap-c)# service policy child_2
Router(config-pmap)# class class-default
Router(config-pmap-c)# service policy child_3
!
Router(config)# policy-map HQos_grandparent
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape 100000000
Router(config-pmap-c)# service-policy HQoS_parent
!

Ethernet Virtual Connection Service(EVCS)QoS サポート

Ethernet Virtual Connection Service(EVCS)では、サービス インスタンスおよび EVC(イーサネット仮想回線)の概念が使用されます。サービス インスタンスは、特定ルータの特定ポートにおける EVC のインスタンスです。EVC は、プロバイダーがお客様に提供しているレイヤ 2 サービスの単一インスタンスのエンドツーエンド表現です。さまざまなパラメータが統合されて、サービスが提供されます。

EVC QoS は次の EVC の組み合わせで動作します。

シングル タグ

ダブル タグ

シングル タグからシングル タグ

シングル タグからダブル タグ

ダブル タグからシングル タグ

ダブル タグからダブル タグ

シングル タグ終端

ダブル タグ終端

1 対 1 タグ変換

EVC QoS を設定する方法については、次のセクションを参照してサービス インスタンスおよびポート チャネル サービス インスタンスの処理方法を確認してください。

「分類の設定」

「ポリシングの設定」

「マーキングの設定」

「シェーピングの設定」

「QoS キュー スケジューリングの設定」

「HQoS の設定」

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードにおいて EVCS で QoS を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

サービス インスタンスは MQC を使用します。

QoS では 16,000 のサービス インスタンスがサポートされます。

HQoS では 2,000 までのポリシーがサポートされます。

入力 QoS では HQoS およびフラットのポリシー マップがサポートされます。

入力シェーピングがサポートされます。

出力 QoS では、階層型およびフラットのポリシー マップがサポートされます。

サービス インスタンスの作成前に、すべてのポリシー マップをメイン インターフェイスで削除してください。

親ポリシーには任意のポリシー マップが存在できます。

メンバーリンクがあるポート チャネル サービス インスタンスで QoS を適用すると、ルータは ES+ ラインカードに対する QoS の互換性を検証します。ただし、ポート チャネル サービス インスタンスにメンバーリンクがない場合に QoS ポリシー マップを適用すると、ルータは ES+ ラインカードの機能を引き受けて、ポリシー マップを結合できます。

ポート チャネルに設定されたサービス インスタンスの場合

ポート チャネルのメンバーリンクは複数のラインカードに設定できますが、ラインカードは同じタイプである必要があります。たとえば、同じポート チャネルに ESM20 と ES+ のメンバーリンクを設定することはできません。

入力 QoS はマーキングおよびポリシングに制限されています。

入力キューイングはサポートされません。

bandwidth percent および police percent コマンドは、フラット ポリシー マップ、または HQoS ポリシー マップの親ではサポートされません。子ポリシー マップではサポートされます。

5 分間のロード インターバルを推奨します(30 秒間のロード インターバルはレートの変動が大きくなる原因になります)。

BRR はポート チャネル サービス インスタンスでサポートされます。

EVC 設定例

次の例は、スケーラブル EoMPLS での入力 QoS を示しています。

Router# enable
Router# configure terminal
Router(config)# interface GE 1/2
Router(config-if)# service instance 1 ethernet
Router(config-if-srv)# encapsulation dot1q 100
Router(config-if-srv)# rewrite ingress tag pop 1 symmetric
Router(config-if)# xconnect 2.2.2.2 100 pw-class vlan-xconnect
Router(config-pmap-c)# service-policy input mark-it-in
Router(config)# policy-map mark-it-in
Router(config-pmap)# class cos0
Router(config-pmap-c)# police
Router(config-pmap-c)# set mpls exp imposition 5

 

次に示すシングル タグ VLAN 設定の例では、カプセル化 dot1q 10 がすでに分類されているので、内部 VLAN および CoS 値だけが設定されます。

Router# enable
Router# configure terminal
Router(config)# interface GE 1/2
Router(config-if)# service instance 1
Router(config-if-srv)# encapsulation dot1q 10 second-dot1q any
Router(config-if-srv)# rewrite ingress tag pop 1 symmetric
Router(config-if-srv)# bridge domain 200
Router(config-pmap-c)# service-policy input mark-it-in
Router(config)# policy-map mark-it-in
Router(config-pmap)# class innervlan20
Router(config-pmap-c)# police 100000000
Router(config-pmap-c)# set cos 0
Router(config-pmap-c)# set cos-inner 0
 

以下は、シングル タグ VLAN 接続入力ポリシーの例です。

Router# enable
Router# configure terminal
Router(config)# interface GigabitEthernet1/1
Router(config-if)# service instance 100 ethernet
Router(config-if-srv)# encapsulation dot1q 10 second-dot1q any
Router(config-if-srv)# rewrite ingress tag pop 1 symmetric
Router(config-pmap-c)# service-policy in mark-it-in
Router(config)# interface GigabitEthernet 1/2
Router(config-if)# service instance 101 ethernet
Router(config-if-srv)# encapsulation dot1q 11 second-dot1q any
Router(config-if-srv)# rewrite ingress tag pop 1 symmetric
Router(config-pmap-c)# service-policy in mark-it-in
Router(config-if-srv)# connect EVC1 GigabitEthernet 1/1 100 GigabitEthernet 1/2 101
Router(config)# policy-map mark-it-in
Router(config-pmap)# class vlaninner20cosinner5
Router(config-pmap-c)# set cos 0
 

以下は、出力ダブル タグ VLAN 接続の階層型設定の例です。

Router# enable
Router# configure terminal
Router(config)# interface GigabitEthernet 1/1
Router(config-if)# service instance 100 ethernet
Router(config-if-srv)# encapsulation dot1q 10 second-dot1q 20
Router(config-if-srv)# rewrite ingress tag pop 2 symmetric
Router(config-pmap-c)# service-policy out parent-out-100
Router(config)# interface GigabitEthernet 1/2
Router(config-if)# service instance 101 ethernet
Router(config-if-srv)# encapsulation dot1q 11 second-dot1q 21
Router(config-if-srv)# rewrite ingress tag pop 2 symmetric
Router(config-pmap-c)# service-policy out parent-out-101
Router(config-if-srv)# connect EVC1 GigabitEthernet 1/1 100 GigabitEthernet 1/2 101
Router(config)# policy-map child-out-100
Router(config-pmap)# class cos5
Router(config-pmap-c)# bandwidth percent 10
Router(config-pmap-c)# set cos 0
Router(config-pmap-c)# set cos-inner 0
Router(config)# policy-map parent-out-100
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 10000000
Router(config-pmap-c)# service-policy child-out-100
Router(config)# policy-map child-out-101
Router(config-pmap)# class cos0
Router(config-pmap-c)# bandwidth percent 10
Router(config-pmap-c)# set cos 5
Router(config-pmap-c)# set cos-inner 5
Router(config)# policy-map parent-out-101
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 10000000
Router(config-pmap-c)# service-policy child-out-101
 

以下は、出力ダブル タグ VLAN 接続のフラット設定の例です。

Router# enable
Router# configure terminal
Router(config)# policy-map flat-100
Router(config-pmap)# class cos5
Router(config-pmap-c)# shape average 10000000
Router(config-pmap-c)# set cos 0
Router(config-pmap-c)# set cos-inner 0
Router(config-pmap)# class class-default <-- required class
Router(config-pmap-c)# shape average 10000000 <-- required queuing action
Router(config-pmap-c)# set cos 6
Router(config)# policy-map flat-101
Router(config-pmap)# class cos0
Router(config-pmap-c)# shape average 10000000
Router(config-pmap-c)# set cos 5
Router(config-pmap-c)# set cos-inner 5
Router(config-pmap)# class class-default <-- required class
Router(config-pmap-c)# shape average 10000000 <-- required queuing action
Router(config-pmap-c)# set cos 4
 
 

ポート チャネル メンバーリンクの QoS

ポート チャネル メンバーリンクの QoS 機能は、次のサービス ポリシーをサポートします。

ポートごとのキューイングが設定されたポート チャネル レイヤ 3 メンバーリンク(出力のみ)

ポリシー マップがポート チャネル メイン インターフェイスに結合している場合は、メンバーリンクの入出力トラフィックにポート チャネル メイン インターフェイスの QoS を適用する必要があります。ポリシー マップがメンバーリンク インターフェイスに結合している場合は、そのメンバーリンクの入出力トラフィックに、ポート チャネルで設定されている EVC/サブインターフェイスに結合している QoS またはメンバーリンクに結合している QoS のいずれかを適用する必要があります。

サポートされる出力 QoS の設定

表 7-6 に、入力および出力でサポートされる QoS の設定を示します。

表 7-6 サポートされる QoS の設定

QoS の設定
説明

ポート チャネル サブインターフェイスに結合しているポリシー マップ(入力のみ)

マーキングはポート チャネル サブインターフェイスでサポートされます。

ポリシングはポート チャネル サブ インターフェイスでサポートされます(各 Trident ごとの集約ポリシング)。

キューイングはポート チャネル サブインターフェイスではサポートされません。

ポート チャネル レイヤ 3 メンバーリンクに結合しているポリシー マップ、かつポート チャネル サブインターフェイス(入力のみ)またはポート チャネル サービス インスタンスに設定されていない QoS

レイヤ 3 ポート チャネルのレイヤ 3 分類。

ポート チャネル レイヤ 3 メンバーを通過するすべてのトラフィックには、チャネル レイヤ 3 メンバーリンクに結合しているポリシー マップが適用されます。

ポート チャネル レイヤ 3 メンバーリンクに結合しているポリシー マップ、かつポート チャネル サブインターフェイス(入力のみ)に設定されている QoS

ポート チャネル サブインターフェイスのポリシー マップは、そのサブインターフェイスのトラフィック用にポート チャネル レイヤ 3 メンバーリンクに設定されているポリシー マップより優先されます。

ポート チャネル レイヤ 3 メンバーリンクに結合しているポリシー マップ、かつポート チャネル サービス インスタンスに設定されている QoS

ポート チャネル サービス インスタンスを通過するトラフィックには、ポート チャネル サービス インスタンスに結合しているポリシー マップが適用されます。

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードにポート チャネル メンバーリンクの QoS 機能を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

cos-inner のマッチングはサポートされません。

ポート チャネル サブインターフェイスまたはポート チャネル サービス インスタンスに属するトラフィックは、そのポート チャネル サブインターフェイスまたはポート チャネル サービス インスタンスに直接結合しているポリシーがない場合に限り、メンバーリンク ポリシーを通過します。

ポート チャネル サブインターフェイスまたはポート チャネル サービス インスタンスに独自のポリシーがある場合は、そのポート チャネル サブインターフェイスまたはポート チャネル サービス インスタンスに適用されるポリシーがトラフィックに適用されます。

ポート チャネル メイン インターフェイスまたはポート チャネル サブインターフェイスにマイクロフロー ポリシング ポリシーが設定されている場合は、入力にメンバーリンク ポリシーを設定することは推奨できません。メンバーリンク ポリシーおよびマイクロフロー ポリシング ポリシーが共存している場合は、最初に Trident のメンバーリンク ポリシー、次に PFC のマイクロフロー ポリシング ポリシーの両方のポリシーがトラフィックに適用されます。

親にユーザ定義クラスのあるレイヤ 3 ポート チャネル メンバーリンクを設定すると、キューイング階層が追加されます。メンバーリンク ポリシーはインターフェイス帯域幅の半分を使用し、残りのポリシー(ポート チャネル サービス インスタンス ポリシー)はインターフェイス帯域幅の残りの半分を使用します。

ポート チャネル サービス インスタンスの帯域幅を保護し、保証するために、メンバーリンク ポリシーには、ポート チャネル サービス インスタンス以外のトラフィックに与えられる最大インターフェイス帯域幅を制限するために、シェーピングが設定された親の親 class-default が必要です(メンバーリンク ポリシーの親レベルに複数のクラスがある場合)。

ポート チャネル メンバーリンクの QoS の設定例

次の例は、ルータのポート チャネル レイヤ 3 メンバーリンクでサービス ポリシーを設定する方法を示します。

Router# enable
Router# configure terminal
Router(config)# interface Port-channel 1
Router(config-if)# ip address
Router(config-if)# mpls ip
 
Router(config)# interface gi1/0
Router(config-if)# channel-group 1
Router(config-if)# service-policy output port-qos
 
Router(config)# interface gi1/1
Router(config-if)# channel-group 1
Router(config-if)# service-policy output port-qos
 

次の例では、BRR が指定されています。

Router# enable
Router# configure terminal
Router(config)# policy-map port-qos
Router(config-pmap)# class cos0 >>>match on cos 0
Router(config-pmap-c)# police cir 100000000
Router(config-pmap-c)# priority
Router(config-pmap)# class cos1
Router(config-pmap-c)# bandwidth remaining ratio 2
Router(config-pmap)# class class-default
Router(config-pmap-c)# bandwidth remaining ratio 1

 

以下に、レイヤ 3 サービス ポリシーの例を 4 つ示します。

Router# enable
Router# configure terminal
Router(config)# policy-map port-qos
Router(config-pmap)# class prec1 >>>match on ip prec 1
Router(config-pmap-c)# police cir 100000000
Router(config-pmap-c)# priority
Router(config-pmap)# class prec2
Router(config-pmap-c)# bandwidth 100000
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# random-detect aggregate
Router(config-pmap-c)# random-detect precedence values 3 minimum-thresh 40 maximum-thresh 60 mark-prob 1
Router(config-pmap-c)# random-detect precedence values 4 minimum-thresh 70 maximum-thresh 90 mark-prob 1
Router(config-pmap-c)# random-detect precedence values 5 minimum-thresh 100 maximum-thresh 120 mark-prob 1

 

Router# enable
Router# configure terminal
Router(config)# policy-map port-qos
Router(config-pmap)# class exp1 >>>match on exp 1
Router(config-pmap-c)# police cir 100000000
Router(config-pmap-c)# priority
Router(config-pmap)# class exp2
Router(config-pmap-c)# bandwidth 100000
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000

 

Router# enable
Router# configure terminal
Router(config)# policy-map port-qos
Router(config-pmap)# class ip-exp1 >>>match on ip prec1, or exp 1
Router(config-pmap-c)# police cir 100000000
Router(config-pmap-c)# priority
Router(config-pmap)# class ip-exp22
Router(config-pmap-c)# bandwidth 100000
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000

 

Router# enable
Router# configure terminal
Router(config)# policy-map port-qos
Router(config-pmap)# class exp1 >>>match on exp 1
Router(config-pmap-c)# police cir 100000000
Router(config-pmap-c)# priority
Router(config-pmap)# class exp2
Router(config-pmap-c)# bandwidth remaining ratio 5
Router(config-pmap)# class class-default
Router(config-pmap-c)# bandwidth remaining ratio 2

 

次の例は、メンバーリンクで設定できるフラット サービス ポリシーを示しています。

Router# enable
Router# configure terminal
Router(config)# policy-map port-qos
Router(config-pmap)# class vlan11 >>>match on vlan 11
Router(config-pmap-c)# police cir 100000000
Router(config-pmap-c)# priority
Router(config-pmap)# class vlan12
Router(config-pmap-c)# bandwidth 100000
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000

 

次の例は、メンバーリンクで設定できる HQoS ポリシーを示しています。

Router# enable
Router# configure terminal
Router(config)# policy-map child
Router(config-pmap)# class prec0 >>>match on prec 0
Router(config-pmap-c)# police cir 100000000
Router(config-pmap-c)# priority
Router(config-pmap)# class prec1
Router(config-pmap-c)# bandwidth 100000
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000

 

Router(config)# policy-map parent
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 300000000
Router(config-pmap-c)# shape average 300000000
Router(config-if)# service-policy child

) 上記の例では、親レベルで他のクラスは定義されていません。


Router# enable
Router# configure terminal
Router(config)# policy-map child
Router(config-pmap)# class cos0 >>>match on cos 0
Router(config-pmap-c)# police cir 100000000
Router(config-pmap-c)# priority
Router(config-pmap)# class cos1
Router(config-pmap-c)# bandwidth 100000
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000
 
Router(config)# policy-map parent
Router(config-pmap)# class vlan11
Router(config-pmap-c)# shape average 300000000
Router(config-if)# service-policy child
Router(config-pmap)# class vlan12
Router(config-pmap-c)# shape average 300000000
Router(config-if)# service-policy child
Router(config-pmap)# class class-default

 

次の例は、さまざまなインターフェイス上のサービス ポリシーの組み合わせを示しています。

最初の例は、ポート チャネル メンバーリンクに結合している出力サービス ポリシーを示しています。ポート チャネル サービス インスタンスにサービス ポリシーはありません。

Router# enable
Router# configure terminal
Router(config)# interface Port-channel 1
Router(config-if)# ip address
Router(config-if)# service instance 1 ethernet
Router(config-if-srv)# encapsulation dot1q 100
Router(config-if-srv)# bridge-domain 200
Router(config-if)# service instance 2 ethernet
Router(config-if-srv)# encapsulation dot1q 101
Router(config-if-srv)# bridge-domain 200
 
interface gi1/0
Router(config-if)# channel-group 1
Router(config-if)# service-policy output port-qos
Router(config)# interface gi1/1
Router(config-if)# channel-group 1
Router(config-if)# service-policy output port-qos

 

次の例では、出力サービス ポリシーはポート チャネル メンバーリンクに結合しています。出力および入力サービス ポリシーはポート チャネル サービス インスタンスで適用されます。

Router# enable
Router# configure terminal
Router(config)# interface Port-channel 1
Router(config-if)# ip address
Router(config-if)# service instance 1 ethernet
Router(config-if-srv)# encapsulation dot1q 100
Router(config-if-srv)# bridge-domain 200
Router(config-if)# service-policy output evc-egress
Router(config-if)# service-policy input evc-ingress
Router(config-if)# service instance 2 ethernet
Router(config-if-srv)# encapsulation dot1q 101
Router(config-if-srv)# bridge-domain 200
Router(config-if)# service-policy output evc-egress
Router(config-if)# service-policy input evc-ingress
 
Router(config)# interface gi1/0
Router(config-if)# channel-group 1
Router(config-if)# service-policy output port-qos
Router(config)# interface gi1/1
Router(config-if)# channel-group 1
Router(config-if)# service-policy output port-qos

 

次の例では、出力サービス ポリシーはポート チャネル メンバーリンクに結合しています。出力および入力サービス ポリシーはポート チャネル サービス インスタンスで適用されます。入力サービス ポリシーはポート チャネル サブインターフェイスで適用されます。

Router# enable
Router# configure terminal
Router(config)# interface Port-channel 1
Router(config-if)# ip address
Router(config-if)# service instance 1 ethernet
Router(config-if-srv)# encapsulation dot1q 100
Router(config-if-srv)# bridge-domain 200
Router(config-if)# service-policy output evc-egress
Router(config-if)# service-policy input evc-ingress
Router(config-if)# service instance 2 ethernet
Router(config-if-srv)# encapsulation dot1q 101
Router(config-if-srv)# bridge-domain 200
Router(config-if)# service-policy output evc-egress
Router(config-if)# service-policy input evc-ingress

 

Router(config)# interface Port-channel 1.1
Router(config-if-srv)# encapsulation dot1q 1000
Router(config-if)# service-policy input subint-ingress
 
Router(config)# interface gi1/0
Router(config-if)# channel-group 1
Router(config-if)# service-policy output port-qos
Router(config)# interface gi1/1
Router(config-if)# channel-group 1
Router(config-if)# service-policy output port-qos
 

IPv6 - ホップバイホップ(HBH)レート リミッタ

IPv6 Hop-by-Hop(HBH; ホップバイホップ)Extension Header(EH; 拡張ヘッダー)は、IPv6 プロトコルの正式仕様(RFC 2460)に記載されています。この EH はヘッダー タイプ 0 によって識別され、存在する場合は常にメイン ヘッダーに続く最初の EH です。ノードは HBH EH を持つ受信パケットを処理しなければならないため、HBH ヘッダーが含まれるパケットの転送はセキュリティの脅威になり、またセキュリティの脅威として使用されることがあります。

IPv6 - HBH レート リミッタ機能は、IPv6 HBH パケットのレートを制限して Denial of Service(DoS; サービス拒絶)攻撃から保護します。

制約事項および使用上のガイドライン

Cisco 7600 シリーズ ES+ ラインカードにおいて IPv6 HBH パケットのレートを制限する場合は、次の制約事項および使用上のガイドラインに従ってください。

次のスーパーバイザ エンジンでサポートされます。

Route Switch Processor 720-1GE

Route Switch Processor 720-10GE

Supervisor Engine 32

Supervisor Engine 720

ポリシング レートを 0 に設定すると、ポリシングはオフになります。

ポリシング レートを設定すると、Cisco IOS Release 12.2(33)SRD1 以降を実行する別のシャーシにラインカードが移動されても、設定はラインカードに残ります。

HBH EH を持つ IPv6 パケットは、Cisco 7600 シリーズ ES+ ラインカードで設定された他の QoS をバイパスします。

IPv6 - HBH レート リミッタの設定

test platform police set コマンドまたは test platform police get コマンドを実行するために特定のラインカードに接続するには、特権 EXEC モードで attach コマンドを使用します。

次に、ラインカード コンソールから特権 EXEC モードで test platform police set コマンドを使用すると、IPv6 内部ポリシング レートを設定できます。

手順概要

1. attach module-number

2. enable

3. test platform police set rate

4. test platform police set

詳細手順

 

コマンド
目的

ステップ 1

attach module-number

 

Router# attach 9

ラインカードに接続します。

ステップ 1

enable

 
Router-dfc3# enable

特権 EXEC モードをイネーブルにします。

パスワードを要求されたら入力します。

ステップ 2

test platform police set rate

 

Router-dfc3# test platform police ipv6 set 1234

IPv6 内部ポリシング レートを設定します。

ステップ 3

test platform police get

 

Router-dfc3# test platform police ipv6 get

IPv6 内部ポリシング レートを取得します。

次の例は、レートの設定方法を示しています。

Console# attach 3

Trying Switch ...

Entering CONSOLE for Switch

Type "^C^C^C" to end this session

osr3-dfc3#

Router-dfc3# enable

Router-dfc3# test platform police ipv6 set 1234

ラインカード コンソールから特権 EXEC モードで test platform police get コマンドを使用すると、IPv6 内部ポリシング レートを取得できます。

Router-dfc3# test platform police ipv6 get

IPv6 with HBH header is policed at 100000 kbps