Cisco 7600 シリーズ ルータ セッション ボーダ コン トローラ コンフィギュレーション ガイド
SBC 冗長性の実装 - ハイ アベイラビリティ
SBC 冗長性の実装 - ハイ アベイラビリティ
発行日;2012/01/30 | 英語版ドキュメント(2011/12/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

SBC 冗長性の実装 - ハイ アベイラビリティ

この章の構成

前提条件 - 冗長性の実装

ACE モジュールへの冗長性の実装

冗長性の設定例

SBC 冗長性の実装 - ハイ アベイラビリティ

Cisco 7600 シリーズ ルータ上の Session Border Controller(SBC; セッション ボーダ コントローラ)は、シャーシ間およびシャーシ内での冗長性をサポートしています。同じ Cisco 7600 シリーズ ルータまたは別のシャーシに最大 2 つの SBC サービスを設定して、冗長性を確保できます。

SBC の耐障害性の冗長性は、1:1 ペアの保護モデルに基づいています。SBC とともに稼動しているアクティブなサービス カードごとに、障害から保護するサービス カード(スタンバイ カード)をもう 1 枚追加する必要があります。両方のカードで同じサービスをプロビジョニングする必要があります(一方がプライマリ カード、他方がスタンバイ カード)。この場合、これらのサービス カードは「ペア」になります。

Cisco IOS システムからは、サービス カードは常にアクティブ モードで稼動しているように見えます。ただし、これらのカードで稼動している SBC サービスは、プライマリ サービスまたはスタンバイ サービスのいずれかとして稼動します。

分散モデルでは、Data Border Element(DBE; データ ボーダ エレメント)サービスは別の Cisco Data Center Operation System(DCOS)プロセスとして稼動します(SBE ごとに 1 つ以上の分散 DBE が存在することがあります)。DBE サービスがこのモードで稼動している場合は、同じ物理デバイス内のさまざまなカードに DBE サービスをプロビジョニングして、使用可能なサービス カード間で処理の負荷を分散できます。


) ACE SBC Release 2.0.00 では、DBE サービスだけが実装されます。



) ACE SBC Release 3.0.00 では、この機能は統合モデルと分散モデルの両方でサポートされます。


アクティブな SBC は状態をスタンバイに複製して、ホット スタンバイ サポートを実現します。この SBC プロセスは Media Packet Forwarder(MPF)コンポーネントと共有されます。一方のコンポーネントが再起動されると、他方のコンポーネントも再起動されます。


) この章で使用されるコマンドの詳細については、次の URL にある『Application Control Engine Module Command Reference』を参照してください。
http://www.cisco.com/en/US/products/hw/modules/ps2706/products_command_reference_book09186a0080685244.html


SBC 冗長性の実装機能の履歴

 

リリース
変更内容

ACE SBC Release 3.1.00

シャーシ内冗長性のサポートが追加されました。

ACE SBC Release 3.0.00

SBC 統合モデルのサポートが追加されました。

ACE SBC Release 2.0.00

この機能は、DBE 用に Cisco 7600 シリーズ ルータに追加されました。

この章の構成

この章で説明する内容は、次のとおりです。

「前提条件 - 冗長性の実装」

「ACE モジュールへの冗長性の実装」

「冗長性の設定例」

前提条件 - 冗長性の実装

次に、SBC 冗長性を実装するための前提条件を示します。

Application Control Engine(ACE)モジュールで SBC コマンドを入力するには、Admin ユーザである必要があります。詳細については、次の URL にある『Application Control Engine Module Administration Guide』を参照してください。
http://www.cisco.com/en/US/products/hw/modules/ps2706/products_configuration_guide_book09186a00806838f4.html

SBC サービスを設定する前に、耐障害性(冗長性)設定を作成しておく必要があります。 第 2 章「SBC の ACE を設定するための前提条件」 に記載された手順に従ってください。

SBC の耐障害性は、1:1 ペアの保護モデルに基づいています。アクティブな SBC コンポーネントが稼動している ACE モジュールごとに、ACE モジュールを 1 つ追加して、障害から保護できます。両方の ACE モジュールで同じサービスをプロビジョニングする必要があるため(一方がプライマリ カード、他方がスタンバイ カード)、これらの ACE モジュールはペアになります。Cisco IOS システムからは、ACE モジュールは常にアクティブ モードで稼動しているように見えますが、これらのカード上で稼動している SBC サービスはプライマリ サービスまたはスタンバイ サービスとして稼動しています。

ACE モジュールへの冗長性の実装

ACE SBC Release 3.0.00 では、Fault Tolerant(FT; 耐障害性)グループ 1 は常に Admin コンテキストに関連付けられています。


) すべての FT グループのプライオリティは同じである必要があります。



) VRF には、コンテキストごとに FT グループが 1 つあります。



) 最大 2 つの ACE アプライアンス(ピア)を設定して、冗長性を確保できます。各ピア アプライアンスには、1 つ以上の耐障害性(FT)グループを含めることができます。各 FT グループは、2 つのメンバーで構成されています。アクティブ コンテキストと、スタンバイ コンテキストです。FT グループには、一意のグループ ID を割り当てます。

1 つの Virtual MAC(VMAC; 仮想 MAC)アドレスが各 FT グループに関連付けられており、FT グループが設定されているコンテキストにあるすべての VLAN 上で、すべてのエイリアス アドレスの VMAC アドレスとして使用されます。VMAC のフォーマットは、00-0b-fc-fe-1b-groupID です。VMAC は切り替え時に変更されないため、クライアントおよびサーバの ARP テーブルは更新する必要がありません。MAC の重複という問題を回避するため、同じサブネットに接続されている ACE カードの各ペアでは一意の FT グループ ID を使用する必要があります。


ACE モジュールに冗長性を設定する方法については、次の URL にある『 Configuring Redundant ACE Modules 』を参照してください。
http://www.cisco.com/en/US/products/hw/modules/ps2706/products_configuration_guide_chapter09186a0080683a15.html


) 現在のリリースでは、ハートビート インターバルとカウント番号が両方とも固定され、ユーザは変更できません。


冗長性の設定例

次に、SBC 冗長性の設定例を示します。

 
On the supervisor
Svclc mod 3 vlan-group 10 !!! create vlan group 10
Svclc vlan-group 10 50,60,70 !!! bind vlan 50, 60 and 70 in same vlan gr 10
Svclc multiple-vlan-interfaces
 
 
On ACE location 1
(On Admin context)
 
interface vlan 60 !!! config vlan and alias
ip address 60.60.60.60 255.255.255.0
alias 60.60.60.62 255.255.255.0
peer ip address 60.60.60.61 255.255.255.0
no shutdown
 
ft interface vlan 50 !!! config vlan 50
ip addr ip addr 50.50.50.50 255.255.255.0
peer ip addr 50.50.50.51 255.255.255.0
no shut
ft peer 1 !!! config peer 1
heartbeat interval 300
heartbeat count 10
ft-interface vlan 20
query-interface vlan 60
 
ft group 1 !!! config ft group 1
peer 1
associate-context Admin
priority 100
peer priority 200
inservice
 
On ACE location 2
(On Admin context)
 
interface vlan 60 !!! config vlan and alias
ip address 60.60.60.61 255.255.255.0
alias 60.60.60.62 255.255.255.0
peer ip address 60.60.60.60 255.255.255.0
no shutdown
 
 
ft interface vlan 50 !!! config vlan 50
ip addr 50.50.50.51 255.255.255.0 ! peer ip address in location 1
peer ip addr 50.50.50.50 255.255.255.0 ! ip address in location 1
no shut
 
ft peer 1 !!! config peer 1
heartbeat interval 300
heartbeat count 10
ft-interface vlan 20
query-interface vlan 60
 
ft group 1
peer 1
associate-context Admin
priority 200
peer priority 100
inservice