Cisco 7600 シリーズ ルータ セッション ボーダ コン トローラ コンフィギュレーション ガイド
SBC の ACE を設定するための前提条件
SBC の ACE を設定するための前提条件
発行日;2012/01/30 | 英語版ドキュメント(2010/04/20 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

SBC の ACE を設定するための前提条件

制約事項および使用上の注意事項

の初期設定

スーパーバイザ上の ACE 用 VLAN およびインターフェイスの設定

へのセッション インおよびログイン

への名前の割り当て

ACE インフラストラクチャの設定

Admin コンテキスト用の VLAN インターフェイスの設定

FT VLAN インターフェイスの設定

FT ピアの設定

FT グループの設定

ACE への IP アドレスの割り当て

スタティック ルートの設定

ヘアピン スタティック ルートの注意事項

Telnet セッションを使用した へのアクセス

ACE 上の SBC イメージの Release 3.1.00 へのアップグレード

ACE 上の SBC イメージのアップグレード

冗長な ACE モジュールの SBC イメージのアップグレード

アクティブ SBC サービス カードとしての ACE ステータスの確認

追加情報

SBC の ACE を設定するための前提条件

Session Border Controller(SBC; セッション ボーダ コントローラ)アプリケーションは、Application Control Engine(ACE)モジュール(以後、ACE と表記)で稼動します。 ACE は、独自のソフトウェアを実行します。ACE の詳細および ACE ソフトウェア リリース ノートについては、
http://www.cisco.com/en/US/products/ps6906/tsd_products_support_model_home.html を参照してください

ACE は、SBC サービス カードとして機能するプライマリ ロールを保持しています。


) ACE モジュールで SBC イメージを実行した場合、SBC 機能だけがサポートされます。ACL 設定はサポートされません。


この章で説明する内容は、次のとおりです。

「制約事項および使用上の注意事項」

「ACE の初期設定」

「アクティブ SBC サービス カードとしての ACE ステータスの確認」

「追加情報」

SBC 設定の前提条件の実装機能の履歴

 

リリース
変更内容

Release 12.2(33)SRC

Route Switching Processor 720-1GE を使用した ACE20-SBC-K9 のサポートが追加されました。

Release 12.2(33)SRB1

スーパーバイザ エンジン 720 を使用した ACE20-SBC-K9 のサポートが追加されました。

制約事項および使用上の注意事項

Cisco 7600 シリーズ ルータに SBC を設定する場合は、次に示す制約事項および使用上の注意事項に従ってください。

ハードウェア:

サポート対象シャーシ:Cisco 7604、Cisco 7606、Cisco 7606-S、Cisco 7609-S、Cisco 7609、Cisco 7613

Cisco 7600 ルータの SBC 機能により、最大 9 つの ACE をサポートできます。

ACE と相互運用するすべての既存ライン カードがサポートされます。

ACE モジュールでサポートされるスーパーバイザ:720-3B、720-3BXL、RSP720-C、および RSP720-CXL

ソフトウェア:

10,000 個の同時接続

1 ms 未満の遅延およびジッタ

最大 VLAN 数:2000

最大共有 VLAN 数:100

最大 VPN 数:250

ACE の初期設定

SBC を設定するには、ACE を設定して次のタスクを実行する必要があります。

Cisco 7600 シリーズ ルータのスーパーバイザ エンジンから ACE へのトラフィック送信

ネットワーク接続許可

Telnet によるリモート管理

ここでは、次のタスクの手順について説明します。

「スーパーバイザ上の ACE 用 VLAN およびインターフェイスの設定」

「ACEへのセッション インおよびログイン」

「ACE への名前の割り当て」

「ACE インフラストラクチャの設定」

「スタティック ルートの設定」

「Telnet セッションを使用した ACE へのアクセス」

「ACE 上の SBC イメージのアップグレード」

スーパーバイザ上の ACE 用 VLAN およびインターフェイスの設定

ACE が Cisco 7600 シリーズ ルータのスーパーバイザ エンジンからトラフィックを受信するには、スーパーバイザ エンジンに VLAN グループを作成し、ACE に割り当てておく必要があります。ACE のスーパーバイザ エンジンに VLAN グループを設定したら、ACE に VLAN インターフェイスを設定してください。

Cisco IOS ソフトウェアで、VLAN グループを 1 つまたは複数作成してから、ACE に割り当てることができます。たとえば、すべての VLAN を特定のグループに割り当てたり、顧客ごとにグループを 1 つ作成したりできます。

複数のグループに同じ VLAN を割り当てることはできませんが、複数のグループを特定の ACE に割り当てることはできます。たとえば、複数の ACE に VLAN を割り当てる場合、各 ACE に対して一意の VLAN とは別のグループを別途作成し、この中に目的の VLAN を格納できます。


) 作業を開始する前に、ネットワーク管理者に問い合せて、ACE で使用できる VLAN およびアドレスを判別してください。


Cisco IOS ソフトウェアを使用して ACE 用の VLAN を設定する手順は、次のとおりです。

1. スーパーバイザ エンジンに接続して、セッションを開きます。たとえば、次のように Telnet を使用して、IP アドレスが 172.19.110.5 のスーパーバイザに接続します。

linux$ telnet 172.19.110.5
User Access Verification
 
Password: cisco
Router#
 

2. SBC ルートの VLAN を作成します。

Router# config
Router(config)# vlan 87
Router(config)# vlan 23
Router(config)# vlan 99

) SBC VRF ルートの VLAN は任意で、Fault Tolerance(FT; 耐障害性)の VLAN は(スタンドアロンの場合も含めて)必須です。


3. スーパーバイザに FT 用の VLAN インターフェイスを作成します。

Router(config)# interface vlan23
Router(config)# ip address 23.23.23.1 255.255.255.0
!
 

4. スーパーバイザにシグナリングおよびメディア アドレス用の VLAN インターフェイスを作成します。

Router(config)# interface vlan87
Router(config)# ip address 88.103.29.1 255.255.255.0
!
Router(config)# interface vlan99
Router(config)# ip address 88.103.33.1 255.255.255.0
 

5. コンフィギュレーション モードで svclc vlan-group group_number vlan_range コマンドを使用して、ACE モジュール用の VLAN グループを作成します。

Router# config
Router(config)# svclc vlan-group 23 23
Router(config)# svclc vlan-group 200 87, 99
 

ACE モジュールごとに複数のシグナリング VLAN を使用する場合は、次のように設定する必要があります。

Router(config)# svclc multiple-vlan-interfaces
 

6. svc module slot_number vlan-group group_number_range コマンドを使用して、ACE に VLAN グループを割り当てます。

Router(config)# svclc module 3 vlan-group 23,200
Router(config)# svclc module 4 vlan-group 23,200
 

7. show svclc vlan-group コマンドを使用して、ACE のグループ設定および対応する VLAN を表示します。

Router(config)# exit
Router# show svclc vlan-group
 

8. show svc module コマンドを使用して、すべてのモジュールの VLAN グループ番号を表示します。

Router# show svclc module

ACEへのセッション インおよびログイン

ACE にはスーパーバイザ エンジンから次の 2 つの方法でアクセスできます。

Telnet セッションを使用します。Telnet セッションを使用して ACE にアクセスする方法の詳細については、「Telnet セッションを使用した ACE へのアクセス」を参照してください。

セッション コマンドを使用します。以下を参照してください。

ACE に最初にセッション インしてログインする手順は、次のとおりです。

1. スーパーバイザ エンジンから session コマンドを使用して、スーパーバイザ エンジンから ACE にセッション インします。たとえば、スロット 5 に搭載された ACE にセッション インするには、次のコマンドを入力します。

Router# session slot 5 processor 0
 

2. ログイン プロンプトでログイン ユーザ名およびパスワードを入力して、ACE にログインします。デフォルトでは、ユーザ名およびパスワードは admin です。

router login: admin
Password: admin
 

次のプロンプトが表示されたら、ACE Command Line Interface(CLI; コマンドライン インターフェイス)を使用できます。

switch/Admin#
 

デフォルトのログイン ユーザ名およびパスワードを変更するには、『 Cisco Application Control Engine Module Administration Guide 』を参照してください。

3. この現行セッションのタイムアウトを防止するには、 terminal session-timeout コマンドを使用し、タイムアウトを 0 に設定します。デフォルトでは、非アクティブ期間が 5 分を超えると、ACE 上のセッションは自動的にログアウトします。

switch/Admin# terminal session-timeout 0
 

4. コンフィギュレーション モードで login timeout コマンドを使用して、ACE に再びログインした場合に、非アクティブ時のタイムアウトをディセーブルにします。次に例を示します。

a. Exec モードで configure コマンドを使用して、コンフィギュレーション モードを開始します。

switch/Admin# configure
Enter configuration commands, one per line. End with CNTL/Z
switch/Admin(config)#
 

b. login timeout コマンドでタイムアウトを 0 に設定して、非アクティブ タイマーをディセーブルにします。

switch/Admin(config)# login timeout 0

ACE への名前の割り当て

コマンドライン プロンプトおよびデフォルト設定のファイル名には、ホスト名が使用されます。複数のデバイスとのセッションを確立する場合、ホスト名を使用すると、入力したコマンドの場所がわかりやすくなります。デフォルトでは、ACE のホスト名は switch です。

ACE のホスト名を変更するには、 host コマンドを使用します。大文字と小文字の区別がある、1 ~ 32 文字の英数字からなる名前を入力します。たとえば、ACE のホスト名を switch から host1 に変更するには、次のコマンドを入力します。

switch/Admin(config)# hostname host1
 

プロンプトに、新しいホスト名が表示されます。

host1/Admin(config)#

ACE インフラストラクチャの設定

ACE インフラストラクチャの設定は、次のアクティビティで構成されています。

「Admin コンテキスト用の VLAN インターフェイスの設定」

「FT VLAN インターフェイスの設定」

「FT ピアの設定」

「FT グループの設定」

「ACE への IP アドレスの割り当て」

Admin コンテキスト用の VLAN インターフェイスの設定

ACE で、Admin コンテキスト用の VLAN インターフェイスを設定する必要があります。

1. interface vlan コマンドを使用して、管理コンテキスト用のインターフェイスを設定します。

host1/Admin(config)# interface vlan 87
 

2. ip address コマンドを使用して、クライアントと接続する VLAN インターフェイスに IP アドレスを割り当てます。

host1/Admin(config-if)# ip address 88.103.29.2 255.255.255.0
 

3. alias コマンドを使用して、VLAN インターフェイスのアクティブ モジュールとスタンバイ モジュール間の IP アドレスを設定します。

host1/Admin(config-if)# alias 88.103.29.100 255.255.255.0
 

4. インターフェイス VLAN 用のスタンバイ ACE の IP アドレスを設定します。

host1/Admin(config-if)# peer ip address 88.103.29.3 255.255.255.0
 

5. no shutdown コマンドを使用して、インターフェイスをイネーブルにします。

host1/Admin(config-if)# no shutdown
 

6. interface vlan コマンドを使用して、管理コンテキスト用の VLAN インターフェイスを設定します。

host1/Admin(config)# interface vlan 99
 

7. ip address コマンドを使用して、クライアントと接続する VLAN インターフェイスに IP アドレスを割り当てます。

host1/Admin(config-if)# ip address 88.103.33.2 255.255.255.0
 

8. alias コマンドを使用して、VLAN インターフェイスのアクティブ モジュールとスタンバイ モジュール間の IP アドレスを設定します。

host1/Admin(config-if)# alias 88.103.33.100 255.255.255.0
 

9. VLAN インターフェイス用のスタンバイ ACE の IP アドレスを設定します。

host1/Admin(config-if)# peer ip address 88.103.33.3 255.255.255.0
 

10. no shutdown コマンドを使用して、インターフェイスをイネーブルにします。

host1/admin(config-if)# no shutdown
 

FT VLAN インターフェイスの設定

FT VLAN インターフェイスの設定は、スタンドアロン設定の場合も含めて必須です。手順は次のとおりです。

1. ft interface vlan コマンドを使用して、2 つの冗長なピアが通信する専用の耐障害性(FT)VLAN を作成します。

host1/Admin(config)# ft interface vlan 23
 

2. ip address コマンドを使用して、クライアントと接続する VLAN インターフェイスに IP アドレスを割り当てます。

host1/Admin(config)# ip address 23.23.23.10 255.255.255.0
 

3. peer ip address コマンドを使用して、VLAN インターフェイスにスタンバイ モジュールの IP アドレスを設定します。

host1/Admin(config)# peer ip address 23.23.23.11 255.255.255.0
 

4. no shutdown コマンドを使用して、インターフェイスをイネーブルにします。

host1/Admin(config)# no shutdown
 

注意 FT VLAN インターフェイスを変更するときは、次の手順を実行します。
1. SBC を削除します。
2. FT グループを削除します。
3. FT ピアを削除します。
4. FT VLAN を変更します。
4. FT ピアを再度追加します。
5. グループを再度追加します。
6. SBC を再度追加します。

FT ピアの設定

FT ピアを設定する手順は、次のとおりです。


) ハートビート カウントのデフォルト値は 300、ハートビート インターバルのデフォルト値は 10 です。どの値も設定しないと、デフォルトでこれらの値が設定されます。


1. ft peer コマンドを使用して、FT ピアを作成し、FT ピア コンフィギュレーション モードを開始します。

host1/Admin(config)# ft peer 1
 

2. heartbeat コマンドを使用して、ハートビート インターバルを設定します。

host1/Admin(config-ft-peer)# heartbeat interval 300
 

3. heartbeat コマンドを使用して、ハートビート インターバルを設定します。

host1/Admin(config-ft-peer)# heartbeat count 10
 

4. ft-interface vlan コマンドを使用して、既存の FT VLAN をピアに関連付けます。

host1/Admin(config)# ft-interface vlan 23
 

FT グループの設定


) SBC アプリケーションの性質により、シャーシ内またはシャーシ間 HA モードでは、プリエンプションはサポートされません。


FT グループを設定する手順は、次のとおりです。

1. ft group コマンドを使用して、FT グループを作成し、FT グループ コンフィギュレーション モードにアクセスします。

host1/Admin(config)# ft group 1
 

2. peer コマンドを使用して、ピア ACE を FT グループに関連付けます。

host1/Admin(config-ft-group)# peer 1
 

3. priority コマンドを使用して、アクティブなグループ メンバーのプライオリティを設定します。

host1/Admin(config-ft-group)# priority 127
 

4. peer priority コマンドを使用して、リモート スタンバイ メンバー上の FT グループのプライオリティを設定します。

host1/Admin(config-ft-group)# peer priority 126
 

5. associate-context コマンドを使用して、FT グループにコンテキストを関連付けます。

host1/Admin(config-ft-group)# associate-context Admin
 

6. inservice コマンドを使用して、FT グループをサービスに配置します。

host1/Admin(config-ft-group)# inservice
 

ACE への IP アドレスの割り当て

ACE に VLAN を割り当てたら、ネットワーク経由でクライアントと接続する ACE に、IP アドレスを割り当てます。


) ACE からサーバに要求を転送するには、クライアントに戻るルートを設定しておく必要があります。そうしないと、フローを確立できません。


Admin コンテキストの場合に、スーパーバイザ エンジンからダウンロードされた ACE VLAN を表示するには、Exec モードで show vlans コマンドを使用します。 show コマンドは Exec モードで使用できるため、 do コマンドを追加することにより、任意のコンフィギュレーション モードから使用できます。たとえば、次のように入力します。

host1/Admin(config)# do show vlans
Vlans configured on SUP for this module
vlan55-57 vlan100
 

ACE に VLAN インターフェイスを設定し、インターフェイス モードを開始して、インターフェイス アトリビュートを設定する手順は、次のとおりです。

1. interface vlan コマンドを使用して、VLAN のインターフェイス コンフィギュレーション モードを開始します。たとえば、インターフェイス VLAN 87 を作成するには、次のコマンドを入力します。

host1/Admin(config)# interface vlan 87
host1/Admin(config-if)#
 

2. ip address コマンドを使用して、クライアントと接続する VLAN インターフェイスに IP アドレスを割り当てます。たとえば、ACE に IP アドレス 88.103.29.2 255.255.255.0 を設定するには、次のコマンドを入力します。

host1/Admin(config-if)# ip address 88.103.29.2 255.255.255.0
 

3. alias コマンドを使用して、VLAN のアクティブ モジュールとスタンバイ モジュール間の IP アドレスを設定します(スタンドアロン設定の場合、この手順は必須です)。たとえば、ACE にエイリアスの IP アドレスおよびマスクとして 88.103.29.100 255.255.255.0 を設定するには、次のコマンドを入力します。

host1/Admin(config-if)# alias 88.103.29.100 255.255.255.0

) Cisco 7600 シリーズ ルータの SBC では、この処理が必須です。エイリアス IP アドレスは制御アドレスと一致する必要があります。


4. peer ip address コマンドを使用して、VLAN インターフェイスにスタンバイ モジュールの IP アドレスを設定します(スタンドアロン設定の場合、この手順は必須です)。たとえば、ACE にピア モジュールの IP アドレスおよびマスクとして 88.103.29.3 255.255.255.02 を設定するには、次のコマンドを入力します。

host1/Admin(config-if)# peer ip address 88.103.29.3 255.255.255.0

) Cisco 7600 シリーズ ルータの SBC では、この処理が必須です。エイリアス IP アドレスは制御アドレスと一致する必要があります。


5. description コマンドを使用して、インターフェイスの説明を入力します。

host1/Admin(config-if)# description Client side connectivity
 

6. no shutdown コマンドを使用して、インターフェイスをイネーブルにします。

host1/admin(config-if)# no shutdown
 

7. show interface コマンドを使用して、VLAN 87 が起動していることを確認します。

host1/admin(config-if)# do show interface vlan 87
 

8. ping コマンドを使用して、ネットワーク接続を確認します。

host1/admin(config-if)# do ping 88.103.29.1
 

9. show arp コマンドを使用して、ARP テーブルを表示します。

host1/admin(config-if)# do show arp
 

10. exit コマンドを使用して、コンフィギュレーション モードを再開します。

host1/admin(config-if)# exit
host1/admin(config)#
 

11. ACE ルーティング テーブルを表示するには、 show ip route コマンドを使用します。

host1/Admin(config)# do show ip route

スタティック ルートの設定

スタティック ルートには IP アドレスを指定し、ACE はこのアドレスにリモート ピア シグナリング アドレスおよびリモート メディア アドレス宛の IP パケットを送信します。スタティック ルートを設定するには、 ip route dest_ip_prefix netmask gateway_ip_address コマンドを使用します。

リモート ピア シグナリング アドレスには、スタティック ルートが必要です。


) 隣接の設定の詳細については、第 3 章「SBC コンフィギュレーション」を参照してください。


adjacency sip Access
signaling-address ipv4 88.103.29.100
remote-address ipv4 200.200.200.0 255.255.255.0
signaling-peer 200.200.200.118
attach
adjacency sip Core
signaling-address ipv4 88.103.33.100
remote-address ipv4 200.200.201.0 255.255.255.0
signaling-peer 200.200.201.118
attach
 

たとえば、上記のリモート ピア シグナリング アドレスのスタティック ルートを作成するには、次のように入力します。

host1/Admin(config)# ip route 200.200.200.0 255.255.255.0 88.103.29.1
host1/Admin(config)# ip route 200.200.201.0 255.255.255.0 88.103.33.1
 

また、SIP プロキシの場合には、追加の(ヘアピン)スタティック ルートが必要です。


) ヘアピン スタティック ルートは、/32 ビット マスクである必要があります(完全修飾)。集約ルートまたはデフォルト ルートは使用しないでください。


host1/Admin(config)# ip route 88.103.29.100 255.255.255.255 88.103.29.1

host1/Admin(config)# ip route 88.103.33.100 255.255.255.255 88.103.33.1


) フォワーディング アドレスは、スーパーバイザ上の VLAN インターフェイスの IP アドレスにすることができます。


リモート メディア アドレスには、スタティック ルートが必要です。

dbe
media-address ipv4 22.22.179.10
activate
 

たとえば、上記のリモート メディア アドレスのスタティック ルートを作成するには、次のように入力します。

host1/Admin(config)# ip route 203.101.0.0 255.255.0.0 22.22.179.1

host1/Admin(config)# ip route 203.102.0.0 255.255.0.0 22.22.179.1


) メディア アドレス ルートは、ローカル メディア アドレスおよびリモート メディア アドレスがシグナリング アドレスと同じサブネット上にある場合には必要ありません。


ヘアピン スタティック ルートの注意事項

ヘアピンとは、ACE 上の SBC から Cisco 7600 シリーズ ルータ上のスーパーバイザを経由して、ACE 上の SBC にループバックする IP トラフィックのことです。ヘアピン スタティック ルートについては、次の注意事項に従ってください。

メディア アドレスがシグナリング エイリアス アドレスと同じ場合は、次のようにします。

スーパーバイザ側のアドレス(通常は VLAN スーパーバイザ アドレス)を指す ACE にスタティック ルートを追加します。

メディア アドレスがシグナリング エイリアス アドレスと異なる場合は、次のようにします。

スーパーバイザ側のアドレス(通常は VLAN スーパーバイザ アドレス)を指す ACE にスタティック ルートを追加します。

ACE VLAN エイリアス アドレスを指すスーパーバイザにスタティック ルートを追加します。

次に示すように、ACE への VLAN インターフェイス上にある ICMP リダイレクトをディセーブルにします。

host1/Admin(config)# interface vlan340
host1/Admin(config-if)# no ip redirects

Telnet セッションを使用した ACE へのアクセス

ここでは、次の設定を使用して Telnet セッション経由で、ACE にアクセスする方法について説明します。

スーパーバイザ設定:

svclc multiple-vlan-interfaces
svclc vlan-group 24 24
svclc module 3 vlan-group 23,24,200
svclc module 4 vlan-group 23,24,200
!
interface Vlan24
ip address 2.4.48.25 255.255.0.0
end
 
 
interface GigabitEthernet1/48
switchport
switchport access vlan 24
switchport mode access
no cdp enable
end
 

ACE 設定:

interface vlan 24
ip address 2.4.48.3 255.255.0.0
alias 2.4.48.10 255.255.0.0
peer ip address 2.4.48.4 255.255.0.0
no shutdown
 

スーパーバイザおよび ACE の設定を完了したら、IP アドレスを使用して、Telnet 経由で ACE にアクセスできます。Telnet を使用して ACE にアクセスする手順は、次のとおりです。

1. スーパーバイザ エンジンに接続して、別のセッションを開きます。たとえば、次のように入力します。

linux$ telnet 2.4.48.25
Trying 2.4.48.25...
Connected to 2.4.48.25.
Escape character is '^]
Router#
 

2. Telnet を使用して、ACE インターフェイスにアクセスできることを確認します。たとえば、VLAN IP アドレス 2.4.48.10 から ACE にアクセスするには、次のコマンドを入力します。

linux% telnet 2.4.48.10
Trying 2.4.48.10...
Connected to 2.4.48.10.
Escape character is '^]'.
 

(または、telnet 127.0.0.x0 と入力します。x はスロット番号です。)

3. プロンプトで、ACE にログインします。ログイン ユーザ名に admin 、パスワードに admin を入力します。

host1 login: admin
Password:
Cisco Application Control Software (Session Border Controller)
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2007, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
host1/Admin#
 

4. show telnet コマンドを使用して、Telnet セッションを表示します。

host1/Admin# show telnet

ACE 上の SBC イメージの Release 3.1.00 へのアップグレード

Release 3.1.0 へのアップグレードは、あとで示すアップグレード手順とは大きく異なります。Release 3.1.00 へのアップグレードの詳細については、 付録 D「Release 3.1.00 へのアップグレード」 を参照してください。

ACE 上の SBC イメージのアップグレード


) Cisco IOS Release 12.2(33)SRD とともにスーパーバイザ エンジンを実行した場合、イメージをそのシャーシ内の ACE モジュールにコピーしようとすると、TFTP がタイムアウトします。ACE モジュールは SBC イメージを実行中であり、ROMMON から eobc とともに起動できますが、起動後は RSP720-3C-10GE から ACE に至る TFTP イメージを直接には使用できません。これは、内部 VRF(iVRF)セキュリティ機能がイネーブルになっているためです(デフォルトの動作)。この問題を回避するには、platform ivrf disable コマンドを使用して、iVRF をディセーブルにすることを推奨します。no platform ivrf disable コマンドを実行すると、このデフォルトの動作がリセットされます。show platform ivrf コマンドを使用すると、現在のステータスを表示できます。



) TFTP は、スーパーバイザからだけ実行できます。


ACE モジュールに新しい SBC イメージをインストールするには、そのイメージを ACE モジュールにコピーし、ACE モジュールをリロードする必要があります。

1. スーパーバイザ エンジンのローカル ディスクに SBC イメージをコピーします。

host1/Admin# copy tftp://172.69.17.19/tftpboot/user/c76-sbck9-mzg.3.0.1_AS1_1.bin disk1:
Destination filename [c76-sbck9-mzg.3.0.1_AS1_1.bin]?
Accessing tftp://172.69.17.19/tftpboot/user/c76-sbck9-mzg.3.0.1_AS1_1.bin...
Loading tftpboot/user/c76-sbck9-mzg.3.0.1_AS1_1.bin from 172.69.1.129 (via Vlan109): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 32184696 bytes]
 
32184696 bytes copied in 167.276 secs (192405 bytes/sec)
 

2. スーパーバイザ エンジンから ACE モジュール上の SBC イメージ パーティション(/mnt/cf)に SBC イメージをコピーします。宛先 IP アドレスは 127.0.0.x0 となります。x はスロット番号です。次の例では、スロット 13 内の ACE モジュールにイメージをコピーするため、IP アドレスは 127.0.0.130 となります。

host1/Admin# copy disk1:c76-sbck9-mzg.3.0.1_AS1_1.bin tftp://127.0.0.130/mnt/cf/
Address or name of remote host [127.0.0.130]?
Destination filename [mnt/cf/c76-sbck9-mzg.3.0.1_AS1_1.bin]?
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
32184696 bytes copied in 48.996 secs (656884 bytes/sec)
 

3. 新しい SBC イメージが ACE モジュールにあるため、その新しいイメージから自動起動するように ACE モジュールを設定する必要があります。

host1/Admin# config t
Enter configuration commands, one per line. End with CNTL/Z.
host1/Admin(config)# boot system image:c76-sbck9-mzg.3.0.1_AS1_1.bin
host1/Admin(config)# config-register 1
host1/Admin(config)# end

 

4. show bootvar コマンドを使用して、ACE モジュールが新しいイメージから自動起動することを確認します。

host1/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS1_1.bin"
Configuration register is 0x1
 

5. ACE カードをリロードして、新しい SBC イメージを起動します。

host1/Admin# reload
This command will reboot the system
Save configurations for all the contexts. Save? [yes/no]: [yes]
Generating configuration....
running config of context Admin saved
Perform system reload. [yes/no]: [yes]
BC7613_13/Admin#
Unmounting ext3 filesystems...
Unmounting FAT filesystems...
Unmounting done...
 
System Bootstrap, Version 12.2[120],
Copyright (c) 1994-2006 by Cisco Systems, Inc.
Slot D : Running DEFAULT rommon image ...
 
ACE platform with 1048576 Kbytes of main memory
 
Loading disk0:c76-sbck9-mzg.3.0.1_AS1_1.bin. Please wait ....
Uncompressing Linux...
Starting the kernel...

 

冗長な ACE モジュールの SBC イメージのアップグレード


) Cisco IOS Release 12.2(33)SRD とともにスーパーバイザ エンジンを実行した場合、イメージをそのシャーシ内の ACE モジュールにコピーしようとすると、TFTP がタイムアウトします。ACE モジュールは SBC イメージを実行中であり、ROMMON から eobc とともに起動できますが、起動後は RSP720-3C-10GE から ACE に至る TFTP イメージを直接には使用できません。これは、内部 VRF(iVRF)セキュリティ機能がイネーブルになっているためです(デフォルトの動作)。この問題を回避するには、platform ivrf disable コマンドを使用して、iVRF をディセーブルにすることを推奨します。no platform ivrf disable コマンドを実行すると、このデフォルトの動作がリセットされます。show platform ivrf コマンドを使用すると、現在のステータスを表示できます。



) TFTP は、スーパーバイザからだけ実行できます。


サービスに影響を与えることなく、ACE モジュールの冗長なペアの SBC イメージをアップグレードするには、ACE 上の SBC イメージのアップグレードと同じような方法を使用します。この手順では、イメージ 3.0.0 からイメージ 3.0.1 にアップグレードします。

1. スーパーバイザ エンジンのローカル ディスクに SBC イメージをコピーします。

SUP720# copy tftp://172.69.17.19/tftpboot/user/c76-sbck9-mzg.3.0.1_AS3_0_01.bin
disk1:
Destination filename [c76-sbck9-mzg.3.0.1_AS3_0_01.bin]?
Accessing tftp://172.69.17.19/tftpboot/user/c76-sbck9-mzg.3.0.1_AS3_0_01.bin...
Loading tftpboot/user/c76-sbck9-mzg.3.0.1_AS3_0_01.bin from 172.69.1.129 (via
Vlan109):
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 32184696 bytes]
32184696 bytes copied in 167.276 secs (192405 bytes/sec)
 

2. スーパーバイザ エンジンからスタンバイ ACE モジュール上の SBC イメージ パーティション(/mnt/cf)に SBC イメージをコピーします。宛先 IP アドレスは 127.0.0.x0 となります。x はスロット番号です。次の例では、スロット 13 内の ACE モジュールにイメージをコピーするため、IP アドレスは 127.0.0.130 となります。

SUP720# copy disk1:c76-sbck9-mzg.3.0.1_AS3_0_01.bin tftp://127.0.0.130/mnt/cf/
Address or name of remote host [127.0.0.130]?
Destination filename [mnt/cf/c76-sbck9-mzg.3.0.1_AS3_0_01.bin]?
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
32184696 bytes copied in 48.996 secs (656884 bytes/sec)
 

3. スーパーバイザ エンジンからアクティブ ACE モジュール上の SBC イメージ パーティション(/mnt/cf)に SBC イメージをコピーします。宛先 IP アドレスは 127.0.0.x0 となります。x はスロット番号です。次の例では、スロット 12 内の ACE モジュールにイメージをコピーするため、IP アドレスは 127.0.0.120 となります。

SUP720# copy disk1:c76-sbck9-mzg.3.0.1_AS3_0_01.bin tftp://127.0.0.120/mnt/cf/
Address or name of remote host [127.0.0.120]?
Destination filename [mnt/cf/c76-sbck9-mzg.3.0.1_AS3_0_01.bin]?
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
32184696 bytes copied in 48.996 secs (656884 bytes/sec)
 

4. bootvar の古いソフトウェア エントリを削除します。3.0.1 エントリを bootvar に追加します。次に、3.0.0 エントリをアクティブ カード_A 上の bootvar に追加して、スタンバイ カード_B に同期させます (これにより、新しいイメージを優先イメージとして、古いイメージをバックアップとして、シーケンス bootvar が作成されます)。

card_A/Admin# show ft group brief
 
FT Group ID: 1 My State:FSM_FT_STATE_ACTIVE Peer State:FSM_FT_STATE_STANDBY_HOT
Context Name: Admin Context Id: 0
 
card_A/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
...
 
card_B/Admin# show ft group brief
 
FT Group ID: 1 My State:FSM_FT_STATE_STANDBY_HOT Peer State:FSM_FT_STATE_ACTIVE
Context Name: Admin Context Id: 0
 
card_B/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
...
 
card_A/Admin# conf t
Enter configuration commands, one per line. End with CNTL/Z.
card_A/Admin(config)# no boot system image:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
card_A/Admin(config)# boot system image:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
card_A/Admin(config)# boot system image:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
card_A/Admin(config)# config-register 1
card_A/Admin(config)# end
card_A/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin;disk0:c76-sbck9-mzg.3.0
.1_AS3_0_00.bin"
Configuration register is 0x1
 
card_B/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin;disk0:c76-sbck9-mzg.3.0
.1_AS3_0_00.bin"
Configuration register is 0x1
 

5. スタンバイ ACE カード_B にスタンバイをリロードします(reload コマンドはスタンバイ モードで許可されます)。

card_B/Admin# reload
This command will reboot the system
Save configurations for all the contexts. Save? [yes/no]: [yes]
Generating configuration....
running config of context Admin saved
Perform system reload. [yes/no]: [yes] y
card_B/Admin#
 
NOTE: Configuration mode is enabled on all sessions
 
Sending all processes the TERM signal...
card_B/Admin# Sending all processes the KILL signal...
Unmounting ext3 filesystems...
Unmounting FAT filesystems...
 
switch login: Unmounting done...
INIT: Sending processes the KILL signal
Rebooting... Rest
System Bootstrap, Version 12.2[121],
Copyright (c) 1994-2008 by cisco Systems, Inc.
Slot 13: Running DEFAULT rommon image ...
 
.ACE platform with 1048576 Kbytes of main memory
 
.Loading disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin. Please wait ....
 

a. 3.0.1 イメージが新しいイメージで起動できない場合は、bootvar にブート ソースとして定義されている以前のイメージがロードされます。カード_A 上の bootvar から新しいソフトウェア エントリを削除する必要があります。これは、スタンバイ カード_B に同期化されます。

 
card_A/Admin# show ft group brief
 
FT Group ID: 1 My State:FSM_FT_STATE_ACTIVE Peer State:FSM_FT_STATE_STANDBY_HOT
Context Name: Admin Context Id: 0
 
card_A/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
...
 
card_B/Admin# show ft group brief
 
FT Group ID: 1 My State:FSM_FT_STATE_STANDBY_HOT Peer State:FSM_FT_STATE_ACTIVE
Context Name: Admin Context Id: 0
 
card_B/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
...
 
card_A/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin;disk0:c76-sbck9-mzg.3.0
.1_AS3_0_00.bin"
Configuration register is 0x1
card_A/Admin# conf t
Enter configuration commands, one per line. End with CNTL/Z.
card_A/Admin(config)# no boot system image:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
card_A/Admin(config)# end
card_A/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin"
Configuration register is 0x1
 
card_B/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin"
Configuration register is 0x1

 

b. 3.0.1 イメージが起動したものの、有効に機能しない場合は、カード_A 上の bootvar から新しいソフトウェア エントリを削除し(これは、スタンバイ カード_B に同期化されます)、スタンバイ カード_B をリロードして、古いイメージにロールバックする必要があります。

 
card_A/Admin# show ft group brief
 
FT Group ID: 1 My State:FSM_FT_STATE_ACTIVE Peer State:FSM_FT_STATE_STANDBY_HOT
Context Name: Admin Context Id: 0
 
card_A/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
...
 
card_B/Admin# show ft group brief
 
FT Group ID: 1 My State:FSM_FT_STATE_STANDBY_HOT Peer State:FSM_FT_STATE_ACTIVE
Context Name: Admin Context Id: 0
 
card_B/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
...
 
card_A/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin;disk0:c76-sbck9-mzg.3.0
.1_AS3_0_00.bin"
Configuration register is 0x1
card_A/Admin# conf t
Enter configuration commands, one per line. End with CNTL/Z.
card_A/Admin(config)# no boot system image:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
card_A/Admin(config)# end
card_A/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin"
Configuration register is 0x1
 
card_B/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin"
Configuration register is 0x1
card_B/Admin# reload
This command will reboot the system
Save configurations for all the contexts. Save? [yes/no]: [yes]
Generating configuration....
running config of context Admin saved
Perform system reload. [yes/no]: [yes] y
 

c. 3.0.1 イメージが正常に起動した場合は、3.0.0 ソフトウェア エントリだけが bootvar に存在するようにアクティブ カード_A 上の bootvar から 3.0.1 エントリを削除して、この新しいイメージを搭載したカードに切り替える必要があります。これで、A から B に切り替えたあとも、A がスタンバイとして 3.0.0 イメージで起動するようになります(3.0.1 イメージ搭載のカード_A をロードするまでは、カード_B が 3.0.1 イメージ搭載のアクティブ カードとして機能します)。


) トラフィックが流れている場合は、スタンバイ カードをリロードしてからアクティブ カードにフェールオーバーするまでの間に、状態が同期化される時間を考慮に入れると、進行中のコールに対する影響が最小限に抑えられます。


card_A/Admin# show ft group brief
 
FT Group ID: 1 My State:FSM_FT_STATE_ACTIVE Peer State:FSM_FT_STATE_STANDBY_HOT
Context Name: Admin Context Id: 0
 
card_A/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
...
 
card_B/Admin# show ft group brief
 
FT Group ID: 1 My State:FSM_FT_STATE_STANDBY_HOT Peer State:FSM_FT_STATE_ACTIVE
Context Name: Admin Context Id: 0
 
card_B/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
...
 
card_A/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.devtest_18SEP08.bin;disk0:c76-sbck9-mzg.3.0
.1_AS3_0_00.bin"
Configuration register is 0x1
card_A/Admin# conf t
Enter configuration commands, one per line. End with CNTL/Z.
card_A/Admin(config)# no boot system image:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
card_A/Admin(config)# end
card_A/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin"
Configuration register is 0x1
card_A/Admin# ft switchover
This command will cause card to switchover (yes/no)? [no] y
 

6. 3.0.1 イメージがアクティブなイメージとして有効に機能している場合は、bootvar から 3.0.0 ソフトウェア エントリを削除し、新しいアクティブ カード_B に新しいソフトウェア エントリを追加する必要があります(これは、スタンバイ カード_A に同期化されます)。次に、スタンバイ カード_A をリロードする必要があります(スタンバイ カード_A は 3.0.1 イメージをロードします)。アップグレードは完了です。

 
card_B/Admin# show ft group brief
 
FT Group ID: 1 My State:FSM_FT_STATE_ACTIVE Peer State:FSM_FT_STATE_STANDBY_
HOT
Context Name: Admin Context Id: 0
 
card_B/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
...
 
card_A/Admin# show ft group bri
 
FT Group ID: 1 My State:FSM_FT_STATE_STANDBY_HOT Peer State:FSM_FT_STATE_
ACTIVE
Context Name: Admin Context Id: 0
 
card_A/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
...
 
card_B/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin"
Configuration register is 0x1
card_B/Admin# conf t
Enter configuration commands, one per line. End with CNTL/Z.
card_B/Admin(config)# no boot system image:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
card_B/Admin(config)# boot system image:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
card_B/Admin(config)# end
card_B/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin"
Configuration register is 0x1
 
card_A/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin"
Configuration register is 0x1
card_A/Admin# reload
This command will reboot the system
Save configurations for all the contexts. Save? [yes/no]: [yes]
Generating configuration....
running config of context Admin saved
Perform system reload. [yes/no]: [yes] y
card_A/Admin#
 
NOTE: Configuration mode is enabled on all sessions
 
Sending all processes the TERM signal...
card_B/Admin# Sending all processes the KILL signal...
Unmounting ext3 filesystems...
Unmounting FAT filesystems...
 
switch login: Unmounting done...
INIT: Sending processes the KILL signal
Rebooting... Rest
System Bootstrap, Version 12.2[121],
Copyright (c) 1994-2008 by cisco Systems, Inc.
Slot 12: Running DEFAULT rommon image ...
 
.ACE platform with 1048576 Kbytes of main memory
 
.Loading disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin. Please wait ....
 

a. 3.0.1 イメージがアクティブになったあとで問題が発生した場合は、3.0.0 イメージ搭載のカード_A がアクティブになるように、カード_B からカード_A への ft 切り替えを行う必要があります。カード_B はイメージ 3.0.0 でリロードされます。

 
card_B/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
...
 
card_A/Admin# show version
...
system image file: [LCP] disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin
...
 
card_B/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin"
Configuration register is 0x1
 
card_A/Admin# show bootvar
BOOT variable = "disk0:c76-sbck9-mzg.3.0.1_AS3_0_00.bin"
Configuration register is 0x1
 
card_B/Admin# ft switchover
This command will cause card to switchover (yes/no)? [no] y

アクティブ SBC サービス カードとしての ACE ステータスの確認

変換および設定された ACE で SBC サービスが適切に実行されているか確認するには、次のいずれかのコマンドを実行します。

show run sbc

show ft group detail

追加情報

ACE 搭載のスーパーバイザの設定の詳細については、次の URL にある ACE のコンフィギュレーション ガイドを参照してください。
http://www.cisco.com/en/US/products/ps6906/tsd_products_support_model_home.html