Cisco 7600 シリーズ ルータ セッション ボーダ コン トローラ コンフィギュレーション ガイド
セッション ボーダ コントローラ(SBC )トラ ンスコーディングの実装
セッション ボーダ コントローラ(SBC)トランスコーディングの実装
発行日;2012/01/30 | 英語版ドキュメント(2011/06/15 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

セッション ボーダ コントローラ(SBC)トランスコーディングの実装

この章の構成

トランスコーディングの実装の前提条件

トランスコーディングに関する情報

拒否後のトランスコーディング

コーデック フィルタリング

トランスコーディングの制約事項

拒否後のトランスコーディングの設定

コーデック フィルタリング トランスコーディングの設定

トランスコーディングの実装の設定例

検証

セッション ボーダ コントローラ(SBC)トランスコーディングの実装

トランスコーディングとは、あるコーデックで符号化されたメディア ストリームを別のコーデックで符号化されたメディア ストリームに変換するプロセスのことです。たとえば、Pulse Code Modulation u-law(PCMU; パルス符号変調 u-law)として符号化されたメディア ストリームを ITU-T G.726-32 として符号化されたものに変換する場合があります。

トランスコーディングのコンフィギュレーションを行う主な理由は、外付けのメディア トランスコーディング デバイスが自動的に検出されない場合に、これらのデバイスの機能を設定するためです。トランスコーダ機能のインバンド自動検出は現在サポートされていません。したがって、現行のすべてのリモート トランスコーディング デバイスとのすべての接続を設定する場合は、この手順を実行する必要があります。


) 上記の理由が該当しない場合は、トランスコーディングのコンフィギュレーションを省略できます。


メディア ゲートウェイには、コンフィギュレーションが提供されているかどうかに関係なく、接続が許可されます。コンフィギュレーションの誤りを避けるために、Data Border Element(DBE; データ ボーダ エレメント)ではない、トランスコーディングが設定されていないメディア ゲートウェイから着信接続を受信した場合は、Signaling Border Element(SBE; シグナリング ボーダ エレメント)によって警告がログに記録されます。


) ACE SBC Release 3.0.0 以降では、この機能は統合モデルに限りサポートされます。


この章で使用されているコマンドの詳細については、 第 39 章「Cisco セッション ボーダ コントローラ コマンド」 を参照してください。この章に記載されたその他のコマンドのマニュアルを特定するには、コマンド リファレンスのマスター インデックスを使用するか、またはオンラインで検索してください。

SBC トランスコーディングの実装機能の履歴

 

リリース
変更内容

ACE SBC Release 3.0.00

この機能は、SBC 統合モデルのサポートとともに Cisco 7600 シリーズ ルータに追加されました。

トランスコーディングの実装の前提条件

次に、SBC トランスコーディングを実装するための前提条件を示します。

Application Control Engine(ACE)モジュールで SBC コマンドを入力するには、Admin ユーザである必要があります。詳細については、次の URL にある『Application Control Engine Module Administration Guide』を参照してください。
http://www.cisco.com/en/US/products/hw/modules/ps2706/products_configuration_guide_book09186a00806838f4.html

トランスコーディングを実装する前に、SBC を作成しておく必要があります。 第 2 章「SBC の ACE を設定するための前提条件」 に記載された手順に従ってください。

単純なコールに必要な SBE および DBE のコンフィギュレーションがすべて設定されている必要があります。トランスコーディングのコンフィギュレーションは、これらのコンフィギュレーションのあとに行います。

トランスコーディングに関する情報

トランスコーディングとは、あるコーデックで符号化されたメディア ストリームを別のコーデックで符号化されたメディア ストリームに変換するプロセスのことです。たとえば、PCMU として符号化されたメディア ストリームを G.726-32 として符号化されたものに変換する場合があります。

トランスコーディングには専用の Digital Signal Processor(DSP; デジタル信号プロセッサ)ハードウェアが必要ですが、SBC 自体には用意されていません。Cisco MGX 8880 デバイスを 1 台使用して、1 つまたは複数の SBC にトランスコーディング機能を提供できます。

SBC では、次の 2 つのタイプのトランスコーディングがサポートされています。

「拒否後のトランスコーディング」

「コーデック フィルタリング」

拒否後のトランスコーディング

SBC は、コーデック間でトランスコーディングを必要としているコールに対してトンラスコーディング デバイスを自動的に使用できるようにします。ただし、Call Admission Control(CAC; コール アドミッション制御)ポリシー コンフィギュレーションでそのコールに対するトランスコーダ サービスの提供が除外されている場合を除きます。トランスコーディングを必要とするコールがセットアップされると、SBE は次の手順を実行します。

コール元のエンドポイントから最初のシグナリング要求を受信します。これをトリガーとして、SBE は着信 DBE および発信 DBE 上でコールの初期セットアップを実行します。次に、SBE は要求をコール先のエンドポイントに転送します。

コール先のエンドポイントから応答を受信します。この応答は、最初の要求に含まれているいずれのコーデックも受け入れ不可であることを示しています。応答は次のとおりです。

415:サポートされていないメディア タイプ(SIP)

488:受け入れ不可(SIP)

H.245 プロトコルの端末機能交換の手順で共通コーデックの識別に失敗する

これをトリガーとして、SBE はトランスコーダをコールに組み込みます。このコールは、着信 DBE と発信 DBE の間のメディア パス上に組み込まれます。新しい要求をコール先のエンドポイントに送信し、新しいコーデック タイプがトランスコーダで生成されたことを通知します。

そのあと、SBE は、コール先のエンドポイントで受け入れ可能なコーデックが見つかるまで、トランスコーダでサポートされるコーデックのリスト全体についてこの作業を繰り返す必要がある場合があります。コーデックが見つかると、コールが接続され、メディアの伝送が開始されます。

図 14-1 に、ネットワーク内でのトランスコーダの配置、およびトランスコーディングされたコール内でメディアがたどるパスを示します。

図 14-1 トランスコーディングのコンフィギュレーション

 


図 14-1 には 2 つの DBE が示されていますが、トランスコーディングは 1 つの DBE で可能です。1 つの DBE の場合、メディアは DBE を 2 回通過します。1 回めは送信元のエンドポイントからトランスコーダまでの経路を、2 回めはトランスコーダから受信側のエンドポイントまでの経路を通過します。


セッション ボーダ コントローラ(SBC)でトランスコーダをプログラムするには、トランスコーダを登録する必要があります。トランスコーディング デバイスは H.248 メディア ゲートウェイとして動作するため、接続先の SBE または SBC の IP アドレスおよびポートを設定する必要があります。SBE または SBC は、H.248 メディア ゲートウェイ コントローラとして動作します (設定方法については、トランスコーダ デバイスのマニュアルを参照してください。Cisco MGX 8880 のマニュアルの場合は、 http://www.cisco.com/en/US/products/hw/gatecont/ps3869/products_configuration_guide_book09186a0080535937.html にアクセスしてください)。

また、SBE には次の専用の設定が必要です。

H.248 の制御アドレスおよびポートを設定する必要があります( sbe control address ipv4 コマンドと sbe control address h248 port コマンドを使用)。デフォルトでは、これはポート 2944 で、トランスコーダの接続先のアドレスとポートになります。

メディア ゲートウェイを明示的に設定する必要があります( sbe media-gateway ipv4 コマンドを使用)。明示的に設定したメディア ゲートウェイには、トランスコーダで変換可能なコーデックを SBC が認識できるように、サポート対象のコーデックのリストを定義し、メディア ゲートウェイをトランスコーダとして識別する必要があります( sbe media-gateway ipv4 codecs コマンドと sbe media-gateway ipv4 transcoder コマンドを使用)。

トランスコーダが正しく SBE に登録されているかどうかを確認するには、 show services sbc sbe media-gateway-associations コマンドを使用します。正しく登録されている場合は、アクティブ アソシエーションが設定されている既知のメディア ゲートウェイのリストにトランスコーダが表示されます。

コーデック フィルタリング

SBC では、特定のコーデックをホワイトリストに登録することによって、特定のコール、コール元、およびコール先で使用可能なコーデックを制限できます。最初は、認識されたすべてのコーデックがホワイトリストに登録されています。コール、コール元、またはコール先のコーデック ホワイトリストに含まれていないコーデックが要求されると、コールは引き続き処理されますが、禁止されているコーデックはオファーとメディア ゲートウェイのコンフィギュレーションから削除されます。

コール元とコール先のコーデック リストをサポートすることによって、SBC はトランスコーディングに関してよりインテリジェントな決定を行うことができます。コール元またはコール先のエンドポイントのコーデック サポートが既知の場合は、CAC ポリシーでコール元とコール先のリストを設定します。ただし、送信元隣接など、他の考慮事項がコーデックの決定に影響する場合があります。この場合でも、コール単位のコーデック リストを使用できます。

たとえば、コール元とコール先のコーデック リストが「A と B」に設定されている場合は、すべてのコールでコーデック A が使用されます。ただし、コールが(送信元隣接で指定されている)中継ネットワーク X を経由したが、X ではコーデック B だけがサポートされている場合は、送信元隣接 X で余分なポリシー マッチングが発生することになり、コール単位のコーデック リストが B に設定されます。このため、ネットワーク X を経由するコールでは、コーデック B が強制的に使用されます。

また、許可されているコーデックごとにパケット化期間の最小許容値を設定することによって、各コーデックの最小パケット化期間を制限することもできます。この制限より短いパケット化期間でセッションが要求されると、コールは引き続き処理されますが、DC SBC によってパケット化期間が設定した最小値まで引き上げられます。

トランスコーディングの制約事項

トランスコーディングについて、次の制約事項を確認してください。

トランスコーディングが必要な場合、H.323 fast-start コールは slow-start プロシージャに引き下げられます。このためには、コール先で fast-start 要求を拒否するか、または隣接関係テーブルに h245-tunnel disable コマンドを設定します。

H.323 と SIP のインターワーキング コールではトランスコーディングはサポートされていません。

拒否後のトランスコーディングの設定

この設定領域の場合、ユーザは、SBE による管理が必要なリモート メディア ゲートウェイのリストを含むコンフィギュレーションを提供します。トランスコーディングが不要な場合、提供の必要はありません。

トランスコーディングのコンフィギュレーションを行う主な理由は、外付けのメディア トランスコーディング デバイスが自動的に検出されない場合に、これらのデバイスの機能を設定するためです。トランスコーダ機能のインバンド自動検出は現在サポートされていません。したがって、現行のすべてのリモート トランスコーディング デバイスとのすべての接続を設定する場合は、この手順を実行する必要があります。


) 上記の理由が該当しない場合は、トランスコーディングのコンフィギュレーションを省略できます。


デフォルトで、メディア ゲートウェイには、コンフィギュレーションが提供されているかどうかに関係なく、接続が許可されます。コンフィギュレーションの誤りを避けるために、DBE ではない、トランスコーディングが設定されていないメディア ゲートウェイから着信接続を受信した場合は、SBE によって警告がログに記録されます。

トランスコーディングを実装する基本的な手順は、次のとおりです。

1. SBC 上で H.248 メディア ゲートウェイ コントローラの IP アドレス、ポート、およびトランスポート プロトコルを設定します。メディア ゲートウェイ コントローラがすでに設定されている場合、このステップは不要である可能性があります。

2. メディア ゲートウェイの IP アドレスを設定します。

3. トランスコーディング対象のコーデックを設定します(たとえば、ITU-T G.711ulaw と ITU-T G.729A の間の変換)。

4. メディア ゲートウェイをトランスコーダとして指定します。

5. SBE をアクティブ化します。

このタスクでは、SBC のトランスコーディングを実装します。

設定が済むと、SBC は、コーデック間でトランスコーディングを必要としているコールに対してトンラスコーディング デバイスを自動的に使用できるようにします。ただし、コール アドミッション制御(CAC)ポリシー コンフィギュレーションで、 transcode-deny コマンドを使用して、そのコールに対するトランスコーダ サービスの提供が除外されている場合を除きます( 「SBC ポリシーの実装」 「コール アドミッション制御ポリシー セットおよび CAC テーブルの設定」を参照)。


) H.323 隣接のコンフィギュレーションでは、H.323 FastStart のトランスコーディングされたコールの h245-tunnel disable コマンドを使用する必要があります。


手順概要

1. configure

2. sbc service-name

3. sbe

4. control address h248 index index-number

5. ipv4 ipv4_IP_address

6. port port-number

7. transport [transport-type]

8. exit

9. media-gateway ipv4 IPv4_IP_address

10. codecs codec-list

11. transcoder

12. exit

13. activate

14. end

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

configure

 

host1/Admin# configure

グローバル コンフィギュレーション モードをイネーブルにします。

ステップ 2

sbc service-name

 

host1/Admin(config)# sbc mysbc

SBC サービス モードを開始します。

サービス名を定義するには、 service-name 引数を使用します。

ステップ 3

sbe

 

host1/Admin(config-sbc)# sbe

SBC サービス内で SBE エンティティ モードを開始します。

ステップ 4

control address h248 index index-number

 

host1/Admin(config-sbc-sbe)# control address h248 index 0

所定の IPv4 H.248 制御アドレスを使用するように SBE を設定します。

ステップ 5

ipv4 ipv4_IP_address

 

host1/Admin(config-sbc-sbe-ctrl-h248)# ipv4 1.1.1.1

所定の IPv4 H.248 制御アドレスを使用するように SBE を設定します。

ステップ 6

port port-number

 

 

 

host1/Admin(config-sbc-sbe-ctrl-h248)# port 2000

H.248 通信に所定の IPv4 H.248 ポートを使用するように SBE を設定します。

ステップ 7

transport [transport-type]

 

host1/Admin(config-sbc-sbe-ctrl-h248)# transport udp

H.248 通信のトランスポート タイプを設定します。

ステップ 8

exit

 

host1/Admin(config-sbc-sbe)# exit

現在のコンフィギュレーション モードを終了します。

ステップ 9

media-gateway ipv4 IPv4_IP_address

 

host1/Admin(config-sbc-sbe)# media-gateway ipv4 10.0.0.1

メディア ゲートウェイを設定します。

ステップ 10

codecs codec-list

 

host1/Admin(config-sbc-sbe-mg)# codecs m=audio 1234 RTP/AVP 0 18,a=rtpmap:0 PCMU/8000,a=rtpmap:18 G729A/8000

メディア ゲートウェイがサポートするコーデックを設定します。

ステップ 11

transcoder

 

host1/Admin(config-sbc-sbe-mg)# transcoder

トランスコーダをサポートするメディア ゲートウェイを設定します。

ステップ 12

exit

 

host1/Admin(config-sbc-sbe-mg)# exit

sbe コマンド モード レベルを終了します。

ステップ 13

activate

 

host1/Admin(config-sbc-sbe)# activate

すべての SBE アドレス設定が正常にコミットされたら、SBC サービスを開始します。

ステップ 14

end

 

host1/Admin(config-sbc-sbe)# end

コンフィギュレーション セッションを終了します。

コーデック フィルタリング トランスコーディングの設定

次のようにコーデック フィルタリング トランスコーディングを設定します。

手順概要

1. configure

2. sbc service-name

3. sbe

4. media-gateway ipv4 IPv4_IP_address

5. codecs codec-list

6. transcoder

7. exit

8. cac-policy-set

9. cac-table

10. entry entry_num

11. caller-codec-list list-name

12. exit

13. exit

14. codec-list list-name

15. codec codec-name

16. exit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

configure

 

host1/Admin# configure

グローバル コンフィギュレーション モードをイネーブルにします。

ステップ 2

sbc service-name

 

host1/Admin(config)# sbc mysbc

SBC サービス モードを開始します。

サービス名を定義するには、 service-name 引数を使用します。

ステップ 3

sbe

 

host1/Admin(config-sbc)# sbe

SBC サービス内で SBE エンティティ モードを開始します。

ステップ 4

media-gateway ipv4 IPv4_IP_address

 

host1/Admin(config-sbc-sbe)# media-gateway ipv4 10.0.0.1

メディア ゲートウェイを設定します。

ステップ 5

codecs codec-list

 

host1/Admin(config-sbc-sbe-mg)# codecs m=audio 1234 RTP/AVP 0 18,a=rtpmap:0 PCMU/8000,a=rtpmap:18 G729A/8000

メディア ゲートウェイがサポートするコーデックを設定します。

ステップ 6

transcoder

 

host1/Admin(config-sbc-sbe-mg)# transcoder

トランスコーダをサポートするメディア ゲートウェイを設定します。

ステップ 7

exit

 

host1/Admin(config-sbc-sbe-mg)# transcoder

メディア ゲートウェイのコンフィギュレーション モードを終了します。

ステップ 8

cac-policy-set

 

host1/Admin(config-sbc-sbe)# cac-policy-set 1

CAC ポリシー サブモードを開始します。

ステップ 9

cac-table

 

host1/Admin(config-sbc-sbe)# cac-table 1

アドミッション制御テーブルを作成または設定します。

ステップ 10

entry

 

host1/Admin(config-sbc-sbe-cacpolicy-cactable)# entry 1

テーブルのエントリを作成または変更します。

ステップ 11

caller-codec-list list-name

 

host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# caller-codec-list test

コールのコール元レッグで使用が許可されているコーデックをリストします。

ステップ 12

exit

 

host1/Admin(config-sbc-sbe-cacpolicy-cactable)# exit

CAC テーブル エントリのコンフィギュレーション モードを終了します。

ステップ 13

exit

 

host1/Admin(config-sbc-sbe-cacpolicy)# exit

CAC ポリシー設定コンフィギュレーション モードを終了します。

ステップ 14

codec-list list-name

 

host1/Admin(config-sbc-sbe)# codec-list my_codecs

コーデック リストを作成します。

ステップ 15

codec codec-name

 

host1/Admin(config-sbc-sbe-codec-list)# codec PCMU

コーデック リストにコーデックを追加します。

ステップ 16

end

 

host1/Admin(config-sbc-sbe)# end

コンフィギュレーション セッションを終了します。

トランスコーディングの実装の設定例

次に、拒否後のトランスコーディングの設定例を示します。

host1/Admin(config)# sbc mySbc
host1/Admin(config-sbc)# sbe
host1/Admin(config-sbc-sbe)# control address h248 index 1
host1/Admin(config-sbc-sbe-ctrl-h248)# ipv4 88.88.133.2
host1/Admin(config-sbc-sbe-ctrl-h248)# port 2000
host1/Admin(config-sbc-sbe-ctrl-h248)# transport udp
host1/Admin(config-sbc-sbe-ctrl-h248)# exit
host1/Admin(config-sbc-sbe)# media-gateway ipv4 10.0.0.1
host1/Admin(config-sbc-sbe-mg)# codecs m=audio 1234 RTP/AVP 0 18,a=rtpmap:0 PCMU/8000,a=rtpmap:18 G729A/8000
host1/Admin(config-sbc-sbe-mg-codecs)# transcoder
host1/Admin(config-sbc-sbe-mg-codecs)# exit
host1/Admin(config-sbc-sbe)# activate
host1/Admin(config-sbc-sbe)# end
 

次に、コーデック フィルタリング トランスコーディングの例を示します。

host1/Admin(config)# sbc mySbc
host1/Admin(config-sbc)# sbe
Router(config)# interface vlan 130
Router(config)# ip address 10.130.10.2 255.255.255.240
host1/Admin(config-if)# alias 10.130.10.4 255.255.255.240
host1/Admin(config-if)# peer ip address 10.130.10.13 255.255.255.240
host1/Admin(config-if)# no shutdown
Router(config)# interface vlan 200
Router(config)# ip address 10.74.50.113 255.255.255.192
 
host1/Admin(config)# ft interface vlan 20
host1/Admin(config)# ip address 10.10.101.21 255.255.255.0
host1/Admin(config-if)# peer ip address 10.10.101.22 255.255.255.0
host1/Admin(config-if)# no shutdown
 
host1/Admin(config)# ft peer 1
host1/Admin(config-ft-peer)# heartbeat interval 300
host1/Admin(config-ft-peer)# heartbeat count 10
host1/Admin(config)# ft-interface vlan 20
host1/Admin(config)# ft group 1
host1/Admin(config-ft-group)# peer 1
host1/Admin(config-ft-group)# priority 90
host1/Admin(config-ft-group)# peer priority 110
host1/Admin(config-ft-group)# associate-context Admin
host1/Admin(config-ft-group)# inservice
 
host1/Admin(config)# ip route 10.0.20.33 255.255.255.255 10.130.10.33
host1/Admin(config)# ip route 0.0.0.0 0.0.0.0 10.74.50.114
host1/Admin(config)# ip route 0.0.0.0 0.0.0.0 10.130.10.1
 
host1/Admin(config)# snmp-server community cisco group Network-Monitor
host1/Admin(config)# snmp-server community public group Network-Monitor
host1/Admin(config)# snmp-server community private group Network-Monitor
 
host1/Admin# configure
host1/Admin(config)# sbc sbc-11
host1/Admin(config-sbc)# sbe
host1/Admin(config-sbc-sbe)# media-gateway ipv4 10.100.181.2
host1/Admin(config-sbc-sbe-mg)# codecs m=audio 20000 RTP/AVP 0 8 18,a=rtpmap:0 PCMU/8000,a=rtpmap:8 PCMA/8000,a=rtpmap:18 G729/8000
host1/Admin(config-sbc-sbe-mg)# transcoder
host1/Admin(config-sbc-sbe)# control address h248 index 1
host1/Admin(config-sbc-sbe-ctrl-h248)# ipv4 10.130.10.4
host1/Admin(config-sbc-sbe-ctrl-h248)# transport udp
host1/Admin(config-sbc-sbe)# adjacency sip SIPP81
host1/Admin(config-sbe-adj-sip)# nat force-off
host1/Admin(config-sbc-sbe-adj-sip)# preferred-transport udp
host1/Admin(config-sbc-sbe-adj-sip)# redirect-mode pass-through
host1/Admin(config-sbe-adj-sip)# authentication nonce timeout 300
host1/Admin(config-sbe-adj-sip)# signaling-address ipv4 10.130.10.4
host1/Admin(config-sbc-sbe-adj-sip)# signaling-port 5060
host1/Admin(config-sbc-sbe-adj-sip)# remote-address ipv4 10.0.244.81 255.255.255.255
host1/Admin(config-sbc-sbe-adj-sip)# signaling-peer 10.0.244.81
host1/Admin(config-sbc-sbe-adj-sip)# signaling-peer-port 5060
host1/Admin(config-sbc-sbe-adj-sip)# dbe-location-id 0
host1/Admin(config-sbc-sbe-adj-sip)# reg-min-expiry 3000
host1/Admin(config-sbc-sbe-adj-sip)# attach
host1/Admin(config-sbc-sbe)# adjacency sip SIPP91
host1/Admin(config-sbc-sbe-adj-sip)# nat force-off
host1/Admin(config-sbc-sbe-adj-sip)# preferred-transport udp
host1/Admin(config-sbc-sbe-adj-sip)# redirect-mode pass-through
host1/Admin(config-sbc-sbe-adj-sip)# authentication nonce timeout 300
host1/Admin(config-sbc-sbe-adj-sip)# signaling-address ipv4 10.130.10.4
host1/Admin(config-sbc-sbe-adj-sip)# signaling-port 5060
host1/Admin(config-sbc-sbe-adj-sip)# remote-address ipv4 10.0.244.91 255.255.255.255
host1/Admin(config-sbc-sbe-adj-sip)# signaling-peer 10.0.244.91
host1/Admin(config-sbc-sbe-adj-sip)# signaling-peer-port 5060
host1/Admin(config-sbc-sbe-adj-sip)# dbe-location-id 0
host1/Admin(config-sbc-sbe-adj-sip)# reg-min-expiry 3000
host1/Admin(config-sbc-sbe-adj-sip)# attach
host1/Admin(config-sbc-sbe)# sip inherit profile preset-core
 
host1/Admin(config-sbc-sbe)# cac-policy-set 1
host1/Admin(config-sbc-sbe-cacpolicy)# first-cac-table table
host1/Admin(config-sbc-sbe-cacpolicy)# first-cac-scope call
host1/Admin(config-sbc-sbe-cacpolicy)# averaging-period 60
host1/Admin(config-sbc-sbe)# cac-table table
host1/Admin(config-sbc-sbe-cacpolicy-cactable)# match-type adjacency
host1/Admin(config-sbc-sbe-cacpolicy-cactable)# entry 1
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# match-value SIPP81
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# action cac-complete
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# max-bandwidth 64009 Gbps
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# max-updates 4294967295
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# max-channels 4294967295
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# early-media-type full-duplex
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# early-media-timeout 0
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# caller-codec-list allow711u
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# callee-privacy never
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# caller-privacy never
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# callee-hold-setting standard
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# caller-hold-setting standard
host1/Admin(config-sbc-sbe-cacpolicy-cactable)# entry 2
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# match-value SIPP91
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# action cac-complete
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# max-bandwidth 64009 Gbps
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# max-updates 4294967295
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# max-channels 4294967295
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# early-media-type full-duplex
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# early-media-timeout 0
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# callee-codec-list allowg729
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# callee-privacy never
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# caller-privacy never
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# callee-hold-setting standard
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# caller-hold-setting standard
host1/Admin(config-sbc-sbe-cacpolicy-cactable-entry)# complete
host1/Admin (config-sbc-sbe)# active-cac-policy-set 1
 
host1/Admin (config-sbc-sbe)# retry-limit 3
 
host1/Admin (config-sbc-sbe)# call-policy-set 1
host1/Admin(config-sbc-sbe-rtgpolicy)# first-call-routing-table table
host1/Admin(config-sbc-sbe-rtgpolicy-rtgtable)# entry 1
host1/Admin(config-sbc-sbe-rtgpolicy-rtgtable-entry)# action complete
host1/Admin(config-sbc-sbe-rtgpolicy-rtgtable-entry)# dst-adjacency SIPP91
host1/Admin(config-sbc-sbe-rtgpolicy-rtgtable-entry)# match-address 318X
host1/Admin(config-sbc-sbe-rtgpolicy-rtgtable-entry)# prefix
host1/Admin(config-sbc-sbe-rtgpolicy-rtgtable-entry)# complete
host1/Admin (config-sbc-sbe)# active-call-policy-set 1
 
host1/Admin(config-sbc-sbe)# sip max-connections 2
host1/Admin(config-sbc-sbe)# sip timer
host1/Admin(config-sbc-sbe-sip-tmr)# tcp-idle-timeout 120000
host1/Admin(config-sbc-sbe-sip-tmr)# tls-idle-timeout 3600000
host1/Admin(config-sbc-sbe-sip-tmr)# udp-response-linger-period 32000
host1/Admin(config-sbc-sbe-sip-tmr)# udp-first-retransmit-interval 500
host1/Admin(config-sbc-sbe-sip-tmr)# udp-max-retransmit-interval 4000
host1/Admin(config-sbc-sbe-sip-tmr)# invite-timeout 180
host1/Admin (config-sbc-sbe)# codec-list allow711u
host1/Admin(config-sbc-sbe-codec-list)# codec PCMU
host1/Admin (config-sbc-sbe)# codec-list allowg729
host1/Admin(config-sbc-sbe-codec-list)# codec G729
host1/Admin(config-sbc-sbe)# h323
host1/Admin(config-sbc-sbe-h323)# ras timeout arq 5000
host1/Admin(config-sbc-sbe-h323)# ras retry arq 2
host1/Admin(config-sbc-sbe-h323)# ras timeout brq 3000
host1/Admin(config-sbc-sbe-h323)# ras retry brq 2
host1/Admin(config-sbc-sbe-h323)# ras timeout drq 3000
host1/Admin(config-sbc-sbe-h323)# ras retry drq 2
host1/Admin(config-sbc-sbe-h323)# ras timeout grq 5000
host1/Admin(config-sbc-sbe-h323)# ras retry grq 2
host1/Admin(config-sbc-sbe-h323)# ras timeout rrq 3000
host1/Admin(config-sbc-sbe-h323)# ras retry rrq 2
host1/Admin(config-sbc-sbe-h323)# ras rrq ttl 60
host1/Admin(config-sbc-sbe-h323)# ras timeout urq 3000
host1/Admin(config-sbc-sbe-h323)# ras retry urq 1
host1/Admin(config-sbc-sbe-h323)# h225 timeout proceeding 10000
host1/Admin(config-sbc-sbe-h323)# h225 timeout establishment 180000
host1/Admin(config-sbc-sbe-h323)# h225 timeout setup 4000
host1/Admin(config-sbc-sbe-h323)# ras rrq keepalive 45000
host1/Admin(config-sbc-sbe)# h323
host1/Admin(config-sbc-sbe-adj-h323)# adjacency timeout 30000
 
host1/Admin(config-sbc-sbe)# blacklist
host1/Admin(config-sbc-sbe-blacklist)# global
host1/Admin(config-sbc-sbe)# blacklist
host1/Admin(config-sbc-sbe-blacklist)# address-default
host1/Admin(config-sbc-sbe)# redirect-limit 2
host1/Admin(config-sbc-sbe)# deact-mode normal
host1/Admin (config-sbc-sbe)# activate
 
host1/Admin(config-sbc)# dbe
host1/Admin(config-sbc-dbe)# location-id 0
host1/Admin(config-sbc-dbe)# media-timeout 360
host1/Admin(config-sbc-dbe)# deact-mode normal
host1/Admin (config-sbc-dbe)# activate
 

検証

動作を検証するには、次のコマンドを使用します。

コマンド
目的

show services sbc sbe media-gateway-associations

既知のメディア ゲートウェイとアクティブ アソシエーションのリストを表示します。

次に、SBC とメディアの通信の例を示します。

host1/Admin# show services sbc slt-n2 sbe media-gateway-associations
SBC Service "slt-n2"
Media gateway 192.169.125.1:2944
Gateway Protocol = megaco
Transport Protocol = UDP
Local Address = 22.46.0.11:2944
 
Sent Received Failed Retried
Requests 117 2 1 7
Replies 2 116 - 0