Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.1E
STP オプション機能の設定
STP オプション機能の設定
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

STP オプション機能の設定

PortFast の機能概要

BPDU ガードの機能概要

PortFast BPDU フィルタリングの機能概要

UplinkFast の機能概要

BackboneFast の機能概要

EtherChannel ガードの機能概要

ルート ガードの機能概要

ループ ガードの機能概要

PortFast のイネーブル化

PortFast BPDU フィルタリングのイネーブル化

BPDU ガードのイネーブル化

UplinkFast のイネーブル化

BackboneFast のイネーブル化

EtherChannel ガードのイネーブル化

ルート ガードのイネーブル化

ループ ガードのイネーブル化

STP オプション機能の設定

この章では、オプションの Spanning Tree Protocol(STP; スパニングツリー プロトコル)機能を設定する手順について説明します。


) この章で使用しているコマンドの構文および使用方法の詳細については、『Cisco 7600 Series Router Cisco IOS Command Reference』を参照してください。


この章で説明する内容は、次のとおりです。

「PortFast の機能概要」

「BPDU ガードの機能概要」

「PortFast BPDU フィルタリングの機能概要」

「UplinkFast の機能概要」

「BackboneFast の機能概要」

「EtherChannel ガードの機能概要」

「ルート ガードの機能概要」

「ループ ガードの機能概要」

「PortFast のイネーブル化」

「PortFast BPDU フィルタリングのイネーブル化」

「BPDU ガードのイネーブル化」

「UplinkFast のイネーブル化」

「BackboneFast のイネーブル化」

「EtherChannel ガードのイネーブル化」

「ルート ガードのイネーブル化」

「ループ ガードのイネーブル化」


) • STP の設定手順については、第15章「STP および IEEE 802.1s MST の設定」を参照してください。

Release 12.1(11b)E 以降を使用している場合に、コンフィギュレーション モードで EXEC モードレベルのコマンドを入力するには、EXEC モードレベルのコマンドの前に do キーワードを入力します。


 

PortFast の機能概要

STP PortFast を使用すると、アクセス ポートとして設定されたレイヤ 2 LAN インターフェイスが、リスニング ステートおよびラーニング ステートを経ずに、ただちにフォワーディング ステートを開始します。1 台のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上で PortFast を使用すると、STP のコンバージェンスを待たずに、装置がただちにネットワークに接続されます。1 台のワークステーションまたはサーバに接続されたインターフェイスが Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)を受信しないようにする必要があります。PortFast 対応として設定しても、ポートは引き続きスパニングツリー プロトコルを実行します。PortFast 対応ポートは、必要に応じてただちにブロッキング ステートに移行します(上位の BPDU を受信した場合に発生する可能性があります)。

Release 12.1(11b)E を使用する場合、

PortFast をトランク ポート上でイネーブルにすることができます。

PortFast に設定された値とは異なる動作値を与えることができます。


注意 PortFast の目的は、アクセス ポートが STP のコンバージェンスを待機する時間を最小限に抑えることです。したがって、PortFast はアクセス ポートに限って使用してください。スイッチに接続されたポート上で PortFast をイネーブルにすると、一時的なブリッジング ループが発生する可能性があります。

BPDU ガードの機能概要

ポート上で BPDU ガードをイネーブルにすると、BPDU を受信するポートがシャットダウンされます。グローバルに設定した場合、BPDU ガードが有効なのは、動作可能 PortFast ステートのポートに限られます。有効な設定では、PortFast レイヤ2 LAN インターフェイスは BPDU を受信しません。PortFast レイヤ 2 LAN インターフェイスが BPDU を受信した場合、認証されていないデバイスが接続された場合と同じように、無効な設定として通知されます。管理者は手動でレイヤ 2 LAN インターフェイスを再び作動させなければならないので、BPDU ガード機能により、無効な設定に対する確実な対処が可能になります。Release 12.1(11b)E を使用する場合、インターフェイス レベルで BPDU ガードを設定することもできます。インターフェイス レベルで設定した場合、PortFast の設定に関係なく、BPDU ガードは BPDU を受信したポートをただちにシャットダウンします。


) グローバルにイネーブルにした場合、BPDU ガードは動作可能 PortFast ステートの全インターフェイスに適用されます。


PortFast BPDU フィルタリングの機能概要

Release 12.1(13)E 以降のリリースでは、PortFast BPDU フィルタリングがサポートされ、管理者はシステムが特定のポートで BPDU を送受信しないようにすることができます。

グローバルに設定した場合、PortFast BPDU フィルタリングは動作可能なすべての PortFast ポートに適用されます。動作可能 PortFast ステートのポートは、ホストに接続されているとみなされ、通常は BPDU をドロップします。BPDU を受信した動作可能 PortFast は、ただちに動作可能 PortFast ステートではなくなります。その場合、そのポートでは PortFast BPDU フィルタリングがディセーブルになり、STP はそのポートでの BPDU の送信を再開します。

PortFast BPDU フィルタリングは、ポート単位で設定することもできます。ポート上で PortFast BPDU フィルタリングを明示的に設定すると、そのポートは BPDU を全く送信せず、受信したすべての BPDU をドロップします。


注意 ホストに接続されていないポート上で PortFast BPDU フィルタリングを明示的に設定した場合、ポートは受信したあらゆる BPDU を無視してフォワーディング ステートになるので、ブリッジング ループが発生する可能性があります。

PortFast BPDU フィルタリングをグローバルにイネーブル化し、PortFast BPDU フィルタリングのデフォルトでポートを設定した場合(PortFast BPDU フィルタリングのイネーブル化を参照)、PortFast が PortFast BPDU フィルタリングをイネーブルまたはディセーブルにします。

ポートがデフォルトに設定されていない場合、PortFast の設定が PortFast BPDU フィルタリングに影響を与えることはありません。 表16-1 に、可能性のあるあらゆる PortFast BPDU フィルタリングの組み合わせを示します。PortFast BPDU フィルタリングによって、アクセス ポートはエンド ホストが接続されるとただちに、フォワーディング ステートに直接移行します。

 

表16-1 PortFast BPDU フィルタリング ポートの設定

ポート単位の設定
グローバルな設定
PortFast ステート
PortFast BPDU
フィルタリング ステート

デフォルト

イネーブル

イネーブル

イネーブル 1

デフォルト

イネーブル

ディセーブル

ディセーブル

デフォルト

ディセーブル

該当しない

ディセーブル

ディセーブル

該当しない

該当しない

ディセーブル

イネーブル

該当しない

該当しない

イネーブル

1.ポートは最低 10 個の BPDU を送信します。そのポートが BPDU を 1 つでも受信すると、PortFast および PortFast BPDU フィルタリングがディセーブルになります。

UplinkFast の機能概要

UplinkFast は、直接リンク障害のあとに高速コンバージェンスを行い、アップリンク グループを使用して、冗長レイヤ 2 リンク間でロードバランシングを実行します。アップリンク グループは、(VLAN ごとの)レイヤ 2 LAN インターフェイスの集合であり、どの指定時間においても、その中の 1 つのインターフェイスだけが転送を行います。つまり、アップリンク グループは、転送を行う 1 つのルート ポートと、(セルフ ループを行うポートを除く)ブロックされたポートの集合で構成されます。アップリンク グループは、転送中のリンクで障害が起きた場合に代替パスを提供します。


) UplinkFast は、配線クローゼット スイッチに使用すると最も効果的です。それ以外の用途には、この機能は有用ではありません。


図16-1 は、リンク障害が発生していないときのトポロジ例です。スイッチ A(ルート ブリッジ)は、リンク L1 を通じてスイッチ B に、リンク L2 を通じてスイッチ C に直接接続されています。スイッチ B に直接接続されているスイッチ C のレイヤ 2 LAN インターフェイスは、ブロッキング ステートです。

図16-1 直接リンク障害が発生する前の UplinkFast の例

 

スイッチ C が、現在アクティブ リンクであるルート ポート上の L2 でリンク障害( 直接 リンク障害)を検出すると、UplinkFast はスイッチ C でブロックされていたポートのブロックを解除し、リスニング ステートおよびラーニング ステートを経ずに、ただちにフォワーディング ステートに移行させます(図16-2 を参照)。この切り替えに要する時間は約 1 ~ 5 秒です。

図16-2 直接リンク障害が発生した後の UplinkFast の例

 

BackboneFast の機能概要

ネットワーク デバイス上のルート ポートまたはブロックされたポートが、そのポートの代表ブリッジから下位 BPDU を受信すると、BackboneFast が開始されます。下位 BPDU は、1 台のネットワーク デバイスをルート ブリッジおよび代表ブリッジの両方として識別します。ネットワーク デバイスが下位 BPDU を受信すると、ネットワーク デバイスはそのネットワーク デバイスが直接接続されていないリンク( 間接 リンク)で障害が発生した(つまり、代表ブリッジがルート ブリッジへの接続を失った)ものとみなします。標準的な STP ルールに従う場合、ネットワーク デバイスは設定されている最大エージング タイム(STP の max-age コマンドで指定)の間、下位 BPDU を無視します。

ネットワーク デバイスは、ルート ブリッジへの代替パスの有無を判別します。下位 BPDU がブロックされたポートに到達した場合には、ネットワーク デバイスのルート ポートおよびその他のブロックされたポートがルート ブリッジへの代替パスになります(セルフ ループを行ったポートはルート ブリッジの代替パスとは見なされません)。下位 BPDU がルート ポートに到達した場合には、すべてのブロックされたポートがルート ブリッジへの代替パスになります。下位 BPDU がルート ポートに到達し、かつブロックされたポートがない場合には、ネットワーク デバイスはルート ブリッジへの接続が切断されたものとみなし、ルートの最大エージング タイムを満了させ、通常の STP ルールに従ってルート ブリッジになります。

ネットワーク デバイスにルート ブリッジへの代替パスがある場合、ネットワーク デバイスはそれらの代替パスを使用して、Root Link Query(RLQ)PDU と呼ばれる新しい種類の PDU を送信します。ネットワーク デバイスはルート ブリッジへのすべての代替パスに対して、RLQ PDU を送信します。ルートへの代替パスがまだ存在していることが判明すると、ネットワーク デバイスは、下位 BPDU を受信したポートの最大エージング タイムを満了させます。ルート ブリッジへのすべての代替パスが、ネットワーク デバイスとルート ブリッジ間の接続が切断されていることを示している場合には、ネットワーク デバイスは、下位 BPDU を受信したポートの最大エージング タイムを満了させます。1 つまたは複数の代替パスからルート ブリッジに引き続き接続できる場合には、ネットワーク デバイスは、下位 BPDU を受信したすべてのポートを指定ポートにして、(ブロッキング ステートになっていた場合)ブロッキング ステートから、リスニング ステートおよびラーニング ステートを経て、フォワーディング ステートに移行させます。

図16-3 は、リンク障害が発生していないときのトポロジ例です。スイッチ A(ルート ブリッジ)は、リンク L1 を通じてスイッチ B に、リンク L2 を通じてスイッチ C に直接接続されています。スイッチ B に直接接続されているスイッチ C のレイヤ 2 LAN インターフェイスは、ブロッキング ステートです。

図16-3 間接リンク障害が発生する前の BackboneFast の例

 

リンク L1 で障害が発生した場合、スイッチ C はリンク L1 に直接接続されていないので、この障害を検出できません。一方、スイッチ B は L1 を通じてルート ブリッジに直接接続されているので、この障害を検出し、自らをルートに選定し、スイッチ C に対して自らがルートであることを表す BPDU の送信を開始します。スイッチ C がスイッチ B から下位 BPDU を受信すると、スイッチ C は間接障害が発生したことを推測します。この時点で、BackboneFast により、スイッチ C のブロックされたポートは、そのポートに設定されている最大エージング タイムの満了を待たずに、ただちにリスニング ステートに移行します。BackboneFast はさらに、スイッチ C のレイヤ 2 LAN インターフェイスをフォワーディング ステートに移行させ、スイッチ B からスイッチ A までのパスを提供します。この切り替えに要する時間は約 30 秒で、転送遅延時間の 2 倍にあたります(転送遅延時間がデフォルトの 15 秒に設定されている場合)。図16-4 に、BackboneFast がリンク L1 で発生した障害に応じてどのようにトポロジを再設定するかを示します。

図16-4 間接リンク障害が発生したあとの BackboneFast の例

 

図16-5 に示すメディア共有型トポロジに新しいネットワーク デバイスが組み込まれた場合、BackboneFast は起動されません。これは、認識されている代表ブリッジ(スイッチ B)からは下位 BPDU が着信しないためです。新しいネットワーク デバイスは、自らがルート ブリッジであることを伝える下位 BPDU の送信を開始しますが、他のネットワーク デバイスはこれらの下位 BPDU を無視します。その結果、新しいネットワーク デバイスはスイッチBがルート ブリッジであるスイッチ A への代表ブリッジであることを学習します。

図16-5 メディア共有型トポロジにおけるネットワーク デバイスの追加

 

EtherChannel ガードの機能概要

EtherChannel ガードは正しく設定されていない EtherChannel を検出します(Cisco 7600 シリーズ ルータのインターフェイスが EtherChannel として設定されているが、他のデバイスのインターフェイスまたはその一部が同じ EtherChannel に設定されていない場合など)。

他のデバイスの設定に誤りがあることが検出されると、EtherChannel ガードはCisco 7600 シリーズ ルータのインターフェイスを errdisable ステートにします。

ルート ガードの機能概要

STP ルート ガード機能は、ポートがルート ポートまたはブロック ポートにならないようにします。ルート ガードが設定されたポートが上位 BPDU を受信すると、そのポートはただちに
root-inconsistent(ブロック)ステートになります。

ループ ガードの機能概要

ループ ガードは、ポイントツーポイント リンク上の単方向リンク障害が原因で発生することのあるブリッジング ループの防止に有効です。グローバルにイネーブル化した場合、ループ ガードはシステム上のすべてのポイントツーポイント ポートに適用されます。ループ ガードは、ルート ポートおよびブロック ポートを検出し、それらのポートがセグメントの指定ポートから送られた BPDU を受信し続けるようにします。ループ ガード対応のルート ポートまたはブロック ポートが指定ポートから送られた BPDU の受信を停止した場合、そのポートは物理リンク エラーがポートで発生したものとして、loop-inconsistent ブロッキング ステートに移行します。ポートは BPDU を受信すると、ただちにこの loop-inconsistent ステートから回復します。

ループ ガードは、ポート単位でイネーブルにできます。ループ ガードをイネーブルにすると、ポートが所属するすべてのアクティブ インスタンスまたは VLAN にループ ガードが自動的に適用されます。ループ ガードをディセーブルにすると、特定のポートに関して、ループ ガードがディセーブルになります。ループ ガードをディセーブルにすると、すべての loop-inconsistent ポートがリスニング ステートに移行します。

チャネル上でループ ガードをイネーブルに設定し、最初のリンクが単方向になった場合、ループ ガードは影響を受けたポートがチャネルから除外されるまで、チャネル全体をブロックします。図16-6 に、3 台のスイッチ構成におけるループ ガードを示します。

図16-6 ループ ガードが設定されたスイッチ 3 台の構成

 

図16-6 の構成は、次のとおりです。

スイッチ A およびスイッチ B は、ディストリビューション スイッチです。

スイッチ C は、アクセス スイッチです。

ループ ガードはスイッチ A、B、および C のポート 3/1 および 3/2 でイネーブルです。

ルート スイッチでループ ガードをイネーブルにしても、効果はありませんが、ルート スイッチが非ルート スイッチになった場合に保護されます。

ループ ガードを使用するときには、次の注意事項に従ってください。

PortFast 対応ポートまたはダイナミック VLAN ポートでは、ループ ガードをイネーブルにできません。

ルート ガードがイネーブルの場合は、ループ ガードをイネーブルにできません。

ループ ガードと他の機能の相互作用は、次のとおりです。

ループ ガードは、UplinkFast または BackboneFast の機能に影響を与えません。

ポイントツーポイント リンクに接続されていないポート上でループ ガードをイネーブルにしても、機能しません。

ルート ガードは強制的に、ポートがルート ポートとしてつねに指定されるようにします。ループ ガードが有効なのは、ポートがルート ポートまたは代替ポートの場合だけです。1 つのポートでループ ガードおよびルート ガードを同時にイネーブルにすることはできません。

ループ ガードは、スパニングツリーが認識しているポートを使用します。ループ ガードは、Port Aggregation Protocol(PAgP; ポート集約プロトコル)が提供する論理ポートの利点を活用できます。ただし、チャネルを形成するには、チャネルとしてまとめたすべての物理ポートを相互に矛盾のない設定にしておく必要があります。PAgP は、チャネルを形成するすべての物理ポート上で、ルート ガードまたはループ ガードを強制的に統一して設定します。

ルート ガードの注意事項は、次のとおりです。

スパニングツリーはつねに、チャネル内で最初の動作可能ポートを選択して BPDU を送信します。そのリンクが単方向になると、チャネル内の他のリンクが正常に動作していても、ループ ガードはそのチャネルをブロックします。

ループ ガードによってすでにブロックされているポートのセットをグループ化してチャネルが形成された場合、スパニングツリーはそれらのポートのあらゆるステート情報を失います。したがって、新しいチャネル ポートは、指定された役割とともに、フォワーディング ステートを取得する可能性があります。

ループ ガードによってチャネルがブロックされていて、チャネルが分断された場合、スパニングツリーはあらゆるステート情報を失います。チャネルを形成していた 1 つまたは複数のリンクが単方向でも、個々の物理ポートは、指定された役割とともにフォワーディング ステートを取得する場合があります。


) UniDirectional Link Detection(UDLD; 単方向リンク検出)をイネーブルにすると、リンク障害の分離に有効です。UDLD が障害を検出しない限りループが発生する可能性がありますが、ループ ガードでは障害は検出できません。


ループ ガードは、ディセーブルに設定されているスパニングツリー インスタンスまたは VLAN では無効です。

PortFast のイネーブル化


注意 PortFast は、単一のエンド ステーションをレイヤ 2 アクセス ポートに接続する場合に限って使用してください。その他の場合に使用すると、ネットワーク ループが発生する可能性があります。

レイヤ 2 アクセス ポート上で PortFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 2 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree portfast

単一のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上で PortFast をイネーブルにします。

ステップ 3

Router(config-if)# spanning-tree portfast default

PortFast をディセーブルにします。

ステップ 4

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 5

Router# show running interface { type 1 slot/port } | { port-channel port_channel_number }

設定を確認します。

2.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、インターフェイス FastEthernet 5/8 上で PortFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# interface fastethernet 5/8
Router(config-if)# spanning-tree portfast
Router(config-if)# end
Router#
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/8
Building configuration...
 
Current configuration:
!
interface FastEthernet5/8
no ip address
switchport
switchport access vlan 200
switchport mode access
spanning-tree portfast
end
 
Router#

PortFast のデフォルト設定をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast default

PortFast をデフォルト設定します。

ステップ 2

Router(config)# show spanning-tree summary totals

グローバルな設定を確認します。

ステップ 3

Router(config)# show spanning-tree interface x detail

特定のポートで作用を確認します。

ステップ 4

Router(config-if)# spanning-tree portfast trunk

ポート上で PortFast トランクをイネーブルにします。

ステップ 5

Router# show spanning-tree interface fastEthernet x detail

設定を確認します。

次に、PortFast のデフォルト設定をイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree portfast default
Router(config)# ^Z
 
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is disabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 0 0 0 1 1
VLAN0010 0 0 0 2 2
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by default
Link type is point-to-point by default
BPDU:sent 10, received 0
 
Router(config-if)# spanning-tree portfast trunk
%Warning:portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
BPDU:sent 30, received 0
Router#

PortFast BPDU フィルタリングのイネーブル化

ここでは、スイッチに PortFast BPDU フィルタリングを設定する手順について説明します。

PortFast BPDU フィルタリングをグローバルにイネーブル化する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast bpdufilter default

スイッチ上で BPDU フィルタリングをグローバルにイネーブル化します。

ステップ 2

Router# show spanning-tree summary totals

設定を確認します。

BPDU フィルタリングは、各ポートでデフォルトに設定されます。次に、ポート上で PortFast BPDU フィルタリングをイネーブルに設定し、PVST+ モードで設定を確認する例を示します。


) PVST+ については、第15章「STP および IEEE 802.1s MST の設定」を参照してください。


Router(config)# spanning-tree portfast bpdufilter default
Router(config)# ^Z
 
Router# show spanning-tree summary totals
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is enabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルにする手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config)# interface fastEthernet 4/4

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree bpdufilter enable

BPDU フィルタリングをイネーブルにします。

ステップ 3

Router# show spanning-tree interface fastEthernet 4/4

設定を確認します。

次に、非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルにする例を示します。

Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree bpdufilter enable
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4
 
Vlan Role Sts Cost Prio.Nbr Status
---------------- ---- --- --------- -------- --------------------------------
VLAN0010 Desg FWD 1000 160.196 Edge P2p
Router# show spanning-tree interface fastEthernet 4/4 detail
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
BPDU:sent 0, received 0
Router#

BPDU ガードのイネーブル化

BPDU ガードをグローバルにイネーブル化する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast bpduguard default

Router(config)# no spanning-tree portfast bpduguard default

BPDU ガードをグローバルにイネーブル化します。

BPDU ガードをグローバルにディセーブル化します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary totals

設定を確認します。

次に、BPDU ガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree portfast bpduguard
Router(config)# end
Router#

次に、設定を確認する例を示します。

Router# show spanning-tree summary totals default
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is enabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

UplinkFast のイネーブル化

UplinkFast を使用すると、ブリッジ プライオリティが 49152 に増えるとともに、Cisco 7600 シリーズ ルータ上のすべてのレイヤ 2 LAN インターフェイスの STP ポート コストに 3000 が加算されます。その結果、ルータがルート ブリッジになる可能性が低くなります。 max_update_rate 値は、1 秒間に送信されるマルチキャスト パケット数を表します(デフォルトは 150 パケット/秒です)。ブリッジ プライオリティを設定している VLAN 上では、UplinkFast をイネーブルにすることはできません。ブリッジ プライオリティを設定している VLAN 上で UplinkFast をイネーブルにするには、グローバル コンフィギュレーション モードで no spanning-tree vlan vlan_ID priority コマンドを入力することにより、VLAN のブリッジ プライオリティをデフォルトに戻します。


) UplinkFast をイネーブルにすると、Cisco 7600 シリーズ ルータ上のすべての VLAN に作用します。個々の VLAN について UplinkFast を設定することはできません。


UplinkFast をイネーブルにする手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree uplinkfast [ max-update-rate max_update_rate ]

UplinkFast をイネーブルにします。

Router(config)# no spanning-tree uplinkfast max-update-rate

デフォルトの速度に戻します。

Router(config)# no spanning-tree uplinkfast

UplinkFast をディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

BackboneFast がイネーブルになっていることを確認します。

次に、UplinkFast をイネーブルにして、アップデート速度を 400 パケット/秒に設定する例を示します。

Router# configure terminal
Router(config)# spanning-tree uplinkfast max-update-rate 400
Router(config)# exit
Router#
 

次に、UplinkFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree uplinkfast
UplinkFast is enabled
Router#

BackboneFast のイネーブル化


) BackboneFast が正常に動作するのは、ネットワーク内のすべてのネットワーク デバイスでイネーブルになっている場合だけです。BackboneFast は、トークンリング VLAN ではサポートされません。この機能は、サードパーティ製のネットワーク デバイスにも使用できます。


BackboneFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree backbonefast

BackboneFast をイネーブルにします。

Router(config)# no spanning-tree backbonefast

BackboneFast をディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

BackboneFast がイネーブルになっていることを確認します。

次に、BackboneFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree backbonefast
Router(config)# end
Router#
 

次に、BackboneFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree backbonefast
BackboneFast is enabled
 
BackboneFast statistics
-----------------------
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
Router#

EtherChannel ガードのイネーブル化

EtherChannel ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree etherchannel guard misconfig

EtherChannel ガードをイネーブルにします。

Router(config)# no spanning-tree etherchannel guard misconfig

EtherChannel ガードをディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary | include EtherChannel

EtherChannel ガードがイネーブルになっていることを確認します。

次に、EtherChannel ガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree etherchannel guard misconfig
Router(config)# end
Router#
 

次に、設定を確認する例を示します。

Router# show spanning-tree summary | include EtherChannel
EtherChannel misconfiguration guard is enabled
 

errdisable ステートのインターフェイスを表示するには、 show interface status err-disable コマンドを入力します。

誤った設定が消去されると、errdisable ステートのインターフェイスは自動的に回復します。インターフェイスを手動で稼働状態に戻すには、 shutdown コマンドを入力してから、該当するインターフェイスに対して no shutdown コマンドを入力します。

ルート ガードのイネーブル化

ルート ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 3 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree guard root

ルート ガードをイネーブルにします。

Router(config-if)# no spanning-tree guard root

ルート ガードをディセーブルにします。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning-tree

Router# show running interface { type 1 slot/port } | { port-channel port_channel_number }

設定を確認します。

3.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

root-inconsistent ステートになっているポートを表示するには、 show spanning-tree inconsistentports コマンドを入力します。

ループ ガードのイネーブル化

set spanning-tree guard コマンドを使用して、ポート単位でスパニングツリー ループ ガード機能をイネーブルまたはディセーブルにします。

スイッチ上でグローバルにループ ガードをイネーブル化する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree loopguard default

スイッチ上でグローバルにループ ガードをイネーブル化します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning tree interface 4/4 detail

設定がポートに与える影響を確認します。

次に、ループ ガードをグローバルにイネーブル化する例を示します。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree loopguard default
Router(config)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled by default on the port
BPDU:sent 0, received 0
 

特定のインターフェイス上でループ ガードをイネーブルにする手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 4 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree guard loop

ループ ガードを設定します。

ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning tree interface 4/4 detail

設定がそのポートに与える影響を確認します。

4.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、ループ ガードをイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree guard loop
Router(config-if)# ^Z
 

次に、設定を確認する例を示します。

Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled on the port
BPDU:sent 0, received 0
Router#