Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.1E
EtherChannel の設定
EtherChannel の設定
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

EtherChannel の設定

EtherChannel の機能概要

EtherChannel の概要

EtherChannel の設定方法

EtherChannel 設定の概要

EtherChannel の手動設定

PAgP による EtherChannel の設定

IEEE 802.3ad LACP による EtherChannel の設定

ポート チャネル インターフェイスの概要

ロード バランシングの概要

EtherChannel 機能の設定時の注意事項および制約事項

EtherChannel の設定

レイヤ 3 EtherChannel に対応するポート チャネル論理インターフェイスの設定

チャネル グループの設定

LACP システム プライオリティおよびシステム ID の設定

EtherChannel ロード バランシングの設定

EtherChannel の設定

この章では、Cisco 7600 シリーズ ルータのレイヤ 2 またはレイヤ 3 LAN ポートに EtherChannel を設定する方法について説明します。


) • この章で使用しているコマンドの構文および使用方法の詳細については、『Cisco 7600 Series Router Cisco IOS Command Reference』を参照してください。

この章で説明するコマンドは、スーパーバイザ エンジンおよび冗長スーパーバイザ エンジンのポートを含む、Cisco 7600 シリーズ ルータのすべての LAN ポートに対して使用できます。

Release 12.1(13)E 以降のリリースでは、IEEE 802.3ad Link Aggregation Control Protocol(LACP)がサポートされます。

WS-X6548-GE-TX および WS-X6548V-GE-TX ファブリック対応スイッチング モジュールでは、EtherChannel ごとに 1 Gbps までのトラフィックしかサポートしていません(ただし、ルータが truncated モードで動作している場合は除く)。

WS-X6148-GE-TX および WS-X6148V-GE-TX スイッチング モジュールでは、EtherChannel ごとに 1 Gbps までのトラフィックしかサポートしていません。


 

この章で説明する内容は、次のとおりです。

「EtherChannel の機能概要」

「EtherChannel 機能の設定時の注意事項および制約事項」

「EtherChannel の設定」

EtherChannel の機能概要

ここでは、EtherChannel の機能について説明します。

「EtherChannel の概要」

「EtherChannel の設定方法」

「ポート チャネル インターフェイスの概要」

「ロード バランシングの概要」

EtherChannel の概要

EtherChannel は、個々のイーサネット リンクを 1 つの論理リンクにバンドルすることによって、最大 8 つの物理リンクの合計帯域幅を提供します。

Cisco 7600 シリーズ ルータは、最大で 64(Release 12.1(2)E より前のリリースでは 256)の EtherChannel をサポートします。Cisco 7600 シリーズ ルータの任意のモジュール上の(設定に互換性のある)LAN ポートを 8 つまで使用して、1 つの EtherChannel を形成できます。各 EtherChannel の LAN ポートは、すべて同じ速度でなければなりません。また、すべてのポートを、レイヤ 2 LAN ポートまたはレイヤ 3 LAN ポートのどちらか一方として設定する必要があります。


) Cisco 7600 シリーズ ルータに接続するネットワーク デバイスによって、1 つの EtherChannel にバンドルできるポート数が制限される場合があります。


EtherChannel 内のセグメントで障害が発生すると、障害リンク上でそれまで伝送されていたトラフィックがその EtherChannel 内の残りのセグメントに切り替えられます。障害が発生すると、ルータ、EtherChannel、および障害リンクを特定するトラップが EtherChannel 機能によって送信されます。EtherChannel の 1 つのセグメントに着信したブロードキャスト パケットおよびマルチキャスト パケットが、EtherChannel の別のセグメントに戻されることはありません。

EtherChannel の設定方法

ここでは、EtherChannel の設定方法について説明します。

「EtherChannel 設定の概要」

「EtherChannel の手動設定」

「PAgP による EtherChannel の設定」

「IEEE 802.3ad LACP による EtherChannel の設定」

EtherChannel 設定の概要

EhterChannel は手動で設定することも、Port Aggregation Control Protocol(PAgP; ポート集約プロトコル)または(Release 12.1(13)E 以降の場合)Link Aggregation Control Protocol(LACP)を使用して形成することもできます。EtherChannel プロトコルを使用すると、接続ネットワーク デバイスとのダイナミック ネゴシエーションによって、特性が類似しているポートで EtherChanel を形成できます。PAgP はシスコ独自のプロトコルです。LACP は IEEE 802.3ad で定義されています。

PAgP と LACP とは相互運用しません。PAgP を使用するように設定されたポートは、LACP を使用するように設定されたポートとともに EtherChannel を形成することはできません。LACP を使用するように設定されたポートは、PAgP を使用するように設定されたポートとともに EtherChannel を形成することはできません。

表13-1 に、ユーザ側で設定できる EtherChannel モードを示します。

 

表13-1 EtherChannel のモード

モード
説明

on

無条件で、LAN ポートを強制的にチャネル化するモード。 on モードでは、 on モードの LAN ポート グループが、 on モードの別の LAN ポート グループに接続されている場合に限り、使用可能な EtherChannel が存在します。 on モードで設定されたポートはネゴシエーションを行わないので、ポート間にネゴシエーション トラフィックは発生しません。EtherChannel プロトコルの場合、 on モードを設定することはできません。

auto

PAgP モード。LAN ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した PAgP パケットには応答しますが、PAgP ネゴシエーションは開始しません(デフォルト)。

desirable

PAgP モード。LAN ポートをアクティブ ネゴシエーション ステートにします。ポートは PAgP パケットを送信して、他の LAN ポートとのネゴシエーションを開始します。

passive

LACP モード。ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した LACP パケットには応答しますが、LACP ネゴシエーションは開始しません(デフォルト)。

active

LACP モード。ポートをアクティブ ネゴシエーション ステートにします。ポートは LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

EtherChannel の手動設定

手動設定された EtherChannel ポートは、EtherChannel プロトコル パケットを交換しません。手動設定された EtherChannel が形成されるのは、EtherChannel の全ポートを互換性があるものとして設定した場合に限られます。

PAgP による EtherChannel の設定

PAgP を使用すると、LAN ポート間で PAgP パケットを交換することにより、EtherChannel を自動的に作成できます。PAgP パケットが交換されるのは、 auto モードおよび desirable モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能をダイナミックに学習し、他の LAN ポートに通知します。PAgP は、正しく一致しているイーサネット リンクを識別すると、これらのリンクを 1 つの EtherChannel としてまとめます。形成された EtherChannel は、単一ブリッジ ポートとしてスパニングツリーに追加されます。

auto モードおよび desirable モードでは、PAgP が LAN ポート間でネゴシエーションを行い、ポート速度、トランキング ステートなどの基準に従って EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel では、VLAN 番号も使用されます。

LAN ポート間で PAgP モードが異なる場合でも、モードに互換性があるかぎり EtherChannel を形成できます。次に例を示します。

desirable モードの LAN ポートは、 desirable モードの他の LAN ポートと EtherChannel を形成できます。

desirable モードの LAN ポートは、 auto モードの他の LAN ポートと EtherChannel を形成できます。

auto モードの LAN ポートは、 auto モードの他の LAN ポートとは EtherChannel を形成できません。どちらのポートもネゴシエーションを開始しないからです。

IEEE 802.3ad LACP による EtherChannel の設定

Release 12.1(13)E 以降のリリースで、IEEE 802.3ad LACP EtherChannel がサポートされます。LACP を使用すると、LAN ポート間で LACP パケットを交換することにより、EtherChannel を自動的に形成できます。LACP パケットが交換されるのは、 passive モードおよび active モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能をダイナミックに学習し、他の LAN ポートに通知します。LACP は、正しく一致しているイーサネット リンクを識別すると、これらのリンクを 1 つの EtherChannel としてまとめます。形成された EtherChannel は、単一ブリッジ ポートとしてスパニングツリーに追加されます。

passive モードおよび active モードでは、LACP が LAN ポート間でネゴシエーションを行い、ポート速度、トランキング ステートなどの基準に従って EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel では、VLAN 番号も使用されます。

LAN ポート間で LACP モードが異なる場合でも、モードに互換性がある限り EtherChannel を形成できます。次に例を示します。

active モードの LAN ポートは、 active モードの他の LAN ポートと EtherChannel を形成できます。

active モードの LAN ポートは、 passive モードの他の LAN ポートと EtherChannel を形成できます。

passive モードの LAN ポートは、 passive モードの他の LAN ポートとは EtherChannel を形成できません。どちらのポートもネゴシエーションを開始しないからです。

LACP では次のパラメータが使用されます。

LACP システム プライオリティ ― LACP が稼働するルータごとに、LACP システム プライオリティを設定する必要があります。システム プライオリティは自動的に設定することも、CLI(コマンドライン インターフェイス)を使用して設定することもできます(LACP システム プライオリティおよびシステム ID の設定を参照)。LACP はシステム プライオリティとともにスイッチの MAC アドレスを使用して、システム ID を形成します。他のシステムとのネゴシエーション時も同様です。


) LACP システム ID は、LACP システム プライオリティ値とルータの MAC アドレスを組み合わせたものです。


LACP プライオリティ ― LACP を使用するように設定したポートごとに、LACP ポート プライオリティを設定する必要があります。ポート プライオリティは自動的に設定することも、CLI を使用して設定することもできます(チャネル グループの設定を参照)。LACP はポート プライオリティとともにポート番号を使用して、ポート ID を形成します。LACP はポート プライオリティによって、ハードウェアの制約上すべての互換ポートを集約することができない場合に、スタンバイ モードにするポートを決定します。

LACP 管理キー ― LACP は、LACP を使用するように設定された各ポートのチャネル グループ ID と同じ管理キー値を自動的に設定します。管理キーによって、他のポートと集約するポートの能力が定義されます。他のポートと集約するポートの能力は、次の要因によって決まります。

データ レート、デュプレックス能力、ポイントツーポイント メディアまたは共用メディアといったポートの物理特性

ユーザが設定したコンフィギュレーションの制約事項

LACP を使用するように設定されたポート上で、LACP はハードウェアが許容する最大数(8 ポート)まで、EtherChannel の最大互換ポート数を設定しようとします。LACP がすべての互換ポートを集約することができなかった場合(リモート システムのハードウェア制約がさらに厳しいなど)、チャネルにアクティブとして含めることのできなかったすべてのポートはホットスタンバイ ステートになり、チャネル化ポートのいずれかで障害が発生した場合に限って使用されます。スタンバイ ポートは 8 つまで(EtherChannel と対応づけられるポートは合計で 16)設定できます。

ポート チャネル インターフェイスの概要

各 EtherChannel には、番号付きのポート チャネル インターフェイスが 1 つずつあります。Release 12.1(5)E 以降のリリースでは、最大で 64 のポート チャネル インターフェイス(1 ~ 256 の番号付き)がサポートされます。


) Release 12.1(4)E1、12.1(3a)E4、および 12.1(3a)E3 では、最大で 64 のポート チャネル インターフェイス(1 ~ 64 の番号付き)がサポートされます。Releases 12.1(2)E 以前では、最大で 256 のポート チャネル インターフェイス(1 ~ 256 の番号付き)がサポートされます。


ポート チャネル インターフェイスに適用する設定は、そのポート チャネル インターフェイスに割り当てられたすべての LAN ポートに対して有効です。

EtherChannel を設定したあと、ポート チャネル インターフェイスに適用する設定は、EtherChannel に対して有効になります。一方、LAN ポートに適用する設定は、適用先の LAN ポートだけに有効です。EtherChannel のすべてのポートのパラメータを変更するには、ポート チャネル インターフェイスに対してコンフィギュレーション コマンドを適用してください。たとえば、Spanning Tree Protocol(STP; スパニング ツリー プロトコル)コマンドまたはレイヤ 2 EtherChannel をトランクとして設定するコマンドなどです。

ロード バランシングの概要

EtherChannel は、フレーム内のアドレスで構成されるバイナリ パターンの一部分を数値化し、EtherChannel 内のリンクの 1 つを選択することによって、チャネルの各リンクに対するトラフィック ロードのバランスをとります。

EtherChannel のロード バランシングでは、MAC アドレスまたは IP アドレスを使用できます。PFC2 の場合、EtherChannel のロード バランシングにレイヤ 4 のポート番号も使用できます。EtherChannel のロード バランシングは、送信元または宛先のどちらか一方を使用することも、送信元または宛先、またはその両方のアドレスあるいはポートを使用することもできます。選択したモードは、ルータ上で設定されているすべての EtherChannel に適用されます。

使用する設定で最も多様性のあるバランス条件が得られるオプションを使用してください。たとえば、EtherChannel 上のトラフィックが 1 つの MAC アドレスにのみ送信され、かつその宛先 MAC アドレスを EtherChannel ロードバランシングの基準として使用している場合、EtherChannel は常に EtherChannel 内の同じリンクを選択します。送信元アドレスまたは IP アドレスを使用すると、ロードバランシングが向上することがあります。

EtherChannel 機能の設定時の注意事項および制約事項

EtherChannel インターフェイスの設定に問題があると、ネットワーク ループなどの問題を回避するために、EtherChannel インターフェイスが自動的にディセーブルになります。設定の問題が起きないように、次の注意事項および制約事項に注意してください。

冗長スーパーバイザ エンジン上のポートも含めて、すべてのモジュール上のすべてのイーサネット LAN ポートが、EtherChannel(最大 8 つの LAN ポート)をサポートします。これらの LAN ポートは、物理的に隣接する LAN ポートや、同じモジュール上の LAN ポートでなくてもかまいません。

EtherChannel 内のすべての LAN ポートが同じ EtherChannel プロトコルを使用するように設定します。1 つの EtherChannel で 2 種類の EtherChannel プロトコルを実行することはできません。

EtherChannel 内のすべての LAN ポートが、同じ速度および同じデュプレックス モードで動作するように設定してください。

LACP は半二重をサポートしません。LACP EtherChannel の半二重ポートは、一時停止の状態になります。

EtherChannel のすべての LAN ポートをイネーブルにしてください。EtherChannel 内の LAN ポートを 1 つシャットダウンすると、リンク障害として処理され、そのポートのトラフィックが EtherChannel 内の残りのポートの 1 つに転送されます。

LAN ポートの 1 つが Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)宛先ポートである場合には、EtherChannel は形成されません。

レイヤ 3 EtherChannel の場合、レイヤ 3 アドレスは、チャネル内の LAN ポートに対してではなく、ポート チャネル論理インターフェイスに割り当ててください。

レイヤ 2 EtherChannel の場合

EtherChannel 内のすべての LAN ポートを同じ VLAN に割り当てるか、またはトランクとして設定してください。

トランキング LAN ポートから EtherChannel を設定する場合は、すべてのトランクでトランキング モードが同じであることを確認してください。1 つの EtherChannel 内で LAN ポートをそれぞれ異なるトランキング モードに設定すると、予想外の動作になることがあります。

EtherChannel は、トランキング レイヤ 2 EtherChannel 内のすべての LAN ポートで同じ許容範囲の VLAN をサポートします。VLAN の許容範囲が異なる場合、LAN ポートは EtherChannel を形成しません。

STP ポート パス コストの異なる LAN ポートは、設定が相互に矛盾しない限り、EtherChannel を形成できます。異なる STP ポート パス コストを設定しても、EtherChannel の形成上、LAN ポートが矛盾するわけではありません。

プロトコル フィルタリングの設定が LAN ポートごとに異なっている場合には、EtherChannel を形成できません。

EtherChannel の設定後、ポート チャネル インターフェイスに適用した設定は、EtherChannel に作用します。LAN ポートに適用した設定は、設定を適用した LAN ポートだけに作用します。

Release 12.1(12c)E1 以降のリリースで、QoS(Quality of Service)がイネーブルになっている場合、 no mls qos channel-consistency ポート チャネル インターフェイス コマンドを入力して、完全優先キューのあるポートと完全優先キューのないポートを持つ EtherChannel をサポートします。

EtherChannel の設定

ここでは、EtherChannel を設定する手順について説明します。

「レイヤ 3 EtherChannel に対応するポート チャネル論理インターフェイスの設定」

「チャネル グループの設定」

「EtherChannel ロード バランシングの設定」


) • LAN ポートが正しく設定されていることを確認してください(EtherChannel 機能の設定時の注意事項および制約事項を参照)。

Release 12.1(11b)E 以降を使用している場合に、コンフィギュレーション モードで EXEC モードのコマンドを入力するには、EXEC モードのコマンドの前に do キーワードを入力します。


 

レイヤ 3 EtherChannel に対応するポート チャネル論理インターフェイスの設定


) • レイヤ 2 EtherChannel を設定した場合、レイヤ 2 LAN ポートを手動で作成したポート チャネル論理インターフェイスに含めることはできません。レイヤ 2 EtherChannel を設定する場合、ここで説明する作業は行わないでください(チャネル グループの設定を参照)。

レイヤ 3 EtherChannel を設定する場合、ここで説明する手順に従って、ポート チャネル論理インターフェイスを手動で作成し、さらにレイヤ 3 LAN ポートをチャネル グループに含める必要があります(チャネル グループの設定を参照)。

レイヤ 3 LAN ポートから EtherChannel に IP アドレスを移動させるには、レイヤ 3 LAN ポートから IP アドレスを削除してから、その IP アドレスをポート チャネル論理インターフェイス上で設定する必要があります。


 

レイヤ 3 EtherChannel 用のポート チャネル インターフェイスを作成するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface port-channel number

ポート チャネル インターフェイスを作成します。

Router(config)# no interface port-channel number

ポート チャネル インターフェイスを削除します。

ステップ 2

Router(config-if)# ip address ip_address mask

EtherChannel に IP アドレスおよびサブネット マスクを割り当てます。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show running-config interface port-channel number

設定を確認します。

ポート チャネル インターフェイスを作成する際、 group 番号には、次のいずれかの番号を指定できます。

Release 12.1(5)E 以降 ― 1 ~ 256、最大で 64 のポート チャネル インターフェイス

Release 12.1(4)E1、12.1(3a)E4、および 12.1(3a)E3 ― 1 ~ 64

Release 12.1(2)E 以前 ― 1 ~ 256

次に、インターフェイス port-channel 1 を作成する例を示します。

Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# ip address 172.32.52.10 255.255.255.0
Router(config-if)# end
 

次に、インターフェイス port-channel 1 の設定を確認する例を示します。

Router# show running-config interface port-channel 1
Building configuration...
 
Current configuration:
!
interface Port-channel1
ip address 172.32.52.10 255.255.255.0
no ip directed-broadcast
end
Router#

チャネル グループの設定


) • レイヤ 3 EtherChannel を設定する場合、先にポート チャネル論理インターフェイスを手動で作成し(レイヤ 3 EtherChannel に対応するポート チャネル論理インターフェイスの設定を参照)、そのあとでレイヤ 3 LAN ポートをここで説明する手順に従ってチャネル グループに含める必要があります。

レイヤ 2 EtherChannel を設定するには、ここで説明するように channel-group コマンドで LAN ポートを設定すると、ポート チャネル論理インターフェイスが自動的に作成されます。手動で作成したポート チャネル インターフェイスにレイヤ 2 LAN ポートを組み込むことはできません。

Cisco IOS がレイヤ 2 EtherChannel 用のポート チャネル インターフェイスを作成するには、レイヤ 2 LAN ポートが接続され、機能している必要があります。


 

チャネル グループを設定するには、LAN ポートごとに次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface type 1 slot/port

設定する LAN ポートを選択します。

ステップ 2

Router(config-if)# no ip address

この LAN ポートに IP アドレスが割り当てられていないことを確認します。

ステップ 3

Router(config-if)# channel-protocol ( lacp | pagp }

(任意)選択した LAN ポート上で、 channel-protocol コマンドで設定された EtherChannel プロトコルに channel-protocol コマンドを限定します。

Router(config-if)# no channel-protocol

制限を解除します。

ステップ 4

Router(config-if)# channel-group number mode { active | auto | desirable | on | passive }

ポート チャネル内の LAN ポートを設定し、モードを指定します( 表13-1 を参照)。PAgP は、auto モードと desirable モードのみをサポートします。LACP は、active モードと passive モードのみをサポートします。

Router(config-if)# no channel-group

チャネル グループから LAN ポートを削除します。

ステップ 5

Router(config-if)# lacp port-priority priority_value

(LACP の場合は任意)有効値は 1 ~ 65535 です。数字が大きいほど、プライオリティが下がります。デフォルトは 32768 です。

Router(config-if)# no lacp port-priority

デフォルトに戻します。

ステップ 6

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Router# show running-config interface type 1 slot/port

Router# show interfaces type 1 slot/port etherchannel

設定を確認します。

1.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、ポート FastEthernet 5/6 および 5/7 を、ポート チャネル 2、PAgP モード desirable に設定する例を示します。

Router# configure terminal
Router(config)# interface range fastethernet 5/6 -7
Router(config-if)# channel-group 2 mode desirable
Router(config-if)# end

range キーワードの詳細については、「インターフェイスの範囲設定」を参照してください。


次に、インターフェイス port-channel 2 の設定を確認する例を示します。

Router# show running-config interface port-channel 2
Building configuration...
 
Current configuration:
!
interface Port-channel2
no ip address
switchport
switchport access vlan 10
switchport mode access
end
Router#
 

次に、ポート FastEthernet 5/6 の設定を確認する例を示します。

Router# show running-config interface fastethernet 5/6
Building configuration...
 
Current configuration:
!
interface FastEthernet5/6
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-group 2 mode desirable
end
Router# show interfaces fastethernet 5/6 etherchannel
Port state = Down Not-in-Bndl
Channel group = 12 Mode = Desirable-Sl Gcchange = 0
Port-channel = null GC = 0x00000000 Pseudo port-channel = Po1
2
Port index = 0 Load = 0x00 Protocol = PAgP
 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
 
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/2 d U1/S1 1s 0 128 Any 0
 
Age of the port in the current state: 04d:18h:57m:19s
 

次に、LAN ポートを設定したあとで、インターフェイス port-channel 2 の設定を確認する例を示します。

Router# show etherchannel 12 port-channel
Port-channels in the group:
----------------------
 
Port-channel: Po12
------------
 
Age of the Port-channel = 04d:18h:58m:50s
Logical slot/port = 14/1 Number of ports = 0
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Not-Inuse
Protocol = PAgP
 
Router#

LACP システム プライオリティおよびシステム ID の設定

LACP システム ID は、LACP システム プライオリティ値とルータの MAC アドレスを組み合わせたものです。

LACP システム プライオリティおよびシステム ID を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config)# lacp system-priority priority_value

(LACP の場合は任意)有効値は 1 ~ 65535 です。数字が大きいほど、プライオリティが下がります。デフォルトは 32768 です。

Router(config)# no lacp system-priority

デフォルトに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show lacp sys-id

設定を確認します。

次に、LACP システム プライオリティを設定する例を示します。

Router# configure terminal
Router(config)# lacp system-priority 23456
Router(config)# end
Router(config)#
 

次に、設定を確認する例を示します。

Router# show lacp sys-id
23456,0050.3e8d.6400
Router#
 

システム プライオリティが先に表示され、続いてルータの MAC アドレスが表示されます。

EtherChannel ロード バランシングの設定

EtherChannel のロード バランシングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# port-channel load-balance { src-mac | dst-mac | src-dst-mac | src-ip | dst-ip | src-dst-ip | src-port | dst-port | src-dst-port }

EtherChannel ロード バランシングを設定します。

Router(config)# no port-channel load-balance

デフォルトの EtherChannel ロード バランシングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show etherchannel load-balance

設定を確認します。

ロードバランシング キーワードは次の情報を表します。

PFC2 の場合:

src-port ― 送信元のレイヤ 4 ポート

dst-port ― 宛先のレイヤ 4 ポート

src-dst-port ― 送信元および宛先のレイヤ 4 ポート

PFC または PFC2 の場合:

src-ip ― 送信元の IP アドレス

dst-ip ― 宛先の IP アドレス

src-dst-ip ― 送信元および宛先の IP アドレス

src-mac ― 送信元の MAC アドレス

dst-mac ― 宛先の MAC アドレス

src-dst-mac ― 送信元および宛先の MAC アドレス

次に、送信元および宛先の IP アドレスを使用するように EtherChannel を設定する例を示します。

Router# configure terminal
Router(config)# port-channel load-balance src-dst-ip
Router(config)# end
Router(config)#
 

次に、設定を確認する例を示します。

Router# show etherchannel load-balance
Source XOR Destination IP address
Router#