Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.1E
レイヤ 3 インターフェイスの設定
レイヤ 3 インターフェイスの設定
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

レイヤ 3 インターフェイスの設定

IP ルーティングおよびアドレスの設定

IPX ルーティングおよびネットワーク番号の設定

AppleTalk ルーティング、ケーブル範囲、およびゾーンの設定

レイヤ 3 インターフェイス上のその他のプロトコルの設定

レイヤ 3 インターフェイスの設定

この章では、Cisco 7600 シリーズ ルータ上でレイヤ 3 インターフェイスを設定する方法について説明します。ここでの説明は、次の URL から利用できる Release 12.1 のマニュアルに記載されている情報および手順を補足するものです。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/index.htm

この章で説明する内容は、次のとおりです。

「IP ルーティングおよびアドレスの設定」

「IPX ルーティングおよびネットワーク番号の設定」

「AppleTalk ルーティング、ケーブル範囲、およびゾーンの設定」

「レイヤ 3 インターフェイス上のその他のプロトコルの設定」


) • この章で使用しているコマンドの構文および使用方法の詳細については、『Cisco 7600 Series Router Cisco IOS Command Reference』および次の URL にある Release 12.1 のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/index.htm

Release 12.1(13)E 以降のリリースで、4,096 のレイヤ 3 VLAN インターフェイスの設定がサポートされます。

Supervisor Engine 1 または Supervisor Engine 2 を装備した MSFC2 上に設定するレイヤ 3 VLAN インターフェイスおよびレイヤ 3 ポートは、合計で 2,000 を超えないようにすることを推奨します。

1 つの MSFC 上に設定するレイヤ 3 VLAN インターフェイスおよびレイヤ 3 ポートは、合計で 1,000 を超えないようにすることを推奨します。

Release 12.1(13)E より前のリリースでは、Supervisor Engine 1 または Supervisor Engine 2 を装備した MSFC2 がサポートするレイヤ 3 VLAN インターフェイスおよびレイヤ 3 ポートは、合計で最大 1,000 です。

Release 12.1(13)E より前のリリースでは、Supervisor Engine 1 を装備した MSFC は最大で 256 のレイヤ 3 VLAN インターフェイスをサポートします。

VLAN インターフェイスをサポートするには、VLAN の作成および設定を行い、レイヤ 2 LAN ポートに VLAN メンバーシップを割り当てます。詳細については、 第9章「VLAN の設定」 および 第8章「VTP の設定」 を参照してください。

Cisco 7600 シリーズ ルータでレイヤ 3 トランクがサポートされるのは、4 ポート ギガビット イーサネット WAN モジュール(OSM-4GE-WAN および OSM-2+4GE-WAN+)だけです。LAN ポートにサブインターフェイスを設定したり、 encapsulation キーワードを設定したりすることはできません。Cisco 7600 シリーズ ルータはレイヤ 2 トランクおよびレイヤ 3 VLAN インターフェイスをサポートしており、これらは LAN ポートと同等の機能を提供します。 第7章「レイヤ 2 スイッチング用 LAN ポートの設定」 および「IP ルーティングおよびアドレスの設定」を参照してください。

Release 12.1(11b)E 以降を使用している場合に、コンフィギュレーション モードで EXEC モードレベルのコマンドを入力するには、EXEC モードレベルのコマンドの前に do キーワードを入力します。


 

IP ルーティングおよびアドレスの設定

詳しい説明および設定手順については、次のマニュアルを参照してください。

次の URL の『 Cisco IOS IP and IP Routing Configuration Guide 』 Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_c/index.htm

次の URL の『 Cisco IOS IP and IP Routing Command Reference 』 Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_r/index.htm

Release 12.1 E の maximum paths コマンドの詳細については、『 Cisco 7600 Series Router Cisco IOS Command Reference 』を参照してください。

Policy Feature Card 2(PFC2; ポリシー フィーチャ カード 2)および Distributed Feature Card(DFC)は、 match ip address および set ip next-hop の Policy-Based Routing(PBR; ポリシーベース ルーティング)キーワードを使用するルートマップ シーケンスに対して、PBR をハードウェアでサポートします。

Release 12.1(11b)E 以降で、PFC2 および DFC は、 ip default next-hop PBR キーワードのハードウェア サポートを提供します。

Multilayer Switch Feature Card 2(MSFC2; マルチレイヤ スイッチ フィーチャ カード 2)は、 match length および set interface キーワードを使用するルートマップ シーケンスをソフトウェアで処理します。

PBR の設定については、次の URL にある『 Cisco IOS Quality of Service Solutions Configuration Guide 』Release 12.1 の「Classification」および「Configuring Policy-Based Routing」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_c/qcprt1/qcdpbr.htm

レイヤ 3 インターフェイスに IP ルーティングおよび IP アドレスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ip routing

IP ルーティングをイネーブルにします(IP ルーティングがディセーブルになっている場合のみ)。

ステップ 2

Router(config)# router ip_routing_protocol

IP ルーティング プロトコルを指定します。

ステップ 3

Router(config-router)# ip_routing_protocol_commands

IP ルーティング プロトコルを設定します。

ステップ 4

Router(config-router)# exit

IP ルーティング プロトコル コンフィギュレーション モードを終了します。

ステップ 5

Router(config)# interface { vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 6

Router(config-if)# ip address ip_address subnet_mask

IP アドレスおよび IP サブネットを設定します。

ステップ 7

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 8

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 9

Router# show interfaces [{ vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }]

Router# show ip interfaces [{ vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }]

Router# show running-config interfaces [{ vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }]

設定を確認します。

1.type = ethernetfastethernetgigabitethernettengigabitethernet、または ge-wan

次に、IP Routing Information Protocol(RIP)ルーティングをイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ip routing
Router(config)# router rip
Router(config-router)# network 10.0.0.0
Router(config-router)# end
Router#
 

次に、ポート FastEthernet 5/4 に IP アドレスを設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 5/4
Router(config-if)# ip address 172.20.52.106 255.255.255.248
Router(config-if)# no shutdown
Router(config-if)# end
Router#
 

次に、show interfaces コマンドを使用して、ポート FastEthernet 5/4 のインターフェイス IP アドレスの設定およびステータスを表示する例を示します。

Router# show interfaces fastethernet 5/4
FastEthernet5/4 is up, line protocol is up
Hardware is Cat6K 100Mb Ethernet, address is 0050.f0ac.3058 (bia 0050.f0ac.3058)
Internet address is 172.20.52.106/29
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
7 packets input, 871 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
8 packets output, 1658 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Router#
 

次に、show ip interface コマンドを使用して、ポート FastEthernet 5/4 の設定の詳細およびステータスを表示する例を示します。

Router# show ip interface fastethernet 5/4
FastEthernet5/4 is up, line protocol is up
Internet address is 172.20.52.106/29
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.10
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP Fast switching turbo vector
IP Normal CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
IP multicast multilayer switching is disabled
IP mls switching is enabled
Router#
 

次に、show running-config コマンドを使用して、ポート FastEthernet 5/4 のインターフェイス IP アドレスの設定を表示する例を示します。

Router# show running-config interfaces fastethernet 5/4
Building configuration...
 
Current configuration:
!
interface FastEthernet5/4
description "Router port"
ip address 172.20.52.106 255.255.255.248
no ip directed-broadcast
!

IPX ルーティングおよびネットワーク番号の設定

詳しい説明および設定手順については、次のマニュアルを参照してください。

次の URL の『 Cisco IOS AppleTalk and Novell IPX Configuration Guide 』Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/atipx_c/index.htm

次の URL の『 Cisco IOS AppleTalk and Novell IPX Command Reference 』Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/atipx_r/index.htm

Internetwork Packet Exchange(IPX)ルーティングを設定し、レイヤ 3 インターフェイスに IPX を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ipx routing

IPX ルーティングをイネーブルにします。

ステップ 2

Router(config)# router ipx_routing_protocol

IP ルーティング プロトコルを指定します。 このステップでは、他のコマンド(ルーティングするネットワークを指定する network コマンドなど)も使用する場合があります。

ステップ 3

Router(config)# interface { vlan vlan_ID } | { type 2 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 4

Router(config-if)# ipx network [ network | unnumbered ] encapsulation encapsulation_type

IPX ネットワーク番号を設定します。このステップにより、インターフェイス上で IPX ルーティングがイネーブルになります。インターフェイス上で IPX ルーティングをイネーブルにするとき、カプセル化タイプも指定できます。

ステップ 5

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Router# show interfaces [{ vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }]

Router# show ipx interfaces [{ vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }]

Router# show running-config interfaces [{ vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }]

設定を確認します。

2.type = ethernetfastethernetgigabitethernettengigabitethernet、または ge-wan

次に、IPX ルーティングをイネーブルにし、インターフェイス VLAN 100 に IPX ネットワーク アドレスを割り当てる例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ipx routing
Router(config)# ipx router rip
Router(config-ipx-router)# network all
Router(config-ipx-router)# interface vlan 100
Router(config-if)# ipx network 100 encapsulation snap
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config

AppleTalk ルーティング、ケーブル範囲、およびゾーンの設定

詳しい説明および設定手順については、次のマニュアルを参照してください。

次の URL の『 Cisco IOS AppleTalk and Novell IPX Configuration Guide 』Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/atipx_c/index.htm

次の URL の『 Cisco IOS AppleTalk and Novell IPX Command Reference 』Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/atipx_r/index.htm

AppleTalk ルーティングを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# appletalk routing

AppleTalk ルーティングをイネーブルにします。

ステップ 2

Router(config)# interface { vlan vlan_ID } | { type 3 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 3

Router(config-if)# appletalk cable-range cable_range

インターフェイスにケーブル範囲を割り当てます。

ステップ 4

Router(config-if)# appletalk zone zone_name

インターフェイスにゾーン名を割り当てます。

ステップ 5

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Router# show interfaces [{ vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }]

Router# show appletalk interfaces [{ vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }]

Router# show running-config interfaces [{ vlan vlan_ID } | { type 1 slot/port } | { port-channel port_channel_number }]

設定を確認します。

3.type = ethernetfastethernetgigabitethernettengigabitethernet、または ge-wan

次に、AppleTalk ルーティングをイネーブルにして、インターフェイス VLAN 100 に AppleTalk ケーブル範囲およびゾーン名を割り当てる例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# appletalk routing
Router(config)# interface vlan 100
Router(config-if)# appletalk cable-range 100-100
Router(config-if)# appletalk zone Engineering
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config

レイヤ 3 インターフェイス上のその他のプロトコルの設定

レイヤ 3 インターフェイスにその他のプロトコルを設定する手順については、次のマニュアルを参照してください。

次の URL の『 Cisco IOS Apollo Domain, VINES, DECnet, ISO CLNS, and XNS Configuration Guide 』Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/apollo_c/index.htm

次の URL の『 Cisco IOS Apollo Domain, VINES, DECnet, ISO CLNS, and XNS Command Reference 』Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/apollo_r/index.htm