Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ ルーティング コマンド リファレンス リリース 4.3.x
Cisco ASR 9000 シリーズ ルータの EIGRP コマンド
Cisco ASR 9000 シリーズ ルータの EIGRP コマンド
発行日;2013/07/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

Cisco ASR 9000 シリーズ ルータの EIGRP コマンド

このモジュールでは、Enhanced Interior Gateway Routing Protocol(EIGRP)の設定およびモニタに使用するコマンドについて説明します。

EIGRP の概念、設定作業、および例については、 『Cisco ASR 9000 Series Aggregation Services Router Routing Configuration Guide』の「Implementing EIGRP on Cisco ASR 9000 Series Router 」のモジュールを参照してください。

address-family(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)で IPv4 アドレス ファミリをイネーブルにするには、適切なモードで address-family コマンドを使用します。 EIGRP 設定からアドレス ファミリを削除するには、このコマンドの no 形式を使用します。

address-family { ipv4 | ipv6 }

no address-family { ipv4 | ipv6 }

構文の説明

ipv4

IPv4 アドレス ファミリを選択します。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

EIGRP で IPv4 アドレス ファミリ セッションを設定するには、address-family ipv4 コマンドを使用します。

EIGRP バーチャル プライベート ネットワーク(VPN)は、まず初めに VRF コンフィギュレーション モードを開始した後に、IPv4 アドレス ファミリ コンフィギュレーション モードで設定できます。 autonomous-system コマンドおよび maximum-prefix コマンドを除く、アドレス ファミリ コンフィギュレーション モードのすべてのコマンドを、VRF アドレス ファミリで設定できます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、vrf1 という VRF を定義した後に IPv4 VRF アドレス ファミリ セッションを設定する例を示します。


  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vrf1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# default-metric 1000 100 255 1 1500

関連コマンド

コマンド

説明

autonomous-system

VRF 内で実行する EIGRP ルーティング プロセスを設定します。

maximum-prefix(EIGRP)

EIGRP がアドレス ファミリで受け入れるプレフィックス数を制限します。

authentication keychain

MD5 アルゴリズムに基づいて 1 つ以上のインターフェイスですべての EIGRP プロトコル トラフィックを認証するには、適切なコンフィギュレーション モードで authentication keychain コマンドを使用します。 認証をディセーブルにするには、このコマンドの no 形式を使用します。

authentication keychain key-chain-name

no authentication keychain key-chain-name

構文の説明

key-chain-name

認証キーチェーン名

コマンド デフォルト

認証はディセーブルです。

コマンド モード

IPv4 アドレス ファミリ インターフェイス コンフィギュレーション

IPv6 アドレス ファミリ インターフェイス コンフィギュレーション

IPv4 VRF アドレス ファミリ インターフェイス コンフィギュレーション

IPv6 VRF アドレス ファミリ インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

EIGRP で IPv4 アドレス ファミリ セッションを設定するには、address-family ipv4 コマンドを使用し、EIGRP で IPv6 アドレス ファミリ セッションを設定するには、address-family ipv6 コマンドを使用します。

EIGRP バーチャル プライベート ネットワーク(VPN)は、まず初めに VRF コンフィギュレーション モードを開始した後に、IPv4 および IPv6 アドレス ファミリ コンフィギュレーション モードで設定できます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、EIGRP 認証キーチェーンをイネーブルにする例を示します。

RP/0/RSP0/CPU0:routerconfigure eigrp 1
RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4 
RP/0/RSP0/CPU0:router(config-eigrp-af)# interface POS 0/2/0/0 
RP/0/RSP0/CPU0:router(config-eigrp-if)# authentication key chain key1

関連コマンド

コマンド

説明

router eigrp

ルーティング プロセスを設定して、Enhanced Interior Gateway Routing Protocol(EIGRP)のルータ コンフィギュレーション モードを開始します。

auto-summary(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスでサブネット ルートをネットワークレベルのルートに自動サマライズできるようにするには、適切なモードで auto-summary コマンドを使用します。 この機能をディセーブルにし、クラスフル ネットワーク境界を越えてサブプレフィックス ルーティング情報を送信するには、このコマンドの no 形式を使用します。

auto-summary

no auto-summary

構文の説明

このコマンドには、キーワードと引数はありません。

コマンド デフォルト

このコマンドの動作は、デフォルトではディセーブルです (ソフトウェアは、クラスフル ネットワーク境界を越えてサブネット ルーティング情報を送信します)。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ルート集約により、ルーティング テーブルにおけるルーティング情報の量が少なくなります。 クラスフル ネットワーク境界を越える場合に、クラスフル ネットワーク境界までのサマリー サブプレフィックスをソフトウェアで作成できるようにするには、auto-summary コマンドを使用します。

EIGRP 集約ルートには、アドミニストレーティブ ディスタンス値 5 が割り当てられます。 この値は設定できません。

タスク ID

タスク ID

操作

eigrp

read, write

次に、EIGRP 1 の自動サマライズをイネーブルにする例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vpn-1
  
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# auto-summary
  
         

関連コマンド

コマンド

説明

summary-address(EIGRP)

指定されたインターフェイスのサマリー集約アドレスを設定します。

autonomous-system

VPN ルーティングおよび転送インスタンス(VRF)内で実行する Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティング プロセスを設定するには、IPv4 VRF アドレス ファミリ コンフィギュレーション モードで autonomous-system コマンドを使用します。

autonomous-system as-number

no autonomous-system as-number

構文の説明

as-number

EIGRP ルーティング プロセスの自律システム番号 値の範囲は 1 ~ 65535 です。

コマンド デフォルト

なし

コマンド モード

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

IPv4 アドレス ファミリ コンフィギュレーション モードで autonomous-system コマンドを使用します。

タスク ID

タスク ID

操作

eigrp

read, write

次に、VRF VPN-1 で自律システム 101 を設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router eigrp 1
 RP/0/RSP0/CPU0:router(config-eigrp)# vrf vpn-1
RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# autonomous-system 101
  
         

関連コマンド

コマンド

説明

vrf(EIGRP)

VRF インスタンスを定義し、VRF コンフィギュレーション モードを開始します。

bandwidth-percent(EIGRP)

インターフェイス上で EIGRP の使用する帯域幅の割合を設定するには、インターフェイス コンフィギュレーション モードで bandwidth-percent コマンドを使用します。 デフォルト値に戻すには、このコマンドの no 形式を使用します。

bandwidth-percent percent

no bandwidth-percent

構文の説明

percent

EIGRP に使用できる帯域幅のパーセンテージ

コマンド デフォルト

percent:50

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

EIGRP では、帯域幅のインターフェイス コンフィギュレーション コマンドによる定義に従って、リンクの帯域幅を最大 50% まで使用します。 このコマンドは、帯域幅のその他のフラクションが必要な場合に使用できます。 100% よりも大きい値を設定することができます。 他の理由で帯域幅が意図的に低く設定されている場合、この設定オプションは便利な場合があります。

タスク ID

タスク ID

操作

eigrp

read, write

次に、自律システム 209 のインターフェイスを最大 75%(42 kbps)まで使用するように EIGRP を設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# router-id 10.1.1.1
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)# bandwidth-percent 75
  
         

関連コマンド

コマンド

説明

bandwidth(インターフェイス)

インターフェイスの帯域幅値を設定します。

clear eigrp neighbors

適切なテーブルから Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバーのエントリを削除および再設定するには、EXEC モードで clear eigrp neighbors コマンドを使用します。

clear eigrp [ as-number ] [ vrf { vrf | | all } ] [ ipv4 | | ipv6 ] neighbors [ ip-address | type interface-path-id ] [ soft ]

構文の説明

as-number

(任意)自律システム番号。 値の範囲は 1 ~ 65535 です。

vrf { vrf | all }

(任意)特定の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスまたはすべての VRF インスタンスを指定します。

ipv4

(任意)IPv4 アドレス ファミリを指定します。

ip-address

(任意)ネイバーのアドレス。

type

インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

soft

(任意)ソフト リセットを指定します。

コマンド デフォルト

自律システム番号または VRF インスタンスを指定しない場合は、すべての EIGRP ネイバーのエントリがテーブルからクリアされます。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

eigrp

read, write

次に、ネイバー ギガビット イーサネット インターフェイス 0/5/0/0 の EIGRP VRF エントリをすべてクリアする例を示します。


RP/0/RSP0/CPU0:router# clear eigrp vrf customer_1 neighbors GigabitEthernet 0/5/0/0
         

関連コマンド

コマンド

説明

show eigrp interfaces

EIGRP に設定されているインターフェイスに関する情報を表示します。

show eigrp neighbors

EIGRP によって検出されたネイバーを表示します。

clear eigrp topology

適切なテーブルから Enhanced Interior Gateway Routing Protocol(EIGRP)トポロジのエントリを削除して再学習するには、EXEC モードで clear eigrp topology コマンドを使用します。

clear eigrp [ as-number ] [ vrf { vrf | | all } ] [ ipv4 | | ipv6 ] topology [ prefix mask | | prefixl/ength ]

構文の説明

as-number

(任意)自律システム番号。 値の範囲は 1 ~ 65535 です。

vrf { vrf | all }

(任意)特定の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスまたはすべての VRF インスタンスを指定します。

ipv4

(任意)IPv4 アドレス ファミリを指定します。

prefix

出力を特定のルートに制限する IP プレフィックス。

mask

IP アドレス マスク

/ length

プレフィックス長。スラッシュ(/)と数字で指定できます。 たとえば、/8 は、IP プレフィックスの最初の 8 ビットがネットワーク ビットであることを示します。 length を使用する場合、スラッシュが必要です。

コマンド デフォルト

EIGRP トポロジのエントリはクリアされません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

eigrp

read, write

次に、特定のルートの EIGRP トポロジのエントリをクリアする例を示します。

RP/0/RSP0/CPU0:router# clear eigrp topology 10.1.0.0/8
         

関連コマンド

コマンド

説明

show eigrp topology

EIGRP トポロジ テーブルに関する情報を表示します。

default-information

Enhanced Interior Gateway Routing Protocol(EIGRP)の候補のデフォルト ルーティング情報を制御するには、適切なコンフィギュレーション モードで default-information コマンドを使用します。 着信アップデートまたは発信アップデートで EIGRP の候補のデフォルト情報を抑制するには、このコマンドの no 形式を使用します。

default-information allowed { in | out } [ route-policy name ]

no default-information allowed { in | out } [ route-policy name ]

構文の説明

allowed

デフォルト ルーティング情報を受け入れるように EIGRP を指定します。

in

着信のデフォルト ルーティング情報を受け入れるように EIGRP を指定します。

out

発信のデフォルト ルーティング情報を受け入れるように EIGRP を指定します。

route-policy name

(任意)ルート ポリシーを指定します。

コマンド デフォルト

デフォルト ルーティング情報を受け入れず、フラグ付けも行われません。

コマンド モード

アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

eigrp

read, write

次に、ルート ポリシー acme とともに指定された着信のデフォルト ルートを、自律システム 1 の EIGRP ピアで受け入れるように設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vrf1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# default-information accept in route-policy acme
  
         

default-metric(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)のメトリックを設定するには、適切なコンフィギュレーション モードで default-metric コマンドを使用します。 メトリック値を削除し、デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

default-metric bandwidth delay reliability loading mtu

no default-metric

構文の説明

bandwidth

ルートの最小帯域幅(キロビット/秒)。 範囲は 1 ~ 4294967295 です。

delay

10 マイクロ秒単位のルート遅延。 範囲は 1 ~ 4294967295 です。

reliability

パケット送信が成功する可能性(0 ~ 255 の数字で表す)。 255 という値は 100% の信頼性を意味し、0 はリンクに信頼性がないことを意味します。

loading

ルートの有効な帯域幅(1 ~ 255 の数字で表す、255 は 100% のローディング)。

mtu

ルートの最大伝送単位(MTU)のサイズ(バイト)。 値の範囲は 1 ~ 65535 です。

コマンド デフォルト

デフォルト値はありません。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

EIGRP にプロトコルを再配布すると同時にデフォルト メトリック値を提供するには、default-metric コマンドを使用します。

メトリックのデフォルトは、さまざまなネットワークで機能するよう慎重に設定されています。 値を変更する場合は、最大限の注意を払うようにしてください。

タスク ID

タスク ID

操作

eigrp

read, write

次に、再配布された Routing Information Protocol(RIP)メトリックを取得し、bandwidth = 1000、delay = 100、reliability = 250、loading = 100、および MTU = 1500 の値を指定して、EIGRP メトリックに変換する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vrf1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# redistribute rip
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# default-metric 1000 100 250 100 1500
  
         

関連コマンド

コマンド

説明

redistribute

ルートを 1 つのルーティング ドメインから他のルーティング ドメインに再配布します。

distance(EIGRP)

ノードまでのより適切なルートの提供を可能にする、内部と外部、2 つのアドミニストレーティブ ディスタンスのいずれかを使用できるようにするには、適切なコンフィギュレーション モードで distance コマンドを使用します。 この値をデフォルトにリセットするには、このコマンドの no 形式を使用します。

distance internal-distance external-distance

no distance

構文の説明

internal-distance

EIGRP 内部ルートのアドミニストレーティブ ディスタンス。 内部ルートは、同一自律システム(AS)内の他のエンティティから学習するルートです。 ディスタンスは、1 ~ 255 の値です。

external-distance

EIGRP 外部ルートのアドミニストレーティブ ディスタンス。 外部ルートは、AS の外部の送信元から学習する最適なパスのルートです。 ディスタンスは、1 ~ 255 の値です。

コマンド デフォルト

internal-distance:90

external-distance:170

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

アドミニストレーティブ ディスタンスは、個々のルータやルータのグループなど、ルーティング情報発信元の信頼性を表す数値です。 数値的に、アドミニストレーティブ ディスタンスは 0 ~ 255 の整数です。 通常、値が大きいほど、信頼性の格付けが下がります。 アドミニストレーティブ ディスタンスが 255 の場合はルーティング情報の送信元をまったく信頼できないため、無視する必要があります。

Enhanced Interior Gateway Routing Protocol(EIGRP)で優先すべき外部 EIGRP ルートまたは一部の内部ルートを使用して実際に学習したルートよりも、ノードまでのより適切なルートを提供するプロトコルがわかっている場合には、distance コマンドを使用します。

指定されたルーティング プロセスのデフォルト アドミニストレーティブ ディスタンスを表示するには、show protocols EXEC コマンドを使用します。

タスク ID

タスク ID

操作

eigrp

read, write

次に、(vrf vpn-1 内の)すべての EIGRP 1 内部ルートのアドミニストレーティブ ディスタンスを 80 に、すべての EIGRP 外部ルートを 130 に設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vrf1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# distance 80 130
  
         

関連コマンド

コマンド

説明

show protocols(EIGRP)

ルータで動作している EIGRP に関する情報を表示します。

hello-interval(EIGRP)

インターフェイスの hello 間隔を設定するには、インターフェイス コンフィギュレーション モードで hello-interval コマンドを使用します。 デフォルト値に戻すには、このコマンドの no 形式を使用します。

hello-interval seconds

no hello-interval

構文の説明

seconds

hello インターバル(秒単位)。 値の範囲は 1 ~ 65535 です。

コマンド デフォルト

低速の非ブロードキャスト マルチアクセス(NBMA)ネットワークの場合:60 秒

その他のすべてのネットワークの場合:5 秒

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

eigrp

read, write

次に、インターフェイスの hello 間隔を 10 秒に設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp)# router-id 10.1.1.1
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)# hello-interval 10
  
         

hold-time(EIGRP)

インターフェイスのホールドタイムを設定するには、インターフェイス コンフィギュレーション モードで hold-time コマンドを使用します。 デフォルト値に戻すには、このコマンドの no 形式を使用します。

hold-time seconds

no hold-time

構文の説明

seconds

ホールド時間(秒単位)。 値の範囲は 1 ~ 65535 です。

コマンド デフォルト

デフォルトの 15 秒の hello 間隔の 3 倍。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

非常に輻輳した大規模なネットワークでは、デフォルトの保留時間では、全ルータがネイバーから hello パケットを受信するまでに十分な時間がない場合もあります。 この場合、ホールド タイムを増やすこともできます。

ホールド タイムは、少なくとも hello 間隔の 3 倍にすることを推奨します。 指定されたホールド時間内にルータが hello パケットを受信しなかった場合は、そのルータ経由のルートが使用できないと判断されます。

ホールド タイムを増やすと、ネットワーク全体のルート収束が遅くなります。

RP フェールオーバー中のノンストップ フォワーディングを確実にするため、ホールドタイムを 30 秒まで増やすことを推奨します。

タスク ID

タスク ID

操作

eigrp

read, write

次に、インターフェイスのホールドタイムを 0 ~ 40 秒に設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp)# router-id 10.1.1.1
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)# hold-time 40
  
         

関連コマンド

コマンド

説明

bandwidth(インターフェイス)

インターフェイスの帯域幅値を設定します。

hello-interval(EIGRP)

自律システム番号によって指定された EIGRP ルーティング プロセスの hello インターバルを設定します。

interface(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティング プロトコルを実行するインターフェイスを定義するには、適切なコンフィギュレーション モードで interface コマンドを使用します。 インターフェイスの EIGRP ルーティングをディセーブルにするには、このコマンドの no 形式を使用します。

interface type interface-path-id

no interface type interface-path-id

構文の説明

type

インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

(注)     

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

コマンド デフォルト

コンフィギュレーション モードでこのコマンドを指定しないと、インターフェイスの EIGRP ルーティングはイネーブルにはなりません。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

特定のインターフェイスを EIGRP プロセスに関連付けるには、interface コマンドを使用します。 インターフェイスの IPv4 アドレスが変更された場合でも、インターフェイスがプロセスに関連付けされた状態は変わりません。

このコマンドを使用すると、ルータをインターフェイス コンフィギュレーション モードにします。このモードから、インターフェイス固有の設定を実行できます。 このモードで設定されたコマンド(hello-interval コマンドなど)は、このインターフェイスに自動的にバインドされます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、EIGRP プロセス 1 のインターフェイス コンフィギュレーション モードを開始し、GigabitEthernet インターフェイス 0/1/0/0 の hello 間隔を 10 秒に設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp)# router-id 10.1.1.1
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)# hello-interval 10
  
         

log-neighbor-changes

Enhanced Interior Gateway Routing Protocol(EIGRP)隣接ルータとの隣接関係における変更のロギングをイネーブルにするには、適切なコンフィギュレーション モードで log-neighbor-changes コマンドを使用します。 EIGRP 隣接ルータとの隣接関係における変更のロギングをディセーブルにするには、このコマンドの no 形式を使用します。

log-neighbor-changes

no log-neighbor-changes

コマンド デフォルト

このコマンドには、キーワードと引数はありません。

隣接の変更はロギングされません。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

隣接ルータとの隣接関係における変更をロギングし、ルーティング システムの安定性をモニタして、問題を検出しやすくするには、log-neighbor-changes コマンドを使用します。 ロギングはデフォルトではディセーブルになっています。 隣接ルータとの隣接関係の変更のロギングをディセーブルにするには、このコマンドの no 形式を使用します。

タスク ID

タスク ID

操作

eigrp

read, write

次に、EIGRP 1 のネイバーの変更に対するロギングをイネーブルにする例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# log-neighbor-changes
  
         

log-neighbor-warnings

Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバー警告メッセージのロギングをイネーブルにするには、適切なコンフィギュレーション モードで log-neighbor-warnings コマンドを使用します。 EIGRP ネイバー警告メッセージのロギングをディセーブルにするには、このコマンドの no 形式を使用します。

log-neighbor-warnings

no log-neighbor-warnings

構文の説明

このコマンドには、キーワードと引数はありません。

コマンド デフォルト

ネイバー警告メッセージのロギングは行われません。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ネイバー警告メッセージをディセーブルおよびイネーブルにするには、log-neighbor-warnings コマンドを使用します。 ネイバー警告メッセージが表示される場合、デフォルトではそのメッセージのロギングは行われません。

タスク ID

タスク ID

操作

eigrp

read, write

次に、EIGRP プロセス 20 のネイバー警告メッセージのログを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 20
  RP/0/RSP0/CPU0:router(config-eigrp) vrf vrf1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# log-neighbor-warnings
  
         

maximum-paths(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)でサポートできる最大パラレル ルート数を制御するには、適切なコンフィギュレーション モードで maximum-paths コマンドを使用します。 コンフィギュレーション ファイルから maximum-paths コマンドを除去して、ルーティング プロトコルに関してシステムをデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum-paths

構文の説明

maximum

EIGRP がルーティング テーブル内にインストールできるパラレル ルートの最大数。 範囲は、1 ~ 32 ルートです

コマンド デフォルト

maximum:4

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

EIGRP プロトコルで複数のパスをプレフィックスごとにルーティング テーブルに追加できるようにするには、maximum-paths コマンドを使用します。 内部ルートと外部ルートの両方について、複数のパスがインストールされます。これは、複数のパスが同じ自律システムで学習され、等コスト(EIGRP 最適パス アルゴリズムに基づいて)である場合に限られます。

タスク ID

タスク ID

操作

eigrp

read, write

次の例では、1 つの宛先に最大 10 のパスが許可されます。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) vrf vrf1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# maximum-paths 10
  
         

maximum-prefix(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)が VRF アドレス ファミリで受け入れるプレフィックス数を制限するには、IPv4 VRF アドレス ファミリ コンフィギュレーション モードで maximum-prefix コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

maximum-prefix maximum [threshold] [dampened] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] [warning-only]

no maximum-prefix maximum [threshold] [dampened] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] [warning-only]

構文の説明

maximum

アドレス ファミリで受け入れる最大プレフィックス数。 範囲は 1 ~ 4294967295 です。

設定可能なプレフィックスの数は、ルータ上の利用可能なシステム リソースによってだけ制限されます。

threshold

(任意)プレフィックス数の上限値を超えた割合として syslog 警告メッセージを指定します。 プレフィックスの割合を表す数値の範囲は 1 ~ 100 です。 デフォルトは 75% です。

dampened

(任意)プレフィックス数の上限値を超えるたびに減衰ペナルティが再起動時間に適用されます。 減衰ペナルティのハーフライフは、デフォルトまたはユーザ定義の再起動時間(分単位)の 150 %です。 このキーワードは、デフォルトでディセーブルです。

reset-time minutes

(任意)再起動回数は、デフォルトまたはユーザ定義のリセット時間を経過した後、0 にリセットされます。 minutes 引数に適用可能な値の範囲は 1 ~ 65535 分です。 デフォルトの reset-time 期間は 15 分です。

restart minutes

(任意)プレフィックス数の上限値を超えた後、ルータ隣接が形成されない、または再配布ルートを Routing Information Base(RIB; ルーティング情報ベース)から受け入れない期間。 minutes 引数の値は 1 ~ 65535 分です。 デフォルト再起動時間は 5 分です。

restart-count number

(任意)ピア セッションを解放した後、または最大プレフィックス数が上限を超えた際に再配布ルートがクリアされて再学習した後、ピア セッションが自動的に再確立される回数。 デフォルトの再起動回数の制限値は 3 です。

再起動回数のしきい値を超えたら、clear route コマンドまたは clear eigrp neighbors コマンドを使用して、標準のピアリングおよび再配布を再確立する必要があります。

warning-only

(任意)プレフィックス数の上限値に達したときだけ、ピア セッションを終了する代わりに syslog メッセージを生成するようにルータを設定します。

コマンド デフォルト

threshold:75%

dampened:False

reset-time:15 分

restart:5 分

restart-count:3

warning-only:False

コマンド モード

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

すべての送信元から受け入れるプレフィックス数を制限するには、maximum-prefix コマンドを使用します。 プレフィックス数の上限値を超えた場合、リモート ピアを含むセッションは解放され、リモート ピアからまたは再配布を通じて学習したすべてのルートはトポロジおよびルーティング テーブルから削除されます。また、デフォルトまたはユーザ定義の期間は再配布およびピアリングを中断します。

タスク ID

タスク ID

操作

eigrp

read, write

次に、EIGRP プロセスのプレフィックス数の上限値を設定する例を示します。これには、再配布を通じて学習したルートおよび EIGRP ピア セッションを通じて学習したルートが含まれます。 最大制限は 50,000 プレフィックスに設定されています。 再配布を通じて学習したプレフィックス数が 37,500(50,000 の 75%)に達した場合、コンソールに警告メッセージが表示されます。 プレフィックス数の上限値を超えた場合、すべてのピア セッションがリセットされます。トポロジおよびルーティング テーブルはクリアされ、再配布ルートおよびすべてのピア セッションはペナルティ ステートになります。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vrf1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# maximum-prefix 50000 
  
         

関連コマンド

コマンド

説明

clear eigrp neighbors

EIGRP VPN ネイバーのエントリをテーブルから削除します。

clear route

IP ルーティング テーブルからルートを削除します。

metric(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスのメトリックを設定するには、インターフェイス コンフィギュレーション モードで metric コマンドを使用します。 メトリック値を削除し、デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

metric { bandwidth | delay [picoseconds] | load | reliability }

no metric

構文の説明

bandwidth

ルートのインターフェイスの最小帯域幅(キロビット/秒)。 範囲は 1 ~ 4294967295 です。

delay

インターフェイスのルート遅延(10 マイクロ秒単位)。 遅延は 1 か、または 39.1 ナノ秒の倍数である正の数値。 範囲は 1 ~ 4294967295 です。

ピコ秒単位でインターフェイスのルート遅延を指定するには、picoseconds キーワードを使用します。
  • picoseconds を使用しない場合は、数十マイクロ秒のインターフェイスのルート遅延(デフォルト)。 範囲は 1 ~ 4294967295 です。
  • picoseconds が使用されている場合は、ピコ秒単位のインターフェイスのルート遅延。 範囲は 1 ~ 4294967295 です。
picoseconds (任意)インターフェイスのルート遅延をピコ秒単位で指定します。
load

ルートの有効な帯域幅(1 ~ 255 の数字で表す、255 は 100% ロード済み)。

reliability

パケット送信が成功する可能性(0 ~ 255 の数字で表す)。 255 という値は 100% の信頼性を意味し、0 はまったく信頼性がないことを意味します。

コマンド デフォルト

メトリック値は設定されていません。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース 変更箇所

リリース 3.6.2

このコマンドが追加されました。

リリース 4.3.0

picoseconds キーワードが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

EIGRP インターフェイスにプロトコルを再配布すると同時にメトリック値を提供するには、metric コマンドを使用します。 メトリックのデフォルトは、さまざまなネットワークで機能するよう慎重に設定されています。 値を変更する場合は、最大限の注意を払うようにしてください。

picoseconds キーワードは 64 ビット モードでのみサポートされます。

タスク ID

タスク ID 操作

eigrp

read, write

次に、bandwidth = 100、delay = 7、reliability = 250、および load = 100 の値を使用してインターフェイス POS 0/1/0/1 のメトリック値を設定する例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# router eigrp 100
RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
RP/0/RSP0/CPU0:router(config-eigrp-af)# interface POS 0/1/0/1
RP/0/RSP0/CPU0:router(config-eigrp-af-if)# metric bandwidth 100 delay 7 reliability 250 load 100

次に、インターフェイス GigabitEthernet0/0/0/0 の遅延を 100 ピコ秒に設定する例を示します。
RP/0/RSP0/CPU0:router#configure
RP/0/RSP0/CPU0:router(config)#router eigrp 1
RP/0/RSP0/CPU0:router(config-eigrp)#address-family ipv6
RP/0/RSP0/CPU0:router(config-eigrp-af-if)#metric delay 100 picoseconds

関連コマンド

コマンド 説明

default-metric(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)のメトリックを設定します

metric maximum-hops

コマンドで指定されたホップ カウントよりも大きいホップ カウントを持つ、Enhanced Interior Gateway Routing Protocol(EIGRP)ルートを到達不能としてアドバタイズするには、適切なコンフィギュレーション モードで metric maximum-hops コマンドを使用します。 値をデフォルトにリセットするには、このコマンドの no 形式を使用します。

metric maximum-hops hops-number

no metric maximum-hops

構文の説明

hops-number

最大ホップ カウント。 範囲は 1 ~ 255 ホップです。

コマンド デフォルト

hops-number100

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

無限にカウントされる潜在的な問題を解決する安全機構を提供するには、metric maximum-hops コマンドを使用します。 このコマンドを使用すると、hops-number 引数に指定された値よりも大きいホップ カウントを持つルートを到達不能として EIGRP ルーティング プロトコルがアドバタイズするようになります。

タスク ID

タスク ID

操作

eigrp

read, write

次に、通常の(ループのない)運用でホップ カウントが大きくなる複雑な WAN を含むルータに、200 までのホップ カウントを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# metric maximum-hops 200
  
         

関連コマンド

コマンド

説明

metric weights

EIGRP メトリック計算の調整が可能になります。

metric rib-scale

EIGRP の RIB スケールを設定するには、適切なコンフィギュレーション モードで metric rib-scale コマンドを使用します。 RIB スケールを削除し、デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

metric rib-scale scale-down-value

no metric rib-scale

構文の説明

scale-down-value

4 バイトの RIB メトリックに変換するために、EIGRP ワイド メトリックを分割する量。 有効な範囲は 1 ~ 256 です。 結果は整数としてのみ表示されます(丸めなし)。

コマンド デフォルト

デフォルトの RIB のスケールは 64 ビット モードで 128 です。

32 ビット モードでは、RIB のスケールは常に 1 です。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv6 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

IPv6 VRF アドレス ファミリ コンフィギュレーション(64 ビット モードでのみサポート)

コマンド履歴

リリース 変更箇所

リリース 4.3.0

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

RIB メトリックをスケールする機能は、metric rib-scaleコンフィギュレーション コマンドを使用して行われます。 このコマンドを入力すると、RIB のすべてのルートがクリアされ、新しいメトリック値で置き換えられます。

タスク ID

タスク ID 操作

eigrp

read, write

次に、metric rib-scale を 64 として設定する例を示します。

RP/0/RSP0/CPU0:router#configure
RP/0/RSP0/CPU0:router(config)#router eigrp 1
RP/0/RSP0/CPU0:router(config-eigrp)#address-family ipv4
RP/0/RSP0/CPU0:router(config-eigrp-af)#metric rib-scale 64

metric weights

Enhanced Interior Gateway Routing Protocol(EIGRP)メトリック計算を調整できるようにするには、適切なコンフィギュレーション モードで metric weights コマンドを使用します。 デフォルト値にリセットするには、このコマンドの no 形式を使用します。

metric weights tos k1 k2 k3 k4 k5 k6

no metric weights

構文の説明

tos

常にゼロにする必要のあるタイプ オブ サービス(ToS)。

k1 k2 k3 k4 k5k6

EIGRP メトリック ベクトルをスカラー量に変換する定数。 範囲は 0 ~ 4294967295 です。

コマンド デフォルト

tos:0

k1:1

k2:0

k3:1

k4:0

k5:0

k6:0

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 4.3.0

k6 定数のサポートが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

EIGRP のルーティングおよびメトリック計算のデフォルト動作を変更し、特定の ToS の EIGRP メトリック計算の調整を可能にするには、metric weights コマンドを使用します。

k5 が 0 に等しい場合、次の計算式に従って複合 EIGRP メトリックが計算されます。

メトリック = [k1 * 帯域幅 + (k2 * 帯域幅)/(256 – 負荷) + k3 * 遅延]

k5 がゼロに等しくない場合、追加の計算が実行されます。

メトリック = メトリック * [k5/(信頼性 + k4)]

帯域幅は、2.56 * 1012 の係数で定めた、BPS 単位のパスの最小帯域幅の逆数です。 範囲は 1200-bps ラインから 10 テラビット/秒です。

遅延は 10 マイクロ秒単位です。 遅延の範囲は 10 マイクロ秒 ~ 168 秒です。 遅延がオール 1 のときは、ネットワークが到達不能であることを示します。

遅延パラメータは 32 ビットのフィールドに格納され、39.1 ナノ秒単位で増加します。 遅延の範囲は 1(39.1 ナノ秒)から 16 進数値 FFFFFFFF(10 進数で 4,294,967,040 ナノ秒)です。 遅延がオール 1(つまり、遅延が 16 進数で FFFFFFFF)のときは、ネットワークが到達不能であることを示します。

次の表に、複数の共通メディアで使用されるデフォルト値を示します。

このコマンドは、64 ビット モードでのみサポートされます。 制約値 k6 は 64 ビット モードでは有効ではありません。

表 1 メディア タイプごとの帯域幅値

メディア タイプ

遅延

帯域幅

Satellite

5120(2 秒)

5120(500 MB)

Ethernet

25600(1 ミリ秒 [ms])

256000(10 メガビット)

1.544 Mbps

512000(20,000 ms)

1,657,856 ビット

64 kbps

512000(20,000 ms)

40,000,000 ビット

56 kbps

512000(20,000 ms)

45,714,176 ビット

10 kbps

512000(20,000 ms)

256,000,000 ビット

1 kbps

512000(20,000 ms)

2,560,000,000 ビット

信頼性は 255 のフラクションとして指定されます。 つまり、255 は 100% の信頼性または、十分に安定したリンクです。 負荷は、255 のフラクションとして指定されます。 負荷 255 は、完全に飽和状態のリンクを表します。

タスク ID

タスク ID

操作

eigrp

read, write

metric weights のデフォルト値の変更例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# metric weights 0 2 0 2 0 0

次に、k6 をデフォルト以外の値 1 に設定する例を示します。
  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# metric weights 0 1 0 1 0 0 1

関連コマンド

コマンド

説明

metric maximum-hops

コマンドで指定されたホップ カウントよりも大きいホップ カウントを持つ EIGRP VPN ルートを到達不能としてアドバタイズします。

neighbor(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)情報を交換する隣接ルータを定義するには、インターフェイス コンフィギュレーション モードで neighbor コマンドを使用します。 エントリを削除するには、このコマンドの no 形式を使用します。

neighbor ip-address

no neighbor ip-address

構文の説明

ip-address

ルーティング情報を交換するピア ルータの IP アドレス。

コマンド デフォルト

隣接ルータは定義されていません。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ルーティング情報のポイントツーポイント(非ブロードキャスト)交換を許可するには、neighbor コマンドを使用します。

ネイバーが neighbor コマンドを使用して、インターフェイスで設定されている場合、インターフェイスはマルチキャスト hello メッセージの送信または受信を停止します。 ただし、インターフェイスはユニキャスト hello メッセージを送信または受信できます。 このため、LAN の各ネイバーは、個別に設定する必要があります。 複数の neighbor コマンドを使用して、他のネイバーまたはピアを指定できます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、EIGRP アップデートの特定のネイバーへの送信を許可する例を示します。 ネイバーごとに 1 つアップデートのコピーが作成されます。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv6
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/1
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)# neighbor 172.20.1.2

関連コマンド

コマンド

説明

passive-interface(EIGRP)

(EIGRP)インターフェイスでの「hello」メッセージの送受信をディセーブルにします。

neighbor maximum-prefix

単一 Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバーまたはすべての EIGRP VPN ネイバーから受け入れるプレフィックス数を制限するには、IPv4 VRF アドレス ファミリ コンフィギュレーション モードで neighbor maximum-prefix コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

Single-Neighbor Configuration CLI

neighbor ip-address maximum-prefix maximum [threshold] [warning-only]

no neighbor ip-address maximum-prefix

All-Neighbor Configuration CLI

neighbor maximum-prefix maximum [threshold] [dampened] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] [warning-only]

no neighbor maximum-prefix

構文の説明

ip-address

(任意)単一ピアの IP アドレス。

maximum

受け入れられるプレフィックスの最大数。 範囲は 1 ~ 4294967295 です。

設定可能なプレフィックスの数は、ルータ上の利用可能なシステム リソースによってだけ制限されます。

threshold

(任意)プレフィックス数の上限値を超えた割合として syslog 警告メッセージを指定します。 プレフィックスの割合を表す数値の範囲は 1 ~ 100 です。 デフォルトは 75% です。

dampened

(任意)プレフィックス数の上限値を超えるたびに再起動時間に適用される減衰ペナルティを設定します。 減衰ペナルティのハーフライフは、デフォルトまたはユーザ定義の再起動時間(分単位)の 150 %です。 このキーワードは、デフォルトでディセーブルです。

reset-time minutes

(任意)デフォルトまたは設定されたリセット時間を経過した後に、再起動回数を 0 にリセットするようにルータを設定します。 範囲は 1 ~ 65535 分です。

restart minutes

(任意)プレフィックス数の上限値を超えた後、ルータが隣接を形成しない、または RIB からの再配布ルートを受け入れない期間を設定します。 範囲は 1 ~ 65535 分です。

restart-count number

(任意)プレフィックス数の上限値を超えたためにピア セッションが解放された後または再配布ルートがクリアされて再学習した後、ピア セッションを自動的に再確立できる回数を設定します。

注意       

再起動回数のしきい値を超えたら、clear eigrp neighbors コマンドを使用して標準のピアリング、再配布、またはその両方の再確立が必要になります。

warning-only

(任意)プレフィックス数の上限値に達したときだけ、ピア セッションを終了する代わりに syslog メッセージを生成するようにルータを設定します。

コマンド デフォルト

threshold:75%

dampened:disabled

warning-only:disabled

reset-time:15 分

restart:5 分

restart-count:3

コマンド モード

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

個々のピア セッションまたはすべてのピア セッションを保護するには、neighbor maximum-prefix コマンドを設定します。 この機能がイネーブルで、プレフィックス数の上限値を超えた場合、ルータはピア セッションを解放し、ピアから学習したルートをすべてクリアしてから、デフォルトまたはユーザ定義の期間、ピアをペナルティ ステートにします。 ペナルティの期限が切れた後、標準のピアリングが再確立されます。


(注)  


EIGRP では従来、neighbor コマンドを使用してスタティック ネイバーを設定していました。 ただし、この機能と関連して、静的に設定されたネイバーおよび動的に検出されたネイバーの両方に対してプレフィックス数の上限値を設定するのに neighbor maximum-prefix コマンドを使用できます。


単一ピア セッションを保護するために neighbor maximum-prefix コマンドを設定する場合に設定できるのは、プレフィックス数の上限、割合のしきい値、および警告だけのコンフィギュレーション オプションだけです。 セッション ダンプニング、再起動、およびリセット タイマーはグローバル ベースで設定されます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、単一ピアに対してプレフィックス数の上限値を設定する例を示します。 最大制限は 1000 プレフィックスに設定されていて、警告しきい値は 80% に設定されています。 プレフィックス数の上限値を超えた場合、このピアを含むセッションは解放され、このピアから学習したすべてのルートはトポロジおよびルーティング テーブルから削除されます。そして、このピアは 5 分間(デフォルト ペナルティ値)ペナルティ ステートになります。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vrf1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# neighbor 10.0.0.1 maximum-prefix 1000 80
  
         

次に、すべてのピアに対してプレフィックス数の上限値を設定する例を示します。 最大制限は 10,000 プレフィックスに設定されて、警告しきい値は 90%、再起動タイマーは 4 分に設定されていて、dampened キーワードによって再起動タイマーに対して減少ペナルティが設定されていて、すべてのタイマーは 60 分ごとにゼロにリセットされます。 プレフィックス数の上限値を超えた場合、すべてのピア セッションは解放され、すべてのピアから学習したすべてのルートはトポロジおよびルーティング テーブルから削除されます。そして、すべてのピアは 4 分間(ユーザ定義のペナルティ値)ペナルティ ステートになります。 ダンプニング指数による減衰ペナルティも適用されます。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vrf1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# neighbor maximum-prefix 10000 90 dampened reset-time 60 restart4

関連コマンド

コマンド

説明

clear eigrp neighbors

EIGRP および VRF ネイバー エントリを適切なテーブルから削除します。

next-hop-self disable

ルートのアドバタイズ時に受信したネクストホップ値を Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスで使用させるには、インターフェイス コンフィギュレーション モードで next-hop-self disable コマンドを使用します。 デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

next-hop-self disable

no next-hop-self disable

構文の説明

このコマンドには、キーワードと引数はありません。

コマンド デフォルト

EIGRP は常に、IP ネクストホップ値を自身に設定します。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

EIGRP はデフォルトでは、ルートを学習したインターフェイスと同じインターフェイス上のルートをアドバタイズする場合でも、アドバタイズしているルートの IP ネクストホップ値が自身になるように設定します。 このデフォルトを変更するには、next-hop-self disable インターフェイス コンフィギュレーション コマンドを使用して、これらのルートのアドバタイズ時には受信したネクストホップ値を EIGRP で使用させる必要があります。

next-hop-self disable 機能は、再配布されたルートでは使用できません。

タスク ID

タスク ID

操作

eigrp

read, write

デフォルトの IP ネクストホップ値を変更し、受信したネクストホップ値を使用するように EIGRP に指示する例を示します。

RP/0/RSP0/CPU0:router(config)# router eigrp 1
RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-eigrp-af-if)# next-hop-self disable

nsf disable(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)ノンストップ フォワーディング(NSF)をディセーブルにするには、適切なコンフィギュレーション モードで nsf disable コマンドを使用します。 EIGRP NSF をディセーブル状態から再びイネーブルにするには、このコマンドの no 形式を使用します。

nsf disable

no nsf disable

構文の説明

このコマンドには、キーワードと引数はありません。

コマンド デフォルト

EIGRP の NSF がイネーブルになっています。

コマンド モード

ルータ コンフィギュレーション

IPv4 アドレス ファミリ コンフィギュレーション

IPv6 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

IPv6 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース 変更箇所

リリース 4.1.1

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

すべての VRF の IPv4 および IPv6 アドレスの両方で NSF をディセーブルにする場合は、ルータ コンフィギュレーション モードで nsf disable コマンドを使用します。

特定の VRF の特定のアドレス ファミリで NSF をディセーブルにする場合は、アドレス ファミリ コンフィギュレーション モードで nsf disable コマンドを使用します。

NSF がディセーブルの場合、EIGRP はそのピアから学習したルートを保持できず、ISSU 時にトラフィックが失われることがあります。

タスク ID

タスク ID 操作

eigrp

read, write

次に、VRF のすべてのアドレス ファミリで NSF をディセーブルにする例を示します。

RP/0/RSP0/CPU0:router#configure
RP/0/RSP0/CPU0:router(config)#router eigrp 1
RP/0/RSP0/CPU0:router(config-eigrp)#nsf disable

次に、VRF v1 の IPv4 アドレス ファミリで NSF をディセーブルにする例を示します。
RP/0/RSP0/CPU0:router#configure
RP/0/RSP0/CPU0:router(config)#router eigrp 1
RP/0/RSP0/CPU0:router(config-eigrp)#vrf v1
RP/0/RSP0/CPU0:router(config-eigrp-vrf)#address-family ipv4
RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)#nsf disable

関連コマンド

コマンド 説明

router eigrp

ルーティング プロセスを設定して、Enhanced Interior Gateway Routing Protocol(EIGRP)のルータ コンフィギュレーション モードを開始します。

passive-interface(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスでの「hello」メッセージの送受信をディセーブルにし、インターフェイスのネイバーの形成をディセーブルにするには、インターフェイス コンフィギュレーション モードで passive-interface コマンドを使用します。 「hello メッセージ」の送受信を再度イネーブルにするには、このコマンドの no 形式を使用します。

passive-interface

no passive-interface

構文の説明

このコマンドには、キーワードと引数はありません。

コマンド デフォルト

passive-interface コマンドはインターフェイスでディセーブルです。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

「hello」メッセージの送信をディセーブルにするには、passive-interface コマンドを使用します。 このインターフェイス上で指定されたサブネットは、他のインターフェイスのネイバーに EIGRP によってアドバタイズされ続けます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、GigabitEthernet インターフェイス 0/6/5/0 で passive-interface コマンドを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv6
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/6/5/0
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)# passive-interface

redistribute(EIGRP)

あるルーティング ドメインからのルートを Enhanced Interior Gateway Routing Protocol(EIGRP)に挿入するには、適切なコンフィギュレーション モードで redistribute コマンドを使用します。 コンフィギュレーション ファイルから redistribute コマンドを削除し、ルートの再配布をしないデフォルトの状態にシステムを戻すには、このコマンドの no 形式を使用します。

redistribute { {bgp | connected | isis | ospf | rip | static} | [ as-number | instance-name ] } [ route-policy name ]

no redistribute { {bgp | connected | isis | ospf | rip | static} | [ as-number | instance-name ] }

構文の説明

bgp

BGP プロトコルからのルートを配布します。

connected

インターフェイスの IP をイネーブルにしたことで、自動的に確立されるルートを配布します。

isis

IS-IS プロトコルからのルートを配布します。

ospf

OSPF プロトコルからのルートを配布します。 このプロトコルは IPv4 アドレス ファミリでサポートされています。

static

IP スタティック ルートを再配布します。

as-number | instance-name

次の 3 つのオプションのいずれかを表します。

bgp キーワードの場合:

2 バイトの自律システム番号(ASN)の範囲は 1 ~ 65535 です。

asplain 形式の 4 バイトの自律システム番号(ASN)の範囲は 1 ~ 4294967295 です。

asdot 形式の 4 バイトの自律システム番号(ASN)の範囲は 1.0 ~ 65535.65535 です。

isis キーワードの場合は、ルートの再配布元である IS-IS インスタンスの名前です。 値は文字列の形式を取ります。 10 進数を入力できますが、ストリングとして内部に格納されます。

ospf キーワードの場合は、ルートの再配布元である OSPF インスタンスの名前です。 値は文字列の形式を取ります。 10 進数を入力できますが、ストリングとして内部に格納されます。

route-policy name

(任意)設定されたポリシーの ID を指定します。 ポリシーは、この送信元のルーティング プロトコルから EIGRP へのルートのインポートのフィルタリングに使用されます。

コマンド デフォルト

ルートの再配布はディセーブルです。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 3.9.0

4 バイトの自律システム番号表記の asplain 形式がサポートされました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

再配布ルーティング情報は常に、route-policy name キーワードと引数によってフィルタされる必要があります。 このフィルタリングによって、管理者が意図するルートだけが EIGRP で再配布されるようになります。

デフォルト メトリックは通常、他のプロトコルからのルートを EIGRP に再配布する必要があります。 メトリックは、default-metric コマンドを使用するか、redistribute コマンドで設定されたルート ポリシーで設定します。 この要件の例外の 1 つに、MPLS-VPN のシナリオにおいて、EIGRP でプロバイダー エッジ(PE)上の BGP ルートを再配布する場合があります。 ルートの発信元プロトコルが同一自律システム内の EIGRP である場合(MPLS-VPN において)、メトリックは、BGP ルートの拡張コミュニティから自動的に学習することになります。

ルーティング ポリシーの詳細については、『Cisco ASR 9000 Series Aggregation Services Router Routing Command Reference』の「Routing Policy Commands on Cisco ASR 9000 Series Router 」のモジュールを参照してください。

タスク ID

タスク ID

操作

eigrp

read, write

次に、BGP ルートを EIGRP 自律システムに再配布させる例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# redistribute bgp 100
  
  
         

次に、VPN ルーティング/転送(VRF)内で指定された IS-IS プロセスのルートを EIGRP 自律システムに再配布する例を示します。 IS-IS ルートは、ルート ポリシー 3 を使用して再配布されます。

  RP/0/RSP0/CPU0:router(config)# router eigrp 109
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# redistribute isis 108 route-policy 3
  
         

関連コマンド

コマンド

説明

default-metric(EIGRP)

EIGRP のメトリックを設定します。

redistribute maximum-prefix

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスに再配布されるプレフィックス数を制限するには、IPv4 VRF アドレス ファミリ コンフィギュレーション モードで redistribute maximum-prefix コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

redistribute maximum-prefix maximum [threshold] [ [dampened] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | [warning-only] ]

no redistribute maximum-prefix

構文の説明

maximum

アドレス ファミリの EIGRP に再配布されるプレフィックスの最大数。 範囲は 1 ~ 4294967295 です。

設定可能なプレフィックスの数は、ルータ上の利用可能なシステム リソースによってだけ制限されます。

threshold

(任意)プレフィックス数の上限値を超えた割合として syslog 警告メッセージを指定します。 プレフィックスの割合を表す数値の範囲は 1 ~ 100 です。 デフォルトは 75% です。

restart minutes

(任意)最大プレフィックス制限が超過した後に、ルータが隣接関係を形成したり RIB からの再配布ルートを受け入れたりすることのない期間を設定します。 minutes 引数の値は 1 ~ 65535 分です。

restart-count number

(任意)プレフィックス数の上限値を超えたためにピア セッションが解放された後または再配布ルートがクリアされて学習した後、ピア セッションを自動的に再確立できる回数を設定します。

再起動回数がしきい値を超えたら、process restart eigrp コマンドを開始して標準のピアリング、再配布、またはその両方の再確立が必要になります。

reset-time minutes

(任意)デフォルトまたは設定されたリセット時間を経過した後に、再起動回数を 0 にリセットするようにルータを設定します。 minutes 引数の値は 1 ~ 65535 分です。

dampened

(任意)プレフィックス数の上限値を超えるたびに再起動時間に適用される減衰ペナルティを設定します。 減衰ペナルティのハーフライフは、デフォルトまたはユーザ定義の再起動時間(分単位)の 150 %です。

warning-only

(任意)プレフィックス数の上限値に達した場合、再配布を中断する代わりに、syslog メッセージの生成だけを行うようにルータを設定します。

コマンド デフォルト

threshold:75%

warning-only:disabled

reset-time:15 分

restart:5 分

restart-count:3

dampened:disabled

コマンド モード

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

再配布を通じて学習するプレフィックス数の制限を設定するには、redistribute maximum-prefix コマンドを使用します。 プレフィックス数の上限値を超えた場合、ルーティング情報ベース(RIB)から学習したすべてのルートは破棄され、デフォルトまたはユーザ定義の期間、再配布は中断されます。 再配布されるプレフィックスに設定できるプレフィックス数の上限値は、ルータ上で使用可能なシステム リソースだけにより制限されます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、再配布を通じて学習したルートに対してプレフィックス数の上限値を設定する例を示します。 上限値を 5000 プレフィックス、警告するしきい値を 95% に設定します。 再配布を通じて学習したプレフィックス数が 4750(5000 の 95%)に達した場合、コンソールに警告メッセージが表示されます。 warning-only キーワードが設定されているため、トポロジおよびルーティング テーブルはクリアされず、ルートの再配布はペナルティ ステートにはなりません。

  RP/0/RSP0/CPU0:router(config)# router eigrp 100
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# redistribute maximum-prefix 5000 95 warning-only
  
         

関連コマンド

コマンド

説明

process

プロセスを開始、終了、再開します。

route-policy(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバーからアドバタイズされるアップデートまたは受信されるアップデートにルーティング ポリシーを適用するには、適切なコンフィギュレーション モードで route-policy コマンドを使用します。 ルーティング ポリシーのアップデートへの適用をディセーブルにするには、このコマンドの no 形式を使用します。

route-policy route-policy-name { in | out }

no route-policy route-policy-name { in | out }

構文の説明

route-policy-name

ルート ポリシーの名前。

in

ポリシーを着信ルートに適用します。

out

ポリシーを発信ルートに適用します。

コマンド デフォルト

ポリシーは適用されません。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

着信ルートまたは発信ルートのルーティング ポリシーを指定するには、route-policy コマンドを使用します。 ポリシーを使用すると、ルートのフィルタリングやルート属性の変更ができます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、着信 IP Version 4(IPv4)ルートに IN-Ipv4 ポリシーを適用する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# route-policy IN-IPv4 in
  
         

router eigrp

ルーティング プロセスを設定して、Enhanced Interior Gateway Routing Protocol(EIGRP)のルータ コンフィギュレーション モードを開始するには、グローバル コンフィギュレーション モードで router eigrp コマンドを使用します。 EIGRP ルーティング プロセスをオフにするには、このコマンドの no 形式を使用します。

router eigrp as-number

no router eigrp as-number

構文の説明

as-number

(任意)自律システム番号。 値の範囲は 1 ~ 65535 です。

コマンド デフォルト

ルーティング プロセスは定義されません。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

EIGRP のインスタンスを 1 つだけサポートします。

タスク ID

タスク ID

操作

eigrp

read, write

次に、EIGRP のルーティング プロセスを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)#
  

router-id(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスのルータ ID を設定するには、適切なコンフィギュレーション モードで router-id コマンドを使用します。 デフォルトの方法でルータ ID を決定するには、このコマンドの no 形式を使用します。

router-id router-id

no router-id

構文の説明

router-id

4 分割のドット付き 10 進表記で指定した 32 ビット ルータ ID

コマンド デフォルト

このコマンドが設定されていない場合、EIGRP はルータのいずれかのインターフェイスの IPv4 アドレスをルータ ID として選択します。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

router-id コマンドを使用して、ルータ ID として明示的に一意の 32 ビット数値を指定することをお勧めします。 この処理によって、インターフェイス アドレスの設定に関係なく、EIGRP が機能することが保証されます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、172.20.1.1 の IP アドレスを EIGRP プロセス 1 に割り当てる例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# router-id 172.20.1.1
  
         

show eigrp accounting

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスのプレフィックス アカウンティング情報を表示するには、EXEC モードで show eigrp accounting コマンドを使用します。

show eigrp [ as-number ] [ vrf { vrf-name | all } ] [ ipv4 | | ipv6 ] accounting

構文の説明

as-number

(任意)自律システム番号。 VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスを指定しないと、このオプションは使用できません。 値の範囲は 1 ~ 65535 です。

vrf { vrf-name | all }

(任意)特定の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスまたはすべての VRF インスタンスを指定します。

[ ipv4 ]

(任意)IPv4 アドレス ファミリを指定します。

コマンド デフォルト

このコマンドには、引数またはキーワードはありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

EIGRP

read

次に、show eigrp accounting コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show eigrp accounting
  
  IP-EIGRP accounting for AS(100)/ID(10.0.2.1) Routing Table: RED
  Total Prefix Count: 4  States: A-Adjacency, P-Pending, D-Down
  
  State Address/Source   Interface        Prefix   Restart  Restart/
                                          Count     Count   Reset(s)
   P    Redistributed     ----               0           3         211
   A    10.0.1.2          Gi0/6/0/0/         2           0          84
   P    10.0.2.4          Gi00/2/0/3         0           2         114
   D    10.0.1.3          Gi0/6/0/0          0           3           0
  
  

(注)  


接続ルートおよびサマリー ルートは、このコマンドの出力には個々に表示されず、プロセスごとの総数で算出されます。


次の表に、この出力で表示される重要なフィールドの説明を示します。



表 2 show eigrp accounting のフィールドの説明

フィールド

説明

EIGRP accounting for AS

AS 番号、ルータ ID、およびテーブル ID に従って EIGRP インスタンスを識別します。

Total Prefix Count

EIGRP インスタンス トポロジ テーブル内にあるプレフィックスの集約合計を示します。 この計算には、すべてのネイバーまたは再配布から学習したプレフィックスが含まれています。

States:A-Adjacency、P-Pending、D-Down

A-Adjacency:ネイバーとの安定した隣接関係または通常の再配布状態を示します。

P-Pending:プレフィックス数の上限値を超えたために、隣接ルータとの隣接関係または再配布が中断されたか、またはペナルティ ステートの状態です。

D-Down:clear route コマンドを使用して手動でリセットされるまで永続的に、隣接ルータとの隣接関係または再配布が中断されます。

Address/Source

再配布ソースのピア IP アドレスを示します。

Prefix Count

ソースによって学習されるプレフィックスの合計数を表示します。

(注)     

ルートは複数の送信元からの同じプレフィックスとして取得できます。また、このカラム内のすべてのプレフィックス カウントの合計が、「Prefix Count」フィールドに表示された数値を上回る場合があります。

Restart Count

ルート送信元がプレフィックス数の上限値を超えた回数。

Restart Reset(s)

ルート ソースが P(ペナルティを科されている)状態である時間を秒数で表示します。 ルート送信元が A(安定または通常の)ステートである場合、表示された時間は penalization 履歴がリセットされるまでの時間になります(秒単位)。

show eigrp interfaces

Enhanced Interior Gateway Routing Protocol(EIGRP)に設定されたインターフェイスに関する情報を表示するには、EXEC モードで show eigrp interfaces コマンドを使用します。

show eigrp [ as-number ] [ vrf { vrf-name | | all } ] [ ipv4 | ipv6 ] interfaces [ type interface-path-id ] [ detail ]

構文の説明

as-number

(任意)自律システム番号。 VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスを指定しないと、このオプションは使用できません。

2 バイトの自律システム番号(ASN)の範囲は 1 ~ 65535 です。

asplain 形式の 4 バイトの自律システム番号(ASN)の範囲は 1 ~ 4294967295 です。

asdot 形式の 4 バイトの自律システム番号(ASN)の範囲は 1.0 ~ 65535.65535 です。

vrf { vrf-name | all }

(任意)特定の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスまたはすべての VRF インスタンスを指定します。

[ ipv4 ]

(任意)IPv4 アドレス ファミリを指定します。

type

(任意)インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

detail

(任意)EIGRP インターフェイスの詳細情報を表示します。

コマンド デフォルト

このコマンドには、引数またはキーワードはありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 3.9.0

4 バイトの自律システム番号表記の asplain 形式がサポートされました。 入力パラメータおよび出力は、asplain または asdot 表記の 4 バイトの自律システム番号と拡張コミュニティを表示するように変更されました。

リリース 4.3.0

コマンド出力は、関連するワイド メトリック情報を表示するように変更されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

どのインターフェイスで EIGRP がアクティブであるかを判別して、このインターフェイスに関連した EIGRP についての情報を学習するには、show eigrp interfaces コマンドを使用します。

インターフェイスが指定された場合、そのインターフェイスのみが表示されます。 指定されない場合、EIGRP を実行しているすべてのインターフェイスが表示されます。

自律システムが指定された場合、指定された自律システムについてのルーティング プロセスのみが表示されます。 指定されない場合、すべての EIGRP プロセスが表示されます。

タスク ID

タスク ID

操作

EIGRP

read

次に、show eigrp interfaces コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show eigrp interfaces
  
  IP EIGRP interfaces for process 1
  
                           Xmit Queue    Mean   Pacing Time   Multicast   Pending
  Interface        Peers   Un/Reliable   SRTT   Un/Reliable   Flow Timer  Routes
  
  Gi0/6/0/2.212      0         0/0          0      11/434          0          0
  
  Gi0/6/0/0          1         0/0        337       0/10           0          0
  
   Gi0/2/0/3         1         0/0         10       1/63         103          0
  
  Gi0/6/2/5          1         0/0        330       0/16           0          0

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 3 show eigrp interfaces のフィールドの説明

フィールド

説明

Interface

EIGRP が設定されているインターフェイス

Peers

直接接続された EIGRP ネイバーの数。

Xmit Queue Un/Reliable

信頼できない、または信頼できる送信キューにあるパケットの数

Mean SRTT

平均 Smoothed Round-Trip Time(SRTT)インターバル(ミリ秒単位)

Pacing Time Un/Reliable

EIGRP パケット(信頼できない、または信頼できるパケット)をインターフェイスに送信するときを決定するペーシング時間

Multicast Flow Timer

ルータがマルチキャスト EIGRP パケットを送信する最大秒数

Pending Routes

送信キュー内で送信を待機しているパケット内のルートの数。

次に、detail キーワードを指定して実行した場合の show eigrp interfaces コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show eigrp interfaces detail
  
  IPv4-EIGRP interfaces for AS(100)
  
                          Xmit Queue   Mean   Pacing Time   Multicast    Pending
  Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
  Lo0                0        0/0         0     640/640          0           0
    Hello interval is 5 sec, hold time is 15 sec
    Next xmit serial <none>
    Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0
    Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
    Retransmissions sent: 0  Out-of-sequence rcvd: 0
    Bandwidth percent is 50
    Total packets received: 0
    Authentication mode: MD5  Key chain: key1
    No active key found in keychain database
    Valid authenticated packets received: 0
    Packets dropped due to wrong keychain config: 0
    Packets dropped due to missing authentication: 0
    Packets dropped due to invalid authentication: 0
    Effective Metric:
      Bandwidth: 10000000, Delay: 500, Reliability: 255, Load: 1, MTU: 1514
  
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 4 show eigrp interfaces detail のフィールドの説明

フィールド

説明

Hello interval

hello パケットの送信間隔。

hold time

ネイバーに通知されたホールドタイム。 ネイバーは、この期間にルータから hello パケットを受け取らなかった場合、ネイバー関係がダウンしていることを宣言します。

Next xmit serial

次の送信シリアル番号。

Un/reliable mcasts

このインターフェイス上で送信された信頼できないマルチキャスト パケットおよび信頼できるマルチキャスト パケットの数。

Un/reliable ucasts

このインターフェイス上で送信された信頼できないユニキャスト パケットおよび信頼できるユニキャスト パケットの数。

Mcast exceptions

マルチキャストの例外数(シーケンス TLV)。

CR packets

条件付き受信ビットが設定されて送信されたパケットの数。

ACKs suppresses

抑制された ACK パケットの数。

Retransmissions

このインターフェイス上での再送信の数。

Out-of-sequence rcvd

シーケンスを外れて受信したパケットの数。

Bandwidth percent

設定された帯域幅の割合。

Authentication

認証のモード。

Valid authenticated packets received

有効な認証パケットの数。

Packets dropped due to wrong keychain config

誤ったキーチェーン設定が原因でドロップされたパケットの数。

Packets dropped due to missing authentication

認証が失われているためにドロップされたパケット数。

Packets dropped due to invalid authentication

無効な認証のためにドロップされたパケット数。

次に、関連するワイド メトリック情報を表示する show eigrp interfaces コマンドの出力例を示します。
RP/0/RSP0/CPU0:router#show eigrp interfaces gigabitEthernet 0/0/0/0 detail 

IPv4-EIGRP interfaces for AS(1)

                 Peers   Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface               Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Gi0/0/0/0          1         0/0       420       0/10        2096           0
  Hello interval is 5 sec, hold time is 15 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/6  Un/reliable ucasts: 4/2
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 1
  Retransmissions sent: 1  Out-of-sequence rcvd: 0
  Bandwidth percent is 50
  Total packets received: 1563
  Authentication mode is not set
  Classic peers: 0 Wide peers: 1
  Effective Metric:
    Bandwidth: 1000000 Kbit, Delay: 10000000 picosecond, 
    Reliability: 255, Load: 1, MTU: 1500

関連コマンド

コマンド

説明

show eigrp neighbors

EIGRP によって検出されたネイバーを表示します。

show eigrp neighbors

Enhanced Interior Gateway Routing Protocol(EIGRP)で検出されたネイバーに関する情報を表示するには、EXEC モードで show eigrp neighbors コマンドを使用します。

show eigrp as-number vrf { vrf-name | all } ipv4ipv6

構文の説明

as-number

(任意)自律システム番号。 VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスを指定しないと、このオプションは使用できません。 値の範囲は 1 ~ 65535 です。

vrf { vrf-name | all }

(任意)特定の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスまたはすべての VRF インスタンスを指定します。

[ ipv4 ]

(任意)IPv4 アドレス ファミリを指定します。

detail

(任意)詳細な EIGRP ネイバー情報を表示します。

type

インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

static

(任意)スタティック ルートを表示します。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 4.3.0

コマンド出力は、関連するワイド メトリック情報を表示するように変更されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ネイバーがいつアクティブになり、いつ非アクティブになるかを判断するには、show eigrp neighbors コマンドを使用します。 このコマンドは、特定の転送問題のデバッグにも役立ちます。

タスク ID

タスク ID

操作

EIGRP

read

次に、show eigrp neighbors コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show eigrp neighbors
  
  IP-EIGRP Neighbors for process 77
  
  Address                 Interface     Holdtime Uptime   Q      Seq  SRTT  RTO
                                        (secs)   (h:m:s)  Count  Num  (ms)  (ms)
  
  172.16.81.28             Gi0/2/0/3     13       0:00:41  0      11   4     20
  
  172.16.80.28            Gi0/6/0/0      14       0:02:01  0      10   12    24
  
  172.16.80.31            Gi0/6/2/5      12       0:02:02  0      4    5     20 
  
  RP/0/RSP0/CPU0:router#
  
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 5 show eigrp neighbors のフィールドの説明

フィールド

説明

process

ルータ コンフィギュレーション コマンドで指定された Autonomous System(AS; 自律システム)番号

Address

EIGRP ピアの IP アドレス

Interface

ルータがピアから hello パケットを受信するインターフェイス

Holdtime

ピアがダウンしていると宣言するまでに、Cisco IOS XR ソフトウェアがピアからの受信を待機する時間(秒単位)

Uptime

ローカル ルータが初めてこのネイバーから受信した時点からの経過時間(時、分、秒単位)。

Q Count

ソフトウェアが送信を待機する EIGRP パケット(アップデート、クエリー、および応答)の数

Seq Num

このネイバーから受信した最新アップデート、クエリー、または応答パケットのシーケンス番号。

SRTT

Smoothed Round-Trip Time(SRTT)。 これは、EIGRP パケットがこのネイバーに送信される際に必要な時間およびローカル ルータがそのパケットの確認応答を受信する際にかかる時間(ミリ秒単位)の数字です。

RTO

Retransmission Timeout(再送信のタイムアウト)(ミリ秒)。 これは、再送信キューからネイバーへパケットを再送信するまでソフトウェアが待機する時間です。

次に、detail キーワードを指定して実行した場合の show eigrp neighbors コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show eigrp neighbors detail 
  
  IP-EIGRP neighbors for AS 1
  
  H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                              (sec)         (ms)       Cnt Num
  0   11.0.0.10               Gi0/6/0/0         14 01:00:52    3   200  0  10
  
     Version 12.4/1.2, Retrans: 0, Retries: 0, Prefixes: 3
  
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 6 show eigrp neighbors detail のフィールドの説明

フィールド

説明

Version

ノードおよびネイバーで実行中の EIGRP ソフトウェアのバージョン(メジャー.マイナー)。

Retrans

このネイバーへの再送信の数。

Retries

最後の Acknowledgement(ACK; 確認応答)を受信した時点からの、このネイバーへの再送信の数。

Prefixes

このネイバーから学習したプレフィックスの数。

次に、関連するワイド メトリック情報を表示する show eigrp neighbors コマンドの出力例を示します。
RP/0/RSP0/CPU0:router#show eigrp neighbors detail 
Mon Oct 31 21:23:37.996 IST

IPv4-EIGRP neighbors for AS(1) vrf default

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.10.10.11             Gi0/0/0/0         12 01:20:40  420  2520  0  5
   Version 3.3/2.0, Retrans: 1, Retries: 0, Prefixes: 2

show eigrp topology

Enhanced Interior Gateway Routing Protocol(EIGRP)トポロジ テーブルを表示するには、EXEC モードで show eigrp topology コマンドを使用します。

show eigrp [ as-number ] [ vrf { vrf-name | all } ] [ ipv4 | | ipv6 ] topology [ ip-address mask ] { active | | all-links | | detail-links | | pending | | summary | | zero-successors }

構文の説明

as-number

(任意)自律システム番号。 VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスを指定しないと、このオプションは使用できません。

2 バイトの自律システム番号(ASN)の範囲は 1 ~ 65535 です。

asplain 形式の 4 バイトの自律システム番号(ASN)の範囲は 1 ~ 4294967295 です。

asdot 形式の 4 バイトの自律システム番号(ASN)の範囲は 1.0 ~ 65535.65535 です。

vrf { vrf-name | all }

(任意)特定の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスまたはすべての VRF インスタンスを指定します。

[ ipv4 ]

(任意)IPv4 アドレス ファミリを指定します。

ip-address

(任意)4 分割ドット付き 10 進表記の IP アドレス。

mask

(任意)次の 2 つの方法のうちいずれかで指定されるネットワーク マスク。

4 分割ドット付き 10 進表記のアドレスでネットワーク マスクを指定します。 たとえば、255.0.0.0 の場合、各ビットが 1 のときに対応するアドレス ビットがネットワーク アドレスであることを示します。

ネットワーク マスクは、スラッシュ(/)と数字で表すことができます。 たとえば、/8 は、マスクの最初の 8 ビットが 1 であり、アドレスの対応するビットはネットワーク アドレスであることを示します。

active

(任意)EIGRP トポロジ テーブル内のアクティブ エントリのみ表示します。

all-links

(任意)EIGRP トポロジ テーブルのエントリをすべて表示します。

detail-links

(任意)EIGRP トポロジ テーブル内の全エントリの詳細情報を表示します。

pending

(任意)ネイバーからの更新を待機しているか、ネイバーへの応答を待機している、EIGRP トポロジ テーブル内のすべてのエントリを表示します。

summary

(任意)EIGRP トポロジ テーブルの要約を表示します。

zero-successors

(任意)EIGRP トポロジ テーブル内の使用可能なルートを表示します。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 3.9.0

4 バイトの自律システム番号表記の asplain 形式がサポートされました。 入力パラメータおよび出力は、asplain または asdot 表記の 4 バイトの自律システム番号と拡張コミュニティを表示するように変更されました。

リリース 4.3.0

コマンド出力は、関連するワイド メトリック情報を表示するように変更されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

キーワードや引数を指定しないで show eigrp topology コマンドを使用した場合、フィジブル サクセサであるルートだけが表示されます。

show eigrp topology コマンドを使用して、拡散更新アルゴリズム(DUAL)ステートを判断し、起こり得る DUAL の問題をデバッグできます。

タスク ID

タスク ID

操作

EIGRP

read

次に、show eigrp topology コマンドの出力例を示します。 指定された内部ルートおよび外部ルートの EIGRP メトリックが表示されます。

  RP/0/RSP0/CPU0:router# show eigrp topology 10.2.1.0/24
  
  IP-EIGRP (AS 1): Topology entry for 10.2.1.0/24
    State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
    Routing Descriptor Blocks:
    0.0.0.0 (GigabitEthernet0/6/0/0), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal !This is the internal route.
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255 
        Minimum MTU is 1500
        Hop count is 0
  
  RP/0/RSP0/CPU0:router# show eigrp topology 10.4.80.0/20
  
  IP-EIGRP (AS 1): Topology entry for 10.4.80.0/20
    State is Passive, Query origin flag is 1, 1 Successor(s), FD is 409600
    Routing Descriptor Blocks:
    10.2.1.1 (GigabitEthernet0/6/0/0), from 10.2.1.1, Send flag is 0x0
      Composite metric is (409600/128256), Route is External
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 6000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 10.89.245.1 
        AS number of route is 0
        External protocol is Connected, external metric is 0
        Administrator tag is 0 (0x00000000)
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 7 show eigrp topology のフィールドの説明

フィールド

説明

Query origin

クエリーの origin ステート

Successors

このプレフィックスのフィジブル サクセサの数

FD

このプレフィックスのフィジブル ディスタンス

10.2.1.1 (Gi0/0)

このパスが学習されたネクスト ホップとインターフェイス

from 10.2.1.1

このパスの情報送信元

Send flag

このネイバーに対してこのプレフィックスの送信が保留中かどうかを示します。

Composite Metric

(409600/128256)

最初の数値は宛先へのコストを表す EIGRP メトリックです。 2 番めの数値はこのピアがアドバタイズした EIGRP メトリックです。

Route is

ルート タイプ(内部または外部)

Vector Metric

ネイバーによってアドバタイズされたメトリック(帯域幅、遅延、信頼性、負荷、MTU、およびホップ カウント)を表示します。

External Data

ネイバーによってアドバタイズされた外部情報(送信元ルータ ID、AS 番号、外部プロトコル、メトリック、およびタグ)を示します。

次に、関連するワイド メトリック情報を表示する show eigrp topology コマンドの出力例を示します。
RP/0/RSP0/CPU0:router#show eigrp topology 1.1.1.0/24

IPv4-EIGRP AS(1): Topology entry for 1.1.1.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 82329600, RIB is 643200
  Routing Descriptor Blocks:
  10.10.10.11 (Ethernet0/0), from 10.10.10.11, Send flag is 0x0
      Composite metric is (82329600/163840), Route is Internal
      Vector metric:
        Minimum bandwidth is 16000 Kbit
        Total delay is 631250000 picosecond
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
        Originating router is 1.1.1.1

show eigrp traffic

送受信した Enhanced Interior Gateway Routing Protocol(EIGRP)パケット数を表示するには、EXEC モードで show eigrp traffic コマンドを使用します。

show eigrp [ as-number ] [ vrf { vrf-name | | all } ] [ ipv4 | | ipv6 ] traffic

構文の説明

as-number

(任意)自律システム番号。 VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスを指定しないと、このオプションは使用できません。 値の範囲は 1 ~ 65535 です。

vrf { vrf-name | all }

(任意)特定の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスまたはすべての VRF インスタンスを指定します。

[ ipv4 ]

(任意)IPv4 アドレス ファミリを指定します。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

送受信したパケット数を確認するには、show eigrp traffic コマンドを使用します。

また、接続またはコンフィギュレーション上の問題のために、あるノードからのパケットがネイバー ノードに到達していないかを判断するには、このコマンドが便利です。

タスク ID

タスク ID

操作

EIGRP

read

次に、show eigrp traffic コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show eigrp traffic
  
  IP-EIGRP Traffic Statistics for AS 1
  
    Hellos sent/received: 736/797
    Updates sent/received: 6/6
    Queries sent/received: 0/1
    Replies sent/received: 1/0
    Acks sent/received: 6/6
    Input queue high water mark 0, 0 drops
    SIA-Queries sent/received: 0/0
    SIA-Replies sent/received: 0/0
  
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 8 show eigrp traffic のフィールドの説明

フィールド

説明

AS

router eigrp コマンドで指定された自律システム番号

Hellos sent/received

送受信された hello パケットの数

Updates sent/received

送受信されたアップデート パケットの数

Queries sent/received

送受信されたクエリー パケットの数

Replies sent/received

送受信された応答パケットの数

Acks sent/received

送受信された Acknowledgment(ACK; 確認応答)パケットの数

Input queue high water mark

入力キューのパケットの最大数とドロップの数

SIA-Queries sent/received

送受信された Stuck-in-Active クエリー パケットの数

SIA-Replies sent/received

送受信された Stuck-in-Active 応答パケットの数

show protocols(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセス コンフィギュレーションに関する情報を表示するには、EXEC モードで show protocols コマンドを使用します。

show protocols [ ipv4 | | | afi-all ] [ all | | protocol ] [ default-context | | vrf | | vrf-name ] [ private ]

構文の説明

ipv4

(任意)IPv4 アドレス ファミリを指定します。

afi-all

(任意)すべてのアドレス ファミリを指定します。

all

(任意)指定されたアドレス ファミリのすべてのプロトコルを指定します。

protocol

(任意)ルーティング プロトコルを指定します。

IPv4 アドレス ファミリの場合、オプションは eigrpbgpisisospf、および rip です。

default-context

(任意)デフォルト コンテキスト情報を表示します。 このキーワードは、eigrp または rip プロトコルを指定した場合に使用できます。

vrf vrf-name

(任意)指定されたプロセスの VPN ルーティング/転送(VRF)情報を表示します。 このキーワードは、eigrp または rip プロトコルを指定した場合に使用できます。

private

(任意)プライベート EIGRP データを表示します。 このキーワードは、eigrp を指定した場合に使用できます。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 3.9.0

4 バイトの自律システム番号表記の asplain 形式がサポートされました。 入力パラメータおよび出力は、asplain または asdot 表記の 4 バイトの自律システム番号と拡張コミュニティを表示するように変更されました。

リリース 4.3.0

コマンド出力は、関連するワイド メトリック情報を表示するように変更されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ルータ上で実行中のプロトコルに関する情報を取得して、どのプロトコルがアクティブであるかを迅速に判断するには、show protocols コマンドを使用します。 このコマンドは、実行しているプロトコルの重要な特定を要約するために設計されていて、コマンドの出力は選択した特定のプロトコルによって異なります。

EIGRP の場合、コマンドの出力は、インスタンス番号、デフォルト AS コンテキスト、ルータ ID、デフォルト ネットワーク、ディスタンス、最大パスなどを示します。

タスク ID

タスク ID

操作

EIGRP

read

次に、show protocols eigrp コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show protocols eigrp
  
  Routing Protocol: EIGRP, instance 1
   Default context AS: 1, Router ID: 192.168.0.22
    Address Family: IPv4
     Default networks not flagged in outgoing updates
     Default networks not accepted from incoming updates
     Distance: internal 90, external 170
     Maximum paths: 4
     EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
     EIGRP maximum hopcount 100
     EIGRP maximum metric variance 1
     EIGRP NSF: enabled
      NSF-aware route hold timer is 240s
      NSF signal timer is 20s
      NSF converge timer is 120s
      Time since last restart is 01:01:21
     SIA Active timer is 180s
     Interfaces:
      GigabitEthernet0/6/0/0
  
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 9 show protocols のフィールドの説明

フィールド

説明

instance

インスタンスの AS 番号。

  • 2 バイトの自律システム番号(ASN)の範囲は 1 ~ 65535 です。
  • asplain 形式の 4 バイトの自律システム番号(ASN)の範囲は 1 ~ 4294967295 です。
  • asdot 形式の 4 バイトの自律システム番号(ASN)の範囲は 1.0 ~ 65535.65535 です。

AS

このコンテキストの AS 番号。

  • 2 バイトの自律システム番号(ASN)の範囲は 1 ~ 65535 です。
  • asplain 形式の 4 バイトの自律システム番号(ASN)の範囲は 1 ~ 4294967295 です。
  • asdot 形式の 4 バイトの自律システム番号(ASN)の範囲は 1.0 ~ 65535.65535 です。

Address Family

コンフィギュレーション ステータスを表示するアドレス ファミリ。

Default Networks Candidate

デフォルトのネットワーク受け入れとアナウンス動作。

Distance

EIGRP ルートのアドミニストレーティブ ディスタンス。

Maximum paths

ルートに対して RIB に追加されている最大パス。

Metric Weight

EIGRP で使用する現在のメトリックの重み

Maximum hopcount

EIGRP で受け入れる最大ホップ カウント。

Variance

ルートの到達可能パスを検索するために使用されるメトリック分散。

Route hold time

ネイバーのグレースフル リスタートの実行と同時にルートを削除せず、ネイバーから学習したルートを保持する時間。

signal time

ノンストップ フォワーディング信号時間。

converge time

ノンストップ フォワーディング コンバージェンス時間。

SIA Active time

SIA のアクティブな時間。

Interfaces

EIGRP に設定されたインターフェイスの一覧。

次に、関連するワイド メトリック情報とともに show protocols eigrp コマンドの出力例を示します。
RP/0/RSP0/CPU0:router#show protocols eigrp 
Routing Protocol: EIGRP, instance 1
 Default context AS: 1, Router ID: 3.3.3.3
  Address Family: IPv4
   Default networks not flagged in outgoing updates
   Default networks not accepted from incoming updates
   Distance: internal 90, external 170
   Maximum paths: 4
   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
   Metric rib-scale 128
   Metric version 64bit
   EIGRP maximum hopcount 100
   EIGRP maximum metric variance 1
   
   EIGRP NSF: enabled
    NSF-aware route hold timer is 480s
    NSF signal timer is 20s
    NSF converge timer is 300s
    Time since last restart is 01:40:15
   SIA Active timer is 180s
   Interfaces:
    Loopback0
    GigabitEthernet0/0/0/0

次の表に、この出力で表示される重要なフィールドの説明を示します。

フィールド

説明

K6=0

K6 制約値

Metric rib-scale 128

メトリック RIB スケール スケール ダウン値

Metric version 64bit

ビット単位のメトリック バージョン

site-of-origin(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイス上で Site of Origin(SoO)フィルタリングを設定するには、インターフェイス コンフィギュレーション モードで site-of-origin コマンドを使用します。 インターフェイス上で SoO フィルタリングをディセーブルにするには、このコマンドの no 形式を使用します。

site-of-origin { as-number : number | ip-address : number }

no site-of-origin

構文の説明

as-number:

Autonomous System(AS; 自律システム)番号。

2 バイトの自律システム番号(ASN)の範囲は 1 ~ 65535 です。

asplain 形式の 4 バイトの自律システム番号(ASN)の範囲は 1 ~ 4294967295 です。

asdot 形式の 4 バイトの自律システム番号(ASN)の範囲は 1.0 ~ 65535.65535 です。

自律システム番号とネットワーク番号はコロンで区切ります。

number

ネットワーク番号。 2 バイトの AS 番号を使用する場合、範囲は 0 ~ 4294967295 です。 4 バイトの AS 番号を使用する場合、範囲は 0 ~ 65535 です。

ip-address:

4 分割ドット付き 10 進表記の IP アドレス。

IP アドレスとネットワーク番号はコロンで区切ります。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 3.9.0

4 バイトの自律システム番号表記の asplain 形式がサポートされました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

バックドア リンクを持つサイト間の MPLS VPN リンクを含む複雑なトポロジのサポートが要求される場合は、ボーダー ゲートウェイ プロトコル(BGP)から再配布されたルートの SoO 属性を EIGRP プロセスで検索できる必要があります。

プレフィックスが再び送信元サイトにアドバタイズされないように、サイトから発信されたルートの識別に使用する SoO BGP 拡張コミュニティ属性を設定するには、site-of-origin コマンドを使用します。 SoO 拡張コミュニティは、プロバイダー エッジ(PE)ルータがルートを学習したサイトを一意に識別します。

タスク ID

タスク ID

操作

eigrp

read, write

次に、EIGRP インターフェイスで SoO フィルタリングを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) vrf customer1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-eigrp--vrf-af-if)# site-of-origin 10.0.0.1:20
  
         

split-horizon disable(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスでスプリット ホライズンをディセーブルにするには、インターフェイス コンフィギュレーション モードで split-horizon disable コマンドを使用します。 スプリット ホライズンをイネーブルにするには、このコマンドの no 形式を使用します。

split-horizon disable

no split-horizon disable

構文の説明

このコマンドには、キーワードと引数はありません。

コマンド デフォルト

スプリット ホライズンは、EIGRP プロセスではイネーブルです。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

eigrp

read, write

次に、GigabitEthernet リンク上でスプリット ホライズンをディセーブルにする例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)# split-horizon disable
  
         

stub(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)にルータをスタブとして設定するには、適切なコンフィギュレーション モードで stub コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

stub [ receive-only | [connected] [redistributed] [static] [summary] ]

no stub [ receive-only | [connected] [redistributed] [static] [summary] ]

構文の説明

receive-only

(任意)ルータを受信専用のネイバーとして設定します。

connected

(任意)接続ルートをアドバタイズします。

redistributed

(任意)他のプロトコルと Autonomous System(AS; 自律システム)から再配布されたルートをアドバタイズします。

static

(任意)スタティック ルートをアドバタイズします。

summary

(任意)集約ルートをアドバタイズします。

コマンド デフォルト

スタブ ルーティングはディセーブルです。

スタブ ルーティングを指定した場合、接続ルートおよびサマリー ルートはデフォルトでアドバタイズされます。

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ルータがすべての IP トラフィックをディストリビューション ルータに渡すスタブとしてルータを設定するには、stub コマンドを使用します。

stub コマンドは、オプションを複数使用して変更することができます。receive-only キーワードを除き、これらのオプションを任意に組み合わせて使用できます。

receive-only キーワードを使用すると、ルータがこの EIGRP 自律システム内の他のルータとルートを共有するのを制限します。ルートのどのタイプも送信されなくなるため、他のオプションを指定できません。 その他の 4 つのオプション キーワード(connectedstaticsummary、および redistributed)は任意の組み合わせで使用できますが、receive-only キーワードと同時には使用できません。 これら 4 つのキーワードのいずれも stub コマンドとともに使用する場合は、特定のキーワード(複数可)で指定されたルート タイプだけが送信されます。 キーワードを使用せずに指定されたルート タイプは送信されません。

connected キーワードを使用すると、EIGRP スタブ ルーティングで接続ルートを送信できます。 すべての接続ルートが EIGRP インターフェイスに含まれていない場合、EIGRP プロセスで redistribute connected コマンドを使用して、接続ルートの再配布が必要になる場合もあります。 このオプションは、デフォルトで有効です。

static キーワードを使用すると、EIGRP スタブ ルーティングでスタティック ルートを送信できます。 このオプションを設定しないと、EIGRP ではスタティック ルートを送信しません。 redistribute static コマンドを使用して、スタティック ルートの再配布がさらに必要な場合もあります。

summary キーワードを使用すると、EIGRP スタブ ルーティングでサマリー ルートを送信できます。 サマリー ルートは、summary address コマンドを使用して手動で作成するか、または auto-summary コマンドがイネーブルの場合には、主要なネットワーク境界ルータで自動に作成できます。 このオプションは、デフォルトで有効です。

redistributed キーワードを使用すると、EIGRP スタブ ルーティングで他のルーティング プロトコルおよび自律システムを送信できます。 このオプションを設定しないと、EIGRP では再配布ルートをアドバタイズしません。

タスク ID

タスク ID

操作

eigrp

read, write

次に、接続ルートおよびサマリー ルートをアドバタイズするスタブとしてルータを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# stub
  
  
         

次に、受信専用ネイバーとしてルータを設定する例を示します(接続ルート、サマリー ルート、およびスタティック ルートは送信されません)。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# stub receive-only
  
         

関連コマンド

コマンド

説明

redistribute(EIGRP)

あるルーティング ドメインからのルートを EIGRP に再配布します。

summary-address(EIGRP)

指定された EIGRP インターフェイスのサマリー集約アドレスを設定します。

auto-summary(EIGRP)

EIGRP プロセスでサブネット ルートをネットワークレベルのルートに自動サマライズできるようにします。

summary-address(EIGRP)

指定された Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスのサマリー集約アドレスを設定するには、インターフェイス コンフィギュレーション モードで summary-address コマンドを使用します。 設定をディセーブルにするには、このコマンドの no 形式を使用します。

summary-address ip-address { /length | mask } [admin-distance]

no summary-address ip-address { /length | mask }

構文の説明

ip-address

IP アドレスの引数は、インターフェイスに適用するサマリー IP アドレスを 4 分割ドット付き 10 進表記で指定します。

/ length

プレフィックス長。スラッシュ(/)と数字で指定できます。 たとえば、/8 は、IP プレフィックスの最初の 8 ビットがネットワーク ビットであることを示します。 length を使用する場合、スラッシュが必要です。

mask

IP アドレス マスク

admin-distance

(任意)アドミニストレーティブ ディスタンス。 値の範囲は 1 ~ 255 です。

コマンド デフォルト

EIGRP サマリー ルートには、アドミニストレーティブ ディスタンス 5 が適用されます。

事前設定されるサマリー アドレスはありません。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

インターフェイスレベルのアドレス サマライズを設定するには、summary-address コマンドを使用します。 EIGRP サマリー ルートのアドミニストレーティブ ディスタンスは 5 です。 アドミニストレーティブ ディスタンスは、サマリーをルーティング テーブルに追加せずにアドバタイズするために使用します。

デフォルトでは、EIGRP はサブネット ルートをネットワーク レベルに集約します。 サブネット レベルの集約を設定するために、no auto-summary コマンドを入力することができます。

タスク ID

タスク ID

操作

eigrp

read, write

EIGRP インターフェイスの 192.168.0.0/16 サマリー アドレスにアドミニストレーティブ ディスタンス 95 を設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)# summary-address 192.168.0.0/16 95 
  
         

関連コマンド

コマンド

説明

auto-summary(EIGRP)

EIGRP プロセスでサブネット ルートをネットワークレベルのルートに自動サマライズできるようにします。

timers active-time

Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティング待機時間を調整するには、適切なコンフィギュレーション モードで timers active-time コマンドを使用します。 この機能をディセーブルにするには、このコマンドの timers active-time no 形式を使用します。

timers active-time [ time-limit | disabled ]

no timers active-time

構文の説明

time-limit

アクティブ時間制限(分単位)。 範囲は 1 ~ 4294967295 分です。

disabled

タイマーをディセーブルにし、ルーティング待機時間は期限なくアクティブのままにできます。

コマンド デフォルト

ディセーブル

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ルータが(クエリー送信後)ルートを Stuck in Active(SIA)ステートであると宣言するまでに待機する時間を制御するには、timers active-time コマンドを使用します。

タスク ID

タスク ID

操作

eigrp

read, write

次に、指定した EIGRP ルートに無制限のルーティング待機時間を設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# timers active-time disabled
  
         

関連コマンド

コマンド

説明

show eigrp topology

EIGRP トポロジ テーブル内のエントリを表示します。

timers nsf route-hold(EIGRP)

NSF 対応 Enhanced Interior Gateway Routing Protocol(EIGRP)ルータが非アクティブなピアのルートを保持する時間を決めるタイマーを設定するには、適切なコンフィギュレーション モードで timers nsf route-hold コマンドを使用します。 このルート ホールド タイマーをデフォルト値に戻すには、このコマンドの no 形式を使用します。

timers nsf route-hold seconds

no timers nsf route-hold

構文の説明

seconds

EIGRP が非アクティブ ピアのルートを保持する時間(秒)。 範囲は 20 ~ 6000 秒です。

コマンド デフォルト

EIGRP NSF 認識がイネーブルになっています。

seconds:480

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 4.1.1

デフォルトのルート ホールド タイムが 240 秒から 480 秒に変更されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

スイッチオーバーの動作中または well-known 障害の状態にある間、NSF 対応ルータが NSF 対応ネイバーの既知のルートを保持する最長時間を設定するには、timers nsf route-hold コマンドを使用します。 ネットワークのパフォーマンスを調整し、スイッチオーバー動作に時間がかかりすぎた場合に起こるルートでのパケット損失など、不要な影響を受けないために、ルートのホールド タイマーを設定します。 このタイマーの期限が切れると、NSF 認識ルータはトポロジ テーブルをスキャンし無効なルートを破棄します。これにより EIGRP ピアは、スイッチオーバー動作中に長い時間待機せずに代替ルートを探すことができます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、NSF 認識ルータのルート ホールド タイマー値を 2 分(120 秒)に設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router eigrp 1
RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
RP/0/RSP0/CPU0:router(config-eigrp-af)# timers nsf route-hold 120

variance

Enhanced Interior Gateway Routing Protocol(EIGRP)ベースのインターネットワークのロード バランシングを制御するには、適切なコンフィギュレーション モードで variance コマンドを使用します。 バリアンスをデフォルト値に戻すには、このコマンドの no 形式を使用します。

variance multiplier

no variance

構文の説明

multiplier

ロード バランシングに使用されるメトリック値。 範囲は 1 ~ 128 です。

コマンド デフォルト

multiplier:1(等コストのロード バランシング)

コマンド モード

IPv4 アドレス ファミリ コンフィギュレーション

IPv4 VRF アドレス ファミリ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ルータで潜在するルートの実行可能性を判断できるように、EIGRP ルータでバリアンスを設定するには、variance コマンドを使用します。 パス内の次のルータが現在のルータよりも宛先に近く、パス全体のメトリックがバリアンスの範囲内にある場合、ルートは実行可能です。 実行可能なパスだけをロード バランシングに使用して、ルーティング テーブルに含めることができます。

次の 2 つの条件を満たす場合、ルートは実行可能と見なされ、ルーティング テーブルに追加されます。

  1. ローカルの最適メトリックは、次のルータから学習したメトリックよりも大きくなければなりません。
  2. 宛先に対するローカルの最適メトリックを調整する乗数は、次のルータを使用するメトリックよりも大きいかまたは等しくなければなりません。

タスク ID

タスク ID

操作

eigrp

read, write

次に、バリアンスとして 4 を設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# variance 4
  
         

vrf(EIGRP)

VPN ルーティングおよび転送(VRF)インスタンスを定義して VRF コンフィギュレーション モードを開始するには、ルータ コンフィギュレーション モードで vrf コマンドを使用します。 VRF インスタンスを削除するには、このコマンドの no 形式を使用します。

vrf vrf-name

no vrf vrf-name

構文の説明

vrf-name

VPN ルーティング/転送インスタンス。

コマンド デフォルト

VRF は定義されていません。

コマンド モード

ルータ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

VRF インスタンスを設定するには、vrf コマンドを使用します。 VRF インスタンスは、プロバイダー エッジ(PE)ルータで保持される VPN ルーティング/転送テーブルを収集したものです。

VRF コンフィギュレーション モードで、アドレス ファミリ コンフィギュレーション モードを開始してから、auto-summary コマンドなどのコマンドを発行する必要があります。

単一の EIGRP ルーティング プロセスでは複数の VRF がサポートされます。 設定できる VRF の数は、ルータ上で使用可能なシステム リソースに応じて制限されます。これは、VRF 数、実行中のプロセス、使用可能なメモリによって決まります。 ただし、各 VPN でサポートできるのは 1 つの VRF だけです。 異なる VRF 間の再配布はサポートされません。

PE ルータとカスタマー エッジ(CE)ルータ間の MPLS VPN のサポートは、サービス プロバイダーのバックボーン上に VPN サービスを提供する PE ルータだけに設定します。 お客様のサイトでは、EIGRP VPN をサポートするために機器や設定を変更する必要はありません。 通常、CE ルータにアドバタイズするルートにメトリックを設定する必要があります。 メトリックは、redistribute プロトコル コマンドの route-policy、または default-metric コマンドで設定できます。

IP インターフェイス上で VRF の割り当て、削除、または変更を行う前に、IPv4/IPv6 アドレスをインターフェイスから削除する必要があります。 これを事前に行わない場合、IP インターフェイス上での VRF 変更はすべて拒否されます。

タスク ID

タスク ID

操作

eigrp

read, write

次に、IPv4 VRF アドレス ファミリ コンフィギュレーション モードを開始して、このモードから発行できる EIGRP コマンドを識別する例を示します。

  RP/0/RSP0/CPU0:router(config)# router eigrp 1
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# ?
  
    auto-summary           Auto summarisation
    autonomous-system      Set the autonomous system of VRF
    commit                 Commit the configuration changes to running
    default-information    Handling of default route
    default-metric         Set metric of redistributed routes
    describe               Describe a command without taking real actions
    distance               Set distance for EIGRP routes
    do                     Run an exec command
    exit                   Exit from this submode
    interface              EIGRP interface configuration submode
    log-neighbor-changes   Enable/Disable EIGRP neighbor logging
    log-neighbor-warnings  Enable/Disable EIGRP neighbor warnings
    maximum-paths          Maximum paths
    maximum-prefix         Maximum number of IP prefixes acceptable in aggregate
    metric                 Modify EIGRP routing metrics and parameters
    neighbor               Neighbor prefix limits configuration
    no                     Negate a command or set its defaults
    redistribute           Redistribute another protocol
    route-policy           Configure inbound/outbound policies
    router-id              Set router ID
    show                   Show contents of configuration
    stub                   EIGRP stub
    timers                 Configure EIGRP timers
    variance               Control load balancing variance
  

関連コマンド

コマンド

説明

default-metric(EIGRP)

EIGRP のメトリックを設定します。

redistribute(EIGRP)

あるルーティング ドメインからのルートを EIGRP に挿入します。