Cisco ASR 9000 シリーズ ルータの RIP コマンド
Cisco ASR 9000 シリーズ ルータの RIP コマンド
発行日;2013/07/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

Cisco ASR 9000 シリーズ ルータの RIP コマンド

このモジュールでは、Routing Information Protocol(RIP)を設定およびモニタするために使用するコマンドについて説明します。

RIP の概念、設定作業、および例については、 『Cisco ASR 9000 Series Aggregation Services Router Routing Configuration Guide』の「Implementing RIP on Cisco ASR 9000 Series Router 」のモジュールを参照してください。

authentication keychain mode(RIP)

RIP インターフェイスに対して認証キーチェーン メカニズムをイネーブルにするには、インターフェイス コンフィギュレーション モードまたは VRF インターフェイス コンフィギュレーション モードで authentication keychain mode コマンドを使用します。 RIP インターフェイスの認証キーチェーン コンフィギュレーションをディセーブルにするには、このコマンドの no 形式を使用します。

authentication keychain keychain_name mode { md5 | text }

no authentication keychain keychain_name mode { md5 | text }

構文の説明

keychain-name
keychain コマンドを使用して設定されたキーチェーンの名前を指定します。
(注)     

すべてのキーチェーンは、キーチェーン コンフィギュレーション コマンドを使用して Cisco IOS XR キーチェーン データベース内で設定する必要があります。 『Cisco ASR 9000 Series Aggregation Services Router System Security Configuration Guide』「Implementing Keychain Management」のモジュールを参照してください。

md5

認証キーチェーン モードがキー付きメッセージ ダイジェスト(md5)であることを指定します。

text

認証キーチェーン モードがクリア テキストであることを指定します。

コマンド デフォルト

キーチェーン認証はディセーブルです。

コマンド モード

インターフェイス コンフィギュレーション

VRF インターフェイス コンフィギュレーション

コマンド履歴

リリース 変更箇所

リリース 4.0.0

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

すべてのキーチェーンは、キーチェーン コンフィギュレーション コマンドを使用して Cisco IOS XR キーチェーン データベース内で設定する必要があります。 『Cisco ASR 9000 Series Aggregation Services Router System Security Configuration Guide』「Implementing Keychain Management」のモジュールを参照してください。

タスク ID

タスク ID 操作

rip

read, write

次の例では、RIP VRF インターフェイスに対して md5 モードの認証キーチェーンを設定する方法を示します。
RP/0/RSP0/CPU0:router#configure
RP/0/RSP0/CPU0:router(config)#router rip
RP/0/RSP0/CPU0:router(config-rip)#vrf vrf_rip_auth
RP/0/RSP0/CPU0:router(config-rip-vrf)#interface POS 0/6/0/0
RP/0/RSP0/CPU0:router(config-rip-vrf-if)#authentication keychain key1 mode md5

次の例では、RIP インターフェイスに対してクリア テキスト モードの認証キーチェーンを設定する方法を示します。
RP/0/RSP0/CPU0:router#configure
RP/0/RSP0/CPU0:router(config)#router rip
RP/0/RSP0/CPU0:router(config-rip)#interface POS 0/6/0/1
RP/0/RSP0/CPU0:router(config-rip-if)#authentication keychain key2 mode text

関連コマンド

コマンド 説明

router rip

ルーティング プロセスを設定し、Routing Information Protocol(RIP)プロセスのルータ コンフィギュレーション モードを開始します。

vrf(RIP)

VPN ルーティング/転送(VRF)インスタンスを定義し、VRF コンフィギュレーション モードを開始します。

完全なコマンド リファレンス情報については、 『Cisco ASR 9000 Series Aggregation Services Router System Security Command Reference』を参照してください。

key chain(キーチェーン)

キーチェーンを作成または変更します。

完全なコマンド リファレンス情報については、 『Cisco ASR 9000 Series Aggregation Services Router System Security Command Reference』を参照してください。

key(キーチェーン)

キーチェーンのキーを作成または変更します。

完全なコマンド リファレンス情報については、 『Cisco ASR 9000 Series Aggregation Services Router System Security Command Reference』を参照してください。

key-string(キーチェーン)

キーのテキスト文字列を指定します。

完全なコマンド リファレンス情報については、 『Cisco ASR 9000 Series Aggregation Services Router System Security Command Reference』を参照してください。

auto-summary(RIP)

サブネット ルートを自動サマライズしてネットワーク レベル ルートにする機能をイネーブルにするには、適切なコンフィギュレーション モードで auto-summary コマンドを使用します。 この機能をディセーブルにして、サブプレフィックス ルーティング情報をクラスフル ネットワーク境界を越えて送信するには、このコマンドの no 形式を使用します。

auto-summary

no auto-summary

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

ディセーブル

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

auto-summary コマンドは、ルート集約をオンにするために使用します。 ルート集約により、ルーティング テーブルにおけるルーティング情報の量が少なくなります。

切断されているサブネット間のルーティングを実行する必要がある場合は、自動サマライズをディセーブルにします。 自動サマライズがオフの場合、サブネットがアドバタイズされます。 自動サマライズはデフォルトでディセーブルになっています。

タスク ID

タスク ID

操作

rip

read, write

次に、RIP の自動サマライズをオンにする例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# auto-summary
  
         

関連コマンド

コマンド

説明

vrf(RIP)

VRF インスタンスを定義し、VRF コンフィギュレーション モードを開始します。

broadcast-for-v2

Routing Information Protocol(RIP)バージョン 2 出力パケットをブロードキャスト アドレスに送信するには、適切なコンフィギュレーション モードで broadcast-for-v2 コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

broadcast-for-v2

no broadcast-for-v2

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

RIPv2 出力パケットはブロードキャストされません。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

broadcast-for-v2 コマンドは、RIP バージョン 2 ブロードキャスト アップデートを、マルチキャストをリッスンしないホストにブロードキャストするために使用します。 バージョン 2 アップデート(要求と応答)は、IP マルチキャスト アドレス 244.0.0.9 ではなく、IP ブロードキャスト アドレス 255.255.255.255 に送信されます。

タスク ID

タスク ID

操作

rip

read, write

次に、全 RIP インターフェイスで、RIP v2 出力メッセージをブロードキャスト アドレスに送信する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# broadcast-for-v2
  
         

clear rip

データベース エントリや統計情報など、Routing Information Protocol(RIP)の VRF およびインターフェイス関連の情報をクリアするには、EXEC モードで clear rip コマンドを使用します。

clear rip [ vrf { vrf | all } ]

構文の説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

メモリ不足状態が原因で RIP VRF とインターフェイスがソフトウェアによって強制的に非アクティブ化された場合に、再度アクティブ化するには、clear ripclear rip interface、または clear rip out-of-memory コマンドを使用してメモリ不足状態をクリアする必要があります。

タスク ID

タスク ID

操作

rip

read

次に、RIP 内のすべてのデータベース、インターフェイス、VRF エントリをクリアする例を示します。

RP/0/RSP0/CPU0:routerr# clear rip vrf all
         

関連コマンド

コマンド

説明

clear rip interface

データベース エントリや統計情報など、RIP のインターフェイス関連の情報をクリアします。

clear rip out-of-memory

RIP のメモリ不足状態をクリアします。

clear rip database

Routing Information Protocol(RIP)トポロジ テーブルからデータベース エントリだけをクリアするには、EXEC モードで clear rip database コマンドを使用します。

clear rip [ vrf { vrf | all } ] database [ interface type interface-path-id ]

構文の説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

interface

(任意)トポロジ エントリを消去するインターフェイスを指定します。

type

インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

(注)     

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

rip

read, write

次に、GigabitEthernet 0/1/0/0 インターフェイスのトポロジ テーブルのデータベース エントリだけをクリアする例を示します。

RP/0/RSP0/CPU0:router# clear rip database interface GigabitEthernet 0/1/0/0
         

関連コマンド

コマンド

説明

show rip statistics

RIP プロセスのデータベースおよびインターフェイス エントリ情報を表示します。

clear rip interface

データベース エントリや統計情報など、Routing Information Protocol(RIP)のインターフェイス関連の情報をクリアするには、EXEC モードで clear rip interface コマンドを使用します。

clear rip [ vrf { vrf | all } ] interface type interface-path-id

構文の説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

interface

トポロジ エントリを消去するインターフェイスを指定します。

type

インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

(注)     

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

メモリ不足状態が原因で RIP VRF とインターフェイスがソフトウェアによって強制的に非アクティブ化された場合に、再度アクティブ化するには、clear ripclear rip interface、または clear rip out-of-memory コマンドを使用してメモリ不足状態をクリアする必要があります。

タスク ID

タスク ID

操作

rip

read, write

次に、ルートや統計情報などのインターフェイス関連のデータすべてを GigabitEthernet 0/1/0/0 インターフェイスからクリアする例を示します。

RP/0/RSP0/CPU0:router# clear rip vrf vpn-1 interface GigabitEthernet 0/1/0/0
         

関連コマンド

コマンド

説明

clear rip

データベース エントリや統計情報など、RIP の VRF およびインターフェイス関連の情報をクリアします。

clear rip out-of-memory

RIP のメモリ不足状態をクリアします。

clear rip out-of-memory

Routing Information Protocol(RIP)のメモリ不足状態をクリアするには、EXEC モードで clear rip out-of-memory コマンドを使用します。

clear rip [ vrf { vrf | all } ] out-of-memory [ interface type interface-path-id ]

構文の説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

interface

(任意)トポロジ エントリを消去するインターフェイスを指定します。

type

インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

(注)     

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

clear rip out-of-memory コマンドを使用すると、メモリ不足状態が完全にクリアされ、RIP プロセスによって VRF またはインターフェイスを強制的にシャットダウンできるようになります。

ルータでメモリが不足し始めると、RIP プロセスは、Normal、Minor、Severe、Critical として定義される各メモリ状態の間を遷移します。

  • Normal 状態では、RIP VRF とインターフェイスは正常に機能します。
  • Minor 状態では、現在アクティブな RIP VRF とインターフェイスはアクティブなままになります。 現在アクティブでない VRF とインターフェイスは、RIP プロセスが Normal 状態に遷移するまでアクティブになることができません。
  • Severe 状態では、RIP プロセスが別の状態に遷移するまで、いくつかの VRF とインターフェイスが強制的にダウン状態にされます。
  • Critical 状態では、RIP プロセスが強制的にシャットダウンされます。

Severe 状態で強制的にシャットダウンされた VRF とインターフェイスは、RIP プロセスが Minor 状態または Normal 状態に遷移しても、自動的にアクティブ化されません。 Severe 状態で VRF またはインターフェイスが強制的にダウン状態にされた場合、clear ripclear rip interface、または clear rip out-of-memory コマンドを実行すると Forced Down 状態がクリアされ、VRF またはインターフェイスが再度アクティブ化されます。

show rip コマンドおよび show rip interface コマンドを使用すると、現在のメモリ不足状態を表示できます。

タスク ID

タスク ID

操作

rip

read, write

次に、RIP プロセスのメモリ不足状態をクリアする例を示します。

RP/0/RSP0/CPU0:router# clear rip out-of-memory
         

関連コマンド

clear rip

データベース エントリや統計情報など、RIP の VRF およびインターフェイス関連の情報をクリアします。

clear rip interface

データベース エントリや統計情報など、RIP のインターフェイス関連の情報をクリアします。

show rip

RIP の設定とステータスを表示します。

show rip interface

RIP トポロジ テーブルのインターフェイス エントリ情報を表示します。

clear rip statistics

Routing Information Protocol(RIP)統計情報をクリアするには、EXEC モードで clear rip statistics コマンドを使用します。

clear rip [ vrf { vrf | all } ] statistics [ interface type interface-path-id ]

構文の説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

interface

(任意)トポロジ エントリをクリアするインターフェイスを指定します。

type

インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

(注)     

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

rip

read, write

次に、すべての RIP 統計情報を消去する例を示します。

RP/0/RSP0/CPU0:router# clear rip statistics
         

関連コマンド

コマンド

説明

show rip statistics

RIP プロセスのデータベースおよびインターフェイス エントリ情報を表示します。

default-information originate(RIP)

Routing Information Protocol(RIP)のデフォルト ルートを生成するには、適切なコンフィギュレーション モードで default-information originate コマンドを使用します。 RIP のデフォルト ルートをディセーブルにするには、このコマンドの no 形式を使用します。

default-information originate [ route-policy name ]

no default-information originate

構文の説明

route-policy name

デフォルト ルートの条件を示すルート ポリシーの名前。

コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

rip

read, write

次に、ルーティング テーブルに対してルート ポリシーを実行した結果に基づき、RIP アップデートでデフォルト ルートを開始する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# default-information originate route-policy policy1
  
         

関連コマンド

コマンド

説明

route-policy(RIP)

RIP ネイバーにアドバタイズするアップデートや、RIP ネイバーから受信するアップデートに、ルーティング ポリシーを適用します。

default-metric(RIP)

他のプロトコルから Routing Information Protocol(RIP)に再配布されるルートのデフォルト メトリック値を設定するには、適切なコンフィギュレーション モードで default-metric コマンドを使用します。 デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

default-metric number-value

no default-metric

構文の説明

number-value

デフォルトのメトリック値。 範囲は 1 ~ 15 です。

コマンド デフォルト

デフォルト メトリックは設定されていません。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

RIP ですべての再配布ルートに同じメトリック値を使用するには、default-metric コマンドを redistribute コマンドとともに使用します。 デフォルト メトリックを使用すると、妥当な代替メトリックを設定し、再配布を可能にすることで、互換性のないメトリックを使用したルートを再配布するという問題を解決することができます。 再配布される他のプロトコルに対して異なるメトリックを設定する場合は、redistribute コマンドで route-policy オプションを使用します。

再配布されるルートで使用される RIP メトリックは、ルート ポリシーによって決まります。 ルート ポリシーが設定されていないか、ルート ポリシーで RIP メトリックが設定されていない場合は、再配布されるプロトコルに基づいてメトリックが決定されます。 BGP によって再配布される VPNv4 ルートの場合、リモート PE ルータで設定された RIP メトリックが有効であれば、それが使用されます。

その他すべての場合(BGP、IS-IS、OSPF、EIGRP、接続済み、スタティック)は、default-metric コマンドで設定されたメトリックが使用されます。 有効なメトリックが決定できない場合、再配布は起こりません。

タスク ID

タスク ID

操作

rip

read, write

次に、自律システム 109 がルーティング プロトコル RIP と Open Shortest Path First(OSPF; オープン ショーテスト パス ファースト)の両方を使用する例を示します。 この例は、OSPF から取得したルートを RIP を使用してアドバタイズし、OSPF から取得したルートに RIP メトリック 10 を割り当てます。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-rip-vrf)# default-metric 10
  RP/0/RSP0/CPU0:router(config-rip-vrf)# redistribute ospf 109
  
         

関連コマンド

コマンド

説明

redistribute(RIP)

ルートを 1 つのルーティング ドメインから RIP に再配布します。

distance(RIP)

Routing Information Protocol(RIP)によって検出されたルートに割り当てるアドミニストレーティブ ディスタンスを定義するには、適切なコンフィギュレーション モードで distance admin-distance コマンドを使用します。 コンフィギュレーション ファイルから距離の定義を削除し、システムをデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

distance admin-distance [ prefix prefix-length | prefix mask ]

no distance admin-distance

構文の説明

admin-distance

RIP ルートに割り当てるアドミニストレーティブ ディスタンス。 範囲は 0 ~ 255 です。

prefix

(任意)ルーティング情報が表示されるネットワーク IP アドレス。

prefix-length

(任意)prefix-length 引数は、IP プレフィックスの長さを指定します。 これは、プレフィックス(アドレスのネットワーク部)を構成するアドレスの上位隣接ビット数を示す 10 進数値です。 10 進数値の前にスラッシュを付ける必要があります。 IPv4 アドレスの場合の範囲は 0 ~ 32 です。

mask

(任意)次の 2 つの方法のうちいずれかで指定されるネットワーク マスク。

  • 4 分割ドット付き 10 進表記のアドレスでネットワーク マスクを指定します。 たとえば、255.0.0.0 の場合、各ビットが 1 のときに対応するアドレス ビットがネットワーク アドレスであることを示します。
  • ネットワーク マスクは、スラッシュ(/)と数字で表すことができます。 たとえば、/8 は、マスクの最初の 8 ビットが 1 であり、アドレスの対応するビットがネットワーク アドレスであることを示します。

コマンド デフォルト

admin-distance:120

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

distance コマンドを使用し、他のプロトコル ルートに対する RIP ルートのプリファレンスを変更します。 アドミニストレーティブ ディスタンスと再配布機能を同時に使用する場合は、RIP ネイバーから受け取るルートや RIP ネイバーにアドバタイズするルートに対する振る舞いが影響を受ける可能性があります。

数値的に、アドミニストレーティブ ディスタンスは 0 ~ 255 の整数です。 通常、値が大きいほど、信頼性の格付けが下がります。 255 のアドミニストレーティブ ディスタンスは、ルーティング情報源がまったく信頼できないため、無視すべきであることを意味します。

distance コマンドを実行する順序は、割り当てられるアドミニストレーティブ ディスタンスに予期せぬ方法で影響を与える可能性があります。

次の表に、デフォルトのアドミニストレーティブ ディスタンスをリストします。

表 1 各ルーティング プロトコルのデフォルトのアドミニストレーティブ ディスタンス

ルーティング プロトコル

アドミニストレーティブ ディスタンス値

接続されているインターフェイス

0

インターフェイス外部のスタティック ルート

0

ネクストホップへのスタティック ルート

1

EIGRP サマリー ルート

5

EBGP

20

内部 EIGRP

90

OSPF

110

IS-IS

115

RIP バージョン 1 および 2

120

外部 EIGRP

170

IBGP

200

不明

255

タスク ID

タスク ID

操作

rip

read, write

次に、特定のプレフィックスに対してアドミニストレーティブ ディスタンスを設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# distance 85 192.168.10.0/24

関連コマンド

コマンド

説明

redistribute(RIP)

ルートを 1 つのルーティング ドメインから RIP に再配布します。

interface(RIP)

Routing Information Protocol(RIP)が動作するインターフェイスを定義し、インターフェイス コンフィギュレーション モードに移行するには、ルータ コンフィギュレーション モードで interface コマンドを使用します。 インターフェイスに対する RIP ルーティングをディセーブルにするには、このコマンドの no 形式を使用します。

interface type interface-path-id

no interface type interface-path-id

構文の説明

type

インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

(注)     

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

コマンド デフォルト

このコマンドをコンフィギュレーション モードで指定しない場合、インターフェイスに対する RIP ルーティングはイネーブルになりません。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

interface コマンドは、特定のインターフェイスを RIP プロセスに関連付けるために使用します。 インターフェイスの IPv4 アドレスが変更された場合でも、インターフェイスがプロセスに関連付けされた状態は変わりません。

このコマンドを使用すると、ルータをインターフェイス コンフィギュレーション モードにします。このモードから、インターフェイス固有の設定を実行できます。 このモードで設定したコマンド(broadcast-for-v2 コマンドなど)は、そのインターフェイスに自動的にバインドされます。

タスク ID

タスク ID

操作

rip

read, write

次に、RIP プロセスのインターフェイス コンフィギュレーション モードに移行し、GigabitEthernet インターフェイス 0/1/0/0 上で RIP バージョン 2 メッセージをブロードキャスト アドレスに送信する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# ?
  
    broadcast-for-v2    Specify broadcast address for RIP v2 output packet
    commit              Commit the configuration changes to running
    describe            Describe a command without taking real actions
    do                  Run an exec command
    exit                Exit from this submode
    metric-zero-accept  Accept rip update with metric 0 to compensate a common bug
    no                  Negate a command or set its defaults
    passive-interface   Suppress routing updates on this interface
    poison-reverse      Enable poison reverse
    receive             Advertisement reception
    route-policy        Apply route policy to routing updates
    send                Advertisement transmission
    show                Show contents of configuration
    site-of-origin      SOO community for prefixes learned over this interface
    split-horizon       Disable split horizon
  RP/0/RSP0/CPU0:router(config-rip-if)# broadcast-for-v2
  
         

関連コマンド

コマンド

説明

broadcast-for-v2

RIP バージョン 2 出力パケットをブロードキャスト アドレスに送信します。

maximum-paths(RIP)

Routing Information Protocol(RIP)がルーティング テーブルに追加する等コスト パラレル ルートの最大数を設定するには、適切なコンフィギュレーション モードで maximum-paths コマンドを使用します。 コンフィギュレーション ファイルから maximum-paths コマンドを削除し、システムを RIP に関してデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum-paths

構文の説明

maximum

RP がルーティング テーブル内にインストールできるパラレル ルートの最大数。 範囲は 1 ~ 32 です。

コマンド デフォルト

4 パス

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

rip

read, write

次の例では、1 つの宛先に最大 16 の等価コスト パスが許可されます。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# maximum-paths 16
  
         

metric-zero-accept

RIP で、メトリックにゼロ(0)が設定された RIP アップデートからのルーティング エントリを受け付けるようにするには、インターフェイス コンフィギュレーション モードで metric-zero-accept コマンドを使用します。 コンフィギュレーション ファイルから metric-zero-accept コマンドを削除し、システムを RIP に関してデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

metric-zero-accept

no metric-zero-accept

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

メトリック ゼロ(0)で受信した RIP ルートは無視されます。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

RIP アップデートからのルーティング エントリに対して metric-zero-accept コマンドを設定した後は、RIP はこれらのルートを受け付けた後でメトリックを 1 に設定します。

タスク ID

タスク ID

操作

rip

read, write

次に、メトリックがゼロのルーティング エントリを受け付けるように RIP インターフェイスを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# metro-zero-accept
  
         

neighbor(RIP)

Routing Information Protocol(RIP)情報を交換する隣接ルータを定義するには、適切なコンフィギュレーション モードで neighbor コマンドを使用します。 エントリを削除するには、このコマンドの no 形式を使用します。

neighbor ip-address

no neighbor ip-address

構文の説明

ip-address

ルーティング情報を交換するピア ルータの IP アドレス。

コマンド デフォルト

隣接ルータは定義されていません。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ルーティング情報のポイントツーポイント(非ブロードキャスト)交換を許可するには、neighbor コマンドを使用します。 ルータ コンフィギュレーション モードで、neighbor コマンドを passive-interface コマンドとともに使用すると、ルータのサブセットと LAN 上のアクセス サーバの間でルーティング情報を交換できます。

複数の neighbor コマンドを使用して、他のネイバーまたはピアを指定できます。

タスク ID

タスク ID

操作

rip

read, write

次に、特定のネイバーに対する RIP アップデートの送信を許可する例を示します。 1 つのネイバーにつきアップデートのコピーが 1 つ生成されます。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-rip-vrf)# neighbor 172.16.1.2
  
         

関連コマンド

コマンド

説明

passive-interface(RIP)

インターフェイス上での RIP アップデートの送信を抑止します。

nsf(RIP)

Routing Information Protocol(RIP)プロセスのシャットダウンまたは再起動後に RIP ルート上のノンストップ フォワーディング NSF を設定するには、適切なコンフィギュレーション モードで nsf コマンドを使用します。 コンフィギュレーション ファイルからこのコマンドを削除し、システムをデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

nsf

no nsf

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

NSF はディセーブルです。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

nsf コマンドを使用した場合、NSF ライフタイムがアップデート時間の 2 倍に自動的に設定されます(最小値は 60 秒)。 RIP プロセスは、この時間に再コンバージする必要があります。 コンバージェンスが NSF ライフタイムを超える場合、ルートは Routing Information Base(RIB; ルーティング情報ベース)から除去され、NSF が失敗することがあります。

タスク ID

タスク ID

操作

rip

read, write

次に、RIP NSF を設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-rip-vrf)# nsf
  
         

output-delay

送信する Routing Information Protocol(RIP)アップデートのパケット間遅延を変更するには、適切なコンフィギュレーション モードで output-delay コマンドを使用します。 遅延を削除するには、このコマンドの no 形式を使用します。

output-delay delay

no output-delay delay

構文の説明

delay

複数パケット RIP アップデートにおける連続パケット間の遅延(ミリ秒単位)。 範囲は 8 ~ 50 です。

コマンド デフォルト

デフォルトは遅延なしです。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

output-delay コマンドは、高速で送信する相手のルータが低速であり、その速度で受信ができない可能性がある場合に使用します。 このコマンドを設定すると、ルーティング テーブルから情報が失われることを防ぐことができます。

タスク ID

タスク ID

操作

rip

read, write

次に、パケット間遅延を 10 ミリ秒に設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-rip-vrf)# output-delay 10
  
         

passive-interface(RIP)

インターフェイス上で Routing Information Protocol(RIP)アップデートの送信を抑止するには、インターフェイス コンフィギュレーション モードで passive-interface コマンドを使用します。 アップデートの抑止を解除するには、このコマンドの no 形式を使用します。

passive-interface

no passive-interface

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

インターフェイス上で RIP アップデートが送信されます。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

受動インターフェイス上でルーティング アップデートのマルチキャスト(またはブロードキャスト)アドレスへの送信が停止されている間も、そのインターフェイス上でのネイバーからのルーティング アップデートの受信と処理は続行されます。

タスク ID

タスク ID

操作

rip

read, write

次に、GigabitEthernet インターフェイス 0/1/0/0 で RIP アップデートのマルチキャスト(またはブロードキャスト)を停止する例を示します。RIP アップデートの受信は正常に続行されます。 GigabitEthernet インターフェイス 0/1/0/3 は、正常にアップデートを送受信します。 また、RIP アップデートは適切なインターフェイス上でネイバー 172.168.1.2 にユニキャストされます。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# neighbor 172.16.1.2
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# passive-interface
  RP/0/RSP0/CPU0:router(config-rip-if)# exit
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/3
  RP/0/RSP0/CPU0:router(config-rip-if)# exit
  
         

関連コマンド

コマンド

説明

neighbor(RIP)

RIP プロトコル情報を交換する隣接ルータを定義します。

poison-reverse

Routing Information Protocol(RIP)ルート アップデートのポイズン リバース処理をイネーブルにするには、インターフェイス コンフィギュレーション モードで poison-reverse コマンドを使用します。 RIP アップデートのポイズン リバース処理をディセーブルにするには、このコマンドの no 形式を使用します。

poison-reverse

no poison-reverse

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

ポイズン リバース処理はディセーブルです。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ルート ポイズニングとは、ルーティング ループを防止するための機能です。特定のルートが到達可能ではなくなったときに、そのことを他のルータに通知します。実質的に、そのルートは他のルータのルーティング テーブルから削除されます。 システム デフォルトであるスプリット ホライズンは、RIP を通じて学習したルートを、そのルートを学習したインターフェイスからはアドバタイズしないようにする機能です。

poison-reverse コマンドは、RIP ルータ アップデートのポイズン リバース処理をイネーブルにします。 ルート ポイズニング情報を受信したルータは、ポイズニング情報を送信元ルータに返します。このプロセスを「ポイズン リバース」といいます。 このプロセスによって、同じインターフェイス上のすべてのルータが確実に、ポイズニングされたルート情報を受信済みになります。

ポイズン リバースとスプリット ホライズンの両方が設定されている場合は、単純なスプリット ホライズン動作(ルートを学習したインターフェイスからのそのルートの抑止)がポイズン リバース動作で置き換えられます。 スプリット ホライズンがディセーブルの場合、ポイズン リバースの設定は無視されます。

タスク ID

タスク ID

操作

rip

read, write

次に、RIP が動作するインターフェイスでポイズン リバース処理をイネーブルにする例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# poison-reverse
  
         

関連コマンド

コマンド

説明

split-horizon disable(RIP)

スプリット ホライズン メカニズムをディセーブルにします。

receive version

バージョン固有のパケットを受け付けるように Routing Information Protocol(RIP)インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで receive version コマンドを使用します。 デフォルト設定に戻すには、このコマンドの no 形式を使用します。

receive version { 1 | 2 | 1 2 }

no receive version { 1 | 2 | 1 2 }

構文の説明

1

バージョン 1 のパケット

2

バージョン 2 のパケット

1 2

バージョン 1 と 2 のパケット

コマンド デフォルト

バージョン 2

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

receive version コマンドは、RIP のデフォルトの動作を変更するために使用します。 このコマンドは、設定中のインターフェイスだけに適用されます。

タスク ID

タスク ID

操作

rip

read, write

次に、RIP バージョン 1 と 2 のパケットを受け付けるようにインターフェイスを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# receive version 1 2
  
         

関連コマンド

コマンド

説明

send version

バージョン固有のパケットを送信するように RIP インターフェイスを設定します。

redistribute(RIP)

別のルーティング ドメインから受け取ったルートを Routing Information Protocol(RIP)に再配布するには、適切なコンフィギュレーション モードで redistribute コマンドを使用します。 コンフィギュレーション ファイルから redistribute コマンドを削除し、ルートの再配布をしないデフォルトの状態にシステムを戻すには、このコマンドの no 形式を使用します。

Border Gateway Protocol (BGP)

redistribute bgp process-id [ route-policy name ] [ external | internal | local ]

no redistribute bgp process-id

Connected Interface Routes

redistribute connected [ route-policy name ]

no redistribute connected

Enhanced Interior Gateway Routing Protocol (EIGRP)

redistribute eigrp process-id [ route-policy name ]

no redistribute eigrp process-id

Intermediate System-to-Intermediate System (ISIS)

redistribute isis process-id [ route-policy name ] [ level-1 | level-1-2 | level-2 ]

no redistribute isis process-id

Open Shortest Path First (OSPF)

redistribute ospf process-id [ route-policy name ] [ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ] } ]

no redistribute ospf process-id

IP Static Routes

redistribute static [ route-policy name ]

no redistribute static

構文の説明

bgp

BGP プロトコルからのルートを配布します。

process-id

  • bgp キーワードの場合:
    • 2 バイトの自律システム番号(ASN)の範囲は 1 ~ 65535 です。
    • asplain 形式の 4 バイトの自律システム番号(ASN)の範囲は 1 ~ 4294967295 です。
    • asdot 形式の 4 バイトの自律システム番号(ASN)の範囲は 1.0 ~ 65535.65535 です。
  • eigrp キーワードの場合は、ルートの再配布元である EIGRP インスタンスの名前です。 値は文字列の形式を取ります。 10 進数を入力できますが、ストリングとして内部に格納されます。
  • isis キーワードの場合は、ルートの再配布元である IS-IS インスタンスの名前です。 値は文字列の形式を取ります。 10 進数を入力できますが、ストリングとして内部に格納されます。
  • ospf キーワードの場合は、ルートの再配布元である OSPF インスタンスの名前です。 値は文字列の形式を取ります。 10 進数を入力できますが、ストリングとして内部に格納されます。

external

(任意)BGP 外部ルートだけを指定します。

internal

(任意)BGP 内部ルートだけを指定します。

local

(任意)BGP ローカル ルートだけを指定します。

route-policy name

(任意)設定されたポリシーの ID を指定します。 ポリシーは、このソース ルーティング プロトコルから RIP へのルートのインポートをフィルタするために使用されます。

level-1

(任意)レベル 1 IS-IS ルートだけを他のルーティング プロトコルに再配布します。

level-1-2

(任意)レベル 1 とレベル 2 の IS-IS ルートを他のルーティング プロトコルに配布します。

level-2

(任意)レベル 2 IS-IS ルートだけを他のルーティング プロトコルに配布します。

[ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ]]} [ route-policy name ]

(任意)OSPF ルートを他のルーティング ドメインに再配布する条件を指定します。 次の 1 つ以上の条件を指定できます。

  • internal:特定の自律システム内部のルート(エリア内およびエリア間の OSPF ルート)。
  • external [1 | 2]:自律システム外部のルートである一方で、タイプ 1 またはタイプ 2 の外部ルートとして OSPF にインポートされているルート。
  • nssa-external [1 | 2]:自律システム外部のルートである一方で、タイプ 1 またはタイプ 2 の Not-So-Stubby Area(NSSA)外部ルートとして OSPF にインポートされているルート。

external および nssa-external オプションでタイプを指定しなかった場合は、タイプ 1 とタイプ 2 の両方であると想定されます。

match が指定されていない場合、デフォルトはフィルタリングなしとなります。

static

IP スタティック ルートを再配布します。

コマンド デフォルト

ルートの再配布はディセーブルです。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 3.9.0

4 バイトの自律システム番号表記の asplain 形式がサポートされました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。


(注)  


属性とルート ポリシーを設定または一致させるための両方のコマンド キーワードを使用して、ルートを RIP に再配布する場合、ルートにまずルート ポリシーが適用され、その後キーワード照合と設定が行われます。


再配布されたルーティング情報は、route-policy name キーワードと引数でフィルタできます。 このフィルタリングにより、管理者が意図したルートだけが RIP によって再配布されます。

再配布されるルートで使用される RIP メトリックは、ルート ポリシーによって決まります。 ルート ポリシーが設定されていないか、ルート ポリシーで RIP メトリックが設定されていない場合は、再配布されるプロトコルに基づいてメトリックが決定されます。 BGP によって再配布される VPNv4 ルートの場合、リモート PE ルータで設定された RIP メトリックが有効であれば、それが使用されます。

その他すべての場合(BGP、IS-IS、OSPF、EIGRP、接続済み、スタティック)は、default-metric コマンドで設定されたメトリックが使用されます。 有効なメトリックが決定できない場合、再配布は起こりません。

ルーティング ポリシーの詳細については、『Cisco ASR 9000 Series Aggregation Services Router Routing Command Reference』の「Cisco ASR 9000 Series Router 」のモジュールの「Routing Policy Commands」を参照してください。

タスク ID

タスク ID

操作

rip

read, write

次に、BGP ルートを RIP プロセスに再配布する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# redistribute bgp 100
  
         

関連コマンド

コマンド

説明

default-metric(RIP)

他のプロトコルから RIP に再配布されるルートのデフォルト メトリック値を設定します。

router rip

ルーティング プロセスを設定し、Routing Information Protocol(RIP)プロセス用のルータ コンフィギュレーション モードに移行するには、グローバル コンフィギュレーション モードで router rip コマンドを使用します。 RIP ルーティング プロセスをオフにするには、このコマンドの no 形式を使用します。

router rip

no router rip

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

ルータ プロセスは定義されていません。

コマンド モード

グローバル コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

rip

read, write

次に、RIP のルータ プロセスを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# 
  
  

次に、RIP 用のルータ コンフィギュレーション モードに移行し、そのモードで実行できるコマンドの一覧を表示する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# ?
  
    auto-summary            Enable automatic network number summarization
    broadcast-for-v2        Send RIP v2 output packets to broadcast address
    commit                  Commit the configuration changes to running
    default-information     Control distribution of default information
    default-metric          Set metric of redistributed routes
    describe                Describe a command without taking real actions
    distance                Define an administrative distance
    do                      Run an exec command
    exit                    Exit from this submode
    interface               Enter the RIP interface configuration submode
    maximum-paths           Maximum number of paths allowed per route
    neighbor                Specify a neighbor router
    no                      Negate a command or set its defaults
    nsf                     Enable Cisco Non Stop Forwarding
    output-delay            Interpacket delay for RIP updates
    redistribute            Redistribute information from another routing protocol
    route-policy            Apply route policy to routing updates
    show                    Show contents of configuration
    timers                  Adjust routing timers
    validate-update-source  Validate source address of routing updates
    vrf                     Enter the RIP vrf configuration submode
  RP/0/RSP0/CPU0:router(config-rip)#
  

route-policy(RIP)

Routing Information Protocol(RIP)ネイバーにアドバタイズするアップデートや、RIP ネイバーから受信するアップデートにルーティング ポリシーを適用するには、適切なコンフィギュレーション モードで route-policy コマンドを使用します。 ルーティング ポリシーのアップデートへの適用をディセーブルにするには、このコマンドの no 形式を使用します。

route-policy name { in | out }

no route-policy name { in | out }

構文の説明

name

ルート ポリシーの名前。

in

ポリシーを着信ルートに適用します。

out

ポリシーを発信ルートに適用します。

コマンド デフォルト

ポリシーは適用されません。

コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

着信ルートまたは発信ルートのルーティング ポリシーを指定するには、route-policy コマンドを使用します。 ポリシーを使用すると、ルートのフィルタリングやルート属性の変更ができます。


(注)  


ルート ポリシーがインターフェイスと VRF の両方に設定されている場合、インターフェイス ルート ポリシーが適用されます。


タスク ID

タスク ID

操作

rip

read, write

次に、インターフェイス上で受信したルーティング アップデートをフィルタする例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# route-policy updpol-1 in
  
         

send version

バージョン固有のパケットを送信するように Routing Information Protocol(RIP)インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで send version コマンドを使用します。 デフォルト設定に戻すには、このコマンドの no 形式を使用します。

send version { 1 | 2 | 1 2 }

no send version { 1 | 2 | 1 2 }

構文の説明

1

バージョン 1 のパケット

2

バージョン 2 のパケット

1 2

バージョン 1 とバージョン 2 のパケット

コマンド デフォルト

バージョン 2

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

send version コマンドは、RIP のデフォルトの動作を変更するために使用します。 このコマンドは、設定中のインターフェイスだけに適用されます。

タスク ID

タスク ID

操作

rip

read, write

次に、RIP バージョン 2 のパケットだけを送信するようにインターフェイスを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# send version 2
  
  
         

関連コマンド

コマンド

説明

receive version

バージョン固有のパケットを受け付けるように RIP インターフェイスを設定します。

show protocols(RIP)

Routing Information Protocol(RIP)プロセス コンフィギュレーションに関する情報を表示するには、EXEC モードで show protocols コマンドを使用します。

show protocols [ ipv4 | afi-all ] [ all | protocol ] [ default-context | vrf vrf-name ] [private]

構文の説明

ipv4

(任意)IPv4 アドレス ファミリを指定します。

afi-all

(任意)すべてのアドレス ファミリを指定します。

all

(任意)指定されたアドレス ファミリのすべてのプロトコルを指定します。

protocol

(任意)ルーティング プロトコルを指定します。

  • IPv4 アドレス ファミリの場合、オプションは eigrpbgpisisospf、および rip です。

default-context

(任意)デフォルト コンテキスト情報を表示します。 このキーワードは、eigrp または rip プロトコルを指定した場合に使用できます。

vrf vrf-name

(任意)指定されたプロセスの VPN ルーティング/転送(VRF)情報を表示します。 このキーワードは、eigrp または rip プロトコルを指定した場合に使用できます。

private

(任意)プライベート EIGRP データを表示します。 このキーワードを使用できるのは、eigrp プロトコルが指定されているときです。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

ルータ上で実行中のプロトコルに関する情報を取得して、どのプロトコルがアクティブであるかを迅速に判断するには、show protocols コマンドを使用します。 このコマンドを使用すると、実行中のプロトコルの重要な特性が要約されて表示されます。コマンドの出力は、選択されたプロトコルによって異なります。

RIP の場合、コマンド出力には、インスタンス番号、デフォルト AS コンテキスト、ルータ ID、デフォルト ネットワーク、距離、最大パスなどが表示されます。

タスク ID

タスク ID

操作

RIP

read

次に、show protocols rip コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show protocols rip
  Routing Protocol RIP
    2 VRFs (including default) configured, 2 active
    25 routes, 16 paths have been allocated
    Current OOM state is "Normal"
    UDP socket descriptor is 37
      VRF              Active   If-config If-active Routes     Paths      Updates
      default          Active   3         3         11         7              30s
  
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 2 show protocols のフィールドの説明

フィールド

説明

VRFs configured

設定されている VRF の数

VRFs active

アクティブな VRF の数

Routes

割り当てられているルートの数

Paths

割り当てられているパスの数

OOM state

RIP プロセスの現在のメモリ不足状態

UDP socket

現在の UDP ソケット記述子の値

show rip

Routing Information Protocol(RIP)の設定とステータスを表示するには、EXEC モードで show rip コマンドを使用します。

show rip [ vrf { vrf | all } ]

構文の説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

rip

read

次に、show rip コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show rip
  
  RIP config:
  Active?:                    Yes
  Added to socket?:           Yes
  Out-of-memory state:        Normal
  Version:                    2
  Default metric:             Not set
  Maximum paths:              4
  Auto summarize?:            No
  Broadcast for V2?:          No
  Packet source validation?:  Yes
  NSF:                        Disabled
  Timers: Update:             30 seconds (25 seconds until next update)
          Invalid:            180 seconds
          Holddown:           180 seconds
          Flush:              240 seconds

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 3 show rip のフィールドの説明

フィールド

説明

Active?

アクティブ状態設定。

Added to socket?

RIP が設定されたインターフェイス上のマルチキャスト グループ設定。 yes の場合、これらのインターフェイス上でアップデートが受信されます。

Out-of-memory state

RIP のメモリ不足状態には、Normal、Minor、Severe、Critical があります。

Version

バージョン番号は 2 です。

Default metric

デフォルト メトリック値(設定されている場合)。 設定されていない場合、Not set になります。

Maximum paths

RIP ルート単位で許可された最大パスの数。

Auto summarize?

自動サマライズ状態設定。

Broadcast for V2?

RIP バージョン 2 ブロードキャスト設定。

Packet source validation?

RIP への受信ルーティング アップデートの送信元 IP アドレスの検証設定。

Timers

RIP ネットワーク タイマー設定。

show rip database

Routing Information Protocol(RIP)トポロジ テーブルのデータベース エントリ情報を表示するには、EXEC モードで show rip database コマンドを使用します。

show rip [ vrf { vrf | all } ] database [ prefix prefix-length | prefix mask ]

構文の説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

prefix

(任意)ルーティング情報が表示されるネットワーク IP アドレス。

prefix-length

(任意)prefix-length 引数は、IP プレフィックスの長さを指定します。 これは、プレフィックス(アドレスのネットワーク部)を構成するアドレスの上位隣接ビット数を示す 10 進数値です。 10 進数値の前にスラッシュ記号を付ける必要があります。 IPv4 アドレスの場合の範囲は 0 ~ 32 です。

prefix-mask

(任意)次の 2 つの方法のうちいずれかで指定されるネットワーク マスク。

  • 4 分割ドット付き 10 進表記のアドレスでネットワーク マスクを指定します。 たとえば、255.0.0.0 の場合、各ビットが 1 のときに対応するアドレス ビットがネットワーク アドレスであることを示します。
  • ネットワーク マスクは、スラッシュ(/)と数字で表すことができます。 たとえば、/8 は、マスクの最初の 8 ビットが 1 であり、アドレスの対応するビットがネットワーク アドレスであることを示します。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

サマリー アドレス エントリは、関連する子ルートが要約される場合にだけデータベースに現れます。 サマリー アドレスの最後の子ルートが無効になると、そのサマリー アドレスもルーティング テーブルから削除されます。

タスク ID

タスク ID

操作

rip

read

次に、show rip database コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show rip database
  
  Routes held in RIP's topology database:
      10.0.0.0/24
          [0]    directly connected, GigabitEthernet0/6/0/0
      10.0.0.0/8    auto-summary
      12.0.0.0/24
          [5] distance: 20    redistributed
      12.0.0.0/8    auto-summary
      50.50.0.0/24
          [1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0
      50.50.1.0/24 (inactive)
          [1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0
      50.0.0.0/8    auto-summary
      90.90.0.0/24
          [5] distance: 20    redistributed
      90.90.1.0/24
          [5] distance: 20    redistributed
  
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 4 show rip database のフィールドの説明

フィールド

説明

10.0.0.0/24

[0] directly connected, GigabitEthernet0/6/0/0

RIP で接続されたルートのプレフィックスとプレフィックス長。

10.0.0.0/24 は GigabitEthernet 0/6/0/0 に直接接続されています。 [0]はメトリックを表します。

10.0.0.0/8 auto-summary

10.0.0.0/8 は自動サマリー エントリです。

12.0.0.0/24

[5] distance: 20 redistributed

12.0.0.0/24 は再配布されるルートです。 メトリックは 5 で、距離は 20 です。

50.50.0.0/24

[1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0

宛先ルート 50.50.0.0/24 が RIP を通じて学習され、ソース 10.0.0.20 が GigabitEthernet 0/6/0/0 からそれをアドバタイズしました。 ルートが最後に更新されたのは 1 秒前です。

50.50.1.0/24 (inactive)

[1] via 10.0.0.20, next hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0

宛先ルート 50.50.1.0/24 はルーティング テーブルでアクティブではありません。

show rip interface

Routing Information Protocol(RIP)トポロジ テーブルのインターフェイス エントリ情報を表示するには、EXEC モードで show rip interface コマンドを使用します。

show rip [ vrf { vrf | all } ] interface [ type interface-path-id ]

構文の説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

interface

(任意)トポロジ エントリをクリアするインターフェイスを指定します。

type

インターフェイス タイプ。 詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

interface-path-id

物理インターフェイスまたは仮想インターフェイス。

(注)     

ルータに現在設定されているすべてのインターフェイスのリストを表示するには、show interfaces コマンドを使用します。

ルータの構文の詳細については、疑問符(? )オンライン ヘルプ機能を使用してください。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 4.0.0

コマンド出力が認証キーチェーン コンフィギュレーション情報を含むように変更されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

rip

read

次に、show rip interface コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show rip interface
  
  GigabitEthernet0_6_0_0 
  Rip enabled?:               Yes
  Out-of-memory state:        Normal
  Broadcast for V2:           No
  Accept Metric 0?:           No
  Send versions:              2
  Receive versions:           2
  Interface state:            Up
  IP address:                 10.0.0.12/24
  Metric Cost:                0
  Split horizon:              Enabled
  Poison Reverse:             Disabled
  Joined multicast group?:    Yes
  
  GigabitEthernet0_6_0_2 
  Out-of-memory state:        Normal
  Rip enabled?:               Yes
  Broadcast for V2:           No
  Accept Metric 0?:           No
  Send versions:              2
  Receive versions:           2
  Interface state:            Up
  IP address:                 12.0.0.12/24
  Metric Cost:                0
  Split horizon:              Enabled
  Poison Reverse:             Disabled
  Joined multicast group?:    Yes 
  
  RIP peers attached to this interface:
      12.0.0.13
          uptime: 3    version: 2
          packets discarded: 0    routes discarded: 402
  
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 5 show rip interface のフィールドの説明

フィールド

説明

Rip enabled?

RIP ルーティング プロトコルがインターフェイスでイネーブルかどうかを示します。

Out-of-memory state

インターフェイス上の現在のメモリ不足状態を示します。

Broadcast for V2

インターフェイス上で RIP バージョン 2 出力パケットをブロードキャスト アドレスに送信するかどうかを示します。

Accept Metric 0?

このインターフェイスが、メトリックにゼロ(0)が設定された RIP アップデートからのルーティング エントリを受け付けるかどうかを示します。

Send versions:

このインターフェイス上でパケットを送出するために RIP が使用するバージョンを示します。

Receive versions:

このインターフェイス上で RIP が受け付けるパケットのバージョンを示します。

Interface state:

インターフェイスがアップ状態かダウン状態かを示します。

IP address:

インターフェイスの IP アドレス。

Metric Cost:

メトリック コスト値を示します。

Split horizon:

スプリット ホライズンがこのインターフェイスでイネーブルかどうかを示します。

Poison Reverse:

ポイズン リバースがこのインターフェイスでイネーブルかどうかを示します。

Joined multicast group?:

インターフェイスが RIP マルチキャスト グループ 224.0.0.9 に属しているかどうかを示します。

RIP peers attached to this interface

12.0.0.13

このインターフェイス上の RIP ネイバーの一覧です。

uptime: 3

このネイバーがアップ状態になっている時間の長さを示します。

version: 2

このネイバーから受信するパケットのバージョンを示します。

packets discarded: 0

このネイバーから受信したパケットのうち、破棄されたパケットの数を示します。

routes discarded: 402

このネイバーから受信したルートのうち、破棄されたルートの数を示します。

デフォルト VRF での RIP インターフェイスの認証キーチェーン設定

次に示す show rip interface interface-path-id コマンドの出力例には、デフォルト VRF での RIP インターフェイスの認証キーチェーン設定が表示されています。

MD5 暗号化アルゴリズムを使用する既存のキーチェーンが RIP インターフェイス上で設定されている場合:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No
 Authentication mode: MD5  Key chain: <key-chain-name>  
 Current active send  key id: <send key id>
 Current active receive key id: <recv key id>
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>

RIP インターフェイス上で設定されたキーチェーンが存在しないか、アクティブ キーがない場合:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No
  
 Authentication mode: MD5  Key chain: <key-chain-name>     
 No active key found  in keychain database.
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>
RIP インターフェイス上で設定されているキーチェーンにアクティブ キーがあるが、MD5 暗号化アルゴリズムを使用するように設定されていない場合:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No
 
 Authentication mode: MD5  Key chain: <key-chain-name>     
 Key(s) not configured with MD5 cryptographic algorithm.
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>

RIP インターフェイス上で認証キーチェーンが設定されていない場合:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
 LPTS filter set?:           No
 
Authentication mode is not set.
 Packets received: <num-rx-packets>

デフォルト以外の VRF での RIP インターフェイスの認証キーチェーン設定

次に示す show rip vrf vrf-name interface interface-path-id コマンドの出力例には、デフォルト以外の VRF での RIP インターフェイスの認証キーチェーン設定が表示されています。

MD5 暗号化アルゴリズムを使用する既存のキーチェーンが RIP インターフェイス上で設定されている場合:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:                2
Receive versions:           2
Interface state:             Unknown State
IP address:                   0.0.0.0/0
Metric Cost:                0
Split horizon:                Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No

 Authentication mode: MD5  Key chain: <key-chain-name>     
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>
RIP インターフェイス上で設定されたキーチェーンが存在しないか、アクティブ キーがない場合:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No

 Authentication mode: MD5  Key chain: <key-chain-name>     
 No active key found  in keychain database.
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>
RIP インターフェイス上で設定されているキーチェーンにアクティブ キーがあるが、MD5 暗号化アルゴリズムを使用するように設定されていない場合:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No

 Authentication mode: MD5  Key chain: <key-chain-name>     
 Key(s) not configured with MD5 cryptographic algorithm.
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>
RIP インターフェイス上で認証キーチェーンが設定されていない場合:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No

 Authentication mode is not set.
 Packets received: <num-rx-packets>
次の表に、この出力で表示される重要なフィールドの説明を示します。

表 6 show rip [vrf <vrf-name>] interface のフィールドの説明

Authentication mode: MD5 Key chain

MD5 認証モードはイネーブルです。

Current active send key id

アクティブ送信キー ID。

Current active receive key id

アクティブ受信キー ID。

Packets received

インターフェイスの受信パケット数。

Authenticated packets received

認証が有効な状態で受信されたパケットの数。

Packets dropped due to wrong keychain config

誤ったキーチェーン設定が原因でドロップされたパケットの数。

Packets received without authentication data

認証データなしで受信されたパケットの数。

Packets received with invalid authentication

認証が無効な状態で受信されたパケットの数。

No active key found in keychain database

IOS XR キーチェーン データベース内にアクティブ キーがありません。

Key(s) not configured with MD5 cryptographic algorithm

キーは MD5 暗号化アルゴリズムを使用するように設定されていません。

Authentication mode is not set

認証モードは設定されていません。

show rip statistics

Routing Information Protocol(RIP)トポロジ テーブルの統計エントリ情報を表示するには、EXEC モードで show rip statistics コマンドを使用します。

show rip [ vrf { vrf | all } ] statistics

構文の説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

EXEC

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

タスク ID

タスク ID

操作

rip

read

次に、show rip statistics コマンドの出力例を示します。

  RP/0/RSP0/CPU0:router# show rip statistics
  
  RIP statistics:
      Total messages sent:        5597
      Message send failures:      0
      Regular updates sent:       5566
      Queries responsed to:       0
      RIB updates:                6
      Total packets received:     5743
      Discarded packets:          0
      Discarded routes:           0
      Number of routes allocated: 18
      Number of paths allocated:  14
  
      Route malloc failures:      0
      Path malloc failures:       0 
  
  

次の表に、この出力で表示される重要なフィールドの説明を示します。



表 7 show rip statistics フィールドの説明

フィールド

説明

Total messages sent

送信された RIP パケットの数。

Message send failures

パケット送信処理に失敗した回数。

Queries responsed to

RIP クエリーに対する応答として RIP アップデートが送信された回数。

RIB updates

RIB に送信されたルート追加/削除メッセージの数。

Total packets received

受信した RIP パケットの数。

Discarded packets

受信した RIP パケットのうち、破棄された数。

Discarded routes

受信した RIP アップデート パケットのうち、破棄されたルートの数。

Number of routes allocated

RIP 内部トポロジ データベース用に割り当てられたルートの数。

Number of paths allocated

RIP 内部トポロジ データベース用に割り当てられたパスの数。

Route malloc failures

ルート割り当て中の失敗の数。

Path malloc failures

ルート割り当て中の失敗の数。


(注)  


割り当てられたルートの数のフィールドに表示される値は、RIP データベースに存在するルートの数と同じとは限りません。


site-of-origin(RIP)

Routing Information Protocol(RIP)インターフェイスに対して Site of Origin(SoO)フィルタリングを設定するには、インターフェイス コンフィギュレーション モードで site-of-origin コマンドを使用します。 インターフェイス上で SoO フィルタリングをディセーブルにするには、このコマンドの no 形式を使用します。

site-of-origin { as-number : number | ip-address : number }

no site-of-origin { as-number : number | ip-address : number }

構文の説明

as-number:

Autonomous System(AS; 自律システム)番号。

  • 2 バイトの自律システム番号(ASN)の範囲は 1 ~ 65535 です。
  • asplain 形式の 4 バイトの自律システム番号(ASN)の範囲は 1 ~ 4294967295 です。
  • asdot 形式の 4 バイトの自律システム番号(ASN)の範囲は 1.0 ~ 65535.65535 です。

自律システム番号とネットワーク番号はコロンで区切ります。

number

ネットワーク番号。 2 バイトの AS 番号を使用する場合、範囲は 0 ~ 4294967295 です。 4 バイトの AS 番号を使用する場合、範囲は 0 ~ 65535 です。

ip-address

IP アドレス引数には、ドット付き 10 進数表記の、4 つの部分からなる IP アドレスを指定します。

IP アドレスとネットワーク番号はコロンで区切ります。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 3.9.0

4 バイトの自律システム番号表記の asplain 形式がサポートされました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

バックドア リンクを使用したサイト間の MPLS VPN リンクを含む複雑なトポロジをサポートする必要がある場合、RIP プロセスは、ボーダー ゲートウェイ プロトコル(BGP)から再配布されるルートに対する SoO 属性を取得できる必要があります。

プレフィックスが再び送信元サイトにアドバタイズされないように、サイトから発信されたルートの識別に使用する SoO BGP 拡張コミュニティ属性を設定するには、site-of-origin コマンドを使用します。 SoO 拡張コミュニティは、プロバイダー エッジ(PE)ルータがルートを学習したサイトを一意に識別します。

タスク ID

タスク ID

操作

rip

read, write

次に、RIP インターフェイス上で SoO フィルタリングを設定する例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip) interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# site-of-origin 10.0.0.1:20
  
         

split-horizon disable(RIP)

Routing Information Protocol(RIP)プロセスのスプリット ホライズンをディセーブルにするには、インターフェイス コンフィギュレーション モードで split-horizon disable コマンドを使用します。 スプリット ホライズンをイネーブルにするには、このコマンドの no 形式を使用します。

split-horizon disable

no split-horizon disable

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

RIP プロセスでスプリット ホライズンはイネーブルになっています。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

設定の中で split-horizon disable コマンドを明示的に指定できます。

スプリット ホライズンがディセーブルの場合、ポイズン リバースの設定は無視されます。


(注)  


一般に、アプリケーションで正しくルートをアドバタイズするために必要であることが確実でない限り、スプリット ホライズンのデフォルトの状態を変更しないことをお勧めします。


タスク ID

タスク ID

操作

rip

read, write

次に、Packet-over-SONET/SDH リンク上でスプリット ホライズンをディセーブルにする例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# split-horizon disable
  
  
         

関連コマンド

コマンド

説明

poison-reverse

RIP ルータ アップデートのポイズン リバース処理をイネーブルにします。

timers basic

Routing Information Protocol(RIP)ネットワーク タイマーを調整するには、ルータ コンフィギュレーション モードで timers basic コマンドを使用します。 タイマーをデフォルト値に戻すには、このコマンドの no 形式を使用します。

timers basic update invalid holddown flush

no timers basic

構文の説明

update

アップデートを送信する頻度を秒単位で指定します。 これは、ルーティング プロトコルの基本的なタイミング パラメータです。 範囲は 5 ~ 50000 です。

invalid

ルートが無効であると宣言するまでの期間(秒単位)です。update 引数の値の 3 倍以上であることが必要です。 ルートをリフレッシュするアップデートがない場合、ルートは無効になります。 その場合、ルートはホールドダウン状態になります。 そのルートはアクセス不可と見なされ、到達不能としてアドバタイズされます。 範囲は 15 ~ 200000 です。

holddown

より良いパスに関するルーティング情報を抑止する期間(秒単位)です。 update 引数の値の 3 倍以上であることが必要です。 ルートが到達不能であることを示すアップデート パケットを受信すると、そのルートはホールドダウン状態になります。 そのルートはアクセス不可と見なされ、到達不能としてアドバタイズされます。 ホールドダウンの期限が切れると、他のソースによってアドバタイズされたルートが受け付けられ、ルートがアクセス可能になります。 範囲は 15 ~ 200000 です。

flush

ルートをルーティング テーブルから削除する前に待つ時間の長さを秒単位で指定します。指定する長さは、invalid 引数の値よりも大きいことが必要です。 invalid タイマー値よりも小さい場合は、ホールドダウン期間に基づく処理が適切に行われず、ホールド期間終了前に新しいルートが受け付けられることになります。 範囲は 16 ~ 250000 です。

コマンド デフォルト

update:30

invalid:180

holddown:180

flush:240

コマンド モード

ルータ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

RIP の基本的なタイミング パラメータは調整可能です。 RIP は、分散型の非同期ルーティング アルゴリズムを実行するため、これらのタイマーはネットワーク内のすべてのルータで同じである必要があります。


(注)  


現在およびデフォルトのタイマー値を表示するには、show rip コマンドを使用します。


タスク ID

タスク ID

操作

rip

read, write

次に、5 秒ごとにアップデートをブロードキャストするよう設定する例を示します。 ルートを 15 秒間受信しないと、そのルートは使用不能と宣言されます。 以降の情報はさらに 15 秒間抑止されます。 フラッシュ期間の終了時に、ルーティング テーブルからルートがフラッシュされます。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip) timers basic 5 15 15 30
  
         

関連コマンド

コマンド

説明

show rip

RIP の設定とステータスを表示します。

validate-update-source disable

Routing Information Protocol(RIP)の受信ルーティング アップデートの送信元 IP アドレスを検証する Cisco IOS XR ソフトウェアの機能を停止するには、ルータ コンフィギュレーション モードで validate-update-source disable コマンドを使用します。 この機能を再度イネーブルにするには、このコマンドの no 形式を使用します。

validate-update-source disable

no validate-update-source disable

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

RIP の受信アップデートの送信元 IP アドレスは常に検証されます。

コマンド モード

ルータ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

validate-update-source disable コマンドを使用すると、検証は行われません。

デフォルトでは、受信ルーティング アップデートの送信元 IP アドレスが、受信インターフェイスに対して定義されたアドレスのいずれかと同じ IP ネットワーク上にあることが確認されます。

unnumbered IP インターフェイス(IP unnumbered として設定されたインターフェイス)では、チェックは行われません。

タスク ID

タスク ID

操作

rip

read, write

次に、送信元検証をディセーブルにする例を示します。

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip) validate-update-source disable
  
         

vrf(RIP)

VPN ルーティングおよび転送(VRF)インスタンスを定義して VRF コンフィギュレーション モードを開始するには、ルータ コンフィギュレーション モードで vrf コマンドを使用します。 VRF インスタンスを削除するには、このコマンドの no 形式を使用します。

vrf vrf-name

no vrf vrf-name

構文の説明

vrf-name

特定の VPN ルーティング/転送インスタンスを指定します。

コマンド デフォルト

VRF は定義されていません。

コマンド モード

ルータ コンフィギュレーション

コマンド履歴

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てのためにコマンドを使用できない場合は、AAA 管理者に連絡してください。

VRF インスタンスを設定するには、vrf コマンドを使用します。 VRF インスタンスは、プロバイダー エッジ(PE)ルータで保持される VPN ルーティング/転送テーブルを収集したものです。

VRF コンフィギュレーション モードでは、auto-summary コマンドなど、ルータ コンフィギュレーション モードで使用できるすべてのコマンドを実行できます。

タスク ID

タスク ID

操作

rip

read, write

次の例では、VRF コンフィギュレーション モードを開始し、そのモードで実行できる RIP コマンドの一覧を表示する方法を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
RP/0/RSP0/CPU0:router(config-rip-vrf)# ?
  
   auto-summary            Enable automatic network number summarization
   broadcast-for-v2        Send RIP v2 output packets to broadcast address
   commit                  Commit the configuration changes to running
   default-information     Control distribution of default information
   default-metric          Set metric of redistributed routes
   describe                Describe a command without taking real actions
   distance                Define an administrative distance
   do                      Run an exec command
   exit                    Exit from this submode
   interface               Enter the RIP interface configuration submode
   maximum-paths           Maximum number of paths allowed per route
   neighbor                Specify a neighbor router
   no                      Negate a command or set its defaults
   nsf                     Enable Cisco Non Stop Forwarding
   output-delay            Interpacket delay for RIP updates
   redistribute            Redistribute information from another routing protocol
   route-policy            Apply route policy to routing updates
   show                    Show contents of configuration
   timers                  Adjust routing timers
   validate-update-source  Validate source address of routing updates
RP/0/RSP0/CPU0:router(config-rip-vrf)#