Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ モジュラ QoS コマンド リファレンス リリース 4.2
パケット分類コマンド
パケット分類コマンド
発行日;2012/12/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

パケット分類コマンド

この章では、QoS のパケット分類に使用するコマンドについて説明します。 パケット分類の概念、設定作業、および例の詳細については、 『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Configuration Guide』の「Configuring Modular QoS Service Packet Classification and Marking」の章を参照してください。

class(ポリシー マップ)

ポリシーを作成または変更するクラスの名前を指定するには、ポリシー マップ コンフィギュレーション モードで class コマンドを使用します。 ポリシー マップからクラスを削除するには、このコマンドの no 形式を使用します。

class [ type qos ] { class-name | class-default }

no class [ type qos ] { class-name | class-default }

Syntax Description

type qos

(オプション)Quality of Service(QoS)クラスを指定します。

class-name

ポリシーを設定または変更するクラスの名前です。

class-default

デフォルト クラスを設定します。

Command Default

クラスの指定はありません。

タイプを指定しないと QoS になります。

Command Modes

ポリシー マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。

ポリシー マップ コンフィギュレーション モード

ポリシー マップ内で、class(ポリシー マップ)コマンドを使用すれば、ポリシーを作成または変更するクラスの名前を指定できます。 ポリシー マップを最初に指定する必要があります。

ポリシー マップを指定する(および、必要なポリシー マップ コンフィギュレーション モードを開始する)には、class(ポリシー マップ)コマンドを使用する前に、policy-map コマンドを使用します。 ポリシー マップを指定したあとは、新しいクラスのポリシーを設定したり、そのポリシー マップ内の既存のクラスのポリシーを変更できます。

クラス特性

ポリシー マップで指定されたクラス名により、class-map コマンドによる設定に従い、そのクラスの特性(つまり、クラス ポリシー)がクラス マップおよび一致基準と結合されます。

デフォルト クラスを設定するには、class-default キーワードを使用します。 これは予約名であり、ユーザ定義クラスでは使用できません。 このキーワードは、クラスが設定されていない場合であっても、ポリシー マップ(タイプ qos)に常に追加されます。 たとえば、次の設定は、クラスが設定されていなくても、実行コンフィギュレーションで「class class-default」が表示されることを示します。

RP/0/RSP0/CPU0:router(config)# policy-map pm1 
RP/0/RSP0/CPU0:router(config-pmap)# end-policy-map 
RP/0/RSP0/CPU0:router(config)# end 
!
RP/0/RSP0/CPU0:router# show running-config 
!
policy-map pm1
 class class-default
 !        
 end-policy-map
!
  

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、policy1 という名前のポリシー マップを作成する方法の例を示します。このポリシー マップは、class1 のトラフィックを 30% に、デフォルト クラスのトラフィックを 20% にそれぞれ整形するように定義されています。

RP/0/RSP0/CPU0:router(config)# class-map class1
RP/0/RSP0/CPU0:router(config-cmap)# match precedence 3
!
RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class class1
RP/0/RSP0/CPU0:routerconfig-pmap-c)# shape average 100 mbps
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# class class-default
RP/0/RSP0/CPU0:router(config-pmap-c)# shape average 50 mbps
  

デフォルト クラスは、class1 に対して設定されている一致基準を満たさないパケットに使用されます。 class1 は policy1 で使用する前に定義しておく必要がありますが、デフォルト クラスは、システムで暗黙に定義されているため、ポリシー マップで直接使用できます。

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義するには、グローバル コンフィギュレーション モードで class-map コマンドを使用します。 ルータから既存のクラス マップを削除するには、このコマンドの no 形式を使用します。

class-map [ type qos ] [match-all] [match-any] class-map-name

no class-map [ type qos ] [match-all] [match-any] class-map-name

Syntax Description

type qos

(任意)Quality of Service(QoS)のクラス マップを指定します。

match-all

(任意)すべての一致基準での一致を指定します。

match-any

(任意)いずれかの一致基準での一致を指定します。 これはデフォルトです。

class-map-name

クラス マップのクラスの名前です。 クラス名は、クラス マップに使用されるだけでなく、ポリシー マップでクラスにポリシーを設定するためにも使用されます。 クラス名には最大 63 文字を使用できますが、英数字で開始する必要があります。英数字以外に次の文字を使用できます。 _ @ $ % + | # : ; - =

Command Default

タイプを指定しないと QoS になります。

Command Modes

グローバル コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。

class-map コマンドでは、クラス マップ一致基準を作成または変更するクラスの名前を指定します。 このコマンドを使用するとクラス マップ コンフィギュレーション モードがイネーブルになり、任意の match コマンドを入力して、そのクラスの一致基準を設定できます。 インターフェイスに着信したパケットは、クラス マップに設定されている一致基準と照らし合わせて検査され、パケットがそのクラスに属しているかどうかを判定されます。

クラス マップでは次のコマンドを使用できます。

  • match access-group
  • match atm
  • match [not] cos
  • match destination-address
  • match [not] discard-class
  • match [not] dscp
  • match frame-relay dlci
  • match [not] mpls experimental topmost
  • match [not] precedence
  • match precedence
  • match [not] protocol
  • match [not] qos-group
  • match source-address
  • match vlan
  • match vpls

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、クラスの名前として class101 を指定し、そのクラスに対してクラス マップを定義する方法の例を示します。 アクセス リスト 101 と一致するパケットは、クラス class101 に一致します。

RP/0/RSP0/CPU0:router(config)# class-map class101
RP/0/RSP0/CPU0:router(config-cmap)# match access-group ipv4 101

Related Commands

Command

Description

class(ポリシー マップ)

ポリシーを作成または変更するクラスの名前を指定します。  

match access-group

指定したアクセス コントロール リスト(ACL)番号をクラス マップの一致基準として識別します。  

match destination-address

特定の宛先 MAC アドレスをクラス マップの一致基準として明示的に識別します。  

match discard-class

特定の廃棄クラスの値をクラス マップの一致基準として識別します。  

match dscp

特定の IP DiffServ コード ポイント(DSCP)値をクラス マップの一致基準として識別します。  

match mpls experimental topmost

最上位のマルチプロトコル ラベル スイッチング(MPLS)ラベル内にある特定の 3 ビット experimental(EXP)フィールド値をクラス マップの一致基準として識別します。  

match precedence

IP precedence 値を一致基準として識別します。  

match protocol

特定のプロトコルをクラス マップの一致基準として識別します。  

match qos-group

クラス マップの一致基準として特定の Quality of Service(QoS)グループ値を識別します。  

match source-address

特定のソース MAC アドレスをクラス マップの一致基準として識別します。  

match vlan

選択された VLAN ID をクラス マップの一致基準として識別します。  

end-class-map

クラスの一致基準の設定を終了し、クラス マップ コンフィギュレーション モードを終了するには、クラス マップ コンフィギュレーション モードで end-class-map コマンドを使用します。

end-class-map

Syntax Description

このコマンドには、キーワードや引数はありません。

Command Default

デフォルトの動作または値はありません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、クラス マップの設定を終了し、クラス マップ コンフィギュレーション モードを終了する方法の例を示します。

RP/0/RSP0/CPU0:router(config)# class-map class101
RP/0/RSP0/CPU0:router(config-cmap)# match access-group ipv4 101
RP/0/RSP0/CPU0:router(config-cmap)# end-class-map 
RP/0/RSP0/CPU0:router(config)# 

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

end-policy-map

ポリシー マップの設定を終了し、ポリシー マップ コンフィギュレーション モードを終了するには、ポリシー マップ コンフィギュレーション モードで end-policy-map コマンドを使用します。

end-policy-map

Syntax Description

このコマンドには、キーワードや引数はありません。

Command Default

デフォルトの動作または値はありません。

Command Modes

ポリシー マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、ポリシー マップの設定を終了し、ポリシー マップ コンフィギュレーション モードを終了する方法の例を示します。

RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class class1
RP/0/RSP0/CPU0:router(config-pmap-c)# police

 rate
 250
RP/0/RSP0/CPU0:router(config-pmap-c)# set precedence 3
RP/0/RSP0/CPU0:router(config-pmap)# end-policy-map 
RP/0/RSP0/CPU0:router(config)#

Related Commands

Command

Description

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

exceed-action

レート制限を超過したパケットに対して実行するアクションを設定するには、ポリシー マップ ポリシング コンフィギュレーション モードで exceed-action コマンドを使用します。 ポリシー マップから超過アクションを削除するには、このコマンドの no 形式を使用します。

exceed-action [ drop | set options | transmit ]

no exceed-action [ drop | set options | transmit ]

Syntax Description

drop

(任意)パケットをドロップします。

set options

指定したパケットのプロパティを設定します。 options を、次のいずれかのキーワードまたはキーワード引数に置き換えます。

  • atm-clp value:セル損失率優先度(CLP)ビットを設定します。
  • cos [inner] value:サービス クラスの値を設定します。 範囲は 0 ~ 7 です。
  • cos value:サービス クラスの値を設定します。 範囲は 0 ~ 7 です。
  • dei:ドロップ適性インジケータ(DEI)を設定します。 0 または 1 の値を指定できます。
  • discard-class value:廃棄クラスの値を設定します。 範囲は 0 ~ 7 です。
  • dscp value:DiffServ コード ポイント(DSCP)の値を設定し、パケットを送信します。 有効な値のリストについては、表 1を参照してください。
  • dscp [tunnel] value:DiffServ コード ポイント(DSCP)値を設定し、パケットを送信します。 有効な値のリストについては、表 1を参照してください。 tunnel キーワードによって、DSCP は外側ヘッダーに設定されます。
  • fr-de value:フレーム リレー フレームのフレーム リレー廃棄適性(DE)ビットを設定し、そのパケットを送信します。 輻輳環境では、DE ビットが 1 に設定されたフレームは、DE ビットが 0 に設定されたフレームの前に廃棄されます。 フレーム リレー DE ビットは 1 ビットしかないため、0 または 1 の 2 つの設定しかありません。 DE ビットのデフォルト設定は 0 です。
  • mpls experimental {topmost | imposition} value:マルチプロトコル ラベル スイッチング(MPLS)パケットの最上位ラベルまたは付加ラベルの experimental(EXP)値を設定します。 範囲は 0 ~ 7 です。
  • precedence precedence:IP precedence を設定し、パケットを送信します。 有効な値のリストについては、表 1を参照してください。
  • precedence [tunnel] precedence:IP precedence を設定し、パケットを送信します。 有効な値のリストについては、表 1を参照してください。 tunnel キーワードによって、優先順位が外側ヘッダーに設定されます。
  • qos-group value:QoS グループの値を設定します。
  • qos-group value:QoS グループの値を設定します。 範囲は 0 ~ 63 です。
  • srp-priority value:スペース再利用プロトコル(SRP)のプライオリティを設定します。 範囲は 0 ~ 7 です。

transmit

(任意)パケットを送信します。

Command Default

デフォルトでは、レート制限を超えるパケットにアクションが設定されていない場合、パケットはドロップされます。

Command Modes

ポリシー マップ ポリシング コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 4.0.0

set dei キーワードが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

トラフィック ポリシング機能の詳細については、police rate コマンドを参照してください。

  • experimental 値、qos-group 値、および廃棄クラス値または
  • experimental 値および qos-group 値または
  • experimental 値および廃棄クラス値

ポリシー マップの set dei アクションは、802.1ad パケットで次の項目に対してサポートされています。

  • 入力および出力
  • レイヤ 2 サブインターフェイス
  • レイヤ 2 メイン インターフェイス
  • レイヤ 3 メイン インターフェイス

(注)  


set dei アクションは、802.1ad カプセル化用に設定されていないインターフェイスのトラフィックに対しては無視されます。


Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次の MPLS の例では、レート制限を超えるトラフィックをドロップするトラフィック ポリシングを設定しています。

RP/0/RSP0/CPU0:router(config)# class-map class1
RP/0/RSP0/CPU0:router(config-cmap)# match mpls experimental topmost 0
RP/0/RSP0/CPU0:router(config-cmap)# exit

RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class class1
RP/0/RSP0/CPU0:router(config-pmap-c)# police rate 250 kbps burst 50
RP/0/RSP0/CPU0:router(config-pmap-c-police)# exceed-action drop
RP/0/RSP0/CPU0:router(config-pmap-c-police)# exit
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit

RP/0/RSP0/CPU0:router(config)# interface pos 0/5/0/0
RP/0/RSP0/CPU0:router(config-if) service-policy input policy1

この例では、ポリシング レートを 5 Mbps に設定しています。 適合するトラフィックは 0 の DEI 値でマーキングします。ポリシング レートを超過したトラフィックは 1 の DEI 値でマーキングします。

RP/0/RSP0/CPU0:router(config)# policy-map 1ad-mark-dei
RP/0/RSP0/CPU0:router(config-pmap)# class c1
RP/0/RSP0/CPU0:router(config-pmap-c)# police rate 5 mbps
RP/0/RSP0/CPU0:router(config-pmap-c-police)# conform-action set dei 0
RP/0/RSP0/CPU0:router(config-pmap-c-police)# exceed-action set dei 1
RP/0/RSP0/CPU0:router(config-pmap-c-police)# end-policy-map

Related Commands

Command

Description

conform-action

レート制限に適合したパケットに対して実行するアクションを設定します。  

exceed-color

(SIP 700 カードだけに使用されます)。アップストリーム ノードで以前に廃棄適性とマーキングされた入力レイヤ 2 のフレーム リレー パケットの事前分類を設定します。 これらの以前マーキングされたパケットは、2 レート 3 カラー(2R3C)トラフィック ポリシング機能の一部として入力インターフェイスのカラーアウェア ポリサーによって解析され、事前に分類されます。  

police rate

トラフィック ポリシングを設定し、ポリシー マップ ポリシング コンフィギュレーション モードを開始します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

show policy-map interface

指定されたインターフェイス上のすべてのサービス ポリシーに対して設定されている全クラスのポリシー設定情報を表示します。  

violate-action

レート制限に違反するパケットに対して実施するアクションを設定します。  

match cos

指定したサービス クラス(CoS)値をクラス マップの一致基準として識別するには、クラス マップ コンフィギュレーション モードで match cos コマンドを使用します。 指定した CoS クラス値をクラス マップの一致基準から削除するには、このコマンドの no 形式を使用します。

match [not] cos { cos-value [ cos-value1 ... cos-value7 ] | inner inner-cos-value [ inner cos-value1 ... inner cos-value7 ] }

no match [not] cos { cos-value [ cos-value1 ... cos-value7 ] | inner inner-cos-value [ inner cos-value1 ... inner cos-value7 ] }

Syntax Description

not

(任意)指定した一致結果を除外します。

cos-value

0 ~ 7 の正確な値を指定する識別子。 パケットに一致する CoS ID を 8 つまで指定できます。

inner

(任意)QinQ 設定などの内部 CoS 値を指定します。

inner-cos-value

0 ~ 7 の正確な値を指定する識別子。 パケットに一致する入力 CoS ID を 8 つまで指定できます。

Command Default

一致基準が指定されていません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

match cos コマンドでは、クラス マップで指定されているクラスにパケットが属するかどうかを判定するために検査対象の一致基準としてサービス クラスを指定します。

match cos コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するためにクラスの名前を指定する必要があります。 クラス マップ内で複数の match cos コマンドを指定すると、最初の match cos コマンドに、後続の match ステートメントの値が追加されます。

match cos コマンドは、出力レイヤ 2 インターフェイス、レイヤ 2 サブインターフェイス、およびレイヤ 3 物理インターフェイスでサポートされます。 レイヤ 3 インターフェイスはレイヤ 2 サブインターフェイスを持つことができるため、レイヤ 3 物理インターフェイスもサポートされます。

  • 入力および出力
  • レイヤ 2 メイン インターフェイスおよびサブインターフェイス
  • レイヤ 3 メイン インターフェイス

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、policy1 という名前のサービス ポリシーを設定し、policy1 をインターフェイスに付加する例を示します。 この例では、クラス マップ cos146 は、1、4、または 6 のサービス クラスの値に対して、Packet-over-SONET(POS)インターフェイス 0/1/0/0.100 に着信するすべてのパケットを評価します。 これらの CoS 値のいずれかがマーキングされている着信パケットは、300 kbps の帯域幅設定でクラス キューに格納されます。

RP/0/RSP0/CPU0:router(config)# class-map cos146
RP/0/RSP0/CPU0:router(config-cmap)# match cos 1 4 6
RP/0/RSP0/CPU0:router(config-cmap)# exit

RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class cos146
RP/0/RSP0/CPU0:router(config-pmap-c)# bandwidth 300
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit

RP/0/RSP0/CPU0:router(config)# interface
 pos 0/1/0/0

RP/0/RSP0/CPU0:router(config-if)# service-policy
 input

 policy1

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

match discard-class

特定の廃棄クラスの値をクラス マップの一致基準として識別します。  

match protocol

特定のプロトコルをクラス マップの一致基準として識別します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

set cos

発信パケットのレイヤ 2 サービス クラス(CoS)値を設定します。  

match vlan

選択された VLAN ID をクラス マップの一致基準として識別するには、クラス マップ コンフィギュレーション モードで match vlan コマンドを使用します。 クラス マップから VLAN ID 一致基準を削除するには、このコマンドの no 形式を使用します。

match vlan [ inner ] vlanid [ vlanid1 ... vlanid7 ]

no match vlan [ inner ] vlanid [ vlanid1 ... vlanid7 ]

Syntax Description

inner

(任意)QinQ 設定などでの照合に内部 VLAN を指定します。

vlanid

1 ~ 4094 の厳密値、または 1 ~ 4094 の値範囲を指定する VLAN ID。 1 つの match ステートメントで最大 8 つの値を指定できます。

Command Default

一致基準が指定されていません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

match vlan コマンドでは、クラス マップで指定されているクラスにパケットが属するかどうかを判定するために検査対象の一致基準として使用される VLAN ID を指定します。

match vlan コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するクラスの名前を指定する必要があります。 クラス マップ内で複数の match vlan コマンドを指定すると、最初の match vlan コマンドに後続の match ステートメントの値が最大 8 つ追加されます。この数を超過すると、ステートメントは拒絶されます。

このコマンドは、レイヤ 3 の入力でだけサポートされます。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、policy1 という名前のサービス ポリシーを設定し、policy1 をインターフェイスに付加する例を示します。 この例では、クラス マップ vlan1 で、ギガビット イーサネット インターフェイス 0/1/0/0 に着信するすべてのパケットに対して、VLAN ID が 1234、1698、および 3000 ~ 4000 の範囲にあるか評価します。 これらの VLAN ID のいずれかがマーキングされている着信パケットは、300 kbps の帯域幅設定でクラス キューに格納されます。

RP/0/RSP0/CPU0:router(config)# class-map vlan1  
RP/0/RSP0/CPU0:router(config-cmap)# match vlan 1234 1698 3000-4000          
RP/0/RSP0/CPU0:router(config-cmap)# exit 
RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class vlan1
RP/0/RSP0/CPU0:router(config-pmap-c)# bandwidth 300 
RP/0/RSP0/CPU0:router(config-pmap-c)# exit  
RP/0/RSP0/CPU0:router(config-pmap)# exit
RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-if)# service-policy input policy1
  

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

match ethertype

選択されたイーサネット タイプ フィールドをクラス マップの一致基準として識別するには、クラス マップ コンフィギュレーション モードで match ethertype コマンドを使用します。 クラス マップからイーサネット タイプ フィールドの一致基準を削除するには、このコマンドの no 形式を使用します。

match ethertype ethertype_field

no match ethertype ethertype_field

Syntax Description

ethertype_field

イーサネット サービスを指定するイーサネット タイプ フィールド。 値は次のとおりです。

  • <1536-65535>:イーサネットの値。2054(ARP を表す値)だけがサポートされています。
  • arp:アドレス解決プロトコルの照合を行います。
  • ipv4(サポートされません)。
  • ipv6(サポートされません)。
注意       

サポートされる値以外の値を指定すると、設定をコミットすることができます。 ただし、インターフェイスにポリシー マップ(無効な ethertype の一致を含む)を適用する設定をコミットしようとすると、コミット アクションは拒否されます。

Command Default

一致基準が指定されていません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース 変更箇所

リリース 4.1.0

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

Task ID

タスク ID 操作
qos

読み取り、書き込み

Examples

次に、イーサネット タイプを設定する例を示します。

RP/0/RSP0/CPU0:router(config)# class-map match-any arp_1            
RP/0/RSP0/CPU0:router(config-cmap)# match ethertype arp
RP/0/RSP0/CPU0:router(config-cmap)# exit
  

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

match fr-de

フレーム リレー廃棄適性(DE)ビット設定に基づいてパケットを照合するには、クラス マップ コンフィギュレーション モードで match fr-de コマンドを使用します。 一致基準を削除するには、このコマンドの no 形式を使用します。

match fr-de fr-de-bit-value

no match fr-de fr-de-bit-value

Syntax Description

not

(任意)指定した一致結果を除外します。

fr-de-bit-value

フレーム リレー DE ビットを指定します。 1 の値を指定できます。

Command Default

パケットは、フレーム リレー DE ビット設定に基づいて照合されません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 4.0.0

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

この一致基準は、service-policy コマンドを使用してサブインターフェイス(L2 PVC)の下で使用され、入力方向でだけサポートされます。 この一致基準は、階層型ポリシー マップでも使用できます。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、match-fr-de と呼ばれるクラスを作成し、フレーム リレー DE ビット設定に基づいてパケットを照合する方法の例を示します。 パケットは、フレーム リレー DE ビット 1 と一致します。

RP/0/RSP0/CPU0:router(config)# class-map match-fr-d
RP/0/RSP0/CPU0:router(config-cmap)# match fr-de 1
RP/0/RSP0/CPU0:routerrouter(config-cmap)# end

フレーム リレー DE ビット 0 を照合するには、次の設定を使用します。

RP/0/RSP0/CPU0:router(config)# class-map match-not-fr-de
RP/0/RSP0/CPU0:router(config-cmap)# match not fr-de 1
RP/0/RSP0/CPU0:router(config-cmap)# end

Related Commands

Command

Description

set fr-de

インターフェイスから送信されるすべてのトラフィックについて、フレーム リレー フレームのアドレス フィールドで廃棄適性(DE)ビット設定を 1 に変更します。  

match frame-relay dlci

クラス マップで一致基準としてフレーム リレー パケットのデータリンク接続識別子(DLCI)番号または番号範囲を指定するには、クラス マップ コンフィギュレーション モードで match frame-relay dlci コマンドを使用します。 以前に一致基準として指定した DLCI 番号を削除するには、このコマンドの no 形式を使用します。

match frame-relay dlci [ Dlci | StartDlci-EndDlci ]

no match frame-relay dlci [ Dlci | StartDlci-EndDlci ]

Syntax Description

Dlci

パケットに関連付けられた DLCI 番号。 範囲は 16 ~ 1007 です。

StartDlci-EndDlci

16 ~ 1007 の DLCI 番号範囲。 番号はハイフンで区切ります。

Command Default

DLCI 番号は指定されません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 4.0.0

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

match frame-relay dlci コマンドの一致基準は、階層型ポリシー マップでだけ使用できます。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、fr-dlci クラス マップを作成し、一致基準としてフレーム リレーの DLCI 番号範囲 100 ~ 200 を指定する例を示します。 この条件を満たす DLCI のパケットが fr-dlci に置かれます。 この例では、クラス マップ fr-dlci は 100 ~ 200 の範囲にある DLCI の Packet-over-SONET/SDH(POS)インターフェイス 0/1/0/0.1 に着信するすべてのパケットを評価します。 着信パケットが 100 ~ 200 の範囲の DLCI でマーキングされている場合、パケットは 300 kbps の帯域幅設定でクラス キューに格納されます。

RP/0/RSP0/CPU0:router(config)# class-map fr-dlci
RP/0/RSP0/CPU0:router(config-cmap)# match frame-relay dlci 100-200
RP/0/RSP0/CPU0:router(config-cmap)# end
RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class fr-dlci
RP/0/RSP0/CPU0:router(config-pmap-c)# bandwidth 300
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit

RP/0/RSP0/CPU0:router(config)# interface pos 0/1/0/0.1
RP/0/RSP0/CPU0:router(config)# service-policy output policy1

RP/0/RSP0/CPU0:router(config)# interface pos 0/1/0/0.1 point-to-point pvc 16
RP/0/RSP0/CPU0:router(config-subif)# pvc 16
RP/0/RSP0/CPU0:router(config-fr-vc)# service-policy output policy1

Related Commands

match access-group

指定したアクセス コントロール リスト(ACL)番号をクラス マップの一致基準として識別するには、クラス マップ コンフィギュレーション モードで match access-group コマンドを使用します。 クラス マップから ACL 一致基準を削除するには、このコマンドの no 形式を使用します。

match access-group ipv4 access-group-name

no match access-group ipv4 access-group-name

Syntax Description

ipv4

照合する IPv4 アクセス グループの名前を指定します。

access-group-name

パケットが特定のクラスに属するかどうかを判定するために検査する対象の一致基準として内容を使用する ACL。

Command Default

クラス マップの一致基準として IPv6 または IPv4 のいずれも指定しない場合は、デフォルトで IPv4 アドレス指定が使用されます。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

クラス ベースの機能(マーキング、Modified Deficit Round Robin(MDRR)、ポリシングなど)の場合は、ACL や入力インターフェイスなどの一致基準に基づいてトラフィック クラスを定義します。 クラスの一致基準を満たすパケットは、そのクラスのトラフィックの一部となります。

match access-group コマンドでは、クラス マップで指定されているクラスにパケットが属するかどうかを判定するために検査対象の一致基準として内容を使用する ACL を指定します。

対応する ACL に SYN、ACK、FIN などの TCP フィールドがあるアクセス コントロール エントリはサポートされていません。

match access-group コマンドを使用するには、先に class-map コマンドを入力して、一致基準を設定するクラスの名前を指定する必要があります。 1 つの match ステートメントで、最大 8 つの IPv4 および IPv6 ACL を指定できます。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、map1 という名前のクラス マップを指定し、このクラスの一致基準として使用するように map1 を設定する方法の例を示します。

RP/0/RSP0/CPU0:router(config)# class-map map1
RP/0/RSP0/CPU0:router(config-cmap)# match access-group ipv4 map1

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

match destination-address

特定の宛先 MAC アドレスをクラス マップの一致基準として明示的に識別するには、クラス マップ コンフィギュレーション モードで match destination-address コマンドを使用します。 特定の宛先 MAC アドレスをクラス マップの一致基準から削除するには、このコマンドの no 形式を使用します。

match destination-address mac address

no match destination-address mac address

Syntax Description

mac

MAC アドレスを指定します。

address

宛先 MAC アドレスを指定します。

Command Default

デフォルトの動作または値はありません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

match destination-address コマンドでは、クラス マップで指定されているクラスにパケットが属するかどうかを判定するために検査対象の一致基準として宛先アドレスを指定します。

match destination-address コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するためにクラスの名前を指定する必要があります。 クラス マップ内で複数の match destination-address コマンドを指定すると、最後に入力したコマンドだけが適用されます。

match destination-address コマンドは、出力サービス ポリシーでだけサポートされます。

レイヤ 3 ターゲットに対するレイヤ 2 一致基準や、レイヤ 2 ターゲットに対するレイヤ 3 一致基準は、許可されていません。 match destination-address コマンドは、出力レイヤ 2 インターフェイス、レイヤ 2 サブインターフェイス、およびレイヤ 3 物理インターフェイスでサポートされます。 レイヤ 3 インターフェイスはレイヤ 2 サブインターフェイスを持つことができるため、レイヤ 3 物理インターフェイスもサポートされます。

このコマンドは、イーサネット インターフェイスに付加されたポリシー マップに使用できます。 このコマンドは、Packet-over-SONET/SDH(POS)インターフェイスまたは経路選択済み VLAN サブインターフェイスに接続するポリシーには使用できません。

一致する 48 ビット MAC アドレスは、L2VPN PE インターフェイスで xxxx.xxxx.xxxx フォーマットで指定します。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、宛先 MAC アドレスを照合する例を示します。

RP/0/RSP0/CPU0:router(config)#class-map match-any A
RP/0/RSP0/CPU0:router(config-cmap)# match destination-address mac 000.f0d0.2356

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

match discard-class

特定の廃棄クラスの値をクラス マップの一致基準として識別するには、クラス マップ コンフィギュレーション モードで match discard-class コマンドを使用します。 指定した廃棄クラスの値をクラス マップの一致基準から削除するには、このコマンドの no 形式を使用します。

match [ not ] discard-class discard-class-value [ discard-class-value1 ... discard-class-value7 ]

no match [ not ] discard-class discard-class-value [ discard-class-value1 ... discard-class-value7 ]

Syntax Description

not

(任意)指定した一致結果を除外します。

discard-class-value

廃棄クラス ID。 パケットに一致する廃棄クラス ID を 8 つまで指定できます。 クラス ID はスペースで区切ります。 範囲は 0 ~ 7 です。

Command Default

デフォルトの動作または値はありません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

match discard-class コマンドでは、クラス マップで指定されているクラスにパケットが属するかどうかを判定するために検査対象の一致基準として廃棄クラスを指定します。

match discard-class コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するためにクラスの名前を指定する必要があります。 クラス マップ内で複数の match discard-class コマンドを指定すると、既存の match ステートメントに新しい値が追加されます。

match discard-class コマンドでは、パケット上にマーキングされた廃棄クラスを調べる一致基準を設定します。 1 つの match ステートメントで、最大 8 つの廃棄クラスの値を照合できます。 たとえば、match discard-class 0 1 2 3 4 5 6 7 を使用すると、廃棄クラスの値 0、1、2、3、4、5、6、および 7 に一致する結果が返されます。 一致すると見なされるために必要な値は、7 つのうちのいずれかだけです(OR 演算)。

廃棄クラスの値は、一致基準としてだけ使用されます。 値に数学的意味はありません。 たとえば、廃棄クラス値 2 が 1 より大きいわけではありません。 値が示すのは、廃棄クラス値 2 がマーキングされたパケットと廃棄クラス値 1 がマーキングされたパケットの扱いが異なることだけです。


(注)  


match discard-class コマンドは、出力ポリシーにだけ適用されます。


Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、policy1 という名前のサービス ポリシーをインターフェイスに付加する例を示します。 この例では、ギガビット イーサネット インターフェイス 0/1/0/9 から発信されるすべてのパケットを、廃棄クラス値 5 と評価するため、クラス マップ discard class5 を作成します。 廃棄クラス値 5 がマーキングされたパケットは、300 kbps の帯域幅設定でクラス キューに格納されます。

RP/0/RSP0/CPU0:router(config)# class-map discard-class5
RP/0/RSP0/CPU0:router(config-cmap)# match discard-class 5
RP/0/RSP0/CPU0:router(config-cmap)# exit
RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class discard-class5
RP/0/RSP0/CPU0:router(config-pmap-c)# bandwidth 300
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit
RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/9
RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

set discard-class

IP Version 4(IPv4)またはマルチプロトコル ラベル スイッチング(MPLS)パケットの廃棄クラスおよび Quality of Service(QoS)グループ ID を設定します。  

set qos-group

パケットの Quality of Service(QoS)グループ ID を設定します。  

match dscp

特定の IP DiffServ コード ポイント(DSCP)値をクラス マップの一致基準として識別するには、クラス マップ コンフィギュレーション モードで match dscp コマンドを使用します。 クラス マップから DSCP 値を削除するには、このコマンドの no 形式を使用します。

match [not] dscp [ ipv4 | ipv6 ] dscp-value [ dscp-value1 . .. dscp-value7 ]

no match [not] dscp [ ipv4 | ipv6 ] dscp-value [ dscp-value1 . .. dscp-value7 ]

Syntax Description

not

(任意)指定した一致結果を除外します。

ipv4

(任意)IPv4 DSCP 値を指定します。

ipv6

(任意)IPv6 DSCP 値を指定します。

dscp-value

正確な値または値の範囲を指定する IP DSCP 値 ID。 範囲は 0 ~ 63 です。 パケットに一致する IP DSCP 値を 8 つまで指定できます。 数値の代わりに、予約済みキーワードも指定できます。 表 1 に、予約済みキーワードを示します。

Command Default

デフォルトでは、IP バージョン 4(IPv4)および IPv6 の両方のパケットに一致します。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

match dscp コマンドでは、クラス マップで指定されているクラスにパケットが属するかどうかを判定するために検査対象の一致基準として DSCP 値を指定します。

match dscp コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するためにクラスの名前を指定する必要があります。 クラス マップ内で複数の match dscp コマンドを指定すると、最後に入力したコマンドだけが適用されます。

match dscp コマンドでは、IP ヘッダーのタイプ オブ サービス(ToS)バイトのうち、上位 6 ビットを調べます。 一致すると見なされるために必要な値は、8 つのうちのいずれかだけです(OR 演算)。

コマンドでサポートする IP DSCP 値は 8 つだけです。 8 つの値すべてが照合された後に、match ステートメントをさらに設定しようとすると、ステートメントが拒否されます。

IP DSCP 値は、一致基準としてだけ使用されます。 値に数学的意味はありません。 たとえば、IP DSCP 値 2 が 1 より大きいわけではありません。 値が示すのは、IP DSCP 値 2 がマーキングされたパケットと IP DSCP 値 1 がマーキングされたパケットの扱いが異なることだけです。 これらのマーキングされたパケットの扱いは、ポリシー マップ クラス コンフィギュレーション モードで、QoS ポリシーの設定を使用してユーザが定義します。

次の表に示す予約済みキーワードは、数値の代わりに指定できます。

表 1 IP DSCP 予約済みキーワード

DSCP 値

予約済みキーワード

0

default

10

AF11

12

AF12

14

AF13

18

AF21

20

AF22

22

AF23

26

AF31

28

AF32

30

AF33

34

AF41

36

AF42

38

AF43

46

EF

8

CS1

16

CS2

24

CS3

32

CS4

40

CS5

48

CS6

56

CS7

ipv4

ipv4 dscp

ipv6

ipv6 dscp

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、policy1 という名前のサービス ポリシーを設定し、policy1 をインターフェイスに付加する例を示します。 この例では、クラス マップ dscp14 は、IP DSCP 値 14 の Packet-over-SONET/SDH(POS)インターフェイス 0/1/0/0 に着信するすべてのパケットを評価します。 IP DSCP 値 14 がマーキングされている着信パケットは、300 kbps の帯域幅設定でクラス キューに格納されます。

RP/0/RSP0/CPU0:router(config)# class-map dscp14
RP/0/RSP0/CPU0:router(config-cmap)# match dscp ipv4 14
RP/0/RSP0/CPU0:router(config-cmap)# exit

RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class dscp14
RP/0/RSP0/CPU0:router(config-pmap-c)# bandwidth 300
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit

RP/0/RSP0/CPU0:router(config)# interface pos 0/1/0/0
RP/0/RSP0/CPU0:router(config-if)# service-policy input policy1

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

set dscp

タイプ オブ サービス(ToS)バイト内の IP DiffServ コード ポイント(DSCP)を設定することでパケットをマーキングします。  

match precedence

IP precedence 値を一致基準として識別します。  

match mpls experimental topmost

最上位のマルチプロトコル ラベル スイッチング(MPLS)ラベル内にある特定の 3 ビット experimental(EXP)フィールド値をクラス マップの一致基準として識別するには、クラス マップ コンフィギュレーション モードで match mpls experimental topmost コマンドを使用します。 EXP フィールド値をクラス マップの一致基準から削除するには、このコマンドの no 形式を使用します。

match [ not ] mpls experimental topmost exp-value [ exp-value1 ...exp-value7 ]

no match [ not ] mpls experimental topmost exp-value [ exp-value1 ...exp-value7 ]

Syntax Description

not

(任意)指定した一致結果を除外します。

exp-value

0 ~ 7 の正確な値を指定する EXP 値。 MPLS ヘッダーに一致する EXP 値を 8 つまで指定できます。

Command Default

デフォルトの動作または値はありません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

クラス マップでは match mpls experimental topmost コマンドを使用して、パケットに一致する MPLS EXP 値を識別します。

match mpls experimental topmost コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するためにクラスの名前を指定する必要があります。 クラス マップ内で複数の match mpls experimental topmost コマンドを指定すると、既存の match ステートメントに新しい値が追加されます。

このコマンドでは、MPLS パケットの最上位ラベルに含まれる 3 つの EXP ビットを調べます。 1 つの match ステートメントで、最大 8 つの EXP 値を照合できます。 たとえば、match mpls experimental topmost 2 4 5 7 を使用すると、EXP 値 2、4、5、および 7 に一致する結果が返されます。 一致すると見なされるために必要な値は、4 つのうちのいずれかだけです(OR 演算)。

EXP 値は、一致基準としてだけ使用されます。 値に数学的意味はありません。 たとえば、EXP 値 2 が 1 より大きいわけではありません。 値が示すのは、EXP 値 2 がマーキングされたパケットと EXP 値 1 がマーキングされたパケットの扱いが異なることです。 これらの異なるパケットの扱いは、ポリシー マップ クラス コンフィギュレーション モードで、QoS ポリシーの設定を使用してユーザが定義します。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、policy1 という名前のサービス ポリシーを設定し、policy1 をインターフェイスに付加する例を示します。 この例では、クラス マップ mplsmap1 で、ギガビット イーサネット インターフェイス 0/1/0/9 に着信するすべてのパケットを、MPLS EXP 値 1 に評価します。 MPLS EXP 値 1 がマーキングされている着信パケットは、300 kbps の帯域幅設定でクラス キューに格納されます。

RP/0/RSP0/CPU0:router(config)# class-map mplsmap1
RP/0/RSP0/CPU0:router(config-cmap)# match mpls experimental topmost 1
RP/0/RSP0/CPU0:router(config-cmap)# exit
RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class mplsmap1
RP/0/RSP0/CPU0:router(config-pmap-c)# bandwidth 300
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit
RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/9
RP/0/RSP0/CPU0:router(config-if)# service-policy input output policy1
  

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

match dscp

特定の IP DiffServ コード ポイント(DSCP)値をクラス マップの一致基準として識別します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

set mpls experimental

 

show policy-map interface

指定されたインターフェイス上のすべてのサービス ポリシーに対して設定されている全クラスのポリシー設定情報を表示します。  

match precedence

IP precedence 値を一致基準として識別するには、クラス マップ コンフィギュレーション モードで match precedence コマンドを使用します。 クラス マップから precedence 値を削除するには、このコマンドの no 形式を使用します。

match [ not ] precedence [ ipv4 | ipv6 ] precedence-value [ precedence-value1 ... precedence-value7 ]

no match [ not ] precedence [ ipv4 | ipv6 ] precedence-value [ precedence-value1 ... precedence-value7 ]

Syntax Description

not

(任意)指定した一致結果を除外します。

ipv4

(任意)IPv4 precedence 値を指定します。

ipv6

(任意)IPv6 precedence 値を指定します。

precedence-value

正確な値を指定する IP precedence 値 ID。 範囲は 0 ~ 7 です。 数値の代わりに、予約済みキーワードも指定できます。 表 1 に、予約済みキーワードを示します。

1 つの match ステートメントで、最大 8 つの precedence 値を照合できます。

Command Default

デフォルトでは、IP バージョン 4(IPv4)および IPv6 の両方のパケットに一致します。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

match precedence コマンドでは、クラス マップで指定されているクラスにパケットが属するかどうかを判定するために検査対象の一致基準として precedence 値を指定します。

match precedence コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するためにクラスの名前を指定する必要があります。 クラス マップ内で複数の match precedence コマンドを指定すると、最後に入力したコマンドだけが適用されます。

match precedence コマンドでは、IP ヘッダーのサービス タイプ(ToS)バイトのうち、上位 3 ビットを調べます。 1 つの match ステートメントで、最大 8 つの precedence 値を照合できます。 たとえば、match precedence ipv4 0 1 2 3 4 5 6 7 を使用すると、IP precedence 値 0、1、2、3、4、5、6、および 7 に一致する結果が返されます。 一致すると見なされるために必要な値は、8 つのうちのいずれかだけです(OR 演算)。

precedence 値は、一致基準としてだけ使用されます。 値に数学的意味はありません。 たとえば、precedence 値 2 が 1 より大きいわけではありません。 値が示すのは、precedence 値 2 がマーキングされたパケットと precedence 値 1 がマーキングされたパケットが異なることだけです。 これらの異なるパケットの扱いは、ポリシー マップ クラス コンフィギュレーション モードで、QoS ポリシーの設定を使用してユーザが定義します。

次の表に、IP precedence 値と対応する名前を、重要度の高い順に示します。

表 2 IP precedence 値と名前

名前

0

routine

1

priority

2

immediate

3

flash

4

flash-override

5

critical

6

internet

7

network

ipv4

ipv4 precedence

ipv6

ipv6 precedence

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、policy1 という名前のサービス ポリシーを設定し、policy1 をインターフェイスに付加する例を示します。 この例では、クラス マップ ipprec5 で、ギガビット イーサネット インターフェイス 0/1/0/9 に着信するすべてのパケットを、precedence 値 5 に評価します。 precedence 値 5 がマーキングされている着信パケットは、300 kbps の帯域幅設定でクラス キューに格納されます。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# class-map ipprec5
RP/0/RSP0/CPU0:router(config-cmap)# match precedence ipv4 5	
RP/0/RSP0/CPU0:router(config-cmap)# exit
RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class ipprec5
RP/0/RSP0/CPU0:router(config-pmap-c)# bandwidth 300
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit
RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/9
RP/0/RSP0/CPU0:router(config-if)# service-policy input policy1
  

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

set precedence

IP ヘッダーに優先順位を設定します。  

show policy-map interface

指定されたインターフェイス上のすべてのサービス ポリシーに対して設定されている全クラスのポリシー設定情報を表示します。  

match protocol

特定のプロトコルをクラス マップの一致基準として識別するには、クラス マップ コンフィギュレーション モードで match protocol コマンドを使用します。 クラス マップからプロトコルごとの一致基準を削除するには、このコマンドの no 形式を使用します。

match [not] protocol protocol-value [ protocol-value1 . .. protocol-value7 ]

no match [not] protocol protocol-value [ protocol-value1 . .. protocol-value7 ]

Syntax Description

not

(任意)指定した一致結果を除外します。

protocol-value

プロトコル ID。 1 つの match ステートメントで 1 つの protocol-value(数字と名前の任意の組み合わせ)を照合できます。

Command Default

デフォルトの動作または値はありません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

トラフィック クラスの定義は、プロトコル、アクセス コントロール リスト(ACL)、入力インターフェイス、QoS ラベル、experimental(EXP)フィールド値などの一致基準に基づいています。 クラスの一致基準を満たすパケットは、そのクラスのトラフィックの一部となります。

match protocol コマンドは、パケットがクラス マップで指定されたクラスに属するかどうか判別するために照合される一致基準として使用されるプロトコル名を指定します。 使用可能なプロトコル名はその後の表に一覧表示されます。

protocol-value 引数は、プロトコル番号の範囲をサポートしています。 クラスを識別した後で、match protocol コマンドを使用して一致基準を設定できます。

表 3 プロトコル名と説明

名前

説明

ahp

認証ヘッダー プロトコル

eigrp

Cisco Enhanced Interior Gateway Routing Protocol

esp

Encapsulation Security Payload

gre

Cisco Generic Routing Encapsulation Tunneling

icmp

インターネット制御メッセージ プロトコル

igmp

Internet Gateway Message Protocol

igrp

Cisco IGRP Routing protocol

ipinip

IP-in-IP トンネリング

ipv4

すべての IPv4 プロトコル

ipv6

すべての IPv6 プロトコル

mpls

すべての MPLS パケット

nos

KA9Q NOS 互換 IP-over-IP トンネリング

ospf

Open Shortest Path First、ルーティング プロトコル

pcp

ペイロード圧縮プロトコル

pim

Protocol Independent Multicast

sctp

Stream Control Transmission Protocol

tcp

Transport Control Protocol

udp

ユーザ データグラム プロトコル

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次の例では、すべての TCP パケットが class1 クラスに属しています。

RP/0/RSP0/CPU0:router(config)# class class1
RP/0/RSP0/CPU0:router(config-cmap)# match protocol tcp
  

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

match access-group

指定したアクセス コントロール リスト(ACL)番号をクラス マップの一致基準として識別します。  

match mpls experimental topmost

最上位のマルチプロトコル ラベル スイッチング(MPLS)ラベル内にある特定の 3 ビット experimental(EXP)フィールド値をクラス マップの一致基準として識別します。  

match qos-group

クラス マップの一致基準として特定の Quality of Service(QoS)グループ値を識別します。  

match qos-group

クラス マップの一致基準として特定の Quality of Service(QoS)グループ値を識別するには、クラス マップ コンフィギュレーション モードで match qos-group コマンドを使用します。 特定の QoS グループ値をクラス マップの一致基準から削除するには、このコマンドの no 形式を使用します。

match [ not ] qos-group [ qos-group-value 1 ... qos-group-value8 ]

no match [ not ] qos-group

Syntax Description

not

(任意)指定した一致結果を除外します。

qos-group-value

0 ~ 63 の厳密値、または 0 ~ 63 の値範囲を指定する QoS グループ値 ID。 1 つの match ステートメントで最大 8 つの値を入力できます。

Command Default

一致基準が指定されていません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

match qos-group コマンドでは、パケット上にマーキングされた QoS グループを調べる一致基準を設定します。 1 つの match ステートメントで、最大 8 つの QoS グループ値を照合できます。 たとえば、match qos-group 4 9 11 15 16 21 30 31 を使用すると、QoS グループ値 4、9、11、15、16、21、30、および 31 に一致する結果が返されます。 一致すると見なされるために必要な値は、8 つのうちのいずれかだけです(OR 演算)。

QoS グループ値は、一致基準としてだけ使用されます。 値に数学的意味はありません。 たとえば、QoS グループ値 2 が 1 より大きいわけではありません。 値が示すのは、QoS グループ値 2 がマーキングされたパケットと QoS グループ値 1 がマーキングされたパケットの扱いが異なることだけです。 これらの異なるパケットの取り扱いは、ポリシー マップ クラス コンフィギュレーション モードで service-policy コマンドを使用して定義されます。

QoS グループの設定は、ローカル ルータの範囲に制限されています。 通常、QoS グループはローカル ルータに設定され、WRED または MDRR と併せて使用されることで、グループ ID に基づく異なるレベルのサービスを提供しています。

match qos-group コマンドは、出力ポリシーでだけサポートされています。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、policy1 という名前のサービス ポリシーをインターフェイスに付加する例を示します。 この例では、クラス マップ qosgroup5 で、GigabitEthernet 0/1/0/9 から発信されるすべてのパケットを QoS グループ値 5 と評価します。 QoS グループ値 5 がマーキングされているパケットは、300 kbps の帯域幅設定でクラス キューに格納されます。

RP/0/RSP0/CPU0:router(config)# class-map qosgroup5
RP/0/RSP0/CPU0:router(config-cmap)# match qos-group 5
RP/0/RSP0/CPU0:router(config-cmap)# exit
RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class qosgroup5
RP/0/RSP0/CPU0:router(config-pmap-c)# bandwidth 300
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit
RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/9
RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1
  

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

set discard-class

IP Version 4(IPv4)またはマルチプロトコル ラベル スイッチング(MPLS)パケットの廃棄クラスおよび Quality of Service(QoS)グループ ID を設定します。  

set qos-group

パケットの Quality of Service(QoS)グループ ID を設定します。  

match source-address

特定のソース MAC アドレスをクラス マップの一致基準として識別するには、クラス マップ コンフィギュレーション モードで match source-address コマンドを使用します。 特定のソース MAC アドレスをクラス マップの一致基準から削除するには、このコマンドの no 形式を使用します。

match source-address mac address

no match source-address mac address

Syntax Description

mac

MAC アドレスを指定します。

address

ソース MAC アドレスを指定します。

Command Default

デフォルトの動作または値はありません。

Command Modes

クラス マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

match source-address コマンドでは、クラス マップで指定されているクラスにパケットが属するかどうかを判定するために検査対象の一致基準として使用されるソース アドレスを指定します。

match source-address コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するクラスの名前を指定する必要があります。 クラス マップ内で複数の match source-address コマンドを指定すると、最後に入力したコマンドだけが適用されます。

このコマンドは、入力サービス ポリシーだけでサポートされます。

レイヤ 3 ターゲットに対するレイヤ 2 一致基準や、レイヤ 2 ターゲットに対するレイヤ 3 一致基準は、許可されていません。

match source-address コマンドは、出力レイヤ 2 インターフェイス、レイヤ 2 サブインターフェイス、およびレイヤ 3 物理インターフェイスでサポートされます。 レイヤ 3 インターフェイスはレイヤ 2 サブインターフェイスを持つことができるため、レイヤ 3 物理インターフェイスもサポートされます。

match source-address コマンドは、イーサネット インターフェイスに付加されたポリシー マップに使用できます。 このコマンドは、Packet-over-SONET/SDH(POS)インターフェイスまたは経路選択済み VLAN サブインターフェイスに接続するポリシーには使用できません。

一致する 48 ビット MAC アドレスは、L2VPN PE インターフェイスで xxxx.xxxx.xxxx フォーマットで指定します。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、ソース MAC アドレスを照合する例を示します。

RP/0/RSP0/CPU0:router(config)# class-map match-any A
RP/0/RSP0/CPU0:router(config-cmap)# match source-address mac 0003.f0d0.2356

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

set fr-de

インターフェイスから送信されるすべてのトラフィックについて、フレーム リレー フレームのアドレス フィールドで廃棄適性(DE)ビット設定を 1 に変更するには、ポリシー マップ コンフィギュレーション モードで set fr-de コマンドを使用します。 DE ビットの設定を削除するには、このコマンドの no 形式を使用します。

set fr-de [fr-de-bit-value]

no set fr-de [fr-de-bit-value]

Syntax Description

not

(任意)指定した一致結果を除外します。

fr-de-bit-value

(任意)フレーム リレー DE ビットを指定します。 0 または 1 の値を指定できます。 1 の値を指定できます。

Command Default

デフォルト値は 0 です。

Command Modes

ポリシー マップ コンフィギュレーション

Command History

リリース

変更箇所

リリース 4.0.0

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

トラフィック ポリシーでこのコマンドをディセーブルにするには、トラフィック ポリシーのポリシー マップ コンフィギュレーション モードで、no set fr-de コマンドを使用します。

DE ビットがすでに 1 に設定されている場合、フレームは変更されません。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、set fr-de コマンドを使用してトラフィック ポリシーで DE ビットを設定する例を示します。 ルータにより、ip-precedence クラスに属す発信パケットの DE ビットが設定されます。

RP/0/RSP0/CPU0:router(config)# class-map ip-precedence
RP/0/RSP0/CPU0:router(config-cmap)# match precedence 0 1
RP/0/RSP0/CPU0:router(config-cmap)# exit
RP/0/RSP0/CPU0:router(config)# policy-map set-de
RP/0/RSP0/CPU0:router(config-pmap)# class ip-precedence
RP/0/RSP0/CPU0:router(config-pmap-c)# set fr-de 1
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit
RP/0/RSP0/CPU0:router(config)# interface serial 0/1/0/0/1
RP/0/RSP0/CPU0:router(config-if)# no ip address
RP/0/RSP0/CPU0:router(config-if)# encapsulation frame-relay
RP/0/RSP0/CPU0:router(config-if)# interface serial 0/1/0/0.1 point-to-point
RP/0/RSP0/CPU0:router(config-subif)# ip address 10.1.1.1 255.255.255.252
RP/0/RSP0/CPU0:router(config-subif)# pvc 16
RP/0/RSP0/CPU0:router(config-fr-vc)# service-policy output set-de
  

Related Commands

Command

Description

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

set discard-class

IP Version 4(IPv4)またはマルチプロトコル ラベル スイッチング(MPLS)パケットの廃棄クラスおよび Quality of Service(QoS)グループ ID を設定するには、ポリシー マップ クラス コンフィギュレーション モードで set discard-class コマンドを使用します。 discard-class 値を変更せずにそのままにしておくには、このコマンドの no 形式を使用します。

set discard-class discard-class-value

no set discard-class discard-class-value

Syntax Description

discard-class-value

廃棄クラスの ID。 0 ~ 7 の整数がパケット上でマーキングされます。

Command Default

デフォルトの動作または値はありません。

Command Modes

ポリシー マップ クラス コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

set discard-class コマンドは、廃棄クラスの ID をパケットと関連付けます。 廃棄クラス設定した後、Modified Deficit Round Robin(MDRR)や重み付けランダム早期検出(WRED)などの他の QoS サービスをビット設定で操作できます。

Discard-class は、per hop behavior(PHB)の廃棄部分を示します。 set discard-class コマンドは、通常、パイプ モードで使用されます。 Discard-class は、出力インターフェイスのパケットを分類するために PHB マーキングが使用されるときに必要となります。

discard-class 値は、輻輳の発生時にドロップされるトラフィックのタイプを指定するために使用できます。


(注)  


廃棄クラスのマーキングは、ノードのローカルでだけ意味があります。


Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、MPLS EXP ビット 1 に一致するパケットに対し、廃棄クラス値を 5 に設定する例を示します。

RP/0/RSP0/CPU0:router(config)# class-map cust1
RP/0/RSP0/CPU0:router(config-cmap)# match mpls experimental topmost 1
RP/0/RSP0/CPU0:router(config-cmap)# exit
RP/0/RSP0/CPU0:router(config)# policy-map policy2
RP/0/RSP0/CPU0:router(config-pmap)# class cust1
RP/0/RSP0/CPU0:router(config-pmap-c)# set discard-class 5
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit
RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/9
RP/0/RSP0/CPU0:router(config-if)# service-policy input policy2
  

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

service-policy(インターフェイス)

入力インターフェイスまたは出力インターフェイスに、インターフェイスのサービス ポリシーとして使用されるポリシー マップを対応付けます。  

set dscp

タイプ オブ サービス(ToS)バイト内の IP DiffServ コード ポイント(DSCP)を設定することでパケットをマーキングするには、ポリシーマップ クラス コンフィギュレーション モードで set dscp コマンドを使用します。 以前に設定した DSCP 値を削除するには、このコマンドの no 形式を使用します。

set dscp [tunnel] dscp-value

no set dscp [tunnel] dscp-value

Syntax Description

tunnel

(任意)外部 IP ヘッダーの DSCP を設定します。 このコマンドは、入力方向のレイヤ 3 インターフェイスで使用できます。

dscp-value

DSCP 値を設定する 0 ~ 63 の番号。 数値の代わりに、予約済みキーワードも指定できます。 表 1 に、予約済みキーワードを示します。

Command Default

デフォルトの動作または値はありません。

Command Modes

ポリシー マップ クラス コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

リリース 3.9.1

入力方向のレイヤ 3 インターフェイスに tunnel キーワードが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

DSCP ビットを設定すると、他の Quality of Service(QoS)サービスがビット設定で動作できます。

マーキングされたトラフィックには、ネットワークによってプライオリティ(または緊急処理のタイプ)が設定されます。 通常は、ネットワーク(または管理ドメイン)のエッジに DSCP 値を設定します。データはこの DSCP 値に基づいてキューイングされます。 Modified Deficit Round Robin(MDRR)は、輻輳ポイントで高 DSCP トラフィックの処理を高速化できます。 重み付けランダム早期検出(WRED)により、輻輳時に高 DSCP トラフィックの損失率を他のトラフィックより確実に小さくできます。

数値の代わりに、予約済みキーワードも指定できます。 表 1 に、予約済みキーワードを示します。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、ポリシー マップ policy1 内で DSCP ToS バイトを 8 に設定する例を示します。 class1 の一致基準を満たすすべてのパケットには、DSCP 値 8 がマーキングされます。 パケットのマーキング方法はネットワーク設定によって決まります。

RP/0/RSP0/CPU0:router (config)# policy-map policy1 
RP/0/RSP0/CPU0:router(config-pmap)# class class1
RP/0/RSP0/CPU0:router(config-pmap-c)# set dscp 8
  

Related Commands

Command

Description

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

service-policy(インターフェイス)

入力インターフェイスまたは出力インターフェイスに、インターフェイスのサービス ポリシーとして使用されるポリシー マップを対応付けます。  

set precedence

IP ヘッダーに優先順位を設定します。  

show policy-map interface

指定されたインターフェイス上のすべてのサービス ポリシーに対して設定されている全クラスのポリシー設定情報を表示します。  

set mpls experimental

マルチプロトコル ラベル スイッチング(MPLS)パケットの experimental(EXP)値を最上位またはインポジションのラベルに設定するには、ポリシー マップ コンフィギュレーション モードで set mpls experimental コマンドを使用します。 EXP 値を変更せずにそのままにしておくには、このコマンドの no 形式を使用します。

set mpls experimental { imposition | topmost } exp-value

no set mpls experimental { imposition | topmost } exp-value

Syntax Description

imposition

インポジション ラベルの EXP 値を設定するように指定します。

topmost

最上位ラベルの EXP 値を設定するように指定します。

exp-value

MPLS パケット ラベルの値。 範囲は 0 ~ 7 です。

Command Default

MPLS EXP 値は設定されていません。

Command Modes

ポリシー マップ クラス コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

MPLS EXP ビットを設定すると、Modified Deficit Round Robin(MDRR)や重み付けランダム早期検出(WRED)などの他の QoS サービスがビット設定で動作します。

ネットワークは、ネットワーク内のダウンストリーム ポイントに MDRR または WRED を適用することで、マーキングされたトラフィックにプライオリティ(または緊急処理のタイプ)を与えます。 通常は、ネットワーク(または管理ドメイン)のエッジに MPLS EXP 値を設定します。その後、キューイングはこの MPLS EXP 値に基づいて実行されます。 MDRR は、輻輳ポイントにおいて、優先順位が高いトラフィックの処理を高速化できます。 WRED を使用すると、トラフィック輻輳時における優先順位が高いトラフィックの損失率は、他のトラフィックよりも低くなります。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、アクセス リスト 101 に一致するパケットに対し、MPLS EXP 値を 5 に設定する例を示します。

RP/0/RSP0/CPU0:router(config)# class-map class1
RP/0/RSP0/CPU0:router(config-cmap)# match access-group ipv4 acl101
RP/0/RSP0/CPU0:router(config-cmap)# exit

RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class class1
RP/0/RSP0/CPU0:router(config-pmap-c)# set mpls experimental  topmost 5
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit

RP/0/RSP0/CPU0:router(config)# interface  pos 0/7/0/0
RP/0/RSP0/CPU0:router(config-if)# service-policy  output policy1
  

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

service-policy(インターフェイス)

入力インターフェイスまたは出力インターフェイスに、インターフェイスのサービス ポリシーとして使用されるポリシー マップを対応付けます。  

set precedence

IP ヘッダーに優先順位の値を設定するには、ポリシー マップ クラス コンフィギュレーション モードで set precedence コマンドを使用します。 precedence 値を変更せずにそのままにしておくには、このコマンドの no 形式を使用します。

set precedence [tunnel] value

no set precedence [tunnel] value

Syntax Description

tunnel

(任意)外部 IP ヘッダーで IP precedence を設定します。 このコマンドは、入力方向のレイヤ 3 インターフェイスで使用できます。

value

precedence ビットを IP ヘッダーに設定する番号または名前。 範囲は 0 ~ 7 です。 数値の代わりに、予約済みキーワードも指定できます。 表 1 に、予約済みキーワードを示します。

Command Default

Command Modes

Command History

リリース 3.7.2

このコマンドが追加されました。

リリース 3.9.1

入力方向のレイヤ 3 インターフェイスに tunnel キーワードが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

優先順位は、番号や対応する名前を使用して設定できます。 IP Precedence ビットを設定すると、Modified Deficit Round Robin(MDRR)や重み付けランダム早期検出(WRED)などの他の QoS サービスがビット設定で動作します。

ネットワークは、ネットワーク内のダウンストリーム ポイントに MDRR または WRED を適用することで、マーキングされたトラフィックにプライオリティ(または緊急処理のタイプ)を与えます。 IP precedence をネットワーク(または管理ドメイン)のエッジに設定して、キューイングを実行することができます。 MDRR は、輻輳ポイントにおいて、優先順位が高いトラフィックの処理を高速化できます。 WRED を使用すると、トラフィック輻輳時における優先順位が高いトラフィックの損失率は、他のトラフィックよりも低くなります。

0(ルーティン)や 1(プライオリティ)のようなキーワードから precedence 値へのマッピングは、場合によって役立ちます。 つまり、precedence ビットの使用はまだ発展途上にあります。 precedence 値の意味は、その値を使用する他の機能をイネーブルにすることで定義できます。 ハイエンド Internet QoS の場合、IP precedence は、ネットワーク上で数値的に優劣が付けられる処理に必ずしも該当しないサービス クラスを設定するために使用できます。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、アクセス コントロール リスト customer1 に一致するパケットに対し、IP precedence を 5(critical)に設定する例を示します。

RP/0/RSP0/CPU0:router(config)# class-map class1
RP/0/RSP0/CPU0:router(config-cmap)# match access-group ipv4 customer1
RP/0/RSP0/CPU0:router(config-cmap)# exit

RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class class1
RP/0/RSP0/CPU0:router(config-pmap-c)# set precedence 5
RP/0/RSP0/CPU0:router(config-pmap-c)# exit
RP/0/RSP0/CPU0:router(config-pmap)# exit

RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/9
RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1
  

Related Commands

Command

Description

class-map

トラフィック クラス、およびパケットをクラスに対応させる関連付けられたルールを定義します。  

policy-map

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。  

service-policy(インターフェイス)

入力インターフェイスまたは出力インターフェイスに、インターフェイスのサービス ポリシーとして使用されるポリシー マップを対応付けます。  

shape average

指定されたアルゴリズムに従って指示されたビット レートにトラフィックをシェーピングするには、ポリシー マップ クラス コンフィギュレーション モードで shape average コマンドを使用します。 トラフィック シェーピングを削除するには、このコマンドの no 形式を使用します。

shape average { percent percentage | rate [units] }

no shape average { percent percentage | rate [units] }

Syntax Description

percent percentage

インターフェイス帯域幅をパーセンテージで指定します。 値は 1 ~ 100 の範囲になります。

rate

指定された単位の平均的なシェーピング レート。 値は 1 ~ 4294967295 の範囲になります。

units

(任意)帯域幅の単位。 値は次のとおりです。

  • bps:ビット/秒(デフォルト)
  • gbps:ギガビット/秒
  • kbps:キロビット/秒
  • mbps:メガビット/秒

Command Default

units: bps

Command Modes

ポリシー マップ クラス コンフィギュレーション

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

子ポリシーの shape average コマンドでは、パーセンテージのパラメータに使用されるリファレンスは、親ポリシーの最大レートに関連しています。 シェーピングまたはポリシングが親ポリシーで設定されていない場合、親ポリシーはインターフェイス レートを継承します。

クラス用に設定された整形と帯域幅の両方がある場合、整形のパーセント値は、帯域幅のパーセント値よりも確実に大きくなるように設定してください。

Task ID

タスク ID

操作

qos

読み取り、書き込み

Examples

次に、トラフィック シェーピングを親のシェーパー比率の 50 パーセントに設定する例を示します。

RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class class1
RP/0/RSP0/CPU0:router(config-pmap-c)# shape average percent 50
  

次に、トラフィック シェーピングを 100000 kbps に設定する例を示します。

RP/0/RSP0/CPU0:router(config)# policy-map policy1
RP/0/RSP0/CPU0:router(config-pmap)# class class1
RP/0/RSP0/CPU0:router(config-pmap-c)# shape average 100000 kbps
  

show qos interface

特定のインターフェイスの QoS 情報を表示するには、EXEC モードで show qos interface コマンドを使用します。

show qos interface type interface-path-id { input | output } [ location node-id ]

Syntax Description

type

インターフェイスのタイプ。 詳細については、疑問符(?)オンライン ヘルプ機能を使用します。

interface-path-id

次に示す、物理インターフェイス インスタンスまたは仮想インターフェイス インスタンスのいずれかです。

  • 物理インターフェイス インスタンス。 名前表記は rack/slot/module/port で、値の間のスラッシュは表記の一部として必要です。
    • rack:ラックのシャーシ番号。
    • slot:モジュラ サービス カードまたはラインカードの物理スロット番号。
    • module:モジュール番号。 物理層インターフェイス モジュール(PLIM)は、常に 0 です。
    • port:インターフェイスの物理ポート番号。
    (注)     

    ルート プロセッサ カード上に管理イーサネット インターフェイスがある場合、物理スロット番号は英数字(RSP0RP0 または RP1)で、モジュールは CPU0 です。 例:インターフェイス MgmtEth0/ RSP0 RP1 /CPU0/0。

  • 仮想インターフェイス インスタンス。 数字の範囲は、インターフェイス タイプによって異なります。

ルータの構文の詳細については、疑問符(?)を使用してオンライン ヘルプを参照してください。

input

指定したポリシー マップを入力インターフェイスに付加します。

output

指定したポリシー マップを出力インターフェイスに付加します。

location node-id

(任意)指定したノードの詳細な QoS 情報を表示します。 node-id 引数は、rack/slot/module の形式で入力します。

Command Default

デフォルトの動作または値はありません。

Command Modes

EXEC

Command History

リリース

変更箇所

リリース 3.7.2

このコマンドが追加されました。

Usage Guidelines

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できない場合は、AAA 管理者に連絡してください。

show qos interface コマンドは、インターフェイスに付加されたサービス ポリシー内のすべてのクラスに関する設定を表示します。

police rate コマンドの処理キーワードによってハードウェア内にプログラムされた実際の値を確認するには、このコマンドを使用します。

Task ID

タスク ID

操作

qos

読み取り

Examples

次に、ギガビット イーサネット インターフェイスの QoS 情報の出力例を示します。

show qos interface gig0/0/0/11.1 output

Wed Mar 18 18:25:20.140 UTC 
Interface: GigabitEthernet0_0_0_11.1 output Bandwidth: 1000000 kbps ANCP: 999936 kbps 
Policy: parent-3play-subscriber-line Total number of classes: 5
----------------------------------------------------------------------
Level: 0 Policy: parent-3play-subscriber-line Class: class-default
QueueID: N/A
Shape Profile: 1 CIR: 200000 kbps (200 mbps)
CBS: 100352 bytes PIR: 999936 kbps PBS: 12517376 bytes
WFQ Profile: 1 Committed Weight: 51 Excess Weight: 100
Bandwidth: 200000 kbps, BW sum for Level 0: 1000000 kbps, Excess Ratio: 100
----------------------------------------------------------------------
Level: 1 Policy: child-3play Class: 3play-voip
Parent Policy: parent-3play-subscriber-line Class: class-default
QueueID: 136 (Priority 1)
Queue Limit: 16 kbytes Profile: 3 Scale Profile: 0
Policer Profile: 0 (Single)
Conform: 65 kbps (65 kbps) Burst: 1598 bytes (0 Default)
Child Policer Conform: TX
Child Policer Exceed: DROP
Child Policer Violate: DROP
----------------------------------------------------------------------
Level: 1 Policy: child-3play Class: 3play-video
Parent Policy: parent-3play-subscriber-line Class: class-default
QueueID: 137 (Priority 2)
Queue Limit: 8 kbytes (11 Unknown) Profile: 4 Scale Profile: 0
Policer Profile: 24 (Single)
Conform: 128 kbps (128 kbps) Burst: 1598 bytes (0 Default)
Child Policer Conform: TX
Child Policer Exceed: DROP
Child Policer Violate: DROP
WRED Type: COS based Table: 0 Profile: 4 Scale Profile: 0 Curves: 3
Default RED Curve Thresholds Min : 8 kbytes Max: 8 kbytes
WRED Curve: 1 Thresholds Min : 8 kbytes Max: 8 kbytes
 Match: 3
WRED Curve: 2 Thresholds Min : 8 kbytes Max: 8 kbytes
 Match: 4
----------------------------------------------------------------------
Level: 1 Policy: child-3play Class: 3play-premium
Parent Policy: parent-3play-subscriber-line Class: class-default
QueueID: 138 (Priority Normal)
Queue Limit: 2097 kbytes Profile: 2 Scale Profile: 0
WFQ Profile: 6 Committed Weight: 1020 Excess Weight: 1020
Bandwidth: 200000 kbps, BW sum for Level 1: 200000 kbps, Excess Ratio: 1
----------------------------------------------------------------------
Level: 1 Policy: child-3play Class: class-default
Parent Policy: parent-3play-subscriber-line Class: class-default
QueueID: 139 (Priority Normal)
Queue Limit: 65 kbytes Profile: 1 Scale Profile: 3
WFQ Profile: 0 Committed Weight: 1 Excess Weight: 1020
Bandwidth: 0 kbps, BW sum for Level 1: 200000 kbps, Excess Ratio: 1
----------------------------------------------------------------------
  

Related Commands

Command

Description

show qos inconsistency

インターフェイス上の QoS ポリシーの不一致情報を表示します。