Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ ルーティング コマンド リファレンス
Cisco ASR 9000 シリーズ ルータ の RIP コ マンド
Cisco ASR 9000 シリーズ ルータの RIP コマンド
発行日;2012/01/30 | 英語版ドキュメント(2009/11/23 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 19MB) | フィードバック

目次

Cisco ASR 9000 シリーズ ルータの RIP コマンド

auto-summary (RIP)

broadcast-for-v2

clear rip

clear rip database

clear rip interface

clear rip out-of-memory

clear rip statistics

default-information originate (RIP)

default-metric (RIP)

distance (RIP)

interface (RIP)

maximum-paths (RIP)

metric-zero-accept

neighbor (RIP)

nsf (RIP)

output-delay

passive-interface (RIP)

poison-reverse

receive version

redistribute (RIP)

router rip

route-policy (RIP)

send version

show protocols (RIP)

show rip

show rip database

show rip interface

show rip statistics

site-of-origin (RIP)

split-horizon disable (RIP)

timers basic

validate-update-source disable

vrf (RIP)

Cisco ASR 9000 シリーズ ルータの RIP コマンド

このモジュールでは、Cisco ASR 9000 シリーズ ルータ で Routing Information Protocol(RIP)を設定および監視するために使用するコマンドについて説明します。

RIP の概念、設定作業、例の詳細については、『 Cisco ASR 9000 Series Aggregation Services Router Routing Configuration Guide 』の「 Implementing RIP on Cisco ASR 9000 シリーズ ルータ 」モジュールを参照してください。

auto-summary (RIP)

サブネット ルートのネットワーク レベルのルートへの自動サマライズをイネーブルにするには、適切なコンフィギュレーション モードで auto-summary コマンドを使用します。この機能をディセーブルにし、クラスフル ネットワーク境界を越えてサブプレフィクス ルーティング情報を送信するには、このコマンドの no 形式を使用します。

auto-summary

no auto-summary

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ディセーブル

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

auto-summary コマンドは、ツート集約をオンにするために使用します。ルートのサマライズにより、ルーティング テーブル内のルーティング情報の量が削減されます。

切断されたサブネット間でルーティングを行う必要がある場合は、自動サマライズをディセーブルにします。自動サマライズがオフの場合、サブネットがアドバタイズされます。自動サマライズはデフォルトでディセーブルになっています。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、RIP の自動サマライズをオンにする例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# auto-summary

 
関連コマンド

コマンド
説明

vrf (RIP)

VRF インスタンスを定義し、VRF コンフィギュレーション モードに移行します。

broadcast-for-v2

Routing Information Protocol(RIP)バージョン 2 出力パケットをブロードキャスト アドレスに送信するには、適切なコンフィギュレーション モードで broadcast-for-v2 コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

broadcast-for-v2

no broadcast-for-v2

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

RIPv2 出力パケットはブロードキャストされません。

 
コマンド モード

ルータ コンフィグレーション

VRF コンフィギュレーション

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

broadcast-for-v2 コマンドは、RIP バージョン 2 ブロードキャスト アップデートを、マルチキャストを受信しないホストにブロードキャストするために使用します。バージョン 2 アップデート(要求と応答)は、IP マルチキャスト アドレス 244.0.0.9 ではなく、IP ブロードキャスト アドレス 255.255.255.255 に送信されます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、全 RIP インターフェイスで、RIP v2 出力メッセージをブロードキャスト アドレスに送信する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# broadcast-for-v2

clear rip

データベース エントリや統計情報など、Routing Information Protocol(RIP)の VRF およびインターフェイス関連の情報をクリアするには、EXEC モードで clear rip コマンドを使用します。

clear rip [ vrf { vrf | all }]

 
シンタックスの説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

メモリ不足状態が原因でソフトウェアにより強制的に非アクティブ化された RIP VRF とインターフェイスは、 clear rip clear rip interface 、または clear rip out-of-memory コマンドを使用してメモリ不足状態をクリアするまでは、再度アクティブ化されません。

タスク ID

タスク ID
動作

rip

読み取り

次に、RIP 内のすべてのデータベース、インターフェイス、VRF エントリをクリアする例を示します。

RP/0/RSP0/CPU0:router# clear rip vrf all

 
関連コマンド

コマンド
説明

clear rip interface

データベース エントリや統計情報など、RIP のインターフェイス関連の情報をクリアします。

clear rip out-of-memory

RIP のメモリ不足状態をクリアします。

clear rip database

Routing Information Protocol(RIP)トポロジ テーブルからデータベース エントリだけをクリアするには、EXEC モードで clear rip database コマンドを使用します。

clear rip [ vrf { vrf | all }] database [ interface type instance ]

 
シンタックスの説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

interface

(任意)トポロジ エントリをクリアするインターフェイスを指定します。

type

(任意)インターフェイスのタイプ。詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

instance

(任意)物理インターフェイス インスタンスまたは仮想インターフェイス インスタンスのいずれかです。

物理インターフェイス インスタンス。命名規則は、 rack/slot/module/port です。値の間のスラッシュ記号は表記の一部として必要です。

rack :ラックのシャーシ番号。

slot :ライン カードの物理スロット番号。

module :モジュール番号。物理レイヤ インターフェイス モジュール(PLIM)は常に 0 です。

port :インターフェイスの物理ポート番号。

仮想インターフェイス インスタンス。番号の範囲は、インターフェイス タイプにより異なります。

ルータの構文の詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、GigabitEthernet 0/1/0/0 インターフェイスのトポロジ テーブルのデータベース エントリだけをクリアする例を示します。

RP/0/RSP0/CPU0:router# clear rip database interface GigabitEthernet 0/1/0/0

 
関連コマンド

コマンド
説明

show rip statistics

RIP プロセスのデータベースおよびインターフェイス エントリ情報を表示します。

clear rip interface

データベース エントリや統計情報など、Routing Information Protocol(RIP)のインターフェイス関連の情報をクリアするには、EXEC モードで clear rip interface コマンドを使用します。

clear rip [ vrf { vrf | all }] interface type instance

 
シンタックスの説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

メモリ不足状態が原因でソフトウェアにより強制的に非アクティブ化された RIP VRF とインターフェイスは、 clear rip clear rip interface 、または c lear rip out-of-memory コマンドを使用してメモリ不足状態をクリアするまでは、再度アクティブ化されません。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、ルートや統計情報などのインターフェイス関連のデータすべてを GigabitEthernet0/1/0/0 インターフェイスからクリアする例を示します。

RP/0/RSP0/CPU0:router# clear rip vrf vpn-1 interface GigabitEthernet 0/1/0/0

 
関連コマンド

コマンド
説明

clear rip

データベース エントリや統計情報など、RIP の VRF およびインターフェイス関連の情報をクリアします。

clear rip out-of-memory

RIP のメモリ不足状態をクリアします。

clear rip out-of-memory

Routing Information Protocol(RIP)のメモリ不足状態をクリアするには、EXEC モードで clear rip out-of-memory コマンドを使用します。

clear rip [ vrf { vrf | all }] out-of-memory [ interface type instance ]

 
シンタックスの説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

interface

(任意)トポロジ エントリをクリアするインターフェイスを指定します。

type

(任意)インターフェイスのタイプ。詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

instance

(任意)物理インターフェイス インスタンスまたは仮想インターフェイス インスタンスのいずれかです。

物理インターフェイス インスタンス。命名規則は、 rack/slot/module/port です。値の間のスラッシュ記号は表記の一部として必要です。

rack :ラックのシャーシ番号。

slot :ライン カードの物理スロット番号。

module :モジュール番号。物理レイヤ インターフェイス モジュール(PLIM)は常に 0 です。

port :インターフェイスの物理ポート番号。

仮想インターフェイス インスタンス。番号の範囲は、インターフェイス タイプにより異なります。

ルータの構文の詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

clear rip out-of-memory コマンドは、メモリ不足状態をすべてクリアし、RIP プロセスが VRF またはインターフェイスを必要に応じてシャットダウンできるようにするために使用します。

ルータでメモリが不足し始めると、RIP プロセスは、Normal、Minor、Severe、Critical として定義される各メモリ状態の間を遷移します。

Normal 状態では、RIP VRF とインターフェイスは正常に機能します。

Minor 状態では、現在アクティブな RIP VRF とインターフェイスはアクティブなままになります。現在アクティブでない VRF とインターフェイスは、RIP プロセスが Normal 状態に遷移するまでアクティブになることができません。

Severe 状態では、RIP プロセスが別の状態に遷移するまで、いくつかの VRF とインターフェイスが強制的にダウン状態にされます。

Critical 状態では、RIP プロセスが強制的にシャットダウンされます。

Severe 状態で強制的にシャットダウンされた VRF とインターフェイスは、RIP プロセスが Minor 状態または Normal 状態に遷移しても、自動的にアクティブ化されません。Severe 状態で VRF またはインターフェイスが強制的にダウン状態にされた場合、 clear rip clear rip interface 、または clear rip out-of-memory コマンドを実行すると Forced Down 状態がクリアされ、VRF またはインターフェイスが再度アクティブ化されます。

show rip コマンドおよび show rip interface コマンドを使用すると、現在のメモリ不足状態を表示できます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、RIP プロセスのメモリ不足状態をクリアする例を示します。

RP/0/RSP0/CPU0:router# clear rip out-of-memory

 
関連コマンド

clear rip

データベース エントリや統計情報など、RIP の VRF およびインターフェイス関連の情報をクリアします。

clear rip interface

データベース エントリや統計情報など、RIP のインターフェイス関連の情報をクリアします。

show rip

RIP の設定とステータスを表示します。

show rip interface

RIP トポロジ テーブルのインターフェイス エントリ情報を表示します。

clear rip statistics

Routing Information Protocol(RIP)統計情報をクリアするには、EXEC モードで clear rip statistics コマンドを使用します。

clear rip [vrf {vrf | all}] statistics [ interface type instance ]

 
シンタックスの説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

interface

(任意)トポロジ エントリをクリアするインターフェイスを指定します。

type

(任意)インターフェイスのタイプ。詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

instance

(任意)物理インターフェイス インスタンスまたは仮想インターフェイス インスタンスのいずれかです。

物理インターフェイス インスタンス。命名規則は、 rack/slot/module/port です。値の間のスラッシュ記号は表記の一部として必要です。

rack :ラックのシャーシ番号。

slot :ライン カードの物理スロット番号。

module :モジュール番号。物理レイヤ インターフェイス モジュール(PLIM)は常に 0 です。

port :インターフェイスの物理ポート番号。

仮想インターフェイス インスタンス。番号の範囲は、インターフェイス タイプにより異なります。

ルータの構文の詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、すべての RIP 統計情報をクリアする例を示します。

RP/0/RSP0/CPU0:router# clear rip statistics

 
関連コマンド

コマンド
説明

show rip statistics

RIP プロセスのデータベースおよびインターフェイス エントリ情報を表示します。

default-information originate (RIP)

Routing Information Protocol(RIP)にデフォルト ルートを生成するには、適切なコンフィギュレーション モードで default-information originate コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

default-information originate [ route-policy name ]

no default-information originate

 
シンタックスの説明

route-policy name

デフォルト ルートの基準を指定するルート ポリシー

 
デフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、ルーティング テーブルに対してルート ポリシーを実行した結果に基づき、RIP アップデートでデフォルト ルートを開始する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# default-information originate route-policy policy1

 
関連コマンド

コマンド
説明

route-policy (RIP)

RIP ネイバにアドバタイズするアップデートや、RIP ネイバから受信するアップデートに、ルーティング ポリシーを適用します。

default-metric (RIP)

他のプロトコルから Routing Information Protocol(RIP)に再配布されるルートのデフォルト メトリック値を設定するには、適切なコンフィギュレーション モードで default-metric コマンドを使用します。デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

default-metric number-value

no default-metric

 
シンタックスの説明

number-value

デフォルト メトリック値。範囲は 1 ~ 15 です。

 
デフォルト

デフォルト メトリックは設定されていません。

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

RIP ですべての再配布ルートに同じメトリック値を使用するには、 default-metric コマンドを redistribute コマンドとともに使用します。デフォルト メトリックを使用すると、妥当な代替メトリックを設定し、再配布を可能にすることで、互換性のないメトリックを使用したルートを再配布するという問題を解決することができます。再配布される他のプロトコルに対して異なるメトリックを設定する場合は、 redistribute コマンドで route-policy オプションを使用します。

再配布されるルートで使用される RIP メトリックは、ルート ポリシーによって決まります。ルート ポリシーが設定されていないか、ルート ポリシーで RIP メトリックが設定されていない場合は、再配布されるプロトコルに基づいてメトリックが決定されます。BGP によって再配布される VPNv4 ルートの場合、リモート PE ルータで設定された RIP メトリックが有効であれば、それが使用されます。

その他すべての場合(BGP、IS-IS、OSPF、EIGRP、接続済み、スタティック)、 default-metric コマンドで設定されたメトリックが使用されます。有効なメトリックが決定できない場合、再配布は起こりません。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、自律システム 109 がルーティング プロトコル RIP と Open Shortest Path First(OSPF; オープン ショーテスト パス ファースト)の両方を使用する例を示します。この例は、OSPF から取得したルートを RIP を使用してアドバタイズし、OSPF から取得したルートに RIP メトリック 10 を割り当てます。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
RP/0/RSP0/CPU0:router(config-rip-vrf)# default-metric 10
RP/0/RSP0/CPU0:router(config-rip-vrf)# redistribute ospf 109

 
関連コマンド

コマンド
説明

redistribute (RIP)

あるルーティング ドメインから RIP にルートを再配布します。

distance (RIP)

Routing Information Protocol(RIP)によって検出されたルートに割り当てるアドミニストレーティブ ディスタンスを定義するには、適切なコンフィギュレーションモードで distance admin-distance コマンドを使用します。コンフィギュレーション ファイルから距離の定義を削除し、システムをデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

distance admin-distance [ prefix prefix-length | prefix mask ]

no distance admin-distance

 
シンタックスの説明

admin-distance

RIP ルートに割り当てるアドミニストレーティブ ディスタンス。範囲は 0 ~ 255 です。

prefix

(任意)ルーティング情報が表示されるネットワーク IP アドレス。

prefix-length

(任意) prefix-length 引数は、IP プレフィクスの長さを指定します。これは、プレフィクス(アドレスのネットワーク部)を構成するアドレスの上位隣接ビット数を示す 10 進数値です。10 進数値の前にスラッシュを付ける必要があります。IPv4 アドレスの場合の範囲は 0 ~ 32 です。

mask

(任意)次の 2 つの方法のうちいずれかで指定されるネットワーク マスク。

4 分割ドット付き 10 進表記のアドレスでネットワーク マスクを指定します。たとえば、255.0.0.0 の場合、各ビットが 1 のときに対応するアドレス ビットがネットワーク アドレスであることを示します。

ネットワーク マスクは、スラッシュ(/)と数字で表すことができます。たとえば、/8 は、マスクの最初の 8 ビットが 1 であり、アドレスの対応するビットがネットワーク アドレスであることを示します。

 
デフォルト

admin-distance :120

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

distance コマンドは、他のプロトコルのルートよりも RIP ルートを優先するように変更するために使用します。アドミニストレーティブ ディスタンスと再配布機能を同時に使用する場合は、RIP ネイバから受け取るルートや RIP ネイバにアドバタイズするルートに対する振る舞いが影響を受ける可能性があります。

アドミニストレーティブ ディスタンスは、0 ~ 255 の範囲の整数です。一般に、値が大きいほど、信頼性は低くなります。アドミニストレーティブ ディスタンス 255 は、ルーティング情報の情報源がまったく信頼できず、無視すべきであることを意味します。

distance コマンドを実行する順序は、割り当てられるアドミニストレーティブ ディスタンスに予期せぬ方法で影響を与える可能性があります。

表 154 に、デフォルトのアドミニストレーティブ ディスタンスをリストします。

 

表 154 各ルーティング プロトコルのデフォルトのアドミニストレーティブ ディスタンス

ルーティング プロトコル
アドミニストレーティブ ディスタンスの値

接続されたインターフェイス

0

インターフェイスから出るスタティック ルート

0

ネクストホップへのスタティック ルート

1

EIGRP サマリー ルート

5

外部 BGP

20

内部 EIGRP

90

OSPF

110

IS-IS

115

RIP バージョン 1 および 2

120

外部 EIGRP

170

内部 BGP

200

不明

255

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、特定のプレフィクスに対してアドミニストレーティブ ディスタンスを設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# distance 85 192.168.10.0/24

 
関連コマンド

コマンド
説明

redistribute (RIP)

あるルーティング ドメインから RIP にルートを再配布します。

interface (RIP)

Routing Information Protocol(RIP)が動作するインターフェイスを定義し、インターフェイス コンフィギュレーション モードに移行するには、ルータ コンフィギュレーション モードで interface コマンドを使用します。インターフェイスで RIP ルーティングをディセーブルにするには、このコマンドの no 形式を使用します。

interface type instance

no interface type instance

 
シンタックスの説明

type

インターフェイスのタイプ。詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

instance

物理インターフェイス インスタンスまたは仮想インターフェイス インスタンスのいずれかです。

物理インターフェイス インスタンス。命名規則は、 rack/slot/module/port です。値の間のスラッシュ記号は表記の一部として必要です。

rack :ラックのシャーシ番号。

slot :ライン カードの物理スロット番号。

module :モジュール番号。物理レイヤ インターフェイス モジュール(PLIM)は常に 0 です。

port :インターフェイスの物理ポート番号。

仮想インターフェイス インスタンス。番号の範囲は、インターフェイス タイプにより異なります。

ルータの構文の詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

 
デフォルト

このコマンドをコンフィギュレーション モードで指定しない場合、インターフェイスに対する RIP ルーティングはイネーブルになりません。

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

interface コマンドは、特定のインターフェイスを RIP プロセスに関連付けるために使用します。インターフェイスの IPv4 アドレスが変更された場合でも、インターフェイスがプロセスに関連付けされた状態は変わりません。

このコマンドを使用すると、ルータをインターフェイス コンフィギュレーション モードにします。このモードから、インターフェイス固有の設定を実行できます。このモードで設定したコマンド( broadcast-for-v2 コマンドなど)は、そのインターフェイスに自動的にバインドされます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、RIP プロセスのインターフェイス コンフィギュレーション モードに移行し、GigabitEthernet インターフェイス 0/1/0/0 上で RIP バージョン 2 メッセージをブロードキャスト アドレスに送信する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-rip-if)# ?
 
broadcast-for-v2 Specify broadcast address for RIP v2 output packet
commit Commit the configuration changes to running
describe Describe a command without taking real actions
do Run an exec command
exit Exit from this submode
metric-zero-accept Accept rip update with metric 0 to compensate a common bug
no Negate a command or set its defaults
passive-interface Suppress routing updates on this interface
poison-reverse Enable poison reverse
receive Advertisement reception
route-policy Apply route policy to routing updates
send Advertisement transmission
show Show contents of configuration
site-of-origin SOO community for prefixes learned over this interface
split-horizon Disable split horizon
RP/0/RSP0/CPU0:router(config-rip-if)# broadcast-for-v2

 
関連コマンド

コマンド
説明

broadcast-for-v2

RIP バージョン 2 出力パケットをブロードキャスト アドレスに送信します。

maximum-paths (RIP)

Routing Information Protocol(RIP)がルーティング テーブルに追加する等コスト パラレル ルートの最大数を設定するには、適切なコンフィギュレーション モードで maximum-paths コマンドを使用します。コンフィギュレーション ファイルから maximum-paths コマンドを削除し、システムを RIP に関してデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum-paths

 
シンタックスの説明

maximum

RIP がルーティング テーブルに追加できるパラレル ルートの最大数。Cisco ASR 9000 シリーズ ルータ の場合、範囲は 1 ~ 32 です。

 
デフォルト

4 パス

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、1 つの宛先に最大 16 個の等コスト パスを許可する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# maximum-paths 16

metric-zero-accept

RIP で、メトリックにゼロ(0)が設定された RIP アップデートからのルーティング エントリを受け付けるようにするには、インターフェイス コンフィギュレーション モードで metric-zero-accept コマンドを使用します。コンフィギュレーション ファイルから metric-zero-accept コマンドを削除し、システムを RIP に関してデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

metric-zero-accept

no metric-zero-accept

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

メトリック ゼロ(0)で受信した RIP ルートは無視されます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

RIP アップデートで受信したルーティング エントリに対して metric-zero-accept コマンドを設定した後、RIP はこれらのルートを受け付け、メトリックに 1 を設定します。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、メトリックがゼロのルーティング エントリを受け付けるように RIP インターフェイスを設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-rip-if)# metro-zero-accept

neighbor (RIP)

Routing Information Protocol(RIP)情報を交換するネイバ ルータを定義するには、適切なコンフィギュレーション モードで neighbor コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

neighbor ip-address

no neighbor ip-address

 
シンタックスの説明

ip-address

ルーティング情報を交換するピア ルータの IP アドレス

 
デフォルト

ネイバ ルータは定義されません。

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

ルーティング情報のポイントツーポイント(非ブロードキャスト)交換を許可するには、 neighbor コマンドを使用します。ルータ コンフィギュレーション モードで、 neighbor コマンドを passive-interface コマンドとともに使用すると、ルータのサブセットと LAN 上のアクセス サーバの間でルーティング情報を交換できます。

複数の neighbor コマンドを使用して、他のネイバまたはピアを指定できます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、特定のネイバに対する RIP アップデートの送信を許可する例を示します。1 つのネイバにつきアップデートのコピーが 1 つ生成されます。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
RP/0/RSP0/CPU0:router(config-rip-vrf)# neighbor 172.16.1.2

 
関連コマンド

コマンド
説明

passive-interface (RIP)

インターフェイス上での RIP アップデートの送信を抑止します。

nsf (RIP)

Routing Information Protocol(RIP)プロセスのシャットダウンまたは再起動後に RIP ルート上の Nonstop Forwarding(NSF; ノンストップ フォワーディング)を設定するには、適切なコンフィギュレーション モードで nsf コマンドを使用します。コンフィギュレーション ファイルからこのコマンドを削除し、システムをデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

nsf

no nsf

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

NSF はディセーブルです。

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

nsf コマンドを使用した場合、NSF ライフタイムがアップデート時間の 2 倍に自動的に設定されます(最小値は 60 秒)。RIP プロセスは、この時間に再コンバージする必要があります。コンバージェンスが NSF ライフタイムを超える場合、ルートは Routing Information Base(RIB; ルーティング情報ベース)から除去され、NSF が失敗することがあります。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、RIP NSF を設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
RP/0/RSP0/CPU0:router(config-rip-vrf)# nsf

output-delay

送信する Routing Information Protocol(RIP)アップデートのパケット間遅延を変更するには、適切なコンフィギュレーションモードで output-delay コマンドを使用します。遅延を削除するには、このコマンドの no 形式を使用します。

output-delay delay

no output-delay delay

 
シンタックスの説明

delay

複数パケット RIP アップデートにおけるパケット間の遅延(ミリ秒単位)。有効な範囲は、8 ~ 50 です。

 
デフォルト

デフォルトは遅延なしです。

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

output-delay コマンドは、高速な受信ができない可能性がある低速なルータに高速に送信する場合に使用します。このコマンドを設定すると、ルーティング テーブルから情報が失われることを防ぐことができます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、パケット間遅延を 10 ミリ秒に設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
RP/0/RSP0/CPU0:router(config-rip-vrf)# output-delay 10

passive-interface (RIP)

インターフェイス上で Routing Information Protocol(RIP)アップデートの送信を抑止するには、インターフェイス コンフィギュレーション モードで passive-interface コマンドを使用します。アップデートの抑止を解除するには、このコマンドの no 形式を使用します。

passive-interface

no passive-interface

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

RIP アップデートはインターフェイス上で送信されます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

受動インターフェイス上でルーティング アップデートのマルチキャスト(またはブロードキャスト)アドレスへの送信が停止されている間も、そのインターフェイス上でのネイバからのルーティング アップデートの受信と処理は続行されます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、GigabitEthernet インターフェイス 0/1/0/0 で RIP アップデートのマルチキャスト(またはブロードキャスト)を停止する例を示します。RIP アップデートの受信は正常に続行されます。GigabitEthernet インターフェイス 0/1/0/3 は、正常にアップデートを送受信します。また、RIP アップデートは適切なインターフェイス上でネイバ 172.168.1.2 にユニキャストされます。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# neighbor 172.16.1.2
RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-rip-if)# passive-interface
RP/0/RSP0/CPU0:router(config-rip-if)# exit
RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/3
RP/0/RSP0/CPU0:router(config-rip-if)# exit

 
関連コマンド

コマンド
説明

neighbor (RIP)

RIP プロトコル情報を交換するネイバ ルータを定義します。

poison-reverse

Routing Information Protocol(RIP)ルート アップデートのポイズン リバース処理をイネーブルにするには、インターフェイス コンフィギュレーション モードで poison-reverse コマンドを使用します。RIP アップデートのポイズン リバース処理をディセーブルにするには、このコマンドの no 形式を使用します。

poison-reverse

no poison-reverse

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ポイズン リバース処理はディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

poison-reverse コマンドは、RIP ルータ アップデートのポイズン リバース処理をイネーブルにするために使用します。システム デフォルトでは、RIP を通じて学習したルートは、それを学習したインターフェイスからアドバタイズされません(スプリット ホライズン)。ポイズン リバースとスプリット ホライズンの両方が設定されている場合、単純なスプリット ホライズン動作(ルートを学習したインターフェイスからのそのルートの抑止)がポイズン リバース動作で置き換えられます。スプリット ホライズンがディセーブルの場合、ポイズン リバースの設定は無視されます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、RIP が動作するインターフェイスでポイズン リバース処理をイネーブルにする例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-rip-if)# poison-reverse

 
関連コマンド

コマンド
説明

split-horizon disable (RIP)

スプリット ホライズン メカニズムをディセーブルにします。

receive version

バージョン固有のパケットを受け付けるように Routing Information Protocol(RIP)インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで receive version コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

receive version { 1 | 2 | 1 2 }

no receive version { 1 | 2 | 1 2 }

 
シンタックスの説明

1

バージョン 1 のパケット

2

バージョン 2 のパケット

1 2

バージョン 1 と 2 のパケット

 
デフォルト

バージョン 2

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

receive version コマンドは、RIP のデフォルトの動作を変更するために使用します。このコマンドは、設定中のインターフェイスだけに適用されます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、RIP バージョン 1 と 2 のパケットを受け付けるようにインターフェイスを設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-rip-if)# receive version 1 2

 
関連コマンド

コマンド
説明

send version

バージョン固有のパケットを送信するように RIP インターフェイスを設定します。

redistribute (RIP)

別のルーティング ドメインから受け取ったルートを Routing Information Protocol(RIP)に再配布するには、適切なコンフィギュレーション モードで redistribute コマンドを使用します。コンフィギュレーション ファイルから redistribute コマンドを除去し、ソフトウェアがルートを再配布しないデフォルトの状態にシステムを戻すには、このコマンドの no 形式を使用します。

ボーダー ゲートウェイ プロトコル(BGP)

redistribute bgp process-id [ route-policy name ] [ external | internal | local ]

no redistribute bgp process-id

接続されたインターフェイス ルート

redistribute connected [ route-policy name ]

no redistribute connected

Enhanced Interior Gateway Routing Protocol(EIGRP)

redistribute eigrp process-id [ route-policy name ]

no redistribute eigrp process-id

Intermediate System-to-Intermediate System(ISIS)

redistribute isis process-id [ route-policy name ] [ level-1 | level-1-2 | level-2 ]

no redistribute isis process-id

Open Shortest Path First(OSPF)

redistribute ospf process-id [ route-policy name ] [ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ]}]

no redistribute ospf process-id

IP スタティック ルート

redistribute static [ route-policy name ]

no redistribute static

 
シンタックスの説明

bgp

BGP プロトコルからのルートを配布します。

process-id

bgp キーワードを指定した場合、自律システム番号。2 バイトの番号の範囲は 1 ~ 65535 です。4 バイトの番号の範囲は 1.0 ~ 65535.65535 です。

eigrp キーワードの場合は、ルートの再配布元である EIGRP インスタンスの名前です。値の形式はストリングです。10 進数値を入力できますが、内部的にはストリングとして格納されます。

isis キーワードの場合は、ルートの再配布元である IS-IS インスタンスの名前です。値の形式はストリングです。10 進数値を入力できますが、内部的にはストリングとして格納されます。

ospf キーワードの場合は、ルートの再配布元である OSPF インスタンスの名前です。値の形式はストリングです。10 進数値を入力できますが、内部的にはストリングとして格納されます。

external

(任意)BGP 外部ルートだけを指定します。

internal

(任意)BGP 内部ルートだけを指定します。

local

(任意)BGP ローカル ルートだけを指定します。

route-policy name

(任意)設定されたポリシーの ID を指定します。ポリシーは、このソース ルーティング プロトコルから RIP へのルートのインポートをフィルタするために使用されます。

level-1

(任意)レベル 1 IS-IS ルートだけを他のルーティング プロトコルに再配布します。

level-1-2

(任意)レベル 1 とレベル 2 の IS-IS ルートを他のルーティング プロトコルに配布します。

level-2

(任意)レベル 2 IS-IS ルートをだけを他のルーティング プロトコルに配布します。

[ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ]]} [ route-policy name ]

(任意)OSPF ルートを他のルーティング ドメインに再配布する条件を指定します。次の 1 つ以上の条件を指定できます。

internal :特定の自律システム内部のルート(エリア内およびエリア間の OSPF ルート)。

external [ 1 | 2 ]:自律システム外部のルートである一方で、タイプ 1 またはタイプ 2 の外部ルートとして OSPF にインポートされているルート。

nssa-external [ 1 | 2 ]:自律システム外部のルートである一方で、タイプ 1 またはタイプ 2 の Not-So-Stubby Area(NSSA)外部ルートとして OSPF にインポートされているルート。

external および nssa-external オプションでタイプを指定しなかった場合は、タイプ 1 とタイプ 2 の両方であると想定されます。

match が指定されていない場合、デフォルトはフィルタリングなしとなります。

static

IP スタティック ルートを再配布します。

 
デフォルト

ルートの再配布はディセーブルです。

 
コマンド モード

ルータ コンフィギュレーション

VRF コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。


) 属性とルート ポリシーを設定または一致させるための両方のコマンド キーワードを使用して、ルートを RIP に再配布する場合、ルートにまずルート ポリシーが適用され、その後キーワード照合と設定が行われます。


再配布されたルーティング情報は、 route-policy name キーワードと引数でフィルタできます。このフィルタリングにより、管理者が意図したルートだけが RIP によって再配布されます。

再配布されるルートで使用される RIP メトリックは、ルート ポリシーによって決まります。ルート ポリシーが設定されていないか、ルート ポリシーで RIP メトリックが設定されていない場合は、再配布されるプロトコルに基づいてメトリックが決定されます。BGP によって再配布される VPNv4 ルートの場合、リモート PE ルータで設定された RIP メトリックが有効であれば、それが使用されます。

その他すべての場合(BGP、IS-IS、OSPF、EIGRP、接続済み、スタティック)、 default-metric コマンドで設定されたメトリックが使用されます。有効なメトリックが決定できない場合、再配布は起こりません。

ルーティング ポリシーの詳細については、『 Cisco ASR 9000 Series Aggregation Services Router Routing Command Reference 』の「 Routing Policy Commands on Cisco ASR 9000 シリーズ ルータ 」モジュールを参照してください。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、BGP ルートを RIP プロセスに再配布する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# redistribute bgp 100

 
関連コマンド

コマンド
説明

default-metric (RIP)

他のプロトコルから RIP に再配布されるルートのデフォルト メトリック値を設定します。

router rip

ルーティング プロセスを設定し、Routing Information Protocol(RIP)プロセス用のルータ コンフィギュレーション モードに移行するには、グローバル コンフィギュレーション モードで router rip コマンドを使用します。RIP ルーティング プロセスをオフにするには、このコマンドの no 形式を使用します。

router rip

no router rip

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ルータ プロセスは定義されていません。

 
コマンド モード

グローバル

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、RIP のルータ プロセスを設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)#
 

次に、RIP 用のルータ コンフィギュレーション モードに移行し、そのモードで実行できるコマンドの一覧を表示する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# ?
 
auto-summary Enable automatic network number summarization
broadcast-for-v2 Send RIP v2 output packets to broadcast address
commit Commit the configuration changes to running
default-information Control distribution of default information
default-metric Set metric of redistributed routes
describe Describe a command without taking real actions
distance Define an administrative distance
do Run an exec command
exit Exit from this submode
interface Enter the RIP interface configuration submode
maximum-paths Maximum number of paths allowed per route
neighbor Specify a neighbor router
no Negate a command or set its defaults
nsf Enable Cisco Non Stop Forwarding
output-delay Interpacket delay for RIP updates
redistribute Redistribute information from another routing protocol
route-policy Apply route policy to routing updates
show Show contents of configuration
timers Adjust routing timers
validate-update-source Validate source address of routing updates
vrf Enter the RIP vrf configuration submode
RP/0/RSP0/CPU0:router(config-rip)#

route-policy (RIP)

Routing Information Protocol(RIP)ネイバにアドバタイズするアップデートや、RIP ネイバから受信するアップデートにルーティング ポリシーを適用するには、適切なコンフィギュレーション モードで route-policy コマンドを使用します。ルーティング ポリシーのアップデートへの適用をディセーブルにするには、このコマンドの no 形式を使用します。

route-policy name { in | out }

no route-policy name { in | out }

 
シンタックスの説明

name

ルート ポリシーの名前。

in

ポリシーを着信ルートに適用します。

out

ポリシーを発信ルートに適用します。

 
デフォルト

ポリシーは適用されません。

 
コマンド モード

ルータ コンフィグレーション

VRF コンフィギュレーション

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

着信ルートまたは発信ルートのルーティング ポリシーを指定するには、 route-policy コマンドを使用します。ポリシーを使用すると、ルートのフィルタリングやルート属性の変更ができます。


) ルート ポリシーがインターフェイスと VRF の両方に設定されている場合、インターフェイス ルート ポリシーが適用されます。


タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、インターフェイス上で受信したルーティング アップデートをフィルタする例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-rip-if)# route-policy updpol-1 in

send version

バージョン固有のパケットを送信するように Routing Information Protocol(RIP)インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで send version コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

send version { 1 | 2 | 1 2 }

no send version { 1 | 2 | 1 2 }

 
シンタックスの説明

1

バージョン 1 のパケット

2

バージョン 2 のパケット

1 2

バージョン 1 とバージョン 2 のパケット

 
デフォルト

バージョン 2

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

send version コマンドは、RIP のデフォルトの動作を変更するために使用します。このコマンドは、設定中のインターフェイスだけに適用されます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、RIP バージョン 2 のパケットだけを送信するようにインターフェイスを設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-rip-if)# send version 2
 

 
関連コマンド

コマンド
説明

receive version

バージョン固有のパケットを受け付けるように RIP インターフェイスを設定します。

show protocols (RIP)

Routing Information Protocol(RIP)プロセスの設定に関する情報を表示するには、EXEC モードで show protocols コマンドを使用します。

show protocols [ ipv4 | afi-all ] [ all | protocol ] [ default-context | vrf vrf-name ] [ private ]

 
シンタックスの説明

ipv4

(任意)IPv4 アドレス ファミリを指定します。

afi-all

(任意)すべてのアドレス ファミリを指定します。

all

(任意)指定されたアドレス ファミリのすべてのプロトコルを指定します。

protocol

(任意)ルーティング プロトコルを指定します。

IPv4 アドレス ファミリの場合、オプションは eigrp bgp isis ospf 、および rip です。

default-context

(任意)デフォルト コンテキスト情報を表示します。このキーワードは、 eigrp または rip のプロトコルを指定した場合に使用できます。

vrf vrf-name

(任意)指定されたプロセスの VPN ルーティング/転送(VRF)情報を表示します。このキーワードは、 eigrp または rip のプロトコルを指定した場合に使用できます。

private

(任意)プライベート EIGRP データを表示します。このキーワードは、 eigrp を指定した場合に使用できます。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

ルータ上で実行中のプロトコルに関する情報を取得して、どのプロトコルがアクティブであるかを迅速に判断するには、 show protocols コマンドを使用します。このコマンドは、実行しているプロトコルの重要な特定を要約するために設計されていて、コマンドの出力は選択した特定のプロトコルによって異なります。

RIP の場合、コマンド出力には、インスタンス番号、デフォルト AS コンテキスト、ルータ ID、デフォルト ネットワーク、距離、最大パスなどが表示されます。

タスク ID

タスク ID
動作

RIP

読み取り

次に、 show protocols rip コマンドの出力例を示します。

RP/0/RSP0/CPU0:router# show protocols rip
Routing Protocol RIP
2 VRFs (including default) configured, 2 active
25 routes, 16 paths have been allocated
Current OOM state is "Normal"
UDP socket descriptor is 37
VRF Active If-config If-active Routes Paths Updates
default Active 3 3 11 7 30s
 

表 155 で、これらの出力に表示される重要なフィールドについて説明します。

 

フィールド
説明

VRFs configured

設定されている VRF の数

VRFs active

アクティブな VRF の数

Routes

割り当てられているルートの数

Paths

割り当てられているパスの数

OOM state

RIP プロセスの現在のメモリ不足状態

UDP socket

現在の UDP ソケット記述子の値

show rip

Routing Information Protocol(RIP)の設定とステータスを表示するには、EXEC モードで show rip コマンドを使用します。

show rip [ vrf { vrf | all }]

 
シンタックスの説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

タスク ID

タスク ID
動作

rip

読み取り

次に、 show rip コマンドの出力例を示します。

RP/0/RSP0/CPU0:router# show rip
 
RIP config:
Active?: Yes
Added to socket?: Yes
Out-of-memory state: Normal
Version: 2
Default metric: Not set
Maximum paths: 4
Auto summarize?: No
Broadcast for V2?: No
Packet source validation?: Yes
NSF: Disabled
Timers: Update: 30 seconds (25 seconds until next update)
Invalid: 180 seconds
Holddown: 180 seconds
Flush: 240 seconds
RP/0/RSP0/CPU0:router#
 

表 155 で、これらの出力に表示される重要なフィールドについて説明します。

 

表 155 show rip のフィールドの説明

フィールド
説明

Active?

アクティブ状態設定。

Added to socket?

RIP が設定されたインターフェイス上のマルチキャスト グループ設定。yes の場合、これらのインターフェイス上でアップデートが受信されます。

Out-of-memory state

RIP のメモリ不足状態には、Normal、Minor、Severe、Critical があります。

Version

バージョン番号は 2 です。

Default metric

デフォルト メトリック値(設定されている場合)。設定されていない場合、Not set になります。

Maximum paths

1 つの RIP ルートに許可される最大パス数。

Auto summarize?

自動サマライズ状態設定。

Broadcast for V2?

RIP バージョン 2 ブロードキャスト設定。

Packet source validation?

RIP への受信ルーティング アップデートの送信元 IP アドレスの検証設定。

Timers

RIP ネットワーク タイマー設定。

show rip database

Routing Information Protocol(RIP)トポロジ テーブルのデータベース エントリ情報を表示するには、EXEC モードで show rip database コマンドを使用します。

show rip [ vrf { vrf | all }] database [ prefix prefix-length | prefix mask ]

 
シンタックスの説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

prefix

(任意)ルーティング情報が表示されるネットワーク IP アドレス。

prefix-length

(任意) prefix-length 引数は、IP プレフィクスの長さを指定します。これは、プレフィクス(アドレスのネットワーク部)を構成するアドレスの上位隣接ビット数を示す 10 進数値です。10 進数値の前にスラッシュ記号を付ける必要があります。IPv4 アドレスの場合の範囲は 0 ~ 32 です。

mask

(任意)次の 2 つの方法のうちいずれかで指定されるネットワーク マスク。

4 分割ドット付き 10 進表記のアドレスでネットワーク マスクを指定します。たとえば、255.0.0.0 の場合、各ビットが 1 のときに対応するアドレス ビットがネットワーク アドレスであることを示します。

ネットワーク マスクは、スラッシュ(/)と数字で表すことができます。たとえば、/8 は、マスクの最初の 8 ビットが 1 であり、アドレスの対応するビットがネットワーク アドレスであることを示します。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

サマリー アドレス エントリは、関連する子ルートが要約される場合にだけデータベースに現れます。サマリー アドレスの最後の子ルートが無効になると、サマリー アドレスもルーティング テーブルから削除されます。

タスク ID

タスク ID
動作

rip

読み取り

次に、 show rip database コマンドの出力例を示します。

RP/0/RSP0/CPU0:router# show rip database
 
Routes held in RIP's topology database:
10.0.0.0/24
[0] directly connected, GigabitEthernet0/6/0/0
10.0.0.0/8 auto-summary
12.0.0.0/24
[5] distance: 20 redistributed
12.0.0.0/8 auto-summary
50.50.0.0/24
[1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0
50.50.1.0/24 (inactive)
[1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0
50.0.0.0/8 auto-summary
90.90.0.0/24
[5] distance: 20 redistributed
90.90.1.0/24
[5] distance: 20 redistributed
 

表 156 で、これらの出力に表示される重要なフィールドについて説明します。

 

表 156 show rip database のフィールドの説明

フィールド
説明

10.0.0.0/24

[0] directly connected, GigabitEthernet0/6/0/0

RIP で接続されたルートのプレフィクスとプレフィクス長。

10.0.0.0/24 は GigabitEthernet 0/6/0/0 に直接接続されています。[0]はメトリックを表します。

10.0.0.0/8 auto-summary

10.0.0.0/8 は自動サマリー エントリです。

12.0.0.0/24

[5] distance: 20 redistributed

12.0.0.0/24 は再配布されるルートです。メトリックは 5 で、距離は 20 です。

50.50.0.0/24

[1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0

宛先ルート 50.50.0.0/24 が RIP を通じて学習され、ソース 10.0.0.20 が GigabitEthernet 0/6/0/0 からそれをアドバタイズしました。ルートが最後に更新されたのは 1 秒前です。

50.50.1.0/24 (inactive)

[1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0

宛先ルート 50.50.1.0/24 はルーティング テーブルでアクティブではありません。

show rip interface

Routing Information Protocol(RIP)トポロジ テーブルのインターフェイス エントリ情報を表示するには、EXEC モードで show rip interface コマンドを使用します。

show rip [ vrf { vrf | all }] interface [ type instance ]

 
シンタックスの説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

type

(任意)インターフェイスのタイプ。詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

instance

(任意)物理インターフェイス インスタンスまたは仮想インターフェイス インスタンスのいずれかです。

物理インターフェイス インスタンス。命名規則は、 rack/slot/module/port です。値の間のスラッシュ記号は表記の一部として必要です。

rack :ラックのシャーシ番号。

slot :ライン カードの物理スロット番号。

module :モジュール番号。物理レイヤ インターフェイス モジュール(PLIM)は常に 0 です。

port :インターフェイスの物理ポート番号。

仮想インターフェイス インスタンス。番号の範囲は、インターフェイス タイプにより異なります。

ルータの構文の詳細については、疑問符( ? )オンライン ヘルプ機能を使用してください。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

タスク ID

タスク ID
動作

rip

読み取り

次に、 show rip interface コマンドの出力例を示します。

RP/0/RSP0/CPU0:router# show rip interface
 
GigabitEthernet0_6_0_0
Rip enabled?: Yes
Out-of-memory state: Normal
Broadcast for V2: No
Accept Metric 0?: No
Send versions: 2
Receive versions: 2
Interface state: Up
IP address: 10.0.0.12/24
Metric Cost: 0
Split horizon: Enabled
Poison Reverse: Disabled
Joined multicast group?: Yes
 
GigabitEthernet0_6_0_2
Out-of-memory state: Normal
Rip enabled?: Yes
Broadcast for V2: No
Accept Metric 0?: No
Send versions: 2
Receive versions: 2
Interface state: Up
IP address: 12.0.0.12/24
Metric Cost: 0
Split horizon: Enabled
Poison Reverse: Disabled
Joined multicast group?: Yes
 
RIP peers attached to this interface:
12.0.0.13
uptime: 3 version: 2
packets discarded: 0 routes discarded: 402
 

表 157 で、これらの出力に表示される重要なフィールドについて説明します。

 

表 157 show rip interface のフィールドの説明

フィールド
説明

Rip enabled?:

RIP ルーティング プロトコルがインターフェイスでイネーブルかどうかを示します。

Out-of-memory state:

インターフェイス上の現在のメモリ不足状態を示します。

Broadcast for V2:

インターフェイス上で RIP バージョン 2 出力パケットをブロードキャスト アドレスに送信するかどうかを示します。

Accept Metric 0?:

このインターフェイスが、メトリックにゼロ(0)が設定された RIP アップデートからのルーティング エントリを受け付けるかどうかを示します。

Send versions:

このインターフェイス上でパケットを送出するために RIP が使用するバージョンを示します。

Receive versions:

このインターフェイス上で RIP が受け付けるパケットのバージョンを示します。

Interface state:

インターフェイスがアップ状態かダウン状態かを示します。

IP address:

インターフェイスの IP アドレス。

Metric Cost:

メトリック コスト値を示します。

Split horizon:

スプリット ホライズンがこのインターフェイスでイネーブルかどうかを示します。

Poison Reverse:

ポイズン リバースがこのインターフェイスでイネーブルかどうかを示します。

Joined multicast group?:

インターフェイスが RIP マルチキャスト グループ 224.0.0.9 に属しているかどうかを示します。

RIP peers attached to this interface:

12.0.0.13

このインターフェイス上の RIP ネイバの一覧です。

uptime: 3

このネイバがアップ状態になっている時間の長さを示します。

version: 2

このネイバから受信するパケットのバージョンを示します。

packets discarded: 0

このネイバから受信したパケットのうち、破棄されたパケットの数を示します。

routes discarded: 402

このネイバから受信したルートのうち、破棄されたルートの数を示します。

show rip statistics

Routing Information Protocol(RIP)トポロジ テーブルの統計エントリ情報を表示するには、EXEC モードで show rip statistics コマンドを使用します。

show rip [ vrf { vrf | all }] statistics

 
シンタックスの説明

vrf { vrf | all }

(任意)特定の VPN ルーティング/転送(VRF)インスタンスまたはすべての VRF インスタンスを指定します。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

タスク ID

タスク ID
動作

rip

読み取り

次に、 show rip statistics コマンドの出力例を示します。

RP/0/RSP0/CPU0:router# show rip statistics
 
RIP statistics:
Total messages sent: 5597
Message send failures: 0
Regular updates sent: 5566
Queries responsed to: 0
RIB updates: 6
Total packets received: 5743
Discarded packets: 0
Discarded routes: 0
Number of routes allocated: 18
Number of paths allocated: 14
 
Route malloc failures: 0
Path malloc failures: 0
 

表 158 で、これらの出力に表示される重要なフィールドについて説明します。

 

表 158 show rip statistics のフィールドの説明

フィールド
説明

Total messages sent:

送信された RIP パケット数

Message send failures:

パケット送信処理に失敗した回数

Queries responsed to:

RIP クエリーに対する応答として RIP アップデートが送信された回数

RIB updates:

ルート追加メッセージと削除メッセージが RIB に送信された回数

Total packets received:

受信した RIP パケットの数

Discarded packets:

受信した RIP パケットのうち、破棄された数

Discarded routes:

受信した RIP アップデート パケットのうち、破棄されたルートの数

Number of routes allocated:

RIP 内部トポロジ データベース用に割り当てられたルートの数

Number of paths allocated:

RIP 内部トポロジ データベース用に割り当てられたパスの数

Route malloc failures:

ルート割り当て中の失敗の数

Path malloc failures:

パス割り当て中の失敗の数


) 割り当て済みのフィールドの中にあるルートの数は、RIP データベースに存在するルートの数と同じとは限りません。


site-of-origin (RIP)

Routing Information Protocol(RIP)インターフェイスに対して Site of Origin(SoO)フィルタリングを設定するには、インターフェイス コンフィギュレーション モードで site-of-origin コマンドを使用します。インターフェイス上で SoO フィルタリングをディセーブルにするには、このコマンドの no 形式を使用します。

site-of-origin { as-number : number | ip-address : number }

no site-of-origin { as-number : number | ip-address : number }

 
シンタックスの説明

as-number :

自律システム番号。2 バイトの番号の範囲は 1 ~ 65535 です。4 バイトの番号の範囲は 1.0 ~ 65535.65535 です。

自律システム番号とネットワーク番号はコロンで区切ります。

number

ネットワーク番号。2 バイトの AS 番号を使用する場合、範囲は 0 ~ 4294967295 です。4 バイトの AS 番号を使用する場合、範囲は 0 ~ 65535 です。

ip-address :

IP アドレス引数には、ドット付き 10 進数表記の、4 つの部分からなる IP アドレスを指定します。

IP アドレスとネットワーク番号はコロンで区切ります。

 
デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

バックドア リンクを使用したサイト間の MPLS VPN リンクを含む複雑なトポロジをサポートする必要がある場合、RIP プロセスは、ボーダー ゲートウェイ プロトコル(BGP)から再配布されるルートに対する SoO 属性を取得できる必要があります。

site-of-origin コマンドは、SoO BGP 拡張コミュニティ属性を設定するために使用します。この属性は、あるサイトから送信されたルートを識別し、そのプレフィクスが送信元サイトに逆にアドバタイズされることを防ぐために使用されます。SoO 拡張コミュニティは、Provider Edge(PE; プロバイダー エッジ)ルータがルートを学習したサイトを一意に識別します。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、RIP インターフェイス上で SoO フィルタリングを設定する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip) interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-rip-if)# site-of-origin 10.0.0.1:20

split-horizon disable (RIP)

Routing Information Protocol(RIP)プロセスのスプリット ホライズンをディセーブルにするには、インターフェイス コンフィギュレーション モードで split-horizon disable コマンドを使用します。スプリット ホライズンをイネーブルにするには、このコマンドの no 形式を使用します。

split-horizon disable

no split-horizon disable

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

RIP プロセスでスプリット ホライズンはイネーブルになっています。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

設定の中で split-horizon disable コマンドを明示的に指定できます。

スプリット ホライズンがディセーブルの場合、ポイズン リバースの設定は無視されます。


) 一般に、アプリケーションで正しくルートをアドバタイズするために必要であることが確実でない限り、スプリット ホライズンのデフォルトの状態を変更しないことをお勧めします。


タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、Packet-over-SONET/SDH リンク上でスプリット ホライズンをディセーブルにする例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-rip-if)# split-horizon disable
 

 
関連コマンド

コマンド
説明

poison-reverse

RIP ルータ アップデートのポイズン リバース処理をイネーブルにします。

timers basic

Routing Information Protocol(RIP)ネットワーク タイマーを調整するには、ルータ コンフィギュレーション モードで timers basic コマンドを使用します。タイマーをデフォルト値に戻すには、このコマンドの no 形式を使用します。

timers basic update invalid holddown flush

no timers basic

 
シンタックスの説明

update

アップデートを送信する頻度を秒単位で指定します。これは、ルーティング プロトコルの基本的なタイミング パラメータです。範囲は 5 ~ 50000 です。

invalid

ルートが無効であると宣言するまでの期間(秒単位)です。update 引数の値の 3 倍以上であることが必要です。ルートをリフレッシュするアップデートがない場合、ルートは無効になります。その場合、ルートはホールドダウン状態になります。そのルートはアクセス不可と見なされ、到達不能としてアドバタイズされます。範囲は 15 ~ 200000 です。

holddown

より良いパスに関するルーティング情報を抑止する期間(秒単位)です。update 引数の値の 3 倍以上であることが必要です。ルートが到達不能であることを示すアップデート パケットを受信すると、そのルートはホールドダウン状態になります。そのルートはアクセス不可と見なされ、到達不能としてアドバタイズされます。ホールドダウンの期限が切れると、他のソースによってアドバタイズされたルートが受け付けられ、ルートがアクセス可能になります。範囲は 15 ~ 200000 です。

flush

ルートがルーティング テーブルから削除される前に経過する必要がある時間を秒単位で指定します。指定する期間は、 invalid 引数の値よりも大きいことが必要です。invalid タイマー値よりも小さいと、適切なホールドダウン期間が使用されず、ホールドダウン期間が経過する前に新しいルートが受け付けられます。範囲は 16 ~ 250000 です。

 
デフォルト

update : 30

invalid : 180

holddown : 180

flush : 240

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

RIP の基本的なタイミング パラメータは調整可能です。RIP は、分散型の非同期ルーティング アルゴリズムを実行するため、これらのタイマーはネットワーク内のすべてのルータで同じである必要があります。


) 現在のタイマー値とデフォルトのタイマー値を表示するには、show rip コマンドを使用します。


タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、5 秒ごとにアップデートをブロードキャストするよう設定する例を示します。ルートを 15 秒間受信しないと、そのルートは使用不能と宣言されます。以降の情報はさらに 15 秒間抑止されます。フラッシュ期間の終了時に、ルーティング テーブルからルートがフラッシュされます。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip) timers basic 5 15 15 30

 
関連コマンド

コマンド
説明

show rip

RIP の設定とステータスを表示します。

validate-update-source disable

Cisco IOS XR ソフトウェア で、Routing Information Protocol(RIP)の受信ルーティング アップデートの送信元 IP アドレスを検証しないようにするには、ルータ コンフィギュレーション モードで validate-update-source disable コマンドを使用します。この機能を再度イネーブルにするには、このコマンドの no 形式を使用します。

validate-update-source disable

no validate-update-source disable

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

RIP の受信アップデートの送信元 IP アドレスは常に検証されます。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

validate-update-source disable コマンドを使用すると、検証は行われません。

デフォルトでは、受信ルーティング アップデートの送信元 IP アドレスが、受信インターフェイスに対して定義されたアドレスのいずれかと同じ IP ネットワーク上にあることが確認されます。

unnumbered IP インターフェイス(IP unnumbered として設定されたインターフェイス)では、チェックは行われません。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、送信元検証をディセーブルにする例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip) validate-update-source disable

vrf (RIP)

VPN ルーティング/転送(VRF)インスタンスを定義し、VRF コンフィギュレーション モードに移行するには、ルータ コンフィギュレーション モードで vrf コマンドを使用します。VRF インスタンスを削除するには、このコマンドの no 形式を使用します。

vrf vrf-name

no vrf vrf-name

 
シンタックスの説明

vrf-name

特定の VPN ルーティング/転送インスタンスを指定します。

 
デフォルト

VRF は定義されていません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

リリース 3.7.2

このコマンドは Cisco ASR 9000 シリーズ ルータで導入されました。

 
使用上のガイドライン

このコマンドを使用するには、適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者にお問い合わせください。

VRF インスタンスを設定するには、vrf コマンドを使用します。VRF インスタンスは、プロバイダー エッジ(PE)ルータで保持される VPN ルーティング/転送テーブルを収集したものです。

VRF コンフィギュレーション モードでは、 auto-summary コマンドなど、ルータ コンフィギュレーション モードで使用できるすべてのコマンドを実行できます。

タスク ID

タスク ID
動作

rip

読み取り、書き込み

次に、VRF コンフィギュレーション モードに移行し、そのモードで実行できる RIP コマンドの一覧を表示する例を示します。

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
RP/0/RSP0/CPU0:router(config-rip-vrf)# ?
 
auto-summary Enable automatic network number summarization
broadcast-for-v2 Send RIP v2 output packets to broadcast address
commit Commit the configuration changes to running
default-information Control distribution of default information
default-metric Set metric of redistributed routes
describe Describe a command without taking real actions
distance Define an administrative distance
do Run an exec command
exit Exit from this submode
interface Enter the RIP interface configuration submode
maximum-paths Maximum number of paths allowed per route
neighbor Specify a neighbor router
no Negate a command or set its defaults
nsf Enable Cisco Non Stop Forwarding
output-delay Interpacket delay for RIP updates
redistribute Redistribute information from another routing protocol
route-policy Apply route policy to routing updates
show Show contents of configuration
timers Adjust routing timers
validate-update-source Validate source address of routing updates
RP/0/RSP0/CPU0:router(config-rip-vrf)#