Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ L2VPN およびイーサネット サービス コンフィギュレーション ガイド Cisco IOS XR ソフトウェア リリース 4.3.x
リンク バンドルの設定
リンク バンドルの設定
発行日;2013/04/10 | 英語版ドキュメント(2013/04/02 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

リンク バンドルの設定

内容

リンク バンドルを設定するための前提条件

リンク バンドルの設定に関する情報

リンク バンドルの概要

リンク バンドルの特性

LACP を通じたリンク集約

IEEE 802.3ad 規格

QoS およびリンク バンドル

イーサネット リンク バンドル上の VLAN

リンク バンドルの設定の概要

カードのフェールオーバー時のノンストップ フォワーディング

リンクのフェールオーバー

バンドル インターフェイス:冗長性、ロード シェアリング、集約

リンク バンドルの設定方法

イーサネット リンク バンドルの設定

VLAN バンドルの設定

リンク バンドルの設定例

LACP が動作する EtherChannel バンドル:例

イーサネット バンドル上での VLAN の作成:例

Cisco 7600 EtherChannel に接続された ASR 9000 リンク バンドル:例

その他の関連資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

リンク バンドルの設定

Cisco ASR 9000 シリーズ アグリゲーション サービス ルータでのバンドルは、1 つに集約され、単一のリンクとして扱われる 1 つ以上のポート グループです。1 つのバンドル内の各リンクの速度は異なっていてもよく、最も高速なリンクの速度は、最も低速なリンクの最大 4 倍とすることができます。各バンドルには、1 つの MAC、1 つの IP アドレス、1 つの設定セット(ACL または Quality of Service など)があります。

Cisco ASR 9000 シリーズ ルータでは、次のタイプのインターフェイスでバンドルがサポートされます。

イーサネット インターフェイス

VLAN サブインターフェイス


) バンドルには、モジュラ サービス カードとの 1 対 1 の関連付けはありません。


Cisco IOS XR ソフトウェアでのリンク バンドル設定機能の履歴

リリース
変更内容

リリース 3.7.2

この機能は、Cisco ASR 9000 シリーズ ルータで導入されました。

リンク バンドルを設定するための前提条件

リンク バンドルを設定する前に、次のタスクと条件を満たしていることを確認してください。

このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。 このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。

ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。

インターフェイスの IP アドレスがわかっていること。

設定するバンドルに含めるリンクがわかっていること。

イーサネット リンク バンドルを設定する場合、ルータに少なくとも次のイーサネット ラインカードのいずれかが搭載されていること。

2 ポート 10 ギガビット イーサネット ラインカード

4 ポート 10 ギガビット イーサネット ラインカード

8 ポート 10 ギガビット イーサネット ラインカード

16 ポート 10 ギガビット イーサネット ラインカード

20 ポート ギガビット イーサネット ラインカード

40 ポート ギガビット イーサネット ラインカード


) 物理インターフェイス、PLIM、およびモジュラ サービス カードの詳細については、『Cisco ASR 9000 Series Routers Hardware Installation Guide』を参照してください。


リンク バンドルの設定に関する情報

リンク バンドル機能を設定するには、次の概念を理解している必要があります。

「リンク バンドルの概要」

「Cisco ASR 9000 シリーズ ルータ リンク バンドルの特性」

「LACP を通じたリンク集約」

「QoS およびリンク バンドル」

「イーサネット リンク バンドル上の VLAN」

「リンク バンドルの設定の概要」

「カードのフェールオーバー時のノンストップ フォワーディング」

「リンクのフェールオーバー」

「バンドル インターフェイス:冗長性、ロード シェアリング、集約」

リンク バンドルの概要

リンク バンドルは、1 つに束ねられたポートのグループであり、1 つのリンクとして振る舞います。リンク バンドルの利点は、次のとおりです。

複数のリンクが複数のラインカードにまたがり、1 つのインターフェイスを構成します。そのため、単一のリンクで障害が発生しても接続性は失われません。

バンドルされたインターフェイスでは、バンドルの使用可能なすべてのメンバにわたってトラフィックが転送されるため、帯域幅の可用性が向上します。したがって、バンドル内のリンクの 1 つで障害が発生した場合、トラフィックは使用可能なリンクを通過できます。帯域幅はパケット フローを中断することなく追加できます。

1 つのバンドル内の個々のリンクにはさまざまな速度を設定できますが、バンドル内のすべてのリンクが同じタイプである必要があります。

Cisco IOS XR ソフトウェアでは、次の方法でイーサネット インターフェイスのバンドルを構成できます。

IEEE 802.3ad:バンドル内のすべてのメンバー リンクの互換性を確保するため、Link Aggregation Control Protocol(LACP)を採用した標準テクノロジー。互換性がないリンクや障害になったリンクは、バンドルから自動的に削除されます。

EtherChannel:ユーザがリンクを設定してバンドルに参加させることができるシスコの専用テクノロジー。バンドル内のリンクに互換性があるかどうかを確認するための仕組みはありません。

Cisco ASR 9000 シリーズ ルータ リンク バンドルの特性

このリストでは、Cisco ASR 9000 シリーズ ルータでのリンク バンドルの特性と制限事項を説明します。

LACP(Link Aggregation Control Protocol)を使用するかにかかわらず、すべてのタイプのイーサネット インターフェイスをバンドルできます。

バンドル メンバーシップは、1 つのルータにインストールされている複数のラインカードにまたがることができます。

1 つのバンドルは最大 64 個の物理リンクをサポートします。

1 つのバンドル内でリンク速度が異なっていてもよく、バンドルのメンバー間で許容される速度の差は、最大 4 倍です。

物理層とリンク層の設定は、バンドルの個々のメンバー リンクに対して実行します。

ネットワーク層プロトコルおよび上位層のアプリケーションの設定は、バンドル自体に対して実行します。

バンドルは、管理上イネーブルまたはディセーブルにできます。

バンドル内のそれぞれのリンクは、管理上イネーブルまたはディセーブルにできます。

イーサネット リンク バンドルは、イーサネット チャネルと同様の方法で作成され、両方のエンド システムで同じコンフィギュレーションを入力します。

バンドルに対して設定された MAC アドレスは、そのバンドル内の各リンクの MAC アドレスになります。

LACP が設定されている場合、バンドル内の各リンクは、異なるメンバーに対して異なるキープアライブ周期を許可するよう設定できます。

ロード バランシング(メンバー リンク間のデータの分散)は、パケットではなくフロー単位で実行されます。データはバンドル対するそのリンクの帯域幅に比例して、リンクに配信されます。

QoS がサポートされており、各バンドル メンバーに均等に適用されます。

CDP キープアライブや HDLC キープアライブなどのリンク層プロトコルは、バンドル内の各リンク上で独立して動作します。

ルーティング アップデートや hello などの上位層プロトコルは、インターフェイス バンドルのどのメンバー リンク上でも送信されます。

バンドルされたインターフェイスはポイント ツー ポイントです。

リンクがバンドル内で distributing 状態になるには、その前にアップ状態なる必要があります。

1 つのバンドル内のすべてのリンクは、802.3ad(LACP)または EtherChannel(非 LACP)のいずれかを実行するように設定する必要があります。1 つのバンドル内の混合リンクはサポートされません。

バンドル インターフェイスには、物理リンクと VLAN サブインターフェイスのみを含めることができます。

リンク バンドルでのアクセス コントロール リスト(ACL)の設定は、通常のインターフェイスでの ACL の設定と同じです。

マルチキャスト トラフィックは、バンドルのメンバー上でロード バランスされます。特定のフローに対し、内部処理によってメンバ リンクが選択され、そのフローのすべてのトラフィックがそのメンバ上で送信されます。

LACP を通じたリンク集約

異なるモジュラ サービス カード上のインターフェイスを集約することで、冗長性が提供され、インターフェイスまたはモジュラ サービス カードで障害が発生したときに、トラフィックをすばやく他のメンバー リンクにリダイレクトできます。

オプションの Link Aggregation Control Protocol(LACP)は IEEE 802 規格で定義されています。LACP では、2 台の直接接続されたシステム(ピア)間で通信し、バンドル メンバーの互換性が確認されます。Cisco ASR 9000 シリーズ ルータの場合、ピアは、別のルータまたはスイッチのいずれかにすることができます。LACP は、リンク バンドルの動作状態を監視し、次のことを確認します。

すべてのリンクが同じ 2 台のシステム上で終端していること。

両方のシステムがリンクを同じバンドルの一部と見なしていること。

すべてのリンクがピア上で適切に設定されていること

LACP は、ローカル ポート状態と、パートナー システムの状態のローカルなビューが格納されたフレームを送信します。これらのフレームが解析され、両方のシステムが同調していることが確認されます。

IEEE 802.3ad 規格

IEEE 802.3ad 規格では、一般にイーサネット リンク バンドルを構成する方法が定義されています。

バンドル メンバーとして設定された各リンクでは、この情報は、リンク バンドルの両端をホストするシステム間で交換されます。

グローバルに一意のローカル システム ID

リンクがメンバーになっているバンドルの ID(動作キー)

リンクの ID(ポート ID)

リンクの現在の集約ステータス

この情報は、リンク集約グループ ID(LAG ID)を構成するために使用されます。共通の LAG ID を共有するリンクは集約できます。個々のリンクには固有の LAG ID があります。

システム ID はルータを区別し、その一意性はシステムの MAC アドレスを使用することで保証されます。バンドル ID とリンク ID は、それを割り当てるルータでだけ意味を持ち、2 つのリンクが同じ ID を持たないことと、2 つのバンドルが同じ ID を持たないことが保証される必要があります。

ピア システムからの情報はローカル システムの情報と組み合わされ、バンドルのメンバーとして設定されたリンクの互換性が判断されます。

Cisco ASR 9000 シリーズ ルータのバンドルの MAC アドレスは、バックプレーンの予約済み MAC アドレス セットから取得されます。この MAC アドレスは、バンドル インターフェイスが存在する限りバンドルにあります。バンドルは、ユーザが別の MAC アドレスを設定するまで、この MAC アドレスを使用します。バンドルの MAC アドレスは、バンドル トラフィックを通過させる際にすべてのメンバー リンクによって使用されます。バンドルに対して設定されたすべてのユニキャスト アドレスまたはマルチキャスト アドレスも、すべてのメンバー リンクで設定されます。


) MAC アドレスを変更するとパケット転送に影響を与えるおそれがあるため、MAC アドレスは変更しないことを推奨します。


QoS およびリンク バンドル

入力方向では、バンドルのローカル インスタンスに QoS が適用されます。各バンドルはキューのセットに関連付けられます。QoS は、バンドル上で設定されているさまざまなネットワーク層プロトコルに適用されます。

出方向では、メンバー リンクへの参照を持つバンドルに QoS が適用されます。QoS は、メンバーの帯域幅の合計に基づいて適用されます。

QoS が入力または出力方向のいずれかのバンドルに適用される場合、QoS は各メンバー インターフェイスに適用されます。

リンク バンドル機能は、『 Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Configuration Guide 』に記載されているすべての QoS 機能をサポートします。

リンク バンドル機能は、次の QoS 機能をサポートします。

高優先順位/低優先順位:最大帯域幅は、バンドル インターフェイスの帯域幅のパーセンテージとして計算されます。このパーセンテージは出力上のすべてのメンバー リンクに適用されるか、入力上のローカル バンドル インスタンスに適用されます。

保証される帯域幅:パーセンテージで提供され、すべてのメンバー リンクに適用されます。

トラフィック シェーピング:パーセンテージで提供され、すべてのメンバー リンクに適用されます。

WRED:最小および最大パラメータは、メンバー リンクまたはバンドル インスタンスごとの正しい比率に変換され、バンドルに適用されます。

マーキング:ポリシーに従ったパケットの QoS レベルの変更プロセス。

テール ドロップ:キューが一杯のときにパケットはドロップされます。

イーサネット リンク バンドル上の VLAN

802.1Q VLAN サブインターフェイスを 802.3ad イーサネット リンク バンドル上で設定できます。イーサネット リンク バンドル上に VLAN を追加するときには、次の点に注意してください。

バンドルごとに許可される VLAN の最大数は 4000 です。

ルータごとに許可されるバンドル VLAN の最大数は 16000 です。


) バンドル VLAN のメモリ要件は、標準の物理インターフェイスよりも若干多くなります。


バンドル上で VLAN サブインターフェイスを作成するには、次のように、 interface Bundle-Ether コマンドを使用して VLAN サブインターフェイス インスタンスを追加します。

interface Bundle-Ether instance.subinterface

イーサネット リンク バンドル上で VLAN を作成した後、すべての物理 VLAN サブインターフェイス コンフィギュレーションがそのリンク バンドル上でサポートされます。

リンク バンドルの設定の概要

リンク バンドルの設定プロセスの一般的な概要を次の手順に示します。リンクをバンドルに追加する前に、リンクから以前のネットワーク層コンフィギュレーションをすべてクリアする必要があることに注意してください。

1. グローバル コンフィギュレーション モードで、リンク バンドルを作成します。イーサネット リンク バンドルを作成するには、interface Bundle-Ether コマンドを入力します。

2. ipv4 address コマンドを使用して、IP アドレスとサブネット マスクを仮想インターフェイスに割り当てます。

3. インターフェイス コンフィギュレーション サブモードで bundle id コマンドを使用し、ステップ 1 で作成したバンドルにインターフェイスを追加します。1 つのバンドルに最大 32 個のリンクを追加できます。


) リンクは、そのリンクのインターフェイス コンフィギュレーション サブモードからバンドルのメンバーに設定できます。


カードのフェールオーバー時のノンストップ フォワーディング

Cisco IOS XR ソフトウェアは、アクティブおよびスタンバイ RSP カード間でのフェールオーバー時のノンストップ フォワーディングをサポートしています。ノンストップ フォワーディングを使用すると、フェールオーバーが発生したときにリンク バンドルの状態が変化しません。

たとえば、アクティブな RSP が障害になった場合、スタンバイ RSP が動作可能になります。障害になった RSP のコンフィギュレーション、ノードの状態、チェックポイント データは、スタンバイ RSP に複製されます。スタンバイ RSP がアクティブ RSP になったとき、バンドルされたインターフェイスはすべて存在します。


) フェールオーバー先は常にスタンバイ RSP です。



) スタンバイ インターフェイス コンフィギュレーションが維持されることを保証するために何かを設定する必要はありません。


リンクのフェールオーバー

バンドルのメンバ リンクの 1 つに障害が発生すると、トラフィックは動作可能な残りのメンバ リンクにリダイレクトされ、トラフィック フローは中断されません。

バンドル インターフェイス:冗長性、ロード シェアリング、集約

Cisco ASR 9000 シリーズ アグリゲーション サービス ルータでのバンドルは、1 つに集約され、単一のリンクとして扱われる 1 つ以上のポート グループです。1 つのバンドル内の各リンクの速度は異なっていてもよく、最も高速なリンクの速度は、最も低速なリンクの最大 4 倍とすることができます。各バンドルには、1 つの MAC、1 つの IP アドレス、1 つの設定セット(ACL または Quality of Service など)があります。

Cisco ASR 9000 シリーズ ルータでは、次のタイプのインターフェイスでバンドルがサポートされます。

イーサネット インターフェイス

VLAN サブインターフェイス

リンク バンドルの設定方法

この項では、次の手順について説明します。

「イーサネット リンク バンドルの設定」

「VLAN バンドルの設定」

イーサネット リンク バンドルの設定

ここでは、イーサネット リンク バンドルの設定方法について説明します。


) イーサネット リンク バンドルでは MAC アカウンティングはサポートされていません。



) イーサネット バンドルをアクティブにするためには、バンドルの両方の接続ポイントで同じ設定を行う必要があります。


手順の概要

イーサネット リンク バンドルを作成するには、次の手順のように、バンドルを作成し、そのバンドルにメンバー インターフェイスを追加します。

1. configure

2. interface Bundle-Ether bundle-id

3. ipv4 address ipv4-address mask

4. bundle minimum-active bandwidth kbps (任意)

5. bundle minimum-active links links (任意)

6. bundle maximum-active links links (任意)

7. bundle maximum-active links links hot-standby (任意)

8. exit

9. interface { GigabitEthernet | TenGigE } instance

10. bundle id bundle-id [ mode { active | on | passive }

11. no shutdown

12. exit

13. ステップ 2 で作成したバンドルにさらにリンクを追加するには、ステップ 8 から 11 を繰り返します。

14. end
または
commit

15. exit

16. exit

17. 接続のリモート エンドでステップ 1 から 15 を実行します。

18. show bundle Bundle-Ether bundle-id [ reasons ]

19. show lacp Bundle-Ether bundle -id

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router#(config)# interface Bundle-Ether 3

新しいイーサネット リンク バンドルを作成し名前を付与します。

この interface Bundle-Ether コマンドを実行すると、インターフェイス コンフィギュレーション サブモードが開始されます。このモードでは、インターフェイス固有のコンフィギュレーション コマンドを入力できます。インターフェイス コンフィギュレーション サブモードを終了して通常のグローバル コンフィギュレーション モードに戻るには、 exit コマンドを使用します。

ステップ 3

ipv4 address ipv4-address mask

 

RP/0/RSP0/CPU0:router(config-if)# ipv4 address 10.1.2.3 255.0.0.0

ipv4 address コンフィギュレーション サブコマンドを使用して、IP アドレスとサブネット マスクを仮想インターフェイスに割り当てます。

ステップ 4

bundle minimum-active bandwidth kbps

 

RP/0/RSP0/CPU0:router(config-if)# bundle minimum-active bandwidth 580000

(任意)ユーザがバンドルをアップ状態にする前に必要な最小帯域幅を設定します。

ステップ 5

bundle minimum-active links links

 

RP/0/RSP0/CPU0:router(config-if)# bundle minimum-active links 2

(任意)特定のバンドルをアップ状態にする前に必要なアクティブ リンク数を設定します。

ステップ 6

bundle maximum-active links links

 

RP/0/RSP0/CPU0:router(config-if)# bundle maximum-active links 1

(任意)1 個のアクティブ リンクと、アクティブ リンクに障害が発生した場合に、バンドルに迅速に引き継ぐことができるスタンバイ モードの 1 個のリンクを指定します(1:1 保護)。

1 つのバンドルで許可されるデフォルトのアクティブ リンク数は 8 です。

コマンドの値に基づいて決定されます(値が小さいほど、プライオリティが高くなります)。したがって、アクティブにするリンクに高いプライオリティを設定することを推奨します。

ステップ 7

bundle maximum-active links links hot-standby

 

RP/0/RSP0/CPU0:router(config-if)# bundle maximum-active links 1 hot-standby

 

hot-standby キーワードは、バンドルが一時的に最小リンクまたは帯域幅しきい値未満になる間にスイッチオーバーまたはスイッチバック イベントでバンドル フラップを回避するために役立ちます。

これは、このために、wait-while タイマーと suppress-flaps タイマーのデフォルト値を設定します。

ステップ 8

exit
 

RP/0/RSP0/CPU0:router(config-if)# exit

イーサネット リンク バンドルのインターフェイス コンフィギュレーション サブモードを終了します。

ステップ 9

interface { GigabitEthernet | TenGigE } instance

 

RP/0/RSP0/CPU0:router(config)# interface GigabitEthernet 1/0/0/0

指定したインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

GigabitEthernet キーワードまたは TenGigE キーワードを入力して、インターフェイスの種類を指定します。 instance 引数には、 rack / slot / module 形式のノード ID を指定します。

混合帯域幅のバンドル メンバの設定は、1:1 冗長性が設定されている場合にだけサポートされます(これは、10 GigabitEthernet インターフェイスのバックアップとして 1 GigabitEthernet メンバしか設定できないことを意味します)。

(注) 混合リンク バンドル モードは、アクティブ/スタンバイ動作が設定されている場合にだけサポートされます(通常はスタンバイ モードで低速リンクです)。

ステップ 10

bundle id bundle-id [mode {active | on | passive}]

 
RP/0/RSP0/CPU0:router(config-if)# bundle-id 3

指定したバンドルにリンクを追加します。

バンドル上でアクティブ LACP またはパッシブ LACP をイネーブルにするには、オプションの mode active キーワードまたは mode passive キーワードをコマンド文字列に追加します。

LACP をサポートせずにバンドルにリンクを追加するには、オプションの mode on キーワードをコマンド文字列に追加します。

になります(LACP はポート上で動作しません)。

ステップ 11

no shutdown

 

RP/0/RSP0/CPU0:router(config-if)# no shutdown

(任意)リンクがダウン状態の場合はアップ状態にします。no shutdown コマンドは、コンフィギュレーションとリンクの状態に応じて、リンクをアップ状態またはダウン状態に戻します。

ステップ 12

exit
 

RP/0/RSP0/CPU0:router(config-if)# exit

イーサネット インターフェイスのインターフェイス コンフィギュレーション サブモードを終了します。

ステップ 13

(任意)バンドルにさらにリンクを追加するには、ステップ 8 から 11 を繰り返します。

 

--

ステップ 14

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 15

exit
 

RP/0/RSP0/CPU0:router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 16

exit
 

RP/0/RSP0/CPU0:router(config)# exit

グローバル コンフィギュレーション モードを終了します。

ステップ 17

接続のリモート エンドでステップ 1 から 15 を実行します。

リンク バンドルの他端をアップ状態にします。

ステップ 18

show bundle Bundle-Ether bundle-id [ reasons ]
 
RP/0/RSP0/CPU0:router# show bundle Bundle-Ether 3 reasons

(任意)指定したイーサネット リンク バンドルに関する情報を表示します。

ステップ 19

show lacp Bundle-Ether bundle-id
 

RP/0/RSP0/CPU0:router# show lacp
Bundle-Ether 3

(任意)LACP ポートとそのピアに関する詳細情報を表示します。

VLAN バンドルの設定

ここでは、VLAN バンドルの設定方法について説明します。VLAN バンドルの作成では、主に次の 3 つの作業を行います。

1. イーサネット バンドルを作成します。

2. VLAN サブインターフェイスを作成し、イーサネット バンドルに割り当てます。

3. イーサネット リンクをイーサネット バンドルに割り当てます。

これらの作業について、以降の手順で詳しく説明します。


) VLAN バンドルをアクティブにするには、バンドル接続の両端で同じ設定を行う必要があります。


手順の概要

VLAN リンク バンドルの作成について、次の手順で説明します。

1. configure

2. interface Bundle-Ether bundle-id

3. ipv4 address ipv4-address mask

4. bundle minimum-active bandwidth kbps (任意)

5. bundle minimum-active links links (任意)

6. bundle maximum-active links links (任意)

7. exit

8. interface Bundle-Ether bundle-id.vlan-id

9. encapsulation dot1q vlan-id

10. ipv4 address ipv4-address mask

11. no shutdown

12. exit

13. ステップ 2 で作成したバンドルにさらに VLAN を追加するには、ステップ 7 から 12 を繰り返します。

14. end
または
commit

15. exit

16. exit

17. show ethernet trunk bundle-Ether instance

18. configure

19. interface { GigabitEthernet | TenGigE } instance

20. bundle id bundle-id [ mode { active | on | passive }]

21. no shutdown

22. ステップ 2 で作成したバンドルにさらにイーサネット インターフェイスを追加するには、ステップ 19 から 21 を繰り返します。

23. end
または
commit

24. 接続のリモート エンドでステップ 1 から 23 を実行します。

25. show bundle Bundle-Ether bundle-id [ reasons ]

26. show ethernet trunk bundle-Ether instance

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router#(config)# interface Bundle-Ether 3

新しいイーサネット リンク バンドルを作成し名前を付与します。

この interface Bundle-Ether コマンドを実行すると、インターフェイス コンフィギュレーション サブモードが開始されます。このモードでは、インターフェイス固有のコンフィギュレーション コマンドを入力できます。インターフェイス コンフィギュレーション サブモードを終了して通常のグローバル コンフィギュレーション モードに戻るには、 exit コマンドを使用します。

ステップ 3

ipv4 address ipv4-address mask

 

RP/0/RSP0/CPU0:router(config-if)# ipv4 address 10.1.2.3 255.0.0.0

ipv4 address コンフィギュレーション サブコマンドを使用して、IP アドレスとサブネット マスクを仮想インターフェイスに割り当てます。

ステップ 4

bundle minimum-active bandwidth kbps

 

RP/0/RSP0/CPU0:router(config-if)# bundle minimum-active bandwidth 580000

(任意)ユーザがバンドルをアップ状態にする前に必要な最小帯域幅を設定します。

ステップ 5

bundle minimum-active links links

 

RP/0/RSP0/CPU0:router(config-if)# bundle minimum-active links 2

(任意)特定のバンドルをアップ状態にする前に必要なアクティブ リンク数を設定します。

ステップ 6

bundle maximum-active links links

 

RP/0/RSP0/CPU0:router(config-if)# bundle maximum-active links 1

(任意)1 個のアクティブ リンクと、アクティブ リンクに障害が発生した場合に、バンドルに迅速に引き継ぐことができるスタンバイ モードの 1 個のリンクを指定します(1:1 保護)。

(注) 1 つのバンドルで許可されるデフォルトのアクティブ リンク数は 8 です。

コマンドの値に基づいて決定されます(値が小さいほど、プライオリティが高くなります)。したがって、アクティブにするリンクに高いプライオリティを設定することを推奨します。

ステップ 7

exit
 

RP/0/RSP0/CPU0:router(config-if)# exit

インターフェイス コンフィギュレーション サブモードを終了します。

ステップ 8

interface Bundle-Ether bundle-id.vlan-id

 

RP/0/RSP0/CPU0:router#(config)# interface Bundle-Ether 3.1

新しい VLAN を作成し、その VLAN をステップ 2 で作成したイーサネット バンドルに割り当てます。

bundle-id 引数には、ステップ 2 で作成した bundle-id を指定します。

vlan-id にはサブインターフェイス ID を指定します。範囲は 1 ~ 4094 です(0 と 4095 は予約されています)。

コマンドに追加すると、サブインターフェイス コンフィギュレーション モードが開始されます。

ステップ 9

encapsulation dot1q vlan-id

 

RP/0/RSP0/CPU0:router#(config-subif)# encapsulation dot1q 10

VLAN をサブインターフェイスに割り当てます。

vlan-id 引数にはサブインターフェイス ID を指定します。範囲は 1 ~ 4094 です(0 と 4095 は予約されています)。

ステップ 10

ipv4 address ipv4-address mask

 

RP/0/RSP0/CPU0:router#(config-subif)# ipv4 address 10.1.2.3/24

IP アドレスおよびサブネット マスクをサブインターフェイスに割り当てます。

ステップ 11

no shutdown

 

RP/0/RSP0/CPU0:router#(config-subif)# no shutdown

(任意)リンクがダウン状態の場合はアップ状態にします。no shutdown コマンドは、コンフィギュレーションとリンクの状態に応じて、リンクをアップ状態またはダウン状態に戻します。

ステップ 12

exit
 

RP/0/RSP0/CPU0:router(config-subif)# exit

VLAN サブインターフェイスのサブインターフェイス コンフィギュレーション モードを終了します。

ステップ 13

ステップ 2 で作成したバンドルにさらに VLAN を追加するには、ステップ 7 から 12 を繰り返します。

(任意)バンドルにさらにサブインターフェイスを追加します。

ステップ 14

end

または

commit

 

RP/0/RSP0/CPU0:router(config-subif)# end

または

RP/0/RSP0/CPU0:router(config-subif)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。

ステップ 15

exit
 

RP/0/RSP0/CPU0:router(config-subif)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 16

exit
 

RP/0/RSP0/CPU0:router(config)# exit

グローバル コンフィギュレーション モードを終了します。

ステップ 17

show ethernet trunk bundle-ether instance

 

RP/0/RP0/CPU0:router# show ethernet trunk bundle-ether 5

(任意)インターフェイス コンフィギュレーションを表示します。

イーサネット バンドル インスタンスの範囲は 1 ~ 65535 です。

ステップ 18

configure
 

RP/0/RSP0/CPU0:router # configure

グローバル コンフィギュレーション モードを開始します。

ステップ 19

interface { GigabitEthernet | TenGigE } instance

 

RP/0/RSP0/CPU0:router(config)# interface GigabitEthernet 1/0/0/0

バンドルに追加するイーサネット インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

GigabitEthernet キーワードまたは TenGigE キーワードを入力して、インターフェイスの種類を指定します。 instance 引数には、 rack /slot/module 形式のノード ID を指定します。

(注) リンク バンドルの両端にイーサネット インターフェイスを追加するまでは、VLAN バンドルはアクティブになりません。

ステップ 20

bundle id bundle-id [ mode { active | on | passive }]

 
RP/0/RSP0/CPU0:router(config-if)# bundle-id 3

ステップ 2 から 13 で設定したバンドルにイーサネット インターフェイスを追加します。

バンドル上でアクティブ LACP またはパッシブ LACP をイネーブルにするには、オプションの mode active キーワードまたは mode passive キーワードをコマンド文字列に追加します。

LACP をサポートせずにバンドルにインターフェイスを追加するには、オプションの mode on キーワードをコマンド文字列に追加します。

になります(LACP はポート上で動作しません)。

ステップ 21

no shutdown

 

RP/0/RSP0/CPU0:router(config-if)# no shutdown

(任意)リンクがダウン状態の場合はアップ状態にします。no shutdown コマンドは、コンフィギュレーションとリンクの状態に応じて、リンクをアップ状態またはダウン状態に戻します。

ステップ 22

VLAN バンドルにさらにイーサネットインターフェイスを追加するには、ステップ 19 から 21 を繰り返します。

--

ステップ 23

end

または

commit

 

RP/0/RSP0/CPU0:router(config-subif)# end

または

RP/0/RSP0/CPU0:router(config-subif)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 24

VLAN バンドル接続のリモート エンドでステップ 1 から 23 を実行します。

リンク バンドルの他端をアップ状態にします。

ステップ 25

show bundle Bundle-Ether bundle-id [ reasons ]
 
RP/0/RSP0/CPU0:router# show bundle Bundle-Ether 3 reasons

(任意)指定したイーサネット リンク バンドルに関する情報を表示します。

show bundle Bundle-Ether コマンドを実行すると、指定したバンドルに関する情報が表示されます。バンドルが正しく設定されており、トラフィックを伝送している場合は、 show bundle Bundle-Ether コマンドの出力の State フィールドに数値 4 が表示されます。これは、指定された VLAN バンドル ポートが「分散している」ことを意味します。

ステップ 26

show ethernet trunk bundle-ether instance

 

RP/0/RP0/CPU0:router# show ethernet trunk bundle-ether 5

(任意)インターフェイス コンフィギュレーションを表示します。

イーサネット バンドル インスタンスの範囲は 1 ~ 65535 です。

リンク バンドルの設定例

ここでは、次の設定例を示します。

LACP が動作する EtherChannel バンドル:例

イーサネット バンドル上での VLAN の作成:例

Cisco 7600 EtherChannel に接続された ASR 9000 リンク バンドル:例

LACP が動作する EtherChannel バンドル:例

次に、2 つのポートを結合して、LACP が動作する EtherChannel バンドルを構成する例を示します。

RP/0/RSP0/CPU0:Router# config
RP/0/RSP0/CPU0:Router(config)# interface Bundle-Ether 3
RP/0/RSP0/CPU0:Router(config-if)# ipv4 address 1.2.3.4/24
RP/0/RSP0/CPU0:Router(config-if)# bundle minimum-active bandwidth 620000
RP/0/RSP0/CPU0:Router(config-if)# bundle minimum-active links 1
RP/0/RSP0/CPU0:Router(config-if)# exit
RP/0/RSP0/CPU0:Router(config)# interface TenGigE 0/3/0/0
RP/0/RSP0/CPU0:Router(config-if)# bundle id 3 mode active
RP/0/RSP0/CPU0:Router(config-if)# no shutdown
RP/0/RSP0/CPU0:Router(config)# exit
RP/0/RSP0/CPU0:Router(config)# interface TenGigE 0/3/0/1
RP/0/RSP0/CPU0:Router(config-if)# bundle id 3 mode active
RP/0/RSP0/CPU0:Router(config-if)# no shutdown
RP/0/RSP0/CPU0:Router(config-if)# exit

イーサネット バンドル上での VLAN の作成:例

次に、イーサネット バンドル上で 2 つの VLAN を作成し起動状態にする例を示します。

RP/0/RSP0/CPU0:Router# config
RP/0/RSP0/CPU0:Router(config)# interface Bundle-Ether 1
RP/0/RSP0/CPU0:Router(config-if)# ipv4 address 1.2.3.4/24
RP/0/RSP0/CPU0:Router(config-if)# bundle minimum-active bandwidth 620000
RP/0/RSP0/CPU0:Router(config-if)# bundle minimum-active links 1
RP/0/RSP0/CPU0:Router(config-if)# exit
RP/0/RSP0/CPU0:Router(config)# interface Bundle-Ether 1.1
RP/0/RSP0/CPU0:Router(config-subif)# dot1q vlan 10
RP/0/RSP0/CPU0:Router(config-subif)# ip addr 10.2.3.4/24
RP/0/RSP0/CPU0:Router(config-subif)# no shutdown
RP/0/RSP0/CPU0:Router(config-subif)# exit
RP/0/RSP0/CPU0:Router(config)# interface Bundle-Ether 1.2
RP/0/RSP0/CPU0:Router(config-subif)# dot1q vlan 20
RP/0/RSP0/CPU0:Router(config-subif)# ip addr 20.2.3.4/24
RP/0/RSP0/CPU0:Router(config-subif)# no shutdown
RP/0/RSP0/CPU0:Router(config-subif)# exit
RP/0/RSP0/CPU0:Router(config)#interface gig 0/1/5/7
RP/0/RSP0/CPU0:Router(config-if)# bundle-id 1 mode act
RP/0/RSP0/CPU0:Router(config-if)# commit
RP/0/RSP0/CPU0:Router(config-if)# exit
RP/0/RSP0/CPU0:Router(config)# exit
RP/0/RSP0/CPU0:Router # show ethernet trunk bundle-ether 1
 

Cisco 7600 EtherChannel に接続された ASR 9000 リンク バンドル:例

次に、ASR 9000 シリーズ ルータ(ASR-9010)と、L2 および L3 サービスの両方をサポートするメトロ イーサネット ネットワーク内の Cisco 7600 シリーズ ルータ(P19_C7609-S)間のバンドルのエンド ツー エンドの例を示します。

Cisco ASR 9000 シリーズ ルータでは、バンドルは、LACP、1:1 リンク保護、2 つの L2 サブインターフェイス、2 つのレイヤ 3 サブインターフェイスで設定されます。

IOS XR 側:

hostname PE44_ASR-9010
 
interface Bundle-Ether16
description Connect to P19_C7609-S Port-Ch 16
mtu 9216
no ipv4 address
bundle maximum-active links 1
!
interface Bundle-Ether16.160 l2transport
description Connect to P19_C7609-S Port-Ch 16 EFP 160
encapsulation dot1q 160
!
interface Bundle-Ether16.161 l2transport
description Connect to P19_C7609-S Port-Ch 16 EFP 161
encapsulation dot1q 161
!
interface Bundle-Ether16.162
description Connect to P19_C7609-S Port-Ch 16.162
ipv4 address 10.194.8.44 255.255.255.0
encapsulation dot1q 162
!
interface Bundle-Ether16.163
description Connect to P19_C7609-S Port-Ch 16.163
ipv4 address 10.194.12.44 255.255.255.0
encapsulation dot1q 163
!
 
 
interface GigabitEthernet0/1/0/16
description Connected to P19_C7609-S GE 8/0/16
bundle id 16 mode active
bundle port-priority 1
!
interface GigabitEthernet0/1/0/17
description Connected to P19_C7609-S GE 8/0/17
bundle id 16 mode active
bundle port-priority 2
!
 

IOS XR 側:CE デバイスへの接続:

hostname PE44_ASR-9010
 
interface GigabitEthernet0/1/0/3.160 l2transport
description VLAN 160 over BE 16.160
encapsulation dot1q 100 second-dot1q 160
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet0/1/0/3.161 l2transport
description VLAN 161 over BE 16.161
encapsulation dot1q 161
!
l2vpn
!
xconnect group 160
p2p 160
interface Bundle-Ether16.160
interface GigabitEthernet0/1/0/3.160
description VLAN_160_over_BE_16.160
!
!
xconnect group 161
p2p 161
interface Bundle-Ether16.161
interface GigabitEthernet0/1/0/3.161
description VLAN_161_over_BE_16.161
!
!
 
 

IOS XR 側:CE デバイス:

hostname PE64_C3750-ME
!
vlan 161
!
interface GigabitEthernet1/0/1
description Connected to PE65_ME-C3400 GE 0/1
switchport access vlan 100
switchport mode dot1q-tunnel
!
interface GigabitEthernet1/0/2
description Connected to PE44_ASR-9010 GE 0/1/0/3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,161
switchport mode trunk
!
interface Vlan161
description VLAN 161 over BE 16.161 on PE44
ip address 161.0.0.64 255.255.255.0
!
 
 
 
hostname PE65_ME-C3400
!
vlan 160
!
interface GigabitEthernet0/1
description Connected to PE64_C3750-ME GE 1/0/1
port-type nni
switchport trunk allowed vlan 160
switchport mode trunk
!
interface Vlan160
description VLAN 160 over BE 16.160 on PE44
ip address 160.0.0.65 255.255.255.0
!
 

IOS 側:

hostname P19_C7609-S
 
port-channel load-balance src-dst-port
!
interface Port-channel16
description Connected to PE44_ASR-9010 BE 16
mtu 9202
no ip address
logging event link-status
logging event status
speed nonegotiate
mls qos trust dscp
lacp fast-switchover
lacp max-bundle 1
service instance 160 ethernet
description Connected to PE44_ASR-9010 BE 16.160
encapsulation dot1q 160
!
service instance 161 ethernet
description Connected to PE44_ASR-9010 BE 16.161
encapsulation dot1q 161
!
!
interface Port-channel16.162
description Connected to PE44_ASR-9010 BE 16.162
encapsulation dot1Q 162
ip address 10.194.8.19 255.255.255.0
!
interface Port-channel16.163
description Connected to PE44_ASR-9010 BE 16.163
encapsulation dot1Q 163
ip address 10.194.12.19 255.255.255.0
!
 
interface GigabitEthernet8/0/16
no shut
description Connected to PE44_ASR-9010 GE 0/1/0/16
mtu 9202
no ip address
logging event link-status
logging event status
speed nonegotiate
no mls qos trust dscp
lacp port-priority 1
channel-protocol lacp
channel-group 16 mode active
!
interface GigabitEthernet8/0/17
no shut
description Connected to PE44_ASR-9010 GE 0/1/0/17
mtu 9202
no ip address
logging event link-status
logging event status
speed nonegotiate
no mls qos trust dscp
lacp port-priority 2
channel-protocol lacp
channel-group 16 mode active
!

IOS 側:CE デバイスへの接続:

 
hostname P19_C7609-S
 
interface GigabitEthernet8/0/7
description Connected to PE62_C3750-ME GE 1/0/2
mtu 9000
no ip address
speed nonegotiate
mls qos trust dscp
service instance 160 ethernet
description VLAN 160 over Port-Ch 16
encapsulation dot1q 100 second-dot1q 160
rewrite ingress tag pop 1 symmetric
!
service instance 161 ethernet
description VLAN 161 over Port-Ch 16
encapsulation dot1q 161
!
!
connect eline-161 Port-channel16 161 GigabitEthernet8/0/7 161
!
!
connect eline-160 Port-channel16 160 GigabitEthernet8/0/7 160
!
!
 

IOS 側:CE デバイス:

 
hostname PE62_C3750-ME
!
vlan 161
!
interface GigabitEthernet1/0/1
description Connected to PE63_ME-C3400 GE 0/1
switchport access vlan 100
switchport mode dot1q-tunnel
!
interface GigabitEthernet1/0/2
description Connected to P19_C7609-S GE 8/0/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,161
switchport mode trunk
!
interface Vlan161
description VLAN 161 over Port-Chan 16 on P19
ip address 161.0.0.62 255.255.255.0
!
 
 
 
hostname PE63_ME-C3400
!
vlan 160
!
interface GigabitEthernet0/1
description Connected to PE62_C3750-ME GE 1/0/1
port-type nni
switchport trunk allowed vlan 160
switchport mode trunk
!
interface Vlan160
description VLAN 160 over Port-Chan 16 on P19
ip address 160.0.0.63 255.255.255.0
!

その他の関連資料

ここでは、リンク バンドルの設定に関連する参考資料を示します。

関連資料

関連項目
参照先

Cisco ASR 9000 シリーズ ルータ マスター コマンド リファレンス

『Cisco ASR 9000 Series Routers Master Commands List』

Cisco ASR 9000 シリーズ ルータ インターフェイス コンフィギュレーション コマンド

『Cisco ASR 9000 Series Routers Interface and Hardware Component Command Reference』

Cisco IOS XR ソフトウェアを使用する Cisco ASR 9000 シリーズ ルータに関する初期システム ブートおよび設定情報

『Cisco ASR 9000 Series Routers Getting Started Guide』

ユーザ グループとタスク ID に関する情報

『Cisco ASR 9000 Series Routers Interface and Hardware Component Command Reference』

リモートの Craft Works Interface(CWI)クライアント管理アプリケーションからの、Cisco ASR 9000 シリーズ ルータ上のインターフェイスとその他のコンポーネントの設定に関する情報

『Cisco ASR 9000 Series Routers Craft Works Interface Configuration Guide』

標準

標準
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--

MIB

MIB
MIB のリンク

このモジュールに適用できる MIB はありません。

Cisco IOS XR ソフトウェアを使用して、選択されたプラットフォームに対応する MIB を検索およびダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクなどの、数千ページに及ぶ技術情報が検索可能です。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/en/US/support/index.html