Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ MPLS レイヤ 3 VPN コンフィギュレーション ガイド Cisco IOS XR ソフトウェア リリース 4.3.x
IPv6 VPN プロバイダー エッジ転送 over MPLS
IPv6 VPN プロバイダー エッジ転送 over MPLS
発行日;2013/04/10 | 英語版ドキュメント(2012/12/20 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

IPv6 VPN プロバイダー エッジ転送 over MPLS

内容

6PE/VPE 設定の前提条件

6PE/VPE に関する情報

6PE/VPE の概要

6PE/VPE の利点

IPv6 over MPLS バックボーンの導入

プロバイダー エッジ ルータおよびカスタマー エッジ ルータ上の IPv6

IPv6 プロバイダー エッジ マルチパス

OSPFv3 6VPE

複数の VRF のサポート

OSPFv3 PE-CE 拡張

VRF Lite

6PE/VPE の実装方法

6PE/VPE の設定

PE から PE コアの設定

PE から CE コアの設定

OSPFv3 を PE ルータと CE ルータ間のルーティング プロトコルに設定

6PE の設定例

PE ルータでの 6PE の設定:例

PE ルータでの 6VPE の設定:例

PE から CE 間の OSPFv3 の設定: 例

その他の関連資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

IPv6 VPN プロバイダー エッジ転送 over MPLS

このモジュールでは、Cisco ASR 9000 シリーズ アグリゲーション サービス ルータで IPv6 VPN プロバイダー エッジ転送 MPLS を実装する方法について説明します。

IPv6 VPN プロバイダー エッジ(6PE/VPE)は、IPv6 転送に既存の MPLS IPv4 コア インフラストラクチャを使用します。6PE/VPE を使用すると、IPv6 サイト同士が MPLS ラベル スイッチド パス(LSP)を使用して MPLS IPv4 コア ネットワークを介して互いに通信できるようになります。

この機能は、プロバイダー エッジ(PE)ルータ上の IPv4 ネットワーク設定のマルチプロトコル ボーダー ゲートウェイ プロトコル(BGP)拡張に大きく依存して、各 IPv6 アドレス プレフィックスの IPv6 到達可能性情報(および MPLS ラベル)を交換します。エッジ ルータは、IPv4 と IPv6 の両方を実行するデュアルスタックとして設定され、IPv4 マッピング IPv6 アドレスを使用して IPv6 プレフィックスの到達可能性情報を交換します。

L2TP 機能を設定するために使用するコマンドの詳細については、『 Cisco ASR 9000 Aggregation Services Router Routing Command Reference 』を参照してください。

6PE の実装の機能履歴:Cisco ASR 9000 シリーズ ルータ

 

リリース
変更内容

リリース 3.9.1

この機能が導入されました。

リリース 4.0.0

A9K-SIP-700 の IPv6 L3VPN に対する 6PE および 6VPE 機能のサポートが追加されました。

6PE 機能での BGP の VRF/CE ごとのラベル割り当てのサポートが追加されました。

リリース 4.1.0

Open Shortest Path First バージョン 3(OSPFv3)IPv6 VPN プロバイダー エッジ(6VPE)機能のサポートが追加されました。

6PE/VPE 設定の前提条件

6PE を実装するには、次の前提条件を満たす必要があります。

適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 これらのコマンド リファレンス ガイドには、各コマンドに必要なタスク ID が含まれます。

ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。

MPLS および BGP4 設定およびトラブルシューティングについての知識。

6PE/VPE に関する情報

6PE 機能を設定するには、ここで説明する概念を理解する必要があります。

「6PE/VPE の概要」

「6PE/VPE の利点」

「IPv6 over MPLS バックボーンの導入」

「プロバイダー エッジ ルータおよびカスタマー エッジ ルータ上の IPv6」

「IPv6 プロバイダー エッジ マルチパス」

「OSPFv3 6VPE」

6PE/VPE の概要

さまざまな手法を使用して、サービス プロバイダーのコア バックボーン上で IPv6 サービスを統合できます。

さまざまなデータリンク層で動作する IPv6 専用ネットワーク

デュアルスタック IPv4-IPv6 バックボーン

既存の MPLS バックボーンの活用

これらのソリューションは、IPv6 トラフィックトラフィックの量と生みだされる収益が、必要な投資と合意済みのリスクと一致する場合に、サービス プロバイダーのバックボーンに導入されます。条件は、エッジからスケーラブルな方法でネイティブ IPv6 サービスを導入する場合に都合が良く、IPv6 アドレッシングの制限はなく、適切に制御された IPv4 バックボーンを危険にさらすこともありません。バックボーンの安定性は、最近 IPv4 インフラストラクチャを安定化させたばかりのサービス プロバイダーに必須です。

MPLS ネットワークで IPv6 サービスを提供統合シナリオは複数考えられるため、MPLS/IPv4 インフラストラクチャを実行する複数のサービス プロバイダーは同様の傾向に従います。シスコ システムズは、これらすべての要件を満たすために特別に 6PE または IPv6 プロバイダー エッジ ルータ over MPLS を開発しました。

6PE の Inter-AS サポートでは、アドレス ファミリをイネーブルにし、PE および ASBR ラベルを割り当て、配布できるようにするため、ボーダー ゲートウェイ プロトコル(BGP)のサポートが必要です。

6PE/VPE の利点

現在 MPLS を導入しているサービス プロバイダーには、次の Cisco 6PE の利点を経験します。

最小限の運用コストとリスク:既存の IPv4 および MPLS サービスに影響はありません。

プロバイダー エッジ ルータのアップグレードのみ:6PE/VPE ルータには、既存の PE ルータまたは新規の IPv6 トラフィック専用のものが使用できます。

IPv6 カスタマー エッジ ルータに影響なし:ISP は、スタティック、IGP または EGP を実行しているすべてのカスタマー CE に接続できます。

生産サービス レディ:ISP は IPv6 プレフィックスを委任できます。

既存の MPLS サービスへの IPv6 導入:6PE/VPE ルータはいつでも追加できます。

IPv6 over MPLS バックボーンの導入

6PE(IPv6 over MPLS)によってイネーブルにされたバックボーンを使用すると、IPv6 ドメイン同士が MPLS IPv4 コア ネットワークを介して互いに通信できるようになります。この実装では、転送は IP ヘッダー自体ではなくラベルに基づいているため、コア ルータのバックボーン インフラストラクチャのアップグレードおよび再設定も必要ありません。これは、IPv6 導入に非常に費用効果の高い方法を提供します。

また、MPLS 環境で本来提供されているバーチャル プライベート ネットワーク(VPN)サービスおよびトラフィック エンジニアリング(TE)サービスを使用して、IPv4 VPN および MPLS-TE をサポートするインフラストラクチャを介して IPv6 ネットワークを VPN やエクストラネットに組み込むことができます。

プロバイダー エッジ ルータおよびカスタマー エッジ ルータ上の IPv6

サービス プロバイダー エッジ ルータ

6PE は特に現在 MPLS ネットワークを実行するサービス プロバイダーに適用されます。利点の 1 つとして、コア ネットワークのハードウェア、ソフトウェア、または設定をアップグレードする必要がなく、動作および既存の IPv4 トラフィックによって生みだされる収益に影響がありません。多くのサービス プロバイダーが MPLS を使用して顧客にサービスを提供しています。マルチサービス インフラストラクチャのテクノロジーとしての MPLS は、レイヤ 3 VPN、QoS、トラフィック エンジニアリング、高速リルート、ATM の統合、および IP スイッチングを提供できます。

カスタマー エッジ ルータ

MPLS ネットワークに IPv6 を導入する最も簡単な方法は、CE ルータ上でトンネルを使用することです。これは、MPLS の動作またはインフラストラクチャに影響がなく、コア内の P ルータまたは PE ルータを変更する必要はありません。ただし接続する CE の数の増加に伴い、ISP のグローバル IPv6 プレフィックスの委任が困難になると、トンネル メッシュが必要です。

図 7 に、CE ルータ上のトンネルを使用したネットワーク アーキテクチャを示します。

図 7 CE ルータ上でトンネルを使用した IPv6

 

IPv6 プロバイダー エッジ マルチパス

IPv6 の内部および外部 BGP マルチパスによって、IPv6 ルータは、宛先に到達するために複数のパス(同じ隣接自律システム(AS)や Sub-AS、または同じメトリックなど)間のロード バランシングを行うことができます。6PE マルチパス機能では、マルチプロトコル内部 BGP(MP-iBGP)を使用して、MPLS IPv4 コア ネットワークを介して IPv6 ルートを配布し、MPLS ラベルを各ルートに付加します。

MP-IBGP マルチパスが 6PE ルータでイネーブルになっていると、MPLS 情報(ラベル スタック)を使用して、ラベルの付いたすべてのパスが、転送テーブルにインストールされます。この機能によって、6PE はロード バランシングを実行できます。

OSPFv3 6VPE

Open Shortest Path First バージョン 3(OSPFv3)IPv6 VPN プロバイダー エッジ(6VPE)機能は、Cisco IOS XR OSPFv3 実装に VPN ルーティングおよび転送(VRF)およびプロバイダー エッジからカスタマー エッジ(PE-CE)へのルーティングのサポートを追加します。この機能により次の内容が可能になります。

OSPFv3 ルーティング プロセスごとに複数の VRF サポート

OSPFV3 PE-CE 拡張

複数の VRF のサポート

OSPFv3 は複数の VRF を単一のルーティング プロセスでサポートしており、ルート プロセッサ(RP)リソースをあまり消費せずに VRF を数十~数百に拡張できます。

複数の OSPFv3 プロセスが、単一のルータで設定できます。大規模な VRF の導入では、これにより複数の RP をまたいでパーティション VRF 処理が可能になります。また、これはデフォルト ルーティング テーブルまたは影響の大きい VRF を通常の VRF から隔離するためにも使用されます。すべての VRF に単一プロセスを使用することを推奨します。必要に応じて、2 番目の OSPFv3 プロセスを、IPv6 ルーティング用に設定する必要があります。


) 最大 4 個の OSPFv3 プロセスがサポートされます。


OSPFv3 PE-CE 拡張

IPv6 プロトコルは、今日のカスタマー ネットワークで大きく導入されつつあります。サービス プロバイダー(SP)は、IPv4 プロトコルですでに提供されている VPN サービスに加えて、IPv6 プロトコルをサポートするために顧客にバーチャル プライベート ネットワーク サービスを提供することが可能である必要があります。

IPv6 をサポートするには、ルーティング プロトコルが VPN 環境での動作するために、追加拡張が必要です。OSPFv3 が PE-CE リンクで動作するためには、OSPFv3 への拡張が必要です。

VRF Lite

VRF-Lite 機能は、BGP または MPLS ベースのバックボーンなしの VRF の実装を可能にします。VRF-Lite では、PE ルータは VRF インターフェイスを使用して直接接続されます。OSPFv3 に場合、BGP または MPLS バックボーンを使用した導入とは反対に、VRF-Lite のシナリオで次の内容が異なる動作をする必要があります。

DN ビット処理:VRF-Lite 環境では、DN ビット処理はディセーブルです。

ABR のステータス:VRF コンテキスト(デフォルト VRF を除く)では、エリア 0 への接続性に関係なく、OSPFv3 ルータは自動的に ABR として設定されます。VRF-Lite 環境では、この自動 ABR のステータス設定がディセーブルです。


) VRF-Lite をイネーブルにするには、OSPFv3 VRF コンフィギュレーション サブモードで capability vrf-lite コマンドを発行します。


6PE/VPE の実装方法

ここでは、次の実装手順について説明します。

「6PE/VPE の設定」

「PE から PE コアの設定」

「PE から CE コアの設定」

「OSPFv3 を PE ルータと CE ルータ間のルーティング プロトコルに設定」

6PE/VPE の設定

ここでは、IPv4 クラウドを介して IPv6 プレフィックスを転送するように PE ルータの 6PE/VPE を設定する方法について説明します。

6PE/VPE を設定する PE ルータが IPv4 クラウドおよび IPv6 クラウドの両方に参加していることを確認します。


) 6PE の場合、両方のクラウドからのルートの学習には、BGP、OSPF、IS-IS、EIGRP、RIP、スタティックなどのCisco IOS XR ソフトウェアでサポートされているすべてのルーティング プロトコルを使用できます。ただし、6VPE の場合、ルートの学習には BGP、EIGRP、およびスタティック ルーティング プロトコルだけを使用できます。


手順の概要

1. configure

2. router bgp as-number

3. neighbor ip-address

4. address-family ipv6 labeled-unicast

5. exit

6. exit

7. address-family ipv6 unicast

8. allocate-label [ all | route-policy policy_name ]

9. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp as-number

 

RP/0/RSP0/CPU0:router(config)# router bgp 1

ルータが存在する自律システム(AS)を識別する番号を入力します。

2 バイトの番号の範囲は 1 ~ 65535 です。4 バイトの番号の範囲は 1.0 ~ 65535.65535 です。

ステップ 3

neighbor ip-address

 

RP/0/RSP0/CPU0:router(config-bgp)# neighbor 1.1.1.1

ボーダー ゲートウェイ プロトコル(BGP)ルーティング セッションを設定するネイバー設定モードを開始します。

ステップ 4

address-family ipv6 labeled-unicast

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# address-family ipv6 labeled-unicast

IPv6 ラベル付きユニキャスト アドレス プレフィックスを指定します。

(注) このオプションは、IPv6 ネイバー設定モード、および VRF ネイバー設定モードでも使用できます。

ステップ 5

exit

 

RP/0/RSP0/CPU0:router(config-bgp-nbr-af)# exit

BGP アドレス ファミリ サブモードを終了します。

ステップ 6

exit

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# exit

BGP ネイバー サブモードを終了します。

ステップ 7

address-family ipv6 unicast

 

RP/0/RSP0/CPU0:router(config-bgp)# address-family ipv6 unicast

IPv6 ユニキャスト アドレス プレフィックスを指定します。

ステップ 8

allocate-label [ all | route-policy policy_name ]

 

RP/0/RSP0/CPU0:router(config-bgp-af)# allocate-label all

指定された IPv4 ユニキャスト ルートの MPLS ラベルを割り当てます。

キーワードを使用すると、ネイバーにアドバタイズされる特定のルートのフィルタリングをより細かく制御できます。

ステップ 9

end

または

commit

 

RP/0/RSP0/CPU0:router(config-bgp-af)# end

または

RP/0/RSP0/CPU0:router(config-bgp-af)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

PE から PE コアの設定

ここでは、プロバイダー エッジ(PE)から PE コアを設定する方法について説明します。

VPN ルーティングおよび転送(VRF)の設定についての詳細は、『 Cisco ASR 9000 Series Aggregation Services Router Routing Configuration Guide 』の「 Implementing BGP on Cisco ASR 9000 Series Router 」モジュールを参照してください。

手順の概要

1. configure

2. router bgp

3. address-family vpnv6 unicast

4. bgp dampening [ half-life [ reuse suppress max-suppress-time ] | route-policy route-policy-name ]

5. bgp client-to-client reflection { cluster-id | disable }

6. neighbor ip-address

7. remote-as as-number

8. description text

9. password { clear | encrypted } password

10. shutdown

11. timers keepalive hold-time

12. update-source type interface-id

13. address-family vpnv6 unicast

14. route-policy route-policy-name { in | out }

15. exit

16. vrf vrf-name

17. rd { as-number : nn | ip-address : nn | auto }

18. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp as-number

 

RP/0/RSP0/CPU0:router(config)# router bgp 10

BGP AS 番号を指定し、BGP コンフィギュレーション モードを開始します。このモードでは、BGP ルーティング プロセスを設定できます。

ステップ 3

address-family vpnv6 unicast

 

RP/0/RSP0/CPU0:router(config-bgp)# address-family vpnv6 unicast

vpnv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション サブモードを開始します。

ステップ 4

bgp dampening [ half-life [ reuse suppress max-suppress-time ] | route-policy route-policy-name ]

 

RP/0/RSP0/CPU0:router(config-bgp-af)# bgp dampening 30 1500 10000 120

指定したアドレス ファミリに対して BGP ダンプニングを設定します。

ステップ 5

bgp client-to-client reflection { cluster-id | disable }

 

RP/0/RSP0/CPU0:router(config-bgp-af)# bgp client-to-client reflection disable

クライアント間のルート リフレクションを設定します。

ステップ 6

exit

 

RP/0/RSP0/CPU0:router(config-bgp-af)# exit

アドレス ファミリ コンフィギュレーション サブモードを終了します。

ステップ 7

neighbor ip-address

 

RP/0/RSP0/CPU0:router(config-bgp)# neighbor 10.1.1.1

BGP ルーティングのためにルータをネイバー コンフィギュレーション モードにして、ネイバーの IP アドレスを BGP ピアとして設定します。

ステップ 8

remote-as as-number

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# remote-as 100

ネイバーを作成し、リモート自律システム番号を割り当てます。

ステップ 9

description text

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# description neighbor 172.16.1.1

ネイバーの説明を提供します。description は、コメントを保存するために使用されます。ソフトウェアの機能には影響しません。

ステップ 10

password { clear | encrypted } password

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# password encrypted 123abc

2 つの BGP ネイバーの間の TCP 接続上で Message Digest 5(MD5)認証をイネーブルにします。

ステップ 11

shutdown

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# router bgp 1

指定されたネイバーのあらゆるアクティブ セッションを終了し、すべての関連するルーティング情報を削除します。

ステップ 12

timers keepalive hold-time

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# timers 12000 200

BGP ネイバーのタイマーを設定します。

ステップ 13

update-source type interface-id

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# update-source gigabitEthernet 0/1/5/0

ネイバーとの iBGP セッションを形成するときに、iBGP セッションが特定のインターフェイスのプライマリ IP アドレスをローカル アドレスとして使用できるようにします。

ステップ 14

address-family vpnv6 unicast

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# address-family vpvn6 unicast

VPN ネイバー アドレス ファミリ設定モードを開始します。

ステップ 15

route-policy route-policy-name { in | out }

 

RP/0/RSP0/CPU0:router(config-bgp-nbr-af)# route-policy pe-pe-vpn-in in

着信ルートのルーティング ポリシーを指定します。ポリシーを使用すると、ルートのフィルタリングやルート属性の変更ができます。

ステップ 16

route-policy route-policy-name { in | out }

 

RP/0/RSP0/CPU0:router(config-bgp-nbr-af)# route-policy pe-pe-vpn-out out

発信ルートのルーティング ポリシーを指定します。ポリシーを使用すると、ルートのフィルタリングやルート属性の変更ができます。

ステップ 17

exit

 

RP/0/RSP0/CPU0:router(config-bgp-nbr-af)# exit

アドレス ファミリ設定およびネイバー サブモードを終了します。

ステップ 18

vrf vrf-name

 

RP/0/RSP0/CPU0:router(config-bgp)# vrf vrf-pe

VRF インスタンスを設定します。

ステップ 19

rd { as-number : nn | ip-address : nn | auto }

 

RP/0/RSP0/CPU0:router(config-bgp-vrf)#
rd 345:567

ルート識別子を設定します。

ルータが自動的に VRF に一意の RD を割り当てるようにする場合は、auto キーワードを使用します。

ステップ 20

end

または

commit

 

RP/0/RSP0/CPU0:router(config-bgp-vrf)# end

または

RP/0/RSP0/CPU0:router(config-bgp-vrf)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

PE から CE コアの設定

ここでは、PE からカスタマー エッジ(CE)コアを設定する方法について説明します。

手順の概要

1. configure

2. router bgp

3. vrf vrf-name

4. bgp router-id ip-address

5. label-allocation-mode { per-ce | per-vrf }

6. address-family ipv6 unicast

7. redistribute { connected | static | eigrp }

8. neighbor ip-address

9. remote-as as-number

10. ebgp-multihop { maximum hops | mpls }

11. address-family ipv6 unicast

12. site-of-origin [ as-number : nn | ip-address : nn ]

13. as-override

14. allowas-in [ as-occurrence-number ]

15. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp as-number

 

RP/0/RSP0/CPU0:router(config)# router bgp 10

BGP AS 番号を指定し、BGP コンフィギュレーション モードを開始します。このモードでは、BGP ルーティング プロセスを設定できます。

ステップ 3

vrf vrf-name

 

RP/0/RSP0/CPU0:router(config-bgp)# vrf vrf-pe

VRF インスタンスを設定します。

ステップ 4

bgp router-id ip-address

 

RP/0/RSP0/CPU0:router(config-bgp-vrf)#bgp router-id 172.16.9.9

BGP スピーキング ルータの固定ルータ ID を設定します。

ステップ 5

label-allocation-mode { per-ce | per-vrf }

 

 

RP/0/RSP0/CPU0:router(config-bgp-vrf)# label-allocation-mode per-ce

CE ごとのラベル割り当てモードを設定して PE ルータでの追加ルックアップを回避し、ラベル スペースを節約します(デフォルトのラベル割り当てモードはプレフィックス単位)。このモードでは、PE ルータは、すべての即時ネクスト ホップ(ほとんどの場合、これは CE ルータ)に 1 個のラベルを割り当てます。このラベルはネクスト ホップに直接マップされるため、データ転送中に VRF ルート ルックアップが実行されることはありません。ただし、割り当てられるラベルの数は、各 VRF に 1 つではなく、各 CE に 1 個です。BGP はすべてのネクスト ホップを認識するため、各ネクスト ホップにラベルを割り当てます(各 PE-CE インターフェイスではありません)。発信インターフェイスがマルチアクセス インターフェイスで、ネイバーのメディア アクセス コントロール(MAC)アドレスが不明な場合は、アドレス解決プロトコル(ARP)がパケット転送の間にトリガーされます。

per-vrf キーワードは同じラベルを一意の VRF からアドバタイズされたすべてのルートに使用するように設定します。

ステップ 6

address-family ipv6 unicast

 

 

RP/0/RSP0/CPU0:router(config-bgp-vrf)# address-family ipv6 unicast

IPv6 アドレス ファミリ ユニキャストを指定し、アドレス ファミリ コンフィギュレーション サブモードを開始します。

このコマンドのすべてのキーワードと引数のリストを参照するには、CLI ヘルプ(?)を使用します。

ステップ 7

redistribute {connected | static | eigrp }

 

RP/0/RSP0/CPU0:router(config-bgp-vrf-af)#

指定したインスタンスからのルートが BGP に再配布されるようにします。

ステップ 8

neighbor ip-address

 

 

RP/0/RSP0/CPU0:router(config-bgp-vrf)#
neighbor 10.0.0.0

CE ネイバーを設定します。ip-address 引数は、プライベート アドレスである必要があります。

ステップ 9

remote-as as-number

 

 

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr)# remote-as 2

CE ネイバーのリモート AS を設定します。

ステップ 10

ebgp-multihop { maximum hops | mpls }

 

 

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr)# ebgp-multihop 55

直接接続していないネットワーク上の外部ピアへの BGP 接続を受け入れて試行するように CE ネイバーを設定します。

ステップ 11

address-family ipv6 unicast

 

 

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr)# address-family ipv6 unicast

IPv6 アドレス ファミリ ユニキャストを指定し、アドレス ファミリ コンフィギュレーション サブモードを開始します。

このコマンドのすべてのキーワードと引数のリストを参照するには、CLI ヘルプ(?)を使用します。

ステップ 12

site-of-origin [ as-number:nn | ip-address:nn ]

 

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)# site-of-origin 234:111

site-of-origin(SoO)拡張コミュニティを設定します。この CE ネイバーから学習されたルートは、その他の PE にアドバタイズされる前に SoO 拡張コミュニティのタグが付けられます。PE ルータで as-override が設定されている場合にループを検出する目的で SoO が使用されることがよくあります。プレフィックスが同じサイトにループする場合、PE はこのことを検出して CE に更新を送信しません。

ステップ 13

as-override

 

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)# as-override

PE ルータで AS オーバーライドを設定します。これにより、PE ルータは CE の ASN と自分(PE)の ASN を置き換えます。

(注) この情報が失われることが原因でルーティング ループが発生することがあります。as-override によって引き起こされるループを防ぐには、as-override と site-of-origin を組み合わせて使用します。

ステップ 14

allowas-in [ as-occurrence-number ]

 

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)# allowas-in 5

PE 自律システム番号(ASN)を持つ AS パスを指定された回数だけ許可します。

ハブ アンド スポーク型 VPN ネットワークは、HUB CE を通じて、HUB PE へのルーティング情報のループ バックを必要とします。この場合、PE ASN が存在するために HUB PE によってループバック情報がドロップされます。これを回避するため、PE ASN が指定された回数に達していても allowas-in コマンドを使用してプレフィックスを許可します。

ステップ 15

end

または

commit

 

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)#
end

または

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

OSPFv3 を PE ルータと CE ルータ間のルーティング プロトコルに設定

プロバイダー エッジ(PE)からカスタマー エッジ(CE)へ Open Shortest Path First バージョン 3(OSPFv3)を使用するルーティング セッションを設定するには、次の作業を実行します。

手順の概要

1. configure

2. router ospfv3 process-name

3. vrf vrf-name

4. capability vrf-lite

5. router-id { router-id | type interface-path-id }

6. domain-id type { 0005 | 0105 | 0205 | 8005 } value domain-id

7. redistribute bgp process-id [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]
または
redistribute connected [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]
または
redistribute ospf process-id [ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ]}] [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]
または
redistribute static [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]
または
redistribute eigrp process-id [ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ]}] [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]
または
redistribute rip [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]

8. area area-id

9. interface type interface-path-id

10. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router ospf process-name

 

RP/0/RSP0/CPU0:router(config)# router ospf 109

OSPF 設定モードを開始します。このモードでは、OSPF ルーティング プロセスの設定を行えます。

ステップ 3

vrf vrf-name

 

RP/0/RSP0/CPU0:router(config-ospf)# vrf vrf_1

VPN ルーティングおよび転送(VRF)インスタンスを設定し、OSPF ルーティングの VRF 設定モードを開始します。

ステップ 4

capability vrf-lite

 

RP/0/RSP0/CPU0:router(config-ospf-vrf)# capability vrf-lite

VRF 機能をイネーブルにします。

ステップ 5

router-id { router-id | type interface-path-id}

 

RP/0/RSP0/CPU0:router(config-ospf-vrf)# router-id 172.20.10.10

VRF のルータ ID を設定します。

(注) VRF 単位でルータ ID の設定が必要です。

ステップ 6

domain-id type {0005 | 0105 | 0205 | 8005} value domain-id

 

RP/0/RSP0/CPU0:router(config-ospf-vrf)# domain-id type 0005 value CAFE00112233

ドメイン ID を指定します。

ステップ 7

redistribute bgp process-id [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]

または

redistribute connected [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]

または

redistribute ospf process-id [ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ]}] [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]

または

redistribute static [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]

または

redistribute eigrp process-id [ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ]]}[ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]

または

redistribute rip [ metric metric-value ] [ metric-type { 1 | 2 }] [ route-policy policy-name ] [ tag tag-value ]

 

RP/0/RSP0/CPU0:router(config-ospf-vrf)# redistribute connected

ルートが OSPF に再配布されるようにします。OSPF に再配布できるルートは次のとおりです。

ボーダー ゲートウェイ プロトコル(BGP)

接続済み

Enhanced Interior Gateway Routing Protocol(EIGRP)

OSPF

スタティック

ルーティング情報プロトコル(RIP)

ステップ 8

area area-id

 

RP/0/RSP0/CPU0:router(config-ospf-vrf)# area 0

OSPF エリアをエリア 0 として設定します。

ステップ 9

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config-ospf-vrf-ar)# interface GigabitEthernet 0/3/0/0

インターフェイス GigabitEthernet 0/3/0/0 をエリア 0 に関連付けます。

ステップ 10

end

または

commit

 

RP/0/RSP0/CPU0:router(config-ospf-vrf-ar-if)# end

または

RP/0/RSP0/CPU0:router(config-ospf-vrf-ar-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

6PE の設定例

ここでは、次の設定例について説明します。

「PE ルータでの 6PE の設定:例」

「PE ルータでの 6VPE の設定:例」

PE ルータでの 6PE の設定:例

この設定例では、PE ルータでの 6PE の設定を示します。

interface GigabitEthernet0/3/0/0
ipv6 address 2001::1/64
!
router isis ipv6-cloud
net 49.0000.0000.0001.00
address-family ipv6 unicast
single-topology
interface GigabitEthernet0/3/0/0
address-family ipv6 unicast
!
!
router bgp 55400
bgp router-id 54.6.1.1
address-family ipv4 unicast
!
address-family ipv6 unicast
network 55:5::/64
redistribute connected
redistribute isis ipv6-cloud
allocate-label all
 
!
neighbor 34.4.3.3
remote-as 55400
address-family ipv4 unicast
!
address-family ipv6 labeled-unicast

PE ルータでの 6VPE の設定:例

この設定例では、PE ルータでの 6VPE の設定を示します。

vrf vpn1
address-family ipv6 unicast
import route-target
200:2
!
export route-target
200:2
 
interface Loopback0
ipv4 address 10.0.0.1 255.255.255.255
 
interface GigabitEthernet0/0/0/1
vrf vpn1
ipv6 address 2001:c003:a::2/64
 
router bgp 1
bgp router-id 10.0.0.1
bgp redistribute-internal
bgp graceful-restart
address-family ipv4 unicast
!
 
address-family vpnv6 unicast
!
neighbor 10.0.0.2 >>>> Remote peer loopback address.
remote-as 1
update-source Loopback0
address-family ipv4 unicast
!
address-family vpnv6 unicast
route-policy pass-all in
route-policy pass-all out
!
 
vrf vpn1
rd 100:2
bgp router-id 140.140.140.140
address-family ipv6 unicast
redistribute connected
!
 
neighbor 2001:c003:a::1
remote-as 6502
address-family ipv6 unicast
route-policy pass-all in
route-policy pass-all out
!

PE から CE 間の OSPFv3 の設定: 例

次に、プロバイダー エッジ(PE)からカスタマー エッジ(CE)へ Open Shortest Path First バージョン 3(OSPFv3)を使用するルーティング セッションを設定する例を示します。

router ospfv3 0
vrf V1
router-id 100.0.0.2
domain-id type 0005 value CAFE00112233
domain-id secondary type 0105 value beef00000001
domain-id secondary type 0205 value beef00000002
capability vrf-lite
redistribute bgp 1
area 0
interface POS0/3/0/1
vrf V2
router-id 200.0.0.2
capability vrf-lite
area 1
interface POS0/3/0/2
 
 

その他の関連資料

この機能に関する詳細については、次の資料を参照してください。

関連資料

 

関連項目
マニュアル タイトル

スタートアップ資料

『Cisco ASR 9000 Series Aggregation Services Router Getting Started Guide

標準

 

標準1
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--

1.サポートされている規格がすべて記載されているわけではありません。

MIB

 

MIB
MIB のリンク

--

Cisco IOS XR ソフトウェアを使用している MIB を特定してダウンロードするには、次の URL にある Cisco MIB Locator を使用し、[Cisco Access Products] メニューからプラットフォームを選択します。 http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

 

RFC
タイトル

--

--

シスコのテクニカル サポート

 

説明
リンク

シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクなどの、数千ページに及ぶ技術情報が検索可能です。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/en/US/support/index.html