Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ IP アドレスおよびサービス コンフィギュレーションガイド リリース 4.3.x
ビデオ モニタリングの実装
ビデオ モニタリングの実装
発行日;2013/08/06   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

ビデオ モニタリングの実装

ビデオ モニタリングの設定は、関連するクラスマップとポリシーマップの設定、インターフェイスへのビデオ モニタリング ポリシーのバインドなどを含む 4 ステップの手順です。

ビデオ モニタリングの実装の前提条件

  • 適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。
  • 高度なビデオ サービスのためのパッケージをインストールしてアクティブ化する必要があります。 オプション パッケージのインストールの詳細については、 『Cisco ASR 9000 Series Aggregation Services Router Getting Started Guide』を参照してください。
  • マルチキャスト ルーティング ソフトウェアのパッケージをインストールしてアクティブ化し、システムでマルチキャスト ルーティングをイネーブルにする必要があります。 ビデオ モニタリングは、マルチキャストがイネーブルになっているインターフェイスでサポートされます。 マルチキャスト ルーティングの詳細については、「Implementing Layer 3 Multicast Routing on Cisco ASR 9000 シリーズ ルータ」の章を参照してください。

ビデオ モニタリングの実装に関する情報

ビデオ モニタリング

ビデオ環境の低下は、サービス プロバイダーにとってサービス コストや収益の損失の面で大きな懸念要因となります。 ヘルプ デスク時間、NOC(ネットワーク オペレーション センター)トラブルシューティング リソース、およびトラック ロールのサービス コストを回避するには、ビデオ トラフィックをモニタする機能が不可欠です。 Cisco IOS XR ソフトウェアでは、ビデオ モニタリングによってビデオ フローの問題を簡単に診断できます。

ビデオ モニタリングの概要

パケット損失は、ビデオ品質低下の一般的な原因の 1 つです。 その影響は、圧縮されたビデオ フローでさらに大きくなります。 サービス プロバイダーの IP ネットワークで送信されるビデオ トラフィックは、ほとんどが圧縮されたビデオ(MPEG または同様の符号化)です。 圧縮の方法により、トラフィックは非常に損失の影響を受けやすくなります。 ビデオは数秒ごとに独立したフレーム(I-frame)で符号化され、後続のフレームは I-frame からのデルタになります。 I-frame で損失が発生すると、3 ミリ秒のトラフィック(約 1 個の IP パケット)損失により、最大 1.2 秒間表示が低下する可能性があります。

ジッターは重要なフロー特性で、エンド デバイスでバッファ プロビジョニングを慎重に行う必要があります。 画面にメディアを表示するセット トップ ボックス(STB)でビデオをリアルタイムにデコードする必要があります。 着信ビデオ ストリームをバッファに格納して、イメージをスムーズにデコードおよび表示できるようにします。 ネットワーク ジッターが大きい場合は、STB でバッファ アンダーランやバッファ オーバーランが発生する可能性があります。 ジッターの大きさに応じて、ディスプレイで視覚的なアーティファクトやブラック スクリーンが発生します。

ブロードキャスト専用のアプリケーションでは、転送におけるエンドツーエンドの遅延は重要ではありません。 ただし、ビデオ アプリケーションはよりインタラクティブになっているため、エンドツーエンドの遅延が重要な Quality of Experience(QoE)コンポーネントになります。 データ損失は QoE 低下の主な原因です。

QoE 低下の主な原因は次の 3 つにまとめられます。

  • パケット ロス
  • ジッター
  • 遅延

ビデオ モニタリングは、ビデオ品質の向上および QoE の拡張において大きな役割を果たします。 ビデオ モニタリングはルータに実装され、ネットワーク オペレータはフローごとにビデオ転送パフォーマンスを測定および追跡できます。 ビデオ パケットはルータを通過します。 パケット ヘッダーを使用して、ビデオ品質に影響を及ぼすネットワークのパフォーマンスの尺度を示すメトリックを計算できます。 同じフローについて複数のルータから取得したこの情報を比較して、ネットワークにおけるビデオ問題および影響を受けるフローをエンドツーエンドで明確に把握できます。

ビデオ モニタリングによってビデオ フロー(一般的にはストリーミング フロー)の問題を診断できます。 ビデオ モニタリングの目的は、QoE 低下の原因となるネットワークによる混乱や異常を検出することです。つまり、ストリーミング(ビデオ)トラフィックの転送パフォーマンスを測定します。 符号化エラー、オーディオとビデオ間のラグ、およびその他のエラーも QoE 低下の原因となります。 ただし、これらはネットワークではなく符号化デバイスで発生します。 これらの後者のエラーはモニタされません。

ビデオ モニタリングでサポートされる主要機能

データ プレーンからの直接測定

ビデオ モニタリングは、ビデオ品質の向上および QoE の拡張において大きな役割を果たします。 Cisco ASR 9000 シリーズ ルータに実装されたビデオ モニタリングを使用することで、ネットワーク オペレータはリアルタイムにフローごとのビデオ転送パフォーマンスを測定および追跡できます。 従来のトラフィック モニタリング ソリューション(サンプリング対象のフローをコントロール プレーン、またはルータ上の専用ブレードなどの他のハードウェアに送信する必要があります)とは対照的に、Cisco ASR 9000 シリーズ ルータのビデオ モニタリングでは、データ プレーン自体でモニタリング操作を実行します。 これにより、転送されたパケットをリアルタイムに分析し、ビデオ品質に影響を及ぼすネットワークのパフォーマンスの尺度を示すメトリックを計算できます。

ローカル ストレージおよびリモート アクセス

ビデオ モニタリングでは、有線と同じ速度でパケット損失およびジッターを測定し、収集した情報をルータに保存して、ネットワーク オペレータがユーザ インターフェイスを介してその情報にアクセスできるようにします。 さらに、測定されて複数のルータに保存されたパフォーマンス メトリックにリモート オペレーション センターから標準の SNMP を介してアクセスできます。 これらのメトリックにより、構成および分析できるビデオ フローをエンドツーエンドで明確に把握できます。

プロアクティブおよびリアクティブな用途

Cisco ASR 9000 シリーズ ルータのビデオ モニタリングには、サービス プロバイダーのためのリアクティブな用途とプロアクティブな用途があります。 ビデオ モニタリングは、サービス カバレッジを新しいカスタマーに拡大する前に、ビデオ サービスの品質を確認する目的で使用できます。 また、強力な分析ツールであり、カスタマー コールのトラブルシューティングに使用できます。 ネットワーク オペレータは、パケット損失、ジッター、フロー レート、フロー数などの変動など、各種イベントに対してアラームを発生させるようにビデオ モニタリングを設定できます。 このようなアラームは、有効な値または範囲でトリガーされるように設定できます。

ビデオ モニタリング上のフロー

ビデオ モニタリングでは、4 つのパケット ヘッダー フィールドを使用して一意のフローを識別します。それらのフィールドは、送信元 IP アドレス、宛先 IP アドレス、送信元 UDP ポート、および宛先 UDP ポート(これはプロトコル ID が常に UDP であることを示します)です。

ユニキャストおよびマルチキャスト

ビデオ モニタリングでは、IP ヘッダーに IPv4 マルチキャスト宛先アドレスを含むフローのモニタリングだけでなく、ユニキャスト宛先アドレスを含むフローのモニタリングもサポートされます。 ユニキャスト フローのビデオ モニタリング機能のサポートは、ASR 9000 Ethernet ラインカードとの下位互換性を提供し、ASR 9000 Enhanced Ethernet ラインカードでも使用できます。

フロー レート タイプおよびプロトコル レイヤ

ビデオ モニタリングでは、IP レイヤで CBR(固定ビット レート)フローをモニタします。 つまり、IPv4 パケット内の UDP データグラムにカプセル化され CBR で符号化されたメディア ストリーム(たとえば MPEG-2)をモニタできます。 ビデオ モニタリングを使用すると、(メディア パケットの数およびサイズとともに)IP レイヤのパケット レートまたはメディア レイヤのビット レートを設定できます。

メトリック

ビデオ モニタリングでは、IP-UDP レベルの MDI(Media Delivery Index、RFC 4445)定義に従ったパケット損失とジッターの両方のメトリックがサポートされます。 MDI メトリックは、MLR(メディア損失レート)と DF(遅延係数)です。 ビデオ モニタリングでは、MDI MLR の拡張である MRV(メディア レート変動)を使用します。つまり、MLR は損失のみをキャプチャし、MRV は損失と超過の両方をキャプチャします。 ビデオ モニタリングの DF は MDI 定義と同じです。DF はモニタ対象の MDI ジッターに加えて 1 つの公称パケット到着間隔時間を表します。 ビデオ モニタリングでは、2 つの主要メトリックとともに、パケット数、バイト数、パケット レート、ビット レート、パケット サイズ、IP ヘッダー内の TTL(存続可能時間)フィールド、フロー数、発生したアラーム、および各種イベントのタイム スタンプがサポートされます。


(注)  


MDI ジッターという用語は、ビデオ モニタリングで測定された DF メトリックの正当性を示すために使用されます。 MDI ジッターは、実際のパケット到着時間を公称到着参照と比較することによって測定され、簡単なパケット間ジッターは、2 つの連続するパケット到着時間の差で測定されます。 前者は後者よりも正確に CBR フローのパフォーマンスをキャプチャします。


フロー数

現在のリリースでは、Cisco ASR 9000 シリーズ ルータのビデオ モニタリングは、ユニキャスト トラフィックとマルチキャスト トラフィックの組み合わせについて、ASR 9000 Ethernet ラインカードでは NP(ネットワーク プロセッサ)あたり 1024 フローをサポートし、ASR 9000 Enhanced Ethernet ラインカードでは NP あたり最大 4096 フローをサポートします。 各ライン カードまたは各システムの最大フローの数は、ラインカード上の NP の数およびシステム上のラインカードの数によって異なります。 シャーシごとのフロー スケールは、シャーシ上の NP の数によって異なります。

たとえば、4 個の ASR 9000 Ethernet ラインカードを搭載した Cisco ASR 9000 シリーズ ルータボックスがあり、各 LC に 8 個の NP が搭載されている場合、シャーシごとのフロー スケールは最大 1K*8 = 8K フローになります。

ハイ アベイラビリティ機能

Cisco ASR 9000 シリーズ ルータのビデオ モニタリングでは、各レベルでハイ アベイラビリティがサポートされます。 ビデオ モニタリングは、プロセスの OIR(活性挿抜)、ラインカードの OIR、RSP(ルート スイッチ プロセッサ)のフェールオーバーと、ルータのリロードをサポートします。 設定はすべてのハイ アベイラビリティ シナリオで永続的です。 モニタされた統計データは、プロセスの OIR および RSP FO 時に保持されます。

インターフェイスのタイプおよび方向

ビデオ モニタリングをアクティブ化するには、インターフェイスに対してビデオ モニタリング サービス ポリシーを設定する必要があります。 ビデオ モニタリング ポリシーを関連付けることができるインターフェイスには 4 つのタイプがあります。これらは、メイン インターフェイス、サブインターフェイス、イーサネット バンドル インターフェイス、およびイーサネット バンドル サブインターフェイスです。 ビデオ モニタリングでは、レイヤ 3 インターフェイスのみサポートされ、レイヤ 2 インターフェイスはサポートされません。 ビデオ モニタリングは、インターフェイスの入力方向にのみ設定できます。

フロー レートと DF 精度

Cisco ASR 9000 シリーズ ルータのビデオ モニタリングでは、1 ミリ秒の精度の DF メトリック パフォーマンスが提供されます。

ビデオ モニタリングは、最大 100 Mbps のフロー レートの標準画質(SD)ビデオ トラフィック(圧縮率の高いビデオ トラフィック)をサポートします。 圧縮されていないビデオ ストリームの場合、最大 3 Gbps のフロー レートがサポートされます。

入力のユーザ インターフェイス

ビデオ モニタリングでは、設定について MQC(モジュラ QoS 設定)構文に従った従来の CLI(コマンドライン インターフェイス)入力がサポートされます。 アクセス コントロール リスト(ACL)、クラスマップ、およびポリシーマップを設定してビデオ モニタリングを設定できます。ビデオ モニタリングは、サービス ポリシーをインターフェイスに関連付けることによってアクティブ化できます。 その場でのポリシーの変更はサポート対象です。 設定済みのサービス ポリシーをインターフェイスに関連付けた後で変更するには、インターフェイスとの関連付けを解除する必要があります。

出力のユーザ インターフェイス

ビデオ モニタリングでは、モニタされた統計を取得するための各種 show コマンドと clear コマンドが提供されます。 ビデオ モニタリング コマンドの詳細については、 『Cisco ASR 9000 Series Aggregation Services Router Multicast Command Reference』の「Video Monitoring Commands on Cisco ASR 9000 シリーズ ルータ」のモジュールを参照してください。

TCA(しきい値超過アラート)をポリシーマップの一部として設定して、ビデオ モニタリングによるさまざまな状況に関する syslog メッセージの生成を可能にすることができます。 show コマンドまたは SNMP pull を使用してスタンディング アラームを取得することもできます。 XML はビデオ モニタリングではサポートされません。

クラスマップとポリシーマップの数

ビデオ モニタリングを使用するには、データ プレーンでモニタするフローを決定するフィルタとして機能するクラスマップとポリシーマップを設定する必要があります。 ビデオ モニタリングでは、ポリシーマップあたり最大 1024 のクラスマップとシステムあたり最大 1024 のクラスマップがサポートされます。 システム全体で最大 256 のポリシーマップがサポートされます。

ビデオ PIE のインストール

ビデオ モニタリングを使用するには、ビデオ PIE をインストールする必要があります。 RSP タイプに応じて、ビデオ PIE の名前に 2 つのバージョンがあります。

  • asr9k-video-p.pie(RSP2 バージョン)
  • asr9k-video-px.pie(RSP3 バージョン)

ビデオ モニタリングのトラップおよびクローン

トラップおよびクローンは、基本的なパフォーマンス モニタリング サービス機能の拡張です。選択した数のフローからのパケットをフィルタ(トラップ)、複製(クローン)、およびネットワーク上のリモート デバイスに送信して、ビデオ品質をより詳細に分析できます。 クローンされたパケットは、マルチキャスト転送プロセスによって、パフォーマンス トラフィック クローン プロファイルで指定されたインターフェイスにレプリケートされます。 リモート デバイスは、MPEG レイヤ レベルでデータを詳細に分析できます。 このデバイスは、デバッグ ツールとしてもモニタリング ツールとしても使用できます。 同じルータ上のサービス エンジン ブレードとしても使用できます。 マルチキャスト フローの場合、トラップおよびクローン機能は完全に下位互換性があります。ただし、ユニキャスト フローの場合、この機能は Typhoon LC 上のレイヤ 3 スイッチド ポート アナライザ(SPAN)でのみサポートされます。


(注)  


L3 SPAN では SNMP はサポートされません。 L3 SPAN の詳細については、「Configuring SPAN」を参照してください。


ビデオ モニタリングの用語

Cisco ASR 9000 シリーズ ルータにビデオ モニタリング サービスを実装して設定するには、まずビデオ モニタリングの用語と概念を理解する必要があります。

インターバル間隔およびインターバル アップデート

ビデオ モニタリングでは、ユーザによって設定されたインターバル期間と呼ばれる時間、データ プレーン上のすべてのパケットを継続的に分析します。 統計情報は、各インターバル期間の最後に定期的にエクスポートされます。 これらのエクスポートされた統計情報はインターバル アップデートと呼ばれます。 ビデオ モニタリングのフローおよびその遷移のステータスは、これらのインターバル アップデートに関してのみ説明されます。 また、これらのインターバル アップデートに関して、エクスポートされたすべてのビデオ モニタリング フロー統計情報が格納されます。

インターバル期間は、重要なビデオ モニタリング パラメータです。 ビデオ モニタリング設定では、エクスポート頻度、保存するエクスポート数、非アクティブなフローを削除する時間などの機能についてインターバル期間を決定します。 (フローの停止およびパフォーマンスの低下を伴うフローに対する)アラームの発生などのすべてのビデオ モニタリング機能は、インターバル アップデートの内容に基づきます。

ビデオ モニタリング フロー

ビデオ モニタリング フローは、ヘッダー フィールドが設定済みのクラスマップ(およびそれに関連付けられたアクセス コントロール リスト)に一致するパケット ストリームのインスタンスです。 一意のフローは、ビデオ モニタリング サービス ポリシーが関連付けられているインターフェイスに対してローカルです。 ビデオ モニタリング フローは一連の保存済みインターバル アップデートで構成されます。 モニタリング インターバル後にビデオ モニタリングで作成された一意のフローは新規フローと呼ばれます。 そのため、存続期間が 1 回のモニタリング インターバルよりも短いパケット ストリームは、ビデオ モニタリング フローとしてエクスポートされず、保存されません。

フローの停止

ルータが 1 回のインターバル アップデート以上の期間、モニタ対象フローでのパケットの受信を停止した場合、そのモニタ対象フローは停止していると見なされます。

フローの再開

停止されたビデオ モニタリング フローでパケットの受信が再開されると、通常のインターバル アップデートが次のモニタリング インターバルでエクスポートされます。 再開されたフローには、1 回以上のゼロ インターバルがあり、その後に通常のインターバル アップデートが続きます。

フローのスイッチオーバー

イーサネット バンドル インターフェイスまたはイーサネット バンドル サブインターフェイス上のビデオ モニタリング フローは、ある物理メンバ インターフェイスから別のインターフェイスに移動する場合があります。つまり、パケット ストリームがあるインターフェイスでフローを停止し、別のインターフェイスでフローを再開します。 これはフローのスイッチオーバーと定義されています。 この場合、両方のインターフェイスが同じラインカード上にあれば、ビデオ モニタリングはスイッチオーバー前のフローとスイッチオーバー後のフローを同じフローとして処理します。 それ以外の場合、2 つの異なるフローとして処理します。

フローの削除

停止されたビデオ モニタリング フローが(モニタリング インターバルの数に関して)設定されたタイムアウトの間ゼロ インターバルをエクスポートし続ける場合、フローはデッドと見なされ、削除対象としてマークされます。 ユーザが非アクティブ フローを制御できる期間は、タイムアウト パラメータを使用して指定されます。 マークされたすべてのフローの実際の削除は、定期的なスイープ機能により少し遅れて実行されます。スイープ機能は、Trident LC では 150 秒ごと、Typhoon LC では 60 秒ごとに実行されます。 フローが削除されると、すべてのエクスポート済み統計情報(ゼロ インターバルを含む一連のインターバル アップデート)は完全にストレージから削除されます。

ビデオ モニタリングの実装

ビデオ モニタリングの設定は、関連するクラスマップとポリシーマップの設定、インターフェイスへのビデオ モニタリング ポリシーのバインドなどを含む 4 ステップの手順です。

IPv4 アクセス リストの作成

この手順は、一般的な IPv4 アクセス リストの作成および設定の手順に似ています。 ここでは、クイック リファレンスとしてビデオ モニタリングの ACL の設定例を示します。 詳細については、 『Cisco ASR 9000 Series Aggregation Services Router IP Addresses and Services Configuration Guide』の「Implementing Access lists and Prefix lists」の章を参照してください。

このタスクでは、標準 IPv4 アクセス リストを設定します。

標準アクセス リストでは、照合操作に送信元アドレスを使用します。


(注)  


ビデオ モニタリング ポリシーでは、ACL 設定で deny ステートメントを使用できますが、deny ステートメントは、permit として扱われます。 また、log または log-input は ACL 設定ではサポートされません。


手順の概要

    1.    configure

    2.    ipv4 access-list name

    3.    [sequence-number] remark remark

    4.    [sequence-number] permit udp source [source-port] destination [destination-port]

    5.    必要に応じてステップ 4 を繰り返し、シーケンス番号でステートメントを追加します。 エントリを削除するには、no sequence-number コマンドを使用します。

    6.    次のいずれかのコマンドを使用します。

    • end
    • commit


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 configure


    例:
    RP/0/RSP0/CPU0:router# configure
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2ipv4 access-list name


    例:
    RP/0/RSP0/CPU0:router# ipv4 access-list acl_1
    
    
     

    IPv4 アクセス リスト コンフィギュレーション モードを開始し、アクセス リスト acl_1 を設定します。

     
    ステップ 3[sequence-number] remark remark


    例:
    RP/0/RSP0/CPU0:router(config-ipv4-acl)# 10 remark Do not allow user1 to telnet out
    
    
     

    (任意)名前付きアクセス リストで後続の permit ステートメントに関するコメントを記述できます。

    • 注釈は最大 255 文字まで可能で、これより長い文字は切り捨てられます。
    • 注釈は permit ステートメントの前後に設定できますが、一貫性のある場所にする必要があります。
     
    ステップ 4[sequence-number] permit udp source [source-port] destination [destination-port]


    例:
    RP/0/RSP0/CPU0:router(config-ipv4-acl)# 20 permit udp 172.16.0.0/24 eq 5000 host 225.0.0.1 eq 5000
    
    
     

    次の条件を指定して送信元ポートと宛先ポートを指定できます。

    • ビデオ モニタリングでは udp のみサポートされます。
    • パケットの送信元のネットワークまたはホスト番号を指定するには、source キーワードを使用します。
    • 送信元に適用するワイルドカード ビットを指定するには、オプションの source-wildcard 引数を使用します。
    • パケットの送信先のネットワークまたはホスト番号を指定するには、destination キーワードを使用します。
    • 宛先に適用するワイルドカード ビットを指定するには、オプションの destination-wildcard 引数を使用します。
     
    ステップ 5必要に応じてステップ 4 を繰り返し、シーケンス番号でステートメントを追加します。 エントリを削除するには、no sequence-number コマンドを使用します。 

    アクセス リストは変更できます。

     
    ステップ 6次のいずれかのコマンドを使用します。
    • end
    • commit


    例:
    RP/0/RSP0/CPU0:router(config)# end

    または

    RP/0/RSP0/CPU0:router(config)# commit
     

    設定変更を保存します。

    • end コマンドを実行すると、変更をコミットするように要求されます。
      Uncommitted changes found, commit them
      before exiting(yes/no/cancel)? [cancel]:
      
      • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
      • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
      • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
    • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
     

    クラスマップの設定

    ここでは、フロー分類子を設定します。 これは個々のフローに一致するか、いくつかのフローに一致する集約フィルタである場合があります。

    手順の概要

      1.    configure

      2.    class-map type traffic class-map-name

      3.    match access-group ipv4 acl-name

      4.    end-class-map

      5.    次のいずれかのコマンドを使用します。

      • end
      • commit


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 configure


      例:
      RP/0/RSP0/CPU0:router# configure
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2class-map type traffic class-map-name


      例:
      RP/0/RSP0/CPU0:router(config)# class-map type traffic class1
      
      
       

      クラスマップ モードを開始します。 クラスマップ タイプは常に traffic として入力する必要があります。

       
      ステップ 3match access-group ipv4 acl-name


      例:
      RP/0/RSP0/CPU0:router(config-cmap)# match access-group ipv4 acl1
      
      
       

      このクラスに一致させる ACL を入力します。 各クラスに一致させることができる ACL は 1 つだけです。

       
      ステップ 4end-class-map


      例:
      RP/0/RSP0/CPU0:router(config-cmap)# end-class-map
      
      
       

      クラスマップの設定を完了します。

       
      ステップ 5次のいずれかのコマンドを使用します。
      • end
      • commit


      例:
      RP/0/RSP0/CPU0:router(config)# end

      または

      RP/0/RSP0/CPU0:router(config)# commit
       

      設定変更を保存します。

      • end コマンドを実行すると、変更をコミットするように要求されます。
        Uncommitted changes found, commit them
        before exiting(yes/no/cancel)? [cancel]:
        
        • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
        • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
        • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
      • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
       

      ポリシーマップの設定

      ビデオ モニタリングのポリシーマップは、performance-traffic タイプです。 ビデオ モニタリングのポリシーマップでは、階層の 1 レベルのみがサポートされます。 つまり、階層型ポリシーマップ設定はビデオ モニタリングではサポートされません。

      ビデオ モニタリングのポリシーマップ設定は次の 3 つで構成されます。

      • フロー パラメータ設定:インターバル期間、必須履歴インターバル、タイムアウトなど、モニタするフローの各種プロパティを指定します。
      • メトリック パラメータ設定:モニタするフローについて計算する必要があるメトリックを指定します。
      • 反応パラメータ設定:フローについて生成するアラートのベースとなるパラメータを指定します。

      設定階層は、policyclassflow の順です。 つまり、上で指定されたすべてのパラメータは、ポリシーマップ内の特定のクラスに一致するすべてのフローに適用されます。 特定のクラスに一致するフローに対するフロー パラメータと反応パラメータの指定はオプションですが、メトリック パラメータは必須です。

      メトリック パラメータを使用したポリシーマップの設定

      ポリシーマップのメトリック パラメータは次のとおりです。

      • レイヤ 3 パケット レート
      • メディア ビット レート(指定された UDP ペイロードにおけるメディア パケット カウントの数およびサイズによる)

      (注)  


      レイヤ 3 パケット レートおよびメディア レートには、相互に排他的なコンフィギュレーション コマンドがあります。


      ここでは、各メトリック パラメータの設定について説明します。

      レイヤ 3 パケット レート
      手順の概要

        1.    configure

        2.    policy-map type performance-traffic policy-map-name

        3.    class type traffic class-name

        4.    monitor metric ip-cbr

        5.    rate layer3 packet packet-rate pps

        6.    次のいずれかのコマンドを使用します。

        • end
        • commit


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 configure


        例:
        RP/0/RSP0/CPU0:router# configure
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2policy-map type performance-traffic policy-map-name


        例:
        RP/0/RSP0/CPU0:router(config)# policy-map type performance-traffic policy1
        
        
         

        ポリシーマップ モードを開始します。 ポリシーマップ タイプは常に performance traffic として入力する必要があります。

         
        ステップ 3class type traffic class-name


        例:
        RP/0/RSP0/CPU0:router(config-pmap)# class type traffic class-name
        
        
         

        このポリシーに一致させるクラスマップを入力します。 1 つのポリシーに対して複数のクラスを指定できます。

         
        ステップ 4monitor metric ip-cbr


        例:
        RP/0/RSP0/CPU0:router(config- pmap-c)# monitor metric ip-cbr
        
        
         

        IP-CBR メトリック モニタ サブモードを開始します。

        (注)     

        現在は IP-CBR メトリック モニタリングのみがビデオ モニタリングでサポートされています。

         
        ステップ 5rate layer3 packet packet-rate pps


        例:
        RP/0/RSP0/CPU0:router(config-pmap-c-ipcbr)# rate layer3 packet packet-rate pps
        
        
         

        IP レイヤ 3 パケット レートをパケット/秒(pps)単位で指定します。

         
        ステップ 6次のいずれかのコマンドを使用します。
        • end
        • commit


        例:
        RP/0/RSP0/CPU0:router(config)# end

        または

        RP/0/RSP0/CPU0:router(config)# commit
         

        設定変更を保存します。

        • end コマンドを実行すると、変更をコミットするように要求されます。
          Uncommitted changes found, commit them
          before exiting(yes/no/cancel)? [cancel]:
          
          • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
          • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
          • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
        • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
         
        メディア ビット レート

        メディア ビット レートのメトリック パラメータは、メディア ビット レート、メディア パケット カウント、およびパケット サイズで構成されます。 レート メディア オプションを使用すると、1 つの UDP パケットに存在するメディア ペイロード パケット(つまり MPEG-2 データグラム)の数および各メディア ペイロードのサイズを指定できます。 メディア ビット レートの指定は必須です。Cisco IOS XR ソフトウェア リリース 3.9.1 では、パケット カウントおよびパケット サイズのデフォルトはありません。 これらの値は設定する必要があります。


        (注)  


        メディア ビット レートを 1052800 bps、メディア パケット カウントを 7、メディア パケット サイズを 188 バイトに設定すると、メディア パケット レートはレイヤ 3 で 100 pps になります。 計算は、1052800 / (7 *188*x 8) = 100 pps です。
        手順の概要

          1.    configure

          2.    policy-map type performance-traffic policy-map-name

          3.    class type traffic class-name

          4.    monitor metric ip-cbr

          5.    rate media bit -rate {bps|kbps|mbps|gbps}

          6.    media packet count in-layer3 packet-count

          7.    media packet size packet-size

          8.    次のいずれかのコマンドを使用します。

          • end
          • commit


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 configure


          例:
          RP/0/RSP0/CPU0:router# configure
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2policy-map type performance-traffic policy-map-name


          例:
          RP/0/RSP0/CPU0:router(config)# policy-map type performance-traffic policy1
           

          ポリシーマップ モードを開始します。 ポリシーマップ タイプは常に performance traffic として入力する必要があります。

           
          ステップ 3class type traffic class-name


          例:
          RP/0/RSP0/CPU0:router(config-pmap)# class type traffic class-name
           

          このポリシーに一致させるクラスマップを入力します。 1 つのポリシーに対して複数のクラスを指定できます。

           
          ステップ 4monitor metric ip-cbr


          例:
          RP/0/RSP0/CPU0:router(config- pmap-c)# monitor metric ip-cbr
           

          IP-CBR メトリック モニタ サブモードを開始します。

          (注)     

          現在は IP-CBR メトリック モニタリングのみがビデオ モニタリングでサポートされています。

           
          ステップ 5rate media bit -rate {bps|kbps|mbps|gbps}


          例:
          RP/0/RSP0/CPU0:router(config- pmap-c-ipcbr)# rate media 100 mbps
           

          フローのメディア ビット レートを bps、kbps、mbps、または gbps で指定します。 ここで設定をコミットできます。 オプション パラメータを指定することもできます。

          (注)     

          メディア ビット レートのデフォルトの単位は kbps です。

           
          ステップ 6media packet count in-layer3 packet-count


          例:
          RP/0/RSP0/CPU0:router(config- pmap-c-ipbr)# media packet count in-layer3 10
           

          各 IP ペイロードのメディア パケット数を指定します。

           
          ステップ 7media packet size packet-size


          例:
          RP/0/RSP0/CPU0:router(config- pmap-c-ipcbr)# media packet size 188
           

          IP ペイロード内の各メディア パケットのサイズをバイト単位で指定します。

           
          ステップ 8次のいずれかのコマンドを使用します。
          • end
          • commit


          例:
          RP/0/RSP0/CPU0:router(config)# end

          または

          RP/0/RSP0/CPU0:router(config)# commit
           

          設定変更を保存します。

          • end コマンドを実行すると、変更をコミットするように要求されます。
            Uncommitted changes found, commit them
            before exiting(yes/no/cancel)? [cancel]:
            
            • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
            • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
            • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
          • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
           

          フロー パラメータを使用したポリシーマップの設定

          ポリシーマップのフロー パラメータは次のとおりです。

          ビデオ モニタリングでは、データ プレーンによってフローおよび各インターバルの最後にエクスポートされるメトリックが継続的にモニタされます。 このインターバルの期間およびフロー(履歴)ごとに保存する必要があるインターバルの数をオプションで指定することもできます。 これらのフロー パラメータはフローごとに指定できます。

          • インターバル期間:このインターバル期間の最後にメトリックがエクスポートされます。 5 の倍数(10 ~ 300 秒の任意の値)で指定します。 デフォルト値は 30 です。
          • 履歴:フローごとに保存する必要があるフロー情報(フロー ID、メトリックなど)を含むインターバル数。 1 ~ 60 の任意の値を指定できます。 デフォルト値は 10 です。
          • タイムアウト:インターバル期間の倍数で指定し、この時間が経過すると、非アクティブなフローが削除対象としてマークされます。 2 ~ 60 の任意の値を指定できます。 デフォルト値は 0 です (注:タイムアウト値 0 には特別な意味があります。フローはタイムアウトせず、スタティック フローになります)。
          • クラスあたりの最大フロー:ポリシーの各クラスでモニタする必要があるフローの最大数。 1 ~ 1024 の任意の値を指定できます。 デフォルト値は 1024 です
          手順の概要

            1.    configure

            2.    policy-map type performance-traffic policy-map-name

            3.    class type traffic class-name

            4.    monitor parameters

            5.    {interval duration duration | flows number of flows | history intervals | timeout duration}

            6.    次のいずれかのコマンドを使用します。

            • end
            • commit


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 configure


            例:
            RP/0/RSP0/CPU0:router# configure
             

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 2policy-map type performance-traffic policy-map-name


            例:
            RP/0/RSP0/CPU0:router(config)# policy-map type performance-traffic policy1
            
            
             

            ポリシーマップ モードを開始します。 ポリシーマップ タイプは常に performance traffic として入力する必要があります。

             
            ステップ 3class type traffic class-name


            例:
            RP/0/RSP0/CPU0:router(config-pmap)# class type traffic class-name
            
            
             

            このポリシーに一致させるクラスマップを入力します。 1 つのポリシーに対して複数のクラスを指定できます。

             
            ステップ 4monitor parameters


            例:
            RP/0/RSP0/CPU0:router(config- pmap-c)# monitor parameters
            
            
             

            フロー モニタ サブモードを開始します。

             
            ステップ 5{interval duration duration | flows number of flows | history intervals | timeout duration}


            例:
            RP/0/RSP0/CPU0:router(config- pmap-c-fparm)# interval duration 10
            
            
             
            • フローごとにインターバル期間を指定するには、interval duration オプションを選択します。範囲は 10 ~ 300(5 の倍数)です。 デフォルト値は 30 です。
            • フローごとに保存するインターバル データの最大数を指定するには、history オプションを選択します。 1 ~ 60 の任意の値を指定できます。 デフォルト値は 10 です。
            • インターバル期間の倍数でタイムアウト値を指定するには、timeout オプションを選択します。この時間が経過すると、非アクティブなフローは削除対象としてマークされます。 範囲は 2 ~ 60 です。 デフォルト値は 0 で、スタティック フローを示します。
            • クラスごとにモニタできるフローの最大数を指定するには、flows オプションを選択します。 範囲は 1 ~ 1024 です。 デフォルト値は 1024 です。
             
            ステップ 6次のいずれかのコマンドを使用します。
            • end
            • commit


            例:
            RP/0/RSP0/CPU0:router(config)# end

            または

            RP/0/RSP0/CPU0:router(config)# commit
             

            設定変更を保存します。

            • end コマンドを実行すると、変更をコミットするように要求されます。
              Uncommitted changes found, commit them
              before exiting(yes/no/cancel)? [cancel]:
              
              • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
              • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
              • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
            • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
             

            反応パラメータを使用したポリシーマップの設定

            ポリシーマップの反応パラメータはオプションです。

            反応パラメータは、ユーザがフロー品質を指定するための直接参照です。 フローは継続的にモニタされ、インターバル期間の最後に、ユーザによって特定のパラメータに指定されたしきい値を超えたかどうかを確認するために統計情報が調べられます。 しきい値を超えた場合は、コンソールに syslog アラームが生成されます。 アラームが設定されると、その条件に対してこれ以上 syslog 通知は発行されなくなります。

            ポリシーマップを設定するには次の反応パラメータが使用されます。

            • メディア レート変動(MRV):フローの MRV 統計情報がユーザによって指定されたしきい値を超えると、ビデオ モニタリングが反応してアラームを生成します。
            • 遅延係数:フローの遅延係数統計情報がユーザによって指定されたしきい値を超えると、ビデオ モニタリングが反応してアラームを生成します。
            • メディア停止:フローが停止すると、ビデオ モニタリングが反応してアラームを生成します。これは、1 回の完全なモニタリング インターバルの間にフローのパケットを受信しなかったことを示します。
            • パケット レート:フローのパケット レートがユーザによって指定されたしきい値を超えると、ビデオ モニタリングが反応してアラームを生成します。
            • フロー カウント:各クラスのフロー カウントがユーザによって指定されたしきい値を超えると、ビデオ モニタリングが反応してアラームを生成します。
            手順の概要

              1.    configure

              2.    policy-map type performance-traffic policy-map-name

              3.    class type traffic class-name

              4.    react react-id {mrv | delay-factor | packet-rate | flow-count | media-stop}

              5.    threshold type immediate

              6.    threshold value {ge | gt | le | lt | range} limit

              7.    action syslog

              8.    alarm severity {error | critical | alert | emergency}

              9.    alarm type {discrete | grouped}

              10.    次のいずれかのコマンドを使用します。

              • end
              • commit


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 configure


              例:
              RP/0/RSP0/CPU0:router# configure
               

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2policy-map type performance-traffic policy-map-name


              例:
              RP/0/RSP0/CPU0:router(config)# policy-map type performance-traffic policy1
              
              
               

              ポリシーマップ モードを開始します。 ポリシーマップ タイプは常に performance traffic として入力する必要があります。

               
              ステップ 3class type traffic class-name


              例:
              RP/0/RSP0/CPU0:router(config-pmap)# class type traffic class-name
              
              
               

              このポリシーに一致させるクラスマップを入力します。 1 つのポリシーに対して複数のクラスを指定できます。

               
              ステップ 4react react-id {mrv | delay-factor | packet-rate | flow-count | media-stop}


              例:
              RP/0/RSP0/CPU0:router(config- pmap-c)# react 1 mrv
              
              
               

              反応パラメータ コンフィギュレーション サブモードを開始します。 ここで指定する反応 ID は、クラスごとに一意である必要があります。

              (注)     

              media-stop 反応パラメータでは、threshold-type および threshold-value オプションは適用されません。 flow-count 反応パラメータでは、alarm-type オプションは適用されません。

               
              ステップ 5threshold type immediate


              例:
              RP/0/RSP0/CPU0:router(config- pmap-c-react)# threshold type immediate
              
              
               

              しきい値のトリガー タイプを指定します。 現在使用可能なしきい値タイプは immediate です。

               
              ステップ 6threshold value {ge | gt | le | lt | range} limit


              例:
              RP/0/RSP0/CPU0:router(config- pmap-c-react)# threshold value ge 50
              
              
               

              しきい値のトリガー値範囲を指定します。

               
              ステップ 7action syslog


              例:
              RP/0/RSP0/CPU0:router(config- pmap-c-react)# action syslog
              
              
               

              action キーワードでは、しきい値制限を超えたときに実行するアクションを指定します。 現在、syslog アクションが唯一使用可能なオプションです。

               
              ステップ 8alarm severity {error | critical | alert | emergency}


              例:
              RP/0/RSP0/CPU0:router(config- pmap-c-react)# alarm severity critical
              
              
               

              syslog のアラーム重大度を指定します。

               
              ステップ 9alarm type {discrete | grouped}


              例:
              RP/0/RSP0/CPU0:router(config- pmap-c-react)# alarm type discrete
              
              
               

              アラーム タイプを指定します。 しきい値を超えたすべてのフローに対して個別アラームが発生します。 特定の数または割合のフローがしきい値を超えた場合は、グループ化されたアラームが発生します。

               
              ステップ 10次のいずれかのコマンドを使用します。
              • end
              • commit


              例:
              RP/0/RSP0/CPU0:router(config)# end

              または

              RP/0/RSP0/CPU0:router(config)# commit
               

              設定変更を保存します。

              • end コマンドを実行すると、変更をコミットするように要求されます。
                Uncommitted changes found, commit them
                before exiting(yes/no/cancel)? [cancel]:
                
                • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
              • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
               

              ビデオ モニタリング メトリック

              ビデオ モニタリングは、このリリースの RTP、MDI、および MPLS メトリックをサポートします。

              • サポートされている RTP のバリエーションは、RTP-MMR、RTP 音声、RTP-J2k および RTP カスタムです
              • サポートされている MDI のバリエーションは、MDI-MPEG、および RTP 上の MDI-MPEG です
              • サポートされている MPLS のバリエーションは、RSVP-TE、P2MP-TE、LDP、および MLDP です

              rtp メトリック パラメータを使用したポリシーマップの設定

              ここでは、各 rtp メトリック パラメータの設定について説明します。

              手順の概要

                1.    configure

                2.    policy-map type performance-traffic policy-map-name

                3.    class type traffic class-name

                4.    monitor parameters

                5.    timeout duration

                6.    exit

                7.    monitor metric[ rtp | rtp-j2k | rtp-mmr | rtp-voice]

                8.    clock-rate value

                9.    max-dropout value

                10.    max-misorder value

                11.    min-sequential value

                12.    次のいずれかのコマンドを使用します。

                • end
                • commit


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1 configure


                例:
                RP/0/RSP0/CPU0:router# configure
                 

                グローバル コンフィギュレーション モードを開始します。

                 
                ステップ 2policy-map type performance-traffic policy-map-name


                例:
                RP/0/RSP0/CPU0:router(config)# policy-map type performance-traffic policy1
                
                
                 

                ポリシーマップ モードを開始します。 ポリシーマップ タイプは常に performance traffic として入力する必要があります。

                 
                ステップ 3class type traffic class-name


                例:
                RP/0/RSP0/CPU0:router(config-pmap)# class type traffic class-name
                
                
                 

                このポリシーに一致させるクラスマップを入力します。 1 つのポリシーに対して複数のクラスを指定できます。

                 
                ステップ 4monitor parameters


                例:
                RP/0/RSP0/CPU0:router(config-pmap-c)# monitor parameters
                
                
                 

                フロー モニタ サブモードを開始します。

                 
                ステップ 5timeout duration


                例:
                RP/0/RSP0/CPU0:router(config-pmap-c-mparm)# timeout 2
                
                
                 

                インターバル期間の倍数で指定し、この時間が経過すると、非アクティブなフローが削除対象としてマークされます。 2 ~ 60 の任意の値を指定できます。

                 
                ステップ 6exit


                例:
                RP/0/RSP0/CPU0:router(config-pmap-c-mparm)# exit
                
                
                 

                フロー モニタ サブモードを終了します。

                 
                ステップ 7monitor metric[ rtp | rtp-j2k | rtp-mmr | rtp-voice]


                例:
                RP/0/RSP0/CPU0:router(config- pmap-c)# monitor metric rtp
                
                
                 
                • 対応する rtp メトリック モニタ サブモードを開始します。 次のオプションを使用できます。
                  • rtp:このオプションは、カスタム rtp トラフィックに使用します。
                  • rtp-j2k:このオプションは、RTP JPEG 2000 トラフィックをモニタする場合に使用します。
                  • rtp-mmr:このオプションは、Microsoft Mediaroom トラフィックをモニタする場合に使用します。
                  • rtp-voice:このオプションは、RTP 音声トラフィックをモニタする場合に使用します。
                  (注)     

                  rtp-j2k、rtp-mmr および rtp-voice メトリックをモニタリングのために使用する場合、ダイナミック範囲の周波数マッピングが、特定の周波数に対して自動的に設定されます。 rtp メトリック パラメータはカスタム rtp トラフィックに使用します。 rtp メトリック パラメータの周波数マッピングを動的に設定する必要があります。

                • フロー モニタ サブモードを開始します。
                 
                ステップ 8clock-rate value


                例:
                RP/0/RSP0/CPU0:router(config-pmap-c-rtp)# clock-rate 97
                
                
                 

                このオプションは、rtp モニタ メトリックのみで使用できます。 ダイナミック ペイロード タイプ値を入力します。 指定できる値の範囲は 96 ~ 27 です。

                RTP タイムスタンプの生成に使用される RTP クロック レートは、チャネル数および符号化に依存しません。 RTP クロック レートは、秒あたりのサンプリング期間の数と同等です。 ほとんどのビデオ ストリームのクロック周波数は約 90 kHz です。 RTP はすべてのスタティック ペイロード タイプ コードをサポートし、ユーザはダイナミック ペイロード タイプの周波数マッピングを設定することができます。 使用可能なペイロード タイプ値は次のとおりです。
                • 周波数 8kHz
                • 周波数 16kHz
                • 周波数 11.025kHz
                • 周波数 22.050kHz
                • 周波数 44.1kHz
                • 周波数 48kHz
                • 周波数 90kHz(RTP のデフォルトの周波数)
                • 周波数 27000kHz
                • 周波数 148500kHz
                • 周波数 148.5/1.001MHz
                 
                ステップ 9max-dropout value


                例:
                RP/0/RSP0/CPU0:router(config-pmap-c-rtp)# max-dropout 20
                
                
                 

                このオプションは、rtp モニタ メトリックのみで使用できます。 RTP フローの最大ドロップアウト値を入力します。 指定できる値の範囲は 1 ~ 65536 です。

                順序外パケットを識別するために、スライディング ウィンドウが維持され、このウィンドウ内にある限り、順序無関係のパケットが受信されます。 最大ドロップアウトはスライディング ウィンドウの look-ahead 設定を提供します。 x が現在のシーケンス番号の前の最大ドロップアウト以下である場合、シーケンス番号 x のパケットが有効と見なされます。

                 
                ステップ 10max-misorder value


                例:
                RP/0/RSP0/CPU0:router(config-pmap-c-rtp)# max-misorder 20
                
                
                 

                このオプションは、rtp モニタ メトリックのみで使用できます。 最大ミスオーダー値を入力します。 指定できる値の範囲は 1 ~ 65536 です。

                x が現在のシーケンス番号の後の最大ミスオーダー以下である場合、シーケンス番号 x のパケットが有効と見なされます。 シーケンス番号は、最大シーケンス(現在表示されている最大シーケンス番号)の前の最大ドロップアウト以下、または最大シーケンスの後の最大ミスオーダー以下である場合にのみ、有効と見なされます。

                 
                ステップ 11min-sequential value


                例:
                RP/0/RSP0/CPU0:router(config-pmap-c-rtp)# min-sequential 20
                
                
                 

                このオプションは、rtp モニタ メトリックのみで使用できます。 最小の連続した値を入力します。 指定できる値の範囲は 1 ~ 65536 です。

                UDP ヘッダーにプロトコル固有の情報がないため、RTP パケットを一意に識別する方法はありません。 代わりにフローを識別するために、PD で N パケット内の RTP ヘッダーを検査するヒューリスティックな方法が使用されます。 パケット数は min-sequential のメトリック パラメータで定義されます。

                 
                ステップ 12次のいずれかのコマンドを使用します。
                • end
                • commit


                例:
                RP/0/RSP0/CPU0:router(config)# end

                または

                RP/0/RSP0/CPU0:router(config)# commit
                 

                設定変更を保存します。

                • end コマンドを実行すると、変更をコミットするように要求されます。
                  Uncommitted changes found, commit them
                  before exiting(yes/no/cancel)? [cancel]:
                  
                  • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                  • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                  • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                 

                rtp 反応パラメータを使用したポリシーマップの設定

                ここでは、反応パラメータを使用した各 rtp メトリックの設定について説明します。

                手順の概要

                  1.    configure

                  2.    policy-map type performance-traffic policy-map-name

                  3.    class type traffic class-name

                  4.    monitor parameters

                  5.    timeout duration

                  6.    exit

                  7.    monitor metric[ rtp | rtp-j2k | rtp-mmr | rtp-voice]

                  8.    react react-id {rtp-loss-fraction | rtp-jitter | rtp-out-of-order | rtp-loss-pkts | rtp-transport-availability | rtp-error-seconds | flow-count | packet-rate}

                  9.    action [ snmp | syslog | clone]

                  10.    alarm type [discrete | grouped { count number | percent percentage} ]

                  11.    alarm severity [ alert | critical | emergency | error]

                  12.    threshold {ge | gt | le | lt | range} limit

                  13.    次のいずれかのコマンドを使用します。

                  • end
                  • commit


                手順の詳細
                   コマンドまたはアクション目的
                  ステップ 1 configure


                  例:
                  RP/0/RSP0/CPU0:router# configure
                   

                  グローバル コンフィギュレーション モードを開始します。

                   
                  ステップ 2policy-map type performance-traffic policy-map-name


                  例:
                  RP/0/RSP0/CPU0:router(config)# policy-map type performance-traffic policy1
                  
                  
                   

                  ポリシーマップ モードを開始します。 ポリシーマップ タイプは常に performance traffic として入力する必要があります。

                   
                  ステップ 3class type traffic class-name


                  例:
                  RP/0/RSP0/CPU0:router(config-pmap)# class type traffic class-name
                  
                  
                   

                  このポリシーに一致させるクラスマップを入力します。 1 つのポリシーに対して複数のクラスを指定できます。

                   
                  ステップ 4monitor parameters


                  例:
                  RP/0/RSP0/CPU0:router(config-pmap-c)# monitor parameters
                  
                  
                   

                  フロー モニタ サブモードを開始します。

                   
                  ステップ 5timeout duration


                  例:
                  RP/0/RSP0/CPU0:router(config-pmap-c-mparm)# timeout 2
                  
                  
                   

                  インターバル期間の倍数で指定し、この時間が経過すると、非アクティブなフローが削除対象としてマークされます。 2 ~ 60 の任意の値を指定できます。

                   
                  ステップ 6exit


                  例:
                  RP/0/RSP0/CPU0:router(config-pmap-c-mparm)# exit
                  
                  
                   

                  フロー モニタ サブモードを終了します。

                   
                  ステップ 7monitor metric[ rtp | rtp-j2k | rtp-mmr | rtp-voice]


                  例:
                  RP/0/RSP0/CPU0:router(config- pmap-c)# monitor metric rtp
                  
                  
                   
                  • 対応する rtp メトリック モニタ サブモードを開始します。 次のオプションを使用できます。
                    • rtp:このオプションは、カスタム rtp トラフィックに使用します。
                    • rtp-j2k:このオプションは、RTP JPEG 2000 トラフィックをモニタする場合に使用します。
                    • rtp-mmr:このオプションは、Microsoft Mediaroom トラフィックをモニタする場合に使用します。
                    • rtp-voice:このオプションは、RTP 音声トラフィックをモニタする場合に使用します。
                    (注)     

                    rtp-j2k、rtp-mmr および rtp-voice メトリックをモニタリングのために使用する場合、ダイナミック範囲の周波数マッピングが、特定の周波数に対して自動的に設定されます。 rtp メトリック パラメータはカスタム rtp トラフィックに使用します。 rtp メトリック パラメータの周波数マッピングを動的に設定する必要があります。

                  • フロー モニタ サブモードを開始します。
                   
                  ステップ 8react react-id {rtp-loss-fraction | rtp-jitter | rtp-out-of-order | rtp-loss-pkts | rtp-transport-availability | rtp-error-seconds | flow-count | packet-rate}


                  例:
                  RP/0/RSP0/CPU0:router(config- pmap-c)# react 1 rtp-loss-fraction
                  
                  
                   
                  反応パラメータ コンフィギュレーション サブモードを開始します。 ここで指定する反応 ID は、クラスごとに一意である必要があります。 次のオプションを使用できます。
                  • rtp-error-seconds:このオプションは、RTP エラー秒数に使用します。 エラー秒数は、ストリームにエラーが発生していた時間を示します。
                  • rtp-jitter:このオプションは、RTP ジッターに使用します。 RTP ジッターは RTP タイムスタンプに基づくパケット間の平均ジッターを示します。
                  • rtp-loss-fraction:このオプションは、RTP 損失率に使用します。 損失率は、失われたパケットの割合を示します。
                  • rtp-loss-pkts:このオプションは、RTP 損失パケットに使用します。 損失パケットは、失われたパケットの数を示します。
                  • rtp-max-jitter:このオプションは、RTP 最大ジッターに使用します。 時間間隔中の瞬時的最大ジッター。
                  • rtp-out-of-order:このオプションは、RTP 順序外パケットに使用します。 順序外パケットは順序外のパケット数を示します。
                  • rtp-transport-availability:このオプションは、RTP トランスポート アベイラビリティに使用します。 トランスポート アベイラビリティはストリームにエラーがない時間の割合を示します。 たとえば、RTP エラー秒数がゼロの場合、RTP トランスポート アベイラビリティは 100% です。
                  • flow-count:このオプションは、フロー カウントに使用します。 フロー カウントは、ポリシー内のフロー数を示します。
                  • packet-rate:このオプションは、パケット レートに使用します。 パケット レートは、指定された時間間隔中のパケット数を示します。
                   
                  ステップ 9action [ snmp | syslog | clone]


                  例:
                  RP/0/RSP0/CPU0:router(config- pmap-c-react)# action snmp
                  
                  
                   

                  action キーワードでは、しきい値制限を超えたときに実行するアクションを指定します。

                   
                  ステップ 10alarm type [discrete | grouped { count number | percent percentage} ]


                  例:
                  RP/0/RSP0/CPU0:router(config- pmap-c-react)# alarm type discrete
                  
                  
                   

                  アラーム タイプを指定します。 しきい値を超えたすべてのフローに対して個別アラームが発生します。

                  カウントのアラームはフローの数に基づいてグループ化されます。 割合のアラームはフローの割合に基づいてグループ化されます。

                   
                  ステップ 11alarm severity [ alert | critical | emergency | error]


                  例:
                  RP/0/RSP0/CPU0:router(config- pmap-c-react)# alarm severity critical
                  
                  
                   

                  syslog のアラーム重大度を指定します。

                   
                  ステップ 12threshold {ge | gt | le | lt | range} limit


                  例:
                  RP/0/RSP0/CPU0:router(config- pmap-c-react)# threshold value ge 50
                  
                  
                   

                  しきい値のトリガー値範囲を指定します。

                   
                  ステップ 13次のいずれかのコマンドを使用します。
                  • end
                  • commit


                  例:
                  RP/0/RSP0/CPU0:router(config)# end

                  または

                  RP/0/RSP0/CPU0:router(config)# commit
                   

                  設定変更を保存します。

                  • end コマンドを実行すると、変更をコミットするように要求されます。
                    Uncommitted changes found, commit them
                    before exiting(yes/no/cancel)? [cancel]:
                    
                    • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                    • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                    • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                  • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                   

                  mdi メトリック パラメータを使用したポリシーマップの設定

                  ここでは、各 mdi メトリック パラメータの設定について説明します。

                  手順の概要

                    1.    configure

                    2.    policy-map type performance-traffic policy-map-name

                    3.    class type class-map-name

                    4.    monitor parameters

                    5.    timeout duration

                    6.    exit

                    7.    monitor metric[ mdi mpeg | mdi mpeg rtp ]

                    8.    max-dropout value

                    9.    monitor pids id

                    10.    次のいずれかのコマンドを使用します。

                    • end
                    • commit


                  手順の詳細
                     コマンドまたはアクション目的
                    ステップ 1 configure


                    例:
                    RP/0/RSP0/CPU0:router# configure
                     

                    グローバル コンフィギュレーション モードを開始します。

                     
                    ステップ 2policy-map type performance-traffic policy-map-name


                    例:
                    RP/0/RSP0/CPU0:router(config)# policy-map type performance-traffic policy1
                    
                    
                     

                    ポリシーマップ モードを開始します。 ポリシーマップ タイプは常に performance traffic として入力する必要があります。

                     
                    ステップ 3class type class-map-name


                    例:
                    RP/0/RSP0/CPU0:router(config-pmap)# class type traffic class-name
                    
                    
                     

                    このポリシーに一致させるクラスマップを入力します。 1 つのポリシーに対して複数のクラスを指定できます。

                     
                    ステップ 4monitor parameters


                    例:
                    RP/0/RSP0/CPU0:router(config-pmap-c)# monitor parameters
                    
                    
                     

                    フロー モニタ サブモードを開始します。

                     
                    ステップ 5timeout duration


                    例:
                    RP/0/RSP0/CPU0:router(config-pmap-c-mparm)# timeout 2
                    
                    
                     

                    インターバル期間の倍数で指定し、この時間が経過すると、非アクティブなフローが削除対象としてマークされます。 2 ~ 60 の任意の値を指定できます。

                     
                    ステップ 6exit


                    例:
                    RP/0/RSP0/CPU0:router(config-pmap-c-mparm)# exit
                    
                    
                     

                    フロー モニタ サブモードを終了します。

                     
                    ステップ 7monitor metric[ mdi mpeg | mdi mpeg rtp ]


                    例:
                    RP/0/RSP0/CPU0:router(config- pmap-c)# monitor metric mdi mpeg
                    
                    
                     

                    対応する mdi メトリック モニタ サブモードを開始します。 mdi mpeg rtp オプションは、mpeg ヘッダーの前に rtp ヘッダーがあることを示します。 IP パケットごとに最大 7 個の mpeg パケットが許可されます。 パケットに 7 つを超える mpeg パケットが含まれている場合、その ip パケットは無視されます。 カプセル化が一致しない場合、フローは学習されません。

                     
                    ステップ 8max-dropout value


                    例:
                    RP/0/RSP0/CPU0:router(config-pmap-c-mdi)# max-dropout 20
                    
                    
                     

                    ストリーム レートの下限に基づくパケット フィルタリングをイネーブルにします。 範囲は 1 ~ 4294967294 です。

                     
                    ステップ 9monitor pids id


                    例:
                    RP/0/RSP0/CPU0:router(config-pmap-c-mdi)# monitor pids 200
                    
                    
                     

                    スタティック PID モニタリングをイネーブルにします。 範囲は 1 ~ 65536 です。

                     
                    ステップ 10次のいずれかのコマンドを使用します。
                    • end
                    • commit


                    例:
                    RP/0/RSP0/CPU0:router(config)# end

                    または

                    RP/0/RSP0/CPU0:router(config)# commit
                     

                    設定変更を保存します。

                    • end コマンドを実行すると、変更をコミットするように要求されます。
                      Uncommitted changes found, commit them
                      before exiting(yes/no/cancel)? [cancel]:
                      
                      • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                      • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                      • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                    • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                     

                    mdi 反応パラメータを使用したポリシーマップの設定

                    ここでは、反応パラメータを使用した各 mdi メトリックの設定について説明します。

                    手順の概要

                      1.    configure

                      2.    policy-map type performance-traffic policy-map-name

                      3.    class type traffic class-name

                      4.    monitor parameters

                      5.    timeout duration

                      6.    exit

                      7.    react react-id {mdi-mlr | mdi-mdc | mdi-transport-availability | mpeg-loss-pkts | mdi-error-seconds | rtp-error-seconds | flow-count | mdi-jitter | packet-rate | media-stop}

                      8.    action [ snmp | syslog | clone ]

                      9.    alarm type [discrete | grouped { count number | percent percentage} ]

                      10.    alarm severity [ alert | critical | emergency | error]

                      11.    threshold {ge | gt | le | lt | range} limit

                      12.    次のいずれかのコマンドを使用します。

                      • end
                      • commit


                    手順の詳細
                       コマンドまたはアクション目的
                      ステップ 1 configure


                      例:
                      RP/0/RSP0/CPU0:router# configure
                       

                      グローバル コンフィギュレーション モードを開始します。

                       
                      ステップ 2policy-map type performance-traffic policy-map-name


                      例:
                      RP/0/RSP0/CPU0:router(config)# policy-map type performance-traffic policy1
                      
                      
                       

                      ポリシーマップ モードを開始します。 ポリシーマップ タイプは常に performance traffic として入力する必要があります。

                       
                      ステップ 3class type traffic class-name


                      例:
                      RP/0/RSP0/CPU0:router(config-pmap)# class type traffic class-name
                      
                      
                       

                      このポリシーに一致させるクラスマップを入力します。 1 つのポリシーに対して複数のクラスを指定できます。

                       
                      ステップ 4monitor parameters


                      例:
                      RP/0/RSP0/CPU0:router(config-pmap-c)# monitor parameters
                      
                      
                       

                      フロー モニタ サブモードを開始します。

                       
                      ステップ 5timeout duration


                      例:
                      RP/0/RSP0/CPU0:router(config-pmap-c-mparm)# timeout 2
                      
                      
                       

                      インターバル期間の倍数で指定し、この時間が経過すると、非アクティブなフローが削除対象としてマークされます。 2 ~ 60 の任意の値を指定できます。

                       
                      ステップ 6exit


                      例:
                      RP/0/RSP0/CPU0:router(config-pmap-c-mparm)# exit
                      
                      
                       

                      フロー モニタ サブモードを終了します。

                       
                      ステップ 7react react-id {mdi-mlr | mdi-mdc | mdi-transport-availability | mpeg-loss-pkts | mdi-error-seconds | rtp-error-seconds | flow-count | mdi-jitter | packet-rate | media-stop}


                      例:
                      RP/0/RSP0/CPU0:router(config- pmap-c)# react 1 rtp-loss-fraction
                      
                      
                       
                      反応パラメータ コンフィギュレーション サブモードを開始します。 ここで指定する反応 ID は、クラスごとに一意である必要があります。 次のオプションを使用できます。
                      • mdi-error-seconds:MDI エラー秒数
                      • mdi-mdc:MDI メディア ディスク。 Count
                      • mdi-mlr:MDI メディア損失レート
                      • mdi-transport-availability:MDI トランスポート アベイラビリティ
                      • mpeg-loss-pkts:MPEG 損失パケット
                      • flow-count:フロー カウント
                      • mdi-jitter:MDI ジッター
                      • packet-rate:パケット レート
                      • media-stop:メディア停止イベント
                       
                      ステップ 8action [ snmp | syslog | clone ]


                      例:
                      RP/0/RSP0/CPU0:router(config- pmap-c-react)# action snmp
                      
                      
                       

                      action キーワードでは、しきい値制限を超えたときに実行するアクションを指定します。

                       
                      ステップ 9alarm type [discrete | grouped { count number | percent percentage} ]


                      例:
                      RP/0/RSP0/CPU0:router(config- pmap-c-react)# alarm type discrete
                      
                      
                       

                      アラーム タイプを指定します。 しきい値を超えたすべてのフローに対して個別アラームが発生します。

                      カウントのアラームはフローの数に基づいてグループ化され、割合のアラームはフローの割合に基づいてグループ化されます。

                       
                      ステップ 10alarm severity [ alert | critical | emergency | error]


                      例:
                      RP/0/RSP0/CPU0:router(config- pmap-c-react)# alarm severity critical
                      
                      
                       

                      syslog のアラーム重大度を指定します。

                       
                      ステップ 11threshold {ge | gt | le | lt | range} limit


                      例:
                      RP/0/RSP0/CPU0:router(config- pmap-c-react)# threshold value ge 50
                      
                      
                       

                      しきい値のトリガー値範囲を指定します。

                       
                      ステップ 12次のいずれかのコマンドを使用します。
                      • end
                      • commit


                      例:
                      RP/0/RSP0/CPU0:router(config)# end

                      または

                      RP/0/RSP0/CPU0:router(config)# commit
                       

                      設定変更を保存します。

                      • end コマンドを実行すると、変更をコミットするように要求されます。
                        Uncommitted changes found, commit them
                        before exiting(yes/no/cancel)? [cancel]:
                        
                        • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                        • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                        • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                      • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                       

                      インターフェイスのサービス ポリシーの設定

                      ビデオ モニタリング サービスをイネーブルにするには、設定したポリシーマップを入力方向のインターフェイスに関連付ける必要があります。

                      イーサネット バンドル インターフェイスの場合、サービス ポリシーは、物理メンバ インターフェイスではなくバンドル親インターフェイスにのみ関連付けることができます。 イーサネット バンドル サブインターフェイスの場合は、サブインターフェイスにのみ関連付けることができます。 VLAN サブインターフェイスの場合は、サービス ポリシーをメイン インターフェイスに関連付けることはできません。

                      手順の概要

                        1.    configure

                        2.    interface type interface-path-id

                        3.    service-policy type performance-traffic input policy-name

                        4.    次のいずれかのコマンドを使用します。

                        • end
                        • commit


                      手順の詳細
                         コマンドまたはアクション目的
                        ステップ 1 configure


                        例:
                        RP/0/RSP0/CPU0:router# configure
                         

                        グローバル コンフィギュレーション モードを開始します。

                         
                        ステップ 2interface type interface-path-id


                        例:
                        RP/0/RSP0/CPU0:router(config)# interface type interface-path-id
                        
                        
                         

                        インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

                        • type 引数でインターフェイス タイプを指定します。 インターフェイス タイプの詳細については、疑問符(?)オンライン ヘルプ機能を使用してください。
                        • instance 引数で物理インターフェイス インスタンスまたは仮想インスタンスを指定します。
                        • 物理インターフェイス インスタンスの表記方法は rack/slot/module/port です。 値を区切るスラッシュ(/)は、表記の一部として必要です。
                        • 仮想インターフェイス インスタンスの番号範囲は、インターフェイス タイプによって異なります。
                         
                        ステップ 3service-policy type performance-traffic input policy-name


                        例:
                        RP/0/RSP0/CPU0:router(config-if)# service-policy type performance-traffic input policy1
                        
                        
                         

                        ポリシーを入力方向のインターフェイスに関連付けます。

                         
                        ステップ 4次のいずれかのコマンドを使用します。
                        • end
                        • commit


                        例:
                        RP/0/RSP0/CPU0:router(config)# end

                        または

                        RP/0/RSP0/CPU0:router(config)# commit
                         

                        設定変更を保存します。

                        • end コマンドを実行すると、変更をコミットするように要求されます。
                          Uncommitted changes found, commit them
                          before exiting(yes/no/cancel)? [cancel]:
                          
                          • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                          • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                          • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                        • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                         

                        インターフェイスのトラップおよびクローンの設定

                        トラップおよびクローンは既存のビデオ モニタリング サービスの拡張であり、現在のコントロール プレーン インフラストラクチャをトラップおよびクローンの設定に対応できるように拡張できます。

                        フローのタプル情報(送信元および宛先 IP アドレス)を使用してトラップをインストールできます。これにより、最終的にリモート デバイスまたはローカル プローブによって一致するパケットがさらに分析されます。

                        ここでは、一般的なビデオ モニタリング シナリオにおけるトラップおよびクローン プロセスの動作方法を示します。

                        • 適切なパッケージ(マルチキャストおよびビデオ PIE)をインストールしてビデオ モニタリングをイネーブルにし、ACL、クラスマップ、ポリシーマップを設定してポリシーマップをインターフェイスにバインドする必要があります。
                        • フローの送信元と宛先を指定してクローンするフローを指定することで、トラップおよびクローンを設定する必要があります。
                        • トラップが VidMon コントロール プレーンによってデータ プレーンにインストールされると、VidMon データ プレーンは指定されたフローのパケットのクローンを開始します。
                        • クローンされたパケットは、リモート モニタリング デバイスに転送されてさらに分析されます。

                        (注)  


                        show performance traffic clone profile コマンドを使用すると、インストールされているトラップを確認できます。 ビデオ モニタリングのトラップおよびクローン機能は、マルチキャスト トラフィックに対してのみサポートされ、ユニキャスト フローについては、ユーザが SPAN を設定する必要があります。 マルチキャストでは、ビデオ モニタリングのトラップおよびクローン機能は、クローン インターフェイスのスタティック IGMP グループを使用して実装されます。 クローン インターフェイスは、ローカル プローブに接続された専用ポートに設定できます。


                        手順の概要

                          1.    configure

                          2.    performance traffic clone profile

                          3.    performance traffic clone profile profile_name description

                          4.    interface type interface-path-id

                          5.    clone flow ipv4 source <source-ip> destination <destination-ip>

                          6.    次のいずれかのコマンドを使用します。

                          • end
                          • commit


                        手順の詳細
                           コマンドまたはアクション目的
                          ステップ 1 configure


                          例:
                          RP/0/RSP0/CPU0:router# configure
                           

                          グローバル コンフィギュレーション モードを開始します。

                           
                          ステップ 2performance traffic clone profile


                          例:
                          RP/0/RSP0/CPU0:router(config)# performance traffic clone profile
                          
                          
                           

                          パフォーマンス トラフィック クローン プロファイル モードを開始します。

                           
                          ステップ 3performance traffic clone profile profile_name description


                          例:
                          RP/0/RSP0/CPU0:router(config-perf-traf-clone-profile)# performance traffic clone profile profile1 description
                          
                          
                           

                          クローン プロファイルに対して説明を設定します。

                           
                          ステップ 4interface type interface-path-id


                          例:
                          RP/0/RSP0/CPU0:router(config-perf-traf-clone-profile)# interface GigabitEthernet 0/0/0/1
                          
                          
                           

                          クローン プロファイルに対して出力インターフェイスを設定します。

                           
                          ステップ 5clone flow ipv4 source <source-ip> destination <destination-ip>


                          例:
                          RP/0/RSP0/CPU0:router(config-perf-traf-clone-profile)# clone flow ipv4 23.1.1.1 224.2.2.2
                          
                          
                           

                          クローン プロファイルに対してクローンが必要なトラフィック フローを設定します。

                          (注)     

                          複数のフローを 1 つのクローン プロファイルに関連付けることができます。 同様に、1 つのフローを複数のクローン プロファイルに関連付けることができます。

                           
                          ステップ 6次のいずれかのコマンドを使用します。
                          • end
                          • commit


                          例:
                          RP/0/RSP0/CPU0:router(config)# end

                          または

                          RP/0/RSP0/CPU0:router(config)# commit
                           

                          設定変更を保存します。

                          • end コマンドを実行すると、変更をコミットするように要求されます。
                            Uncommitted changes found, commit them
                            before exiting(yes/no/cancel)? [cancel]:
                            
                            • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                            • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                            • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                          • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                           

                          ビデオ モニタリングの実装の設定例

                          シナリオ 1

                          イーサネット バンドル インターフェイスに 3 つの物理メンバがあり、マルチキャスト ビデオ トラフィックはそのメンバ上をフローあたり 300 pps で移動しています。

                          ビデオ モニタリングを使用して、このイーサネット バンドル上のすべてのフローをモニタします。フロー単位のトラフィック負荷が予想レートの 10 % を超えた場合に、クリティカル レベルのアラームを発生させます。 遅延係数が 4 ミリ秒を超えた場合はエラー レベルのアラームを発生させます。 収集した統計情報を 10 秒ごとに報告します。 フローがアクティブであるかぎり、報告した統計情報を 10 分間保管します。 パケットを 30 秒間受信しなかった場合はフロー統計情報を削除します。

                          ipv4 access-list sample-acl
                           10 permit udp any any
                          !
                          class-map type traffic match-any sample-class
                           match access-group ipv4 sample-acl
                           end-class-map
                          !
                          policy-map type performance-traffic sample-policy
                           class type traffic sample-class
                            monitor parameters
                             interval duration 10
                             history 60
                             timeout 3
                            !
                            monitor metric ip-cbr
                             rate layer3 packet 300 pps
                            !
                            react 100 mrv
                             threshold type immediate
                             threshold value gt 10.00
                             action syslog
                             alarm severity error
                             alarm type discrete
                            !
                            react 101  delay-factor
                             threshold type immediate
                             threshold value gt 4.00
                             action syslog
                             alarm severity error
                             alarm type discrete
                            !
                           !
                           end-policy-map
                          !
                          interface Bundle-Ether10
                           ipv4 address 172.192.1.1 255.255.255.0
                           service-policy type performance-traffic input sample-policy
                          !
                          interface TenGigE0/6/0/0
                           bundle id 10 mode on
                          !
                          interface TenGigE0/6/0/1
                           bundle id 10 mode on
                          !
                          interface TenGigE0/6/0/2
                           bundle id 10 mode on
                          !
                          
                          

                          シナリオ 2

                          VLAN サブインターフェイスは、共通のマルチキャスト グループ アドレス 225.0.0.1 とさまざまな UDP ポート番号を持つ 100 個のビデオ ストリームを伝送しています。 IP レイヤの予想パケット レートは不明ですが、メディア ビット レートは 1052800 bps であることがわかっています。 メディア ペイロードには MPEG-2 で符号化された CBR フローが含まれ、デフォルトのパケット化が使用されます(つまり、1 つの UDP ペイロードに 7 つの MPEG パケットがあり、各パケットの長さは 188 バイトです)。

                          100 を超えるフローはモニタしません。 フローが停止してもフローのタイムアウトと削除を実行しませんが、停止したフローの割合が 90 % を超えた場合はエラー レベルのアラームを発生させます。

                          ipv4 access-list sample-acl
                           10 permit udp any host 225.0.0.1
                          !
                          class-map type traffic match-any sample-class
                           match access-group ipv4 sample-acl
                           end-class-map
                          !
                          policy-map type performance-traffic sample-policy
                           class type traffic sample-class
                            monitor parameters
                             flows 100
                          !
                            monitor metric ip-cbr
                             rate media 1052800 bps
                            !
                            react 100 media-stop
                             action syslog
                             alarm severity error
                             alarm type grouped percent 90
                            !
                           end-policy-map
                          !
                          interface GigabitEthernet0/0/0/0
                           no shutdown
                          !
                          interface GigabitEthernet0/0/0/0.1
                           encapsulation dot1q 500
                           ipv4 address 172.192.1.1 255.255.255.0
                           service-policy type performance-traffic input sample-policy
                          !
                          
                          

                          monitor metric ip-cbr で、次の 2 行はデフォルトであるため設定する必要はありません。

                          • media packet count in-layer3 7
                          • media packet size 188

                          ただし、これらのパラメータがデフォルト値と異なる場合は設定する必要があります。

                          シナリオ 3

                          メイン インターフェイスに、マルチキャスト ストリームのグループが 3 つあり、最初のグループでは UDP 宛先ポートが 1000、2 番めのグループでは 2000、3 番めのグループでは 3000 と 4000 です。 これらの 3 つのストリーム グループは、それぞれ 100 pps、200 pps、300 pps で移動します。

                          各グループのフローの最大数を 300 フローに制限し、フローがプロビジョニングされたフロー容量の 90 % に達した場合にエラー レベルのアラームを発生させます。

                          ipv4 access-list sample-acl-1
                           10 permit udp any any eq 1000
                          !
                          ipv4 access-list sample-acl-2
                           10 permit udp any any eq 2000
                          !
                          ipv4 access-list sample-acl-3
                           10 permit udp any any eq 3000
                           20 permit udp any any eq 4000
                          !
                          class-map type traffic match-any sample-class-1
                           match access-group ipv4 sample-acl-1
                           end-class-map
                          !
                          class-map type traffic match-any sample-class-2
                           match access-group ipv4 sample-acl-2
                           end-class-map
                          !
                          class-map type traffic match-any sample-class-3
                           match access-group ipv4 sample-acl-3
                           end-class-map
                          !
                          policy-map type performance-traffic sample-policy
                           class type traffic sample-class-1
                            monitor parameters
                             interval duration 10
                             history 60
                             timeout 3
                             flows 300
                            !
                            monitor metric ip-cbr
                             rate layer3 packet 100 pps
                            !
                            react 100 flow-count
                             threshold type immediate
                             threshold value gt 270
                             action syslog
                             alarm severity error
                            !
                          class type traffic sample-class-2
                            monitor parameters
                             interval duration 10
                             history 60
                             timeout 3
                             flows 300
                            !
                            monitor metric ip-cbr
                             rate layer3 packet 200 pps
                            !
                            react 100 flow-count
                             threshold type immediate
                             threshold value gt 270
                             action syslog
                             alarm severity error
                            !
                          class type traffic sample-class-1
                            monitor parameters
                             interval duration 10
                             history 60
                             timeout 3
                             flows 300
                            !
                            monitor metric ip-cbr
                             rate layer3 packet 300 pps
                            !
                            react 100 flow-count
                             threshold type immediate
                             threshold value gt 270
                             action syslog
                             alarm severity error
                            !
                           !
                           end-policy-map
                          !
                          interface GigabitEthernet0/0/0/0
                           ipv4 address 172.192.1.1 255.255.255.0
                           service-policy type performance-traffic input sample-policy
                          !
                          
                          

                          シナリオ 4

                          10GE メイン インターフェイスは、スポーツ スタジアムの 6 台の高精度(HD)カメラに直接接続されたデジタル コンテンツ マネージャ(DCM)から 6 つの HD ビデオ ストリームを受信します。 各 HD ビデオ ストリームは圧縮されず、帯域幅はレイヤ 2 で 1.611 Gbps であり、これは 140625 pps に相当します。 これらの 6 つの受信ストリームはマルチキャスト グループが 225.0.0.1 ~ 225.0.0.6、UDP ポート番号は 5000 です。

                          フローの遅延係数が 2 ミリ秒を超えた場合、またはメディア損失率が 5 % を超えた場合にクリティカル レベルのアラームを発生させます。 10 秒のインターバルを使用し、最大の履歴を保管します。 このインターフェイスでは 6 つを超えるフローはモニタしません。 非アクティブなフローをタイムアウトにしません。

                          ipv4 access-list sample-acl
                           10 permit udp any eq 5000 225.0.0.0/24 eq 5000
                          !
                          class-map type traffic match-any sample-class
                           match access-group ipv4 sample-acl
                           end-class-map
                          !
                          policy-map type performance-traffic sample-policy
                           class type traffic sample-class
                            monitor parameters
                             interval duration 10
                             history 60
                             flows 6
                            !
                            monitor metric ip-cbr
                             rate layer3 packet 140625 pps
                            !
                            react 100 mrv
                             threshold type immediate
                             threshold value gt 5.00
                             action syslog
                             alarm severity critical
                             alarm type discrete
                            !
                            react 200 delay-factor
                             threshold type immediate
                             threshold value gt 2.00
                             action syslog
                             alarm severity critical
                             alarm type discrete
                            !
                           end-policy-map
                          !
                          interface TenGigE0/2/0/0
                           ipv4 address 172.192.1.1 255.255.255.0
                           service-policy type performance-traffic input sample-policy
                          !
                          
                          

                          シナリオ 5

                          イーサネット インターフェイスが Cisco ASR 9000 シリーズ ルータに設定され、そこをマルチキャスト ビデオ トラフィックが移動しています。 ビデオ モニタリングを使用して、このイーサネット インターフェイス上のすべてのビデオ フローのパフォーマンスをモニタします。 ビデオ モニタリングのトラップおよびクローン機能を使用して、これらのフロー パケットをトラップし、指定された出力インターフェイスにクローン(または複製)します。

                          指定された出力インターフェイスにクローンするフローを含むトラップおよびクローン プロファイルを設定します。 プロファイルに説明を追加します。

                          Performance traffic clone profile profile1
                             Description video flows monitored by vidmon
                             Interface GigE 0/1/1/1
                             flow ipv4 source 23.1.1.1 destination 231.2.2.2
                          
                          

                          シナリオ 6

                          100GE メイン インターフェイスは、ユニキャスト トラフィックの 5 つの高精度(HD)ビデオ ストリームを受信しています。 各 HD ビデオ ストリームは圧縮されず、そのビット レートは 3 Gbps です。 各ストリームは CBR フローで、パケット レートが 284954 pps であることがわかっています。 これらのストリームの送信元は 192.1.1.2 で、宛先は 10.1.1.1 ~ 10.1.1.5 です。 送信元と宛先の両方に UDP ポート 7700 が使用されています。

                          フローの遅延係数が 5 ミリ秒を超えた場合、または CBR フロー レートが予想公称レートの 10 % 以上低下した場合、クリティカル レベルのアラームを発生させます。 30 秒のインターバルを使用し、10 インターバルを履歴として保管します。 このポートはまもなく低レートの VoD フローを受信することがわかっているため、最大フロー カウントとして 4000 を許可します。 10.1.1.0/24 サブネット宛てのストリームのみをモニタします。 品質低下が検出された場合は、アラームを syslog 出力以外に NMS システムに報告します。

                          ipv4 access-list sample-acl
                           10 permit udp 192.1.1.2/32 eq 7700 10.1.1.0/24 eq 7700 
                          !
                          class-map type traffic match-any sample-class  match access-group ipv4 sample-acl  end-class-map 
                          !
                          policy-map type performance-traffic sample-policy  class type traffic sample-class
                            monitor parameters
                             interval duration 30
                             history 10
                             flows 4000
                            !
                            monitor metric ip-cbr
                             rate layer3 packet 284954 pps
                            !
                            react 100 mrv
                             threshold type immediate
                             threshold value lt 10.00
                             action syslog
                             action snmp
                             alarm severity critical
                             alarm type discrete
                            !
                            react 200 delay-factor
                             threshold type immediate
                             threshold value gt 5.00
                             action syslog
                             action snmp
                             alarm severity critical
                             alarm type discrete
                            !
                           end-policy-map
                          !
                          interface HundredGigE0/1/0/1
                           ipv4 address 172.192.1.1 255.255.255.0
                           service-policy type performance-traffic input sample-policy 
                          !
                          
                          

                          シナリオ 7

                          ビデオ モニタリングを使用して、すべての vidmon-rtp トラフィックをモニタします。

                          
                          ipv4 access-list uc
                           10 permit udp any 20.0.0.0/24
                          !
                          class-map type traffic match-any ucast
                           match access-group ipv4 uc 
                           end-class-map
                          !
                          interface TenGigE0/2/0/10
                           ipv4 address 10.0.0.1 255.255.255.0
                           service-policy type performance input vidmon-rtp
                           load-interval 30
                          !
                          policy-map type performance-traffic vidmon-rtp
                           class type traffic ucast 
                            monitor parameters
                             interval duration 10
                             history 60
                             timeout 2
                            !
                            monitor metric rtp
                             clock-rate 96  48kHz
                             clock-rate 97  27000kHz
                             clock-rate 99  148500kHz
                             clock-rate 100  148351.648kHz
                            !
                           !
                           react 101  flow-count
                             threshold type immediate
                             threshold value gt 0 
                             action syslog
                             alarm severity alert
                            !
                            react 102  media-stop
                             action syslog
                             alarm severity critical
                             alarm type discrete
                            !
                           !
                           end-policy-map
                          !
                          
                          

                          シナリオ 8

                          ビデオ モニタリングを使用して、すべての vidmon-rtp-j2k トラフィックをモニタします。

                          
                          policy-map type performance-traffic vidmon-rtp-j2k
                           class type traffic ucast 
                            monitor parameters
                             interval duration 10
                             history 60
                             timeout 2
                            !
                            monitor metric rtp-j2k
                           !
                           end-policy-map
                          !
                          
                          

                          シナリオ 9

                          ビデオ モニタリングを使用して、すべての mdi mpeg トラフィックをモニタします。

                          
                          policy-map type performance-traffic ipcbr-mdi
                           class type traffic ucast 
                            monitor parameters
                             interval duration 10
                             history 60
                             timeout 2
                            !
                            monitor metric mdi mpeg
                             filter packet-rate 22 pps
                            !
                           !
                           end-policy-map
                          !
                          
                          

                          シナリオ 10

                          ビデオ モニタリングを使用して、すべての mdi mpeg rtp トラフィックをモニタします。

                          
                          policy-map type performance-traffic rtp-mdi
                           class type traffic ucast 
                            monitor parameters
                             interval duration 10
                             history 60
                             timeout 2
                            !
                            monitor metric mdi mpeg rtp
                            !
                           !
                           end-policy-map
                          !
                          
                          

                          その他の関連資料

                          関連資料

                          関連項目

                          マニュアル タイトル

                          マルチキャスト コマンド リファレンス

                          『Cisco ASR 9000 Series Aggregation Services Router Multicast Command Reference』

                          スタートアップ資料

                          『Cisco ASR 9000 Series Aggregation Services Router Getting Started Guide』

                          モジュラ Quality of Service コマンド リファレンス

                          『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference』

                          MIB

                          MIB

                          MIB のリンク

                          Cisco IOS XR ソフトウェアを使用して MIB を特定およびダウンロードするには、次の URL にある Cisco MIB Locator を使用し、[Cisco Access Products] メニューからプラットフォームを選択します。http:/​/​cisco.com/​public/​sw-center/​netmgmt/​cmtk/​mibs.shtml

                          RFC

                          RFC

                          タイトル

                          RFC4445

                          『Proposed Media Delivery Index (MDI)』

                          シスコのテクニカル サポート

                          説明

                          リンク

                          シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクなどの、数千ページに及ぶ技術情報が検索可能です。 Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

                          http:/​/​www.cisco.com/​en/​US/​support/​index.html