Cisco ASR 9000 シリーズ アグリゲーション サービス ルーター モジュラ QoS サービス コンフィギュレーション ガイド リリース 4.3.x
モジュラ QoS の導入シナリオ
モジュラ QoS の導入シナリオ
発行日;2013/02/24   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

モジュラ QoS の導入シナリオ

このモジュールでは、L2VPN または MPLS などの他のテクノロジー ガイドに記載されている特定の QoS 機能または QoS 実装の導入シナリオの使用例について説明します。

ラインカード、SIP および SPA のサポート

機能

ASR 9000 イーサネット ラインカード

ASR 9000 用 SIP 700

802.1ad DEI

yes

no

フレーム リレー QoS

no

yes

IPHC QoS

no

2 ポート チャネライズド OC-12c/DS0 SPA のみ

L2VPN QoS

yes

yes

MLPPP/MLFR QoS

no

2 ポート チャネライズド OC-12c/DS0 SPA のみ

MPLS QoS

yes

yes

マルチキャスト VPN での QoS

yes

yes

NxDS0 インターフェイスでの QoS

no

2 ポート チャネライズド OC-12c/DS0 SPA のみ

Cisco ASR 9000 シリーズ ルータの QoS 導入シナリオの機能履歴

リリース

変更内容

リリース 3.7.2

L2VPN QoS 機能が、ASR 9000 イーサネット ラインカードに導入されました。

MPLS QoS 機能が、ASR 9000 イーサネット ラインカードに導入されました。

リリース 3.9.0

MLPPP QoS 機能が、ASR 9000 用 SIP 700 に導入されました。

リリース 3.9.1

マルチキャスト VPN での QoS 機能が、ASR 9000 イーサネット ラインカードに導入されました。

リリース 4.0.0

802.1ad DEI 機能が、ASR 9000 用 SIP 700 に導入されました。

フレーム リレー QoS 機能が、ASR 9000 用 SIP 700 に導入されました。

IP ヘッダー圧縮 QoS 機能が、ASR 9000 用 SIP 700 に導入されました。

L2VPN QoS 機能が、ASR 9000 用 SIP 700 でサポートされました。

MLFR QoS 機能が、ASR 9000 用 SIP 700 に導入されました。

一時停止/再開の方法が MLPPP および MLFR インターフェイスに追加されました。

MPLS QoS 機能が、ASR 9000 用 SIP 700 でサポートされました。

NxDS0 インターフェイスの QoS 機能が、ASR 9000 用 SIP 700 に導入されました。

リリース 4.1.0

VPLS と VPWS QoS 機能が導入されました。

802.1ad DEI

802.1ad フレームと 802.1ah フレームに含まれる Drop Eligible Indicator(DEI)ビットに基づいてトラフィックを分類できます。 DEI のサポートには次の機能が含まれます。

  • 特定のレートにポリシングし、トラフィックが適合または超過しているかどうかに基づいて、DEI を 0 または 1 としてマークします。
  • 入力に対して、ポリシングを行い、廃棄クラスを設定します(802.1ad カプセル化が設定されていないインターフェイスでも)。
  • 出力に対して、廃棄クラス値に基づいて DEI をマーキングします(802.1ad インターフェイスのみ)。

802.1ad フレームと 802.1ah フレームに含まれる Drop Eligible Indicator(DEI)ビットに基づいて輻輳を管理できます。 DEI のサポートには次の機能が含まれます。

  • DEI ビットの値に基づいて、重み付けランダム早期検出(WRED)を実行します。
  • あるインターフェイスでの輻輳時にトラフィックに優先処理(他より大きなしきい値)を与えることによって、アクティブ キュー管理を行います。あるいは、DEI 値に基づいて不適合なトラフィックに他より小さなしきい値を設定します。

ポリシング アクションに基づく DEI のマーキング:例

この例では、ポリシング レートを 5 Mbps に設定しています。 適合するトラフィックは 0 の DEI 値でマーキングします。ポリシング レートを超過したトラフィックは 1 の DEI 値でマーキングします。


policy-map 1ad-mark-dei
class c1
police rate 5 mbps
      conform-action set dei 0
      exceed-action set dei 1
end-policy-map

着信フィールドに基づく DEI のマーキング:例

この例では、802.1ad CoS と DEI は、着信する 802.1q CoS から導かれます。 CoS 値が 0 のパケットは、DEI 値 1 でマーキングされます。


class-map match-any remark-cos
  match cos 0
end-class-map

policy-map p1
  class remark-cos
  set dei 1
end-policy-map

interface GigabitEthernet0/4/0/39.1 l2transport
 encapsulation dot1q 1
 rewrite ingress tag push dot1ad 5 symmetric
 service-policy input p1
!

DEI を使用する輻輳管理:例

この例では、DEI 値が 0 のパケットをドロップする前に、DEI 値が 1 のパケットをドロップすることで輻輳を管理します。


policy-map dei-sample
  class class-default
    random-detect dei 1 1000 6000
    random-detect dei 0 5000 10000
end-policy-map

フレーム リレー QoS

フレーム リレー QoS と他のインターフェイス タイプとの主な違いは、以下のことを実行できることです。

  • フレーム リレー DLCI の分類
  • フレーム リレー DE の分類
  • フレーム リレー DE のマーキング

    (注)  


    QoS ポリシーは、フレーム リレー サブ インターフェイスの PVC に対してのみ適用できます。フレーム リレー サブ インターフェイスに直接適用することはできません。


フレーム リレー DLCI の分類

この設定では、フレーム リレーでカプセル化されたパケットのフレーム リレー DLCI 値に基づいて照合できます。 フレーム リレーでカプセル化されていないパケットはこの設定に対応しません。


class-map foo
            match frame-relay list of dlci-values

DLCI 値のリストには、次の例のように、範囲や個々の値を含めることができます。


class-map foo
            match frame-relay dlci 1-100 150 200-300

(注)  


DLCI のマッチングはメイン インターフェイスでのみサポートされています。


フレーム リレー DE の分類

この設定では、フレーム リレー ヘッダーに廃棄適性(DE)ビットが設定されているフレーム リレー パケットを照合できます。


class-map fr_class
  match fr-de 1

フレーム リレー DE ビット 0 を照合するには、次の設定を使用します。


class-map match-not-fr-de
  match not fr-de 1

(注)  


DE ビットの分類は、レイヤ 3 インターフェイスではサポートされていません。


フレーム リレー DE のマーキング

この例では、トラフィックがポリシング認定情報レートを超えたときに fr-de ビットを設定します。そのため、(輻輳が発生したとき)下位システムでは fr-de ビットが 1 に設定されたトラフィックを廃棄します。


policy-map fr_de_marking
 class class-default
  police rate percent 50
   conform-action transmit
   exceed-action set fr-de 1
  !
 !
 end-policy-map

(注)  


DE ビットのマーキングは、レイヤ 3 インターフェイスではサポートされていません。


フレームリレー QoS:例

この例では、parent_policy をマルチリンク フレーム リレーのメイン インターフェイスに適用します。 フレーム リレー DLCI で一致する parent_policy には 2 つのクラスがあります。 マルチリンク フレーム リレーのメイン インターフェイスには、2 つのフレーム リレー PVC が設定されています(DLCI 16、DLCI 17)。


show run int multi 0/2/1/0/1
Mon Aug  2 11:34:31.019 UTC
interface Multilink0/2/1/0/1
 service-policy output parent_policy
 encapsulation frame-relay
 frame-relay intf-type dce
!

show run policy-map parent_policy
Mon Aug  2 11:34:36.118 UTC
policy-map parent_policy
 class parentQ_1
  service-policy child_queuing_policy
  shape average 64 kbps
 !
 class parentQ_2
  service-policy child_queuing_policy
  shape average 1 mbps
 !
 class class-default
 !
 end-policy-map
!

show run class-map  parentQ_1 <----- class map parent class dlci=16
Mon Aug  2 11:34:43.363 UTC
class-map match-any parentQ_1
 match frame-relay dlci 16
 end-class-map
!

show run class-map  parentQ_2 <----- class map parent class dlci=17
Mon Aug  2 11:34:45.647 UTC
class-map match-any parentQ_2
 match frame-relay dlci 17
 end-class-map
!

show run int multi 0/2/1/0/1.16 <------ dlci 16 pvc config
Mon Aug  2 11:34:53.988 UTC
interface Multilink0/2/1/0/1.16 point-to-point
 ipv4 address 192.1.1.1 255.255.255.0
 pvc 16
  encap cisco
 !
!
show run int multi 0/2/1/0/1.17  <------ dlci 17 pvc config
Mon Aug  2 11:34:56.862 UTC
interface Multilink0/2/1/0/1.17 point-to-point
 ipv4 address 192.1.2.1 255.255.255.0
 pvc 17
  encap cisco
 !
!
show run policy-map child_queuing_policy <--------- child policy-map
Mon Aug  2 11:35:05.821 UTC
policy-map child_queuing_policy
 class voice-ip
  priority level 1
  police rate percent 20
  !
 !
 class video
  bandwidth percent 40
 !
 class premium
  service-policy gchild_policy
  bandwidth percent 10
  random-detect discard-class 2 10 ms 100 ms
  random-detect discard-class 3 20 ms 200 ms
  queue-limit 200 ms
 !
 class best-effort
  bandwidth percent 20
  queue-limit 200 ms
 !
 class class-default
 !
 end-policy-map
!

show run policy-map gchild_policy  <-------- grandchild policy map
Mon Aug  2 11:35:15.428 UTC
policy-map gchild_policy
 class premium_g1
  police rate percent 10
  !
  set discard-class 2
 !
 class premium_g2
  police rate percent 50
  !
  set discard-class 3
 !
 class class-default
 !
 end-policy-map
!

show run class-map  <----------- shows all class map configs
Mon Aug  2 11:35:19.479 UTC
class-map match-any video
 match precedence 1
 end-class-map
!
class-map match-any premium
 match precedence 2 3
 end-class-map
!
class-map match-any voice-ip
 match precedence 0
 end-class-map
!
class-map match-any parentQ_1
 match frame-relay dlci 16
 end-class-map
!
class-map match-any parentQ_2
 match frame-relay dlci 17
 end-class-map
!
class-map match-any premium_g1
 match precedence 2
 end-class-map
!
class-map match-any premium_g2
 match precedence 3
 end-class-map
!
class-map match-any best-effort
 match precedence 4
 end-class-map
!

IP ヘッダー圧縮の QoS

IP ヘッダー圧縮(IPHC)プロファイルはインターフェイス上でイネーブルにできるため、QoS サービス ポリシーと一致するパケットにのみ IPHC プロファイルが適用されます。 この場合、QoS サービス ポリシー クラス属性によって、圧縮するパケットが決定されます。 これにより、ユーザはより IPHC の精度を最適化できます。

ポリシー マップは、service-policy コマンドを使用してインターフェイスに割り当てます。 IPHC アクションは、出力サービス ポリシーにだけ適用されます。 IPHC は、入力サービス ポリシーではサポートされません。 (IPHC は入力方向でサポートされていますが、入力ポリシーで IPHC を設定する使用例はありません)。

次のように QoS を使用して IPHC を設定できます

  • compression header ip アクションで QoS ポリシーを作成します。
  • ipv4 iphc profile profile_name mode service-policy コマンドを使用して、IPHC プロファイルをインターフェイスに付加します。
  • service-policy output コマンドを使用して compression header ip アクションが含まれる QoS ポリシーを付加します。

また、次の例に示すように、show policy-map interface コマンドを使用して、IPHC の統計情報を表示できます。


show policy-map interface Serial0/0/3/0/3:0 output

show policy-map int  Serial0/0/3/0/3:0  output
Mon May 18 22:06:14.698 UTC
Serial0/0/3/0/3:0 output: p1
Class class-default
  Classification statistics          (packets/bytes)     (rate - kbps)
    Matched             :                   0/0                    0
    Transmitted         :                   0/0                    0
    Total Dropped       :                   0/0                    0
  Queueing statistics
    Queue ID                             : 0
    High watermark  (Unknown)            : 0
    Inst-queue-len  (packets)            : 0
    Avg-queue-len   (packets)            : 0
    Taildropped(packets/bytes)           : 0/0
  Compression Statistics
    Header ip rtp
    Sent Total       (packets)           : 880
    Sent Compressed  (packets)           : 877
    Sent full header (packets)           : 342
    Saved            (bytes)             : 31570
    Sent             (bytes)             : 24750
    Efficiency improvement factor        : 2.27

IP ヘッダー圧縮の QoS:例

この例では、compress header ip コマンドを使用し、クラス マップのアクションとしての QoS を通じて、IPHC を設定しています。

パケットはクラス マップの基準に基づいて分類されます。 ポリシー マップでは、クラスに適用する動作を指定します。 IPHC は、クラスに対する compress header ip アクションを使用してイネーブルにします。 QoS サービス ポリシーを持つ IPHC プロファイルを、シリアル インターフェイスに適用します。


class-map match-all voice1
	 match precedence 2
class-map match-all voice2
	 match access-group acl_iphc

access-list acl_iphc permit udp any range lower-bound src udp port 5000 upper-bound src udp port15000 any lower-bound udp dst port 5000 upper-bound dst udp port 15000

ipv4 access-list acl_iphc permit udp any range 5000 15000 any range 5000 15000

policy-map iphc_policy
	class iphc_class_1
		compress header ip
	class iphc_class_2
		compress header ip

interface serial 0/1/0/1:1 
	ipv4 iphc profile Profile_3 mode service-policy 
		service-policy output iphc_policy

interface Serial 0/2/0/0/1/1/1:1
  ipv4 address 10.0.0.1 255.255.255.252
  ipv4 iphc profile Profile_3 mode service-policy
  service-policy output iphc_policy
  encapsulation ppp

L2VPN QoS

ここでは、次のフレーム リレー L2VPN の導入シナリオについて説明します。

  • フレーム リレー <-> 疑似配線上でのフレーム リレー
  • フレーム リレー <-> 疑似配線上でのイーサネット

    (注)  


    これらのシナリオの疑似配線を経由しないローカル接続形態もあります。 ここでは、疑似配線シナリオに重点を置いて説明します。


フレーム リレー <-> 疑似配線上でのフレーム リレーの例

この例では、ルータ PE1 の入力フレーム リレー インターフェイスのフレーム リレー DLCI に基づいて照合を行い、fr-de 値を設定できることを示します。 この設定は、L2VPN 疑似配線に引き継がれます。 フレーム リレー パケットがフレーム リレー l2transport インターフェイスを経由してルータ PE2 から出るとき、fr-de 値はそのままです。

この設定を変更し、L2VPN を越えてフレーム リレー QoS 値に引き継ぐことができます。 図 2 に、ネットワーク トポロジを示します。

図 1. MPLS 上のフレーム リレー

CE1


interface pos0/2/0/0.26
 pvc 26
 ipv4 add 10.0.0.1 255.0.0.0

PE1


interface pos0/2/0/0.26 l2transport
 pvc 26

l2vpn
 xconnect group frfr
 p2p p1
interface pos0/2/0/0.26
 neighbor y.y.y.y pw-id 1001

!QoS Policy
class-map matchdlci
 match frame-relay dlci 26

policy-map setde1
 class matchdlci
  set fr-de 1

interface pos0/2/0/0
 service-policy input setde1

PE2


interface pos0/3/0/0.26 l2transport
 pvc 26

l2vpn
 xconnect group frfr
 p2p p1
interface pos0/3/0/0.26
 neighbor x.x.x.x pw-id 1001

CE2


interface pos0/3/0/0.26
 pvc 26
 ipv4 add 10.0.0.2 255.0.0.0

フレーム リレー <-> 疑似配線上でのイーサネット:例

この例では、ルータ PE1 の入力フレーム リレー l2transport インターフェイスの fr-de 値に基づいて照合を行い、特定の MPLS EXP 値を設定できることを示します。 MPLS パケットが PE1 コア インターフェイスを出るとき、この EXP 値が設定されます。 パケットがイーサネット l2transport インターフェイスを経由してルータ PE2 から出るとき、この値はイーサネット パケットの CoS フィールドの値の一部になります。

この設定により、QoS フィールドをフレーム リレー ネットワークからイーサネット ネットワークに引き継ぐ、またはマップできます。 図 3 に、ネットワーク トポロジを示します。

図 2. MPLS 上の IP Interworking

CE1


interface pos0/2/0/0.26
 pvc 26
 ipv4 add 10.0.0.1 255.0.0.0

PE1


interface pos0/2/0/0.26 l2transport
 pvc 26

l2vpn
 xconnect group freth
 p2p p1
interface pos0/2/0/0.26
 neighbor y.y.y.y pw-id 1001
 interworking ipv4

!QoS Policy
class-map matchfrde
 match fr-de 1

policy-map setexp
 class matchfrde
  set mpls exp imposition 5

interface pos0/2/0/0.26 l2transport
 pvc 26
 service-policy input setexp

PE2


interface gig0/4/0/0.26 l2transport
 encapsulation dot1q 100

l2vpn
 xconnect group freth
 p2p p1
interface gig0/4/0/0.26
 neighbor x.x.x.x pw-id 1001
 interworking ipv4

CE2


interface gig0/4/0/0.26
 encapsulation dot1q 100
 ipv4 add 10.0.0.2 255.0.0.0

MLPPP QoS/MLFR QoS

マルチリンクとは、複数のシリアル リンクを 1 つのバンドルに集約するメカニズムです。 バンドルにより、より高い帯域幅、リンク間のロード バランシングが可能になり、シングル ポイント障害からの保護によりサービス アベイラビリティが向上します。 このサービスで、複数の低速リンクを集約して帯域幅を増やすことができます。1 本の高速リンクにアップグレードするよりも費用対効果に優れています。 これは T1 レートより大きく T3 レートより小さい帯域幅の専用回線サービスを必要とするユーザにとって、費用対効果の高いソリューションです。

マルチリンク インターフェイスは、PPP カプセル化(MLPPP)またはフレーム リレー カプセル化(MLFR)で設定できます。 マルチリンク インターフェイスがフレーム リレー カプセル化で設定されている場合、その下にサブインターフェイスを設定できます。

マルチリンク インターフェイスで使用可能な総帯域幅は、マルチリンク インターフェイスへのリンクの追加や、マルチリンク インターフェイスからのリンクの削除によって動的に変化します。 メンバのリンクの状態が動作面でアップまたはダウンに変化した場合や、ポリシーの保留状態を変更することによって、使用可能な総帯域幅も変化します。 このようなインターフェイスに付加されている QoS ポリシーは、帯域幅の変更に基づいて更新する必要があります。 この場合、次のいずれかの操作を実行します。

  • ポリシーを保留にする:付加されているポリシーの帯域幅要件が使用可能な帯域幅(メンバ リンクが運用面でダウンすると小さくなります)を上回ったときには、ポリシーが保留状態になります。 ポリシーが保留状態になると、そのインターフェイスの着信パケットまたは発信パケットは QoS の影響を受けなくなります。 次の状況では、入力に対してポリシーは保留状態になります。
    • 拡張階層型の入力ポリシングでは、子ポリシング レートの合計が親ポリシングの適合レートよりも大きい場合
    • ポリシング ピーク レートがポリシング適合レートを下回っている場合 次の状況では、出力に対してポリシーは保留状態になります。
    • 最小帯域幅レートとプライオリティ クラスのポリシング レートの合計がインターフェイスのレートを上回っている場合
    • シェーピング レートが最小帯域幅レートを下回っている場合
    • プライオリティ クラスのポリシング適合レートがインターフェイスのレートを上回っている場合
    • プライオリティ クラスのポリシング ピーク レートが、インターフェイスのレートを上回っている場合
    • ポリシング ピーク レートがポリシング適合レートを下回っている場合
  • ポリシーを再開する:付加されているポリシーの帯域幅要件が使用可能な帯域幅(メンバ リンクが運用面でアップすると大きくなります)以下のときには、ポリシーが再開されます。 保留中のポリシーは、メンバ リンクのステータスの変化がなくても、ポリシー マップの保留状態を変更することでも再開できます。
  • ポリシーを更新する:新しい使用可能な帯域幅を反映するように、アクティブなポリシー レートを更新します。 使用可能な帯域幅は、増加または減少している場合がありますが、適用されているポリシーの帯域幅要件は引き続き満たされています。

QoS 統計情報は、アクティブ状態から保留状態に移行するポリシーについては保持されません。 ポリシーを再度アクティブにすると、それまでに収集された統計情報はすべて失われ、再アクティブ化後にインターフェイスを通過したパケットだけがカウントされます。 保留中のポリシーを変更して帯域幅要件を減らし、再アクティブ化することができます。 保留中のポリシーは、インターフェイスに付加したまま変更できます。

QoS を使用するマルチクラス MLPPP

マルチクラスのマルチリンク ポイントツーポイント プロトコル(MLPPP)は、QoS と一緒に使用することができ、ポリシー マップのクラスでのencap-sequence コマンドを使用して設定できます。 encap-sequence コマンドは、MQC 定義クラス内のパケットの MLPPP MCMP クラス ID を指定します。

encap-sequence ID 番号の有効値は、none、1、2、または 3 です。 none 値は、priority level が 1 のときだけ適用でき、MLPPP カプセル化がないことを示します。 1、2、または 3 の値は、プライオリティ 1 もしくは 2 のクラスまたはキューイング アクションを含むその他のクラスで使用できます。 ゼロ(0)の encap-sequence ID 番号は、システムでのみ使用し、デフォルト クラス用に予約されているため、他のクラスでは使用できません。


(注)  


encap-sequence ID 番号は番号順に設定する必要があります。 たとえば、1 と 2 をすでに割り当てていない限り、ID 番号 3 は割り当てることができません。


encap-sequence ID 番号の数は、マルチリンク ヘッダーによってピア間でネゴシエーションされた MLPPP クラスの数よりも小さくする必要があります。 システムによってこれが確認されないため、ユーザは設定がこれに合っていることを確認する必要があります。

ppp multilink multiclass remote apply コマンドは、これを確認する方法を提供します。 encap-sequence ID 番号(デフォルト値の 0 を含む)を使用するクラスの数が、ppp multilink multiclass remote apply コマンドの min-number 値よりも小さいことを確認します。 たとえば、min-number 値が 4 の場合は、encap-sequence ID 番号を持つクラスを 3 つまでしか使用できません。

QoS ポリシーは、次の条件を検証します。 これらの条件が満たされていない場合、ポリシーは拒否されます。

  • encap-sequence ID 番号が 1~3 という許容値内である。
  • encap-sequence がポリシー マップ内のいずれかのクラスに設定されている場合は、priority level 1 を持つポリシー マップ内のすべてのクラスに encap-sequence ID 番号を含める必要があります。
  • encap-sequencenone の設定は、priority level が 1 のクラスに限定されます。
  • class-default には encap-sequence 設定は含まれていません。
  • キューイング アクションを含むクラスだけが encap-sequence 設定を持ちます。

    (注)  


    同じ encap-sequence ID 番号を共有するクラスは、プライオリティが同じである必要があります。


QoS ポリシー マップは、次のとおりに設定されます。


config 
	policy-map type qos policy-name		class class-name			action			action			action
. . .

次に、MLPPP のポリシー マップを設定する例を示します。


config 
	policy-map foo
		class ip-prec-1
			encap-sequence none
			police rate percent 10
			priority level 1
	!
		class ip-prec-2
			encap-sequence 1
			shape average percent 80
	!
		class ip-prec-3
			encap-sequence 1
			bandwidth percent 10
	!
		class class-default
	!
	end-policy-map
	!

MLPPP QoS/MLFR QoS:例

メンバ リンクがアップまたはダウンすると、バンドル インターフェイスの帯域幅は動的に変化するため、このようなインターフェイスに適用されている QoS ポリシーは帯域幅の変更に基づいて更新する必要があります。

MPLS QoS


(注)  


導入テキストとトポロジ図は、『MPLS Fundamentals』(Luc De Ghein、Copyright 2007, Cisco Systems, Inc)から引用しました。


MPLS QoS には、均一モード、パイプ モード、およびショート パイプ モードという、トンネリング モデルに基づく 3 つの導入シナリオがあります。 表 2 に、トンネリング モデルの概要を示します。

トンネリング モード

IP-to-Label

Label-to-Label

Label-to-IP

Uniform

IP precedence/DiffServ を MPLS EXP にコピー /DiffServ から MPLS EXP へ

コピーされた MPLS EXP

MPLS EXP を IP precedence/DiffServ にコピー

Pipe

サービス プロバイダーのポリシーに応じた MPLS EXP 設定

コピーされた MPLS EXP

IP precedence/DiffServ を保持 /DiffServ

MPLS EXP に基づく転送処理

Short Pipe

サービス プロバイダーのポリシーに応じた MPLS EXP 設定

コピーされた MPLS EXP

IP precedence/DiffServ を保持 /DiffServ

IP precedence/DiffServ に基づく転送処理

MPLS 均一モード

均一モードでは(図 4 に図示)、MPLS ネットワークを通過するときに、パケットに関連する DiffServ マーキングが 1 つだけ存在します。 パケットの DiffServ マーキングが MPLS ネットワーク内で変更された場合、更新情報は LSP の出口で意味のあるものになります。 MPLS ネットワーク内でのパケット マーキングに対するあらゆる変更は永続的であり、パケットが MPLS ネットワークを出るときに伝播されます。

図 3. 均一モード

MPLS パイプ モード

パイプ モード(図 5 に図示)では、MPLS ネットワークを通過するときに、2 つのマーキングがパケットに関連します。 1 つめは、出力 LSR を含む LSP スパンに沿って中間ノードによって使用されるマーキングです。 2 つめは、元のマーキングであり、MPLS ネットワークに入る前にパケットによって伝送され、パケットを出た後も継続して使用されます。 MPLS ネットワーク内のパケット マーキングに対するあらゆる変更は、永続的なものではなく、パケットが MPLS ネットワークを出るときに伝播されません。

出力 LSR ではまだ中間 LSR で使用されたマーキングを引き続き使用することに注意してください。 ただし、出力 LSR は、元のパケットにインポーズされたすべてのラベルを削除する必要があります。 ラベルで伝送されるマーキングを維持するために、エッジ LSR は、マーキングの内部コピーを保管してから、ラベルを削除します。 この内部コピーは、ラベルが削除されたあとに、(CE 方向の)アウトバウンド インターフェイスでパケットを分類するために使用されます。 これは通常、set qos-group コマンドと match qos-group コマンドを使用して行います。

図 4. パイプ モード

MPLS ショート パイプ モード

ショート パイプ モード(図 6 に図示)は、パイプ モードとわずかに異なります。 唯一の違いは、出力 LSR が中間 LSR によって使用されるマーキングを使用する代わりに元のパケット マーキングを使用することです。

図 5. ショート パイプ モード

均一、パイプ、ショート パイプ モード:入力 PE の例

この例では、MPLS DiffServ を実装する方法と、入力 PE で必要な設定について説明します。 precedence 4 のみ一致します。 precedence 4 は、帯域幅が超過しない限り、ポリサーによって EXP ビット値 4 にマップされます。この場合、EXP ビットは値 2 にリカラーされます。 出力インターフェイスの設定は、MPLS DiffServ 均一モデルには不要ですが、EXP ビットに対する QoS の実行方法を示すために追加しています。


!Ingress interface:
class-map prec4
match precedence 4
!
policy-map set-MPLS-PHB
class prec4
police rate 8000 kbps
conform-action set mpls experimental imposition 4
exceed-action set mpls experimental imposition 2
!
interface GigabitEthernet0/0/0/1
service-policy input set-MPLS-PHB

!Egress interface:
class-map exp2and4
match mpls experimental topmost 2 4
!
policy-map output-qos
class exp2and4
bandwidth percent 40
random-detect default
!
interface GigabitEthernet0/0/0/2
service-policy output output-qos

均一モード:出力 PE の例

出力 PE では、EXP ビットは set qos-group コマンドと match qos-group コマンドを使用して precedence ビットにコピーします。


!Ingress interface:
class-map exp2
match mpls experimental topmost 2
!
class-map exp4
match mpls experimental topmost 4
!
policy-map policy2
class exp2
set qos-group 2
class exp4
set qos-group 4
!
interface GigabitEthernet0/0/0/2
service-policy input policy2

!Egress interface:
class-map qos2
match qos-group 2
class-map qos4
match qos-group 4
!
policy-map policy3
class qos2
set precedence 2
bandwidth percent 20
random-detect default
class qos4
set precedence 4
bandwidth percent 20
random-detect default
!
interface GigabitEthernet0/0/0/1
service-policy output policy3

パイプ モード:出力 PE の例

次に、MPLS DiffServ パイプ モードの出力 PE の設定例を示します。 出力 LSR では発信 IP パケットの precedence ビットに EXP ビットをコピーしません。 出力インターフェイスでのパケットのスケジューリングは、set qos-group コマンドと match qos-group コマンドを使用して EXP ビットに間接的に行います。


!Ingress interface:
class-map exp2
match mpls experimental topmost 2
!
class-map exp4
match mpls experimental topmost 4
!
policy-map policy2
class exp2
set qos-group 2
class exp4
set qos-group 4
!
interface GigabitEthernet0/0/0/2
service-policy input policy2

!Egress interface:
class-map qos2
match qos-group 2
class-map qos4
match qos-group 4
!
policy-map policy3
class qos2
bandwidth percent 20
random-detect default
class qos4
bandwidth percent 20
random-detect default
!
interface GigabitEthernet0/0/0/1
service-policy output policy3

ショート パイプ モード:出力 PE の例

次に、MPLS DiffServ ショート パイプ モードの出力 PE の設定例を示します。 出力 LSR では、ラベルを削除した後、IP パケットの precedence または DiffServ コード ポイント(DSCP)ビットに基づいてパケットを転送します。 出力 LSR では発信 IP パケットの precedence ビットに EXP ビットをコピーしません。


! Configuration is not needed for ingress interface

!Egress interface:
class-map prec4
match precedence 4
!
policy-map policy3
class prec4
bandwidth percent 40
random-detect precedence 4 100 ms 200 ms
!
interface GigabitEthernet0/0/0/1
service-policy output policy3

マルチキャスト VPN での QoS

ASR 9000 イーサネット ラインカード

マルチキャスト VPN(mVPN)対応ネットワークでの QoS サービスのサポートには、トンネル IP ヘッダーの DSCP または precedence ビットのマーキングが含まれます。 この機能により、mVPN サービスの QoS を行う MPLS キャリアがイネーブルになります。 mVPN ネットワークでは、プロバイダー エッジ(PE)デバイス間の総称ルーティング カプセル化(GRE)トンネルを使用します。 マルチキャスト パケットは、MPLS コア ネットワーク上で送信するために GRE トンネルに置かれます。

入力インターフェイスでは、入力インターフェイスに適用される入力ポリシー セット内で set precedence tunnel コマンドと set dscp tunnel コマンド(条件付きと無制限の両方)を使用します。 一般的な mVPN ネットワークを示します。 IP パケットが入力インターフェイス E1 の PE1 に着信すると、GRE トンネル内で IP パケットをカプセル化することによって、パケットがトンネル インターフェイス E2 からコア ネットワークに送信されます。

図 6. mVPN ネットワーク

set dscp tunnel コマンドまたは set precedence tunnel コマンドが入力インターフェイス E1 で設定されている場合、DSCP または precedence 値はインターフェイス E2 から送信されるカプセル化パケットの GRE トンネル ヘッダーに設定されます。 そのため、次の点に注意してください。

  • set dscp コマンドまたは set precedence コマンド(条件付きまたは無条件)により、IP ヘッダー内の DSCP または precedence 値がマークされます。
  • set dscp tunnel コマンドまたは set precedence tunnel コマンド(条件付きまたは無条件)により、GRE ヘッダー内の DSCP または precedence 値がマークされます。

マルチキャスト VPN での QoS:例

mVPN 対応ネットワークで QoS をサポートするには、トンネル ヘッダーに DSCP または precedence ビットの条件付きおよび無条件マーキングが必要です。 無条件マーキングでは、ポリシー アクションとして DSCP または precedence トンネルをマークします。 条件付きマーキングでは、ポリサーのアクションとしてトンネル ヘッダーに DSCP または precedence 値をマークします(適合、超過、または違反)。

無条件マーキング


class-map c1
  match vlan 1-10

policy-map p1
 class c1
  set precedence tunnel 3

条件付きマーキング


policy-map p2
 class c1

  police rate percent 50
  conform action set dscp tunnel af11
  exceed action set dscp tunnel af12

ASR 9000 用 SIP 700

set precendence tunnel コマンドおよび set dscp tunnel コマンドはサポートされませんが、次の例に示すように一般的なマルチキャスト VPN はサポートされます。

マルチキャスト VPN での QoS:例

この例では、ネットワーク全体で、モバイル、エンタープライズ、およびその他の 3 つのサービスが提供されています。 モバイル トラフィックは、ブロードバンド 2G モバイル トラフィックと 3G モバイル トラフィックとして分類されます。

制御トラフィックには最高のプライオリティが必要であり、プライオリティ レベル 1 を持ちます。 ブロードバンド 2G モバイル トラフィックは、プライオリティ レベル 2 を持ちます。 プライオリティ キューは、これらの各トラフィック クラスに関連付けられます。 これらのクラスのトラフィックは、100 パーセントのレートでポリシングされます。つまり、フル回線レート帯域幅がこれらのトラフィック クラス専用であることを意味します。

残存帯域幅は Mcast_BBTV_Traffic クラス、Enterprise_Traffic クラス、および Enterprise_Low_Traffic クラスに分配されます。


policy-map CompanyA-Profile
 class Control_Traffic
  priority level 1
  police rate percent 100
  !
 !
 class BB_2GMobile_Traffic
  priority level 2
  police rate percent 100
  !
 !
 class Mcast_BBTV_Traffic
  bandwidth remaining ratio 1000
 !
 class 3GMobile_Traffic
  bandwidth remaining ratio 100
 !
 class Enterprise_Traffic
  bandwidth remaining ratio 10
 !
 class Enterprise_Low_Traffic
  bandwidth remaining ratio 1
 !
 class class-default
 !
 end-policy-map

NxDS0 インターフェイスでの QoS

NxDS0 インターフェイスの QoS では、シェーピング、ポリシング、およびキューイングの最小レートは 8 kbps、粒度は 1 kbps です。 QoS が低速 NxDS0 リンクに適用されると、リアルタイム プライオリティ トラフィックに低遅延を行うために、フレーム リレー フラグメンテーション(frf12)設定を行うことを推奨します。 NxDS0 インターフェイスでの一般的な設定は次のとおりです。

  • 1 レベルのポリシーが、フレーム リレーの設定のないメイン インターフェイスに適用される
  • 2 レベルのポリシーが、フレーム リレーが設定されたサブインターフェイスに適用される

メイン インターフェイスに適用される 1 レベルのポリシー:例


show run int Serial0/2/1/0/1/1:0

Mon Aug  9 11:29:50.721 UTC
interface Serial0/2/1/0/1/1:0
 service-policy output fractional_T1_E1_policy --------policy applied to serial interface
 encapsulation frame-relay
!

RP/0/RSP1/CPU0:viking-1#show run policy-map
policy-map fractional_T1_E1_policy
 class Conversational
  priority level 1
  police rate 64 kbps
  !
 !
 class Streaming-Interactive
  bandwidth remaining percent 35
 !
 class Background
  bandwidth remaining percent 15
 !
 class TCP-traffic
  bandwidth remaining percent 10
 !
 class class-default
 bandwidth remaining percent 40
 !
 end-policy-map

サブインターフェイスに適用される 2 レベルのポリシー:例


show run int Serial0/2/1/0/1/1:0

Mon Aug  9 11:29:50.721 UTC
interface Serial0/2/1/0/1/1:0
 encapsulation frame-relay
 frame-relay intf-type dce
!

Mon Aug  9 11:29:37.150 UTC
interface Serial0/2/1/0/1/1:0.16 point-to-point
 ipv4 address 192.1.1.1 255.255.255.0
 pvc 16
 service-policy output parent_policy --------policy applied to serial subinterface
  encap cisco
  fragment end-to-end 350  -------------------frf12 enabled
  !
 !
!

show run policy-map

policy-map parent_policy
 class class-default
  shape average rate 768 kbps

show run policy-map

policy-map fractional_T1_E1_policy
 class Conversational
  priority level 1
  police rate 64 kbps
  !
 !
 class Streaming-Interactive
  bandwidth remaining percent 35
 !
 class Background
  bandwidth remaining percent 15
 !
 class TCP-traffic
  bandwidth remaining percent 10
 !
 class class-default
 bandwidth remaining percent 40
 !
 end-policy-map

VPLS と VPWS QoS

1 つまたは複数の Virtual Private Wire Services(VPWS)対応ネットワーク上で、次の一致基準に基づいてパケットを分類できます。

  • vpls ブロードキャストとの一致(VPLS に適用可能)
  • vpls マルチキャストとの一致(VPLS に適用可能)
  • vpls 制御との一致(VPLS に適用可能)
  • arp ethertype との一致(VPLS と VPWS の両方に適用可能)

    (注)  


    VPLS 固有および VPWS 固有の分類は、入力方向に対してのみ実行されます。


次のガイドラインが、VPLS と VPWS の QoS 機能に適用されます。

  • 入力レイヤ 2 バンドルおよび非バンドル サブインターフェイスでサポートされます。
  • レイヤ 3 サブインターフェイスではサポートされませんが、ポート継承ポリシーを持つポートではサポートされます。 システムは、ポートに対応付けられたレイヤ 3 サブ インターフェイスの VPLS の分類を無視します。
  • match vpls <control | multicast | broadcast> および match ethertype arp は、レイヤ 2 のサービス タイプに関係なくレイヤ 2 インターフェイスに適用されますが、vpls <control | multicast | broadcast> の分類は非 VPLS レイヤ 2 インターフェイス タイプでは無視されます。

図 9 は標準的な VPLS トポロジを示しています。 VPLS ネットワークはルータのドメインをブリッジングするために相互接続された疑似配線(PW)のメッシュです。 プロバイダー エッジ(PE)ルータのそれぞれがブリッジ ドメインを持ちます。 各 PW は、ブリッジ ドメインに対するブリッジ ポートです。 各 PE ルータに対するカスタマー エッジ(CE)接続は、同じブリッジ ドメインに対する接続回線(AC)ブリッジ ポートです。 QoS のコンフィギュレーション コマンドは、一方の CE ルータに接続する AC と、他方の PE ルータのブリッジ ドメインに適用されます。

図 7. 一般的な VPLS ネットワーク トポロジ

VPLS と VPWS の QoS:例

ここでは、図 9 に示す構成要素に基づいて設定例を説明し、さらに設定された値に基づいてネットワークでパケットを照合する方法について説明します。

PE1 ルータ上では、次のようにポリシーマップと PE-to-CE 接続が設定されています。


class c1
  match vpls multicast
!
class c2
  match vpls broadcast
!
class c3
  match vpls control
!
class c4
  match ethertype arp
!
policy-map p1
  class c1
   set qos-group 3
   set mpls experimental imposition 4
   shape average percent 40
!
  class c2
   bandwidth remaining percent 10
   set mpls experimental imposition 5
!
  class c3
   police rate percent 10
   set mpls experimental imposition 6
!
  class c4
   bandwidth remaining percent 10
   set mpls experimental imposition 7
!
class class-default
!
end policy-map

interface GigabitEthernet0/2/0/0 l2transport
  description PE to CE connection
  service-policy input p1
!
 
l2vpn
 bridge group examples
  bridge-domain vpls-bridge
   interface GigabitEthernet0/2/0/0
   !
   vfi pe12link
    neighbor 10.0.0.2 pw-id 12
    !
   !
   vfi pe13link
    neighbor 10.0.0.3 pw-id 13
    !
   !
  !
 !
!
 

この例に従い、VPLS と VPWS をイネーブルにして設計および実装されているネットワークでは、一致基準を満たすパケットは、ポリシーに定義されているポリシー アクションに従って QoS の処理を受けます。

  • VPLS のマルチキャスト パケットが PE ルータの入力インターフェイスに着信すると、クラス c1 に一致します。
  • VPLS のブロードキャスト パケットが PE ルータの入力インターフェイスに着信すると、クラス c2 に一致します。
  • VPLS 制御パケットが、MAC アドレスの範囲が 01-80-C2-00-00-00 ~ 01-80-C2-00-00-3F の PE ルータの入力インターフェイスに着信すると、クラス c3 に一致します。
  • ARP パケットが PE ルータの入力インターフェイスに着信すると、クラス c4 に一致します。

関連情報

このモジュールでは、他のテクノロジー ガイドに記載されている機能での QoS 実装について説明します。 次の表に、これらの機能の詳細を入手できるマニュアルを示します。

機能

ガイド

802.1ad DEI

このマニュアルの「モジュラ QoS パケット分類とマーキングの設定」および「モジュラ QoS の輻輳管理の設定」

フレーム リレー

『Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Configuration Guide』

Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Command Reference

IP ヘッダー圧縮

『Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Configuration Guide』

Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Command Reference

L2VPN

『Cisco ASR 9000 Series Aggregation Services Router L2VPN』および『Ethernet Services Configuration Guide』

Cisco ASR 9000 Series Aggregation Services Router L2VPN and Ethernet Services Command Reference

MLPPP/MLFR

『Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Configuration Guide』

Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Command Reference

MPLS

『Cisco ASR 9000 Series Aggregation Services Router MPLS Configuration Guide』

Cisco ASR 9000 Series Aggregation Services Router MPLS Command Reference

マルチキャスト VPN での QoS

『Cisco ASR 9000 Series Aggregation Services Router Multicast Configuration Guide』

Cisco ASR 9000 Series Aggregation Services Router Multicast Command Reference

NxDS0 インターフェイスでの QoS

『Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Configuration Guide』

Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Command Reference