Cisco ASR 9000 シリーズ アグリゲーション サービス ルーター モジュラ QoS サービス コンフィギュレーション ガイド リリース 4.3.x
モジュラ QoS サービス パケットの分類の設定
モジュラ QoS サービス パケットの分類の設定
発行日;2013/02/24   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

モジュラ QoS サービス パケットの分類の設定

パケット分類は、データ パス上で輻輳管理または輻輳回避を必要とするトラフィック フローを識別し、マーキングします。 モジュラ Quality of Service(QoS)コマンドライン インターフェイス(MQC)は、分類する必要のあるトラフィック フローを定義するために使用します。このとき、各トラフィック フローをサービス クラス、またはクラスと呼びます。 その後、トラフィック ポリシーを作成し、クラスに適用します。 定義されたクラスに該当しないトラフィックは、すべてデフォルト クラスのカテゴリに分類されます。

このモジュールでは、QoS パケット分類の概念および設定情報について説明します。

ラインカード、SIP および SPA のサポート

機能

ASR 9000 イーサネット ラインカード

ASR 9000 用 SIP 700

DEI に基づく分類

yes

no

クラスベースの無条件パケット マーキング

yes

yes

In-Place ポリシーの変更

yes

yes

IPv6 QoS

yes

yes

パケットの分類とマーキング

yes

yes

ポリシーの継承

yes

yes

ポート シェーピング ポリシー

yes

no

共有ポリシー インスタンス

yes

no

Cisco ASR 9000 シリーズ ルータでのモジュラ QoS パケット分類とマーキングの設定に関する機能履歴

リリース

変更内容

リリース 3.7.2

クラスベース無条件パケット マーキング機能が、ASR 9000 イーサネット ラインカードに導入されました。

IPv6 QoS 機能が、ASR 9000 イーサネット ラインカードに導入されました。 (IPv6 ACL に対する QoS の照合はサポートされていません)。

パケットの分類とマーキング機能が、ASR 9000 イーサネット ラインカードに導入されました。

リリース 3.9.0

クラスベース無条件パケット マーキング機能が、ASR 9000 用 SIP 700 でサポートされました。

パケットの分類とマーキング機能が、ASR 9000 用 SIP 700 でサポートされました。

ポリシーの継承機能が、ASR 9000 イーサネット ラインカードと ASR 9000 用 SIP 700 に導入されました。

共有ポリシー インスタンス機能が、ASR 9000 イーサネット ラインカードに導入されました。

リリース 4.0.0

DEI 機能に基づく分類機能が、ASR 9000 イーサネット ラインカードに導入されました。

In-Place ポリシーの変更機能は、ASR 9000 イーサネット ラインカードと ASR 9000 用 SIP 700 に導入されました。

IPv6 QoS 機能が、ASR 9000 用 SIP 700 でサポートされました。

同じクラスのポリサー アクションの一部として、スタンドアロン マーキング アクションが 3 つ、マーキング アクションが 3 つ、ASR 9000 用 SIP 700 に追加されました。 (ASR 9000 イーサネット ラインカードでは、同じクラスのポリサー アクションの一部として、スタンドアロン マーキング アクションを 2 つ、マーキング アクションを 2 つサポートしています)。

リリース 4.0.1

ポート シェーピング ポリシー機能のサポートが、ASR 9000 イーサネット ラインカードに導入されました。

リリース 4.2.1 衛星機能の QoS が追加されました。

モジュラ QoS パケット分類の設定の前提条件

ネットワークでモジュラ QoS パケット分類とマーキングを設定するには、次の前提条件が必要です。

  • 適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。このコマンド リファレンス ガイドには、各コマンドに必要なタスク ID が含まれます。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。
  • Cisco IOS XR QoS の設定作業と概念に関する知識が必要です。

モジュラ QoS パケットの分類の設定に関する情報

このマニュアルの QoS パケット分類機能を設定するには、次の概念を理解している必要があります。

パケット分類の概要

パケットの分類には、特定のグループ(またはクラス)内のパケットを分類し、これにトラフィック記述子を割り当てて、ネットワークで QoS 処理用にアクセスできるようにする処理が含まれます。 トラフィック記述子には、パケットが受ける転送処理(Quality of Service)に関する情報が含まれます。 パケット分類を使用すると、複数のプライオリティ レベルまたは CoS にネットワーク トラフィックを区分できます。 発信元が契約された条項に従うことに同意し、ネットワークが QoS の実行を約束します。 トラフィック ポリサーとトラフィック シェーパーは、契約を順守するために、パケットのトラフィック記述子を使用します。

トラフィック ポリサーおよびトラフィック シェーパーは、IP precedence などのパケット分類機能を使用して、さまざまなタイプの QoS サービスに対して、ルータを通過するパケット(またはトラフィック フロー)を選択します。 たとえば、IP パケット ヘッダーのタイプ オブ サービス(ToS)フィールドの 3 つの precedence ビットを使用すると、最大 8 種類のトラフィック クラスで構成される限定的な設定にパケットを分類できます。 パケットを分類した後、他の QoS 機能を使用して、輻輳管理、帯域幅割り当て、および遅延限度などの適切なトラフィック処理ポリシーを、各トラフィック クラスに割り当てることができます。


(注)  


IPv6 ベースの分類は、レイヤ 3 インターフェイスでのみサポートされています。


トラフィック クラスの要素

トラフィック クラスの目的は、ルータのトラフィックを分類することです。 class-map コマンドを使用して、トラフィック クラスを定義します。

トラフィック クラスに含まれる 3 つの主な要素は、名前、一連の match コマンド、そしてトラフィック クラスに複数の match コマンドが存在する場合に match コマンドを評価する方法です。 トラフィック クラスの名前は、class-map コマンドで指定します。 たとえば、class-map コマンドで cisco を使用すると、トラフィック クラスの名前は cisco になります。

match コマンドは、パケット分類のためのさまざまな基準を指定するために使用します。 パケットは、match コマンドで指定された基準に合っているかどうかを判断するために、チェックされます。 指定された基準に合っていれば、パケットはクラスのメンバーと見なされ、トラフィック ポリシーで設定された QoS 仕様に従って転送されます。 一致基準を満たさないパケットは、デフォルトのトラフィック クラスのメンバーとして分類されます。 18 ページの「デフォルト トラフィック クラス」の項を参照してください。

複数の一致基準をトラフィック クラスに指定する場合は、これらの match コマンドを評価する方法の説明を指定する必要があります。 評価の説明は、class-map match-any コマンドで指定します。 match-any オプションを評価の説明として指定した場合、トラフィック クラスによって評価されるトラフィックは、指定した条件のうち少なくとも 1 つを満たす必要があります。 match-all オプションを指定した場合、トラフィックはすべての一致基準を満たす必要があります。

これらのコマンドの機能については、『Cisco ASR 9000 Series Aggregation Services Routers Modular Quality of Service Command Reference』でより詳細に説明します。 トラフィック クラスの設定作業については、32 ページの「Creating a Traffic Class」の項で説明されています。

トラフィック ポリシーの要素

トラフィック ポリシーの目的は、ユーザが指定したトラフィック クラスまたはクラスに分類されたトラフィックに関連付ける QoS 機能を設定することです。 トラフィック ポリシーを作成するには、policy-map コマンドを使用します。 トラフィック ポリシーには、名前、トラフィック クラス(class コマンドで指定)、および QoS ポリシーという 3 つの要素が含まれます。 トラフィック ポリシーの名前は、ポリシー マップの Modular Quality of Service(MQC)で指定します(たとえば、policy-map policy1 コマンドによって policy1 という名前のトラフィック ポリシーを作成できます)。 指定したトラフィック ポリシーにトラフィックを分類するために使用するトラフィック クラスは、クラス マップ コンフィギュレーション モードで定義します。 トラフィック ポリシーにトラフィックを分類に使用するトラフィック クラスを選択した後で、この分類されたトラフィックに適用する QoS 機能を入力できます。

MQC では、必ずしも 1 つのトラフィック クラスだけを 1 つのトラフィック ポリシーに関連付ける必要はありません。 パケットが複数の一致基準に一致する場合、1 つのトラフィック ポリシーに 1024 のトラフィック クラスを関連付けることができます。 1024 のクラス マップには、デフォルト クラスと子ポリシーのクラスが含まれます(存在する場合)。

クラスをポリシー マップで設定する順序が重要です。 クラスの一致規則は、クラスをポリシー マップで指定した順序で TCAM にプログラミングされます。 したがって、あるパケットが複数のクラスと一致する場合は、最初に一致したクラスだけが返され、対応するポリシーが適用されます。

これらのコマンドの機能については、『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference』でより詳細に説明します。

トラフィック クラスの設定作業については、38 ページの「Creating a Traffic Policy」の項で説明されています。

デフォルト トラフィック クラス

未分類のトラフィック(トラフィック クラスで指定された一致条件を満たさないトラフィック)は、デフォルト トラフィック クラスに属するものとして扱われます。

ユーザがデフォルト クラスを設定しない場合でも、パケットはデフォルト クラスのメンバとして扱われます。 ただし、デフォルトでは、デフォルト クラスにイネーブルな機能はありません。 そのため、機能が設定されていないデフォルト クラスに属するパケットには QoS 機能は適用されません。 この後、これらのパケットは、ファーストイン ファーストアウト(FIFO)キューに配置され、使用可能な下位リンクの帯域幅で決められたレートで転送されます。 この FIFO キューは、テール ドロップと呼ばれる輻輳回避技術で管理されます。 テール ドロップなどの輻輳回避技術の詳細については、このマニュアルの「Configuring Modular QoS Congestion Avoidance on Cisco ASR 9000 Series Routers」モジュールを参照してください。

バンドル トラフィック ポリシー

ポリシーがバンドルにバインドされている場合、各バンドル メンバ(ポート)で同じポリシーがプログラミングされます。 たとえば、ポリサーまたはシェーパー レートがある場合、各ポートに同じレートが設定されます。 トラフィックはロード バランシング アルゴリズムに基づいてメンバをバンドルするようスケジュールされます。

ポリシーは次のものにバインドできます。

  • バンドル
  • バンドル レイヤ 3 サブインターフェイス
  • バンドル レイヤ 2 サブインターフェイス(レイヤ 2 転送)

入力および出力トラフィックの両方がサポートされています。 パーセントベースのポリシーと絶対レートベースのポリシーがサポートされています。 ただし、使いやすさのため、パーセントベースのポリシーを使用することを推奨します。

共有ポリシー インスタンス

トラフィック クラスとトラフィック ポリシーを作成した後、任意で共有ポリシー インスタンス(SPI)を使用して、QoS リソースを 1 つ割り当て、これをサブインターフェイス、複数のイーサネット フロー ポイント(EFP)、またはバンドル インターフェイスで共有することができます。

SPI を使用して、QoS ポリシーの 1 つのインスタンスを複数のサブインターフェイスで共有し、サブインターフェイスのシェーピングを 1 つのレートに集約できます。 QoS ポリシーのインスタンスを共有するサブインターフェイスは、すべて同じ物理インターフェイスに属する必要があります。 QoS ポリシーのインスタンスを共有するサブインターフェイスの数は、2 からポートのサブインターフェイスの最大数までです。

バンドル インターフェイスの場合、ハードウェア リソースはバンドル メンバごとに複製されます。 共通の共有ポリシー インスタンスを使用し、Link Aggregation Control Protocol(LAG)バンドルで設定されたサブインターフェイスは、すべて同じメンバ リンクにロード バランシングされる必要があります。

バンドル EFP にポリシーが設定されている場合、バンドルのメンバ リンクごとにポリシーのインスタンスが 1 つ設定されます。 同じバンドルの複数のバンドル EFP 間で SPI を使用する場合、バンドルのメンバ リンクごとにポリシーの共有インスタンスが 1 つ設定されます。 デフォルトでは、バンドルのロード バランシング アルゴリズムでは、ハッシュを使用して(バンドル EFP から送信される必要のある)トラフィックをバンドル メンバ間に分散させます。 1 つまたは複数の EFP のトラフィックを、複数のバンドル メンバ間に分散させることができます。 複数の EFP に、SPI を使用して一緒にシェーピングまたはポリシングを実行しなければならないトラフィックがある場合は、同じ共有ポリシーのインスタンスに属するすべての EFP へのトラフィックに対して、バンドル ロード バランシングで同じバンドル メンバを選択する(ハッシュ選択)ように設定する必要があります。 これによって、同じポリシーの共有インスタンスを持つすべての EFP に向かうトラフィックで、同じポリサー/シェーパー インスタンスが使用されます。

これは通常は同じ加入者が多数の EFP を持つ場合(たとえば、各サービス タイプに対して 1 つの EFP を持つなど)や、プロバイダーですべての加入者の EFP に対してシェーピングおよびキューイングを一緒に実装することが求められる場合に使用されます。

ポリシーの継承

ポリシー マップを物理ポートに適用すると、ポリシーは、その物理ポートのすべてのレイヤ 2 およびレイヤ 3 サブインターフェイスに適用されます。

ポート シェーピング ポリシー

ポート シェーピング ポリシーをメイン インターフェイスに適用するときには、個々の通常のサービス ポリシーをそのサブインターフェイスに適用できます。 ポート シェーピング ポリシー マップには、次の制限事項があります。

  • class-default が許可された唯一のクラス マップです。
  • シェイプ クラス アクションが許可された唯一のクラス アクションです。
  • これらは出力方向でだけ設定できます。
  • これらのスクリプトは、メイン インターフェイスにのみ適用します。サブインターフェイスには適用できません。
  • 2 レベルまたは 3 レベルのポリシーはサポートされていません。 1 レベルまたはフラットなポリシーだけがサポートされています。

上記の制限のいずれかに違反した場合、設定したポリシー マップはポート シェーピング ポリシーではなく、通常のポリシーとして適用されます。

クラスベース無条件パケット マーキングの機能と利点

クラスベースの無条件パケット マーキング機能は、ユーザが指定したマーキングに基づいてパケットを区別できる効率的なパケット マーキング機能です。

クラスベースの無条件パケット マーキングでは、次の作業を行うことができます。

  • IP precedence ビットまたは IP DiffServ コード ポイント(DSCP)を IP ToS バイトに設定してパケットをマーキング。
  • インポーズされたラベルまたは最上位ラベル内の EXP ビットを設定して、マルチプロトコル ラベル スイッチング(MPLS)パケットをマーキング。
  • レイヤ 2 サービス クラス(CoS)値を設定して、パケットをマーキング。
  • IEEE 802.1Q トンネリング(QinQ)設定に内部および外部 CoS タグを設定してパケットをマーキング。
  • qos-group 引数の値を設定してパケットをマーキング。
  • discard-class 引数の値を設定してパケットをマーキング。

    (注)  


    qos-group および discard-class はルータの内部変数であり、送信されません。


無条件パケット マーキングにより、次のようにネットワークを複数のプライオリティ レベルまたはサービス クラスに区切ることができます。

  • QoS 無条件パケット マーキングを使用して、ネットワークに入るパケットの IP precedence または DSCP 値を設定します。 ネットワーク内のルータは、新しくマーキングされた IP precedence 値を使用して、トラフィックの処理方法を決定できます。 たとえば、輻輳回避技術である重み付けランダム早期検出(WRED)を使用すると、パケットがドロップされる確率を判断できます。 さらに、低遅延キューイング(LLQ)を設定して、そのマークのすべてのパケットをプライオリティ キューに送るよう設定できます。
  • QoS 無条件パケット マーキングを使用して、パケットを QoS グループに割り当てます。 QoS グループ ID を MPLS パケットに設定するには、ポリシー マップ クラス コンフィギュレーション モードで set qos-group コマンドを使用します。

    (注)  


    QoS グループ ID を設定しても、パケットを送信する優先順位が自動的に決まるわけではありません。 最初に QoS グループを使用する出力ポリシーを設定する必要があります。


  • CoS 無条件パケット マーキングを使用して、IEEE 802.1p/ スイッチ間リンク(ISL)パケットのプライオリティ値を設定するパケットを割り当てます。 スイッチ間リンク(ISL)パケット。 ルータでは、CoS 値を使用して、パケットに転送のための優先順位を付ける方法を決定し、このマーキングを使用してレイヤ 2 からレイヤ 3 へのマッピングを行います。 送信パケットのレイヤ 2 CoS 値を設定するには、ポリシー マップ コンフィギュレーション モードで set cos コマンドを使用します。

設定作業については、46 ページの「クラスベース無条件パケット マーキングの設定」で説明されています。


(注)  


特に明記されていないかぎり、レイヤ 3 物理インターフェイスのクラス単位の無条件パケット マーキングがバンドル インターフェイスに適用されます。


IP precedence によるパケットの CoS の指定

IP precedence を使用すると、パケットの CoS を指定できます。 この目的には、IP Version 4(IPv4)ヘッダーの ToS フィールドの 3 つの precedence ビットを使用します。 図 1 に、ToS フィールドを示します。

図 1. IPv4 パケットのタイプ オブ サービス フィールド

ToS ビットを使用して、最大 8 つのサービス クラスを定義できます。 その後、ネットワーク全体で設定された他の機能によって、これらのビットを使用して、ToS の付与に関するパケットの処理方法を決定します。 これらの他の QoS 機能では、輻輳管理戦略や帯域幅の割り当てなど適切なトラフィック処理ポリシーを割り当てることができます。 たとえば、などのパケットの IP 優先順位設定を使用してトラフィックのプライオリティを設定できます。

着信トラフィックに precedence レベルを設定し、Cisco IOS XR QoS キューイング機能と一緒に使用することで、ディファレンシエーテッド サービスを作成できます。

後続の各ネットワーク要素が決定されたポリシーに基づいてサービスを提供できるように、できるだけ IP precedence は、通常ネットワークの端または管理ドメインの近くに配置します。 これによって、他のコアまたはバックボーンにおいて、優先順位に基づいて QoS を設定できます。

設定作業については、46 ページの「クラスベース無条件パケット マーキングの設定」の項で説明されています。

パケットの分類に使用する IP precedence ビット

IP ヘッダーの ToS フィールドにある 3 つの IP precedence ビットを使用して、各パケットの CoS 割り当てを指定します。 前述したように、最大 8 個のクラスにトラフィックを分類した後、ポリシー マップを作成して、各クラスの輻輳処理、帯域幅割り当てといったネットワーク ポリシーを定義できます。

歴史的な理由から、各優先度はある名前に対応します。 これらの名前は RFC 791 で定義されています。 表 5 に、重要度のより小さいものから大きいものへの順序で、番号とそれに対応する名前を表示します。

表 1 IP precedence 値

番号

名前

0

routine

1

priority

2

immediate

3

flash

4

flash-override

5

critical

6

internet

7

network


(注)  


IP precedence ビットの設定 6 と 7 は、ルーティング アップデートなどのネットワーク制御情報用に予約されています。


IP precedence 値の設定

デフォルトでは、Cisco IOS XR ソフトウェアは、IP precedence 値をそのまま残します。 これによって、ヘッダーの precedence 値セットが維持され、すべての内部ネットワーク デバイスが IP precedence の設定に基づいてサービスを提供できるようになります。 このポリシーは、ネットワークのエッジでネットワーク トラフィックをさまざまなタイプのサービスにソートすること、またこれらのサービス タイプをネットワーク コアで設定することを指定する標準的な方法に従っています。 その後、ネットワークのコアにあるルータは、precedence ビットを使用して、送信順やパケット ドロップの可能性などを決定できるようになります。

ネットワークに入ってくるトラフィックには外部デバイスで設定された precedence が設定されている可能性があるので、ネットワークに入るすべてのトラフィックの precedence をリセットすることを推奨します。 IP precedence の設定を制御することによって、すでに IP precedence を設定したユーザが、自身のすべてのパケットに高い優先度設定を設定して、自身のトラフィックに対してより高いサービスを得ることを禁止します。

クラスベースの無条件パケット マーキング、LLQ、および WRED 機能では、IP precedence ビットを使用できます。

DEI に基づく分類

802.1ad フレームと 802.1ah フレームに含まれる Drop Eligible Indicator(DEI)ビットに基づいて、トラフィックを分類できます。 デフォルトの DEI マーキングがサポートされています。 ポリシー マップの set dei アクションは、802.1ad パケットで次の項目に対してサポートされています。

  • 入力および出力
  • レイヤ 2 サブインターフェイス
  • レイヤ 2 メイン インターフェイス
  • レイヤ 3 メイン インターフェイス

    (注)  


    set dei アクションは、802.1ad カプセル化用に設定されていないインターフェイスのトラフィックに対しては無視されます。


デフォルト DEI マーキング

着信パケット

 

インポーズされた 802.1ad ヘッダーのデフォルト DEI

802.1q パケット

なし

0

802.1ad パケット

なし

着信パケットの最上位タグの DEI

802.1ad パケットに変換された 802.1q パケット

または

802.1ad パケット

set dei {0 | 1}

0 または 1

set アクションの DEI 値に基づく

IP precedence と IP DSCP マーキングの比較

ネットワークでパケットをマークする必要があり、すべてのデバイスで IP DSCP マーキングがサポートされている場合は、IP DSCP マーキングの方が無条件パケット マーキングのオプションが多いため、IP DSCP マーキングを使用してください。 IP DSCP によるマーキングが好ましくない場合、またはネットワークにあるデバイスで IP DSCP 値がサポートされているかどうか不明な場合は、パケットのマーキングに IP precedence 値を使用してください。 IP precedence 値は、おそらくネットワーク内のすべてのデバイスでサポートされています。

最大 8 種類の IP precedence マーキングと、64 種類の IP DSCP マーキングを設定できます。

ボーダー ゲートウェイ プロトコルを使用した QoS ポリシー伝搬

パケット分類は、データ パス上で輻輳管理または輻輳回避を必要とするトラフィック フローを識別し、マーキングします。 ボーダー ゲートウェイ プロトコルを使用した Quality of Service ポリシー伝搬(QPPB)では、アクセス リスト(ACL)、ボーダー ゲートウェイ プロトコル(BGP)コミュニティ リスト、BGP 自律システム(AS)パス、送信元プレフィックス アドレス、または宛先プレフィックス アドレスに基づいて、パケットを QoS グループ ID で分類できます。 パケットを分類しておくと、ポリシングや重み付けランダム早期検出(WRED)などの他の QoS 機能を使用して、ビジネス モデルに適合するようにポリシーを指定し、実行できます。

BGP を使用した QoS ポリシー伝搬(QPPB)では、トラフィック ポリシングの適用に使用できるシスコ エクスプレス フォワーディング(CEF)パラメータに BGP プレフィックスおよび BGP 属性をマッピングできます。 QPPB を使用すると、ネットワークのある場所で設定した BGP ポリシーを、BGP を使用してネットワークの別の場所に伝搬し、そこで適切な QoS ポリシーを作成できます。

QPPB では、次の各点に基づいてパケットを分類できます。

  • アクセス リスト
  • BGP コミュニティ リスト。 コミュニティ リストを使用すると、ルート ポリシーの match 句で使用するコミュニティ グループを作成できます。 アクセス リストと同様に、一連のコミュニティ リストを作成できます。
  • BGP 自律システム パス。 BGP 自律システム パスに基づいて、着信および発信の両方のルーティング アップデートに対してアクセス リストを指定することにより、これらのルーティング アップデートをフィルタリングできます。
  • 送信元プレフィックス アドレス。 BGP ネイバーのアドレスから送信されたプレフィックス セットを分類できます。
  • 宛先プレフィックス アドレス。 一連の BGP プレフィックスを分類できます。

分類は、トラフィックの送信元または宛先アドレスに基づいて実行できます。 BGP および CEF は、サポートされている QPPB 機能に対して有効にする必要があります。

衛星システム上の QoS

QoS 機能の一貫した展開を自動化する自動 QoS は、衛星システムで有効化されています。 すべてのユーザ設定のレイヤ 2 およびレイヤ 3 機能が ASR9000 で適用され、衛星システムに対する個別の QoS 設定は必要ありません。 自動 QoS は、ICL リンクのオーバーサブスクリプションを処理します。 通常のポート上のその他すべての QoS 機能(ブロードバンド QoS を含む)は、衛星ポートでもサポートされています。 ASR9000 シリーズ ルータと衛星ポート間のシステムの輻輳処理は、プライオリティと保護を維持するように設定されます。 自動 QoS は、ASR9000 シリーズ ルータと衛星間の衛星 ICL で流れるトラフィックの異なるクラス間に対する十分な区別を提供します。

システムは、1G ポート シェーパーに対して、最大 14 個の一意のシェーピング レートをサポートできます。 1G ポートは、トラフィック マネージャ(TM)階層の L0 エンティティを使用して表されます。 ポート シェーパーは、このレベルで適用されます。 衛星ポートで速度が変更された場合、QoS EA は、基本となる衛星ポートの速度に基づいてポリシーマップを自動的に再設定します。 ただし、ポリシーが存在ない場合、ポリシー マネージャ(PM)は、ポート シェーパー API(アプリケーション プログラミング インターフェイス)を呼び出すことによってポートの速度を設定する必要があります。 システムは、AN によって基本となるポートの速度が変更された場合に、パーセンテージベースのポリシーを変更します。 ASR9000 シリーズ ルータ上のポリシーに自動ネゴシエーションされた速度を伝播すると、時間差が発生する場合があります。この期間中は、衛星デバイスでパケット ドロップが発生することが想定されます。


(注)  


入力サービス ポリシーでのキューイングは、衛星インターフェイスではサポートされていません。


衛星システムの QoS の詳細については、 『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Configuration Guide』を参照してください。

自動 QoS

衛星システムから Cisco IOS XR ASR9000 シリーズ ルータへのトラフィック、および ASR9000 シリーズ ルータから衛星システムへのトラフィックについて説明します。

衛星から ASR9000 シリーズ ルータ

  • トラフィックは、信頼ポート モデルを使用して処理されます。
  • パケットが制御パケット(LACP、STP、CDP、CFM、ARP、OSPF など)、高プライオリティのデータ(VLAN COS 5、6、7、IP prec 5、6、7)、または通常のプライオリティのデータであり、それに応じてキューイングされるかどうかは、自動パケット分類ルールによって決定されます。
  • 衛星によって自動で優先順位付けされるプロトコル タイプ:すべての IEEE コントロール プロトコル(01 80 C2 xx xx xx)、LACP、802.3ah、CFM、STP、CDP、LLDP、ARP、OSPF、RIP、BGP、IGMP、RSVP、HSRP、VRRP p2 q。
  • 衛星によって自動で優先順位付けされるユーザ データ パケット:VLAN CoS 5、6、7、IP precedence 5、6、7、MPLS EXP 5、6、7。
図 2. 自動 QoS、衛星からホスト



ASR9000 シリーズ ルータから衛星

  • 衛星出力ポートに宛てられたトラフィックは、ダウンストリームのシェーピング アクセス ポートの速度を一致させるために ASR9K でシェーピングされます。
  • トラフィックは、フル 3 レベル出力キューイング階層に基づいてストリーミングされます。
  • リモートで管理されている各衛星アクセス GigE ポートは、アクセス回線速度を一致させるために自動シェーピングされます。
図 3. 自動 QoS、ホストから衛星



PWHE 上の QoS

疑似配線ヘッド エンド(PWHE)上の QoS は、サービス プロバイダーのエッジ ルータの拡張 L3VPN サービスをイネーブルにします。

PWHE-QoS の詳細については、 『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Configuration Guide』を参照してください。

サポートされる機能

PWHE での QoS の機能:

  • 入力 PWHE と出力 PWHE の両方のポリシー マップ。 ハードウェア制限内でのポリシング、マーキング、およびキューイングが入力と出力の両方でサポートされています。
  • 通過トラフィック用のポートのポリシーは、PWHE インターフェイス用のポリシーと同時に適用できます。
  • ポリシーは、すべての PWHE メンバでレプリケートされます。 これは、PWHE ポリシー マップで指定されたレートが、特定されたすべてのメンバの最低のレートに制限されることを意味します。 たとえば、PW-HE インターフェイスに 1G と 10G の両方で特定されたメンバが存在する場合、レートは 1G に制限されます。 10G メンバに 900 mbps のシェーパーがある場合、PWHE インターフェイス ポリシーのレートは、900 Mbps に制限されます。
  • メンバ インターフェイスのポート シェーピング ポリシーは、そのポートを通過する PWHE トラフィックに影響を与えます。

制限事項

  • PW-HE ポリシーの親レベルでのパーセンテージ ベースのシェーピングまたはポリシングはサポートされていません。
  • QoS アカウンティングには、疑似配線ヘッダーが含まれません。

帯域幅の分配

異なる PW HE 仮想インターフェイスの QoS ポリシー、および物理インターフェイスの QoS ポリシーに対応するキューイング リソースは、すべて TM 内の同一のポート下にあります。 スケジューリングの観点から、物理インターフェイス QoS ポリシーおよび PW HE インターフェイス QoS ポリシーで設定されたキューイング パラメータ(minimum bandwidth、maximum bandwidth/shape、weight/bandwidth remaining)は、互いに影響します。 物理インターフェイスの帯域幅は、すべての QoS ポリシーによって共有されます。

Bandwidth remaining コマンドを PW-HE ポリシーの親デフォルト クラスで使用して、さまざまな PW-HE インターフェイスと物理インターフェイス間の超過帯域幅の分配を制御できます。

QoS アカウンティング

  • QoS 機能(ポリシング、シェーピング、統計情報など)を実行する際のパケット長は、カスタマー IP パケット、カスタマー L2 ヘッダー、および設定された追加オーバーヘッドに基づきます。
  • QoS 統計情報には、カスタマー IP パケット、カスタマー L2 ヘッダー、および設定された追加オーバーヘッドが含まれます。
  • 外部 MPLS ヘッダー(VC ラベル、トランスポート ラベルなど)および外部 L2 ヘッダー(基本となる物理インターフェイスのレイヤ 2 カプセル化)は、PW HE 仮想インターフェイスで QoS を実行する際のパケット長には含まれません。

マーキング サポート

PW ether:入力と出力

  • カスタマー IP ヘッダー、qos-group、および discard-class のマーキングがサポートされます。
  • インポーズされたすべての MPLS ラベルの EXP ビットのマーキングがサポートされます。
  • インポーズされたラベルの EXP は、入力ポリシーにだけ設定できます。 ただし、出力 QoS ポリシーの処理後、より多くのラベルがカスタマー IP パケットにインポーズされるため、PW HE インターフェイスに付加された出力ポリシーでも設定できるように例外が適用されます。
  • 転送 L2 ヘッダーの CoS ビットのマーキングはサポートされず、デフォルトの動作になります。
  • 入力方向の無条件マーキングの場合は、DSCP/precedence、インポーズされたラベルの EXP、qos-group、および discard-class の各フィールドをマーキングできます。
  • 出力方向の無条件マーキングの場合は、DSCP/precedence およびインポーズされたラベルの EXP の各フィールドをマーキングできます。
  • 入力方向の条件付きポリサー マーキングの場合は、DSCP/precedence、インポーズされたラベルの EXP、qos-group、および discard-class の各フィールドのうち、最大で 2 つのフィールドをマーキングできます。
  • 出力方向の条件付きポリサー マーキングの場合は、DSCP/precedence およびインポーズされたラベルの EXP の各フィールドをマーキングできます。

ポリシングおよびキューイングのサポート

通常の L3 インターフェイスでサポートされているすべてのポリシング機能は、PW-HE でもサポートされます。

キューイング

  入力および出力キュー 入力および出力ポリサー
ポリシー マップのない PW-HE インターフェイス

各 PW-HE メンバには、ポートごとにデフォルト キューがあります。 入力および出力の両方のトラフィックは、メンバ ポートのデフォルト キューを使用します。

N/A
ポリシー マップ付きの PW-HE インターフェイス

ポリシー マップの入力および出力キューは、各 PW-HE メンバで複製されます。

ポリシー マップの入力および出力ポリサーは、各 PW-HE メンバごとに複製されます。


(注)  


PW-HE メンバがバンドルの場合、ポリシー マップはバンドル メンバで複製されます。

統計

PW HE 仮想インターフェイス QoS ポリシーの show コマンドは、入力/出力の統計情報を次の条件で提供します。

  • 特定されたメンバごと。
  • 特定されたメンバがバンドルの場合、統計情報はバンドルごとに集約されます。
  • pwhe インターフェイス全体で集約された統計情報。

ポリシーのインスタンス化

ここでは、PW-HE の QoS のさまざまなシナリオについて説明します。

  • 任意のメンバ インターフェイスに適用されるポリシーがある場合は、非 PW-HE トラフィックだけがこれらのポリシーの対象になります。 これに対する例外は、設定されたポート シェーパーです。
  • PW-HE ポリシーが PW-HE 仮想インターフェイスに追加されると、すべての PW-HE トラフィックがそのポリシーの対象になります。 ただし、メンバ インターフェイスの非 PW-HE トラフィックは、対応するメンバ インターフェイスで設定されているポリシーの対象になります。
  • PW-HE ポリシーは、2 レベル階層である必要があります。 仮想インターフェイスに適用される親ポリシーには、絶対レートに基づいて設定されたシェーピング/ポリシング付きの class-default が必要です。
  • メンバ インターフェイスが異なるラインカードから割り当てられている場合、VC ラベル ベースのハッシュを使用して出力インターフェイス(PW-HE トラフィックにアクセスするコア)を判断する場合にだけ精度を保証できます。 VC ラベル ベースのハッシュは、PW-HE に対応するトラフィックを特定のメンバ インターフェイスに対して偏向します。 これにより、絶対値が設定される際に正確な QoS シェーピングを保証します。
  • 複数の PW-HE インターフェイス(LC ごとに最大 1792)は、単一のメンバ インターフェイス(物理インターフェイスまたはバンドル インターフェイス)を共有できます。 それぞれの PW-HE インターフェイス QoS ポリシがメンバ インターフェイス上でインスタンス化されます。
  • PW-HE メンバ インターフェイスがバンドルの場合、PW-HE ポリシーは、各バンドル メンバでインスタンス化されます。

(注)  


PWHE インターフェイスが作成された場合で、PWHE QoS ポリシーが適用されない場合、PW-HE と非 PW-HE の両方のトラフィックがメンバ インターフェイスのデフォルト キューを介して渡されます。

 


QoS ポリシーのない PW-HE

次の 2 つのケースは、疑似配線ヘッドエンド インターフェイスのデフォルト動作を表します。

  • PW-HE 入力からコア側出力(アクセスからコア):カスタマー IP パケットからの DSCP/precedence 値は、コア側方向のすべてのインポーズされたラベル(VPN および転送)の EXP にコピーされます。
  • PW-HE 出力(コアからアクセス):カスタマー IP パケットからの DSCP/precedence 値は、アクセス側方向のすべてのインポーズされたラベル(VPN および転送)の EXP にコピーされます。

例:PW-HE

policy-map pw_child_in
 class voip
  priority level 1
  police rate 1 percent 1

class video 
police rate percent 10

	priority level 2

class data 
  police rate percent 70 peak-rate-percent
  100
  exceed-action transmit
  violate action drop
end-policy-map
!
policy-map pw_child_out
 class voip
 priority level 1 
 police rate 1 mbps
 !
!
class data 
 bandwidth remaining percent 70
 random-detect discard-class 3 40 ms 50 ms 
!
class video
 priority level2
 police rate 10 mbps
!
1
class class-default
 random-detect discard-class 1 20 ms 30 ms
!
end policy-map

policy-map pw_child_out
 class voip
  priority level 1
  police rate 1 mbps
  !
 !
 class data
  bandwidth remaining percent 70
  random-detect discard-class 3 40 ms 50 ms
 !
 class video
  priority level 2
  police rate 10 mbps
  !
 !
 class class-default
  random-detect discard-class 1 20 ms 30 ms
 !
 end-policy-map
!
policy-map pw_parent_out
 class class-default
  service-policy pw_child_out
  shape average 100 mbps
 !
 end-policy-map
!

interface pw-ether 1
 service-policy input pw_parent_in
 service-policy output pw_parent_out 

その他の PW-HE の関連情報については、 『Cisco ASR 9000 Series Aggregation Services Router L2VPN and Ethernet Services Configuration Guide』を参照してください。

In-Place ポリシーの変更

In-Place ポリシーの変更機能では、QoS ポリシーが 1 つ以上のインターフェイスに付加されている場合でも QoS ポリシーを変更できます。 1 つ以上のインターフェイスに付加されている QoS ポリシーを変更すると、その QoS ポリシーが付加されているすべてのインターフェイスで QoS ポリシーが自動的に変更されます。 変更されたポリシーは、新しいポリシーをインターフェイスにバインドするときと同じチェックを受けます。

ポリシー変更が成功した場合、変更されたポリシーは、ポリシーが付加されているすべてのインターフェイスに対して有効になります。 コンフィギュレーション セッションはポリシーの変更が完了するまでブロックされます。

ただし、ポリシーの変更がいずれかのインターフェイスで失敗した場合には、すべてのインターフェイスに対して変更前のポリシーが有効になるように、自動ロール バックが開始されます。 コンフィギュレーション セッションは、影響を受けるすべてのインターフェイスでロール バックが完了するまでブロックされます。

In-Place ポリシーの変更時に回復不可能なエラーが発生した場合は、ポリシーは対象のインターフェイスに対して矛盾した状態になります。 各場所における矛盾を表示するには、show qos inconsistency コマンドを使用してください。 (このコマンドは、ASR 9000 イーサネット ラインカードでのみサポートされています)。 コンフィギュレーション セッションは、変更されたポリシーが、ポリシーを使用するすべてのインターフェイスで有効になるまでブロックされます。 コンフィギュレーション セッションのブロックが解除されるまで、新たな設定を行うことはできません。

インターフェイスに付加されている QoS ポリシーを変更したとき、変更されたポリシーを使用するインターフェイスでは、短期間、有効なポリシーがない場合が生じる可能性があります。


(注)  


インターフェイスに付加されているポリシーの QoS 統計情報は、ポリシーを変更すると失われます(0 にリセット)。


In-Place ポリシーの変更を引き起こす可能性のある変更

QoS ポリシーの変更

  • 帯域幅またはポリシングなどの新しいアクションの追加
  • 新しいサービス ポリシーの追加(階層レベルを上げる)
  • 既存のアクションの削除
  • 既存のアクションの変更
  • サービス ポリシーの削除(階層レベルを下げる)
  • 新しいアクションを伴う新しいクラスの追加
  • ポリシーへの複数のクラスの追加または削除
  • 子ポリシーの変更

クラス マップの変更

  • 新しい match 文の追加
  • 既存の match 文の削除
  • 照合タイプの変更(match-all から match-any、またはその逆)
  • 既存の match 文の変更

クラス マップで使用するアクセス リストの変更

  • 新しいアクセス コントロール エントリ(ACE)の追加
  • ACE の削除
  • ACE の修正

In-Place ポリシー変更に関する推奨事項

QoS ポリシーを変更している間の短期間、変更するポリシーを使用するインターフェイスでは、有効なポリシーがない状態が生じることがあります。 このため、同時に最小限のインターフェイスに影響する QoS ポリシーを変更します。 ポリシー マップの変更時に影響するインターフェイスの数を確認するには、show policy-map targets コマンドを使用します。

インターフェイス帯域幅の動的な変更

ここでは、インターフェイス帯域幅機能の動的な変更について説明します。

ポリシー状態

  • 検証:この状態は、新しいインターフェイス帯域幅値について、設定された QoS ポリシーの非互換性を示します。 システムは、ベストエフォート方式でトラフィックを処理します。また、トラフィック ドロップが発生する場合があります。

モジュラ QoS のパケット分類の設定方法

ここでは、次のタスクの手順を示します。

トラフィック クラスの作成

一致基準が含まれるトラフィック クラスを作成するには、class-map コマンドを使用してトラフィック クラス名を指定し、必要に応じて、次の match コマンドをクラスマップ コンフィギュレーション モードで使用します。

概念の情報については、16 ページの「トラフィック クラスの要素」の項を参照してください。

制約事項

この設定作業で指定するすべての match コマンドの使用は任意ですが、1 つのクラスに少なくとも 1 つの一致基準を設定する必要があります。

手順の概要

    1.    configure

    2.    class-map [type qos] [match-any] [match-all] class-map-name

    3.    match access-group [ipv4 | ipv6] access-group-name

    4.    match [not] cos [cos-value] [cos-value0 ... cos-value7]

    5.    match [not] cos inner [inner-cos-value] [inner-cos-value0...inner-cos-value7]

    6.    match destination-address mac destination-mac-address

    7.    match source-address mac source-mac-address

    8.    match [not] discard-class discard-class-value [discard-class-value1 ... discard-class-value6]

    9.    match [not] dscp [ipv4 | ipv6] dscp-value [dscp-value ... dscp-value]

    10.    match [not] mpls experimental topmost exp-value [exp-value1 ... exp-value7]

    11.    match [not] precedence [ipv4 | ipv6] precedence-value [precedence-value1 ... precedence-value6]

    12.    match [not] protocol protocol-value [protocol-value1 ... protocol-value7]

    13.    match [not] qos-group [qos-group-value1 ... qos-group-value8]

    14.    match vlan [inner] vlanid [vlanid1 ... vlanid7]

    15.    次のいずれかのコマンドを使用します。

    • end
    • commit


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 configure


    例:
    RP/0/RSP0/CPU0:router# configure
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2class-map [type qos] [match-any] [match-all] class-map-name

    例:
    
    RP/0/RSP0/CPU0:router(config)# class-map class201
    
     

    クラス マップ コンフィギュレーション モードを開始します。

    • 名前を指定したクラスとパケットとの照合に使用されるクラス マップを作成します。
    • match-any を指定すると、トラフィック クラスで受信したトラフィックの場合、一致基準の 1 つに必ず一致し、そのトラフィック クラスの一部と分類されます。 これがデフォルトです。 match-all を指定した場合は、トラフィックがすべての一致基準を満たす必要があります。
     
    ステップ 3match access-group [ipv4 | ipv6] access-group-name


    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match access-group ipv4 map1
    
     

    (任意)指定したアクセス コントロール リスト(ACL)名に基づいて、クラス マップの一致基準を設定します。

     
    ステップ 4match [not] cos [cos-value] [cos-value0 ... cos-value7]


    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match cos 5
    
     

    (任意)クラス マップにパケットに一致する cos-value を指定します。

    • cos-value 引数は、0 ~ 7 の整数で指定します。
     
    ステップ 5match [not] cos inner [inner-cos-value] [inner-cos-value0...inner-cos-value7]

    例:
    
    RP/0/RSP0/CPU0:router match cos inner 7
    
     

    (任意)クラス マップにパケットに一致する inner-cos-value を指定します。

    • inner-cos-value 引数は、0 ~ 7 の整数で指定します。
     
    ステップ 6match destination-address mac destination-mac-address


    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match destination-address mac 00.00.00
    
     

    (任意)指定する宛先 MAC アドレスに基づくクラス マップの一致基準を設定します。

     
    ステップ 7match source-address mac source-mac-address


    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match source-address mac 00.00.00
    
     

    (任意)指定する送信元 MAC アドレスに基づくクラス マップの一致基準を設定します。

     
    ステップ 8match [not] discard-class discard-class-value [discard-class-value1 ... discard-class-value6]

    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match discard-class 5
    
     

    (任意)クラス マップにパケットに一致する discard-class-value を指定します。

    • discard-class-value 引数は、0 ~ 7 の整数で指定します。

    match discard-class コマンドは、出力ポリシーに対してのみサポートされています。

     
    ステップ 9match [not] dscp [ipv4 | ipv6] dscp-value [dscp-value ... dscp-value]

    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match dscp ipv4 15
    
     

    (任意)一致基準として特定の DSCP 値を指定します。

    • 値の範囲は 0 ~ 63 です。
    • 数値の代わりに、予約済みキーワードも指定できます。
    • match 文ごとに最大 8 つの値または範囲を使用できます。
     
    ステップ 10match [not] mpls experimental topmost exp-value [exp-value1 ... exp-value7]


    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match mpls experimental topmost 3
    
     

    (任意)クラス マップを設定し、最上位のマルチプロトコル ラベル スイッチング(MPLS)ラベルの 3 ビット experimental(EXP)フィールドが、EXP フィールド値に対して検査されるようにします。

    値の範囲は 0 ~ 7 です。

     
    ステップ 11match [not] precedence [ipv4 | ipv6] precedence-value [precedence-value1 ... precedence-value6]


    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match precedence ipv4 5
    
     

    (任意)IP precedence 値を一致基準として確認します。

    • 値の範囲は 0 ~ 7 です。
    • 数値の代わりに、予約済みキーワードも指定できます。
     
    ステップ 12match [not] protocol protocol-value [protocol-value1 ... protocol-value7]

    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match protocol igmp
    
     

    (任意)指定されたプロトコルに基づいて、クラス マップの一致基準を設定します。

     
    ステップ 13match [not] qos-group [qos-group-value1 ... qos-group-value8]

    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match qos-group 1 2 3 4 5 6 7 8
    
     

    (任意)クラス マップにパケットに一致するサービス(QoS)グループ値を指定します。

    • qos-group-value ID 引数の値は、0 ~ 63 の範囲の正確な値または値の範囲として指定します。
    • 1 つの match 文に対して最大 8 つの値(スペースで区切る)を入力できます。
    • match qos-group コマンドは、出力ポリシーに対してのみサポートされています。
     
    ステップ 14match vlan [inner] vlanid [vlanid1 ... vlanid7]

    例:
    
    RP/0/RSP0/CPU0:router(config-cmap)# match vlan vlanid vlanid1
    
     

    (任意)クラス マップにパケットに一致する VLAN ID または VLAN ID の範囲を指定します。

    • vlanid は、1 ~ 4094 の範囲の正確な値または値の範囲として指定します。
    • サポートされている VLAN の値または範囲の総数は 8 つです。
     
    ステップ 15次のいずれかのコマンドを使用します。
    • end
    • commit


    例:
    RP/0/RSP0/CPU0:router(config)# end

    または

    RP/0/RSP0/CPU0:router(config)# commit
     

    設定変更を保存します。

    • end コマンドを実行すると、変更をコミットするように要求されます。
      Uncommitted changes found, commit them
      before exiting(yes/no/cancel)? [cancel]:
      
      • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
      • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
      • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
    • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
     

    トラフィック ポリシーの作成

    トラフィック ポリシーを作成するには、policy-map グローバル コンフィギュレーション コマンドを使用して、トラフィック ポリシーの名前を指定します。

    トラフィック クラスは、class コマンドを使用したときにサービス ポリシーと関連付けられます。 class コマンドは、ポリシー マップ コンフィギュレーション モードを開始した後に実行しなければなりません。 class コマンドを入力すると、ルータは自動的にポリシー マップ クラス コンフィギュレーション モードを開始します。ここでトラフィック ポリシーの QoS ポリシーを定義します。

    次のクラス アクションがサポートされています。

    • bandwidth:クラスの帯域幅を設定します。 このガイドの Cisco ASR 9000 シリーズ ルータでのモジュラ QoS の輻輳管理の設定に関するモジュールを参照してください。
    • police:トラフィックをポリシングします。 このガイドの Cisco ASR 9000 シリーズ ルータでのモジュラ QoS の輻輳管理の設定に関するモジュールを参照してください。
    • priority:クラスにプライオリティを割り当てます。 このガイドの Cisco ASR 9000 シリーズ ルータでのモジュラ QoS の輻輳管理の設定に関するモジュールを参照してください。
    • queue-limit:クラスにキュー制限(テール ドロップしきい値)を設定します。 このガイドの「Configuring Modular QoS Congestion Avoidance on Cisco ASR 9000 Series Routers」を参照してください。
    • random-detect:ランダム早期検出をイネーブルにします。 このガイドの「Configuring Modular QoS Congestion Avoidance on Cisco ASR 9000 Series Routers」を参照してください。
    • service-policy:子サービス ポリシーを設定します。
    • set:このクラスのマーキングを設定します。 20 ページの「クラスベース無条件パケット マーキングの機能と利点」の項を参照してください。
    • shape:クラスのシェーピングを設定します。 このガイドの Cisco ASR 9000 シリーズ ルータでのモジュラ QoS の輻輳管理の設定に関するモジュールを参照してください。

    一致基準として入力できるその他のコマンドについては、『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference』を参照してください。

    概念の情報については、17 ページの「トラフィック ポリシーの要素」の項を参照してください。

    手順の概要

      1.    configure

      2.    policy-map [type qos] policy-name

      3.    class class-name

      4.    set precedence

      5.    end または commit


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1configure


      例:
      
      RP/0/RSP0/CPU0:router# configure
      
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2policy-map [type qos] policy-name


      例:

      RP/0/RSP0/CPU0:router(config)# policy-map policy1

       

      ポリシー マップ コンフィギュレーション モードを開始します。

      • 1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または修正し、サービス ポリシーを指定します。
       
      ステップ 3class class-name

      例:
      
      RP/0/RSP0/CPU0:router(config-pmap)# class class1
      
       

      ポリシーを作成または変更するクラスの名前を指定します。

       
      ステップ 4set precedence


      例:
      
      RP/0/RSP0/CPU0:router(config-pmap-c)# set precedence 3
      
       

      IP ヘッダーに優先順位を設定します。

       
      ステップ 5end または commit

      例:
      
      RP/0/RSP0/CPU0:router(config-pmap-c)# end
      

      または

      
      RP/0/RSP0/CPU0:router(config-pmap-c)# commit
      
       

      設定変更を保存します。

      • end コマンドを実行すると、変更をコミットするように要求されます。 Uncommitted changes found, commit them before exiting(yes/no/cancel)? [cancel]: yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。 no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。 cancel と入力すると、ルータは現在のコンフィギュレーション セッションで継続されます。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
      • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
       

      トラフィック ポリシーのインターフェイスへの適用

      トラフィック クラスとトラフィック ポリシーの作成後、service-policy インターフェイス コンフィギュレーション コマンドを使用して、トラフィック ポリシーをインターフェイスに付加し、ポリシーを適用する方向を指定します(インターフェイスに着信するパケットまたはインターフェイスから送信されるパケット)。

      ポリシー マップ クラス コンフィギュレーション モードで入力できるその他のコマンドについては、『Cisco ASR 9000 Series Aggregation Services RoutersModular Quality of Service Command Reference.』を参照してください。

      前提条件

      インターフェイスにトラフィック ポリシーを付加する前に、トラフィック クラスとトラフィック ポリシーを作成する必要があります。

      制約事項

      なし

      手順の概要

        1.    configure

        2.    interface type interface-path-id

        3.    service-policy {input | output} policy-map

        4.    次のいずれかのコマンドを使用します。

        • end
        • commit

        5.    show policy-map interface type interface-path-id [input | output]


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 configure


        例:
        RP/0/RSP0/CPU0:router# configure
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2interface type interface-path-id


        例:
        
        RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/9
        
         

        インターフェイス コンフィギュレーション モードを開始し、インターフェイスを設定します。

         
        ステップ 3service-policy {input | output} policy-map


        例:
        
        RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1
        
         

        インターフェイスのサービス ポリシーとして使用する入力インターフェイスまたは出力インターフェイスにポリシー マップを付加します。

        • この例では、トラフィック ポリシーでそのインターフェイスから送信されるすべてのトラフィックを評価します。
         
        ステップ 4次のいずれかのコマンドを使用します。
        • end
        • commit


        例:
        RP/0/RSP0/CPU0:router(config)# end

        または

        RP/0/RSP0/CPU0:router(config)# commit
         

        設定変更を保存します。

        • end コマンドを実行すると、変更をコミットするように要求されます。
          Uncommitted changes found, commit them
          before exiting(yes/no/cancel)? [cancel]:
          
          • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
          • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
          • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
        • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
         
        ステップ 5show policy-map interface type interface-path-id [input | output]


        例:
        
        RP/0/RSP0/CPU0:router# show policy-map interface gigabitethernet 0/1/0/9
        
         

        (任意)指定されたインターフェイスのポリシーの統計情報を表示します。

         

        複数のサブインターフェイスへの共有ポリシー インスタンスの付加

        トラフィック クラスとトラフィック ポリシーの作成後、任意で service-policy(インターフェイス)コンフィギュレーション コマンドを使用して、共有ポリシー インスタンスを複数のサブインターフェイスに付加し、ポリシーを適用する方向を指定します(サブインターフェイスに着信するパケットまたはサブインターフェイスから送信されるパケット)。


        (注)  


        共有ポリシーには、レイヤ 2 とレイヤ 3 のサブ インターフェイスの組み合わせを含めることができます。


        ポリシー マップ クラス コンフィギュレーション モードで入力できるその他のコマンドについては、『Cisco ASR 9000 Series Aggregation Services Routers Modular Quality of Service Command Reference』を参照してください。

        前提条件

        共有ポリシーのインスタンスをサブインターフェイスに付加する前に、トラフィック クラスとトラフィック ポリシーを作成する必要があります。

        制約事項

        複数の物理インターフェイスにまたがる共有ポリシー インスタンスはサポートされていません。

        手順の概要

          1.    configure

          2.    interface type interface-path-id

          3.    service-policy {input | output} policy-map [shared-policy-instance instance-name]

          4.    次のいずれかのコマンドを使用します。

          • end
          • commit

          5.    show policy-map shared-policy-instance instance-name [input | output] location rack/slot/module


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 configure


          例:
          RP/0/RSP0/CPU0:router# configure
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2interface type interface-path-id


          例:
          
          RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/0.1
          
           

          インターフェイス コンフィギュレーション モードを開始し、サブインターフェイスを設定します。

           
          ステップ 3service-policy {input | output} policy-map [shared-policy-instance instance-name]

          例:
          
          RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1 shared-policy-instance Customer1
          
           

          サブインターフェイスのサービス ポリシーとして使用する入力サブインターフェイスまたは出力サブインターフェイスにポリシー マップを付加します。

          • この例では、トラフィック ポリシーでそのインターフェイスから送信されるすべてのトラフィックを評価します。
           
          ステップ 4次のいずれかのコマンドを使用します。
          • end
          • commit


          例:
          RP/0/RSP0/CPU0:router(config)# end

          または

          RP/0/RSP0/CPU0:router(config)# commit
           

          設定変更を保存します。

          • end コマンドを実行すると、変更をコミットするように要求されます。
            Uncommitted changes found, commit them
            before exiting(yes/no/cancel)? [cancel]:
            
            • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
            • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
            • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
          • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
           
          ステップ 5show policy-map shared-policy-instance instance-name [input | output] location rack/slot/module


          例:
          
          RP/0/RSP0/CPU0:router# show policy-map shared-policy-instance Customer1 location 0/1/0/7.1
          
           

          (任意)指定した共有ポリシー インスタンスのサブインターフェイスに対するポリシーの統計情報を表示します。

           

          バンドル インターフェイスまたは EFP バンドルへの共有ポリシー インスタンスの付加

          トラフィック クラスとトラフィック ポリシーの作成後、任意で service-policy(インターフェイス)コンフィギュレーション コマンドを使用して、共有ポリシー インスタンスをバンドル インターフェイスやバンドル EFP に付加し、ポリシーを適用する方向を指定します(サブインターフェイスに着信するパケットまたはサブインターフェイスから送信されるパケット)。

          ポリシー マップ クラス コンフィギュレーション モードで入力できるその他のコマンドについては、『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference』を参照してください。

          前提条件

          共有ポリシー インスタンスをバンドル インターフェイスまたは EFP バンドルに付加する前に、トラフィック クラスとトラフィック ポリシーを作成する必要があります。

          制約事項

          複数の物理インターフェイスにまたがる共有ポリシー インスタンスはサポートされていません。

          手順の概要

            1.    configure

            2.    interface Bundle-Ether bundle-id

            3.    service-policy {input | output} policy-map [shared-policy-instance instance-name]

            4.    次のいずれかのコマンドを使用します。

            • end
            • commit

            5.    show policy-map shared-policy-instance instance-name [input | output] location location-id


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 configure


            例:
            RP/0/RSP0/CPU0:router# configure
             

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 2interface Bundle-Ether bundle-id


            例:
            
            RP/0/RP1/CPU0:router(config)# interface Bundle-Ether 100.1 l2transport
            
             

            インターフェイス コンフィギュレーション モードを開始し、バンドル インターフェイスを設定します。

             
            ステップ 3service-policy {input | output} policy-map [shared-policy-instance instance-name]

            例:
            
            RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1 shared-policy-instance Customer1
            
             

            サブインターフェイスのサービス ポリシーとして使用する入力または出力バンドル インターフェイスにポリシー マップを付加します。

            • この例では、トラフィック ポリシーでそのインターフェイスから送信されるすべてのトラフィックを評価します。
             
            ステップ 4次のいずれかのコマンドを使用します。
            • end
            • commit


            例:
            RP/0/RSP0/CPU0:router(config)# end

            または

            RP/0/RSP0/CPU0:router(config)# commit
             

            設定変更を保存します。

            • end コマンドを実行すると、変更をコミットするように要求されます。
              Uncommitted changes found, commit them
              before exiting(yes/no/cancel)? [cancel]:
              
              • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
              • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
              • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
            • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
             
            ステップ 5show policy-map shared-policy-instance instance-name [input | output] location location-id


            例:
            
            RP/0/RSP0/CPU0:router# show policy-map shared-policy-instance Customer1 location 0/rsp0/cpu0
            
             

            (任意)指定した共有ポリシー インスタンスの場所でのポリシーの統計情報を表示します。

             

            クラスベース無条件パケット マーキングの設定

            この設定作業では、以下のクラスベースの無条件パケット マーキング機能をルータに設定する方法を説明します。

            • IP precedence 値
            • IP DSCP 値
            • QoS グループ値(入力のみ)
            • CoS 値(レイヤ 3 サブ インターフェイスの出力のみ
            • MPLS EXP 値
            • 廃棄クラス

            (注)  


            MPLS タグ付きパケットに適用される IPv4 および IPv6 QoS アクションはサポートされていません。 設定は受け入れられますが、アクションは実行されません。



            (注)  


            クラスごとに set コマンドを 2 つだけ選択します。


            手順の概要

              1.    configure

              2.    policy-map policy-name

              3.    class class-name

              4.    set precedence

              5.    set dscp

              6.    set qos-group qos-group-value

              7.    set cos cos-value

              8.    set cos [inner] cos-value

              9.    set mpls experimental {imposition | topmost} exp-value

              10.    set srp-priority priority-value

              11.    set discard-class discard-class-value

              12.    set atm-clp

              13.    exit

              14.    exit

              15.    interface type interface-path-id

              16.    service-policy {input | output]} policy-map

              17.    次のいずれかのコマンドを使用します。

              • end
              • commit

              18.    show policy-map interface type interface-path-id [input | output]


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 configure


              例:
              RP/0/RSP0/CPU0:router# configure
               

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2policy-map policy-name


              例:
              
              RP/0/RSP0/CPU0:router(config)# policy-map policy1
              
               

              ポリシー マップ コンフィギュレーション モードを開始します。

              • 1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または修正し、サービス ポリシーを指定します。
               
              ステップ 3class class-name


              例:
              
              RP/0/RSP0/CPU0:router(config-pmap)# class class1
              
               

              ポリシー クラス マップ コンフィギュレーション モードを開始します。

              • ポリシーを作成または変更するクラスの名前を指定します。 クラスごとに 1 つの set コマンドを選択します
               
              ステップ 4set precedence


              例:
              
              RP/0/RSP0/CPU0:router(config-pmap-c)# set precedence 1
              
               

              IP ヘッダーに優先順位を設定します。

              • tunnel キーワードは、外側 IP ヘッダーで IP precedence を設定します。 このオプションは、IPSec がインストールおよび設定されている Cisco XR 12000 シリーズ ルータだけで使用できます。
               
              ステップ 5set dscp


              例:
              
              RP/0/RSP0/CPU0:router(config-pmap-c)# set dscp 5
              
               

              ToS バイトに DSCP を設定することにより、パケットにマーキングします。

              • tunnel キーワードは、外側 IP ヘッダーで IP DSCP を設定します。 このオプションは、IPSec がインストールおよび設定されている Cisco XR 12000 シリーズ ルータだけで使用できます。
               
              ステップ 6set qos-group qos-group-value


              例:
              
              RP/0/RSP0/CPU0:router(config-pmap-c)# set qos-group 31
              
               

              IPv4 パケットまたは MPLS パケットに QoS グループ ID を設定します。

              set qos-group コマンドは入力ポリシーでのみサポートされています。

               
              ステップ 7set cos cos-value


              例:
              
              RP/0/RP0/CPU0:router(config-pmap-c)# set cos 7
              
               

              発信パケットの固有の IEEE 802.1Q レイヤ 2 CoS 値を設定します。 値は 0 ~ 7 です。

              発信パケットのレイヤ 2 CoS 値を設定します。

              • このコマンドは、スイッチに送信中のパケットにマーキングをする場合に、ルータで使用する必要があります。 スイッチは、CoS 値のマーキングを含む レイヤ 2 ヘッダー情報を利用できます。
              • インターフェイスが受信するパケットは、CoS 値で設定できません。
               
              ステップ 8set cos [inner] cos-value

              例:
              
              RP/0/RSP0/CPU0:router(config-pmap-c)# set cos 7
              
               

              発信パケットの固有の IEEE 802.1Q レイヤ 2 CoS 値を設定します。 値は 0 ~ 7 です。

              発信パケットのレイヤ 2 CoS 値を設定します。

              • このコマンドは、スイッチに送信中のパケットにマーキングをする場合に、ルータで使用する必要があります。 スイッチは、CoS 値のマーキングを含む レイヤ 2 ヘッダー情報を利用できます。
              • レイヤ 2 インターフェイスでは、set cos コマンドは次のように処理されます。 メイン インターフェイスの入力または出力ポリシーでは拒否されます。 サブインターフェイスの入力ポリシーでは受け入れられますが、無視されます。 サブインターフェイスの出力ポリシーではサポートされています。
              • レイヤ 3 インターフェイスでは、set cos コマンドは次のように処理されます。 メイン インターフェイスの入力ポリシーでは無視されます。 サブインターフェイスの入力ポリシーで拒否されます。 メイン インターフェイスとサブインターフェイスの出力ポリシーではサポートされています。
               
              ステップ 9set mpls experimental {imposition | topmost} exp-value


              例:
              
              RP/0/RSP0/CPU0:router(config-pmap-c)# set mpls experimental imposition 3
              
               

              MPLS パケットの最上位ラベルまたはインポジション ラベルの EXP 値を設定します。

              • imposition は、入力ポリシーに付加されるサービス ポリシーに対してのみ使用できます。
               
              ステップ 10set srp-priority priority-value


              例:
              
              RP/0//CPU0:router(config-pmap-c)# set srp-priority 3
              
               

              発信パケットのスペース再利用プロトコル(SRP)のプライオリティ値を設定します。

              • このコマンドは、インターフェイスの出力方向に対応付けられたサービス ポリシーでのみ使用できます。
               
              ステップ 11set discard-class discard-class-value


              例:
              
              RP/0//CPU0:router(config-pmap-c)# set discard-class 3
              
               

              IP Version 4(IPv4)またはマルチプロトコル ラベル スイッチング(MPLS)パケットの廃棄クラスを設定します。

              • このコマンドは、入力ポリシーに付加されるサービス ポリシーに対してのみ使用できます。
               
              ステップ 12set atm-clp


              例:
              
              RP/0/0/CPU0:router(config-pmap-c)# set atm-clp
              
               

              セル損失率優先度(CLP)ビットを設定します。

               
              ステップ 13exit


              例:

              RP/0/RSP0/CPU0:router(config-pmap-c)# exit

               

              ルータをポリシー マップ コンフィギュレーション モードに戻します。

               
              ステップ 14exit


              例:
              
              RP/0/RSP0/CPU0:router(config-pmap)# exit
              
               

              ルータをグローバル コンフィギュレーション モードに戻します。

               
              ステップ 15interface type interface-path-id

              例:
              
              RP/0/RSP0/CPU0:router(config)# interface pos 0/2/0/0
              
               

              インターフェイス コンフィギュレーション モードを開始し、インターフェイスを設定します。

               
              ステップ 16service-policy {input | output]} policy-map


              例:
              
              RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1
              
               

              インターフェイスのサービス ポリシーとして使用する入力インターフェイスまたは出力インターフェイスにポリシー マップを付加します。

              • この例では、トラフィック ポリシーでそのインターフェイスから送信されるすべてのトラフィックを評価します。
               
              ステップ 17次のいずれかのコマンドを使用します。
              • end
              • commit


              例:
              RP/0/RSP0/CPU0:router(config-if)# end

              または

              RP/0/RSP0/CPU0:router(config-if)# commit
               

              設定変更を保存します。

              • end コマンドを実行すると、変更をコミットするように要求されます。
                Uncommitted changes found, commit them
                before exiting(yes/no/cancel)? [cancel]:
                
                • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
              • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
               
              ステップ 18show policy-map interface type interface-path-id [input | output]

              例:
              
              RP/0/RSP0/CPU0:router# show policy-map interface pos 0/2/0/0
              
               

              (任意)指定されたインターフェイス上のすべてのサービス ポリシーに対して設定されている全クラスのポリシー設定情報を表示します。

               

              ボーダー ゲートウェイ プロトコルを使用した QoS ポリシー伝搬の設定

              ここでは、ボーダー ゲートウェイ プロトコル(BGP)コミュニティ リスト、BGP 自律システム パス、アクセス リスト、送信元プレフィックス アドレス、または宛先プレフィックス アドレスに基づいて、BGP を使用したポリシー伝搬をルータ上で設定する方法について説明します。

              BGP を使用したポリシー伝搬の設定のタスク リスト

              BGP を使用したポリシー伝搬では、BGP コミュニティ リスト、BGP 自律システム パス、アクセス リスト、送信元プレフィックス アドレス、および宛先プレフィックス アドレスに基づいて、IP precedence または QoS グループ ID(あるいはその両方)でパケットを分類できます。 パケットを分類しておくと、重み付けランダム早期検出(WRED)などの他の QoS 機能を使用して、ビジネス モデルに適合するようにポリシーを指定し、実行できます。

              タスクの概要

              BGP によるポリシー伝搬を設定するには、次の基本作業を実行します。

              • BGP およびシスコ エクスプレス フォワーディング(CEF)を設定します。 BGP を設定するには、『Cisco IOS XR Routing Configuration Guide』を参照してください。 CEF を設定するには、『Cisco IOS XR IP Address and Services Configuration Guide』を参照してください。
              • BGP コミュニティ リストまたはアクセス リストを設定します。
              • ルート ポリシーを定義します。 BGP コミュニティ リスト、BGP 自律システム パス、アクセス リスト、送信元プレフィックス アドレス、または宛先プレフィックス アドレスに基づいて、IP precedence または QoS グループ ID を設定します。
              • BGP にルート ポリシーを適用します。
              • 目的のインターフェイス上で QPPB を設定します。
              • 上記の分類(IP precedence または QoS グループ ID による分類)を使用するように QoS ポリシーを設定します。 専用アクセス レート(CAR)、WRED、およびテール ドロップを設定するには、「Configuring Modular QoS Congestion Avoidance on Cisco IOS XR Software」モジュールを参照してください。

              ルート ポリシーの定義

              この作業では、IP precedence または QoS グループ ID による BGP プレフィックスの分類に使用するルート ポリシーを定義します。

              前提条件

              ルート ポリシーで使用する BGP コミュニティ リストまたはアクセス リストを設定します。

              制約事項

              • 出力 QoS ポリシーを使用した IPv4 QPPB および IPv6 QPPB は、すべてのイーサネットおよび SIP-700 ラインカードでサポートされています。
              • 入力 QoS ポリシーを使用した IPv4 QPPB は、最初の世代の ASR9000 イーサネット ラインカードでサポートされています。
              手順の概要

                1.    configure

                2.    route-policy name

                3.    set qos-groupqos-group-value

                4.    次のいずれかのコマンドを使用します。

                • end
                • commit


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1 configure


                例:
                RP/0/RSP0/CPU0:router# configure
                 

                グローバル コンフィギュレーション モードを開始します。

                 
                ステップ 2route-policy name


                例:
                
                RP/0/RSP0/CPU0:router(config)# route-policy r1
                
                 

                ルート ポリシー コンフィギュレーション モードに切り替え、設定するルート ポリシーの名前を指定します。

                 
                ステップ 3 set qos-groupqos-group-value


                例:
                RP/0/RSP0/CPU0:router(config-pmap-c) # set qos-group 30
                 

                QoS グループ ID を設定します。 set qos-group コマンドは入力ポリシーでのみサポートされています。

                 
                ステップ 4次のいずれかのコマンドを使用します。
                • end
                • commit


                例:
                RP/0/RSP0/CPU0:router(config)# end

                または

                RP/0/RSP0/CPU0:router(config)# commit
                 

                設定変更を保存します。

                • end コマンドを実行すると、変更をコミットするように要求されます。
                  Uncommitted changes found, commit them
                  before exiting(yes/no/cancel)? [cancel]:
                  
                  • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                  • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                  • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                 

                BGP に対するルート ポリシーの適用

                この作業では、BGP にルート ポリシーを適用します。

                前提条件

                BGP および CEF を設定します。

                手順の概要

                  1.    configure

                  2.    router bgpas-number

                  3.    address-familyaddress-prefix

                  4.    table-policypolicy-name

                  5.    次のいずれかのコマンドを使用します。

                  • end
                  • commit


                手順の詳細
                   コマンドまたはアクション目的
                  ステップ 1 configure


                  例:
                  RP/0/RSP0/CPU0:router# configure
                   

                  グローバル コンフィギュレーション モードを開始します。

                   
                  ステップ 2 router bgpas-number


                  例:
                  RP/0/RSP0/CPU0:router(config) # router bgp 120
                   

                  BGP コンフィギュレーション モードを開始します。

                   
                  ステップ 3 address-familyaddress-prefix


                  例:
                  RP/0/RSP0/CPU0:router(config-bgp) # address-family ipv4 unicast
                   

                  アドレス ファミリ コンフィギュレーション モードを開始します。このモードでは、アドレス ファミリを設定できます。

                   
                  ステップ 4 table-policypolicy-name


                  例:
                  RP/0/RSP0/CPU0:router(config-bgp-af) # table-policy qppb a1
                   

                  ルーティング ポリシーを適用します。

                   
                  ステップ 5次のいずれかのコマンドを使用します。
                  • end
                  • commit


                  例:
                  RP/0/RSP0/CPU0:router(config)# end

                  または

                  RP/0/RSP0/CPU0:router(config)# commit
                   

                  設定変更を保存します。

                  • end コマンドを実行すると、変更をコミットするように要求されます。
                    Uncommitted changes found, commit them
                    before exiting(yes/no/cancel)? [cancel]:
                    
                    • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                    • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                    • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                  • 設定変更を実行コンフィギュレーション ファイルに保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                   

                  目的のインターフェイスでの QPPB の設定

                  この作業では、指定したインターフェイスに QPPB を適用します。 ルート ポリシーでのプレフィックスの一致に基づいて、トラフィックの分類が始まります。 トラフィックの送信元または宛先の IP アドレスを使用して、ルート ポリシーを照合できます。

                  手順の概要

                    1.    configure

                    2.    interface type interface-path-id

                    3.    ipv4 | ipv6 bgp policy propagation input {ip-precedence | qos-group} {destination [ip-precedence {destination | source}] | source [ip-precedence {destination | source}] } RP/0/RSP0/CPU0:router(config)#ipv4 bgp policy propagation input qos-group destination


                  手順の詳細
                     コマンドまたはアクション目的
                    ステップ 1 configure


                    例:
                    RP/0/RSP0/CPU0:router# configure
                     

                    グローバル コンフィギュレーション モードを開始します。

                     
                    ステップ 2interface type interface-path-id


                    例:
                    
                    RP/0/RSP0/CPU0:router(config)#interface POS 0/0/0/0
                    
                     

                    インターフェイス コンフィギュレーション モードを開始して、1 つ以上のインターフェイスを VRF に関連付けます。

                     
                    ステップ 3ipv4 | ipv6 bgp policy propagation input {ip-precedence | qos-group} {destination [ip-precedence {destination | source}] | source [ip-precedence {destination | source}] } RP/0/RSP0/CPU0:router(config)#ipv4 bgp policy propagation input qos-group destination 

                    いずれかのインターフェイスで QPPB をイネーブルにします。

                     

                    QPPB の使用例

                    トラフィックが(単一の)ルータ port1 および port2 を介して Network1 から Network2 に移動する場合について考えます。 QPPB が port1 でイネーブルの場合

                    • 入力の QoS の場合:インターフェイス port1 の入力ポリシーに対応付けます。
                    • 出力の QoS の場合:インターフェイス port2 の出力ポリシーに対応付けます。

                    階層型入力ポリシングの設定

                    手順の概要

                      1.   

                      2.    policy-map policy-name

                      3.    class class-name

                      4.    service-policy policy-name

                      5.    police rate percent percentage

                      6.    conform-action action

                      7.    exceed-action action

                      8.    end または commit


                    手順の詳細
                       コマンドまたはアクション目的
                      ステップ 1

                      例:
                      
                      RP/0//CPU0:router# configure
                      
                       

                      グローバル コンフィギュレーション モードを開始します。

                       
                      ステップ 2policy-map policy-name


                      例:
                      
                      RP/0//CPU0:router(config)# policy-map parent
                      
                       

                      ポリシー マップ コンフィギュレーション モードを開始します。

                      1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または修正し、サービス ポリシーを指定します

                       
                      ステップ 3class class-name


                      例:
                      
                      RP/0//CPU0:router(config-pmap)# class class-default
                      
                       

                      ポリシー マップ クラス コンフィギュレーション モードを開始します。

                      ポリシーを作成または変更するクラスの名前を指定します。

                       
                      ステップ 4 service-policy policy-name


                      例:
                      
                      RP/0//CPU0:router(config-pmap-c)# service-policy child
                      
                       

                      ポリシー マップを入力または出力インターフェイスに適用します。

                       
                      ステップ 5police rate percent percentage


                      例:
                      
                      RP/0//CPU0:router(config-pmap-c)# police rate percent 50 	
                      
                       

                      トラフィック ポリシングを設定し、ポリシー マップ ポリシング コンフィギュレーション モードを開始します。

                       
                      ステップ 6conform-action action


                      例:
                      
                      RP/0//CPU0:router(config-pmap-c-police)# conform-action transmit
                      
                       

                      レート制限に適合したパケットに対して実行するアクションを設定します。 可能なアクションは次のとおりです。

                      transmit:パケットを送信します。

                       
                      ステップ 7exceed-action action


                      例:
                      
                      RP/0//CPU0:router(config-pmap-c-police)# exceed-action drop
                      
                       

                      レート制限を超過したパケットに対して実行するアクションを設定します。 可能なアクションは次のとおりです。

                      drop:パケットをドロップします。

                       
                      ステップ 8end または commit

                      例:
                      
                      RP/0//CPU0:router(config-pmap-c-police)# end
                      

                      または

                      
                      RP/0//CPU0:router(config-pmap-c-police)# commit
                      
                       

                      設定変更を保存します。

                      • end コマンドを実行すると、変更をコミットするように要求されます。 Uncommitted changes found, commit them before exiting(yes/no/cancel)? [cancel]: yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。 no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。 cancel と入力すると、ルータは現在のコンフィギュレーション セッションで継続されます。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                      • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                       

                      モジュラ QoS パケット分類の設定例

                      ここでは、次の例を示します。

                      定義されたトラフィック クラス:例

                      次に、2 つのトラフィック クラスを作成し、その一致条件を定義する例を示します。 1 つ目のトラフィック クラス class1 では、ACL 101 を一致基準として使用します。 2 番めのトラフィック クラス class2 では、ACL 102 を一致条件として使用しています。 パケットはこれらの ACL の内容と照合され、そのクラスに属するかどうかが判断されます。

                      
                      class-map class1
                        match access-group ipv4 101
                        exit
                      !
                      class-map class2
                        match access-group ipv4 102
                        exit
                      

                      not キーワードを match コマンドに使用すると、指定していないフィールド値に基にして照合を行います。 次の例では、DSCP 値が 4、8、10 以外である qos_example クラスのすべてのパケットが含まれます。

                      
                      class-map match-any qos_example
                        match not dscp 4 8 10
                      !
                      end
                      

                      トラフィック ポリシーの作成:例

                      次の例では、policy1 というトラフィック ポリシーを定義し、class1 と class2 という 2 つのクラスのポリシー設定を含めます。 これらのクラスの一致基準は、68 ページの「定義されたトラフィック クラス:例」の項で作成されたトラフィック クラスで定義されています。

                      class1 では、帯域幅割り当て要求と、そのクラス用に予約されるキューの最大バイト数の制限がポリシーに含まれています。 class2 に対しては、帯域幅割り当て要求だけがポリシーで指定されています。

                      
                      policy-map policy1
                        class class1
                          bandwidth 3000
                          queue-limit bytes 1000000000
                          exit
                      !
                        class class2
                          bandwidth 2000
                          exit
                      
                      policy-map policy1
                        class class1
                          bandwidth 3000 kbps
                          queue-limit 1000 packets
                      !
                        class class2
                          bandwidth 2000 kbps
                      !
                        class class-default
                      !
                      end-policy-map
                      !
                      end
                      

                      インターフェイスへのトラフィック ポリシーの付加:例

                      次に、既存のトラフィック ポリシーをインターフェイスに付加する例を示します(68 ページの「定義されたトラフィック クラス:例」の項を参照)。 policy-map コマンドを使用してトラフィック ポリシーを定義した後、インターフェイス コンフィギュレーション モードで service-policy コマンドを使用して、このポリシーを 1 つ以上のインターフェイスに付加し、これらのインターフェイスのトラフィック ポリシーを指定できます。 同じトラフィック ポリシーは複数のインターフェイスに付加することができますが、各インターフェイスには入力と出力に対してそれぞれトラフィック ポリシーを 1 つだけ付加することができます。

                      
                      interface gigabitethernet 0/1/0/9
                        service-policy output policy1
                        exit
                      !
                      interface TenGigE 0/5/0/1
                        service-policy output policy1
                        exit
                      

                      複数のサブインターフェイスへのトラフィック ポリシーの付加:例

                      次に、複数のサブ インターフェイスに既存のトラフィック ポリシーを付加する例を示します。 policy-map コマンドを使用してトラフィック ポリシーを定義した後、サブインターフェイス コンフィギュレーション モードで service-policy コマンドを使用して、このポリシーを 1 つ以上のサブインターフェイスに付加できます。

                      
                      interface gigabitethernet 0/1/0/0.1
                        service-policy input policy1 shared-policy-instance ethernet101
                        exit
                      !
                      interface gigabitethernet 0/1/0/0.2
                        service-policy input policy1 shared-policy-instance ethernet101
                        exit
                      

                      バンドル インターフェイスへのトラフィック ポリシーの付加:例

                      次に、既存のトラフィック ポリシーをバンドル インターフェイスに付加する例を示します。 policy-map コマンドを使用してトラフィック ポリシーを定義した後、サブインターフェイス コンフィギュレーション モードで service-policy コマンドを使用して、このポリシーを 1 つ以上のバンドル サブインターフェイスに付加できます。

                      
                      interface Bundle-Ether 100.1
                        service-policy tripleplaypolicy shared-policy-instance subscriber1
                        exit
                      !
                      interface Bundle-Ether 100.2
                        service-policy output tripleplaypolicy shared-policy instance subscriber1
                        exit
                      

                      共有ポリシー インスタンスによる EFP ロード バランシング:例

                      次に、SPI が実装されている場合に EFP に対してロード バランシングを設定する例を示します。 リンク バンドルの EFP ロード バランシングの詳細については、『Cisco IOS XR Interface and Hardware Component Configuration Guide』を参照してください。

                      バンドル インターフェイスの設定:例

                      
                      interface Bundle-Ether 50
                      interface gigabitethernet 0/1/0/5
                        bundle id 50 mode active
                      interface gigabitethernet 0/1/0/8
                        bundle id 50 mode active
                      

                      ロード バランス オプションによる 2 つのバンドル EFP の設定:例

                      次の例では、同じ物理メンバ リンクを通過する 2 つのバンドル EFP 宛てのトラフィックを設定します。

                      
                      interface Bundle-Ether 50.25 l2transport
                        encapsulation dot1q 25
                        bundle load-balance hash-select 2
                      !
                      interface Bundle-Ether 50.36 l2transport
                        encapsulation dot1q 36
                        bundle load-balance hash-select 2
                      

                      デフォルト トラフィック クラスの設定例

                      次に、トラフィック ポリシー policy1 のデフォルト クラスに対してトラフィック ポリシーを設定する例を示します。 デフォルト クラスの名前は class-default で、他のすべてのトラフィックから構成され、インターフェイスの帯域幅の 60 パーセントでシェーピングされます。

                      
                      policy-map policy1
                        class class-default
                          shape average percent 60
                      

                      class-map match-any コマンドの設定: 例

                      次の例では、一致基準が複数ある場合に、パケットがどのように評価されるかについて説明します。 class-map match-any コマンド中のパケットがトラフィック クラスのメンバであると見なされるためには、一致基準が 1 つだけが満たされる必要があります(論理的な OR 演算子)。 この例では、プロトコル IP OR QoS グループ 4 OR アクセス グループ 101 が成功する一致基準になる必要があります。

                      
                      class-map match-any class1
                        match protocol ipv4
                        match qos-group 4
                        match access-group ipv4 101
                      

                      トラフィック クラス class1 では、成功する一致条件が見つかるまで連続的に一致基準が評価されます。 各一致基準が評価され、パケットがその基準に一致するかどうかが判断されます。 パケットが指定した条件のうち少なくとも 1 つに一致すると、パケットはトラフィック クラスのメンバとして分類されます。


                      (注)  


                      match qos-group コマンドは、出力ポリシーでのみサポートされています。


                      クラスベースの無条件パケット マーキングの例

                      次に、一般的なクラスベースの無条件パケット マーキングの例を示します。

                      IP precedence のマーキングの設定:例

                      次の例では、policy1 というサービス ポリシーを作成します。 このサービス ポリシーは、class コマンドを使用して事前に定義したクラス マップ class1 に関連付けられ、その後、出力 POS インターフェイス 0/1/0/0 に付加されます。 ToS バイトの IP precedence ビットを 1 に設定します。

                      
                      policy-map policy1
                        class class1
                          set precedence 1
                      !
                      interface pos 0/1/0/0
                        service-policy output policy1
                      

                      IP DSCP マーキングの設定:例

                      次の例では、policy1 というサービス ポリシーを作成します。 このサービス ポリシーは、class コマンドを使用して事前に定義したクラス マップに関連付けられます。 この例では、class1 というクラス マップが事前に設定されていることを前提としています。

                      次の例では、ToS バイトの IP DSCP 値を 5 に設定します。

                      
                      policy-map policy1
                        class class1
                          set dscp 5
                      
                        class class2
                          set dscp ef
                      

                      エッジで音声パケットに対して示される設定を行った後、すべての中間ルータは次のように音声パケットに低遅延処理を行うよう設定されます。

                      
                      class-map voice
                        match dscp ef
                      policy-map qos-policy
                        class voice
                          priority level 1
                          police rate percent 10
                      

                      QoS グループ マーキングの設定:例

                      次の例では、policy1 というサービス ポリシーを作成します。 このサービス ポリシーは、class コマンドを使用してクラス マップ class1 に関連付けられ、その後 GigabitEthernet インターフェイス 0/1/0/9 の入力方向に付加されます。 qos-group 値は 1 に設定されます。

                      
                      class-map match-any class1
                        match protocol ipv4
                        match access-group ipv4 101
                      
                      policy-map policy1
                        class class1
                          set qos-group 1
                        !
                      interface gigabitethernet 0/1/0/9
                        service-policy input policy1
                      

                      (注)  


                      set qos-group コマンドは入力ポリシーでのみサポートされています。


                      CoS マーキングの設定:例

                      次の例では、policy1 というサービス ポリシーを作成します。 このサービス ポリシーは、class コマンドを使用してクラス マップ class1 に関連付けられ、その後 10-Gigabit Ethernet インターフェイス TenGigE0/1/0/0 の出力方向に付加されます。 レイヤ 2 ヘッダーの IEEE 802.1p(CoS)ビットは 1 に設定します。

                      
                      class-map match-any class1
                        match protocol ipv4
                        match access-group ipv4 101
                      
                      policy-map policy1
                        class class1
                          set cos 1
                        !
                      interface TenGigE0/1/0/0
                      interface TenGigE0/1/0/0.100
                        service-policy output policy1
                      

                      MPLS EXP ビット インポジション マーキングの設定:例

                      次の例では、policy1 というサービス ポリシーを作成します。 このサービス ポリシーは、class コマンドを使用してクラス マップ class1 に関連付けられ、その後 10-Gigabit Ethernet インターフェイス TenGigE0/1/0/0 の入力方向に付加されます。 すべてのインポーズされたラベルの MPLS EXP ビットは 1 に設定します。

                      
                      class-map match-any class1
                        match protocol ipv4
                        match access-group ipv4 101
                      
                      policy-map policy1
                        class class1
                          set mpls exp imposition 1
                       !
                      interface TenGigE0/1/0/0
                        service-policy input policy1
                      

                      (注)  


                      set mpls exp imposition コマンドは入力ポリシーでのみサポートされています。


                      MPLS EXP 最上位マーキングの設定:例

                      次の例では、policy1 というサービス ポリシーを作成します。 このサービス ポリシーは、class コマンドを使用してクラス マップ class1 に関連付けられ、その後 10-Gigabit Ethernet インターフェイス TenGigE0/1/0/0 の出力方向に付加されます。 最上位ラベルの MPLS EXP ビットは 1 に設定します。

                      
                      class-map match-any class1
                        match mpls exp topmost 2
                      
                      policy-map policy1
                        class class1
                          set mpls exp topmost 1
                        !
                      interface TenGigE0/1/0/0
                        service-policy output policy1
                      

                      In-Place ポリシーの変更:例

                      この例では、ポリシーを定義してインターフェイスに付加した後、precedence を 3 から 5 に変更します。

                      クラスを定義します。

                      
                      class-map match-any class1
                       match cos 7
                       end-class-map
                      

                      クラスを使用するポリシー マップを定義します。

                      
                      policy-map policy1
                       class class1
                       set precedence 3
                      

                      インターフェイスにポリシー マップを付加します。

                      
                      interface gigabitethernet 0/6/0/1
                       service-policy output policy1
                       commit
                      

                      ポリシー マップの precedence 値を変更します。

                      
                      policy-map policy1
                       class class1
                       set precedence 5
                       commit
                      

                      (注)  


                      変更されたポリシー policy1 は、ポリシーが付加されるすべてのインターフェイスに反映されます。 また、ポリシー マップに使用するすべてのクラス マップを変更できます。 クラス マップに対して行った変更は、ポリシーが付加されているすべてのインターフェイスに反映されます。


                      この show policy-map targets コマンドの出力は、ギガ ビット イーサネット インターフェイス 0/1/0/0 に、メイン ポリシーとして付加されているポリシー マップがあることを示しています(階層型 QoS 設定の子ポリシーに付加されるのではなく)。 このインターフェイスの発信トラフィックは、ポリシーが変更された場合に影響を受けます。

                      
                      show policy-map targets
                      
                      Fri Jul 16 16:38:24.789 DST
                      1) Policymap: policy1    Type: qos
                           Targets (applied as main policy):
                             GigabitEthernet0/1/0/0 output
                           Total targets: 1
                      
                           Targets (applied as child policy):
                           Total targets: 0
                      

                      その他の関連資料

                      ここでは、パケット分類の実装に関する関連資料について説明します。

                      関連資料

                      関連項目

                      参照先

                      初期システム起動と設定

                      『Cisco ASR 9000 Series Aggregation Services Router Getting Started Guide』

                      マスター コマンド リファレンス

                      『Cisco ASR 9000 Series Aggregation Services Router Master Command Listing』

                      QoS コマンド

                      『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference』

                      ユーザ グループとタスク ID

                      『Cisco ASR 9000 Series Aggregation Services Router System Security Configuration Guide』の「Configuring AAA Services on Cisco ASR 9000 Series Router」モジュール

                      標準

                      標準

                      タイトル

                      この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

                      MIB

                      MIB

                      MIB のリンク

                      Cisco IOS XR ソフトウェアを使用して MIB を検索およびダウンロードするには、http:/​/​cisco.com/​public/​sw-center/​netmgmt/​cmtk/​mibs.shtml にある Cisco MIB Locator を使用し、[Cisco Access Products] メニューからプラットフォームを選択します。

                      RFC

                      RFC

                      タイトル

                      この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

                      シスコのテクニカル サポート

                      説明

                      リンク

                      シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクなどの、数千ページに及ぶ技術情報が検索可能です。 Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

                      http:/​/​www.cisco.com/​en/​US/​support/​index.html