Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ ルーティング コンフィギュレーション ガイド リリース 4.2.x
Cisco ASR 9000 シリーズ ルータへの EIGRP の実装
Cisco ASR 9000 シリーズ ルータへの EIGRP の実装
発行日;2012/12/12   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

Cisco ASR 9000 シリーズ ルータへの EIGRP の実装

Enhanced Interior Gateway Routing Protocol(EIGRP)は、シスコによって開発された IGRP の拡張バージョンです。 このモジュールでは、Cisco IOS XR ソフトウェアを使用して基本 EIGRP 設定を実装するために理解する必要がある概念と作業について説明します。 EIGRP はディスタンス ベクトル ルーティング テクノロジーを採用しているため、ルータはネットワーク全体でのルータとリンクのすべての関係を認識する必要がありません。 各ルータは対応する距離の宛先をアドバタイズし、ルート受信時に距離を調整し、ネイバー ルートへ情報を伝搬します。

次の機能に関連する EIGRP の設定については、このモジュールの関連資料を参照してください。

  • マルチプロトコル ラベル スイッチング(MPLS)レイヤ 3 バーチャル プライベート ネットワーク(VPN)
  • Site of Origin(SoO)のサポート

(注)  


Cisco IOS XR ソフトウェアの EIGRP の詳細とこのモジュールに示す EIGRP コマンドの詳細な説明については、このモジュールの関連資料を参照してください。 設定作業の実行時に使用する可能性があるその他のコマンドに関するドキュメントを見つけるには、オンラインのCisco IOS XR ソフトウェア マスター コマンド索引を検索してください。


Cisco ASR 9000 シリーズ ルータ ソフトウェアでの EIGRP 実装機能の履歴

リリース

変更箇所

リリース 3.7.2

この機能が導入されました。

リリース 3.9.0

変更なし。

EIGRP の実装の前提条件

適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。

EIGRP の実装での制約事項

このバージョンの Cisco IOS XR ソフトウェア で EIGRP を実行するときには次の制約が適用されます。

  • サポートされる EIGRP プロセス インスタンスは 1 つだけです。
  • 双方向フォワーディング検出(BFD)機能と Simple Network Management Protocol(SNMP)MIB はサポートされていません。
  • ネットワーク コマンドがないため、インターフェイス スタティック ルートは EIGRP に自動再配布されません。
  • 接続ルートおよびスタティック ルートを再配布するには(default-metric コマンドまたはルート ポリシーによる)メトリック設定が必要です。
  • 自動要約はデフォルトではディセーブルになっています。
  • スタブ リーク マップはサポートされていません。

EIGRP の実装に関する情報

EIGRP を実装するには、次の概念を理解する必要があります。

EIGRP 機能の概要

Enhanced Interior Gateway Routing Protocol(EIGRP)は、さまざまなトポロジとメディアに適した内部ゲートウェイ プロトコルです。 EIGRP は拡張性が高く、最小限のネットワーク トラフィックで非常に短いコンバージェンス時間を実現します。

通常の動作では EIGRP のネットワーク リソース使用率は非常に低くなります。 安定したネットワークでは hello パケットだけが送信されます。 トポロジの変更が発生した場合、ルーティング テーブル全体ではなくルーティング テーブルの変更だけが伝搬されます。 この伝搬により、ネットワーク上でのルーティング プロトコル自体による負荷が減ります。 EIGRP は、ネットワーク トポロジ変更においても短いコンバージェンス時間を実現します。

EIGRP における距離情報は、使用可能な帯域幅、遅延、負荷率、リンク信頼性の総合情報として表され、またコンバージェンス プロパティと運用効率が向上します。 リンク特性を細かく調整することで最適なパスが実現します。

EIGRP に採用されているコンバージェンス テクノロジーは、SRI International で行われた調査に基づき、Diffusing Update Algorithm(DUAL)と呼ばれるアルゴリズムを採用しています。 このアルゴリズムは、ルート計算中のどの時点でもループが発生しないようにし、トポロジ変更に関与するすべてのデバイスを同時に同期できるようにします。 トポロジ変更の影響を受けないルータは、再計算に含まれません。 DUAL を使用した場合のコンバージェンス時間は、既存の他のルーティング プロトコルのコンバージェンス時間に匹敵します。

EIGRP の機能

EIGRP は、次の機能を提供します。

  • 高速コンバージェンス:DUAL アルゴリズムにより、現在利用可能なルーティング プロトコルと同様にルーティング情報を迅速にコンバージできます。
  • 部分アップデート:宛先の状態が変化した場合、EIGRP は、ルーティング テーブルの内容全体を送信するのではなく、差分アップデートを送信します。 この機能により、EIGRP パケットに必要な帯域幅が最小限に抑えられます。
  • ネイバー探索メカニズム:隣接ルータの学習に使用される簡単な hello メカニズムです。 これはプロトコルに依存しません。
  • 可変長サブネット マスク(VLSM)
  • 任意のルート集約
  • スケーリング:EIGRP は大規模なネットワークに合わせて拡張します。

Cisco IOS XR 実装でサポートされている主な機能を次に示します。

  • Site of Origin(SoO)およびボーダー ゲートウェイ プロトコル(BGP)コスト コミュニティ サポートによるプロバイダー エッジ(PE)- カスタマー エッジ(CE)プロトコルのサポート。
  • MPLS に対する PECE プロトコル サポート。

EIGRP コンポーネント

EIGRP には、次の 4 つの基本コンポーネントがあります。

  • ネイバー探索またはネイバー回復
  • Reliable Transport Protocol
  • DUAL 有限状態マシン
  • プロトコル依存モジュール

ネイバー探索またはネイバー回復:ルータが直接接続されたネットワーク上の他のルータに関する情報をダイナミックに学習する際に使用されるプロセスです。 また、ネイバーが到達不能または動作不能になっていることを検出するためにも使用されます。 ネイバー探索またはネイバー回復は、サイズの小さな hello パケットを定期的に送信することにより、わずかなオーバーヘッドで実現されます。 hello パケットを受信しているかぎり、Cisco IOS XR ソフトウェア はネイバーがダウンせずに機能しているものと判定します。 ネイバーが正常に動作していることが確認されると、隣接ルータとの間でルーティング情報を交換できます。

Reliable Transport Protocol:EIGRP パケットをすべてのネイバーに確実に、順序どおりに配信します。 マルチキャスト パケットとユニキャスト パケットが混在した伝送もサポートされます。 EIGRP パケットには、確実に送信する必要があるものと、その必要がないものがあります。 効率化のため、信頼性は必要時にのみ提供されます。 たとえば、マルチキャスト機能を備えているマルチアクセス ネットワーク(イーサネットなど)では、すべてのネイバーに対して個別に hello パケットを高信頼性で送信する必要はありません。 そのため、EIGRP は、1 つのマルチキャスト hello を送信し、パケットに確認応答が必要ないという通知をそのパケットに含めます。 その他のタイプのパケット(アップデートなど)には、確認応答が必要であり、そのことをパケットで示します。 信頼性の高い転送では、確認応答のないパケットの保留中にすばやくマルチキャスト パケットを送信できます。 これにより、さまざまな速度のリンクが存在する場合でも短いコンバージェンス時間を維持できます。

DUAL 有限状態マシンには、すべてのルート計算の決定プロセスが組み込まれており、 すべてのネイバーによってアドバタイズされたすべてのルートが追跡されます。 DUAL は距離情報(メトリックともいう)を使用して、効率的な、ループのないパスを選択し、 DUAL は到達可能条件の計算に基づいてルーティング テーブルに挿入するルートを選択します。 後継ルータは、宛先への最小コスト パス(ルーティング ループに関連しないことが保証されている)を持つ、パケット転送に使用される隣接ルータです。 フィジブル サクセサはないが、宛先をアドバタイジングするネイバーがある場合、再計算が行われ、 この結果、新しい後継ルータが決定されます。 ルートの再計算に必要な時間は、コンバージェンス時間に影響します。 再計算は、プロセッサに高い負荷を与えます。したがって、不要な再計算を行わないことを推奨します。 トポロジが変更されると、DUAL はフィジブル サクセサの有無を調べます。 適切なフィジブル サクセサが存在する場合は、それらを探して使用し、不要な再計算を回避します。

プロトコル依存モジュールは、ネットワーク層プロトコル固有のタスクを実行します。 たとえば EIGRP モジュールでは、IP で暗号化されている EIGRP パケットの送信と受信を行います。 また、EIGRP パケットを解析したり、DUAL に受信した新しい情報を通知したりします。 EIGRP は DUAL にルーティング決定を行うように要求しますが、結果は IP ルーティング テーブルに格納されます。 EIGRP は、他の IP ルーティング プロトコルによって取得したルートの再配信も行います。

EIGRP 設定のグループ化

Cisco IOS XR ソフトウェア は、ルータ EIGRP コンフィギュレーション モードですべての EIGRP 設定(EIGRP に関連するインターフェイス設定も含む)をグループ化します。 EIGRP 設定全体を表示するには、show running-config router eigrp コマンドを使用します。 このコマンドの出力には、設定されている EIGRP インスタンスの実行設定(インターフェイス割り当てとインターフェイス属性を含む)が表示されます。

EIGRP コンフィギュレーション モード

次に、各コンフィギュレーション モードを開始する例を示します。 各モードから、? コマンドを入力すると、そのモードで使用できるコマンドが表示されます。

ルータ コンフィギュレーション モード

次に、ルータ コンフィギュレーション モードを開始する例を示します。

RP/0/RSP0/CPU0:router# configuration
RP/0/RSP0/CPU0:router(config)# router eigrp 100
RP/0/RSP0/CPU0:router(config-eigrp)#
  

VRF コンフィギュレーション モード

次に、VRF コンフィギュレーション モードを開始する例を示します。

  RP/0/RSP0/CPU0:router# configuration
  RP/0/RSP0/CPU0:router(config)# router eigrp 100
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf customer1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)#
  

IPv4 アドレス ファミリ コンフィギュレーション モード

次に、IPv4 アドレス ファミリ コンフィギュレーション モードを開始する例を示します。

  RP/0/RSP0/CPU0:router# configuration
  RP/0/RSP0/CPU0:router(config)# router eigrp 100
  RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)#
  

IPv4 VRF アドレス ファミリ コンフィギュレーション モード

次に、IPv4 VRF アドレス ファミリ コンフィギュレーション モードを開始する例を示します。

  RP/0/RSP0/CPU0:router# configuration
  RP/0/RSP0/CPU0:router(config)# router eigrp 100
  RP/0/RSP0/CPU0:router(config-eigrp)# vrf customer1
  RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)#
  

インターフェイス コンフィギュレーション モード

次に、IPv4 アドレス ファミリ コンフィギュレーション モードでインターフェイス コンフィギュレーション モードを開始する例を示します。

  RP/0/RSP0/CPU0:router# configuration
  RP/0/RSP0/CPU0:router(config)# router eigrp 100
  RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/3/0/0
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)#
  
  

EIGRP インターフェイス

EIGRP インターフェイスは次のいずれかのタイプとして設定できます。

  • アクティブ:接続されたプレフィックスをアドバタイズし、隣接関係を形成します。 これはデフォルトのインターフェイス タイプです。
  • パッシブ:接続されたプレフィックスをアドバタイズしますが、隣接関係は形成しません。 インターフェイスをパッシブに設定するには、passive コマンドを使用します。 パッシブ インターフェイスはむやみに使用せず、EIGRP ドメインに挿入する必要がある重要なプレフィックス(ループバック アドレスなど)に対して使用してください。 アドバタイズする必要がある接続プレフィックスが多数ある場合は、代わりに適切なポリシーを使用した接続ルートの再配布を使用してください。

EIGRP プロセスへの再配布

他のプロトコルからのルートを EIGRP に再配布できます。 redistribute コマンドを使用してルート ポリシーを設定できます。 ルートを EIGRP にインポートするには、default-metric コマンド、または redistribute コマンドで設定されたルート ポリシーのいずれかを使用して設定されたメトリックが必要です。

ルート ポリシーでは、宛先、発信元プロトコル、ルート タイプ、ルート タグなどの属性に基づいてルートをフィルタリングできます。 VRF で再配布が設定されている場合、EIGRP はルーティング情報ベース(RIB)でルートに付加されている拡張コミュニティを取得します。 MPSL VPN バックドア リンクが存在する場合にはルーティング ループを除外するため SoO が使用されます。

EIGRP ルーティングのメトリックの重み付け

EIGRP は宛先ネットワークへのパスで最小の帯域幅を使用し、ルーティング メトリックを計算するために合計遅延を使用します。 metric weights コマンドを使用して、EIGRP のルーティングおよびメトリック計算のデフォルト動作を調整できます。 たとえば、この調整によって、人工衛星との送信を可能にするためにシステムの動作をチューニングすることができます。 EIGRP メトリックのデフォルトは、大半のネットワークで最適なパフォーマンスを実現できるよう、慎重に選択されています。

デフォルトでは、EIGRP 複合メトリックは、特定のルートのセグメント遅延と(拡張およびインバートされた)最小セグメント帯域幅の合計である 32 ビットになります。 同種メディアのネットワークでは、このメトリックは 1 ホップ カウントまで減少します。 混合メディア(FDDI、イーサネット、および毎秒 9600 ビットから T1 まで多様なレートのシリアル回線)のネットワークでは、最低メトリックのルートが、宛先までの最適なパスになります。

K 値の不一致

K 値(EIGRP メトリック)の不一致があると、ネイバー関係を確立することができなくなり、ネットワークのコンバージェンスに悪影響を与えることがあります。 次の例で、2 つの EIGRP ピア(ルータ A とルータ B)間のこの動作について説明します。

K 値が一致しないため、ルータ B のコンソールに次のエラー メッセージが表示されます。

  RP/0/RSP0/CPU0:Mar 13 08:19:55:eigrp[163]:%ROUTING-EIGRP-5-NBRCHANGE:IP-EIGRP(0) 1:Neighbor 11.0.0.20 (GigabitEthernet0/6/0/0) is down: K-value mismatch

次の 2 つのシナリオで、このエラー メッセージが表示される可能性があります。

  • 同じリンク上に 2 台のルータが接続されており、ネイバー関係を確立するよう設定されている。 ただし、各ルータには異なる K 値が設定されている。 次の設定がルータ A に適用されています。 metric weights コマンドによって K 値が変更されます。 帯域幅計算を調整するために、k1 引数に値 2 が入力されます。 遅延計算を調整するために、k3 引数に値 1 が入力されます。
      hostname ROUTER-A!
      interface GigabitEthernet0/6/0/0
       ipv4 address 10.1.1.1 255.255.255.0 
      
      router eigrp 100 
       metric weights 0 2 0 1 0 0
       interface GigabitEthernet0/6/0/0
    
    次の設定がルータ B に適用されています。 ただし、metric weights コマンドは適用されず、デフォルトの K 値が使用されます。 デフォルトの K 値は、1、0、1、0、および 0 です。
      hostname ROUTER-B!
      interface GigabitEthernet0/6/0/1
       ipv4 address 10.1.1.2 255.255.255.0
      
      router eigrp 100 
       interface GigabitEthernet0/6/0/1
    
    ルータ A では帯域幅計算が 2 に設定され、ルータ B では 1(デフォルト)に設定されます。 この設定では、これらのピアでネイバー関係が形成されません。
  • 2 つのピアのうち、いずれかが「goodbye」メッセージを送信したのに、受信側のルータがこのメッセージをサポートしていない場合に、K 値の不一致エラー メッセージが表示されることがあります。 この場合には、受信側のルータが、このメッセージを K 値の不一致と解釈します。

goodbye メッセージ

goodbye メッセージは、EIGRP ネットワークのコンバージェンスを改善するために設計された機能です。 goodbye メッセージは、EIGRP ルーティング プロセスがシャットダウンしたときに、隣接するピアに、近い将来トポロジの変更が生じることを知らせるブロードキャストです。 この機能により、ホールド タイマーの期限が切れた後でピアがトポロジの変更を検出した場合よりも効率よく、EIGRP ピアがネイバー関係を同期化および再計算する機能をサポートできます。

goodbye メッセージを受信すると、サポートされているリリースを実行しているルータによって、次のメッセージが表示されます。

RP/0/RSP0/CPU0:Mar 13 09:13:17:eigrp[163]:%ROUTING-EIGRP-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.20 (GigabitEthernet0/6/0/0) is down: Interface Goodbye received

goodbye メッセージをサポートしていないソフトウェア リリースを実行している Cisco ルータは、このメッセージが、K 値の不一致であると誤った解釈をして、次のメッセージを表示することがあります。

RP/0/RSP0/CPU0:Mar 13 09:13:17:eigrp[163]:%ROUTING-EIGRP-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.20 (GigabitEthernet0/6/0/0) is down: K-value mismatch

(注)  


サポートしていないピアが goodbye メッセージを受信しても、通常のネットワーク処理を中断することはありません。 ホールド タイマーの期限が切れると、サポートしていないピアはセッションを終了します。 送信元がリロードした後も、送信側および受信側のルータは正常に再コンバージェンスします。


EIGRP パケットに使用されているリンク帯域幅のパーセンテージ

デフォルトでは、bandwidth interface コンフィギュレーション コマンドでの設定に従い、リンク帯域幅の最大 50 % が EIGRP パケットに消費されます。 異なるレベルのリンク使用率が必要な場合、または設定されている帯域幅が実際のリンク帯域幅と一致しない場合は(ルート メトリックの計算に影響するように設定されている場合があります)、この値を変更できます。

EIGRP プロセスの浮動サマリー ルート

summary-address コマンドを設定するときには浮動サマリー ルートも使用できます。 浮動サマリー ルートは、インターフェイス レベルでデフォルトのルートおよびアドミニストレーティブ ディスタンスを適用することによって作成されます。 この拡張機能の動作を次のシナリオで説明します。

図 1 は、ルータ A、ルータ B、およびルータ C の 3 台のルータを持つネットワークを示しています。 ルータ A はネットワーク上の他の場所からデフォルト ルートを学習し、そのルートをルータ B へアドバタイズします。 ルータ B は、デフォルトのサマリー ルートだけをルータ C へアドバタイズするよう設定されています。 次の設定では、ルータ B のインターフェイス 0/1 にデフォルトのサマリー ルートが適用されます。

  RP/0/RSP0/CPU0:router(config)# router eigrp 100
  RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/3/0/0
  RP/0/RSP0/CPU0:router(config-eigrp-af-if)# summary-address 100.0.0.0 0.0.0.0
  
図 1. ルータ B に適用される浮動サマリー ルート

ルータ B 上のデフォルト サマリー ルートの設定により、0.0.0.0/0 サマリー ルートがルータ C に送信され、10.1.1.0/24 ルートを含むすべてのルートがルータ C へアドバタイズされないようにします。 ただし、この設定によってルータ B 上にはローカルな廃棄ルート、つまりアドミニストレーティブ ディスタンスが 5 で、null 0 インターフェイスへの 0.0.0.0/0 に対するルートが生成されます。 このルートが作成された場合、EIGRP が学習したデフォルト ルートよりも優先されます。 このためルータ B は、通常では 0.0.0.0.0/0 ルートに到達する宛先に到達できなくなります。

この問題は、ルータ C に接続しているルータ B 上のインターフェイスに対して浮動サマリー ルートを適用することによって解決されます。 浮動サマリー ルートを適用するには、次のコマンド行を使用して、ルータ B のインターフェイス上でデフォルトのサマリー ルートに対してアドミニストレーティブ ディスタンスを関連付けます。

  RP/0/RSP0/CPU0:router(config-if)# summary-address 100 0.0.0.0 0.0.0.0 250
  
  
      

このコマンド行で適用されたアドミニストレーティブ ディスタンス 250 は、ルータ B で生成された廃棄ルートに割り当てられています。 ルータ A からの 0.0.0.0/0 は EIGRP を介して学習され、ローカル ルーティング テーブルにインストールされます。 ルータ C へのルーティングが復元されます。

ルータ A がルータ B に対する接続を失っても、ルータ B がルータ C へ継続してデフォルト ルートをアドバタイズしていると、トラフィックは、ルータ B へ割り当てられている宛先へ、そのまま到達することが可能です。 ただしルータ A に到達するネットワークまたはルータ A の背後にあるネットワークを宛先とするトラフィックは、ルータ B に到達するとドロップされます。

図 2 は、コアからの 2 つの接続、ルータ A およびルータ D を持つネットワークを示しています。 両方のルータで、ルータ C に接続するインターフェイスで浮動サマリー ルートが設定されています。 ルータ E とルータ C 間の接続が失敗しても、ネットワークは正常な処理を続行します。 すべてのトラフィックは、ルータ B を通ってルータ C に流れ、ルータ A およびルータ D へ接続されているホストへ到達します。

図 2. デュアルホーム接続リモートへ適用される浮動サマリー ルート

ただしルータ D とルータ E の間のリンクで障害が発生した場合、ルータ E へのリンク(ルータ C へのリンク以外)が少なくとも 1 つアクティブであるかぎり、ルータ E は引き続きデフォルト ルート(0.0.0.0/0)をルータ C にアドバタイズするため、ネットワークではトラフィックがブラックホールにダンプされることがあります。 このシナリオではルータ C は引き続きルータ E にトラフィックを転送しますが、ルータ E はトラフィックをドロップするためブラックホールが形成されます。 この問題を防ぐには、ネットワーク セグメント間の出力点が 1 つのみのシングルホーム接続リモート ルータまたはエリアでのみ、アドミニストレーティブ ディスタンスを使用してサマリー アドレスを設定してください。 (ネットワークのセグメント間の)出力点が 2 つ以上存在する場合には、フローティング デフォルト ルートを設定すると、ブラック ホールが形成される原因となることがあります。

EIGRP プロセスのスプリット ホライズン

スプリット ホライズンは、EIGRP アップデート パケットとクエリー パケットの送信を制御します。 スプリット ホライズンがインターフェイスでイネーブルになると、アップデート パケットとクエリー パケットは、このインターフェイスがネクスト ホップとなる宛先には送信されません。 この方法でアップデート パケットとクエリー パケットを制御すると、ルーティング ループが発生する可能性が低くなります。

デフォルトでは、スプリット ホライズンはすべてのインターフェイスでイネーブルになっています。

スプリット ホライズンは、ルート情報が、その情報の発信元となるインターフェイスからルータによってアドバタイズされないようにします。 通常、特にリンクが切断された場合には、この動作によって複数のルーティング デバイス間の通信が最適化されます。 ただし、非ブロードキャスト ネットワーク(フレーム リレーや SMDS など)を使用している場合は、この動作では不十分な状況が発生する可能性があります。 このような場合は、EIGRP を設定したネットワークを含め、スプリット ホライズンをディセーブルにする必要が生じることもあります。

EIGRP プロセスの hello 間隔と保留時間の調整

hello パケットの間隔と保留時間は調整することができます。

ルーティング デバイスは、定期的に hello パケットを相互に送信して、直接接続されたネットワーク上の他のルータをダイナミックに学習します。 この情報は、ネイバーを検出したり、ネイバーが到達不能または動作不能になったことを学習したりするために使用されます。 デフォルトでは、hello パケットは 5 秒間隔で送信されます。

自律システム番号によって指定された特定の EIGRP ルーティング プロセスの保留時間を、指定したインターフェイスに対して設定できます。 保留時間は、hello パケットでアドバタイズされ、送信元を有効と見なす時間の長さをネイバーに示します。 デフォルトの保留時間は、hello 間隔の 3 倍(15 秒)です。

EIGRP プロセスのスタブ ルーティング

EIGRP スタブ ルーティング機能は、ネットワークの安定性を高め、リソース利用率を抑え、スタブ ルータ構成を簡素化します。

スタブ ルーティングは一般にハブ アンド スポーク型のネットワーク トポロジで使用されます。 ハブ アンド スポーク ネットワークでは、1 つ以上のエンド(スタブ)ネットワークが 1 台のリモート ルータ(スポーク)に接続され、そのリモート ルータは 1 つ以上のディストリビューション ルータ(ハブ)に接続されています。 リモート ルータは、1 つ以上のディストリビューション ルータにのみ隣接しています。 リモート ルータへ流れる IP トラフィックのルートは、ディストリビューション ルータ経由のルートのみです。 このタイプの設定は、ディストリビューション ルータが直接 WAN に接続されている WAN トポロジで使用されるのが一般的です。 ディストリビューション ルータは、さらに多くのリモート ルータに接続できます。 ディストリビューション ルータが 100 台以上のリモート ルータに接続されていることも、よくあります。 ハブ アンド スポーク型トポロジでは、リモート ルータがすべての非ローカル トラフィックをディストリビューション ルータに転送する必要があります。これにより、リモート ルータが完全なルーティング テーブルを保持する必要はなくなります。 一般に、ディストリビューション ルータはデフォルト ルート以外の情報をリモート ルータに送信する必要はありません。

EIGRP スタブ ルーティング機能を使用する場合、EIGRP を使用するようにディストリビューション ルータおよびリモート ルータを設定し、さらにリモート ルータだけをスタブとして設定する必要があります。 指定されたルートのみが、リモート(スタブ)ルータから伝播されます。 スタブ ルータは、要約、接続ルート、再配布されたスタティック ルート、外部ルート、内部ルートに対するクエリーすべてに、「アクセスできない」メッセージで対応します。スタブとして設定されたルータは、すべての隣接ルータに特別なピア情報パケットを送信して、自身の状態をスタブ ルータとして報告します。

スタブ ルータの状態を通知するパケットを受信した隣接ルータは、ルートについてはスタブ ルータに照会しません。また、スタブ ピアを持つルータは、そのピアについては照会しません。 スタブ ルータは、ディストリビューション ルータを使用して適切なアップデートをすべてのピアに送信します。

図 3. 単純なハブ アンド スポーク ネットワーク.

次の図に単純なハブ アンド スポーク型設定を示します。



ルートがリモート ルータにアドバタイズされることを、スタブ ルーティング機能自体が回避することはありません。 図 1 の例では、リモート ルータはディストリビューション ルータだけを通じて企業ネットワークおよびインターネットにアクセスできます。 この例では、リモート ルータが完全なルート テーブルを保有しても機能面での意味はありません。これは、企業ネットワークとインターネットへのパスは常にディストリビューション ルータを経由するためです。 ルート テーブルが大きくなると、リモート ルータに必要なメモリ量が減るだけです。 帯域幅とメモリは、ディストリビューション ルータのルートを集約およびフィルタリングすることによって節約できます。 リモート ルータは、宛先に関係なく、ディストリビューション ルータにすべての非ローカル トラフィックを送信する必要があるため、他のネットワークから学習されたルートを受け取る必要がありません。 真のスタブ ネットワークが望ましい場合、ディストリビューション ルータがリモート ルータにデフォルト ルートだけを送信するように設定する必要があります。 EIGRP スタブ ルーティング機能では、ディストリビューション ルータでの集約を自動的にイネーブルにしません。 ほとんどの場合には、ネットワーク管理者がディストリビューション ルータ上で集約を設定する必要があります。

スタブ機能がない場合、ディストリビューション ルータからリモート ルータに送信されたルートがフィルタリングまたは集約された後でも、問題が発生することがあります。 企業ネットワーク内でルートが失われると、EIGRP はクエリーをディストリビューション ルータに送信することができます。ルートが集約されている場合でも、ディストリビューション ルータが代わりにリモート ルータにクエリーを送信します。 WAN リンクを介したディストリビューション ルータとリモート ルータ間の通信に問題がある場合、EIGRP Stuck In Active(SIA)状態が発生し、ネットワークのどこかで不安定になる可能性があります。 EIGRP スタブ ルーティング機能を使用することにより、ネットワーク管理者はリモート ルータへクエリーが送信されないようにできます。

EIGRP プロセスのルート ポリシー オプション

ルート ポリシーは、route-policy キーワードおよび end-policy キーワードで囲まれた一連のステートメントと式によって構成されます。 個別のコマンド(1 行に 1 つのコマンド)の集合ではなく、ルート ポリシー内のステートメントには相互に関連するコンテキストがあります。 そのため、個別のコマンドを各行に記すのではなく、各ポリシーまたはセットは独立した設定オブジェクトとして、1 つのユニットとして使用、入力、操作できます。

ポリシー設定の各行は論理サブユニットです。 thenelseend-policy キーワードの後ろには、少なくとも 1 つの新しい行を続ける必要があります。 パラメータ リストの閉じ括弧の後と、AS パス セット、コミュニティ セット、拡張コミュニティ セット、またはプレフィックス セット(EIGRP コンテキスト)への参照での名前ストリングの後にも、1 つの新しい行を続ける必要があります。 ルート ポリシーの定義またはプレフィックス セットの前には 1 行以上の新しい行を挿入する必要があります。 新しい行はポリシー式の論理ユニットの最後に記される必要があります。他の場所に記すことはできません。

これはルート ポリシーに EIGRP メトリックを設定するコマンドです。

RP/0/RSP0/CPU0:router(config-rpl)# set eigrp-metric bandwidth delay reliability loading mtu

これはルート ポリシーに EIGRP オフセット リスト機能を提供するコマンドです。

RP/0/RSP0/CPU0:router(config-rpl)# add eigrp-metric bandwidth delay reliability loading mtu  

EIGRP でルート ポリシーを使用できるのは、特定の EIGRP 付加ポイントにすべてのステートメントが適用できる場合に限られます。 ルート ポリシーを受け入れるコマンドを次に示します。

  • default-information allowed:match ステートメントが宛先に対して許可されます。 set ステートメントは許可されません。
  • route-policy:match ステートメントが宛先、ネクスト ホップ、およびタグに対して許可されます。 set ステートメントが eigrp-metric および tag に対して許可されます。
  • redistribute:match ステートメントが宛先、ネクスト ホップ、ソース プロトコル、タグ、およびルート タイプに対して許可されます。 set ステートメントが eigrp-metric および tag に対して許可されます。

タグ設定範囲は、内部ルートの場合は 0 ~ 255、外部ルートの場合は 0 ~ 4294967295 です。

EIGRP レイヤ 3 VPN PE-CE Site-of-Origin

EIGRP MPLS と IP VPN PE-CE Site-of-Origin(SoO)機能により、マルチプロトコル ラベル スイッチング(MPLS)および IP バーチャル プライベート ネットワーク(VPN)トラフィックを、EIGRP ネットワークに対してサイト単位でフィルタリングする機能が実現しました。 SoO フィルタリングはインターフェイス レベルで設定され、これを使用して MPLS および IP VPN トラフィックを管理し、複雑で複合的なネットワーク トポロジにおいて過渡的なルーティング ループが発生しないようにできます。

Site-of-Origin 拡張コミュニティでのルータの相互運用

SoO 拡張コミュニティの設定により、各ルータの発信元サイトを特定するこの機能に対応したルータが使用可能になります。 この機能が有効になっていると、PE または CE ルータ上の EIGRP ルーティング プロセスは、受信したそれぞれのルートを SoO 拡張コミュニティに対してチェックし、次の条件に基づいてフィルタリングします。

  • BGP または CE ルータから受信したルートに、受信インターフェイス上の SoO 値と一致する SoO 値が含まれている。
    • 受信したルートに関連付けられている SoO 値が、受信インターフェイスで設定されている SoO 値と一致している場合、そのルートは、別の PE ルータまたはバックドア リンクから学習されたものであるため、除外されます。 この動作は、ルーティング ループを回避するために設計されています。
  • CE ルータから受信したルートが、一致しない SoO 値を使用して設定されている。
    • 受信したルートの SoO 値が、受信インターフェイスで設定されている SoO 値と一致しない場合、そのルートは、BGP へ再配布されるように EIGRP トポロジ テーブルに受け入れられます。
    • ルートがすでに EIGRP トポロジ テーブルにインストールされているが、別の SoO 値が関連付けられている場合は、そのルートが BGP へ再配布されるときにトポロジ テーブルの SoO 値が使用されます。
  • CE ルータから受信したルートに、SoO 値が含まれていない。
    • 受信したルートに SoO 値がない場合、そのルートは EIGRP トポロジ テーブルに受け入れられます。ルートが BGP へ再配布される前に、ネクスト ホップ CE ルータに到達するために使用されるインターフェイスの SoO 値がそのルートに付加されます。
    SoO 拡張コミュニティをサポートする BGP および EIGRP ピアがこれらのルートを受信する場合には、関連付けられている SoO 値も受信します。次に、これらの値を、SoO 拡張コミュニティをサポートしている他の BGP および EIGRP ピアへ渡します。 このフィルタリングは、過渡的なルートが発信元サイトから再学習されないように、つまり過渡的なルーティング ループが発生しないようにする目的で設計されています。 BGP コスト コミュニティと EIGRP、BGP、および RIB を組み合わせて使用することで、バックドア リンクよりも MPLS VPN コアを介したパスが優先されます。 MPLS VPN、IP VPN、および SoO の設定については、『Cisco  ASR 9000 Series Aggregation Services Router MPLS Configuration Guide』の「Implementing MPLS Layer 3 VPNs」を参照してください。

キーチェーンを使用した EIGRP v4/v6 認証

キーチェーンを使用した EIGRP 認証により、インターフェイス単位で EIGRP プロトコル パケットを認証できる機能が導入されました。 EIGRP ルーティング認証は、1 つ以上のインターフェイスですべての EIGRP プロトコル トラフィックを Message Digest 5(MD5)認証に基づいて認証するメカニズムを提供します。

EIGRP ルーティング認証では Cisco IOS XR ソフトウェア セキュリティ キーチェーン インフラストラクチャを使用して秘密キーが格納および取得され、インターフェイス単位で着信トラフィックと発信トラフィックが認証されます。

EIGRP の実装方法

ここでは、次のタスクの手順について説明します。


(注)  


設定の変更を保存するには、システムでプロンプトが表示されたら、変更を確定する必要があります。


EIGRP ルーティングのイネーブル化

この作業では、EIGRP ルーティングをイネーブルにし、EIGRP ルーティング プロセスを確立します。

はじめる前に

IP アドレスを設定する前に EIGRP を設定できますが、1 つ以上の IP アドレスが設定されていない場合には EIGRP ルーティングは行われません。

手順の概要

    1.    configure

    2.    router eigrp as-number

    3.    address-family { ipv4 }

    4.    router-id id

    5.    default-metric bandwidth delay reliability loading mtu

    6.    distance internal-distance external-distance

    7.    interface type interface-path-id

    8.    holdtime seconds

    9.    bandwidth-percent percent

    10.    次のいずれかを実行します。

    • end
    • commit


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 configure


    例:
    RP/0/RSP0/CPU0:router# configure
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2 router eigrp as-number


    例:
    RP/0/RSP0/CPU0:router(config)# router eigrp 100
     

    ルーティング プロセスの自律システム番号を指定して、EIGRP ルーティング プロセスを設定します。

     
    ステップ 3 address-family { ipv4 }


    例:
    RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
     

    アドレス ファミリ コンフィギュレーション モードを開始します。

     
    ステップ 4 router-id id


    例:
    RP/0/RSP0/CPU0:router(config-eigrp)# router-id 172.20.1.1
     

    (任意)EIGRP プロセスのルータ ID を設定します。

    (注)     

    適切な方法は、router-id コマンドを使用して、ルータ ID に固有の 32 ビットの数値を明示的に指定することです。 この処理によって、インターフェイス アドレスの設定に関係なく、EIGRP が機能することが保証されます。

     
    ステップ 5 default-metric bandwidth delay reliability loading mtu


    例:
    RP/0/RSP0/CPU0:router(config-eigrp-af)# default-metric 1000 100 250 100 1500 
     

    (任意)EIGRP プロセスのメトリックを設定します。

     
    ステップ 6 distance internal-distance external-distance


    例:
    RP/0/RSP0/CPU0:router(config-eigrp-af)# distance 80 130
     

    (任意)2 つのアドミニストレーティブ ディスタンス(内部ディスタンスと外部ディスタンス)を使用できるようにします。これはあるノードへの適切なルートになります。

     
    ステップ 7 interface type interface-path-id


    例:
    RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
     

    EIGRP ルーティング プロトコルを実行するインターフェイスを定義します。

     
    ステップ 8 holdtime seconds


    例:
    RP/0/RSP0/CPU0:router(config-eigrp-af-if)# holdtime 30
     

    (任意)インターフェイスの保留時間を設定します。

    (注)     

    RP フェールオーバーでノンストップ フォワーディングが行われるようにするため、ネイバー数の増加に伴ってデフォルト値よりも長い保留時間を設定することを推奨します。 すべての VRF でのネイバーの数が 256 の場合、60 秒を推奨します。

     
    ステップ 9 bandwidth-percent percent


    例:
    RP/0/RSP0/CPU0:router(config-eigrp-af-if)# bandwidth-percent 75
     

    (任意)インターフェイス上で EIGRP が使用可能な帯域幅のパーセンテージを設定します。

     
    ステップ 10次のいずれかを実行します。
    • end
    • commit


    例:
    RP/0/RSP0/CPU0:router(config-eigrp-af-if)# end

    または

    RP/0/RSP0/CPU0:router(config-eigrp-af-if)# commit
     

    設定変更を保存します。

    • end コマンドを実行すると、変更をコミットするように要求されます。
        Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
      • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
      • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
      • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
    • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
     

    EIGRP プロセスのルート集約の設定

    この作業では、EIGRP プロセスのルート集約を設定します。

    指定したインターフェイスにサマリー集約アドレスを設定できます。 より具体的なアドレスがルーティング テーブルにある場合、EIGRP は、より具体的なルートの最小メトリックに等しいメトリックを持つインターフェイスからのサマリー アドレスをアドバタイズします。

    はじめる前に

    (注)  


    インターフェイスからのデフォルト ルート(0.0.0.0)を生成するときに、summary-address 集約コマンドは使用しないでください。 このコマンドを使用すると、アドミニストレーティブ ディスタンスが 5 で、ヌル 0 インターフェイスへの EIGRP サマリー デフォルト ルートが作成されます。 このデフォルト ルートのアドミニストレーティブ ディスタンスの値が小さいと、ルーティング テーブル内の他のネイバーから学習されたデフォルト ルートにこのルートが置き換えられてしまうことがあります。 ネイバーから学習したデフォルト ルートがサマリー デフォルト ルートと置き換えられてしまった場合や、デフォルト ルートとしてサマリー ルートしか存在しない場合、デフォルト ルートを宛先とするすべてのトラフィックはルータから発信されず、ヌル 0 インターフェイスへ送信されてドロップされてしまいます。

    所定のインターフェイスからのデフォルト ルートだけを送信するようにするには、route-policy コマンドを使用することを推奨します。


    手順の概要

      1.    configure

      2.    router eigrp as-number

      3.    address-family { ipv4 }

      4.    route-policy name out

      5.    interface type interface-path-id

      6.    summary-address ip-address { / length | mask } [ admin-distance ]

      7.    次のいずれかを実行します。

      • end
      • commit


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 configure


      例:
      RRP/0/RSP0/CPU0:router# configure
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2 router eigrp as-number


      例:
      RP/0/RSP0/CPU0:router(config)# router eigrp 100
       

      ルーティング プロセスの AS 番号を指定して、EIGRP ルーティング プロセスを設定します

       
      ステップ 3 address-family { ipv4 }


      例:
      RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
       

      アドレス ファミリのコンフィギュレーション モードを入力します。

       
      ステップ 4 route-policy name out


      例:
      RP/0/RSP0/CPU0:router(config-eigrp-af)# route-policy FILTER_DEFAULT out
       

      EIGRP ネイバーにアドバタイズされる更新または EIGRP ネイバーから受信する更新にルーティング ポリシーを適用します。

       
      ステップ 5 interface type interface-path-id


      例:
      RP/0/RSP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0 
       

      EIGRP ルーティング プロトコルを実行するインターフェイスを定義します。

       
      ステップ 6 summary-address ip-address { / length | mask } [ admin-distance ]


      例:
      RP/0/RSP0/CPU0:router(config-eigrp-af-if)# summary-address 192.168.0.0/16 95 
       

      指定された EIGRP インターフェイスのサマリー集約アドレスを設定します。

       
      ステップ 7次のいずれかを実行します。
      • end
      • commit


      例:
      RP/0/RSP0/CPU0:router(config-eigrp-af-if)# end

      または

      RP/0/RSP0/CPU0:router(config-eigrp-af-if)# commit
       

      設定変更を保存します。

      • end コマンドを実行すると、変更をコミットするように要求されます。
          Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
         
        • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
        • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
        • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
      • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
       

      EIGRP の再配布ルート

      ここでは、ルートの再配布、ルート数制限の適用、ノンストップ フォワーディングのタイマーの設定方法を説明します。

      手順の概要

        1.    configure

        2.    router eigrp as-number

        3.    address-family { ipv4 }

        4.    redistribute {{ bgp | connected | isis | ospf | rip | static } [ as-number ]} [ route-policy name ]

        5.    redistribute maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | [ warning-only ]]

        6.    timers nsf route-hold seconds

        7.    maximum paths maximum

        8.    maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | [ warning-only]]

        9.    次のいずれかを実行します。

        • end
        • commit


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 configure


        例:
        RP/0/RSP0/CPU0:router# configure
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2 router eigrp as-number


        例:
        RP/0/RSP0/CPU0:router(config)# router eigrp 100
         

        ルーティング プロセスの AS 番号を指定して、EIGRP ルーティング プロセスを設定します。

         
        ステップ 3 address-family { ipv4 }


        例:
        RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
         

        アドレス ファミリのコンフィギュレーション モードを入力します。

         
        ステップ 4 redistribute {{ bgp | connected | isis | ospf | rip | static } [ as-number ]} [ route-policy name ]


        例:
        RP/0/RSP0/CPU0:router(config-eigrp-af)# redistribute bgp 100
         

        指定されたプロトコルと AS 番号から EIGRP プロセスへルートを再配布します。 任意でルート ポリシーを指定して、EIGRP プロセスへの再配布されるルートをフィルタリングできます。

         
        ステップ 5 redistribute maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | [ warning-only ]]


        例:
        RP/0/RSP0/CPU0:router(config-eigrp-af)# redistribute maximum-prefix 5000 95 warning-only
         

        EIGRP プロセスに再配布されるプレフィックスの最大数を制限します。

         
        ステップ 6 timers nsf route-hold seconds


        例:
        RP/0/RSP0/CPU0:router(config-eigrp-af)# timers nsf route-hold 120
         

        NSF 対応 EIGRP ルータが非アクティブ ピアのルートを維持する時間を決定するタイマーを設定します。

         
        ステップ 7 maximum paths maximum


        例:
        RP/0/RSP0/CPU0:router(config-eigrp-af)# maximum paths 10
         

        EIGRP がサポートできる並列ルートの最大数を制御します。

         
        ステップ 8 maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | [ warning-only]]


        例:
        RP/0/RSP0/CPU0:router(config-eigrp-af)# maximum-prefix 50000
         

        EIGRP がアドレス ファミリで受け入れるプレフィックス数を制限します。

         
        ステップ 9次のいずれかを実行します。
        • end
        • commit


        例:
        RP/0/RSP0/CPU0:router(config-eigrp-af)# end

        または

        RP/0/RSP0/CPU0:router(config-eigrp-af)# commit
         

        設定変更を保存します。

        • end コマンドを実行すると、変更をコミットするように要求されます。
            Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
          • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
          • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
          • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
        • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
         

        ルート ポリシーの作成と EIGRP プロセスへのアタッチ

        ここでは、ルート ポリシーを定義し、EIGRP プロセスにアタッチする方法について説明します。

        ルート ポリシーの定義は、route-policy コマンドと name 引数、その後に続く一連のオプションのポリシー ステートメントで構成され、end-policy コマンドで閉じられます。

        ルート ポリシーはルーティング プロトコルのルートに適用されてはじめて役に立ちます。

        手順の概要

          1.    configure

          2.    route-policy name

          3.    set eigrp-metric bandwidth delay reliability load mtu

          4.    end-policy

          5.    次のいずれかを実行します。

          • end
          • commit

          6.    configure

          7.    router eigrp as-number

          8.    address-family { ipv4 }

          9.    route-policy route-policy-name { in | out }

          10.    次のいずれかを実行します。

          • end
          • commit


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 configure


          例:
          RP/0/RSP0/CPU0:router# configure
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2 route-policy name


          例:
          RP/0/RSP0/CPU0:router(config)# route-policy IN-IPv4
           

          ルート ポリシーを定義して、ルート ポリシー コンフィギュレーション モードを開始します。

           
          ステップ 3 set eigrp-metric bandwidth delay reliability load mtu


          例:
          RP/0/RSP0/CPU0:router(config-rpl)# set eigrp metric 42 100 200 100 1200
           

          (任意)EIGRP メトリック属性を設定します。

           
          ステップ 4 end-policy


          例:
          RP/0/RSP0/CPU0:router(config-rpl)# end-policy
           

          ルート ポリシーの定義を終了して、ルート ポリシー コンフィギュレーション モードを終了します。

           
          ステップ 5次のいずれかを実行します。
          • end
          • commit


          例:
          RP/0/RSP0/CPU0:router(config-rpl)# end

          または

          RP/0/RSP0/CPU0:router(config-rpl)# commit
           

          設定変更を保存します。

          • end コマンドを実行すると、変更をコミットするように要求されます。
              Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
              
            • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
            • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
            • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
          • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
           
          ステップ 6 configure


          例:
          RP/0/RSP0/CPU0:router
          
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 7 router eigrp as-number


          例:
          RP/0/RSP0/CPU0:router(config)# router eigrp 100
           

          ルーティング プロセスの自律システム番号を指定して、EIGRP ルーティング プロセスを設定します。

           
          ステップ 8 address-family { ipv4 }


          例:
          RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
           

          アドレス ファミリ コンフィギュレーション モードを開始します。

           
          ステップ 9 route-policy route-policy-name { in | out }


          例:
          RP/0/RSP0/CPU0:router(config-eigrp-af)# route-policy IN-IPv4 in
           

          EIGRP ネイバーにアドバタイズされる更新または EIGRP ネイバーから受信する更新にルーティング ポリシーを適用します。

           
          ステップ 10次のいずれかを実行します。
          • end
          • commit


          例:
          RP/0/RSP0/CPU0:router(config-eigrp-af)# end

          または

          RP/0/RSP0/CPU0:router(config-eigrp-af)# commit
           

          設定変更を保存します。

          • end コマンドを実行すると、変更をコミットするように要求されます。
              Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
            • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
            • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
            • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
          • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
           

          EIGRP プロセスのスタブ ルーティングの設定

          ここでは、スタブ ルーティングに EIGRP プロセスを使用するようにディストリビューション ルータおよびリモート ルータを設定します。

          はじめる前に

          (注)  


          EIGRP スタブ ルーティングは、リモート ルータ上でだけ使用してください。 スタブ ルータは、コア中継トラフィックが通過しないネットワーク コアまたはディストリビューション レイヤに接続されたルータとして定義されます。 スタブ ルータがディストリビューション ルータ以外の EIGRP ネイバーを持つことはできません。 この制約事項を無視すると、望ましくない動作が発生します。


          手順の概要

            1.    configure

            2.    router eigrp as-number

            3.    address-family { ipv4 }

            4.    stub [ receive-only | {[ connected ] [ redistributed ] [ static ] [ summary ]}]

            5.    次のいずれかを実行します。

            • end
            • commit

            6.    show eigrp [ ipv4 ] [ vrf { vrf-name | all }] neighbors [ as-number ] [ detail ] [ type interface-path-id | static ]


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 configure


            例:
            RRP/0/RSP0/CPU0:router# configure
             

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 2 router eigrp as-number


            例:
            RP/0/RSP0/CPU0:router(config)# router eigrp 100
             

            ルーティング プロセスの自律システム番号を指定して、EIGRP ルーティング プロセスを設定します。

             
            ステップ 3 address-family { ipv4 }


            例:
            RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
             

            アドレス ファミリ コンフィギュレーション モードを開始します。

             
            ステップ 4 stub [ receive-only | {[ connected ] [ redistributed ] [ static ] [ summary ]}]


            例:
            RP/0/RSP0/CPU0:router(config-eigrp-af)# stub receive-only 
             

            ルータを EIGRP のスタブとして設定します。

             
            ステップ 5次のいずれかを実行します。
            • end
            • commit


            例:
            RP/0/RSP0/CPU0:router(config-eigrp-af)# end

            または

            RP/0/RSP0/CPU0:router(config-eigrp-af)# commit
             

            設定変更を保存します。

            • end コマンドを実行すると、変更をコミットするように要求されます。
                Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
                
                
              • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
              • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
              • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
            • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
             
            ステップ 6 show eigrp [ ipv4 ] [ vrf { vrf-name | all }] neighbors [ as-number ] [ detail ] [ type interface-path-id | static ]


            例:
            RP/0/RSP0/CPU0:router# show eigrp neighbors detail
             

            EIGRP のスタブ ルータとしてリモート ルータが設定されていることを確認します。

            出力の最後の行は、リモート ルータまたはスポーク ルータのスタブ ステータスを示します。

             

            PE-CE プロトコルとしての EIGRP の設定

            プロバイダー エッジ(PE)で EIGRP を設定し、EIGRP を使用したプロバイダー エッジからカスタマー エッジ(PE-CE)への通信を確立するには、次の作業を実行します。

            手順の概要

              1.    configure

              2.    router eigrp as-number

              3.    vrf vrf-name

              4.    address-family { ipv4 }

              5.    router-id router-id

              6.    autonomous-system as-number

              7.    redistribute {{ bgp | connected | isis | ospf | ospfv3 | rip | static } [ as-number | instance-name ]} [ route-policy name ]

              8.    interface type interface-path-id

              9.    site-of-origin { as-number:number | ip-address : number }

              10.    次のいずれかを実行します。

              • end
              • commit


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 configure


              例:
              RP/0/RSP0/CPU0:router# configure
               

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2 router eigrp as-number


              例:
              RP/0/RSP0/CPU0:router(config)# router eigrp 100
               

              ルーティング プロセスの自律システム番号を指定して、EIGRP ルーティング プロセスを設定します

               
              ステップ 3 vrf vrf-name


              例:
              RP/0/RSP0/CPU0:router(config-eigrp)# vrf vrf_A
               

              VPN ルーティングおよび転送(VRF)インスタンスを設定します。

               
              ステップ 4 address-family { ipv4 }


              例:
              RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
               

              VRF アドレス ファミリ コンフィギュレーション モードを開始します。

               
              ステップ 5 router-id router-id


              例:
              RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# router-id 33
               

              EIGRP プロセスのルータ ID を設定します。

               
              ステップ 6 autonomous-system as-number


              例:
              RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# autonomous-system 2
               

              VRF インスタンス内で実行する EIGRP ルーティング プロセスを設定します。

              (注)     

              VRF インターフェイスを起動するために、VRF 設定の中で自律システムを設定する必要があります。

               
              ステップ 7 redistribute {{ bgp | connected | isis | ospf | ospfv3 | rip | static } [ as-number | instance-name ]} [ route-policy name ]


              例:
              RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# redistribute bgp 100
               

              1 つのルーティング ドメインから EIGRP にルートを注入します。

               
              ステップ 8 interface type interface-path-id


              例:
              RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# interface gigabitEthernet 0/1/5/0
               

              ルーティング プロトコルが実行される EIGRP のインターフェイスを設定します。

               
              ステップ 9 site-of-origin { as-number:number | ip-address : number }


              例:
              RP/0/RSP0/CPU0:router(config-eigrp-vrf-af-if)# site-of-origin 3:4
               

              EIGRP インターフェイスに site-of-origin(SoO)フィルタリングを設定します。

               
              ステップ 10次のいずれかを実行します。
              • end
              • commit


              例:
              RP/0/RSP0/CPU0:router(config-eigrp-vrf-af-if)# end

              または

              RP/0/RSP0/CPU0:router(config-eigrp-vrf-af-if)# commit
               

              設定変更を保存します。

              • end コマンドを実行すると、変更をコミットするように要求されます。
                  Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
                  
                  
                • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
              • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
               

              BGP ルートの EIGRP への再配布

              BGP ルートを EIGRP に再配布するには、次の作業を実行します。

              通常 EIGRP ルートは、ルートに付加された拡張コミュニティ情報を伴って BGP に再配布されます。 BGP は VPN バックボーン上で、BGP 拡張コミュニティ属性内にエンコードされた EIGRP 固有情報と共にルートを伝送します。 ピアリング カスタマー サイトがルートを受信した後に、EIGRP は BGP ルートを再配布し、BGP 拡張コミュニティ情報を抽出して元のカスタマー サイトと同じルートを再構築します。

              BGP ルートを EIGRP に再配布する場合、受信側のプロバイダー エッジ(PE)EIGRP ルータは BGP 拡張コミュニティ情報を探します。 この情報を受信した場合、元の EIGRP ルートを再構築するためにその情報が使用されます。 情報がない場合、EIGRP は設定されたデフォルトのメトリック値を使用します。

              メトリック値が BGP 拡張コミュニティから得られず、デフォルトのメトリックも設定されていない場合には、PE EIGRP によるカスタマー エッジ(CE)ルータへのルートのアドバタイズは行われません。 BGP が BGP に再配布されるときには、メトリックが拡張コミュニティとして BGP プレフィックスに追加されない場合があります(EIGRP が相手ルータで実行されていない場合など)。 この場合、EIGRP は「no-metrics」オプションを伴って BGP に再配布されます。

              手順の概要

                1.    configure

                2.    router eigrp as-number

                3.    vrf vrf-name

                4.    address-family { ipv4 }

                5.    redistribute {{ bgp | connected | isis | ospf | ospfv3 | rip | static } [ as-number | instance-name ]} [ route-policy name ]

                6.    route-policy route-policy-name { in | out }

                7.    default-metric bandwidth delay reliability loading mtu

                8.    次のいずれかを実行します。

                • end
                • commit


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1 configure


                例:
                RP/0/RSP0/CPU0:router# configure
                 

                グローバル コンフィギュレーション モードを開始します。

                 
                ステップ 2 router eigrp as-number


                例:
                RP/0/RSP0/CPU0:router(config)# router eigrp 100
                 

                ルーティング プロセスの自律システム番号を指定して、EIGRP ルーティング プロセスを設定します。

                 
                ステップ 3 vrf vrf-name


                例:
                RP/0/RSP0/CPU0:router(config-eigrp)# router eigrp 100
                 

                VRF インスタンスを設定します。

                 
                ステップ 4 address-family { ipv4 }


                例:
                RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
                 

                VRF アドレス ファミリ コンフィギュレーション モードを開始します。

                 
                ステップ 5 redistribute {{ bgp | connected | isis | ospf | ospfv3 | rip | static } [ as-number | instance-name ]} [ route-policy name ]


                例:
                RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# redistribute bgp 100
                 

                1 つのルーティング ドメインから EIGRP にルートを注入します。

                 
                ステップ 6 route-policy route-policy-name { in | out }


                例:
                RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# route-policy policy_A in
                 

                EIGRP ネイバーにアドバタイズされる更新または EIGRP ネイバーから受信する更新にルーティング ポリシーを適用します。

                 
                ステップ 7 default-metric bandwidth delay reliability loading mtu


                例:
                RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# default-metric 1000 100 250 100 1500
                 

                EIGRP のメトリックを設定します。

                 
                ステップ 8次のいずれかを実行します。
                • end
                • commit


                例:
                RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# end

                または

                RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)# commit
                 

                設定変更を保存します。

                • end コマンドを実行すると、変更をコミットするように要求されます。
                    Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
                  • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                  • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                  • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                 

                EIGRP ルーティングのモニタリング

                この項のコマンドは、ネイバーとの隣接関係に関する変更のロギング、ルーティング システムの安定性の監視、および問題の検出に使用します。

                手順の概要

                  1.    configure

                  2.    router eigrp as-number

                  3.    address-family [ ipv4 ]

                  4.    log-neighbor-changes

                  5.    log-neighbor-warnings

                  6.    次のいずれかを実行します。

                  • end
                  • commit

                  7.    clear eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] neighbors [ ip-address | type interface-path-id ]

                  8.    clear eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] topology [ prefix mask ] [ prefix / length ]

                  9.    show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] accounting

                  10.    show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] interfaces [ type interface-path-id ] [ detail ]

                  11.    show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] neighbors [ detail ] [ type interface-path-id | static ]

                  12.    show protocols eigrp [ vrf vrf-name ]

                  13.    show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] topology [ ip-address mask ] [ active | all-links | detail-links | pending | summary | zero-successors ]

                  14.    show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] traffic


                手順の詳細
                   コマンドまたはアクション目的
                  ステップ 1 configure


                  例:
                  RP/0/RSP0/CPU0:router# configure
                   

                  グローバル コンフィギュレーション モードを開始します。

                   
                  ステップ 2 router eigrp as-number


                  例:
                  RP/0/RSP0/CPU0:router(config)# router eigrp 100
                   

                  ルーティング プロセスの自律システム番号を指定して、EIGRP ルーティング プロセスを設定します。

                   
                  ステップ 3 address-family [ ipv4 ]


                  例:
                  RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
                  
                   

                  アドレス ファミリ コンフィギュレーション モードを開始します。

                   
                  ステップ 4 log-neighbor-changes


                  例:
                  RP/0/RSP0/CPU0:router(config-eigrp-af)# log-neighbor-changes
                   

                  EIGRP ネイバーとの隣接関係に関する変更のロギングをイネーブルにします。

                   
                  ステップ 5 log-neighbor-warnings


                  例:
                  RP/0/RSP0/CPU0:router(config-eigrp-af)# log-neighbor-warnings
                   

                  EIGRP ネイバーの警告メッセージのロギングをイネーブルにします。

                   
                  ステップ 6次のいずれかを実行します。
                  • end
                  • commit


                  例:
                  RP/0/RSP0/CPU0:router(config-eigrp-af)# end

                  または

                  RP/0/RSP0/CPU0:router(config-eigrp-af)# commit
                   

                  設定変更を保存します。

                  • end コマンドを実行すると、変更をコミットするように要求されます。
                      Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
                    • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                    • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                    • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                  • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                   
                  ステップ 7 clear eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] neighbors [ ip-address | type interface-path-id ]


                  例:
                  RP/0/RSP0/CPU0:routerr# clear eigrp 20 neighbors GigabitEthernet 0/1/0/0
                   

                  EIGRP および VPN ネイバー エントリを適切なテーブルから削除します。

                   
                  ステップ 8 clear eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] topology [ prefix mask ] [ prefix / length ]


                  例:
                  RP/0/RSP0/CPU0:router# clear eigrp topology
                   

                  EIGRP および VRF トポロジ エントリを適切なタブから削除します。

                   
                  ステップ 9 show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] accounting


                  例:
                  RP/0/RSP0/CPU0:router# show eigrp vrf all accounting
                   

                  EIGRP プロセスのプレフィックス アカウンティング情報を表示します。

                   
                  ステップ 10 show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] interfaces [ type interface-path-id ] [ detail ]


                  例:
                  RP/0/RSP0/CPU0:router# show eigrp interfaces detail
                   

                  EIGRP に設定されているインターフェイスに関する情報を表示します。

                   
                  ステップ 11 show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] neighbors [ detail ] [ type interface-path-id | static ]


                  例:
                  RP/0/RSP0/CPU0:router# show eigrp neighbors 20 detail static
                   

                  EIGRP によって検出されたネイバーを表示します。

                   
                  ステップ 12 show protocols eigrp [ vrf vrf-name ]


                  例:
                  RP/0/RSP0/CPU0:router# show protocols eigrp
                   

                  EIGRP プロセスのコンフィギュレーションに関する情報を表示します。

                   
                  ステップ 13 show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] topology [ ip-address mask ] [ active | all-links | detail-links | pending | summary | zero-successors ]


                  例:
                  RP/0/RSP0/CPU0:router# show eigrp topology 10.0.0.1 253.254.255.255 summary
                   

                  EIGRP トポロジ テーブル内のエントリを表示します。

                   
                  ステップ 14 show eigrp [ as-number ] [ vrf { vrf | all }] [ ipv4 ] traffic


                  例:
                  RP/0/RSP0/CPU0:router# show eigrp traffic
                   

                  送受信された EIGRP パケットの数を表示します。

                   

                  EIGRP 認証キーチェーンの設定

                  EIGRP インターフェイスで認証キーチェーンを設定するには、次の作業を実行します。

                  デフォルトの VRF での IPv4/IPv6 インターフェイスの認証キーチェーンの設定

                  デフォルトの VRF で IPv4/IPv6 インターフェイスの認証キーチェーンを設定するには、次の作業を実行します。

                  手順の概要

                    1.    configure

                    2.    router eigrp as-number

                    3.    address-family { ipv4 | ipv6 }

                    4.    interface type interface-path-id

                    5.    authentication keychain keychain-name

                    6.    次のいずれかを実行します。

                    • end
                    • commit


                  手順の詳細
                     コマンドまたはアクション目的
                    ステップ 1 configure


                    例:
                    RP/0/RSP0/CPU0:router# configure
                     

                    グローバル コンフィギュレーション モードを開始します。

                     
                    ステップ 2 router eigrp as-number


                    例:
                    RP/0/RSP0/CPU0:router(config)# router eigrp 100
                     

                    ルーティング プロセスの自律システム番号を指定して、EIGRP ルーティング プロセスを設定します。

                     
                    ステップ 3 address-family { ipv4 | ipv6 }


                    例:
                    RP/0/RSP0/CPU0:router(config-eigrp)# address-family ipv4
                     

                    VRF アドレス ファミリ コンフィギュレーション モードを開始します。

                     
                    ステップ 4 interface type interface-path-id


                    例:
                    RP/0/RSP0/CPU0:router(config-eigrp-af)#
                      interface gigabitEthernet 0/1/5/0
                      
                     

                    ルーティング プロトコルが実行される EIGRP のインターフェイスを設定します。

                     
                    ステップ 5 authentication keychain keychain-name


                    例:
                    RP/0/RSP0/CPU0:router(config-eigrp-af-if)# authentication keychain
                     

                    MD5 アルゴリズムに基づいて、インターフェイス上のすべての EIGRP プロトコル トラフィックを認証します。

                     
                    ステップ 6次のいずれかを実行します。
                    • end
                    • commit


                    例:
                    RP/0/RSP0/CPU0:router(config-eigrp-vrf-af-if)#end

                    または

                    RP/0/RSP0/CPU0:router(config-eigrp-vrf-af-if)#commit
                     

                    設定変更を保存します。

                    • end コマンドを実行すると、変更をコミットするように要求されます。
                        Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
                      
                      • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                      • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                      • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                    • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                     

                    デフォルト以外の VRF での IPv4/IPv6 インターフェイスの認証キーチェーンの設定

                    デフォルト以外の VRF で IPv4/IPv6 インターフェイスの認証キーチェーンを設定するには、次の作業を実行します。

                    手順の概要

                      1.    configure

                      2.    router eigrp as-number

                      3.    vrf vrf-name

                      4.    address-family { ipv4 | ipv6 }

                      5.    interface type interface-path-id

                      6.    authentication keychain keychain-name

                      7.    次のいずれかを実行します。

                      • end
                      • commit


                    手順の詳細
                       コマンドまたはアクション目的
                      ステップ 1 configure


                      例:
                      RP/0/RSP0/CPU0:router# configure
                       

                      グローバル コンフィギュレーション モードを開始します。

                       
                      ステップ 2 router eigrp as-number


                      例:
                      RP/0/RSP0/CPU0:router(config)# router eigrp 100
                       

                      ルーティング プロセスの自律システム番号を指定して、EIGRP ルーティング プロセスを設定します。

                       
                      ステップ 3 vrf vrf-name


                      例:
                      RP/0/RSP0/CPU0:router(config-eigrp)# vrf vrf1
                       

                      VRF インスタンスを作成し、VRF コンフィギュレーション モードを開始します。

                       
                      ステップ 4 address-family { ipv4 | ipv6 }


                      例:
                      RP/0/RSP0/CPU0:router(config-eigrp-vrf)# address-family ipv4
                       

                      VRF アドレス ファミリ コンフィギュレーション モードを開始します。

                       
                      ステップ 5 interface type interface-path-id


                      例:
                      RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)#
                        interface gigabitEthernet 0/1/5/0
                        
                       

                      EIGRP が実行されるインターフェイスを設定します。

                       
                      ステップ 6 authentication keychain keychain-name


                      例:
                      RP/0/RSP0/CPU0:router(config-eigrp-vrf-af-if)# authentication keychain
                       

                      MD5 アルゴリズムに基づいて、インターフェイス上のすべての EIGRP プロトコル トラフィックを認証します。

                       
                      ステップ 7次のいずれかを実行します。
                      • end
                      • commit


                      例:
                      RP/0/RSP0/CPU0:router(config-eigrp-vrf-af-if)#end

                      または

                      RP/0/RSP0/CPU0:router(config-eigrp-vrf-af-if)#commit
                       

                      設定変更を保存します。

                      • end コマンドを実行すると、変更をコミットするように要求されます。
                          Uncommitted changes found, commit them before exiting(yes/no/cancel)?[cancel]:
                        
                        • yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。
                        • no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。
                        • cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。
                      • 実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。
                       

                      EIGRP の実装の設定例

                      ここでは、次の設定例について説明します。

                      基本的な EIGRP 実装の設定:例

                      次に、受信ルートをフィルタリングするポリシーを含む EIGRP を設定する例を示します。 これは、ネイバーが 1 つだけであるが、接続された他のサブネットをアドバタイズするルータの一般的な設定です。

                        router eigrp 144
                          address-family ipv4
                            metric maximum-hops 20 
                            router-id 10.10.9.4 
                            route-policy GLOBAL_FILTER_POLICY in
                            log-neighbor-changes 
                            log-neighbor-warnings 
                            interface Loopback0
                            !
                            interface GigabitEthernet 0/2/0/0
                              passive-interface 
                            !
                            interface GigabitEthernet 0/6/0/0
                              hello-interval 8 
                              hold-time 30 
                              summary-address 10.0.0.0 255.255.0.0 
                              !

                      EIGRP スタブ動作の設定:例

                      次に、EIGRP スタブを設定する例を示します。 スタブ動作では、接続されたスタティックなサマリー ルートのみをネイバーにアドバタイズできます。

                        router eigrp 200
                          address-family ipv4
                            stub connected static summary 
                            router-id 172.16.82.22 
                            log-neighbor-changes 
                            log-neighbor-warnings 
                            redistribute connected route-policy CONN_POLICY 
                            interface GigabitEthernet0/6/0/0
                              passive-interface 
                              neighbor 10.0.0.31
                            !
                            interface GigabitEthernet0/6/0/1
                              passive-interface 
                              neighbor 10.0.1.21
                              !
                            !
                          !
                        

                      プレフィックス制限のある EIGRP PE-CE 構成の設定:例

                      次に、PE-CE プロトコルとして動作するように PE ルータ上で EIGRP を設定する例を示します。 この設定は VRF CUSTOMER_1 の下にあります。 最大プレフィックスは一般的に、1 組のカスタマー ルートによって EIGRP プロセスが過負荷にならないようにするために設定します。

                        router eigrp 500
                          vrf CUSTOMER_1
                            address-family ipv4
                              timers nsf route-hold 300 
                              router-id 172.16.6.11 
                              maximum-prefix 450 70 
                              default-metric 200000 10000 195 10 1500 
                              log-neighbor-changes 
                              log-neighbor-warnings 
                              redistribute maximum-prefix 350 70 
                              redistribute bgp 1.65500 route-policy SITE_1_POLICY 
                              interface GigabitEthernet 0/4/0/5
                              neighbor 10.22.1.1 
                              !
                            !
                          !
                        

                      EIGRP 認証キーチェーンの設定:例

                      次に、デフォルト以外の VRF で IPv4 インターフェイスの認証キーチェーンを設定する例を示します。

                      RP/0/RSP0/CPU0:router(config)#router eigrp 100
                      RP/0/RSP0/CPU0:router(config-eigrp)#vrf vrf1
                      RP/0/RSP0/CPU0:router(config-eigrp-vrf)#address-family ipv4 
                      RP/0/RSP0/CPU0:router(config-eigrp-vrf-af)#interface POS 0/1/0/0
                      RP/0/RSP0/CPU0:router(config-eigrp-vrf-af-if)#authentication keychain key1
                      
                      

                      次に、デフォルトの VRF で IPv6 インターフェイスの認証キーチェーンを設定する例を示します。

                      RP/0/RSP0/CPU0:router(config)#router eigrp 100
                      RP/0/RSP0/CPU0:router(config-eigrp)#address-family ipv6
                      RP/0/RSP0/CPU0:router(config-eigrp-af)#interface POS 0/1/0/0
                      RP/0/RSP0/CPU0:router(config-eigrp-af-if)#authentication keychain key2
                      
                      

                      その他の参考資料

                      ここでは、EIGRP の実装に関する参考資料について説明します。

                      関連資料

                      関連項目

                      参照先

                      EIGRP コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

                      『Cisco ASR 9000 Series Aggregation Services Router Routing Command Reference』

                      EIGRP 機能向けの MPLS VPN のサポート情報

                      『Cisco ASR 9000 Series Aggregation Services Router MPLS Configuration Guide』の「Implementing MPLS Layer 3 VPNs」モジュールおよび「Implementing MPLS Layer 2 VPNs」モジュール

                      EIGRP 機能向けの Site of Origin(SoO)のサポート情報

                      『Cisco ASR 9000 Series Aggregation Services Router MPLS Configuration Guide』の「Implementing MPLS Traffic Engineering on Cisco ASR 9000 シリーズ ルータ 」モジュール

                      MIB リファレンス

                      『Cisco ASR 9000 Series Aggregation Services Router MIB Specification Guide』

                      標準

                      標準

                      タイトル

                      この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

                      MIB

                      MIB

                      MIB のリンク

                      Cisco IOS XR ソフトウェアを使用して MIB の場所を特定してダウンロードするには、次の URL にある Cisco MIB Locator を使用して、[Cisco Access Products] メニューからプラットフォームを選択します。 http:/​/​cisco.com/​public/​sw-center/​netmgmt/​cmtk/​mibs.shtml

                      RFC

                      RFC

                      タイトル

                      この機能がサポートする新しい RFC または変更された RFC はありません。また、この機能は既存の規格に対するサポートに影響を及ぼしません。

                      シスコのテクニカル サポート

                      説明

                      リンク

                      シスコのテクニカル サポート Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。 Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

                      http:/​/​www.cisco.com/​techsupport