Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ モジュラ Quality of Service コンフィギュレーション ガイド Release 4.2
Cisco ASR 9000 シリーズ ルータでのモジュラ QoS サービス パケットの分類およびマーキングの設定
Cisco ASR 9000 シリーズ ルータでのモジュラ QoS サービス パケットの分類およびマーキングの設定
発行日;2012/07/10 | 英語版ドキュメント(2012/03/18 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

Cisco ASR 9000 シリーズ ルータでのモジュラ QoS サービス パケットの分類およびマーキングの設定

内容

でのモジュラ QoS パケット分類とマーキングの設定のための前提条件

でのモジュラ QoS パケット分類とマーキングの設定に関する情報

パケット分類の概要

トラフィック クラスの要素

トラフィック ポリシーの要素

デフォルト トラフィック クラス

バンドル トラフィック ポリシー

共有ポリシー インスタンス

ポリシーの継承

ポート シェーピング ポリシー

クラスベース無条件パケット マーキングの機能と利点

IP precedence によるパケットの CoS の指定

パケットの分類に使用する IP precedence ビット

IP precedence 値の設定

DEI に基づく分類

デフォルト DEI マーキング

IP precedence と IP DSCP マーキングの比較

In-Place ポリシーの変更

In-Place ポリシーの変更を引き起こす可能性のある変更

In-Place ポリシー変更に関する推奨事項

ボーダー ゲートウェイ プロトコルを使用した QoS ポリシー伝搬

でのモジュラ QoS パケットの分類とマーキングの設定例

トラフィック クラスの作成

制約事項

トラフィック ポリシーの作成

トラフィック ポリシーのインターフェイスへの付加

前提条件

制約事項

共有ポリシー インスタンスの設定

複数のサブインターフェイスへの共有ポリシー インスタンスの付加

前提条件

制約事項

バンドル インターフェイスまたは EFP バンドルへの共有ポリシー インスタンスの付加

前提条件

制約事項

クラスベース無条件パケット マーキングの設定

ボーダー ゲートウェイ プロトコルを使用した QoS ポリシー伝搬の設定

BGP を使用したポリシー伝搬の設定のタスク リスト

タスクの概要

ルート ポリシーの定義

前提条件

Cisco ASR 9000 シリーズ ルータでのモジュラ QoS サービス パケットの分類およびマーキングの設定

パケット分類は(パケットの)トラフィック フローを特定し、データ パスでの輻輳管理または輻輳回避を必要とするトラフィック フローをマーキングで特定します。分類する必要のあるトラフィック フローを定義するには、モジュラ Quality of Service(QoS)コマンドライン インターフェイス(MQC)を使用します。各トラフィック フローを サービス クラス または クラス と呼びます。その後、トラフィック ポリシーを作成し、クラスに適用します。定義されたクラスに該当しないトラフィックは、すべてデフォルト クラスのカテゴリに分類されます。

このモジュールでは、QoS パケット分類の概念および設定情報について説明します。

ラインカード、SIP および SPA のサポート

機能
ASR 9000 イーサネット ラインカード
ASR 9000 用 SIP 700

DEI に基づく分類

Yes

No

クラスベースの無条件パケット マーキング

Yes

Yes

In-Place ポリシーの変更

Yes

Yes

IPv6 QoS

Yes

Yes

パケットの分類とマーキング

Yes

Yes

ポリシーの継承

Yes

Yes

ポート シェーピング ポリシー

Yes

No

共有ポリシー インスタンス

Yes

No

Cisco ASR 9000 シリーズ ルータでのモジュラ QoS パケット分類とマーキングの設定機能の履歴

 

リリース
変更箇所

リリース 3.7.2

クラスベース無条件パケット マーキング機能が、ASR 9000 イーサネット ラインカードに導入されました。

IPv6 QoS 機能が、ASR 9000 イーサネット ラインカードに導入されました。(IPv6 ACL に対する QoS の照合はサポートされていません)。

パケットの分類とマーキング機能が、ASR 9000 イーサネット ラインカードに導入されました。

リリース 3.9.0

クラスベース無条件パケット マーキング機能が、ASR 9000 用 SIP 700 でサポートされました。

パケットの分類とマーキング機能が、ASR 9000 用 SIP 700 でサポートされました。

ポリシーの継承機能が、ASR 9000 イーサネット ラインカードと ASR 9000 用 SIP 700 に導入されました。

共有ポリシー インスタンス機能が、ASR 9000 イーサネット ラインカードに導入されました。

リリース 4.0

DEI 機能に基づく分類機能が、ASR 9000 イーサネット ラインカードに導入されました。

In-Place ポリシーの変更機能は、ASR 9000 イーサネット ラインカードと ASR 9000 用 SIP 700 に導入されました。

IPv6 QoS 機能が、ASR 9000 用 SIP 700 でサポートされました。

同じクラスのポリサー アクションの一部として、スタンドアロン マーキング アクションが 3 つ、マーキング アクションが 3 つ、ASR 9000 用 SIP 700 に追加されました。(ASR 9000 イーサネット ラインカードでは、同じクラスのポリサー アクションの一部として、スタンドアロン マーキング アクションを 2 つ、マーキング アクションを 2 つサポートしています)。

リリース 4.0.1

ポート シェーピング ポリシー機能のサポートが、ASR 9000 イーサネット ラインカードに導入されました。

リリース 4.2.0

BGP による QoS 機能に基づくポリシー伝搬が導入されました。

Cisco ASR 9000 シリーズ ルータでのモジュラ QoS パケット分類とマーキングの設定のための前提条件

ネットワークでモジュラ QoS パケット分類とマーキングを設定するには、次の前提条件が必要です。

適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。

Cisco IOS XRQoS 設定の作業と概念に関する知識が必要です。

Cisco ASR 9000 シリーズ ルータでのモジュラ QoS パケット分類とマーキングの設定に関する情報

このマニュアルの QoS パケット分類機能を設定するには、次の概念を理解している必要があります。

「パケット分類の概要」

「トラフィック クラスの要素」

「トラフィック ポリシーの要素」

「デフォルト トラフィック クラス」

「バンドル トラフィック ポリシー」

「共有ポリシー インスタンス」

「ポート シェーピング ポリシー」

「クラスベース無条件パケット マーキングの機能と利点」

「IP precedence と IP DSCP マーキングの比較」

「IP precedence によるパケットの CoS の指定」

「DEI に基づく分類」

「In-Place ポリシーの変更」

パケット分類の概要

パケットの分類には、特定のグループ(またはクラス)内のパケットを分類し、これにトラフィック記述子を割り当てて、ネットワークで QoS 処理用にアクセスできるようにする処理が含まれます。トラフィック記述子には、パケットが受ける転送処理(Quality of Service)に関する情報が含まれます。パケット分類を使用すると、複数のプライオリティ レベルまたは CoS にネットワーク トラフィックを区分できます。発信元が契約された条項に従うことに同意し、ネットワークが QoS の実行を約束します。トラフィック ポリサーとトラフィック シェーパーは、契約を順守するために、パケットのトラフィック記述子を使用します。

トラフィック ポリサーおよびトラフィック シェーパーは、IP precedence などのパケット分類機能を使用して、さまざまなタイプの QoS サービスに対して、ルータを通過するパケット(またはトラフィック フロー)を選択します。たとえば、IP パケット ヘッダーのタイプ オブ サービス(ToS)フィールドの 3 つの precedence ビットを使用すると、最大 8 種類のトラフィック クラスで構成される限定的な設定にパケットを分類できます。パケットを分類した後、他の QoS 機能を使用して、輻輳管理、帯域幅割り当て、および遅延限度などの適切なトラフィック処理ポリシーを、各トラフィック クラスに割り当てることができます。


) IPv6 ベースの分類は、レイヤ 3 インターフェイスでのみサポートされています。


トラフィック クラスの要素

トラフィック クラスの目的は、ルータのトラフィックを分類することです。トラフィック クラスを定義するには、 class-map コマンドを使用します。

トラフィック クラスに含まれる 3 つの主な要素は、名前、一連の match コマンド、そして、トラフィック クラスで複数の match コマンドを使用する場合に match コマンドを評価する方法です。トラフィック クラスの名前は、 class-map コマンドで指定します。たとえば、 class-map コマンドで cisco を使用すると、トラフィック クラスの名前は cisco になります。

match コマンドは、パケット分類のためのさまざまな基準を指定するために使用します。パケットは、 match コマンドで指定された基準に合っているかどうかを判断するためにチェックされます。指定された基準に合っていれば、パケットはクラスのメンバと見なされ、トラフィック ポリシーで設定された QoS 仕様に従って転送されます。一致基準を満たさないパケットは、デフォルトのトラフィック クラスのメンバとして分類されます。「デフォルト トラフィック クラス」を参照してください。

複数の一致基準がトラフィック クラスに存在する場合、それらの match コマンドを評価する方法を指定する必要があります。評価の説明は、 class-map match-any コマンドで指定します。 match-any オプションを評価方法として指定した場合、トラフィック クラスによって評価されるトラフィックは、指定した条件の少なくとも 1 つに一致する必要があります。 match- all オプションを指定した場合、トラフィックはすべての一致基準を満たす必要があります。

これらのコマンドの機能は、『 Cisco ASR 9000 Series Aggregation Services Routers Modular Quality of Service Command Reference 』に詳しく記載されています。トラフィック クラスの設定作業については、「トラフィック クラスの作成」で説明します。

トラフィック ポリシーの要素

トラフィック ポリシーの目的は、ユーザが指定したトラフィック クラスまたはクラスに分類されたトラフィックに関連付ける QoS 機能を設定することです。トラフィック ポリシーは、 policy-map コマンドを使用して作成します。トラフィック ポリシーには、 名前、トラフィック クラス( class コマンドで指定)、および QoS ポリシーという 3 つの要素が含まれます。トラフィック ポリシーの名前は、ポリシー マップのモジュラ Quality of Service(MQC)で指定します(たとえば、 policy-map policy1 コマンドによって policy1 という名前のトラフィック ポリシーを作成できます)。指定したトラフィック ポリシーにトラフィックを分類するために使用するトラフィック クラスは、クラス マップ コンフィギュレーション モードで定義します。トラフィック ポリシーにトラフィックを分類に使用するトラフィック クラスを選択した後で、この分類されたトラフィックに適用する QoS 機能を入力できます。

MQC では、必ずしも 1 つのトラフィック クラスだけを 1 つのトラフィック ポリシーに関連付ける必要はありません。パケットが複数の一致基準に一致する場合、1 つのトラフィック ポリシーに 1024 のトラフィック クラスを関連付けることができます。1024 のクラス マップには、デフォルト クラスと子ポリシーのクラスが含まれます(存在する場合)。

クラスをポリシー マップで設定する順序が重要です。クラスの一致規則は、クラスをポリシー マップで指定した順序で TCAM にプログラミングされます。したがって、あるパケットが複数のクラスと一致する場合は、最初に一致したクラスだけが返され、対応するポリシーが適用されます。

これらのコマンドの機能については、『 Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference 』でより詳細に説明します。

トラフィック ポリシーの設定作業については、「トラフィック ポリシーの作成」で説明します。

デフォルト トラフィック クラス

未分類のトラフィック(トラフィック クラスで指定された一致基準を満たさないトラフィック)は、デフォルト トラフィック クラスに属するものとして扱われます。

ユーザがデフォルト クラスを設定しない場合でも、パケットはデフォルト クラスのメンバとして扱われます。ただし、デフォルトでは、デフォルト クラスにイネーブルな機能はありません。そのため、機能が設定されていないデフォルト クラスに属するパケットには QoS 機能は適用されません。この後、これらのパケットは、ファーストイン ファーストアウト(FIFO)キューに配置され、使用可能な下位リンクの帯域幅で決められたレートで転送されます。この FIFO キューは、テール ドロップと呼ばれる輻輳回避技術で管理されます。 テール ドロップなどの輻輳回避技術の詳細については、 このマニュアルの「Cisco ASR 9000 シリーズ ルータでのモジュラ QoS 輻輳回避の設定」 モジュールを参照してください。

バンドル トラフィック ポリシー

ポリシーがバンドルにバインドされている場合、各バンドル メンバ(ポート)で同じポリシーがプログラミングされます。たとえば、ポリサーまたはシェーパー レートがある場合、各ポートに同じレートが設定されます。トラフィックはロード バランシング アルゴリズムに基づいてメンバをバンドルするようスケジュールされます。

ポリシーは次のものにバインドできます。

バンドル

バンドル レイヤ 3 サブインターフェイス

バンドル レイヤ 2 サブインターフェイス(レイヤ 2 転送)

入力および出力トラフィックの両方がサポートされています。パーセントベースのポリシーと絶対レートベースのポリシーがサポートされています。ただし、使いやすさのため、パーセントベースのポリシーを使用することを推奨します。

共有ポリシー インスタンス

トラフィック クラスとトラフィック ポリシーを作成した後、任意で共有ポリシー インスタンス(SPI)を使用して、QoS リソースを 1 つ割り当て、これをサブインターフェイス、複数のイーサネット フロー ポイント(EFP)、またはバンドル インターフェイスで共有することができます。

SPI を使用して、QoS ポリシーの 1 つのインスタンスを複数のサブインターフェイスで共有し、サブインターフェイスのシェーピングを 1 つのレートに集約できます。QoS ポリシーのインスタンスを共有するサブインターフェイスは、すべて同じ物理インターフェイスに属する必要があります。QoS ポリシーのインスタンスを共有するサブインターフェイスの数は、2 からポートのサブインターフェイスの最大数までです。

バンドル インターフェイスの場合、ハードウェア リソースはバンドル メンバごとに複製されます。共通の共有ポリシー インスタンスを使用し、Link Aggregation Control Protocol(LAG)バンドルで設定されたサブインターフェイスは、すべて同じメンバ リンクにロード バランシングされる必要があります。

バンドル EFP にポリシーが設定されている場合、バンドルのメンバ リンクごとにポリシーのインスタンスが 1 つ設定されます。同じバンドルの複数のバンドル EFP 間で SPI を使用する場合、バンドルのメンバ リンクごとにポリシーの共有インスタンスが 1 つ設定されます。デフォルトでは、バンドルのロード バランシング アルゴリズムでは、ハッシュを使用して(バンドル EFP から送信される必要のある)トラフィックをバンドル メンバ間に分散させます。1 つまたは複数の EFP のトラフィックを、複数のバンドル メンバ間に分散させることができます。複数の EFP に、SPI を使用して一緒にシェーピングまたはポリシングを実行しなければならないトラフィックがある場合は、同じ共有ポリシーのインスタンスに属するすべての EFP へのトラフィックに対して、バンドル ロード バランシングで同じバンドル メンバを選択する(ハッシュ選択)ように設定する必要があります。これによって、同じポリシーの共有インスタンスを持つすべての EFP に向かうトラフィックで、同じポリサー/シェーパー インスタンスが使用されます。

これは通常は同じ加入者が多数の EFP を持つ場合(たとえば、各サービス タイプに対して 1 つの EFP を持つなど)や、プロバイダーですべての加入者の EFP に対してシェーピングおよびキューイングを一緒に実装することが求められる場合に使用されます。

SPI の設定作業については、「共有ポリシー インスタンスの設定」で説明します。

ポリシーの継承

ポリシー マップを物理ポートに適用すると、ポリシーは、その物理ポートのすべてのレイヤ 2 およびレイヤ 3 サブインターフェイスに適用されます。

ポート シェーピング ポリシー

ポート シェーピング ポリシーをメイン インターフェイスに適用するときには、個々の通常のサービス ポリシーをそのサブインターフェイスに適用できます。ポート シェーピング ポリシー マップには、次の制限事項があります。

class-default が許可された唯一のクラス マップです。

シェイプ クラス アクションが許可された唯一のクラス アクションです。

これらは出力方向でだけ設定できます。

これらのスクリプトは、メイン インターフェイスにのみ適用します。サブインターフェイスには適用できません。

2 レベルまたは 3 レベルのポリシーはサポートされていません。1 レベルまたはフラットなポリシーだけがサポートされています。

上記の制限のいずれかに違反した場合、設定したポリシー マップはポート シェーピング ポリシーではなく、通常のポリシーとして適用されます。

クラス マップの設定、ポリシー マップの設定、クラス アクションの適用、およびサービス ポリシーの適用については、「Cisco ASR 9000 シリーズ ルータでのモジュラ QoS パケットの分類とマーキングの設定例」を参照してください。

クラスベース無条件パケット マーキングの機能と利点

クラスベースの無条件パケット マーキング機能は、ユーザが指定したマーキングに基づいてパケットを区別できる効率的なパケット マーキング機能です。

クラスベースの無条件パケット マーキングでは、次の作業を行うことができます。

IP precedence ビットまたは IP DiffServ コード ポイント(DSCP)を IP ToS バイトに設定してパケットをマーキング。

インポーズされたラベルまたは最上位ラベル内の EXP ビットを設定して、マルチプロトコル ラベル スイッチング(MPLS)パケットをマーキング。

レイヤ 2 サービス クラス(CoS)値を設定して、パケットをマーキング。

IEEE 802.1Q トンネリング(QinQ)設定に内部および外部 CoS タグを設定してパケットをマーキング。

qos-group 引数の値を設定してパケットをマーキング。

discard-class 引数の値を設定してパケットをマーキング。


qos-group および discard-class はルータの内部変数であり、送信されません。


無条件パケット マーキングにより、次のようにネットワークを複数のプライオリティ レベルまたはサービス クラスに区切ることができます。

QoS 無条件パケット マーキングを使用して、ネットワークに入るパケットの IP precedence または DSCP 値を設定します。ネットワーク内のルータは、新しくマーキングされた IP precedence 値を使用して、トラフィックの処理方法を決定できます。

たとえば、輻輳回避技術である重み付けランダム早期検出(WRED)を使用して、パケットの廃棄確率を決めることができます。さらに、低遅延キューイング(LLQ)を設定して、そのマークのすべてのパケットをプライオリティ キューに送るよう設定できます。

QoS 無条件パケット マーキングを使用して、パケットを QoS グループに割り当てます。QoS グループ ID を MPLS パケットに設定するには、ポリシー マップ クラス コンフィギュレーション モードで set qos-group コマンドを使用します。


) QoS グループ ID を設定しても、パケットを送信する優先順位が自動的に決まるわけではありません。最初に QoS グループを使用する出力ポリシーを設定する必要があります。


CoS 無条件パケット マーキングを使用して、IEEE 802.1p/ スイッチ間リンク(ISL)パケットのプライオリティ値を設定するパケットを割り当てます。
ルータでは、CoS 値を使用して、パケットに転送のための優先順位を付ける方法を決定し、このマーキングを使用してレイヤ 2 からレイヤ 3 へのマッピングを行います。送信パケットのレイヤ 2 CoS 値を設定するには、ポリシー マップ コンフィギュレーション モードで set cos コマンドを使用します。

設定作業については、 「クラスベース無条件パケット マーキングの設定」 で説明します。

 

IP precedence によるパケットの CoS の指定

IP precedence を使用すると、パケットの CoS を指定できます。この目的には、IP Version 4(IPv4)ヘッダーの ToS フィールドの 3 つの precedence ビットを使用します。 図 1 に ToS フィールドを示します。

図 1 IPv4 パケットのタイプ オブ サービス フィールド

 

ToS ビットを使用して、最大 8 つのサービス クラスを定義できます。その後、ネットワーク全体で設定された他の機能によって、これらのビットを使用して、ToS の付与に関するパケットの処理方法を決定します。これらの他の QoS 機能では、輻輳管理戦略や帯域幅の割り当てなど適切なトラフィック処理ポリシーを割り当てることができます。たとえば、LLQ などのキューイング機能は、パケットの IP precedence 設定を使用して、トラフィックに優先順位を付けることができます。

着信トラフィックに precedence レベルを設定し、Cisco IOS XRQoS キューイング機能と一緒に使用することで、ディファレンシエーテッド サービスを作成できます。

後続の各ネットワーク要素が決定されたポリシーに基づいてサービスを提供できるように、できるだけ IP precedence は、通常ネットワークの端または管理ドメインの近くに配置します。これによって、他のコアまたはバックボーンにおいて、優先順位に基づいて QoS を設定できます。

設定作業については、 「クラスベース無条件パケット マーキングの設定」 で説明します。

パケットの分類に使用する IP precedence ビット

IP ヘッダーの ToS フィールドにある 3 つの IP precedence ビットを使用して、各パケットの CoS 割り当てを指定します。前述したように、最大 8 個のクラスにトラフィックを分類した後、ポリシー マップを作成して、各クラスの輻輳処理、帯域幅割り当てといったネットワーク ポリシーを定義できます。

歴史的な理由から、各優先度はある名前に対応します。これらの名前は RFC 791 で定義されています。 表 1 に、重要度の低いものから高いものへという順に、数値と対応する名前を示します。

 

表 1 IP precedence 値

番号
名前

0

routine

1

priority

2

immediate

3

flash

4

flash-override

5

critical

6

internet

7

network


) IP precedence ビットの設定 6 と 7 は、ルーティング アップデートなどのネットワーク制御情報用に予約されています。


IP precedence 値の設定

デフォルトでは、Cisco IOS XR ソフトウェアでは IP precedence 値を変更しません。これによって、ヘッダーの precedence 値セットが維持され、すべての内部ネットワーク デバイスが IP precedence の設定に基づいてサービスを提供できるようになります。このポリシーは、ネットワークのエッジでネットワーク トラフィックをさまざまなタイプのサービスにソートすること、またこれらのサービス タイプをネットワーク コアで設定することを指定する標準的な方法に従っています。その後、ネットワークのコアにあるルータは、precedence ビットを使用して、送信順やパケット ドロップの可能性などを決定できるようになります。

ネットワークに入ってくるトラフィックには外部デバイスで設定された precedence が設定されている可能性があるので、ネットワークに入るすべてのトラフィックの precedence をリセットすることを推奨します。IP precedence の設定を制御することによって、すでに IP precedence を設定したユーザが、自身のすべてのパケットに高い優先度設定を設定して、自身のトラフィックに対してより高いサービスを得ることを禁止します。

クラスベースの無条件パケット マーキング、LLQ、および WRED 機能では、IP precedence ビットを使用できます。

DEI に基づく分類

802.1ad フレームと 802.1ah フレームに含まれる Drop Eligible Indicator(DEI)ビットに基づいて、トラフィックを分類できます。デフォルトの DEI マーキングがサポートされています。ポリシー マップの set dei アクションは、802.1ad パケットで次の項目に対してサポートされています。

入力および出力

レイヤ 2 サブインターフェイス

レイヤ 2 メイン インターフェイス

レイヤ 3 メイン インターフェイス


) set dei アクションは、802.1ad カプセル化用に設定されていないインターフェイスのトラフィックに対しては無視されます。


デフォルト DEI マーキング

着信パケット
入力 set アクション
インポーズされた 802.1ad ヘッダーのデフォルト DEI

802.1q パケット

なし

0

802.1ad パケット

なし

着信パケットの最上位タグの DEI

802.1ad パケットに変換された 802.1q パケット

または

802.1ad パケット

set dei {0 | 1}

0 または 1

set アクションの DEI 値に基づく

IP precedence と IP DSCP マーキングの比較

IP DSCP 値は、ToS バイトの最初の 6 ビットで、IP precedence 値は ToS バイトの最初の 3 ビットです。IP precedence 値は、実際には IP DSCP 値の一部です。したがって、これらの値は同時に設定できません。

ネットワークでパケットをマークする必要があり、すべてのデバイスで IP DSCP マーキングがサポートされている場合は、IP DSCP マーキングの方が無条件パケット マーキングのオプションが多いため、IP DSCP マーキングを使用してください。IP DSCP によるマーキングが好ましくない場合、またはネットワークにあるデバイスで IP DSCP 値がサポートされているかどうか不明な場合は、パケットのマーキングに IP precedence 値を使用してください。IP precedence 値は、おそらくネットワーク内のすべてのデバイスでサポートされています。

最大 8 種類の IP precedence マーキングと、64 種類の IP DSCP マーキングを設定できます。

In-Place ポリシーの変更

In-Place ポリシーの変更機能では、QoS ポリシーが 1 つ以上のインターフェイスに付加されている場合でも QoS ポリシーを変更できます。1 つ以上のインターフェイスに付加されている QoS ポリシーを変更すると、その QoS ポリシーが付加されているすべてのインターフェイスで QoS ポリシーが自動的に変更されます。変更されたポリシーは、新しいポリシーをインターフェイスにバインドするときと同じチェックを受けます。

ポリシー変更が成功した場合、変更されたポリシーは、ポリシーが付加されているすべてのインターフェイスに対して有効になります。コンフィギュレーション セッションはポリシーの変更が完了するまでブロックされます。

ただし、ポリシーの変更がいずれかのインターフェイスで失敗した場合には、すべてのインターフェイスに対して変更前のポリシーが有効になるように、自動ロール バックが開始されます。コンフィギュレーション セッションは、影響を受けるすべてのインターフェイスでロール バックが完了するまでブロックされます。

In-Place ポリシーの変更時に回復不可能なエラーが発生した場合は、ポリシーは対象のインターフェイスに対して矛盾した状態になります。各場所における矛盾を表示するには、 show qos inconsistency コマンドを使用してください。(このコマンドは、ASR 9000 イーサネット ラインカードでのみサポートされています)。コンフィギュレーション セッションは、変更されたポリシーが、ポリシーを使用するすべてのインターフェイスで有効になるまでブロックされます。コンフィギュレーション セッションのブロックが解除されるまで、新たな設定を行うことはできません。

インターフェイスに付加されている QoS ポリシーを変更したとき、変更されたポリシーを使用するインターフェイスでは、短期間、有効なポリシーがない場合が生じる可能性があります。


) インターフェイスに付加されているポリシーの QoS 統計情報は、ポリシーを変更すると失われます(0 にリセット)。


In-Place ポリシーの変更を引き起こす可能性のある変更

QoS ポリシーの変更

QoS ポリシーの変更は次のとおりです。

帯域幅またはポリシングなどの新しいアクションの追加

新しいサービス ポリシーの追加(階層レベルを上げる)

既存のアクションの削除

既存のアクションの変更

サービス ポリシーの削除(階層レベルを下げる)

新しいアクションを伴う新しいクラスの追加

ポリシーへの複数のクラスの追加または削除

子ポリシーの変更

クラス マップの変更

クラス マップの変更は次のとおりです。

新しい match 文の追加

既存の match 文の削除

照合タイプの変更(match-all から match-any、またはその逆)

既存の match 文の変更

クラス マップで使用するアクセス リストの変更

新しいアクセス コントロール エントリ(ACE)の追加

ACE の削除

ACE の修正

In-Place ポリシー変更に関する推奨事項

QoS ポリシーを変更している間の短期間、変更するポリシーを使用するインターフェイスでは、有効なポリシーがない状態が生じることがあります。このため、同時に最小限のインターフェイスに影響する QoS ポリシーを変更します。ポリシー マップの変更時に影響するインターフェイスの数を確認するには、 show policy-map targets コマンドを使用します。

ボーダー ゲートウェイ プロトコルを使用した QoS ポリシー伝搬

パケット分類は、データ パス上で輻輳管理または輻輳回避を必要とするトラフィック フローを識別し、マーキングします。ボーダー ゲートウェイ プロトコルを使用した Quality of Service ポリシー伝搬(QPPB)では、アクセス リスト(ACL)、ボーダー ゲートウェイ プロトコル(BGP)コミュニティ リスト、BGP 自律システム(AS)パス、送信元プレフィックス アドレス、または宛先プレフィックス アドレスに基づいて、パケットを QoS グループ ID で分類できます。ボーダー ゲートウェイ プロトコルを使用した Quality of Service ポリシー伝搬(QPPB)では、ボーダー ゲートウェイ プロトコル(BGP)コミュニティ リスト、BGP 自律システム(AS)パス、送信元プレフィックス アドレス、または宛先プレフィックス アドレスに基づいて、IP precedence と QoS グループ ID でパケットを再マーキングできます。パケットを分類しておくと、ポリシングや重み付けランダム早期検出(WRED)などの他の QoS 機能を使用して、ビジネス モデルに適合するようにポリシーを指定し、実行できます。

BGP を使用した QoS ポリシー伝搬(QPPB)では、トラフィック ポリシングの適用に使用できるシスコ エクスプレス フォワーディング(CEF)パラメータに BGP プレフィックスおよび BGP 属性をマッピングできます。QPPB を使用すると、ネットワークのある場所で設定した BGP ポリシーを、BGP を使用してネットワークの別の場所に伝搬し、そこで適切な QoS ポリシーを作成できます。

QPPB では、次の各点に基づいてパケットを分類できます。

アクセス リスト

BGP コミュニティ リスト

コミュニティ リストを使用すると、ルート ポリシーの match 句で使用するコミュニティ グループを作成できます。アクセス リストと同様に、一連のコミュニティ リストを作成できます。

BGP 自律システム パス

BGP 自律システム パスに基づいて、着信および発信の両方のルーティング アップデートに対してアクセス リストを指定することにより、これらのルーティング アップデートをフィルタリングできます。

送信元プレフィックス アドレス

1 つ以上の BGP ネイバーのアドレスから着信する一連のプレフィックスを分類できます。

送信先プレフィックス アドレス

一連の BGP プレフィックスを分類できます。

この分類も、トラフィックの送信元アドレスまたは宛先アドレスに基づいて実行できます。QPPB 機能をサポートするには、BGP および CEF をイネーブルにする必要があります。

QPPB の利点

アクセス リスト、コミュニティ リスト、および AS パスに基づいてパケットを分類できます。

BGP を使用して、ネットワークのリモート ルータに QoS ポリシーを配布します。

受信側ルータで、着信トラフィックおよび発信トラフィックにプライオリティを設定できます。

Cisco ASR 9000 シリーズ ルータでのモジュラ QoS パケットの分類とマーキングの設定例

ここでは、次のタスクの手順を説明します。

「トラフィック クラスの作成」 (必須)

「トラフィック ポリシーの作成」 (必須)

「トラフィック ポリシーのインターフェイスへの付加」 (必須)

「共有ポリシー インスタンス」(任意)

「クラスベース無条件パケット マーキングの設定」 (必須)

トラフィック クラスの作成

一致基準を指定したトラフィック クラスを作成するには、 class-map コマンドを使用してトラフィック クラスの名前を指定し、次に、クラスマップ コンフィギュレーション モードでここに示す match コマンドを必要に応じて使用します。

概念の詳細については、「トラフィック クラスの要素」を参照してください。

制約事項

この 設定 作業で指定するすべての match コマンドの使用は任意ですが、1 つのクラスに少なくとも 1 つの一致基準を設定する必要があります。

手順の概要

1. configure

2. class-map [ type qos] [ match-any ] [ match-all ] class-map-name

3. match access-group [ ipv4 | ipv6 ] access-group-name

4. match [ not ] cos [ cos-value ] [ cos-value1 ... cos-value7 ]

5. match [ not] cos inner [ inner-cos-value ] [ inner-cos-value1 ... inner-cos-value7 ]

6. match destination-address mac destination-mac-address

7. match source-address mac source-mac-address

8. match [ not ] discard-class discard-class-value [ discard-class-value1 ... discard-class-value6 ]

9. match [ not ] dscp [ ipv4 | ipv6 ] dscp-value [ dscp-value1 ... dscp-value7 ]

10. match [ not ] mpls experimental topmost exp-value [ exp-value1 ... exp-value7 ]

11. match [ not ] precedence [ ipv4 | ipv6 ] precedence-value [ precedence-value1 ... precedence-value7 ]

12. match [ not ] protocol protocol value [ protocol-value1 ... protocol-value7 ]

13. match [ not ] qos-group [ qos-group-value1 ... qos-group-value8 ]

14. match vlan [ inner ] vlanid [ vlanid1 ... vlanid7 ]

15. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

class-map [ type qos ] [ match -any ] [ match -all ] class-map-name

 

RP/0/RSP0/CPU0:router(config)# class-map class201

クラス マップ コンフィギュレーション モードを開始します。

名前を指定したクラスとパケットとの照合に使用するクラス マップを作成します。

match-any を指定する場合は、一致基準のいずれかがトラフィック クラスに入るトラフィックに一致し、そのトラフィック クラスの一部として分類される必要があります。これはデフォルトです。 match-all を指定した場合は、トラフィックがすべての一致基準を満たす必要があります。

ステップ 3

match access-group [ ipv4 | ipv6 ] access-group-name

 

RP/0/RSP0/CPU0:router(config-cmap)# match access-group ipv4 map1

(任意)指定したアクセス コントロール リスト(ACL)名に基づいて、クラス マップの一致基準を設定します。

ステップ 4

match [ not ] cos [ cos-value ] [ cos-value0 ... cos-value7 ]

 

RP/0/RSP0/CPU0:router(config-cmap)# match cos 5

(任意)クラス マップにパケットに一致する cos-value を指定します。

cos-value 引数は、0 ~ 7 の整数で指定します。

ステップ 5

match [ not ] cos inner [ inner-cos-value ] [ inner-cos-value0 ... inner-cos-value7 ]

 

RP/0/RSP0/CPU0:router match cos inner 7

(任意)クラス マップにパケットに一致する inner-cos-value を指定します。

inner-cos-value 引数は、0 ~ 7 の整数で指定します。

ステップ 6

match destination-address mac destination-mac-address

 

RP/0/RSP0/CPU0:router(config-cmap)# match destination-address mac 00.00.00

(任意)指定する宛先 MAC アドレスに基づくクラス マップの一致基準を設定します。

ステップ 7

match source-address mac source-mac-address

 

RP/0/RSP0/CPU0:router(config-cmap)# match source-address mac 00.00.00

(任意)指定する送信元 MAC アドレスに基づくクラス マップの一致基準を設定します。

ステップ 8

match [ not ] discard-class discard-class-value [ discard-class-value1 ... discard-class-value6 ]

 

RP/0/RSP0/CPU0:router(config-cmap)# match discard-class 5

(任意)クラス マップにパケットに一致する discard-class-value を指定します。

discard-class-value 引数は、0 ~ 7 の整数で指定します。

match discard-class コマンドは、出力ポリシーに対してのみサポートされています。

ステップ 9

match [ not ] dscp [ ipv4 | ipv6 ] dscp-value [ dscp-value ... dscp-value ]

 

RP/0/RSP0/CPU0:router(config-cmap)# match dscp ipv4 15

(任意)一致基準として特定の DSCP 値を指定します。

値の範囲は 0 ~ 63 です。

数値の代わりに、予約済みキーワードも指定できます。

match 文ごとに最大 8 つの値または範囲を使用できます。

ステップ 10

match [ not ] mpls experimental topmost exp-value [ exp-value1 ... exp-value7 ]

 

RP/0/RSP0/CPU0:router(config-cmap)# match mpls experimental topmost 3

(任意)クラス マップを設定し、最上位のマルチプロトコル ラベル スイッチング(MPLS)ラベルの 3 ビット experimental(EXP)フィールドが、EXP フィールド値に対して検査されるようにします。

指定できる値の範囲は、0 ~ 7 です。

ステップ 11

match [ not ] precedence [ ipv4 | ipv6 ] precedence-value [ precedence-value1 ... precedence-value6 ]

 

RP/0/RSP0/CPU0:router(config-cmap)# match precedence ipv4 5

(任意)IP precedence 値を一致基準として確認します。

値の範囲は 0 ~ 7 です。

数値の代わりに、予約済みキーワードも指定できます。

ステップ 12

match [ not ] protocol protocol-value
[ protocol-value1 ... protocol-value7 ]

 

RP/0/RSP0/CPU0:router(config-cmap)# match protocol igmp

(任意)指定されたプロトコルに基づいて、クラス マップの一致基準を設定します。

ステップ 13

match [ not ] qos-group [ qos-group-value1 ... qos-group-value8 ]

 

RP/0/RSP0/CPU0:router(config-cmap)# match qos-group 1 2 3 4 5 6 7 8

(任意)クラス マップにパケットに一致するサービス(QoS)グループ値を指定します。

qos-group-value ID 引数の値は、0 ~ 63 の範囲の正確な値または値の範囲として指定します。

1 つの match 文に対して最大 8 つの値(スペースで区切る)を入力できます。

match qos-group コマンドは、出力ポリシーに対してのみサポートされています。

ステップ 14

match vlan [inner] vlanid [vlanid1 ... vlanid7]

 

RP/0/RSP0/CPU0:router(config-cmap)# match vlan vlanid vlanid1

(任意)クラス マップにパケットに一致する VLAN ID または VLAN ID の範囲を指定します。

vlanid は、1 ~ 4094 の範囲の正確な値または値の範囲として指定します。

サポートされている VLAN の値または範囲の総数は 8 つです。

ステップ 15

end

または

commit

 

RP/0/RSP0/CPU0:router(config-cmap)# end

または

RP/0/RSP0/CPU0:router(config-cmap)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

トラフィック ポリシーの作成

トラフィック ポリシーを作成するには、 policy-map グローバル コンフィギュレーション コマンドを使用して、トラフィック ポリシーの名前を指定します。

トラフィック クラスは、 class コマンドを使用したときにサービス ポリシーと関連付けられます。 class コマンドは、ポリシー マップ コンフィギュレーション モードを開始した後に実行しなければなりません。 class コマンドを入力すると、ルータは自動的にポリシー マップ クラス コンフィギュレーション モードを開始します。ここでトラフィック ポリシーの QoS ポリシーを定義します。

次のクラス アクションがサポートされています。

bandwidth:クラスの帯域幅を設定します。このマニュアルの「Cisco ASR 9000 シリーズ ルータでのモジュラ QoS 輻輳管理の設定」モジュールを参照してください。

police:トラフィックをポリシングします。このマニュアルの「Cisco ASR 9000 シリーズ ルータでのモジュラ QoS 輻輳管理の設定」モジュールを参照してください。

priority:クラスにプライオリティを割り当てます。このマニュアルの「Cisco ASR 9000 シリーズ ルータでのモジュラ QoS 輻輳管理の設定」モジュールを参照してください。

queue-limit:クラスにキュー制限(テール ドロップしきい値)を設定します。このマニュアルの「Cisco ASR 9000 シリーズ ルータでのモジュラ QoS 輻輳回避の設定」モジュールを参照してください。

random-detect:ランダム早期検出をイネーブルにします。このマニュアルの「Cisco ASR 9000 シリーズ ルータでのモジュラ QoS 輻輳回避の設定」モジュールを参照してください。

service-policy:子サービス ポリシーを設定します。

set:このクラスのマーキングを設定します。「クラスベース無条件パケット マーキングの機能と利点」を参照してください。

shape:クラスのシェーピングを設定します。このマニュアルの「Cisco ASR 9000 シリーズ ルータでのモジュラ QoS 輻輳管理の設定」モジュールを参照してください。

一致基準として入力できるその他のコマンドについては、『 Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference 』を参照してください。

概念の詳細については、「トラフィック ポリシーの要素」を参照してください。

手順の概要

1. configure

2. policy-map [type qos] policy-name

3. class class-name

4. set precedence precedence-value

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

policy-map [ type qos ] policy-name

 

RP/0/RSP0/CPU0:router(config)# policy-map policy1

ポリシー マップ コンフィギュレーション モードを開始します。

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。

ステップ 3

class class-name

 

RP/0/RSP0/CPU0:router(config-pmap)# class class1

ポリシーを作成または変更するクラスの名前を指定します。

ステップ 4

set precedence precedence-value

 

RP/0/RSP0/CPU0:router(config-pmap-c)# set precedence 3

IP ヘッダーに優先順位を設定します。

(注)

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router(config-pmap-c)# end

または

RP/0/RSP0/CPU0:router(config-pmap-c)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

トラフィック ポリシーのインターフェイスへの付加

トラフィック クラスとトラフィック ポリシーの作成後、service-policy インターフェイス コンフィギュレーション コマンドを使用して、トラフィック ポリシーをインターフェイスに付加し、ポリシーを適用する方向を指定します(インターフェイスに着信するパケットまたはインターフェイスから送信されるパケット)。

ポリシー マップ クラス コンフィギュレーション モードで入力できるその他のコマンドについては、『 Cisco ASR 9000 Series Aggregation Services Routers Modular Quality of Service Command Reference 』を参照してください。

前提条件

インターフェイスにトラフィック ポリシーを付加する前に、トラフィック クラスとトラフィック ポリシーを作成する必要があります。

制約事項

なし

手順の概要

1. configure

2. interface type interface-path-id

3. service-policy {input | output} policy-map

4. end
または
commit

5. show policy-map interface type interface-path-id [ input | output ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/9

インターフェイス コンフィギュレーション モードを開始し、インターフェイスを設定します。

ステップ 3

service-policy { input | output } policy-map

 

RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1

インターフェイスのサービス ポリシーとして使用する入力インターフェイスまたは出力インターフェイスにポリシー マップを付加します。

この例では、トラフィック ポリシーでそのインターフェイスから送信されるすべてのトラフィックを評価します。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 5

show policy-map interface type interface-path-id [ input | output ]

 

RP/0/RSP0/CPU0:router# show policy-map interface gigabitethernet 0/1/0/9

(任意)指定されたインターフェイスのポリシーの統計情報を表示します。

共有ポリシー インスタンスの設定

複数のサブインターフェイスへの共有ポリシー インスタンスの付加

トラフィック クラスとトラフィック ポリシーの作成後、任意で service-policy(インターフェイス) コンフィギュレーション コマンドを使用して、共有ポリシー インスタンスを複数のサブインターフェイスに付加し、ポリシーを適用する方向を指定します(サブインターフェイスに着信するパケットまたはサブインターフェイスから送信されるパケット)。


) 共有ポリシーには、レイヤ 2 とレイヤ 3 のサブ インターフェイスの組み合わせを含めることができます。


ポリシー マップ クラス コンフィギュレーション モードで入力できるその他のコマンドについては、『 Cisco ASR 9000 Series Aggregation Services Routers Modular Quality of Service Command Reference 』を参照してください。

前提条件

共有ポリシーのインスタンスをサブインターフェイスに付加する前に、トラフィック クラスとトラフィック ポリシーを作成する必要があります。

制約事項

複数の物理インターフェイスにまたがる共有ポリシー インスタンスはサポートされていません。

手順の概要

1. configure

2. interface type interface-path-id

3. service-policy {input | output } policy - map [ shared -policy-instance instance-name ]

4. end
または
commit

5. show policy-map shared-policy-instance instance name [ input | output ] location rack/slot/module

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config)# interface gigabitethernet 0/1/0/0.1

インターフェイス コンフィギュレーション モードを開始し、サブインターフェイスを設定します。

ステップ 3

service-policy { input | output } policy - map [ shared -policy-instance instance-name ]

 

RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1 shared-policy-instance Customer1

サブインターフェイスのサービス ポリシーとして使用する入力サブインターフェイスまたは出力サブインターフェイスにポリシー マップを付加します。

この例では、トラフィック ポリシーでそのインターフェイスから送信されるすべてのトラフィックを評価します。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting (yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 5

show policy-map shared-policy-instance instance-name [ input | output ] location rack/slot/module

 

RP/0/RSP0/CPU0:router# show policy-map shared-policy-instance Customer1 location 0/1/0/7.1

(任意)指定した共有ポリシー インスタンスのサブインターフェイスに対するポリシーの統計情報を表示します。

バンドル インターフェイスまたは EFP バンドルへの共有ポリシー インスタンスの付加

トラフィック クラスとトラフィック ポリシーの作成後、任意で service-policy(インターフェイス) コンフィギュレーション コマンドを使用して、共有ポリシー インスタンスをバンドル インターフェイスやバンドル EFP に付加し、ポリシーを適用する方向を指定します(サブインターフェイスに着信するパケットまたはサブインターフェイスから送信されるパケット)。

ポリシー マップ クラス コンフィギュレーション モードで入力できるその他のコマンドについては、『 Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference 』を参照してください。

前提条件

共有ポリシー インスタンスをバンドル インターフェイスまたは EFP バンドルに付加する前に、トラフィック クラスとトラフィック ポリシーを作成する必要があります。

制約事項

複数の物理インターフェイスにまたがる共有ポリシー インスタンスはサポートされていません。

手順の概要

1. configure

2. interface Bundle-Ether bundle-id

3. service-policy { input | output } policy-map [ shared-policy-instance instance-name ]

4. end
または
commit

5. show policy-map shared-policy-instance instance name [ input | output ] location location-id

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RP1/CPU0:router(config)# interface Bundle-Ether 100.1 l2transport

インターフェイス コンフィギュレーション モードを開始し、バンドル インターフェイスを設定します。

ステップ 3

service-policy { input | output } policy-map [ shared-policy-instance instance-name ]

 

RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1 shared-policy-instance Customer1

サブインターフェイスのサービス ポリシーとして使用する入力または出力バンドル インターフェイスにポリシー マップを付加します。

この例では、トラフィック ポリシーでそのインターフェイスから送信されるすべてのトラフィックを評価します。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 5

show policy-map shared-policy-instance instance-name [ input | output ] location location-id

 

RP/0/RSP0/CPU0:router# show policy-map shared-policy-instance Customer1 location 0/rsp0/cpu0

(任意)指定した共有ポリシー インスタンスの場所でのポリシーの統計情報を表示します。

クラスベース無条件パケット マーキングの設定

この設定作業では、以下のクラスベースの無条件パケット マーキング機能をルータに設定する方法を説明します。

IP precedence 値

IP DSCP 値

QoS グループ値(入力のみ)

CoS 値(レイヤ 3 サブ インターフェイスの出力のみ)

MPLS EXP 値

廃棄クラス


) MPLS タグ付きパケットに適用される IPv4 および IPv6 QoS アクションはサポートされていません。設定は受け入れられますが、アクションは実行されません。



) クラスごとに set コマンドを 2 つだけ選択します。


手順の概要

1. configure

2. policy-map policy-name

3. class class-name

4. set precedence number

5. set dscp dscp-value

6. set qos-group qos-group-value

7. set cos [ inner ] cos-value

8. set mpls experimental { imposition | topmost } exp-value

9. set discard-class discard-class-value

10. exit

11. exit

12. interface type interface-path-id

13. service-policy { input | output } policy-map

14. end
または
commit

15. show policy-map interface type instance [ input | output ]


) この作業では使用可能なすべての set コマンドについて説明していますが、クラスごとに設定できる set コマンドは 2 つに限られています。


手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

policy-map policy-name

 

RP/0/RSP0/CPU0:router(config)# policy-map policy1

ポリシー マップ コンフィギュレーション モードを開始します。

1 つ以上のインターフェイスに付加できるポリシー マップを作成または変更し、サービス ポリシーを指定します。

ステップ 3

class class-name

 

RP/0/RSP0/CPU0:router(config-pmap)# class class1

ポリシー クラス マップ コンフィギュレーション モードを開始します。

ポリシーを作成または変更するクラスの名前を指定します。

ステップ 4

set precedence number

 

RP/0/RSP0/CPU0:router(config-pmap-c)# set precedence 1

IP ヘッダーに優先順位を設定します。

ステップ 5

set dscp dscp-value

 

RP/0/RSP0/CPU0:router(config-pmap-c)# set dscp 5

ToS バイトに DSCP を設定することにより、パケットにマーキングします。

ステップ 6

set qos-group qos-group-value

 

RP/0/RSP0/CPU0:router(config-pmap-c)# set qos-group 31

IPv4 パケットまたは MPLS パケットに QoS グループ ID を設定します。

set qos-group コマンドは入力ポリシーでのみサポートされています。

ステップ 7

set cos [ inner ] cos-value

 

RP/0/RSP0/CPU0:router(config-pmap-c)# set cos 7

発信パケットの固有の IEEE 802.1Q レイヤ 2 CoS 値を設定します。値は 0 ~ 7 です。

発信パケットのレイヤ 2 CoS 値を設定します。

このコマンドは、スイッチに送信中のパケットにマーキングをする場合に、ルータで使用する必要があります。スイッチは、CoS 値のマーキングを含むレイヤ 2 ヘッダー情報を利用できます。

レイヤ 2 インターフェイスでは、 set cos コマンドは次のように処理されます。

メイン インターフェイスの入力または出力ポリシーでは拒否されます。

サブインターフェイスの入力ポリシーでは受け入れられますが、無視されます。

サブインターフェイスの出力ポリシーではサポートされています。

レイヤ 3 インターフェイスでは、 set cos コマンドは次のように処理されます。

メイン インターフェイスの入力ポリシーでは無視されます。

サブインターフェイスの入力ポリシーで拒否されます。

メイン インターフェイスとサブインターフェイスの出力ポリシーではサポートされています。

ステップ 8

set mpls experimental { imposition | topmost } exp-value

 

RP/0/RSP0/CPU0:router(config-pmap-c)# set mpls experimental imposition 3

MPLS パケットの最上位ラベルまたはインポジション ラベルの EXP 値を設定します。

imposition は、入力ポリシーに付加されるサービス ポリシーに対してのみ使用できます。

ステップ 9

set discard-class discard-class-value

 

RP/0//CPU0:router(config-pmap-c)# set discard-class 3

IP Version 4(IPv4)またはマルチプロトコル ラベル スイッチング(MPLS)パケットの廃棄クラスを設定します。

このコマンドは、入力ポリシーに付加されるサービス ポリシーに対してのみ使用できます。

ステップ 10

exit

 
RP/0/RSP0/CPU0:router(config-pmap-c)# exit

ルータをポリシー マップ コンフィギュレーション モードに戻します。

ステップ 11

exit

 

RP/0/RSP0/CPU0:router(config-pmap)# exit

ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 12

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config)# interface pos 0/2/0/0

インターフェイス コンフィギュレーション モードを開始し、インターフェイスを設定します。

ステップ 13

service-policy { input | output ]} policy-map

 

RP/0/RSP0/CPU0:router(config-if)# service-policy output policy1

インターフェイスのサービス ポリシーとして使用する入力インターフェイスまたは出力インターフェイスにポリシー マップを付加します。

この例では、トラフィック ポリシーでそのインターフェイスから送信されるすべてのトラフィックを評価します。

ステップ 14

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 15

show policy-map interface type interface-path-id [ input | output ]

 

RP/0/RSP0/CPU0:router# show policy-map interface pos 0/2/0/0

(任意)指定されたインターフェイス上のすべてのサービス ポリシーに対して設定されている全クラスのポリシー設定情報を表示します。

ボーダー ゲートウェイ プロトコルを使用した QoS ポリシー伝搬の設定

ここでは、ボーダー ゲートウェイ プロトコル(BGP)コミュニティ リスト、BGP 自律システム パス、アクセス リスト、送信元プレフィックス アドレス、または宛先プレフィックス アドレスに基づいて、BGP を使用したポリシー伝搬をルータ上で設定する方法について説明します。

BGP を使用したポリシー伝搬の設定のタスク リスト

BGP を使用したポリシー伝搬では、BGP コミュニティ リスト、BGP 自律システム パス、アクセス リスト、送信元プレフィックス アドレス、および宛先プレフィックス アドレスに基づいて、IP precedence または QoS グループ ID(あるいはその両方)でパケットを分類できます。パケットを分類しておくと、重み付けランダム早期検出(WRED)などの他の QoS 機能を使用して、ビジネス モデルに適合するようにポリシーを指定し、実行できます。

タスクの概要

BGP を使用したポリシー伝搬を設定するには、次の基本的な作業を実行します。

BGP およびシスコ エクスプレス フォワーディング(CEF)を設定します。

BGP を設定するには、『 Cisco IOS XR Routing Configuration Guide 』を参照してください。CEF を設定するには、Cisco ASR 9000 ルータCisco XR 12000 シリーズ ルータの『 Cisco IOS XR IP Address and Services Configuration Guide 』を参照してください。

BGP コミュニティ リストまたはアクセス リストを設定します。

ルート ポリシーを定義します。

BGP コミュニティ リスト、BGP 自律システム パス、アクセス リスト、送信元プレフィックス アドレス、または宛先プレフィックス アドレスに基づいて、IP precedence または QoS グループ ID を設定します。

BGP にルート ポリシーを適用します。

目的のインターフェイス上で QPPB を設定します。

上記の分類(IP precedence または QoS グループ ID による分類)を使用するように QoS ポリシーを設定します。専用アクセス レート(CAR)、WRED、およびテール ドロップを設定するには、「 Configuring Modular QoS Congestion Avoidance on Cisco IOS XR Software 」モジュールを参照してください。

ルート ポリシーの定義

この作業では、IP precedence または QoS グループ ID による BGP プレフィックスの分類に使用するルート ポリシーを定義します。

前提条件

ルート ポリシーで使用する BGP コミュニティ リストまたはアクセス リストを設定します。

 

制約事項

出力 QoS ポリシーを使用した IPv4 QPPB および IPv6 QPPB は、すべてのイーサネットおよび SIP-700 ラインカードでサポートされています。

入力 QoS ポリシーを使用した IPv4 QPPB は、最初の世代の ASR9000 イーサネット ラインカードでサポートされています。

手順の概要

1. configure

2. route-policy name

3. set qos-group qos-group-value

4. end-policy

手順の詳細

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

route-policy name

 

RP/0/RSP0/CPU0:router(config)# route-policy

costA

ルート ポリシー コンフィギュレーション モードを開始し、設定するルート ポリシーの名前を指定します。

ステップ 3

set qos-group qos-group-value

 

RP/0/RSP0/CPU0:router(config-pmap-c)# set qos-group 31

IPv4 パケットまたは MPLS パケットに QoS グループ ID を設定します。

set qos-group コマンドは入力ポリシーでのみサポートされています。

ステップ 4

end-policy

 

RP/0/RSP0/CPU0:router(config)# end-policy

ルート ポリシーの定義を終了して、ルート ポリシー コンフィギュレーション モードを終了します。

BGP に対するルート ポリシーの適用

この作業では、BGP にルート ポリシーを適用します。

前提条件

Cisco ASR 9000 ルータルータで BGP およびシスコ エクスプレス フォワーディングを設定します。

手順の概要

1. configure

2. router bgp as-number

3. address-family address-prefix

4. table-policy policy-name

5. end

または

commit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0//CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp as-number

 

RP/0//CPU0:router(config)# router bgp 120

BGP コンフィギュレーション モードを開始します。このモードでは、BGP ルーティング プロセスを設定できます。

ステップ 3

address-family address-prefix

 

RP/0//CPU0:router(config-bgp)#

address-family ipv4 unicast

アドレス ファミリ コンフィギュレーション モードを開始します。このモードでは、アドレス ファミリを設定できます。

ステップ 4

table-policy policy-name

 

RP/0//CPU0:router(config-bgp-af)#

table-policy qppb-comm6200

ルーティング テーブルにインストールされるルートにルーティング ポリシーを適用します。

ステップ 5

end

または

commit

 

RP/0//CPU0:router(config-if)# end

または

RP/0//CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

目的のインターフェイスでの QPPB の設定

この作業では、指定したインターフェイスに QPPB を適用します。ルート ポリシーでのプレフィックスの一致に基づいて、トラフィックの分類が始まります。トラフィックの送信元または宛先の IP アドレスを使用して、ルート ポリシーを照合できます。

手順の概要

1. configure

2. interface type interface-path-id

3. ipv4 bgp policy propagation input {ip-precedence | qos-group} {destination [ip-precedence {destination | source}] | source [ip-precedence {destination | source}] }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config)#interface POS 0/0/0/0

インターフェイス コンフィギュレーション モードを開始し、VRF に 1 つ以上のインターフェイスを関連付けます。

ステップ 3

ipv4 bgp policy propagation input { ip-precedence | qos-group } { destination [ ip-precedence {destination | source}] | source [ ip-precedence {destination | source}] }

 

RP/0/RSP0/CPU0:router(config)#ipv4 bgp policy propagation input qos-group destination

いずれかのインターフェイスで QPPB をイネーブルにします。

Cisco ASR 9000 シリーズ ルータでのモジュラ QoS パケット分類とマーキングの設定例

ここでは、次の例を示します。

「定義されたトラフィック クラス:例」

「トラフィック ポリシーの作成:例」

「インターフェイスへのトラフィック ポリシーの付加:例」

「複数のサブインターフェイスへのトラフィック ポリシーの付加:例」

「バンドル インターフェイスへのトラフィック ポリシーの付加:例」

「共有ポリシー インスタンスによる EFP ロード バランシング:例」

「デフォルト トラフィック クラスの設定:例」

「class-map match-any コマンドの設定: 例」

「クラスベースの無条件パケット マーキングの例」

「In-Place ポリシーの変更:例」

定義されたトラフィック クラス:例

次に、2 つのトラフィック クラスを作成し、その一致基準を定義する例を示します。1 つ目のトラフィック クラス class1 では、ACL 101 を一致基準として使用します。2 つ目のトラフィック クラス class2 では、ACL 102 を一致基準として使用します。パケットはこれらの ACL の内容と照合され、それぞれのクラスに属するかどうかが判断されます。

class-map class1
match access-group ipv4 101
exit
!
class-map class2
match access-group ipv4 102
exit
 

not キーワードを match コマンドに使用すると、指定していないフィールド値に基にして照合を行います。次の例では、DSCP 値が 4、8、10 以外である qos_example クラスのすべてのパケットを対象としています。

class-map match-any qos_example
match not dscp 4 8 10
!
end

トラフィック ポリシーの作成:例

次の例では、class1 と class2 という 2 つのクラスのポリシーを指定した policy1 というトラフィック ポリシーを定義します。これらのクラスの一致基準は、「定義されたトラフィック クラス:例」で作成されたトラフィック クラスで定義されています。

class1 では、帯域幅割り当て要求と、そのクラス用に予約されるキューの最大バイト数の制限がポリシーに含まれています。class2 では、帯域幅割り当て要求だけがポリシーで指定されています。

policy-map policy1
class class1
bandwidth 3000
queue-limit bytes 1000000000
exit
!
class class2
bandwidth 2000
exit
 
 

インターフェイスへのトラフィック ポリシーの付加:例

次の例では、既存のトラフィック ポリシーをインターフェイスに付加します(「定義されたトラフィック クラス:例」を参照してください)。 policy-map コマンドを使用してトラフィック ポリシーを定義した後、インターフェイス コンフィギュレーション モードで service-policy コマンドを使用して、このポリシーを 1 つ以上のインターフェイスに付加し、これらのインターフェイスのトラフィック ポリシーを指定できます。同じトラフィック ポリシーは複数のインターフェイスに付加することができますが、各インターフェイスには入力と出力に対してそれぞれトラフィック ポリシーを 1 つだけ付加することができます。

interface gigabitethernet 0/1/0/9
service-policy output policy1
exit
!
interface TenGigE 0/5/0/1
service-policy output policy1
exit

複数のサブインターフェイスへのトラフィック ポリシーの付加:例

次の例では、既存のトラフィック ポリシーを複数のサブ インターフェイスに付加します。 policy-map コマンドを使用してトラフィック ポリシーを定義した後、サブインターフェイス コンフィギュレーション モードで service-policy コマンドを使用して、このポリシーを 1 つ以上のサブインターフェイスに付加できます。

interface gigabitethernet 0/1/0/0.1
service-policy output1 shared-policy-instance ethernet101
exit
!
interface gigabitethernet 0/1/0/0.2
service-policy output1 shared-policy-instance ethernet101
exit

バンドル インターフェイスへのトラフィック ポリシーの付加:例

次の例では、既存のトラフィック ポリシーをバンドル インターフェイスに付加します。 policy-map コマンドを使用してトラフィック ポリシーを定義した後、サブインターフェイス コンフィギュレーション モードで service-policy コマンドを使用して、このポリシーを 1 つ以上のバンドル サブインターフェイスに付加できます。

interface Bundle-Ether 100.1
service-policy tripleplaypolicy shared-policy-instance subscriber1
exit
!
interface Bundle-Ether 100.2
service-policy output tripleplaypolicy shared-policy instance subscriber1
exit

共有ポリシー インスタンスによる EFP ロード バランシング:例

次の例では、SPI が実装されている場合に、EFP のロード バランシングを設定します。リンク バンドルでの EFP ロード バランシングの詳細については、『Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Configuration Guide』を参照してください。

バンドル インターフェイスの設定:例

interface Bundle-Ether 50
interface gigabitethernet 0/1/0/5
bundle id 50 mode active
interface gigabitethernet 0/1/0/8
bundle id 50 mode active

ロード バランス オプションによる 2 つのバンドル EFP の設定:例

次の例では、同じ物理メンバ リンクを通過する 2 つのバンドル EFP 宛てのトラフィックを設定します。

interface Bundle-Ether 50.25 l2transport
encapsulation dot1q 25
bundle load-balance hash-select 2
!
interface Bundle-Ether 50.36 l2transport
encapsulation dot1q 36
bundle load-balance hash-select 2

デフォルト トラフィック クラスの設定:例

次の例では、トラフィック ポリシー policy1 のデフォルト クラスにトラフィック ポリシーを設定します。デフォルト クラスの名前は class-default で、他のすべてのトラフィックから構成され、インターフェイスの帯域幅の 60 パーセントでシェーピングされます。

policy-map policy1
class class-default
shape average percent 60

class-map match-any コマンドの設定: 例

次の例では、複数の一致条件がある場合にパケットを評価する方法を示します。 class-map match-any コマンド中のパケットがトラフィック クラスのメンバであると見なされるためには、一致基準が 1 つだけが満たされる必要があります(論理的な OR 演算子)。この例では、プロトコル IP OR QoS グループ 4 OR アクセス グループ 101 が成功する一致基準になる必要があります。

class-map match-any class1
match protocol ipv4
match qos-group 4
match access-group ipv4 101
 

トラフィック クラス class1 では、成功する一致条件が見つかるまで連続的に一致基準が評価されます。各一致基準が評価され、パケットがその基準に一致するかどうかが判断されます。パケットが指定した条件のうち少なくとも 1 つに一致すると、パケットはトラフィック クラスのメンバとして分類されます。


match qos-group コマンドは、出力ポリシーでのみサポートされています。


IP precedence のマーキングの設定:例

この例では、 policy1 というサービス ポリシーを作成します。このサービス ポリシーは、 class コマンドを使用して事前に定義したクラス マップ class1 に関連付けられ、その後、出力 POS インターフェイス 0/1/0/0 に付加されます。ToS バイトの IP precedence ビットを 1 に設定します。

policy-map policy1
class class1
set precedence 1
!
interface pos 0/1/0/0
service-policy output policy1

IP DSCP マーキングの設定:例

この例では、policy1 というサービス ポリシーを作成します。このサービス ポリシーは、 class コマンドを使用して事前に定義したクラス マップに関連付けられます。この例では、class1 というクラス マップが事前に設定されていることを前提としています。

次の例では、ToS バイトの IP DSCP 値を 5 に設定します。

policy-map policy1
class class1
set dscp 5
 
class class2
set dscp ef
 

エッジで音声パケットに対して示される設定を行った後、すべての中間ルータは次のように音声パケットに低遅延処理を行うよう設定されます。

class-map voice
match dscp ef
policy-map qos-policy
class voice
priority level 1
police rate percent 10
 

QoS グループ マーキングの設定:例

この例では、 policy1 というサービス ポリシーを作成します。このサービス ポリシーは、 class コマンドを使用してクラス マップ class1 に関連付けられ、その後 GigabitEthernet インターフェイス 0/1/0/9 の入力方向に付加されます。qos-group 値は 1 に設定されます。

class-map match-any class1
match protocol ipv4
match access-group ipv4 101
 
policy-map policy1
class class1
set qos-group 1
!
interface gigabitethernet 0/1/0/9
service-policy input policy1
 

set qos-group コマンドは入力ポリシーでのみサポートされています。


CoS マーキングの設定:例

この例では、 policy1 というサービス ポリシーを作成します。このサービス ポリシーは、 class コマンドを使用してクラス マップ class1 に関連付けられ、その後 10-Gigabit Ethernet インターフェイス TenGigE0/1/0/0 の出力方向に付加されます。レイヤ 2 ヘッダーの IEEE 802.1p(CoS)ビットは 1 に設定します。

class-map match-any class1
match protocol ipv4
match access-group ipv4 101
 
policy-map policy1
class class1
set cos 1
!
interface TenGigE0/1/0/0
service-policy output policy1
 

MPLS EXP ビット インポジション マーキングの設定:例

この例では、 policy1 というサービス ポリシーを作成します。このサービス ポリシーは、 class コマンドを使用してクラス マップ class1 に関連付けられ、その後 10-Gigabit Ethernet インターフェイス TenGigE0/1/0/0 の入力方向に付加されます。すべてのインポーズされたラベルの MPLS EXP ビットは 1 に設定します。

class-map match-any class1
match protocol ipv4
match access-group ipv4 101
 
policy-map policy1
class class1
set mpls exp imposition 1
!
interface TenGigE0/1/0/0
service-policy input policy1
 

set mpls exp imposition コマンドは入力ポリシーでのみサポートされています。


MPLS EXP 最上位マーキングの設定:例

この例では、 policy1 というサービス ポリシーを作成します。このサービス ポリシーは、 class コマンドを使用してクラス マップ class1 に関連付けられ、その後 10-Gigabit Ethernet インターフェイス TenGigE0/1/0/0 の出力方向に付加されます。最上位ラベルの MPLS EXP ビットは 1 に設定します。

class-map match-any class1
match mpls exp topmost 2
 
policy-map policy1
class class1
set mpls exp topmost 1
!
interface TenGigE0/1/0/0
service-policy output policy1

QPPB の送信元プレフィックスの設定:例

この設定は、QPPB の送信元プレフィックスの設定例です。

route-policy qppb-src10-20
if source in (201.1.1.0/24 le 32) then
set qos-group 10
elseif source in (201.2.2.0/24 le 32) then
set qos-group 20
else
set qos-group 1
endif
pass
end-policy
!
 
router bgp 100
bgp router-id 10.10.10.10
address-family ipv4 unicast
table-policy qppb-src10-
!
neighbor 201.1.1.2
remote-as 62100
address-family ipv4 unicast
route-policy pass-all in
route-policy pass-all out
!
!
neighbor 201.2.2.2
remote-as 62200
address-family ipv4 unicast
route-policy pass-all in
route-policy pass-all out
!
!
neighbor 202.4.1.1
remote-as 100
address-family ipv4 unicast
!
!
!
 
policy-map p1-in
class class-qos10
set discard-class 4
shape average percent 20
!
class class-qos20
set precedence critical
shape average percent 30
!
class class-default
!
end-policy-map
!
policy-map p2-out
class class-qos10
set precedence priority
police rate percent 30
!
class class-qos20
set precedence immediate
police rate percent 40
!
class class-default
!
end-policy-map
!
 
interface GigabitEthernet0/0/5/4
service-policy output p1-in
ipv4 address 201.1.0.1 255.255.255.0
ipv4 bgp policy propagation input qos-group source
negotiation auto
!
 
interface GigabitEthernet0/1/5/6
service-policy input p2-out
ipv4 address 201.32.21.1 255.255.255.0
ipv4 bgp policy propagation input qos-group destination
negotiation auto
!

QPPB の宛先プレフィックスの設定:例

この設定は、QPPB の宛先プレフィックスの例です。

route-policy qppb-des10to20
if destination in (10.10.0.0/16 le 28) then
set qos-group 10
elseif destination in (10.11.0.0/16 le 28) then
set qos-group 11
elseif destination in (10.12.0.0/16 le 28) then
set qos-group 12
elseif destination in (10.13.0.0/16 le 28) then
set qos-group 13
elseif destination in (10.14.0.0/16 le 28) then
set qos-group 14
elseif destination in (10.15.0.0/16 le 28) then
set qos-group 15
elseif destination in (20.20.0.0/16 le 28) then
set qos-group 20
else
set qos-group 1
endif
pass
end-policy
!
 
router bgp 100
bgp router-id 10.10.10.10
address-family ipv4 unicast
table-policy qppb-des10to20
!
neighbor 201.1.1.2
remote-as 62100
address-family ipv4 unicast
route-policy pass-all in
route-policy pass-all out
!
!
neighbor 201.1.2.2
remote-as 62102
address-family ipv4 unicast
route-policy pass-all in
route-policy pass-all out
!
!
neighbor 201.1.3.2
remote-as 62103
address-family ipv4 unicast
route-policy pass-all in
route-policy pass-all out
!
!
neighbor 201.1.4.2
remote-as 62104
address-family ipv4 unicast
route-policy pass-all in
route-policy pass-all out
!
!
neighbor 201.1.5.2
remote-as 62105
address-family ipv4 unicast
route-policy pass-all in
route-policy pass-all out
!
!
 
 
policy-map p11-in
class class-qos10
set precedence priority
shape average percent 30
!
class class-qos11
set precedence immediate
shape average percent 10
!
class class-qos12
set precedence flash
shape average percent 15
!
class class-qos13
set precedence flash-override
shape average percent 20
!
class class-qos14
set precedence flash
shape average percent 25
!
class class-qos15
set precedence flash-override
shape average percent 30
!
class class-qos20
set precedence critical
shape average percent 40
!
class class-default
!
end-policy-map
!
policy-map p1-out
class class-qos10
set precedence priority
police rate percent 30
!
class class-qos20
set precedence critical
police rate percent 40
!
class class-default
!
end-policy-map
!
 
interface GigabitEthernet0/2/2/1
service-policy output p1-out
ipv4 address 201.1.0.1 255.255.255.0
ipv4 bgp policy propagation input qos-group source
negotiation auto
!
interface GigabitEthernet0/2/2/1.2
service-policy input p11-in
ipv4 address 201.1.2.1 255.255.255.0
ipv4 bgp policy propagation input qos-group destination
dot1q vlan 2
!
interface GigabitEthernet0/2/2/1.3
service-policy input p11-in
ipv4 address 201.1.3.1 255.255.255.0
ipv4 bgp policy propagation input qos-group destination
dot1q vlan 3
!
interface GigabitEthernet0/2/2/1.4
service-policy input p11-in
ipv4 address 201.1.4.1 255.255.255.0
ipv4 bgp policy propagation input qos-group destination
dot1q vlan 4
!
interface GigabitEthernet0/2/2/1.5
service-policy input p11-in
ipv4 address 201.1.5.1 255.255.255.0
ipv4 bgp policy propagation input qos-group destination
dot1q vlan 5
 

In-Place ポリシーの変更:例

この例では、ポリシーを定義してインターフェイスに付加した後、precedence を 3 から 5 に変更します。

クラスを定義します。

class-map match-any class1
match cos 7
end-class-map
 

クラスを使用するポリシー マップを定義します。

policy-map policy1
class class1
set precedence 3
 

インターフェイスにポリシー マップを付加します。

interface gigabitethernet 0/6/0/1
service-policy output policy1
commit
 

ポリシー マップの precedence 値を変更します。

policy-map policy1
class class1
set precedence 5
commit

) 変更されたポリシー policy1 は、ポリシーが付加されるすべてのインターフェイスに反映されます。また、ポリシー マップに使用するすべてのクラス マップを変更できます。クラス マップに対して行った変更は、ポリシーが付加されているすべてのインターフェイスに反映されます。


この show policy-map targets コマンドの出力は、ギガ ビット イーサネット インターフェイス 0/1/0/0 に、メイン ポリシーとして付加されているポリシー マップがあることを示しています(階層型 QoS 設定の子ポリシーに付加されるのではなく)。このインターフェイスの発信トラフィックは、ポリシーが変更された場合に影響を受けます。

show policy-map targets
 
Fri Jul 16 16:38:24.789 DST
1) Policymap: policy1 Type: qos
Targets (applied as main policy):
GigabitEthernet0/1/0/0 output
Total targets: 1
 
Targets (applied as child policy):
Total targets: 0

その他の関連資料

ここでは、パケット分類の実装に関する関連資料について説明します。

関連資料

関連項目
参照先

初期システム起動と設定

『Cisco ASR 9000 Series Aggregation Services Router Getting Started Guide』

マスター コマンド リファレンス

『Cisco ASR 9000 Series Aggregation Services Router Master Command Listing』

QoS コマンド

『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference』

ユーザ グループとタスク ID

『Cisco ASR 9000 Series Aggregation Services Router System Security Configuration Guide』の「Configuring AAA Services on Cisco ASR 9000 Series Router」モジュール

標準

標準
タイトル

この機能によってサポートされる新しい標準または変更された標準はありません。またこの機能による既存標準のサポートに変更はありません。

--

MIB

MIB
MIB のリンク

--

Cisco IOS XR ソフトウェアを使用して MIB を検索およびダウンロードするには、 http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml の URL にある Cisco MIB Locator を使用し、[Cisco Access Products] メニューからプラットフォームを選択します。

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/en/US/support/index.html