Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド Cisco IOS XR ソフトウェア リリース 4.1
Cisco ASR 9000 シリーズ ルータでのリンク バンドルの設定
Cisco ASR 9000 シリーズ ルータ でのリンク バンドルの設定
発行日;2012/05/08 | 英語版ドキュメント(2012/03/01 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

Cisco ASR 9000 シリーズ ルータ でのリンク バンドルの設定

内容

リンク バンドルを設定するための前提条件

でリンク バンドルを設定するための前提条件

リンク バンドルの設定に関する情報

リンク バンドルの概要

リンク バンドルの機能と互換性のある特性

LACP を通じたリンク集約

IEEE 802.3ad 規格

マルチシャーシ リンク集約

失敗状況

シャーシ間通信プロトコル

アクセス ネットワーク冗長モデル

コア ネットワーク冗長モデル

スイッチオーバー

MC-LAG のトポロジ

ロード バランシング

リンク バンドルのレイヤ 2 入力ロード バランシング

リンク バンドルのレイヤ 3 出力ロード バランシング

LAG のダイナミック ロード バランシング

QoS およびリンク バンドル

イーサネット リンク バンドル上の VLAN

リンク バンドルの設定の概要

カードのフェールオーバー時のノンストップ フォワーディング

リンクのフェールオーバー

マルチギガビット サービス コントロール ポイント

リンク バンドルの設定方法

イーサネット リンク バンドルの設定

イーサネット リンク バンドルでの EFP ロード バランシングの設定

VLAN バンドルの設定

マルチシャーシ リンク集約の設定

シャーシ間通信プロトコルの設定

マルチシャーシ Link Aggregation Control Protocol セッションの設定

マルチシャーシ Link Aggregation Control Protocol バンドルの設定

デュアルホーム接続デバイスの設定

アクセス バックアップ疑似回線の設定

MC-LAG での一方向疑似回線冗長性の設定

MC-LAG での VPWS クロスコネクトの設定

MC-LAG での VPLS の設定

MGSCP の設定方法

MGSCP の設定の前提条件

MGSCP の設定に関する制約事項

加入者側のアクセス バンドルの設定

コア側のネットワーク バンドルの設定

バンドル メンバ インターフェイスの設定

トラフィックをバンドルにルーティングする VRF の設定

スタティック ルーティングを使用した VRF の設定

ダイナミック ルーティングを使用した VRF の設定

リンク バンドルの設定例

例:イーサネット リンク バンドルの設定

例:VLAN リンク バンドルの設定

例:イーサネット リンク バンドルでの EFP ロード バランシングの設定

例:マルチシャーシ リンク集約の設定

MGSCP の設定例

例:バンドル インターフェイスおよびメンバ リンクの設定

例:トラフィックをバンドルにルーティングする VRF の設定

例:スタティック ルーティングを使用した VRF の設定

例:OSPF ルーティングを使用した VRF の設定

例:ABF を使用しバンドルにトラフィックをルーティングする MGSCP の設定

その他の関連資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

Cisco ASR 9000 シリーズ ルータ でのリンク バンドルの設定

このモジュールでは、Cisco ASR 9000 シリーズ アグリゲーション サービス ルータのリンク バンドル インターフェイスの設定について説明します。

リンク バンドルは、1 つ以上のポートを集約したグループで、1 つのリンクとして扱われます。

1 つのバンドル内の各リンクは、同じ速度でなければなりません。

各バンドルには、1 つの MAC、1 つの IP アドレス、1 つの設定セット(ACL など)があります。


) Cisco ASR 9000 シリーズ ルータは、レイヤ 2 およびレイヤ 3 リンク バンドルの両方をサポートします。リンク バンドルがレイヤ 3 インターフェイスである場合、IP アドレスが必要です。リンク バンドルがレイヤ 2 インターフェイスの場合、IP アドレスは要求されません。Cisco ASR 9000 シリーズ ルータのリンク バンドル内には、レイヤ 2 およびレイヤ 3 サブインターフェイスが含まれている場合があります。その場合、レイヤ 3 サブインターフェイスには IP アドレスが必要ですが、リンク バンドル インターフェイスには IP アドレスは不要です。


Cisco ASR 9000 シリーズ ルータは、次のタイプのインターフェイスへのバンドルをサポートします。

イーサネット インターフェイス

リンク バンドルの設定の機能履歴

 

リリース
変更内容

リリース 3.7.2

この機能は、Cisco ASR 9000 シリーズ ルータで導入されました。

リリース 3.9.0

ロード バランシングのサポートが追加されました。

バンドル メンバ リングは、バンドル インターフェイスがシャット ダウンされたときに、新しい err-disable リンク インターフェイス状態および admin-down protocol 状態に追加されます。

リリース 3.9.1

レイヤ 2 リンク バンドルでのレイヤ 3 ロード バランシングのサポートが追加されました。

リリース 4.0.0

次のサポートが追加されました。

バンドルごとに最大 64 のメンバ リンク。

IPv6 アドレッシング。

マルチシャーシ リンク集約。

リリース 4.0.1

リンク集約(LAG)メンバのダイナミック ロード バランシングのサポートが追加されました。

L2VPN コンフィギュレーション モードで hw-module load-balance bundle l2-service l3-params コマンドが load-balancing flow コマンドに置き換わりました。詳細については、『 Cisco ASR 9000 Series Aggregation Services Router L2VPN and Ethernet Services Configuration Guide 』および『 Cisco ASR 9000 Series Aggregation Services Router L2VPN and Ethernet Services Command Reference 』を参照してください。

リリース 4.1.0

マルチギガビット サービス コントロール ポイントのサポートが追加されました。

リンク バンドルを設定するための前提条件

適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。

リンク バンドルの前提条件は、この機能を設定しようとしているプラットフォームに依存します。ここでは次の内容について説明します。

「Cisco ASR 9000 シリーズ ルータでリンク バンドルを設定するための前提条件」

Cisco ASR 9000 シリーズ ルータでリンク バンドルを設定するための前提条件

リンク バンドルを設定する前に、次の作業が終了し条件が満たされていることを確認してください。

インターフェイスの IP アドレス(レイヤ 3 のみ)がわかっていること。

設定するバンドルに含めるリンクがわかっていること。

イーサネット リンク バンドルを設定する場合、ルータに少なくとも次のイーサネット ラインカードのいずれかが搭載されていること。

4 ポート 10 ギガビット イーサネット ラインカード

8 ポート 10 ギガビット イーサネット ラインカード

40 ポート ギガビット イーサネット ラインカード


) 物理インターフェイス、PLIM、およびモジュラ サービス カードの詳細については、『Cisco ASR 9000 Series Router Hardware Installation Guide』を参照してください。


リンク バンドルの設定に関する情報

リンク バンドルを設定するには、次の概念について理解する必要があります。

「リンク バンドルの概要」

「リンク バンドルの機能と互換性のある特性」

「LACP を通じたリンク集約」

「マルチシャーシ リンク集約」

「ロード バランシング」

「QoS およびリンク バンドル」

「イーサネット リンク バンドル上の VLAN」

「リンク バンドルの設定の概要」

「カードのフェールオーバー時のノンストップ フォワーディング」

「リンクのフェールオーバー」

「マルチギガビット サービス コントロール ポイント」

リンク バンドルの概要

リンク バンドル機能を使用すると、複数のポイントツーポイント リンクを 1 つの論理リンクにグループ化して、2 台のルータ間により高い双方向帯域幅、冗長性とロード バランシングを提供できます。仮想インターフェイスは、バンドル リンクに割り当てられます。コンポーネント リンクは仮想インターフェイスに動的に追加および削除できます。

仮想インターフェイスは、IP アドレスやリンク バンドルで使用されるその他のソフトウェア機能を設定できる、単一のインターフェイスとして扱われます。リンク バンドルに送信されたパケットは、バンドル内のリンクの 1 つに転送されます。

リンク バンドルは、1 つに束ねられたポートのグループであり、1 つのリンクとして振る舞います。リンク バンドルには次のような利点があります。

複数のリンクが複数のラインカードにまたがり、1 つのインターフェイスを形成します。そのため、単一のリンクで障害が発生しても接続性は失われません。

バンドルされたインターフェイスでは、バンドルの使用可能なすべてのメンバにわたってトラフィックが転送されるため、帯域幅の可用性が向上します。したがって、バンドル内のリンクの 1 つで障害が発生した場合、トラフィックは使用可能なリンクを通過できます。帯域幅はパケット フローを中断することなく追加できます。

1 つのバンドル内の個別リンクは、すべて同じタイプと同じ速度でなければなりません。

Cisco IOS XR ソフトウェアでは、次の方法でイーサネット インターフェイスのバンドルを形成できます。

IEEE 802.3ad:バンドル内のすべてのメンバ リンクの互換性を確保するため、Link Aggregation Control Protocol(LACP)を採用した標準テクノロジー。互換性がないリンクや障害になったリンクは、バンドルから自動的に削除されます。

EtherChannel:ユーザがリンクを設定してバンドルに参加させることができるシスコの専用テクノロジー。バンドル内のリンクに互換性があるかどうかを確認するための仕組みはありません。

リンク バンドルの機能と互換性のある特性

Cisco ASR 9000 シリーズ ルータのリンク バンドルの特性と制限を次に示します。

LACP(Link Aggregation Control Protocol)を使用するかにかかわらず、すべてのタイプのイーサネット インターフェイスをバンドルできます。

バンドル メンバーシップは、1 つのルータにインストールされている複数のラインカードにまたがることができます。

1 つのバンドルは最大 64 個の物理リンクをサポートします。バンドルに 64 よりも多くのリンクを追加すると、64 個のリンクだけが distributing 状態になり、残りのリンクは待機状態になります。

1 つのCisco ASR 9000 シリーズ ルータで最大 128 個のバンドルをサポートします。

1 つのバンドル内のすべての個々のリンクは、同じ速度でなければなりません。

物理層とリンク層の設定は、バンドルの個々のメンバ リンクに対して実行します。

ネットワーク層プロトコルおよび上位層のアプリケーションの設定は、バンドル自体に対して実行します。

IPv4 および IPv6 アドレッシングがリンク バンドル上でサポートされます。

バンドルは、管理上イネーブルまたはディセーブルにできます。Cisco IOS XR Release 3.9.0 から、バンドル インターフェイスシャット ダウンすると、メンバ リンクは err-disable link interface 状態および admin-down line protocol 状態になります。 show interfaces コマンドを使用して、バンドル インターフェイスの状態およびそのメンバを表示できます。

バンドル内のそれぞれのリンクは、管理上イネーブルまたはディセーブルにできます。

イーサネット リンク バンドルは、イーサネット チャネルと同様の方法で作成され、両方のエンド システムで同じコンフィギュレーションを入力します。

バンドルに対して設定された MAC アドレスは、そのバンドル内の各リンクの MAC アドレスになります。

LACP が設定されている場合、バンドル内の各リンクでは、異なるメンバに対して異なるキープアライブ周期を設定できます。

ロード バランシング(メンバ リンク間のデータの配信)は、パケットではなくフロー単位で実行されます。データはバンドル対するそのリンクの帯域幅に比例して、リンクに配信されます。

QoS がサポートされており、各バンドル メンバに均等に適用されます。

CDP キープアライブや HDLC キープアライブなどのリンク層プロトコルは、バンドル内の各リンク上で独立して動作します。

ルーティング アップデートや hello などの上位層プロトコルは、インターフェイス バンドルのどのメンバ リンク上でも送信されます。

1 つのバンドル内のすべてのリンクは、同じ 2 台のシステム上で終端する必要があります。 どちらのシステムも直接接続されている必要があります。

バンドルされたインターフェイスはポイントツーポイントです。

リンクがバンドル内で distributing 状態になるには、その前にアップ状態なる必要があります。

1 つのバンドル内のすべてのリンクは、802.3ad(LACP)または EtherChannel(非 LACP)のいずれかを実行するように設定する必要があります。1 つのバンドル内の混合リンクはサポートされません。

バンドル インターフェイスには、物理リンクと VLAN サブインターフェイスのみを含めることができます。トンネルは、バンドルのメンバにはできません。

リンク バンドルでのアクセス コントロール リスト(ACL)の設定は、通常のインターフェイスでの ACL の設定と同じです。

マルチキャスト トラフィックは、バンドルのメンバ上でロード バランシングされます。特定のフローに対し、内部処理によってメンバ リンクが選択され、そのフローのすべてのトラtィックがそのメンバ上で送信されます。

LACP を通じたリンク集約

オプションの Link Aggregation Control Protocol(LACP)は IEEE 802 規格で定義されています。LACP では、2 台の直接接続されたシステム(ピア)間で通信し、バンドル メンバの互換性が確認されます。Cisco ASR 9000 シリーズ ルータの場合、ピアは、別のルータまたはスイッチにすることができます。LACP は、リンク バンドルの動作状態をモニタし、次のことを確認します。

すべてのリンクが同じ 2 台のシステム上で終端していること。

両方のシステムがリンクを同じバンドルの一部と見なしていること。

すべてのリンクがピア上で適切に設定されていること

LACP は、ローカル ポート状態と、パートナー システムの状態のローカルなビューが格納されたフレームを送信します。これらのフレームが解析され、両方のシステムが同調していることが確認されます。

IEEE 802.3ad 規格

IEEE 802.3ad 規格では、一般にイーサネット リンク バンドルを構成する方法が定義されています。

バンドル メンバとして設定された各リンクに対し、リンク バンドルの各エンドをホストするシステム間で、次の情報が交換されます。

グローバルに一意のローカル システム ID

リンクがメンバになっているバンドルの ID(動作キー)

リンクの ID(ポート ID)

リンクの現在の集約ステータス

この情報は、リンク集約グループ ID(LAG ID)を構成するために使用されます。共通の LAG ID を共有するリンクは集約できます。個々のリンクには固有の LAG ID があります。

システム ID はルータを区別し、その一意性はシステムの MAC アドレスを使用することで保証されます。バンドル ID とリンク ID は、それを割り当てるルータでだけ意味を持ち、2 つのリンクが同じ ID を持たないことと、2 つのバンドルが同じ ID を持たないことが保証される必要があります。

ピア システムからの情報はローカル システムの情報と組み合わされ、バンドルのメンバとして設定されたリンクの互換性が判断されます。

Cisco ASR 9000 シリーズ ルータのバンドル MAC アドレスは、バックプレーンの一連の予約済み MAC アドレスに由来します。この MAC アドレスは、バンドル インターフェイスが存在する限り、このバンドルに付いたままになります。バンドルは、ユーザが別の MAC アドレスを設定するまで、この MAC アドレスを使用します。バンドルの MAC アドレスは、バンドル トラフィックを通過させる際にすべてのメンバ リンクによって使用されます。バンドルに対して設定されたすべてのユニキャスト アドレスまたはマルチキャスト アドレスも、すべてのメンバ リンクで設定されます。


) MAC アドレスを変更するとパケット転送に影響を与えるおそれがあるため、MAC アドレスは変更しないことを推奨します。


マルチシャーシ リンク集約

マルチシャーシ リンク集約(MC-LAG)機能は、キャリア イーサネット ネットワークでのエンドツーエンドのシャーシ間冗長ソリューションを提供します。MC-LAG に、(第 3 の)接続デバイスから見たときに、単一の LAG として共同で動作する 2 台のデバイスが含まれているため、デバイス レベルとリンク レベルの冗長性が提供されます。

そのためには、2 台のデバイスは相互に強調して、相手側のデバイスに対して単一の(2 台のデバイスにスパニングする)LACP バンドルとして表示されるようにします。転送ループのリスクを排除するため、任意の時点でのトラフィックの転送は 1 台のデバイスのみで行います。障害が発生すると、これらのデバイスは協調してスイッチオーバーを実行し、リンク LACP 状態を操作してトラフィックの転送左記デバイスを変更します。

コア ネットワーク内の既存の疑似回線冗長性は、次の内容に基づいてアクセス ネットワークの冗長性と協調します。

マルチシャーシ Link Aggregation Control Protocol(mLACP)

シャーシ間通信プロトコル(ICCP)

mLACP プロトコルは、2 台のデバイス間の予想される動作を定義し、シャーシ間制御プロトコル(ICCP)を使用して TLV を交換して、動作で使用するピア デバイスを識別します。プロバイダー ネットワークのエッジでは、標準 LACP だけをサポートする単純なカスタマー エッジ(CE)デバイスが、2 台のプロバイダー エッジ(PE)デバイスに接続されます。したがって CE デバイスはデュアルホーム接続となり、プロバイダー側からより適切な L2 冗長性が提供されます。mLACP 用語では、CE デバイスにはデュアルホーム接続デバイス(DHD)と呼ばれ、各 PE デバイスは接続ポイント(POA)と呼ばれます。バンドルに対する POA 転送トラフィックは、そのバンドルのアクティブ デバイスであり、その他の POA はスタンバイ デバイスです。

失敗状況

次の障害が発生した場合、MC-LAG は DHD に対しては変更のないバンドル インターフェイスを表示しながら、影響を受けていない POA にトラフィックをスイッチングすることで、冗長性を提供します。

リンク障害:POA のいずれかと DHD 間のポートまたはリンクに障害が発生。

デバイス障害:POA のいずれかにメルトダウンまたはリロードが発生し全体的な接続の喪失が発生(DHD、コアおよび他の POA に対して)。

コアの分離:POA がコア ネットワークへの接続を失ったために値がなくなり、DHD とのトラフィックの転送が不可能。

POA 間で接続の喪失が発生すると、両方のデバイスは相手側でデバイス障害が発生したと見なし、両方がアクティブ ロールを担うよう試みます。これは、スプリット ブレーンのシナリオと呼ばれ、次のいずれかで発生する可能性があります。

その他の接続はすべて残り、POA 間リンクだけ失われた場合。

1 つの POA がコア ネットワークから切断された場合(つまり 2 つの POA 間の接続がコア ネットワーク経由である場合のコア分離シナリオ)。

MC-LAG 自体はこの状況を回避する方法を提供しません。POA 間の接続の復元力が必須です。バンドル内でアクティブになるリンク数に制限を設定することで、問題を低減する責任は、DHD に与えられます。任意の時点で、POA の 1 つに接続しているリンクのみがアクティブになります。

シャーシ間通信プロトコル

図 4 に、シャーシ間通信プロトコル(ICCP)をグラフィカルに表示されます。

図 4 ICCP プロトコル

 

2 つの POA がシャーシ間通信プロトコル(ICCP)を使用して LDP リンクを介して相互に通信します。ICCP は、冗長グループの POA 間で LDP セッションが作成される LDP ベースのプロトコルであり、ICCP メッセージは LDP セッションを介して伝送されます。冗長グループの PE ルータは、シングルホップ(直接接続)、または相互にマルチホップである場合があります。ICCP プロトコルは設定を管理し、冗長グループを制御します。また、ICCP 接続を確立、維持、解除します。ICCP プロトコルは route-watch を使用して、特定の冗長グループの PE への接続をモニタリングします。これはコア分離の障害をトラッキングする役割もあります。この場合、すべてのクライアント アプリケーションにに対して、障害(コアの分離およびアクティブ PE 障害)が通知されます。

ICCP を動作させるには、デバイスは冗長グループ(RG)のメンバとして設定します。


) mLACP の設定では、2 台のデバイスは、各 RG のメンバとして設定されます(1 つのメンバだけを残してデバイスレベルのエラーが発生するまで)。ただし、各デバイスは複数の RG のメンバにすることができます。


各冗長グループでは、POA の mLACP ピアは、ICCP を介した mLACP を使用して通信している相手側である、そのグループ内の別の POA になります。各バンドルについて、両端の POA および DHD は標準 LACP プロトコルを使用して通信する LACP パートナーです。

アクセス ネットワーク冗長モデル

マルチシャーシ Link Aggregation Control Protocol(mLACP)をベースとした、カスタマー エッジ(CE)デバイスまたはアクセス ネットワークとプロバイダー エッジ(PE)デバイス間の冗長性は、CE が 2 台の PE ルータに接続できるようにすることによって実現されます。2 台の PE ルータは、ICCP を介してデータを同期します。そのため、これらは CE に対して 1 つのデバイスとして表示されます。

図 5 mLACP/ICCP 冗長モデル

 

CE は、デュアルホーム接続デバイス(DHD)とも呼ばれ、PE は接続ポイント(POA)とも呼ばれます。単一 DHD に接続された POA のペアは、冗長グループ(RG)を形成します。

常に、1 つの POA だけがバンドルに対してアクティブです。DHD とアクティブ POA 間のリンクのセットだけが、アクティブにトラフィックを送信します。DHD とスタンバイ POA 間のリンクのセットはトラフィックを転送しません。マルチシャーシ リンク バンドルのソフトウェアは、アクティブ POA への接続が失敗したことを検出すると、スタンバイ POA がアクティブ POA になり、トラフィックが DHD と新しくアクティブになった POA 間のリンクを使用してフローするようにトリガーします。

ICCP プロトコルは、アクティブ POA およびスタンバイ POA 間で動作し、POA がまたは設定を調整し、いずれをアクティブ POA にするかを決定し、POA がアクティブになるようにトリガーします。2 つの POA で動作するアプリケーション(mLACP、IGMP スヌーピング、DHCP スヌーピングまたは ANCP)は、ICCP を使用して状態を同期させます。

障害モード

mLACP 機能には、ポート障害、リンク障害、およびノード障害からの保護によるネットワーク復元力が備わっています。 図 6 に、さまざまな障害モードを示します。

図 6 障害モード

 

障害のカテゴリは次のとおりです。

A:DHD アップリンク ポート障害。POA に接続する DHD 上のポートの障害です。

B:DHD アップリンク障害。DHD と POA 間の接続の障害です。

C:アクティブ POA のダウンリンク ポートの障害。

D:アクティブ POA のノード障害。

E:アクティブ POA アップリンク障害(ネットワークの分離)。アクティブ POA とコア ネットワーク間のリンクの障害です

コア ネットワーク冗長モデル

このセクションでは次の内容について説明します。

一方向疑似回線冗長性

双方向疑似回線冗長性

一方向疑似回線冗長性

図 7 に、VPWS 一方向疑似回線冗長性モデルを示します。疑似回線の片端だけがバックアップ疑似回線によって保護されます。

図 7 VPWS 一方向疑似回線冗長性

 

双方向疑似回線冗長性

図 8 に、VPWS 双方向疑似回線冗長性モデルを示します。このトポロジでは、PW の端にある各 T-PE は各プライマリおよびバックアップ PW があります。PW の状態は、DHD と PE 間の mLACP リンクの状態と調整されます。

図 8 VPWS 双方向疑似回線冗長性

 

スイッチオーバー

POA のアクティブ/スタンバイ ロールを変更するスイッチオーバーは、動的優先権管理またはブルート フォース動作を使用して実行されます。

動的優先権管理

動的優先権管理には、メンバ リンクの LACP ポート プライオリティを処理する POA 間の調整が含まれます。2 つのプライオリティ値が各リンクについて追跡されます。

明示的に設定するか、デフォルトの 32768 で設定する、設定されたプライオリティ

LACP ネゴシエーションで使用される運用上のプライオリティ。スイッチオーバーが発生している場合、設定されたプライオリティと異なる場合があります。

常に、ハイ プライオリティ LACP リンクはロー プライオリティ LACP リンクより先に選択されます。これは、運用上のプライオリティを操作して、(POA および DHD の)標準 LACP 選択ロジックで、両端の目的のリンクが強制的に選択されるようにできることを意味します。

たとえば、DHD が各 POA に対して 2 個のリンクを持ち、各 POA の最小アクティブ リンクが 2 に設定されている場合を検討します。(これはアクティブ リンク数が 2 を下回るとバンドルが POA でダウンすることを意味します)。メンバ リンクの運用上のプライオリティは、POA-1 で 1、POA-2 で 2 です。つまり、POA-1 はアクティブ(ハイ プライオリティ)であり POA-2 のリンクはスタンバイ状態のままになっています。スイッチオーバーのイベント シーケンスは次のとおりです。

1. リンクの障害が POA-1 で発生し、アクティブ リンクの数が最小の 2 未満になります。

2. POA-1 は、両リンクの運用上のプライオリティを 3 に変更し、これにより POA 2 のリンクがハイ プライオリティになります。

3. POA-1 は DHD に LACP メッセージ、POA-2 に mLACP にメッセージを送信し、両方のデバイスに変更を通知します。

4. 現在、POA-2 の方がハイ プライオリティになるため、DHD は POA-2 に接続されたリンクをアクティブ化しようとします。

5. また、POA-2 はそのリンクが最も高いプライオリティであることも確認し、DHD へのリンクをアクティブにします。

この時点でスイッチオーバーが完了しました。

ブルート フォースの動作

ブルート フォースのスイッチオーバーでは、ポート プライオリティは変更されません。その代わり、障害の発生した POA は LACP 経由で DHD に Dying Gasp を送信し、強制的にリンクが選択解除されるようにします。次に、そのリンクでの LACP の通信を終了します。これにより、選択できるリンクとして DHD と POA-2 間のリンクだけが残ります。したがって、両端でこれらのリンクを選択します。

MC-LAG のトポロジ

ここでは、サポートされている MC-LAG トポロジについて説明します。

図 9 冗長グループの VPWS 一方向疑似回線冗長性

 

図 10 VPWS 双方向疑似回線冗長性

 

図 11 1 つの冗長性グループの VPLS 疑似回線

 

図 12 2 つの冗長性グループの VPLS 疑似回線

 

図 13 H-VPLS:アクセス疑似回線上の EoMPLS

 

図 14 H-VPLS:uPE 上の VPWS 疑似回線との nPE 上のアクセス疑似回線

 

ロード バランシング

ロード バランシングは、特定のパラメータに基づいて複数のリンクのトラフィックを配信するトランスポート メカニズムです。Cisco ASR 9000 シリーズ ルータは、レイヤ 2、レイヤ 3、およびレイヤ 4 ルーティング情報を使用して、バンドル内のすべてのリンクのロード バランシングをサポートします。

ここでは、リンク バンドルのロード バランシング サポートについて説明します。

Cisco ASR 9000 シリーズ ルータでのその他のロード バランシング形式の詳細については、次の資料を参照してください。

レイヤ 3 およびレイヤ 4 ルーティング情報を使用した非バンドル インターフェイス上のフローごとのロード バランシング:『 Cisco ASR 9000 Series Aggregation Services Router IP Addresses and Services Configuration Guide 』を参照してください。

Cisco IOS XR 4.0.1 以降の疑似回線(PW)ロード バランシング:『 Cisco ASR 9000 Series Aggregation Services Router L2VPN and Ethernet Services Configuration Guide 』を参照してください。

リンク バンドルのレイヤ 2 入力ロード バランシング

デフォルトで、レイヤ 2 リンク バンドルのロード バランシングは、着信パケット ヘッダーの送信元および宛先 MAC アドレス(SA/DA)フィールドに基づいて行われます。 表 HC-1 に、デフォルト モード、EFP ベース、フローベースのいずれのロード バランシングが使用中であるかに応じて、レイヤ 2 での着信トラフィックのロード バランシングに使用されるパラメータのサマリーを表示します。

フローごとのロード バランシングは、バンドルのすべてのリンクでサポートされます。この方法では、ルータが、ハッシュ計算で決定されたバンドル内のリンクの 1 つを経由してパケットを配信することによって、ロード シェアリングが実行されます。ハッシュ計算は特定のパラメータに基づいたリンク選択のアルゴリズムです。

標準のハッシュ計算は、次のパラメータを使用する 5 タプル ハッシングです。

IP 送信元アドレス

IP 宛先アドレス

ルータ ID

レイヤ 4 送信元ポート

レイヤ 4 宛先ポート

フローごとのロード バランシングをイネーブルにすると、特定の送信元と宛先間のペア間のすべてのパケットは、使用可能なリンクが複数あっても、同じリンクを通過します。フローごとのロード バランシングは、特定の送信元と宛先ペアのパケットが順序どおりに到達できるようにします。


) マルチキャスト トラフィックに対するロード バランシングは、発信インターフェイスがリンク バンドル インターフェイスまたはサブインターフェイスの場合だけ適用されます。


 

表 HC-1 着信トラフィックのバンドルロード バランシング

入力ユニキャスト、フラッド、またはマルチキャスト トラフィック
パラメータ
設定

デフォルト

送信元 MAC アドレス

宛先 MAC アドレス

n/a

EFP ベース自動モード

xconnect の XID

自動モードは、 bundle load-balancing hash auto コマンドを使用してイネーブルにします。

ユーザ ハッシュを使用する EFP ベース

ユーザ ハッシュ

ユーザ ハッシュがバンドルは bundle load-balancing hash-value コマンドで設定します。

IP 送信元と宛先と使用するフローベース

送信元 IP アドレス

宛先 IP アドレス

L2VPN load-balancing flow src-dst-ip コマンドを使用してイネーブルにします。

MAC 送信元と宛先と使用するフローベース

送信元 MAC アドレス

宛先 MAC アドレス

L2VPN load-balancing flow src-dst-mac コマンドを使用してイネーブルにします。

リンク バンドルのレイヤ 3 出力ロード バランシング

レイヤ 3 ロード バランシングのサポートは、Cisco ASR 9000 シリーズ ルータの Cisco IOS XR 3.9.1 から開始され、Cisco IOS XR Release 4.0.1 で変更が導入されました。

Cisco IOS XR Release 4.0.1 よりもの前のレイヤ 3 ロード バランシング

Cisco IOS XR 3.9.1 から Cisco IOS XR 4.0 では、リンク バンドルのレイヤ 3 ロード バランシングは、パケットの IPv4 送信元および宛先アドレスに基づいて、イーサネット フロー ポイント(EFP)で実行されます。レイヤ 3 サービス固有のロード バランシングが設定されている場合、すべての出力バンドルは IPv4 送信元および宛先アドレスにロード バランシングされます。パケットに IPv4 アドレスがない場合、デフォルトのロード バランシングが使用されます。

リンク バンドルのレイヤ 3 ロード バランシングは、次のコマンドを使用して、グローバルにイネーブルになります。

hw-module load-balance bundle l2-service l3-params

Cisco IOS XR リリース 4.0.1 以降のレイヤ 3 ロード バランシング

リンク バンドルのレイヤ 3 ロード バランシングは、発信インターフェイスがバンドルまたはバンドル サブインターフェイスのときに実行されます。5 タプル ハッシングは、次のパラメータを使用して、バンドルのメンバ リンク間のロード バランシングに使用されます。

IP 送信元アドレス

IP 宛先アドレス

ルータ ID

レイヤ 4 送信元ポート

レイヤ 4 宛先ポート

入力ラインカードはバンドル メンバを選択し、選択したバンドル メンバに対応するラインカードおよびネットワーク プロセッサ(NP)パケットを転送します。入力と出力の両方のラインカードに同じハッシュ値が使用されます。したがって、出力ラインカードでもメンバ選択を行う場合でも、入力ラインカードによって選択された同じバンドル メンバが選択されます。

マルチキャスト IPv4 および IPv6 トラフィック

発信マルチキャスト IPv4 または IPv6 トラフィックの場合は、出力ラインカードのセットがシステムによって事前に決定されます。バンドルまたはバンドル インターフェイスのサブインターフェイスが発信インターフェイスの場合、システムはマルチキャスト グループ アドレスに基づいてルートの各発信インターフェイスのバンドル メンバを選択します。これは、特定のルートで特定のトラフィック シーケンスを維持しながら、異なるバンドル メンバに対するマルチキャスト ルーテッド トラフィックの負荷分散を実行する場合に役立ちます。

バンドル メンバが出力ラインカード内の複数の NP に分散した場合、出力ラインカードは同じアプローチを使用して NP を選択します。

パケットが出力 NP に到着すると、5 タプル ハッシュを使用して、各パケットの NP 内のバンドル メンバを選択します。これにより、NP 内のバンドル メンバの状態変更の復元性が向上します。

LAG のダイナミック ロード バランシング

Cisco IOS XR Release 4.0.1 以降の Cisco ASR 9000 シリーズ ルータでは、リンク集約(LAG)メンバ間のダイナミック ロード バランシング方式がサポートされています。ダイナミック ロード バランシングによって、バンドル内の現在のアクティブ メンバの数に基づいて、リンク選択のハッシュ アルゴリズムに最大 64 のリンクが含まれます。

QoS およびリンク バンドル

Cisco ASR 9000 シリーズ ルータでは、QoS が入力または出力方向のバンドルに適用される場合、各メンバ インターフェイスに QoS が適用されます。Cisco CRS ルータでのリンク バンドルの QoS の設定の詳細については、『 Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Configuration Guide 』および『 Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Command Reference 』を参照してください。

イーサネット リンク バンドル上の VLAN

802.1Q VLAN サブインターフェイスを 802.3ad イーサネット リンク バンドル上で設定できます。イーサネット リンク バンドル上に VLAN を追加するときには、次の点に注意してください。

各バンドルに許可される VLAN の最大数は、4096 です。

各ルータに許可されるバンドル VLAN の最大数は、16384 です。


) バンドル VLAN のメモリ要件は、標準の物理インターフェイスよりも若干多くなります。


バンドル上で VLAN サブインターフェイスを作成するには、次のように、 interface Bundle-Ether コマンドを使用して VLAN サブインターフェイス インスタンスを追加します。

interface Bundle-Ether interface-bundle-id.subinterface

イーサネット リンク バンドル上で VLAN を作成した後、すべての VLAN サブインターフェイス コンフィギュレーションがそのリンク バンドル上でサポートされます。

VLAN サブインターフェイスでは、イーサネット フロー ポイント(EFP)およびレイヤ 3 サービスなどの複数のレイヤ 2 フレーム タイプおよびサービスをサポートできます。

レイヤ 2 EFP は次のように設定します。

interface bundle-ether instance.subinterface l2transport.encapsulation dot1q xxxxx

 

レイヤ 3 VLAN サブインターフェイスは次のように設定します。

interface bundle-ether instance.subinterface, encapsulation dot1q xxxxx

) レイヤ 2 およびレイヤ 3 インターフェイス間の違いは、l2transport キーワードです。両方のタイプのインターフェイスは、dot1q encapsulation を使用します。


リンク バンドルの設定の概要

リンク バンドルの設定プロセスの一般的な概要を次の手順に示します。リンクをバンドルに追加する前に、リンクから以前のネットワーク層コンフィギュレーションをすべてクリアする必要があることに注意してください。

1. グローバル コンフィギュレーション モードで、リンク バンドルを作成します。イーサネット リンク バンドルを作成するには、interface Bundle-Ether コマンドを入力します。

2. ipv4 address コマンドを使用して、IP アドレスとサブネット マスクを仮想インターフェイスに割り当てます。

3. インターフェイス コンフィギュレーション サブモードで bundle id コマンドを使用し、ステップ 1 で作成したバンドルにインターフェイスを追加します。1 つのバンドルに最大 64 個のリンクを追加できます。


) リンクは、そのリンクのインターフェイス コンフィギュレーション サブモードからバンドルのメンバに設定できます。


カードのフェールオーバー時のノンストップ フォワーディング

Cisco IOS XR ソフトウェアは、アクティブおよびスタンバイ RSP カード間でのフェールオーバー時のノンストップ フォワーディングをサポートしています。ノンストップ フォワーディングを使用すると、フェールオーバーが発生したときにリンク バンドルの状態が変化しません。

たとえば、アクティブな RSP が障害になった場合、スタンバイ RSP が動作可能になります。障害になった RSP のコンフィギュレーション、ノードの状態、チェックポイント データは、スタンバイ RSP に複製されます。スタンバイ RSP がアクティブ RSP になったとき、バンドルされたインターフェイスはすべて存在します。


) フェールオーバー先は常にスタンバイ RSP です。



) スタンバイ インターフェイス コンフィギュレーションが維持されることを保証するために何かを設定する必要はありません。


リンクのフェールオーバー

バンドルのメンバ リンクの 1 つに障害が発生すると、トラフィックは動作可能な残りのメンバ リンクにリダイレクトされ、トラフィック フローは中断されません。

マルチギガビット サービス コントロール ポイント

マルチギガビット サービス コントロール ポイント(MGSCP)は、Cisco ASR 9000 シリーズ アグリゲーション サービス ルータの特定のリンク バンドルおよび転送機能を使用する導入モデルで、Cisco Service Control Engine(SCE)デバイスのブロードバンド加入者トラフィックのロード バランシング、クラスタリング、および冗長性をサポートします。

Cisco SCE プラットフォームは、ブロードバンド加入者にユーザ認可、レポート、およびアプリケーション帯域幅測定などのさまざまなサービスを提供するために使用されます。これは、アプリケーションおよび加入者の認識に基づいてステートフル処理メカニズムを使用して IP トラフィックを管理します。このステートフルネスを維持するには、SCE プラットフォームがセッションのアップストリームおよびダウンストリームの両方のフローをキャプチャして、それを分類し、アプリケーション レベルでレイヤ 7 プロセスを提供する必要があります。

FTP または Session Initiation Protocol(SIP)などの、フローのバンドルとあわせて実装されているアプリケーションを処理するには、SCE プラットフォームは、このアプリケーションでセッションを構成するすべてのフローを処理する必要があります。また、SCE プラットフォームが加入者ごとのレポートまたは制御( 加入者認識 とも呼ばれる)を実装するように設定されている場合、特定の加入者が生成するすべてのトラフィック フローを処理する必要があります。

この加入者レベルへのステートフル処理のため、SCE プラットフォームはレイヤ 2 およびレイヤ 3 透過性の「bump-in-the-wire」トポロジのネットワークに実装されています。ただし、SCE プラットフォームがサポートする必要のある帯域幅にあわせてブロードバンド加入者数が増加すると、このソリューションが、非対称ルーティングが実装されていることが多く、1 つのセッションの 2 方向(または特定の加入者の多数のフロー)が異なるリンク間で分割される一般的なネットワーク環境に挿入された場合、ソリューションのスケーリングにおいて特定の問題が生じます。

Cisco ASR 9000 シリーズ ルータの MGSCP ソリューションは、すべての加入者トラフィックが同じバンドルのメンバ リンクを介して送信されるリンク バンドルを使用してルータに接続しているクラスタの、複数の SCE デバイスを拡張するためのトポロジを提供することで、これらの要件を満たしています。また、MGSCP は、ロード バランシングと冗長性の利点があります。

図 1 に、Cisco ASR 9000 シリーズ ルータが加入者とコア ネットワーク間に接続され、接続された SCE クラスタのディスパッチャとして動作する、MGSCP の基本的なネットワーク トポロジを示しています。N+1 表記は、SCE の両側にある他のアクティブ リンクに対するバックアップ(または保護)リンクを示します。

図 1 基本的な MGSCP ネットワーク トポロジ

 

リンク バンドルの設定方法

ここでは、次の手順について説明します。

「イーサネット リンク バンドルの設定」

「イーサネット リンク バンドルでの EFP ロード バランシングの設定」

「VLAN バンドルの設定」

「マルチシャーシ リンク集約の設定」

イーサネット リンク バンドルの設定

ここでは、イーサネット リンク バンドルの設定方法について説明します。


) イーサネット リンク バンドルでは MAC アカウンティングはサポートされていません。



) イーサネット バンドルをアクティブにするためには、バンドルの両方の接続エンドポイントで同じ設定を行う必要があります。


手順の概要

イーサネット リンク バンドルを作成するには、次の手順のように、バンドルを作成し、そのバンドルにメンバ インターフェイスを追加します。

1. configure

2. interface Bundle-Ether bundle-id

3. ipv4 address ipv4-address mask

4. bundle minimum-active bandwidth kbps (任意)

5. bundle minimum-active links links (任意)

6. bundle maximum-active links links (任意)

7. exit

8. interface { GigabitEthernet | TenGigE }

9. bundle id bundle-id [ mode { active | on | passive }

10. no shutdown

11. exit

12. ステップ 2 で作成したバンドルにさらにリンクを追加するには、ステップ 8 から 11 を繰り返します。

13. end
または
commit

14. exit

15. exit

16. 接続のリモート エンドでステップ 1 から 15 を実行します。

17. show bundle Bundle-Ether bundle-id [ reasons ]

18. show lacp Bundle-Ether bundle -id

イーサネット リンク バンドルでの EFP ロード バランシングの設定

ここでは、イーサネット リンク バンドルでイーサネット フロー ポイント(EFP)ロード バランシングを設定する情報を説明します。

デフォルトでは、イーサネット フロー ポイント(EFP)ロード バランシングはイネーブルです。ただし、バンドルの固定メンバのすべての出力トラフィックを、同じ物理メンバ リンクを介して送信されるように設定できます。この設定は、レイヤ 2 転送( l2transport )をイネーブルにしたイーサネット バンドル サブインターフェイスでしか使用できません。


) バンドルのアクティブ メンバが変更されると、バンドルへのトラフィックは、設定値と一致するハッシュ値を持つ別の物理リンクにマッピングされる場合があります。


手順の概要

 

イーサネット リンク バンドルの EFP ロード バランシングを設定するには、次の手順を実行します。

1. configure

2. hw-module load-balance bundle l2-service l3-params

3. interface Bundle-Ether bundle-id l2transport

4. bundle load-balance hash hash-value [ auto ]

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

hw-module load-balance bundle l2-service l3-params

 

RP/0/RSP0/CPU0:router(config)# hw-module load-balance bundle l2-service l3-params

(任意)レイヤ 2 リンク バンドルでのレイヤ 3 ロード バランシングをイネーブルにします。

ステップ 3

interface Bundle-Ether bundle-id l2transport

 

RP/0/RSP0/CPU0:router#(config)# interface Bundle-Ether 3 l2transport

指定した bundle-id を使用し、レイヤ 2 転送をイネーブルにして、新しいイーサネット リンク バンドルを作成します。

範囲は 1 ~ 65535 です。

ステップ 4

bundle load-balance hash hash-value [ auto ]

 

RP/0/RSP0/CPU0:router(config-subif)# bundle load-balancing hash 1

または

RP/0/RSP0/CPU0:router(config-subif)# bundle load-balancing hash auto

バンドルの固定メンバのすべての出力トラフィックを、同じ物理メンバ リンクを通過するように設定します。

hash-value :このバンドルのすべての出力トラフィックが通過する物理メンバ リンクを指定する数値。値は 1 ~ 8 です。

auto :このバンドルのすべての出力トラフィックが通過する物理メンバ リンクが自動的に選択されます。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

VLAN バンドルの設定

ここでは、VLAN バンドルの設定方法について説明します。VLAN バンドルの作成では、主に次の 3 つの作業を行います。

1. イーサネット バンドルを作成します。

2. VLAN サブインターフェイスを作成し、イーサネット バンドルに割り当てます。

3. イーサネット リンクをイーサネット バンドルに割り当てます。

これらの作業について、以降の手順で詳しく説明します。


) VLAN バンドルをアクティブにするには、バンドル接続の両端で同じ設定を行う必要があります。


手順の概要

VLAN リンク バンドルの作成について、次の手順で説明します。

1. configure

2. interface Bundle-Ether bundle-id

3. ipv4 address ipv4-address mask

4. bundle minimum-active bandwidth kbps (任意)

5. bundle minimum-active links links (任意)

6. bundle maximum-active links links (任意)

7. exit

8. interface Bundle-Ether bundle-id.vlan-id

9. encapsulation dot1q

10. ipv4 address ipv4-address mask

11. no shutdown

12. exit

13. ステップ 2 で作成したバンドル にさらに VLAN を追加するには、 ステップ 7 から 12 を繰り返します。

14. end
または
commit

15. exit

16. exit

17. show ethernet trunk bundle-Ether instance

18. configure

19. interface { GigabitEthernet | TenGigE } interface-path-id

20. bundle id bundle-id [ mode { active | on | passive }]

21. no shutdown

22. ステップ 2 で作成したバンドルに さらに イーサネット インターフェイスを追加するには、ステップ 19 から 21 を繰り返します。

23. end
または
commit

24. 接続のリモート エンドでステップ 1 から 23 を実行します。

25. show bundle Bundle-Ether bundle-id [ reasons ]

26. show ethernet trunk bundle-Ether instance

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0//CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0//CPU0:router#(config)# interface Bundle-Ether 3

新しいイーサネット リンク バンドルを作成し名前を付与します。

この interface Bundle-Ether コマンドを実行すると、インターフェイス コンフィギュレーション サブモードが開始されます。このモードでは、インターフェイス固有のコンフィギュレーション コマンドを入力できます。インターフェイス コンフィギュレーション サブモードを終了して通常のグローバル コンフィギュレーション モードに戻るには、 exit コマンドを使用します。

ステップ 3

ipv4 address ipv4-address mask

 

RP/0//CPU0:router(config-if)# ipv4 address 10.1.2.3 255.0.0.0

ipv4 address コンフィギュレーション サブコマンドを使用して、IP アドレスとサブネット マスクを仮想インターフェイスに割り当てます。

ステップ 4

bundle minimum-active bandwidth kbps

 

RP/0//CPU0:router(config-if)# bundle minimum-active bandwidth 580000

(任意)ユーザがバンドルをアップ状態にする前に必要な最小帯域幅を設定します。

ステップ 5

bundle minimum-active links links

 

RP/0//CPU0:router(config-if)# bundle minimum-active links 2

(任意)特定のバンドルをアップ状態にする前に必要なアクティブ リンク数を設定します。

ステップ 6

bundle maximum-active links links

 

RP/0//CPU0:router(config-if)# bundle maximum-active links 1

(任意)1 個のアクティブ リンクと、アクティブ リンクに障害が発生した場合に、バンドルに迅速に引き継ぐことができるスタンバイ モードの 1 個のリンクを指定します(1:1 保護)。

(注) 1 つのバンドルで許可されるデフォルトのアクティブ リンク数は 8 です。

コマンドの値に基づいて決定されます(値が小さいほど、プライオリティが高くなります)。したがって、アクティブにするリンクに高いプライオリティを設定することを推奨します。

ステップ 7

exit
 

RP/0//CPU0:router(config-if)# exit

インターフェイス コンフィギュレーション サブモードを終了します。

ステップ 8

interface Bundle-Ether bundle-id.vlan-id

 

RP/0//CPU0:router#(config)# interface Bundle-Ether 3.1

新しい VLAN を作成し、その VLAN をステップ 2 で作成したイーサネット バンドルに割り当てます。

bundle-id 引数には、ステップ 2 で作成した bundle-id を指定します。

vlan-id にはサブインターフェイス ID を指定します。範囲は 1 ~ 4094 です(0 と 4095 は予約されています)。

コマンドに追加すると、サブインターフェイス コンフィギュレーション モードが開始されます。

ステップ 9

dot1q vlan vlan-id

 

RP/0//CPU0:router#(config-subif)# dot1q vlan 10

VLAN をサブインターフェイスに割り当てます。

vlan-id 引数にはサブインターフェイス ID を指定します。範囲は 1 ~ 4094 です(0 と 4095 は予約されています)。

ステップ 10

ipv4 address ipv4-address mask

 

RP/0//CPU0:router#(config-subif)# ipv4 address 10.1.2.3/24

IP アドレスおよびサブネット マスクをサブインターフェイスに割り当てます。

ステップ 11

no shutdown

 

RP/0//CPU0:router#(config-subif)# no shutdown

(任意)リンクがダウン状態の場合はアップ状態にします。no shutdown コマンドは、コンフィギュレーションとリンクの状態に応じて、リンクをアップ状態またはダウン状態に戻します。

ステップ 12

exit
 

RP/0//CPU0:router(config-subif)# exit

VLAN サブインターフェイスのサブインターフェイス コンフィギュレーション モードを終了します。

ステップ 13

ステップ 2 で作成したバンドルにさらに VLAN を追加するには、ステップ 7 から 12 を繰り返します。

(任意)バンドルにさらにサブインターフェイスを追加します。

ステップ 14

end

または

commit

 

RP/0//CPU0:router(config-subif)# end

または

RP/0//CPU0:router(config-subif)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、commit コマンドを使用します。

ステップ 15

exit
 

RP/0//CPU0:router(config-subif)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 16

exit
 

RP/0/RSP0/CPU0:router(config)# exit

グローバル コンフィギュレーション モードを終了します。

ステップ 17

show ethernet trunk bundle-ether instance

 

RP/0//CPU0:router# show ethernet trunk bundle-ether 5

(任意)インターフェイス コンフィギュレーションを表示します。

イーサネット バンドル インスタンスの範囲は 1 ~ 65535 です。

ステップ 18

configure
 

RP/0//CPU0:router # configure

グローバル コンフィギュレーション モードを開始します。

ステップ 19

interface { GigabitEthernet | TenGigE } interface-path-id

 

RP/0//CPU0:router(config)# interface GigabitEthernet 1/0/0/0

バンドルに追加するイーサネット インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

GigabitEthernet キーワードまたは TenGigE キーワードを入力して、インターフェイスの種類を指定します。 interface-path-id 引数には、 rack/slot/module 形式のノード ID を指定します。

(注) リンク バンドルの両端にイーサネット インターフェイスを追加するまでは、VLAN バンドルはアクティブになりません。

ステップ 20

bundle id bundle-id [ mode { active | on | passive }]

 
RP/0//CPU0:router(config-if)# bundle-id 3

ステップ 2 から 13 で設定したバンドルにイーサネット インターフェイスを追加します。

バンドル上でアクティブ LACP またはパッシブ LACP をイネーブルにするには、オプションの mode active キーワードまたは mode passive キーワードをコマンド文字列に追加します。

LACP をサポートせずにバンドルにインターフェイスを追加するには、オプションの mode on キーワードをコマンド文字列に追加します。

になります(LACP はポート上で動作しません)。

ステップ 21

no shutdown

 

RP/0//CPU0:router(config-if)# no shutdown

(任意)リンクがダウン状態の場合はアップ状態にします。no shutdown コマンドは、コンフィギュレーションとリンクの状態に応じて、リンクをアップ状態またはダウン状態に戻します。

ステップ 22

VLAN バンドルにさらにイーサネットインターフェイスを追加するには、ステップ 19 から 21 を繰り返します。

--

ステップ 23

end

または

commit

 

RP/0//CPU0:router(config-subif)# end

または

RP/0//CPU0:router(config-subif)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 24

VLAN バンドル接続のリモート エンドでステップ 1 から 23 を実行します。

リンク バンドルの他端をアップ状態にします。

ステップ 25

show bundle Bundle-Ether bundle-id [ reasons ]
 
RP/0//CPU0:router# show bundle Bundle-Ether 3 reasons

(任意)指定したイーサネット リンク バンドルに関する情報を表示します。

show bundle Bundle-Ether コマンドを実行すると、指定したバンドルに関する情報が表示されます。バンドルが正しく設定されており、トラフィックを伝送している場合は、 show bundle Bundle-Ether コマンドの出力の State フィールドに数値 4 が表示されます。これは、指定された VLAN バンドル ポートが「分散している」ことを意味します。

ステップ 26

show ethernet trunk bundle-ether instance

 

RP/0//CPU0:router# show ethernet trunk bundle-ether 5

(任意)インターフェイス コンフィギュレーションを表示します。

イーサネット バンドル インスタンスの範囲は 1 ~ 65535 です。

シャーシ間通信プロトコルの設定

シャーシ間通信プロトコル(ICCP)を設定するには、次の作業を実行します。

手順の概要

1. configure

2. redundancy iccp group group-id

3. member neighbor neighbor-ip-address

4. backbone interface interface-type-id

5. isolation recovery-delay delay

6. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

redundancy iccp group group-id

 

RP/0/RSP0/CPU0:router#(config-redundancy-iccp-group)# redundancy iccp group 100

ICCP 冗長性グループを追加します。

ステップ 3

member neighbor neighbor-ip-address

 

RP/0/RSP0/CPU0:router#(config-redundancy-iccp-group)# member neighbor 10.1.1.1

ICCP メンバを設定します。

この冗長グループの ICCP ピアです。冗長性グループごとに 1 つのネイバーだけを設定できます。IP アドレスは、ネイバーの LDP router-ID です。この設定は ICCP が機能するためには必須です。

ステップ 4

backbone interface interface-type-id

 

RP/0/RSP0/CPU0:router#(config-redundancy-iccp-group)# backbone interface GigabitEthernet0/1/0/2

ICCP バックボーン インターフェイスを設定します。

これはネットワーク コアからの分離を検出するオプションの設定で、問題が発生している POA がアクティブな場合はピア POA へのスイッチオーバーをトリガーします。複数のバックボーン インターフェイスは、各冗長グループ用に設定できます。すべてのバックボーン インターフェイスがアップでない場合、これはコア分離の表示です。1 つ以上のバックボーン インターフェイスがアップの場合、POA はネットワークのコアから分離されていません。バックボーン インターフェイスは、通常は L2VPN 疑似回線が使用できるインターフェイスです。

ステップ 5

isolation recovery-delay delay

 

RP/0/RSP0/CPU0:router#(config-redundancy-iccp-group)# isolation recovery-delay 30

分離パラメータを設定し、障害からの復旧後に分離状態をクリアするまでの遅延を指定します。

分離リカバリ遅延タイマーはコア分離状態がクリアされたときに開始します。タイマーの期限が切れると、POA は(バンドルのリカバリ遅延タイマーなどの他の条件に応じて)アクティブ POA として引き継ぐことができます。これにより、次が可能になります。

バックボーン インターフェイスがアップした後のネットワーク コアの再コンバージェンス

MCLAG バンドルが過度にフラップしないように、POA が入るべき状態を把握できるようにするための ICCP 状態の交換。

この設定は、オプションです。設定しない場合、遅延はデフォルトで 180 秒に設定されます。

ステップ 6

end

または

commit

 

RP/0/RSP0/CPU0:router(config-redundancy-iccp-group)# end

または

RP/0/RSP0/CPU0:router(config-redundancy-iccp-group)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

マルチシャーシ Link Aggregation Control Protocol セッションの設定

マルチシャーシ Link Aggregation Control Protocol セッションをイネーブルにするには、次の作業を実行します。

手順の概要

1. configure

2. redundancy iccp group group-id

3. mlacp system mac mac-id

4. mlacp system priority priority

5. mlacp node node-id

6. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

redundancy iccp group group-id

 

RP/0/RSP0/CPU0:router#(config-redundancy-iccp-group)# redundancy iccp group 100

ICCP 冗長性グループを追加します。

ステップ 3

mlacp system mac mac-id

 

RP/0/RSP0/CPU0:router#(config-redundancy-iccp-group)# mlacp system mac 1.1.1

LACP システム ID がこの ICCP グループで使用されるように設定します。

は、両方の POA で同じ値にすることを強く推奨します。異なるグループごとに異なる LAG ID を持つことができます。

ステップ 4

mlacp system priority priority

 

RP/0/RSP0/CPU0:router#(config-redundancy-iccp-group)# mlacp system priority 10

LACP システム プライオリティがこの ICCP グループで使用されるように設定します。

(注) POA のシステム プライオリティは、DHD の LACP LAG ID よりも低い数値(ハイ プライオリティ)に設定することを推奨します。DHD の方がシステム プライオリティが高い場合、および、動的優先権管理が機能せず、ブルート フォース スイッチオーバーが自動的に使用されます。

ステップ 5

mlacp node node-id

 

RP/0/RSP0/CPU0:router#(config-redundancy-iccp-group)# mlacp node 1

LACP システム プライオリティがこの ICCP グループで使用されるように設定します。

は、各 POA に固有である必要があります。

ステップ 6

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

マルチシャーシ Link Aggregation Control Protocol バンドルの設定

マルチシャーシ Link Aggregation Control Protocol(mLACP)バンドルを設定するには、次の作業を実行します。

手順の概要

1. configure

2. interface Bundle-Ether bundle-id

3. mac-address mac-id

4. bundle wait-while milliseconds

5. lacp switchover suppress-flaps milliseconds

6. mlacp iccp-group group-id

7. mlacp port-priority priority

8. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router#(config)# interface Bundle-Ether 3

新しいイーサネット リンク バンドルを作成し名前を付与します。

ステップ 3

mac-address mac-id

 

RP/0/RSP0/CPU0:router#(config-if)# mac-address 1.1.1

インターフェイスに MAC アドレスを設定します。

(注) 両方の POA に同じ MAC アドレスを設定することを強く推奨します。

ステップ 4

bundle wait-while milliseconds

 

RP/0/RSP0/CPU0:router#(config-if)# bundle wait-while 100

このバンドル メンバに wait-while タイムアウトを設定します。

ステップ 5

lacp switchover suppress-flaps milliseconds

 

RP/0/RSP0/CPU0:router#(config-if)# lacp switchover suppress-flaps 300

LACP のスイッチオーバー中のフラップを抑制する時間を設定します。

引数に使用する値は、ローカル デバイス(および DHD)wait-while タイマーよりも大きくすることを推奨します。

ステップ 6

mlacp iccp-group group-id

 

RP/0/RSP0/CPU0:router#(config-if)# mlacp iccp-group 10

このバンドルが動作する ICCP 冗長性グループを設定します。

ステップ 7

mlacp port-priority priority

 

RP/0/RSP0/CPU0:router#(config-if)# mlacp port-priority 10

mLACP を実行するときの、このデバイスのすべてのメンバ リンクの開始プライオリティを設定します。

(注) 値が小さいほど、プライオリティが高くなります。動的優先権管理を使用している場合、スイッチオーバーが発生したときに、リンクのプライオリティが変わります。

ステップ 8

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

デュアルホーム接続デバイスの設定

デュアルホーム接続デバイス(DHD)を設定するには、次の作業を実行します。


) ASR 9000 シリーズ ルータを DHD として使用する場合は、bundle maximum-active links links コマンド(links は DHD を POA の 1 つに接続するリンクの数)を設定することを推奨します。


手順の概要

1. configure

2. interface Bundle-Ether bundle-id

3. bundle wait-while milliseconds

4. lacp switchover suppress-flaps milliseconds

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router#(config-if)# interface Bundle-Ether 3

新しいイーサネット リンク バンドルを作成し名前を付与します。

ステップ 3

bundle wait-while milliseconds

 

RP/0/RSP0/CPU0:router#(config-if)# bundle wait-while 100

このバンドル メンバに wait-while タイムアウトを設定します。

ステップ 4

lacp switchover suppress-flaps milliseconds

 

RP/0/RSP0/CPU0:router#(config-if)# lacp switchover suppress-flaps 300

LACP のスイッチオーバー中のフラップを抑制する時間を設定します。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

POA の 1 つのバンドルに追加されたメンバは Active 、別の POA のメンバは Standby 状態になります。これは、いずれかの POA で show bundle コマンドを使用し、両方の POA で正しく設定されたメンバのメンバーシップ情報を表示することで確認できます。

RP/0/RSP0/CPU0:router# show bundle
 
Bundle-Ether1
Status: Up
Local links <active/standby/configured>: 1 / 0 / 1
Local bandwidth <effective/available>: 1000000 (1000000) kbps
MAC address (source): 0000.deaf.0000 (Configured)
Minimum active links / bandwidth: 1 / 1 kbps
Maximum active links: 64
Wait while timer: 100 ms
LACP: Operational
Flap suppression timer: 300 ms
mLACP: Operational
ICCP Group: 1
Role: Active
Foreign links <active/configured>: 0 / 1
Switchover type: Non-revertive
Recovery delay: 300 s
Maximize threshold: Not configured
IPv4 BFD: Not configured
 
Port Device State Port ID B/W, kbps
-------------------- --------------- ----------- -------------- ----------
Gi0/0/0/0 Local Active 0x8001, 0x9001 1000000
Link is Active
Gi0/0/0/0 5.4.3.2 Standby 0x8002, 0xa001 1000000
Link is marked as Standby by mLACP peer

) アクティブ POA に切り替えるには、現在アクティブなルータで mlacp switchover Bundle-Ether コマンドを使用します。


アクセス バックアップ疑似回線の設定

VPLS アクセス疑似回線にバックアップ疑似回線を追加するには、次の作業を実行します。

手順の概要

1. configure

2. l2vpn

3. bridge group bridge-group name

4. bridge-domain bridge-domain name

5. neighbor A.B.C.D ip-address pw-id pseudowire-id

6. pw-class { class-class name }

7. backup neighbor A.B.C.D ip-address pw-id pseudowire-id

8. pw-class { class-class name }

9. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

RP/0/RSP0/CPU0:router(config-l2vpn)#

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

bridge group bridge-group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# bridge group csco

RP/0/RSP0/CPU0:router(config-l2vpn-bg)#

ブリッジ ドメインを包含できるようにブリッジ グループを作成し、ブリッジ ドメインにネットワーク インターフェイスを割り当てます。

ステップ 4

bridge-domain bridge-domain-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg)# bridge-domain abc

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd)#

ブリッジ ドメインを確立し、l2vpn ブリッジ グループ ブリッジ ドメイン コンフィギュレーション モードを開始します。

ステップ 5

neighbor A.B.C.D pw-id pseudowire-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd)# neighbor 10.2.2.2 pw-id 2000

疑似回線セグメントを設定します。

ステップ 6

pw-class { class-name }

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-pw)# pw-class class1

疑似回線に使用する疑似回線クラス テンプレート名を設定します。

ステップ 7

backup neighbor A.B.C.D pw-id pseudowire-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-pw)# backup neighbor 10.2.2.2 pw-id 2000

VPLS アクセス疑似回線(PW)にバックアップ疑似回線を追加します。

ステップ 8

pw-class { class-name }

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-pw)# pw-class class2

バックアップ疑似回線に使用する疑似回線クラス テンプレート名を設定します。

ステップ 9

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-mac)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-mac)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

MC-LAG での一方向疑似回線冗長性の設定

冗長グループが設定されている場合に、一方向疑似回線冗長性の動作を許可するには、次の作業を実行します。

手順の概要

1. configure

2. l2vpn

3. pw-class { class-name }

4. encapsulation mpls

5. redundancy one-way

6. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

RP/0/RSP0/CPU0:router(config-l2vpn)#

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

pw-class { class-name }

 

RP/0/RSP0/CPU0:router(config-l2vpn)# pw-class class1

疑似回線に使用する疑似回線クラス テンプレート名を設定します。

ステップ 4

encapsulation mpls

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc)# encapsulation mpls

MPLS に疑似回線カプセル化を設定します。

ステップ 5

redundancy one-way

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc-mpls)# redundancy one-way

一方向 PW 冗長性の動作を設定します。

コマンドは、冗長グループが設定されている場合にだけ有効です。

ステップ 6

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-mac)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-mac)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

MC-LAG での VPWS クロスコネクトの設定

MC-LAG で VPWS クロスコネクトを設定するには、次の作業を実行します。

手順の概要

1. configure

2. l2vpn

3. pw-status

4. xconnect group group-name

5. p2p xconnect-name

6. interface type interface-path-id

7. neighbor A.B.C.D ip-address pw-id pseudowire-id

8. pw-class { class-class name }

9. backup neighbor A.B.C.D ip-address pw-id pseudowire-id

10. pw-class { class-class name }

11. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

pw-status

 

RP/0/RSP0/CPU0:router(config-l2vpn)# pw-status

疑似回線のステータスをイネーブルにします。

接続回線が冗長状態を Standby に変更すると、Standby pw-status がプライマリおよびバックアップ疑似回線に送信されます。

ステップ 4

xconnect group group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# xconnect group grp_1

クロスコネクト グループの名前を入力します。

ステップ 5

p2p xconnect-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc)# p2p p1

ポイントツーポイント クロスコネクトの名前を入力します。

ステップ 6

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# interface Bundle-Ether 1.1

インターフェイス タイプ ID を指定します。

ステップ 7

neighbor A.B.C.D pw-id pseudowire-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# neighbor 10.2.2.2 pw-id 2000

クロスコネクトの疑似回線セグメントを設定します。

オプションで、コントロール ワードをディセーブルにするか、イーサネットまたは VLAN に transport-type を設定できます。

ステップ 8

pw-class { class-name }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# pw-class c1

疑似回線に使用する疑似回線クラス テンプレート名を設定します。

ステップ 9

backup neighbor A.B.C.D pw-id pseudowire-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# backup neighbor 10.2.2.2 pw-id 2000

バックアップ疑似回線を追加します。

ステップ 10

pw-class { class-name }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw-backup)# pw-class c2

バックアップ疑似回線に使用する疑似回線クラス テンプレート名を設定します。

ステップ 11

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw-backup)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw-backup)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

MC-LAG での VPLS の設定

MC-LAG で VPLS を設定するには、次の作業を実行します。

手順の概要

1. configure

2. l2vpn

3. pw-status

4. bridge group bridge-group-name

5. bridge-domain bridge-domain-name

6. interface type interface-path-id

7. vfi vfi-name

8. neighbor A.B.C.D ip-address pw-id pseudowire-id

9. pw-class { class-class name }

10. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

pw-status

 

RP/0/RSP0/CPU0:router(config-l2vpn)# pw-status

(任意)疑似回線のステータスをイネーブルにします。

接続回線の冗長状態に関係なく、VFI のすべての疑似回線は常にアクティブです。

ステップ 4

bridge group bridge-group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# bridge group csco

RP/0/RSP0/CPU0:router(config-l2vpn-bg)#

ブリッジ ドメインを包含できるようにブリッジ グループを作成し、ブリッジ ドメインにネットワーク インターフェイスを割り当てます。

ステップ 5

bridge-domain bridge-domain-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg)# bridge-domain abc

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd)#

ブリッジ ドメインを確立し、L2VPN ブリッジ グループ ブリッジ ドメイン コンフィギュレーション モードを開始します。

ステップ 6

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd)# interface Bundle-Ether 1.1

インターフェイス タイプ ID を指定します。

ステップ 7

vfi {vfi-name}

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-ac)# vfi vfi-east

仮想転送インスタンス(VFI)コンフィギュレーション モードを開始します。

ステップ 8

neighbor A.B.C.D pw-id pseudowire-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-vfi)# neighbor 10.2.2.2 pw-id 2000

クロスコネクトの疑似回線セグメントを設定します。

オプションで、コントロール ワードをディセーブルにするか、イーサネットまたは VLAN に transport-type を設定できます。

ステップ 9

pw-class { class-name }

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-vfi-pw)# pw-class canada

疑似回線に使用する疑似回線クラス テンプレート名を設定します。

ステップ 10

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-vfi-pw)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn-bg-bd-vfi-pw)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

MGSCP の設定方法

「MGSCP の設定の前提条件」

「MGSCP の設定に関する制約事項」

「加入者側のアクセス バンドルの設定」(必須)

「コア側のネットワーク バンドルの設定」(必須)

「バンドル メンバ インターフェイスの設定」(必須)

「トラフィックをバンドルにルーティングする VRF の設定」(推奨)

MGSCP の設定の前提条件

MGSCP を設定する前に、次の前提条件を満たしていることを確認してください。

Cisco ASR 9000 シリーズ ルータにインストールされたギガビット イーサネットまたは 10 ギガビット イーサネット ラインカードがあります。

Service Control Engine(SCE)デバイスのクラスタの設定方法を理解し、ネットワークの目的の要件(MGSCP サポートの次の要件を含む)に応じてこれを設定すること。

Cisco ASR 9000 シリーズ ルータに SCE デバイスを接続する場合は、各 SCE デバイスに、次のようなCisco ASR 9000 シリーズ ルータの 2 つのバンドル インターフェイスに接続する 2 つの個別の物理リンクがあることを確認してください。

- 各 SCE デバイスからの 1 つのリンクはネットワークのアクセス(または加入者)側にルーティングされているバンドル インターフェイス上のリンクに接続されます。

- 各 SCE デバイスからのもう 1 つのリンクはネットワークのコア側にルーティングされている別のバンドル インターフェイス上のリンクに接続されます。

SCE デバイスに、リンク障害リフレクション用の SCE ポートを設定( link failure-reflection コマンドを使用)し、SCE の片方のリンクがダウンした場合に、他方のリンクが自動的にシャット ダウンされるようにしていること。詳細については、ご使用のデバイスの『Cisco SCE software configuration guide』の「Configuring the Connection」の章および次の URL のリリースを参照してください。

http://www.cisco.com/en/US/products/ps6134/products_installation_and_configuration_guides_list.html

Cisco ASR 9000 シリーズ ルータのバンドルの設定について、次の情報を特定します。

サポートするアクティブ リンクの最大数。

保護(バックアップ)リンクとするバンドル リンク。最大 4 つの保護リンクを設定できます。

接続された SCE のステートフルネスを維持するため、すべての加入者フローは同じ SCE を通過します。したがって、MGSCP を設定する前に、加入者トラフィックをルータがどのようにリダイレクトするかを決定し、その SCE に接続されている適切なバンドル インターフェイスを加入者トラフィックが通過するようにしておく必要があります。

次のいずれかの方法を使用できます。

ACL ベースの転送(ABF):ネクスト ホップの IP アドレスだけをサポートします。設定は複雑です。ABF の詳細については、『 Cisco ASR 9000 Series Aggregation Services Router IP Addresses and Services Configuration Guide 』の「 Implementing Access Lists and Prefix Lists 」の章を参照してください。

仮想ルーティングおよびフォワーディング(VRF):推奨。OSPF および BGP によるスタティックまたはダイナミック ルーティングを使用してルーティングされる、アクセス バンドルおよびネットワーク バンドルの VRF インスタンスを使用します。

MGSCP の設定に関する制約事項

MGSCP を設定する前に、次の制限事項を考慮してください。

バンドルには、最大 4 個の保護リンクを設定できます。

IPv6 アドレス指定はサポートされません。IPv4 アドレッシングを使用する必要があります。

MPLS はサポートされていません。

加入者側のアクセス バンドルの設定

ネットワークの加入者側に面するアクセス バンドルの設定は、コア バンドルの設定に似ています。次の注意事項を参照してください。

VRF を使用して加入者トラフィックを同じ SCE にルーティングする場合(推奨)、加入者側には別の VRF が使用されます。

リンク順序シグナリングによりロード バランシング テーブルのリンク順序番号(LON)の LACP プロセスをイネーブルにする必要があります。

バンドルのロード バランシングは、送信元 IP アドレスに基づいて設定されます。

アクティブ リンクの最大数はコア バンドルのアクティブ リンクの最大数と一致するように設定する必要があります。

手順の概要

1. configure

2. interface Bundle-Ether bundle-id

3. vrf vrf-name

4. ipv4 address ipv4-address mask

5. lacp cisco enable link-order signaled

6. bundle load-balancing hash src-ip

7. bundle maximum-active links links [ hot-standby ]

8. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router(config)# interface Bundle-Ether 100

ネットワークの加入者側のイーサネット バンドル インターフェイスを指定または作成(ここで、 bundle-id は 1 ~ 65535 の数値)し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrf vrf-name

 

RP/0/RSP0/CPU0:router(config-if)# vrf access

(任意:推奨)このイーサネット バンドルが参加しているネットワークの加入者側の VRF インスタンスを指定します。

ステップ 4

ipv4 address ipv4-address mask

 

RP/0/RSP0/CPU0:router(config-if)# ipv4 address 10.1.1.1 255.255.255.0

このインターフェイスの指定した VRF の一部である IPv4 アドレスおよびマスクを指定します。ここで、 ipv4-address は 32 ビット IP アドレスであり、対応するマスクをドット付き 10 進表記形式(A.B.C.D)で持ちます。

コマンドの後ろに指定する必要があります。

ステップ 5

lacp cisco enable link-order signaled

 

RP/0/RSP0/CPU0:router(config-if)# lacp cisco enable link-order signaled

このバンドルで処理する LACP プロセスの一部としてリンクの順序番号を含む Cisco TLV の使用をイネーブルにします。

ステップ 6

bundle load-balancing hash src-ip

 

RP/0/RSP0/CPU0:router(config-if)# bundle load-balancing hash src-ip

加入者のバンドル インターフェイスのロード バランシングに使用されるハッシュは、送信元 IP アドレスに基づいていることを指定します。

ステップ 7

bundle maximum-active links links [ hot-standby ]

 

RP/0/RSP0/CPU0:router(config-if)# bundle maximum-active links 2

バンドルで許可されるアクティブ リンクの最大数を指定し、をロード バランシング テーブルで使用されるリンク順序番号の上限を設定します。

(注) MGSCP をサポートするには、このコマンドもコア バンドルと同じ値に設定する必要があります。

ステップ 8

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

コア側のネットワーク バンドルの設定

ネットワークのコア側に面するバンドルの設定は、アクセス バンドルの設定に似ています。次の注意事項を参照してください。

VRF を使用して加入者トラフィックを同じ SCE にルーティングする場合(推奨)、コア側には別の VRF が使用されます。

リンク順序シグナリングによりロード バランシング テーブルの LON の LACP プロセスをイネーブルにする必要があります。

バンドルのロード バランシングは、宛先 IP アドレスに基づいて設定されます。

アクティブ リンクの最大数はアクセス バンドルのアクティブ リンクの最大数と一致するように設定する必要があります。

手順の概要

1. configure

2. interface Bundle-Ether bundle-id

3. vrf vrf-name

4. ipv4 address ipv4-address mask

5. lacp cisco enable link-order signaled

6. bundle load-balancing hash dst-ip

7. bundle maximum-active links links [ hot-standby ]

8. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router(config)# interface Bundle-Ether 100

ネットワークの加入者側のイーサネット バンドル インターフェイスを指定または作成(ここで、 bundle-id は 1 ~ 65535 の数値)し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrf vrf-name

 

RP/0/RSP0/CPU0:router(config-if)# vrf access

(任意:推奨)このイーサネット バンドルが参加しているネットワークのコア側の VRF インスタンスを指定します。

ステップ 4

ipv4 address ipv4-address mask

 

RP/0/RSP0/CPU0:router(config-if)# ipv4 address 10.1.1.1 255.255.255.0

このインターフェイスの指定した VRF の一部である IPv4 アドレスおよびマスクを指定します。ここで、 ipv4-address は 32 ビット IP アドレスであり、対応するマスクをドット付き 10 進表記形式(A.B.C.D)で持ちます。

コマンドの後ろに指定する必要があります。

ステップ 5

lacp cisco enable link-order signaled

 

RP/0/RSP0/CPU0:router(config-if)# lacp cisco enable link-order signaled

このバンドルで処理する LACP プロセスの一部としてリンクの順序番号を含む Cisco TLV の使用をイネーブルにします。

ステップ 6

bundle load-balancing hash dst-ip

 

RP/0/RSP0/CPU0:router(config-if)# bundle load-balancing hash dst-ip

加入者のバンドル インターフェイスのロード バランシングに使用されるハッシュは、宛先 IP アドレスに基づいていることを指定します。

ステップ 7

bundle maximum-active links links [ hot-standby ]

 

RP/0/RSP0/CPU0:router(config-if)# bundle maximum-active links 2

バンドルで許可されるアクティブ リンクの最大数を指定し、をロード バランシング テーブルで使用されるリンク順序番号の上限を設定します。

(注) MGSCP をサポートするには、このコマンドもアクセス バンドルと同じ値に設定する必要があります。

ステップ 8

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

バンドル メンバ インターフェイスの設定

アクセス バンドルおよびコア バンドルが設定されている場合、バンドル インターフェイスはこれらのバンドル上のアクティブ リンクおよび保護リンクとして設定する必要があります。次の注意事項を参照してください。

リンクは bundle id コマンドを使用し、対応するバンドル インターフェイスの ID を指定してバンドル メンバとなります。MGSCP では、2 種類の異なるバンドルが存在し、1 つはアクセス側トラフィック用、もう 1 つはコア側トラフィック用です。これらの各バンドルには SCE の両側に接続するリンクがあります。慎重に適切なバンドルにインターフェイスをマッピングしてください。

リンクは mode active を使用してバンドル上に設定する必要があるため、MGSCP には LACP が必要です。

アクティブ リンクおよびバックアップ(保護)リンクは bundle port-priority コマンドで設定します。

機能(アクティブ)リンクを設定するには、プライオリティ 1 を使用します。設定できるアクティブ リンクの最大数はバンドルの bundle maximum-active links コマンドの値によって決まります。

1 以外の任意のプライオリティで、リンクを保護リンクに指定します。最大 4 つの保護リンクを設定できます。

手順の概要

1. configure

2. interface [ GigabitEthernet | TenGigE ] interface-path-id

3. bundle id bundle-id mode active

4. bundle port-priority priority

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface [ GigabitEthernet | TenGigE ] interface-path-id

 

RP/0/RSP0/CPU0:router(config)# interface GigabitEthernet 0/0/0/0

ギガビット イーサネットまたは 10 ギガビット イーサネット インターフェイスを指定または作成し、インターフェイス コンフィギュレーション モードを開始します。ここで、 interface-path-id rack / slot / module / port 表記を使用したインターフェイスの物理的な場所です。

ステップ 3

bundle id bundle-id mode active

 

RP/0/RSP0/CPU0:router(config-if)# bundle id 100 mode active

インターフェイスを指定したバンドルのメンバとして追加し、インターフェイス上で LACP をアクティブ モードで実行して、MGSCP の LACP パケットを交換します。

ステップ 4

bundle port-priority priority

 

RP/0/RSP0/CPU0:router(config-if)# bundle port-priority 1

LACP プライオリティをインターフェイスに指定して、バンドル インターフェイスがアクティブであるか、または MGSCP の保護であるかを特定します。

値 1:リンクがアクティブ インターフェイスであることを指定します。

1 以外の値:リンクが保護インターフェイスであることを指定します。

デフォルトは 32768 です。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

トラフィックをバンドルにルーティングする VRF の設定

ステートフルネスのために、すべての加入者トラフィックが同じ SCE に残るようにするためには、VRF は、すべての加入者トラフィックをバンドルにルーティングする方法として推奨されます。MGSCP に VRF を設定するには、次のいずれかの作業を実行します。

「スタティック ルーティングを使用した VRF の設定」

「ダイナミック ルーティングを使用した VRF の設定」

スタティック ルーティングを使用した VRF の設定

次の手順は、スタティック ルーティングを使用して VRF を設定するために必要なタスクの概要を示します。

1. 2 つの VRF をグローバル コンフィギュレーションで設定します(ネットワークのアクセス側に 1 つ、コア側に 1 つ)。IPv4 ユニキャスト アドレス ファミリを指定してください。

2. IPv4 アドレスをバンドルの各インターフェイスとして設定し、ネットワークのアクセス側およびコア側にグローバル コンフィギュレーションで設定した、対応する VRF にこれらのアドレスを関連付けます。

3. IPv4 アドレスをギガビット イーサネット物理インターフェイスとして設定し、ネットワークのアクセス側およびコア側にグローバル コンフィギュレーションで設定した、対応する VRF にこれらのアドレスを関連付けます。

4. router static コマンドを使用してスタティック ルーティングを設定し、アクセス VRF およびコア VRF を対応するバンドル インターフェイスにマッピングします。

設定例については、「例:スタティック ルーティングを使用した VRF の設定」を参照してください。

ダイナミック ルーティングを使用した VRF の設定

MGSCP の VRF では、OSPF と BGP の両方のルーティング プロトコルがサポートされます。グローバル コンフィギュレーションと、バンドルおよび物理インターフェイスの VRF の全般設定は、スタティック ルーティングと同じです。

次の手順は、OSPF ルーティングを使用して VRF を設定するために必要なタスクの概要を示します。

1. 2 つの VRF をグローバル コンフィギュレーションで設定します(ネットワークのアクセス側に 1 つ、コア側に 1 つ)。IPv4 ユニキャスト アドレス ファミリを指定してください。

2. IPv4 アドレスをバンドルの各インターフェイスとして設定し、ネットワークのアクセス側およびコア側にグローバル コンフィギュレーションで設定した、対応する VRF にこれらのアドレスを関連付けます。

3. IPv4 アドレスをギガビット イーサネット物理インターフェイスとして設定し、ネットワークのアクセス側およびコア側にグローバル コンフィギュレーションで設定した、対応する VRF にこれらのアドレスを関連付けます。

4. router ospf コマンドを使用して OSPF などのダイナミック ルーティング プロトコルを設定することで VRF を定義し、バンドルおよび物理インターフェイスを OSPF 領域に関連付けます。

設定例については、「例:OSPF ルーティングを使用した VRF の設定」を参照してください

リンク バンドルの設定例

ここでは、次の例を示します。

「例:イーサネット リンク バンドルの設定」

「例:VLAN リンク バンドルの設定」

「例:イーサネット リンク バンドルでの EFP ロード バランシングの設定」

「例:マルチシャーシ リンク集約の設定」

例:イーサネット リンク バンドルの設定

 

次に、2 つのポートを結合して、LACP が動作する EtherChannel バンドルを構成する例を示します。

RP/0/RSP0/CPU0:Router# config
RP/0/RSP0/CPU0:Router(config)# interface Bundle-Ether 3
RP/0/RSP0/CPU0:Router(config-if)# ipv4 address 1.2.3.4/24
RP/0/RSP0/CPU0:Router(config-if)# bundle minimum-active bandwidth 620000
RP/0/RSP0/CPU0:Router(config-if)# bundle minimum-active links 1
RP/0/RSP0/CPU0:Router(config-if)# exit
RP/0/RSP0/CPU0:Router(config)# interface TenGigE 0/3/0/0
RP/0/RSP0/CPU0:Router(config-if)# bundle id 3 mode active
RP/0/RSP0/CPU0:Router(config-if)# no shutdown
RP/0/RSP0/CPU0:Router(config)# exit
RP/0/RSP0/CPU0:Router(config)# interface TenGigE 0/3/0/1
RP/0/RSP0/CPU0:Router(config-if)# bundle id 3 mode active
RP/0/RSP0/CPU0:Router(config-if)# no shutdown
RP/0/RSP0/CPU0:Router(config-if)# exit
 

例:VLAN リンク バンドルの設定

 

次に、イーサネット バンドル上で 2 つの VLAN を作成しアップ状態にする例を示します。

RP/0/RSP0/CPU0:Router# config
RP/0/RSP0/CPU0:Router(config)# interface Bundle-Ether 1
RP/0/RSP0/CPU0:Router(config-if)# ipv4 address 1.2.3.4/24
RP/0/RSP0/CPU0:Router(config-if)# bundle minimum-active bandwidth 620000
RP/0/RSP0/CPU0:Router(config-if)# bundle minimum-active links 1
RP/0/RSP0/CPU0:Router(config-if)# exit
RP/0/RSP0/CPU0:Router(config)# interface Bundle-Ether 1.1
RP/0/RSP0/CPU0:Router(config-subif)# dot1q vlan 10
RP/0/RSP0/CPU0:Router(config-subif)# ip addr 10.2.3.4/24
RP/0/RSP0/CPU0:Router(config-subif)# no shutdown
RP/0/RSP0/CPU0:Router(config-subif)# exit
RP/0/RSP0/CPU0:Router(config)# interface Bundle-Ether 1.2
RP/0/RSP0/CPU0:Router(config-subif)# dot1q vlan 20
RP/0/RSP0/CPU0:Router(config-subif)# ip addr20.2.3.4/24
RP/0/RSP0/CPU0:Router(config-subifif)# no shutdown
RP/0/RSP0/CPU0:Router(config-subifif)# exit
RP/0/RSP0/CPU0:Router(config)# interface gig 0/1/5/7
RP/0/RSP0/CPU0:Router(config-if)# bundle-id 1 mode act
RP/0/RSP0/CPU0:Router(config-if)# commit
RP/0/RSP0/CPU0:Router(config-if)# exit
 

例:イーサネット リンク バンドルでの EFP ロード バランシングの設定

次に、バンドルの固定メンバのすべての出力トラフィックが、同じ物理メンバ リンクを介して自動的に送信されるように設定する例を示します。

RP/0/RP0/CPU0:router# configuration terminal
RP/0/RP0/CPU0:router(config)# interface bundle-ether 1.1 l2transport
RP/0/RP0/CPU0:router(config-subif)# bundle load-balancing hash auto
RP/0/RP0/CPU0:router(config-subif)#
 

次に、バンドルの固定メンバのすべての出力トラフィックが、指定した物理メンバ リンクを介して送信されるように設定する例を示します。

RP/0/RP0/CPU0:router# configuration terminal
RP/0/RP0/CPU0:router(config)# interface bundle-ether 1.1 l2transport
RP/0/RP0/CPU0:router(config-subif)# bundle load-balancing hash 1
RP/0/RP0/CPU0:router(config-subif)#
 

例:マルチシャーシ リンク集約の設定

 

次に、POA を設定する例を示します。

アクティブ POA

interface Bundle-Ether10
mlacp iccp-group 1
mlacp port-priority 10
 

スタンバイ POA

interface Bundle-Ether10
mlacp iccp-group 1
mlacp port-priority 20
 

次に、ICCP を設定する例を示します。

redundancy iccp group
member neighbor 1.2.3.4
backbone interface GigabitEthernet 0/0/0/0
isolation recovery-delay 30
 

次に、mLACP を設定する例を示します。

configure
redundancy iccp group 100
mlacp system mac 1.1.1
mlacp system priority 10
mlacp node 1
interface Bundle-Ether 3
mac-address 1.1.1
bundle wait-while 100
lacp switchover suppress-flaps 300
mlacp iccp-group 100
 

次に、スイッチオーバーの例を示します。

RP/0/0/CPU0:router# show bundle
 
Bundle-Ether1
Status: Up
Local links <active/standby/configured>: 1 / 0 / 1
Local bandwidth <effective/available>: 1000000 (1000000) kbps
MAC address (source): 0000.deaf.0000 (Configured)
Minimum active links / bandwidth: 1 / 1 kbps
Maximum active links: 64
Wait while timer: 100 ms
LACP: Operational
Flap suppression timer: 300 ms
mLACP: Operational
ICCP Group: 1
Role: Active
Foreign links <active/configured>: 0 / 1
Switchover type: Non-revertive
Recovery delay: 300 s
Maximize threshold: Not configured
IPv4 BFD: Not configured
 
Port Device State Port ID B/W, kbps
-------------------- --------------- ----------- -------------- ----------
Gi0/0/0/0 Local Active 0x8001, 0x9001 1000000
Link is Active
Gi0/0/0/0 5.4.3.2 Standby 0x8002, 0xa001 1000000
Link is marked as Standby by mLACP peer
 
 
RP/0/0/CPU0:router#mlacp switchover Bundle-Ether 1
 
This will trigger the peer device (Node 5.4.3.2 in IG 1) to become active for Bundle-Ether1.This may result in packet loss on the specified bundle.
 
Proceed with switch over?[confirm]
 
RP/0/0/CPU0:Jan 31 23:46:44.666 : BM-DISTRIB[282]: %L2-BM-5-MLACP_BUNDLE_ACTIVE : This device is no longer the active device for Bundle-Ether1
RP/0/0/CPU0:Jan 31 23:46:44.668 : BM-DISTRIB[282]: %L2-BM-6-ACTIVE : GigabitEthernet0/0/0/0 is no longer Active as part of Bundle-Ether1 (Not enough links available to meet minimum-active threshold)
 
RP/0/0/CPU0:router#show bundle
Mon Jun 7 06:04:17.778 PDT
 
Bundle-Ether1
Status: mLACP hot standby
Local links <active/standby/configured>: 0 / 1 / 1
Local bandwidth <effective/available>: 0 (0) kbps
MAC address (source): 0000.deaf.0000 (Configured)
Minimum active links / bandwidth: 1 / 1 kbps
Maximum active links: 64
Wait while timer: 100 ms
LACP: Operational
Flap suppression timer: 300 ms
mLACP: Operational
ICCP Group: 1
Role: Standby
Foreign links <active/configured>: 1 / 1
Switchover type: Non-revertive
Recovery delay: 300 s
Maximize threshold: Not configured
IPv4 BFD: Not configured
 
Port Device State Port ID B/W, kbps
-------------------- --------------- ----------- -------------- ----------
Gi0/0/0/0 Local Standby 0x8003, 0x9001 1000000
mLACP peer is active
Gi0/0/0/0 5.4.3.2 Active 0x8002, 0xa001 1000000
Link is Active
RP/0/0/CPU0:router#
 

次に、VPLS アクセス疑似回線にバックアップ疑似回線を追加する例を示します。

l2vpn bridge group bg1
bridge-domain bd1
neighbor 101.101.101.101 pw-id 5000
pw-class class1
backup neighbor 102.102.102.102 pw-id 3000
pw-class class1
!
!
!
!

次に、冗長グループが設定されている場合に、一方向疑似回線冗長性の動作を設定する例を示します。

 
l2vpn pw-class class_mpls
encapsulation mpls
redundancy one-way
!
!

 

次に、全体的な MC-LAG 設定の例を示します。

トロポジの場合:

DHD POA 1 POA 2
 
Gi0/0/0/0 --------------- Gi0/0/0/0
Gi0/0/0/1 --------------- Gi0/0/0/1
Gi0/0/0/2
Gi0/0/0/3 ----------------------------------------- Gi0/0/0/0
Gi0/0/0/4 ----------------------------------------- Gi0/0/0/1
Gi0/0/0/2 Gi0/0/0/2
Gi0/0/0/3 --------------- Gi0/0/0/3
Gi0/0/0/4 --------------- Gi0/0/0/4
 

POA 1 の場合:

 
redundancy
iccp
group 1
mlacp node 1
mlacp system mac 000d.000e.000f
mlacp system priority 1
member
neighbor 5.4.3.2
!
!
!
!
interface Bundle-Ether1
lacp switchover suppress-flaps 300
mlacp iccp-group 1
mac-address 0.deaf.0
bundle wait-while 100
!
interface Loopback0
ipv4 address 5.4.3.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0
description Connected to DHD Gi0/0/0/0
bundle id 1 mode active
lacp period short
no shutdown
!
interface GigabitEthernet0/0/0/3
description Connected to POA2 Gi0/0/0/3
ipv4 address 1.2.3.1 255.255.255.0
proxy-arp
no shutdown
!
router static
address-family ipv4 unicast
5.4.3.2/32 1.2.3.2
!
!
mpls ldp
router-id 5.4.3.1
discovery targeted-hello accept
log
neighbor
!
interface GigabitEthernet0/0/0/3
!
!

POA 2 の場合:

 
redundancy
iccp
group 1
mlacp node 2
mlacp system mac 000d.000e.000f
mlacp system priority 1
member
neighbor 5.4.3.1
!
!
!
!
interface Bundle-Ether1
lacp switchover suppress-flaps 300
mlacp iccp-group 1
mac-address 0.deaf.0
bundle wait-while 100
!
interface Loopback0
ipv4 address 5.4.3.2 255.255.255.255
!
interface GigabitEthernet0/0/0/0
description Connected to DHD Gi0/0/0/3
bundle id 1 mode active
lacp period short
no shutdown
!
interface GigabitEthernet0/0/0/3
description Connected to POA1 Gi0/0/0/3
ipv4 address 1.2.3.2 255.255.255.0
proxy-arp
no shutdown
!
router static
address-family ipv4 unicast
5.4.3.1/32 1.2.3.1
!
!
mpls ldp
router-id 5.4.3.2
discovery targeted-hello accept
log
neighbor
!
interface GigabitEthernet0/0/0/3
!
!

DHD の場合:

 
interface Bundle-Ether1
lacp switchover suppress-flaps 300
bundle wait-while 100
!
interface GigabitEthernet0/0/0/0
description Connected to POA1 Gi0/0/0/0
bundle id 1 mode active
lacp period short
no shutdown
!
interface GigabitEthernet0/0/0/3
description Connected to POA2 Gi0/0/0/0
bundle id 1 mode active
lacp period short
no shutdown
!

MGSCP の設定例

図 2 に、設定例として使用する SCE デバイスのクラスタのディスパッチャとして、1 台の Cisco ASR 9000 シリーズ ルータを使用したネットワーク例について説明します。

図 2 SCE クラスタのディスパッチャとしての Cisco ASR 9000 シリーズ ルータ

 

ここでは、次の例について説明します。

「例:バンドル インターフェイスおよびメンバ リンクの設定」

「例:トラフィックをバンドルにルーティングする VRF の設定」

「例:ABF を使用しバンドルにトラフィックをルーティングする MGSCP の設定」

例:バンドル インターフェイスおよびメンバ リンクの設定

次に、図 2 に示した Cisco ASR 9000 シリーズ ルータ上に 2 つのバンドルを設定する例を示します。各バンドルは、最大 2 個のアクティブ リンクをサポートし(両方のバンドルの設定は一致させる必要があります)、1 つはバックアップ保護リンクとします。

イーサネット バンドル 100 のバンドル インターフェイス メンバは、送信元 IP アドレスに基づいたロード バランシングを使用して、ネットワークの加入者側への SCE デバイス リンクに接続します。イーサネット バンドル 200 のバンドル インターフェイス メンバは、宛先 IP アドレスに基づいたロード バランシングを使用して、ネットワークのコア側への SCE デバイス リンクに接続します。

加入者側アクセス バンドルの設定

interface Bundle-Ether 100
description Subscriber-facing end
vrf access
ipv4 address 10.10.1.2 255.255.255.0
lacp cisco enable link-order signaled
bundle load-balancing hash src-ip
bundle maximum-active links 2
!
interface GigabitEthernet 0/0/0/0
description to SCE1
bundle id 100 mode active
bundle port-priority 1
!
interface GigabitEthernet 0/0/0/1
description to SCE2
bundle id 100 mode active
bundle port-priority 1
!
interface GigabitEthernet 0/0/0/3
description to SCE3 (backup)
bundle id 100 mode active

コア側バンドル設定

interface Bundle-Ether 200
description Core-facing end
vrf core
ipv4 address 10.20.1.2 255.255.255.0
lacp cisco enable link-order signaled
bundle load-balancing hash dst-ip
bundle maximum active links 2
!
interface GigabitEthernet 0/0/1/0
description from SCE1
bundle id 200 mode active
bundle port-priority 1
!
interface GigabitEthernet 0/0/1/1
description from SCE2
bundle id 200 mode active
bundle port-priority 1
!
interface GigabitEthernet 0/0/1/2
description from SCE3 (standby)
bundle id 200 mode active

例:トラフィックをバンドルにルーティングする VRF の設定

同じ加入者との間のトラフィックが確実に SCE の同じポートを通過するようにするには、VRF が推奨されます。MGSCP には、2 つの VRF を設定する必要があります(1 つはアクセス トラフィック用、もう 1 つはコア トラフィック用)。

このセクションの例では、VRF のバンドル インターフェイスで、スタティックまたはダイナミック(OSPF)ルーティングのいずれかの VRF を使用してルーティングできる、2 つの方法を示します。

「例:スタティック ルーティングを使用した VRF の設定」

「例:OSPF ルーティングを使用した VRF の設定」

例:スタティック ルーティングを使用した VRF の設定

次の設定例では、VRF は IPv4 を使用してネットワークのコア側とアクセス側に確立されます。そこから、各側のバンドル インターフェイス アドレスは、それぞれ VRF の一部として、また 2 つの物理インターフェイスとして設定されます。設定の最後では、バンドル インターフェイスを使用して各 VRF にスタティック ルートを設定しています。

VRF グローバル コンフィギュレーション

vrf core
address-family ipv4 unicast
import route-target
1:1
!
export route-target
1:1
!
vrf access
address-family ipv4 unicast
import route-target
1:1
!
export route-target
1:1
!

バンドル インターフェイスの VRF 設定

interface Bundle-Ether100
vrf access
ipv4 address 10.10.1.2 255.255.255.0
!
interface Bundle-Ether200
vrf core
ipv4 address 10.20.1.2 255.255.255.0

物理インターフェイスの VRF 設定

interface GigabitEthernet0/2/0/1
vrf access
ipv4 address 10.10.1.4 255.255.255.0
 
interface GigabitEthernet0/2/0/9
vrf core
ipv4 address 10.20.1.4 255.255.255.0
negotiation auto

VRF のバンドル インターフェイスへのスタティック ルーティング設定

router static
vrf core
address-family ipv4 unicast
0.0.0.0/0 Bundle-Ether200
!
!
vrf access
address-family ipv4 unicast
0.0.0.0/0 Bundle-Ether100
!
!

例:OSPF ルーティングを使用した VRF の設定

次の設定例では、VRF は IPv4 を使用してネットワークのコア側とアクセス側に確立されます。そこから、OSPF ルーティング インスタンスおよび VRF を含める領域を設定し、バンドル インターフェイスと物理インターフェイスを関連付けます。

VRF グローバル コンフィギュレーション

vrf core
address-family ipv4 unicast
import route-target
1:1
export route-target
1:1
 
vrf access
address-family ipv4 unicast
import route-target
1:1
export route-target
1:1

物理インターフェイスの VRF 設定

interface GigabitEthernet0/2/0/1
vrf access
ipv4 address 10.10.1.4 255.255.255.0
_
interface GigabitEthernet0/2/0/9
vrf core
ipv4 address 10.20.1.4 255.255.255.0

VRF の OSPF ルーティング設定とバンドルと物理インターフェイス

router ospf 100
vrf core
router-id 10.20.1.2
area 0
interface Bundle-Ether200
interface GigabitEthernet0/2/0/9
 
vrf access
router-id 10.10.1.2
area 0
interface Bundle-Ether100
interface GigabitEthernet0/2/0/1

例:ABF を使用しバンドルにトラフィックをルーティングする MGSCP の設定

次に、アクセス リストを使用してバンドルにトラフィックを転送するトラフィックのルーティングの例を示します。

ipv4 access-list inbound
!
!Set the nexthop address to be a virtual IP address on the same network
!as the access bundle.
!
10 permit ipv4 any any nexthop 10.10.1.5
!
ipv4 access-list outbound
!
!Set the nexthop address to be a virtual IP address on the same network
!as the core bundle.
!
10 permit ipv4 any any nexthop 10.20.1.5
!
!Configure static ARP for the virtual IP addresses
!
arp vrf default 10.10.1.5 0024.98eb.bf8a ARPA
arp vrf default 10.20.1.5 0024.98eb.bf8b ARPA
 
interface Bundle-Ether100
ipv4 address 10.10.1.2 255.255.255.0
!
interface Bundle-Ether200
ipv4 address 10.20.1.2 255.255.255.0
!
interface GigabitEthernet0/2/0/1
ipv4 address 10.10.1.3 255.255.255.0
ipv4 access-group inbound
!
interface GigabitEthernet0/2/0/9
ipv4 address 10.20.1.3 255.255.255.0
ipv4 access-group outbound
!

その他の関連資料

ここでは、リンク バンドルの設定に関連する参考資料を示します。

関連資料

関連項目
参照先

Cisco ASR 9000 シリーズ ルータ マスター コマンド リファレンス

『Cisco ASR 9000 Series Router Master Commands List』

Cisco ASR 9000 シリーズ ルータ インターフェイス コンフィギュレーション コマンド

『Cisco ASR 9000 Series Router Interface and Hardware Component Command Reference』

Cisco IOS XR ソフトウェアを使用する Cisco ASR 9000 シリーズ ルータの初期システム ブートアップと設定に関する情報。

『Cisco ASR 9000 Series Router Getting Started Guide』

ユーザ グループとタスク ID に関する情報

『Cisco ASR 9000 Series Router Interface and Hardware Component Command Reference』

リモートの Craft Works Interface(CWI)クライアント管理アプリケーションからの、Cisco ASR 9000 シリーズ ルータ上のインターフェイスとその他のコンポーネントの設定に関する情報

『Cisco ASR 9000 Series Router Craft Works Interface Configuration Guide』

標準

標準
タイトル

この機能によってサポートされる新しい標準または変更された標準はありません。またこの機能による既存標準のサポートに変更はありません。

--

MIB

MIB
MIB のリンク

このモジュールに適用できる MIB はありません。

Cisco IOS XR ソフトウェアを使用して、選択したプラットフォームの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/en/US/support/index.html